BECKHOFF 现场总线组件

Documentation for

EK1110 - EtherCAT Extension

Version 1.2
Date: 2011-12-28


EK1110 - Documentation issue status

BECKHOFF EK1110:前言

文档版本说明

版本 | 注释
1.2 | 添加技术数据
1.1 | 添加技术数据
1.0 | 添加技术数据
0.1 | EK1110的序言文档


EK1110 - Introduction

BECKHOFF EK1110: 产品概述

介绍

EK1110 | EtherCAT 扩展端子模块

与 E-bus 末端端子模块一样，EtherCAT 扩展端子模块 EK1110 与 EtherCAT 端子块的末端相连。该端子模块可以将以太网电缆与 RJ 45 接头相连，因此可将 EtherCAT 电缆束的电气隔离长度增加最多 100 m。在 EK1110 端子模块中，E-bus 信号被“飞速”转换为 100BASE-TX 以太网信号。EK1110 电子元件通过 E-bus 供电。无需执行参数化或组态任务。

连接

端子模块连接 | 描述
名称
X1 | 连接EtherCAT 网络的RJ45接口 (转换为 100BASE-TX 以太网信号)


EK1110- Technical data

BECKHOFF EK1110:产品概述

技术参数

技术参数 | EK1110
EtherCAT 系统中的任务 | 将 E-bus 信号转换为 100BASE-TX 以太网信号，以扩展 EtherCAT 网络
数据传输介质 | Ethernet/EtherCAT CAT5 电缆
站点之间的距离 | 100 m (100BASE-TX)
延迟 | 约 1 µs
数据传输速率 | 100 Mbaud
组态 | 不需要
总线接口 | 1 x RJ45
电源 | 由 E-bus 供电
E-bus 电流消耗 | 约 130mA
电气隔离 | 500 Vrms (电源电压/ Ethernet)
尺寸(W x H x D) | 大约44 mm x 100 mm x 68 mm
重量 | 大约50 g
工作温度 | 0°C ... + 55°C
储藏温度 | -25°C ... + 85°C
相对湿度 | 95%, 无冷凝
导轨安装 | 安装在35 mm的安装轨道上遵照 EN 50022
抗振动/抗冲击性能 | 遵照EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
抗电磁干扰/抗电磁辐射性能 | 遵照EN 61000-6-2 / EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认证 | CE Ex UL


Start

BECKHOFF EK1110: 产品概述

启动

调试:

  • 如"安装和接线" 章节中所述，安装EK1110
  • 如"参数化及调试"章节中所述，在TwinCAT 中配置EK1110


EtherCAT basics

BECKHOFF EtherCAT: 基础通信

EtherCAT 基本资料

请参考EtherCAT系统文件的相关章节来获取EtherCAT现场总线的基本资料。


CoE-Interface

BECKHOFF EtherCAT: 基础通信

CoE接口

CoE接口是EtherCAT装置的参数管理机构。在CAN-over-EtherCAT (CoE)的管理机构中， 特定的固件参数可以在网上或EtherCAT的离线参数中获得。CoE接口的详细信息可以在网站上的EtherCAT的系统文件 EtherCAT system documentation里获得。


Distributed Clock

BECKHOFF EtherCAT: 基础通信

分布式时钟

分布式时钟代表了EtherCAT 从属控制器（ESC）中的本地时钟，有如下的特性：

• 单位 1 ns
• 基准点 1.1.2000 00:00
• 大小 64字节（足够提供未来584年；然而，有些EtherCAT只提供对32位字节的支持，即大约4.2S）
• EtherCAT主站会通过主站时钟将在EhterCAT总线中的本地时钟自动同步，精度达< 100 ns。

需要详细信息请参考 EtherCAT system description


Mounting of Passive Terminals

BECKHOFF EtherCAT: 装配和接线

接线端子模块的装配

注意 		装配接线端子模块子的提示
EtherCAT 的总线端子 (ELxxxx / ESxxxx)，其在终端接线盒中并不担任数据传输的任务。
接线端子模块在E-Bus之外没有电流消耗。
为确保最优的数据传输，不能直接将两个接线端子模块连接起来.

装配接线端子模块的实例 (高亮部分):

例1: 正确的设置

例2: 错误的设置


EK1110 - Configuration overview

BECKHOFF EK1110: 设置

设置概述

TwinCAT 树

就像其他在EtherCAT设备一样，可以将EK1110（直接方式）加入到 TwinCAT System Manager 系统下。任何已连接到网络中的端子模块都可以读到。 这将会载入所有总线耦合器的总线端子模块。然后你可以选择你所需要的模块。

图 1 TwinCAT 树 EK1110

在线状态

State, Online 标签

显示端子模块的在线状态

图2 State, "Online" 标签

值 | 描述
0x___1 | 从站处于“初始化”状态
0x___2 | 从站处于“预操作”状态
0x___3 | 从站处于“引导状态
0x___4 | 从站处于“安全”状态
0x___8 | 从站处于“运行”状态
0x001_ | 从站信号错误
0x002_ | 无效的供应商ID，产品号...读
0x004_ | 出现初始化错误
0x010_ | 从站当前不存在
0x020_ | 从站信号连接错误
0x040_ | 从站信号丢失连接
0x080_ | 从站信号不可预知的连接
0x100_ | 通信口A
0x200_ | 通信口B
0x400_ | 通信口C
0x800_ | 通信口D


EK1110 - Diagnotic LED

BECKHOFF EK1110: 故障处理和诊断

LED诊断指示灯

诊断总线时的LED

LED |  | 显示 | 状态 | 含义
LINK / ACT (X1) | 绿 | 灭 | - | 和EtherCAT客户端无连接
 |  | 亮 | 已连接 | 已连接EtherCAT客户端
 |  | 慢闪 | 激活 | 和EtherCAT客户端通信中

LED for EtherCAT 状态机诊断

LED | 颜色 | 含义
RUN | 绿色 | 此LED灯显示端子模块的工作状态：
 |  | 灭 | EtherCAT状态机的状态: 初始化 = 初始化
 |  | 平稳闪烁 | EtherCAT状态机的状态: PREOP = 预操作
 |  | 缓慢闪烁 | EtherCAT状态机的状态: SAFEOP = 安全操作
 |  | 亮 | EtherCAT状态机的状态: OP = 运行
 |  | 快速闪烁 | EtherCAT状态机的状态: BOOT = 引导程序 (耦合器固件更新)


Firmware compatibility

BECKHOFF EK1110: 附录

固件兼容性

EL1110总线端子模块系列没有更新的固件。