Namespaces

 ScopeAPI
Namespaces
Namespace | Description
TwinCAT.Measurement.ProjectBase |
TwinCAT.Measurement.Scope.API |
TwinCAT.Measurement.Scope.API.Model |
TwinCAT.Measurement.Scope.Control |


TwinCAT.Measurement.ProjectBase Namespace

Classes
 | Class | Description
Public class | MeasurementMemberBase | Base Class for MeasurementMember
Public class | MeasurementMemberContainerBase | Basis Container Implementation
Public class | MeasurementProjectBase | Base Implementation for Project


MeasurementMemberBase Class

Base Class for MeasurementMember
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelSequenceDataSource
TwinCAT.Measurement.Scope.APIReportOptionMember

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public abstract class MeasurementMemberBase : INotifyPropertyChanged,
    INotifyPropertyChanging, IXmlSerializable, ICloneable
Public MustInherit Class MeasurementMemberBase
    Implements INotifyPropertyChanged, INotifyPropertyChanging, IXmlSerializable, ICloneable
public ref class MeasurementMemberBase abstract : INotifyPropertyChanged,
    INotifyPropertyChanging, IXmlSerializable, ICloneable

The MeasurementMemberBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment.
Public property | DisplayColor | Gets or Sets the DisplayColor.
Public property | DragData | Gets the drag data.
Public property | FilePath | Gets or Sets the FilePath.
Public property | Guid | Gets or Sets the Guid.
Public property | HandleException | Gets or Sets the HandleException.
Public property | HasIcon | Determines wether the Icon is initialized
Public property | Icon | Get or Set the Icon
Public property | IsFileBased | Gets or Sets the IsFilebased.
Public property | IsMoving |
Public property | Name | Gets or Sets the Name.
Public property | Namespace | Gets or Sets the Namespace.
Public property | ProjectState | Gets or Sets the ProjectState.
Public property | SortPriority | Gets or Sets the SortPriority.
Public property | Suffix | Gets or sets the Suffix.
Public property | Title | Gets or Sets the Title.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges.
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element
Public method | CloneRecursive | Clone this element recursive
Public method | ConvertT | Convert a Value from String
Public method | Copy | Copy Elements to this Member
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Get all MenuCommands
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements
Public method | ReadXml | Read Element Configuration from XML
Public method | SaveToFile | Save the Member to File. Save is not undoable
Public method | SaveToStream | Save the Project to Current Position of the Stream
Public method | SaveToString | Saves the actual configuration to a xml-string.
Public method | SetCopy | Copy Properties from another member
Public method | SetFromFile | Set Member Properties from File
Public method | SetFromStream | Set Element from Stream
Public method | SetFromString | Set the Member Properties from XML-String
Public method | StartMoving |
Public method | StopMoving |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties
Public method | WriteToString | Write this SubMember to String
Public method | WriteXml | Wrtie Element to XML
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed.
Public event | CommentValidating | Fired while validating the new value for Comment.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed.
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor.
Public event | FilePathChanged | Fired when the FilePath is changed.
Public event | FilePathValidating | Fired while validating the new value for FilePath.
Public event | GuidChanged | Fired when the Guid is changed.
Public event | GuidValidating | Fired while validating the new value for Guid.
Public event | HandleExceptionChanged | Fired when the HandleException is changed.
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException.
Public event | IconChanged | Called when the Icon has Changed
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed.
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased.
 | MessageEvent | The Static Message Event
Public event | NameChanged | Fired when the Name is changed.
Public event | NamespaceChanged | Fired when the Namespace is changed.
Public event | NamespaceValidating | Fired while validating the new value for Namespace.
Public event | NameValidating | Fired while validating the new value for Name.
Public event | OnSaving | Fired on Before Saving the Member
Public event | ProjectStateChanged | Fired when the ProjectState is changed.
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState.
Public event | PropertyChanged | Fired on PropertyChanged
Public event | PropertyChanging | Fired on Before Property Changed
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid
Public event | SortPriorityChanged | Fired when the SortPriority is changed.
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority.
Public event | TitleChanged | Fired when the Title is changed.
Public event | TitleValidating | Fired while validating the new value for Title.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed.
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges.
Top
See Also

Reference

TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase Properties

The MeasurementMemberBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment.
Public property | DisplayColor | Gets or Sets the DisplayColor.
Public property | DragData | Gets the drag data.
Public property | FilePath | Gets or Sets the FilePath.
Public property | Guid | Gets or Sets the Guid.
Public property | HandleException | Gets or Sets the HandleException.
Public property | HasIcon | Determines wether the Icon is initialized
Public property | Icon | Get or Set the Icon
Public property | IsFileBased | Gets or Sets the IsFilebased.
Public property | IsMoving |
Public property | Name | Gets or Sets the Name.
Public property | Namespace | Gets or Sets the Namespace.
Public property | ProjectState | Gets or Sets the ProjectState.
Public property | SortPriority | Gets or Sets the SortPriority.
Public property | Suffix | Gets or sets the Suffix.
Public property | Title | Gets or Sets the Title.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges.
Top
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.Comment Property

Gets or Sets the Comment.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public virtual string Comment { get; set; }
<BrowsableAttribute(true)>
Public Overridable Property Comment As String
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.DisplayColor Property

Gets or Sets the DisplayColor.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public virtual Color DisplayColor { get; set; }
<BrowsableAttribute(true)>
Public Overridable Property DisplayColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property Color DisplayColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.DragData Property

Gets the drag data.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public virtual Object DragData { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property DragData As Object
    Get
public:
[BrowsableAttribute(false)]
virtual property Object^ DragData {
    Object^ get ();
}

Property Value

Type: Object
The drag data.
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.FilePath Property

Gets or Sets the FilePath.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public string FilePath { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property FilePath As String
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property String^ FilePath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.Guid Property

Gets or Sets the Guid.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public Guid Guid { get; set; }
<BrowsableAttribute(false)>
Public Property Guid As Guid
    Get
    Set
public:
[BrowsableAttribute(false)]
property Guid Guid {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.HandleException Property

Gets or Sets the HandleException.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool HandleException { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property HandleException As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool HandleException {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.HasIcon Property

Determines wether the Icon is initialized

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool HasIcon { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property HasIcon As Boolean
    Get
public:
[BrowsableAttribute(false)]
property bool HasIcon {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.Icon Property

Get or Set the Icon

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public Icon Icon { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property Icon As Icon
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property Icon^ Icon {
    Icon^ get ();
    void set (Icon^ value);
}

Property Value

Type: Icon
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.IsFileBased Property

Gets or Sets the IsFilebased.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool IsFileBased { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property IsFileBased As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool IsFileBased {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.IsMoving Property

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool IsMoving { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property IsMoving As Boolean
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool IsMoving {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.Name Property

Gets or Sets the Name.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string Name { get; set; }
<BrowsableAttribute(true)>
Public Property Name As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.Namespace Property

Gets or Sets the Namespace.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public string Namespace { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property Namespace As String
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property String^ Namespace {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.ProjectState Property

Gets or Sets the ProjectState.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public int ProjectState { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property ProjectState As Integer
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property int ProjectState {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.SortPriority Property

Gets or Sets the SortPriority.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public virtual int SortPriority { get; set; }
<BrowsableAttribute(false)>
Public Overridable Property SortPriority As Integer
    Get
    Set
public:
[BrowsableAttribute(false)]
virtual property int SortPriority {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.Suffix Property

Gets or sets the Suffix.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public string Suffix { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property Suffix As String
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property String^ Suffix {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.Title Property

Gets or Sets the Title.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public virtual string Title { get; set; }
<BrowsableAttribute(true)>
Public Overridable Property Title As String
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property String^ Title {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.UnsavedChanges Property

Gets or Sets the UnsavedChanges.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool UnsavedChanges { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property UnsavedChanges As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool UnsavedChanges {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase Methods

The MeasurementMemberBase type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element
Public method | CloneRecursive | Clone this element recursive
Public method | ConvertT | Convert a Value from String
Public method | Copy | Copy Elements to this Member
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Get all MenuCommands
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements
Public method | ReadXml | Read Element Configuration from XML
Public method | SaveToFile | Save the Member to File. Save is not undoable
Public method | SaveToStream | Save the Project to Current Position of the Stream
Public method | SaveToString | Saves the actual configuration to a xml-string.
Public method | SetCopy | Copy Properties from another member
Public method | SetFromFile | Set Member Properties from File
Public method | SetFromStream | Set Element from Stream
Public method | SetFromString | Set the Member Properties from XML-String
Public method | StartMoving |
Public method | StopMoving |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties
Public method | WriteToString | Write this SubMember to String
Public method | WriteXml | Wrtie Element to XML
Top
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.Clone Method

Clone the Current Element

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()

Return Value

Type: Object
The Cloned Element

Implements

ICloneableClone
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.CloneRecursive Method

Clone this element recursive

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual MeasurementMemberBase CloneRecursive()
Public Overridable Function CloneRecursive As MeasurementMemberBase
public:
virtual MeasurementMemberBase^ CloneRecursive()

Return Value

Type: MeasurementMemberBase
Returns the clone
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.Convert(T) Method

Convert a Value from String

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public T Convert<T>(
    string input
)

Public Function Convert(Of T) (
    input As String
) As T
public:
generic<typename T>
T Convert(
    String^ input
)

Parameters

input
Type: SystemString
The String to Convert

Type Parameters

T
The Type to Convert to

Return Value

Type: T
The Converter Value or default
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.Copy Method

Copy Elements to this Member

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void Copy(
    List<Object> Elements,
    bool UseOneParent = false,
    int SortPriority = -1
)
Public Overridable Sub Copy (
    Elements As List(Of Object),
    Optional UseOneParent As Boolean = false,
    Optional SortPriority As Integer = -1
)
public:
virtual void Copy(
    List<Object^>^ Elements,
    bool UseOneParent = false,
    int SortPriority = -1
)

Parameters

Elements
Type: System.Collections.GenericList Object
Elements to Copy
UseOneParent (Optional)
Type: SystemBoolean
Determine wether to use only 1 SubParent
SortPriority (Optional)
Type: SystemInt32
Determine the Sort Priority to use
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.GetCommands Method

Get all MenuCommands

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual MenuCommand[] GetCommands()
Public Overridable Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands()

Return Value

Type: MenuCommand
An array of MenuCommands
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.GetSchema Method

Get the XML-Schema

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public XmlSchema GetSchema()
Public Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() sealed

Return Value

Type: XmlSchema
The XML Schema

Implements

IXmlSerializableGetSchema
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.Link Method

Link the List of Elements to this Member

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void Link(
    List<Object> Elements
)
Public Overridable Sub Link (
    Elements As List(Of Object)
)
public:
virtual void Link(
    List<Object^>^ Elements
)

Parameters

Elements
Type: System.Collections.GenericList Object
The Elements to Link
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.PrepaireInteraction Method

Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual InteractionType PrepaireInteraction(
    List<Object> Elements,
    uint KeyState
)
Public Overridable Function PrepaireInteraction (
    Elements As List(Of Object),
    KeyState As UInteger
) As InteractionType
public:
virtual InteractionType PrepaireInteraction(
    List<Object^>^ Elements,
    unsigned int KeyState
)

Parameters

Elements
Type: System.Collections.GenericList Object
The Elements Draged or Copied
KeyState
Type: SystemUInt32
The State of Strg, ALT and Shift Key

Return Value

Type: InteractionType
The Type of Interaction with this Elements
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.ReadXml Method

Read Element Configuration from XML

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void ReadXml(
    XmlReader reader
)
Public Overridable Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
)

Parameters

reader
Type: System.XmlXmlReader
Reader to read from

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.SaveToFile Method

Save the Member to File. Save is not undoable

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void SaveToFile(
    string filePath
)
Public Overridable Sub SaveToFile (
    filePath As String
)
public:
virtual void SaveToFile(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The File to Save to
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.SaveToStream Method

Save the Project to Current Position of the Stream

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void SaveToStream(
    Stream stream
)
Public Overridable Sub SaveToStream (
    stream As Stream
)
public:
virtual void SaveToStream(
    Stream^ stream
)

Parameters

stream
Type: System.IOStream
The Stream to Save at
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.SaveToString Method

Saves the actual configuration to a xml-string.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public string SaveToString()
Public Function SaveToString As String
public:
String^ SaveToString()

Return Value

Type: String
String with xml-configuration.
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.SetCopy Method

Copy Properties from another member

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void SetCopy(
    MeasurementMemberBase org
)
Public Overridable Sub SetCopy (
    org As MeasurementMemberBase
)
public:
virtual void SetCopy(
    MeasurementMemberBase^ org
)

Parameters

org
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
Member to Copy from
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.SetFromFile Method

Set Member Properties from File

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void SetFromFile(
    string filePath
)
Public Overridable Sub SetFromFile (
    filePath As String
)
public:
virtual void SetFromFile(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The FilePath to Set from
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.SetFromStream Method

Set Element from Stream

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void SetFromStream(
    Stream stream
)
Public Overridable Sub SetFromStream (
    stream As Stream
)
public:
virtual void SetFromStream(
    Stream^ stream
)

Parameters

stream
Type: System.IOStream
Stream to Set from
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.SetFromString Method

Set the Member Properties from XML-String

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void SetFromString(
    string Content
)
Public Overridable Sub SetFromString (
    Content As String
)
public:
virtual void SetFromString(
    String^ Content
)

Parameters

Content
Type: SystemString
The Text to parse
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.StartMoving Method

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void StartMoving()
Public Overridable Sub StartMoving
public:
virtual void StartMoving()
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.StopMoving Method

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void StopMoving()
Public Overridable Sub StopMoving
public:
virtual void StopMoving()
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.UpdatePropertyAttributes Method

Update Attributes of Properties

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void UpdatePropertyAttributes()
Public Overridable Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes()
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.WriteToString Method

Write this SubMember to String

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual string WriteToString()
Public Overridable Function WriteToString As String
public:
virtual String^ WriteToString()

Return Value

Type: String
The String representation for this Element
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.WriteXml Method

Wrtie Element to XML

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void WriteXml(
    XmlWriter writer
)
Public Overridable Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
)

Parameters

writer
Type: System.XmlXmlWriter
Write to Write to

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase Events

The MeasurementMemberBase type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed.
Public event | CommentValidating | Fired while validating the new value for Comment.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed.
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor.
Public event | FilePathChanged | Fired when the FilePath is changed.
Public event | FilePathValidating | Fired while validating the new value for FilePath.
Public event | GuidChanged | Fired when the Guid is changed.
Public event | GuidValidating | Fired while validating the new value for Guid.
Public event | HandleExceptionChanged | Fired when the HandleException is changed.
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException.
Public event | IconChanged | Called when the Icon has Changed
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed.
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased.
 | MessageEvent | The Static Message Event
Public event | NameChanged | Fired when the Name is changed.
Public event | NamespaceChanged | Fired when the Namespace is changed.
Public event | NamespaceValidating | Fired while validating the new value for Namespace.
Public event | NameValidating | Fired while validating the new value for Name.
Public event | OnSaving | Fired on Before Saving the Member
Public event | ProjectStateChanged | Fired when the ProjectState is changed.
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState.
Public event | PropertyChanged | Fired on PropertyChanged
Public event | PropertyChanging | Fired on Before Property Changed
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid
Public event | SortPriorityChanged | Fired when the SortPriority is changed.
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority.
Public event | TitleChanged | Fired when the Title is changed.
Public event | TitleValidating | Fired while validating the new value for Title.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed.
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges.
Top
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.CommentChanged Event

Fired when the Comment is changed.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler CommentChanged
Public Event CommentChanged As EventHandler
public:
 event EventHandler^ CommentChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.CommentValidating Event

Fired while validating the new value for Comment.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> CommentValidating
Public Event CommentValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ CommentValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.DisplayColorChanged Event

Fired when the DisplayColor is changed.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler DisplayColorChanged
Public Event DisplayColorChanged As EventHandler
public:
 event EventHandler^ DisplayColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.DisplayColorValidating Event

Fired while validating the new value for DisplayColor.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DisplayColorValidating
Public Event DisplayColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DisplayColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.FilePathChanged Event

Fired when the FilePath is changed.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler FilePathChanged
Public Event FilePathChanged As EventHandler
public:
 event EventHandler^ FilePathChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.FilePathValidating Event

Fired while validating the new value for FilePath.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> FilePathValidating
Public Event FilePathValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ FilePathValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.GuidChanged Event

Fired when the Guid is changed.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler GuidChanged
Public Event GuidChanged As EventHandler
public:
 event EventHandler^ GuidChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.GuidValidating Event

Fired while validating the new value for Guid.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> GuidValidating
Public Event GuidValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ GuidValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.HandleExceptionChanged Event

Fired when the HandleException is changed.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler HandleExceptionChanged
Public Event HandleExceptionChanged As EventHandler
public:
 event EventHandler^ HandleExceptionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.HandleExceptionValidating Event

Fired while validating the new value for HandleException.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> HandleExceptionValidating
Public Event HandleExceptionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ HandleExceptionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.IconChanged Event

Called when the Icon has Changed

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler IconChanged
Public Event IconChanged As EventHandler
public:
 event EventHandler^ IconChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.IsFilebasedChanged Event

Fired when the IsFilebased is changed.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler IsFilebasedChanged
Public Event IsFilebasedChanged As EventHandler
public:
 event EventHandler^ IsFilebasedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.IsFilebasedValidating Event

Fired while validating the new value for IsFilebased.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IsFilebasedValidating
Public Event IsFilebasedValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IsFilebasedValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.MessageEvent Event

The Static Message Event

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public static event EventHandler<MessageEventArgs> MessageEvent
Public Shared Event MessageEvent As EventHandler(Of MessageEventArgs)
public:
static  event EventHandler<MessageEventArgs^>^ MessageEvent {
    void add (EventHandler<MessageEventArgs^>^ value);
    void remove (EventHandler<MessageEventArgs^>^ value);
}

Value

Type: SystemEventHandler MessageEventArgs
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.NameChanged Event

Fired when the Name is changed.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler NameChanged
Public Event NameChanged As EventHandler
public:
 event EventHandler^ NameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.NamespaceChanged Event

Fired when the Namespace is changed.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler NamespaceChanged
Public Event NamespaceChanged As EventHandler
public:
 event EventHandler^ NamespaceChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.NamespaceValidating Event

Fired while validating the new value for Namespace.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> NamespaceValidating
Public Event NamespaceValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ NamespaceValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.NameValidating Event

Fired while validating the new value for Name.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> NameValidating
Public Event NameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ NameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.OnSaving Event

Fired on Before Saving the Member

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler OnSaving
Public Event OnSaving As EventHandler
public:
 event EventHandler^ OnSaving {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.ProjectStateChanged Event

Fired when the ProjectState is changed.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler ProjectStateChanged
Public Event ProjectStateChanged As EventHandler
public:
 event EventHandler^ ProjectStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.ProjectStateValidating Event

Fired while validating the new value for ProjectState.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ProjectStateValidating
Public Event ProjectStateValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ProjectStateValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.PropertyChanged Event

Fired on PropertyChanged

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.PropertyChanging Event

Fired on Before Property Changed

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event PropertyChangingEventHandler PropertyChanging
Public Event PropertyChanging As PropertyChangingEventHandler
public:
virtual  event PropertyChangingEventHandler^ PropertyChanging {
    void add (PropertyChangingEventHandler^ value);
    void remove (PropertyChangingEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangingEventHandler

Implements

INotifyPropertyChangingPropertyChanging
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.RefreshPropertyGrid Event

Fired to Invalidate the PropertyGrid

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler RefreshPropertyGrid
Public Event RefreshPropertyGrid As EventHandler
public:
 event EventHandler^ RefreshPropertyGrid {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.SortPriorityChanged Event

Fired when the SortPriority is changed.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler SortPriorityChanged
Public Event SortPriorityChanged As EventHandler
public:
 event EventHandler^ SortPriorityChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.SortPriorityValidating Event

Fired while validating the new value for SortPriority.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SortPriorityValidating
Public Event SortPriorityValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SortPriorityValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.TitleChanged Event

Fired when the Title is changed.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler TitleChanged
Public Event TitleChanged As EventHandler
public:
 event EventHandler^ TitleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.TitleValidating Event

Fired while validating the new value for Title.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TitleValidating
Public Event TitleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TitleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.UnsavedChangesChanged Event

Fired when the UnsavedChanges is changed.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler UnsavedChangesChanged
Public Event UnsavedChangesChanged As EventHandler
public:
 event EventHandler^ UnsavedChangesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberBase.UnsavedChangesValidating Event

Fired while validating the new value for UnsavedChanges.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UnsavedChangesValidating
Public Event UnsavedChangesValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UnsavedChangesValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MeasurementMemberBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase Class

Basis Container Implementation
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.ProjectBaseMeasurementProjectBase
TwinCAT.Measurement.Scope.API.ModelRefDataCollector
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public abstract class MeasurementMemberContainerBase : MeasurementMemberBase
Public MustInherit Class MeasurementMemberContainerBase
    Inherits MeasurementMemberBase
public ref class MeasurementMemberContainerBase abstract : public MeasurementMemberBase

The MeasurementMemberContainerBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate
Public method | ClearSubMember | Remove all SubMembers
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate.
Public method | FirstOrDefaultT | Get the First SubElement of Type T
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate
Public method | GetAllSubmember |
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMember | Get all Submember
Public method | GetSubMemberT | Get all Submember of a specific type
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate.
Public method | GetSubMemberT1, T2 | Get all SubMember from the Second Layer
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Overrides MeasurementMemberBaseSetCopy(MeasurementMemberBase).)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Overrides MeasurementMemberBaseSetFromString(String).)
Public method | StartMoving | (Overrides MeasurementMemberBaseStartMoving.)
Public method | StopMoving | (Overrides MeasurementMemberBaseStopMoving.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase Properties

The MeasurementMemberContainerBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.SaveSubMember Property

Gets or Sets the SaveSubMember.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool SaveSubMember { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property SaveSubMember As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool SaveSubMember {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.SubMember Property

Get all SubMember

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public virtual ReadOnlyMeasurementMemberCollection SubMember { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property SubMember As ReadOnlyMeasurementMemberCollection
    Get
public:
[BrowsableAttribute(false)]
virtual property ReadOnlyMeasurementMemberCollection^ SubMember {
    ReadOnlyMeasurementMemberCollection^ get ();
}

Property Value

Type: ReadOnlyMeasurementMemberCollection
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase Methods

The MeasurementMemberContainerBase type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate
Public method | ClearSubMember | Remove all SubMembers
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate.
Public method | FirstOrDefaultT | Get the First SubElement of Type T
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate
Public method | GetAllSubmember |
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMember | Get all Submember
Public method | GetSubMemberT | Get all Submember of a specific type
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate.
Public method | GetSubMemberT1, T2 | Get all SubMember from the Second Layer
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Overrides MeasurementMemberBaseSetCopy(MeasurementMemberBase).)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Overrides MeasurementMemberBaseSetFromString(String).)
Public method | StartMoving | (Overrides MeasurementMemberBaseStartMoving.)
Public method | StopMoving | (Overrides MeasurementMemberBaseStopMoving.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.AddMember Method

Add a Member to the SubMemberCollection

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void AddMember(
    MeasurementMemberBase add
)
Public Overridable Sub AddMember (
    add As MeasurementMemberBase
)
public:
virtual void AddMember(
    MeasurementMemberBase^ add
)

Parameters

add
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
The Member to add
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.AddMemberRange Method

Add a Range of Member to the SubMember Collection

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void AddMemberRange(
    MeasurementMemberBase[] add
)
Public Overridable Sub AddMemberRange (
    add As MeasurementMemberBase()
)
public:
virtual void AddMemberRange(
    array<MeasurementMemberBase^>^ add
)

Parameters

add
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.Any Method

Overload List
 | Name | Description
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate
Top
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.Any(T) Method

Returns true if at least one SubMember of Type T contained in SubMember

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public bool Any<T>()

Public Function Any(Of T) As Boolean
public:
generic<typename T>
bool Any()

Type Parameters

T

Return Value

Type: Boolean
True if any SubMember contained
See Also

Reference

MeasurementMemberContainerBase Class
Any Overload
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.Any(T) Method (Func(T, Boolean))

Determine wether any SubMember of Type T fullfils the predicate

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public bool Any<T>(
    Func<T, bool> predicate
)
where T : class

Public Function Any(Of T As Class) (
    predicate As Func(Of T, Boolean)
) As Boolean
public:
generic<typename T>
where T : ref class
bool Any(
    Func<T, bool>^ predicate
)

Parameters

predicate
Type: SystemFunc T, Boolean
Predicate to fullfil

Type Parameters

T
Type of SubMember

Return Value

Type: Boolean
true if any fullfil the Predicate
See Also

Reference

MeasurementMemberContainerBase Class
Any Overload
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.ClearSubMember Method

Remove all SubMembers

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void ClearSubMember()
Public Overridable Sub ClearSubMember
public:
virtual void ClearSubMember()
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.Contains Method

Determine wether the Member is Contained in SubMemberList

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual bool Contains(
    MeasurementMemberBase member,
    bool recursive = false
)
Public Overridable Function Contains (
    member As MeasurementMemberBase,
    Optional recursive As Boolean = false
) As Boolean
public:
virtual bool Contains(
    MeasurementMemberBase^ member,
    bool recursive = false
)

Parameters

member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
The Member to check
recursive (Optional)
Type: SystemBoolean
Determine wether to search Recursive in all SubMember

Return Value

Type: Boolean
True if the Member is conained
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.Find(T) Method

Find the first SubMember of Type T, which fulfils the predicate.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public bool Find<T>(
    Func<T, bool> predicate,
    out T value
)
where T : class

Public Function Find(Of T As Class) (
    predicate As Func(Of T, Boolean),
    <OutAttribute> ByRef value As T
) As Boolean
public:
generic<typename T>
where T : ref class
bool Find(
    Func<T, bool>^ predicate,
    [OutAttribute] T% value
)

Parameters

predicate
Type: SystemFunc T, Boolean
The predicate to fulfil
value
Type: T
The found value or null if no value was found

Type Parameters

T
The Type to search for

Return Value

Type: Boolean
if an SubMember fulfils the predicate otherwise
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.FirstOrDefault Method

Overload List
 | Name | Description
Public method | FirstOrDefaultT | Get the First SubElement of Type T
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate
Top
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.FirstOrDefault(T) Method

Get the First SubElement of Type T

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public T FirstOrDefault<T>()

Public Function FirstOrDefault(Of T) As T
public:
generic<typename T>
T FirstOrDefault()

Type Parameters

T
The Type search for

Return Value

Type: T
The First Element or default/null if no Element was found
See Also

Reference

MeasurementMemberContainerBase Class
FirstOrDefault Overload
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.FirstOrDefault(T) Method (Func(T, Boolean))

Get the First SubElement of Type T, which fulfils the predicate

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public T FirstOrDefault<T>(
    Func<T, bool> predicate
)

Public Function FirstOrDefault(Of T) (
    predicate As Func(Of T, Boolean)
) As T
public:
generic<typename T>
T FirstOrDefault(
    Func<T, bool>^ predicate
)

Parameters

predicate
Type: SystemFunc T, Boolean
predicate to fulfil

Type Parameters

T
Type to search for

Return Value

Type: T
The first found or default/null
See Also

Reference

MeasurementMemberContainerBase Class
FirstOrDefault Overload
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.GetAllSubmember Method

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public IEnumerable<MeasurementMemberBase> GetAllSubmember(
    Type searchType,
    Func<MeasurementMemberContainerBase, int, bool> continueRecursiv = null
)
Public Function GetAllSubmember (
    searchType As Type,
    Optional continueRecursiv As Func(Of MeasurementMemberContainerBase, Integer, Boolean) = Nothing
) As IEnumerable(Of MeasurementMemberBase)
public:
IEnumerable<MeasurementMemberBase^>^ GetAllSubmember(
    Type^ searchType,
    Func<MeasurementMemberContainerBase^, int, bool>^ continueRecursiv = nullptr
)

Parameters

searchType
Type: SystemType
Type of the Searched Value
continueRecursiv (Optional)
Type: SystemFunc MeasurementMemberContainerBase, Int32, Boolean
If return true continue in SubMember of Element

Return Value

Type: IEnumerable MeasurementMemberBase
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.GetSubMember Method

Overload List
 | Name | Description
Public method | GetSubMemberT | Get all Submember of a specific type
Public method | GetSubMember | Get all Submember
Public method | GetSubMemberT1, T2 | Get all SubMember from the Second Layer
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate.
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer
Top
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.GetSubMember(T) Method

Get all Submember of a specific type

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public IEnumerable<T> GetSubMember<T>()

Public Function GetSubMember(Of T) As IEnumerable(Of T)
public:
generic<typename T>
IEnumerable<T>^ GetSubMember()

Type Parameters

T
Type to search for

Return Value

Type: IEnumerable T
Enumerable of elements
See Also

Reference

MeasurementMemberContainerBase Class
GetSubMember Overload
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.GetSubMember Method

Get all Submember

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public IEnumerable<MeasurementMemberBase> GetSubMember()
Public Function GetSubMember As IEnumerable(Of MeasurementMemberBase)
public:
IEnumerable<MeasurementMemberBase^>^ GetSubMember()

Return Value

Type: IEnumerable MeasurementMemberBase
Enumerable of elements
See Also

Reference

MeasurementMemberContainerBase Class
GetSubMember Overload
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.GetSubMember(T1, T2) Method

Get all SubMember from the Second Layer

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public IEnumerable<T2> GetSubMember<T1, T2>()
where T1 : MeasurementMemberContainerBase

Public Function GetSubMember(Of T1 As MeasurementMemberContainerBase, T2) As IEnumerable(Of T2)
public:
generic<typename T1, typename T2>
where T1 : MeasurementMemberContainerBase
IEnumerable<T2>^ GetSubMember()

Type Parameters

T1
Type in Layer 1
T2
Type in Layer 2

Return Value

Type: IEnumerable T2
Elements of Layer 2
See Also

Reference

MeasurementMemberContainerBase Class
GetSubMember Overload
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.GetSubMember(T) Method (Func(T, Boolean))

Filter GetSubMemberT by predicate.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public IEnumerable<T> GetSubMember<T>(
    Func<T, bool> predicate
)

Public Function GetSubMember(Of T) (
    predicate As Func(Of T, Boolean)
) As IEnumerable(Of T)
public:
generic<typename T>
IEnumerable<T>^ GetSubMember(
    Func<T, bool>^ predicate
)

Parameters

predicate
Type: SystemFunc T, Boolean

Type Parameters

T

Return Value

Type: IEnumerable T
See Also

Reference

MeasurementMemberContainerBase Class
GetSubMember Overload
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.GetSubMember(T1, T2) Method (Func(T2, Boolean))

Get all SubMember from the Second Layer

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public IEnumerable<T2> GetSubMember<T1, T2>(
    Func<T2, bool> predicate
)
where T1 : MeasurementMemberContainerBase

Public Function GetSubMember(Of T1 As MeasurementMemberContainerBase, T2) (
    predicate As Func(Of T2, Boolean)
) As IEnumerable(Of T2)
public:
generic<typename T1, typename T2>
where T1 : MeasurementMemberContainerBase
IEnumerable<T2>^ GetSubMember(
    Func<T2, bool>^ predicate
)

Parameters

predicate
Type: SystemFunc T2, Boolean

Type Parameters

T1
Type in Layer 1
T2
Type in Layer 2

Return Value

Type: IEnumerable T2
Elements of Layer 2
See Also

Reference

MeasurementMemberContainerBase Class
GetSubMember Overload
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.MeasurementMemberContainerBase_MemberContentChanged Method

Used to Handle MemberContentChanged-Event of an SubMember

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void MeasurementMemberContainerBase_MemberContentChanged(
    Object sender,
    ContentChangedArgs<MeasurementMemberBase> e
)
Public Overridable Sub MeasurementMemberContainerBase_MemberContentChanged (
    sender As Object,
    e As ContentChangedArgs(Of MeasurementMemberBase)
)
public:
virtual void MeasurementMemberContainerBase_MemberContentChanged(
    Object^ sender,
    ContentChangedArgs<MeasurementMemberBase^>^ e
)

Parameters

sender
Type: SystemObject
The sender
e
Type: ContentChangedArgsMeasurementMemberBase
The EventArgs
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.MeasurementMemberContainerBase_SubMemberContentChanged Method

Used to Handle SubMemberContentChanged-Event of an SubMember

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void MeasurementMemberContainerBase_SubMemberContentChanged(
    Object sender,
    SubContentChangedEventArgs<MeasurementMemberContainerBase, MeasurementMemberBase> e
)
Public Overridable Sub MeasurementMemberContainerBase_SubMemberContentChanged (
    sender As Object,
    e As SubContentChangedEventArgs(Of MeasurementMemberContainerBase, MeasurementMemberBase)
)
public:
virtual void MeasurementMemberContainerBase_SubMemberContentChanged(
    Object^ sender,
    SubContentChangedEventArgs<MeasurementMemberContainerBase^, MeasurementMemberBase^>^ e
)

Parameters

sender
Type: SystemObject
The sneder
e
Type: SubContentChangedEventArgsMeasurementMemberContainerBase, MeasurementMemberBase
The EventArgs
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.Move Method

Overload List
 | Name | Description
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container
Top
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.Move Method (List(Tuple(MeasurementMemberContainerBase, MeasurementMemberBase)), Boolean, Int32)

Move Elements to this Container

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void Move(
    List<Tuple<MeasurementMemberContainerBase, MeasurementMemberBase>> Pairs,
    bool UseOneParent = false,
    int SortPriority = -1
)
Public Overridable Sub Move (
    Pairs As List(Of Tuple(Of MeasurementMemberContainerBase, MeasurementMemberBase)),
    Optional UseOneParent As Boolean = false,
    Optional SortPriority As Integer = -1
)
public:
virtual void Move(
    List<Tuple<MeasurementMemberContainerBase^, MeasurementMemberBase^>^>^ Pairs,
    bool UseOneParent = false,
    int SortPriority = -1
)

Parameters

Pairs
Type: System.Collections.GenericList Tuple MeasurementMemberContainerBase, MeasurementMemberBase
Pairs of old Parent and Member
UseOneParent (Optional)
Type: SystemBoolean
Determine wether to use only 1 SubParent
SortPriority (Optional)
Type: SystemInt32
The SortPriority of the new Member
See Also

Reference

MeasurementMemberContainerBase Class
Move Overload
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.Move Method (MeasurementMemberContainerBase, MeasurementMemberBase, Int32)

Move Element to this Container

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void Move(
    MeasurementMemberContainerBase SourceParent,
    MeasurementMemberBase Element,
    int SortPriority = -1
)
Public Overridable Sub Move (
    SourceParent As MeasurementMemberContainerBase,
    Element As MeasurementMemberBase,
    Optional SortPriority As Integer = -1
)
public:
virtual void Move(
    MeasurementMemberContainerBase^ SourceParent,
    MeasurementMemberBase^ Element,
    int SortPriority = -1
)

Parameters

SourceParent
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
The Old Parent
Element
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
The Element to Move
SortPriority (Optional)
Type: SystemInt32
The SortPriority
See Also

Reference

MeasurementMemberContainerBase Class
Move Overload
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.RemoveMember Method

Remove a Member from the SubMemberList

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void RemoveMember(
    MeasurementMemberBase rem
)
Public Overridable Sub RemoveMember (
    rem As MeasurementMemberBase
)
public:
virtual void RemoveMember(
    MeasurementMemberBase^ rem
)

Parameters

rem
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
The Member to Remove
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.RemoveMemberRange Method

Remove a Range of Member from the SubMemberList

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public virtual void RemoveMemberRange(
    MeasurementMemberBase[] rem
)
Public Overridable Sub RemoveMemberRange (
    rem As MeasurementMemberBase()
)
public:
virtual void RemoveMemberRange(
    array<MeasurementMemberBase^>^ rem
)

Parameters

rem
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
Member to Remove
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.SetCopy Method

Copy Properties from another member

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public override void SetCopy(
    MeasurementMemberBase org
)
Public Overrides Sub SetCopy (
    org As MeasurementMemberBase
)
public:
virtual void SetCopy(
    MeasurementMemberBase^ org
) override

Parameters

org
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
Member to Copy from
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.SetFromString Method

Set the Member Properties from XML-String

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public override void SetFromString(
    string Content
)
Public Overrides Sub SetFromString (
    Content As String
)
public:
virtual void SetFromString(
    String^ Content
) override

Parameters

Content
Type: SystemString
The Text to parse
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.StartMoving Method

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public override void StartMoving()
Public Overrides Sub StartMoving
public:
virtual void StartMoving() override
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.StopMoving Method

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public override void StopMoving()
Public Overrides Sub StopMoving
public:
virtual void StopMoving() override
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase Events

The MeasurementMemberContainerBase type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.MemberContentChanged Event

Fired after memberContent has changed

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ContentChangedArgs<MeasurementMemberBase>> MemberContentChanged
Public Event MemberContentChanged As EventHandler(Of ContentChangedArgs(Of MeasurementMemberBase))
public:
 event EventHandler<ContentChangedArgs<MeasurementMemberBase^>^>^ MemberContentChanged {
    void add (EventHandler<ContentChangedArgs<MeasurementMemberBase^>^>^ value);
    void remove (EventHandler<ContentChangedArgs<MeasurementMemberBase^>^>^ value);
}

Value

Type: SystemEventHandler ContentChangedArgsMeasurementMemberBase
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementMemberContainerBase.SubMemberContentChanged Event

Event fired, when an element was added to an SubMember

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<SubContentChangedEventArgs<MeasurementMemberContainerBase, MeasurementMemberBase>> SubMemberContentChanged
Public Event SubMemberContentChanged As EventHandler(Of SubContentChangedEventArgs(Of MeasurementMemberContainerBase, MeasurementMemberBase))
public:
 event EventHandler<SubContentChangedEventArgs<MeasurementMemberContainerBase^, MeasurementMemberBase^>^>^ SubMemberContentChanged {
    void add (EventHandler<SubContentChangedEventArgs<MeasurementMemberContainerBase^, MeasurementMemberBase^>^>^ value);
    void remove (EventHandler<SubContentChangedEventArgs<MeasurementMemberContainerBase^, MeasurementMemberBase^>^>^ value);
}

Value

Type: SystemEventHandler SubContentChangedEventArgsMeasurementMemberContainerBase, MeasurementMemberBase
See Also

Reference

MeasurementMemberContainerBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementProjectBase Class

Base Implementation for Project
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.ProjectBaseMeasurementProjectBase
TwinCAT.Measurement.Scope.API.ModelScopeProjectBase

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public abstract class MeasurementProjectBase : MeasurementMemberContainerBase
Public MustInherit Class MeasurementProjectBase
    Inherits MeasurementMemberContainerBase
public ref class MeasurementProjectBase abstract : public MeasurementMemberContainerBase

The MeasurementProjectBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | EnabledUndoRedoStack | Gets or Sets the EnabledUndoRedoStack.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | Version | Gets or Sets the Version.
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Overrides MeasurementMemberBaseSetFromStream(Stream).)
Public method | SetFromString | Set the Member Properties from XML-String (Overrides MeasurementMemberContainerBaseSetFromString(String).)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | VersionChanged | Fired when the Version is changed.
Public event | VersionValidating | Fired while validating the new value for Version.
Top
See Also

Reference

TwinCAT.Measurement.ProjectBase Namespace


MeasurementProjectBase Properties

The MeasurementProjectBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | EnabledUndoRedoStack | Gets or Sets the EnabledUndoRedoStack.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | Version | Gets or Sets the Version.
Top
See Also

Reference

MeasurementProjectBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementProjectBase.EnabledUndoRedoStack Property

Gets or Sets the EnabledUndoRedoStack.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public bool EnabledUndoRedoStack { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property EnabledUndoRedoStack As Boolean
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property bool EnabledUndoRedoStack {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MeasurementProjectBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementProjectBase.Version Property

Gets or Sets the Version.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Version Version { get; }
<BrowsableAttribute(true)>
Public ReadOnly Property Version As Version
    Get
public:
[BrowsableAttribute(true)]
property Version^ Version {
    Version^ get ();
}

Property Value

Type: Version
See Also

Reference

MeasurementProjectBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementProjectBase Methods

The MeasurementProjectBase type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Overrides MeasurementMemberBaseSetFromStream(Stream).)
Public method | SetFromString | Set the Member Properties from XML-String (Overrides MeasurementMemberContainerBaseSetFromString(String).)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MeasurementProjectBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementProjectBase.SetFromStream Method

Set Element from Stream

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public override void SetFromStream(
    Stream stream
)
Public Overrides Sub SetFromStream (
    stream As Stream
)
public:
virtual void SetFromStream(
    Stream^ stream
) override

Parameters

stream
Type: System.IOStream
Stream to Set from
See Also

Reference

MeasurementProjectBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementProjectBase.SetFromString Method

Set the Member Properties from XML-String

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public override void SetFromString(
    string Content
)
Public Overrides Sub SetFromString (
    Content As String
)
public:
virtual void SetFromString(
    String^ Content
) override

Parameters

Content
Type: SystemString
The Text to parse
See Also

Reference

MeasurementProjectBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementProjectBase Events

The MeasurementProjectBase type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | VersionChanged | Fired when the Version is changed.
Public event | VersionValidating | Fired while validating the new value for Version.
Top
See Also

Reference

MeasurementProjectBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementProjectBase.VersionChanged Event

Fired when the Version is changed.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler VersionChanged
Public Event VersionChanged As EventHandler
public:
 event EventHandler^ VersionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MeasurementProjectBase Class
TwinCAT.Measurement.ProjectBase Namespace


MeasurementProjectBase.VersionValidating Event

Fired while validating the new value for Version.

Namespace: TwinCAT.Measurement.ProjectBase
Assembly: TwinCAT.Measurement.ProjectBase (in TwinCAT.Measurement.ProjectBase.dll) Version: 3.4.4000.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> VersionValidating
Public Event VersionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ VersionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MeasurementProjectBase Class
TwinCAT.Measurement.ProjectBase Namespace


TwinCAT.Measurement.Scope.API Namespace

Classes
 | Class | Description
Public class | AxisOptions | Class prevents all UserOptions for Axes
Public class | ChannelOptions | Class prevents all UserOptions for Channels
Public class | ChartOptions | Class prevents all UserOptions for Charts
Public class | ChartTimePosEventArgs | EventArgs containing the actual Chart Times
Public class | CompressionOptionConverter |
Public class | CopyClipboardStartupArgs | Event arguments class for starting the copy to clipboard tool.
Public class | CopyToClipboardArgs |
Public class | CreateAcquisitionEventArgs |
Public class | DirectoryDiagArgs |
Public class | ElementGUIDEventArgs |
Public class | ExportEventArgs | EventArgs for Export Event
Public class | ExportEventArgsChannelFrame | Hold data for event-export.
Public class | ExportEventArgsXYChannelFrame | The XYChannelFrame specialized the ChannelFrame for an XY-Channel.
Public class | FindEditorArgs |
Public class | FindMemberHelper |
Public class | InteractionHelper |
Public class | InvalidFileException |
Public class | Marker3DPartsConverter | Converts the Markertype into a string
Public class | OpcException | Base Class for all Scope OPC Exceptions
Public class | OpcServerNotTrustedException | Exception thrown on try to connect untrusted OPC Channel
Public class | OpcWrongCredentialsException | Exception throw if Opc Credentials are wrong
Public class | OrderDataEventArgs |
Public class | ProjectBaseDesignPropertyDescriptorBase |
Public class | ProjectHelper | Project Helper Class
Public class | PropertyUpdater | PropertyUpdater can Bind a Property to an Value
Public class | RemoteImageTriggerReleaseArgs |
Public class | ReportArgs |
Public class | ReportAutomaticArgs |
Public class | ReportManualArgs |
Public class | ReportOptionMember | UserSettings for the ScopeReport
Public class | ReportOptions | ReportOptions
Public class | RetryEventArgs | EventArgs to Ask for a Retry
Public class | ScopeConverterSVDToSVDX | Converts a .svd to .svdx
Public class | ScopeConverterSvdxToSvd | Converter to Convert from SVDX to SVD
Public class | ScopeConverterSVProjectToTcScope | Class to convert a ScopeProject to a ScopeViewControl
Public class | ScopeConverterTcScopeToTcScopeX | Converts a .tcscope to .tcscopex
Public class | SymbolInfo | SymbolInfo class parsing TB XML-String
Public class | SymbolInfoCollection | SymbolInfo Collection to Parse TB-XML-String
Public class | TriggerGroupContentChangedEventArgs | Classed used to fire TriggerGroupContentChangedEvents
Public class | TriggerWindowControlRowM | Holds the data for a row in the trigger window.
Public class | TypeInfo | TypeInfo for deserializing from TargetBrowser-XML
Public class | TypeInfoCollection | TypeInfoCollection for deserializing DataTypes from TB-XML
Public class | TypePropertyInfo |
Public class | UnkownProductVersionException | Exception thrown in case of an invalid Product Version.
Public class | UpdateDataSequenceEventArgs | AddDataEventArgs for Sequences.
Public class | WrongChildTypeException | Exception class used if Child with wrong Type is added to MeasurementMemberContainerBase
Public class | WrongConfigurationException | Exception class fired, when an invalid Scope Configuration is detected
Public class | WrongDisplayModeException | ExceptionClass used to show wrong DisplayMode
Public class | WrongScopeStateException | Exception Typ used to show WrongScopeState
Enumerations
 | Enumeration | Description
Public enumeration | AutoSaveModes | Modes of AutoSave
Public enumeration | AxisOrientation | Enum describing the Orientation of an Axis
Public enumeration | ButtonsEnabled | Enum describing the Buttonstate of the ChartPannel
Public enumeration | ChannelHighlightingMode | An Enum of the useable Channel-Highlighting.
Public enumeration | ChartType | Enum describing the Type of a Chart
Public enumeration | CompareOperators | Enum for CompareOperators
Public enumeration | ConditionLinkOptions | Determines how the Conditions of an Dynamic Style or Combined
Public enumeration | CursorAlignment | Enum describing the Cursor Alignment
Public enumeration | DataBaseType | Defines the Type of DataBase to Export to
Public enumeration | DataModifyOptions | Different actions that can be made in Sequences.
Public enumeration | DataUsage | Enum describing the usage of the data collect for an AcquisitionInterpreter
Public enumeration | Direction | Indicates a direction for chart-operations.
Public enumeration | EventExportMode | EventExportMode Enumeration
Public enumeration | GraphFillMode | The Fillmode of the Graph
Public enumeration | ImagesAutoDeleteMode | Auto Delete Mode
Public enumeration | Linestate | Enum to describe LinestateSettings
Public enumeration | MarkConfiguration | Enum decribing the MarkState
Public enumeration | Marker3DParts | Defines the Visible Parts of the Canvas Border
Public enumeration | MarkerTable_ChooserType | Defines two Types for the Marker Table Chooser
Public enumeration | MarkerType | Define the Type of Marker
Public enumeration | MouseModes | Enum describing the MouseMode
Public enumeration | ReportChartBackground | Modes of Report Chart Background
Public enumeration | RunMode | Defines how the record starts up
Public enumeration | ScopeDisplayModes | The possible displaymodes to update the display in live-mode.
Public enumeration | ScopeLicense | Defines different types of licenses for scope
Public enumeration | ScopeViewDetailLevel | View Detail Level of the Scope Project
Public enumeration | ScopeViewState | Enum representing the State of the Scope Project
Public enumeration | SequenceExportLocations |
Public enumeration | SequenceExportOptions | Options for saving the data of a sequence.
Public enumeration | ShapeFillMode | The Fillmode of a Shape
Public enumeration | ShowErrorLog | ShowErrorLogs shows the state of the Messages in the Errorlog
Public enumeration | StringType | Defines the Type of an string
Public enumeration | StyleType | Define the Style of an ChartLayer
Public enumeration | SymbolArea | SymbolArea
Public enumeration | TimeRefreshMode | define the time refresh mode for chart layer
Public enumeration | TimesEnabled | Flag enum to hold visible Time-labels.
Public enumeration | TimeSynchronisationModes | Defines the Mode of Timesynchronisation
Public enumeration | TriggerCombineOptions | Defines possible Trigger combinations
Public enumeration | TriggerExportTimeModes | Modes of TriggerExport Times
Public enumeration | UseColorFrom |
Public enumeration | UseTitleFrom | use title from other property


AutoSaveModes Enumeration

Modes of AutoSave

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum AutoSaveModes
Public Enumeration AutoSaveModes
public enum class AutoSaveModes
Members
Member name | Value | Description
None | 0 | No Autosave
SVDX | 1 | Save full Configuration and data
Export | 2 | Export data on AutoSave
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


AxisOptions Class

Class prevents all UserOptions for Axes
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APIAxisOptions

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class AxisOptions
Public Class AxisOptions
public ref class AxisOptions

The AxisOptions type exposes the following members.

Properties
 | Name | Description
Public property | CanvasColor | Get or Set the CanvasColor
Public property | Comment | Get or Set the Comment
Public property | GridColor | Get or Set the GridColor
Public property | GridDivisions | Get or Set the Grid Divisions
Public property | GridLineWidth | Get or Set the GridLineWidth
Public property | IndexAxisInverted | Get or Set the Inverted Property of Index Axes
Public property | IndexAxisManualMax | Get or Set the Manual Max of Index Axes
Public property | IndexAxisManualMin | Get or Set the Manual Min of Index Axes
Public property | IndexAxisScalingMode | Get or Set the ScaleMode of IndexAxes
Public property | IndexColorMode | Get or Set the Color Mode Property of Index Axes
Public property | KeepAspectRatio | Get or Set KeepAspectRatio
Public property | LineColor | Get or Set the Line Color
Public property | LineWidth | Get or Set the LineWidth
Public property | Precision | Get or Set the Precision
Public property | ReferenceAxis | Get or Set the ReferenceAxis
Public property | ShowName | Get or Set the Show Name Property
Public property | ShowTitle | Get or Set the ShowTitle
Public property | SubGridDivisions | Get or Set the SubGridDivisions
Public property | TimeAxisInverted | Get or Set the Inverted Property of TimeAxes
Public property | TimeColorMode | Get or Set the Color Mode Property of Index Axes
Public property | UseGrid | Get or Set the Grid Visibility
Public property | UseScientificNotation | Get or Set the Precision
Public property | UseSubGrid | Get or Set the SubGrid Visibility
Public property | ValueAxisInverted | Get or Set the Inverted of the ValueAxis
Public property | ValueAxisLogarithmic | Get or Set Logarithmic Properties of ValueAxes
Public property | ValueAxisManualMax | Get or Set the Manual Max of an Value Axis
Public property | ValueAxisManualMin | Get or Set the Manual Min of the ValueAxis
Public property | ValueAxisScalingMode | Get or Set the ScaleMode of the Value Axis
Public property | ValueColorMode | Get or Set the Color Mode Property of Index Axes
Public property | Visible | Get or Set the Visibility
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


AxisOptions Properties

The AxisOptions type exposes the following members.

Properties
 | Name | Description
Public property | CanvasColor | Get or Set the CanvasColor
Public property | Comment | Get or Set the Comment
Public property | GridColor | Get or Set the GridColor
Public property | GridDivisions | Get or Set the Grid Divisions
Public property | GridLineWidth | Get or Set the GridLineWidth
Public property | IndexAxisInverted | Get or Set the Inverted Property of Index Axes
Public property | IndexAxisManualMax | Get or Set the Manual Max of Index Axes
Public property | IndexAxisManualMin | Get or Set the Manual Min of Index Axes
Public property | IndexAxisScalingMode | Get or Set the ScaleMode of IndexAxes
Public property | IndexColorMode | Get or Set the Color Mode Property of Index Axes
Public property | KeepAspectRatio | Get or Set KeepAspectRatio
Public property | LineColor | Get or Set the Line Color
Public property | LineWidth | Get or Set the LineWidth
Public property | Precision | Get or Set the Precision
Public property | ReferenceAxis | Get or Set the ReferenceAxis
Public property | ShowName | Get or Set the Show Name Property
Public property | ShowTitle | Get or Set the ShowTitle
Public property | SubGridDivisions | Get or Set the SubGridDivisions
Public property | TimeAxisInverted | Get or Set the Inverted Property of TimeAxes
Public property | TimeColorMode | Get or Set the Color Mode Property of Index Axes
Public property | UseGrid | Get or Set the Grid Visibility
Public property | UseScientificNotation | Get or Set the Precision
Public property | UseSubGrid | Get or Set the SubGrid Visibility
Public property | ValueAxisInverted | Get or Set the Inverted of the ValueAxis
Public property | ValueAxisLogarithmic | Get or Set Logarithmic Properties of ValueAxes
Public property | ValueAxisManualMax | Get or Set the Manual Max of an Value Axis
Public property | ValueAxisManualMin | Get or Set the Manual Min of the ValueAxis
Public property | ValueAxisScalingMode | Get or Set the ScaleMode of the Value Axis
Public property | ValueColorMode | Get or Set the Color Mode Property of Index Axes
Public property | Visible | Get or Set the Visibility
Top
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.CanvasColor Property

Get or Set the CanvasColor

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color CanvasColor { get; set; }
Public Property CanvasColor As Color
    Get
    Set
public:
property Color CanvasColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.Comment Property

Get or Set the Comment

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.GridColor Property

Get or Set the GridColor

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color GridColor { get; set; }
Public Property GridColor As Color
    Get
    Set
public:
property Color GridColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.GridDivisions Property

Get or Set the Grid Divisions

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int GridDivisions { get; set; }
Public Property GridDivisions As Integer
    Get
    Set
public:
property int GridDivisions {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.GridLineWidth Property

Get or Set the GridLineWidth

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int GridLineWidth { get; set; }
Public Property GridLineWidth As Integer
    Get
    Set
public:
property int GridLineWidth {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.IndexAxisInverted Property

Get or Set the Inverted Property of Index Axes

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool IndexAxisInverted { get; set; }
Public Property IndexAxisInverted As Boolean
    Get
    Set
public:
property bool IndexAxisInverted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.IndexAxisManualMax Property

Get or Set the Manual Max of Index Axes

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public double IndexAxisManualMax { get; set; }
Public Property IndexAxisManualMax As Double
    Get
    Set
public:
property double IndexAxisManualMax {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.IndexAxisManualMin Property

Get or Set the Manual Min of Index Axes

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public double IndexAxisManualMin { get; set; }
Public Property IndexAxisManualMin As Double
    Get
    Set
public:
property double IndexAxisManualMin {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.IndexAxisScalingMode Property

Get or Set the ScaleMode of IndexAxes

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScaleModes IndexAxisScalingMode { get; set; }
Public Property IndexAxisScalingMode As ScaleModes
    Get
    Set
public:
property ScaleModes IndexAxisScalingMode {
    ScaleModes get ();
    void set (ScaleModes value);
}

Property Value

Type: ScaleModes
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.IndexColorMode Property

Get or Set the Color Mode Property of Index Axes

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public UseColorFrom IndexColorMode { get; set; }
Public Property IndexColorMode As UseColorFrom
    Get
    Set
public:
property UseColorFrom IndexColorMode {
    UseColorFrom get ();
    void set (UseColorFrom value);
}

Property Value

Type: UseColorFrom
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.KeepAspectRatio Property

Get or Set KeepAspectRatio

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool KeepAspectRatio { get; set; }
Public Property KeepAspectRatio As Boolean
    Get
    Set
public:
property bool KeepAspectRatio {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.LineColor Property

Get or Set the Line Color

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color LineColor { get; set; }
Public Property LineColor As Color
    Get
    Set
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.LineWidth Property

Get or Set the LineWidth

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int LineWidth { get; set; }
Public Property LineWidth As Integer
    Get
    Set
public:
property int LineWidth {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.Precision Property

Get or Set the Precision

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int Precision { get; set; }
Public Property Precision As Integer
    Get
    Set
public:
property int Precision {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.ReferenceAxis Property

Get or Set the ReferenceAxis

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AxisOrientation ReferenceAxis { get; set; }
Public Property ReferenceAxis As AxisOrientation
    Get
    Set
public:
property AxisOrientation ReferenceAxis {
    AxisOrientation get ();
    void set (AxisOrientation value);
}

Property Value

Type: AxisOrientation
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.ShowName Property

Get or Set the Show Name Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public UseTitleFrom ShowName { get; set; }
Public Property ShowName As UseTitleFrom
    Get
    Set
public:
property UseTitleFrom ShowName {
    UseTitleFrom get ();
    void set (UseTitleFrom value);
}

Property Value

Type: UseTitleFrom
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.ShowTitle Property

Get or Set the ShowTitle

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public UseTitleFrom ShowTitle { get; set; }
Public Property ShowTitle As UseTitleFrom
    Get
    Set
public:
property UseTitleFrom ShowTitle {
    UseTitleFrom get ();
    void set (UseTitleFrom value);
}

Property Value

Type: UseTitleFrom
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.SubGridDivisions Property

Get or Set the SubGridDivisions

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int SubGridDivisions { get; set; }
Public Property SubGridDivisions As Integer
    Get
    Set
public:
property int SubGridDivisions {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.TimeAxisInverted Property

Get or Set the Inverted Property of TimeAxes

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool TimeAxisInverted { get; set; }
Public Property TimeAxisInverted As Boolean
    Get
    Set
public:
property bool TimeAxisInverted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.TimeColorMode Property

Get or Set the Color Mode Property of Index Axes

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public UseColorFrom TimeColorMode { get; set; }
Public Property TimeColorMode As UseColorFrom
    Get
    Set
public:
property UseColorFrom TimeColorMode {
    UseColorFrom get ();
    void set (UseColorFrom value);
}

Property Value

Type: UseColorFrom
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.UseGrid Property

Get or Set the Grid Visibility

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool UseGrid { get; set; }
Public Property UseGrid As Boolean
    Get
    Set
public:
property bool UseGrid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.UseScientificNotation Property

Get or Set the Precision

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool UseScientificNotation { get; set; }
Public Property UseScientificNotation As Boolean
    Get
    Set
public:
property bool UseScientificNotation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.UseSubGrid Property

Get or Set the SubGrid Visibility

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool UseSubGrid { get; set; }
Public Property UseSubGrid As Boolean
    Get
    Set
public:
property bool UseSubGrid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.ValueAxisInverted Property

Get or Set the Inverted of the ValueAxis

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool ValueAxisInverted { get; set; }
Public Property ValueAxisInverted As Boolean
    Get
    Set
public:
property bool ValueAxisInverted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.ValueAxisLogarithmic Property

Get or Set Logarithmic Properties of ValueAxes

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool ValueAxisLogarithmic { get; set; }
Public Property ValueAxisLogarithmic As Boolean
    Get
    Set
public:
property bool ValueAxisLogarithmic {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.ValueAxisManualMax Property

Get or Set the Manual Max of an Value Axis

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public double ValueAxisManualMax { get; set; }
Public Property ValueAxisManualMax As Double
    Get
    Set
public:
property double ValueAxisManualMax {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.ValueAxisManualMin Property

Get or Set the Manual Min of the ValueAxis

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public double ValueAxisManualMin { get; set; }
Public Property ValueAxisManualMin As Double
    Get
    Set
public:
property double ValueAxisManualMin {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.ValueAxisScalingMode Property

Get or Set the ScaleMode of the Value Axis

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScaleModes ValueAxisScalingMode { get; set; }
Public Property ValueAxisScalingMode As ScaleModes
    Get
    Set
public:
property ScaleModes ValueAxisScalingMode {
    ScaleModes get ();
    void set (ScaleModes value);
}

Property Value

Type: ScaleModes
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.ValueColorMode Property

Get or Set the Color Mode Property of Index Axes

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public UseColorFrom ValueColorMode { get; set; }
Public Property ValueColorMode As UseColorFrom
    Get
    Set
public:
property UseColorFrom ValueColorMode {
    UseColorFrom get ();
    void set (UseColorFrom value);
}

Property Value

Type: UseColorFrom
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions.Visible Property

Get or Set the Visibility

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOptions Methods

The AxisOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AxisOptions Class
TwinCAT.Measurement.Scope.API Namespace


AxisOrientation Enumeration

Enum describing the Orientation of an Axis

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum AxisOrientation
Public Enumeration AxisOrientation
public enum class AxisOrientation
Members
Member name | Value | Description
X | 1 | Width
Y | 2 | Height
Z | 3 | Depth
Ring | 4 | Ring orientation
Radial | 5 | Radial orientation
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ButtonsEnabled Enumeration

Enum describing the Buttonstate of the ChartPannel

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[FlagsAttribute]
public enum ButtonsEnabled
<FlagsAttribute>
Public Enumeration ButtonsEnabled
[FlagsAttribute]
public enum class ButtonsEnabled
Members
Member name | Value | Description
All | 9223372036854775807 | All buttons enabled
None | 0 | No buttons enabled
AllYTMaster | 4398457520127 | All buttons needed for YT charts which are MasterCharts
AllYT | 4398580236288 | All buttons needded for YT charts which have a MasterChart
AllXYMaster | 410681343 | All buttons needed for XY charts which are MasterCharts
AllXY | 433717248 | All buttons needed for XY charts which have a MasterChart
AllXYZMaster | 2020638719 | All buttons needed for XYZ charts which are MasterCharts
AllXYZ | 2043674624 | All buttons needed for XYZ charts which have a MasterChart
AllArrayMaster | 406814719 | All buttons needed for array bar charts which are MasterCharts
AllArray | 429522944 | All buttons needed for array bar charts which have a MasterChart
AllDigitalMaster | 410025983 | All buttons needed for digital charts which are MasterCharts
AllDigital | 432013312 | All buttons needed for digital charts which have a MasterChart
AllSingleBarMaster | 519077887 | All buttons needed for single bar charts which are MasterCharts
AllSingleBar | 533725184 | All buttons needed for single bar which have a MasterChart
AllFusionYIMaster | 65968692756472 | All buttons needed for Fusion charts which are MasterCharts
AllFusionYI | 1070596096 | All buttons needded for Fusion charts which have a MasterChart
IsMaster | 270893055 | Buttons visible only if MasterChart
HasMaster | 394264576 |
RunButton | 1 | RunButton enabled
PauseButton | 2 | PauseButton enabled
Splitter1 | 4 | Splitter 1 enabled
DisplaywidthTextBox | 8 | Display width TextBox enabled
Splitter2 | 16 | Splitter 2 enabled
ScrollBackBig | 32 | Scroll back big enabled
ScrollBackSmall | 64 | ScrollBack small enabled
ScrollForwardSmall | 128 | Scroll forward small enabled
ScrollForwardBig | 256 | Scroll forward big enabled
Splitter3 | 512 | Splitter 3 enabled
PositionTextBox | 1024 | Position Text Box enabled
Splitter4 | 2048 | Splitter 4 enabled
UndoButton | 4096 | Undo enabled
RedoButton | 8192 | Redo enabled
Splitter5 | 16384 | Splitter 5 enabled
PanXButton | 65536 | PanX button enabled
PanXYButton | 131072 | PanXY button enabled
ZoomXButton | 262144 | ZoomX button enabled
ZoomXYButton | 524288 | ZommXY button enabled
UnzoomButton | 1048576 | Un zoom button enabled
ZoomOutMaxButton | 2097152 | Zoom out Max button enabled
OverviewButton | 4194304 | Overview button enabled
Splitter6 | 8388608 | Splitter 6 enabled
MasterLabel | 16777216 | MasterLabel enabled
PanYButton | 33554432 | PanY button enabled
ZoomYButton | 67108864 | ZoomY button enabled
CopyToClipboard | 134217728 | Copy to clipboard enabled
TimelineButton | 268435456 | Timeline enabled
ZoomXYZPoint | 536870912 | XYZ Point Zoom enabled
PanningXYZChart | 1073741824 | XYZ Panning Mode as default
Splitter7 | 2147483648 | Splitter 7 enabled
SetStartButton | 4294967296 | Modify start point enabled
SetEndButton | 8589934592 | Modify end point enabled
SpacingButton | 17179869184 | Modify index spacing enabled
OffsetButton | 34359738368 | Modify offset enabled
Splitter8 | 68719476736 | Splitter 8 enabled
SelectModeButton | 137438953472 | Active select mode enabled
CurveTransformButton | 274877906944 | Curve transformation enabled
Splitter9 | 549755813888 | Splitter 9 enabled
UndoDataButton | 1099511627776 | Undo data action enabled
RedoDataButton | 2199023255552 | Redo data action enabled
OpenCurveCreatorButton | 4398046511104 | Open curve creator enabled
AcceptTransformButton | 8796093022208 | Accepting transformations enabled
DiscardTransformButton | 17592186044416 | Discarding transformations enabled
OffsetTransformButton | 35184372088832 | Offset transformation enabled
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ChannelHighlightingMode Enumeration

An Enum of the useable Channel-Highlighting.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum ChannelHighlightingMode
Public Enumeration ChannelHighlightingMode
public enum class ChannelHighlightingMode
Members
Member name | Value | Description
Disabled | 0 | No highlighting
Enabled | 1 | Highlight within Chart and Overview
DoubleClick | 2 | Highlight on DoubleClick
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ChannelOptions Class

Class prevents all UserOptions for Channels
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APIChannelOptions

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChannelOptions
Public Class ChannelOptions
public ref class ChannelOptions

The ChannelOptions type exposes the following members.

Properties
 | Name | Description
Public property | Antialias | Get or Set Antialias
Public property | Comment | Get or Set the Comment
Public property | FillColor | Get or Set the FillColor
Public property | FillMode | Get or Set the FillMode
Public property | GraphType | Get or Set the GraphType
Public property | LineColor | Get or Set the LineColor
Public property | LineWidth | Get or Set the LineWidth
Public property | MarkColor | Get or Set the MarkColor
Public property | Marks | Get or Set the Marks
Public property | MarkSize | Get or Set the MarkSize
Public property | Visible | Get or Set the Visiblity
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ChannelOptions Properties

The ChannelOptions type exposes the following members.

Properties
 | Name | Description
Public property | Antialias | Get or Set Antialias
Public property | Comment | Get or Set the Comment
Public property | FillColor | Get or Set the FillColor
Public property | FillMode | Get or Set the FillMode
Public property | GraphType | Get or Set the GraphType
Public property | LineColor | Get or Set the LineColor
Public property | LineWidth | Get or Set the LineWidth
Public property | MarkColor | Get or Set the MarkColor
Public property | Marks | Get or Set the Marks
Public property | MarkSize | Get or Set the MarkSize
Public property | Visible | Get or Set the Visiblity
Top
See Also

Reference

ChannelOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChannelOptions.Antialias Property

Get or Set Antialias

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool Antialias { get; set; }
Public Property Antialias As Boolean
    Get
    Set
public:
property bool Antialias {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChannelOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChannelOptions.Comment Property

Get or Set the Comment

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ChannelOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChannelOptions.FillColor Property

Get or Set the FillColor

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color FillColor { get; set; }
Public Property FillColor As Color
    Get
    Set
public:
property Color FillColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ChannelOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChannelOptions.FillMode Property

Get or Set the FillMode

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[DefaultValueAttribute(GraphFillMode.None)]
public GraphFillMode FillMode { get; set; }
<DefaultValueAttribute(GraphFillMode.None)>
Public Property FillMode As GraphFillMode
    Get
    Set
public:
[DefaultValueAttribute(GraphFillMode::None)]
property GraphFillMode FillMode {
    GraphFillMode get ();
    void set (GraphFillMode value);
}

Property Value

Type: GraphFillMode
See Also

Reference

ChannelOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChannelOptions.GraphType Property

Get or Set the GraphType

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SeriesTypes GraphType { get; set; }
Public Property GraphType As SeriesTypes
    Get
    Set
public:
property SeriesTypes GraphType {
    SeriesTypes get ();
    void set (SeriesTypes value);
}

Property Value

Type: SeriesTypes
See Also

Reference

ChannelOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChannelOptions.LineColor Property

Get or Set the LineColor

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color LineColor { get; set; }
Public Property LineColor As Color
    Get
    Set
public:
property Color LineColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ChannelOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChannelOptions.LineWidth Property

Get or Set the LineWidth

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public float LineWidth { get; set; }
Public Property LineWidth As Single
    Get
    Set
public:
property float LineWidth {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

ChannelOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChannelOptions.MarkColor Property

Get or Set the MarkColor

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color MarkColor { get; set; }
Public Property MarkColor As Color
    Get
    Set
public:
property Color MarkColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ChannelOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChannelOptions.Marks Property

Get or Set the Marks

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkConfiguration Marks { get; set; }
Public Property Marks As MarkConfiguration
    Get
    Set
public:
property MarkConfiguration Marks {
    MarkConfiguration get ();
    void set (MarkConfiguration value);
}

Property Value

Type: MarkConfiguration
See Also

Reference

ChannelOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChannelOptions.MarkSize Property

Get or Set the MarkSize

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int MarkSize { get; set; }
Public Property MarkSize As Integer
    Get
    Set
public:
property int MarkSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ChannelOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChannelOptions.Visible Property

Get or Set the Visiblity

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChannelOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChannelOptions Methods

The ChannelOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChannelOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartOptions Class

Class prevents all UserOptions for Charts
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APIChartOptions

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChartOptions
Public Class ChartOptions
public ref class ChartOptions

The ChartOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoStartOnRecord | Get or Set the AutoStart
Public property | BorderColor | Get or Set the BorderColor
Public property | Comment | Get or Set the Comment
Public property | DefaultDisplayWidth | Get or Set the DefaultDisplayWidth
Public property | ScaleOnZoom | Get or Set the ScaleOnZoom
Public property | ShowName | Get or Set the ShowName
Public property | StackedYAxis | Get or Set StackedAxes
Public property | TimeBar | Get or Set the TimeBar
Public property | ToolBar | Get or Set the ToolBar
Public property | ToolTipEnabled | Get or Set the ToolTipEnabled
Public property | YZoom | Get or Set the YZoom
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ChartOptions Properties

The ChartOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoStartOnRecord | Get or Set the AutoStart
Public property | BorderColor | Get or Set the BorderColor
Public property | Comment | Get or Set the Comment
Public property | DefaultDisplayWidth | Get or Set the DefaultDisplayWidth
Public property | ScaleOnZoom | Get or Set the ScaleOnZoom
Public property | ShowName | Get or Set the ShowName
Public property | StackedYAxis | Get or Set StackedAxes
Public property | TimeBar | Get or Set the TimeBar
Public property | ToolBar | Get or Set the ToolBar
Public property | ToolTipEnabled | Get or Set the ToolTipEnabled
Public property | YZoom | Get or Set the YZoom
Top
See Also

Reference

ChartOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartOptions.AutoStartOnRecord Property

Get or Set the AutoStart

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool AutoStartOnRecord { get; set; }
Public Property AutoStartOnRecord As Boolean
    Get
    Set
public:
property bool AutoStartOnRecord {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartOptions.BorderColor Property

Get or Set the BorderColor

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color BorderColor { get; set; }
Public Property BorderColor As Color
    Get
    Set
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ChartOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartOptions.Comment Property

Get or Set the Comment

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ChartOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartOptions.DefaultDisplayWidth Property

Get or Set the DefaultDisplayWidth

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long DefaultDisplayWidth { get; set; }
Public Property DefaultDisplayWidth As Long
    Get
    Set
public:
property long long DefaultDisplayWidth {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

ChartOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartOptions.ScaleOnZoom Property

Get or Set the ScaleOnZoom

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool ScaleOnZoom { get; set; }
Public Property ScaleOnZoom As Boolean
    Get
    Set
public:
property bool ScaleOnZoom {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartOptions.ShowName Property

Get or Set the ShowName

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool ShowName { get; set; }
Public Property ShowName As Boolean
    Get
    Set
public:
property bool ShowName {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartOptions.StackedYAxis Property

Get or Set StackedAxes

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool StackedYAxis { get; set; }
Public Property StackedYAxis As Boolean
    Get
    Set
public:
property bool StackedYAxis {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartOptions.TimeBar Property

Get or Set the TimeBar

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool TimeBar { get; set; }
Public Property TimeBar As Boolean
    Get
    Set
public:
property bool TimeBar {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartOptions.ToolBar Property

Get or Set the ToolBar

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool ToolBar { get; set; }
Public Property ToolBar As Boolean
    Get
    Set
public:
property bool ToolBar {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartOptions.ToolTipEnabled Property

Get or Set the ToolTipEnabled

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool ToolTipEnabled { get; set; }
Public Property ToolTipEnabled As Boolean
    Get
    Set
public:
property bool ToolTipEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartOptions.YZoom Property

Get or Set the YZoom

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool YZoom { get; set; }
Public Property YZoom As Boolean
    Get
    Set
public:
property bool YZoom {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartOptions Methods

The ChartOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChartOptions Class
TwinCAT.Measurement.Scope.API Namespace


ChartTimePosEventArgs Class

EventArgs containing the actual Chart Times
Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.APIChartTimePosEventArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChartTimePosEventArgs : EventArgs
Public Class ChartTimePosEventArgs
    Inherits EventArgs
public ref class ChartTimePosEventArgs : public EventArgs

The ChartTimePosEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ChartEndTime | Gets or sets the ChartEndTime.
Public property | ChartStartTime | Gets the ChartStartTime
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ChartTimePosEventArgs Properties

The ChartTimePosEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ChartEndTime | Gets or sets the ChartEndTime.
Public property | ChartStartTime | Gets the ChartStartTime
Top
See Also

Reference

ChartTimePosEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ChartTimePosEventArgs.ChartEndTime Property

Gets or sets the ChartEndTime.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long ChartEndTime { get; }
Public ReadOnly Property ChartEndTime As Long
    Get
public:
property long long ChartEndTime {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ChartTimePosEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ChartTimePosEventArgs.ChartStartTime Property

Gets the ChartStartTime

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long ChartStartTime { get; }
Public ReadOnly Property ChartStartTime As Long
    Get
public:
property long long ChartStartTime {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ChartTimePosEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ChartTimePosEventArgs Methods

The ChartTimePosEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChartTimePosEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ChartType Enumeration

Enum describing the Type of a Chart

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum ChartType
Public Enumeration ChartType
public enum class ChartType
Members
Member name | Value | Description
None | 0 | Chart Type could not be determined
YT | 1 | YT-Chart
XY | 2 | XY-Chart
XYZ | 3 | XYZ-Chart
ArrayBar | 4 | Array-Bar-Chart
Digital | 8 | Digital-Chart
SingleBar | 16 | Single-Bar-Chart
YIFusion | 32 | YI-Fusion-Chart
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


CompareOperators Enumeration

Enum for CompareOperators

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum CompareOperators
Public Enumeration CompareOperators
public enum class CompareOperators
Members
Member name | Value | Description
Smaller | -2 | <
SmallerOrEqual | -1 | <=
Equal | 0 | =
Different | 1 | != / <>
BiggerOrEqual | 2 | >=
Bigger | 3 | >
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter Class

Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
TwinCAT.Measurement.Scope.APICompressionOptionConverter

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class CompressionOptionConverter : TypeConverter
Public Class CompressionOptionConverter
    Inherits TypeConverter
public ref class CompressionOptionConverter : public TypeConverter

The CompressionOptionConverter type exposes the following members.

Constructors
 | Name | Description
Public method | CompressionOptionConverter | Initializes a new instance of the CompressionOptionConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Determines wether the Value can be converted from the Type (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Determines wether the Value can be converted to the Type (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the Value back (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Convert to (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Gets the StandardValueCollection (Overrides TypeConverterGetStandardValues(ITypeDescriptorContext).)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Determines wether only Standard Values can be Used (Overrides TypeConverterGetStandardValuesExclusive(ITypeDescriptorContext).)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Determines wethter this TypeConverter has a Standard Value Collection (Overrides TypeConverterGetStandardValuesSupported(ITypeDescriptorContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter Constructor

Initializes a new instance of the CompressionOptionConverter class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public CompressionOptionConverter()
Public Sub New
public:
CompressionOptionConverter()
See Also

Reference

CompressionOptionConverter Class
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter Methods

The CompressionOptionConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Determines wether the Value can be converted from the Type (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Determines wether the Value can be converted to the Type (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the Value back (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Convert to (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Gets the StandardValueCollection (Overrides TypeConverterGetStandardValues(ITypeDescriptorContext).)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Determines wether only Standard Values can be Used (Overrides TypeConverterGetStandardValuesExclusive(ITypeDescriptorContext).)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Determines wethter this TypeConverter has a Standard Value Collection (Overrides TypeConverterGetStandardValuesSupported(ITypeDescriptorContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompressionOptionConverter Class
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.CanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Determines wether the Value can be converted from the Type (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

CompressionOptionConverter Class
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

Determines wether the Value can be converted from the Type

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
The Context of the Property
sourceType
Type: SystemType
The Source Type to convert from

Return Value

Type: Boolean
Ture if the Value con be converted back
See Also

Reference

CompressionOptionConverter Class
CanConvertFrom Overload
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.CanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Determines wether the Value can be converted to the Type (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

CompressionOptionConverter Class
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

Determines wether the Value can be converted to the Type

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
The context of the Property
destinationType
Type: SystemType
The Destination Type

Return Value

Type: Boolean
True if the Value can be converted
See Also

Reference

CompressionOptionConverter Class
CanConvertTo Overload
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.ConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the Value back (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

CompressionOptionConverter Class
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the Value back

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
The Context of the Property
culture
Type: System.GlobalizationCultureInfo
The Current Culture
value
Type: SystemObject
The Value to convert back

Return Value

Type: Object
The Converted Value
See Also

Reference

CompressionOptionConverter Class
ConvertFrom Overload
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.ConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Convert to (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

CompressionOptionConverter Class
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Convert to

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
The Context of the Property
culture
Type: System.GlobalizationCultureInfo
The Current Culture
value
Type: SystemObject
The Value
destinationType
Type: SystemType
The Detstination Type

Return Value

Type: Object
The Converted Value
See Also

Reference

CompressionOptionConverter Class
ConvertTo Overload
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.GetStandardValues Method

Overload List
 | Name | Description
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Gets the StandardValueCollection (Overrides TypeConverterGetStandardValues(ITypeDescriptorContext).)
Top
See Also

Reference

CompressionOptionConverter Class
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.GetStandardValues Method (ITypeDescriptorContext)

Gets the StandardValueCollection

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override TypeConverterStandardValuesCollection GetStandardValues(
    ITypeDescriptorContext context
)
Public Overrides Function GetStandardValues (
    context As ITypeDescriptorContext
) As TypeConverterStandardValuesCollection
public:
virtual TypeConverterStandardValuesCollection^ GetStandardValues(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
The Context of the Property

Return Value

Type: TypeConverterStandardValuesCollection
A Standard Value Collection
See Also

Reference

CompressionOptionConverter Class
GetStandardValues Overload
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.GetStandardValuesExclusive Method

Overload List
 | Name | Description
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Determines wether only Standard Values can be Used (Overrides TypeConverterGetStandardValuesExclusive(ITypeDescriptorContext).)
Top
See Also

Reference

CompressionOptionConverter Class
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.GetStandardValuesExclusive Method (ITypeDescriptorContext)

Determines wether only Standard Values can be Used

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool GetStandardValuesExclusive(
    ITypeDescriptorContext context
)
Public Overrides Function GetStandardValuesExclusive (
    context As ITypeDescriptorContext
) As Boolean
public:
virtual bool GetStandardValuesExclusive(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
The Context of the Property

Return Value

Type: Boolean
True if only standard Value can be used
See Also

Reference

CompressionOptionConverter Class
GetStandardValuesExclusive Overload
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.GetStandardValuesSupported Method

Overload List
 | Name | Description
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Determines wethter this TypeConverter has a Standard Value Collection (Overrides TypeConverterGetStandardValuesSupported(ITypeDescriptorContext).)
Top
See Also

Reference

CompressionOptionConverter Class
TwinCAT.Measurement.Scope.API Namespace


CompressionOptionConverter.GetStandardValuesSupported Method (ITypeDescriptorContext)

Determines wethter this TypeConverter has a Standard Value Collection

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool GetStandardValuesSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetStandardValuesSupported (
    context As ITypeDescriptorContext
) As Boolean
public:
virtual bool GetStandardValuesSupported(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
The Context of the Property

Return Value

Type: Boolean
True if a StandardValue Collection is Supported
See Also

Reference

CompressionOptionConverter Class
GetStandardValuesSupported Overload
TwinCAT.Measurement.Scope.API Namespace


ConditionLinkOptions Enumeration

Determines how the Conditions of an Dynamic Style or Combined

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum ConditionLinkOptions
Public Enumeration ConditionLinkOptions
public enum class ConditionLinkOptions
Members
Member name | Value | Description
AND | 0 | AND
OR | 1 | OR
XOR | 2 | XOR
Custom | 4 | Custom Link
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


CopyClipboardStartupArgs Class

Event arguments class for starting the copy to clipboard tool.
Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.APICopyClipboardStartupArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class CopyClipboardStartupArgs : EventArgs
Public Class CopyClipboardStartupArgs
    Inherits EventArgs
public ref class CopyClipboardStartupArgs : public EventArgs

The CopyClipboardStartupArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CopyClipboardStartupArgs | Initializes a new instance of the CopyClipboardStartupArgs class
Top
Properties
 | Name | Description
Public property | AxisScalings |
Public property | Chart |
Public property | ChartSize |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


CopyClipboardStartupArgs Constructor

Initializes a new instance of the CopyClipboardStartupArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public CopyClipboardStartupArgs(
    Chart chart,
    Rectangle size,
    Dictionary<Axis, Tuple<double, double>> axisScaling
)
Public Sub New (
    chart As Chart,
    size As Rectangle,
    axisScaling As Dictionary(Of Axis, Tuple(Of Double, Double))
)
public:
CopyClipboardStartupArgs(
    Chart^ chart,
    Rectangle size,
    Dictionary<Axis^, Tuple<double, double>^>^ axisScaling
)

Parameters

chart
Type: TwinCAT.Measurement.Scope.API.ModelChart
size
Type: System.DrawingRectangle
axisScaling
Type: System.Collections.GenericDictionary Axis, Tuple Double, Double
See Also

Reference

CopyClipboardStartupArgs Class
TwinCAT.Measurement.Scope.API Namespace


CopyClipboardStartupArgs Properties

The CopyClipboardStartupArgs type exposes the following members.

Properties
 | Name | Description
Public property | AxisScalings |
Public property | Chart |
Public property | ChartSize |
Top
See Also

Reference

CopyClipboardStartupArgs Class
TwinCAT.Measurement.Scope.API Namespace


CopyClipboardStartupArgs.AxisScalings Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Dictionary<Axis, Tuple<double, double>> AxisScalings { get; }
Public ReadOnly Property AxisScalings As Dictionary(Of Axis, Tuple(Of Double, Double))
    Get
public:
property Dictionary<Axis^, Tuple<double, double>^>^ AxisScalings {
    Dictionary<Axis^, Tuple<double, double>^>^ get ();
}

Property Value

Type: Dictionary Axis, Tuple Double, Double
See Also

Reference

CopyClipboardStartupArgs Class
TwinCAT.Measurement.Scope.API Namespace


CopyClipboardStartupArgs.Chart Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Chart Chart { get; }
Public ReadOnly Property Chart As Chart
    Get
public:
property Chart^ Chart {
    Chart^ get ();
}

Property Value

Type: Chart
See Also

Reference

CopyClipboardStartupArgs Class
TwinCAT.Measurement.Scope.API Namespace


CopyClipboardStartupArgs.ChartSize Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Rectangle ChartSize { get; }
Public ReadOnly Property ChartSize As Rectangle
    Get
public:
property Rectangle ChartSize {
    Rectangle get ();
}

Property Value

Type: Rectangle
See Also

Reference

CopyClipboardStartupArgs Class
TwinCAT.Measurement.Scope.API Namespace


CopyClipboardStartupArgs Methods

The CopyClipboardStartupArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CopyClipboardStartupArgs Class
TwinCAT.Measurement.Scope.API Namespace


CopyToClipboardArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.APICopyToClipboardArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class CopyToClipboardArgs : EventArgs
Public Class CopyToClipboardArgs
    Inherits EventArgs
public ref class CopyToClipboardArgs : public EventArgs

The CopyToClipboardArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CopyToClipboardArgs | Initializes a new instance of the CopyToClipboardArgs class
Top
Properties
 | Name | Description
Public property | StartupArgs |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


CopyToClipboardArgs Constructor

Initializes a new instance of the CopyToClipboardArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public CopyToClipboardArgs(
    List<CopyClipboardStartupArgs> startupArgs
)
Public Sub New (
    startupArgs As List(Of CopyClipboardStartupArgs)
)
public:
CopyToClipboardArgs(
    List<CopyClipboardStartupArgs^>^ startupArgs
)

Parameters

startupArgs
Type: System.Collections.GenericList CopyClipboardStartupArgs
See Also

Reference

CopyToClipboardArgs Class
TwinCAT.Measurement.Scope.API Namespace


CopyToClipboardArgs Properties

The CopyToClipboardArgs type exposes the following members.

Properties
 | Name | Description
Public property | StartupArgs |
Top
See Also

Reference

CopyToClipboardArgs Class
TwinCAT.Measurement.Scope.API Namespace


CopyToClipboardArgs.StartupArgs Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public List<CopyClipboardStartupArgs> StartupArgs { get; }
Public ReadOnly Property StartupArgs As List(Of CopyClipboardStartupArgs)
    Get
public:
property List<CopyClipboardStartupArgs^>^ StartupArgs {
    List<CopyClipboardStartupArgs^>^ get ();
}

Property Value

Type: List CopyClipboardStartupArgs
See Also

Reference

CopyToClipboardArgs Class
TwinCAT.Measurement.Scope.API Namespace


CopyToClipboardArgs Methods

The CopyToClipboardArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CopyToClipboardArgs Class
TwinCAT.Measurement.Scope.API Namespace


CreateAcquisitionEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.APICreateAcquisitionEventArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class CreateAcquisitionEventArgs : EventArgs
Public Class CreateAcquisitionEventArgs
    Inherits EventArgs
public ref class CreateAcquisitionEventArgs : public EventArgs

The CreateAcquisitionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | CreateAcquisitionEventArgs | Initializes a new instance of the CreateAcquisitionEventArgs class
Top
Properties
 | Name | Description
Public property | CreatedAcquisition |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


CreateAcquisitionEventArgs Constructor

Initializes a new instance of the CreateAcquisitionEventArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public CreateAcquisitionEventArgs()
Public Sub New
public:
CreateAcquisitionEventArgs()
See Also

Reference

CreateAcquisitionEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


CreateAcquisitionEventArgs Properties

The CreateAcquisitionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | CreatedAcquisition |
Top
See Also

Reference

CreateAcquisitionEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


CreateAcquisitionEventArgs.CreatedAcquisition Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Acquisition CreatedAcquisition { get; set; }
Public Property CreatedAcquisition As Acquisition
    Get
    Set
public:
property Acquisition^ CreatedAcquisition {
    Acquisition^ get ();
    void set (Acquisition^ value);
}

Property Value

Type: Acquisition
See Also

Reference

CreateAcquisitionEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


CreateAcquisitionEventArgs Methods

The CreateAcquisitionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateAcquisitionEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


CursorAlignment Enumeration

Enum describing the Cursor Alignment

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum CursorAlignment
Public Enumeration CursorAlignment
public enum class CursorAlignment
Members
Member name | Value | Description
Vertical | 1 | Vertical
Horizontal | 2 | Horizontal
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


DataBaseType Enumeration

Defines the Type of DataBase to Export to

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum DataBaseType
Public Enumeration DataBaseType
public enum class DataBaseType
Members
Member name | Value | Description
UNKOWN | 0 | Unknown-DataBaseType
SQL | 1 | SQL-DataBase
CSV | 2 | CSV-DataBase
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


DataModifyOptions Enumeration

Different actions that can be made in Sequences.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum DataModifyOptions
Public Enumeration DataModifyOptions
public enum class DataModifyOptions
Members
Member name | Value | Description
Init | 0 | Initialze or first add of values.
Insert | 1 | Insert new values.
Trim | 2 | Remove values.
Replace | 3 | Replace values.
Clear | 4 | Remove all values.
Move | 5 | Move the display.
Indices | 6 | Only indices changed.
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


DataUsage Enumeration

Enum describing the usage of the data collect for an AcquisitionInterpreter

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum DataUsage
Public Enumeration DataUsage
public enum class DataUsage
Members
Member name | Value | Description
X | 1 | Width
Y | 2 | Height
Z | 3 | Depth
Ring | 4 | Ring orientation
Radial | 5 | Radial orientation
Style | 10 | Data used for Dynamic Style
Trigger | 11 | Data used for Trigger
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


Direction Enumeration

Indicates a direction for chart-operations.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum Direction
Public Enumeration Direction
public enum class Direction
Members
Member name | Value | Description
Forward | 0 | Forward direction.
Reverse | 1 | Backwards.
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


DirectoryDiagArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.APIDirectoryDiagArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class DirectoryDiagArgs : EventArgs
Public Class DirectoryDiagArgs
    Inherits EventArgs
public ref class DirectoryDiagArgs : public EventArgs

The DirectoryDiagArgs type exposes the following members.

Constructors
 | Name | Description
Public method | DirectoryDiagArgs | Initializes a new instance of the DirectoryDiagArgs class
Top
Properties
 | Name | Description
Public property | SelectedDirectory |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


DirectoryDiagArgs Constructor

Initializes a new instance of the DirectoryDiagArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DirectoryDiagArgs()
Public Sub New
public:
DirectoryDiagArgs()
See Also

Reference

DirectoryDiagArgs Class
TwinCAT.Measurement.Scope.API Namespace


DirectoryDiagArgs Properties

The DirectoryDiagArgs type exposes the following members.

Properties
 | Name | Description
Public property | SelectedDirectory |
Top
See Also

Reference

DirectoryDiagArgs Class
TwinCAT.Measurement.Scope.API Namespace


DirectoryDiagArgs.SelectedDirectory Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string SelectedDirectory { get; set; }
Public Property SelectedDirectory As String
    Get
    Set
public:
property String^ SelectedDirectory {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DirectoryDiagArgs Class
TwinCAT.Measurement.Scope.API Namespace


DirectoryDiagArgs Methods

The DirectoryDiagArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DirectoryDiagArgs Class
TwinCAT.Measurement.Scope.API Namespace


ElementGUIDEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.APIElementGUIDEventArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ElementGUIDEventArgs : EventArgs
Public Class ElementGUIDEventArgs
    Inherits EventArgs
public ref class ElementGUIDEventArgs : public EventArgs

The ElementGUIDEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ElementGUIDEventArgs | Initializes a new instance of the ElementGUIDEventArgs class
Top
Properties
 | Name | Description
Public property | Element |
Public property | ElementGuid |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ElementGUIDEventArgs Constructor

Initializes a new instance of the ElementGUIDEventArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ElementGUIDEventArgs(
    Guid ElementGuid,
    MeasurementMemberBase Element
)
Public Sub New (
    ElementGuid As Guid,
    Element As MeasurementMemberBase
)
public:
ElementGUIDEventArgs(
    Guid ElementGuid,
    MeasurementMemberBase^ Element
)

Parameters

ElementGuid
Type: SystemGuid
Element
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
See Also

Reference

ElementGUIDEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ElementGUIDEventArgs Properties

The ElementGUIDEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Element |
Public property | ElementGuid |
Top
See Also

Reference

ElementGUIDEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ElementGUIDEventArgs.Element Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MeasurementMemberBase Element { get; set; }
Public Property Element As MeasurementMemberBase
    Get
    Set
public:
property MeasurementMemberBase^ Element {
    MeasurementMemberBase^ get ();
    void set (MeasurementMemberBase^ value);
}

Property Value

Type: MeasurementMemberBase
See Also

Reference

ElementGUIDEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ElementGUIDEventArgs.ElementGuid Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Guid ElementGuid { get; }
Public ReadOnly Property ElementGuid As Guid
    Get
public:
property Guid ElementGuid {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

ElementGUIDEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ElementGUIDEventArgs Methods

The ElementGUIDEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ElementGUIDEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


EventExportMode Enumeration

EventExportMode Enumeration

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum EventExportMode
Public Enumeration EventExportMode
public enum class EventExportMode
Members
Member name | Value | Description
Channels_in_Rows | 0 | The data for all channels are exported successively.
Channels_in_Columns | 1 | Each export block contains data for all connected channels.
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs Class

EventArgs for Export Event
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
TwinCAT.Measurement.Scope.APIExportEventArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ExportEventArgs : CancelEventArgs
Public Class ExportEventArgs
    Inherits CancelEventArgs
public ref class ExportEventArgs : public CancelEventArgs

The ExportEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ExportEventArgs | Creates a new export event block
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | ChannelFrames | Gets a data set for each channel.
Public property | FrameCount | Gets the expected count of frames.
Public property | FrameNumber | Gets the index of the current frame.
Public property | FrameStartTime | Gets the frame start time.
Public property | Mode | Gets the ExportMode.
Public property | RecordEndTime | Gets the record end time.
Public property | RecordStartTime | Gets the record start time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs Constructor

Creates a new export event block

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ExportEventArgs(
    long recordStartTime,
    long recordEndTime,
    long frameStartTime,
    EventExportMode mode,
    uint frameCount,
    uint frameNumber,
    ExportEventArgsChannelFrame[] channelFrames
)
Public Sub New (
    recordStartTime As Long,
    recordEndTime As Long,
    frameStartTime As Long,
    mode As EventExportMode,
    frameCount As UInteger,
    frameNumber As UInteger,
    channelFrames As ExportEventArgsChannelFrame()
)
public:
ExportEventArgs(
    long long recordStartTime,
    long long recordEndTime,
    long long frameStartTime,
    EventExportMode mode,
    unsigned int frameCount,
    unsigned int frameNumber,
    array<ExportEventArgsChannelFrame^>^ channelFrames
)

Parameters

recordStartTime
Type: SystemInt64
recordEndTime
Type: SystemInt64
frameStartTime
Type: SystemInt64
mode
Type: TwinCAT.Measurement.Scope.APIEventExportMode
frameCount
Type: SystemUInt32
frameNumber
Type: SystemUInt32
channelFrames
Type: TwinCAT.Measurement.Scope.APIExportEventArgsChannelFrame
See Also

Reference

ExportEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs Properties

The ExportEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | ChannelFrames | Gets a data set for each channel.
Public property | FrameCount | Gets the expected count of frames.
Public property | FrameNumber | Gets the index of the current frame.
Public property | FrameStartTime | Gets the frame start time.
Public property | Mode | Gets the ExportMode.
Public property | RecordEndTime | Gets the record end time.
Public property | RecordStartTime | Gets the record start time.
Top
See Also

Reference

ExportEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.ChannelFrames Property

Gets a data set for each channel.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ExportEventArgsChannelFrame[] ChannelFrames { get; }
Public ReadOnly Property ChannelFrames As ExportEventArgsChannelFrame()
    Get
public:
property array<ExportEventArgsChannelFrame^>^ ChannelFrames {
    array<ExportEventArgsChannelFrame^>^ get ();
}

Property Value

Type: ExportEventArgsChannelFrame
The channel frames.
See Also

Reference

ExportEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.FrameCount Property

Gets the expected count of frames.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public uint FrameCount { get; }
Public ReadOnly Property FrameCount As UInteger
    Get
public:
property unsigned int FrameCount {
    unsigned int get ();
}

Property Value

Type: UInt32
The expected count of frames.
See Also

Reference

ExportEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.FrameNumber Property

Gets the index of the current frame.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public uint FrameNumber { get; }
Public ReadOnly Property FrameNumber As UInteger
    Get
public:
property unsigned int FrameNumber {
    unsigned int get ();
}

Property Value

Type: UInt32
The index of the current frame.
See Also

Reference

ExportEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.FrameStartTime Property

Gets the frame start time.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DateTime FrameStartTime { get; }
Public ReadOnly Property FrameStartTime As DateTime
    Get
public:
property DateTime FrameStartTime {
    DateTime get ();
}

Property Value

Type: DateTime
The frame start time.
See Also

Reference

ExportEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.Mode Property

Gets the ExportMode.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public EventExportMode Mode { get; }
Public ReadOnly Property Mode As EventExportMode
    Get
public:
property EventExportMode Mode {
    EventExportMode get ();
}

Property Value

Type: EventExportMode
The mode.
See Also

Reference

ExportEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.RecordEndTime Property

Gets the record end time.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long RecordEndTime { get; }
Public ReadOnly Property RecordEndTime As Long
    Get
public:
property long long RecordEndTime {
    long long get ();
}

Property Value

Type: Int64
The record end time.
See Also

Reference

ExportEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.RecordStartTime Property

Gets the record start time.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long RecordStartTime { get; }
Public ReadOnly Property RecordStartTime As Long
    Get
public:
property long long RecordStartTime {
    long long get ();
}

Property Value

Type: Int64
The record start time.
See Also

Reference

ExportEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs Methods

The ExportEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExportEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.ChannelFrame Class

Hold data for event-export.
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APIExportEventArgsChannelFrame
TwinCAT.Measurement.Scope.APIExportEventArgsXYChannelFrame

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChannelFrame
Public Class ChannelFrame
public ref class ChannelFrame

The ExportEventArgsChannelFrame type exposes the following members.

Constructors
 | Name | Description
Public method | ExportEventArgsChannelFrame | Creates a new YT-ChannelFrame
Top
Properties
 | Name | Description
Public property | Channel | Gets the channel according to this frame.
Public property | Times | Gets the times array for this frame.
Public property | Values | Gets the values array for this frame.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.ChannelFrame Constructor

Creates a new YT-ChannelFrame

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChannelFrame(
    Channel channel,
    List<long> times,
    List<Object> values
)
Public Sub New (
    channel As Channel,
    times As List(Of Long),
    values As List(Of Object)
)
public:
ChannelFrame(
    Channel^ channel,
    List<long long>^ times,
    List<Object^>^ values
)

Parameters

channel
Type: TwinCAT.Measurement.Scope.API.ModelChannel
The channel Information
times
Type: System.Collections.GenericList Int64
Time-Values
values
Type: System.Collections.GenericList Object
Y-Values
See Also

Reference

ExportEventArgsChannelFrame Class
TwinCAT.Measurement.Scope.API Namespace


ChannelFrame Properties

The ExportEventArgsChannelFrame type exposes the following members.

Properties
 | Name | Description
Public property | Channel | Gets the channel according to this frame.
Public property | Times | Gets the times array for this frame.
Public property | Values | Gets the values array for this frame.
Top
See Also

Reference

ExportEventArgsChannelFrame Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.ChannelFrame.Channel Property

Gets the channel according to this frame.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Channel Channel { get; }
Public ReadOnly Property Channel As Channel
    Get
public:
property Channel^ Channel {
    Channel^ get ();
}

Property Value

Type: Channel
The channel.
See Also

Reference

ExportEventArgsChannelFrame Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.ChannelFrame.Times Property

Gets the times array for this frame.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public List<long> Times { get; }
Public ReadOnly Property Times As List(Of Long)
    Get
public:
property List<long long>^ Times {
    List<long long>^ get ();
}

Property Value

Type: List Int64
The times.
See Also

Reference

ExportEventArgsChannelFrame Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.ChannelFrame.Values Property

Gets the values array for this frame.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public List<Object> Values { get; }
Public ReadOnly Property Values As List(Of Object)
    Get
public:
property List<Object^>^ Values {
    List<Object^>^ get ();
}

Property Value

Type: List Object
The values.
See Also

Reference

ExportEventArgsChannelFrame Class
TwinCAT.Measurement.Scope.API Namespace


ChannelFrame Methods

The ExportEventArgsChannelFrame type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExportEventArgsChannelFrame Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.XYChannelFrame Class

The XYChannelFrame specialized the ChannelFrame for an XY-Channel.
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APIExportEventArgsChannelFrame
TwinCAT.Measurement.Scope.APIExportEventArgsXYChannelFrame

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class XYChannelFrame : ExportEventArgsChannelFrame
Public Class XYChannelFrame
    Inherits ExportEventArgsChannelFrame
public ref class XYChannelFrame : public ExportEventArgsChannelFrame

The ExportEventArgsXYChannelFrame type exposes the following members.

Constructors
 | Name | Description
Public method | ExportEventArgsXYChannelFrame | Creates a new XYChannelFrame witch contains the channel Inforamtion
Top
Properties
 | Name | Description
Public property | Channel | Gets the channel according to this frame. (Inherited from ExportEventArgsChannelFrame.)
Public property | Times | Gets the times array for this frame. (Inherited from ExportEventArgsChannelFrame.)
Public property | Values | Gets the values array for this frame. (Inherited from ExportEventArgsChannelFrame.)
Public property | XValues | Gets the values array for this frame.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.XYChannelFrame Constructor

Creates a new XYChannelFrame witch contains the channel Inforamtion

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public XYChannelFrame(
    Channel channel,
    List<long> times,
    List<Object> values,
    List<Object> xValues
)
Public Sub New (
    channel As Channel,
    times As List(Of Long),
    values As List(Of Object),
    xValues As List(Of Object)
)
public:
XYChannelFrame(
    Channel^ channel,
    List<long long>^ times,
    List<Object^>^ values,
    List<Object^>^ xValues
)

Parameters

channel
Type: TwinCAT.Measurement.Scope.API.ModelChannel
channel-info
times
Type: System.Collections.GenericList Int64
Time data
values
Type: System.Collections.GenericList Object
y data
xValues
Type: System.Collections.GenericList Object
x data
See Also

Reference

ExportEventArgsXYChannelFrame Class
TwinCAT.Measurement.Scope.API Namespace


XYChannelFrame Properties

The ExportEventArgsXYChannelFrame type exposes the following members.

Properties
 | Name | Description
Public property | Channel | Gets the channel according to this frame. (Inherited from ExportEventArgsChannelFrame.)
Public property | Times | Gets the times array for this frame. (Inherited from ExportEventArgsChannelFrame.)
Public property | Values | Gets the values array for this frame. (Inherited from ExportEventArgsChannelFrame.)
Public property | XValues | Gets the values array for this frame.
Top
See Also

Reference

ExportEventArgsXYChannelFrame Class
TwinCAT.Measurement.Scope.API Namespace


ExportEventArgs.XYChannelFrame.XValues Property

Gets the values array for this frame.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public List<Object> XValues { get; }
Public ReadOnly Property XValues As List(Of Object)
    Get
public:
property List<Object^>^ XValues {
    List<Object^>^ get ();
}

Property Value

Type: List Object
The values.
See Also

Reference

ExportEventArgsXYChannelFrame Class
TwinCAT.Measurement.Scope.API Namespace


XYChannelFrame Methods

The ExportEventArgsXYChannelFrame type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExportEventArgsXYChannelFrame Class
TwinCAT.Measurement.Scope.API Namespace


FindEditorArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.APIFindEditorArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class FindEditorArgs : EventArgs
Public Class FindEditorArgs
    Inherits EventArgs
public ref class FindEditorArgs : public EventArgs

The FindEditorArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FindEditorArgs | Initializes a new instance of the FindEditorArgs class
Top
Properties
 | Name | Description
Public property | Converter |
Public property | EditorBaseType |
Public property | ResultEditor |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


FindEditorArgs Constructor

Initializes a new instance of the FindEditorArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public FindEditorArgs(
    Type editorBaseType,
    TypeConverter converter
)
Public Sub New (
    editorBaseType As Type,
    converter As TypeConverter
)
public:
FindEditorArgs(
    Type^ editorBaseType,
    TypeConverter^ converter
)

Parameters

editorBaseType
Type: SystemType
converter
Type: System.ComponentModelTypeConverter
See Also

Reference

FindEditorArgs Class
TwinCAT.Measurement.Scope.API Namespace


FindEditorArgs Properties

The FindEditorArgs type exposes the following members.

Properties
 | Name | Description
Public property | Converter |
Public property | EditorBaseType |
Public property | ResultEditor |
Top
See Also

Reference

FindEditorArgs Class
TwinCAT.Measurement.Scope.API Namespace


FindEditorArgs.Converter Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TypeConverter Converter { get; }
Public ReadOnly Property Converter As TypeConverter
    Get
public:
property TypeConverter^ Converter {
    TypeConverter^ get ();
}

Property Value

Type: TypeConverter
See Also

Reference

FindEditorArgs Class
TwinCAT.Measurement.Scope.API Namespace


FindEditorArgs.EditorBaseType Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Type EditorBaseType { get; }
Public ReadOnly Property EditorBaseType As Type
    Get
public:
property Type^ EditorBaseType {
    Type^ get ();
}

Property Value

Type: Type
See Also

Reference

FindEditorArgs Class
TwinCAT.Measurement.Scope.API Namespace


FindEditorArgs.ResultEditor Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Object ResultEditor { get; set; }
Public Property ResultEditor As Object
    Get
    Set
public:
property Object^ ResultEditor {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

FindEditorArgs Class
TwinCAT.Measurement.Scope.API Namespace


FindEditorArgs Methods

The FindEditorArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FindEditorArgs Class
TwinCAT.Measurement.Scope.API Namespace


FindMemberHelper Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APIFindMemberHelper

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static class FindMemberHelper
Public NotInheritable Class FindMemberHelper
public ref class FindMemberHelper abstract sealed

The FindMemberHelper type exposes the following members.

Methods
Name | Description
FindMarker(AxisGroup, Guid, Marker) |
FindMarker(MarkerContainer, Guid, Marker) |
FindMarker(Chart, Guid, Marker, Boolean) |
FindMarker(ScopeProject, Guid, Marker, Boolean) |
FindTriggerGroup(ScopeProject, Guid, MeasurementMemberBase, Boolean) |
FindTriggerGroup(TriggerModule, Guid, MeasurementMemberBase, Boolean) |
FindTriggerRelInfo |
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


FindMemberHelper Methods

The FindMemberHelper type exposes the following members.

Methods
Name | Description
FindMarker(AxisGroup, Guid, Marker) |
FindMarker(MarkerContainer, Guid, Marker) |
FindMarker(Chart, Guid, Marker, Boolean) |
FindMarker(ScopeProject, Guid, Marker, Boolean) |
FindTriggerGroup(ScopeProject, Guid, MeasurementMemberBase, Boolean) |
FindTriggerGroup(TriggerModule, Guid, MeasurementMemberBase, Boolean) |
FindTriggerRelInfo |
Top
See Also

Reference

FindMemberHelper Class
TwinCAT.Measurement.Scope.API Namespace


FindMemberHelper.FindMarker Method

Overload List
Name | Description
FindMarker(AxisGroup, Guid, Marker) |
FindMarker(MarkerContainer, Guid, Marker) |
FindMarker(Chart, Guid, Marker, Boolean) |
FindMarker(ScopeProject, Guid, Marker, Boolean) |
Top
See Also

Reference

FindMemberHelper Class
TwinCAT.Measurement.Scope.API Namespace


FindMemberHelper.FindMarker Method (AxisGroup, Guid, Marker)

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool FindMarker(
    AxisGroup axisGroup,
    Guid guid,
    out Marker foundMarker
)
Public Shared Function FindMarker (
    axisGroup As AxisGroup,
    guid As Guid,
    <OutAttribute> ByRef foundMarker As Marker
) As Boolean
public:
static bool FindMarker(
    AxisGroup^ axisGroup,
    Guid guid,
    [OutAttribute] Marker^% foundMarker
)

Parameters

axisGroup
Type: TwinCAT.Measurement.Scope.API.ModelAxisGroup
guid
Type: SystemGuid
foundMarker
Type: TwinCAT.Measurement.Scope.API.ModelMarker

Return Value

Type: Boolean
See Also

Reference

FindMemberHelper Class
FindMarker Overload
TwinCAT.Measurement.Scope.API Namespace


FindMemberHelper.FindMarker Method (MarkerContainer, Guid, Marker)

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool FindMarker(
    MarkerContainer markerContainer,
    Guid guid,
    out Marker foundMarker
)
Public Shared Function FindMarker (
    markerContainer As MarkerContainer,
    guid As Guid,
    <OutAttribute> ByRef foundMarker As Marker
) As Boolean
public:
static bool FindMarker(
    MarkerContainer^ markerContainer,
    Guid guid,
    [OutAttribute] Marker^% foundMarker
)

Parameters

markerContainer
Type: TwinCAT.Measurement.Scope.API.ModelMarkerContainer
guid
Type: SystemGuid
foundMarker
Type: TwinCAT.Measurement.Scope.API.ModelMarker

Return Value

Type: Boolean
See Also

Reference

FindMemberHelper Class
FindMarker Overload
TwinCAT.Measurement.Scope.API Namespace


FindMemberHelper.FindMarker Method (Chart, Guid, Marker, Boolean)

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool FindMarker(
    Chart chart,
    Guid guid,
    out Marker foundMarker,
    bool fullSubTree = false
)
Public Shared Function FindMarker (
    chart As Chart,
    guid As Guid,
    <OutAttribute> ByRef foundMarker As Marker,
    Optional fullSubTree As Boolean = false
) As Boolean
public:
static bool FindMarker(
    Chart^ chart,
    Guid guid,
    [OutAttribute] Marker^% foundMarker,
    bool fullSubTree = false
)

Parameters

chart
Type: TwinCAT.Measurement.Scope.API.ModelChart
guid
Type: SystemGuid
foundMarker
Type: TwinCAT.Measurement.Scope.API.ModelMarker
fullSubTree (Optional)
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

FindMemberHelper Class
FindMarker Overload
TwinCAT.Measurement.Scope.API Namespace


FindMemberHelper.FindMarker Method (ScopeProject, Guid, Marker, Boolean)

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool FindMarker(
    ScopeProject scopeProject,
    Guid guid,
    out Marker foundMarker,
    bool fullSubTree = false
)
Public Shared Function FindMarker (
    scopeProject As ScopeProject,
    guid As Guid,
    <OutAttribute> ByRef foundMarker As Marker,
    Optional fullSubTree As Boolean = false
) As Boolean
public:
static bool FindMarker(
    ScopeProject^ scopeProject,
    Guid guid,
    [OutAttribute] Marker^% foundMarker,
    bool fullSubTree = false
)

Parameters

scopeProject
Type: TwinCAT.Measurement.Scope.API.ModelScopeProject
guid
Type: SystemGuid
foundMarker
Type: TwinCAT.Measurement.Scope.API.ModelMarker
fullSubTree (Optional)
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

FindMemberHelper Class
FindMarker Overload
TwinCAT.Measurement.Scope.API Namespace


FindMemberHelper.FindTriggerGroup Method

Overload List
Name | Description
FindTriggerGroup(ScopeProject, Guid, MeasurementMemberBase, Boolean) |
FindTriggerGroup(TriggerModule, Guid, MeasurementMemberBase, Boolean) |
Top
See Also

Reference

FindMemberHelper Class
TwinCAT.Measurement.Scope.API Namespace


FindMemberHelper.FindTriggerGroup Method (ScopeProject, Guid, MeasurementMemberBase, Boolean)

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool FindTriggerGroup(
    ScopeProject scopeProject,
    Guid guid,
    out MeasurementMemberBase foundMember,
    bool checkTriggerReleaseInfo = false
)
Public Shared Function FindTriggerGroup (
    scopeProject As ScopeProject,
    guid As Guid,
    <OutAttribute> ByRef foundMember As MeasurementMemberBase,
    Optional checkTriggerReleaseInfo As Boolean = false
) As Boolean
public:
static bool FindTriggerGroup(
    ScopeProject^ scopeProject,
    Guid guid,
    [OutAttribute] MeasurementMemberBase^% foundMember,
    bool checkTriggerReleaseInfo = false
)

Parameters

scopeProject
Type: TwinCAT.Measurement.Scope.API.ModelScopeProject
guid
Type: SystemGuid
foundMember
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
checkTriggerReleaseInfo (Optional)
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

FindMemberHelper Class
FindTriggerGroup Overload
TwinCAT.Measurement.Scope.API Namespace


FindMemberHelper.FindTriggerGroup Method (TriggerModule, Guid, MeasurementMemberBase, Boolean)

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool FindTriggerGroup(
    TriggerModule triggerModule,
    Guid guid,
    out MeasurementMemberBase foundMember,
    bool checkTriggerReleaseInfo = false
)
Public Shared Function FindTriggerGroup (
    triggerModule As TriggerModule,
    guid As Guid,
    <OutAttribute> ByRef foundMember As MeasurementMemberBase,
    Optional checkTriggerReleaseInfo As Boolean = false
) As Boolean
public:
static bool FindTriggerGroup(
    TriggerModule^ triggerModule,
    Guid guid,
    [OutAttribute] MeasurementMemberBase^% foundMember,
    bool checkTriggerReleaseInfo = false
)

Parameters

triggerModule
Type: TwinCAT.Measurement.Scope.API.ModelTriggerModule
guid
Type: SystemGuid
foundMember
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
checkTriggerReleaseInfo (Optional)
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

FindMemberHelper Class
FindTriggerGroup Overload
TwinCAT.Measurement.Scope.API Namespace


FindMemberHelper.FindTriggerRelInfo Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool FindTriggerRelInfo(
    TriggerGroup triggerGroup,
    Guid guid,
    out TriggerReleaseInfo foundReleaseInfo
)
Public Shared Function FindTriggerRelInfo (
    triggerGroup As TriggerGroup,
    guid As Guid,
    <OutAttribute> ByRef foundReleaseInfo As TriggerReleaseInfo
) As Boolean
public:
static bool FindTriggerRelInfo(
    TriggerGroup^ triggerGroup,
    Guid guid,
    [OutAttribute] TriggerReleaseInfo^% foundReleaseInfo
)

Parameters

triggerGroup
Type: TwinCAT.Measurement.Scope.API.ModelTriggerGroup
guid
Type: SystemGuid
foundReleaseInfo
Type: TwinCAT.Measurement.Scope.API.ModelTriggerReleaseInfo

Return Value

Type: Boolean
See Also

Reference

FindMemberHelper Class
TwinCAT.Measurement.Scope.API Namespace


GraphFillMode Enumeration

The Fillmode of the Graph

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum GraphFillMode
Public Enumeration GraphFillMode
public enum class GraphFillMode
Members
Member name | Value | Description
None | 0 | No filling
FromVerticalZero | 32 | Filled between Vertical Zero and the graph
FromHorizontalZero | 64 | Filled between Horizontel Zero and the graph
FromCenter | 96 | Filled between Center and the graph
FromLeft | 128 | Filled from Left border to graph
FromRight | 256 | Filled from Right border to graph
FromTop | 288 | Filled from top border to graph
FromBottom | 320 | Filled from bot border to graph
FromSource | 352 | Filled from first to last point
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ImagesAutoDeleteMode Enumeration

Auto Delete Mode

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum ImagesAutoDeleteMode
Public Enumeration ImagesAutoDeleteMode
public enum class ImagesAutoDeleteMode
Members
Member name | Value | Description
Disabled | 0 | Disabled
Capacity | 1 | Capacity
OlderThan | 2 | Older Then
CapacityOrOlderThan | 3 | Older Than and Capacity
SameSettingLikeData | 4 | Use same settings as the Data Delete Mode
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


InteractionHelper Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APIInteractionHelper

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static class InteractionHelper
Public NotInheritable Class InteractionHelper
public ref class InteractionHelper abstract sealed

The InteractionHelper type exposes the following members.

Methods
Name | Description
CtrlPressed |
GetChart |
GetStringType(String) |
GetStringType(String, MeasurementMemberBase) |
IsTargetBrowserXML |
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


InteractionHelper Methods

The InteractionHelper type exposes the following members.

Methods
Name | Description
CtrlPressed |
GetChart |
GetStringType(String) |
GetStringType(String, MeasurementMemberBase) |
IsTargetBrowserXML |
Top
See Also

Reference

InteractionHelper Class
TwinCAT.Measurement.Scope.API Namespace


InteractionHelper.CtrlPressed Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool CtrlPressed(
    uint KeyState
)
Public Shared Function CtrlPressed (
    KeyState As UInteger
) As Boolean
public:
static bool CtrlPressed(
    unsigned int KeyState
)

Parameters

KeyState
Type: SystemUInt32

Return Value

Type: Boolean
See Also

Reference

InteractionHelper Class
TwinCAT.Measurement.Scope.API Namespace


InteractionHelper.GetChart Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static Chart GetChart(
    MeasurementMemberBase Member
)
Public Shared Function GetChart (
    Member As MeasurementMemberBase
) As Chart
public:
static Chart^ GetChart(
    MeasurementMemberBase^ Member
)

Parameters

Member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase

Return Value

Type: Chart
See Also

Reference

InteractionHelper Class
TwinCAT.Measurement.Scope.API Namespace


InteractionHelper.GetStringType Method

Overload List
Name | Description
GetStringType(String) |
GetStringType(String, MeasurementMemberBase) |
Top
See Also

Reference

InteractionHelper Class
TwinCAT.Measurement.Scope.API Namespace


InteractionHelper.GetStringType Method (String)

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static StringType GetStringType(
    string value
)
Public Shared Function GetStringType (
    value As String
) As StringType
public:
static StringType GetStringType(
    String^ value
)

Parameters

value
Type: SystemString

Return Value

Type: StringType
See Also

Reference

InteractionHelper Class
GetStringType Overload
TwinCAT.Measurement.Scope.API Namespace


InteractionHelper.GetStringType Method (String, MeasurementMemberBase)

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static StringType GetStringType(
    string value,
    out MeasurementMemberBase newMember
)
Public Shared Function GetStringType (
    value As String,
    <OutAttribute> ByRef newMember As MeasurementMemberBase
) As StringType
public:
static StringType GetStringType(
    String^ value,
    [OutAttribute] MeasurementMemberBase^% newMember
)

Parameters

value
Type: SystemString
newMember
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase

Return Value

Type: StringType
See Also

Reference

InteractionHelper Class
GetStringType Overload
TwinCAT.Measurement.Scope.API Namespace


InteractionHelper.IsTargetBrowserXML Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool IsTargetBrowserXML(
    string value
)
Public Shared Function IsTargetBrowserXML (
    value As String
) As Boolean
public:
static bool IsTargetBrowserXML(
    String^ value
)

Parameters

value
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

InteractionHelper Class
TwinCAT.Measurement.Scope.API Namespace


InvalidFileException Class

Inheritance Hierarchy
SystemObject
SystemException
TwinCAT.Measurement.Scope.APIInvalidFileException

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class InvalidFileException : Exception
Public Class InvalidFileException
    Inherits Exception
public ref class InvalidFileException : public Exception

The InvalidFileException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidFileException | Initializes a new instance of the InvalidFileException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FilePath |
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


InvalidFileException Constructor

Initializes a new instance of the InvalidFileException class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public InvalidFileException(
    string filePath
)
Public Sub New (
    filePath As String
)
public:
InvalidFileException(
    String^ filePath
)

Parameters

filePath
Type: SystemString
See Also

Reference

InvalidFileException Class
TwinCAT.Measurement.Scope.API Namespace


InvalidFileException Properties

The InvalidFileException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FilePath |
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidFileException Class
TwinCAT.Measurement.Scope.API Namespace


InvalidFileException.FilePath Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string FilePath { get; }
Public ReadOnly Property FilePath As String
    Get
public:
property String^ FilePath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InvalidFileException Class
TwinCAT.Measurement.Scope.API Namespace


InvalidFileException Methods

The InvalidFileException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidFileException Class
TwinCAT.Measurement.Scope.API Namespace


Linestate Enumeration

Enum to describe LinestateSettings

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[FlagsAttribute]
public enum Linestate
<FlagsAttribute>
Public Enumeration Linestate
[FlagsAttribute]
public enum class Linestate
Members
Member name | Value | Description
None | 0 | State not defined
Normal | 1 | Normal
Bold | 2 | Bold
MediumBold | 4 | Medium Bold
Invisible | 8 | Invisible
Up | 16 | Line shiftet up by an half LineWidth
Down | 32 | Line shiftet down by a half LineWidth
Dashed | 256 | Dashed
DashedLine | 4352 | Dashed Line
MarkerArrowRight | 17408 | Marks have a Right Arrow
MarkerArrowLeft | 18432 | Marks have a Left Arrow
ApplyToLine | 4096 | LineState applyed to Line
ApplyToFillArea | 8192 | LineStateApplyed to FillArea
ApplyToMark | 16384 | LineStateApplyed to Marks
ApplyToLineNMarkNFill | 28672 | Combines ApplyToMark, ApplyToLine, ApplyToFill
InvisibleLine | 4104 | Line Invisible
InvisibleMark | 16392 | Marks Invisible
InvisibleLineNMark | 20488 | Line and Marks Invisible
LineUp | 4112 | Line shifted up
LineDown | 4128 | Line shifted down
MarkUp | 16400 | Marks shifted up
MarkDown | 16416 | Marks shifted down
LineNMarkUp | 20496 | Line and Marks shifted up
LineNMarkDown | 20512 | Line and Marks shifted down
NormalLine | 4097 | Line Normal
NormalLineUp | 4113 | Line Normal and up
NormalLineDown | 4129 | Line Normal and Down
NormalFill | 8193 | FillArea Normal
NormalMark | 16385 | Normal Mark
NormalMarkUp | 16401 | Normal Mark Up
NormalMarkDown | 16417 | Normal Mark Down
NormalLineNMark | 20481 | Normal Line and Mark
NormalLineNMarkUp | 20497 | Normal Line and Mark Up
NormalLineNMarkDown | 20513 | Normal Line and Mark Down
BoldLine | 4098 | Bold Line
BoldLineUp | 4114 | Bold Line up
BoldLineDown | 4130 | Bold line down
BoldMark | 16386 | Bold Mark
BoldMarkUp | 16402 | Bold Mark up
BoldMarkDown | 16418 | Bold Mark down
BoldLineNMark | 20482 | Bold Line and Mark
BoldLineNMarkUp | 20498 | Bold Line and Mark up
BoldLineNMarkDown | 20514 | Bold Line and Mark down
MediumBoldLine | 4100 | Medium Bold Line
MediumBoldLineUp | 4116 | Medium Bold Line Up
MediumBoldLineDown | 4132 | Medium Bold Line Down
MediumBoldMark | 16388 | Medium Bold Mark
MediumBoldMarkUp | 16404 | Medium Bold Mark Up
MediumBoldMarkDown | 16420 | Medium Bold Mark Down
MediumBoldLineNMark | 20484 | Medium Bold Line and Mark
MediumBoldLineNMarkUp | 20500 | Medium Bold Line and Mark up
MediumBoldLineNMarkDown | 20516 | Medium Bold Line and Mark down
Colored | 1099511562240 | Colored
ColoredRed | 1095216660480 | Colored Red
ColoredGreen | 4278190080 | Colored Green
ColoredBlue | 16711680 | Colored Blue
Transparent | 280375465082880 | Transparent
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


MarkConfiguration Enumeration

Enum decribing the MarkState

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum MarkConfiguration
Public Enumeration MarkConfiguration
public enum class MarkConfiguration
Members
Member name | Value | Description
Off | 0 | No Marks are shown
On | 1 | All Marks are shown
Auto | 2 | Turn Marks of if there are to much
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


Marker3DParts Enumeration

Defines the Visible Parts of the Canvas Border

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[FlagsAttribute]
public enum Marker3DParts
<FlagsAttribute>
Public Enumeration Marker3DParts
[FlagsAttribute]
public enum class Marker3DParts
Members
Member name | Value | Description
None | 0 | Marker is invisible
HighlightDataPoint | 1 | Highlight the Data Point
HighlightPointOn2DChart | 2 | Show a point on the visible Grids
HighlightPointOnAxis | 4 | Show a point on the axis with the value labels
ShowLineTo2DChart | 8 | Combine the DataPoint with the Grid
ShowLineOn2DChart | 16 | Show a line on the Grid
AllLines | 28 | Show all Lines
AllPoints | 7 | Show all Points
All | 31 | Show all
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


Marker3DPartsConverter Class

Converts the Markertype into a string
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
System.ComponentModelStringConverter
TwinCAT.Measurement.Scope.APIMarker3DPartsConverter

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class Marker3DPartsConverter : StringConverter
Public Class Marker3DPartsConverter
    Inherits StringConverter
public ref class Marker3DPartsConverter : public StringConverter

The Marker3DPartsConverter type exposes the following members.

Constructors
 | Name | Description
Public method | Marker3DPartsConverter | Initializes a new instance of the Marker3DPartsConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object in the given source type to a string using the specified context. (Inherited from StringConverter.)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the specified value object to a String object. (Inherited from StringConverter.)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts to (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


Marker3DPartsConverter Constructor

Initializes a new instance of the Marker3DPartsConverter class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Marker3DPartsConverter()
Public Sub New
public:
Marker3DPartsConverter()
See Also

Reference

Marker3DPartsConverter Class
TwinCAT.Measurement.Scope.API Namespace


Marker3DPartsConverter Methods

The Marker3DPartsConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object in the given source type to a string using the specified context. (Inherited from StringConverter.)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the specified value object to a String object. (Inherited from StringConverter.)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts to (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Marker3DPartsConverter Class
TwinCAT.Measurement.Scope.API Namespace


Marker3DPartsConverter.ConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts to (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

Marker3DPartsConverter Class
TwinCAT.Measurement.Scope.API Namespace


Marker3DPartsConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts to

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject
destinationType
Type: SystemType

Return Value

Type: Object
See Also

Reference

Marker3DPartsConverter Class
ConvertTo Overload
TwinCAT.Measurement.Scope.API Namespace


MarkerTable_ChooserType Enumeration

Defines two Types for the Marker Table Chooser

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum MarkerTable_ChooserType
Public Enumeration MarkerTable_ChooserType
public enum class MarkerTable_ChooserType
Members
Member name | Value | Description
Marker | 0 | Marker Chooser Type
Channel | 1 | Channel Chooser Type
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


MarkerType Enumeration

Define the Type of Marker

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[FlagsAttribute]
public enum MarkerType
<FlagsAttribute>
Public Enumeration MarkerType
[FlagsAttribute]
public enum class MarkerType
Members
Member name | Value | Description
None | 0 | Show nothing
Circle | 1 | Default Value - Shows only the Circle
Marker | 2 | Shows Marker
Fill | 4 | Fill the Elements
Cross | 8 | Draw a Cross
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


MouseModes Enumeration

Enum describing the MouseMode

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum MouseModes
Public Enumeration MouseModes
public enum class MouseModes
Members
Member name | Value | Description
NONE | 0 | No mouse acions associated.
CURSOR | 1 | The mouse can change cursorpositions.
ZOOM_X | 2 | The mouse opens a zoomrect with full display height.
ZOOM_Y | 3 | The mouse opens a zoomrect with full display width.
ZOOM_XY | 4 | The mouse opens a zoomrect.
PANNING_X | 5 | The mouse shifts the display along the timeline.
PANNING_XY | 6 | The mouse shifts the display in all directions.
PANNING_Y | 7 | The mouse shifts the display along the y-Axis.
MODIFY | 8 |
SELECT | 9 |
TRANSFORM | 10 |
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


OpcException Class

Base Class for all Scope OPC Exceptions
Inheritance Hierarchy
SystemObject
SystemException
TwinCAT.Measurement.Scope.APIOpcException
TwinCAT.Measurement.Scope.APIOpcServerNotTrustedException
TwinCAT.Measurement.Scope.APIOpcWrongCredentialsException

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class OpcException : Exception
Public MustInherit Class OpcException
    Inherits Exception
public ref class OpcException abstract : public Exception

The OpcException type exposes the following members.

Constructors
 | Name | Description
Public method | OpcException | Create a new OPCException
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Help | Show how to Handle this Exception
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


OpcException Constructor

Create a new OPCException

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public OpcException(
    string Message,
    Exception inner,
    string Help
)
Public Sub New (
    Message As String,
    inner As Exception,
    Help As String
)
public:
OpcException(
    String^ Message,
    Exception^ inner,
    String^ Help
)

Parameters

Message
Type: SystemString
The Message
inner
Type: SystemException
The inner Exception
Help
Type: SystemString
Shows how to handle this Exception
See Also

Reference

OpcException Class
TwinCAT.Measurement.Scope.API Namespace


OpcException Properties

The OpcException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Help | Show how to Handle this Exception
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

OpcException Class
TwinCAT.Measurement.Scope.API Namespace


OpcException.Help Property

Show how to Handle this Exception

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Help { get; }
Public ReadOnly Property Help As String
    Get
public:
property String^ Help {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

OpcException Class
TwinCAT.Measurement.Scope.API Namespace


OpcException Methods

The OpcException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

OpcException Class
TwinCAT.Measurement.Scope.API Namespace


OpcServerNotTrustedException Class

Exception thrown on try to connect untrusted OPC Channel
Inheritance Hierarchy
SystemObject
SystemException
TwinCAT.Measurement.Scope.APIOpcException
TwinCAT.Measurement.Scope.APIOpcServerNotTrustedException

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class OpcServerNotTrustedException : OpcException
Public Class OpcServerNotTrustedException
    Inherits OpcException
public ref class OpcServerNotTrustedException : public OpcException

The OpcServerNotTrustedException type exposes the following members.

Constructors
 | Name | Description
Public method | OpcServerNotTrustedException | Create a new OpcServerNotTrustException
Top
Properties
 | Name | Description
Public property | AmsNetId | Get the AmsNetId
Public property | CommonName | Get the CommonName
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Help | Show how to Handle this Exception (Inherited from OpcException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | LocalServer | Determines wether the local Server should be trusted.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | OpcAddress | Get the OPC Adress
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ThumbPrint | Get the ThumbPrint
Public property | ValidFrom | Get the ValidFrom
Public property | ValidTo | Get the ValidTo
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


OpcServerNotTrustedException Constructor

Create a new OpcServerNotTrustException

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public OpcServerNotTrustedException(
    OpcUaAddress OpcAddress,
    bool LocalServer,
    AmsNetId AmsNetId,
    string CommonName,
    string ThumbPrint,
    string ValidFrom,
    string ValidTo,
    Exception inner
)
Public Sub New (
    OpcAddress As OpcUaAddress,
    LocalServer As Boolean,
    AmsNetId As AmsNetId,
    CommonName As String,
    ThumbPrint As String,
    ValidFrom As String,
    ValidTo As String,
    inner As Exception
)
public:
OpcServerNotTrustedException(
    OpcUaAddress^ OpcAddress,
    bool LocalServer,
    AmsNetId^ AmsNetId,
    String^ CommonName,
    String^ ThumbPrint,
    String^ ValidFrom,
    String^ ValidTo,
    Exception^ inner
)

Parameters

OpcAddress
Type: OpcUaAddress
The Opc Adress to trust
LocalServer
Type: SystemBoolean
True if Local Server is used
AmsNetId
Type: AmsNetId
AmsNetId
CommonName
Type: SystemString
Common Name
ThumbPrint
Type: SystemString
ThumbPrint
ValidFrom
Type: SystemString
Valid From
ValidTo
Type: SystemString
Valid To
inner
Type: SystemException
The Inner Exception
See Also

Reference

OpcServerNotTrustedException Class
TwinCAT.Measurement.Scope.API Namespace


OpcServerNotTrustedException Properties

The OpcServerNotTrustedException type exposes the following members.

Properties
 | Name | Description
Public property | AmsNetId | Get the AmsNetId
Public property | CommonName | Get the CommonName
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Help | Show how to Handle this Exception (Inherited from OpcException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | LocalServer | Determines wether the local Server should be trusted.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | OpcAddress | Get the OPC Adress
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ThumbPrint | Get the ThumbPrint
Public property | ValidFrom | Get the ValidFrom
Public property | ValidTo | Get the ValidTo
Top
See Also

Reference

OpcServerNotTrustedException Class
TwinCAT.Measurement.Scope.API Namespace


OpcServerNotTrustedException.AmsNetId Property

Get the AmsNetId

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AmsNetId AmsNetId { get; }
Public ReadOnly Property AmsNetId As AmsNetId
    Get
public:
property AmsNetId^ AmsNetId {
    AmsNetId^ get ();
}

Property Value

Type: AmsNetId
See Also

Reference

OpcServerNotTrustedException Class
TwinCAT.Measurement.Scope.API Namespace


OpcServerNotTrustedException.CommonName Property

Get the CommonName

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string CommonName { get; }
Public ReadOnly Property CommonName As String
    Get
public:
property String^ CommonName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

OpcServerNotTrustedException Class
TwinCAT.Measurement.Scope.API Namespace


OpcServerNotTrustedException.LocalServer Property

Determines wether the local Server should be trusted.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool LocalServer { get; }
Public ReadOnly Property LocalServer As Boolean
    Get
public:
property bool LocalServer {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

OpcServerNotTrustedException Class
TwinCAT.Measurement.Scope.API Namespace


OpcServerNotTrustedException.OpcAddress Property

Get the OPC Adress

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public OpcUaAddress OpcAddress { get; }
Public ReadOnly Property OpcAddress As OpcUaAddress
    Get
public:
property OpcUaAddress^ OpcAddress {
    OpcUaAddress^ get ();
}

Property Value

Type: OpcUaAddress
See Also

Reference

OpcServerNotTrustedException Class
TwinCAT.Measurement.Scope.API Namespace


OpcServerNotTrustedException.ThumbPrint Property

Get the ThumbPrint

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string ThumbPrint { get; }
Public ReadOnly Property ThumbPrint As String
    Get
public:
property String^ ThumbPrint {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

OpcServerNotTrustedException Class
TwinCAT.Measurement.Scope.API Namespace


OpcServerNotTrustedException.ValidFrom Property

Get the ValidFrom

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string ValidFrom { get; }
Public ReadOnly Property ValidFrom As String
    Get
public:
property String^ ValidFrom {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

OpcServerNotTrustedException Class
TwinCAT.Measurement.Scope.API Namespace


OpcServerNotTrustedException.ValidTo Property

Get the ValidTo

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string ValidTo { get; }
Public ReadOnly Property ValidTo As String
    Get
public:
property String^ ValidTo {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

OpcServerNotTrustedException Class
TwinCAT.Measurement.Scope.API Namespace


OpcServerNotTrustedException Methods

The OpcServerNotTrustedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

OpcServerNotTrustedException Class
TwinCAT.Measurement.Scope.API Namespace


OpcWrongCredentialsException Class

Exception throw if Opc Credentials are wrong
Inheritance Hierarchy
SystemObject
SystemException
TwinCAT.Measurement.Scope.APIOpcException
TwinCAT.Measurement.Scope.APIOpcWrongCredentialsException

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class OpcWrongCredentialsException : OpcException
Public Class OpcWrongCredentialsException
    Inherits OpcException
public ref class OpcWrongCredentialsException : public OpcException

The OpcWrongCredentialsException type exposes the following members.

Constructors
 | Name | Description
Public method | OpcWrongCredentialsException | Create a new OpcWrongCredetialsException
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Help | Show how to Handle this Exception (Inherited from OpcException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | OpcAddress | Get the OPC Adress
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


OpcWrongCredentialsException Constructor

Create a new OpcWrongCredetialsException

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public OpcWrongCredentialsException(
    OpcUaAddress OpcAddress,
    Exception inner
)
Public Sub New (
    OpcAddress As OpcUaAddress,
    inner As Exception
)
public:
OpcWrongCredentialsException(
    OpcUaAddress^ OpcAddress,
    Exception^ inner
)

Parameters

OpcAddress
Type: OpcUaAddress
The OpcAddress
inner
Type: SystemException
The inner Exception
See Also

Reference

OpcWrongCredentialsException Class
TwinCAT.Measurement.Scope.API Namespace


OpcWrongCredentialsException Properties

The OpcWrongCredentialsException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | Help | Show how to Handle this Exception (Inherited from OpcException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | OpcAddress | Get the OPC Adress
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

OpcWrongCredentialsException Class
TwinCAT.Measurement.Scope.API Namespace


OpcWrongCredentialsException.OpcAddress Property

Get the OPC Adress

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public OpcUaAddress OpcAddress { get; }
Public ReadOnly Property OpcAddress As OpcUaAddress
    Get
public:
property OpcUaAddress^ OpcAddress {
    OpcUaAddress^ get ();
}

Property Value

Type: OpcUaAddress
See Also

Reference

OpcWrongCredentialsException Class
TwinCAT.Measurement.Scope.API Namespace


OpcWrongCredentialsException Methods

The OpcWrongCredentialsException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

OpcWrongCredentialsException Class
TwinCAT.Measurement.Scope.API Namespace


OrderDataEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.APIOrderDataEventArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class OrderDataEventArgs : EventArgs
Public Class OrderDataEventArgs
    Inherits EventArgs
public ref class OrderDataEventArgs : public EventArgs

The OrderDataEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OrderDataEventArgs | Initializes a new instance of the OrderDataEventArgs class
Top
Properties
 | Name | Description
Public property | Channel |
Public property | End |
Public property | Frame |
Public property | Start |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


OrderDataEventArgs Constructor

Initializes a new instance of the OrderDataEventArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public OrderDataEventArgs(
    long start,
    long end,
    ClientChannel channel
)
Public Sub New (
    start As Long,
    end As Long,
    channel As ClientChannel
)
public:
OrderDataEventArgs(
    long long start,
    long long end,
    ClientChannel^ channel
)

Parameters

start
Type: SystemInt64
end
Type: SystemInt64
channel
Type: ClientChannel
See Also

Reference

OrderDataEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


OrderDataEventArgs Properties

The OrderDataEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Channel |
Public property | End |
Public property | Frame |
Public property | Start |
Top
See Also

Reference

OrderDataEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


OrderDataEventArgs.Channel Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ClientChannel Channel { get; }
Public ReadOnly Property Channel As ClientChannel
    Get
public:
property ClientChannel^ Channel {
    ClientChannel^ get ();
}

Property Value

Type: ClientChannel
See Also

Reference

OrderDataEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


OrderDataEventArgs.End Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long End { get; }
Public ReadOnly Property End As Long
    Get
public:
property long long End {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

OrderDataEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


OrderDataEventArgs.Frame Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SingleChannelFrame Frame { get; set; }
Public Property Frame As SingleChannelFrame
    Get
    Set
public:
property SingleChannelFrame^ Frame {
    SingleChannelFrame^ get ();
    void set (SingleChannelFrame^ value);
}

Property Value

Type: SingleChannelFrame
See Also

Reference

OrderDataEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


OrderDataEventArgs.Start Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long Start { get; }
Public ReadOnly Property Start As Long
    Get
public:
property long long Start {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

OrderDataEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


OrderDataEventArgs Methods

The OrderDataEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OrderDataEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase Class

Inheritance Hierarchy
SystemObject
System.ComponentModelMemberDescriptor
System.ComponentModelPropertyDescriptor
TwinCAT.Measurement.Scope.APIProjectBaseDesignPropertyDescriptorBase

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ProjectBaseDesignPropertyDescriptorBase : PropertyDescriptor
Public Class ProjectBaseDesignPropertyDescriptorBase
    Inherits PropertyDescriptor
public ref class ProjectBaseDesignPropertyDescriptorBase : public PropertyDescriptor

The ProjectBaseDesignPropertyDescriptorBase type exposes the following members.

Constructors
 | Name | Description
Public method | ProjectBaseDesignPropertyDescriptorBase | Initializes a new instance of the ProjectBaseDesignPropertyDescriptorBase class
Top
Properties
 | Name | Description
Public property | Attributes | Gets the collection of attributes for this member. (Inherited from MemberDescriptor.)
Public property | Category | (Overrides MemberDescriptorCategory.)
Public property | ComponentType | (Overrides PropertyDescriptorComponentType.)
Public property | Converter | (Overrides PropertyDescriptorConverter.)
Public property | Description | Gets the description of the member, as specified in the DescriptionAttribute. (Inherited from MemberDescriptor.)
Public property | DesignTimeOnly | Gets whether this member should be set only at design time, as specified in the DesignOnlyAttribute. (Inherited from MemberDescriptor.)
Public property | DisplayName | (Overrides MemberDescriptorDisplayName.)
Public property | Element |
Public property | IsBrowsable | (Overrides MemberDescriptorIsBrowsable.)
Public property | IsLocalizable | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute. (Inherited from PropertyDescriptor.)
Public property | IsReadOnly | (Overrides PropertyDescriptorIsReadOnly.)
Public property | Name | Gets the name of the member. (Inherited from MemberDescriptor.)
Public property | PropertyType | (Overrides PropertyDescriptorPropertyType.)
Public property | SerializationVisibility | Gets a value indicating whether this property should be serialized, as specified in the DesignerSerializationVisibilityAttribute. (Inherited from PropertyDescriptor.)
Public property | SupportsChangeEvents | Gets a value indicating whether value change notifications for this property may originate from outside the property descriptor. (Inherited from PropertyDescriptor.)
Top
Methods
 | Name | Description
Public method | AddValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | CanResetValue | (Overrides PropertyDescriptorCanResetValue(Object).)
Public method | Equals | Compares this to another object to see if they are equivalent. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties | Returns the default PropertyDescriptorCollection. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Attribute) | Returns a PropertyDescriptorCollection using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object) | Returns a PropertyDescriptorCollection for a given object. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object, Attribute) | (Overrides PropertyDescriptorGetChildProperties(Object, Attribute).)
Public method | GetEditor | (Overrides PropertyDescriptorGetEditor(Type).)
Public method | GetHashCode | Returns the hash code for this object. (Inherited from PropertyDescriptor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Overrides PropertyDescriptorGetValue(Object).)
Public method | RemoveValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | ResetValue | (Overrides PropertyDescriptorResetValue(Object).)
Public method | SetValue | (Overrides PropertyDescriptorSetValue(Object, Object).)
Public method | ShouldSerializeValue | (Overrides PropertyDescriptorShouldSerializeValue(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
Name | Description
EditorCreator |
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase Constructor

Initializes a new instance of the ProjectBaseDesignPropertyDescriptorBase class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ProjectBaseDesignPropertyDescriptorBase(
    PropertyDescriptor prop,
    MeasurementMemberBase element
)
Public Sub New (
    prop As PropertyDescriptor,
    element As MeasurementMemberBase
)
public:
ProjectBaseDesignPropertyDescriptorBase(
    PropertyDescriptor^ prop,
    MeasurementMemberBase^ element
)

Parameters

prop
Type: System.ComponentModelPropertyDescriptor
element
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase Properties

The ProjectBaseDesignPropertyDescriptorBase type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets the collection of attributes for this member. (Inherited from MemberDescriptor.)
Public property | Category | (Overrides MemberDescriptorCategory.)
Public property | ComponentType | (Overrides PropertyDescriptorComponentType.)
Public property | Converter | (Overrides PropertyDescriptorConverter.)
Public property | Description | Gets the description of the member, as specified in the DescriptionAttribute. (Inherited from MemberDescriptor.)
Public property | DesignTimeOnly | Gets whether this member should be set only at design time, as specified in the DesignOnlyAttribute. (Inherited from MemberDescriptor.)
Public property | DisplayName | (Overrides MemberDescriptorDisplayName.)
Public property | Element |
Public property | IsBrowsable | (Overrides MemberDescriptorIsBrowsable.)
Public property | IsLocalizable | Gets a value indicating whether this property should be localized, as specified in the LocalizableAttribute. (Inherited from PropertyDescriptor.)
Public property | IsReadOnly | (Overrides PropertyDescriptorIsReadOnly.)
Public property | Name | Gets the name of the member. (Inherited from MemberDescriptor.)
Public property | PropertyType | (Overrides PropertyDescriptorPropertyType.)
Public property | SerializationVisibility | Gets a value indicating whether this property should be serialized, as specified in the DesignerSerializationVisibilityAttribute. (Inherited from PropertyDescriptor.)
Public property | SupportsChangeEvents | Gets a value indicating whether value change notifications for this property may originate from outside the property descriptor. (Inherited from PropertyDescriptor.)
Top
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.Category Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string Category { get; }
Public Overrides ReadOnly Property Category As String
    Get
public:
virtual property String^ Category {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.ComponentType Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override Type ComponentType { get; }
Public Overrides ReadOnly Property ComponentType As Type
    Get
public:
virtual property Type^ ComponentType {
    Type^ get () override;
}

Property Value

Type: Type
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.Converter Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override TypeConverter Converter { get; }
Public Overrides ReadOnly Property Converter As TypeConverter
    Get
public:
virtual property TypeConverter^ Converter {
    TypeConverter^ get () override;
}

Property Value

Type: TypeConverter
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.DisplayName Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get
public:
virtual property String^ DisplayName {
    String^ get () override;
}

Property Value

Type: String
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.Element Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MeasurementMemberBase Element { get; }
Public ReadOnly Property Element As MeasurementMemberBase
    Get
public:
virtual property MeasurementMemberBase^ Element {
    MeasurementMemberBase^ get () sealed;
}

Property Value

Type: MeasurementMemberBase
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.IsBrowsable Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool IsBrowsable { get; }
Public Overrides ReadOnly Property IsBrowsable As Boolean
    Get
public:
virtual property bool IsBrowsable {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.IsReadOnly Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.PropertyType Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override Type PropertyType { get; }
Public Overrides ReadOnly Property PropertyType As Type
    Get
public:
virtual property Type^ PropertyType {
    Type^ get () override;
}

Property Value

Type: Type
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase Methods

The ProjectBaseDesignPropertyDescriptorBase type exposes the following members.

Methods
 | Name | Description
Public method | AddValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | CanResetValue | (Overrides PropertyDescriptorCanResetValue(Object).)
Public method | Equals | Compares this to another object to see if they are equivalent. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties | Returns the default PropertyDescriptorCollection. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Attribute) | Returns a PropertyDescriptorCollection using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object) | Returns a PropertyDescriptorCollection for a given object. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object, Attribute) | (Overrides PropertyDescriptorGetChildProperties(Object, Attribute).)
Public method | GetEditor | (Overrides PropertyDescriptorGetEditor(Type).)
Public method | GetHashCode | Returns the hash code for this object. (Inherited from PropertyDescriptor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | (Overrides PropertyDescriptorGetValue(Object).)
Public method | RemoveValueChanged | Enables other objects to be notified when this property changes. (Inherited from PropertyDescriptor.)
Public method | ResetValue | (Overrides PropertyDescriptorResetValue(Object).)
Public method | SetValue | (Overrides PropertyDescriptorSetValue(Object, Object).)
Public method | ShouldSerializeValue | (Overrides PropertyDescriptorShouldSerializeValue(Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.CanResetValue Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool CanResetValue(
    Object component
)
Public Overrides Function CanResetValue (
    component As Object
) As Boolean
public:
virtual bool CanResetValue(
    Object^ component
) override

Parameters

component
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.GetChildProperties Method

Overload List
 | Name | Description
Public method | GetChildProperties | Returns the default PropertyDescriptorCollection. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Attribute) | Returns a PropertyDescriptorCollection using a specified array of attributes as a filter. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object) | Returns a PropertyDescriptorCollection for a given object. (Inherited from PropertyDescriptor.)
Public method | GetChildProperties(Object, Attribute) | (Overrides PropertyDescriptorGetChildProperties(Object, Attribute).)
Top
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.GetChildProperties Method (Object, Attribute[])

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override PropertyDescriptorCollection GetChildProperties(
    Object instance,
    Attribute[] filter
)
Public Overrides Function GetChildProperties (
    instance As Object,
    filter As Attribute()
) As PropertyDescriptorCollection
public:
virtual PropertyDescriptorCollection^ GetChildProperties(
    Object^ instance,
    array<Attribute^>^ filter
) override

Parameters

instance
Type: SystemObject
filter
Type: SystemAttribute

Return Value

Type: PropertyDescriptorCollection
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
GetChildProperties Overload
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.GetEditor Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override Object GetEditor(
    Type editorBaseType
)
Public Overrides Function GetEditor (
    editorBaseType As Type
) As Object
public:
virtual Object^ GetEditor(
    Type^ editorBaseType
) override

Parameters

editorBaseType
Type: SystemType

Return Value

Type: Object
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.GetValue Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override Object GetValue(
    Object component
)
Public Overrides Function GetValue (
    component As Object
) As Object
public:
virtual Object^ GetValue(
    Object^ component
) override

Parameters

component
Type: SystemObject

Return Value

Type: Object
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.ResetValue Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void ResetValue(
    Object component
)
Public Overrides Sub ResetValue (
    component As Object
)
public:
virtual void ResetValue(
    Object^ component
) override

Parameters

component
Type: SystemObject
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.SetValue Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void SetValue(
    Object component,
    Object value
)
Public Overrides Sub SetValue (
    component As Object,
    value As Object
)
public:
virtual void SetValue(
    Object^ component,
    Object^ value
) override

Parameters

component
Type: SystemObject
value
Type: SystemObject
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.ShouldSerializeValue Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool ShouldSerializeValue(
    Object component
)
Public Overrides Function ShouldSerializeValue (
    component As Object
) As Boolean
public:
virtual bool ShouldSerializeValue(
    Object^ component
) override

Parameters

component
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase Events

The ProjectBaseDesignPropertyDescriptorBase type exposes the following members.

Events
Name | Description
EditorCreator |
Top
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectBaseDesignPropertyDescriptorBase.EditorCreator Event

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static event EventHandler<FindEditorArgs> EditorCreator
Public Shared Event EditorCreator As EventHandler(Of FindEditorArgs)
public:
static  event EventHandler<FindEditorArgs^>^ EditorCreator {
    void add (EventHandler<FindEditorArgs^>^ value);
    void remove (EventHandler<FindEditorArgs^>^ value);
}

Value

Type: SystemEventHandler FindEditorArgs
See Also

Reference

ProjectBaseDesignPropertyDescriptorBase Class
TwinCAT.Measurement.Scope.API Namespace


ProjectHelper Class

Project Helper Class
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APIProjectHelper

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static class ProjectHelper
<ExtensionAttribute>
Public NotInheritable Class ProjectHelper
[ExtensionAttribute]
public ref class ProjectHelper abstract sealed

The ProjectHelper type exposes the following members.

Methods
Name | Description
FindElementsT | Find new Elements for old Elements
StartShaddow | Starts an Project as a Shaddow Project
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ProjectHelper Methods

The ProjectHelper type exposes the following members.

Methods
Name | Description
FindElementsT | Find new Elements for old Elements
StartShaddow | Starts an Project as a Shaddow Project
Top
See Also

Reference

ProjectHelper Class
TwinCAT.Measurement.Scope.API Namespace


ProjectHelper.FindElements(T) Method

Find new Elements for old Elements

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static T[] FindElements<T>(
    this Dictionary<Guid, MeasurementMemberBase> guidDict,
    IEnumerable<T> oldElements
)
where T : MeasurementMemberBase

<ExtensionAttribute>
Public Shared Function FindElements(Of T As MeasurementMemberBase) (
    guidDict As Dictionary(Of Guid, MeasurementMemberBase),
    oldElements As IEnumerable(Of T)
) As T()
public:
[ExtensionAttribute]
generic<typename T>
where T : MeasurementMemberBase
static array<T>^ FindElements(
    Dictionary<Guid, MeasurementMemberBase^>^ guidDict,
    IEnumerable<T>^ oldElements
)

Parameters

guidDict
Type: System.Collections.GenericDictionary Guid, MeasurementMemberBase
The Dictionary to find elements at
oldElements
Type: System.Collections.GenericIEnumerable T
The old Elements

Type Parameters

T
The type of elements to search

Return Value

Type: T
An Array containing all elements found

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Dictionary Guid, MeasurementMemberBase . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ProjectHelper Class
TwinCAT.Measurement.Scope.API Namespace


ProjectHelper.StartShaddow Method

Starts an Project as a Shaddow Project

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool StartShaddow(
    ScopeProject scopeProject,
    Guid shaddowID
)
Public Shared Function StartShaddow (
    scopeProject As ScopeProject,
    shaddowID As Guid
) As Boolean
public:
static bool StartShaddow(
    ScopeProject^ scopeProject,
    Guid shaddowID
)

Parameters

scopeProject
Type: TwinCAT.Measurement.Scope.API.ModelScopeProject
shaddowID
Type: SystemGuid

Return Value

Type: Boolean
See Also

Reference

ProjectHelper Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater Class

PropertyUpdater can Bind a Property to an Value
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.APIPropertyUpdater

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class PropertyUpdater : ScopeMemberContainerBase
Public Class PropertyUpdater
    Inherits ScopeMemberContainerBase
public ref class PropertyUpdater : public ScopeMemberContainerBase

The PropertyUpdater type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyUpdater | Create a new instance of PropertyUpdater
Public method | PropertyUpdater(PropertyUpdater) | Create a copy of the propertyUpdater
Public method | PropertyUpdater(String, String, String) | Create a new instance of PropertyUpdater
Public method | PropertyUpdater(String, String, String, String) | Create a new instance of PropertyUpdater
Top
Properties
 | Name | Description
Public property | AdditionalPropertyInfo | Gets or Sets the AdditionalPropertyInfo.
Public property | CategoryName | Gets or Sets the CategoryName.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | InterpreterGUID | Gets or Sets the InterpreterGUID.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | PropertyDisplayName | Gets or Sets the PropertyDisplayName.
Public property | PropertyName | Gets or Sets the PropertyName.
Public property | ReferenceAcquisitionInterpreter | Gets or Sets the ReferenceAcquisitionInterpreter.
Public property | ReusedAcquisitionOrInterpreter | Gets or Sets the ReusedAcquisitionOrInterpreter.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RefreshData |
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AdditionalPropertyInfoChanged | Fired when the AdditionalPropertyInfo is changed.
Public event | AdditionalPropertyInfoValidating | Fired while validating the new value for AdditionalPropertyInfo.
Public event | CategoryNameChanged | Fired when the CategoryName is changed.
Public event | CategoryNameValidating | Fired while validating the new value for CategoryName.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InterpreterGUIDChanged | Fired when the InterpreterGUID is changed.
Public event | InterpreterGUIDValidating | Fired while validating the new value for InterpreterGUID.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | PropertyDisplayNameChanged | Fired when the PropertyDisplayName is changed.
Public event | PropertyDisplayNameValidating | Fired while validating the new value for PropertyDisplayName.
Public event | PropertyNameChanged | Fired when the PropertyName is changed.
Public event | PropertyNameValidating | Fired while validating the new value for PropertyName.
Public event | ReferenceAcquisitionInterpreterChanged | Fired when the ReferenceAcquisitionInterpreterChanged is changed.
Public event | ReferenceAcquisitionInterpreterChanging | Fired before Changing the value of ReferenceAcquisitionInterpreter.
Public event | ReferenceAcquisitionInterpreterValidating | Fired while validating the new value for ReferenceAcquisitionInterpreter.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReusedAcquisitionOrInterpreterChanged | Fired when the ReusedAcquisitionOrInterpreter is changed.
Public event | ReusedAcquisitionOrInterpreterValidating | Fired while validating the new value for ReusedAcquisitionOrInterpreter.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater Constructor

Overload List
 | Name | Description
Public method | PropertyUpdater | Create a new instance of PropertyUpdater
Public method | PropertyUpdater(PropertyUpdater) | Create a copy of the propertyUpdater
Public method | PropertyUpdater(String, String, String) | Create a new instance of PropertyUpdater
Public method | PropertyUpdater(String, String, String, String) | Create a new instance of PropertyUpdater
Top
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater Constructor

Create a new instance of PropertyUpdater

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public PropertyUpdater()
Public Sub New
public:
PropertyUpdater()
See Also

Reference

PropertyUpdater Class
PropertyUpdater Overload
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater Constructor (PropertyUpdater)

Create a copy of the propertyUpdater

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public PropertyUpdater(
    PropertyUpdater propertyUpdater
)
Public Sub New (
    propertyUpdater As PropertyUpdater
)
public:
PropertyUpdater(
    PropertyUpdater^ propertyUpdater
)

Parameters

propertyUpdater
Type: TwinCAT.Measurement.Scope.APIPropertyUpdater
See Also

Reference

PropertyUpdater Class
PropertyUpdater Overload
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater Constructor (String, String, String)

Create a new instance of PropertyUpdater

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public PropertyUpdater(
    string propertyName,
    string propertyDisplayName,
    string categoryName
)
Public Sub New (
    propertyName As String,
    propertyDisplayName As String,
    categoryName As String
)
public:
PropertyUpdater(
    String^ propertyName,
    String^ propertyDisplayName,
    String^ categoryName
)

Parameters

propertyName
Type: SystemString
propertyDisplayName
Type: SystemString
categoryName
Type: SystemString
See Also

Reference

PropertyUpdater Class
PropertyUpdater Overload
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater Constructor (String, String, String, String)

Create a new instance of PropertyUpdater

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public PropertyUpdater(
    string propertyName,
    string additionalPropertyInfo,
    string propertyDisplayName,
    string categoryName
)
Public Sub New (
    propertyName As String,
    additionalPropertyInfo As String,
    propertyDisplayName As String,
    categoryName As String
)
public:
PropertyUpdater(
    String^ propertyName,
    String^ additionalPropertyInfo,
    String^ propertyDisplayName,
    String^ categoryName
)

Parameters

propertyName
Type: SystemString
additionalPropertyInfo
Type: SystemString
propertyDisplayName
Type: SystemString
categoryName
Type: SystemString
See Also

Reference

PropertyUpdater Class
PropertyUpdater Overload
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater Properties

The PropertyUpdater type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalPropertyInfo | Gets or Sets the AdditionalPropertyInfo.
Public property | CategoryName | Gets or Sets the CategoryName.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | InterpreterGUID | Gets or Sets the InterpreterGUID.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | PropertyDisplayName | Gets or Sets the PropertyDisplayName.
Public property | PropertyName | Gets or Sets the PropertyName.
Public property | ReferenceAcquisitionInterpreter | Gets or Sets the ReferenceAcquisitionInterpreter.
Public property | ReusedAcquisitionOrInterpreter | Gets or Sets the ReusedAcquisitionOrInterpreter.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.AdditionalPropertyInfo Property

Gets or Sets the AdditionalPropertyInfo.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string AdditionalPropertyInfo { get; set; }
Public Property AdditionalPropertyInfo As String
    Get
    Set
public:
property String^ AdditionalPropertyInfo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.CategoryName Property

Gets or Sets the CategoryName.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string CategoryName { get; set; }
<BrowsableAttribute(false)>
Public Property CategoryName As String
    Get
    Set
public:
[BrowsableAttribute(false)]
property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.InterpreterGUID Property

Gets or Sets the InterpreterGUID.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public Guid InterpreterGUID { get; set; }
<BrowsableAttribute(false)>
Public Property InterpreterGUID As Guid
    Get
    Set
public:
[BrowsableAttribute(false)]
property Guid InterpreterGUID {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.PropertyDisplayName Property

Gets or Sets the PropertyDisplayName.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string PropertyDisplayName { get; set; }
<BrowsableAttribute(false)>
Public Property PropertyDisplayName As String
    Get
    Set
public:
[BrowsableAttribute(false)]
property String^ PropertyDisplayName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.PropertyName Property

Gets or Sets the PropertyName.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string PropertyName { get; set; }
<BrowsableAttribute(false)>
Public Property PropertyName As String
    Get
    Set
public:
[BrowsableAttribute(false)]
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.ReferenceAcquisitionInterpreter Property

Gets or Sets the ReferenceAcquisitionInterpreter.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public AcquisitionInterpreter ReferenceAcquisitionInterpreter { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property ReferenceAcquisitionInterpreter As AcquisitionInterpreter
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property AcquisitionInterpreter^ ReferenceAcquisitionInterpreter {
    AcquisitionInterpreter^ get ();
    void set (AcquisitionInterpreter^ value);
}

Property Value

Type: AcquisitionInterpreter
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.ReusedAcquisitionOrInterpreter Property

Gets or Sets the ReusedAcquisitionOrInterpreter.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
public Guid ReusedAcquisitionOrInterpreter { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(true)>
Public Property ReusedAcquisitionOrInterpreter As Guid
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
property Guid ReusedAcquisitionOrInterpreter {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater Methods

The PropertyUpdater type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RefreshData |
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.RefreshData Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void RefreshData()
Public Sub RefreshData
public:
void RefreshData()
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.UpdatePropertyAttributes Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater Events

The PropertyUpdater type exposes the following members.

Events
 | Name | Description
Public event | AdditionalPropertyInfoChanged | Fired when the AdditionalPropertyInfo is changed.
Public event | AdditionalPropertyInfoValidating | Fired while validating the new value for AdditionalPropertyInfo.
Public event | CategoryNameChanged | Fired when the CategoryName is changed.
Public event | CategoryNameValidating | Fired while validating the new value for CategoryName.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InterpreterGUIDChanged | Fired when the InterpreterGUID is changed.
Public event | InterpreterGUIDValidating | Fired while validating the new value for InterpreterGUID.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | PropertyDisplayNameChanged | Fired when the PropertyDisplayName is changed.
Public event | PropertyDisplayNameValidating | Fired while validating the new value for PropertyDisplayName.
Public event | PropertyNameChanged | Fired when the PropertyName is changed.
Public event | PropertyNameValidating | Fired while validating the new value for PropertyName.
Public event | ReferenceAcquisitionInterpreterChanged | Fired when the ReferenceAcquisitionInterpreterChanged is changed.
Public event | ReferenceAcquisitionInterpreterChanging | Fired before Changing the value of ReferenceAcquisitionInterpreter.
Public event | ReferenceAcquisitionInterpreterValidating | Fired while validating the new value for ReferenceAcquisitionInterpreter.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReusedAcquisitionOrInterpreterChanged | Fired when the ReusedAcquisitionOrInterpreter is changed.
Public event | ReusedAcquisitionOrInterpreterValidating | Fired while validating the new value for ReusedAcquisitionOrInterpreter.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.AdditionalPropertyInfoChanged Event

Fired when the AdditionalPropertyInfo is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AdditionalPropertyInfoChanged
Public Event AdditionalPropertyInfoChanged As EventHandler
public:
 event EventHandler^ AdditionalPropertyInfoChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.AdditionalPropertyInfoValidating Event

Fired while validating the new value for AdditionalPropertyInfo.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AdditionalPropertyInfoValidating
Public Event AdditionalPropertyInfoValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AdditionalPropertyInfoValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.CategoryNameChanged Event

Fired when the CategoryName is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CategoryNameChanged
Public Event CategoryNameChanged As EventHandler
public:
 event EventHandler^ CategoryNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.CategoryNameValidating Event

Fired while validating the new value for CategoryName.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> CategoryNameValidating
Public Event CategoryNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ CategoryNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.InterpreterGUIDChanged Event

Fired when the InterpreterGUID is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler InterpreterGUIDChanged
Public Event InterpreterGUIDChanged As EventHandler
public:
 event EventHandler^ InterpreterGUIDChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.InterpreterGUIDValidating Event

Fired while validating the new value for InterpreterGUID.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> InterpreterGUIDValidating
Public Event InterpreterGUIDValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ InterpreterGUIDValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.PropertyDisplayNameChanged Event

Fired when the PropertyDisplayName is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PropertyDisplayNameChanged
Public Event PropertyDisplayNameChanged As EventHandler
public:
 event EventHandler^ PropertyDisplayNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.PropertyDisplayNameValidating Event

Fired while validating the new value for PropertyDisplayName.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PropertyDisplayNameValidating
Public Event PropertyDisplayNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PropertyDisplayNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.PropertyNameChanged Event

Fired when the PropertyName is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PropertyNameChanged
Public Event PropertyNameChanged As EventHandler
public:
 event EventHandler^ PropertyNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.PropertyNameValidating Event

Fired while validating the new value for PropertyName.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PropertyNameValidating
Public Event PropertyNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PropertyNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.ReferenceAcquisitionInterpreterChanged Event

Fired when the ReferenceAcquisitionInterpreterChanged is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReferenceAcquisitionInterpreterChanged
Public Event ReferenceAcquisitionInterpreterChanged As EventHandler
public:
 event EventHandler^ ReferenceAcquisitionInterpreterChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.ReferenceAcquisitionInterpreterChanging Event

Fired before Changing the value of ReferenceAcquisitionInterpreter.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReferenceAcquisitionInterpreterChanging
Public Event ReferenceAcquisitionInterpreterChanging As EventHandler
public:
 event EventHandler^ ReferenceAcquisitionInterpreterChanging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.ReferenceAcquisitionInterpreterValidating Event

Fired while validating the new value for ReferenceAcquisitionInterpreter.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReferenceAcquisitionInterpreterValidating
Public Event ReferenceAcquisitionInterpreterValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReferenceAcquisitionInterpreterValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.ReusedAcquisitionOrInterpreterChanged Event

Fired when the ReusedAcquisitionOrInterpreter is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReusedAcquisitionOrInterpreterChanged
Public Event ReusedAcquisitionOrInterpreterChanged As EventHandler
public:
 event EventHandler^ ReusedAcquisitionOrInterpreterChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


PropertyUpdater.ReusedAcquisitionOrInterpreterValidating Event

Fired while validating the new value for ReusedAcquisitionOrInterpreter.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReusedAcquisitionOrInterpreterValidating
Public Event ReusedAcquisitionOrInterpreterValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReusedAcquisitionOrInterpreterValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

PropertyUpdater Class
TwinCAT.Measurement.Scope.API Namespace


RemoteImageTriggerReleaseArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
ImageTriggerReleaseArgs
TwinCAT.Measurement.Scope.APIRemoteImageTriggerReleaseArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class RemoteImageTriggerReleaseArgs : ImageTriggerReleaseArgs
Public Class RemoteImageTriggerReleaseArgs
    Inherits ImageTriggerReleaseArgs
public ref class RemoteImageTriggerReleaseArgs : public ImageTriggerReleaseArgs

The RemoteImageTriggerReleaseArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RemoteImageTriggerReleaseArgs | Initializes a new instance of the RemoteImageTriggerReleaseArgs class
Top
Properties
 | Name | Description
Public property | SingleGroupHandle |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


RemoteImageTriggerReleaseArgs Constructor

Initializes a new instance of the RemoteImageTriggerReleaseArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public RemoteImageTriggerReleaseArgs(
    string PicPath,
    long Timestamp,
    uint singleGroupHandle
)
Public Sub New (
    PicPath As String,
    Timestamp As Long,
    singleGroupHandle As UInteger
)
public:
RemoteImageTriggerReleaseArgs(
    String^ PicPath,
    long long Timestamp,
    unsigned int singleGroupHandle
)

Parameters

PicPath
Type: SystemString
Timestamp
Type: SystemInt64
singleGroupHandle
Type: SystemUInt32
See Also

Reference

RemoteImageTriggerReleaseArgs Class
TwinCAT.Measurement.Scope.API Namespace


RemoteImageTriggerReleaseArgs Properties

The RemoteImageTriggerReleaseArgs type exposes the following members.

Properties
 | Name | Description
Public property | SingleGroupHandle |
Top
See Also

Reference

RemoteImageTriggerReleaseArgs Class
TwinCAT.Measurement.Scope.API Namespace


RemoteImageTriggerReleaseArgs.SingleGroupHandle Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public uint SingleGroupHandle { get; }
Public ReadOnly Property SingleGroupHandle As UInteger
    Get
public:
property unsigned int SingleGroupHandle {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

RemoteImageTriggerReleaseArgs Class
TwinCAT.Measurement.Scope.API Namespace


RemoteImageTriggerReleaseArgs Methods

The RemoteImageTriggerReleaseArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RemoteImageTriggerReleaseArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.APIReportArgs
TwinCAT.Measurement.Scope.APIReportAutomaticArgs
TwinCAT.Measurement.Scope.APIReportManualArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ReportArgs : EventArgs
Public Class ReportArgs
    Inherits EventArgs
public ref class ReportArgs : public EventArgs

The ReportArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ReportArgs | Initializes a new instance of the ReportArgs class
Public method | ReportArgs(ReportChartBackground, Int64) | Initializes a new instance of the ReportArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | chartBackground |
Public field | LegendFontSize |
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ReportArgs Constructor

Overload List
 | Name | Description
Public method | ReportArgs | Initializes a new instance of the ReportArgs class
Public method | ReportArgs(ReportChartBackground, Int64) | Initializes a new instance of the ReportArgs class
Top
See Also

Reference

ReportArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportArgs Constructor

Initializes a new instance of the ReportArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReportArgs()
Public Sub New
public:
ReportArgs()
See Also

Reference

ReportArgs Class
ReportArgs Overload
TwinCAT.Measurement.Scope.API Namespace


ReportArgs Constructor (ReportChartBackground, Int64)

Initializes a new instance of the ReportArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReportArgs(
    ReportChartBackground chartBackground,
    long legendFontSize
)
Public Sub New (
    chartBackground As ReportChartBackground,
    legendFontSize As Long
)
public:
ReportArgs(
    ReportChartBackground chartBackground,
    long long legendFontSize
)

Parameters

chartBackground
Type: TwinCAT.Measurement.Scope.APIReportChartBackground
legendFontSize
Type: SystemInt64
See Also

Reference

ReportArgs Class
ReportArgs Overload
TwinCAT.Measurement.Scope.API Namespace


ReportArgs Methods

The ReportArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReportArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportArgs Fields

The ReportArgs type exposes the following members.

Fields
 | Name | Description
Public field | chartBackground |
Public field | LegendFontSize |
Top
See Also

Reference

ReportArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportArgs.chartBackground Field

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReportChartBackground chartBackground
Public chartBackground As ReportChartBackground
public:
ReportChartBackground chartBackground

Field Value

Type: ReportChartBackground
See Also

Reference

ReportArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportArgs.LegendFontSize Field

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long LegendFontSize
Public LegendFontSize As Long
public:
long long LegendFontSize

Field Value

Type: Int64
See Also

Reference

ReportArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportAutomaticArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.APIReportArgs
TwinCAT.Measurement.Scope.APIReportAutomaticArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ReportAutomaticArgs : ReportArgs
Public Class ReportAutomaticArgs
    Inherits ReportArgs
public ref class ReportAutomaticArgs : public ReportArgs

The ReportAutomaticArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ReportAutomaticArgs | Initializes a new instance of the ReportAutomaticArgs class
Public method | ReportAutomaticArgs(Int64) | Initializes a new instance of the ReportAutomaticArgs class
Public method | ReportAutomaticArgs(Int64, Int64) | Initializes a new instance of the ReportAutomaticArgs class
Public method | ReportAutomaticArgs(ReportChartBackground, Int64) | Initializes a new instance of the ReportAutomaticArgs class
Public method | ReportAutomaticArgs(ReportChartBackground, Int64, Int64, Int64) | Initializes a new instance of the ReportAutomaticArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | chartBackground | (Inherited from ReportArgs.)
Public field | EndTime |
Public field | LegendFontSize | (Inherited from ReportArgs.)
Public field | StartTime |
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ReportAutomaticArgs Constructor

Overload List
 | Name | Description
Public method | ReportAutomaticArgs | Initializes a new instance of the ReportAutomaticArgs class
Public method | ReportAutomaticArgs(Int64) | Initializes a new instance of the ReportAutomaticArgs class
Public method | ReportAutomaticArgs(Int64, Int64) | Initializes a new instance of the ReportAutomaticArgs class
Public method | ReportAutomaticArgs(ReportChartBackground, Int64) | Initializes a new instance of the ReportAutomaticArgs class
Public method | ReportAutomaticArgs(ReportChartBackground, Int64, Int64, Int64) | Initializes a new instance of the ReportAutomaticArgs class
Top
See Also

Reference

ReportAutomaticArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportAutomaticArgs Constructor

Initializes a new instance of the ReportAutomaticArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReportAutomaticArgs()
Public Sub New
public:
ReportAutomaticArgs()
See Also

Reference

ReportAutomaticArgs Class
ReportAutomaticArgs Overload
TwinCAT.Measurement.Scope.API Namespace


ReportAutomaticArgs Constructor (Int64)

Initializes a new instance of the ReportAutomaticArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReportAutomaticArgs(
    long endTime
)
Public Sub New (
    endTime As Long
)
public:
ReportAutomaticArgs(
    long long endTime
)

Parameters

endTime
Type: SystemInt64
See Also

Reference

ReportAutomaticArgs Class
ReportAutomaticArgs Overload
TwinCAT.Measurement.Scope.API Namespace


ReportAutomaticArgs Constructor (Int64, Int64)

Initializes a new instance of the ReportAutomaticArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReportAutomaticArgs(
    long startTime,
    long endTime
)
Public Sub New (
    startTime As Long,
    endTime As Long
)
public:
ReportAutomaticArgs(
    long long startTime,
    long long endTime
)

Parameters

startTime
Type: SystemInt64
endTime
Type: SystemInt64
See Also

Reference

ReportAutomaticArgs Class
ReportAutomaticArgs Overload
TwinCAT.Measurement.Scope.API Namespace


ReportAutomaticArgs Constructor (ReportChartBackground, Int64)

Initializes a new instance of the ReportAutomaticArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReportAutomaticArgs(
    ReportChartBackground chartBackground,
    long legendFontSize
)
Public Sub New (
    chartBackground As ReportChartBackground,
    legendFontSize As Long
)
public:
ReportAutomaticArgs(
    ReportChartBackground chartBackground,
    long long legendFontSize
)

Parameters

chartBackground
Type: TwinCAT.Measurement.Scope.APIReportChartBackground
legendFontSize
Type: SystemInt64
See Also

Reference

ReportAutomaticArgs Class
ReportAutomaticArgs Overload
TwinCAT.Measurement.Scope.API Namespace


ReportAutomaticArgs Constructor (ReportChartBackground, Int64, Int64, Int64)

Initializes a new instance of the ReportAutomaticArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReportAutomaticArgs(
    ReportChartBackground chartBackground,
    long legendFontSize,
    long startTime,
    long endTime
)
Public Sub New (
    chartBackground As ReportChartBackground,
    legendFontSize As Long,
    startTime As Long,
    endTime As Long
)
public:
ReportAutomaticArgs(
    ReportChartBackground chartBackground,
    long long legendFontSize,
    long long startTime,
    long long endTime
)

Parameters

chartBackground
Type: TwinCAT.Measurement.Scope.APIReportChartBackground
legendFontSize
Type: SystemInt64
startTime
Type: SystemInt64
endTime
Type: SystemInt64
See Also

Reference

ReportAutomaticArgs Class
ReportAutomaticArgs Overload
TwinCAT.Measurement.Scope.API Namespace


ReportAutomaticArgs Methods

The ReportAutomaticArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReportAutomaticArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportAutomaticArgs Fields

The ReportAutomaticArgs type exposes the following members.

Fields
 | Name | Description
Public field | chartBackground | (Inherited from ReportArgs.)
Public field | EndTime |
Public field | LegendFontSize | (Inherited from ReportArgs.)
Public field | StartTime |
Top
See Also

Reference

ReportAutomaticArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportAutomaticArgs.EndTime Field

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long EndTime
Public EndTime As Long
public:
long long EndTime

Field Value

Type: Int64
See Also

Reference

ReportAutomaticArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportAutomaticArgs.StartTime Field

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long StartTime
Public StartTime As Long
public:
long long StartTime

Field Value

Type: Int64
See Also

Reference

ReportAutomaticArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportChartBackground Enumeration

Modes of Report Chart Background

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum ReportChartBackground
Public Enumeration ReportChartBackground
public enum class ReportChartBackground
Members
Member name | Value | Description
Light | 0 | Report Chart Light Background
Transparent | 1 | Report Chart Transparent Background
Dark | 2 | Report Chart Dark Background
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ReportManualArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.APIReportArgs
TwinCAT.Measurement.Scope.APIReportManualArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ReportManualArgs : ReportArgs
Public Class ReportManualArgs
    Inherits ReportArgs
public ref class ReportManualArgs : public ReportArgs

The ReportManualArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ReportManualArgs | Initializes a new instance of the ReportManualArgs class
Public method | ReportManualArgs(ReportChartBackground, Int64) | Initializes a new instance of the ReportManualArgs class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | chartBackground | (Inherited from ReportArgs.)
Public field | LegendFontSize | (Inherited from ReportArgs.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ReportManualArgs Constructor

Overload List
 | Name | Description
Public method | ReportManualArgs | Initializes a new instance of the ReportManualArgs class
Public method | ReportManualArgs(ReportChartBackground, Int64) | Initializes a new instance of the ReportManualArgs class
Top
See Also

Reference

ReportManualArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportManualArgs Constructor

Initializes a new instance of the ReportManualArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReportManualArgs()
Public Sub New
public:
ReportManualArgs()
See Also

Reference

ReportManualArgs Class
ReportManualArgs Overload
TwinCAT.Measurement.Scope.API Namespace


ReportManualArgs Constructor (ReportChartBackground, Int64)

Initializes a new instance of the ReportManualArgs class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReportManualArgs(
    ReportChartBackground chartBackground,
    long legendFontSize
)
Public Sub New (
    chartBackground As ReportChartBackground,
    legendFontSize As Long
)
public:
ReportManualArgs(
    ReportChartBackground chartBackground,
    long long legendFontSize
)

Parameters

chartBackground
Type: TwinCAT.Measurement.Scope.APIReportChartBackground
legendFontSize
Type: SystemInt64
See Also

Reference

ReportManualArgs Class
ReportManualArgs Overload
TwinCAT.Measurement.Scope.API Namespace


ReportManualArgs Methods

The ReportManualArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReportManualArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportManualArgs Fields

The ReportManualArgs type exposes the following members.

Fields
 | Name | Description
Public field | chartBackground | (Inherited from ReportArgs.)
Public field | LegendFontSize | (Inherited from ReportArgs.)
Top
See Also

Reference

ReportManualArgs Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember Class

UserSettings for the ScopeReport
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.APIReportOptionMember

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ReportOptionMember : MeasurementMemberBase
Public Class ReportOptionMember
    Inherits MeasurementMemberBase
public ref class ReportOptionMember : public MeasurementMemberBase

The ReportOptionMember type exposes the following members.

Constructors
 | Name | Description
Public method | ReportOptionMember | Create a new Instance of ReportOptionMember
Top
Properties
 | Name | Description
Public property | BorderBackground | Gets or Sets the BorderBackground.
Public property | ChartBackground | Gets or Sets the ChartBackground.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | ExportRawData | Gets or Sets the ExportRawData.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ShowBars | Gets or Sets the ShowBars.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseCustomColor | Gets or Sets the UseCustomColor.
Public property | XAxisColor | Gets or Sets the XAxisColor.
Public property | XGridColor | Gets or Sets the XGridColor.
Public property | YAxisColor | Gets or Sets the YAxisColor.
Public property | YGridColor | Gets or Sets the YGridColor.
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | BorderBackgroundChanged | Fired when the BorderBackground is changed.
Public event | BorderBackgroundValidating | Fired while validating the new value for BorderBackground.
Public event | ChartBackgroundChanged | Fired when the ChartBackground is changed.
Public event | ChartBackgroundValidating | Fired while validating the new value for ChartBackground.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ExportRawDataChanged | Fired when the ExportRawData is changed.
Public event | ExportRawDataValidating | Fired while validating the new value for ExportRawData.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowBarsChanged | Fired when the ShowBars is changed.
Public event | ShowBarsValidating | Fired while validating the new value for ShowBars.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseCustomColorChanged | Fired when the UseCustomColor is changed.
Public event | UseCustomColorValidating | Fired while validating the new value for UseCustomColor.
Public event | XAxisColorChanged | Fired when the XAxisColor is changed.
Public event | XAxisColorValidating | Fired while validating the new value for XAxisColor.
Public event | XGridColorChanged | Fired when the XGridColor is changed.
Public event | XGridColorValidating | Fired while validating the new value for XGridColor.
Public event | YAxisColorChanged | Fired when the YAxisColor is changed.
Public event | YAxisColorValidating | Fired while validating the new value for YAxisColor.
Public event | YGridColorChanged | Fired when the YGridColor is changed.
Public event | YGridColorValidating | Fired while validating the new value for YGridColor.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember Constructor

Create a new Instance of ReportOptionMember

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReportOptionMember()
Public Sub New
public:
ReportOptionMember()
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember Properties

The ReportOptionMember type exposes the following members.

Properties
 | Name | Description
Public property | BorderBackground | Gets or Sets the BorderBackground.
Public property | ChartBackground | Gets or Sets the ChartBackground.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | ExportRawData | Gets or Sets the ExportRawData.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ShowBars | Gets or Sets the ShowBars.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseCustomColor | Gets or Sets the UseCustomColor.
Public property | XAxisColor | Gets or Sets the XAxisColor.
Public property | XGridColor | Gets or Sets the XGridColor.
Public property | YAxisColor | Gets or Sets the YAxisColor.
Public property | YGridColor | Gets or Sets the YGridColor.
Top
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.BorderBackground Property

Gets or Sets the BorderBackground.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Color BorderBackground { get; set; }
<BrowsableAttribute(true)>
Public Property BorderBackground As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
property Color BorderBackground {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.ChartBackground Property

Gets or Sets the ChartBackground.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Color ChartBackground { get; set; }
<BrowsableAttribute(true)>
Public Property ChartBackground As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
property Color ChartBackground {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.ExportRawData Property

Gets or Sets the ExportRawData.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ExportRawData { get; set; }
<BrowsableAttribute(true)>
Public Property ExportRawData As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ExportRawData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.ShowBars Property

Gets or Sets the ShowBars.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowBars { get; set; }
<BrowsableAttribute(true)>
Public Property ShowBars As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowBars {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.UseCustomColor Property

Gets or Sets the UseCustomColor.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool UseCustomColor { get; set; }
<BrowsableAttribute(true)>
Public Property UseCustomColor As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool UseCustomColor {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.XAxisColor Property

Gets or Sets the XAxisColor.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Color XAxisColor { get; set; }
<BrowsableAttribute(true)>
Public Property XAxisColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
property Color XAxisColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.XGridColor Property

Gets or Sets the XGridColor.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Color XGridColor { get; set; }
<BrowsableAttribute(true)>
Public Property XGridColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
property Color XGridColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.YAxisColor Property

Gets or Sets the YAxisColor.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Color YAxisColor { get; set; }
<BrowsableAttribute(true)>
Public Property YAxisColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
property Color YAxisColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.YGridColor Property

Gets or Sets the YGridColor.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Color YGridColor { get; set; }
<BrowsableAttribute(true)>
Public Property YGridColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
property Color YGridColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember Methods

The ReportOptionMember type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember Events

The ReportOptionMember type exposes the following members.

Events
 | Name | Description
Public event | BorderBackgroundChanged | Fired when the BorderBackground is changed.
Public event | BorderBackgroundValidating | Fired while validating the new value for BorderBackground.
Public event | ChartBackgroundChanged | Fired when the ChartBackground is changed.
Public event | ChartBackgroundValidating | Fired while validating the new value for ChartBackground.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ExportRawDataChanged | Fired when the ExportRawData is changed.
Public event | ExportRawDataValidating | Fired while validating the new value for ExportRawData.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowBarsChanged | Fired when the ShowBars is changed.
Public event | ShowBarsValidating | Fired while validating the new value for ShowBars.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseCustomColorChanged | Fired when the UseCustomColor is changed.
Public event | UseCustomColorValidating | Fired while validating the new value for UseCustomColor.
Public event | XAxisColorChanged | Fired when the XAxisColor is changed.
Public event | XAxisColorValidating | Fired while validating the new value for XAxisColor.
Public event | XGridColorChanged | Fired when the XGridColor is changed.
Public event | XGridColorValidating | Fired while validating the new value for XGridColor.
Public event | YAxisColorChanged | Fired when the YAxisColor is changed.
Public event | YAxisColorValidating | Fired while validating the new value for YAxisColor.
Public event | YGridColorChanged | Fired when the YGridColor is changed.
Public event | YGridColorValidating | Fired while validating the new value for YGridColor.
Top
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.BorderBackgroundChanged Event

Fired when the BorderBackground is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BorderBackgroundChanged
Public Event BorderBackgroundChanged As EventHandler
public:
 event EventHandler^ BorderBackgroundChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.BorderBackgroundValidating Event

Fired while validating the new value for BorderBackground.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> BorderBackgroundValidating
Public Event BorderBackgroundValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ BorderBackgroundValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.ChartBackgroundChanged Event

Fired when the ChartBackground is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ChartBackgroundChanged
Public Event ChartBackgroundChanged As EventHandler
public:
 event EventHandler^ ChartBackgroundChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.ChartBackgroundValidating Event

Fired while validating the new value for ChartBackground.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ChartBackgroundValidating
Public Event ChartBackgroundValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ChartBackgroundValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.ExportRawDataChanged Event

Fired when the ExportRawData is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ExportRawDataChanged
Public Event ExportRawDataChanged As EventHandler
public:
 event EventHandler^ ExportRawDataChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.ExportRawDataValidating Event

Fired while validating the new value for ExportRawData.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ExportRawDataValidating
Public Event ExportRawDataValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ExportRawDataValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.ShowBarsChanged Event

Fired when the ShowBars is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowBarsChanged
Public Event ShowBarsChanged As EventHandler
public:
 event EventHandler^ ShowBarsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.ShowBarsValidating Event

Fired while validating the new value for ShowBars.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowBarsValidating
Public Event ShowBarsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowBarsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.UseCustomColorChanged Event

Fired when the UseCustomColor is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UseCustomColorChanged
Public Event UseCustomColorChanged As EventHandler
public:
 event EventHandler^ UseCustomColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.UseCustomColorValidating Event

Fired while validating the new value for UseCustomColor.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UseCustomColorValidating
Public Event UseCustomColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UseCustomColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.XAxisColorChanged Event

Fired when the XAxisColor is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler XAxisColorChanged
Public Event XAxisColorChanged As EventHandler
public:
 event EventHandler^ XAxisColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.XAxisColorValidating Event

Fired while validating the new value for XAxisColor.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> XAxisColorValidating
Public Event XAxisColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ XAxisColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.XGridColorChanged Event

Fired when the XGridColor is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler XGridColorChanged
Public Event XGridColorChanged As EventHandler
public:
 event EventHandler^ XGridColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.XGridColorValidating Event

Fired while validating the new value for XGridColor.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> XGridColorValidating
Public Event XGridColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ XGridColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.YAxisColorChanged Event

Fired when the YAxisColor is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler YAxisColorChanged
Public Event YAxisColorChanged As EventHandler
public:
 event EventHandler^ YAxisColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.YAxisColorValidating Event

Fired while validating the new value for YAxisColor.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> YAxisColorValidating
Public Event YAxisColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ YAxisColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.YGridColorChanged Event

Fired when the YGridColor is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler YGridColorChanged
Public Event YGridColorChanged As EventHandler
public:
 event EventHandler^ YGridColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptionMember.YGridColorValidating Event

Fired while validating the new value for YGridColor.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> YGridColorValidating
Public Event YGridColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ YGridColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ReportOptionMember Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptions Class

ReportOptions
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APIReportOptions

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ReportOptions
Public Class ReportOptions
public ref class ReportOptions

The ReportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ReportOptions | Initializes a new instance of the ReportOptions class
Top
Properties
 | Name | Description
Public property | BorderBackground | Get or Set the BorderBackground
Public property | ChartBackground | Get or Set the ChartBackground
Public property | ExportRawData | Get or Set the ExportRawDAta
Public property | ShowBars | Get or Set the ShowBars
Public property | UseCustomColor | Get or Set the UseCustomColor
Public property | XAxisColor | Get or Set the XAxisColor
Public property | XGridColor | Get or Set the XGridColor
Public property | YAxisColor | Get or Set the YAxisColor
Public property | YGridColor | Get or Set the YGridColor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ReportOptions Constructor

Initializes a new instance of the ReportOptions class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReportOptions()
Public Sub New
public:
ReportOptions()
See Also

Reference

ReportOptions Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptions Properties

The ReportOptions type exposes the following members.

Properties
 | Name | Description
Public property | BorderBackground | Get or Set the BorderBackground
Public property | ChartBackground | Get or Set the ChartBackground
Public property | ExportRawData | Get or Set the ExportRawDAta
Public property | ShowBars | Get or Set the ShowBars
Public property | UseCustomColor | Get or Set the UseCustomColor
Public property | XAxisColor | Get or Set the XAxisColor
Public property | XGridColor | Get or Set the XGridColor
Public property | YAxisColor | Get or Set the YAxisColor
Public property | YGridColor | Get or Set the YGridColor
Top
See Also

Reference

ReportOptions Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptions.BorderBackground Property

Get or Set the BorderBackground

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color BorderBackground { get; set; }
Public Property BorderBackground As Color
    Get
    Set
public:
property Color BorderBackground {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ReportOptions Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptions.ChartBackground Property

Get or Set the ChartBackground

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color ChartBackground { get; set; }
Public Property ChartBackground As Color
    Get
    Set
public:
property Color ChartBackground {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ReportOptions Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptions.ExportRawData Property

Get or Set the ExportRawDAta

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool ExportRawData { get; set; }
Public Property ExportRawData As Boolean
    Get
    Set
public:
property bool ExportRawData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ReportOptions Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptions.ShowBars Property

Get or Set the ShowBars

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool ShowBars { get; set; }
Public Property ShowBars As Boolean
    Get
    Set
public:
property bool ShowBars {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ReportOptions Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptions.UseCustomColor Property

Get or Set the UseCustomColor

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool UseCustomColor { get; set; }
Public Property UseCustomColor As Boolean
    Get
    Set
public:
property bool UseCustomColor {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ReportOptions Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptions.XAxisColor Property

Get or Set the XAxisColor

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color XAxisColor { get; set; }
Public Property XAxisColor As Color
    Get
    Set
public:
property Color XAxisColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ReportOptions Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptions.XGridColor Property

Get or Set the XGridColor

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color XGridColor { get; set; }
Public Property XGridColor As Color
    Get
    Set
public:
property Color XGridColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ReportOptions Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptions.YAxisColor Property

Get or Set the YAxisColor

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color YAxisColor { get; set; }
Public Property YAxisColor As Color
    Get
    Set
public:
property Color YAxisColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ReportOptions Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptions.YGridColor Property

Get or Set the YGridColor

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color YGridColor { get; set; }
Public Property YGridColor As Color
    Get
    Set
public:
property Color YGridColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ReportOptions Class
TwinCAT.Measurement.Scope.API Namespace


ReportOptions Methods

The ReportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReportOptions Class
TwinCAT.Measurement.Scope.API Namespace


RetryEventArgs Class

EventArgs to Ask for a Retry
Inheritance Hierarchy
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
TwinCAT.Measurement.Scope.APIRetryEventArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class RetryEventArgs : CancelEventArgs
Public Class RetryEventArgs
    Inherits CancelEventArgs
public ref class RetryEventArgs : public CancelEventArgs

The RetryEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RetryEventArgs | Create a new Instance of RetryEventArgs
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Message | The Message for the Retry
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


RetryEventArgs Constructor

Create a new Instance of RetryEventArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public RetryEventArgs(
    string Message
)
Public Sub New (
    Message As String
)
public:
RetryEventArgs(
    String^ Message
)

Parameters

Message
Type: SystemString
See Also

Reference

RetryEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


RetryEventArgs Properties

The RetryEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Message | The Message for the Retry
Top
See Also

Reference

RetryEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


RetryEventArgs.Message Property

The Message for the Retry

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Message { get; }
Public ReadOnly Property Message As String
    Get
public:
property String^ Message {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

RetryEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


RetryEventArgs Methods

The RetryEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RetryEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


RunMode Enumeration

Defines how the record starts up

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[FlagsAttribute]
public enum RunMode
<FlagsAttribute>
Public Enumeration RunMode
[FlagsAttribute]
public enum class RunMode
Members
Member name | Value | Description
None | 0 | Default
ClientStart | 2 | The client sends a start command
TrigerStart | 4 | A triger event ist the start command
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ScopeConverterSVDToSVDX Class

Converts a .svd to .svdx
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APIScopeConverterSVDToSVDX

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static class ScopeConverterSVDToSVDX
Public NotInheritable Class ScopeConverterSVDToSVDX
public ref class ScopeConverterSVDToSVDX abstract sealed

The ScopeConverterSVDToSVDX type exposes the following members.

Methods
Name | Description
ConvertSvdToSvdx | Converts the project and the files from the old to the new base.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ScopeConverterSVDToSVDX Methods

The ScopeConverterSVDToSVDX type exposes the following members.

Methods
Name | Description
ConvertSvdToSvdx | Converts the project and the files from the old to the new base.
Top
See Also

Reference

ScopeConverterSVDToSVDX Class
TwinCAT.Measurement.Scope.API Namespace


ScopeConverterSVDToSVDX.ConvertSvdToSvdx Method

Converts the project and the files from the old to the new base.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool ConvertSvdToSvdx(
    string svdFile,
    string svdxFile
)
Public Shared Function ConvertSvdToSvdx (
    svdFile As String,
    svdxFile As String
) As Boolean
public:
static bool ConvertSvdToSvdx(
    String^ svdFile,
    String^ svdxFile
)

Parameters

svdFile
Type: SystemString
svdxFile
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

ScopeConverterSVDToSVDX Class
TwinCAT.Measurement.Scope.API Namespace


ScopeConverterSvdxToSvd Class

Converter to Convert from SVDX to SVD
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APIScopeConverterSvdxToSvd

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static class ScopeConverterSvdxToSvd
Public NotInheritable Class ScopeConverterSvdxToSvd
public ref class ScopeConverterSvdxToSvd abstract sealed

The ScopeConverterSvdxToSvd type exposes the following members.

Methods
Name | Description
ConvertSvdxToSvd | Convert a SVDX to SVD
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ScopeConverterSvdxToSvd Methods

The ScopeConverterSvdxToSvd type exposes the following members.

Methods
Name | Description
ConvertSvdxToSvd | Convert a SVDX to SVD
Top
See Also

Reference

ScopeConverterSvdxToSvd Class
TwinCAT.Measurement.Scope.API Namespace


ScopeConverterSvdxToSvd.ConvertSvdxToSvd Method

Convert a SVDX to SVD

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool ConvertSvdxToSvd(
    string svdxFile,
    string svdFile
)
Public Shared Function ConvertSvdxToSvd (
    svdxFile As String,
    svdFile As String
) As Boolean
public:
static bool ConvertSvdxToSvd(
    String^ svdxFile,
    String^ svdFile
)

Parameters

svdxFile
Type: SystemString
FileName of the SVDX
svdFile
Type: SystemString
Destination FileName for the SVDFile

Return Value

Type: Boolean
See Also

Reference

ScopeConverterSvdxToSvd Class
TwinCAT.Measurement.Scope.API Namespace


ScopeConverterSVProjectToTcScope Class

Class to convert a ScopeProject to a ScopeViewControl
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APIScopeConverterSVProjectToTcScope

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static class ScopeConverterSVProjectToTcScope
Public NotInheritable Class ScopeConverterSVProjectToTcScope
public ref class ScopeConverterSVProjectToTcScope abstract sealed

The ScopeConverterSVProjectToTcScope type exposes the following members.

Methods
Name | Description
ConvertScopeProjectToTcScope | Converter the hole Project to an DestinationPath
CreateSerializableScope | Create a ScopeViewSerializable from a ScopeProject
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ScopeConverterSVProjectToTcScope Methods

The ScopeConverterSVProjectToTcScope type exposes the following members.

Methods
Name | Description
ConvertScopeProjectToTcScope | Converter the hole Project to an DestinationPath
CreateSerializableScope | Create a ScopeViewSerializable from a ScopeProject
Top
See Also

Reference

ScopeConverterSVProjectToTcScope Class
TwinCAT.Measurement.Scope.API Namespace


ScopeConverterSVProjectToTcScope.ConvertScopeProjectToTcScope Method

Converter the hole Project to an DestinationPath

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static void ConvertScopeProjectToTcScope(
    ScopeProject Project,
    string DestinationPath
)
Public Shared Sub ConvertScopeProjectToTcScope (
    Project As ScopeProject,
    DestinationPath As String
)
public:
static void ConvertScopeProjectToTcScope(
    ScopeProject^ Project,
    String^ DestinationPath
)

Parameters

Project
Type: TwinCAT.Measurement.Scope.API.ModelScopeProject
The Project to convert
DestinationPath
Type: SystemString
The Path to save
See Also

Reference

ScopeConverterSVProjectToTcScope Class
TwinCAT.Measurement.Scope.API Namespace


ScopeConverterSVProjectToTcScope.CreateSerializableScope Method

Create a ScopeViewSerializable from a ScopeProject

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static ScopeViewSerializable CreateSerializableScope(
    ScopeProject Project
)
Public Shared Function CreateSerializableScope (
    Project As ScopeProject
) As ScopeViewSerializable
public:
static ScopeViewSerializable^ CreateSerializableScope(
    ScopeProject^ Project
)

Parameters

Project
Type: TwinCAT.Measurement.Scope.API.ModelScopeProject

Return Value

Type: ScopeViewSerializable
See Also

Reference

ScopeConverterSVProjectToTcScope Class
TwinCAT.Measurement.Scope.API Namespace


ScopeConverterTcScopeToTcScopeX Class

Converts a .tcscope to .tcscopex
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APIScopeConverterTcScopeToTcScopeX

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static class ScopeConverterTcScopeToTcScopeX
Public NotInheritable Class ScopeConverterTcScopeToTcScopeX
public ref class ScopeConverterTcScopeToTcScopeX abstract sealed

The ScopeConverterTcScopeToTcScopeX type exposes the following members.

Methods
Name | Description
ConvertTcScopeToNewBase | Converts the old tcscope to the new base.
ProjectConverter | Converts the project from the old to the new base.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ScopeConverterTcScopeToTcScopeX Methods

The ScopeConverterTcScopeToTcScopeX type exposes the following members.

Methods
Name | Description
ConvertTcScopeToNewBase | Converts the old tcscope to the new base.
ProjectConverter | Converts the project from the old to the new base.
Top
See Also

Reference

ScopeConverterTcScopeToTcScopeX Class
TwinCAT.Measurement.Scope.API Namespace


ScopeConverterTcScopeToTcScopeX.ConvertTcScopeToNewBase Method

Converts the old tcscope to the new base.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static ScopeProject ConvertTcScopeToNewBase(
    string tcScopePath
)
Public Shared Function ConvertTcScopeToNewBase (
    tcScopePath As String
) As ScopeProject
public:
static ScopeProject^ ConvertTcScopeToNewBase(
    String^ tcScopePath
)

Parameters

tcScopePath
Type: SystemString
Path of the tcscope

Return Value

Type: ScopeProject
See Also

Reference

ScopeConverterTcScopeToTcScopeX Class
TwinCAT.Measurement.Scope.API Namespace


ScopeConverterTcScopeToTcScopeX.ProjectConverter Method

Converts the project from the old to the new base.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static ScopeProject ProjectConverter(
    ScopeViewSerializable scopeViewSerializable
)
Public Shared Function ProjectConverter (
    scopeViewSerializable As ScopeViewSerializable
) As ScopeProject
public:
static ScopeProject^ ProjectConverter(
    ScopeViewSerializable^ scopeViewSerializable
)

Parameters

scopeViewSerializable
Type: ScopeViewSerializable

Return Value

Type: ScopeProject
See Also

Reference

ScopeConverterTcScopeToTcScopeX Class
TwinCAT.Measurement.Scope.API Namespace


ScopeDisplayModes Enumeration

The possible displaymodes to update the display in live-mode.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum ScopeDisplayModes
Public Enumeration ScopeDisplayModes
public enum class ScopeDisplayModes
Members
Member name | Value | Description
YT | 0 | Display is updated continious.
XY | 1 | not used
XYZ | 2 | not used
ARRAY | 3 | not used
YTOverwrite | 4 | Display is updated after full display.
Polar | 5 | not used
Digital | 6 | not used
SingleBar | 7 |
Fusion | 8 | Chart to fusion channels.
Network | 1000 | Network
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ScopeLicense Enumeration

Defines different types of licenses for scope

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum ScopeLicense
Public Enumeration ScopeLicense
public enum class ScopeLicense
Members
Member name | Value | Description
None | 0 | No License
Base | 1 | Base License
ProfessionalTrial | 2 | Professional Trial License
Professional | 3 | Professional License
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ScopeViewDetailLevel Enumeration

View Detail Level of the Scope Project

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum ScopeViewDetailLevel
Public Enumeration ScopeViewDetailLevel
public enum class ScopeViewDetailLevel
Members
Member name | Value | Description
Default | 0 | Default Detail Level
ExtendedXYOnly | 2 | Only XY Extended Detail Level
Extended | 65535 | Extended Detail Level
FullAly | 1048575 | Show full aly tree
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ScopeViewState Enumeration

Enum representing the State of the Scope Project

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum ScopeViewState
Public Enumeration ScopeViewState
public enum class ScopeViewState
Members
Member name | Value | Description
Unknown | 0 | Unknown
Invalid | 10 | Invalid
Config | 20 | Config
Config_SVDX | 21 | SVD is Disconnected cause of Server Reset
Connected | 30 | Connected
Running | 40 | Running
Record | 50 | Record
Reply | 60 | Reply
Reply_SVDX | 61 | Reply
Offline | 62 | State of data scout projects
AutoStop | 70 | Auto stopped
RouterStop | 80 | Router stopped
ServerRouterStop | 90 | Server router stopped
ServerTriggerStop | 100 | Stopped by Trigger
OverloadStop | 110 | Stop cause of overload
UnExpectedStop | 120 | Unexpected stop
ServerReset | 130 | Server reset
TriggerOverload | 140 | Stop cause of Trigger Overload
Detached | 150 | Scope is detached from the Server
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


SequenceExportLocations Enumeration

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[FlagsAttribute]
public enum SequenceExportLocations
<FlagsAttribute>
Public Enumeration SequenceExportLocations
[FlagsAttribute]
public enum class SequenceExportLocations
Members
Member name | Value | Description
ProjectPath | 1 |
CustomPath | 2 |
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


SequenceExportOptions Enumeration

Options for saving the data of a sequence.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[FlagsAttribute]
public enum SequenceExportOptions
<FlagsAttribute>
Public Enumeration SequenceExportOptions
[FlagsAttribute]
public enum class SequenceExportOptions
Members
Member name | Value | Description
None | 0 | None
Compressed | 1 | Compress exported file.
HeadTimeStamp | 2 | Only write the timestamp to the header and not in each sample.
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ShapeFillMode Enumeration

The Fillmode of a Shape

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum ShapeFillMode
Public Enumeration ShapeFillMode
public enum class ShapeFillMode
Members
Member name | Value | Description
None | 0 | Shape is not Filled
FromFirst | 1 | Shape is Filled from First Point to last Point
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


ShowErrorLog Enumeration

ShowErrorLogs shows the state of the Messages in the Errorlog

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum ShowErrorLog
Public Enumeration ShowErrorLog
public enum class ShowErrorLog
Members
Member name | Value | Description
ShowAll | 0 | Show all information
ShowNoMessage | 1 | Show no message
ShowOnlyError | 2 | Show only Error
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


StringType Enumeration

Defines the Type of an string

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum StringType
Public Enumeration StringType
public enum class StringType
Members
Member name | Value | Description
None | 0 | No Format Specification
XML | 1 | XML string
JSON | 2 | JSON String
ExistingFilePath | 3 | File at the Path exists
NotExistingFilePath | 4 | File at the Path does not exists
TargetBrowserXML | 5 | XMLString from TargetBrowser
EventViewXML | 6 | XMLString from EventView
ExistingDirectoryPath | 7 | Path to an existing Directory
NotExistingDirectoryPath | 8 | Path to an not existing Directory
MemberBaseXML | 9 | XML Serialized Measurement Member
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


StyleType Enumeration

Define the Style of an ChartLayer

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum StyleType
Public Enumeration StyleType
public enum class StyleType
Members
Member name | Value | Description
Opacity | 0 | Change opacity in the layer
Color | 1 | Set one color for the full layer
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


SymbolArea Enumeration

SymbolArea

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum SymbolArea
Public Enumeration SymbolArea
public enum class SymbolArea
Members
Member name | Value | Description
None | 0 | None
Retain | 1 | Retain
Local | 2 | Local
Input | 3 | Input
Memory | 4 | Memory
Output | 5 | Output
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


SymbolInfo Class

SymbolInfo class parsing TB XML-String
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APISymbolInfo

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class SymbolInfo
Public Class SymbolInfo
public ref class SymbolInfo

The SymbolInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SymbolInfo(XElement, TargetDefinitionCollection, TypeInfoCollection) | Create a new SymbolInfo from XML
Public method | SymbolInfo(String, TypeInfo, TargetDefinition_InputSource, TypeInfoCollection) | Create a new SymbolInfo
Public method | SymbolInfo(String, TypeInfo, TargetDefinition_InputSource, TypeInfoCollection, Int32, Int64) | Create a new SymbolInfo
Top
Properties
 | Name | Description
Public property | Context | Get the Context.
Public property | CycleTime | Gets the Cycle Time.
Public property | Name | Get the Name
Public property | SubSymbols | Get the SubSymbols of the Symbol
Public property | TargetDefinition | Get the TargetDefinition
Public property | TypeInfo | Get the TypeInfo
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShortName |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


SymbolInfo Constructor

Overload List
 | Name | Description
Public method | SymbolInfo(XElement, TargetDefinitionCollection, TypeInfoCollection) | Create a new SymbolInfo from XML
Public method | SymbolInfo(String, TypeInfo, TargetDefinition_InputSource, TypeInfoCollection) | Create a new SymbolInfo
Public method | SymbolInfo(String, TypeInfo, TargetDefinition_InputSource, TypeInfoCollection, Int32, Int64) | Create a new SymbolInfo
Top
See Also

Reference

SymbolInfo Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfo Constructor (XElement, TargetDefinitionCollection, TypeInfoCollection)

Create a new SymbolInfo from XML

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SymbolInfo(
    XElement symbol,
    TargetDefinitionCollection targets,
    TypeInfoCollection types
)
Public Sub New (
    symbol As XElement,
    targets As TargetDefinitionCollection,
    types As TypeInfoCollection
)
public:
SymbolInfo(
    XElement^ symbol,
    TargetDefinitionCollection^ targets,
    TypeInfoCollection^ types
)

Parameters

symbol
Type: System.Xml.LinqXElement
targets
Type: TargetDefinitionCollection
Parsed TargetInfos
types
Type: TwinCAT.Measurement.Scope.APITypeInfoCollection
Parsed TypeInfos
See Also

Reference

SymbolInfo Class
SymbolInfo Overload
TwinCAT.Measurement.Scope.API Namespace


SymbolInfo Constructor (String, TypeInfo, TargetDefinition_InputSource, TypeInfoCollection)

Create a new SymbolInfo

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SymbolInfo(
    string Name,
    TypeInfo TypeInfo,
    TargetDefinition_InputSource TargetDefinition,
    TypeInfoCollection types
)
Public Sub New (
    Name As String,
    TypeInfo As TypeInfo,
    TargetDefinition As TargetDefinition_InputSource,
    types As TypeInfoCollection
)
public:
SymbolInfo(
    String^ Name,
    TypeInfo^ TypeInfo,
    TargetDefinition_InputSource^ TargetDefinition,
    TypeInfoCollection^ types
)

Parameters

Name
Type: SystemString
TypeInfo
Type: TwinCAT.Measurement.Scope.APITypeInfo
TargetDefinition
Type: TargetDefinition_InputSource
types
Type: TwinCAT.Measurement.Scope.APITypeInfoCollection
See Also

Reference

SymbolInfo Class
SymbolInfo Overload
TwinCAT.Measurement.Scope.API Namespace


SymbolInfo Constructor (String, TypeInfo, TargetDefinition_InputSource, TypeInfoCollection, Int32, Int64)

Create a new SymbolInfo

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SymbolInfo(
    string Name,
    TypeInfo TypeInfo,
    TargetDefinition_InputSource TargetDefinition,
    TypeInfoCollection types,
    int context,
    long cycleTime
)
Public Sub New (
    Name As String,
    TypeInfo As TypeInfo,
    TargetDefinition As TargetDefinition_InputSource,
    types As TypeInfoCollection,
    context As Integer,
    cycleTime As Long
)
public:
SymbolInfo(
    String^ Name,
    TypeInfo^ TypeInfo,
    TargetDefinition_InputSource^ TargetDefinition,
    TypeInfoCollection^ types,
    int context,
    long long cycleTime
)

Parameters

Name
Type: SystemString
TypeInfo
Type: TwinCAT.Measurement.Scope.APITypeInfo
TargetDefinition
Type: TargetDefinition_InputSource
types
Type: TwinCAT.Measurement.Scope.APITypeInfoCollection
context
Type: SystemInt32
cycleTime
Type: SystemInt64
See Also

Reference

SymbolInfo Class
SymbolInfo Overload
TwinCAT.Measurement.Scope.API Namespace


SymbolInfo Properties

The SymbolInfo type exposes the following members.

Properties
 | Name | Description
Public property | Context | Get the Context.
Public property | CycleTime | Gets the Cycle Time.
Public property | Name | Get the Name
Public property | SubSymbols | Get the SubSymbols of the Symbol
Public property | TargetDefinition | Get the TargetDefinition
Public property | TypeInfo | Get the TypeInfo
Top
See Also

Reference

SymbolInfo Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfo.Context Property

Get the Context.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int Context { get; }
Public ReadOnly Property Context As Integer
    Get
public:
property int Context {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

SymbolInfo Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfo.CycleTime Property

Gets the Cycle Time.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long CycleTime { get; }
Public ReadOnly Property CycleTime As Long
    Get
public:
property long long CycleTime {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

SymbolInfo Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfo.Name Property

Get the Name

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

SymbolInfo Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfo.SubSymbols Property

Get the SubSymbols of the Symbol

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SymbolInfoCollection SubSymbols { get; }
Public ReadOnly Property SubSymbols As SymbolInfoCollection
    Get
public:
property SymbolInfoCollection^ SubSymbols {
    SymbolInfoCollection^ get ();
}

Property Value

Type: SymbolInfoCollection
See Also

Reference

SymbolInfo Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfo.TargetDefinition Property

Get the TargetDefinition

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TargetDefinition_InputSource TargetDefinition { get; }
Public ReadOnly Property TargetDefinition As TargetDefinition_InputSource
    Get
public:
property TargetDefinition_InputSource^ TargetDefinition {
    TargetDefinition_InputSource^ get ();
}

Property Value

Type: TargetDefinition_InputSource
See Also

Reference

SymbolInfo Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfo.TypeInfo Property

Get the TypeInfo

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TypeInfo TypeInfo { get; }
Public ReadOnly Property TypeInfo As TypeInfo
    Get
public:
property TypeInfo^ TypeInfo {
    TypeInfo^ get ();
}

Property Value

Type: TypeInfo
See Also

Reference

SymbolInfo Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfo Methods

The SymbolInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ShortName |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SymbolInfo Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfo.ShortName Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string ShortName()
Public Function ShortName As String
public:
String^ ShortName()

Return Value

Type: String
See Also

Reference

SymbolInfo Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfoCollection Class

SymbolInfo Collection to Parse TB-XML-String
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APISymbolInfoCollection

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class SymbolInfoCollection : IEnumerable<SymbolInfo>,
    IEnumerable
Public Class SymbolInfoCollection
    Implements IEnumerable(Of SymbolInfo), IEnumerable
public ref class SymbolInfoCollection : IEnumerable<SymbolInfo^>,
    IEnumerable

The SymbolInfoCollection type exposes the following members.

Constructors
 | Name | Description
Public method | SymbolInfoCollection(ListSymbolInfo) | Create a new SymbolInfoCollection
Public method | SymbolInfoCollection(XElement, TargetDefinitionCollection, TypeInfoCollection) | Create a new SymbolInfo Collection
Top
Properties
 | Name | Description
Public property | Count | Get the Count
Public property | Item | Get the Symbol with the Specific Index
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMatchingSymbolEnd | Find a specific Symbol wich Name end with Ending
Public method | FirstOrDefault | Find the First Matching SymbolInfo
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


SymbolInfoCollection Constructor

Overload List
 | Name | Description
Public method | SymbolInfoCollection(ListSymbolInfo) | Create a new SymbolInfoCollection
Public method | SymbolInfoCollection(XElement, TargetDefinitionCollection, TypeInfoCollection) | Create a new SymbolInfo Collection
Top
See Also

Reference

SymbolInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfoCollection Constructor (List(SymbolInfo))

Create a new SymbolInfoCollection

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SymbolInfoCollection(
    List<SymbolInfo> SymbolInfos
)
Public Sub New (
    SymbolInfos As List(Of SymbolInfo)
)
public:
SymbolInfoCollection(
    List<SymbolInfo^>^ SymbolInfos
)

Parameters

SymbolInfos
Type: System.Collections.GenericList SymbolInfo
See Also

Reference

SymbolInfoCollection Class
SymbolInfoCollection Overload
TwinCAT.Measurement.Scope.API Namespace


SymbolInfoCollection Constructor (XElement, TargetDefinitionCollection, TypeInfoCollection)

Create a new SymbolInfo Collection

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SymbolInfoCollection(
    XElement symbols,
    TargetDefinitionCollection targets,
    TypeInfoCollection types
)
Public Sub New (
    symbols As XElement,
    targets As TargetDefinitionCollection,
    types As TypeInfoCollection
)
public:
SymbolInfoCollection(
    XElement^ symbols,
    TargetDefinitionCollection^ targets,
    TypeInfoCollection^ types
)

Parameters

symbols
Type: System.Xml.LinqXElement
XML Symbols Element
targets
Type: TargetDefinitionCollection
Parsed TargetInfos
types
Type: TwinCAT.Measurement.Scope.APITypeInfoCollection
Parsed TypeInfos
See Also

Reference

SymbolInfoCollection Class
SymbolInfoCollection Overload
TwinCAT.Measurement.Scope.API Namespace


SymbolInfoCollection Properties

The SymbolInfoCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Get the Count
Public property | Item | Get the Symbol with the Specific Index
Top
See Also

Reference

SymbolInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfoCollection.Count Property

Get the Count

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

SymbolInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfoCollection.Item Property

Get the Symbol with the Specific Index

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SymbolInfo this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As SymbolInfo
    Get
public:
property SymbolInfo^ default[int index] {
    SymbolInfo^ get (int index);
}

Parameters

index
Type: SystemInt32

Return Value

Type: SymbolInfo
See Also

Reference

SymbolInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfoCollection Methods

The SymbolInfoCollection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindMatchingSymbolEnd | Find a specific Symbol wich Name end with Ending
Public method | FirstOrDefault | Find the First Matching SymbolInfo
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SymbolInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfoCollection.FindMatchingSymbolEnd Method

Find a specific Symbol wich Name end with Ending

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SymbolInfo FindMatchingSymbolEnd(
    string Ending,
    bool Recursive = true,
    Func<SymbolInfo, bool> AdditionalCondition = null
)
Public Function FindMatchingSymbolEnd (
    Ending As String,
    Optional Recursive As Boolean = true,
    Optional AdditionalCondition As Func(Of SymbolInfo, Boolean) = Nothing
) As SymbolInfo
public:
SymbolInfo^ FindMatchingSymbolEnd(
    String^ Ending,
    bool Recursive = true,
    Func<SymbolInfo^, bool>^ AdditionalCondition = nullptr
)

Parameters

Ending
Type: SystemString
The Ending to Check for
Recursive (Optional)
Type: SystemBoolean
Determine wether to search Recursive
AdditionalCondition (Optional)
Type: SystemFunc SymbolInfo, Boolean
An additional Condition used while matching

Return Value

Type: SymbolInfo
The First found Element
See Also

Reference

SymbolInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfoCollection.FirstOrDefault Method

Find the First Matching SymbolInfo

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SymbolInfo FirstOrDefault(
    Func<SymbolInfo, bool> Func = null,
    bool Recursive = false
)
Public Function FirstOrDefault (
    Optional Func As Func(Of SymbolInfo, Boolean) = Nothing,
    Optional Recursive As Boolean = false
) As SymbolInfo
public:
SymbolInfo^ FirstOrDefault(
    Func<SymbolInfo^, bool>^ Func = nullptr,
    bool Recursive = false
)

Parameters

Func (Optional)
Type: SystemFunc SymbolInfo, Boolean
MatchFunction
Recursive (Optional)
Type: SystemBoolean
Determine wether to search in all SubSymbols

Return Value

Type: SymbolInfo
The First Matching Symbol
See Also

Reference

SymbolInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


SymbolInfoCollection.GetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerator<SymbolInfo> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of SymbolInfo)
public:
virtual IEnumerator<SymbolInfo^>^ GetEnumerator() sealed

Return Value

Type: IEnumerator SymbolInfo
A System.Collections.Generic.IEnumerator`1 that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

SymbolInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


TimeRefreshMode Enumeration

define the time refresh mode for chart layer

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum TimeRefreshMode
Public Enumeration TimeRefreshMode
public enum class TimeRefreshMode
Members
Member name | Value | Description
Explicit | 0 | Set explicit timestamp
RelatedMember | 1 | Get time from related member
ParentTimeOffset | 2 | get parent time with an offset
Duration | 3 | Duration Time Mode
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


TimesEnabled Enumeration

Flag enum to hold visible Time-labels.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[FlagsAttribute]
public enum TimesEnabled
<FlagsAttribute>
Public Enumeration TimesEnabled
[FlagsAttribute]
public enum class TimesEnabled
Members
Member name | Value | Description
None | 0 | Noting visible
All | 511 | All visible
StartTimeLabel | 1 | StartTime Label visible
Splitter1 | 2 | Splitter 1 visible
EndTimeLabel | 4 | End time Label Visible
Splitter2 | 8 | Splitter 2 visible
PositionLabel | 16 | Position Label visible
Splitter3 | 32 | Splitter 3 visible
AbsTimeLabel | 64 | Absolute time Label visible
Splitter4 | 128 | Splitter 4 visible
DateLabel | 256 | Date Label Visible
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


TimeSynchronisationModes Enumeration

Defines the Mode of Timesynchronisation

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum TimeSynchronisationModes
Public Enumeration TimeSynchronisationModes
public enum class TimeSynchronisationModes
Members
Member name | Value | Description
Default | -1 | Use default Synchronistion Mode
Hard | 1 | Hardwaresynchronisation
Medium | 2 | IEEE1588
Soft | 3 | NTP Synchronistion
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


TriggerCombineOptions Enumeration

Defines possible Trigger combinations

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum TriggerCombineOptions
Public Enumeration TriggerCombineOptions
public enum class TriggerCombineOptions
Members
Member name | Value | Description
AND | 0 | A logical and
OR | 1 | a logical or
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


TriggerExportTimeModes Enumeration

Modes of TriggerExport Times

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum TriggerExportTimeModes
Public Enumeration TriggerExportTimeModes
public enum class TriggerExportTimeModes
Members
Member name | Value | Description
LastData | 0 | Use latest data
SinceLastTrigger | 1 | Data between last Triggerevent and current
TimeRange | 2 | Export TimeRange Data
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


TriggerGroupContentChangedEventArgs Class

Classed used to fire TriggerGroupContentChangedEvents
Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.APITriggerGroupContentChangedEventArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TriggerGroupContentChangedEventArgs : EventArgs
Public Class TriggerGroupContentChangedEventArgs
    Inherits EventArgs
public ref class TriggerGroupContentChangedEventArgs : public EventArgs

The TriggerGroupContentChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerGroupContentChangedEventArgs | Create a new TriggerGroupContentChangedEventArg
Top
Properties
 | Name | Description
Public property | Added | Get the added TriggerGroup
Public property | Removed | Get the removed TriggerGroup
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


TriggerGroupContentChangedEventArgs Constructor

Create a new TriggerGroupContentChangedEventArg

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerGroupContentChangedEventArgs(
    TriggerGroup add,
    TriggerGroup rem
)
Public Sub New (
    add As TriggerGroup,
    rem As TriggerGroup
)
public:
TriggerGroupContentChangedEventArgs(
    TriggerGroup^ add,
    TriggerGroup^ rem
)

Parameters

add
Type: TwinCAT.Measurement.Scope.API.ModelTriggerGroup
TriggerGroup added to TriggerModule
rem
Type: TwinCAT.Measurement.Scope.API.ModelTriggerGroup
TriggerGroup removed from TriggerModule
See Also

Reference

TriggerGroupContentChangedEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


TriggerGroupContentChangedEventArgs Properties

The TriggerGroupContentChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Added | Get the added TriggerGroup
Public property | Removed | Get the removed TriggerGroup
Top
See Also

Reference

TriggerGroupContentChangedEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


TriggerGroupContentChangedEventArgs.Added Property

Get the added TriggerGroup

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerGroup Added { get; }
Public ReadOnly Property Added As TriggerGroup
    Get
public:
property TriggerGroup^ Added {
    TriggerGroup^ get ();
}

Property Value

Type: TriggerGroup
See Also

Reference

TriggerGroupContentChangedEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


TriggerGroupContentChangedEventArgs.Removed Property

Get the removed TriggerGroup

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerGroup Removed { get; }
Public ReadOnly Property Removed As TriggerGroup
    Get
public:
property TriggerGroup^ Removed {
    TriggerGroup^ get ();
}

Property Value

Type: TriggerGroup
See Also

Reference

TriggerGroupContentChangedEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


TriggerGroupContentChangedEventArgs Methods

The TriggerGroupContentChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerGroupContentChangedEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM Class

Holds the data for a row in the trigger window.
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APITriggerWindowControlRowM

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TriggerWindowControlRowM : INotifyPropertyChanged
Public Class TriggerWindowControlRowM
    Implements INotifyPropertyChanged
public ref class TriggerWindowControlRowM : INotifyPropertyChanged

The TriggerWindowControlRowM type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerWindowControlRowM | Creates a new instance of the TriggerWindowControlRowM class.
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment
Public property | ReleaseCount | Gets or Sets the ReleaseCount
Public property | ReleaseInfo | Gets or Sets the ReleaseInfo.
Public property | ReleaseTime | Gets or Sets the ReleaseTime
Public property | TriggerGroup | Gets or Sets the TriggerGroup.
Public property | TriggerGroupName | Gets or Sets the TriggerGoupName
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | BeforeReleaseInfoChanged | Fired before the ReleaseInfo is changed.
Public event | BeforeTriggerGroupChanged | Fired before the TriggerGroup is changed.
Public event | PropertyChanged | Called when a Property is changed.
Public event | ReleaseInfoChanged | Fired when the ReleaseInfo is changed.
Public event | TriggerGroupChanged | Fired when the TriggerGroup is changed.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM Constructor

Creates a new instance of the TriggerWindowControlRowM class.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerWindowControlRowM(
    TriggerReleaseInfo info,
    TriggerGroup parent
)
Public Sub New (
    info As TriggerReleaseInfo,
    parent As TriggerGroup
)
public:
TriggerWindowControlRowM(
    TriggerReleaseInfo^ info,
    TriggerGroup^ parent
)

Parameters

info
Type: TwinCAT.Measurement.Scope.API.ModelTriggerReleaseInfo
parent
Type: TwinCAT.Measurement.Scope.API.ModelTriggerGroup
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM Properties

The TriggerWindowControlRowM type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment
Public property | ReleaseCount | Gets or Sets the ReleaseCount
Public property | ReleaseInfo | Gets or Sets the ReleaseInfo.
Public property | ReleaseTime | Gets or Sets the ReleaseTime
Public property | TriggerGroup | Gets or Sets the TriggerGroup.
Public property | TriggerGroupName | Gets or Sets the TriggerGoupName
Top
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM.Comment Property

Gets or Sets the Comment

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM.ReleaseCount Property

Gets or Sets the ReleaseCount

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int ReleaseCount { get; set; }
Public Property ReleaseCount As Integer
    Get
    Set
public:
property int ReleaseCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM.ReleaseInfo Property

Gets or Sets the ReleaseInfo.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerReleaseInfo ReleaseInfo { get; set; }
Public Property ReleaseInfo As TriggerReleaseInfo
    Get
    Set
public:
property TriggerReleaseInfo^ ReleaseInfo {
    TriggerReleaseInfo^ get ();
    void set (TriggerReleaseInfo^ value);
}

Property Value

Type: TriggerReleaseInfo
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM.ReleaseTime Property

Gets or Sets the ReleaseTime

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string ReleaseTime { get; set; }
Public Property ReleaseTime As String
    Get
    Set
public:
property String^ ReleaseTime {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM.TriggerGroup Property

Gets or Sets the TriggerGroup.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerGroup TriggerGroup { get; set; }
Public Property TriggerGroup As TriggerGroup
    Get
    Set
public:
property TriggerGroup^ TriggerGroup {
    TriggerGroup^ get ();
    void set (TriggerGroup^ value);
}

Property Value

Type: TriggerGroup
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM.TriggerGroupName Property

Gets or Sets the TriggerGoupName

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string TriggerGroupName { get; set; }
Public Property TriggerGroupName As String
    Get
    Set
public:
property String^ TriggerGroupName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM Methods

The TriggerWindowControlRowM type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM Events

The TriggerWindowControlRowM type exposes the following members.

Events
 | Name | Description
Public event | BeforeReleaseInfoChanged | Fired before the ReleaseInfo is changed.
Public event | BeforeTriggerGroupChanged | Fired before the TriggerGroup is changed.
Public event | PropertyChanged | Called when a Property is changed.
Public event | ReleaseInfoChanged | Fired when the ReleaseInfo is changed.
Public event | TriggerGroupChanged | Fired when the TriggerGroup is changed.
Top
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM.BeforeReleaseInfoChanged Event

Fired before the ReleaseInfo is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeReleaseInfoChanged
Public Event BeforeReleaseInfoChanged As EventHandler
public:
 event EventHandler^ BeforeReleaseInfoChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM.BeforeTriggerGroupChanged Event

Fired before the TriggerGroup is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeTriggerGroupChanged
Public Event BeforeTriggerGroupChanged As EventHandler
public:
 event EventHandler^ BeforeTriggerGroupChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM.PropertyChanged Event

Called when a Property is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM.ReleaseInfoChanged Event

Fired when the ReleaseInfo is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReleaseInfoChanged
Public Event ReleaseInfoChanged As EventHandler
public:
 event EventHandler^ ReleaseInfoChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TriggerWindowControlRowM.TriggerGroupChanged Event

Fired when the TriggerGroup is changed.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TriggerGroupChanged
Public Event TriggerGroupChanged As EventHandler
public:
 event EventHandler^ TriggerGroupChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerWindowControlRowM Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo Class

TypeInfo for deserializing from TargetBrowser-XML
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APITypeInfo

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TypeInfo
Public Class TypeInfo
public ref class TypeInfo

The TypeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | TypeInfo(XElement) | Create a new TypeInfo from XML-Element
Public method | TypeInfo(String, DataTypeCategory, Int32, UnitConfiguration) | Create a new TypeInfo
Top
Properties
 | Name | Description
Public property | ArrayIndicees | Obsolete. Get the ArrayIndicees of the first Dimension
Public property | ArrayInfos |
Public property | ArrayLength | Gets or Sets the ArrayLength.
Public property | ArrayStartIndex | Get the Starting index of the Array
Public property | BaseType | Gets or Sets the BaseType.
Public property | BitSize | Gets or Sets the BitSize.
Public property | Category | Gets or Sets the Category.
Public property | MultiDimensionalArrayIndicees | Get Array Indicees of all Dimensions
Public property | Name | Get the Name
Public property | PropertyInformation |
Public property | ScopeType |
Public property | StringLength | Gets the Length of String or WString Types.
Public property | SubTypes | Gets or Sets the SubTypes.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


TypeInfo Constructor

Overload List
 | Name | Description
Public method | TypeInfo(XElement) | Create a new TypeInfo from XML-Element
Public method | TypeInfo(String, DataTypeCategory, Int32, UnitConfiguration) | Create a new TypeInfo
Top
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo Constructor (XElement)

Create a new TypeInfo from XML-Element

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TypeInfo(
    XElement element
)
Public Sub New (
    element As XElement
)
public:
TypeInfo(
    XElement^ element
)

Parameters

element
Type: System.Xml.LinqXElement
See Also

Reference

TypeInfo Class
TypeInfo Overload
TwinCAT.Measurement.Scope.API Namespace


TypeInfo Constructor (String, DataTypeCategory, Int32, UnitConfiguration)

Create a new TypeInfo

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TypeInfo(
    string name,
    DataTypeCategory symbol = DataTypeCategory.Primitive,
    int arrayLength = 0,
    UnitConfiguration config = null
)
Public Sub New (
    name As String,
    Optional symbol As DataTypeCategory = DataTypeCategory.Primitive,
    Optional arrayLength As Integer = 0,
    Optional config As UnitConfiguration = Nothing
)
public:
TypeInfo(
    String^ name,
    DataTypeCategory symbol = DataTypeCategory::Primitive,
    int arrayLength = 0,
    UnitConfiguration^ config = nullptr
)

Parameters

name
Type: SystemString
symbol (Optional)
Type: DataTypeCategory
arrayLength (Optional)
Type: SystemInt32
config (Optional)
Type: UnitConfiguration
See Also

Reference

TypeInfo Class
TypeInfo Overload
TwinCAT.Measurement.Scope.API Namespace


TypeInfo Properties

The TypeInfo type exposes the following members.

Properties
 | Name | Description
Public property | ArrayIndicees | Obsolete. Get the ArrayIndicees of the first Dimension
Public property | ArrayInfos |
Public property | ArrayLength | Gets or Sets the ArrayLength.
Public property | ArrayStartIndex | Get the Starting index of the Array
Public property | BaseType | Gets or Sets the BaseType.
Public property | BitSize | Gets or Sets the BitSize.
Public property | Category | Gets or Sets the Category.
Public property | MultiDimensionalArrayIndicees | Get Array Indicees of all Dimensions
Public property | Name | Get the Name
Public property | PropertyInformation |
Public property | ScopeType |
Public property | StringLength | Gets the Length of String or WString Types.
Public property | SubTypes | Gets or Sets the SubTypes.
Top
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo.ArrayIndicees Property

Note: This API is now obsolete.

Get the ArrayIndicees of the first Dimension

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Use MultiDimensionalArrayIndicees instead to support Array with more then 1 Dimension")]
public IEnumerable<int> ArrayIndicees { get; }
<ObsoleteAttribute("Use MultiDimensionalArrayIndicees instead to support Array with more then 1 Dimension")>
Public ReadOnly Property ArrayIndicees As IEnumerable(Of Integer)
    Get
public:
[ObsoleteAttribute(L"Use MultiDimensionalArrayIndicees instead to support Array with more then 1 Dimension")]
property IEnumerable<int>^ ArrayIndicees {
    IEnumerable<int>^ get ();
}

Property Value

Type: IEnumerable Int32
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo.ArrayInfos Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReadOnlyCollection<ArrayInfo> ArrayInfos { get; }
Public ReadOnly Property ArrayInfos As ReadOnlyCollection(Of ArrayInfo)
    Get
public:
property ReadOnlyCollection<ArrayInfo^>^ ArrayInfos {
    ReadOnlyCollection<ArrayInfo^>^ get ();
}

Property Value

Type: ReadOnlyCollection ArrayInfo
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo.ArrayLength Property

Gets or Sets the ArrayLength.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int ArrayLength { get; }
Public ReadOnly Property ArrayLength As Integer
    Get
public:
property int ArrayLength {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo.ArrayStartIndex Property

Get the Starting index of the Array

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int ArrayStartIndex { get; }
Public ReadOnly Property ArrayStartIndex As Integer
    Get
public:
property int ArrayStartIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo.BaseType Property

Gets or Sets the BaseType.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string BaseType { get; }
Public ReadOnly Property BaseType As String
    Get
public:
property String^ BaseType {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo.BitSize Property

Gets or Sets the BitSize.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public uint BitSize { get; }
Public ReadOnly Property BitSize As UInteger
    Get
public:
property unsigned int BitSize {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo.Category Property

Gets or Sets the Category.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DataTypeCategory Category { get; }
Public ReadOnly Property Category As DataTypeCategory
    Get
public:
property DataTypeCategory Category {
    DataTypeCategory get ();
}

Property Value

Type: DataTypeCategory
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo.MultiDimensionalArrayIndicees Property

Get Array Indicees of all Dimensions

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<string> MultiDimensionalArrayIndicees { get; }
Public ReadOnly Property MultiDimensionalArrayIndicees As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ MultiDimensionalArrayIndicees {
    IEnumerable<String^>^ get ();
}

Property Value

Type: IEnumerable String
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo.Name Property

Get the Name

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo.PropertyInformation Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public List<TypePropertyInfo> PropertyInformation { get; }
Public ReadOnly Property PropertyInformation As List(Of TypePropertyInfo)
    Get
public:
property List<TypePropertyInfo^>^ PropertyInformation {
    List<TypePropertyInfo^>^ get ();
}

Property Value

Type: List TypePropertyInfo
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo.ScopeType Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Scope2DataType ScopeType { get; }
Public ReadOnly Property ScopeType As Scope2DataType
    Get
public:
property Scope2DataType ScopeType {
    Scope2DataType get ();
}

Property Value

Type: Scope2DataType
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo.StringLength Property

Gets the Length of String or WString Types.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public uint StringLength { get; }
Public ReadOnly Property StringLength As UInteger
    Get
public:
property unsigned int StringLength {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo.SubTypes Property

Gets or Sets the SubTypes.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public List<SubType> SubTypes { get; }
Public ReadOnly Property SubTypes As List(Of SubType)
    Get
public:
property List<SubType>^ SubTypes {
    List<SubType>^ get ();
}

Property Value

Type: List SubType
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfo Methods

The TypeInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TypeInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfoCollection Class

TypeInfoCollection for deserializing DataTypes from TB-XML
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APITypeInfoCollection

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TypeInfoCollection : IEnumerable<TypeInfo>,
    IEnumerable
Public Class TypeInfoCollection
    Implements IEnumerable(Of TypeInfo), IEnumerable
public ref class TypeInfoCollection : IEnumerable<TypeInfo^>,
    IEnumerable

The TypeInfoCollection type exposes the following members.

Constructors
 | Name | Description
Public method | TypeInfoCollection | Create a new TypeInfoCollection
Top
Properties
 | Name | Description
Public property | Count | Get the Count
 | Empty | Create a new Empty TypeInfoCollection
Public property | Item | Get a TypeInfo by Name
Public property | Names | Get the Names
Top
Methods
 | Name | Description
Public method | ContainsKey | Determine wether the Key is contained in dictionary
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseType |
Public method | GetEnumerator | Get the Enumerator to use Dictionary in foreach
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Try to get a specific value
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


TypeInfoCollection Constructor

Create a new TypeInfoCollection

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TypeInfoCollection(
    XElement TypesElement
)
Public Sub New (
    TypesElement As XElement
)
public:
TypeInfoCollection(
    XElement^ TypesElement
)

Parameters

TypesElement
Type: System.Xml.LinqXElement
See Also

Reference

TypeInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfoCollection Properties

The TypeInfoCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Get the Count
 | Empty | Create a new Empty TypeInfoCollection
Public property | Item | Get a TypeInfo by Name
Public property | Names | Get the Names
Top
See Also

Reference

TypeInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfoCollection.Count Property

Get the Count

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

TypeInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfoCollection.Empty Property

Create a new Empty TypeInfoCollection

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static TypeInfoCollection Empty { get; }
Public Shared ReadOnly Property Empty As TypeInfoCollection
    Get
public:
static property TypeInfoCollection^ Empty {
    TypeInfoCollection^ get ();
}

Property Value

Type: TypeInfoCollection
See Also

Reference

TypeInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfoCollection.Item Property

Get a TypeInfo by Name

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TypeInfo this[
    string key
] { get; }
Public ReadOnly Default Property Item (
    key As String
) As TypeInfo
    Get
public:
property TypeInfo^ default[String^ key] {
    TypeInfo^ get (String^ key);
}

Parameters

key
Type: SystemString

Return Value

Type: TypeInfo
See Also

Reference

TypeInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfoCollection.Names Property

Get the Names

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<string> Names { get; }
Public ReadOnly Property Names As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ Names {
    IEnumerable<String^>^ get ();
}

Property Value

Type: IEnumerable String
See Also

Reference

TypeInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfoCollection Methods

The TypeInfoCollection type exposes the following members.

Methods
 | Name | Description
Public method | ContainsKey | Determine wether the Key is contained in dictionary
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseType |
Public method | GetEnumerator | Get the Enumerator to use Dictionary in foreach
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Try to get a specific value
Top
See Also

Reference

TypeInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfoCollection.ContainsKey Method

Determine wether the Key is contained in dictionary

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool ContainsKey(
    string key
)
Public Function ContainsKey (
    key As String
) As Boolean
public:
bool ContainsKey(
    String^ key
)

Parameters

key
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

TypeInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfoCollection.GetBaseType Method

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TypeInfo GetBaseType(
    string type,
    bool recursive = true
)
Public Function GetBaseType (
    type As String,
    Optional recursive As Boolean = true
) As TypeInfo
public:
TypeInfo^ GetBaseType(
    String^ type,
    bool recursive = true
)

Parameters

type
Type: SystemString
recursive (Optional)
Type: SystemBoolean

Return Value

Type: TypeInfo
See Also

Reference

TypeInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfoCollection.GetEnumerator Method

Get the Enumerator to use Dictionary in foreach

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerator<TypeInfo> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of TypeInfo)
public:
virtual IEnumerator<TypeInfo^>^ GetEnumerator() sealed

Return Value

Type: IEnumerator TypeInfo

Implements

IEnumerableTGetEnumerator
See Also

Reference

TypeInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


TypeInfoCollection.TryGetValue Method

Try to get a specific value

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool TryGetValue(
    string key,
    out TypeInfo value
)
Public Function TryGetValue (
    key As String,
    <OutAttribute> ByRef value As TypeInfo
) As Boolean
public:
bool TryGetValue(
    String^ key,
    [OutAttribute] TypeInfo^% value
)

Parameters

key
Type: SystemString
The key to search for
value
Type: TwinCAT.Measurement.Scope.APITypeInfo
The found value

Return Value

Type: Boolean
True if the Key is contained in Dictionary
See Also

Reference

TypeInfoCollection Class
TwinCAT.Measurement.Scope.API Namespace


TypePropertyInfo Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.APITypePropertyInfo

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TypePropertyInfo
Public Class TypePropertyInfo
public ref class TypePropertyInfo

The TypePropertyInfo type exposes the following members.

Constructors
 | Name | Description
Public method | TypePropertyInfo | Initializes a new instance of the TypePropertyInfo class
Top
Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


TypePropertyInfo Constructor

Initializes a new instance of the TypePropertyInfo class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TypePropertyInfo(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
public:
TypePropertyInfo(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
value
Type: SystemString
See Also

Reference

TypePropertyInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypePropertyInfo Properties

The TypePropertyInfo type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
See Also

Reference

TypePropertyInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypePropertyInfo.Name Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TypePropertyInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypePropertyInfo.Value Property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TypePropertyInfo Class
TwinCAT.Measurement.Scope.API Namespace


TypePropertyInfo Methods

The TypePropertyInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TypePropertyInfo Class
TwinCAT.Measurement.Scope.API Namespace


UnkownProductVersionException Class

Exception thrown in case of an invalid Product Version.
Inheritance Hierarchy
SystemObject
SystemException
TwinCAT.Measurement.Scope.APIUnkownProductVersionException

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class UnkownProductVersionException : Exception
Public Class UnkownProductVersionException
    Inherits Exception
public ref class UnkownProductVersionException : public Exception

The UnkownProductVersionException type exposes the following members.

Constructors
 | Name | Description
Public method | UnkownProductVersionException | Initializes a new instance of the UnkownProductVersionException class.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


UnkownProductVersionException Constructor

Initializes a new instance of the UnkownProductVersionException class.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public UnkownProductVersionException()
Public Sub New
public:
UnkownProductVersionException()
See Also

Reference

UnkownProductVersionException Class
TwinCAT.Measurement.Scope.API Namespace


UnkownProductVersionException Properties

The UnkownProductVersionException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

UnkownProductVersionException Class
TwinCAT.Measurement.Scope.API Namespace


UnkownProductVersionException Methods

The UnkownProductVersionException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

UnkownProductVersionException Class
TwinCAT.Measurement.Scope.API Namespace


UpdateDataSequenceEventArgs Class

AddDataEventArgs for Sequences.
Inheritance Hierarchy
SystemObject
SystemEventArgs
AddDataEventArgs
TwinCAT.Measurement.Scope.APIUpdateDataSequenceEventArgs

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class UpdateDataSequenceEventArgs : AddDataEventArgs
Public Class UpdateDataSequenceEventArgs
    Inherits AddDataEventArgs
public ref class UpdateDataSequenceEventArgs : public AddDataEventArgs

The UpdateDataSequenceEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateDataSequenceEventArgs(DataModifyOptions) | Creates a new instance of the UpdateDataSequenceEventArgs.
Public method | UpdateDataSequenceEventArgs(DataModifyOptions, Int32) | Creates a new instance of the UpdateDataSequenceEventArgs with option and index.
Top
Properties
 | Name | Description
Public property | Index | Gets the Index.
Public property | ModifyOption | Gets the ModifyOption.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


UpdateDataSequenceEventArgs Constructor

Overload List
 | Name | Description
Public method | UpdateDataSequenceEventArgs(DataModifyOptions) | Creates a new instance of the UpdateDataSequenceEventArgs.
Public method | UpdateDataSequenceEventArgs(DataModifyOptions, Int32) | Creates a new instance of the UpdateDataSequenceEventArgs with option and index.
Top
See Also

Reference

UpdateDataSequenceEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


UpdateDataSequenceEventArgs Constructor (DataModifyOptions)

Creates a new instance of the UpdateDataSequenceEventArgs.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public UpdateDataSequenceEventArgs(
    DataModifyOptions option
)
Public Sub New (
    option As DataModifyOptions
)
public:
UpdateDataSequenceEventArgs(
    DataModifyOptions option
)

Parameters

option
Type: TwinCAT.Measurement.Scope.APIDataModifyOptions
The action that is performed.
See Also

Reference

UpdateDataSequenceEventArgs Class
UpdateDataSequenceEventArgs Overload
TwinCAT.Measurement.Scope.API Namespace


UpdateDataSequenceEventArgs Constructor (DataModifyOptions, Int32)

Creates a new instance of the UpdateDataSequenceEventArgs with option and index.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public UpdateDataSequenceEventArgs(
    DataModifyOptions option,
    int index
)
Public Sub New (
    option As DataModifyOptions,
    index As Integer
)
public:
UpdateDataSequenceEventArgs(
    DataModifyOptions option,
    int index
)

Parameters

option
Type: TwinCAT.Measurement.Scope.APIDataModifyOptions
The action that is performed.
index
Type: SystemInt32
The start index of the action.
See Also

Reference

UpdateDataSequenceEventArgs Class
UpdateDataSequenceEventArgs Overload
TwinCAT.Measurement.Scope.API Namespace


UpdateDataSequenceEventArgs Properties

The UpdateDataSequenceEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets the Index.
Public property | ModifyOption | Gets the ModifyOption.
Top
See Also

Reference

UpdateDataSequenceEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


UpdateDataSequenceEventArgs.Index Property

Gets the Index.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

UpdateDataSequenceEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


UpdateDataSequenceEventArgs.ModifyOption Property

Gets the ModifyOption.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DataModifyOptions ModifyOption { get; }
Public ReadOnly Property ModifyOption As DataModifyOptions
    Get
public:
property DataModifyOptions ModifyOption {
    DataModifyOptions get ();
}

Property Value

Type: DataModifyOptions
See Also

Reference

UpdateDataSequenceEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


UpdateDataSequenceEventArgs Methods

The UpdateDataSequenceEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateDataSequenceEventArgs Class
TwinCAT.Measurement.Scope.API Namespace


UseColorFrom Enumeration

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum UseColorFrom
Public Enumeration UseColorFrom
public enum class UseColorFrom
Members
Member name | Value | Description
CustomColor | 0 |
Channel | 1 |
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


UseTitleFrom Enumeration

use title from other property

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public enum UseTitleFrom
Public Enumeration UseTitleFrom
public enum class UseTitleFrom
Members
Member name | Value | Description
False | 0 | none title
True | 1 | custom title
Name | 2 | own name
XAxisTitle | 3 | title from x axis
YAxisTitle | 4 | title from y axis
ZAxisTitle | 5 | title from z axis
Channel | 6 | Name of the first channel
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


WrongChildTypeException Class

Exception class used if Child with wrong Type is added to MeasurementMemberContainerBase
Inheritance Hierarchy
SystemObject
SystemException
TwinCAT.Measurement.Scope.APIWrongChildTypeException

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class WrongChildTypeException : Exception
Public Class WrongChildTypeException
    Inherits Exception
public ref class WrongChildTypeException : public Exception

The WrongChildTypeException type exposes the following members.

Constructors
 | Name | Description
Public method | WrongChildTypeException | Creates a new object of WrongChildTypeException-Class
Top
Properties
 | Name | Description
Public property | Child | Gets the Member
Public property | Container | Gets the Container
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the Message (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


WrongChildTypeException Constructor

Creates a new object of WrongChildTypeException-Class

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public WrongChildTypeException(
    MeasurementMemberContainerBase Container,
    MeasurementMemberBase Child
)
Public Sub New (
    Container As MeasurementMemberContainerBase,
    Child As MeasurementMemberBase
)
public:
WrongChildTypeException(
    MeasurementMemberContainerBase^ Container,
    MeasurementMemberBase^ Child
)

Parameters

Container
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
The Container, who can't at the Member
Child
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
The Member, which can't be added.
See Also

Reference

WrongChildTypeException Class
TwinCAT.Measurement.Scope.API Namespace


WrongChildTypeException Properties

The WrongChildTypeException type exposes the following members.

Properties
 | Name | Description
Public property | Child | Gets the Member
Public property | Container | Gets the Container
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the Message (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

WrongChildTypeException Class
TwinCAT.Measurement.Scope.API Namespace


WrongChildTypeException.Child Property

Gets the Member

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MeasurementMemberBase Child { get; }
Public ReadOnly Property Child As MeasurementMemberBase
    Get
public:
property MeasurementMemberBase^ Child {
    MeasurementMemberBase^ get ();
}

Property Value

Type: MeasurementMemberBase
See Also

Reference

WrongChildTypeException Class
TwinCAT.Measurement.Scope.API Namespace


WrongChildTypeException.Container Property

Gets the Container

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MeasurementMemberContainerBase Container { get; }
Public ReadOnly Property Container As MeasurementMemberContainerBase
    Get
public:
property MeasurementMemberContainerBase^ Container {
    MeasurementMemberContainerBase^ get ();
}

Property Value

Type: MeasurementMemberContainerBase
See Also

Reference

WrongChildTypeException Class
TwinCAT.Measurement.Scope.API Namespace


WrongChildTypeException.Message Property

Gets the Message

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
public:
virtual property String^ Message {
    String^ get () override;
}

Property Value

Type: String

Implements

_ExceptionMessage
See Also

Reference

WrongChildTypeException Class
TwinCAT.Measurement.Scope.API Namespace


WrongChildTypeException Methods

The WrongChildTypeException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

WrongChildTypeException Class
TwinCAT.Measurement.Scope.API Namespace


WrongConfigurationException Class

Exception class fired, when an invalid Scope Configuration is detected
Inheritance Hierarchy
SystemObject
SystemException
TwinCAT.Measurement.Scope.APIWrongConfigurationException

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class WrongConfigurationException : Exception
Public Class WrongConfigurationException
    Inherits Exception
public ref class WrongConfigurationException : public Exception

The WrongConfigurationException type exposes the following members.

Constructors
 | Name | Description
Public method | WrongConfigurationException(String) | Creates a new WrongConfigurationException object
Public method | WrongConfigurationException(ScopeDisplayModes, Channel) | Creates a new Wrong Configuration Exception in case of Channel Validation
Public method | WrongConfigurationException(ScopeDisplayModes, Channel, Acquisition) | Creates an new Wrong Configuration Exception in case of Channel Validation with invalid Acquisition
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


WrongConfigurationException Constructor

Overload List
 | Name | Description
Public method | WrongConfigurationException(String) | Creates a new WrongConfigurationException object
Public method | WrongConfigurationException(ScopeDisplayModes, Channel) | Creates a new Wrong Configuration Exception in case of Channel Validation
Public method | WrongConfigurationException(ScopeDisplayModes, Channel, Acquisition) | Creates an new Wrong Configuration Exception in case of Channel Validation with invalid Acquisition
Top
See Also

Reference

WrongConfigurationException Class
TwinCAT.Measurement.Scope.API Namespace


WrongConfigurationException Constructor (String)

Creates a new WrongConfigurationException object

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public WrongConfigurationException(
    string Message
)
Public Sub New (
    Message As String
)
public:
WrongConfigurationException(
    String^ Message
)

Parameters

Message
Type: SystemString
Message to show problem
See Also

Reference

WrongConfigurationException Class
WrongConfigurationException Overload
TwinCAT.Measurement.Scope.API Namespace


WrongConfigurationException Constructor (ScopeDisplayModes, Channel)

Creates a new Wrong Configuration Exception in case of Channel Validation

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public WrongConfigurationException(
    ScopeDisplayModes Mode,
    Channel channel
)
Public Sub New (
    Mode As ScopeDisplayModes,
    channel As Channel
)
public:
WrongConfigurationException(
    ScopeDisplayModes Mode,
    Channel^ channel
)

Parameters

Mode
Type: TwinCAT.Measurement.Scope.APIScopeDisplayModes
The Mode of the Channel
channel
Type: TwinCAT.Measurement.Scope.API.ModelChannel
The Channel witch Configuration is invalid
See Also

Reference

WrongConfigurationException Class
WrongConfigurationException Overload
TwinCAT.Measurement.Scope.API Namespace


WrongConfigurationException Constructor (ScopeDisplayModes, Channel, Acquisition)

Creates an new Wrong Configuration Exception in case of Channel Validation with invalid Acquisition

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public WrongConfigurationException(
    ScopeDisplayModes Mode,
    Channel channel,
    Acquisition acquisition
)
Public Sub New (
    Mode As ScopeDisplayModes,
    channel As Channel,
    acquisition As Acquisition
)
public:
WrongConfigurationException(
    ScopeDisplayModes Mode,
    Channel^ channel,
    Acquisition^ acquisition
)

Parameters

Mode
Type: TwinCAT.Measurement.Scope.APIScopeDisplayModes
The DisplayMode of the Channel
channel
Type: TwinCAT.Measurement.Scope.API.ModelChannel
The Channel
acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
The Wrong Acquisition
See Also

Reference

WrongConfigurationException Class
WrongConfigurationException Overload
TwinCAT.Measurement.Scope.API Namespace


WrongConfigurationException Properties

The WrongConfigurationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

WrongConfigurationException Class
TwinCAT.Measurement.Scope.API Namespace


WrongConfigurationException Methods

The WrongConfigurationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

WrongConfigurationException Class
TwinCAT.Measurement.Scope.API Namespace


WrongDisplayModeException Class

ExceptionClass used to show wrong DisplayMode
Inheritance Hierarchy
SystemObject
SystemException
TwinCAT.Measurement.Scope.APIWrongDisplayModeException

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class WrongDisplayModeException : Exception
Public Class WrongDisplayModeException
    Inherits Exception
public ref class WrongDisplayModeException : public Exception

The WrongDisplayModeException type exposes the following members.

Constructors
 | Name | Description
Public method | WrongDisplayModeException | Create a new WrongDisplayModeException object
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Message to show (Overrides ExceptionMessage.)
Public property | Mode | The SelectedMode
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


WrongDisplayModeException Constructor

Create a new WrongDisplayModeException object

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public WrongDisplayModeException(
    ScopeDisplayModes Mode
)
Public Sub New (
    Mode As ScopeDisplayModes
)
public:
WrongDisplayModeException(
    ScopeDisplayModes Mode
)

Parameters

Mode
Type: TwinCAT.Measurement.Scope.APIScopeDisplayModes
Selected DisplayMode
See Also

Reference

WrongDisplayModeException Class
TwinCAT.Measurement.Scope.API Namespace


WrongDisplayModeException Properties

The WrongDisplayModeException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Message to show (Overrides ExceptionMessage.)
Public property | Mode | The SelectedMode
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

WrongDisplayModeException Class
TwinCAT.Measurement.Scope.API Namespace


WrongDisplayModeException.Message Property

Message to show

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get
public:
virtual property String^ Message {
    String^ get () override;
}

Property Value

Type: String

Implements

_ExceptionMessage
See Also

Reference

WrongDisplayModeException Class
TwinCAT.Measurement.Scope.API Namespace


WrongDisplayModeException.Mode Property

The SelectedMode

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeDisplayModes Mode { get; }
Public ReadOnly Property Mode As ScopeDisplayModes
    Get
public:
property ScopeDisplayModes Mode {
    ScopeDisplayModes get ();
}

Property Value

Type: ScopeDisplayModes
See Also

Reference

WrongDisplayModeException Class
TwinCAT.Measurement.Scope.API Namespace


WrongDisplayModeException Methods

The WrongDisplayModeException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

WrongDisplayModeException Class
TwinCAT.Measurement.Scope.API Namespace


WrongScopeStateException Class

Exception Typ used to show WrongScopeState
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
TwinCAT.Measurement.Scope.APIWrongScopeStateException

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class WrongScopeStateException : ApplicationException
Public Class WrongScopeStateException
    Inherits ApplicationException
public ref class WrongScopeStateException : public ApplicationException

The WrongScopeStateException type exposes the following members.

Constructors
 | Name | Description
Public method | WrongScopeStateException | Creates a new instance of ScopeStateException.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Fields
 | Name | Description
Public field | ActualState | The valid state.
Public field | RequestedState | The requested state.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API Namespace


WrongScopeStateException Constructor

Creates a new instance of ScopeStateException.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public WrongScopeStateException(
    ScopeViewState actual,
    ScopeViewState requested
)
Public Sub New (
    actual As ScopeViewState,
    requested As ScopeViewState
)
public:
WrongScopeStateException(
    ScopeViewState actual,
    ScopeViewState requested
)

Parameters

actual
Type: TwinCAT.Measurement.Scope.APIScopeViewState
the valid state
requested
Type: TwinCAT.Measurement.Scope.APIScopeViewState
the requested state
See Also

Reference

WrongScopeStateException Class
TwinCAT.Measurement.Scope.API Namespace


WrongScopeStateException Properties

The WrongScopeStateException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

WrongScopeStateException Class
TwinCAT.Measurement.Scope.API Namespace


WrongScopeStateException Methods

The WrongScopeStateException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

WrongScopeStateException Class
TwinCAT.Measurement.Scope.API Namespace


WrongScopeStateException Fields

The WrongScopeStateException type exposes the following members.

Fields
 | Name | Description
Public field | ActualState | The valid state.
Public field | RequestedState | The requested state.
Top
See Also

Reference

WrongScopeStateException Class
TwinCAT.Measurement.Scope.API Namespace


WrongScopeStateException.ActualState Field

The valid state.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeViewState ActualState
Public ActualState As ScopeViewState
public:
ScopeViewState ActualState

Field Value

Type: ScopeViewState
See Also

Reference

WrongScopeStateException Class
TwinCAT.Measurement.Scope.API Namespace


WrongScopeStateException.RequestedState Field

The requested state.

Namespace: TwinCAT.Measurement.Scope.API
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeViewState RequestedState
Public RequestedState As ScopeViewState
public:
ScopeViewState RequestedState

Field Value

Type: ScopeViewState
See Also

Reference

WrongScopeStateException Class
TwinCAT.Measurement.Scope.API Namespace


TwinCAT.Measurement.Scope.API.Model Namespace

Classes
 | Class | Description
Public class | Acquisition | Base class for all Scope Acquisitions
Public class | AcquisitionInterpreter | Class determines how to interpret data from Scope Server
Public class | AcquisitionSequence | Sequence class which references another acquisition to collect data.
Public class | AdsAcquisition | Acquisition Class to order Data via ADS
Public class | AnchorTimeBase | Base class of member which contains an anchor timestamp
Public class | AngularShape | Represents the angular scope shapes
Public class | AreaCondition | Condition with a MinValue and a MaxValue
Public class | ArrayBarChart | Scope ArrayBar-Chart class
Public class | AspectRatioScalingStyle | Class for fixed AspectRatio Scaling of an AxisGroup
Public class | Attachment | Class for mail attachment information.
Public class | Axis | Base class for all Scope Axes
Public class | AxisGroup | Class combines an couple of Axis with the Channels
Public class | AxisStyle | Style class for Axis
Public class | BarChart | Scope Bar-Chart class
Public class | BitmapArgs | Bitmap Event Args
Public class | CapStyle | Style class for start- and endcap
Public class | Channel | Channel in Scope API project
Public class | ChannelLayer |
Public class | ChannelStyle | Style Class for Scope Project Channel
Public class | ChannelTriggerSet | Channel Trigger Set Class in TwinCAT 3 Scope API Model
Public class | Chart | Base Class for all TwinCAT 3 Scope Charts
Public class | ChartLayer |
Public class | ChartLayerBase |
Public class | ChartMenuStyle | Class contains Style for Chart Menu
Public class | ChartMenuXYZStyle | Class contains Style for XYZ Chart Menu
Public class | ChartPositionStyle | Contains all information about the position of a channel in a Bar-Chart
Public class | ChartStyle | Class witch contains Style Elements of a Chart
Public class | ChartZoomStyle | Class which contains Zoom Properties for a chart
Public class | ColumnConfig | Base Column Configuration
Public class | CommandMember |
Public class | Condition | Base Class for all DynamicStyle Conditions
Public class | ConnectableChart |
Public class | CustomSequence | Sequence class that generates signals.
Public class | DataPool | Datapool Class for Scope Projects
Public class | DbAcquisition | Acquisition class to order data from a DataBase
Public class | DigitalChart | Scope Digital-Chart class
Public class | DigitalStyle | Style for Digital Channel
Public class | DirectoryTriggerSet | DirectoryTriggerSet Class in TwinCAT 3 Scope API Model
Public class | DoubleInputFunction | Base class for Function with 2 Conditions
Public class | DynamicStyle | Class defining a Dynamic Style
Public class | DynamicStyleContainer | Container for DynamicStyles
Public class | EchoChartLayerCollection |
Public class | Function | Base class for all Funcitons
Public class | HistoricalAcquisition | Base class for all Scope Acquisitions, which can be historical. E. g. the MqttAcquisition can also be not historical, check "IsHistorical" to be safe!
Public class | ImageMarker | Model class for Scope Image Marker
Public class | ImageSize | Represents the Image Settings of an Acquisition
Public class | ImageStreamStyle | Class of the Image Marker Style
Public class | IndexAxis | Model class for Index Axis
Public class | IndexScaling | Class defining Scaling Properties for Index value of ArrayBar Chart
Public class | InteractionShape | Shape class for interactive items in charting. The shape form and size is based on the interaction, only the center point can be set.
Public class | IotFileAcquisition | Acquisition to order data from IotFile
Public class | IotFileSequence |
Public class | IotFileSequenceData |
Public class | IotMultiSequenceData |
Public class | LinestateIndexPair | Class defining an LinestateIndex Pair
Public class | LineStateSettings |
Public class | Marker | Model class for Scope Marker
Public class | MarkerContainer | Container for all marker in a AxisGroup
Public class | MarkerControlStyle | MarkerControlStyle Class - Modelclass of an Marker Table
Public class | MarkerTable_Container | Abstract class of the Container Models
Public class | MarkerTable_PairContainer | Contains the Model a Paircontainer
Public class | MarkerTable_RowVM | ViewModel of the Row in the Markerwindow
Public class | MarkerTable_SingleContainer | MarkerTable_SingleContainer
Public class | MarkerTableBoardVM | ViewModel of the MarkerTableBoard
Public class | MarkerTableVM | ViewModel for a single MarkerTable of the Markerwindow
Public class | MarkerTreeItem | Marker TreeElement Item
Public class | MinMaxRangeAxis |
Public class | MinMaxStyle | MinMax Style for Channel
Public class | MqttAcquisition | Acquisition class to order data via MQTT
Public class | NegateFunction | Function with NOT Operator
Public class | OpcAcquisition | Acquisition to order data via OPC UA
Public class | OrFunction | Function with OR Operator
Public class | OverviewBase |
Public class | OverviewChart | Model class for an OverviewChart
Public class | PointsCollection |
Public class | PropertyUpdaterMarker | Makrer to update the PropertyUpdate VAlues
Public class | RefAcquisitionSequenceData |
Public class | RefDataCollector |
Public class | RefElementItem | ViewModel of an ChartItem
Public class | RepeatDataCollector |
Public class | RoundShape | Represents the round scope shapes
Public class | SavedExternalInformation |
Public class | ScopeMemberBase | Base Class for Scope Members without SubElements
Public class | ScopeMemberContainerBase | Base class for Scope Members with SubMembers
Public class | ScopeProject | TwinCAT 3 Scope Project Model
Public class | ScopeProjectBase | Base class for ScopeProject
Public class | ScopeShape | Represents the base class of the ScopeShapes
Public class | SelectableMember |
Public class | Sequence | Base class for acquisition that do not store their data in the scope server.
Public class | SequenceDataSource |
Public class | SeriesStyle | Class describing the Style of the Marks
Public class | ServerTriggerSet |
Public class | ShapePoint | Point Class for Shape Editor
Public class | ShapeStyle | Represents the Shape Style
Public class | ShapeXYPoint | Shape Point Class for XY-Points
Public class | SingleValuesChart | SingleValueChart class
Public class | SvdxAcquisition | Acquistion to acquire data from an old SVDX File
Public class | ThresholdCondition | Dynamic Style condition with one Threshold to compare value with
Public class | TimeAxis | Model class for Time Axis
Public class | TimeMarker | Model class for Scope Time Marker
Public class | TimeShiftStyle | Class to Store a TimeShift for an YT-Channel
Public class | TimeTriggerSet |
Public class | TriggerGroup | Trigger Group Class in TwinCAT 3 Scope API Model
Public class | TriggerModule | TriggerModule Class of the TwinCAT 3 Scope API
Public class | TriggerReleaseInfo | TriggerReleaseInfo contains all information about the released trigger
Public class | TriggerReleaseInfoReporting |
Public class | TriggerSet | abstract TriggerSet Class in TwinCAT 3 Scope API Model
Public class | TriggerTimeOffset | TriggerTimeOffset Class in TwinCAT 3 Scope API
Public class | TwoElementSelection_VM | ViewModel of the TwoElementSelection
Public class | ValueAxis | Model class for Value Axis
Public class | XORFunction | Function object with XOR Comparer
Public class | XYChart | Scope Project XY-Chart class
Public class | XYZChart | Chart Class for XYZ-Charts
Public class | YTChart | Scope YT-Chart Class
Interfaces
 | Interface | Description
Public interface | ICondition | Interface for all Conditions and Function in an Dynamic Style
Public interface | IScopeMember | Interface witch all ScopeMembers should Implement
Public interface | ITreeElementItem | Interface for an Tree Element Item
Public interface | IValueToTimestampCollector | Interface for members that can collect data
Public interface | IVisibleStateUpdater | Interface for an Visible State Updater
Delegates
 | Delegate | Description
Public delegate | ImageMarkerDelShowLiveOverview | Ask view member, if the overview is live and open
Public delegate | MarkerTableVMDelRemoveMemberQuestion |
Public delegate | MarkerTableVMDelUseMultiselect |
Public delegate | MinMaxRangeAxisGetRange | Delegate to get an ValueRange
Public delegate | ScopeProjectDelRemainingTrigger | Delegete Type to show RemainingTrigger
Enumerations
 | Enumeration | Description
Public enumeration | MarkerWindow_RemoveOptions | MarkerWindow Remove Answer Enumeration


Acquisition Class

Base class for all Scope Acquisitions
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisition
TwinCAT.Measurement.Scope.API.ModelAdsAcquisition
TwinCAT.Measurement.Scope.API.ModelHistoricalAcquisition
TwinCAT.Measurement.Scope.API.ModelOpcAcquisition
TwinCAT.Measurement.Scope.API.ModelSequence

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class Acquisition : ScopeMemberContainerBase
Public MustInherit Class Acquisition
    Inherits ScopeMemberContainerBase
public ref class Acquisition abstract : public ScopeMemberContainerBase

The Acquisition type exposes the following members.

Constructors
 | Name | Description
Public method | Acquisition | Initialize Properties with default values.
Public method | Acquisition(Acquisition) | Initialize Properties with values copied from other Acquisition
Top
Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange.
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll
Public property | Area | Gets or Sets the Area.
Public property | ArrayLength | Gets or Sets the ArrayLength.
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime.
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation.
Public property | Comment | (Overrides MeasurementMemberBaseComment.)
Public property | CompressionMode | Gets or Sets the CompressionMode.
Public property | ContextMask | Gets or Sets the ContextMask.
Public property | DataAccess | Gets or Sets the DataAccess.
Public property | DataType | Gets or Sets the DataType.
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled.
Public property | FileHandle | Gets or Sets the FileHandle.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical.
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit.
Public property | ReferenceCount | Get the number of Times this Acquisition is used
Public property | SampleTime | Gets or Sets the SampleTime.
Public property | SaveOption | Gets or Sets the SaveOption.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel.
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer.
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime.
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding.
Public property | VariableSize | Gets or Sets the VariableSize.
Top
Methods
 | Name | Description
 | AcquisitionsFromXml | Creates a list of acquisitions based on a XML string.
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
 | FromScopeDataType |
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition
Public method | GetCommands | Gets a List of possible Commands for this Element (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetDataSize |
Public method | GetFullName | Gets the complete identifier of this acqusition
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues |
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Overrides MeasurementMemberBaseReadXml(XmlReader).)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of all Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
 | XmlFromAcquisitions | Creates a XML string based on a list of acquisitions.
Top
Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed.
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId.
Public event | AreaChanged | Fired when the Area is changed.
Public event | AreaValidating | Fired while validating the new value for Area.
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed.
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength.
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed.
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime.
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed.
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed.
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode.
Public event | ContextMaskChanged | Fired when the ContextMask is changed.
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask.
Public event | DataAccessChanged | Fired when the DataAccess is changed.
Public event | DataAccessValidating | Fired while validating the new value for DataAccess.
Public event | DataTypeChanged | Fired when the DataType is changed.
Public event | DataTypeValidating | Fired while validating the new value for DataType.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | FileHandleChanged | Fired when the FileHandle is changed.
Public event | FileHandleValidating | Fired while validating the new value for FileHandle.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed.
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed.
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData |
Public event | OversampleChanged | Fired when the Oversample is changed.
Public event | OversampleValidating | Fired while validating the new value for Oversample.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed.
Public event | RawUnitValidating | Fired while validating the new value for RawUnit.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed.
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption.
Public event | ServerHandleChanged | Fired when the ServerHandle is changed.
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed.
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed.
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer.
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed.
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime.
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed.
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding.
Public event | VariableSizeChanged | Fired when the VariableSize is changed.
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize.
Top
Fields
 | Name | Description
Public field | TargetBrowserXML |
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


Acquisition Constructor

Overload List
 | Name | Description
Public method | Acquisition | Initialize Properties with default values.
Public method | Acquisition(Acquisition) | Initialize Properties with values copied from other Acquisition
Top
See Also

Reference

Acquisition Class


Acquisition Constructor

Initialize Properties with default values.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Acquisition()
Public Sub New
public:
Acquisition()
See Also

Reference

Acquisition Class
Acquisition Overload


Acquisition Constructor (Acquisition)

Initialize Properties with values copied from other Acquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Acquisition(
    Acquisition acquisition
)
Public Sub New (
    acquisition As Acquisition
)
public:
Acquisition(
    Acquisition^ acquisition
)

Parameters

acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
Acquisition to copy from
See Also

Reference

Acquisition Class
Acquisition Overload


Acquisition Properties

The Acquisition type exposes the following members.

Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange.
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll
Public property | Area | Gets or Sets the Area.
Public property | ArrayLength | Gets or Sets the ArrayLength.
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime.
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation.
Public property | Comment | (Overrides MeasurementMemberBaseComment.)
Public property | CompressionMode | Gets or Sets the CompressionMode.
Public property | ContextMask | Gets or Sets the ContextMask.
Public property | DataAccess | Gets or Sets the DataAccess.
Public property | DataType | Gets or Sets the DataType.
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled.
Public property | FileHandle | Gets or Sets the FileHandle.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical.
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit.
Public property | ReferenceCount | Get the number of Times this Acquisition is used
Public property | SampleTime | Gets or Sets the SampleTime.
Public property | SaveOption | Gets or Sets the SaveOption.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel.
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer.
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime.
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding.
Public property | VariableSize | Gets or Sets the VariableSize.
Top
See Also

Reference

Acquisition Class


Acquisition.AmsNetId Property

Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public AmsNetId AmsNetId { get; set; }
<BrowsableAttribute(true)>
Public Property AmsNetId As AmsNetId
    Get
    Set
public:
[BrowsableAttribute(true)]
property AmsNetId^ AmsNetId {
    AmsNetId^ get ();
    void set (AmsNetId^ value);
}

Property Value

Type: AmsNetId
See Also

Reference

Acquisition Class


Acquisition.AmsNetIdExchange Property

Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public string AmsNetIdExchange { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property AmsNetIdExchange As String
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property String^ AmsNetIdExchange {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Acquisition Class


Acquisition.Area Property

Gets or Sets the Area.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public SymbolArea Area { get; set; }
<BrowsableAttribute(true)>
Public Property Area As SymbolArea
    Get
    Set
public:
[BrowsableAttribute(true)]
property SymbolArea Area {
    SymbolArea get ();
    void set (SymbolArea value);
}

Property Value

Type: SymbolArea
See Also

Reference

Acquisition Class


Acquisition.ArrayLength Property

Gets or Sets the ArrayLength.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int ArrayLength { get; set; }
<BrowsableAttribute(true)>
Public Property ArrayLength As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int ArrayLength {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Acquisition Class


Acquisition.BaseSampleTime Property

Gets or Sets the BaseSampleTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public uint BaseSampleTime { get; set; }
<BrowsableAttribute(false)>
Public Property BaseSampleTime As UInteger
    Get
    Set
public:
[BrowsableAttribute(false)]
property unsigned int BaseSampleTime {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

Acquisition Class


Acquisition.ChannelStyleInformation Property

Gets or Sets the ChannelStyleInformation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string ChannelStyleInformation { get; set; }
<BrowsableAttribute(false)>
Public Property ChannelStyleInformation As String
    Get
    Set
public:
[BrowsableAttribute(false)]
property String^ ChannelStyleInformation {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Acquisition Class


Acquisition.Comment Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public override string Comment { get; set; }
<BrowsableAttribute(true)>
Public Overrides Property Comment As String
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property String^ Comment {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

Acquisition Class


Acquisition.CompressionMode Property

Gets or Sets the CompressionMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[TypeConverterAttribute(typeof(CompressionOptionConverter))]
public virtual CompressionMode CompressionMode { get; set; }
<BrowsableAttribute(true)>
<TypeConverterAttribute(GetType(CompressionOptionConverter))>
Public Overridable Property CompressionMode As CompressionMode
    Get
    Set
public:
[BrowsableAttribute(true)]
[TypeConverterAttribute(typeof(CompressionOptionConverter))]
virtual property CompressionMode CompressionMode {
    CompressionMode get ();
    void set (CompressionMode value);
}

Property Value

Type: CompressionMode
See Also

Reference

Acquisition Class


Acquisition.ContextMask Property

Gets or Sets the ContextMask.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public int ContextMask { get; set; }
<BrowsableAttribute(false)>
Public Property ContextMask As Integer
    Get
    Set
public:
[BrowsableAttribute(false)]
property int ContextMask {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Acquisition Class


Acquisition.DataAccess Property

Gets or Sets the DataAccess.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public DataAccessMode DataAccess { get; set; }
<BrowsableAttribute(false)>
Public Property DataAccess As DataAccessMode
    Get
    Set
public:
[BrowsableAttribute(false)]
property DataAccessMode^ DataAccess {
    DataAccessMode^ get ();
    void set (DataAccessMode^ value);
}

Property Value

Type: DataAccessMode
See Also

Reference

Acquisition Class


Acquisition.DataType Property

Gets or Sets the DataType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public virtual Scope2DataType DataType { get; set; }
<BrowsableAttribute(true)>
Public Overridable Property DataType As Scope2DataType
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property Scope2DataType DataType {
    Scope2DataType get ();
    void set (Scope2DataType value);
}

Property Value

Type: Scope2DataType
See Also

Reference

Acquisition Class


Acquisition.Description Property

A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public abstract ChannelDescription Description { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public MustOverride ReadOnly Property Description As ChannelDescription
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property ChannelDescription^ Description {
    ChannelDescription^ get () abstract;
}

Property Value

Type: ChannelDescription
See Also

Reference

Acquisition Class


Acquisition.Enabled Property

Gets or Sets the Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Enabled { get; set; }
<BrowsableAttribute(true)>
Public Property Enabled As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Acquisition Class


Acquisition.FileHandle Property

Gets or Sets the FileHandle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public int FileHandle { get; set; }
<BrowsableAttribute(false)>
Public Property FileHandle As Integer
    Get
    Set
public:
[BrowsableAttribute(false)]
property int FileHandle {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Acquisition Class


Acquisition.ForceOversampling Property

Gets or Sets the ForceOversampling.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ForceOversampling { get; set; }
<BrowsableAttribute(true)>
Public Property ForceOversampling As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ForceOversampling {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Acquisition Class


Acquisition.IsArray Property

Gets or Sets the IsArray.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool IsArray { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property IsArray As Boolean
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool IsArray {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

Acquisition Class


Acquisition.IsHistorical Property

Gets or Sets the IsHistorical.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool IsHistorical { get; set; }
<BrowsableAttribute(false)>
Public Property IsHistorical As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool IsHistorical {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Acquisition Class


Acquisition.Oversample Property

Gets or Sets the Oversample.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public uint Oversample { get; set; }
<BrowsableAttribute(true)>
Public Property Oversample As UInteger
    Get
    Set
public:
[BrowsableAttribute(true)]
property unsigned int Oversample {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

Acquisition Class


Acquisition.RawUnit Property

Gets or Sets the RawUnit.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public UnitConfiguration RawUnit { get; set; }
<BrowsableAttribute(true)>
Public Property RawUnit As UnitConfiguration
    Get
    Set
public:
[BrowsableAttribute(true)]
property UnitConfiguration^ RawUnit {
    UnitConfiguration^ get ();
    void set (UnitConfiguration^ value);
}

Property Value

Type: UnitConfiguration
See Also

Reference

Acquisition Class


Acquisition.ReferenceCount Property

Get the number of Times this Acquisition is used

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public int ReferenceCount { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property ReferenceCount As Integer
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property int ReferenceCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Acquisition Class


Acquisition.SampleTime Property

Gets or Sets the SampleTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public virtual uint SampleTime { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Overridable Property SampleTime As UInteger
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
virtual property unsigned int SampleTime {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

Acquisition Class


Acquisition.SaveOption Property

Gets or Sets the SaveOption.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public virtual SaveOption SaveOption { get; set; }
<BrowsableAttribute(true)>
Public Overridable Property SaveOption As SaveOption
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property SaveOption SaveOption {
    SaveOption get ();
    void set (SaveOption value);
}

Property Value

Type: SaveOption
See Also

Reference

Acquisition Class


Acquisition.ScopeClientChannel Property

Gets or Sets the ScopeClientChannel.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public ClientChannel ScopeClientChannel { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property ScopeClientChannel As ClientChannel
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property ClientChannel^ ScopeClientChannel {
    ClientChannel^ get ();
}

Property Value

Type: ClientChannel
See Also

Reference

Acquisition Class


Acquisition.ServerHandle Property

Gets or Sets the ServerHandle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public int ServerHandle { get; set; }
<BrowsableAttribute(false)>
Public Property ServerHandle As Integer
    Get
    Set
public:
[BrowsableAttribute(false)]
property int ServerHandle {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Acquisition Class


Acquisition.TimeOffset Property

Gets or Sets the TimeOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long TimeOffset { get; set; }
<BrowsableAttribute(true)>
Public Property TimeOffset As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long TimeOffset {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

Acquisition Class


Acquisition.UseLocalServer Property

Gets or Sets the UseLocalServer.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool UseLocalServer { get; set; }
<BrowsableAttribute(true)>
Public Property UseLocalServer As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool UseLocalServer {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Acquisition Class


Acquisition.UseTaskSampleTime Property

Gets or Sets the UseTaskSampleTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool UseTaskSampleTime { get; set; }
<BrowsableAttribute(true)>
Public Property UseTaskSampleTime As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool UseTaskSampleTime {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Acquisition Class


Acquisition.UTF8Encoding Property

Gets or Sets the UTF8Encoding.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool UTF8Encoding { get; set; }
<BrowsableAttribute(false)>
Public Property UTF8Encoding As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool UTF8Encoding {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Acquisition Class


Acquisition.VariableSize Property

Gets or Sets the VariableSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public uint VariableSize { get; set; }
<BrowsableAttribute(true)>
Public Property VariableSize As UInteger
    Get
    Set
public:
[BrowsableAttribute(true)]
property unsigned int VariableSize {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

Acquisition Class


Acquisition Methods

The Acquisition type exposes the following members.

Methods
 | Name | Description
 | AcquisitionsFromXml | Creates a list of acquisitions based on a XML string.
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
 | FromScopeDataType |
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition
Public method | GetCommands | Gets a List of possible Commands for this Element (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetDataSize |
Public method | GetFullName | Gets the complete identifier of this acqusition
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues |
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Overrides MeasurementMemberBaseReadXml(XmlReader).)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of all Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
 | XmlFromAcquisitions | Creates a XML string based on a list of acquisitions.
Top
See Also

Reference

Acquisition Class


Acquisition.AcquisitionsFromXml Method

Creates a list of acquisitions based on a XML string.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static List<Acquisition> AcquisitionsFromXml(
    string xml,
    bool preferSequence = false
)
Public Shared Function AcquisitionsFromXml (
    xml As String,
    Optional preferSequence As Boolean = false
) As List(Of Acquisition)
public:
static List<Acquisition^>^ AcquisitionsFromXml(
    String^ xml,
    bool preferSequence = false
)

Parameters

xml
Type: SystemString
The XML to parse.
preferSequence (Optional)
Type: SystemBoolean
Prefere Sequences

Return Value

Type: List Acquisition
A list of Acquisition representing the XML data.
See Also

Reference

Acquisition Class


Acquisition.FromScopeDataType Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string FromScopeDataType(
    Scope2DataType type
)
Public Shared Function FromScopeDataType (
    type As Scope2DataType
) As String
public:
static String^ FromScopeDataType(
    Scope2DataType type
)

Parameters

type
Type: Scope2DataType

Return Value

Type: String
See Also

Reference

Acquisition Class


Acquisition.GetByteSize Method

Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual uint GetByteSize()
Public Overridable Function GetByteSize As UInteger
public:
virtual unsigned int GetByteSize()

Return Value

Type: UInt32
The Size of the Symbol
See Also

Reference

Acquisition Class


Acquisition.GetCommands Method

Gets a List of possible Commands for this Element

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
An Array of Commands
See Also

Reference

Acquisition Class


Acquisition.GetDataSize Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual ulong GetDataSize(
    long recordTime,
    uint blockSize
)
Public Overridable Function GetDataSize (
    recordTime As Long,
    blockSize As UInteger
) As ULong
public:
virtual unsigned long long GetDataSize(
    long long recordTime,
    unsigned int blockSize
)

Parameters

recordTime
Type: SystemInt64
blockSize
Type: SystemUInt32

Return Value

Type: UInt64
See Also

Reference

Acquisition Class


Acquisition.GetFullName Method

Gets the complete identifier of this acqusition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual string GetFullName()
Public Overridable Function GetFullName As String
public:
virtual String^ GetFullName()

Return Value

Type: String
The full name
See Also

Reference

Acquisition Class


Acquisition.GetHashCode Method

Serves as a hash function for a particular type.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

Acquisition Class


Acquisition.HasSameTarget Method

Determines wether the two Acquisition will acquire the same Data

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual bool HasSameTarget(
    Acquisition Acquisition
)
Public Overridable Function HasSameTarget (
    Acquisition As Acquisition
) As Boolean
public:
virtual bool HasSameTarget(
    Acquisition^ Acquisition
)

Parameters

Acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
The Acquisition to compare with

Return Value

Type: Boolean
True if the Acquisitions have the Same Target
See Also

Reference

Acquisition Class


Acquisition.OrderValues Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual SingleChannelFrame OrderValues(
    long start,
    long end
)
Public Overridable Function OrderValues (
    start As Long,
    end As Long
) As SingleChannelFrame
public:
virtual SingleChannelFrame^ OrderValues(
    long long start,
    long long end
)

Parameters

start
Type: SystemInt64
end
Type: SystemInt64

Return Value

Type: SingleChannelFrame
See Also

Reference

Acquisition Class


Acquisition.ReadXml Method

Read Element Configuration from XML

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override

Parameters

reader
Type: System.XmlXmlReader
Reader to read from

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

Acquisition Class


Acquisition.UpdatePropertyAttributes Method

Update Attributes of all Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

Acquisition Class


Acquisition.XmlFromAcquisitions Method

Creates a XML string based on a list of acquisitions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string XmlFromAcquisitions(
    Acquisition acqs
)
Public Shared Function XmlFromAcquisitions (
    acqs As Acquisition
) As String
public:
static String^ XmlFromAcquisitions(
    Acquisition^ acqs
)

Parameters

acqs
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
Lists of acquisitions

Return Value

Type: String
XL string based on the acquisitions
See Also

Reference

Acquisition Class


Acquisition Events

The Acquisition type exposes the following members.

Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed.
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId.
Public event | AreaChanged | Fired when the Area is changed.
Public event | AreaValidating | Fired while validating the new value for Area.
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed.
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength.
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed.
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime.
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed.
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed.
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode.
Public event | ContextMaskChanged | Fired when the ContextMask is changed.
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask.
Public event | DataAccessChanged | Fired when the DataAccess is changed.
Public event | DataAccessValidating | Fired while validating the new value for DataAccess.
Public event | DataTypeChanged | Fired when the DataType is changed.
Public event | DataTypeValidating | Fired while validating the new value for DataType.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | FileHandleChanged | Fired when the FileHandle is changed.
Public event | FileHandleValidating | Fired while validating the new value for FileHandle.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed.
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed.
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData |
Public event | OversampleChanged | Fired when the Oversample is changed.
Public event | OversampleValidating | Fired while validating the new value for Oversample.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed.
Public event | RawUnitValidating | Fired while validating the new value for RawUnit.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed.
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption.
Public event | ServerHandleChanged | Fired when the ServerHandle is changed.
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed.
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed.
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer.
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed.
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime.
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed.
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding.
Public event | VariableSizeChanged | Fired when the VariableSize is changed.
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize.
Top
See Also

Reference

Acquisition Class


Acquisition.AmsNetIdChanged Event

Fired when the AmsNetId is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AmsNetIdChanged
Public Event AmsNetIdChanged As EventHandler
public:
 event EventHandler^ AmsNetIdChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.AmsNetIdValidating Event

Fired while validating the new value for AmsNetId.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AmsNetIdValidating
Public Event AmsNetIdValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AmsNetIdValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.AreaChanged Event

Fired when the Area is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AreaChanged
Public Event AreaChanged As EventHandler
public:
 event EventHandler^ AreaChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.AreaValidating Event

Fired while validating the new value for Area.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AreaValidating
Public Event AreaValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AreaValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.ArrayLengthChanged Event

Fired when the ArrayLength is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ArrayLengthChanged
Public Event ArrayLengthChanged As EventHandler
public:
 event EventHandler^ ArrayLengthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.ArrayLengthValidating Event

Fired while validating the new value for ArrayLength.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ArrayLengthValidating
Public Event ArrayLengthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ArrayLengthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.BaseSampleTimeChanged Event

Fired when the BaseSampleTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BaseSampleTimeChanged
Public Event BaseSampleTimeChanged As EventHandler
public:
 event EventHandler^ BaseSampleTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.BaseSampleTimeValidating Event

Fired while validating the new value for BaseSampleTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> BaseSampleTimeValidating
Public Event BaseSampleTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ BaseSampleTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.ChannelStyleInformationChanged Event

Fired when the ChannelStyleInformation is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ChannelStyleInformationChanged
Public Event ChannelStyleInformationChanged As EventHandler
public:
 event EventHandler^ ChannelStyleInformationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.ChannelStyleInformationValidating Event

Fired while validating the new value for ChannelStyleInformation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ChannelStyleInformationValidating
Public Event ChannelStyleInformationValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ChannelStyleInformationValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.CompressionModeChanged Event

Fired when the CompressionMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CompressionModeChanged
Public Event CompressionModeChanged As EventHandler
public:
 event EventHandler^ CompressionModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.CompressionModeValidating Event

Fired while validating the new value for CompressionMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> CompressionModeValidating
Public Event CompressionModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ CompressionModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.ContextMaskChanged Event

Fired when the ContextMask is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ContextMaskChanged
Public Event ContextMaskChanged As EventHandler
public:
 event EventHandler^ ContextMaskChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.ContextMaskValidating Event

Fired while validating the new value for ContextMask.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ContextMaskValidating
Public Event ContextMaskValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ContextMaskValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.DataAccessChanged Event

Fired when the DataAccess is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DataAccessChanged
Public Event DataAccessChanged As EventHandler
public:
 event EventHandler^ DataAccessChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.DataAccessValidating Event

Fired while validating the new value for DataAccess.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DataAccessValidating
Public Event DataAccessValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DataAccessValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.DataTypeChanged Event

Fired when the DataType is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DataTypeChanged
Public Event DataTypeChanged As EventHandler
public:
 event EventHandler^ DataTypeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.DataTypeValidating Event

Fired while validating the new value for DataType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DataTypeValidating
Public Event DataTypeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DataTypeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.EnabledChanged Event

Fired when the Enabled is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EnabledChanged
Public Event EnabledChanged As EventHandler
public:
 event EventHandler^ EnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.EnabledValidating Event

Fired while validating the new value for Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EnabledValidating
Public Event EnabledValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EnabledValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.FileHandleChanged Event

Fired when the FileHandle is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler FileHandleChanged
Public Event FileHandleChanged As EventHandler
public:
 event EventHandler^ FileHandleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.FileHandleValidating Event

Fired while validating the new value for FileHandle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> FileHandleValidating
Public Event FileHandleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ FileHandleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.ForceOversamplingChanged Event

Fired when the ForceOversampling is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ForceOversamplingChanged
Public Event ForceOversamplingChanged As EventHandler
public:
 event EventHandler^ ForceOversamplingChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.ForceOversamplingValidating Event

Fired while validating the new value for ForceOversampling.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ForceOversamplingValidating
Public Event ForceOversamplingValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ForceOversamplingValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.IsHistoricalChanged Event

Fired when the IsHistorical is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IsHistoricalChanged
Public Event IsHistoricalChanged As EventHandler
public:
 event EventHandler^ IsHistoricalChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.IsHistoricalValidating Event

Fired while validating the new value for IsHistorical.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IsHistoricalValidating
Public Event IsHistoricalValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IsHistoricalValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.OrderData Event

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<OrderDataEventArgs> OrderData
Public Event OrderData As EventHandler(Of OrderDataEventArgs)
public:
 event EventHandler<OrderDataEventArgs^>^ OrderData {
    void add (EventHandler<OrderDataEventArgs^>^ value);
    void remove (EventHandler<OrderDataEventArgs^>^ value);
}

Value

Type: SystemEventHandler OrderDataEventArgs
See Also

Reference

Acquisition Class


Acquisition.OversampleChanged Event

Fired when the Oversample is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OversampleChanged
Public Event OversampleChanged As EventHandler
public:
 event EventHandler^ OversampleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.OversampleValidating Event

Fired while validating the new value for Oversample.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> OversampleValidating
Public Event OversampleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ OversampleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.RawUnitChanged Event

Fired when the RawUnit is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler RawUnitChanged
Public Event RawUnitChanged As EventHandler
public:
 event EventHandler^ RawUnitChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.RawUnitValidating Event

Fired while validating the new value for RawUnit.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> RawUnitValidating
Public Event RawUnitValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ RawUnitValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.SaveOptionChanged Event

Fired when the SaveOption is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SaveOptionChanged
Public Event SaveOptionChanged As EventHandler
public:
 event EventHandler^ SaveOptionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.SaveOptionValidating Event

Fired while validating the new value for SaveOption.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SaveOptionValidating
Public Event SaveOptionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SaveOptionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.ServerHandleChanged Event

Fired when the ServerHandle is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ServerHandleChanged
Public Event ServerHandleChanged As EventHandler
public:
 event EventHandler^ ServerHandleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.ServerHandleValidating Event

Fired while validating the new value for ServerHandle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ServerHandleValidating
Public Event ServerHandleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ServerHandleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.TimeOffsetChanged Event

Fired when the TimeOffset is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TimeOffsetChanged
Public Event TimeOffsetChanged As EventHandler
public:
 event EventHandler^ TimeOffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.TimeOffsetValidating Event

Fired while validating the new value for TimeOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TimeOffsetValidating
Public Event TimeOffsetValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TimeOffsetValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.UseLocalServerChanged Event

Fired when the UseLocalServer is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UseLocalServerChanged
Public Event UseLocalServerChanged As EventHandler
public:
 event EventHandler^ UseLocalServerChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.UseLocalServerValidating Event

Fired while validating the new value for UseLocalServer.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UseLocalServerValidating
Public Event UseLocalServerValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UseLocalServerValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.UseTaskSampleTimeChanged Event

Fired when the UseTaskSampleTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UseTaskSampleTimeChanged
Public Event UseTaskSampleTimeChanged As EventHandler
public:
 event EventHandler^ UseTaskSampleTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.UseTaskSampleTimeValidating Event

Fired while validating the new value for UseTaskSampleTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UseTaskSampleTimeValidating
Public Event UseTaskSampleTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UseTaskSampleTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.UTF8EncodingChanged Event

Fired when the UTF8Encoding is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UTF8EncodingChanged
Public Event UTF8EncodingChanged As EventHandler
public:
 event EventHandler^ UTF8EncodingChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.UTF8EncodingValidating Event

Fired while validating the new value for UTF8Encoding.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UTF8EncodingValidating
Public Event UTF8EncodingValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UTF8EncodingValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition.VariableSizeChanged Event

Fired when the VariableSize is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler VariableSizeChanged
Public Event VariableSizeChanged As EventHandler
public:
 event EventHandler^ VariableSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Acquisition Class


Acquisition.VariableSizeValidating Event

Fired while validating the new value for VariableSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> VariableSizeValidating
Public Event VariableSizeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ VariableSizeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Acquisition Class


Acquisition Fields

The Acquisition type exposes the following members.

Fields
 | Name | Description
Public field | TargetBrowserXML |
Top
See Also

Reference

Acquisition Class


Acquisition.TargetBrowserXML Field

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string TargetBrowserXML
Public TargetBrowserXML As String
public:
String^ TargetBrowserXML

Field Value

Type: String
See Also

Reference

Acquisition Class


AcquisitionInterpreter Class

Class determines how to interpret data from Scope Server
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisitionInterpreter

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class AcquisitionInterpreter : ScopeMemberContainerBase
Public Class AcquisitionInterpreter
    Inherits ScopeMemberContainerBase
public ref class AcquisitionInterpreter : public ScopeMemberContainerBase

The AcquisitionInterpreter type exposes the following members.

Constructors
 | Name | Description
Public method | AcquisitionInterpreter | Create a new AcquisitionInterpreter
Public method | AcquisitionInterpreter(Acquisition) | Initializes a new instance of the AcquisitionInterpreter class
Public method | AcquisitionInterpreter(AcquisitionInterpreter) | Create a new Acquisitioninterpreter, by copying Properties
Top
Properties
 | Name | Description
Public property | Acquisition | Gets or Sets the Acquisition.
Public property | AcquisitionGUID | Gets or Sets the AcquisitionGUID.
Public property | BitMask | Gets or Sets the BitMask.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | HideInHierarchy | Gets or Sets the HideInHierarchy.
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Offset | Gets or Sets the Offset.
Public property | OffsetResult | Gets or Sets the OffsetResult.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ResultingUnit | Gets or Sets the ResultingUnit.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScaleFactor | Gets or Sets the ScaleFactor.
Public property | ScaleResult | Gets or Sets the ScaleResult.
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel.
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShortInfo | Gets or Sets the ShortInfo.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | Usage | Gets or Sets the Usage.
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copies Elments to this Container (Overrides MeasurementMemberBaseCopy(ListObject, Boolean, Int32).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets an Array of all possible Commands on this Element (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsedClientChannel | Return the used client channel
Public method | Highlight | Raises the Highlight event
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AcquisitionChanged | Fired when the Acquisition is changed.
Public event | AcquisitionGUIDChanged | Fired when the AcquisitionGUID is changed.
Public event | AcquisitionGUIDValidating | Fired while validating the new value for AcquisitionGUID.
Public event | AcquisitionValidating | Fired while validating the new value for Acquisition.
Public event | BeforeAcquisitionChanged | Fired before the Acquisition changed
Public event | BeforeAcquisitionGUIDChanged | Fired before the AcquisitionGUID changed
Public event | BitMaskChanged | Fired when the BitMask is changed.
Public event | BitMaskValidating | Fired while validating the new value for BitMask.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HideInHierarchyChanged | Fired when the HideInHierarchy is changed.
Public event | HideInHierarchyValidating | Fired while validating the new value for HideInHierarchy.
Public event | HighlightEvent | Fired to Highlight OverviewChannel
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OffsetChanged | Fired when the Offset is changed.
Public event | OffsetResultChanged | Fired when the OffsetResult is changed.
Public event | OffsetResultValidating | Fired while validating the new value for OffsetResult.
Public event | OffsetValidating | Fired while validating the new value for Offset.
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResultingUnitChanged | Fired when the ResultingUnit is changed.
Public event | ResultingUnitValidating | Fired while validating the new value for ResultingUnit.
Public event | ScaleFactorChanged | Fired when the ScaleFactor is changed.
Public event | ScaleFactorValidating | Fired while validating the new value for ScaleFactor.
Public event | ScaleResultChanged | Fired when the ScaleResult is changed.
Public event | ScaleResultValidating | Fired while validating the new value for ScaleResult.
Public event | ShortInfoChanged | Fired when the ShortInfo is changed.
Public event | ShortInfoValidating | Fired while validating the new value for ShortInfo.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UsageChanged | Fired when the Usage is changed.
Public event | UsageValidating | Fired while validating the new value for Usage.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


AcquisitionInterpreter Constructor

Overload List
 | Name | Description
Public method | AcquisitionInterpreter | Create a new AcquisitionInterpreter
Public method | AcquisitionInterpreter(Acquisition) | Initializes a new instance of the AcquisitionInterpreter class
Public method | AcquisitionInterpreter(AcquisitionInterpreter) | Create a new Acquisitioninterpreter, by copying Properties
Top
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter Constructor

Create a new AcquisitionInterpreter

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AcquisitionInterpreter()
Public Sub New
public:
AcquisitionInterpreter()
See Also

Reference

AcquisitionInterpreter Class
AcquisitionInterpreter Overload


AcquisitionInterpreter Constructor (Acquisition)

Initializes a new instance of the AcquisitionInterpreter class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AcquisitionInterpreter(
    Acquisition acquisition
)
Public Sub New (
    acquisition As Acquisition
)
public:
AcquisitionInterpreter(
    Acquisition^ acquisition
)

Parameters

acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
See Also

Reference

AcquisitionInterpreter Class
AcquisitionInterpreter Overload


AcquisitionInterpreter Constructor (AcquisitionInterpreter)

Create a new Acquisitioninterpreter, by copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AcquisitionInterpreter(
    AcquisitionInterpreter ai
)
Public Sub New (
    ai As AcquisitionInterpreter
)
public:
AcquisitionInterpreter(
    AcquisitionInterpreter^ ai
)

Parameters

ai
Type: TwinCAT.Measurement.Scope.API.ModelAcquisitionInterpreter
AcquisitionInterpreter to copy from
See Also

Reference

AcquisitionInterpreter Class
AcquisitionInterpreter Overload


AcquisitionInterpreter Properties

The AcquisitionInterpreter type exposes the following members.

Properties
 | Name | Description
Public property | Acquisition | Gets or Sets the Acquisition.
Public property | AcquisitionGUID | Gets or Sets the AcquisitionGUID.
Public property | BitMask | Gets or Sets the BitMask.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | HideInHierarchy | Gets or Sets the HideInHierarchy.
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Offset | Gets or Sets the Offset.
Public property | OffsetResult | Gets or Sets the OffsetResult.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ResultingUnit | Gets or Sets the ResultingUnit.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScaleFactor | Gets or Sets the ScaleFactor.
Public property | ScaleResult | Gets or Sets the ScaleResult.
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel.
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShortInfo | Gets or Sets the ShortInfo.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | Usage | Gets or Sets the Usage.
Top
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.Acquisition Property

Gets or Sets the Acquisition.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public Acquisition Acquisition { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property Acquisition As Acquisition
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
virtual property Acquisition^ Acquisition {
    Acquisition^ get () sealed;
    void set (Acquisition^ value) sealed;
}

Property Value

Type: Acquisition
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.AcquisitionGUID Property

Gets or Sets the AcquisitionGUID.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Guid AcquisitionGUID { get; set; }
<BrowsableAttribute(true)>
Public Property AcquisitionGUID As Guid
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property Guid AcquisitionGUID {
    Guid get () sealed;
    void set (Guid value) sealed;
}

Property Value

Type: Guid
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.BitMask Property

Gets or Sets the BitMask.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public ulong BitMask { get; set; }
<BrowsableAttribute(true)>
Public Property BitMask As ULong
    Get
    Set
public:
[BrowsableAttribute(true)]
property unsigned long long BitMask {
    unsigned long long get ();
    void set (unsigned long long value);
}

Property Value

Type: UInt64
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.HideInHierarchy Property

Gets or Sets the HideInHierarchy.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool HideInHierarchy { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property HideInHierarchy As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool HideInHierarchy {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.Offset Property

Gets or Sets the Offset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double Offset { get; set; }
<BrowsableAttribute(true)>
Public Property Offset As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double Offset {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.OffsetResult Property

Gets or Sets the OffsetResult.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public double OffsetResult { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property OffsetResult As Double
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property double OffsetResult {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.ResultingUnit Property

Gets or Sets the ResultingUnit.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public UnitConfiguration ResultingUnit { get; set; }
<BrowsableAttribute(true)>
Public Property ResultingUnit As UnitConfiguration
    Get
    Set
public:
[BrowsableAttribute(true)]
property UnitConfiguration^ ResultingUnit {
    UnitConfiguration^ get ();
    void set (UnitConfiguration^ value);
}

Property Value

Type: UnitConfiguration
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.ScaleFactor Property

Gets or Sets the ScaleFactor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double ScaleFactor { get; set; }
<BrowsableAttribute(true)>
Public Property ScaleFactor As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double ScaleFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.ScaleResult Property

Gets or Sets the ScaleResult.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public double ScaleResult { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property ScaleResult As Double
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property double ScaleResult {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.ScopeClientChannel Property

Gets or Sets the ScopeClientChannel.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public ClientChannel ScopeClientChannel { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property ScopeClientChannel As ClientChannel
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property ClientChannel^ ScopeClientChannel {
    ClientChannel^ get ();
}

Property Value

Type: ClientChannel
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.ShortInfo Property

Gets or Sets the ShortInfo.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string ShortInfo { get; set; }
<BrowsableAttribute(false)>
Public Property ShortInfo As String
    Get
    Set
public:
[BrowsableAttribute(false)]
property String^ ShortInfo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.Usage Property

Gets or Sets the Usage.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public DataUsage Usage { get; set; }
<BrowsableAttribute(false)>
Public Property Usage As DataUsage
    Get
    Set
public:
[BrowsableAttribute(false)]
property DataUsage Usage {
    DataUsage get ();
    void set (DataUsage value);
}

Property Value

Type: DataUsage
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter Methods

The AcquisitionInterpreter type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copies Elments to this Container (Overrides MeasurementMemberBaseCopy(ListObject, Boolean, Int32).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets an Array of all possible Commands on this Element (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsedClientChannel | Return the used client channel
Public method | Highlight | Raises the Highlight event
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.Copy Method

Copies Elments to this Container

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void Copy(
    List<Object> Elements,
    bool UseOneParent = false,
    int SortPriority = -1
)
Public Overrides Sub Copy (
    Elements As List(Of Object),
    Optional UseOneParent As Boolean = false,
    Optional SortPriority As Integer = -1
)
public:
virtual void Copy(
    List<Object^>^ Elements,
    bool UseOneParent = false,
    int SortPriority = -1
) override

Parameters

Elements
Type: System.Collections.GenericList Object
A List of Elments
UseOneParent (Optional)
Type: SystemBoolean
Determiens wether all Properties should have the same Parent
SortPriority (Optional)
Type: SystemInt32
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.GetCommands Method

Gets an Array of all possible Commands on this Element

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.GetUsedClientChannel Method

Return the used client channel

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ClientChannel GetUsedClientChannel()
Public Function GetUsedClientChannel As ClientChannel
public:
ClientChannel^ GetUsedClientChannel()

Return Value

Type: ClientChannel
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.Highlight Method

Raises the Highlight event

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Highlight()
Public Sub Highlight
public:
virtual void Highlight() sealed
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.UpdatePropertyAttributes Method

Update Attributes of Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter Events

The AcquisitionInterpreter type exposes the following members.

Events
 | Name | Description
Public event | AcquisitionChanged | Fired when the Acquisition is changed.
Public event | AcquisitionGUIDChanged | Fired when the AcquisitionGUID is changed.
Public event | AcquisitionGUIDValidating | Fired while validating the new value for AcquisitionGUID.
Public event | AcquisitionValidating | Fired while validating the new value for Acquisition.
Public event | BeforeAcquisitionChanged | Fired before the Acquisition changed
Public event | BeforeAcquisitionGUIDChanged | Fired before the AcquisitionGUID changed
Public event | BitMaskChanged | Fired when the BitMask is changed.
Public event | BitMaskValidating | Fired while validating the new value for BitMask.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HideInHierarchyChanged | Fired when the HideInHierarchy is changed.
Public event | HideInHierarchyValidating | Fired while validating the new value for HideInHierarchy.
Public event | HighlightEvent | Fired to Highlight OverviewChannel
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OffsetChanged | Fired when the Offset is changed.
Public event | OffsetResultChanged | Fired when the OffsetResult is changed.
Public event | OffsetResultValidating | Fired while validating the new value for OffsetResult.
Public event | OffsetValidating | Fired while validating the new value for Offset.
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResultingUnitChanged | Fired when the ResultingUnit is changed.
Public event | ResultingUnitValidating | Fired while validating the new value for ResultingUnit.
Public event | ScaleFactorChanged | Fired when the ScaleFactor is changed.
Public event | ScaleFactorValidating | Fired while validating the new value for ScaleFactor.
Public event | ScaleResultChanged | Fired when the ScaleResult is changed.
Public event | ScaleResultValidating | Fired while validating the new value for ScaleResult.
Public event | ShortInfoChanged | Fired when the ShortInfo is changed.
Public event | ShortInfoValidating | Fired while validating the new value for ShortInfo.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UsageChanged | Fired when the Usage is changed.
Public event | UsageValidating | Fired while validating the new value for Usage.
Top
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.AcquisitionChanged Event

Fired when the Acquisition is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AcquisitionChanged
Public Event AcquisitionChanged As EventHandler
public:
 event EventHandler^ AcquisitionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.AcquisitionGUIDChanged Event

Fired when the AcquisitionGUID is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AcquisitionGUIDChanged
Public Event AcquisitionGUIDChanged As EventHandler
public:
 event EventHandler^ AcquisitionGUIDChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.AcquisitionGUIDValidating Event

Fired while validating the new value for AcquisitionGUID.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AcquisitionGUIDValidating
Public Event AcquisitionGUIDValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AcquisitionGUIDValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.AcquisitionValidating Event

Fired while validating the new value for Acquisition.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AcquisitionValidating
Public Event AcquisitionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AcquisitionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.BeforeAcquisitionChanged Event

Fired before the Acquisition changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeAcquisitionChanged
Public Event BeforeAcquisitionChanged As EventHandler
public:
 event EventHandler^ BeforeAcquisitionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.BeforeAcquisitionGUIDChanged Event

Fired before the AcquisitionGUID changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeAcquisitionGUIDChanged
Public Event BeforeAcquisitionGUIDChanged As EventHandler
public:
 event EventHandler^ BeforeAcquisitionGUIDChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.BitMaskChanged Event

Fired when the BitMask is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BitMaskChanged
Public Event BitMaskChanged As EventHandler
public:
 event EventHandler^ BitMaskChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.BitMaskValidating Event

Fired while validating the new value for BitMask.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> BitMaskValidating
Public Event BitMaskValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ BitMaskValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.HideInHierarchyChanged Event

Fired when the HideInHierarchy is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler HideInHierarchyChanged
Public Event HideInHierarchyChanged As EventHandler
public:
 event EventHandler^ HideInHierarchyChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.HideInHierarchyValidating Event

Fired while validating the new value for HideInHierarchy.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> HideInHierarchyValidating
Public Event HideInHierarchyValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ HideInHierarchyValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.HighlightEvent Event

Fired to Highlight OverviewChannel

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<HighlightEventArgs> HighlightEvent
Public Event HighlightEvent As EventHandler(Of HighlightEventArgs)
public:
 event EventHandler<HighlightEventArgs^>^ HighlightEvent {
    void add (EventHandler<HighlightEventArgs^>^ value);
    void remove (EventHandler<HighlightEventArgs^>^ value);
}

Value

Type: SystemEventHandler HighlightEventArgs
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.OffsetChanged Event

Fired when the Offset is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OffsetChanged
Public Event OffsetChanged As EventHandler
public:
 event EventHandler^ OffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.OffsetResultChanged Event

Fired when the OffsetResult is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OffsetResultChanged
Public Event OffsetResultChanged As EventHandler
public:
 event EventHandler^ OffsetResultChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.OffsetResultValidating Event

Fired while validating the new value for OffsetResult.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> OffsetResultValidating
Public Event OffsetResultValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ OffsetResultValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.OffsetValidating Event

Fired while validating the new value for Offset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> OffsetValidating
Public Event OffsetValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ OffsetValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.ResultingUnitChanged Event

Fired when the ResultingUnit is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ResultingUnitChanged
Public Event ResultingUnitChanged As EventHandler
public:
 event EventHandler^ ResultingUnitChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.ResultingUnitValidating Event

Fired while validating the new value for ResultingUnit.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ResultingUnitValidating
Public Event ResultingUnitValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ResultingUnitValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.ScaleFactorChanged Event

Fired when the ScaleFactor is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ScaleFactorChanged
Public Event ScaleFactorChanged As EventHandler
public:
 event EventHandler^ ScaleFactorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.ScaleFactorValidating Event

Fired while validating the new value for ScaleFactor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ScaleFactorValidating
Public Event ScaleFactorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ScaleFactorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.ScaleResultChanged Event

Fired when the ScaleResult is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ScaleResultChanged
Public Event ScaleResultChanged As EventHandler
public:
 event EventHandler^ ScaleResultChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.ScaleResultValidating Event

Fired while validating the new value for ScaleResult.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ScaleResultValidating
Public Event ScaleResultValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ScaleResultValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.ShortInfoChanged Event

Fired when the ShortInfo is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShortInfoChanged
Public Event ShortInfoChanged As EventHandler
public:
 event EventHandler^ ShortInfoChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.ShortInfoValidating Event

Fired while validating the new value for ShortInfo.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShortInfoValidating
Public Event ShortInfoValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShortInfoValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.UsageChanged Event

Fired when the Usage is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UsageChanged
Public Event UsageChanged As EventHandler
public:
 event EventHandler^ UsageChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionInterpreter Class


AcquisitionInterpreter.UsageValidating Event

Fired while validating the new value for Usage.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UsageValidating
Public Event UsageValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UsageValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionInterpreter Class


AcquisitionSequence Class

Sequence class which references another acquisition to collect data.
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisition
TwinCAT.Measurement.Scope.API.ModelSequence
TwinCAT.Measurement.Scope.API.ModelAcquisitionSequence

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class AcquisitionSequence : Sequence
Public Class AcquisitionSequence
    Inherits Sequence
public ref class AcquisitionSequence : public Sequence

The AcquisitionSequence type exposes the following members.

Constructors
 | Name | Description
Public method | AcquisitionSequence | Creates a new empty AcquisitionSequence object.
Public method | AcquisitionSequence(AcquisitionSequence) | Initialize Properties with values copied from other Acquisition
Top
Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | Data | Gets the Data of this acquisition. (Inherited from Sequence.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataFilePath | Gets or Sets the DataFilePath. (Inherited from Sequence.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | (Inherited from Sequence.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | ExportOptions | Gets or Sets the ExportOptions. (Inherited from Sequence.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LastEndTime | Gets or Sets the LastEndTime.
Public property | LastStartTime | Gets or Sets the LastStartTime.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | RefAmsNetId | Gets or Sets the RefAmsNetId.
Public property | RefDataType | Gets or Sets the RefDataType.
Public property | Reference | Gets or Sets the Reference.
Public property | ReferenceConnected | Gets or Sets the ReferenceConnected.
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | RefFilePath | Gets or Sets the RefFilePath.
Public property | RefFullName | Gets or Sets the RefFullName.
Public property | RefGuid | Gets or Sets the RefGuid.
Public property | RefLocalServer | Gets or Sets the RefLocalServer.
Public property | RefProtocoll | Gets or Sets the RefProtocoll.
Public property | RefSampleTime | Gets or Sets the RefSampleTime.
Public property | SampleCount | Gets or Sets the SampleCount. (Inherited from Sequence.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
Methods
 | Name | Description
Public method | AddData | Adds a list of samples to the end. (Inherited from Sequence.)
Public method | AddFromTimeRange | Orders samples from the reference and adds them to this acquistion.
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CopyData | (Overrides SequenceCopyData(Sequence).)
Public method | DeleteDataFiles | Deletes the data file(s) at the DataFilePath. (Inherited from Sequence.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportToAlyFile | (Inherited from Sequence.)
Public method | ExtendDataEnd | Adds samples to the end. (Overrides SequenceExtendDataEnd(Int64).)
Public method | ExtendDataEndTimeStamp | Orders samples from the reference and adds them to the end.
Public method | ExtendDataStart | Adds samples at the start. (Overrides SequenceExtendDataStart(Int64).)
Public method | ExtendDataStartTimeStamp | Orders samples from the reference and adds them to the start.
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllFileInfos | Get all files which are used in this sequence (Inherited from Sequence.)
Public method | GetAllFilePathes | Get all files which are used in this sequence (Inherited from Sequence.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAlyFilePath | (Inherited from Sequence.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | (Inherited from Sequence.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Inherited from Acquisition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Acquisition.)
Public method | GetIotType | (Inherited from Sequence.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTasPath | (Inherited from Sequence.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Get the data from the timestamp First Value = Timestamp == 0 (Inherited from Sequence.)
Public method | GetValueConverter | (Inherited from Sequence.)
Public method | HasSameTarget | (Inherited from Sequence.)
Public method | Import(IotFileSequenceData) | (Inherited from Sequence.)
Public method | Import(RefAcquisitionSequenceData) | (Inherited from Sequence.)
Public method | Import(SequenceDataSource) | (Inherited from Sequence.)
Public method | InsertData | Inserts a list of data at the given index. (Inherited from Sequence.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | LoadData | Trys to load the data from the DataFilePath. (Inherited from Sequence.)
Public method | LoadData(String) | (Inherited from Sequence.)
Public method | MaxEndIndex | Gets the largest possible end index relative to the current end. (Overrides SequenceMaxEndIndex.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MinStartIndex | Gets the smallest possible start index relative to the current start. (Overrides SequenceMinStartIndex.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | NewDataAlyFilePath | (Inherited from Sequence.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ReplaceData | Replaces a part of the data. (Inherited from Sequence.)
Public method | SaveData | Saves the data to the DataFilePath. The data is stored in the aly file format. (Inherited from Sequence.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | (Inherited from Sequence.)
Public method | TrimData | Removes data from the acquisition. (Inherited from Sequence.)
Public method | TrimDataEnd | Removes samples at the end. (Overrides SequenceTrimDataEnd(Int64).)
Public method | TrimDataStart | Removes samples from the start. (Overrides SequenceTrimDataStart(Int64).)
Public method | UpdatePropertyAttributes | (Inherited from Sequence.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | (Inherited from Sequence.)
Top
Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataFilePathChanged | Fired when the DataFilePath is changed. (Inherited from Sequence.)
Public event | DataFilePathValidating | Fired while validating the new value for DataFilePath. (Inherited from Sequence.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DataUpdated | Raised when data is added to Data. (Inherited from Sequence.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | ExportOptionsChanged | Fired when the ExportOptions is changed. (Inherited from Sequence.)
Public event | ExportOptionsValidating | Fired while validating the new value for ExportOptions. (Inherited from Sequence.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | LastEndTimeChanged | Fired when the LastEndTime is changed.
Public event | LastEndTimeValidating | Fired while validating the new value for LastEndTime.
Public event | LastStartTimeChanged | Fired when the LastStartTime is changed.
Public event | LastStartTimeValidating | Fired while validating the new value for LastStartTime.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | ReferenceChanged | Fired when the Reference is changed.
Public event | ReferenceValidating | Fired while validating the new value for Reference.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SampleCountChanged | Fired when the SampleCount is changed. (Inherited from Sequence.)
Public event | SampleCountValidating | Fired while validating the new value for SampleCount. (Inherited from Sequence.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


AcquisitionSequence Constructor

Overload List
 | Name | Description
Public method | AcquisitionSequence | Creates a new empty AcquisitionSequence object.
Public method | AcquisitionSequence(AcquisitionSequence) | Initialize Properties with values copied from other Acquisition
Top
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence Constructor

Creates a new empty AcquisitionSequence object.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AcquisitionSequence()
Public Sub New
public:
AcquisitionSequence()
See Also

Reference

AcquisitionSequence Class
AcquisitionSequence Overload


AcquisitionSequence Constructor (AcquisitionSequence)

Initialize Properties with values copied from other Acquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AcquisitionSequence(
    AcquisitionSequence acquisition
)
Public Sub New (
    acquisition As AcquisitionSequence
)
public:
AcquisitionSequence(
    AcquisitionSequence^ acquisition
)

Parameters

acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisitionSequence
Acquisition to copy from
See Also

Reference

AcquisitionSequence Class
AcquisitionSequence Overload


AcquisitionSequence Properties

The AcquisitionSequence type exposes the following members.

Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | Data | Gets the Data of this acquisition. (Inherited from Sequence.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataFilePath | Gets or Sets the DataFilePath. (Inherited from Sequence.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | (Inherited from Sequence.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | ExportOptions | Gets or Sets the ExportOptions. (Inherited from Sequence.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LastEndTime | Gets or Sets the LastEndTime.
Public property | LastStartTime | Gets or Sets the LastStartTime.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | RefAmsNetId | Gets or Sets the RefAmsNetId.
Public property | RefDataType | Gets or Sets the RefDataType.
Public property | Reference | Gets or Sets the Reference.
Public property | ReferenceConnected | Gets or Sets the ReferenceConnected.
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | RefFilePath | Gets or Sets the RefFilePath.
Public property | RefFullName | Gets or Sets the RefFullName.
Public property | RefGuid | Gets or Sets the RefGuid.
Public property | RefLocalServer | Gets or Sets the RefLocalServer.
Public property | RefProtocoll | Gets or Sets the RefProtocoll.
Public property | RefSampleTime | Gets or Sets the RefSampleTime.
Public property | SampleCount | Gets or Sets the SampleCount. (Inherited from Sequence.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.LastEndTime Property

Gets or Sets the LastEndTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long LastEndTime { get; set; }
<BrowsableAttribute(true)>
Public Property LastEndTime As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long LastEndTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.LastStartTime Property

Gets or Sets the LastStartTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long LastStartTime { get; set; }
<BrowsableAttribute(true)>
Public Property LastStartTime As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long LastStartTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.RefAmsNetId Property

Gets or Sets the RefAmsNetId.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public AmsNetId RefAmsNetId { get; set; }
<BrowsableAttribute(true)>
Public Property RefAmsNetId As AmsNetId
    Get
    Set
public:
[BrowsableAttribute(true)]
property AmsNetId^ RefAmsNetId {
    AmsNetId^ get ();
    void set (AmsNetId^ value);
}

Property Value

Type: AmsNetId
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.RefDataType Property

Gets or Sets the RefDataType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Scope2DataType RefDataType { get; set; }
<BrowsableAttribute(true)>
Public Property RefDataType As Scope2DataType
    Get
    Set
public:
[BrowsableAttribute(true)]
property Scope2DataType RefDataType {
    Scope2DataType get ();
    void set (Scope2DataType value);
}

Property Value

Type: Scope2DataType
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.Reference Property

Gets or Sets the Reference.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public Acquisition Reference { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property Reference As Acquisition
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property Acquisition^ Reference {
    Acquisition^ get ();
    void set (Acquisition^ value);
}

Property Value

Type: Acquisition
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.ReferenceConnected Property

Gets or Sets the ReferenceConnected.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
public bool ReferenceConnected { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(true)>
Public ReadOnly Property ReferenceConnected As Boolean
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
property bool ReferenceConnected {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.RefFilePath Property

Gets or Sets the RefFilePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string RefFilePath { get; set; }
<BrowsableAttribute(true)>
Public Property RefFilePath As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ RefFilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.RefFullName Property

Gets or Sets the RefFullName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string RefFullName { get; set; }
<BrowsableAttribute(true)>
Public Property RefFullName As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ RefFullName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.RefGuid Property

Gets or Sets the RefGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public Guid RefGuid { get; set; }
<BrowsableAttribute(false)>
Public Property RefGuid As Guid
    Get
    Set
public:
[BrowsableAttribute(false)]
property Guid RefGuid {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.RefLocalServer Property

Gets or Sets the RefLocalServer.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool RefLocalServer { get; set; }
<BrowsableAttribute(true)>
Public Property RefLocalServer As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool RefLocalServer {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.RefProtocoll Property

Gets or Sets the RefProtocoll.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public ProtocollType RefProtocoll { get; set; }
<BrowsableAttribute(true)>
Public Property RefProtocoll As ProtocollType
    Get
    Set
public:
[BrowsableAttribute(true)]
property ProtocollType RefProtocoll {
    ProtocollType get ();
    void set (ProtocollType value);
}

Property Value

Type: ProtocollType
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.RefSampleTime Property

Gets or Sets the RefSampleTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public uint RefSampleTime { get; set; }
<BrowsableAttribute(true)>
Public Property RefSampleTime As UInteger
    Get
    Set
public:
[BrowsableAttribute(true)]
property unsigned int RefSampleTime {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence Methods

The AcquisitionSequence type exposes the following members.

Methods
 | Name | Description
Public method | AddData | Adds a list of samples to the end. (Inherited from Sequence.)
Public method | AddFromTimeRange | Orders samples from the reference and adds them to this acquistion.
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CopyData | (Overrides SequenceCopyData(Sequence).)
Public method | DeleteDataFiles | Deletes the data file(s) at the DataFilePath. (Inherited from Sequence.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportToAlyFile | (Inherited from Sequence.)
Public method | ExtendDataEnd | Adds samples to the end. (Overrides SequenceExtendDataEnd(Int64).)
Public method | ExtendDataEndTimeStamp | Orders samples from the reference and adds them to the end.
Public method | ExtendDataStart | Adds samples at the start. (Overrides SequenceExtendDataStart(Int64).)
Public method | ExtendDataStartTimeStamp | Orders samples from the reference and adds them to the start.
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllFileInfos | Get all files which are used in this sequence (Inherited from Sequence.)
Public method | GetAllFilePathes | Get all files which are used in this sequence (Inherited from Sequence.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAlyFilePath | (Inherited from Sequence.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | (Inherited from Sequence.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Inherited from Acquisition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Acquisition.)
Public method | GetIotType | (Inherited from Sequence.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTasPath | (Inherited from Sequence.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Get the data from the timestamp First Value = Timestamp == 0 (Inherited from Sequence.)
Public method | GetValueConverter | (Inherited from Sequence.)
Public method | HasSameTarget | (Inherited from Sequence.)
Public method | Import(IotFileSequenceData) | (Inherited from Sequence.)
Public method | Import(RefAcquisitionSequenceData) | (Inherited from Sequence.)
Public method | Import(SequenceDataSource) | (Inherited from Sequence.)
Public method | InsertData | Inserts a list of data at the given index. (Inherited from Sequence.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | LoadData | Trys to load the data from the DataFilePath. (Inherited from Sequence.)
Public method | LoadData(String) | (Inherited from Sequence.)
Public method | MaxEndIndex | Gets the largest possible end index relative to the current end. (Overrides SequenceMaxEndIndex.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MinStartIndex | Gets the smallest possible start index relative to the current start. (Overrides SequenceMinStartIndex.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | NewDataAlyFilePath | (Inherited from Sequence.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ReplaceData | Replaces a part of the data. (Inherited from Sequence.)
Public method | SaveData | Saves the data to the DataFilePath. The data is stored in the aly file format. (Inherited from Sequence.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | (Inherited from Sequence.)
Public method | TrimData | Removes data from the acquisition. (Inherited from Sequence.)
Public method | TrimDataEnd | Removes samples at the end. (Overrides SequenceTrimDataEnd(Int64).)
Public method | TrimDataStart | Removes samples from the start. (Overrides SequenceTrimDataStart(Int64).)
Public method | UpdatePropertyAttributes | (Inherited from Sequence.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | (Inherited from Sequence.)
Top
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.AddFromTimeRange Method

Orders samples from the reference and adds them to this acquistion.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void AddFromTimeRange(
    long start,
    long end
)
Public Sub AddFromTimeRange (
    start As Long,
    end As Long
)
public:
void AddFromTimeRange(
    long long start,
    long long end
)

Parameters

start
Type: SystemInt64
Ordrer start timestamp.
end
Type: SystemInt64
Order end timestamp.
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.CopyData Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void CopyData(
    Sequence acquisition
)
Public Overrides Sub CopyData (
    acquisition As Sequence
)
public:
virtual void CopyData(
    Sequence^ acquisition
) override

Parameters

acquisition
Type: TwinCAT.Measurement.Scope.API.ModelSequence
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.ExtendDataEnd Method

Adds samples to the end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void ExtendDataEnd(
    long numSamples
)
Public Overrides Sub ExtendDataEnd (
    numSamples As Long
)
public:
virtual void ExtendDataEnd(
    long long numSamples
) override

Parameters

numSamples
Type: SystemInt64
The number of samples to add.
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.ExtendDataEndTimeStamp Method

Orders samples from the reference and adds them to the end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void ExtendDataEndTimeStamp(
    long to
)
Public Sub ExtendDataEndTimeStamp (
    to As Long
)
public:
void ExtendDataEndTimeStamp(
    long long to
)

Parameters

to
Type: SystemInt64
Samples are ordered between the LastEndTime timestamp and this parameter.
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.ExtendDataStart Method

Adds samples at the start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void ExtendDataStart(
    long numSamples
)
Public Overrides Sub ExtendDataStart (
    numSamples As Long
)
public:
virtual void ExtendDataStart(
    long long numSamples
) override

Parameters

numSamples
Type: SystemInt64
The number of samples to add.
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.ExtendDataStartTimeStamp Method

Orders samples from the reference and adds them to the start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void ExtendDataStartTimeStamp(
    long to
)
Public Sub ExtendDataStartTimeStamp (
    to As Long
)
public:
void ExtendDataStartTimeStamp(
    long long to
)

Parameters

to
Type: SystemInt64
Samples are ordered between the LastStartTime timestamp and this parameter.
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.MaxEndIndex Method

Gets the largest possible end index relative to the current end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override double MaxEndIndex()
Public Overrides Function MaxEndIndex As Double
public:
virtual double MaxEndIndex() override

Return Value

Type: Double
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.MinStartIndex Method

Gets the smallest possible start index relative to the current start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override double MinStartIndex()
Public Overrides Function MinStartIndex As Double
public:
virtual double MinStartIndex() override

Return Value

Type: Double
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.TrimDataEnd Method

Removes samples at the end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void TrimDataEnd(
    long numSamples
)
Public Overrides Sub TrimDataEnd (
    numSamples As Long
)
public:
virtual void TrimDataEnd(
    long long numSamples
) override

Parameters

numSamples
Type: SystemInt64
The number of samples to remove.
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.TrimDataStart Method

Removes samples from the start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void TrimDataStart(
    long numSamples
)
Public Overrides Sub TrimDataStart (
    numSamples As Long
)
public:
virtual void TrimDataStart(
    long long numSamples
) override

Parameters

numSamples
Type: SystemInt64
The number of samples to remove.
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence Events

The AcquisitionSequence type exposes the following members.

Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataFilePathChanged | Fired when the DataFilePath is changed. (Inherited from Sequence.)
Public event | DataFilePathValidating | Fired while validating the new value for DataFilePath. (Inherited from Sequence.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DataUpdated | Raised when data is added to Data. (Inherited from Sequence.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | ExportOptionsChanged | Fired when the ExportOptions is changed. (Inherited from Sequence.)
Public event | ExportOptionsValidating | Fired while validating the new value for ExportOptions. (Inherited from Sequence.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | LastEndTimeChanged | Fired when the LastEndTime is changed.
Public event | LastEndTimeValidating | Fired while validating the new value for LastEndTime.
Public event | LastStartTimeChanged | Fired when the LastStartTime is changed.
Public event | LastStartTimeValidating | Fired while validating the new value for LastStartTime.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | ReferenceChanged | Fired when the Reference is changed.
Public event | ReferenceValidating | Fired while validating the new value for Reference.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SampleCountChanged | Fired when the SampleCount is changed. (Inherited from Sequence.)
Public event | SampleCountValidating | Fired while validating the new value for SampleCount. (Inherited from Sequence.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.LastEndTimeChanged Event

Fired when the LastEndTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LastEndTimeChanged
Public Event LastEndTimeChanged As EventHandler
public:
 event EventHandler^ LastEndTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.LastEndTimeValidating Event

Fired while validating the new value for LastEndTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LastEndTimeValidating
Public Event LastEndTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LastEndTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.LastStartTimeChanged Event

Fired when the LastStartTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LastStartTimeChanged
Public Event LastStartTimeChanged As EventHandler
public:
 event EventHandler^ LastStartTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.LastStartTimeValidating Event

Fired while validating the new value for LastStartTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LastStartTimeValidating
Public Event LastStartTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LastStartTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.ReferenceChanged Event

Fired when the Reference is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReferenceChanged
Public Event ReferenceChanged As EventHandler
public:
 event EventHandler^ ReferenceChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence.ReferenceValidating Event

Fired while validating the new value for Reference.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReferenceValidating
Public Event ReferenceValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReferenceValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AcquisitionSequence Class


AcquisitionSequence Fields

The AcquisitionSequence type exposes the following members.

Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

AcquisitionSequence Class


AdsAcquisition Class

Acquisition Class to order Data via ADS
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisition
TwinCAT.Measurement.Scope.API.ModelAdsAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class AdsAcquisition : Acquisition
Public Class AdsAcquisition
    Inherits Acquisition
public ref class AdsAcquisition : public Acquisition

The AdsAcquisition type exposes the following members.

Constructors
 | Name | Description
Public method | AdsAcquisition | Creates a new Empty AdsAcquisition
Public method | AdsAcquisition(SymbolAcquisitionInfo) | Create a new AdsAcquisition with SymbolAcquisitionInfo Data
Public method | AdsAcquisition(AdsAcquisition) | Creates a new ADsAcquisition and copy Properties from other AdsAcquisition
Top
Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName. (Overrides AcquisitionDescription.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IndexGroup | Gets or Sets the IndexGroup.
Public property | IndexOffset | Gets or Sets the IndexOffset.
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SymbolBased | Gets or Sets the SymbolBased.
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | TargetPort | Gets or Sets the TargetPort.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Overrides AcquisitionGetFullName.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AcquisitionGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides AcquisitionHasSameTarget(Acquisition).)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RefreshSymbolInfo | Refreshes the SymbolInfo
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IndexGroupChanged | Fired when the IndexGroup is changed.
Public event | IndexGroupValidating | Fired while validating the new value for IndexGroup.
Public event | IndexOffsetChanged | Fired when the IndexOffset is changed.
Public event | IndexOffsetValidating | Fired while validating the new value for IndexOffset.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SymbolBasedChanged | Fired when the SymbolBased is changed.
Public event | SymbolBasedValidating | Fired while validating the new value for SymbolBased.
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | TargetPortChanged | Fired when the TargetPort is changed.
Public event | TargetPortValidating | Fired while validating the new value for TargetPort.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


AdsAcquisition Constructor

Overload List
 | Name | Description
Public method | AdsAcquisition | Creates a new Empty AdsAcquisition
Public method | AdsAcquisition(SymbolAcquisitionInfo) | Create a new AdsAcquisition with SymbolAcquisitionInfo Data
Public method | AdsAcquisition(AdsAcquisition) | Creates a new ADsAcquisition and copy Properties from other AdsAcquisition
Top
See Also

Reference

AdsAcquisition Class


AdsAcquisition Constructor

Creates a new Empty AdsAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AdsAcquisition()
Public Sub New
public:
AdsAcquisition()
See Also

Reference

AdsAcquisition Class
AdsAcquisition Overload


AdsAcquisition Constructor (SymbolAcquisitionInfo)

Create a new AdsAcquisition with SymbolAcquisitionInfo Data

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AdsAcquisition(
    SymbolAcquisitionInfo symbolInfo
)
Public Sub New (
    symbolInfo As SymbolAcquisitionInfo
)
public:
AdsAcquisition(
    SymbolAcquisitionInfo^ symbolInfo
)

Parameters

symbolInfo
Type: SymbolAcquisitionInfo
See Also

Reference

AdsAcquisition Class
AdsAcquisition Overload


AdsAcquisition Constructor (AdsAcquisition)

Creates a new ADsAcquisition and copy Properties from other AdsAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AdsAcquisition(
    AdsAcquisition adsAcq
)
Public Sub New (
    adsAcq As AdsAcquisition
)
public:
AdsAcquisition(
    AdsAcquisition^ adsAcq
)

Parameters

adsAcq
Type: TwinCAT.Measurement.Scope.API.ModelAdsAcquisition
AdsAcquisition to Copy from
See Also

Reference

AdsAcquisition Class
AdsAcquisition Overload


AdsAcquisition Properties

The AdsAcquisition type exposes the following members.

Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName. (Overrides AcquisitionDescription.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IndexGroup | Gets or Sets the IndexGroup.
Public property | IndexOffset | Gets or Sets the IndexOffset.
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SymbolBased | Gets or Sets the SymbolBased.
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | TargetPort | Gets or Sets the TargetPort.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

AdsAcquisition Class


AdsAcquisition.Description Property

A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override ChannelDescription Description { get; }
Public Overrides ReadOnly Property Description As ChannelDescription
    Get
public:
virtual property ChannelDescription^ Description {
    ChannelDescription^ get () override;
}

Property Value

Type: ChannelDescription
See Also

Reference

AdsAcquisition Class


AdsAcquisition.IndexGroup Property

Gets or Sets the IndexGroup.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public uint IndexGroup { get; set; }
<BrowsableAttribute(true)>
Public Property IndexGroup As UInteger
    Get
    Set
public:
[BrowsableAttribute(true)]
property unsigned int IndexGroup {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

AdsAcquisition Class


AdsAcquisition.IndexOffset Property

Gets or Sets the IndexOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public uint IndexOffset { get; set; }
<BrowsableAttribute(true)>
Public Property IndexOffset As UInteger
    Get
    Set
public:
[BrowsableAttribute(true)]
property unsigned int IndexOffset {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

AdsAcquisition Class


AdsAcquisition.SymbolBased Property

Gets or Sets the SymbolBased.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool SymbolBased { get; set; }
<BrowsableAttribute(true)>
Public Property SymbolBased As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool SymbolBased {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AdsAcquisition Class


AdsAcquisition.SymbolName Property

Gets or Sets the SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string SymbolName { get; set; }
<BrowsableAttribute(true)>
Public Property SymbolName As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ SymbolName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AdsAcquisition Class


AdsAcquisition.TargetPort Property

Gets or Sets the TargetPort.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int TargetPort { get; set; }
<BrowsableAttribute(true)>
Public Property TargetPort As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int TargetPort {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AdsAcquisition Class


AdsAcquisition Methods

The AdsAcquisition type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Overrides AcquisitionGetFullName.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AcquisitionGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides AcquisitionHasSameTarget(Acquisition).)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RefreshSymbolInfo | Refreshes the SymbolInfo
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AdsAcquisition Class


AdsAcquisition.GetFullName Method

Gets the complete identifier of this acqusition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string GetFullName()
Public Overrides Function GetFullName As String
public:
virtual String^ GetFullName() override

Return Value

Type: String
The full name
See Also

Reference

AdsAcquisition Class


AdsAcquisition.GetHashCode Method

Serves as a hash function for a particular type.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

AdsAcquisition Class


AdsAcquisition.HasSameTarget Method

Determines wether the two Acquisition will acquire the same Data

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool HasSameTarget(
    Acquisition Acquisition
)
Public Overrides Function HasSameTarget (
    Acquisition As Acquisition
) As Boolean
public:
virtual bool HasSameTarget(
    Acquisition^ Acquisition
) override

Parameters

Acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
The Acquisition to compare with

Return Value

Type: Boolean
True if the Acquisitions have the Same Target
See Also

Reference

AdsAcquisition Class


AdsAcquisition.RefreshSymbolInfo Method

Refreshes the SymbolInfo

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void RefreshSymbolInfo()
Public Sub RefreshSymbolInfo
public:
void RefreshSymbolInfo()
See Also

Reference

AdsAcquisition Class


AdsAcquisition.UpdatePropertyAttributes Method

Sets the value off Propertyattributes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

AdsAcquisition Class


AdsAcquisition Events

The AdsAcquisition type exposes the following members.

Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IndexGroupChanged | Fired when the IndexGroup is changed.
Public event | IndexGroupValidating | Fired while validating the new value for IndexGroup.
Public event | IndexOffsetChanged | Fired when the IndexOffset is changed.
Public event | IndexOffsetValidating | Fired while validating the new value for IndexOffset.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SymbolBasedChanged | Fired when the SymbolBased is changed.
Public event | SymbolBasedValidating | Fired while validating the new value for SymbolBased.
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | TargetPortChanged | Fired when the TargetPort is changed.
Public event | TargetPortValidating | Fired while validating the new value for TargetPort.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

AdsAcquisition Class


AdsAcquisition.IndexGroupChanged Event

Fired when the IndexGroup is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IndexGroupChanged
Public Event IndexGroupChanged As EventHandler
public:
 event EventHandler^ IndexGroupChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AdsAcquisition Class


AdsAcquisition.IndexGroupValidating Event

Fired while validating the new value for IndexGroup.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IndexGroupValidating
Public Event IndexGroupValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IndexGroupValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AdsAcquisition Class


AdsAcquisition.IndexOffsetChanged Event

Fired when the IndexOffset is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IndexOffsetChanged
Public Event IndexOffsetChanged As EventHandler
public:
 event EventHandler^ IndexOffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AdsAcquisition Class


AdsAcquisition.IndexOffsetValidating Event

Fired while validating the new value for IndexOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IndexOffsetValidating
Public Event IndexOffsetValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IndexOffsetValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AdsAcquisition Class


AdsAcquisition.SymbolBasedChanged Event

Fired when the SymbolBased is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SymbolBasedChanged
Public Event SymbolBasedChanged As EventHandler
public:
 event EventHandler^ SymbolBasedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AdsAcquisition Class


AdsAcquisition.SymbolBasedValidating Event

Fired while validating the new value for SymbolBased.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SymbolBasedValidating
Public Event SymbolBasedValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SymbolBasedValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AdsAcquisition Class


AdsAcquisition.SymbolNameChanged Event

Fired when the SymbolName is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SymbolNameChanged
Public Event SymbolNameChanged As EventHandler
public:
 event EventHandler^ SymbolNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AdsAcquisition Class


AdsAcquisition.SymbolNameValidating Event

Fired while validating the new value for SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SymbolNameValidating
Public Event SymbolNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SymbolNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AdsAcquisition Class


AdsAcquisition.TargetPortChanged Event

Fired when the TargetPort is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TargetPortChanged
Public Event TargetPortChanged As EventHandler
public:
 event EventHandler^ TargetPortChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AdsAcquisition Class


AdsAcquisition.TargetPortValidating Event

Fired while validating the new value for TargetPort.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TargetPortValidating
Public Event TargetPortValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TargetPortValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AdsAcquisition Class


AdsAcquisition Fields

The AdsAcquisition type exposes the following members.

Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

AdsAcquisition Class


AnchorTimeBase Class

Base class of member which contains an anchor timestamp
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAnchorTimeBase
TwinCAT.Measurement.Scope.API.ModelChart
TwinCAT.Measurement.Scope.API.ModelRepeatDataCollector

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class AnchorTimeBase : ScopeMemberContainerBase
Public MustInherit Class AnchorTimeBase
    Inherits ScopeMemberContainerBase
public ref class AnchorTimeBase abstract : public ScopeMemberContainerBase

The AnchorTimeBase type exposes the following members.

Constructors
 | Name | Description
Public method | AnchorTimeBase | Creates a new member of AnchorTimeBase
Public method | AnchorTimeBase(AnchorTimeBase) | Creates a new member of AnchorTimeBase and copy properties
Top
Properties
 | Name | Description
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember.
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset.
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed.
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp.
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed.
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed.
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid.
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed.
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed.
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset.
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed.
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed.
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


AnchorTimeBase Constructor

Overload List
 | Name | Description
Public method | AnchorTimeBase | Creates a new member of AnchorTimeBase
Public method | AnchorTimeBase(AnchorTimeBase) | Creates a new member of AnchorTimeBase and copy properties
Top
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase Constructor

Creates a new member of AnchorTimeBase

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AnchorTimeBase()
Public Sub New
public:
AnchorTimeBase()
See Also

Reference

AnchorTimeBase Class
AnchorTimeBase Overload


AnchorTimeBase Constructor (AnchorTimeBase)

Creates a new member of AnchorTimeBase and copy properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AnchorTimeBase(
    AnchorTimeBase anchorTimeBase
)
Public Sub New (
    anchorTimeBase As AnchorTimeBase
)
public:
AnchorTimeBase(
    AnchorTimeBase^ anchorTimeBase
)

Parameters

anchorTimeBase
Type: TwinCAT.Measurement.Scope.API.ModelAnchorTimeBase
Copy properties from this
See Also

Reference

AnchorTimeBase Class
AnchorTimeBase Overload


AnchorTimeBase Properties

The AnchorTimeBase type exposes the following members.

Properties
 | Name | Description
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember.
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset.
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.AnchorTimestamp Property

Gets or Sets the AnchorTimestamp.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public long AnchorTimestamp { get; set; }
<BrowsableAttribute(false)>
Public Property AnchorTimestamp As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
property long long AnchorTimestamp {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.ConnectedTimeMember Property

Gets or Sets the ConnectedTimeMember.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public MeasurementMemberBase ConnectedTimeMember { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property ConnectedTimeMember As MeasurementMemberBase
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property MeasurementMemberBase^ ConnectedTimeMember {
    MeasurementMemberBase^ get ();
    void set (MeasurementMemberBase^ value);
}

Property Value

Type: MeasurementMemberBase
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.ConnectedTimeMemberGuid Property

Gets or Sets the ConnectedTimeMemberGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public Guid ConnectedTimeMemberGuid { get; set; }
<BrowsableAttribute(false)>
Public Property ConnectedTimeMemberGuid As Guid
    Get
    Set
public:
[BrowsableAttribute(false)]
property Guid ConnectedTimeMemberGuid {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.DurationLength Property

Gets or Sets the DurationLength.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public long DurationLength { get; set; }
<BrowsableAttribute(false)>
Public Property DurationLength As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
property long long DurationLength {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.TimeOffset Property

Gets or Sets the TimeOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public long TimeOffset { get; set; }
<BrowsableAttribute(false)>
Public Property TimeOffset As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
property long long TimeOffset {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.TimeRefreshMode Property

Gets or Sets the TimeRefreshMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public TimeRefreshMode TimeRefreshMode { get; set; }
<BrowsableAttribute(false)>
Public Property TimeRefreshMode As TimeRefreshMode
    Get
    Set
public:
[BrowsableAttribute(false)]
property TimeRefreshMode TimeRefreshMode {
    TimeRefreshMode get ();
    void set (TimeRefreshMode value);
}

Property Value

Type: TimeRefreshMode
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.TriggerGroupOffset Property

Gets or Sets the TriggerGroupOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public int TriggerGroupOffset { get; set; }
<BrowsableAttribute(false)>
Public Property TriggerGroupOffset As Integer
    Get
    Set
public:
[BrowsableAttribute(false)]
property int TriggerGroupOffset {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase Methods

The AnchorTimeBase type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase Events

The AnchorTimeBase type exposes the following members.

Events
 | Name | Description
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed.
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp.
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed.
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed.
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid.
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed.
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed.
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset.
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed.
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed.
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.AnchorTimestampChanged Event

Fired when the AnchorTimestamp is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AnchorTimestampChanged
Public Event AnchorTimestampChanged As EventHandler
public:
 event EventHandler^ AnchorTimestampChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.AnchorTimestampValidating Event

Fired while validating the new value for AnchorTimestamp.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AnchorTimestampValidating
Public Event AnchorTimestampValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AnchorTimestampValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.BeforeConnectedTimeMemberChanged Event

Fired before the connected timemember changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeConnectedTimeMemberChanged
Public Event BeforeConnectedTimeMemberChanged As EventHandler
public:
 event EventHandler^ BeforeConnectedTimeMemberChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.ConnectedTimeMemberChanged Event

Fired when the ConnectedTimeMember is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ConnectedTimeMemberChanged
Public Event ConnectedTimeMemberChanged As EventHandler
public:
 event EventHandler^ ConnectedTimeMemberChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.ConnectedTimeMemberGuidChanged Event

Fired when the ConnectedTimeMemberGuid is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ConnectedTimeMemberGuidChanged
Public Event ConnectedTimeMemberGuidChanged As EventHandler
public:
 event EventHandler^ ConnectedTimeMemberGuidChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.ConnectedTimeMemberGuidValidating Event

Fired while validating the new value for ConnectedTimeMemberGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ConnectedTimeMemberGuidValidating
Public Event ConnectedTimeMemberGuidValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ConnectedTimeMemberGuidValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.ConnectedTimeMemberValidating Event

Fired while validating the new value for ConnectedTimeMember.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ConnectedTimeMemberValidating
Public Event ConnectedTimeMemberValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ConnectedTimeMemberValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.DurationLengthChanged Event

Fired when the DurationLength is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DurationLengthChanged
Public Event DurationLengthChanged As EventHandler
public:
 event EventHandler^ DurationLengthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.DurationLengthValidating Event

Fired while validating the new value for DurationLength.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DurationLengthValidating
Public Event DurationLengthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DurationLengthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.TimeOffsetChanged Event

Fired when the TimeOffset is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TimeOffsetChanged
Public Event TimeOffsetChanged As EventHandler
public:
 event EventHandler^ TimeOffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.TimeOffsetValidating Event

Fired while validating the new value for TimeOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TimeOffsetValidating
Public Event TimeOffsetValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TimeOffsetValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.TimeRefreshModeChanged Event

Fired when the TimeRefreshMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TimeRefreshModeChanged
Public Event TimeRefreshModeChanged As EventHandler
public:
 event EventHandler^ TimeRefreshModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.TimeRefreshModeValidating Event

Fired while validating the new value for TimeRefreshMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TimeRefreshModeValidating
Public Event TimeRefreshModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TimeRefreshModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.TriggerGroupOffsetChanged Event

Fired when the TriggerGroupOffset is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TriggerGroupOffsetChanged
Public Event TriggerGroupOffsetChanged As EventHandler
public:
 event EventHandler^ TriggerGroupOffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AnchorTimeBase Class


AnchorTimeBase.TriggerGroupOffsetValidating Event

Fired while validating the new value for TriggerGroupOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TriggerGroupOffsetValidating
Public Event TriggerGroupOffsetValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TriggerGroupOffsetValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AnchorTimeBase Class


AngularShape Class

Represents the angular scope shapes
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeShape
TwinCAT.Measurement.Scope.API.ModelAngularShape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class AngularShape : ScopeShape
Public Class AngularShape
    Inherits ScopeShape
public ref class AngularShape : public ScopeShape

The AngularShape type exposes the following members.

Constructors
 | Name | Description
Public method | AngularShape | Creates a new instance of AngularShape
Public method | AngularShape(AngularShape) | Creates a new instance of AngularShape and copy content from angularShape
Top
Properties
 | Name | Description
Public property | ClosedShape | Gets or Sets the ClosedShape.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from ScopeShape.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Points | Obsolete. Gets or Sets the Points.
Public property | PointsString | Get or Set the String Value of Points
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShapePoints | Gets the ShapePoints (Overrides ScopeShapeShapePoints.)
Public property | ShapePointsValue | Get or Set the ShapePointsValue
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | Gets a underlying Style Object (Inherited from ScopeShape.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | XOffset | Gets or Sets the XOffset.
Public property | XScalefactor | Gets or Sets the XScalefactor.
Public property | YOffset | Gets or Sets the YOffset.
Public property | YScalefactor | Gets or Sets the YScalefactor.
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | Highlight the Shape (Inherited from ScopeShape.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | Save | Saves this Shape to a file (Inherited from ScopeShape.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Overrides ScopeShapeUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ClosedShapeChanged | Fired when the ClosedShape is changed.
Public event | ClosedShapeValidating | Fired while validating the new value for ClosedShape.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | Hightlight | Raise to highlight the shape (Inherited from ScopeShape.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPoints | Raise to refresh the points in the view (Inherited from ScopeShape.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | XOffsetChanged | Fired when the XOffset is changed.
Public event | XOffsetValidating | Fired while validating the new value for XOffset.
Public event | XScalefactorChanged | Fired when the XScalefactor is changed.
Public event | XScalefactorValidating | Fired while validating the new value for XScalefactor.
Public event | YOffsetChanged | Fired when the YOffset is changed.
Public event | YOffsetValidating | Fired while validating the new value for YOffset.
Public event | YScalefactorChanged | Fired when the YScalefactor is changed.
Public event | YScalefactorValidating | Fired while validating the new value for YScalefactor.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


AngularShape Constructor

Overload List
 | Name | Description
Public method | AngularShape | Creates a new instance of AngularShape
Public method | AngularShape(AngularShape) | Creates a new instance of AngularShape and copy content from angularShape
Top
See Also

Reference

AngularShape Class


AngularShape Constructor

Creates a new instance of AngularShape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AngularShape()
Public Sub New
public:
AngularShape()
See Also

Reference

AngularShape Class
AngularShape Overload


AngularShape Constructor (AngularShape)

Creates a new instance of AngularShape and copy content from angularShape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AngularShape(
    AngularShape angularShape
)
Public Sub New (
    angularShape As AngularShape
)
public:
AngularShape(
    AngularShape^ angularShape
)

Parameters

angularShape
Type: TwinCAT.Measurement.Scope.API.ModelAngularShape
See Also

Reference

AngularShape Class
AngularShape Overload


AngularShape Properties

The AngularShape type exposes the following members.

Properties
 | Name | Description
Public property | ClosedShape | Gets or Sets the ClosedShape.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from ScopeShape.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Points | Obsolete. Gets or Sets the Points.
Public property | PointsString | Get or Set the String Value of Points
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShapePoints | Gets the ShapePoints (Overrides ScopeShapeShapePoints.)
Public property | ShapePointsValue | Get or Set the ShapePointsValue
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | Gets a underlying Style Object (Inherited from ScopeShape.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | XOffset | Gets or Sets the XOffset.
Public property | XScalefactor | Gets or Sets the XScalefactor.
Public property | YOffset | Gets or Sets the YOffset.
Public property | YScalefactor | Gets or Sets the YScalefactor.
Top
See Also

Reference

AngularShape Class


AngularShape.ClosedShape Property

Gets or Sets the ClosedShape.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ClosedShape { get; set; }
<BrowsableAttribute(true)>
Public Property ClosedShape As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ClosedShape {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AngularShape Class


AngularShape.Points Property

Note: This API is now obsolete.

Gets or Sets the Points.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
[ObsoleteAttribute]
public List<double[]> Points { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
<ObsoleteAttribute>
Public Property Points As List(Of Double())
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
[ObsoleteAttribute]
property List<array<double>^>^ Points {
    List<array<double>^>^ get ();
    void set (List<array<double>^>^ value);
}

Property Value

Type: List Double
See Also

Reference

AngularShape Class


AngularShape.PointsString Property

Get or Set the String Value of Points

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public string PointsString { get; set; }
<BrowsableAttribute(false)>
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Property PointsString As String
    Get
    Set
public:
[BrowsableAttribute(false)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
property String^ PointsString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AngularShape Class


AngularShape.ShapePoints Property

Gets the ShapePoints

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override ReadOnlyCollection<double[]> ShapePoints { get; }
Public Overrides ReadOnly Property ShapePoints As ReadOnlyCollection(Of Double())
    Get
public:
virtual property ReadOnlyCollection<array<double>^>^ ShapePoints {
    ReadOnlyCollection<array<double>^>^ get () override;
}

Property Value

Type: ReadOnlyCollection Double
See Also

Reference

AngularShape Class


AngularShape.ShapePointsValue Property

Get or Set the ShapePointsValue

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
public PointsCollection ShapePointsValue { get; set; }
<XmlIgnoreAttribute>
Public Property ShapePointsValue As PointsCollection
    Get
    Set
public:
[XmlIgnoreAttribute]
property PointsCollection^ ShapePointsValue {
    PointsCollection^ get ();
    void set (PointsCollection^ value);
}

Property Value

Type: PointsCollection
See Also

Reference

AngularShape Class


AngularShape.XOffset Property

Gets or Sets the XOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double XOffset { get; set; }
<BrowsableAttribute(true)>
Public Property XOffset As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double XOffset {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AngularShape Class


AngularShape.XScalefactor Property

Gets or Sets the XScalefactor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double XScalefactor { get; set; }
<BrowsableAttribute(true)>
Public Property XScalefactor As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double XScalefactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AngularShape Class


AngularShape.YOffset Property

Gets or Sets the YOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double YOffset { get; set; }
<BrowsableAttribute(true)>
Public Property YOffset As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double YOffset {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AngularShape Class


AngularShape.YScalefactor Property

Gets or Sets the YScalefactor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double YScalefactor { get; set; }
<BrowsableAttribute(true)>
Public Property YScalefactor As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double YScalefactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AngularShape Class


AngularShape Methods

The AngularShape type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | Highlight the Shape (Inherited from ScopeShape.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | Save | Saves this Shape to a file (Inherited from ScopeShape.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Overrides ScopeShapeUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AngularShape Class


AngularShape.UpdatePropertyAttributes Method

Update Attributes of Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

AngularShape Class


AngularShape Events

The AngularShape type exposes the following members.

Events
 | Name | Description
Public event | ClosedShapeChanged | Fired when the ClosedShape is changed.
Public event | ClosedShapeValidating | Fired while validating the new value for ClosedShape.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | Hightlight | Raise to highlight the shape (Inherited from ScopeShape.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPoints | Raise to refresh the points in the view (Inherited from ScopeShape.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | XOffsetChanged | Fired when the XOffset is changed.
Public event | XOffsetValidating | Fired while validating the new value for XOffset.
Public event | XScalefactorChanged | Fired when the XScalefactor is changed.
Public event | XScalefactorValidating | Fired while validating the new value for XScalefactor.
Public event | YOffsetChanged | Fired when the YOffset is changed.
Public event | YOffsetValidating | Fired while validating the new value for YOffset.
Public event | YScalefactorChanged | Fired when the YScalefactor is changed.
Public event | YScalefactorValidating | Fired while validating the new value for YScalefactor.
Top
See Also

Reference

AngularShape Class


AngularShape.ClosedShapeChanged Event

Fired when the ClosedShape is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ClosedShapeChanged
Public Event ClosedShapeChanged As EventHandler
public:
 event EventHandler^ ClosedShapeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AngularShape Class


AngularShape.ClosedShapeValidating Event

Fired while validating the new value for ClosedShape.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ClosedShapeValidating
Public Event ClosedShapeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ClosedShapeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AngularShape Class


AngularShape.XOffsetChanged Event

Fired when the XOffset is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler XOffsetChanged
Public Event XOffsetChanged As EventHandler
public:
 event EventHandler^ XOffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AngularShape Class


AngularShape.XOffsetValidating Event

Fired while validating the new value for XOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> XOffsetValidating
Public Event XOffsetValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ XOffsetValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AngularShape Class


AngularShape.XScalefactorChanged Event

Fired when the XScalefactor is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler XScalefactorChanged
Public Event XScalefactorChanged As EventHandler
public:
 event EventHandler^ XScalefactorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AngularShape Class


AngularShape.XScalefactorValidating Event

Fired while validating the new value for XScalefactor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> XScalefactorValidating
Public Event XScalefactorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ XScalefactorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AngularShape Class


AngularShape.YOffsetChanged Event

Fired when the YOffset is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler YOffsetChanged
Public Event YOffsetChanged As EventHandler
public:
 event EventHandler^ YOffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AngularShape Class


AngularShape.YOffsetValidating Event

Fired while validating the new value for YOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> YOffsetValidating
Public Event YOffsetValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ YOffsetValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AngularShape Class


AngularShape.YScalefactorChanged Event

Fired when the YScalefactor is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler YScalefactorChanged
Public Event YScalefactorChanged As EventHandler
public:
 event EventHandler^ YScalefactorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AngularShape Class


AngularShape.YScalefactorValidating Event

Fired while validating the new value for YScalefactor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> YScalefactorValidating
Public Event YScalefactorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ YScalefactorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AngularShape Class


AreaCondition Class

Condition with a MinValue and a MaxValue
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelCondition
TwinCAT.Measurement.Scope.API.ModelAreaCondition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class AreaCondition : Condition
Public Class AreaCondition
    Inherits Condition
public ref class AreaCondition : public Condition

The AreaCondition type exposes the following members.

Constructors
 | Name | Description
Public method | AreaCondition | Create a new AreaCondition
Public method | AreaCondition(AreaCondition) | Create a new AreaCondition by copying Properties
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Condition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | InterpreterGUID | Gets or Sets the InterpreterGUID. (Inherited from Condition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LowerLimit | Gets or Sets the LowerLimit.
Public property | LowerOperator | Gets or Sets the LowerOperator.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReferenceAcquisitionInterpreter | Gets or Sets the ReferenceAcquisitionInterpreter. (Inherited from Condition.)
Public property | ReusedAcquisitionOrInterpreter | Gets or Sets the ReusedAcquisitionOrInterpreter. (Inherited from Condition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UpperLimit | Gets or Sets the UpperLimit.
Public property | UpperOperator | Gets or Sets the UpperOperator.
Public property | UseChannelData | Gets or Sets the UseChannelData. (Inherited from Condition.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Commands (Inherited from Condition.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Udates the Attributes of the Properties (Inherited from Condition.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Condition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Condition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InterpreterGUIDChanged | Fired when the InterpreterGUID is changed. (Inherited from Condition.)
Public event | InterpreterGUIDValidating | Fired while validating the new value for InterpreterGUID. (Inherited from Condition.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LowerLimitChanged | Fired when the LowerLimit is changed.
Public event | LowerLimitValidating | Fired while validating the new value for LowerLimit.
Public event | LowerOperatorChanged | Fired when the LowerOperator is changed.
Public event | LowerOperatorValidating | Fired while validating the new value for LowerOperator.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReferenceAcquisitionInterpreterChanged | Fired when the ReferenceAcquisitionInterpreterChanged is changed. (Inherited from Condition.)
Public event | ReferenceAcquisitionInterpreterChanging | Fired before Changing the value of ReferenceAcquisitionInterpreter. (Inherited from Condition.)
Public event | ReferenceAcquisitionInterpreterValidating | Fired while validating the new value for ReferenceAcquisitionInterpreter. (Inherited from Condition.)
Public event | RefreshDisplay | Fired to Refresh Display (Inherited from Condition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReusedAcquisitionOrInterpreterChanged | Fired when the ReusedAcquisitionOrInterpreter is changed. (Inherited from Condition.)
Public event | ReusedAcquisitionOrInterpreterValidating | Fired while validating the new value for ReusedAcquisitionOrInterpreter. (Inherited from Condition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpperLimitChanged | Fired when the UpperLimit is changed.
Public event | UpperLimitValidating | Fired while validating the new value for UpperLimit.
Public event | UpperOperatorChanged | Fired when the UpperOperator is changed.
Public event | UpperOperatorValidating | Fired while validating the new value for UpperOperator.
Public event | UseChannelDataChanged | Fired when the UseChannelData is changed. (Inherited from Condition.)
Public event | UseChannelDataValidating | Fired while validating the new value for UseChannelData. (Inherited from Condition.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


AreaCondition Constructor

Overload List
 | Name | Description
Public method | AreaCondition | Create a new AreaCondition
Public method | AreaCondition(AreaCondition) | Create a new AreaCondition by copying Properties
Top
See Also

Reference

AreaCondition Class


AreaCondition Constructor

Create a new AreaCondition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AreaCondition()
Public Sub New
public:
AreaCondition()
See Also

Reference

AreaCondition Class
AreaCondition Overload


AreaCondition Constructor (AreaCondition)

Create a new AreaCondition by copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AreaCondition(
    AreaCondition org
)
Public Sub New (
    org As AreaCondition
)
public:
AreaCondition(
    AreaCondition^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelAreaCondition
AreaCondition to copy from
See Also

Reference

AreaCondition Class
AreaCondition Overload


AreaCondition Properties

The AreaCondition type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Condition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | InterpreterGUID | Gets or Sets the InterpreterGUID. (Inherited from Condition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LowerLimit | Gets or Sets the LowerLimit.
Public property | LowerOperator | Gets or Sets the LowerOperator.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReferenceAcquisitionInterpreter | Gets or Sets the ReferenceAcquisitionInterpreter. (Inherited from Condition.)
Public property | ReusedAcquisitionOrInterpreter | Gets or Sets the ReusedAcquisitionOrInterpreter. (Inherited from Condition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UpperLimit | Gets or Sets the UpperLimit.
Public property | UpperOperator | Gets or Sets the UpperOperator.
Public property | UseChannelData | Gets or Sets the UseChannelData. (Inherited from Condition.)
Top
See Also

Reference

AreaCondition Class


AreaCondition.LowerLimit Property

Gets or Sets the LowerLimit.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double LowerLimit { get; set; }
<BrowsableAttribute(true)>
Public Property LowerLimit As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double LowerLimit {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AreaCondition Class


AreaCondition.LowerOperator Property

Gets or Sets the LowerOperator.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public CompareOperators LowerOperator { get; set; }
<BrowsableAttribute(true)>
Public Property LowerOperator As CompareOperators
    Get
    Set
public:
[BrowsableAttribute(true)]
property CompareOperators LowerOperator {
    CompareOperators get ();
    void set (CompareOperators value);
}

Property Value

Type: CompareOperators
See Also

Reference

AreaCondition Class


AreaCondition.UpperLimit Property

Gets or Sets the UpperLimit.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double UpperLimit { get; set; }
<BrowsableAttribute(true)>
Public Property UpperLimit As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double UpperLimit {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AreaCondition Class


AreaCondition.UpperOperator Property

Gets or Sets the UpperOperator.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public CompareOperators UpperOperator { get; set; }
<BrowsableAttribute(true)>
Public Property UpperOperator As CompareOperators
    Get
    Set
public:
[BrowsableAttribute(true)]
property CompareOperators UpperOperator {
    CompareOperators get ();
    void set (CompareOperators value);
}

Property Value

Type: CompareOperators
See Also

Reference

AreaCondition Class


AreaCondition Methods

The AreaCondition type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Commands (Inherited from Condition.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Udates the Attributes of the Properties (Inherited from Condition.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AreaCondition Class


AreaCondition Events

The AreaCondition type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Condition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Condition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InterpreterGUIDChanged | Fired when the InterpreterGUID is changed. (Inherited from Condition.)
Public event | InterpreterGUIDValidating | Fired while validating the new value for InterpreterGUID. (Inherited from Condition.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LowerLimitChanged | Fired when the LowerLimit is changed.
Public event | LowerLimitValidating | Fired while validating the new value for LowerLimit.
Public event | LowerOperatorChanged | Fired when the LowerOperator is changed.
Public event | LowerOperatorValidating | Fired while validating the new value for LowerOperator.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReferenceAcquisitionInterpreterChanged | Fired when the ReferenceAcquisitionInterpreterChanged is changed. (Inherited from Condition.)
Public event | ReferenceAcquisitionInterpreterChanging | Fired before Changing the value of ReferenceAcquisitionInterpreter. (Inherited from Condition.)
Public event | ReferenceAcquisitionInterpreterValidating | Fired while validating the new value for ReferenceAcquisitionInterpreter. (Inherited from Condition.)
Public event | RefreshDisplay | Fired to Refresh Display (Inherited from Condition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReusedAcquisitionOrInterpreterChanged | Fired when the ReusedAcquisitionOrInterpreter is changed. (Inherited from Condition.)
Public event | ReusedAcquisitionOrInterpreterValidating | Fired while validating the new value for ReusedAcquisitionOrInterpreter. (Inherited from Condition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpperLimitChanged | Fired when the UpperLimit is changed.
Public event | UpperLimitValidating | Fired while validating the new value for UpperLimit.
Public event | UpperOperatorChanged | Fired when the UpperOperator is changed.
Public event | UpperOperatorValidating | Fired while validating the new value for UpperOperator.
Public event | UseChannelDataChanged | Fired when the UseChannelData is changed. (Inherited from Condition.)
Public event | UseChannelDataValidating | Fired while validating the new value for UseChannelData. (Inherited from Condition.)
Top
See Also

Reference

AreaCondition Class


AreaCondition.LowerLimitChanged Event

Fired when the LowerLimit is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LowerLimitChanged
Public Event LowerLimitChanged As EventHandler
public:
 event EventHandler^ LowerLimitChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AreaCondition Class


AreaCondition.LowerLimitValidating Event

Fired while validating the new value for LowerLimit.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LowerLimitValidating
Public Event LowerLimitValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LowerLimitValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AreaCondition Class


AreaCondition.LowerOperatorChanged Event

Fired when the LowerOperator is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LowerOperatorChanged
Public Event LowerOperatorChanged As EventHandler
public:
 event EventHandler^ LowerOperatorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AreaCondition Class


AreaCondition.LowerOperatorValidating Event

Fired while validating the new value for LowerOperator.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LowerOperatorValidating
Public Event LowerOperatorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LowerOperatorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AreaCondition Class


AreaCondition.UpperLimitChanged Event

Fired when the UpperLimit is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UpperLimitChanged
Public Event UpperLimitChanged As EventHandler
public:
 event EventHandler^ UpperLimitChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AreaCondition Class


AreaCondition.UpperLimitValidating Event

Fired while validating the new value for UpperLimit.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UpperLimitValidating
Public Event UpperLimitValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UpperLimitValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AreaCondition Class


AreaCondition.UpperOperatorChanged Event

Fired when the UpperOperator is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UpperOperatorChanged
Public Event UpperOperatorChanged As EventHandler
public:
 event EventHandler^ UpperOperatorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AreaCondition Class


AreaCondition.UpperOperatorValidating Event

Fired while validating the new value for UpperOperator.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UpperOperatorValidating
Public Event UpperOperatorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UpperOperatorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AreaCondition Class


ArrayBarChart Class

Scope ArrayBar-Chart class
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAnchorTimeBase
TwinCAT.Measurement.Scope.API.ModelChart
TwinCAT.Measurement.Scope.API.ModelConnectableChart
TwinCAT.Measurement.Scope.API.ModelSingleValuesChart
TwinCAT.Measurement.Scope.API.ModelArrayBarChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ArrayBarChart : SingleValuesChart
Public Class ArrayBarChart
    Inherits SingleValuesChart
public ref class ArrayBarChart : public SingleValuesChart

The ArrayBarChart type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayBarChart | Create a new Empty ArrayBarChart
Public method | ArrayBarChart(ArrayBarChart) | Create a new ArrayBar-Chart and copy Properties from old AB-Chart
Top
Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | BarOrientation | Gets or Sets the BarOrientation.
Public property | CanContainsChartLayer | (Inherited from SingleValuesChart.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Inherited from Chart.)
Public property | ChartType | (Overrides ChartChartType.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | PreferredSendTime | Gets or Sets the PreferredSendTime. (Inherited from SingleValuesChart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | (Overrides ChartGetCommands.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartDisplayWithoutOverview | (Inherited from SingleValuesChart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Chart.)
Public method | Validate | Validate the current configuration (Overrides ChartValidate.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Called Rescales the hole Display (Overrides ChartZoomOutMax.)
Top
Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BarOrientationChanged | Fired when the BarOrientation is changed.
Public event | BarOrientationValidating | Fired while validating the new value for BarOrientation.
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | PreferredSendTimeChanged | Fired when the PreferredSendTime is changed. (Inherited from SingleValuesChart.)
Public event | PreferredSendTimeValidating | Fired while validating the new value for PreferredSendTime. (Inherited from SingleValuesChart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ArrayBarChart Constructor

Overload List
 | Name | Description
Public method | ArrayBarChart | Create a new Empty ArrayBarChart
Public method | ArrayBarChart(ArrayBarChart) | Create a new ArrayBar-Chart and copy Properties from old AB-Chart
Top
See Also

Reference

ArrayBarChart Class


ArrayBarChart Constructor

Create a new Empty ArrayBarChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ArrayBarChart()
Public Sub New
public:
ArrayBarChart()
See Also

Reference

ArrayBarChart Class
ArrayBarChart Overload


ArrayBarChart Constructor (ArrayBarChart)

Create a new ArrayBar-Chart and copy Properties from old AB-Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ArrayBarChart(
    ArrayBarChart Chart
)
Public Sub New (
    Chart As ArrayBarChart
)
public:
ArrayBarChart(
    ArrayBarChart^ Chart
)

Parameters

Chart
Type: TwinCAT.Measurement.Scope.API.ModelArrayBarChart
Old AB-Chart
See Also

Reference

ArrayBarChart Class
ArrayBarChart Overload


ArrayBarChart Properties

The ArrayBarChart type exposes the following members.

Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | BarOrientation | Gets or Sets the BarOrientation.
Public property | CanContainsChartLayer | (Inherited from SingleValuesChart.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Inherited from Chart.)
Public property | ChartType | (Overrides ChartChartType.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | PreferredSendTime | Gets or Sets the PreferredSendTime. (Inherited from SingleValuesChart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ArrayBarChart Class


ArrayBarChart.BarOrientation Property

Gets or Sets the BarOrientation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public CursorAlignment BarOrientation { get; set; }
<BrowsableAttribute(true)>
Public Property BarOrientation As CursorAlignment
    Get
    Set
public:
[BrowsableAttribute(true)]
property CursorAlignment BarOrientation {
    CursorAlignment get ();
    void set (CursorAlignment value);
}

Property Value

Type: CursorAlignment
See Also

Reference

ArrayBarChart Class


ArrayBarChart.ChartType Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public override ChartType ChartType { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ChartType As ChartType
    Get
public:
[BrowsableAttribute(false)]
virtual property ChartType ChartType {
    ChartType get () override;
}

Property Value

Type: ChartType
See Also

Reference

ArrayBarChart Class


ArrayBarChart Methods

The ArrayBarChart type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | (Overrides ChartGetCommands.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartDisplayWithoutOverview | (Inherited from SingleValuesChart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Chart.)
Public method | Validate | Validate the current configuration (Overrides ChartValidate.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Called Rescales the hole Display (Overrides ChartZoomOutMax.)
Top
See Also

Reference

ArrayBarChart Class


ArrayBarChart.GetCommands Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
See Also

Reference

ArrayBarChart Class


ArrayBarChart.Validate Method

Validate the current configuration

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void Validate()
Public Overrides Sub Validate
public:
virtual void Validate() override
See Also

Reference

ArrayBarChart Class


ArrayBarChart.ZoomOutMax Method

Called Rescales the hole Display

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void ZoomOutMax()
Public Overrides Sub ZoomOutMax
public:
virtual void ZoomOutMax() override
See Also

Reference

ArrayBarChart Class


ArrayBarChart Events

The ArrayBarChart type exposes the following members.

Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BarOrientationChanged | Fired when the BarOrientation is changed.
Public event | BarOrientationValidating | Fired while validating the new value for BarOrientation.
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | PreferredSendTimeChanged | Fired when the PreferredSendTime is changed. (Inherited from SingleValuesChart.)
Public event | PreferredSendTimeValidating | Fired while validating the new value for PreferredSendTime. (Inherited from SingleValuesChart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ArrayBarChart Class


ArrayBarChart.BarOrientationChanged Event

Fired when the BarOrientation is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BarOrientationChanged
Public Event BarOrientationChanged As EventHandler
public:
 event EventHandler^ BarOrientationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArrayBarChart Class


ArrayBarChart.BarOrientationValidating Event

Fired while validating the new value for BarOrientation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> BarOrientationValidating
Public Event BarOrientationValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ BarOrientationValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ArrayBarChart Class


ArrayBarChart Fields

The ArrayBarChart type exposes the following members.

Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

ArrayBarChart Class


AspectRatioScalingStyle Class

Class for fixed AspectRatio Scaling of an AxisGroup
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelAspectRatioScalingStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class AspectRatioScalingStyle : ScopeMemberBase
Public Class AspectRatioScalingStyle
    Inherits ScopeMemberBase
public ref class AspectRatioScalingStyle : public ScopeMemberBase

The AspectRatioScalingStyle type exposes the following members.

Constructors
 | Name | Description
Public method | AspectRatioScalingStyle | Create a new AspectRatioScalingStyle
Public method | AspectRatioScalingStyle(AspectRatioScalingStyle) | Create a new AspectRatioScalingStyle by copying Properties
Top
Properties
 | Name | Description
Public property | AspectRatioScaling | Gets or Sets the AspectRatioScaling.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | KeepAspectRatio | Gets or Sets the KeepAspectRatio.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReferenceAxis | Gets or Sets the ReferenceAxis.
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of the Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AspectRatioScalingChanged | Fired when the AspectRatioScaling is changed.
Public event | AspectRatioScalingValidating | Fired while validating the new value for AspectRatioScaling.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | KeepAspectRatioChanged | Fired when the KeepAspectRatio is changed.
Public event | KeepAspectRatioValidating | Fired while validating the new value for KeepAspectRatio.
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReferenceAxisChanged | Fired when the ReferenceAxis is changed.
Public event | ReferenceAxisValidating | Fired while validating the new value for ReferenceAxis.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


AspectRatioScalingStyle Constructor

Overload List
 | Name | Description
Public method | AspectRatioScalingStyle | Create a new AspectRatioScalingStyle
Public method | AspectRatioScalingStyle(AspectRatioScalingStyle) | Create a new AspectRatioScalingStyle by copying Properties
Top
See Also

Reference

AspectRatioScalingStyle Class


AspectRatioScalingStyle Constructor

Create a new AspectRatioScalingStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AspectRatioScalingStyle()
Public Sub New
public:
AspectRatioScalingStyle()
See Also

Reference

AspectRatioScalingStyle Class
AspectRatioScalingStyle Overload


AspectRatioScalingStyle Constructor (AspectRatioScalingStyle)

Create a new AspectRatioScalingStyle by copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AspectRatioScalingStyle(
    AspectRatioScalingStyle org
)
Public Sub New (
    org As AspectRatioScalingStyle
)
public:
AspectRatioScalingStyle(
    AspectRatioScalingStyle^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelAspectRatioScalingStyle
AspectRatioScalingStyle to copy from
See Also

Reference

AspectRatioScalingStyle Class
AspectRatioScalingStyle Overload


AspectRatioScalingStyle Properties

The AspectRatioScalingStyle type exposes the following members.

Properties
 | Name | Description
Public property | AspectRatioScaling | Gets or Sets the AspectRatioScaling.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | KeepAspectRatio | Gets or Sets the KeepAspectRatio.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReferenceAxis | Gets or Sets the ReferenceAxis.
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AspectRatioScalingStyle Class


AspectRatioScalingStyle.AspectRatioScaling Property

Gets or Sets the AspectRatioScaling.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string AspectRatioScaling { get; set; }
<BrowsableAttribute(true)>
Public Property AspectRatioScaling As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ AspectRatioScaling {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AspectRatioScalingStyle Class


AspectRatioScalingStyle.KeepAspectRatio Property

Gets or Sets the KeepAspectRatio.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool KeepAspectRatio { get; set; }
<BrowsableAttribute(true)>
Public Property KeepAspectRatio As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool KeepAspectRatio {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AspectRatioScalingStyle Class


AspectRatioScalingStyle.ReferenceAxis Property

Gets or Sets the ReferenceAxis.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public AxisOrientation ReferenceAxis { get; set; }
<BrowsableAttribute(true)>
Public Property ReferenceAxis As AxisOrientation
    Get
    Set
public:
[BrowsableAttribute(true)]
property AxisOrientation ReferenceAxis {
    AxisOrientation get ();
    void set (AxisOrientation value);
}

Property Value

Type: AxisOrientation
See Also

Reference

AspectRatioScalingStyle Class


AspectRatioScalingStyle Methods

The AspectRatioScalingStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of the Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AspectRatioScalingStyle Class


AspectRatioScalingStyle.UpdatePropertyAttributes Method

Updates the Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

AspectRatioScalingStyle Class


AspectRatioScalingStyle Events

The AspectRatioScalingStyle type exposes the following members.

Events
 | Name | Description
Public event | AspectRatioScalingChanged | Fired when the AspectRatioScaling is changed.
Public event | AspectRatioScalingValidating | Fired while validating the new value for AspectRatioScaling.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | KeepAspectRatioChanged | Fired when the KeepAspectRatio is changed.
Public event | KeepAspectRatioValidating | Fired while validating the new value for KeepAspectRatio.
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReferenceAxisChanged | Fired when the ReferenceAxis is changed.
Public event | ReferenceAxisValidating | Fired while validating the new value for ReferenceAxis.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AspectRatioScalingStyle Class


AspectRatioScalingStyle.AspectRatioScalingChanged Event

Fired when the AspectRatioScaling is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AspectRatioScalingChanged
Public Event AspectRatioScalingChanged As EventHandler
public:
 event EventHandler^ AspectRatioScalingChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AspectRatioScalingStyle Class


AspectRatioScalingStyle.AspectRatioScalingValidating Event

Fired while validating the new value for AspectRatioScaling.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AspectRatioScalingValidating
Public Event AspectRatioScalingValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AspectRatioScalingValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AspectRatioScalingStyle Class


AspectRatioScalingStyle.KeepAspectRatioChanged Event

Fired when the KeepAspectRatio is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler KeepAspectRatioChanged
Public Event KeepAspectRatioChanged As EventHandler
public:
 event EventHandler^ KeepAspectRatioChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AspectRatioScalingStyle Class


AspectRatioScalingStyle.KeepAspectRatioValidating Event

Fired while validating the new value for KeepAspectRatio.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> KeepAspectRatioValidating
Public Event KeepAspectRatioValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ KeepAspectRatioValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AspectRatioScalingStyle Class


AspectRatioScalingStyle.ReferenceAxisChanged Event

Fired when the ReferenceAxis is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReferenceAxisChanged
Public Event ReferenceAxisChanged As EventHandler
public:
 event EventHandler^ ReferenceAxisChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AspectRatioScalingStyle Class


AspectRatioScalingStyle.ReferenceAxisValidating Event

Fired while validating the new value for ReferenceAxis.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReferenceAxisValidating
Public Event ReferenceAxisValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReferenceAxisValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AspectRatioScalingStyle Class


Attachment Class

Class for mail attachment information.
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.API.ModelAttachment

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class Attachment
Public Class Attachment
public ref class Attachment

The Attachment type exposes the following members.

Constructors
 | Name | Description
Public method | Attachment | Creates a new instance of the Attachment class with a file path and indication if the file is temporary.
Top
Properties
 | Name | Description
Public property | FilePath | Gets the FilePath.
Public property | IsTemporary | Gets the IsTemporary.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


Attachment Constructor

Creates a new instance of the Attachment class with a file path and indication if the file is temporary.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Attachment(
    string file,
    bool temporary
)
Public Sub New (
    file As String,
    temporary As Boolean
)
public:
Attachment(
    String^ file,
    bool temporary
)

Parameters

file
Type: SystemString
The path to the attachment file.
temporary
Type: SystemBoolean
Indicates if the file is temporary and can be deleted afterwards.
See Also

Reference

Attachment Class


Attachment Properties

The Attachment type exposes the following members.

Properties
 | Name | Description
Public property | FilePath | Gets the FilePath.
Public property | IsTemporary | Gets the IsTemporary.
Top
See Also

Reference

Attachment Class


Attachment.FilePath Property

Gets the FilePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string FilePath { get; }
Public ReadOnly Property FilePath As String
    Get
public:
property String^ FilePath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

Attachment Class


Attachment.IsTemporary Property

Gets the IsTemporary.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool IsTemporary { get; }
Public ReadOnly Property IsTemporary As Boolean
    Get
public:
property bool IsTemporary {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

Attachment Class


Attachment Methods

The Attachment type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Attachment Class


Axis Class

Base class for all Scope Axes
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAxis
TwinCAT.Measurement.Scope.API.ModelMinMaxRangeAxis
TwinCAT.Measurement.Scope.API.ModelTimeAxis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class Axis : ScopeMemberContainerBase
Public MustInherit Class Axis
    Inherits ScopeMemberContainerBase
public ref class Axis abstract : public ScopeMemberContainerBase

The Axis type exposes the following members.

Constructors
 | Name | Description
Public method | Axis | Create a new Axis with default params
Public method | Axis(Axis) | Create a new Axis by Copying Properties from another Axis
Top
Properties
 | Name | Description
Public property | ActualTitle | Gets or Sets the ActualTitle.
Public property | AspectRatioScaleFactor | Gets or Sets the AspectRatioScaleFactor.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Inverted | Gets or Sets the Inverted.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Logarithmic | Gets or Sets the Logarithmic.
Public property | ManualMax | Gets or Sets the ManualMax.
Public property | ManualMin | Gets or Sets the ManualMin.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScalingMode | Gets or Sets the ScalingMode.
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style |
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Overrides MeasurementMemberBaseTitle.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserSettingsAxisInstance |
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ActualTitleChanged | Fired when the ActualTitle is changed.
Public event | ActualTitleValidating | Fired while validating the new value for ActualTitle.
Public event | AspectRatioScaleFactorChanged | Fired when the AspectRatioScaleFactor is changed.
Public event | AspectRatioScaleFactorValidating | Fired while validating the new value for AspectRatioScaleFactor.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DefaultRescale | Fired if the axis should rescale to default values
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InvertedChanged | Fired when the Inverted is changed.
Public event | InvertedValidating | Fired while validating the new value for Inverted.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LogarithmicChanged | Fired when the Logarithmic is changed.
Public event | LogarithmicValidating | Fired while validating the new value for Logarithmic.
Public event | ManualMaxChanged | Fired when the ManualMax is changed.
Public event | ManualMaxValidating | Fired while validating the new value for ManualMax.
Public event | ManualMinChanged | Fired when the ManualMin is changed.
Public event | ManualMinValidating | Fired while validating the new value for ManualMin.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed.
Public event | OrientationValidating | Fired while validating the new value for Orientation.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScalingModeChanged | Fired when the ScalingMode is changed.
Public event | ScalingModeValidating | Fired while validating the new value for ScalingMode.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


Axis Constructor

Overload List
 | Name | Description
Public method | Axis | Create a new Axis with default params
Public method | Axis(Axis) | Create a new Axis by Copying Properties from another Axis
Top
See Also

Reference

Axis Class


Axis Constructor

Create a new Axis with default params

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Axis()
Public Sub New
public:
Axis()
See Also

Reference

Axis Class
Axis Overload


Axis Constructor (Axis)

Create a new Axis by Copying Properties from another Axis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Axis(
    Axis org
)
Public Sub New (
    org As Axis
)
public:
Axis(
    Axis^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelAxis
Axis to Copy from
See Also

Reference

Axis Class
Axis Overload


Axis Properties

The Axis type exposes the following members.

Properties
 | Name | Description
Public property | ActualTitle | Gets or Sets the ActualTitle.
Public property | AspectRatioScaleFactor | Gets or Sets the AspectRatioScaleFactor.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Inverted | Gets or Sets the Inverted.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Logarithmic | Gets or Sets the Logarithmic.
Public property | ManualMax | Gets or Sets the ManualMax.
Public property | ManualMin | Gets or Sets the ManualMin.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScalingMode | Gets or Sets the ScalingMode.
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style |
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Overrides MeasurementMemberBaseTitle.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

Axis Class


Axis.ActualTitle Property

Gets or Sets the ActualTitle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public string ActualTitle { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property ActualTitle As String
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property String^ ActualTitle {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Axis Class


Axis.AspectRatioScaleFactor Property

Gets or Sets the AspectRatioScaleFactor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public double AspectRatioScaleFactor { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property AspectRatioScaleFactor As Double
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property double AspectRatioScaleFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Axis Class


Axis.Inverted Property

Gets or Sets the Inverted.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public virtual bool Inverted { get; set; }
<BrowsableAttribute(true)>
Public Overridable Property Inverted As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property bool Inverted {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Axis Class


Axis.Logarithmic Property

Gets or Sets the Logarithmic.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public virtual bool Logarithmic { get; set; }
<BrowsableAttribute(true)>
Public Overridable Property Logarithmic As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property bool Logarithmic {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Axis Class


Axis.ManualMax Property

Gets or Sets the ManualMax.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double ManualMax { get; set; }
<BrowsableAttribute(true)>
Public Property ManualMax As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double ManualMax {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Axis Class


Axis.ManualMin Property

Gets or Sets the ManualMin.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double ManualMin { get; set; }
<BrowsableAttribute(true)>
Public Property ManualMin As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double ManualMin {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Axis Class


Axis.Orientation Property

Gets or Sets the Orientation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public AxisOrientation Orientation { get; set; }
<BrowsableAttribute(false)>
Public Property Orientation As AxisOrientation
    Get
    Set
public:
[BrowsableAttribute(false)]
property AxisOrientation Orientation {
    AxisOrientation get ();
    void set (AxisOrientation value);
}

Property Value

Type: AxisOrientation
See Also

Reference

Axis Class


Axis.ScalingMode Property

Gets or Sets the ScalingMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public virtual ScaleModes ScalingMode { get; set; }
<BrowsableAttribute(true)>
Public Overridable Property ScalingMode As ScaleModes
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property ScaleModes ScalingMode {
    ScaleModes get ();
    void set (ScaleModes value);
}

Property Value

Type: ScaleModes
See Also

Reference

Axis Class


Axis.Style Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public AxisStyle Style { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property Style As AxisStyle
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property AxisStyle^ Style {
    AxisStyle^ get ();
}

Property Value

Type: AxisStyle
See Also

Reference

Axis Class


Axis.Title Property

Gets or Sets the Title.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public override string Title { get; set; }
<BrowsableAttribute(true)>
Public Overrides Property Title As String
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property String^ Title {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

Axis Class


Axis Methods

The Axis type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserSettingsAxisInstance |
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

Axis Class


Axis.GetUserSettingsAxisInstance Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract Axis GetUserSettingsAxisInstance()
Public MustOverride Function GetUserSettingsAxisInstance As Axis
public:
virtual Axis^ GetUserSettingsAxisInstance() abstract

Return Value

Type: Axis
See Also

Reference

Axis Class


Axis.UpdatePropertyAttributes Method

Update the Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

Axis Class


Axis Events

The Axis type exposes the following members.

Events
 | Name | Description
Public event | ActualTitleChanged | Fired when the ActualTitle is changed.
Public event | ActualTitleValidating | Fired while validating the new value for ActualTitle.
Public event | AspectRatioScaleFactorChanged | Fired when the AspectRatioScaleFactor is changed.
Public event | AspectRatioScaleFactorValidating | Fired while validating the new value for AspectRatioScaleFactor.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DefaultRescale | Fired if the axis should rescale to default values
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InvertedChanged | Fired when the Inverted is changed.
Public event | InvertedValidating | Fired while validating the new value for Inverted.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LogarithmicChanged | Fired when the Logarithmic is changed.
Public event | LogarithmicValidating | Fired while validating the new value for Logarithmic.
Public event | ManualMaxChanged | Fired when the ManualMax is changed.
Public event | ManualMaxValidating | Fired while validating the new value for ManualMax.
Public event | ManualMinChanged | Fired when the ManualMin is changed.
Public event | ManualMinValidating | Fired while validating the new value for ManualMin.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed.
Public event | OrientationValidating | Fired while validating the new value for Orientation.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScalingModeChanged | Fired when the ScalingMode is changed.
Public event | ScalingModeValidating | Fired while validating the new value for ScalingMode.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

Axis Class


Axis.ActualTitleChanged Event

Fired when the ActualTitle is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ActualTitleChanged
Public Event ActualTitleChanged As EventHandler
public:
 event EventHandler^ ActualTitleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Axis Class


Axis.ActualTitleValidating Event

Fired while validating the new value for ActualTitle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ActualTitleValidating
Public Event ActualTitleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ActualTitleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Axis Class


Axis.AspectRatioScaleFactorChanged Event

Fired when the AspectRatioScaleFactor is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AspectRatioScaleFactorChanged
Public Event AspectRatioScaleFactorChanged As EventHandler
public:
 event EventHandler^ AspectRatioScaleFactorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Axis Class


Axis.AspectRatioScaleFactorValidating Event

Fired while validating the new value for AspectRatioScaleFactor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AspectRatioScaleFactorValidating
Public Event AspectRatioScaleFactorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AspectRatioScaleFactorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Axis Class


Axis.DefaultRescale Event

Fired if the axis should rescale to default values

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DefaultRescale
Public Event DefaultRescale As EventHandler
public:
 event EventHandler^ DefaultRescale {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Axis Class


Axis.InvertedChanged Event

Fired when the Inverted is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler InvertedChanged
Public Event InvertedChanged As EventHandler
public:
 event EventHandler^ InvertedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Axis Class


Axis.InvertedValidating Event

Fired while validating the new value for Inverted.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> InvertedValidating
Public Event InvertedValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ InvertedValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Axis Class


Axis.LogarithmicChanged Event

Fired when the Logarithmic is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LogarithmicChanged
Public Event LogarithmicChanged As EventHandler
public:
 event EventHandler^ LogarithmicChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Axis Class


Axis.LogarithmicValidating Event

Fired while validating the new value for Logarithmic.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LogarithmicValidating
Public Event LogarithmicValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LogarithmicValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Axis Class


Axis.ManualMaxChanged Event

Fired when the ManualMax is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ManualMaxChanged
Public Event ManualMaxChanged As EventHandler
public:
 event EventHandler^ ManualMaxChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Axis Class


Axis.ManualMaxValidating Event

Fired while validating the new value for ManualMax.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ManualMaxValidating
Public Event ManualMaxValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ManualMaxValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Axis Class


Axis.ManualMinChanged Event

Fired when the ManualMin is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ManualMinChanged
Public Event ManualMinChanged As EventHandler
public:
 event EventHandler^ ManualMinChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Axis Class


Axis.ManualMinValidating Event

Fired while validating the new value for ManualMin.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ManualMinValidating
Public Event ManualMinValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ManualMinValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Axis Class


Axis.OrientationChanged Event

Fired when the Orientation is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OrientationChanged
Public Event OrientationChanged As EventHandler
public:
 event EventHandler^ OrientationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Axis Class


Axis.OrientationValidating Event

Fired while validating the new value for Orientation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> OrientationValidating
Public Event OrientationValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ OrientationValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Axis Class


Axis.ScalingModeChanged Event

Fired when the ScalingMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ScalingModeChanged
Public Event ScalingModeChanged As EventHandler
public:
 event EventHandler^ ScalingModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Axis Class


Axis.ScalingModeValidating Event

Fired while validating the new value for ScalingMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ScalingModeValidating
Public Event ScalingModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ScalingModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Axis Class


AxisGroup Class

Class combines an couple of Axis with the Channels
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAxisGroup

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class AxisGroup : ScopeMemberContainerBase
Public Class AxisGroup
    Inherits ScopeMemberContainerBase
public ref class AxisGroup : public ScopeMemberContainerBase

The AxisGroup type exposes the following members.

Constructors
 | Name | Description
Public method | AxisGroup | Create a new AxisGroup with default Parameters
Public method | AxisGroup(AxisGroup) | Create a new AxisGroup by Copying the Properties from an existing AxisGroup
Top
Properties
 | Name | Description
Public property | ActualTitle | Gets or Sets the ActualTitle.
Public property | AxisGroupNameSetter |
Public property | ChannelRelatedGuid | Gets or Sets the ChannelRelatedGuid.
Public property | Channels |
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowTitle | Gets or Sets the ShowTitle.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | (Overrides MeasurementMemberBaseTitle.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | CanAddXMarker | an x marker can be added to the axis
Public method | CanAddXMarker(ChartType) | an x marker can be added to the axis
Public method | CanAddYMarker | an y marker can be added to the axis
Public method | CanAddYMarker(ChartType) | an y marker can be added to the axis
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateConfiguratedChannel | Adds a new Channel to the Axis and the correct number of AcquisitionInterpreter
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets an Array of Commands for this Model object (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRelatedAxis | Get the marker related axis
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | LoadShapeFromFile | Adds an Shape from a File to this AxisGroup
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of all Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | Validate | Validate this AxisGroup
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ActualTitleChanged | Fired when the ActualTitle is changed.
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow.
Public event | ChannelRelatedGuidChanged | Fired when the ChannelRelatedGuid is changed.
Public event | ChannelRelatedGuidValidating | Fired while validating the new value for ChannelRelatedGuid.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowTitleChanged | Fired when the ShowTitle is changed.
Public event | ShowTitleValidating | Fired while validating the new value for ShowTitle.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Fields
 | Name | Description
 | DefaultDisplayColor | Get or Set the DefaultDisplayColor
Public field | RefControlStyle | ///gets the ControlStyle
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


AxisGroup Constructor

Overload List
 | Name | Description
Public method | AxisGroup | Create a new AxisGroup with default Parameters
Public method | AxisGroup(AxisGroup) | Create a new AxisGroup by Copying the Properties from an existing AxisGroup
Top
See Also

Reference

AxisGroup Class


AxisGroup Constructor

Create a new AxisGroup with default Parameters

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AxisGroup()
Public Sub New
public:
AxisGroup()
See Also

Reference

AxisGroup Class
AxisGroup Overload


AxisGroup Constructor (AxisGroup)

Create a new AxisGroup by Copying the Properties from an existing AxisGroup

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AxisGroup(
    AxisGroup org
)
Public Sub New (
    org As AxisGroup
)
public:
AxisGroup(
    AxisGroup^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelAxisGroup
See Also

Reference

AxisGroup Class
AxisGroup Overload


AxisGroup Properties

The AxisGroup type exposes the following members.

Properties
 | Name | Description
Public property | ActualTitle | Gets or Sets the ActualTitle.
Public property | AxisGroupNameSetter |
Public property | ChannelRelatedGuid | Gets or Sets the ChannelRelatedGuid.
Public property | Channels |
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowTitle | Gets or Sets the ShowTitle.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | (Overrides MeasurementMemberBaseTitle.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AxisGroup Class


AxisGroup.ActualTitle Property

Gets or Sets the ActualTitle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public string ActualTitle { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property ActualTitle As String
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property String^ ActualTitle {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AxisGroup Class


AxisGroup.AxisGroupNameSetter Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public Object AxisGroupNameSetter { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property AxisGroupNameSetter As Object
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property Object^ AxisGroupNameSetter {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

AxisGroup Class


AxisGroup.ChannelRelatedGuid Property

Gets or Sets the ChannelRelatedGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public Guid ChannelRelatedGuid { get; set; }
<BrowsableAttribute(false)>
Public Property ChannelRelatedGuid As Guid
    Get
    Set
public:
[BrowsableAttribute(false)]
property Guid ChannelRelatedGuid {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

AxisGroup Class


AxisGroup.Channels Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public IEnumerable<Channel> Channels { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Channels As IEnumerable(Of Channel)
    Get
public:
[BrowsableAttribute(false)]
property IEnumerable<Channel^>^ Channels {
    IEnumerable<Channel^>^ get ();
}

Property Value

Type: IEnumerable Channel
See Also

Reference

AxisGroup Class


AxisGroup.DisplayColor Property

Gets or Sets the DisplayColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public override Color DisplayColor { get; set; }
<BrowsableAttribute(true)>
Public Overrides Property DisplayColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property Color DisplayColor {
    Color get () override;
    void set (Color value) override;
}

Property Value

Type: Color
See Also

Reference

AxisGroup Class


AxisGroup.Enabled Property

Gets or Sets the Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Enabled { get; set; }
<BrowsableAttribute(true)>
Public Property Enabled As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisGroup Class


AxisGroup.ShowTitle Property

Gets or Sets the ShowTitle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public UseTitleFrom ShowTitle { get; set; }
Public Property ShowTitle As UseTitleFrom
    Get
    Set
public:
property UseTitleFrom ShowTitle {
    UseTitleFrom get ();
    void set (UseTitleFrom value);
}

Property Value

Type: UseTitleFrom
See Also

Reference

AxisGroup Class


AxisGroup.Title Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string Title { get; set; }
Public Overrides Property Title As String
    Get
    Set
public:
virtual property String^ Title {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

AxisGroup Class


AxisGroup Methods

The AxisGroup type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | CanAddXMarker | an x marker can be added to the axis
Public method | CanAddXMarker(ChartType) | an x marker can be added to the axis
Public method | CanAddYMarker | an y marker can be added to the axis
Public method | CanAddYMarker(ChartType) | an y marker can be added to the axis
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateConfiguratedChannel | Adds a new Channel to the Axis and the correct number of AcquisitionInterpreter
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets an Array of Commands for this Model object (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRelatedAxis | Get the marker related axis
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | LoadShapeFromFile | Adds an Shape from a File to this AxisGroup
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of all Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | Validate | Validate this AxisGroup
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AxisGroup Class


AxisGroup.CanAddXMarker Method

Overload List
 | Name | Description
Public method | CanAddXMarker | an x marker can be added to the axis
Public method | CanAddXMarker(ChartType) | an x marker can be added to the axis
Top
See Also

Reference

AxisGroup Class


AxisGroup.CanAddXMarker Method

an x marker can be added to the axis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool CanAddXMarker()
Public Function CanAddXMarker As Boolean
public:
bool CanAddXMarker()

Return Value

Type: Boolean
See Also

Reference

AxisGroup Class
CanAddXMarker Overload


AxisGroup.CanAddXMarker Method (ChartType)

an x marker can be added to the axis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool CanAddXMarker(
    ChartType chartType
)
Public Function CanAddXMarker (
    chartType As ChartType
) As Boolean
public:
bool CanAddXMarker(
    ChartType chartType
)

Parameters

chartType
Type: TwinCAT.Measurement.Scope.APIChartType

Return Value

Type: Boolean
See Also

Reference

AxisGroup Class
CanAddXMarker Overload


AxisGroup.CanAddYMarker Method

Overload List
 | Name | Description
Public method | CanAddYMarker | an y marker can be added to the axis
Public method | CanAddYMarker(ChartType) | an y marker can be added to the axis
Top
See Also

Reference

AxisGroup Class


AxisGroup.CanAddYMarker Method

an y marker can be added to the axis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool CanAddYMarker()
Public Function CanAddYMarker As Boolean
public:
bool CanAddYMarker()

Return Value

Type: Boolean
See Also

Reference

AxisGroup Class
CanAddYMarker Overload


AxisGroup.CanAddYMarker Method (ChartType)

an y marker can be added to the axis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool CanAddYMarker(
    ChartType chartType
)
Public Function CanAddYMarker (
    chartType As ChartType
) As Boolean
public:
bool CanAddYMarker(
    ChartType chartType
)

Parameters

chartType
Type: TwinCAT.Measurement.Scope.APIChartType

Return Value

Type: Boolean
See Also

Reference

AxisGroup Class
CanAddYMarker Overload


AxisGroup.CreateConfiguratedChannel Method

Adds a new Channel to the Axis and the correct number of AcquisitionInterpreter

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual Channel CreateConfiguratedChannel()
Public Overridable Function CreateConfiguratedChannel As Channel
public:
virtual Channel^ CreateConfiguratedChannel()

Return Value

Type: Channel
See Also

Reference

AxisGroup Class


AxisGroup.GetCommands Method

Gets an Array of Commands for this Model object

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
See Also

Reference

AxisGroup Class


AxisGroup.GetRelatedAxis Method

Get the marker related axis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Axis GetRelatedAxis(
    Marker marker
)
Public Function GetRelatedAxis (
    marker As Marker
) As Axis
public:
Axis^ GetRelatedAxis(
    Marker^ marker
)

Parameters

marker
Type: TwinCAT.Measurement.Scope.API.ModelMarker

Return Value

Type: Axis
See Also

Reference

AxisGroup Class


AxisGroup.LoadShapeFromFile Method

Adds an Shape from a File to this AxisGroup

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void LoadShapeFromFile(
    string FilePath
)
Public Sub LoadShapeFromFile (
    FilePath As String
)
public:
void LoadShapeFromFile(
    String^ FilePath
)

Parameters

FilePath
Type: SystemString
See Also

Reference

AxisGroup Class


AxisGroup.UpdatePropertyAttributes Method

Update the Attributes of all Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

AxisGroup Class


AxisGroup.Validate Method

Validate this AxisGroup

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Validate(
    ScopeDisplayModes Mode
)
Public Sub Validate (
    Mode As ScopeDisplayModes
)
public:
void Validate(
    ScopeDisplayModes Mode
)

Parameters

Mode
Type: TwinCAT.Measurement.Scope.APIScopeDisplayModes
DisplayMode of this Chart
See Also

Reference

AxisGroup Class


AxisGroup Events

The AxisGroup type exposes the following members.

Events
 | Name | Description
Public event | ActualTitleChanged | Fired when the ActualTitle is changed.
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow.
Public event | ChannelRelatedGuidChanged | Fired when the ChannelRelatedGuid is changed.
Public event | ChannelRelatedGuidValidating | Fired while validating the new value for ChannelRelatedGuid.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowTitleChanged | Fired when the ShowTitle is changed.
Public event | ShowTitleValidating | Fired while validating the new value for ShowTitle.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AxisGroup Class


AxisGroup.ActualTitleChanged Event

Fired when the ActualTitle is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ActualTitleChanged
Public Event ActualTitleChanged As EventHandler
public:
 event EventHandler^ ActualTitleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisGroup Class


AxisGroup.AddToMarkerWindow Event

Fired, when the Chart should be add to the MarkerWindow.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AddToMarkerWindow
Public Event AddToMarkerWindow As EventHandler
public:
 event EventHandler^ AddToMarkerWindow {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisGroup Class


AxisGroup.ChannelRelatedGuidChanged Event

Fired when the ChannelRelatedGuid is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ChannelRelatedGuidChanged
Public Event ChannelRelatedGuidChanged As EventHandler
public:
 event EventHandler^ ChannelRelatedGuidChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisGroup Class


AxisGroup.ChannelRelatedGuidValidating Event

Fired while validating the new value for ChannelRelatedGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ChannelRelatedGuidValidating
Public Event ChannelRelatedGuidValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ChannelRelatedGuidValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisGroup Class


AxisGroup.EnabledChanged Event

Fired when the Enabled is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EnabledChanged
Public Event EnabledChanged As EventHandler
public:
 event EventHandler^ EnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisGroup Class


AxisGroup.EnabledValidating Event

Fired while validating the new value for Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EnabledValidating
Public Event EnabledValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EnabledValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisGroup Class


AxisGroup.ShowTitleChanged Event

Fired when the ShowTitle is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowTitleChanged
Public Event ShowTitleChanged As EventHandler
public:
 event EventHandler^ ShowTitleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisGroup Class


AxisGroup.ShowTitleValidating Event

Fired while validating the new value for ShowTitle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowTitleValidating
Public Event ShowTitleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowTitleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisGroup Class


AxisGroup Fields

The AxisGroup type exposes the following members.

Fields
 | Name | Description
 | DefaultDisplayColor | Get or Set the DefaultDisplayColor
Public field | RefControlStyle | ///gets the ControlStyle
Top
See Also

Reference

AxisGroup Class


AxisGroup.DefaultDisplayColor Field

Get or Set the DefaultDisplayColor

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static Color DefaultDisplayColor
Public Shared DefaultDisplayColor As Color
public:
static Color DefaultDisplayColor

Field Value

Type: Color
See Also

Reference

AxisGroup Class


AxisGroup.RefControlStyle Field

///gets the ControlStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
public MarkerControlStyle RefControlStyle
<XmlIgnoreAttribute>
Public RefControlStyle As MarkerControlStyle
public:
[XmlIgnoreAttribute]
MarkerControlStyle^ RefControlStyle

Field Value

Type: MarkerControlStyle
See Also

Reference

AxisGroup Class


AxisStyle Class

Style class for Axis
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelAxisStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class AxisStyle : ScopeMemberBase
Public Class AxisStyle
    Inherits ScopeMemberBase
public ref class AxisStyle : public ScopeMemberBase

The AxisStyle type exposes the following members.

Constructors
 | Name | Description
Public method | AxisStyle | Create a new AxisStyle with default parameters
Public method | AxisStyle(AxisStyle) | Create a new Axis Style by copying Properties from another AxisStyle
Top
Properties
 | Name | Description
Public property | AxisNameSetter |
Public property | ChannelRelatedGuid | Gets or Sets the ChannelRelatedGuid.
Public property | ColorMode | Gets or Sets the ColorMode.
Public property | ColorSourceSetter |
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Grid | Gets or Sets the Grid.
Public property | GridColor | Gets or Sets the GridColor.
Public property | GridDivisions | Gets or Sets the GridDivisions.
Public property | GridLineWidth | Gets or Sets the GridLineWidth.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineWidth | Gets or Sets the LineWidth.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Precision | Gets or Sets the Precision.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SelectedColor | Gets or Sets the SelectedColor.
Public property | ShowName | Gets or Sets the ShowName.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubGrid | Gets or Sets the SubGrid.
Public property | SubGridDivisions | Gets or Sets the SubGridDivisions.
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseScientificNotation | Gets or Sets the UseScientificNotation.
Public property | Visible | Gets or Sets the Visible.
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of all Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ChannelRelatedGuidChanged | Fired when the ChannelRelatedGuid is changed.
Public event | ChannelRelatedGuidValidating | Fired while validating the new value for ChannelRelatedGuid.
Public event | ColorModeChanged | Fired when the ColorMode is changed.
Public event | ColorModeValidating | Fired while validating the new value for ColorMode.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GridChanged | Fired when the Grid is changed.
Public event | GridColorChanged | Fired when the GridColor is changed.
Public event | GridColorValidating | Fired while validating the new value for GridColor.
Public event | GridDivisionsChanged | Fired when the GridDivisions is changed.
Public event | GridDivisionsValidating | Fired while validating the new value for GridDivisions.
Public event | GridLineWidthChanged | Fired when the GridLineWidth is changed.
Public event | GridLineWidthValidating | Fired while validating the new value for GridLineWidth.
Public event | GridValidating | Fired while validating the new value for Grid.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineWidthChanged | Fired when the LineWidth is changed.
Public event | LineWidthValidating | Fired while validating the new value for LineWidth.
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PrecisionChanged | Fired when the Precision is changed.
Public event | PrecisionValidating | Fired while validating the new value for Precision.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SelectedColorChanged | Fired when the SelectedColor is changed.
Public event | SelectedColorValidating | Fired while validating the new value for SelectedColor.
Public event | ShowNameChanged | Fired when the ShowName is changed.
Public event | ShowNameValidating | Fired while validating the new value for ShowName.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubGridChanged | Fired when the SubGrid is changed.
Public event | SubGridDivisionsChanged | Fired when the SubGridDivisions is changed.
Public event | SubGridDivisionsValidating | Fired while validating the new value for SubGridDivisions.
Public event | SubGridValidating | Fired while validating the new value for SubGrid.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseScientificNotationChanged | Fired when the UseScientificNotation is changed.
Public event | UseScientificNotationValidating | Fired while validating the new value for UseScientificNotation.
Public event | VisibleChanged | Fired when the Visible is changed.
Public event | VisibleValidating | Fired while validating the new value for Visible.
Top
Fields
Name | Description
DefaultDisplayColor | Get or Set the DefaultDisplayColor
DefaultGridColor | Get or Set the DefaultGridColor;
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


AxisStyle Constructor

Overload List
 | Name | Description
Public method | AxisStyle | Create a new AxisStyle with default parameters
Public method | AxisStyle(AxisStyle) | Create a new Axis Style by copying Properties from another AxisStyle
Top
See Also

Reference

AxisStyle Class


AxisStyle Constructor

Create a new AxisStyle with default parameters

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AxisStyle()
Public Sub New
public:
AxisStyle()
See Also

Reference

AxisStyle Class
AxisStyle Overload


AxisStyle Constructor (AxisStyle)

Create a new Axis Style by copying Properties from another AxisStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public AxisStyle(
    AxisStyle style
)
Public Sub New (
    style As AxisStyle
)
public:
AxisStyle(
    AxisStyle^ style
)

Parameters

style
Type: TwinCAT.Measurement.Scope.API.ModelAxisStyle
Axis Style to copy from
See Also

Reference

AxisStyle Class
AxisStyle Overload


AxisStyle Properties

The AxisStyle type exposes the following members.

Properties
 | Name | Description
Public property | AxisNameSetter |
Public property | ChannelRelatedGuid | Gets or Sets the ChannelRelatedGuid.
Public property | ColorMode | Gets or Sets the ColorMode.
Public property | ColorSourceSetter |
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Grid | Gets or Sets the Grid.
Public property | GridColor | Gets or Sets the GridColor.
Public property | GridDivisions | Gets or Sets the GridDivisions.
Public property | GridLineWidth | Gets or Sets the GridLineWidth.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineWidth | Gets or Sets the LineWidth.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Precision | Gets or Sets the Precision.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SelectedColor | Gets or Sets the SelectedColor.
Public property | ShowName | Gets or Sets the ShowName.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubGrid | Gets or Sets the SubGrid.
Public property | SubGridDivisions | Gets or Sets the SubGridDivisions.
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseScientificNotation | Gets or Sets the UseScientificNotation.
Public property | Visible | Gets or Sets the Visible.
Top
See Also

Reference

AxisStyle Class


AxisStyle.AxisNameSetter Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public Object AxisNameSetter { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property AxisNameSetter As Object
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property Object^ AxisNameSetter {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

AxisStyle Class


AxisStyle.ChannelRelatedGuid Property

Gets or Sets the ChannelRelatedGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public Guid ChannelRelatedGuid { get; set; }
<BrowsableAttribute(false)>
Public Property ChannelRelatedGuid As Guid
    Get
    Set
public:
[BrowsableAttribute(false)]
property Guid ChannelRelatedGuid {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

AxisStyle Class


AxisStyle.ColorMode Property

Gets or Sets the ColorMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public UseColorFrom ColorMode { get; set; }
<BrowsableAttribute(false)>
Public Property ColorMode As UseColorFrom
    Get
    Set
public:
[BrowsableAttribute(false)]
property UseColorFrom ColorMode {
    UseColorFrom get ();
    void set (UseColorFrom value);
}

Property Value

Type: UseColorFrom
See Also

Reference

AxisStyle Class


AxisStyle.ColorSourceSetter Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public Object ColorSourceSetter { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property ColorSourceSetter As Object
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property Object^ ColorSourceSetter {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

AxisStyle Class


AxisStyle.DisplayColor Property

Gets or Sets the DisplayColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public override Color DisplayColor { get; set; }
<BrowsableAttribute(true)>
Public Overrides Property DisplayColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property Color DisplayColor {
    Color get () override;
    void set (Color value) override;
}

Property Value

Type: Color
See Also

Reference

AxisStyle Class


AxisStyle.Grid Property

Gets or Sets the Grid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Grid { get; set; }
<BrowsableAttribute(true)>
Public Property Grid As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Grid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisStyle Class


AxisStyle.GridColor Property

Gets or Sets the GridColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Color GridColor { get; set; }
<BrowsableAttribute(true)>
Public Property GridColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
property Color GridColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

AxisStyle Class


AxisStyle.GridDivisions Property

Gets or Sets the GridDivisions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int GridDivisions { get; set; }
<BrowsableAttribute(true)>
Public Property GridDivisions As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int GridDivisions {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AxisStyle Class


AxisStyle.GridLineWidth Property

Gets or Sets the GridLineWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int GridLineWidth { get; set; }
Public Property GridLineWidth As Integer
    Get
    Set
public:
property int GridLineWidth {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AxisStyle Class


AxisStyle.LineWidth Property

Gets or Sets the LineWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int LineWidth { get; set; }
<BrowsableAttribute(true)>
Public Property LineWidth As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int LineWidth {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AxisStyle Class


AxisStyle.Precision Property

Gets or Sets the Precision.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int Precision { get; set; }
<BrowsableAttribute(true)>
Public Property Precision As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int Precision {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AxisStyle Class


AxisStyle.SelectedColor Property

Gets or Sets the SelectedColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public Color SelectedColor { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property SelectedColor As Color
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property Color SelectedColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

AxisStyle Class


AxisStyle.ShowName Property

Gets or Sets the ShowName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public UseTitleFrom ShowName { get; set; }
<BrowsableAttribute(false)>
Public Property ShowName As UseTitleFrom
    Get
    Set
public:
[BrowsableAttribute(false)]
property UseTitleFrom ShowName {
    UseTitleFrom get ();
    void set (UseTitleFrom value);
}

Property Value

Type: UseTitleFrom
See Also

Reference

AxisStyle Class


AxisStyle.SubGrid Property

Gets or Sets the SubGrid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool SubGrid { get; set; }
Public Property SubGrid As Boolean
    Get
    Set
public:
property bool SubGrid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisStyle Class


AxisStyle.SubGridDivisions Property

Gets or Sets the SubGridDivisions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int SubGridDivisions { get; set; }
Public Property SubGridDivisions As Integer
    Get
    Set
public:
property int SubGridDivisions {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AxisStyle Class


AxisStyle.UseScientificNotation Property

Gets or Sets the UseScientificNotation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool UseScientificNotation { get; set; }
<BrowsableAttribute(true)>
Public Property UseScientificNotation As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool UseScientificNotation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisStyle Class


AxisStyle.Visible Property

Gets or Sets the Visible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Visible { get; set; }
<BrowsableAttribute(true)>
Public Property Visible As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Visible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AxisStyle Class


AxisStyle Methods

The AxisStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of all Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

AxisStyle Class


AxisStyle.UpdatePropertyAttributes Method

Update Attributes of all Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

AxisStyle Class


AxisStyle Events

The AxisStyle type exposes the following members.

Events
 | Name | Description
Public event | ChannelRelatedGuidChanged | Fired when the ChannelRelatedGuid is changed.
Public event | ChannelRelatedGuidValidating | Fired while validating the new value for ChannelRelatedGuid.
Public event | ColorModeChanged | Fired when the ColorMode is changed.
Public event | ColorModeValidating | Fired while validating the new value for ColorMode.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GridChanged | Fired when the Grid is changed.
Public event | GridColorChanged | Fired when the GridColor is changed.
Public event | GridColorValidating | Fired while validating the new value for GridColor.
Public event | GridDivisionsChanged | Fired when the GridDivisions is changed.
Public event | GridDivisionsValidating | Fired while validating the new value for GridDivisions.
Public event | GridLineWidthChanged | Fired when the GridLineWidth is changed.
Public event | GridLineWidthValidating | Fired while validating the new value for GridLineWidth.
Public event | GridValidating | Fired while validating the new value for Grid.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineWidthChanged | Fired when the LineWidth is changed.
Public event | LineWidthValidating | Fired while validating the new value for LineWidth.
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PrecisionChanged | Fired when the Precision is changed.
Public event | PrecisionValidating | Fired while validating the new value for Precision.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SelectedColorChanged | Fired when the SelectedColor is changed.
Public event | SelectedColorValidating | Fired while validating the new value for SelectedColor.
Public event | ShowNameChanged | Fired when the ShowName is changed.
Public event | ShowNameValidating | Fired while validating the new value for ShowName.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubGridChanged | Fired when the SubGrid is changed.
Public event | SubGridDivisionsChanged | Fired when the SubGridDivisions is changed.
Public event | SubGridDivisionsValidating | Fired while validating the new value for SubGridDivisions.
Public event | SubGridValidating | Fired while validating the new value for SubGrid.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseScientificNotationChanged | Fired when the UseScientificNotation is changed.
Public event | UseScientificNotationValidating | Fired while validating the new value for UseScientificNotation.
Public event | VisibleChanged | Fired when the Visible is changed.
Public event | VisibleValidating | Fired while validating the new value for Visible.
Top
See Also

Reference

AxisStyle Class


AxisStyle.ChannelRelatedGuidChanged Event

Fired when the ChannelRelatedGuid is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ChannelRelatedGuidChanged
Public Event ChannelRelatedGuidChanged As EventHandler
public:
 event EventHandler^ ChannelRelatedGuidChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.ChannelRelatedGuidValidating Event

Fired while validating the new value for ChannelRelatedGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ChannelRelatedGuidValidating
Public Event ChannelRelatedGuidValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ChannelRelatedGuidValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle.ColorModeChanged Event

Fired when the ColorMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ColorModeChanged
Public Event ColorModeChanged As EventHandler
public:
 event EventHandler^ ColorModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.ColorModeValidating Event

Fired while validating the new value for ColorMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ColorModeValidating
Public Event ColorModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ColorModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle.GridChanged Event

Fired when the Grid is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler GridChanged
Public Event GridChanged As EventHandler
public:
 event EventHandler^ GridChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.GridColorChanged Event

Fired when the GridColor is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler GridColorChanged
Public Event GridColorChanged As EventHandler
public:
 event EventHandler^ GridColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.GridColorValidating Event

Fired while validating the new value for GridColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> GridColorValidating
Public Event GridColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ GridColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle.GridDivisionsChanged Event

Fired when the GridDivisions is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler GridDivisionsChanged
Public Event GridDivisionsChanged As EventHandler
public:
 event EventHandler^ GridDivisionsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.GridDivisionsValidating Event

Fired while validating the new value for GridDivisions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> GridDivisionsValidating
Public Event GridDivisionsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ GridDivisionsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle.GridLineWidthChanged Event

Fired when the GridLineWidth is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler GridLineWidthChanged
Public Event GridLineWidthChanged As EventHandler
public:
 event EventHandler^ GridLineWidthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.GridLineWidthValidating Event

Fired while validating the new value for GridLineWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> GridLineWidthValidating
Public Event GridLineWidthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ GridLineWidthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle.GridValidating Event

Fired while validating the new value for Grid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> GridValidating
Public Event GridValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ GridValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle.LineWidthChanged Event

Fired when the LineWidth is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LineWidthChanged
Public Event LineWidthChanged As EventHandler
public:
 event EventHandler^ LineWidthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.LineWidthValidating Event

Fired while validating the new value for LineWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LineWidthValidating
Public Event LineWidthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LineWidthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle.PrecisionChanged Event

Fired when the Precision is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PrecisionChanged
Public Event PrecisionChanged As EventHandler
public:
 event EventHandler^ PrecisionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.PrecisionValidating Event

Fired while validating the new value for Precision.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PrecisionValidating
Public Event PrecisionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PrecisionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle.SelectedColorChanged Event

Fired when the SelectedColor is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SelectedColorChanged
Public Event SelectedColorChanged As EventHandler
public:
 event EventHandler^ SelectedColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.SelectedColorValidating Event

Fired while validating the new value for SelectedColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SelectedColorValidating
Public Event SelectedColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SelectedColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle.ShowNameChanged Event

Fired when the ShowName is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowNameChanged
Public Event ShowNameChanged As EventHandler
public:
 event EventHandler^ ShowNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.ShowNameValidating Event

Fired while validating the new value for ShowName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowNameValidating
Public Event ShowNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle.SubGridChanged Event

Fired when the SubGrid is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SubGridChanged
Public Event SubGridChanged As EventHandler
public:
 event EventHandler^ SubGridChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.SubGridDivisionsChanged Event

Fired when the SubGridDivisions is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SubGridDivisionsChanged
Public Event SubGridDivisionsChanged As EventHandler
public:
 event EventHandler^ SubGridDivisionsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.SubGridDivisionsValidating Event

Fired while validating the new value for SubGridDivisions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SubGridDivisionsValidating
Public Event SubGridDivisionsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SubGridDivisionsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle.SubGridValidating Event

Fired while validating the new value for SubGrid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SubGridValidating
Public Event SubGridValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SubGridValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle.UseScientificNotationChanged Event

Fired when the UseScientificNotation is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UseScientificNotationChanged
Public Event UseScientificNotationChanged As EventHandler
public:
 event EventHandler^ UseScientificNotationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.UseScientificNotationValidating Event

Fired while validating the new value for UseScientificNotation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UseScientificNotationValidating
Public Event UseScientificNotationValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UseScientificNotationValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle.VisibleChanged Event

Fired when the Visible is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler VisibleChanged
Public Event VisibleChanged As EventHandler
public:
 event EventHandler^ VisibleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AxisStyle Class


AxisStyle.VisibleValidating Event

Fired while validating the new value for Visible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> VisibleValidating
Public Event VisibleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ VisibleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

AxisStyle Class


AxisStyle Fields

The AxisStyle type exposes the following members.

Fields
Name | Description
DefaultDisplayColor | Get or Set the DefaultDisplayColor
DefaultGridColor | Get or Set the DefaultGridColor;
Top
See Also

Reference

AxisStyle Class


AxisStyle.DefaultDisplayColor Field

Get or Set the DefaultDisplayColor

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static Color DefaultDisplayColor
Public Shared DefaultDisplayColor As Color
public:
static Color DefaultDisplayColor

Field Value

Type: Color
See Also

Reference

AxisStyle Class


AxisStyle.DefaultGridColor Field

Get or Set the DefaultGridColor;

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static Color DefaultGridColor
Public Shared DefaultGridColor As Color
public:
static Color DefaultGridColor

Field Value

Type: Color
See Also

Reference

AxisStyle Class


BarChart Class

Scope Bar-Chart class
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAnchorTimeBase
TwinCAT.Measurement.Scope.API.ModelChart
TwinCAT.Measurement.Scope.API.ModelConnectableChart
TwinCAT.Measurement.Scope.API.ModelSingleValuesChart
TwinCAT.Measurement.Scope.API.ModelBarChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class BarChart : SingleValuesChart
Public Class BarChart
    Inherits SingleValuesChart
public ref class BarChart : public SingleValuesChart

The BarChart type exposes the following members.

Constructors
 | Name | Description
Public method | BarChart | Creates a new Empty BarChart
Public method | BarChart(BarChart) | Create a new Bar-Chart and copy Properties from old BarChart
Top
Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Inherited from SingleValuesChart.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Inherited from Chart.)
Public property | ChartType | (Overrides ChartChartType.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | PreferredSendTime | Gets or Sets the PreferredSendTime. (Inherited from SingleValuesChart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartDisplayWithoutOverview | (Inherited from SingleValuesChart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Chart.)
Public method | Validate | Validate the current configuration (Overrides ChartValidate.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | PreferredSendTimeChanged | Fired when the PreferredSendTime is changed. (Inherited from SingleValuesChart.)
Public event | PreferredSendTimeValidating | Fired while validating the new value for PreferredSendTime. (Inherited from SingleValuesChart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


BarChart Constructor

Overload List
 | Name | Description
Public method | BarChart | Creates a new Empty BarChart
Public method | BarChart(BarChart) | Create a new Bar-Chart and copy Properties from old BarChart
Top
See Also

Reference

BarChart Class


BarChart Constructor

Creates a new Empty BarChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public BarChart()
Public Sub New
public:
BarChart()
See Also

Reference

BarChart Class
BarChart Overload


BarChart Constructor (BarChart)

Create a new Bar-Chart and copy Properties from old BarChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public BarChart(
    BarChart barChart
)
Public Sub New (
    barChart As BarChart
)
public:
BarChart(
    BarChart^ barChart
)

Parameters

barChart
Type: TwinCAT.Measurement.Scope.API.ModelBarChart
See Also

Reference

BarChart Class
BarChart Overload


BarChart Properties

The BarChart type exposes the following members.

Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Inherited from SingleValuesChart.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Inherited from Chart.)
Public property | ChartType | (Overrides ChartChartType.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | PreferredSendTime | Gets or Sets the PreferredSendTime. (Inherited from SingleValuesChart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

BarChart Class


BarChart.ChartType Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public override ChartType ChartType { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ChartType As ChartType
    Get
public:
[BrowsableAttribute(false)]
virtual property ChartType ChartType {
    ChartType get () override;
}

Property Value

Type: ChartType
See Also

Reference

BarChart Class


BarChart Methods

The BarChart type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartDisplayWithoutOverview | (Inherited from SingleValuesChart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Chart.)
Public method | Validate | Validate the current configuration (Overrides ChartValidate.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
See Also

Reference

BarChart Class


BarChart.Validate Method

Validate the current configuration

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void Validate()
Public Overrides Sub Validate
public:
virtual void Validate() override
See Also

Reference

BarChart Class


BarChart Events

The BarChart type exposes the following members.

Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | PreferredSendTimeChanged | Fired when the PreferredSendTime is changed. (Inherited from SingleValuesChart.)
Public event | PreferredSendTimeValidating | Fired while validating the new value for PreferredSendTime. (Inherited from SingleValuesChart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

BarChart Class


BarChart Fields

The BarChart type exposes the following members.

Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

BarChart Class


BitmapArgs Class

Bitmap Event Args
Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.API.ModelBitmapArgs

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class BitmapArgs : EventArgs
Public Class BitmapArgs
    Inherits EventArgs
public ref class BitmapArgs : public EventArgs

The BitmapArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BitmapArgs | CTOR to Create BitmapArgs
Top
Properties
 | Name | Description
Public property | ByteImage | Image Data
Public property | Timestamp | Timestamp
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


BitmapArgs Constructor

CTOR to Create BitmapArgs

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public BitmapArgs(
    long timestamp,
    ByteImage byteImage
)
Public Sub New (
    timestamp As Long,
    byteImage As ByteImage
)
public:
BitmapArgs(
    long long timestamp,
    ByteImage^ byteImage
)

Parameters

timestamp
Type: SystemInt64
byteImage
Type: ByteImage
See Also

Reference

BitmapArgs Class


BitmapArgs Properties

The BitmapArgs type exposes the following members.

Properties
 | Name | Description
Public property | ByteImage | Image Data
Public property | Timestamp | Timestamp
Top
See Also

Reference

BitmapArgs Class


BitmapArgs.ByteImage Property

Image Data

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ByteImage ByteImage { get; }
Public ReadOnly Property ByteImage As ByteImage
    Get
public:
property ByteImage^ ByteImage {
    ByteImage^ get ();
}

Property Value

Type: ByteImage
See Also

Reference

BitmapArgs Class


BitmapArgs.Timestamp Property

Timestamp

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long Timestamp { get; }
Public ReadOnly Property Timestamp As Long
    Get
public:
property long long Timestamp {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

BitmapArgs Class


BitmapArgs Methods

The BitmapArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BitmapArgs Class


CapStyle Class

Style class for start- and endcap
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelCapStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class CapStyle : ScopeMemberBase
Public Class CapStyle
    Inherits ScopeMemberBase
public ref class CapStyle : public ScopeMemberBase

The CapStyle type exposes the following members.

Constructors
 | Name | Description
Public method | CapStyle | Create a new CapStyle
Public method | CapStyle(CapStyle) | Create a new CapStyle and CopyProperties
Top
Properties
 | Name | Description
Public property | CapSize | Gets or Sets the CapSize.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | EndCap | Gets or Sets the EndCap.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartCap | Gets or Sets the StartCap.
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of the Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CapSizeChanged | Fired when the CapSize is changed.
Public event | CapSizeValidating | Fired while validating the new value for CapSize.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EndCapChanged | Fired when the EndCap is changed.
Public event | EndCapValidating | Fired while validating the new value for EndCap.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartCapChanged | Fired when the StartCap is changed.
Public event | StartCapValidating | Fired while validating the new value for StartCap.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


CapStyle Constructor

Overload List
 | Name | Description
Public method | CapStyle | Create a new CapStyle
Public method | CapStyle(CapStyle) | Create a new CapStyle and CopyProperties
Top
See Also

Reference

CapStyle Class


CapStyle Constructor

Create a new CapStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public CapStyle()
Public Sub New
public:
CapStyle()
See Also

Reference

CapStyle Class
CapStyle Overload


CapStyle Constructor (CapStyle)

Create a new CapStyle and CopyProperties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public CapStyle(
    CapStyle org
)
Public Sub New (
    org As CapStyle
)
public:
CapStyle(
    CapStyle^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelCapStyle
Object to copy from
See Also

Reference

CapStyle Class
CapStyle Overload


CapStyle Properties

The CapStyle type exposes the following members.

Properties
 | Name | Description
Public property | CapSize | Gets or Sets the CapSize.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | EndCap | Gets or Sets the EndCap.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartCap | Gets or Sets the StartCap.
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

CapStyle Class


CapStyle.CapSize Property

Gets or Sets the CapSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public float CapSize { get; set; }
<BrowsableAttribute(true)>
Public Property CapSize As Single
    Get
    Set
public:
[BrowsableAttribute(true)]
property float CapSize {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

CapStyle Class


CapStyle.DisplayColor Property

Gets or Sets the DisplayColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public override Color DisplayColor { get; set; }
<BrowsableAttribute(true)>
Public Overrides Property DisplayColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property Color DisplayColor {
    Color get () override;
    void set (Color value) override;
}

Property Value

Type: Color
See Also

Reference

CapStyle Class


CapStyle.EndCap Property

Gets or Sets the EndCap.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool EndCap { get; set; }
<BrowsableAttribute(true)>
Public Property EndCap As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool EndCap {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CapStyle Class


CapStyle.StartCap Property

Gets or Sets the StartCap.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool StartCap { get; set; }
<BrowsableAttribute(true)>
Public Property StartCap As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool StartCap {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CapStyle Class


CapStyle Methods

The CapStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of the Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

CapStyle Class


CapStyle.UpdatePropertyAttributes Method

Update Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

CapStyle Class


CapStyle Events

The CapStyle type exposes the following members.

Events
 | Name | Description
Public event | CapSizeChanged | Fired when the CapSize is changed.
Public event | CapSizeValidating | Fired while validating the new value for CapSize.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EndCapChanged | Fired when the EndCap is changed.
Public event | EndCapValidating | Fired while validating the new value for EndCap.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartCapChanged | Fired when the StartCap is changed.
Public event | StartCapValidating | Fired while validating the new value for StartCap.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

CapStyle Class


CapStyle.CapSizeChanged Event

Fired when the CapSize is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CapSizeChanged
Public Event CapSizeChanged As EventHandler
public:
 event EventHandler^ CapSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

CapStyle Class


CapStyle.CapSizeValidating Event

Fired while validating the new value for CapSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> CapSizeValidating
Public Event CapSizeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ CapSizeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

CapStyle Class


CapStyle.EndCapChanged Event

Fired when the EndCap is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EndCapChanged
Public Event EndCapChanged As EventHandler
public:
 event EventHandler^ EndCapChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

CapStyle Class


CapStyle.EndCapValidating Event

Fired while validating the new value for EndCap.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EndCapValidating
Public Event EndCapValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EndCapValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

CapStyle Class


CapStyle.StartCapChanged Event

Fired when the StartCap is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StartCapChanged
Public Event StartCapChanged As EventHandler
public:
 event EventHandler^ StartCapChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

CapStyle Class


CapStyle.StartCapValidating Event

Fired while validating the new value for StartCap.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> StartCapValidating
Public Event StartCapValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ StartCapValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

CapStyle Class


Channel Class

Channel in Scope API project
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelChannel

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class Channel : ScopeMemberContainerBase
Public Class Channel
    Inherits ScopeMemberContainerBase
public ref class Channel : public ScopeMemberContainerBase

The Channel type exposes the following members.

Constructors
 | Name | Description
Public method | Channel | Create a new Channel
Public method | Channel(Channel) | Create a new Channel and copying Properties
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ContainedAcquisitions | Gets all underlying Acquisitions
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DynamicStyles |
Public property | Enabled | Gets or Sets the Enabled.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LayerAmount |
Public property | MaxContainedSampleTime | Gets or Sets the MaxContainedSampleTime.
Public property | MaxInterpreterCount | Gets or Sets the MaxInterpreterCount.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | Gets a underlying Style Object
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Adds a Member to the SubMemberList (Overrides MeasurementMemberContainerBaseAddMember(MeasurementMemberBase).)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddSequenceData |
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChannelTime | Gets the Time of a position
Public method | GetCommands | Gets a List of possible Commands for this Element (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInnerCommands |
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | Highlight the Graph of this channel
Public method | Highlight(Int64, Int64) | Hightlight a part of the graph of this channel
Public method | HighlightLayer |
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Return the Name of the Channel (Overrides ObjectToString.)
Public method | TryValidate(Chart) | Validate the channel depending on the Parent Chart
Public method | TryValidate(ScopeDisplayModes) | Validate the channel depending on the Parent Chart
Public method | UpdatePropertyAttributes | Updates Attributes of Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | Validate | Validate the Channel
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AddItemsToContextMenu | Fired to get commands for the context menu.
Public event | ClearData | Raised when the graph should clear the data.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightEvent | Event fired to Highlight Channel
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MaxInterpreterCountChanged | Fired when the MaxInterpreterCount is changed.
Public event | MaxInterpreterCountValidating | Fired while validating the new value for MaxInterpreterCount.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NewData | Fired, when new data is available for Main Graph
Public event | NewOverviewData | Fired, when new Data is available for OverviewGraph
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Fields
 | Name | Description
Public field | arrayIndicesMinMax | The Indicees for an ArrayBarMinMax Graph
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


Channel Constructor

Overload List
 | Name | Description
Public method | Channel | Create a new Channel
Public method | Channel(Channel) | Create a new Channel and copying Properties
Top
See Also

Reference

Channel Class


Channel Constructor

Create a new Channel

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Channel()
Public Sub New
public:
Channel()
See Also

Reference

Channel Class
Channel Overload


Channel Constructor (Channel)

Create a new Channel and copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Channel(
    Channel channel
)
Public Sub New (
    channel As Channel
)
public:
Channel(
    Channel^ channel
)

Parameters

channel
Type: TwinCAT.Measurement.Scope.API.ModelChannel
Object to copy Properties from
See Also

Reference

Channel Class
Channel Overload


Channel Properties

The Channel type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ContainedAcquisitions | Gets all underlying Acquisitions
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DynamicStyles |
Public property | Enabled | Gets or Sets the Enabled.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LayerAmount |
Public property | MaxContainedSampleTime | Gets or Sets the MaxContainedSampleTime.
Public property | MaxInterpreterCount | Gets or Sets the MaxInterpreterCount.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | Gets a underlying Style Object
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

Channel Class


Channel.ContainedAcquisitions Property

Gets all underlying Acquisitions

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public IEnumerable<Acquisition> ContainedAcquisitions { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property ContainedAcquisitions As IEnumerable(Of Acquisition)
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property IEnumerable<Acquisition^>^ ContainedAcquisitions {
    IEnumerable<Acquisition^>^ get ();
}

Property Value

Type: IEnumerable Acquisition
See Also

Reference

Channel Class


Channel.DisplayColor Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public override Color DisplayColor { get; set; }
<BrowsableAttribute(true)>
Public Overrides Property DisplayColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property Color DisplayColor {
    Color get () override;
    void set (Color value) override;
}

Property Value

Type: Color
See Also

Reference

Channel Class


Channel.DynamicStyles Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public DynamicStyleContainer DynamicStyles { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property DynamicStyles As DynamicStyleContainer
    Get
public:
[BrowsableAttribute(false)]
property DynamicStyleContainer^ DynamicStyles {
    DynamicStyleContainer^ get ();
}

Property Value

Type: DynamicStyleContainer
See Also

Reference

Channel Class


Channel.Enabled Property

Gets or Sets the Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Enabled { get; set; }
<BrowsableAttribute(true)>
Public Property Enabled As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Channel Class


Channel.LayerAmount Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public int LayerAmount { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property LayerAmount As Integer
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property int LayerAmount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Channel Class


Channel.MaxContainedSampleTime Property

Gets or Sets the MaxContainedSampleTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public uint MaxContainedSampleTime { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property MaxContainedSampleTime As UInteger
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property unsigned int MaxContainedSampleTime {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

Channel Class


Channel.MaxInterpreterCount Property

Gets or Sets the MaxInterpreterCount.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public int MaxInterpreterCount { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property MaxInterpreterCount As Integer
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property int MaxInterpreterCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Channel Class


Channel.Style Property

Gets a underlying Style Object

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public ChannelStyle Style { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property Style As ChannelStyle
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property ChannelStyle^ Style {
    ChannelStyle^ get ();
}

Property Value

Type: ChannelStyle
See Also

Reference

Channel Class


Channel Methods

The Channel type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Adds a Member to the SubMemberList (Overrides MeasurementMemberContainerBaseAddMember(MeasurementMemberBase).)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddSequenceData |
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChannelTime | Gets the Time of a position
Public method | GetCommands | Gets a List of possible Commands for this Element (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInnerCommands |
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | Highlight the Graph of this channel
Public method | Highlight(Int64, Int64) | Hightlight a part of the graph of this channel
Public method | HighlightLayer |
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Return the Name of the Channel (Overrides ObjectToString.)
Public method | TryValidate(Chart) | Validate the channel depending on the Parent Chart
Public method | TryValidate(ScopeDisplayModes) | Validate the channel depending on the Parent Chart
Public method | UpdatePropertyAttributes | Updates Attributes of Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | Validate | Validate the Channel
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

Channel Class


Channel.AddMember Method

Adds a Member to the SubMemberList

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void AddMember(
    MeasurementMemberBase add
)
Public Overrides Sub AddMember (
    add As MeasurementMemberBase
)
public:
virtual void AddMember(
    MeasurementMemberBase^ add
) override

Parameters

add
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
Member to add
See Also

Reference

Channel Class


Channel.AddSequenceData Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void AddSequenceData(
    UpdateDataSequenceEventArgs data
)
Public Sub AddSequenceData (
    data As UpdateDataSequenceEventArgs
)
public:
void AddSequenceData(
    UpdateDataSequenceEventArgs^ data
)

Parameters

data
Type: TwinCAT.Measurement.Scope.APIUpdateDataSequenceEventArgs
See Also

Reference

Channel Class


Channel.GetChannelTime Method

Gets the Time of a position

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long GetChannelTime(
    int posIdx
)
Public Function GetChannelTime (
    posIdx As Integer
) As Long
public:
long long GetChannelTime(
    int posIdx
)

Parameters

posIdx
Type: SystemInt32

Return Value

Type: Int64
See Also

Reference

Channel Class


Channel.GetCommands Method

Gets a List of possible Commands for this Element

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
An Array of Commands
See Also

Reference

Channel Class


Channel.GetInnerCommands Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void GetInnerCommands(
    EventArgs e
)
Public Sub GetInnerCommands (
    e As EventArgs
)
public:
void GetInnerCommands(
    EventArgs^ e
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

Channel Class


Channel.Highlight Method

Overload List
 | Name | Description
Public method | Highlight | Highlight the Graph of this channel
Public method | Highlight(Int64, Int64) | Hightlight a part of the graph of this channel
Top
See Also

Reference

Channel Class


Channel.Highlight Method

Highlight the Graph of this channel

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Highlight()
Public Sub Highlight
public:
virtual void Highlight() sealed
See Also

Reference

Channel Class
Highlight Overload


Channel.Highlight Method (Int64, Int64)

Hightlight a part of the graph of this channel

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Highlight(
    long startTime,
    long endTime
)
Public Sub Highlight (
    startTime As Long,
    endTime As Long
)
public:
void Highlight(
    long long startTime,
    long long endTime
)

Parameters

startTime
Type: SystemInt64
endTime
Type: SystemInt64
See Also

Reference

Channel Class
Highlight Overload


Channel.HighlightLayer Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void HighlightLayer(
    Guid layerGuid
)
Public Sub HighlightLayer (
    layerGuid As Guid
)
public:
void HighlightLayer(
    Guid layerGuid
)

Parameters

layerGuid
Type: SystemGuid
See Also

Reference

Channel Class


Channel.ToString Method

Return the Name of the Channel

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
Name
See Also

Reference

Channel Class


Channel.TryValidate Method

Overload List
 | Name | Description
Public method | TryValidate(Chart) | Validate the channel depending on the Parent Chart
Public method | TryValidate(ScopeDisplayModes) | Validate the channel depending on the Parent Chart
Top
See Also

Reference

Channel Class


Channel.TryValidate Method (Chart)

Validate the channel depending on the Parent Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool TryValidate(
    Chart chart
)
Public Function TryValidate (
    chart As Chart
) As Boolean
public:
bool TryValidate(
    Chart^ chart
)

Parameters

chart
Type: TwinCAT.Measurement.Scope.API.ModelChart
Include the parent chart in this param

Return Value

Type: Boolean
True if validation was successfull
See Also

Reference

Channel Class
TryValidate Overload


Channel.TryValidate Method (ScopeDisplayModes)

Validate the channel depending on the Parent Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool TryValidate(
    ScopeDisplayModes Mode
)
Public Function TryValidate (
    Mode As ScopeDisplayModes
) As Boolean
public:
bool TryValidate(
    ScopeDisplayModes Mode
)

Parameters

Mode
Type: TwinCAT.Measurement.Scope.APIScopeDisplayModes
The DisplayMode of the Chart

Return Value

Type: Boolean
True if validation was successfull
See Also

Reference

Channel Class
TryValidate Overload


Channel.UpdatePropertyAttributes Method

Updates Attributes of Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

Channel Class


Channel.Validate Method

Validate the Channel

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Validate(
    ScopeDisplayModes Mode
)
Public Sub Validate (
    Mode As ScopeDisplayModes
)
public:
void Validate(
    ScopeDisplayModes Mode
)

Parameters

Mode
Type: TwinCAT.Measurement.Scope.APIScopeDisplayModes
The DisplayMode of the Chart
See Also

Reference

Channel Class


Channel Events

The Channel type exposes the following members.

Events
 | Name | Description
Public event | AddItemsToContextMenu | Fired to get commands for the context menu.
Public event | ClearData | Raised when the graph should clear the data.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightEvent | Event fired to Highlight Channel
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MaxInterpreterCountChanged | Fired when the MaxInterpreterCount is changed.
Public event | MaxInterpreterCountValidating | Fired while validating the new value for MaxInterpreterCount.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NewData | Fired, when new data is available for Main Graph
Public event | NewOverviewData | Fired, when new Data is available for OverviewGraph
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

Channel Class


Channel.AddItemsToContextMenu Event

Fired to get commands for the context menu.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AddItemsToContextMenu
Public Event AddItemsToContextMenu As EventHandler
public:
 event EventHandler^ AddItemsToContextMenu {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Channel Class


Channel.ClearData Event

Raised when the graph should clear the data.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ClearData
Public Event ClearData As EventHandler
public:
 event EventHandler^ ClearData {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Channel Class


Channel.EnabledChanged Event

Fired when the Enabled is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EnabledChanged
Public Event EnabledChanged As EventHandler
public:
 event EventHandler^ EnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Channel Class


Channel.EnabledValidating Event

Fired while validating the new value for Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EnabledValidating
Public Event EnabledValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EnabledValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Channel Class


Channel.HighlightEvent Event

Event fired to Highlight Channel

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<HighlightEventArgs> HighlightEvent
Public Event HighlightEvent As EventHandler(Of HighlightEventArgs)
public:
 event EventHandler<HighlightEventArgs^>^ HighlightEvent {
    void add (EventHandler<HighlightEventArgs^>^ value);
    void remove (EventHandler<HighlightEventArgs^>^ value);
}

Value

Type: SystemEventHandler HighlightEventArgs
See Also

Reference

Channel Class


Channel.MaxInterpreterCountChanged Event

Fired when the MaxInterpreterCount is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler MaxInterpreterCountChanged
Public Event MaxInterpreterCountChanged As EventHandler
public:
 event EventHandler^ MaxInterpreterCountChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Channel Class


Channel.MaxInterpreterCountValidating Event

Fired while validating the new value for MaxInterpreterCount.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> MaxInterpreterCountValidating
Public Event MaxInterpreterCountValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ MaxInterpreterCountValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Channel Class


Channel.NewData Event

Fired, when new data is available for Main Graph

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<AddDataEventArgs> NewData
Public Event NewData As EventHandler(Of AddDataEventArgs)
public:
 event EventHandler<AddDataEventArgs^>^ NewData {
    void add (EventHandler<AddDataEventArgs^>^ value);
    void remove (EventHandler<AddDataEventArgs^>^ value);
}

Value

Type: SystemEventHandler AddDataEventArgs
See Also

Reference

Channel Class


Channel.NewOverviewData Event

Fired, when new Data is available for OverviewGraph

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<AddDataYTEventArgs> NewOverviewData
Public Event NewOverviewData As EventHandler(Of AddDataYTEventArgs)
public:
 event EventHandler<AddDataYTEventArgs^>^ NewOverviewData {
    void add (EventHandler<AddDataYTEventArgs^>^ value);
    void remove (EventHandler<AddDataYTEventArgs^>^ value);
}

Value

Type: SystemEventHandler AddDataYTEventArgs
See Also

Reference

Channel Class


Channel Fields

The Channel type exposes the following members.

Fields
 | Name | Description
Public field | arrayIndicesMinMax | The Indicees for an ArrayBarMinMax Graph
Top
See Also

Reference

Channel Class


Channel.arrayIndicesMinMax Field

The Indicees for an ArrayBarMinMax Graph

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long[] arrayIndicesMinMax
Public arrayIndicesMinMax As Long()
public:
array<long long>^ arrayIndicesMinMax

Field Value

Type: Int64
See Also

Reference

Channel Class


ChannelLayer Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelChannelLayer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChannelLayer : ScopeMemberContainerBase
Public Class ChannelLayer
    Inherits ScopeMemberContainerBase
public ref class ChannelLayer : public ScopeMemberContainerBase

The ChannelLayer type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelLayer | Create a new instance of a ChannelLayer
Public method | ChannelLayer(Guid) | Create a new instance of a ChannelLayer with a specific LayerIndex
Public method | ChannelLayer(ChannelLayer) | Create a new instance of a ChannelLayer and copy propertie settings
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsFullLayerVisible | Gets or Sets the IsFullLayerVisible.
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RelatedChartLayer | Gets or Sets the RelatedChartLayer.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style |
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight |
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ClearData | Raised when the graph should clear the data.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightEvent | Fired, when the ChannelLayer should highlight
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsFullLayerVisibleChanged | Fired when the IsFullLayerVisible is changed.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NewData | Fired, when new data is available for Main Graph
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | RelatedChartLayerChanged | Fired when the RelatedChartLayer is changed.
Public event | RelatedChartLayerValidating | Fired while validating the new value for RelatedChartLayer.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ChannelLayer Constructor

Overload List
 | Name | Description
Public method | ChannelLayer | Create a new instance of a ChannelLayer
Public method | ChannelLayer(Guid) | Create a new instance of a ChannelLayer with a specific LayerIndex
Public method | ChannelLayer(ChannelLayer) | Create a new instance of a ChannelLayer and copy propertie settings
Top
See Also

Reference

ChannelLayer Class


ChannelLayer Constructor

Create a new instance of a ChannelLayer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChannelLayer()
Public Sub New
public:
ChannelLayer()
See Also

Reference

ChannelLayer Class
ChannelLayer Overload


ChannelLayer Constructor (Guid)

Create a new instance of a ChannelLayer with a specific LayerIndex

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChannelLayer(
    Guid layerGuid
)
Public Sub New (
    layerGuid As Guid
)
public:
ChannelLayer(
    Guid layerGuid
)

Parameters

layerGuid
Type: SystemGuid
Specific Channel Layer
See Also

Reference

ChannelLayer Class
ChannelLayer Overload


ChannelLayer Constructor (ChannelLayer)

Create a new instance of a ChannelLayer and copy propertie settings

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChannelLayer(
    ChannelLayer channelLayer
)
Public Sub New (
    channelLayer As ChannelLayer
)
public:
ChannelLayer(
    ChannelLayer^ channelLayer
)

Parameters

channelLayer
Type: TwinCAT.Measurement.Scope.API.ModelChannelLayer
See Also

Reference

ChannelLayer Class
ChannelLayer Overload


ChannelLayer Properties

The ChannelLayer type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsFullLayerVisible | Gets or Sets the IsFullLayerVisible.
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RelatedChartLayer | Gets or Sets the RelatedChartLayer.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style |
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChannelLayer Class


ChannelLayer.IsFullLayerVisible Property

Gets or Sets the IsFullLayerVisible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool IsFullLayerVisible { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property IsFullLayerVisible As Boolean
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool IsFullLayerVisible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ChannelLayer Class


ChannelLayer.RelatedChartLayer Property

Gets or Sets the RelatedChartLayer.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public Guid RelatedChartLayer { get; set; }
<BrowsableAttribute(false)>
Public Property RelatedChartLayer As Guid
    Get
    Set
public:
[BrowsableAttribute(false)]
property Guid RelatedChartLayer {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

ChannelLayer Class


ChannelLayer.Style Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
public ChannelStyle Style { get; }
<XmlIgnoreAttribute>
Public ReadOnly Property Style As ChannelStyle
    Get
public:
[XmlIgnoreAttribute]
property ChannelStyle^ Style {
    ChannelStyle^ get ();
}

Property Value

Type: ChannelStyle
See Also

Reference

ChannelLayer Class


ChannelLayer Methods

The ChannelLayer type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight |
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChannelLayer Class


ChannelLayer.Highlight Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Highlight()
Public Sub Highlight
public:
void Highlight()
See Also

Reference

ChannelLayer Class


ChannelLayer Events

The ChannelLayer type exposes the following members.

Events
 | Name | Description
Public event | ClearData | Raised when the graph should clear the data.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightEvent | Fired, when the ChannelLayer should highlight
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsFullLayerVisibleChanged | Fired when the IsFullLayerVisible is changed.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NewData | Fired, when new data is available for Main Graph
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | RelatedChartLayerChanged | Fired when the RelatedChartLayer is changed.
Public event | RelatedChartLayerValidating | Fired while validating the new value for RelatedChartLayer.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChannelLayer Class


ChannelLayer.ClearData Event

Raised when the graph should clear the data.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ClearData
Public Event ClearData As EventHandler
public:
 event EventHandler^ ClearData {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChannelLayer Class


ChannelLayer.HighlightEvent Event

Fired, when the ChannelLayer should highlight

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler HighlightEvent
Public Event HighlightEvent As EventHandler
public:
 event EventHandler^ HighlightEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChannelLayer Class


ChannelLayer.IsFullLayerVisibleChanged Event

Fired when the IsFullLayerVisible is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IsFullLayerVisibleChanged
Public Event IsFullLayerVisibleChanged As EventHandler
public:
 event EventHandler^ IsFullLayerVisibleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChannelLayer Class


ChannelLayer.NewData Event

Fired, when new data is available for Main Graph

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<AddDataEventArgs> NewData
Public Event NewData As EventHandler(Of AddDataEventArgs)
public:
 event EventHandler<AddDataEventArgs^>^ NewData {
    void add (EventHandler<AddDataEventArgs^>^ value);
    void remove (EventHandler<AddDataEventArgs^>^ value);
}

Value

Type: SystemEventHandler AddDataEventArgs
See Also

Reference

ChannelLayer Class


ChannelLayer.RelatedChartLayerChanged Event

Fired when the RelatedChartLayer is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler RelatedChartLayerChanged
Public Event RelatedChartLayerChanged As EventHandler
public:
 event EventHandler^ RelatedChartLayerChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChannelLayer Class


ChannelLayer.RelatedChartLayerValidating Event

Fired while validating the new value for RelatedChartLayer.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> RelatedChartLayerValidating
Public Event RelatedChartLayerValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ RelatedChartLayerValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChannelLayer Class


ChannelStyle Class

Style Class for Scope Project Channel
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelChannelStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChannelStyle : ScopeMemberContainerBase
Public Class ChannelStyle
    Inherits ScopeMemberContainerBase
public ref class ChannelStyle : public ScopeMemberContainerBase

The ChannelStyle type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelStyle | Create a new ChannelStyle
Public method | ChannelStyle(ChannelStyle) | Create a new ChannelStyle by copying Properties
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | Visible | Gets or Sets the Visible.
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | SubStyleT | Get the First Submember with the Specific Type
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | VisibleChanged | Fired when the Visible is changed.
Public event | VisibleValidating | Fired while validating the new value for Visible.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ChannelStyle Constructor

Overload List
 | Name | Description
Public method | ChannelStyle | Create a new ChannelStyle
Public method | ChannelStyle(ChannelStyle) | Create a new ChannelStyle by copying Properties
Top
See Also

Reference

ChannelStyle Class


ChannelStyle Constructor

Create a new ChannelStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChannelStyle()
Public Sub New
public:
ChannelStyle()
See Also

Reference

ChannelStyle Class
ChannelStyle Overload


ChannelStyle Constructor (ChannelStyle)

Create a new ChannelStyle by copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChannelStyle(
    ChannelStyle style
)
Public Sub New (
    style As ChannelStyle
)
public:
ChannelStyle(
    ChannelStyle^ style
)

Parameters

style
Type: TwinCAT.Measurement.Scope.API.ModelChannelStyle
Object to copy Properties from
See Also

Reference

ChannelStyle Class
ChannelStyle Overload


ChannelStyle Properties

The ChannelStyle type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | Visible | Gets or Sets the Visible.
Top
See Also

Reference

ChannelStyle Class


ChannelStyle.Visible Property

Gets or Sets the Visible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Visible { get; set; }
<BrowsableAttribute(true)>
Public Property Visible As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Visible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChannelStyle Class


ChannelStyle Methods

The ChannelStyle type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | SubStyleT | Get the First Submember with the Specific Type
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChannelStyle Class


ChannelStyle.SubStyle(T) Method

Get the First Submember with the Specific Type

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public T SubStyle<T>()
where T : MeasurementMemberBase

Public Function SubStyle(Of T As MeasurementMemberBase) As T
public:
generic<typename T>
where T : MeasurementMemberBase
T SubStyle()

Type Parameters

T
The Type of SubMember

Return Value

Type: T
The Element or null
See Also

Reference

ChannelStyle Class


ChannelStyle.UpdatePropertyAttributes Method

Update the Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ChannelStyle Class


ChannelStyle Events

The ChannelStyle type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | VisibleChanged | Fired when the Visible is changed.
Public event | VisibleValidating | Fired while validating the new value for Visible.
Top
See Also

Reference

ChannelStyle Class


ChannelStyle.VisibleChanged Event

Fired when the Visible is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler VisibleChanged
Public Event VisibleChanged As EventHandler
public:
 event EventHandler^ VisibleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChannelStyle Class


ChannelStyle.VisibleValidating Event

Fired while validating the new value for Visible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> VisibleValidating
Public Event VisibleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ VisibleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChannelStyle Class


ChannelTriggerSet Class

Channel Trigger Set Class in TwinCAT 3 Scope API Model
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelTriggerSet
TwinCAT.Measurement.Scope.API.ModelServerTriggerSet
TwinCAT.Measurement.Scope.API.ModelChannelTriggerSet

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChannelTriggerSet : ServerTriggerSet
Public Class ChannelTriggerSet
    Inherits ServerTriggerSet
public ref class ChannelTriggerSet : public ServerTriggerSet

The ChannelTriggerSet type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelTriggerSet | Creates an instance of a ChannelTriggerSet
Public method | ChannelTriggerSet(ChannelTriggerSet) | Creates an instance of a ChannelTriggerSet and copy values from org
Top
Properties
 | Name | Description
Public property | AcquisitionInterpreterGuid | Gets or Sets the AcquisitionInterpreterGuid.
Public property | ClientTriggerHandle | Gets or Sets the ClientTriggerHandle. (Inherited from TriggerSet.)
Public property | CombineOption | Gets or Sets the CombineOption. (Inherited from ServerTriggerSet.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ConnectedAcquisitionInterpreter | Gets or Sets the ConnectedAcquisitionInterpreter.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from TriggerSet.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GroupHandle | Gets or Sets the GroupHandle. (Inherited from TriggerSet.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsReleased | Gets or Sets the IsReleased. (Inherited from TriggerSet.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReleaseOption | Gets or Sets the ReleaseOption.
Public property | ReusedAcquisitionOrInterpreter | Obsolete. Gets or Sets the ReusedAcquisitionOrInterpreter.
Public property | ReusedAcquisitionOrInterpreterGuid | Gets or Sets the ReusedAcquisitionOrInterpreter.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Threshold | Gets or Sets the Threshold.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | BindToGroup | bind this instance to a TriggerGroup (Overrides ServerTriggerSetBindToGroup(IClientTriggerGroup, Boolean).)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Menucommands for thie Element (Inherited from ServerTriggerSet.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | ManualSetReleased | Release Trigger manual (Inherited from ServerTriggerSet.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides ServerTriggerSetUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AcquisitionGuidChanged | Fired when the AcquisitionInterpreterGuid is changed.
Public event | AcquisitionGuidValidating | Fired while validating the new value for AcquisitionInterpreterGuid.
Public event | BeforeConnectedAcquisitionInterpreterChanged | Fired before the new value for ConnectedAcquisitionInterpreter changed.
Public event | ClientTriggerHandleChanged | Fired when the ClientTriggerHandle is changed. (Inherited from TriggerSet.)
Public event | ClientTriggerHandleValidating | Fired while validating the new value for ClientTriggerHandle. (Inherited from TriggerSet.)
Public event | CombineOptionChanged | Fired when the CombineOption is changed. (Inherited from ServerTriggerSet.)
Public event | CombineOptionValidating | Fired while validating the new value for CombineOption. (Inherited from ServerTriggerSet.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedAcquisitionInterpreterChanged | Fired when the ConnectedAcquisitionInterpreter is changed.
Public event | ConnectedAcquisitionInterpreterValidating | Fired while validating the new value for ConnectedAcquisitionInterpreter.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from TriggerSet.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from TriggerSet.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GroupHandleChanged | Fired when the GroupHandle is changed. (Inherited from TriggerSet.)
Public event | GroupHandleValidating | Fired while validating the new value for GroupHandle. (Inherited from TriggerSet.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsReleasedChanged | Fired when the IsReleased is changed. (Inherited from TriggerSet.)
Public event | IsReleasedValidating | Fired while validating the new value for IsReleased. (Inherited from TriggerSet.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReleaseOptionChanged | Fired when the ReleaseOption is changed.
Public event | ReleaseOptionValidating | Fired while validating the new value for ReleaseOption.
Public event | ReusedAcquisitionOrInterpreterGuidChanged | Fired when the ReusedAcquisitionOrInterpreterGuid is changed.
Public event | ReusedAcquisitionOrInterpreterGuidValidating | Fired while validating the new value for ReusedAcquisitionOrInterpreterGuid.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | ThresholdChanged | Fired when the Threshold is changed.
Public event | ThresholdValidating | Fired while validating the new value for Threshold.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ChannelTriggerSet Constructor

Overload List
 | Name | Description
Public method | ChannelTriggerSet | Creates an instance of a ChannelTriggerSet
Public method | ChannelTriggerSet(ChannelTriggerSet) | Creates an instance of a ChannelTriggerSet and copy values from org
Top
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet Constructor

Creates an instance of a ChannelTriggerSet

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChannelTriggerSet()
Public Sub New
public:
ChannelTriggerSet()
See Also

Reference

ChannelTriggerSet Class
ChannelTriggerSet Overload


ChannelTriggerSet Constructor (ChannelTriggerSet)

Creates an instance of a ChannelTriggerSet and copy values from org

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChannelTriggerSet(
    ChannelTriggerSet org
)
Public Sub New (
    org As ChannelTriggerSet
)
public:
ChannelTriggerSet(
    ChannelTriggerSet^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelChannelTriggerSet
See Also

Reference

ChannelTriggerSet Class
ChannelTriggerSet Overload


ChannelTriggerSet Properties

The ChannelTriggerSet type exposes the following members.

Properties
 | Name | Description
Public property | AcquisitionInterpreterGuid | Gets or Sets the AcquisitionInterpreterGuid.
Public property | ClientTriggerHandle | Gets or Sets the ClientTriggerHandle. (Inherited from TriggerSet.)
Public property | CombineOption | Gets or Sets the CombineOption. (Inherited from ServerTriggerSet.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ConnectedAcquisitionInterpreter | Gets or Sets the ConnectedAcquisitionInterpreter.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from TriggerSet.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GroupHandle | Gets or Sets the GroupHandle. (Inherited from TriggerSet.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsReleased | Gets or Sets the IsReleased. (Inherited from TriggerSet.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReleaseOption | Gets or Sets the ReleaseOption.
Public property | ReusedAcquisitionOrInterpreter | Obsolete. Gets or Sets the ReusedAcquisitionOrInterpreter.
Public property | ReusedAcquisitionOrInterpreterGuid | Gets or Sets the ReusedAcquisitionOrInterpreter.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Threshold | Gets or Sets the Threshold.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.AcquisitionInterpreterGuid Property

Gets or Sets the AcquisitionInterpreterGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public Guid AcquisitionInterpreterGuid { get; set; }
<BrowsableAttribute(false)>
Public Property AcquisitionInterpreterGuid As Guid
    Get
    Set
public:
[BrowsableAttribute(false)]
property Guid AcquisitionInterpreterGuid {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.ConnectedAcquisitionInterpreter Property

Gets or Sets the ConnectedAcquisitionInterpreter.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public AcquisitionInterpreter ConnectedAcquisitionInterpreter { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property ConnectedAcquisitionInterpreter As AcquisitionInterpreter
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property AcquisitionInterpreter^ ConnectedAcquisitionInterpreter {
    AcquisitionInterpreter^ get ();
    void set (AcquisitionInterpreter^ value);
}

Property Value

Type: AcquisitionInterpreter
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.ReleaseOption Property

Gets or Sets the ReleaseOption.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public TriggerReleaseOptions ReleaseOption { get; set; }
<BrowsableAttribute(true)>
Public Property ReleaseOption As TriggerReleaseOptions
    Get
    Set
public:
[BrowsableAttribute(true)]
property TriggerReleaseOptions ReleaseOption {
    TriggerReleaseOptions get ();
    void set (TriggerReleaseOptions value);
}

Property Value

Type: TriggerReleaseOptions
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.ReusedAcquisitionOrInterpreter Property

Note: This API is now obsolete.

Gets or Sets the ReusedAcquisitionOrInterpreter.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
[ObsoleteAttribute("ReusedAcquisitionOrInterpreter is Obsolete pls use ReusedAcquisitionOrInterpreterGuid instead")]
public MeasurementMemberBase ReusedAcquisitionOrInterpreter { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
<ObsoleteAttribute("ReusedAcquisitionOrInterpreter is Obsolete pls use ReusedAcquisitionOrInterpreterGuid instead")>
Public Property ReusedAcquisitionOrInterpreter As MeasurementMemberBase
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
[ObsoleteAttribute(L"ReusedAcquisitionOrInterpreter is Obsolete pls use ReusedAcquisitionOrInterpreterGuid instead")]
property MeasurementMemberBase^ ReusedAcquisitionOrInterpreter {
    MeasurementMemberBase^ get ();
    void set (MeasurementMemberBase^ value);
}

Property Value

Type: MeasurementMemberBase
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.ReusedAcquisitionOrInterpreterGuid Property

Gets or Sets the ReusedAcquisitionOrInterpreter.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
public Guid ReusedAcquisitionOrInterpreterGuid { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(true)>
Public Property ReusedAcquisitionOrInterpreterGuid As Guid
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
property Guid ReusedAcquisitionOrInterpreterGuid {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.Threshold Property

Gets or Sets the Threshold.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double Threshold { get; set; }
<BrowsableAttribute(true)>
Public Property Threshold As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double Threshold {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet Methods

The ChannelTriggerSet type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | BindToGroup | bind this instance to a TriggerGroup (Overrides ServerTriggerSetBindToGroup(IClientTriggerGroup, Boolean).)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Menucommands for thie Element (Inherited from ServerTriggerSet.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | ManualSetReleased | Release Trigger manual (Inherited from ServerTriggerSet.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides ServerTriggerSetUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.BindToGroup Method

bind this instance to a TriggerGroup

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void BindToGroup(
    IClientTriggerGroup TriggerGroup,
    bool reattach = false
)
Public Overrides Sub BindToGroup (
    TriggerGroup As IClientTriggerGroup,
    Optional reattach As Boolean = false
)
public:
virtual void BindToGroup(
    IClientTriggerGroup^ TriggerGroup,
    bool reattach = false
) override

Parameters

TriggerGroup
Type: IClientTriggerGroup
TriggerGroup to attach to
reattach (Optional)
Type: SystemBoolean
Determines wether the TriggerSet should be reattached to an active client
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.UpdatePropertyAttributes Method

Sets the value off Propertyattributes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet Events

The ChannelTriggerSet type exposes the following members.

Events
 | Name | Description
Public event | AcquisitionGuidChanged | Fired when the AcquisitionInterpreterGuid is changed.
Public event | AcquisitionGuidValidating | Fired while validating the new value for AcquisitionInterpreterGuid.
Public event | BeforeConnectedAcquisitionInterpreterChanged | Fired before the new value for ConnectedAcquisitionInterpreter changed.
Public event | ClientTriggerHandleChanged | Fired when the ClientTriggerHandle is changed. (Inherited from TriggerSet.)
Public event | ClientTriggerHandleValidating | Fired while validating the new value for ClientTriggerHandle. (Inherited from TriggerSet.)
Public event | CombineOptionChanged | Fired when the CombineOption is changed. (Inherited from ServerTriggerSet.)
Public event | CombineOptionValidating | Fired while validating the new value for CombineOption. (Inherited from ServerTriggerSet.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedAcquisitionInterpreterChanged | Fired when the ConnectedAcquisitionInterpreter is changed.
Public event | ConnectedAcquisitionInterpreterValidating | Fired while validating the new value for ConnectedAcquisitionInterpreter.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from TriggerSet.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from TriggerSet.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GroupHandleChanged | Fired when the GroupHandle is changed. (Inherited from TriggerSet.)
Public event | GroupHandleValidating | Fired while validating the new value for GroupHandle. (Inherited from TriggerSet.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsReleasedChanged | Fired when the IsReleased is changed. (Inherited from TriggerSet.)
Public event | IsReleasedValidating | Fired while validating the new value for IsReleased. (Inherited from TriggerSet.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReleaseOptionChanged | Fired when the ReleaseOption is changed.
Public event | ReleaseOptionValidating | Fired while validating the new value for ReleaseOption.
Public event | ReusedAcquisitionOrInterpreterGuidChanged | Fired when the ReusedAcquisitionOrInterpreterGuid is changed.
Public event | ReusedAcquisitionOrInterpreterGuidValidating | Fired while validating the new value for ReusedAcquisitionOrInterpreterGuid.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | ThresholdChanged | Fired when the Threshold is changed.
Public event | ThresholdValidating | Fired while validating the new value for Threshold.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.AcquisitionGuidChanged Event

Fired when the AcquisitionInterpreterGuid is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AcquisitionGuidChanged
Public Event AcquisitionGuidChanged As EventHandler
public:
 event EventHandler^ AcquisitionGuidChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.AcquisitionGuidValidating Event

Fired while validating the new value for AcquisitionInterpreterGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AcquisitionGuidValidating
Public Event AcquisitionGuidValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AcquisitionGuidValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.BeforeConnectedAcquisitionInterpreterChanged Event

Fired before the new value for ConnectedAcquisitionInterpreter changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeConnectedAcquisitionInterpreterChanged
Public Event BeforeConnectedAcquisitionInterpreterChanged As EventHandler
public:
 event EventHandler^ BeforeConnectedAcquisitionInterpreterChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.ConnectedAcquisitionInterpreterChanged Event

Fired when the ConnectedAcquisitionInterpreter is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ConnectedAcquisitionInterpreterChanged
Public Event ConnectedAcquisitionInterpreterChanged As EventHandler
public:
 event EventHandler^ ConnectedAcquisitionInterpreterChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.ConnectedAcquisitionInterpreterValidating Event

Fired while validating the new value for ConnectedAcquisitionInterpreter.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ConnectedAcquisitionInterpreterValidating
Public Event ConnectedAcquisitionInterpreterValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ConnectedAcquisitionInterpreterValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.ReleaseOptionChanged Event

Fired when the ReleaseOption is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReleaseOptionChanged
Public Event ReleaseOptionChanged As EventHandler
public:
 event EventHandler^ ReleaseOptionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.ReleaseOptionValidating Event

Fired while validating the new value for ReleaseOption.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReleaseOptionValidating
Public Event ReleaseOptionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReleaseOptionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.ReusedAcquisitionOrInterpreterGuidChanged Event

Fired when the ReusedAcquisitionOrInterpreterGuid is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReusedAcquisitionOrInterpreterGuidChanged
Public Event ReusedAcquisitionOrInterpreterGuidChanged As EventHandler
public:
 event EventHandler^ ReusedAcquisitionOrInterpreterGuidChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.ReusedAcquisitionOrInterpreterGuidValidating Event

Fired while validating the new value for ReusedAcquisitionOrInterpreterGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReusedAcquisitionOrInterpreterGuidValidating
Public Event ReusedAcquisitionOrInterpreterGuidValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReusedAcquisitionOrInterpreterGuidValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.ThresholdChanged Event

Fired when the Threshold is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ThresholdChanged
Public Event ThresholdChanged As EventHandler
public:
 event EventHandler^ ThresholdChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChannelTriggerSet Class


ChannelTriggerSet.ThresholdValidating Event

Fired while validating the new value for Threshold.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ThresholdValidating
Public Event ThresholdValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ThresholdValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChannelTriggerSet Class


Chart Class

Base Class for all TwinCAT 3 Scope Charts
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAnchorTimeBase
TwinCAT.Measurement.Scope.API.ModelChart
TwinCAT.Measurement.Scope.API.ModelConnectableChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class Chart : AnchorTimeBase
Public MustInherit Class Chart
    Inherits AnchorTimeBase
public ref class Chart abstract : public AnchorTimeBase

The Chart type exposes the following members.

Constructors
 | Name | Description
Public method | Chart | Initialize all Properties to default Values
Public method | Chart(Chart) | Initialize a new Chart object by copying property Values
Top
Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode.
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore.
Public property | AutoStart | Gets or Sets the AutoStart.
Public property | CanContainsChartLayer |
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false.
Public property | ChannelDimensions | Get the ChannelDimensions
Public property | ChartType |
Public property | CMasterChart | Gets or Sets the CMasterChart.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth.
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor.
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel.
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating.
Public property | Live | Gets or Sets the Live.
Public property | MasterChart | Gets or Sets the MasterChart.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute.
Public property | PositionOffset | Gets or Sets the PositionOffset.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible.
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method
Public property | Resolution | Gets or Sets the Resolution.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime.
Public property | Style | Returns the first Style object found in the SubMemberCollection
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name.
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers
Public method | GetCommands | Gets an Array of possible Commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups
Public method | GetDisplay | Refreshes the values of the actual Chart
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event.
Public method | RaiseMessage | Raise the Message Event and log it in the Trace
Public method | RaiseSelected | Raises Selection
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display
Public method | ReorderLayers |
Public method | Rescale | Rescale the actual Display
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval.
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display
Public method | StartDisplay_Async | Restarts the Display
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack
Public method | StopDisplay | Stops the Display
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Overrides ObjectToString.)
Public method | UndoPosition | Undo 1 Position Setting
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | Validate | Validates the Chart Configuration and adds an ChartStyle, if not exists.
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max
Top
Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed.
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode.
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow.
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed.
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore.
Public event | AutoStartChanged | Fired when the AutoStart is changed.
Public event | AutoStartValidating | Fired while validating the new value for AutoStart.
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed.
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard.
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed
Public event | ClearDisplay | Event fired, when the Display needs to be cleared.
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed.
Public event | CMasterChartChanged | Fired when the CMasterChart is changed.
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart.
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed.
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed.
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth.
Public event | DoRescale | Fired to Control should Rescale
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed.
Public event | EndTimeValidating | Fired while validating the new value for EndTime.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed.
Public event | ForeColorValidating | Fired while validating the new value for ForeColor.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed.
Public event | LiveChanged | Fired when the Live is changed.
Public event | LiveValidating | Fired while validating the new value for Live.
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject
Public event | MasterChartChanged | Fired when the MasterChart is changed.
Public event | MasterChartValidating | Fired while validating the new value for MasterChart.
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed.
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute.
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed.
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed.
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed.
Public event | ResolutionValidating | Fired while validating the new value for Resolution.
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed.
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed.
Public event | StartTimeValidating | Fired while validating the new value for StartTime.
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed.
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Fields
 | Name | Description
 | DefaultDisplayColor | Get or Set the DefaultDisplayColor
 | DefaultForeColor | Get or Set the DefaultForeColor
 | DisplayWidthMinimum | The Minimum DisplayWidth, which can be used.
Public field | RefControlStyle | ///gets the ControlStyle
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


Chart Constructor

Overload List
 | Name | Description
Public method | Chart | Initialize all Properties to default Values
Public method | Chart(Chart) | Initialize a new Chart object by copying property Values
Top
See Also

Reference

Chart Class


Chart Constructor

Initialize all Properties to default Values

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Chart()
Public Sub New
public:
Chart()
See Also

Reference

Chart Class
Chart Overload


Chart Constructor (Chart)

Initialize a new Chart object by copying property Values

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Chart(
    Chart org
)
Public Sub New (
    org As Chart
)
public:
Chart(
    Chart^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelChart
Chart to copy from
See Also

Reference

Chart Class
Chart Overload


Chart Properties

The Chart type exposes the following members.

Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode.
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore.
Public property | AutoStart | Gets or Sets the AutoStart.
Public property | CanContainsChartLayer |
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false.
Public property | ChannelDimensions | Get the ChannelDimensions
Public property | ChartType |
Public property | CMasterChart | Gets or Sets the CMasterChart.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth.
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor.
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel.
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating.
Public property | Live | Gets or Sets the Live.
Public property | MasterChart | Gets or Sets the MasterChart.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute.
Public property | PositionOffset | Gets or Sets the PositionOffset.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible.
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method
Public property | Resolution | Gets or Sets the Resolution.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime.
Public property | Style | Returns the first Style object found in the SubMemberCollection
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

Chart Class


Chart.ActiveMouseMode Property

Gets or Sets the ActiveMouseMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public MouseModes ActiveMouseMode { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property ActiveMouseMode As MouseModes
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property MouseModes ActiveMouseMode {
    MouseModes get ();
    void set (MouseModes value);
}

Property Value

Type: MouseModes
See Also

Reference

Chart Class


Chart.AssignedCore Property

Gets or Sets the AssignedCore.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int AssignedCore { get; set; }
<BrowsableAttribute(true)>
Public Property AssignedCore As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int AssignedCore {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Chart Class


Chart.AutoStart Property

Gets or Sets the AutoStart.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool AutoStart { get; set; }
<BrowsableAttribute(true)>
Public Property AutoStart As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool AutoStart {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Chart Class


Chart.CanContainsChartLayer Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public virtual bool CanContainsChartLayer { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Overridable ReadOnly Property CanContainsChartLayer As Boolean
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
virtual property bool CanContainsChartLayer {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

Chart Class


Chart.CanCopyToClipboard Property

Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool CanCopyToClipboard { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property CanCopyToClipboard As Boolean
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool CanCopyToClipboard {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

Chart Class


Chart.ChannelDimensions Property

Get the ChannelDimensions

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public virtual int ChannelDimensions { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property ChannelDimensions As Integer
    Get
public:
[BrowsableAttribute(false)]
virtual property int ChannelDimensions {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Chart Class


Chart.ChartType Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public abstract ChartType ChartType { get; }
<BrowsableAttribute(false)>
Public MustOverride ReadOnly Property ChartType As ChartType
    Get
public:
[BrowsableAttribute(false)]
virtual property ChartType ChartType {
    ChartType get () abstract;
}

Property Value

Type: ChartType
See Also

Reference

Chart Class


Chart.CMasterChart Property

Gets or Sets the CMasterChart.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public Chart CMasterChart { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property CMasterChart As Chart
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property Chart^ CMasterChart {
    Chart^ get ();
    void set (Chart^ value);
}

Property Value

Type: Chart
See Also

Reference

Chart Class


Chart.Connected Property

Get the ConnectionState

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public abstract bool Connected { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public MustOverride ReadOnly Property Connected As Boolean
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property bool Connected {
    bool get () abstract;
}

Property Value

Type: Boolean
See Also

Reference

Chart Class


Chart.ContainsImageAcquisition Property

Delegate Property to get the Contains Image Acquisition Information

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public DelContainsImageAcquisition ContainsImageAcquisition { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property ContainsImageAcquisition As DelContainsImageAcquisition
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property DelContainsImageAcquisition^ ContainsImageAcquisition {
    DelContainsImageAcquisition^ get ();
    void set (DelContainsImageAcquisition^ value);
}

Property Value

Type: DelContainsImageAcquisition
See Also

Reference

Chart Class


Chart.DefaultDisplayWidth Property

Gets or Sets the DefaultDisplayWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long DefaultDisplayWidth { get; set; }
<BrowsableAttribute(true)>
Public Property DefaultDisplayWidth As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long DefaultDisplayWidth {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

Chart Class


Chart.DisplayColor Property

Gets or Sets the DisplayColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public override Color DisplayColor { get; set; }
<BrowsableAttribute(true)>
Public Overrides Property DisplayColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property Color DisplayColor {
    Color get () override;
    void set (Color value) override;
}

Property Value

Type: Color
See Also

Reference

Chart Class


Chart.DisplayWidth Property

Gets or Sets the DisplayWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public long DisplayWidth { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property DisplayWidth As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property long long DisplayWidth {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

Chart Class


Chart.EndTime Property

Gets or Sets the EndTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public long EndTime { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property EndTime As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property long long EndTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

Chart Class


Chart.ForeColor Property

Gets or Sets the ForeColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Color ForeColor { get; set; }
<BrowsableAttribute(true)>
Public Property ForeColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
property Color ForeColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

Chart Class


Chart.GetMarkerContainerFromProject Property

/Delegate Property to ask for the MarkerContainer from ScopeProject

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public GetMarkerContainer GetMarkerContainerFromProject { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property GetMarkerContainerFromProject As GetMarkerContainer
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property GetMarkerContainer^ GetMarkerContainerFromProject {
    GetMarkerContainer^ get ();
    void set (GetMarkerContainer^ value);
}

Property Value

Type: GetMarkerContainer
See Also

Reference

Chart Class


Chart.GetMarkerImageSpace Property

Delegate Property to ask for MaxImageSize from Scope Project

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public GetImageSpace GetMarkerImageSpace { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property GetMarkerImageSpace As GetImageSpace
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property GetImageSpace^ GetMarkerImageSpace {
    GetImageSpace^ get ();
    void set (GetImageSpace^ value);
}

Property Value

Type: GetImageSpace
See Also

Reference

Chart Class


Chart.GetRecordTime Property

Delegate Property to ask for RecordTime from Scope Project

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public delRecordTime GetRecordTime { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property GetRecordTime As delRecordTime
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property delRecordTime^ GetRecordTime {
    delRecordTime^ get ();
    void set (delRecordTime^ value);
}

Property Value

Type: delRecordTime
See Also

Reference

Chart Class


Chart.GetTriggerGroupsFromProject Property

Delegate Property to ask for all TriggerGroups from Scope Project

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public GetTriggerGroups GetTriggerGroupsFromProject { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property GetTriggerGroupsFromProject As GetTriggerGroups
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property GetTriggerGroups^ GetTriggerGroupsFromProject {
    GetTriggerGroups^ get ();
    void set (GetTriggerGroups^ value);
}

Property Value

Type: GetTriggerGroups
See Also

Reference

Chart Class


Chart.GraphicLibrary Property

Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public GraphicLibrary GraphicLibrary { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property GraphicLibrary As GraphicLibrary
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property GraphicLibrary GraphicLibrary {
    GraphicLibrary get ();
    void set (GraphicLibrary value);
}

Property Value

Type: GraphicLibrary
See Also

Reference

Chart Class


Chart.HasPanel Property

Gets or sets a value indicating whether this instance has panel.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool HasPanel { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property HasPanel As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool HasPanel {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Chart Class


Chart.IsUpdating Property

Gets or Sets the IsUpdating.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool IsUpdating { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property IsUpdating As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool IsUpdating {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Chart Class


Chart.Live Property

Gets or Sets the Live.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public bool Live { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property Live As Boolean
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property bool Live {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Chart Class


Chart.MasterChart Property

Gets or Sets the MasterChart.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Guid MasterChart { get; set; }
<BrowsableAttribute(true)>
Public Property MasterChart As Guid
    Get
    Set
public:
[BrowsableAttribute(true)]
property Guid MasterChart {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

Chart Class


Chart.PositionAbsolute Property

Gets or Sets the PositionAbsolute.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public long PositionAbsolute { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property PositionAbsolute As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property long long PositionAbsolute {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

Chart Class


Chart.PositionOffset Property

Gets or Sets the PositionOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public long PositionOffset { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property PositionOffset As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property long long PositionOffset {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

Chart Class


Chart.RedoPossible Property

Gets or Sets the RedoPossible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool RedoPossible { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property RedoPossible As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool RedoPossible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Chart Class


Chart.RefreshChartTimes Property

Delegate Property to call Controls RefreshChartScreen Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public RefreshChartScreen RefreshChartTimes { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property RefreshChartTimes As RefreshChartScreen
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property RefreshChartScreen^ RefreshChartTimes {
    RefreshChartScreen^ get ();
    void set (RefreshChartScreen^ value);
}

Property Value

Type: RefreshChartScreen
See Also

Reference

Chart Class


Chart.Resolution Property

Gets or Sets the Resolution.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public uint Resolution { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property Resolution As UInteger
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property unsigned int Resolution {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

Chart Class


Chart.ShowImageChart Property

Gets or Sets the ShowImageChart.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool ShowImageChart { get; set; }
<BrowsableAttribute(false)>
Public Property ShowImageChart As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool ShowImageChart {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Chart Class


Chart.StartTime Property

Gets or Sets the StartTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public long StartTime { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property StartTime As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property long long StartTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

Chart Class


Chart.Style Property

Returns the first Style object found in the SubMemberCollection

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public ChartStyle Style { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property Style As ChartStyle
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property ChartStyle^ Style {
    ChartStyle^ get ();
}

Property Value

Type: ChartStyle
See Also

Reference

Chart Class


Chart.SuspendGetData Property

Suspend the GetData

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public bool SuspendGetData { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property SuspendGetData As Boolean
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property bool SuspendGetData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Chart Class


Chart.UndoPossible Property

Gets or Sets the UndoPossible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool UndoPossible { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property UndoPossible As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool UndoPossible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Chart Class


Chart Methods

The Chart type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name.
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers
Public method | GetCommands | Gets an Array of possible Commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups
Public method | GetDisplay | Refreshes the values of the actual Chart
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event.
Public method | RaiseMessage | Raise the Message Event and log it in the Trace
Public method | RaiseSelected | Raises Selection
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display
Public method | ReorderLayers |
Public method | Rescale | Rescale the actual Display
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval.
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display
Public method | StartDisplay_Async | Restarts the Display
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack
Public method | StopDisplay | Stops the Display
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Overrides ObjectToString.)
Public method | UndoPosition | Undo 1 Position Setting
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | Validate | Validates the Chart Configuration and adds an ChartStyle, if not exists.
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max
Top
See Also

Reference

Chart Class


Chart.AddTimestampImageTrigger Method

Adds a Trigger with a path of an Image with an Timestamp in the name.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void AddTimestampImageTrigger(
    string str
)
Public Sub AddTimestampImageTrigger (
    str As String
)
public:
void AddTimestampImageTrigger(
    String^ str
)

Parameters

str
Type: SystemString
See Also

Reference

Chart Class


Chart.AppandDisplayWidthAndPositionCommand Method

Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void AppandDisplayWidthAndPositionCommand(
    long BeforePosition,
    long BeforeDisplayWidth
)
Public Sub AppandDisplayWidthAndPositionCommand (
    BeforePosition As Long,
    BeforeDisplayWidth As Long
)
public:
void AppandDisplayWidthAndPositionCommand(
    long long BeforePosition,
    long long BeforeDisplayWidth
)

Parameters

BeforePosition
Type: SystemInt64
BeforeDisplayWidth
Type: SystemInt64
See Also

Reference

Chart Class


Chart.CreateChartRefLayer Method

Create autogenerated RefLayer and copy channels to seperated class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void CreateChartRefLayer(
    Dictionary<Chart, List<Channel>> droppedMember
)
Public Sub CreateChartRefLayer (
    droppedMember As Dictionary(Of Chart, List(Of Channel))
)
public:
void CreateChartRefLayer(
    Dictionary<Chart^, List<Channel^>^>^ droppedMember
)

Parameters

droppedMember
Type: System.Collections.GenericDictionary Chart, List Channel
See Also

Reference

Chart Class


Chart.EndPositionMultiCommand Method

Start MultiCommand on Position Stack

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void EndPositionMultiCommand(
    MeasurementMultiCommand MultiCommand,
    bool Skipped
)
Public Sub EndPositionMultiCommand (
    MultiCommand As MeasurementMultiCommand,
    Skipped As Boolean
)
public:
void EndPositionMultiCommand(
    MeasurementMultiCommand^ MultiCommand,
    bool Skipped
)

Parameters

MultiCommand
Type: MeasurementMultiCommand
Command to End
Skipped
Type: SystemBoolean
Skipped
See Also

Reference

Chart Class


Chart.Errorhandler Method

Used to catch errors from Controls

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Errorhandler(
    Exception err
)
Public Sub Errorhandler (
    err As Exception
)
public:
void Errorhandler(
    Exception^ err
)

Parameters

err
Type: SystemException
See Also

Reference

Chart Class


Chart.GetAcquisitionData Method

Gets the Acquisition Data from the timestamp

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract Tuple<long, Object> GetAcquisitionData(
    long timestamp,
    Acquisition acquisition
)
Public MustOverride Function GetAcquisitionData (
    timestamp As Long,
    acquisition As Acquisition
) As Tuple(Of Long, Object)
public:
virtual Tuple<long long, Object^>^ GetAcquisitionData(
    long long timestamp,
    Acquisition^ acquisition
) abstract

Parameters

timestamp
Type: SystemInt64
Timestamp of the data
acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
Acquisition for the Data

Return Value

Type: Tuple Int64, Object
Returns a Tuple with the right Timestamp and the Data
See Also

Reference

Chart Class


Chart.GetChartLayers Method

Return all ChartLayers

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<ChartLayer> GetChartLayers()
Public Function GetChartLayers As IEnumerable(Of ChartLayer)
public:
IEnumerable<ChartLayer^>^ GetChartLayers()

Return Value

Type: IEnumerable ChartLayer
See Also

Reference

Chart Class


Chart.GetCommands Method

Gets an Array of possible Commands

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
An Array of commands
See Also

Reference

Chart Class


Chart.GetConnectedTriggerGroups Method

Get Connected TriggerGroups

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<TriggerGroup> GetConnectedTriggerGroups()
Public Function GetConnectedTriggerGroups As IEnumerable(Of TriggerGroup)
public:
IEnumerable<TriggerGroup^>^ GetConnectedTriggerGroups()

Return Value

Type: IEnumerable TriggerGroup
See Also

Reference

Chart Class


Chart.GetDisplay Method

Refreshes the values of the actual Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract void GetDisplay()
Public MustOverride Sub GetDisplay
public:
virtual void GetDisplay() abstract
See Also

Reference

Chart Class


Chart.GetLayerLicenseState Method

Get the loaded layer license state

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public LayerLicenseState GetLayerLicenseState()
Public Function GetLayerLicenseState As LayerLicenseState
public:
LayerLicenseState GetLayerLicenseState()

Return Value

Type: LayerLicenseState
Loaded license
See Also

Reference

Chart Class


Chart.HighlightTriggerGroup Method

Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract void HighlightTriggerGroup(
    TriggerGroup triggerGroup
)
Public MustOverride Sub HighlightTriggerGroup (
    triggerGroup As TriggerGroup
)
public:
virtual void HighlightTriggerGroup(
    TriggerGroup^ triggerGroup
) abstract

Parameters

triggerGroup
Type: TwinCAT.Measurement.Scope.API.ModelTriggerGroup
TriggerGroup to Highlight
See Also

Reference

Chart Class


Chart.JumpToWithOffset Method

Jump to timestamp with small offset. Only if the timestamp is outside of the current chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void JumpToWithOffset(
    long timestamp,
    double percentageOffset = 0,2
)
Public Sub JumpToWithOffset (
    timestamp As Long,
    Optional percentageOffset As Double = 0,2
)
public:
void JumpToWithOffset(
    long long timestamp,
    double percentageOffset = 0,2
)

Parameters

timestamp
Type: SystemInt64
New start position
percentageOffset (Optional)
Type: SystemDouble
Percentage offset of the display width (0 - 1).
See Also

Reference

Chart Class


Chart.RaiseCopyToClipboard Method

Raises the CopyToClipboard event.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void RaiseCopyToClipboard(
    CopyToClipboardArgs resolution
)
Public Sub RaiseCopyToClipboard (
    resolution As CopyToClipboardArgs
)
public:
void RaiseCopyToClipboard(
    CopyToClipboardArgs^ resolution
)

Parameters

resolution
Type: TwinCAT.Measurement.Scope.APICopyToClipboardArgs
See Also

Reference

Chart Class


Chart.RaiseMessage Method

Raise the Message Event and log it in the Trace

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void RaiseMessage(
    string message,
    MessageType type
)
Public Sub RaiseMessage (
    message As String,
    type As MessageType
)
public:
void RaiseMessage(
    String^ message,
    MessageType type
)

Parameters

message
Type: SystemString
Message to Raise
type
Type: MessageType
Type of Message
See Also

Reference

Chart Class


Chart.RaiseSelected Method

Raises Selection

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void RaiseSelected()
Public Sub RaiseSelected
public:
void RaiseSelected()
See Also

Reference

Chart Class


Chart.RedoPosition Method

Redo 1 Position Setting

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void RedoPosition()
Public Overridable Sub RedoPosition
public:
virtual void RedoPosition()
See Also

Reference

Chart Class


Chart.RenewDisplay Method

Renew the actual Display

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract void RenewDisplay()
Public MustOverride Sub RenewDisplay
public:
virtual void RenewDisplay() abstract
See Also

Reference

Chart Class


Chart.ReorderLayers Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void ReorderLayers()
Public Overridable Sub ReorderLayers
public:
virtual void ReorderLayers()
See Also

Reference

Chart Class


Chart.Rescale Method

Rescale the actual Display

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Rescale()
Public Sub Rescale
public:
void Rescale()
See Also

Reference

Chart Class


Chart.Scroll Method

Overload List
 | Name | Description
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval.
Top
See Also

Reference

Chart Class


Chart.Scroll Method (Direction)

Scrolls the Display 10% of the DisplayWidth

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Scroll(
    Direction direction
)
Public Sub Scroll (
    direction As Direction
)
public:
void Scroll(
    Direction direction
)

Parameters

direction
Type: TwinCAT.Measurement.Scope.APIDirection
The Direction to Scroll
See Also

Reference

Chart Class
Scroll Overload


Chart.Scroll Method (Direction, Int64)

Scrolls the chart in the given direction and by the given interval.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract void Scroll(
    Direction direction,
    long shifttime
)
Public MustOverride Sub Scroll (
    direction As Direction,
    shifttime As Long
)
public:
virtual void Scroll(
    Direction direction,
    long long shifttime
) abstract

Parameters

direction
Type: TwinCAT.Measurement.Scope.APIDirection
The move direction.
shifttime
Type: SystemInt64
The interval to shift.
See Also

Reference

Chart Class
Scroll Overload


Chart.ScrollBig Method

Scrolls the Diplay on DisplayWidth

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void ScrollBig(
    Direction direction
)
Public Sub ScrollBig (
    direction As Direction
)
public:
void ScrollBig(
    Direction direction
)

Parameters

direction
Type: TwinCAT.Measurement.Scope.APIDirection
The Direction to Scroll
See Also

Reference

Chart Class


Chart.StartDisplay Method

Restarts the Display

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void StartDisplay()
Public Sub StartDisplay
public:
void StartDisplay()
See Also

Reference

Chart Class


Chart.StartDisplay_Async Method

Restarts the Display

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void StartDisplay_Async()
Public Sub StartDisplay_Async
public:
void StartDisplay_Async()
See Also

Reference

Chart Class


Chart.StartPositionMultiCommand Method

Start a new MultiCommand on Position Stack

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MeasurementMultiCommand StartPositionMultiCommand()
Public Function StartPositionMultiCommand As MeasurementMultiCommand
public:
MeasurementMultiCommand^ StartPositionMultiCommand()

Return Value

Type: MeasurementMultiCommand
See Also

Reference

Chart Class


Chart.StopDisplay Method

Stops the Display

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void StopDisplay()
Public Sub StopDisplay
public:
void StopDisplay()
See Also

Reference

Chart Class


Chart.ToString Method

Converts the Chart to a representive String

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
The Title
See Also

Reference

Chart Class


Chart.UndoPosition Method

Undo 1 Position Setting

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void UndoPosition()
Public Overridable Sub UndoPosition
public:
virtual void UndoPosition()
See Also

Reference

Chart Class


Chart.UpdatePropertyAttributes Method

Update the Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

Chart Class


Chart.Validate Method

Validates the Chart Configuration and adds an ChartStyle, if not exists.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void Validate()
Public Overridable Sub Validate
public:
virtual void Validate()
See Also

Reference

Chart Class


Chart.ZoomOutMax Method

Zooms out max

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void ZoomOutMax()
Public Overridable Sub ZoomOutMax
public:
virtual void ZoomOutMax()
See Also

Reference

Chart Class


Chart Events

The Chart type exposes the following members.

Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed.
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode.
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow.
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed.
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore.
Public event | AutoStartChanged | Fired when the AutoStart is changed.
Public event | AutoStartValidating | Fired while validating the new value for AutoStart.
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed.
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard.
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed
Public event | ClearDisplay | Event fired, when the Display needs to be cleared.
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed.
Public event | CMasterChartChanged | Fired when the CMasterChart is changed.
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart.
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed.
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed.
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth.
Public event | DoRescale | Fired to Control should Rescale
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed.
Public event | EndTimeValidating | Fired while validating the new value for EndTime.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed.
Public event | ForeColorValidating | Fired while validating the new value for ForeColor.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed.
Public event | LiveChanged | Fired when the Live is changed.
Public event | LiveValidating | Fired while validating the new value for Live.
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject
Public event | MasterChartChanged | Fired when the MasterChart is changed.
Public event | MasterChartValidating | Fired while validating the new value for MasterChart.
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed.
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute.
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed.
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed.
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed.
Public event | ResolutionValidating | Fired while validating the new value for Resolution.
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed.
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed.
Public event | StartTimeValidating | Fired while validating the new value for StartTime.
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed.
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

Chart Class


Chart.ActiveMouseModeChanged Event

Fired when the ActiveMouseMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ActiveMouseModeChanged
Public Event ActiveMouseModeChanged As EventHandler
public:
 event EventHandler^ ActiveMouseModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.ActiveMouseModeValidating Event

Fired while validating the new value for ActiveMouseMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ActiveMouseModeValidating
Public Event ActiveMouseModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ActiveMouseModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.AddToMarkerWindow Event

Fired, when the Chart should be add to the MarkerWindow.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AddToMarkerWindow
Public Event AddToMarkerWindow As EventHandler
public:
 event EventHandler^ AddToMarkerWindow {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.AssignedCoreChanged Event

Fired when the AssignedCore is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AssignedCoreChanged
Public Event AssignedCoreChanged As EventHandler
public:
 event EventHandler^ AssignedCoreChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.AssignedCoreValidating Event

Fired while validating the new value for AssignedCore.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AssignedCoreValidating
Public Event AssignedCoreValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AssignedCoreValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.AutoStartChanged Event

Fired when the AutoStart is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoStartChanged
Public Event AutoStartChanged As EventHandler
public:
 event EventHandler^ AutoStartChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.AutoStartValidating Event

Fired while validating the new value for AutoStart.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoStartValidating
Public Event AutoStartValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoStartValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.CanCopyToClipboardChanged Event

Fired when the CanCopyToClipboard is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CanCopyToClipboardChanged
Public Event CanCopyToClipboardChanged As EventHandler
public:
 event EventHandler^ CanCopyToClipboardChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.CanCopyToClipboardValidating Event

Fired while validating the new value for CanCopyToClipboard.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> CanCopyToClipboardValidating
Public Event CanCopyToClipboardValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ CanCopyToClipboardValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.ChartPositionChanged Event

Fired when the ChartPosition has Changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ChartTimePosEventArgs> ChartPositionChanged
Public Event ChartPositionChanged As EventHandler(Of ChartTimePosEventArgs)
public:
 event EventHandler<ChartTimePosEventArgs^>^ ChartPositionChanged {
    void add (EventHandler<ChartTimePosEventArgs^>^ value);
    void remove (EventHandler<ChartTimePosEventArgs^>^ value);
}

Value

Type: SystemEventHandler ChartTimePosEventArgs
See Also

Reference

Chart Class


Chart.ClearDisplay Event

Event fired, when the Display needs to be cleared.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ClearDisplay
Public Event ClearDisplay As EventHandler
public:
 event EventHandler^ ClearDisplay {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.CMasterChartBeforeChanging Event

Fired before CMasterChart is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CMasterChartBeforeChanging
Public Event CMasterChartBeforeChanging As EventHandler
public:
 event EventHandler^ CMasterChartBeforeChanging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.CMasterChartChanged Event

Fired when the CMasterChart is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CMasterChartChanged
Public Event CMasterChartChanged As EventHandler
public:
 event EventHandler^ CMasterChartChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.CMasterChartValidating Event

Fired while validating the new value for CMasterChart.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> CMasterChartValidating
Public Event CMasterChartValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ CMasterChartValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.CopyToClipboard Event

Fired, when the reporting to should be shown for this chart.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<CopyToClipboardArgs> CopyToClipboard
Public Event CopyToClipboard As EventHandler(Of CopyToClipboardArgs)
public:
 event EventHandler<CopyToClipboardArgs^>^ CopyToClipboard {
    void add (EventHandler<CopyToClipboardArgs^>^ value);
    void remove (EventHandler<CopyToClipboardArgs^>^ value);
}

Value

Type: SystemEventHandler CopyToClipboardArgs
See Also

Reference

Chart Class


Chart.DefaultDisplayWidthChanged Event

Fired when the DefaultDisplayWidth is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DefaultDisplayWidthChanged
Public Event DefaultDisplayWidthChanged As EventHandler
public:
 event EventHandler^ DefaultDisplayWidthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.DefaultDisplayWidthValidating Event

Fired while validating the new value for DefaultDisplayWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DefaultDisplayWidthValidating
Public Event DefaultDisplayWidthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DefaultDisplayWidthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.DisplayFrameEnded Event

Fired when DisplayFramehandling is completed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DisplayFrameEnded
Public Event DisplayFrameEnded As EventHandler
public:
 event EventHandler^ DisplayFrameEnded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.DisplayWidthChanged Event

Fired when the DisplayWidth is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DisplayWidthChanged
Public Event DisplayWidthChanged As EventHandler
public:
 event EventHandler^ DisplayWidthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.DisplayWidthValidating Event

Fired while validating the new value for DisplayWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DisplayWidthValidating
Public Event DisplayWidthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DisplayWidthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.DoRescale Event

Fired to Control should Rescale

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DoRescale
Public Event DoRescale As EventHandler
public:
 event EventHandler^ DoRescale {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.EndTimeChanged Event

Fired when the EndTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EndTimeChanged
Public Event EndTimeChanged As EventHandler
public:
 event EventHandler^ EndTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.EndTimeValidating Event

Fired while validating the new value for EndTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EndTimeValidating
Public Event EndTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EndTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.ForeColorChanged Event

Fired when the ForeColor is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ForeColorChanged
Public Event ForeColorChanged As EventHandler
public:
 event EventHandler^ ForeColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.ForeColorValidating Event

Fired while validating the new value for ForeColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ForeColorValidating
Public Event ForeColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ForeColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.IsUpdatingChanged Event

Fired when the IsUpdating is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IsUpdatingChanged
Public Event IsUpdatingChanged As EventHandler
public:
 event EventHandler^ IsUpdatingChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.LiveChanged Event

Fired when the Live is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LiveChanged
Public Event LiveChanged As EventHandler
public:
 event EventHandler^ LiveChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.LiveValidating Event

Fired while validating the new value for Live.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LiveValidating
Public Event LiveValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LiveValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.MarkerContainerBindingsChanged Event

Fired, when a MarkerContainer is Added or Removed from ScopeProject

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<MarkerContainerContentChangedEventArgs> MarkerContainerBindingsChanged
Public Event MarkerContainerBindingsChanged As EventHandler(Of MarkerContainerContentChangedEventArgs)
public:
 event EventHandler<MarkerContainerContentChangedEventArgs^>^ MarkerContainerBindingsChanged {
    void add (EventHandler<MarkerContainerContentChangedEventArgs^>^ value);
    void remove (EventHandler<MarkerContainerContentChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandler MarkerContainerContentChangedEventArgs
See Also

Reference

Chart Class


Chart.MasterChartChanged Event

Fired when the MasterChart is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler MasterChartChanged
Public Event MasterChartChanged As EventHandler
public:
 event EventHandler^ MasterChartChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.MasterChartValidating Event

Fired while validating the new value for MasterChart.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> MasterChartValidating
Public Event MasterChartValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ MasterChartValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.MaxMarkerImageSizeChanged Event

Fired, when the MaxMarkerImageSize Changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<int> MaxMarkerImageSizeChanged
Public Event MaxMarkerImageSizeChanged As EventHandler(Of Integer)
public:
 event EventHandler<int>^ MaxMarkerImageSizeChanged {
    void add (EventHandler<int>^ value);
    void remove (EventHandler<int>^ value);
}

Value

Type: SystemEventHandler Int32
See Also

Reference

Chart Class


Chart.PositionAbsoluteChanged Event

Fired when the PositionAbsolute is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PositionAbsoluteChanged
Public Event PositionAbsoluteChanged As EventHandler
public:
 event EventHandler^ PositionAbsoluteChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.PositionAbsoluteValidating Event

Fired while validating the new value for PositionAbsolute.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PositionAbsoluteValidating
Public Event PositionAbsoluteValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PositionAbsoluteValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.PositionOffsetChanged Event

Fired when the PositionOffset is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PositionOffsetChanged
Public Event PositionOffsetChanged As EventHandler
public:
 event EventHandler^ PositionOffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.PositionOffsetValidating Event

Fired while validating the new value for PositionOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PositionOffsetValidating
Public Event PositionOffsetValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PositionOffsetValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.RedoPossibleChanged Event

Fired when the RedoPossible is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler RedoPossibleChanged
Public Event RedoPossibleChanged As EventHandler
public:
 event EventHandler^ RedoPossibleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.RedoPossibleValidating Event

Fired while validating the new value for RedoPossible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> RedoPossibleValidating
Public Event RedoPossibleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ RedoPossibleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.ResolutionChanged Event

Fired when the Resolution is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ResolutionChanged
Public Event ResolutionChanged As EventHandler
public:
 event EventHandler^ ResolutionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.ResolutionValidating Event

Fired while validating the new value for Resolution.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ResolutionValidating
Public Event ResolutionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ResolutionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.ShowImageChartChanged Event

Fired when the ShowImageChart is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowImageChartChanged
Public Event ShowImageChartChanged As EventHandler
public:
 event EventHandler^ ShowImageChartChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.ShowImageChartValidating Event

Fired while validating the new value for ShowImageChart.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowImageChartValidating
Public Event ShowImageChartValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowImageChartValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.StartTimeChanged Event

Fired when the StartTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StartTimeChanged
Public Event StartTimeChanged As EventHandler
public:
 event EventHandler^ StartTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.StartTimeValidating Event

Fired while validating the new value for StartTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> StartTimeValidating
Public Event StartTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ StartTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart.StatusTimesChanged Event

Event fired, when the StatusTimes have been changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StatusTimesChanged
Public Event StatusTimesChanged As EventHandler
public:
 event EventHandler^ StatusTimesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.TriggerGroupBindingsChanged Event

Fired, when a TriggerGroup is Added or Removed From ScopeProject

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<TriggerGroupContentChangedEventArgs> TriggerGroupBindingsChanged
Public Event TriggerGroupBindingsChanged As EventHandler(Of TriggerGroupContentChangedEventArgs)
public:
 event EventHandler<TriggerGroupContentChangedEventArgs^>^ TriggerGroupBindingsChanged {
    void add (EventHandler<TriggerGroupContentChangedEventArgs^>^ value);
    void remove (EventHandler<TriggerGroupContentChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandler TriggerGroupContentChangedEventArgs
See Also

Reference

Chart Class


Chart.UndoPossibleChanged Event

Fired when the UndoPossible is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UndoPossibleChanged
Public Event UndoPossibleChanged As EventHandler
public:
 event EventHandler^ UndoPossibleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Chart Class


Chart.UndoPossibleValidating Event

Fired while validating the new value for UndoPossible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UndoPossibleValidating
Public Event UndoPossibleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UndoPossibleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Chart Class


Chart Fields

The Chart type exposes the following members.

Fields
 | Name | Description
 | DefaultDisplayColor | Get or Set the DefaultDisplayColor
 | DefaultForeColor | Get or Set the DefaultForeColor
 | DisplayWidthMinimum | The Minimum DisplayWidth, which can be used.
Public field | RefControlStyle | ///gets the ControlStyle
Top
See Also

Reference

Chart Class


Chart.DefaultDisplayColor Field

Get or Set the DefaultDisplayColor

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static Color DefaultDisplayColor
Public Shared DefaultDisplayColor As Color
public:
static Color DefaultDisplayColor

Field Value

Type: Color
See Also

Reference

Chart Class


Chart.DefaultForeColor Field

Get or Set the DefaultForeColor

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static Color DefaultForeColor
Public Shared DefaultForeColor As Color
public:
static Color DefaultForeColor

Field Value

Type: Color
See Also

Reference

Chart Class


Chart.DisplayWidthMinimum Field

The Minimum DisplayWidth, which can be used.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public const long DisplayWidthMinimum = 100
Public Const DisplayWidthMinimum As Long = 100
public:
literal long long DisplayWidthMinimum = 100

Field Value

Type: Int64
See Also

Reference

Chart Class


Chart.RefControlStyle Field

///gets the ControlStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
public MarkerControlStyle RefControlStyle
<XmlIgnoreAttribute>
Public RefControlStyle As MarkerControlStyle
public:
[XmlIgnoreAttribute]
MarkerControlStyle^ RefControlStyle

Field Value

Type: MarkerControlStyle
See Also

Reference

Chart Class


ChartLayer Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelChartLayerBase
TwinCAT.Measurement.Scope.API.ModelChartLayer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChartLayer : ChartLayerBase
Public Class ChartLayer
    Inherits ChartLayerBase
public ref class ChartLayer : public ChartLayerBase

The ChartLayer type exposes the following members.

Constructors
 | Name | Description
Public method | ChartLayer | Create a new ChartLayer instance
Public method | ChartLayer(ChartLayer) | Create a new instance as a copy
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | InsideDisplay | Gets or Sets the InsideDisplay.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | OpacityValue | Gets or Sets the OpacityValue.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style |
Public property | StyleMode | Gets or Sets the StyleMode.
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | highlight the layer in the charting (Overrides ChartLayerBaseHighlight.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | MoveDown | Move down the Layer in the LayerControl (Inherited from ChartLayerBase.)
Public method | MoveUp | Move up the Layer in the LayerControl (Inherited from ChartLayerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightLayer | Fired to highlight the current chartlayer
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InsideDisplayChanged | Fired when the InsideDisplay is changed.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OpacityValueChanged | Fired when the OpacityValue is changed.
Public event | OpacityValueValidating | Fired while validating the new value for OpacityValue.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StyleModeChanged | Fired when the StyleMode is changed.
Public event | StyleModeValidating | Fired while validating the new value for StyleMode.
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ChartLayer Constructor

Overload List
 | Name | Description
Public method | ChartLayer | Create a new ChartLayer instance
Public method | ChartLayer(ChartLayer) | Create a new instance as a copy
Top
See Also

Reference

ChartLayer Class


ChartLayer Constructor

Create a new ChartLayer instance

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartLayer()
Public Sub New
public:
ChartLayer()
See Also

Reference

ChartLayer Class
ChartLayer Overload


ChartLayer Constructor (ChartLayer)

Create a new instance as a copy

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartLayer(
    ChartLayer chartLayer
)
Public Sub New (
    chartLayer As ChartLayer
)
public:
ChartLayer(
    ChartLayer^ chartLayer
)

Parameters

chartLayer
Type: TwinCAT.Measurement.Scope.API.ModelChartLayer
See Also

Reference

ChartLayer Class
ChartLayer Overload


ChartLayer Properties

The ChartLayer type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | InsideDisplay | Gets or Sets the InsideDisplay.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | OpacityValue | Gets or Sets the OpacityValue.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style |
Public property | StyleMode | Gets or Sets the StyleMode.
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartLayer Class


ChartLayer.InsideDisplay Property

Gets or Sets the InsideDisplay.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
public bool InsideDisplay { get; set; }
<XmlIgnoreAttribute>
Public Property InsideDisplay As Boolean
    Get
    Set
public:
[XmlIgnoreAttribute]
property bool InsideDisplay {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartLayer Class


ChartLayer.OpacityValue Property

Gets or Sets the OpacityValue.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public byte OpacityValue { get; set; }
<BrowsableAttribute(true)>
Public Property OpacityValue As Byte
    Get
    Set
public:
[BrowsableAttribute(true)]
property unsigned char OpacityValue {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

ChartLayer Class


ChartLayer.Style Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
public ChannelStyle Style { get; }
<XmlIgnoreAttribute>
Public ReadOnly Property Style As ChannelStyle
    Get
public:
[XmlIgnoreAttribute]
property ChannelStyle^ Style {
    ChannelStyle^ get ();
}

Property Value

Type: ChannelStyle
See Also

Reference

ChartLayer Class


ChartLayer.StyleMode Property

Gets or Sets the StyleMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public StyleType StyleMode { get; set; }
<BrowsableAttribute(true)>
Public Property StyleMode As StyleType
    Get
    Set
public:
[BrowsableAttribute(true)]
property StyleType StyleMode {
    StyleType get ();
    void set (StyleType value);
}

Property Value

Type: StyleType
See Also

Reference

ChartLayer Class


ChartLayer Methods

The ChartLayer type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | highlight the layer in the charting (Overrides ChartLayerBaseHighlight.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | MoveDown | Move down the Layer in the LayerControl (Inherited from ChartLayerBase.)
Public method | MoveUp | Move up the Layer in the LayerControl (Inherited from ChartLayerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Overrides ObjectToString.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartLayer Class


ChartLayer.Highlight Method

highlight the layer in the charting

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void Highlight()
Public Overrides Sub Highlight
public:
virtual void Highlight() override
See Also

Reference

ChartLayer Class


ChartLayer.ToString Method

Returns a string that represents the current object.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
See Also

Reference

ChartLayer Class


ChartLayer Events

The ChartLayer type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightLayer | Fired to highlight the current chartlayer
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InsideDisplayChanged | Fired when the InsideDisplay is changed.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OpacityValueChanged | Fired when the OpacityValue is changed.
Public event | OpacityValueValidating | Fired while validating the new value for OpacityValue.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StyleModeChanged | Fired when the StyleMode is changed.
Public event | StyleModeValidating | Fired while validating the new value for StyleMode.
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartLayer Class


ChartLayer.HighlightLayer Event

Fired to highlight the current chartlayer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler HighlightLayer
Public Event HighlightLayer As EventHandler
public:
 event EventHandler^ HighlightLayer {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartLayer Class


ChartLayer.InsideDisplayChanged Event

Fired when the InsideDisplay is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler InsideDisplayChanged
Public Event InsideDisplayChanged As EventHandler
public:
 event EventHandler^ InsideDisplayChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartLayer Class


ChartLayer.OpacityValueChanged Event

Fired when the OpacityValue is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OpacityValueChanged
Public Event OpacityValueChanged As EventHandler
public:
 event EventHandler^ OpacityValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartLayer Class


ChartLayer.OpacityValueValidating Event

Fired while validating the new value for OpacityValue.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> OpacityValueValidating
Public Event OpacityValueValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ OpacityValueValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartLayer Class


ChartLayer.StyleModeChanged Event

Fired when the StyleMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StyleModeChanged
Public Event StyleModeChanged As EventHandler
public:
 event EventHandler^ StyleModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartLayer Class


ChartLayer.StyleModeValidating Event

Fired while validating the new value for StyleMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> StyleModeValidating
Public Event StyleModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ StyleModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartLayer Class


ChartLayerBase Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelChartLayerBase
TwinCAT.Measurement.Scope.API.ModelChartLayer
TwinCAT.Measurement.Scope.API.ModelEchoChartLayerCollection

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class ChartLayerBase : ScopeMemberContainerBase
Public MustInherit Class ChartLayerBase
    Inherits ScopeMemberContainerBase
public ref class ChartLayerBase abstract : public ScopeMemberContainerBase

The ChartLayerBase type exposes the following members.

Constructors
 | Name | Description
Public method | ChartLayerBase | Create a new instance
Public method | ChartLayerBase(ChartLayerBase) | Create a new instance as a copy
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | highlight the layer in the charting
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | MoveDown | Move down the Layer in the LayerControl
Public method | MoveUp | Move up the Layer in the LayerControl
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ChartLayerBase Constructor

Overload List
 | Name | Description
Public method | ChartLayerBase | Create a new instance
Public method | ChartLayerBase(ChartLayerBase) | Create a new instance as a copy
Top
See Also

Reference

ChartLayerBase Class


ChartLayerBase Constructor

Create a new instance

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartLayerBase()
Public Sub New
public:
ChartLayerBase()
See Also

Reference

ChartLayerBase Class
ChartLayerBase Overload


ChartLayerBase Constructor (ChartLayerBase)

Create a new instance as a copy

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartLayerBase(
    ChartLayerBase chartLayerBase
)
Public Sub New (
    chartLayerBase As ChartLayerBase
)
public:
ChartLayerBase(
    ChartLayerBase^ chartLayerBase
)

Parameters

chartLayerBase
Type: TwinCAT.Measurement.Scope.API.ModelChartLayerBase
See Also

Reference

ChartLayerBase Class
ChartLayerBase Overload


ChartLayerBase Properties

The ChartLayerBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartLayerBase Class


ChartLayerBase Methods

The ChartLayerBase type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | highlight the layer in the charting
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | MoveDown | Move down the Layer in the LayerControl
Public method | MoveUp | Move up the Layer in the LayerControl
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartLayerBase Class


ChartLayerBase.Highlight Method

highlight the layer in the charting

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract void Highlight()
Public MustOverride Sub Highlight
public:
virtual void Highlight() abstract
See Also

Reference

ChartLayerBase Class


ChartLayerBase.MoveDown Method

Move down the Layer in the LayerControl

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void MoveDown()
Public Sub MoveDown
public:
void MoveDown()
See Also

Reference

ChartLayerBase Class


ChartLayerBase.MoveUp Method

Move up the Layer in the LayerControl

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void MoveUp()
Public Sub MoveUp
public:
void MoveUp()
See Also

Reference

ChartLayerBase Class


ChartLayerBase Events

The ChartLayerBase type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartLayerBase Class


ChartMenuStyle Class

Class contains Style for Chart Menu
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelChartMenuStyle
TwinCAT.Measurement.Scope.API.ModelChartMenuXYZStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChartMenuStyle : ScopeMemberBase
Public Class ChartMenuStyle
    Inherits ScopeMemberBase
public ref class ChartMenuStyle : public ScopeMemberBase

The ChartMenuStyle type exposes the following members.

Constructors
 | Name | Description
Public method | ChartMenuStyle | Creates a new ChartMenuStyle
Public method | ChartMenuStyle(ChartMenuStyle) | Crates a new ChartMenuStyle by Copying Properties
Top
Properties
 | Name | Description
Public property | ButtonSize | Gets or Sets the ButtonSize.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | EnabledButtons | Gets or Sets the EnabledButtons.
Public property | EnabledTimeLabels | Gets or Sets the EnabledTimeLabels.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IndexNavigation | Gets or Sets the IndexNavigation.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | TimeStripFontSize | Gets or Sets the TimeStripFontSize.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | ToolStripFontSize | Gets or Sets the ToolStripFontSize.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLongTimeFormat | Gets or Sets the UseLongTimeFormat.
Public property | VisibleTimeStrip | Gets or Sets the VisibleTimeStrip.
Public property | VisibleToolStrip | Gets or Sets the VisibleToolStrip.
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of the Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ButtonSizeChanged | Fired when the ButtonSize is changed.
Public event | ButtonSizeValidating | Fired while validating the new value for ButtonSize.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledButtonsChanged | Fired when the EnabledButtons is changed.
Public event | EnabledButtonsValidating | Fired while validating the new value for EnabledButtons.
Public event | EnabledTimeLabelsChanged | Fired when the EnabledTimeLabels is changed.
Public event | EnabledTimeLabelsValidating | Fired while validating the new value for EnabledTimeLabels.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IndexNavigationChanged | Fired when the IndexNavigation is changed.
Public event | IndexNavigationValidating | Fired while validating the new value for IndexNavigation.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TimeStripFontSizeChanged | Fired when the TimeStripFontSize is changed.
Public event | TimeStripFontSizeValidating | Fired while validating the new value for TimeStripFontSize.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | ToolStripFontSizeChanged | Fired when the ToolStripFontSize is changed.
Public event | ToolStripFontSizeValidating | Fired while validating the new value for ToolStripFontSize.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLongTimeFormatChanged | Fired when the UseLongTimeFormat is changed.
Public event | UseLongTimeFormatValidating | Fired while validating the new value for UseLongTimeFormat.
Public event | VisibleTimeStripChanged | Fired when the VisibleTimeStrip is changed.
Public event | VisibleTimeStripValidating | Fired while validating the new value for VisibleTimeStrip.
Public event | VisibleToolStripChanged | Fired when the VisibleToolStrip is changed.
Public event | VisibleToolStripValidating | Fired while validating the new value for VisibleToolStrip.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ChartMenuStyle Constructor

Overload List
 | Name | Description
Public method | ChartMenuStyle | Creates a new ChartMenuStyle
Public method | ChartMenuStyle(ChartMenuStyle) | Crates a new ChartMenuStyle by Copying Properties
Top
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle Constructor

Creates a new ChartMenuStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartMenuStyle()
Public Sub New
public:
ChartMenuStyle()
See Also

Reference

ChartMenuStyle Class
ChartMenuStyle Overload


ChartMenuStyle Constructor (ChartMenuStyle)

Crates a new ChartMenuStyle by Copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartMenuStyle(
    ChartMenuStyle style
)
Public Sub New (
    style As ChartMenuStyle
)
public:
ChartMenuStyle(
    ChartMenuStyle^ style
)

Parameters

style
Type: TwinCAT.Measurement.Scope.API.ModelChartMenuStyle
See Also

Reference

ChartMenuStyle Class
ChartMenuStyle Overload


ChartMenuStyle Properties

The ChartMenuStyle type exposes the following members.

Properties
 | Name | Description
Public property | ButtonSize | Gets or Sets the ButtonSize.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | EnabledButtons | Gets or Sets the EnabledButtons.
Public property | EnabledTimeLabels | Gets or Sets the EnabledTimeLabels.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IndexNavigation | Gets or Sets the IndexNavigation.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | TimeStripFontSize | Gets or Sets the TimeStripFontSize.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | ToolStripFontSize | Gets or Sets the ToolStripFontSize.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLongTimeFormat | Gets or Sets the UseLongTimeFormat.
Public property | VisibleTimeStrip | Gets or Sets the VisibleTimeStrip.
Public property | VisibleToolStrip | Gets or Sets the VisibleToolStrip.
Top
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.ButtonSize Property

Gets or Sets the ButtonSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public Size ButtonSize { get; set; }
<BrowsableAttribute(false)>
Public Property ButtonSize As Size
    Get
    Set
public:
[BrowsableAttribute(false)]
property Size ButtonSize {
    Size get ();
    void set (Size value);
}

Property Value

Type: Size
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.EnabledButtons Property

Gets or Sets the EnabledButtons.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public ButtonsEnabled EnabledButtons { get; set; }
<BrowsableAttribute(false)>
Public Property EnabledButtons As ButtonsEnabled
    Get
    Set
public:
[BrowsableAttribute(false)]
property ButtonsEnabled EnabledButtons {
    ButtonsEnabled get ();
    void set (ButtonsEnabled value);
}

Property Value

Type: ButtonsEnabled
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.EnabledTimeLabels Property

Gets or Sets the EnabledTimeLabels.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public TimesEnabled EnabledTimeLabels { get; set; }
<BrowsableAttribute(false)>
Public Property EnabledTimeLabels As TimesEnabled
    Get
    Set
public:
[BrowsableAttribute(false)]
property TimesEnabled EnabledTimeLabels {
    TimesEnabled get ();
    void set (TimesEnabled value);
}

Property Value

Type: TimesEnabled
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.IndexNavigation Property

Gets or Sets the IndexNavigation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool IndexNavigation { get; set; }
<BrowsableAttribute(false)>
Public Property IndexNavigation As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool IndexNavigation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.TimeStripFontSize Property

Gets or Sets the TimeStripFontSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public float TimeStripFontSize { get; set; }
<BrowsableAttribute(false)>
Public Property TimeStripFontSize As Single
    Get
    Set
public:
[BrowsableAttribute(false)]
property float TimeStripFontSize {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.ToolStripFontSize Property

Gets or Sets the ToolStripFontSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public float ToolStripFontSize { get; set; }
<BrowsableAttribute(false)>
Public Property ToolStripFontSize As Single
    Get
    Set
public:
[BrowsableAttribute(false)]
property float ToolStripFontSize {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.UseLongTimeFormat Property

Gets or Sets the UseLongTimeFormat.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool UseLongTimeFormat { get; set; }
<BrowsableAttribute(false)>
Public Property UseLongTimeFormat As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool UseLongTimeFormat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.VisibleTimeStrip Property

Gets or Sets the VisibleTimeStrip.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool VisibleTimeStrip { get; set; }
<BrowsableAttribute(true)>
Public Property VisibleTimeStrip As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool VisibleTimeStrip {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.VisibleToolStrip Property

Gets or Sets the VisibleToolStrip.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool VisibleToolStrip { get; set; }
<BrowsableAttribute(true)>
Public Property VisibleToolStrip As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool VisibleToolStrip {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle Methods

The ChartMenuStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of the Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.UpdatePropertyAttributes Method

Updates the Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle Events

The ChartMenuStyle type exposes the following members.

Events
 | Name | Description
Public event | ButtonSizeChanged | Fired when the ButtonSize is changed.
Public event | ButtonSizeValidating | Fired while validating the new value for ButtonSize.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledButtonsChanged | Fired when the EnabledButtons is changed.
Public event | EnabledButtonsValidating | Fired while validating the new value for EnabledButtons.
Public event | EnabledTimeLabelsChanged | Fired when the EnabledTimeLabels is changed.
Public event | EnabledTimeLabelsValidating | Fired while validating the new value for EnabledTimeLabels.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IndexNavigationChanged | Fired when the IndexNavigation is changed.
Public event | IndexNavigationValidating | Fired while validating the new value for IndexNavigation.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TimeStripFontSizeChanged | Fired when the TimeStripFontSize is changed.
Public event | TimeStripFontSizeValidating | Fired while validating the new value for TimeStripFontSize.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | ToolStripFontSizeChanged | Fired when the ToolStripFontSize is changed.
Public event | ToolStripFontSizeValidating | Fired while validating the new value for ToolStripFontSize.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLongTimeFormatChanged | Fired when the UseLongTimeFormat is changed.
Public event | UseLongTimeFormatValidating | Fired while validating the new value for UseLongTimeFormat.
Public event | VisibleTimeStripChanged | Fired when the VisibleTimeStrip is changed.
Public event | VisibleTimeStripValidating | Fired while validating the new value for VisibleTimeStrip.
Public event | VisibleToolStripChanged | Fired when the VisibleToolStrip is changed.
Public event | VisibleToolStripValidating | Fired while validating the new value for VisibleToolStrip.
Top
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.ButtonSizeChanged Event

Fired when the ButtonSize is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ButtonSizeChanged
Public Event ButtonSizeChanged As EventHandler
public:
 event EventHandler^ ButtonSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.ButtonSizeValidating Event

Fired while validating the new value for ButtonSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ButtonSizeValidating
Public Event ButtonSizeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ButtonSizeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.EnabledButtonsChanged Event

Fired when the EnabledButtons is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EnabledButtonsChanged
Public Event EnabledButtonsChanged As EventHandler
public:
 event EventHandler^ EnabledButtonsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.EnabledButtonsValidating Event

Fired while validating the new value for EnabledButtons.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EnabledButtonsValidating
Public Event EnabledButtonsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EnabledButtonsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.EnabledTimeLabelsChanged Event

Fired when the EnabledTimeLabels is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EnabledTimeLabelsChanged
Public Event EnabledTimeLabelsChanged As EventHandler
public:
 event EventHandler^ EnabledTimeLabelsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.EnabledTimeLabelsValidating Event

Fired while validating the new value for EnabledTimeLabels.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EnabledTimeLabelsValidating
Public Event EnabledTimeLabelsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EnabledTimeLabelsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.IndexNavigationChanged Event

Fired when the IndexNavigation is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IndexNavigationChanged
Public Event IndexNavigationChanged As EventHandler
public:
 event EventHandler^ IndexNavigationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.IndexNavigationValidating Event

Fired while validating the new value for IndexNavigation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IndexNavigationValidating
Public Event IndexNavigationValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IndexNavigationValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.TimeStripFontSizeChanged Event

Fired when the TimeStripFontSize is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TimeStripFontSizeChanged
Public Event TimeStripFontSizeChanged As EventHandler
public:
 event EventHandler^ TimeStripFontSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.TimeStripFontSizeValidating Event

Fired while validating the new value for TimeStripFontSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TimeStripFontSizeValidating
Public Event TimeStripFontSizeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TimeStripFontSizeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.ToolStripFontSizeChanged Event

Fired when the ToolStripFontSize is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ToolStripFontSizeChanged
Public Event ToolStripFontSizeChanged As EventHandler
public:
 event EventHandler^ ToolStripFontSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.ToolStripFontSizeValidating Event

Fired while validating the new value for ToolStripFontSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ToolStripFontSizeValidating
Public Event ToolStripFontSizeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ToolStripFontSizeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.UseLongTimeFormatChanged Event

Fired when the UseLongTimeFormat is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UseLongTimeFormatChanged
Public Event UseLongTimeFormatChanged As EventHandler
public:
 event EventHandler^ UseLongTimeFormatChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.UseLongTimeFormatValidating Event

Fired while validating the new value for UseLongTimeFormat.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UseLongTimeFormatValidating
Public Event UseLongTimeFormatValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UseLongTimeFormatValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.VisibleTimeStripChanged Event

Fired when the VisibleTimeStrip is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler VisibleTimeStripChanged
Public Event VisibleTimeStripChanged As EventHandler
public:
 event EventHandler^ VisibleTimeStripChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.VisibleTimeStripValidating Event

Fired while validating the new value for VisibleTimeStrip.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> VisibleTimeStripValidating
Public Event VisibleTimeStripValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ VisibleTimeStripValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.VisibleToolStripChanged Event

Fired when the VisibleToolStrip is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler VisibleToolStripChanged
Public Event VisibleToolStripChanged As EventHandler
public:
 event EventHandler^ VisibleToolStripChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartMenuStyle Class


ChartMenuStyle.VisibleToolStripValidating Event

Fired while validating the new value for VisibleToolStrip.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> VisibleToolStripValidating
Public Event VisibleToolStripValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ VisibleToolStripValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartMenuStyle Class


ChartMenuXYZStyle Class

Class contains Style for XYZ Chart Menu
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelChartMenuStyle
TwinCAT.Measurement.Scope.API.ModelChartMenuXYZStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChartMenuXYZStyle : ChartMenuStyle
Public Class ChartMenuXYZStyle
    Inherits ChartMenuStyle
public ref class ChartMenuXYZStyle : public ChartMenuStyle

The ChartMenuXYZStyle type exposes the following members.

Constructors
 | Name | Description
Public method | ChartMenuXYZStyle | Creates a new ChartMenuStyle
Public method | ChartMenuXYZStyle(ChartMenuXYZStyle) | Crates a new ChartMenuStyle by Copying Properties
Top
Properties
 | Name | Description
Public property | ButtonSize | Gets or Sets the ButtonSize. (Inherited from ChartMenuStyle.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | EnabledButtons | Gets or Sets the EnabledButtons. (Inherited from ChartMenuStyle.)
Public property | EnabledTimeLabels | Gets or Sets the EnabledTimeLabels. (Inherited from ChartMenuStyle.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IndexNavigation | Gets or Sets the IndexNavigation. (Inherited from ChartMenuStyle.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | ShowPanningMode | Gets or Sets the ShowPanningMode.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | TimeStripFontSize | Gets or Sets the TimeStripFontSize. (Inherited from ChartMenuStyle.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | ToolStripFontSize | Gets or Sets the ToolStripFontSize. (Inherited from ChartMenuStyle.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLongTimeFormat | Gets or Sets the UseLongTimeFormat. (Inherited from ChartMenuStyle.)
Public property | VisibleTimeStrip | Gets or Sets the VisibleTimeStrip. (Inherited from ChartMenuStyle.)
Public property | VisibleToolStrip | Gets or Sets the VisibleToolStrip. (Inherited from ChartMenuStyle.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of the Properties (Inherited from ChartMenuStyle.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ButtonSizeChanged | Fired when the ButtonSize is changed. (Inherited from ChartMenuStyle.)
Public event | ButtonSizeValidating | Fired while validating the new value for ButtonSize. (Inherited from ChartMenuStyle.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledButtonsChanged | Fired when the EnabledButtons is changed. (Inherited from ChartMenuStyle.)
Public event | EnabledButtonsValidating | Fired while validating the new value for EnabledButtons. (Inherited from ChartMenuStyle.)
Public event | EnabledTimeLabelsChanged | Fired when the EnabledTimeLabels is changed. (Inherited from ChartMenuStyle.)
Public event | EnabledTimeLabelsValidating | Fired while validating the new value for EnabledTimeLabels. (Inherited from ChartMenuStyle.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IndexNavigationChanged | Fired when the IndexNavigation is changed. (Inherited from ChartMenuStyle.)
Public event | IndexNavigationValidating | Fired while validating the new value for IndexNavigation. (Inherited from ChartMenuStyle.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowPanningModeChanged | Fired when the ShowPanningMode is changed.
Public event | ShowPanningModeValidating | Fired while validating the new value for ShowPanningMode.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TimeStripFontSizeChanged | Fired when the TimeStripFontSize is changed. (Inherited from ChartMenuStyle.)
Public event | TimeStripFontSizeValidating | Fired while validating the new value for TimeStripFontSize. (Inherited from ChartMenuStyle.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | ToolStripFontSizeChanged | Fired when the ToolStripFontSize is changed. (Inherited from ChartMenuStyle.)
Public event | ToolStripFontSizeValidating | Fired while validating the new value for ToolStripFontSize. (Inherited from ChartMenuStyle.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLongTimeFormatChanged | Fired when the UseLongTimeFormat is changed. (Inherited from ChartMenuStyle.)
Public event | UseLongTimeFormatValidating | Fired while validating the new value for UseLongTimeFormat. (Inherited from ChartMenuStyle.)
Public event | VisibleTimeStripChanged | Fired when the VisibleTimeStrip is changed. (Inherited from ChartMenuStyle.)
Public event | VisibleTimeStripValidating | Fired while validating the new value for VisibleTimeStrip. (Inherited from ChartMenuStyle.)
Public event | VisibleToolStripChanged | Fired when the VisibleToolStrip is changed. (Inherited from ChartMenuStyle.)
Public event | VisibleToolStripValidating | Fired while validating the new value for VisibleToolStrip. (Inherited from ChartMenuStyle.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ChartMenuXYZStyle Constructor

Overload List
 | Name | Description
Public method | ChartMenuXYZStyle | Creates a new ChartMenuStyle
Public method | ChartMenuXYZStyle(ChartMenuXYZStyle) | Crates a new ChartMenuStyle by Copying Properties
Top
See Also

Reference

ChartMenuXYZStyle Class


ChartMenuXYZStyle Constructor

Creates a new ChartMenuStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartMenuXYZStyle()
Public Sub New
public:
ChartMenuXYZStyle()
See Also

Reference

ChartMenuXYZStyle Class
ChartMenuXYZStyle Overload


ChartMenuXYZStyle Constructor (ChartMenuXYZStyle)

Crates a new ChartMenuStyle by Copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartMenuXYZStyle(
    ChartMenuXYZStyle chartMenuXYZStyle
)
Public Sub New (
    chartMenuXYZStyle As ChartMenuXYZStyle
)
public:
ChartMenuXYZStyle(
    ChartMenuXYZStyle^ chartMenuXYZStyle
)

Parameters

chartMenuXYZStyle
Type: TwinCAT.Measurement.Scope.API.ModelChartMenuXYZStyle
Set the chart menu xyz style
See Also

Reference

ChartMenuXYZStyle Class
ChartMenuXYZStyle Overload


ChartMenuXYZStyle Properties

The ChartMenuXYZStyle type exposes the following members.

Properties
 | Name | Description
Public property | ButtonSize | Gets or Sets the ButtonSize. (Inherited from ChartMenuStyle.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | EnabledButtons | Gets or Sets the EnabledButtons. (Inherited from ChartMenuStyle.)
Public property | EnabledTimeLabels | Gets or Sets the EnabledTimeLabels. (Inherited from ChartMenuStyle.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IndexNavigation | Gets or Sets the IndexNavigation. (Inherited from ChartMenuStyle.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | ShowPanningMode | Gets or Sets the ShowPanningMode.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | TimeStripFontSize | Gets or Sets the TimeStripFontSize. (Inherited from ChartMenuStyle.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | ToolStripFontSize | Gets or Sets the ToolStripFontSize. (Inherited from ChartMenuStyle.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLongTimeFormat | Gets or Sets the UseLongTimeFormat. (Inherited from ChartMenuStyle.)
Public property | VisibleTimeStrip | Gets or Sets the VisibleTimeStrip. (Inherited from ChartMenuStyle.)
Public property | VisibleToolStrip | Gets or Sets the VisibleToolStrip. (Inherited from ChartMenuStyle.)
Top
See Also

Reference

ChartMenuXYZStyle Class


ChartMenuXYZStyle.ShowPanningMode Property

Gets or Sets the ShowPanningMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public bool ShowPanningMode { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property ShowPanningMode As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property bool ShowPanningMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartMenuXYZStyle Class


ChartMenuXYZStyle Methods

The ChartMenuXYZStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of the Properties (Inherited from ChartMenuStyle.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartMenuXYZStyle Class


ChartMenuXYZStyle Events

The ChartMenuXYZStyle type exposes the following members.

Events
 | Name | Description
Public event | ButtonSizeChanged | Fired when the ButtonSize is changed. (Inherited from ChartMenuStyle.)
Public event | ButtonSizeValidating | Fired while validating the new value for ButtonSize. (Inherited from ChartMenuStyle.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledButtonsChanged | Fired when the EnabledButtons is changed. (Inherited from ChartMenuStyle.)
Public event | EnabledButtonsValidating | Fired while validating the new value for EnabledButtons. (Inherited from ChartMenuStyle.)
Public event | EnabledTimeLabelsChanged | Fired when the EnabledTimeLabels is changed. (Inherited from ChartMenuStyle.)
Public event | EnabledTimeLabelsValidating | Fired while validating the new value for EnabledTimeLabels. (Inherited from ChartMenuStyle.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IndexNavigationChanged | Fired when the IndexNavigation is changed. (Inherited from ChartMenuStyle.)
Public event | IndexNavigationValidating | Fired while validating the new value for IndexNavigation. (Inherited from ChartMenuStyle.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowPanningModeChanged | Fired when the ShowPanningMode is changed.
Public event | ShowPanningModeValidating | Fired while validating the new value for ShowPanningMode.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TimeStripFontSizeChanged | Fired when the TimeStripFontSize is changed. (Inherited from ChartMenuStyle.)
Public event | TimeStripFontSizeValidating | Fired while validating the new value for TimeStripFontSize. (Inherited from ChartMenuStyle.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | ToolStripFontSizeChanged | Fired when the ToolStripFontSize is changed. (Inherited from ChartMenuStyle.)
Public event | ToolStripFontSizeValidating | Fired while validating the new value for ToolStripFontSize. (Inherited from ChartMenuStyle.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLongTimeFormatChanged | Fired when the UseLongTimeFormat is changed. (Inherited from ChartMenuStyle.)
Public event | UseLongTimeFormatValidating | Fired while validating the new value for UseLongTimeFormat. (Inherited from ChartMenuStyle.)
Public event | VisibleTimeStripChanged | Fired when the VisibleTimeStrip is changed. (Inherited from ChartMenuStyle.)
Public event | VisibleTimeStripValidating | Fired while validating the new value for VisibleTimeStrip. (Inherited from ChartMenuStyle.)
Public event | VisibleToolStripChanged | Fired when the VisibleToolStrip is changed. (Inherited from ChartMenuStyle.)
Public event | VisibleToolStripValidating | Fired while validating the new value for VisibleToolStrip. (Inherited from ChartMenuStyle.)
Top
See Also

Reference

ChartMenuXYZStyle Class


ChartMenuXYZStyle.ShowPanningModeChanged Event

Fired when the ShowPanningMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowPanningModeChanged
Public Event ShowPanningModeChanged As EventHandler
public:
 event EventHandler^ ShowPanningModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartMenuXYZStyle Class


ChartMenuXYZStyle.ShowPanningModeValidating Event

Fired while validating the new value for ShowPanningMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowPanningModeValidating
Public Event ShowPanningModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowPanningModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartMenuXYZStyle Class


ChartPositionStyle Class

Contains all information about the position of a channel in a Bar-Chart
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelChartPositionStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChartPositionStyle : ScopeMemberBase
Public Class ChartPositionStyle
    Inherits ScopeMemberBase
public ref class ChartPositionStyle : public ScopeMemberBase

The ChartPositionStyle type exposes the following members.

Constructors
 | Name | Description
Public method | ChartPositionStyle | Creates an instance of ChartPositionStyle
Public method | ChartPositionStyle(ChartPositionStyle) | Creates an instance of ChartPositionStyle and copy all properties
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Position | Gets or Sets the Position.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of the Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | BeforePositionChanged | Fired before position changed
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionChanged | Fired when the Position is changed.
Public event | PositionValidating | Fired while validating the new value for Position.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Fields
Name | Description
DefaultDisplayColor | Get or Set the DefaultDisplayColor
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ChartPositionStyle Constructor

Overload List
 | Name | Description
Public method | ChartPositionStyle | Creates an instance of ChartPositionStyle
Public method | ChartPositionStyle(ChartPositionStyle) | Creates an instance of ChartPositionStyle and copy all properties
Top
See Also

Reference

ChartPositionStyle Class


ChartPositionStyle Constructor

Creates an instance of ChartPositionStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartPositionStyle()
Public Sub New
public:
ChartPositionStyle()
See Also

Reference

ChartPositionStyle Class
ChartPositionStyle Overload


ChartPositionStyle Constructor (ChartPositionStyle)

Creates an instance of ChartPositionStyle and copy all properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartPositionStyle(
    ChartPositionStyle cps
)
Public Sub New (
    cps As ChartPositionStyle
)
public:
ChartPositionStyle(
    ChartPositionStyle^ cps
)

Parameters

cps
Type: TwinCAT.Measurement.Scope.API.ModelChartPositionStyle
See Also

Reference

ChartPositionStyle Class
ChartPositionStyle Overload


ChartPositionStyle Properties

The ChartPositionStyle type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Position | Gets or Sets the Position.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartPositionStyle Class


ChartPositionStyle.DisplayColor Property

Gets or Sets the DisplayColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override Color DisplayColor { get; set; }
Public Overrides Property DisplayColor As Color
    Get
    Set
public:
virtual property Color DisplayColor {
    Color get () override;
    void set (Color value) override;
}

Property Value

Type: Color
See Also

Reference

ChartPositionStyle Class


ChartPositionStyle.Position Property

Gets or Sets the Position.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int Position { get; set; }
<BrowsableAttribute(true)>
Public Property Position As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int Position {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ChartPositionStyle Class


ChartPositionStyle Methods

The ChartPositionStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of the Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartPositionStyle Class


ChartPositionStyle.UpdatePropertyAttributes Method

Update Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ChartPositionStyle Class


ChartPositionStyle Events

The ChartPositionStyle type exposes the following members.

Events
 | Name | Description
Public event | BeforePositionChanged | Fired before position changed
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionChanged | Fired when the Position is changed.
Public event | PositionValidating | Fired while validating the new value for Position.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartPositionStyle Class


ChartPositionStyle.BeforePositionChanged Event

Fired before position changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforePositionChanged
Public Event BeforePositionChanged As EventHandler
public:
 event EventHandler^ BeforePositionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartPositionStyle Class


ChartPositionStyle.PositionChanged Event

Fired when the Position is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PositionChanged
Public Event PositionChanged As EventHandler
public:
 event EventHandler^ PositionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartPositionStyle Class


ChartPositionStyle.PositionValidating Event

Fired while validating the new value for Position.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PositionValidating
Public Event PositionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PositionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartPositionStyle Class


ChartPositionStyle Fields

The ChartPositionStyle type exposes the following members.

Fields
Name | Description
DefaultDisplayColor | Get or Set the DefaultDisplayColor
Top
See Also

Reference

ChartPositionStyle Class


ChartPositionStyle.DefaultDisplayColor Field

Get or Set the DefaultDisplayColor

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static Color DefaultDisplayColor
Public Shared DefaultDisplayColor As Color
public:
static Color DefaultDisplayColor

Field Value

Type: Color
See Also

Reference

ChartPositionStyle Class


ChartStyle Class

Class witch contains Style Elements of a Chart
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelChartStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChartStyle : ScopeMemberContainerBase
Public Class ChartStyle
    Inherits ScopeMemberContainerBase
public ref class ChartStyle : public ScopeMemberContainerBase

The ChartStyle type exposes the following members.

Constructors
 | Name | Description
Public method | ChartStyle | Creates a new Style object and initializes the Properties with default values.
Public method | ChartStyle(ChartStyle) | Creates a new Style object by copy Properties form other Style
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GradientBackground | Gets or Sets the GradientBackground.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowName | Gets or Sets the ShowName.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StackedAxes | Gets or Sets the StackedAxes.
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | ToolTipEnabled | Gets or Sets the ToolTipEnabled.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GradientBackgroundChanged | Fired when the GradientBackground is changed.
Public event | GradientBackgroundValidating | Fired while validating the new value for GradientBackground.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowNameChanged | Fired when the ShowName is changed.
Public event | ShowNameValidating | Fired while validating the new value for ShowName.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StackedAxesChanged | Fired when the StackedAxes is changed.
Public event | StackedAxesValidating | Fired while validating the new value for StackedAxes.
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | ToolTipEnabledChanged | Fired when the ToolTipEnabled is changed.
Public event | ToolTipEnabledValidating | Fired while validating the new value for ToolTipEnabled.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ChartStyle Constructor

Overload List
 | Name | Description
Public method | ChartStyle | Creates a new Style object and initializes the Properties with default values.
Public method | ChartStyle(ChartStyle) | Creates a new Style object by copy Properties form other Style
Top
See Also

Reference

ChartStyle Class


ChartStyle Constructor

Creates a new Style object and initializes the Properties with default values.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartStyle()
Public Sub New
public:
ChartStyle()
See Also

Reference

ChartStyle Class
ChartStyle Overload


ChartStyle Constructor (ChartStyle)

Creates a new Style object by copy Properties form other Style

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartStyle(
    ChartStyle style
)
Public Sub New (
    style As ChartStyle
)
public:
ChartStyle(
    ChartStyle^ style
)

Parameters

style
Type: TwinCAT.Measurement.Scope.API.ModelChartStyle
Style to Copy From
See Also

Reference

ChartStyle Class
ChartStyle Overload


ChartStyle Properties

The ChartStyle type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GradientBackground | Gets or Sets the GradientBackground.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowName | Gets or Sets the ShowName.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StackedAxes | Gets or Sets the StackedAxes.
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | ToolTipEnabled | Gets or Sets the ToolTipEnabled.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartStyle Class


ChartStyle.GradientBackground Property

Gets or Sets the GradientBackground.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public float GradientBackground { get; set; }
Public Property GradientBackground As Single
    Get
    Set
public:
property float GradientBackground {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

ChartStyle Class


ChartStyle.ShowName Property

Gets or Sets the ShowName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowName { get; set; }
<BrowsableAttribute(true)>
Public Property ShowName As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowName {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartStyle Class


ChartStyle.StackedAxes Property

Gets or Sets the StackedAxes.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool StackedAxes { get; set; }
<BrowsableAttribute(true)>
Public Property StackedAxes As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool StackedAxes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartStyle Class


ChartStyle.ToolTipEnabled Property

Gets or Sets the ToolTipEnabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ToolTipEnabled { get; set; }
<BrowsableAttribute(true)>
Public Property ToolTipEnabled As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ToolTipEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartStyle Class


ChartStyle Methods

The ChartStyle type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartStyle Class


ChartStyle.UpdatePropertyAttributes Method

Update the Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ChartStyle Class


ChartStyle Events

The ChartStyle type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GradientBackgroundChanged | Fired when the GradientBackground is changed.
Public event | GradientBackgroundValidating | Fired while validating the new value for GradientBackground.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowNameChanged | Fired when the ShowName is changed.
Public event | ShowNameValidating | Fired while validating the new value for ShowName.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StackedAxesChanged | Fired when the StackedAxes is changed.
Public event | StackedAxesValidating | Fired while validating the new value for StackedAxes.
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | ToolTipEnabledChanged | Fired when the ToolTipEnabled is changed.
Public event | ToolTipEnabledValidating | Fired while validating the new value for ToolTipEnabled.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartStyle Class


ChartStyle.GradientBackgroundChanged Event

Fired when the GradientBackground is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler GradientBackgroundChanged
Public Event GradientBackgroundChanged As EventHandler
public:
 event EventHandler^ GradientBackgroundChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartStyle Class


ChartStyle.GradientBackgroundValidating Event

Fired while validating the new value for GradientBackground.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> GradientBackgroundValidating
Public Event GradientBackgroundValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ GradientBackgroundValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartStyle Class


ChartStyle.ShowNameChanged Event

Fired when the ShowName is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowNameChanged
Public Event ShowNameChanged As EventHandler
public:
 event EventHandler^ ShowNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartStyle Class


ChartStyle.ShowNameValidating Event

Fired while validating the new value for ShowName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowNameValidating
Public Event ShowNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartStyle Class


ChartStyle.StackedAxesChanged Event

Fired when the StackedAxes is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StackedAxesChanged
Public Event StackedAxesChanged As EventHandler
public:
 event EventHandler^ StackedAxesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartStyle Class


ChartStyle.StackedAxesValidating Event

Fired while validating the new value for StackedAxes.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> StackedAxesValidating
Public Event StackedAxesValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ StackedAxesValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartStyle Class


ChartStyle.ToolTipEnabledChanged Event

Fired when the ToolTipEnabled is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ToolTipEnabledChanged
Public Event ToolTipEnabledChanged As EventHandler
public:
 event EventHandler^ ToolTipEnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartStyle Class


ChartStyle.ToolTipEnabledValidating Event

Fired while validating the new value for ToolTipEnabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ToolTipEnabledValidating
Public Event ToolTipEnabledValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ToolTipEnabledValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartStyle Class


ChartZoomStyle Class

Class which contains Zoom Properties for a chart
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelChartZoomStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChartZoomStyle : ScopeMemberBase
Public Class ChartZoomStyle
    Inherits ScopeMemberBase
public ref class ChartZoomStyle : public ScopeMemberBase

The ChartZoomStyle type exposes the following members.

Constructors
 | Name | Description
Public method | ChartZoomStyle | Creates a new ChartZoomStyle
Public method | ChartZoomStyle(ChartZoomStyle) | Creates a new ChartZoomStyle and copying the Properties
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScaleOnZoom | Gets or Sets the ScaleOnZoom.
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | YZoom | Gets or Sets the YZoom.
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of the Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScaleOnZoomChanged | Fired when the ScaleOnZoom is changed.
Public event | ScaleOnZoomValidating | Fired while validating the new value for ScaleOnZoom.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | YZoomChanged | Fired when the YZoom is changed.
Public event | YZoomValidating | Fired while validating the new value for YZoom.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ChartZoomStyle Constructor

Overload List
 | Name | Description
Public method | ChartZoomStyle | Creates a new ChartZoomStyle
Public method | ChartZoomStyle(ChartZoomStyle) | Creates a new ChartZoomStyle and copying the Properties
Top
See Also

Reference

ChartZoomStyle Class


ChartZoomStyle Constructor

Creates a new ChartZoomStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartZoomStyle()
Public Sub New
public:
ChartZoomStyle()
See Also

Reference

ChartZoomStyle Class
ChartZoomStyle Overload


ChartZoomStyle Constructor (ChartZoomStyle)

Creates a new ChartZoomStyle and copying the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartZoomStyle(
    ChartZoomStyle iMem
)
Public Sub New (
    iMem As ChartZoomStyle
)
public:
ChartZoomStyle(
    ChartZoomStyle^ iMem
)

Parameters

iMem
Type: TwinCAT.Measurement.Scope.API.ModelChartZoomStyle
See Also

Reference

ChartZoomStyle Class
ChartZoomStyle Overload


ChartZoomStyle Properties

The ChartZoomStyle type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScaleOnZoom | Gets or Sets the ScaleOnZoom.
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | YZoom | Gets or Sets the YZoom.
Top
See Also

Reference

ChartZoomStyle Class


ChartZoomStyle.ScaleOnZoom Property

Gets or Sets the ScaleOnZoom.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ScaleOnZoom { get; set; }
<BrowsableAttribute(true)>
Public Property ScaleOnZoom As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ScaleOnZoom {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartZoomStyle Class


ChartZoomStyle.YZoom Property

Gets or Sets the YZoom.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool YZoom { get; set; }
<BrowsableAttribute(false)>
Public Property YZoom As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool YZoom {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartZoomStyle Class


ChartZoomStyle Methods

The ChartZoomStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of the Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ChartZoomStyle Class


ChartZoomStyle.UpdatePropertyAttributes Method

Updates the Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ChartZoomStyle Class


ChartZoomStyle Events

The ChartZoomStyle type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScaleOnZoomChanged | Fired when the ScaleOnZoom is changed.
Public event | ScaleOnZoomValidating | Fired while validating the new value for ScaleOnZoom.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | YZoomChanged | Fired when the YZoom is changed.
Public event | YZoomValidating | Fired while validating the new value for YZoom.
Top
See Also

Reference

ChartZoomStyle Class


ChartZoomStyle.ScaleOnZoomChanged Event

Fired when the ScaleOnZoom is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ScaleOnZoomChanged
Public Event ScaleOnZoomChanged As EventHandler
public:
 event EventHandler^ ScaleOnZoomChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartZoomStyle Class


ChartZoomStyle.ScaleOnZoomValidating Event

Fired while validating the new value for ScaleOnZoom.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ScaleOnZoomValidating
Public Event ScaleOnZoomValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ScaleOnZoomValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartZoomStyle Class


ChartZoomStyle.YZoomChanged Event

Fired when the YZoom is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler YZoomChanged
Public Event YZoomChanged As EventHandler
public:
 event EventHandler^ YZoomChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartZoomStyle Class


ChartZoomStyle.YZoomValidating Event

Fired while validating the new value for YZoom.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> YZoomValidating
Public Event YZoomValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ YZoomValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ChartZoomStyle Class


ColumnConfig Class

Base Column Configuration
Inheritance Hierarchy
SystemObject
ModelBase
TwinCAT.Measurement.Scope.API.ModelColumnConfig

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class ColumnConfig : ModelBase
Public MustInherit Class ColumnConfig
    Inherits ModelBase
public ref class ColumnConfig abstract : public ModelBase

The ColumnConfig type exposes the following members.

Properties
 | Name | Description
Public property | Visible | Gets or Sets the Visibility
Public property | Width | Gets or Sets the Width.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | OnWidthChanged | Fired when the Width Changed
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ColumnConfig Properties

The ColumnConfig type exposes the following members.

Properties
 | Name | Description
Public property | Visible | Gets or Sets the Visibility
Public property | Width | Gets or Sets the Width.
Top
See Also

Reference

ColumnConfig Class


ColumnConfig.Visible Property

Gets or Sets the Visibility

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool Visible { get; }
Public ReadOnly Property Visible As Boolean
    Get
public:
property bool Visible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ColumnConfig Class


ColumnConfig.Width Property

Gets or Sets the Width.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public double Width { get; set; }
Public Property Width As Double
    Get
    Set
public:
property double Width {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ColumnConfig Class


ColumnConfig Methods

The ColumnConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColumnConfig Class


ColumnConfig Events

The ColumnConfig type exposes the following members.

Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | OnWidthChanged | Fired when the Width Changed
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

ColumnConfig Class


ColumnConfig.OnWidthChanged Event

Fired when the Width Changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OnWidthChanged
Public Event OnWidthChanged As EventHandler
public:
 event EventHandler^ OnWidthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ColumnConfig Class


CommandMember Class

Inheritance Hierarchy
SystemObject
ModelBase
TwinCAT.Measurement.Scope.API.ModelCommandMember

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class CommandMember : ModelBase
Public Class CommandMember
    Inherits ModelBase
public ref class CommandMember : public ModelBase

The CommandMember type exposes the following members.

Constructors
 | Name | Description
Public method | CommandMember | Initializes a new instance of the CommandMember class
Top
Properties
 | Name | Description
Public property | Command | Gets or Sets the Command.
Public property | CommandName | Gets or Sets the CommandName.
Public property | IsVisible | Gets or Sets the IsVisible.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


CommandMember Constructor

Initializes a new instance of the CommandMember class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public CommandMember(
    string name,
    Action<Object> action,
    bool isVisible = true
)
Public Sub New (
    name As String,
    action As Action(Of Object),
    Optional isVisible As Boolean = true
)
public:
CommandMember(
    String^ name,
    Action<Object^>^ action,
    bool isVisible = true
)

Parameters

name
Type: SystemString
action
Type: SystemAction Object
isVisible (Optional)
Type: SystemBoolean
See Also

Reference

CommandMember Class


CommandMember Properties

The CommandMember type exposes the following members.

Properties
 | Name | Description
Public property | Command | Gets or Sets the Command.
Public property | CommandName | Gets or Sets the CommandName.
Public property | IsVisible | Gets or Sets the IsVisible.
Top
See Also

Reference

CommandMember Class


CommandMember.Command Property

Gets or Sets the Command.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ICommand Command { get; set; }
Public Property Command As ICommand
    Get
    Set
public:
property ICommand^ Command {
    ICommand^ get ();
    void set (ICommand^ value);
}

Property Value

Type: ICommand
See Also

Reference

CommandMember Class


CommandMember.CommandName Property

Gets or Sets the CommandName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string CommandName { get; set; }
Public Property CommandName As String
    Get
    Set
public:
property String^ CommandName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CommandMember Class


CommandMember.IsVisible Property

Gets or Sets the IsVisible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool IsVisible { get; set; }
Public Property IsVisible As Boolean
    Get
    Set
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CommandMember Class


CommandMember Methods

The CommandMember type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CommandMember Class


CommandMember Events

The CommandMember type exposes the following members.

Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

CommandMember Class


Condition Class

Base Class for all DynamicStyle Conditions
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelCondition
TwinCAT.Measurement.Scope.API.ModelAreaCondition
TwinCAT.Measurement.Scope.API.ModelThresholdCondition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class Condition : ScopeMemberContainerBase,
    ICondition
Public MustInherit Class Condition
    Inherits ScopeMemberContainerBase
    Implements ICondition
public ref class Condition abstract : public ScopeMemberContainerBase,
    ICondition

The Condition type exposes the following members.

Constructors
 | Name | Description
Public method | Condition | Create a new Condition
Public method | Condition(Condition) | Create a new Condition by copying Properties
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | InterpreterGUID | Gets or Sets the InterpreterGUID.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReferenceAcquisitionInterpreter | Gets or Sets the ReferenceAcquisitionInterpreter.
Public property | ReusedAcquisitionOrInterpreter | Gets or Sets the ReusedAcquisitionOrInterpreter.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseChannelData | Gets or Sets the UseChannelData.
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Udates the Attributes of the Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InterpreterGUIDChanged | Fired when the InterpreterGUID is changed.
Public event | InterpreterGUIDValidating | Fired while validating the new value for InterpreterGUID.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReferenceAcquisitionInterpreterChanged | Fired when the ReferenceAcquisitionInterpreterChanged is changed.
Public event | ReferenceAcquisitionInterpreterChanging | Fired before Changing the value of ReferenceAcquisitionInterpreter.
Public event | ReferenceAcquisitionInterpreterValidating | Fired while validating the new value for ReferenceAcquisitionInterpreter.
Public event | RefreshDisplay | Fired to Refresh Display
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReusedAcquisitionOrInterpreterChanged | Fired when the ReusedAcquisitionOrInterpreter is changed.
Public event | ReusedAcquisitionOrInterpreterValidating | Fired while validating the new value for ReusedAcquisitionOrInterpreter.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseChannelDataChanged | Fired when the UseChannelData is changed.
Public event | UseChannelDataValidating | Fired while validating the new value for UseChannelData.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


Condition Constructor

Overload List
 | Name | Description
Public method | Condition | Create a new Condition
Public method | Condition(Condition) | Create a new Condition by copying Properties
Top
See Also

Reference

Condition Class


Condition Constructor

Create a new Condition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Condition()
Public Sub New
public:
Condition()
See Also

Reference

Condition Class
Condition Overload


Condition Constructor (Condition)

Create a new Condition by copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Condition(
    Condition org
)
Public Sub New (
    org As Condition
)
public:
Condition(
    Condition^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelCondition
Condition to copy from
See Also

Reference

Condition Class
Condition Overload


Condition Properties

The Condition type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | InterpreterGUID | Gets or Sets the InterpreterGUID.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReferenceAcquisitionInterpreter | Gets or Sets the ReferenceAcquisitionInterpreter.
Public property | ReusedAcquisitionOrInterpreter | Gets or Sets the ReusedAcquisitionOrInterpreter.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseChannelData | Gets or Sets the UseChannelData.
Top
See Also

Reference

Condition Class


Condition.Enabled Property

Gets or Sets the Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Enabled { get; set; }
<BrowsableAttribute(true)>
Public Property Enabled As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Condition Class


Condition.InterpreterGUID Property

Gets or Sets the InterpreterGUID.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public Guid InterpreterGUID { get; set; }
<BrowsableAttribute(false)>
Public Property InterpreterGUID As Guid
    Get
    Set
public:
[BrowsableAttribute(false)]
property Guid InterpreterGUID {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

Condition Class


Condition.ReferenceAcquisitionInterpreter Property

Gets or Sets the ReferenceAcquisitionInterpreter.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public AcquisitionInterpreter ReferenceAcquisitionInterpreter { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property ReferenceAcquisitionInterpreter As AcquisitionInterpreter
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property AcquisitionInterpreter^ ReferenceAcquisitionInterpreter {
    AcquisitionInterpreter^ get ();
    void set (AcquisitionInterpreter^ value);
}

Property Value

Type: AcquisitionInterpreter
See Also

Reference

Condition Class


Condition.ReusedAcquisitionOrInterpreter Property

Gets or Sets the ReusedAcquisitionOrInterpreter.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
public Guid ReusedAcquisitionOrInterpreter { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(true)>
Public Property ReusedAcquisitionOrInterpreter As Guid
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
property Guid ReusedAcquisitionOrInterpreter {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

Condition Class


Condition.UseChannelData Property

Gets or Sets the UseChannelData.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool UseChannelData { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property UseChannelData As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool UseChannelData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Condition Class


Condition Methods

The Condition type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Udates the Attributes of the Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

Condition Class


Condition.GetCommands Method

Gets a List of Commands

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
An Array of Commands
See Also

Reference

Condition Class


Condition.UpdatePropertyAttributes Method

Udates the Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

Condition Class


Condition Events

The Condition type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InterpreterGUIDChanged | Fired when the InterpreterGUID is changed.
Public event | InterpreterGUIDValidating | Fired while validating the new value for InterpreterGUID.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReferenceAcquisitionInterpreterChanged | Fired when the ReferenceAcquisitionInterpreterChanged is changed.
Public event | ReferenceAcquisitionInterpreterChanging | Fired before Changing the value of ReferenceAcquisitionInterpreter.
Public event | ReferenceAcquisitionInterpreterValidating | Fired while validating the new value for ReferenceAcquisitionInterpreter.
Public event | RefreshDisplay | Fired to Refresh Display
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReusedAcquisitionOrInterpreterChanged | Fired when the ReusedAcquisitionOrInterpreter is changed.
Public event | ReusedAcquisitionOrInterpreterValidating | Fired while validating the new value for ReusedAcquisitionOrInterpreter.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseChannelDataChanged | Fired when the UseChannelData is changed.
Public event | UseChannelDataValidating | Fired while validating the new value for UseChannelData.
Top
See Also

Reference

Condition Class


Condition.EnabledChanged Event

Fired when the Enabled is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EnabledChanged
Public Event EnabledChanged As EventHandler
public:
 event EventHandler^ EnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Condition Class


Condition.EnabledValidating Event

Fired while validating the new value for Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EnabledValidating
Public Event EnabledValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EnabledValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Condition Class


Condition.InterpreterGUIDChanged Event

Fired when the InterpreterGUID is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler InterpreterGUIDChanged
Public Event InterpreterGUIDChanged As EventHandler
public:
 event EventHandler^ InterpreterGUIDChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Condition Class


Condition.InterpreterGUIDValidating Event

Fired while validating the new value for InterpreterGUID.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> InterpreterGUIDValidating
Public Event InterpreterGUIDValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ InterpreterGUIDValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Condition Class


Condition.ReferenceAcquisitionInterpreterChanged Event

Fired when the ReferenceAcquisitionInterpreterChanged is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReferenceAcquisitionInterpreterChanged
Public Event ReferenceAcquisitionInterpreterChanged As EventHandler
public:
 event EventHandler^ ReferenceAcquisitionInterpreterChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Condition Class


Condition.ReferenceAcquisitionInterpreterChanging Event

Fired before Changing the value of ReferenceAcquisitionInterpreter.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReferenceAcquisitionInterpreterChanging
Public Event ReferenceAcquisitionInterpreterChanging As EventHandler
public:
 event EventHandler^ ReferenceAcquisitionInterpreterChanging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Condition Class


Condition.ReferenceAcquisitionInterpreterValidating Event

Fired while validating the new value for ReferenceAcquisitionInterpreter.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReferenceAcquisitionInterpreterValidating
Public Event ReferenceAcquisitionInterpreterValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReferenceAcquisitionInterpreterValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Condition Class


Condition.RefreshDisplay Event

Fired to Refresh Display

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler RefreshDisplay
Public Event RefreshDisplay As EventHandler
public:
 event EventHandler^ RefreshDisplay {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Condition Class


Condition.ReusedAcquisitionOrInterpreterChanged Event

Fired when the ReusedAcquisitionOrInterpreter is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReusedAcquisitionOrInterpreterChanged
Public Event ReusedAcquisitionOrInterpreterChanged As EventHandler
public:
 event EventHandler^ ReusedAcquisitionOrInterpreterChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Condition Class


Condition.ReusedAcquisitionOrInterpreterValidating Event

Fired while validating the new value for ReusedAcquisitionOrInterpreter.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReusedAcquisitionOrInterpreterValidating
Public Event ReusedAcquisitionOrInterpreterValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReusedAcquisitionOrInterpreterValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Condition Class


Condition.UseChannelDataChanged Event

Fired when the UseChannelData is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UseChannelDataChanged
Public Event UseChannelDataChanged As EventHandler
public:
 event EventHandler^ UseChannelDataChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Condition Class


Condition.UseChannelDataValidating Event

Fired while validating the new value for UseChannelData.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UseChannelDataValidating
Public Event UseChannelDataValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UseChannelDataValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Condition Class


ConnectableChart Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAnchorTimeBase
TwinCAT.Measurement.Scope.API.ModelChart
TwinCAT.Measurement.Scope.API.ModelConnectableChart
TwinCAT.Measurement.Scope.API.ModelSingleValuesChart
TwinCAT.Measurement.Scope.API.ModelXYChart
TwinCAT.Measurement.Scope.API.ModelXYZChart
TwinCAT.Measurement.Scope.API.ModelYTChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class ConnectableChart : Chart
Public MustInherit Class ConnectableChart
    Inherits Chart
public ref class ConnectableChart abstract : public Chart

The ConnectableChart type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectableChart | Initializes a new instance of the ConnectableChart class
Public method | ConnectableChart(ConnectableChart) | Initializes a new instance of the ConnectableChart class
Top
Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Inherited from Chart.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Inherited from Chart.)
Public property | ChartType | (Inherited from Chart.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Overrides ChartConnected.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay |
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Overrides ChartGetAcquisitionData(Int64, Acquisition).)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Overrides ChartGetDisplay.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Overrides ChartHighlightTriggerGroup(TriggerGroup).)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Overrides ChartRenewDisplay.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Overrides ChartScroll(Direction, Int64).)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Chart.)
Public method | Validate | Validates the Chart Configuration and adds an ChartStyle, if not exists. (Inherited from Chart.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ConnectableChart Constructor

Overload List
 | Name | Description
Public method | ConnectableChart | Initializes a new instance of the ConnectableChart class
Public method | ConnectableChart(ConnectableChart) | Initializes a new instance of the ConnectableChart class
Top
See Also

Reference

ConnectableChart Class


ConnectableChart Constructor

Initializes a new instance of the ConnectableChart class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ConnectableChart()
Public Sub New
public:
ConnectableChart()
See Also

Reference

ConnectableChart Class
ConnectableChart Overload


ConnectableChart Constructor (ConnectableChart)

Initializes a new instance of the ConnectableChart class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ConnectableChart(
    ConnectableChart chart
)
Public Sub New (
    chart As ConnectableChart
)
public:
ConnectableChart(
    ConnectableChart^ chart
)

Parameters

chart
Type: TwinCAT.Measurement.Scope.API.ModelConnectableChart
See Also

Reference

ConnectableChart Class
ConnectableChart Overload


ConnectableChart Properties

The ConnectableChart type exposes the following members.

Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Inherited from Chart.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Inherited from Chart.)
Public property | ChartType | (Inherited from Chart.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Overrides ChartConnected.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ConnectableChart Class


ConnectableChart.Connected Property

Get the ConnectionState

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public override bool Connected { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property Connected As Boolean
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property bool Connected {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

ConnectableChart Class


ConnectableChart Methods

The ConnectableChart type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay |
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Overrides ChartGetAcquisitionData(Int64, Acquisition).)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Overrides ChartGetDisplay.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Overrides ChartHighlightTriggerGroup(TriggerGroup).)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Overrides ChartRenewDisplay.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Overrides ChartScroll(Direction, Int64).)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Chart.)
Public method | Validate | Validates the Chart Configuration and adds an ChartStyle, if not exists. (Inherited from Chart.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
See Also

Reference

ConnectableChart Class


ConnectableChart.ForceDisplay Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void ForceDisplay(
    long Pos
)
Public Sub ForceDisplay (
    Pos As Long
)
public:
void ForceDisplay(
    long long Pos
)

Parameters

Pos
Type: SystemInt64
See Also

Reference

ConnectableChart Class


ConnectableChart.GetAcquisitionData Method

Gets the Acquisition Data from the timestamp

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override Tuple<long, Object> GetAcquisitionData(
    long timestamp,
    Acquisition acquisition
)
Public Overrides Function GetAcquisitionData (
    timestamp As Long,
    acquisition As Acquisition
) As Tuple(Of Long, Object)
public:
virtual Tuple<long long, Object^>^ GetAcquisitionData(
    long long timestamp,
    Acquisition^ acquisition
) override

Parameters

timestamp
Type: SystemInt64
Timestamp of the data
acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
Acquisition for the Data

Return Value

Type: Tuple Int64, Object
Returns a Tuple with the right Timestamp and the Data
See Also

Reference

ConnectableChart Class


ConnectableChart.GetDisplay Method

Refreshes the values of the actual Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void GetDisplay()
Public Overrides Sub GetDisplay
public:
virtual void GetDisplay() override
See Also

Reference

ConnectableChart Class


ConnectableChart.HighlightTriggerGroup Method

Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void HighlightTriggerGroup(
    TriggerGroup triggerGroup
)
Public Overrides Sub HighlightTriggerGroup (
    triggerGroup As TriggerGroup
)
public:
virtual void HighlightTriggerGroup(
    TriggerGroup^ triggerGroup
) override

Parameters

triggerGroup
Type: TwinCAT.Measurement.Scope.API.ModelTriggerGroup
TriggerGroup to Highlight
See Also

Reference

ConnectableChart Class


ConnectableChart.RenewDisplay Method

Renew the actual Display

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void RenewDisplay()
Public Overrides Sub RenewDisplay
public:
virtual void RenewDisplay() override
See Also

Reference

ConnectableChart Class


ConnectableChart.Scroll Method

Overload List
 | Name | Description
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Overrides ChartScroll(Direction, Int64).)
Top
See Also

Reference

ConnectableChart Class


ConnectableChart.Scroll Method (Direction, Int64)

Scrolls the chart in the given direction and by the given interval.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void Scroll(
    Direction direction,
    long shifttime
)
Public Overrides Sub Scroll (
    direction As Direction,
    shifttime As Long
)
public:
virtual void Scroll(
    Direction direction,
    long long shifttime
) override

Parameters

direction
Type: TwinCAT.Measurement.Scope.APIDirection
The move direction.
shifttime
Type: SystemInt64
The interval to shift.
See Also

Reference

ConnectableChart Class
Scroll Overload


ConnectableChart Events

The ConnectableChart type exposes the following members.

Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ConnectableChart Class


ConnectableChart Fields

The ConnectableChart type exposes the following members.

Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

ConnectableChart Class


CustomSequence Class

Sequence class that generates signals.
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisition
TwinCAT.Measurement.Scope.API.ModelSequence
TwinCAT.Measurement.Scope.API.ModelCustomSequence

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class CustomSequence : Sequence
Public Class CustomSequence
    Inherits Sequence
public ref class CustomSequence : public Sequence

The CustomSequence type exposes the following members.

Constructors
 | Name | Description
Public method | CustomSequence | Creates a new empty CustomSequence
Public method | CustomSequence(CustomSequence) | Initialize Properties with values copied from other Acquisition
Public method | CustomSequence(Double, Int32) | Creates a new CustomSequence that adds a default value.
Top
Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | (Overrides AcquisitionCompressionMode.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | Data | Gets the Data of this acquisition. (Inherited from Sequence.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataFilePath | Gets or Sets the DataFilePath. (Inherited from Sequence.)
Public property | DataPoints |
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | (Inherited from Sequence.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | ExportOptions | Gets or Sets the ExportOptions. (Inherited from Sequence.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleCount | Gets or Sets the SampleCount. (Inherited from Sequence.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | (Overrides AcquisitionSaveOption.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
Methods
 | Name | Description
Public method | AddData | Adds a list of samples to the end. (Inherited from Sequence.)
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CopyData | (Inherited from Sequence.)
Public method | DeleteDataFiles | Deletes the data file(s) at the DataFilePath. (Inherited from Sequence.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportToAlyFile | (Inherited from Sequence.)
Public method | ExtendDataEnd | Adds samples to the end. (Overrides SequenceExtendDataEnd(Int64).)
Public method | ExtendDataStart | Adds samples at the start. (Overrides SequenceExtendDataStart(Int64).)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllFileInfos | Get all files which are used in this sequence (Inherited from Sequence.)
Public method | GetAllFilePathes | Get all files which are used in this sequence (Inherited from Sequence.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAlyFilePath | (Inherited from Sequence.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | (Inherited from Sequence.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Inherited from Acquisition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Acquisition.)
Public method | GetIotType | (Inherited from Sequence.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTasPath | (Inherited from Sequence.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Get the data from the timestamp First Value = Timestamp == 0 (Inherited from Sequence.)
Public method | GetValueConverter | (Inherited from Sequence.)
Public method | HasSameTarget | (Inherited from Sequence.)
Public method | Import(IotFileSequenceData) | (Inherited from Sequence.)
Public method | Import(RefAcquisitionSequenceData) | (Inherited from Sequence.)
Public method | Import(SequenceDataSource) | (Inherited from Sequence.)
Public method | InsertData | Inserts a list of data at the given index. (Inherited from Sequence.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | LoadData | Trys to load the data from the DataFilePath. (Inherited from Sequence.)
Public method | LoadData(String) | (Inherited from Sequence.)
Public method | MaxEndIndex | Gets the largest possible end index relative to the current end. (Overrides SequenceMaxEndIndex.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MinStartIndex | Gets the smallest possible start index relative to the current start. (Overrides SequenceMinStartIndex.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | NewDataAlyFilePath | (Inherited from Sequence.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ReplaceData | Replaces a part of the data. (Inherited from Sequence.)
Public method | SaveData | Saves the data to the DataFilePath. The data is stored in the aly file format. (Inherited from Sequence.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | (Inherited from Sequence.)
Public method | TrimData | Removes data from the acquisition. (Inherited from Sequence.)
Public method | TrimDataEnd | Removes samples at the end. (Overrides SequenceTrimDataEnd(Int64).)
Public method | TrimDataStart | Removes samples from the start. (Overrides SequenceTrimDataStart(Int64).)
Public method | UpdatePropertyAttributes | (Inherited from Sequence.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | (Inherited from Sequence.)
Top
Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataFilePathChanged | Fired when the DataFilePath is changed. (Inherited from Sequence.)
Public event | DataFilePathValidating | Fired while validating the new value for DataFilePath. (Inherited from Sequence.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DataUpdated | Raised when data is added to Data. (Inherited from Sequence.)
Public event | DefaultValueChanged | Fired when the DefaultValue is changed.
Public event | DefaultValueValidating | Fired while validating the new value for DefaultValue.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | ExportOptionsChanged | Fired when the ExportOptions is changed. (Inherited from Sequence.)
Public event | ExportOptionsValidating | Fired while validating the new value for ExportOptions. (Inherited from Sequence.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SampleCountChanged | Fired when the SampleCount is changed. (Inherited from Sequence.)
Public event | SampleCountValidating | Fired while validating the new value for SampleCount. (Inherited from Sequence.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


CustomSequence Constructor

Overload List
 | Name | Description
Public method | CustomSequence | Creates a new empty CustomSequence
Public method | CustomSequence(CustomSequence) | Initialize Properties with values copied from other Acquisition
Public method | CustomSequence(Double, Int32) | Creates a new CustomSequence that adds a default value.
Top
See Also

Reference

CustomSequence Class


CustomSequence Constructor

Creates a new empty CustomSequence

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public CustomSequence()
Public Sub New
public:
CustomSequence()
See Also

Reference

CustomSequence Class
CustomSequence Overload


CustomSequence Constructor (CustomSequence)

Initialize Properties with values copied from other Acquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public CustomSequence(
    CustomSequence acquisition
)
Public Sub New (
    acquisition As CustomSequence
)
public:
CustomSequence(
    CustomSequence^ acquisition
)

Parameters

acquisition
Type: TwinCAT.Measurement.Scope.API.ModelCustomSequence
Acquisition to copy from
See Also

Reference

CustomSequence Class
CustomSequence Overload


CustomSequence Constructor (Double, Int32)

Creates a new CustomSequence that adds a default value.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public CustomSequence(
    double defaultValue,
    int initSamples
)
Public Sub New (
    defaultValue As Double,
    initSamples As Integer
)
public:
CustomSequence(
    double defaultValue,
    int initSamples
)

Parameters

defaultValue
Type: SystemDouble
The value to add.
initSamples
Type: SystemInt32
The number of samples which are added.
See Also

Reference

CustomSequence Class
CustomSequence Overload


CustomSequence Properties

The CustomSequence type exposes the following members.

Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | (Overrides AcquisitionCompressionMode.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | Data | Gets the Data of this acquisition. (Inherited from Sequence.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataFilePath | Gets or Sets the DataFilePath. (Inherited from Sequence.)
Public property | DataPoints |
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | (Inherited from Sequence.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | ExportOptions | Gets or Sets the ExportOptions. (Inherited from Sequence.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleCount | Gets or Sets the SampleCount. (Inherited from Sequence.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | (Overrides AcquisitionSaveOption.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

CustomSequence Class


CustomSequence.CompressionMode Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
public override CompressionMode CompressionMode { get; set; }
<XmlIgnoreAttribute>
Public Overrides Property CompressionMode As CompressionMode
    Get
    Set
public:
[XmlIgnoreAttribute]
virtual property CompressionMode CompressionMode {
    CompressionMode get () override;
    void set (CompressionMode value) override;
}

Property Value

Type: CompressionMode
See Also

Reference

CustomSequence Class


CustomSequence.DataPoints Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[EditorBrowsableAttribute(EditorBrowsableState.Always)]
[EditorAttribute(typeof(MultilineStringEditor), typeof(UITypeEditor))]
public string DataPoints { get; set; }
<XmlIgnoreAttribute>
<EditorBrowsableAttribute(EditorBrowsableState.Always)>
<EditorAttribute(GetType(MultilineStringEditor), GetType(UITypeEditor))>
Public Property DataPoints As String
    Get
    Set
public:
[XmlIgnoreAttribute]
[EditorBrowsableAttribute(EditorBrowsableState::Always)]
[EditorAttribute(typeof(MultilineStringEditor), typeof(UITypeEditor))]
property String^ DataPoints {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CustomSequence Class


CustomSequence.SaveOption Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
public override SaveOption SaveOption { get; set; }
<XmlIgnoreAttribute>
Public Overrides Property SaveOption As SaveOption
    Get
    Set
public:
[XmlIgnoreAttribute]
virtual property SaveOption SaveOption {
    SaveOption get () override;
    void set (SaveOption value) override;
}

Property Value

Type: SaveOption
See Also

Reference

CustomSequence Class


CustomSequence Methods

The CustomSequence type exposes the following members.

Methods
 | Name | Description
Public method | AddData | Adds a list of samples to the end. (Inherited from Sequence.)
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CopyData | (Inherited from Sequence.)
Public method | DeleteDataFiles | Deletes the data file(s) at the DataFilePath. (Inherited from Sequence.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportToAlyFile | (Inherited from Sequence.)
Public method | ExtendDataEnd | Adds samples to the end. (Overrides SequenceExtendDataEnd(Int64).)
Public method | ExtendDataStart | Adds samples at the start. (Overrides SequenceExtendDataStart(Int64).)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllFileInfos | Get all files which are used in this sequence (Inherited from Sequence.)
Public method | GetAllFilePathes | Get all files which are used in this sequence (Inherited from Sequence.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAlyFilePath | (Inherited from Sequence.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | (Inherited from Sequence.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Inherited from Acquisition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Acquisition.)
Public method | GetIotType | (Inherited from Sequence.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTasPath | (Inherited from Sequence.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Get the data from the timestamp First Value = Timestamp == 0 (Inherited from Sequence.)
Public method | GetValueConverter | (Inherited from Sequence.)
Public method | HasSameTarget | (Inherited from Sequence.)
Public method | Import(IotFileSequenceData) | (Inherited from Sequence.)
Public method | Import(RefAcquisitionSequenceData) | (Inherited from Sequence.)
Public method | Import(SequenceDataSource) | (Inherited from Sequence.)
Public method | InsertData | Inserts a list of data at the given index. (Inherited from Sequence.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | LoadData | Trys to load the data from the DataFilePath. (Inherited from Sequence.)
Public method | LoadData(String) | (Inherited from Sequence.)
Public method | MaxEndIndex | Gets the largest possible end index relative to the current end. (Overrides SequenceMaxEndIndex.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MinStartIndex | Gets the smallest possible start index relative to the current start. (Overrides SequenceMinStartIndex.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | NewDataAlyFilePath | (Inherited from Sequence.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ReplaceData | Replaces a part of the data. (Inherited from Sequence.)
Public method | SaveData | Saves the data to the DataFilePath. The data is stored in the aly file format. (Inherited from Sequence.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | (Inherited from Sequence.)
Public method | TrimData | Removes data from the acquisition. (Inherited from Sequence.)
Public method | TrimDataEnd | Removes samples at the end. (Overrides SequenceTrimDataEnd(Int64).)
Public method | TrimDataStart | Removes samples from the start. (Overrides SequenceTrimDataStart(Int64).)
Public method | UpdatePropertyAttributes | (Inherited from Sequence.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | (Inherited from Sequence.)
Top
See Also

Reference

CustomSequence Class


CustomSequence.ExtendDataEnd Method

Adds samples to the end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void ExtendDataEnd(
    long numSamples
)
Public Overrides Sub ExtendDataEnd (
    numSamples As Long
)
public:
virtual void ExtendDataEnd(
    long long numSamples
) override

Parameters

numSamples
Type: SystemInt64
The number of samples to add.
See Also

Reference

CustomSequence Class


CustomSequence.ExtendDataStart Method

Adds samples at the start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void ExtendDataStart(
    long numSamples
)
Public Overrides Sub ExtendDataStart (
    numSamples As Long
)
public:
virtual void ExtendDataStart(
    long long numSamples
) override

Parameters

numSamples
Type: SystemInt64
The number of samples to add.
See Also

Reference

CustomSequence Class


CustomSequence.MaxEndIndex Method

Gets the largest possible end index relative to the current end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override double MaxEndIndex()
Public Overrides Function MaxEndIndex As Double
public:
virtual double MaxEndIndex() override

Return Value

Type: Double
See Also

Reference

CustomSequence Class


CustomSequence.MinStartIndex Method

Gets the smallest possible start index relative to the current start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override double MinStartIndex()
Public Overrides Function MinStartIndex As Double
public:
virtual double MinStartIndex() override

Return Value

Type: Double
See Also

Reference

CustomSequence Class


CustomSequence.TrimDataEnd Method

Removes samples at the end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void TrimDataEnd(
    long numSamples
)
Public Overrides Sub TrimDataEnd (
    numSamples As Long
)
public:
virtual void TrimDataEnd(
    long long numSamples
) override

Parameters

numSamples
Type: SystemInt64
The number of samples to remove.
See Also

Reference

CustomSequence Class


CustomSequence.TrimDataStart Method

Removes samples from the start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void TrimDataStart(
    long numSamples
)
Public Overrides Sub TrimDataStart (
    numSamples As Long
)
public:
virtual void TrimDataStart(
    long long numSamples
) override

Parameters

numSamples
Type: SystemInt64
The number of samples to remove.
See Also

Reference

CustomSequence Class


CustomSequence Events

The CustomSequence type exposes the following members.

Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataFilePathChanged | Fired when the DataFilePath is changed. (Inherited from Sequence.)
Public event | DataFilePathValidating | Fired while validating the new value for DataFilePath. (Inherited from Sequence.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DataUpdated | Raised when data is added to Data. (Inherited from Sequence.)
Public event | DefaultValueChanged | Fired when the DefaultValue is changed.
Public event | DefaultValueValidating | Fired while validating the new value for DefaultValue.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | ExportOptionsChanged | Fired when the ExportOptions is changed. (Inherited from Sequence.)
Public event | ExportOptionsValidating | Fired while validating the new value for ExportOptions. (Inherited from Sequence.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SampleCountChanged | Fired when the SampleCount is changed. (Inherited from Sequence.)
Public event | SampleCountValidating | Fired while validating the new value for SampleCount. (Inherited from Sequence.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

CustomSequence Class


CustomSequence.DefaultValueChanged Event

Fired when the DefaultValue is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DefaultValueChanged
Public Event DefaultValueChanged As EventHandler
public:
 event EventHandler^ DefaultValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

CustomSequence Class


CustomSequence.DefaultValueValidating Event

Fired while validating the new value for DefaultValue.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DefaultValueValidating
Public Event DefaultValueValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DefaultValueValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

CustomSequence Class


CustomSequence Fields

The CustomSequence type exposes the following members.

Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

CustomSequence Class


DataPool Class

Datapool Class for Scope Projects
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelDataPool

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class DataPool : ScopeMemberContainerBase
Public Class DataPool
    Inherits ScopeMemberContainerBase
public ref class DataPool : public ScopeMemberContainerBase

The DataPool type exposes the following members.

Constructors
 | Name | Description
Public method | DataPool | Create a new DataPool
Public method | DataPool(DataPool) | Create a new DataPool by copying Properties from another DataPool
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AcquisitionByGuid |
Public method | AcquisitionWithSameTarget |
Public method | AddIotFileSequence |
Public method | AddMember | Adds a Member to SubMemberList (Overrides MeasurementMemberContainerBaseAddMember(MeasurementMemberBase).)
Public method | AddMemberRange | Adds a Range of Member to the List (Overrides MeasurementMemberContainerBaseAddMemberRange(MeasurementMemberBase).)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether this instance and a specified object, which must also be a DataPool object, have the same value. (Overrides ObjectEquals(Object).)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FindAcquistionWithSameTarget |
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Removes a Member from the SubMemberCollection (Overrides MeasurementMemberContainerBaseRemoveMember(MeasurementMemberBase).)
Public method | RemoveMemberRange | Removes an Range of Member from the SubMemberCollection (Overrides MeasurementMemberContainerBaseRemoveMemberRange(MeasurementMemberBase).)
Public method | RemoveUnusedAcquisitions |
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


DataPool Constructor

Overload List
 | Name | Description
Public method | DataPool | Create a new DataPool
Public method | DataPool(DataPool) | Create a new DataPool by copying Properties from another DataPool
Top
See Also

Reference

DataPool Class


DataPool Constructor

Create a new DataPool

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DataPool()
Public Sub New
public:
DataPool()
See Also

Reference

DataPool Class
DataPool Overload


DataPool Constructor (DataPool)

Create a new DataPool by copying Properties from another DataPool

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DataPool(
    DataPool dp
)
Public Sub New (
    dp As DataPool
)
public:
DataPool(
    DataPool^ dp
)

Parameters

dp
Type: TwinCAT.Measurement.Scope.API.ModelDataPool
DataPool to copy from
See Also

Reference

DataPool Class
DataPool Overload


DataPool Properties

The DataPool type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DataPool Class


DataPool Methods

The DataPool type exposes the following members.

Methods
 | Name | Description
Public method | AcquisitionByGuid |
Public method | AcquisitionWithSameTarget |
Public method | AddIotFileSequence |
Public method | AddMember | Adds a Member to SubMemberList (Overrides MeasurementMemberContainerBaseAddMember(MeasurementMemberBase).)
Public method | AddMemberRange | Adds a Range of Member to the List (Overrides MeasurementMemberContainerBaseAddMemberRange(MeasurementMemberBase).)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether this instance and a specified object, which must also be a DataPool object, have the same value. (Overrides ObjectEquals(Object).)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FindAcquistionWithSameTarget |
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Removes a Member from the SubMemberCollection (Overrides MeasurementMemberContainerBaseRemoveMember(MeasurementMemberBase).)
Public method | RemoveMemberRange | Removes an Range of Member from the SubMemberCollection (Overrides MeasurementMemberContainerBaseRemoveMemberRange(MeasurementMemberBase).)
Public method | RemoveUnusedAcquisitions |
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DataPool Class


DataPool.AcquisitionByGuid Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Acquisition AcquisitionByGuid(
    Guid guid
)
Public Function AcquisitionByGuid (
    guid As Guid
) As Acquisition
public:
Acquisition^ AcquisitionByGuid(
    Guid guid
)

Parameters

guid
Type: SystemGuid

Return Value

Type: Acquisition
See Also

Reference

DataPool Class


DataPool.AcquisitionWithSameTarget Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Acquisition AcquisitionWithSameTarget(
    Acquisition compareAcquisition
)
Public Function AcquisitionWithSameTarget (
    compareAcquisition As Acquisition
) As Acquisition
public:
Acquisition^ AcquisitionWithSameTarget(
    Acquisition^ compareAcquisition
)

Parameters

compareAcquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition

Return Value

Type: Acquisition
See Also

Reference

DataPool Class


DataPool.AddIotFileSequence Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public List<IotFileSequence> AddIotFileSequence(
    string path,
    List<string> channelNames,
    long startTime = -1,
    long endTime = -1
)
Public Function AddIotFileSequence (
    path As String,
    channelNames As List(Of String),
    Optional startTime As Long = -1,
    Optional endTime As Long = -1
) As List(Of IotFileSequence)
public:
List<IotFileSequence^>^ AddIotFileSequence(
    String^ path,
    List<String^>^ channelNames,
    long long startTime = -1,
    long long endTime = -1
)

Parameters

path
Type: SystemString
channelNames
Type: System.Collections.GenericList String
startTime (Optional)
Type: SystemInt64
endTime (Optional)
Type: SystemInt64

Return Value

Type: List IotFileSequence
See Also

Reference

DataPool Class


DataPool.AddMember Method

Adds a Member to SubMemberList

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void AddMember(
    MeasurementMemberBase add
)
Public Overrides Sub AddMember (
    add As MeasurementMemberBase
)
public:
virtual void AddMember(
    MeasurementMemberBase^ add
) override

Parameters

add
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
Member to add
See Also

Reference

DataPool Class


DataPool.AddMemberRange Method

Adds a Range of Member to the List

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void AddMemberRange(
    MeasurementMemberBase[] add
)
Public Overrides Sub AddMemberRange (
    add As MeasurementMemberBase()
)
public:
virtual void AddMemberRange(
    array<MeasurementMemberBase^>^ add
) override

Parameters

add
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
Range to add
See Also

Reference

DataPool Class


DataPool.Equals Method

Determines whether this instance and a specified object, which must also be a DataPool object, have the same value.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The DataPool to compare to this instance

Return Value

Type: Boolean
true if obj is a DataPool and its value is the same as this instance; otherwise, false
See Also

Reference

DataPool Class


DataPool.FindAcquistionWithSameTarget Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool FindAcquistionWithSameTarget(
    Acquisition compareAcquistion,
    out Acquisition acquisition
)
Public Function FindAcquistionWithSameTarget (
    compareAcquistion As Acquisition,
    <OutAttribute> ByRef acquisition As Acquisition
) As Boolean
public:
bool FindAcquistionWithSameTarget(
    Acquisition^ compareAcquistion,
    [OutAttribute] Acquisition^% acquisition
)

Parameters

compareAcquistion
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition

Return Value

Type: Boolean
See Also

Reference

DataPool Class


DataPool.GetCommands Method

Gets a List of possible Commands

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
The List of Commands
See Also

Reference

DataPool Class


DataPool.GetHashCode Method

Serves as a hash function for a particular type.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

DataPool Class


DataPool.RemoveMember Method

Removes a Member from the SubMemberCollection

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void RemoveMember(
    MeasurementMemberBase rem
)
Public Overrides Sub RemoveMember (
    rem As MeasurementMemberBase
)
public:
virtual void RemoveMember(
    MeasurementMemberBase^ rem
) override

Parameters

rem
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
Member to remove
See Also

Reference

DataPool Class


DataPool.RemoveMemberRange Method

Removes an Range of Member from the SubMemberCollection

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void RemoveMemberRange(
    MeasurementMemberBase[] rem
)
Public Overrides Sub RemoveMemberRange (
    rem As MeasurementMemberBase()
)
public:
virtual void RemoveMemberRange(
    array<MeasurementMemberBase^>^ rem
) override

Parameters

rem
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
See Also

Reference

DataPool Class


DataPool.RemoveUnusedAcquisitions Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void RemoveUnusedAcquisitions()
Public Sub RemoveUnusedAcquisitions
public:
void RemoveUnusedAcquisitions()
See Also

Reference

DataPool Class


DataPool.UpdatePropertyAttributes Method

Update Attributes of Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

DataPool Class


DataPool Events

The DataPool type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DataPool Class


DbAcquisition Class

Acquisition class to order data from a DataBase
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisition
TwinCAT.Measurement.Scope.API.ModelHistoricalAcquisition
TwinCAT.Measurement.Scope.API.ModelDbAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class DbAcquisition : HistoricalAcquisition
Public Class DbAcquisition
    Inherits HistoricalAcquisition
public ref class DbAcquisition : public HistoricalAcquisition

The DbAcquisition type exposes the following members.

Constructors
 | Name | Description
Public method | DbAcquisition | Create a new Empty DbAcquisition
Public method | DbAcquisition(DbAcquisition) | Create a new DbAcuisition by copy Properties from other DbAcquisition
Top
Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Column | Gets or Sets the Column.
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName. (Overrides AcquisitionDescription.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | ID | Gets or Sets the ID.
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | Records | Gets or Sets the Records. (Overrides HistoricalAcquisitionRecords.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | Select | Gets or Sets the Select.
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | ServerId | Gets or Sets the ServerId.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Table | Gets or Sets the Table.
Public property | TimeColumn | Gets or Sets the TimeColumn.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | TimeRangeId | Gets or Sets the TimeRangeId. (Overrides HistoricalAcquisitionTimeRangeId.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UpdateOtherAcq | If this property is true all other Acquisitions with the same Target get updated without a question. (Inherited from HistoricalAcquisition.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Overrides AcquisitionGetFullName.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AcquisitionGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides HistoricalAcquisitionHasSameTarget(Acquisition).)
Public method | HasSameTargetExceptRecords | Determines wether the two Acquisition will acquire the same Data except the selected Records (Overrides HistoricalAcquisitionHasSameTargetExceptRecords(HistoricalAcquisition).)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateDataAccessTimes | Sets time properties based on the Records. (Overrides HistoricalAcquisitionUpdateDataAccessTimes.)
Public method | UpdatePropertyAttributes | Updates the Attributes of alle Properties (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | ColumnChanged | Fired when the Column is changed.
Public event | ColumnValidating | Fired while validating the new value for Column.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IDChanged | Fired when the ID is changed.
Public event | IDValidating | Fired while validating the new value for ID.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RecordsChanged | Fired when the Records is changed. (Inherited from HistoricalAcquisition.)
Public event | RecordsValidating | Fired while validating the new value for Records. (Inherited from HistoricalAcquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | SelectChanged | Fired when the Select is changed.
Public event | SelectValidating | Fired while validating the new value for Select.
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | ServerIdChanged | Fired when the ServerId is changed.
Public event | ServerIdValidating | Fired while validating the new value for ServerId.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TableChanged | Fired when the Table is changed.
Public event | TableValidating | Fired while validating the new value for Table.
Public event | TimeColumnChanged | Fired when the TimeColumn is changed.
Public event | TimeColumnValidating | Fired while validating the new value for TimeColumn.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TimeRangeIdChanged | Fired when the TimeRangeId is changed. (Inherited from HistoricalAcquisition.)
Public event | TimeRangeIdValidating | Fired while validating the new value for TimeRangeId. (Inherited from HistoricalAcquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateOtherAcqChanged | Fired when the UpdateOtherAcq is changed. (Inherited from HistoricalAcquisition.)
Public event | UpdateOtherAcqValidating | Fired while validating the new value for UpdateOtherAcq. (Inherited from HistoricalAcquisition.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


DbAcquisition Constructor

Overload List
 | Name | Description
Public method | DbAcquisition | Create a new Empty DbAcquisition
Public method | DbAcquisition(DbAcquisition) | Create a new DbAcuisition by copy Properties from other DbAcquisition
Top
See Also

Reference

DbAcquisition Class


DbAcquisition Constructor

Create a new Empty DbAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DbAcquisition()
Public Sub New
public:
DbAcquisition()
See Also

Reference

DbAcquisition Class
DbAcquisition Overload


DbAcquisition Constructor (DbAcquisition)

Create a new DbAcuisition by copy Properties from other DbAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DbAcquisition(
    DbAcquisition dbacq
)
Public Sub New (
    dbacq As DbAcquisition
)
public:
DbAcquisition(
    DbAcquisition^ dbacq
)

Parameters

dbacq
Type: TwinCAT.Measurement.Scope.API.ModelDbAcquisition
DBAcquisition to copy from
See Also

Reference

DbAcquisition Class
DbAcquisition Overload


DbAcquisition Properties

The DbAcquisition type exposes the following members.

Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Column | Gets or Sets the Column.
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName. (Overrides AcquisitionDescription.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | ID | Gets or Sets the ID.
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | Records | Gets or Sets the Records. (Overrides HistoricalAcquisitionRecords.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | Select | Gets or Sets the Select.
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | ServerId | Gets or Sets the ServerId.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Table | Gets or Sets the Table.
Public property | TimeColumn | Gets or Sets the TimeColumn.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | TimeRangeId | Gets or Sets the TimeRangeId. (Overrides HistoricalAcquisitionTimeRangeId.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UpdateOtherAcq | If this property is true all other Acquisitions with the same Target get updated without a question. (Inherited from HistoricalAcquisition.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

DbAcquisition Class


DbAcquisition.Column Property

Gets or Sets the Column.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Column { get; set; }
Public Property Column As String
    Get
    Set
public:
property String^ Column {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DbAcquisition Class


DbAcquisition.Description Property

A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override ChannelDescription Description { get; }
Public Overrides ReadOnly Property Description As ChannelDescription
    Get
public:
virtual property ChannelDescription^ Description {
    ChannelDescription^ get () override;
}

Property Value

Type: ChannelDescription
See Also

Reference

DbAcquisition Class


DbAcquisition.ID Property

Gets or Sets the ID.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public uint ID { get; set; }
Public Property ID As UInteger
    Get
    Set
public:
property unsigned int ID {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

DbAcquisition Class


DbAcquisition.Records Property

Gets or Sets the Records.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override RecordsContainer Records { get; set; }
Public Overrides Property Records As RecordsContainer
    Get
    Set
public:
virtual property RecordsContainer^ Records {
    RecordsContainer^ get () override;
    void set (RecordsContainer^ value) override;
}

Property Value

Type: RecordsContainer
See Also

Reference

DbAcquisition Class


DbAcquisition.Select Property

Gets or Sets the Select.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Select { get; set; }
Public Property Select As String
    Get
    Set
public:
property String^ Select {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DbAcquisition Class


DbAcquisition.ServerId Property

Gets or Sets the ServerId.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string ServerId { get; set; }
Public Property ServerId As String
    Get
    Set
public:
property String^ ServerId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DbAcquisition Class


DbAcquisition.Table Property

Gets or Sets the Table.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Table { get; set; }
Public Property Table As String
    Get
    Set
public:
property String^ Table {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DbAcquisition Class


DbAcquisition.TimeColumn Property

Gets or Sets the TimeColumn.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string TimeColumn { get; set; }
Public Property TimeColumn As String
    Get
    Set
public:
property String^ TimeColumn {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DbAcquisition Class


DbAcquisition.TimeRangeId Property

Gets or Sets the TimeRangeId.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override ulong TimeRangeId { get; set; }
Public Overrides Property TimeRangeId As ULong
    Get
    Set
public:
virtual property unsigned long long TimeRangeId {
    unsigned long long get () override;
    void set (unsigned long long value) override;
}

Property Value

Type: UInt64
See Also

Reference

DbAcquisition Class


DbAcquisition Methods

The DbAcquisition type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Overrides AcquisitionGetFullName.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AcquisitionGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides HistoricalAcquisitionHasSameTarget(Acquisition).)
Public method | HasSameTargetExceptRecords | Determines wether the two Acquisition will acquire the same Data except the selected Records (Overrides HistoricalAcquisitionHasSameTargetExceptRecords(HistoricalAcquisition).)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateDataAccessTimes | Sets time properties based on the Records. (Overrides HistoricalAcquisitionUpdateDataAccessTimes.)
Public method | UpdatePropertyAttributes | Updates the Attributes of alle Properties (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DbAcquisition Class


DbAcquisition.GetFullName Method

Gets the complete identifier of this acqusition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string GetFullName()
Public Overrides Function GetFullName As String
public:
virtual String^ GetFullName() override

Return Value

Type: String
The full name
See Also

Reference

DbAcquisition Class


DbAcquisition.GetHashCode Method

Serves as a hash function for a particular type.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

DbAcquisition Class


DbAcquisition.HasSameTarget Method

Determines wether the two Acquisition will acquire the same Data

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool HasSameTarget(
    Acquisition acquisition
)
Public Overrides Function HasSameTarget (
    acquisition As Acquisition
) As Boolean
public:
virtual bool HasSameTarget(
    Acquisition^ acquisition
) override

Parameters

acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
The Acquisition to compare with

Return Value

Type: Boolean
True if the Acquisitions have the Same Target
See Also

Reference

DbAcquisition Class


DbAcquisition.HasSameTargetExceptRecords Method

Determines wether the two Acquisition will acquire the same Data except the selected Records

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool HasSameTargetExceptRecords(
    HistoricalAcquisition Acquisition
)
Public Overrides Function HasSameTargetExceptRecords (
    Acquisition As HistoricalAcquisition
) As Boolean
public:
virtual bool HasSameTargetExceptRecords(
    HistoricalAcquisition^ Acquisition
) override

Parameters

Acquisition
Type: TwinCAT.Measurement.Scope.API.ModelHistoricalAcquisition
The Acquisition to compare with

Return Value

Type: Boolean
True if the Acquisitions have the Same Target
See Also

Reference

DbAcquisition Class


DbAcquisition.UpdateDataAccessTimes Method

Sets time properties based on the Records.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdateDataAccessTimes()
Public Overrides Sub UpdateDataAccessTimes
public:
virtual void UpdateDataAccessTimes() override
See Also

Reference

DbAcquisition Class


DbAcquisition.UpdatePropertyAttributes Method

Updates the Attributes of alle Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

DbAcquisition Class


DbAcquisition Events

The DbAcquisition type exposes the following members.

Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | ColumnChanged | Fired when the Column is changed.
Public event | ColumnValidating | Fired while validating the new value for Column.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IDChanged | Fired when the ID is changed.
Public event | IDValidating | Fired while validating the new value for ID.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RecordsChanged | Fired when the Records is changed. (Inherited from HistoricalAcquisition.)
Public event | RecordsValidating | Fired while validating the new value for Records. (Inherited from HistoricalAcquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | SelectChanged | Fired when the Select is changed.
Public event | SelectValidating | Fired while validating the new value for Select.
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | ServerIdChanged | Fired when the ServerId is changed.
Public event | ServerIdValidating | Fired while validating the new value for ServerId.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TableChanged | Fired when the Table is changed.
Public event | TableValidating | Fired while validating the new value for Table.
Public event | TimeColumnChanged | Fired when the TimeColumn is changed.
Public event | TimeColumnValidating | Fired while validating the new value for TimeColumn.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TimeRangeIdChanged | Fired when the TimeRangeId is changed. (Inherited from HistoricalAcquisition.)
Public event | TimeRangeIdValidating | Fired while validating the new value for TimeRangeId. (Inherited from HistoricalAcquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateOtherAcqChanged | Fired when the UpdateOtherAcq is changed. (Inherited from HistoricalAcquisition.)
Public event | UpdateOtherAcqValidating | Fired while validating the new value for UpdateOtherAcq. (Inherited from HistoricalAcquisition.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

DbAcquisition Class


DbAcquisition.ColumnChanged Event

Fired when the Column is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ColumnChanged
Public Event ColumnChanged As EventHandler
public:
 event EventHandler^ ColumnChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DbAcquisition Class


DbAcquisition.ColumnValidating Event

Fired while validating the new value for Column.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ColumnValidating
Public Event ColumnValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ColumnValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DbAcquisition Class


DbAcquisition.IDChanged Event

Fired when the ID is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IDChanged
Public Event IDChanged As EventHandler
public:
 event EventHandler^ IDChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DbAcquisition Class


DbAcquisition.IDValidating Event

Fired while validating the new value for ID.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IDValidating
Public Event IDValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IDValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DbAcquisition Class


DbAcquisition.SelectChanged Event

Fired when the Select is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SelectChanged
Public Event SelectChanged As EventHandler
public:
 event EventHandler^ SelectChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DbAcquisition Class


DbAcquisition.SelectValidating Event

Fired while validating the new value for Select.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SelectValidating
Public Event SelectValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SelectValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DbAcquisition Class


DbAcquisition.ServerIdChanged Event

Fired when the ServerId is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ServerIdChanged
Public Event ServerIdChanged As EventHandler
public:
 event EventHandler^ ServerIdChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DbAcquisition Class


DbAcquisition.ServerIdValidating Event

Fired while validating the new value for ServerId.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ServerIdValidating
Public Event ServerIdValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ServerIdValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DbAcquisition Class


DbAcquisition.TableChanged Event

Fired when the Table is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TableChanged
Public Event TableChanged As EventHandler
public:
 event EventHandler^ TableChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DbAcquisition Class


DbAcquisition.TableValidating Event

Fired while validating the new value for Table.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TableValidating
Public Event TableValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TableValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DbAcquisition Class


DbAcquisition.TimeColumnChanged Event

Fired when the TimeColumn is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TimeColumnChanged
Public Event TimeColumnChanged As EventHandler
public:
 event EventHandler^ TimeColumnChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DbAcquisition Class


DbAcquisition.TimeColumnValidating Event

Fired while validating the new value for TimeColumn.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TimeColumnValidating
Public Event TimeColumnValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TimeColumnValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DbAcquisition Class


DbAcquisition Fields

The DbAcquisition type exposes the following members.

Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

DbAcquisition Class


DigitalChart Class

Scope Digital-Chart class
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAnchorTimeBase
TwinCAT.Measurement.Scope.API.ModelChart
TwinCAT.Measurement.Scope.API.ModelConnectableChart
TwinCAT.Measurement.Scope.API.ModelSingleValuesChart
TwinCAT.Measurement.Scope.API.ModelDigitalChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class DigitalChart : SingleValuesChart
Public Class DigitalChart
    Inherits SingleValuesChart
public ref class DigitalChart : public SingleValuesChart

The DigitalChart type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalChart | Create a new empty Digital-Chart
Public method | DigitalChart(DigitalChart) | Create a new Chart by copying Values from old Chart
Top
Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Inherited from SingleValuesChart.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Inherited from Chart.)
Public property | ChartType | (Overrides ChartChartType.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | PreferredSendTime | Gets or Sets the PreferredSendTime. (Inherited from SingleValuesChart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartDisplayWithoutOverview | (Inherited from SingleValuesChart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Chart.)
Public method | Validate | Validate the Configuration (Overrides ChartValidate.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | PreferredSendTimeChanged | Fired when the PreferredSendTime is changed. (Inherited from SingleValuesChart.)
Public event | PreferredSendTimeValidating | Fired while validating the new value for PreferredSendTime. (Inherited from SingleValuesChart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


DigitalChart Constructor

Overload List
 | Name | Description
Public method | DigitalChart | Create a new empty Digital-Chart
Public method | DigitalChart(DigitalChart) | Create a new Chart by copying Values from old Chart
Top
See Also

Reference

DigitalChart Class


DigitalChart Constructor

Create a new empty Digital-Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DigitalChart()
Public Sub New
public:
DigitalChart()
See Also

Reference

DigitalChart Class
DigitalChart Overload


DigitalChart Constructor (DigitalChart)

Create a new Chart by copying Values from old Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DigitalChart(
    DigitalChart Chart
)
Public Sub New (
    Chart As DigitalChart
)
public:
DigitalChart(
    DigitalChart^ Chart
)

Parameters

Chart
Type: TwinCAT.Measurement.Scope.API.ModelDigitalChart
Old chart to Copy From
See Also

Reference

DigitalChart Class
DigitalChart Overload


DigitalChart Properties

The DigitalChart type exposes the following members.

Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Inherited from SingleValuesChart.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Inherited from Chart.)
Public property | ChartType | (Overrides ChartChartType.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | PreferredSendTime | Gets or Sets the PreferredSendTime. (Inherited from SingleValuesChart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DigitalChart Class


DigitalChart.ChartType Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public override ChartType ChartType { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ChartType As ChartType
    Get
public:
[BrowsableAttribute(false)]
virtual property ChartType ChartType {
    ChartType get () override;
}

Property Value

Type: ChartType
See Also

Reference

DigitalChart Class


DigitalChart Methods

The DigitalChart type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartDisplayWithoutOverview | (Inherited from SingleValuesChart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Chart.)
Public method | Validate | Validate the Configuration (Overrides ChartValidate.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
See Also

Reference

DigitalChart Class


DigitalChart.Validate Method

Validate the Configuration

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void Validate()
Public Overrides Sub Validate
public:
virtual void Validate() override
See Also

Reference

DigitalChart Class


DigitalChart Events

The DigitalChart type exposes the following members.

Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | PreferredSendTimeChanged | Fired when the PreferredSendTime is changed. (Inherited from SingleValuesChart.)
Public event | PreferredSendTimeValidating | Fired while validating the new value for PreferredSendTime. (Inherited from SingleValuesChart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DigitalChart Class


DigitalChart Fields

The DigitalChart type exposes the following members.

Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

DigitalChart Class


DigitalStyle Class

Style for Digital Channel
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelDigitalStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class DigitalStyle : ScopeMemberBase
Public Class DigitalStyle
    Inherits ScopeMemberBase
public ref class DigitalStyle : public ScopeMemberBase

The DigitalStyle type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalStyle | Create a new DigitalStyle
Public method | DigitalStyle(DigitalStyle) | Create a new DigitalStyle by copying Properties
Top
Properties
 | Name | Description
Public property | BackgroundColor | Gets or Sets the BackgroundColor.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Precision | Gets or Sets the Precision.
Public property | PrefixScaled | Gets or Sets the PrefixScaled.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | ShowMinMax | Gets or Sets the ShowMinMax.
Public property | ShowName | Gets or Sets the ShowName.
Public property | ShowUnit | Gets or Sets the ShowUnit.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseAllPrefixes | Gets or Sets the UseAllPrefixes.
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the attributes of the properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | BackgroundColorChanged | Fired when the BackgroundColor is changed.
Public event | BackgroundColorValidating | Fired while validating the new value for BackgroundColor.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PrecisionChanged | Fired when the Precision is changed.
Public event | PrecisionValidating | Fired while validating the new value for Precision.
Public event | PrefixScaledChanged | Fired when the PrefixScaled is changed.
Public event | PrefixScaledValidating | Fired while validating the new value for PrefixScaled.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowMinMaxChanged | Fired when the ShowMinMax is changed.
Public event | ShowMinMaxValidating | Fired while validating the new value for ShowMinMax.
Public event | ShowNameChanged | Fired when the ShowName is changed.
Public event | ShowNameValidating | Fired while validating the new value for ShowName.
Public event | ShowUnitChanged | Fired when the ShowUnit is changed.
Public event | ShowUnitValidating | Fired while validating the new value for ShowUnit.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseAllPrefixesChanged | Fired when the UseAllPrefixes is changed.
Public event | UseAllPrefixesValidating | Fired while validating the new value for UseAllPrefixes.
Top
Fields
Name | Description
DefaultBackgroundColor | Get or Set the
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


DigitalStyle Constructor

Overload List
 | Name | Description
Public method | DigitalStyle | Create a new DigitalStyle
Public method | DigitalStyle(DigitalStyle) | Create a new DigitalStyle by copying Properties
Top
See Also

Reference

DigitalStyle Class


DigitalStyle Constructor

Create a new DigitalStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DigitalStyle()
Public Sub New
public:
DigitalStyle()
See Also

Reference

DigitalStyle Class
DigitalStyle Overload


DigitalStyle Constructor (DigitalStyle)

Create a new DigitalStyle by copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DigitalStyle(
    DigitalStyle org
)
Public Sub New (
    org As DigitalStyle
)
public:
DigitalStyle(
    DigitalStyle^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelDigitalStyle
DigitalStyle to copy from
See Also

Reference

DigitalStyle Class
DigitalStyle Overload


DigitalStyle Properties

The DigitalStyle type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Gets or Sets the BackgroundColor.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Precision | Gets or Sets the Precision.
Public property | PrefixScaled | Gets or Sets the PrefixScaled.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | ShowMinMax | Gets or Sets the ShowMinMax.
Public property | ShowName | Gets or Sets the ShowName.
Public property | ShowUnit | Gets or Sets the ShowUnit.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseAllPrefixes | Gets or Sets the UseAllPrefixes.
Top
See Also

Reference

DigitalStyle Class


DigitalStyle.BackgroundColor Property

Gets or Sets the BackgroundColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Color BackgroundColor { get; set; }
<BrowsableAttribute(true)>
Public Property BackgroundColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

DigitalStyle Class


DigitalStyle.Precision Property

Gets or Sets the Precision.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int Precision { get; set; }
<BrowsableAttribute(true)>
Public Property Precision As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int Precision {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DigitalStyle Class


DigitalStyle.PrefixScaled Property

Gets or Sets the PrefixScaled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool PrefixScaled { get; set; }
<BrowsableAttribute(true)>
Public Property PrefixScaled As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool PrefixScaled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DigitalStyle Class


DigitalStyle.ShowMinMax Property

Gets or Sets the ShowMinMax.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowMinMax { get; set; }
<BrowsableAttribute(true)>
Public Property ShowMinMax As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowMinMax {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DigitalStyle Class


DigitalStyle.ShowName Property

Gets or Sets the ShowName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowName { get; set; }
<BrowsableAttribute(true)>
Public Property ShowName As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowName {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DigitalStyle Class


DigitalStyle.ShowUnit Property

Gets or Sets the ShowUnit.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowUnit { get; set; }
<BrowsableAttribute(true)>
Public Property ShowUnit As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowUnit {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DigitalStyle Class


DigitalStyle.UseAllPrefixes Property

Gets or Sets the UseAllPrefixes.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool UseAllPrefixes { get; set; }
<BrowsableAttribute(true)>
Public Property UseAllPrefixes As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool UseAllPrefixes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DigitalStyle Class


DigitalStyle Methods

The DigitalStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the attributes of the properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DigitalStyle Class


DigitalStyle.UpdatePropertyAttributes Method

Updates the attributes of the properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

DigitalStyle Class


DigitalStyle Events

The DigitalStyle type exposes the following members.

Events
 | Name | Description
Public event | BackgroundColorChanged | Fired when the BackgroundColor is changed.
Public event | BackgroundColorValidating | Fired while validating the new value for BackgroundColor.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PrecisionChanged | Fired when the Precision is changed.
Public event | PrecisionValidating | Fired while validating the new value for Precision.
Public event | PrefixScaledChanged | Fired when the PrefixScaled is changed.
Public event | PrefixScaledValidating | Fired while validating the new value for PrefixScaled.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowMinMaxChanged | Fired when the ShowMinMax is changed.
Public event | ShowMinMaxValidating | Fired while validating the new value for ShowMinMax.
Public event | ShowNameChanged | Fired when the ShowName is changed.
Public event | ShowNameValidating | Fired while validating the new value for ShowName.
Public event | ShowUnitChanged | Fired when the ShowUnit is changed.
Public event | ShowUnitValidating | Fired while validating the new value for ShowUnit.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseAllPrefixesChanged | Fired when the UseAllPrefixes is changed.
Public event | UseAllPrefixesValidating | Fired while validating the new value for UseAllPrefixes.
Top
See Also

Reference

DigitalStyle Class


DigitalStyle.BackgroundColorChanged Event

Fired when the BackgroundColor is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BackgroundColorChanged
Public Event BackgroundColorChanged As EventHandler
public:
 event EventHandler^ BackgroundColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DigitalStyle Class


DigitalStyle.BackgroundColorValidating Event

Fired while validating the new value for BackgroundColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> BackgroundColorValidating
Public Event BackgroundColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ BackgroundColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DigitalStyle Class


DigitalStyle.PrecisionChanged Event

Fired when the Precision is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PrecisionChanged
Public Event PrecisionChanged As EventHandler
public:
 event EventHandler^ PrecisionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DigitalStyle Class


DigitalStyle.PrecisionValidating Event

Fired while validating the new value for Precision.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PrecisionValidating
Public Event PrecisionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PrecisionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DigitalStyle Class


DigitalStyle.PrefixScaledChanged Event

Fired when the PrefixScaled is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PrefixScaledChanged
Public Event PrefixScaledChanged As EventHandler
public:
 event EventHandler^ PrefixScaledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DigitalStyle Class


DigitalStyle.PrefixScaledValidating Event

Fired while validating the new value for PrefixScaled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PrefixScaledValidating
Public Event PrefixScaledValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PrefixScaledValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DigitalStyle Class


DigitalStyle.ShowMinMaxChanged Event

Fired when the ShowMinMax is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowMinMaxChanged
Public Event ShowMinMaxChanged As EventHandler
public:
 event EventHandler^ ShowMinMaxChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DigitalStyle Class


DigitalStyle.ShowMinMaxValidating Event

Fired while validating the new value for ShowMinMax.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowMinMaxValidating
Public Event ShowMinMaxValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowMinMaxValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DigitalStyle Class


DigitalStyle.ShowNameChanged Event

Fired when the ShowName is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowNameChanged
Public Event ShowNameChanged As EventHandler
public:
 event EventHandler^ ShowNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DigitalStyle Class


DigitalStyle.ShowNameValidating Event

Fired while validating the new value for ShowName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowNameValidating
Public Event ShowNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DigitalStyle Class


DigitalStyle.ShowUnitChanged Event

Fired when the ShowUnit is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowUnitChanged
Public Event ShowUnitChanged As EventHandler
public:
 event EventHandler^ ShowUnitChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DigitalStyle Class


DigitalStyle.ShowUnitValidating Event

Fired while validating the new value for ShowUnit.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowUnitValidating
Public Event ShowUnitValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowUnitValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DigitalStyle Class


DigitalStyle.UseAllPrefixesChanged Event

Fired when the UseAllPrefixes is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UseAllPrefixesChanged
Public Event UseAllPrefixesChanged As EventHandler
public:
 event EventHandler^ UseAllPrefixesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DigitalStyle Class


DigitalStyle.UseAllPrefixesValidating Event

Fired while validating the new value for UseAllPrefixes.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UseAllPrefixesValidating
Public Event UseAllPrefixesValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UseAllPrefixesValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DigitalStyle Class


DigitalStyle Fields

The DigitalStyle type exposes the following members.

Fields
Name | Description
DefaultBackgroundColor | Get or Set the
Top
See Also

Reference

DigitalStyle Class


DigitalStyle.DefaultBackgroundColor Field

Get or Set the

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static Color DefaultBackgroundColor
Public Shared DefaultBackgroundColor As Color
public:
static Color DefaultBackgroundColor

Field Value

Type: Color
See Also

Reference

DigitalStyle Class


DirectoryTriggerSet Class

DirectoryTriggerSet Class in TwinCAT 3 Scope API Model
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelTriggerSet
TwinCAT.Measurement.Scope.API.ModelDirectoryTriggerSet

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class DirectoryTriggerSet : TriggerSet
Public Class DirectoryTriggerSet
    Inherits TriggerSet
public ref class DirectoryTriggerSet : public TriggerSet

The DirectoryTriggerSet type exposes the following members.

Constructors
 | Name | Description
Public method | DirectoryTriggerSet | Creates an instance of DirectoryTriggerSet
Public method | DirectoryTriggerSet(DirectoryTriggerSet) | Creates an instance of DirectoryTriggerSet and copy the property values from dts
Top
Properties
 | Name | Description
Public property | ClientTriggerHandle | Gets or Sets the ClientTriggerHandle. (Inherited from TriggerSet.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from TriggerSet.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GroupHandle | Gets or Sets the GroupHandle. (Inherited from TriggerSet.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IncludeSubdirectories | Gets or Sets the IncludeSubdirectories.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsReleased | Gets or Sets the IsReleased. (Inherited from TriggerSet.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ObservedPath | Gets or Sets the ObservedPath.
Public property | ObservedSystem | Gets or Sets the ObservedSystem.
Public property | ObservedSystemExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseServerFileSystem | Gets or Sets the UseServerFileSystem.
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | BindToGroup | bind this instance to a TriggerGroup
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
 | ConvertTriggerImageTimestamp | Converts an ImageFileName to an FileTime
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides TriggerSetUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ClientTriggerHandleChanged | Fired when the ClientTriggerHandle is changed. (Inherited from TriggerSet.)
Public event | ClientTriggerHandleValidating | Fired while validating the new value for ClientTriggerHandle. (Inherited from TriggerSet.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from TriggerSet.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from TriggerSet.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GroupHandleChanged | Fired when the GroupHandle is changed. (Inherited from TriggerSet.)
Public event | GroupHandleValidating | Fired while validating the new value for GroupHandle. (Inherited from TriggerSet.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IncludeSubdirectoriesChanged | Fired when the IncludeSubdirectories is changed.
Public event | IncludeSubdirectoriesValidating | Fired while validating the new value for IncludeSubdirectories.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsReleasedChanged | Fired when the IsReleased is changed. (Inherited from TriggerSet.)
Public event | IsReleasedValidating | Fired while validating the new value for IsReleased. (Inherited from TriggerSet.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | ObservedPathChanged | Fired when the ObservedPath is changed.
Public event | ObservedPathValidating | Fired while validating the new value for ObservedPath.
Public event | ObservedSystemChanged | Fired when the ObservedSystem is changed.
Public event | ObservedSystemValidating | Fired while validating the new value for ObservedSystem.
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerReleased | TriggerReleased is thrown, if one image was added to the folder.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseServerFileSystemChanged | Fired when the UseServerFileSystem is changed.
Public event | UseServerFileSystemValidating | Fired while validating the new value for UseServerFileSystem.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


DirectoryTriggerSet Constructor

Overload List
 | Name | Description
Public method | DirectoryTriggerSet | Creates an instance of DirectoryTriggerSet
Public method | DirectoryTriggerSet(DirectoryTriggerSet) | Creates an instance of DirectoryTriggerSet and copy the property values from dts
Top
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet Constructor

Creates an instance of DirectoryTriggerSet

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DirectoryTriggerSet()
Public Sub New
public:
DirectoryTriggerSet()
See Also

Reference

DirectoryTriggerSet Class
DirectoryTriggerSet Overload


DirectoryTriggerSet Constructor (DirectoryTriggerSet)

Creates an instance of DirectoryTriggerSet and copy the property values from dts

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DirectoryTriggerSet(
    DirectoryTriggerSet dts
)
Public Sub New (
    dts As DirectoryTriggerSet
)
public:
DirectoryTriggerSet(
    DirectoryTriggerSet^ dts
)

Parameters

dts
Type: TwinCAT.Measurement.Scope.API.ModelDirectoryTriggerSet
See Also

Reference

DirectoryTriggerSet Class
DirectoryTriggerSet Overload


DirectoryTriggerSet Properties

The DirectoryTriggerSet type exposes the following members.

Properties
 | Name | Description
Public property | ClientTriggerHandle | Gets or Sets the ClientTriggerHandle. (Inherited from TriggerSet.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from TriggerSet.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GroupHandle | Gets or Sets the GroupHandle. (Inherited from TriggerSet.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IncludeSubdirectories | Gets or Sets the IncludeSubdirectories.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsReleased | Gets or Sets the IsReleased. (Inherited from TriggerSet.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ObservedPath | Gets or Sets the ObservedPath.
Public property | ObservedSystem | Gets or Sets the ObservedSystem.
Public property | ObservedSystemExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseServerFileSystem | Gets or Sets the UseServerFileSystem.
Top
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.IncludeSubdirectories Property

Gets or Sets the IncludeSubdirectories.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool IncludeSubdirectories { get; set; }
<BrowsableAttribute(true)>
Public Property IncludeSubdirectories As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool IncludeSubdirectories {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.ObservedPath Property

Gets or Sets the ObservedPath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string ObservedPath { get; set; }
<BrowsableAttribute(true)>
Public Property ObservedPath As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ ObservedPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.ObservedSystem Property

Gets or Sets the ObservedSystem.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public AmsNetId ObservedSystem { get; set; }
<BrowsableAttribute(true)>
Public Property ObservedSystem As AmsNetId
    Get
    Set
public:
[BrowsableAttribute(true)]
property AmsNetId^ ObservedSystem {
    AmsNetId^ get ();
    void set (AmsNetId^ value);
}

Property Value

Type: AmsNetId
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.ObservedSystemExchange Property

Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public string ObservedSystemExchange { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property ObservedSystemExchange As String
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property String^ ObservedSystemExchange {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.UseServerFileSystem Property

Gets or Sets the UseServerFileSystem.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool UseServerFileSystem { get; set; }
<BrowsableAttribute(true)>
Public Property UseServerFileSystem As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool UseServerFileSystem {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet Methods

The DirectoryTriggerSet type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | BindToGroup | bind this instance to a TriggerGroup
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
 | ConvertTriggerImageTimestamp | Converts an ImageFileName to an FileTime
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides TriggerSetUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.BindToGroup Method

bind this instance to a TriggerGroup

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void BindToGroup(
    IClientTriggerGroup TriggerGroup,
    bool reattach = false
)
Public Sub BindToGroup (
    TriggerGroup As IClientTriggerGroup,
    Optional reattach As Boolean = false
)
public:
void BindToGroup(
    IClientTriggerGroup^ TriggerGroup,
    bool reattach = false
)

Parameters

TriggerGroup
Type: IClientTriggerGroup
TriggerGroup to attach to
reattach (Optional)
Type: SystemBoolean
Determines wether the TriggerSet should be reattached to an active client
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.ConvertTriggerImageTimestamp Method

Converts an ImageFileName to an FileTime

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static long? ConvertTriggerImageTimestamp(
    string imageName
)
Public Shared Function ConvertTriggerImageTimestamp (
    imageName As String
) As Long?
public:
static Nullable<long long> ConvertTriggerImageTimestamp(
    String^ imageName
)

Parameters

imageName
Type: SystemString

Return Value

Type: Nullable Int64
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.UpdatePropertyAttributes Method

Sets the value off Propertyattributes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet Events

The DirectoryTriggerSet type exposes the following members.

Events
 | Name | Description
Public event | ClientTriggerHandleChanged | Fired when the ClientTriggerHandle is changed. (Inherited from TriggerSet.)
Public event | ClientTriggerHandleValidating | Fired while validating the new value for ClientTriggerHandle. (Inherited from TriggerSet.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from TriggerSet.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from TriggerSet.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GroupHandleChanged | Fired when the GroupHandle is changed. (Inherited from TriggerSet.)
Public event | GroupHandleValidating | Fired while validating the new value for GroupHandle. (Inherited from TriggerSet.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IncludeSubdirectoriesChanged | Fired when the IncludeSubdirectories is changed.
Public event | IncludeSubdirectoriesValidating | Fired while validating the new value for IncludeSubdirectories.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsReleasedChanged | Fired when the IsReleased is changed. (Inherited from TriggerSet.)
Public event | IsReleasedValidating | Fired while validating the new value for IsReleased. (Inherited from TriggerSet.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | ObservedPathChanged | Fired when the ObservedPath is changed.
Public event | ObservedPathValidating | Fired while validating the new value for ObservedPath.
Public event | ObservedSystemChanged | Fired when the ObservedSystem is changed.
Public event | ObservedSystemValidating | Fired while validating the new value for ObservedSystem.
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerReleased | TriggerReleased is thrown, if one image was added to the folder.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseServerFileSystemChanged | Fired when the UseServerFileSystem is changed.
Public event | UseServerFileSystemValidating | Fired while validating the new value for UseServerFileSystem.
Top
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.IncludeSubdirectoriesChanged Event

Fired when the IncludeSubdirectories is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IncludeSubdirectoriesChanged
Public Event IncludeSubdirectoriesChanged As EventHandler
public:
 event EventHandler^ IncludeSubdirectoriesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.IncludeSubdirectoriesValidating Event

Fired while validating the new value for IncludeSubdirectories.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IncludeSubdirectoriesValidating
Public Event IncludeSubdirectoriesValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IncludeSubdirectoriesValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.ObservedPathChanged Event

Fired when the ObservedPath is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ObservedPathChanged
Public Event ObservedPathChanged As EventHandler
public:
 event EventHandler^ ObservedPathChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.ObservedPathValidating Event

Fired while validating the new value for ObservedPath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ObservedPathValidating
Public Event ObservedPathValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ObservedPathValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.ObservedSystemChanged Event

Fired when the ObservedSystem is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ObservedSystemChanged
Public Event ObservedSystemChanged As EventHandler
public:
 event EventHandler^ ObservedSystemChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.ObservedSystemValidating Event

Fired while validating the new value for ObservedSystem.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ObservedSystemValidating
Public Event ObservedSystemValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ObservedSystemValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.TriggerReleased Event

TriggerReleased is thrown, if one image was added to the folder.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ImageTriggerReleaseArgs> TriggerReleased
Public Event TriggerReleased As EventHandler(Of ImageTriggerReleaseArgs)
public:
 event EventHandler<ImageTriggerReleaseArgs^>^ TriggerReleased {
    void add (EventHandler<ImageTriggerReleaseArgs^>^ value);
    void remove (EventHandler<ImageTriggerReleaseArgs^>^ value);
}

Value

Type: SystemEventHandler ImageTriggerReleaseArgs
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.UseServerFileSystemChanged Event

Fired when the UseServerFileSystem is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UseServerFileSystemChanged
Public Event UseServerFileSystemChanged As EventHandler
public:
 event EventHandler^ UseServerFileSystemChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DirectoryTriggerSet Class


DirectoryTriggerSet.UseServerFileSystemValidating Event

Fired while validating the new value for UseServerFileSystem.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UseServerFileSystemValidating
Public Event UseServerFileSystemValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UseServerFileSystemValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DirectoryTriggerSet Class


DoubleInputFunction Class

Base class for Function with 2 Conditions
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.API.ModelFunction
TwinCAT.Measurement.Scope.API.ModelDoubleInputFunction
TwinCAT.Measurement.Scope.API.ModelOrFunction
TwinCAT.Measurement.Scope.API.ModelXORFunction

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class DoubleInputFunction : Function
Public MustInherit Class DoubleInputFunction
    Inherits Function
public ref class DoubleInputFunction abstract : public Function

The DoubleInputFunction type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleInputFunction | Create a new Double Input Function
Top
Properties
 | Name | Description
Public property | Value | The result of the Function (Inherited from Function.)
Top
Methods
 | Name | Description
Public method | Contains | Test if the Function contains the ICodition (Overrides FunctionContains(ICondition).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


DoubleInputFunction Constructor

Create a new Double Input Function

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DoubleInputFunction(
    ICondition Input1,
    ICondition Input2
)
Public Sub New (
    Input1 As ICondition,
    Input2 As ICondition
)
public:
DoubleInputFunction(
    ICondition^ Input1,
    ICondition^ Input2
)

Parameters

Input1
Type: TwinCAT.Measurement.Scope.API.ModelICondition
First Input Condition
Input2
Type: TwinCAT.Measurement.Scope.API.ModelICondition
Second Input Condition
See Also

Reference

DoubleInputFunction Class


DoubleInputFunction Properties

The DoubleInputFunction type exposes the following members.

Properties
 | Name | Description
Public property | Value | The result of the Function (Inherited from Function.)
Top
See Also

Reference

DoubleInputFunction Class


DoubleInputFunction Methods

The DoubleInputFunction type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Test if the Function contains the ICodition (Overrides FunctionContains(ICondition).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleInputFunction Class


DoubleInputFunction.Contains Method

Test if the Function contains the ICodition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool Contains(
    ICondition Input
)
Public Overrides Function Contains (
    Input As ICondition
) As Boolean
public:
virtual bool Contains(
    ICondition^ Input
) override

Parameters

Input
Type: TwinCAT.Measurement.Scope.API.ModelICondition

Return Value

Type: Boolean
See Also

Reference

DoubleInputFunction Class


DynamicStyle Class

Class defining a Dynamic Style
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelDynamicStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class DynamicStyle : ScopeMemberContainerBase
Public Class DynamicStyle
    Inherits ScopeMemberContainerBase
public ref class DynamicStyle : public ScopeMemberContainerBase

The DynamicStyle type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicStyle | Create a new DynamicStyle
Public method | DynamicStyle(DynamicStyle) | Create a new DynamicStyle by copying Properties
Top
Properties
 | Name | Description
Public property | ApplyTo | Gets or Sets the ApplyTo.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Linestate | Gets or Sets the Linestate.
Public property | LinkOptions | Gets or Sets the LinkOptions.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a list of Possible Commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ApplyToChanged | Fired when the ApplyTo is changed.
Public event | ApplyToValidating | Fired while validating the new value for ApplyTo.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LinestateChanged | Fired when the Linestate is changed.
Public event | LinestateValidating | Fired while validating the new value for Linestate.
Public event | LinkOptionsChanged | Fired when the LinkOptions is changed.
Public event | LinkOptionsValidating | Fired while validating the new value for LinkOptions.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshDisplay | Fired to Refresh the Chart
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


DynamicStyle Constructor

Overload List
 | Name | Description
Public method | DynamicStyle | Create a new DynamicStyle
Public method | DynamicStyle(DynamicStyle) | Create a new DynamicStyle by copying Properties
Top
See Also

Reference

DynamicStyle Class


DynamicStyle Constructor

Create a new DynamicStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DynamicStyle()
Public Sub New
public:
DynamicStyle()
See Also

Reference

DynamicStyle Class
DynamicStyle Overload


DynamicStyle Constructor (DynamicStyle)

Create a new DynamicStyle by copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DynamicStyle(
    DynamicStyle org
)
Public Sub New (
    org As DynamicStyle
)
public:
DynamicStyle(
    DynamicStyle^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelDynamicStyle
DynamicStyle to copy from
See Also

Reference

DynamicStyle Class
DynamicStyle Overload


DynamicStyle Properties

The DynamicStyle type exposes the following members.

Properties
 | Name | Description
Public property | ApplyTo | Gets or Sets the ApplyTo.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Linestate | Gets or Sets the Linestate.
Public property | LinkOptions | Gets or Sets the LinkOptions.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DynamicStyle Class


DynamicStyle.ApplyTo Property

Gets or Sets the ApplyTo.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Linestate ApplyTo { get; set; }
<BrowsableAttribute(true)>
Public Property ApplyTo As Linestate
    Get
    Set
public:
[BrowsableAttribute(true)]
property Linestate ApplyTo {
    Linestate get ();
    void set (Linestate value);
}

Property Value

Type: Linestate
See Also

Reference

DynamicStyle Class


DynamicStyle.Enabled Property

Gets or Sets the Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Enabled { get; set; }
<BrowsableAttribute(true)>
Public Property Enabled As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DynamicStyle Class


DynamicStyle.Linestate Property

Gets or Sets the Linestate.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Linestate Linestate { get; set; }
<BrowsableAttribute(true)>
Public Property Linestate As Linestate
    Get
    Set
public:
[BrowsableAttribute(true)]
property Linestate Linestate {
    Linestate get ();
    void set (Linestate value);
}

Property Value

Type: Linestate
See Also

Reference

DynamicStyle Class


DynamicStyle.LinkOptions Property

Gets or Sets the LinkOptions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public ConditionLinkOptions LinkOptions { get; set; }
<BrowsableAttribute(true)>
Public Property LinkOptions As ConditionLinkOptions
    Get
    Set
public:
[BrowsableAttribute(true)]
property ConditionLinkOptions LinkOptions {
    ConditionLinkOptions get ();
    void set (ConditionLinkOptions value);
}

Property Value

Type: ConditionLinkOptions
See Also

Reference

DynamicStyle Class


DynamicStyle Methods

The DynamicStyle type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a list of Possible Commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DynamicStyle Class


DynamicStyle.GetCommands Method

Gets a list of Possible Commands

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
An Array of Commands
See Also

Reference

DynamicStyle Class


DynamicStyle.UpdatePropertyAttributes Method

Update the Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

DynamicStyle Class


DynamicStyle Events

The DynamicStyle type exposes the following members.

Events
 | Name | Description
Public event | ApplyToChanged | Fired when the ApplyTo is changed.
Public event | ApplyToValidating | Fired while validating the new value for ApplyTo.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LinestateChanged | Fired when the Linestate is changed.
Public event | LinestateValidating | Fired while validating the new value for Linestate.
Public event | LinkOptionsChanged | Fired when the LinkOptions is changed.
Public event | LinkOptionsValidating | Fired while validating the new value for LinkOptions.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshDisplay | Fired to Refresh the Chart
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DynamicStyle Class


DynamicStyle.ApplyToChanged Event

Fired when the ApplyTo is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ApplyToChanged
Public Event ApplyToChanged As EventHandler
public:
 event EventHandler^ ApplyToChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DynamicStyle Class


DynamicStyle.ApplyToValidating Event

Fired while validating the new value for ApplyTo.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ApplyToValidating
Public Event ApplyToValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ApplyToValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DynamicStyle Class


DynamicStyle.EnabledChanged Event

Fired when the Enabled is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EnabledChanged
Public Event EnabledChanged As EventHandler
public:
 event EventHandler^ EnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DynamicStyle Class


DynamicStyle.EnabledValidating Event

Fired while validating the new value for Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EnabledValidating
Public Event EnabledValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EnabledValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DynamicStyle Class


DynamicStyle.LinestateChanged Event

Fired when the Linestate is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LinestateChanged
Public Event LinestateChanged As EventHandler
public:
 event EventHandler^ LinestateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DynamicStyle Class


DynamicStyle.LinestateValidating Event

Fired while validating the new value for Linestate.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LinestateValidating
Public Event LinestateValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LinestateValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DynamicStyle Class


DynamicStyle.LinkOptionsChanged Event

Fired when the LinkOptions is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LinkOptionsChanged
Public Event LinkOptionsChanged As EventHandler
public:
 event EventHandler^ LinkOptionsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DynamicStyle Class


DynamicStyle.LinkOptionsValidating Event

Fired while validating the new value for LinkOptions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LinkOptionsValidating
Public Event LinkOptionsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LinkOptionsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

DynamicStyle Class


DynamicStyle.RefreshDisplay Event

Fired to Refresh the Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler RefreshDisplay
Public Event RefreshDisplay As EventHandler
public:
 event EventHandler^ RefreshDisplay {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DynamicStyle Class


DynamicStyleContainer Class

Container for DynamicStyles
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelDynamicStyleContainer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class DynamicStyleContainer : ScopeMemberContainerBase
Public Class DynamicStyleContainer
    Inherits ScopeMemberContainerBase
public ref class DynamicStyleContainer : public ScopeMemberContainerBase

The DynamicStyleContainer type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicStyleContainer | Create a new DynamicStyleContainer
Public method | DynamicStyleContainer(DynamicStyleContainer) | Create a new DynamicStyleContainer by copying Properties
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a list of Possible Commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | ValuesToLineStateIndexPair(ListObject) |
Public method | ValuesToLineStateIndexPair(ChannelFrame) | Converts a List of Values to List Of Linestatearray
Public method | ValueToLineStateIndexPair | Converts a value to a LinestateIndexPair
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


DynamicStyleContainer Constructor

Overload List
 | Name | Description
Public method | DynamicStyleContainer | Create a new DynamicStyleContainer
Public method | DynamicStyleContainer(DynamicStyleContainer) | Create a new DynamicStyleContainer by copying Properties
Top
See Also

Reference

DynamicStyleContainer Class


DynamicStyleContainer Constructor

Create a new DynamicStyleContainer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DynamicStyleContainer()
Public Sub New
public:
DynamicStyleContainer()
See Also

Reference

DynamicStyleContainer Class
DynamicStyleContainer Overload


DynamicStyleContainer Constructor (DynamicStyleContainer)

Create a new DynamicStyleContainer by copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DynamicStyleContainer(
    DynamicStyleContainer org
)
Public Sub New (
    org As DynamicStyleContainer
)
public:
DynamicStyleContainer(
    DynamicStyleContainer^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelDynamicStyleContainer
DynamicStyleContainer to copy from
See Also

Reference

DynamicStyleContainer Class
DynamicStyleContainer Overload


DynamicStyleContainer Properties

The DynamicStyleContainer type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DynamicStyleContainer Class


DynamicStyleContainer Methods

The DynamicStyleContainer type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a list of Possible Commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | ValuesToLineStateIndexPair(ListObject) |
Public method | ValuesToLineStateIndexPair(ChannelFrame) | Converts a List of Values to List Of Linestatearray
Public method | ValueToLineStateIndexPair | Converts a value to a LinestateIndexPair
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DynamicStyleContainer Class


DynamicStyleContainer.GetCommands Method

Gets a list of Possible Commands

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
An Array of Commands
See Also

Reference

DynamicStyleContainer Class


DynamicStyleContainer.ValuesToLineStateIndexPair Method

Overload List
 | Name | Description
Public method | ValuesToLineStateIndexPair(ListObject) |
Public method | ValuesToLineStateIndexPair(ChannelFrame) | Converts a List of Values to List Of Linestatearray
Top
See Also

Reference

DynamicStyleContainer Class


DynamicStyleContainer.ValuesToLineStateIndexPair Method (List(Object))

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public List<LinestateIndexPair> ValuesToLineStateIndexPair(
    List<Object> values
)
Public Function ValuesToLineStateIndexPair (
    values As List(Of Object)
) As List(Of LinestateIndexPair)
public:
List<LinestateIndexPair^>^ ValuesToLineStateIndexPair(
    List<Object^>^ values
)

Parameters

values
Type: System.Collections.GenericList Object

Return Value

Type: List LinestateIndexPair
See Also

Reference

DynamicStyleContainer Class
ValuesToLineStateIndexPair Overload


DynamicStyleContainer.ValuesToLineStateIndexPair Method (DisplayFrameEventArgs.ChannelFrame)

Converts a List of Values to List Of Linestatearray

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public List<LinestateIndexPair> ValuesToLineStateIndexPair(
    ChannelFrame Frame
)
Public Function ValuesToLineStateIndexPair (
    Frame As ChannelFrame
) As List(Of LinestateIndexPair)
public:
List<LinestateIndexPair^>^ ValuesToLineStateIndexPair(
    ChannelFrame Frame
)

Parameters

Frame
Type: ChannelFrame
The ChannelFrame Containing all Values

Return Value

Type: List LinestateIndexPair
See Also

Reference

DynamicStyleContainer Class
ValuesToLineStateIndexPair Overload


DynamicStyleContainer.ValueToLineStateIndexPair Method

Converts a value to a LinestateIndexPair

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public LinestateIndexPair ValueToLineStateIndexPair(
    double value
)
Public Function ValueToLineStateIndexPair (
    value As Double
) As LinestateIndexPair
public:
LinestateIndexPair^ ValueToLineStateIndexPair(
    double value
)

Parameters

value
Type: SystemDouble
The value to convert

Return Value

Type: LinestateIndexPair
See Also

Reference

DynamicStyleContainer Class


DynamicStyleContainer Events

The DynamicStyleContainer type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

DynamicStyleContainer Class


EchoChartLayerCollection Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelChartLayerBase
TwinCAT.Measurement.Scope.API.ModelEchoChartLayerCollection

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class EchoChartLayerCollection : ChartLayerBase
Public Class EchoChartLayerCollection
    Inherits ChartLayerBase
public ref class EchoChartLayerCollection : public ChartLayerBase

The EchoChartLayerCollection type exposes the following members.

Constructors
 | Name | Description
Public method | EchoChartLayerCollection | Create a new EchoChartLayerCollection instance
Public method | EchoChartLayerCollection(EchoChartLayerCollection) | Create a new instance as a copy
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength.
Public property | EchoAmount | Gets or Sets the EchoAmount.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | Visibility | Gets or Sets the Visibility.
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | highlight the layer in the charting (Overrides ChartLayerBaseHighlight.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | MoveDown | Move down the Layer in the LayerControl (Inherited from ChartLayerBase.)
Public method | MoveUp | Move up the Layer in the LayerControl (Inherited from ChartLayerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed.
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | VisibilityChanged | Fired when the Visibility is changed.
Public event | VisibilityValidating | Fired while validating the new value for Visibility.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


EchoChartLayerCollection Constructor

Overload List
 | Name | Description
Public method | EchoChartLayerCollection | Create a new EchoChartLayerCollection instance
Public method | EchoChartLayerCollection(EchoChartLayerCollection) | Create a new instance as a copy
Top
See Also

Reference

EchoChartLayerCollection Class


EchoChartLayerCollection Constructor

Create a new EchoChartLayerCollection instance

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public EchoChartLayerCollection()
Public Sub New
public:
EchoChartLayerCollection()
See Also

Reference

EchoChartLayerCollection Class
EchoChartLayerCollection Overload


EchoChartLayerCollection Constructor (EchoChartLayerCollection)

Create a new instance as a copy

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public EchoChartLayerCollection(
    EchoChartLayerCollection echoChartLayerCollection
)
Public Sub New (
    echoChartLayerCollection As EchoChartLayerCollection
)
public:
EchoChartLayerCollection(
    EchoChartLayerCollection^ echoChartLayerCollection
)

Parameters

echoChartLayerCollection
Type: TwinCAT.Measurement.Scope.API.ModelEchoChartLayerCollection
See Also

Reference

EchoChartLayerCollection Class
EchoChartLayerCollection Overload


EchoChartLayerCollection Properties

The EchoChartLayerCollection type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength.
Public property | EchoAmount | Gets or Sets the EchoAmount.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | Visibility | Gets or Sets the Visibility.
Top
See Also

Reference

EchoChartLayerCollection Class


EchoChartLayerCollection.DurationLength Property

Gets or Sets the DurationLength.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public long DurationLength { get; set; }
<BrowsableAttribute(false)>
Public Property DurationLength As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
property long long DurationLength {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

EchoChartLayerCollection Class


EchoChartLayerCollection.EchoAmount Property

Gets or Sets the EchoAmount.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public int EchoAmount { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property EchoAmount As Integer
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property int EchoAmount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

EchoChartLayerCollection Class


EchoChartLayerCollection.Visibility Property

Gets or Sets the Visibility.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool Visibility { get; set; }
<BrowsableAttribute(false)>
Public Property Visibility As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool Visibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

EchoChartLayerCollection Class


EchoChartLayerCollection Methods

The EchoChartLayerCollection type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | highlight the layer in the charting (Overrides ChartLayerBaseHighlight.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | MoveDown | Move down the Layer in the LayerControl (Inherited from ChartLayerBase.)
Public method | MoveUp | Move up the Layer in the LayerControl (Inherited from ChartLayerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

EchoChartLayerCollection Class


EchoChartLayerCollection.Highlight Method

highlight the layer in the charting

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void Highlight()
Public Overrides Sub Highlight
public:
virtual void Highlight() override
See Also

Reference

EchoChartLayerCollection Class


EchoChartLayerCollection Events

The EchoChartLayerCollection type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed.
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | VisibilityChanged | Fired when the Visibility is changed.
Public event | VisibilityValidating | Fired while validating the new value for Visibility.
Top
See Also

Reference

EchoChartLayerCollection Class


EchoChartLayerCollection.DurationLengthChanged Event

Fired when the DurationLength is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DurationLengthChanged
Public Event DurationLengthChanged As EventHandler
public:
 event EventHandler^ DurationLengthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

EchoChartLayerCollection Class


EchoChartLayerCollection.DurationLengthValidating Event

Fired while validating the new value for DurationLength.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DurationLengthValidating
Public Event DurationLengthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DurationLengthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

EchoChartLayerCollection Class


EchoChartLayerCollection.VisibilityChanged Event

Fired when the Visibility is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler VisibilityChanged
Public Event VisibilityChanged As EventHandler
public:
 event EventHandler^ VisibilityChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

EchoChartLayerCollection Class


EchoChartLayerCollection.VisibilityValidating Event

Fired while validating the new value for Visibility.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> VisibilityValidating
Public Event VisibilityValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ VisibilityValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

EchoChartLayerCollection Class


Function Class

Base class for all Funcitons
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.API.ModelFunction
TwinCAT.Measurement.Scope.API.ModelDoubleInputFunction
TwinCAT.Measurement.Scope.API.ModelNegateFunction

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class Function : ICondition
Public MustInherit Class Function
    Implements ICondition
public ref class Function abstract : ICondition

The Function type exposes the following members.

Constructors
 | Name | Description
Public method | Function | Create a new Functions
Top
Properties
 | Name | Description
Public property | Value | The result of the Function
Top
Methods
 | Name | Description
Public method | Contains | Test if the Function contains the Input Condition
 | CreateFunction | Create a complex Function from string
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


Function Constructor

Create a new Functions

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Function(
    ICondition Input1
)
Public Sub New (
    Input1 As ICondition
)
public:
Function(
    ICondition^ Input1
)

Parameters

Input1
Type: TwinCAT.Measurement.Scope.API.ModelICondition
First Input Condition
See Also

Reference

Function Class


Function Properties

The Function type exposes the following members.

Properties
 | Name | Description
Public property | Value | The result of the Function
Top
See Also

Reference

Function Class


Function.Value Property

The result of the Function

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract bool Value { get; }
Public MustOverride ReadOnly Property Value As Boolean
    Get
public:
virtual property bool Value {
    bool get () abstract;
}

Property Value

Type: Boolean

Implements

IConditionValue
See Also

Reference

Function Class


Function Methods

The Function type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Test if the Function contains the Input Condition
 | CreateFunction | Create a complex Function from string
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Function Class


Function.Contains Method

Test if the Function contains the Input Condition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual bool Contains(
    ICondition Input
)
Public Overridable Function Contains (
    Input As ICondition
) As Boolean
public:
virtual bool Contains(
    ICondition^ Input
)

Parameters

Input
Type: TwinCAT.Measurement.Scope.API.ModelICondition
Condition to test

Return Value

Type: Boolean
True if this Function or a Subfunction contains the Condtion
See Also

Reference

Function Class


Function.CreateFunction Method

Create a complex Function from string

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static ICondition CreateFunction(
    string s,
    List<Condition> InnerConditions
)
Public Shared Function CreateFunction (
    s As String,
    InnerConditions As List(Of Condition)
) As ICondition
public:
static ICondition^ CreateFunction(
    String^ s,
    List<Condition^>^ InnerConditions
)

Parameters

s
Type: SystemString
The String to pars
InnerConditions
Type: System.Collections.GenericList Condition
Conditions to replace indicees

Return Value

Type: ICondition
The Created Function
See Also

Reference

Function Class


HistoricalAcquisition Class

Base class for all Scope Acquisitions, which can be historical. E. g. the MqttAcquisition can also be not historical, check "IsHistorical" to be safe!
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisition
TwinCAT.Measurement.Scope.API.ModelHistoricalAcquisition
TwinCAT.Measurement.Scope.API.ModelDbAcquisition
TwinCAT.Measurement.Scope.API.ModelIotFileAcquisition
TwinCAT.Measurement.Scope.API.ModelMqttAcquisition
TwinCAT.Measurement.Scope.API.ModelSvdxAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class HistoricalAcquisition : Acquisition
Public MustInherit Class HistoricalAcquisition
    Inherits Acquisition
public ref class HistoricalAcquisition abstract : public Acquisition

The HistoricalAcquisition type exposes the following members.

Constructors
 | Name | Description
Public method | HistoricalAcquisition | Create a new Historical Acquistion
Public method | HistoricalAcquisition(HistoricalAcquisition) | Create a new Historical Acquisition
Top
Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName. (Inherited from Acquisition.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | Records | Gets the Records.
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | TimeRangeId | Gets or Sets the TimeRangeId.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UpdateOtherAcq | If this property is true all other Acquisitions with the same Target get updated without a question.
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Inherited from Acquisition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Acquisition.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides AcquisitionHasSameTarget(Acquisition).)
Public method | HasSameTargetExceptRecords | Determines wether the two Acquisition will acquire the same Data except the selected Records
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateDataAccessTimes | Sets the time property of the DataAccess based on the Records.
Public method | UpdatePropertyAttributes | Update Attributes of all Properties (Inherited from Acquisition.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RecordsChanged | Fired when the Records is changed.
Public event | RecordsValidating | Fired while validating the new value for Records.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TimeRangeIdChanged | Fired when the TimeRangeId is changed.
Public event | TimeRangeIdValidating | Fired while validating the new value for TimeRangeId.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateOtherAcqChanged | Fired when the UpdateOtherAcq is changed.
Public event | UpdateOtherAcqValidating | Fired while validating the new value for UpdateOtherAcq.
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


HistoricalAcquisition Constructor

Overload List
 | Name | Description
Public method | HistoricalAcquisition | Create a new Historical Acquistion
Public method | HistoricalAcquisition(HistoricalAcquisition) | Create a new Historical Acquisition
Top
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition Constructor

Create a new Historical Acquistion

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public HistoricalAcquisition()
Public Sub New
public:
HistoricalAcquisition()
See Also

Reference

HistoricalAcquisition Class
HistoricalAcquisition Overload


HistoricalAcquisition Constructor (HistoricalAcquisition)

Create a new Historical Acquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public HistoricalAcquisition(
    HistoricalAcquisition historicalAcquisition
)
Public Sub New (
    historicalAcquisition As HistoricalAcquisition
)
public:
HistoricalAcquisition(
    HistoricalAcquisition^ historicalAcquisition
)

Parameters

historicalAcquisition
Type: TwinCAT.Measurement.Scope.API.ModelHistoricalAcquisition
Copy Properties from this Element
See Also

Reference

HistoricalAcquisition Class
HistoricalAcquisition Overload


HistoricalAcquisition Properties

The HistoricalAcquisition type exposes the following members.

Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName. (Inherited from Acquisition.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | Records | Gets the Records.
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | TimeRangeId | Gets or Sets the TimeRangeId.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UpdateOtherAcq | If this property is true all other Acquisitions with the same Target get updated without a question.
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition.Records Property

Gets the Records.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual RecordsContainer Records { get; set; }
Public Overridable Property Records As RecordsContainer
    Get
    Set
public:
virtual property RecordsContainer^ Records {
    RecordsContainer^ get ();
    void set (RecordsContainer^ value);
}

Property Value

Type: RecordsContainer
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition.TimeRangeId Property

Gets or Sets the TimeRangeId.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual ulong TimeRangeId { get; set; }
Public Overridable Property TimeRangeId As ULong
    Get
    Set
public:
virtual property unsigned long long TimeRangeId {
    unsigned long long get ();
    void set (unsigned long long value);
}

Property Value

Type: UInt64
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition.UpdateOtherAcq Property

If this property is true all other Acquisitions with the same Target get updated without a question.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool UpdateOtherAcq { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property UpdateOtherAcq As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool UpdateOtherAcq {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition Methods

The HistoricalAcquisition type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Inherited from Acquisition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Acquisition.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides AcquisitionHasSameTarget(Acquisition).)
Public method | HasSameTargetExceptRecords | Determines wether the two Acquisition will acquire the same Data except the selected Records
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateDataAccessTimes | Sets the time property of the DataAccess based on the Records.
Public method | UpdatePropertyAttributes | Update Attributes of all Properties (Inherited from Acquisition.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition.HasSameTarget Method

Determines wether the two Acquisition will acquire the same Data

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool HasSameTarget(
    Acquisition Acquisition
)
Public Overrides Function HasSameTarget (
    Acquisition As Acquisition
) As Boolean
public:
virtual bool HasSameTarget(
    Acquisition^ Acquisition
) override

Parameters

Acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
The Acquisition to compare with

Return Value

Type: Boolean
True if the Acquisitions have the Same Target
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition.HasSameTargetExceptRecords Method

Determines wether the two Acquisition will acquire the same Data except the selected Records

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual bool HasSameTargetExceptRecords(
    HistoricalAcquisition Acquisition
)
Public Overridable Function HasSameTargetExceptRecords (
    Acquisition As HistoricalAcquisition
) As Boolean
public:
virtual bool HasSameTargetExceptRecords(
    HistoricalAcquisition^ Acquisition
)

Parameters

Acquisition
Type: TwinCAT.Measurement.Scope.API.ModelHistoricalAcquisition
The Acquisition to compare with

Return Value

Type: Boolean
True if the Acquisitions have the Same Target
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition.UpdateDataAccessTimes Method

Sets the time property of the DataAccess based on the Records.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void UpdateDataAccessTimes()
Public Overridable Sub UpdateDataAccessTimes
public:
virtual void UpdateDataAccessTimes()
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition Events

The HistoricalAcquisition type exposes the following members.

Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RecordsChanged | Fired when the Records is changed.
Public event | RecordsValidating | Fired while validating the new value for Records.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TimeRangeIdChanged | Fired when the TimeRangeId is changed.
Public event | TimeRangeIdValidating | Fired while validating the new value for TimeRangeId.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateOtherAcqChanged | Fired when the UpdateOtherAcq is changed.
Public event | UpdateOtherAcqValidating | Fired while validating the new value for UpdateOtherAcq.
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition.RecordsChanged Event

Fired when the Records is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler RecordsChanged
Public Event RecordsChanged As EventHandler
public:
 event EventHandler^ RecordsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition.RecordsValidating Event

Fired while validating the new value for Records.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> RecordsValidating
Public Event RecordsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ RecordsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition.TimeRangeIdChanged Event

Fired when the TimeRangeId is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TimeRangeIdChanged
Public Event TimeRangeIdChanged As EventHandler
public:
 event EventHandler^ TimeRangeIdChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition.TimeRangeIdValidating Event

Fired while validating the new value for TimeRangeId.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TimeRangeIdValidating
Public Event TimeRangeIdValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TimeRangeIdValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition.UpdateOtherAcqChanged Event

Fired when the UpdateOtherAcq is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UpdateOtherAcqChanged
Public Event UpdateOtherAcqChanged As EventHandler
public:
 event EventHandler^ UpdateOtherAcqChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition.UpdateOtherAcqValidating Event

Fired while validating the new value for UpdateOtherAcq.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UpdateOtherAcqValidating
Public Event UpdateOtherAcqValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UpdateOtherAcqValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

HistoricalAcquisition Class


HistoricalAcquisition Fields

The HistoricalAcquisition type exposes the following members.

Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

HistoricalAcquisition Class


ICondition Interface

Interface for all Conditions and Function in an Dynamic Style

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public interface ICondition
Public Interface ICondition
public interface class ICondition

The ICondition type exposes the following members.

Properties
 | Name | Description
Public property | Value | The Result of an Function or Condition
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ICondition Properties

The ICondition type exposes the following members.

Properties
 | Name | Description
Public property | Value | The Result of an Function or Condition
Top
See Also

Reference

ICondition Interface


ICondition.Value Property

The Result of an Function or Condition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
bool Value { get; }
ReadOnly Property Value As Boolean
    Get
property bool Value {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ICondition Interface


ImageMarker Class

Model class for Scope Image Marker
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelMarker
TwinCAT.Measurement.Scope.API.ModelTimeMarker
TwinCAT.Measurement.Scope.API.ModelImageMarker

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ImageMarker : TimeMarker
Public Class ImageMarker
    Inherits TimeMarker
public ref class ImageMarker : public TimeMarker

The ImageMarker type exposes the following members.

Constructors
 | Name | Description
Public method | ImageMarker | Create a new ImageMarker with default Values
Public method | ImageMarker(ImageMarker) | Create a new ImageMarker by copying properties from another marker
Top
Properties
 | Name | Description
Public property | AttachToAxis | Gets or Sets the AttachToAxis. If AttachToAxis is True --> The position is an absolut value of this axis. If AttachToAxis is False --> The position is an relative value of the displayed axis. (Inherited from Marker.)
Public property | AttachToAxisBrowsable | (Inherited from Marker.)
Public property | Bandwidth | Gets or Sets the Bandwidth. (Inherited from Marker.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Marker.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetNearestPosition | Get Field for GetNearestPosition Delegate (Inherited from Marker.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | ImageAcquisition | Gets or Sets the ImageAcquisition.
Public property | ImageAcquisitionGuid | Gets or Sets the ImageAcquisitionGuid.
Public property | ImageStreamStyle | Gets the ImageStreamStyle
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineStyle | Gets or Sets the LineStyle. (Inherited from Marker.)
Public property | Live | Gets or Sets the Live.
Public property | Locked | Gets or Sets the Locked. (Inherited from Marker.)
Public property | Marker3DType | Gets or Sets the Marker3DType. (Inherited from TimeMarker.)
Public property | MarkerType | Gets or Sets the MarkerType. (Inherited from TimeMarker.)
Public property | MenuStyle | Gets the MenuStyle
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Marker.)
Public property | Position | Gets or Sets the Position. (Inherited from Marker.)
Public property | PositionPropertyUpdater | (Inherited from Marker.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowFullArray | Gets or Sets the ShowFullArray. (Inherited from TimeMarker.)
Public property | ShowLiveOverview | Ask view member, if the overview is live and open
Public property | ShowPosition | Gets or Sets the ShowPosition. (Inherited from Marker.)
Public property | ShowTitle | Gets or Sets the ShowTitle. (Inherited from Marker.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimePosition | Gets or Sets the TimePosition. (Inherited from Marker.)
Public property | Title | Gets or Sets the Title (Inherited from Marker.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | ValuePrecision | Gets or Sets the ValuePrecision. (Inherited from Marker.)
Public property | Visible | Gets or Sets the Visible. (Inherited from Marker.)
Public property | Width | Gets or Sets the Width. (Inherited from Marker.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddValue | (Inherited from Marker.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AttachToEnd | Attachs the Imagemarker to the end
Public method | CalcTimePosition | Calculate the current timeposition with the given position (Inherited from Marker.)
Public method | ClearDataValues |
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ContainsChannelValue | Obsolete. Check if the Marker has an value from the channel (Inherited from Marker.)
Public method | ContainsMemberValue | Check if the Marker has an value from the member (Inherited from Marker.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllValues | Returns a copy of the ValueDictionary (Inherited from Marker.)
Public method | GetChannelValue | Obsolete. Gets the channelvalue of the Marker (Inherited from Marker.)
Public method | GetCommands | Gets the possible commands (Overrides TimeMarkerGetCommands.)
Public method | GetCurrentImage | Gets the current image of the ImageMarker
Public method | GetCurrentImageData | Gets the current image data
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageRange |
Public method | GetMemberValue | Gets the membervalue of the Marker (Inherited from Marker.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubInterpreterValue | (Inherited from Marker.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue |
Public method | GetValues | Get the Values for this Marker as string (Inherited from Marker.)
Public method | Highlight | Highlight the Graph of this channel (Inherited from Marker.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RefreshPictureData | RefreshPictureData
Public method | RefreshValue | (Inherited from Marker.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartLivePlayback | Starts the live playback
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartOverview |
Public method | StopLivePlayback | Stops the live playback
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopOverview |
Public method | ToString | Converts a Marker to string (Inherited from Marker.)
Public method | UpdatePropertyAttributes | Updates the Attributes of all Properties (Overrides TimeMarkerUpdatePropertyAttributes.)
Public method | UpdateTimePosition | Calculate the current timeposition with the given position (Inherited from Marker.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AttachToAxisChanged | Fired when the AttachToAxis is changed. (Inherited from Marker.)
Public event | AttachToAxisValidating | Fired while validating the new value for AttachToAxis. (Inherited from Marker.)
Public event | BandwidthChanged | Fired when the Bandwidth is changed. (Inherited from Marker.)
Public event | BandwidthValidating | Fired while validating the new value for Bandwidth. (Inherited from Marker.)
Public event | BeforeImageAcquisitionChanged | Fired before a ImageAcquisition changed.
Public event | BeforePositionChanged | Fired before the position changed (Inherited from Marker.)
Public event | CenterToScreen | Event fired to Center the Marker to Screen (Inherited from TimeMarker.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightEvent | Event fired when the marker should be highlighted (Inherited from Marker.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | ImageAcquisitionChanged | Fired when the ImageAcquisition is changed.
Public event | ImageAcquisitionGuidChanged | Fired when the ImageAcquisitionGuid is changed.
Public event | ImageAcquisitionGuidValidating | Fired while validating the new value for ImageAcquisitionGuid.
Public event | ImageAcquisitionValidating | Fired while validating the new value for ImageAcquisition.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineStyleChanged | Fired when the LineStyle is changed. (Inherited from Marker.)
Public event | LineStyleValidating | Fired while validating the new value for LineStyle. (Inherited from Marker.)
Public event | LiveChanged | Fired when the Live is changed.
Public event | LiveValidating | Fired while validating the new value for Live.
Public event | LockedChanged | Fired when the Locked is changed. (Inherited from Marker.)
Public event | LockedValidating | Fired while validating the new value for Locked. (Inherited from Marker.)
Public event | Marker3DTypeChanged | Fired when the Marker3DType is changed. (Inherited from TimeMarker.)
Public event | Marker3DTypeValidating | Fired while validating the new value for Marker3DType. (Inherited from TimeMarker.)
Public event | MarkerTypeChanged | Fired when the MarkerType is changed. (Inherited from TimeMarker.)
Public event | MarkerTypeValidating | Fired while validating the new value for MarkerType. (Inherited from TimeMarker.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NewMarkerValues | Event fired when Values has Changed (Inherited from Marker.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Marker.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Marker.)
Public event | PositionChanged | Fired when the Position is changed. (Inherited from Marker.)
Public event | PositionValidating | Fired while validating the new value for Position. (Inherited from Marker.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshClientTimePosition | Event fired to check, if the Chart is running or stopped (Inherited from TimeMarker.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowFullArrayChanged | Fired when the ShowFullArray is changed. (Inherited from TimeMarker.)
Public event | ShowFullArrayChanging | Fired while changing the ShowFullArray. (Inherited from TimeMarker.)
Public event | ShowFullArrayValidating | Fired while validating the new value for ShowFullArray. (Inherited from TimeMarker.)
Public event | ShowPositionChanged | Fired when the ShowPosition is changed. (Inherited from Marker.)
Public event | ShowPositionValidating | Fired while validating the new value for ShowPosition. (Inherited from Marker.)
Public event | ShowTitleChanged | Fired when the ShowTitle is changed. (Inherited from Marker.)
Public event | ShowTitleValidating | Fired while validating the new value for ShowTitle. (Inherited from Marker.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimePositionChanged | Fired when the TimePosition is changed. (Inherited from Marker.)
Public event | TimePositionValidating | Fired while validating the new value for TimePosition. (Inherited from Marker.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateImage | Raise, if there is a new image
Public event | UpdateOverviewImage | Raise, if there is a new image
Public event | ValueDictChanged | Fired when the ValueDict is changed. (Inherited from Marker.)
Public event | ValueDictValidating | Fired while validating the new value for ValueDict. (Inherited from Marker.)
Public event | ValuePrecisionChanged | Fired when the ValuePrecision is changed. (Inherited from Marker.)
Public event | ValuePrecisionValidating | Fired while validating the new value for ValuePrecision. (Inherited from Marker.)
Public event | VisibleChanged | Fired when the Visible is changed. (Inherited from Marker.)
Public event | VisibleValidating | Fired while validating the new value for Visible. (Inherited from Marker.)
Public event | WidthChanged | Fired when the Width is changed. (Inherited from Marker.)
Public event | WidthValidating | Fired while validating the new value for Width. (Inherited from Marker.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ImageMarker Constructor

Overload List
 | Name | Description
Public method | ImageMarker | Create a new ImageMarker with default Values
Public method | ImageMarker(ImageMarker) | Create a new ImageMarker by copying properties from another marker
Top
See Also

Reference

ImageMarker Class


ImageMarker Constructor

Create a new ImageMarker with default Values

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ImageMarker()
Public Sub New
public:
ImageMarker()
See Also

Reference

ImageMarker Class
ImageMarker Overload


ImageMarker Constructor (ImageMarker)

Create a new ImageMarker by copying properties from another marker

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ImageMarker(
    ImageMarker imageMarker
)
Public Sub New (
    imageMarker As ImageMarker
)
public:
ImageMarker(
    ImageMarker^ imageMarker
)

Parameters

imageMarker
Type: TwinCAT.Measurement.Scope.API.ModelImageMarker
Marker to copy from
See Also

Reference

ImageMarker Class
ImageMarker Overload


ImageMarker Properties

The ImageMarker type exposes the following members.

Properties
 | Name | Description
Public property | AttachToAxis | Gets or Sets the AttachToAxis. If AttachToAxis is True --> The position is an absolut value of this axis. If AttachToAxis is False --> The position is an relative value of the displayed axis. (Inherited from Marker.)
Public property | AttachToAxisBrowsable | (Inherited from Marker.)
Public property | Bandwidth | Gets or Sets the Bandwidth. (Inherited from Marker.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Marker.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetNearestPosition | Get Field for GetNearestPosition Delegate (Inherited from Marker.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | ImageAcquisition | Gets or Sets the ImageAcquisition.
Public property | ImageAcquisitionGuid | Gets or Sets the ImageAcquisitionGuid.
Public property | ImageStreamStyle | Gets the ImageStreamStyle
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineStyle | Gets or Sets the LineStyle. (Inherited from Marker.)
Public property | Live | Gets or Sets the Live.
Public property | Locked | Gets or Sets the Locked. (Inherited from Marker.)
Public property | Marker3DType | Gets or Sets the Marker3DType. (Inherited from TimeMarker.)
Public property | MarkerType | Gets or Sets the MarkerType. (Inherited from TimeMarker.)
Public property | MenuStyle | Gets the MenuStyle
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Marker.)
Public property | Position | Gets or Sets the Position. (Inherited from Marker.)
Public property | PositionPropertyUpdater | (Inherited from Marker.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowFullArray | Gets or Sets the ShowFullArray. (Inherited from TimeMarker.)
Public property | ShowLiveOverview | Ask view member, if the overview is live and open
Public property | ShowPosition | Gets or Sets the ShowPosition. (Inherited from Marker.)
Public property | ShowTitle | Gets or Sets the ShowTitle. (Inherited from Marker.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimePosition | Gets or Sets the TimePosition. (Inherited from Marker.)
Public property | Title | Gets or Sets the Title (Inherited from Marker.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | ValuePrecision | Gets or Sets the ValuePrecision. (Inherited from Marker.)
Public property | Visible | Gets or Sets the Visible. (Inherited from Marker.)
Public property | Width | Gets or Sets the Width. (Inherited from Marker.)
Top
See Also

Reference

ImageMarker Class


ImageMarker.ImageAcquisition Property

Gets or Sets the ImageAcquisition.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public Acquisition ImageAcquisition { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property ImageAcquisition As Acquisition
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property Acquisition^ ImageAcquisition {
    Acquisition^ get ();
    void set (Acquisition^ value);
}

Property Value

Type: Acquisition
See Also

Reference

ImageMarker Class


ImageMarker.ImageAcquisitionGuid Property

Gets or Sets the ImageAcquisitionGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Guid ImageAcquisitionGuid { get; set; }
<BrowsableAttribute(true)>
Public Property ImageAcquisitionGuid As Guid
    Get
    Set
public:
[BrowsableAttribute(true)]
property Guid ImageAcquisitionGuid {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

ImageMarker Class


ImageMarker.ImageStreamStyle Property

Gets the ImageStreamStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public ImageStreamStyle ImageStreamStyle { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property ImageStreamStyle As ImageStreamStyle
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property ImageStreamStyle^ ImageStreamStyle {
    ImageStreamStyle^ get ();
}

Property Value

Type: ImageStreamStyle
See Also

Reference

ImageMarker Class


ImageMarker.Live Property

Gets or Sets the Live.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool Live { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property Live As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool Live {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ImageMarker Class


ImageMarker.MenuStyle Property

Gets the MenuStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public ChartMenuStyle MenuStyle { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property MenuStyle As ChartMenuStyle
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property ChartMenuStyle^ MenuStyle {
    ChartMenuStyle^ get ();
}

Property Value

Type: ChartMenuStyle
See Also

Reference

ImageMarker Class


ImageMarker.ShowLiveOverview Property

Ask view member, if the overview is live and open

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public ImageMarkerDelShowLiveOverview ShowLiveOverview { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property ShowLiveOverview As ImageMarkerDelShowLiveOverview
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property ImageMarkerDelShowLiveOverview^ ShowLiveOverview {
    ImageMarkerDelShowLiveOverview^ get ();
    void set (ImageMarkerDelShowLiveOverview^ value);
}

Property Value

Type: ImageMarkerDelShowLiveOverview
See Also

Reference

ImageMarker Class


ImageMarker Methods

The ImageMarker type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddValue | (Inherited from Marker.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AttachToEnd | Attachs the Imagemarker to the end
Public method | CalcTimePosition | Calculate the current timeposition with the given position (Inherited from Marker.)
Public method | ClearDataValues |
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ContainsChannelValue | Obsolete. Check if the Marker has an value from the channel (Inherited from Marker.)
Public method | ContainsMemberValue | Check if the Marker has an value from the member (Inherited from Marker.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllValues | Returns a copy of the ValueDictionary (Inherited from Marker.)
Public method | GetChannelValue | Obsolete. Gets the channelvalue of the Marker (Inherited from Marker.)
Public method | GetCommands | Gets the possible commands (Overrides TimeMarkerGetCommands.)
Public method | GetCurrentImage | Gets the current image of the ImageMarker
Public method | GetCurrentImageData | Gets the current image data
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageRange |
Public method | GetMemberValue | Gets the membervalue of the Marker (Inherited from Marker.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubInterpreterValue | (Inherited from Marker.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue |
Public method | GetValues | Get the Values for this Marker as string (Inherited from Marker.)
Public method | Highlight | Highlight the Graph of this channel (Inherited from Marker.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RefreshPictureData | RefreshPictureData
Public method | RefreshValue | (Inherited from Marker.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartLivePlayback | Starts the live playback
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartOverview |
Public method | StopLivePlayback | Stops the live playback
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopOverview |
Public method | ToString | Converts a Marker to string (Inherited from Marker.)
Public method | UpdatePropertyAttributes | Updates the Attributes of all Properties (Overrides TimeMarkerUpdatePropertyAttributes.)
Public method | UpdateTimePosition | Calculate the current timeposition with the given position (Inherited from Marker.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ImageMarker Class


ImageMarker.AttachToEnd Method

Attachs the Imagemarker to the end

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void AttachToEnd()
Public Sub AttachToEnd
public:
void AttachToEnd()
See Also

Reference

ImageMarker Class


ImageMarker.ClearDataValues Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void ClearDataValues()
Public Sub ClearDataValues
public:
void ClearDataValues()
See Also

Reference

ImageMarker Class


ImageMarker.Errorhandler Method

Used to catch errors from Controls

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Errorhandler(
    Exception err
)
Public Sub Errorhandler (
    err As Exception
)
public:
void Errorhandler(
    Exception^ err
)

Parameters

err
Type: SystemException
See Also

Reference

ImageMarker Class


ImageMarker.GetCommands Method

Gets the possible commands

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
See Also

Reference

ImageMarker Class


ImageMarker.GetCurrentImage Method

Gets the current image of the ImageMarker

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Bitmap GetCurrentImage()
Public Function GetCurrentImage As Bitmap
public:
Bitmap^ GetCurrentImage()

Return Value

Type: Bitmap
See Also

Reference

ImageMarker Class


ImageMarker.GetCurrentImageData Method

Gets the current image data

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ByteImage GetCurrentImageData()
Public Function GetCurrentImageData As ByteImage
public:
ByteImage^ GetCurrentImageData()

Return Value

Type: ByteImage
See Also

Reference

ImageMarker Class


ImageMarker.GetImageRange Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public List<Tuple<long, Object>> GetImageRange(
    long timestamp,
    bool includeTimestamp,
    params int[] elementShifts
)
Public Function GetImageRange (
    timestamp As Long,
    includeTimestamp As Boolean,
    ParamArray elementShifts As Integer()
) As List(Of Tuple(Of Long, Object))
public:
List<Tuple<long long, Object^>^>^ GetImageRange(
    long long timestamp,
    bool includeTimestamp,
    ... array<int>^ elementShifts
)

Parameters

timestamp
Type: SystemInt64
includeTimestamp
Type: SystemBoolean
elementShifts
Type: SystemInt32

Return Value

Type: List Tuple Int64, Object
See Also

Reference

ImageMarker Class


ImageMarker.GetValue Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Tuple<long, Object> GetValue(
    long timestamp
)
Public Function GetValue (
    timestamp As Long
) As Tuple(Of Long, Object)
public:
Tuple<long long, Object^>^ GetValue(
    long long timestamp
)

Parameters

timestamp
Type: SystemInt64

Return Value

Type: Tuple Int64, Object
See Also

Reference

ImageMarker Class


ImageMarker.RefreshPictureData Method

RefreshPictureData

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void RefreshPictureData(
    ByteImage image,
    long timestamp
)
Public Sub RefreshPictureData (
    image As ByteImage,
    timestamp As Long
)
public:
void RefreshPictureData(
    ByteImage^ image,
    long long timestamp
)

Parameters

image
Type: ByteImage
timestamp
Type: SystemInt64
See Also

Reference

ImageMarker Class


ImageMarker.StartLivePlayback Method

Starts the live playback

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void StartLivePlayback()
Public Sub StartLivePlayback
public:
void StartLivePlayback()
See Also

Reference

ImageMarker Class


ImageMarker.StartOverview Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void StartOverview(
    bool forceStart = false
)
Public Sub StartOverview (
    Optional forceStart As Boolean = false
)
public:
void StartOverview(
    bool forceStart = false
)

Parameters

forceStart (Optional)
Type: SystemBoolean
See Also

Reference

ImageMarker Class


ImageMarker.StopLivePlayback Method

Stops the live playback

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void StopLivePlayback()
Public Sub StopLivePlayback
public:
void StopLivePlayback()
See Also

Reference

ImageMarker Class


ImageMarker.StopOverview Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void StopOverview()
Public Sub StopOverview
public:
void StopOverview()
See Also

Reference

ImageMarker Class


ImageMarker.UpdatePropertyAttributes Method

Updates the Attributes of all Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ImageMarker Class


ImageMarker Events

The ImageMarker type exposes the following members.

Events
 | Name | Description
Public event | AttachToAxisChanged | Fired when the AttachToAxis is changed. (Inherited from Marker.)
Public event | AttachToAxisValidating | Fired while validating the new value for AttachToAxis. (Inherited from Marker.)
Public event | BandwidthChanged | Fired when the Bandwidth is changed. (Inherited from Marker.)
Public event | BandwidthValidating | Fired while validating the new value for Bandwidth. (Inherited from Marker.)
Public event | BeforeImageAcquisitionChanged | Fired before a ImageAcquisition changed.
Public event | BeforePositionChanged | Fired before the position changed (Inherited from Marker.)
Public event | CenterToScreen | Event fired to Center the Marker to Screen (Inherited from TimeMarker.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightEvent | Event fired when the marker should be highlighted (Inherited from Marker.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | ImageAcquisitionChanged | Fired when the ImageAcquisition is changed.
Public event | ImageAcquisitionGuidChanged | Fired when the ImageAcquisitionGuid is changed.
Public event | ImageAcquisitionGuidValidating | Fired while validating the new value for ImageAcquisitionGuid.
Public event | ImageAcquisitionValidating | Fired while validating the new value for ImageAcquisition.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineStyleChanged | Fired when the LineStyle is changed. (Inherited from Marker.)
Public event | LineStyleValidating | Fired while validating the new value for LineStyle. (Inherited from Marker.)
Public event | LiveChanged | Fired when the Live is changed.
Public event | LiveValidating | Fired while validating the new value for Live.
Public event | LockedChanged | Fired when the Locked is changed. (Inherited from Marker.)
Public event | LockedValidating | Fired while validating the new value for Locked. (Inherited from Marker.)
Public event | Marker3DTypeChanged | Fired when the Marker3DType is changed. (Inherited from TimeMarker.)
Public event | Marker3DTypeValidating | Fired while validating the new value for Marker3DType. (Inherited from TimeMarker.)
Public event | MarkerTypeChanged | Fired when the MarkerType is changed. (Inherited from TimeMarker.)
Public event | MarkerTypeValidating | Fired while validating the new value for MarkerType. (Inherited from TimeMarker.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NewMarkerValues | Event fired when Values has Changed (Inherited from Marker.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Marker.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Marker.)
Public event | PositionChanged | Fired when the Position is changed. (Inherited from Marker.)
Public event | PositionValidating | Fired while validating the new value for Position. (Inherited from Marker.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshClientTimePosition | Event fired to check, if the Chart is running or stopped (Inherited from TimeMarker.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowFullArrayChanged | Fired when the ShowFullArray is changed. (Inherited from TimeMarker.)
Public event | ShowFullArrayChanging | Fired while changing the ShowFullArray. (Inherited from TimeMarker.)
Public event | ShowFullArrayValidating | Fired while validating the new value for ShowFullArray. (Inherited from TimeMarker.)
Public event | ShowPositionChanged | Fired when the ShowPosition is changed. (Inherited from Marker.)
Public event | ShowPositionValidating | Fired while validating the new value for ShowPosition. (Inherited from Marker.)
Public event | ShowTitleChanged | Fired when the ShowTitle is changed. (Inherited from Marker.)
Public event | ShowTitleValidating | Fired while validating the new value for ShowTitle. (Inherited from Marker.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimePositionChanged | Fired when the TimePosition is changed. (Inherited from Marker.)
Public event | TimePositionValidating | Fired while validating the new value for TimePosition. (Inherited from Marker.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateImage | Raise, if there is a new image
Public event | UpdateOverviewImage | Raise, if there is a new image
Public event | ValueDictChanged | Fired when the ValueDict is changed. (Inherited from Marker.)
Public event | ValueDictValidating | Fired while validating the new value for ValueDict. (Inherited from Marker.)
Public event | ValuePrecisionChanged | Fired when the ValuePrecision is changed. (Inherited from Marker.)
Public event | ValuePrecisionValidating | Fired while validating the new value for ValuePrecision. (Inherited from Marker.)
Public event | VisibleChanged | Fired when the Visible is changed. (Inherited from Marker.)
Public event | VisibleValidating | Fired while validating the new value for Visible. (Inherited from Marker.)
Public event | WidthChanged | Fired when the Width is changed. (Inherited from Marker.)
Public event | WidthValidating | Fired while validating the new value for Width. (Inherited from Marker.)
Top
See Also

Reference

ImageMarker Class


ImageMarker.BeforeImageAcquisitionChanged Event

Fired before a ImageAcquisition changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeImageAcquisitionChanged
Public Event BeforeImageAcquisitionChanged As EventHandler
public:
 event EventHandler^ BeforeImageAcquisitionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ImageMarker Class


ImageMarker.ImageAcquisitionChanged Event

Fired when the ImageAcquisition is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ImageAcquisitionChanged
Public Event ImageAcquisitionChanged As EventHandler
public:
 event EventHandler^ ImageAcquisitionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ImageMarker Class


ImageMarker.ImageAcquisitionGuidChanged Event

Fired when the ImageAcquisitionGuid is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ImageAcquisitionGuidChanged
Public Event ImageAcquisitionGuidChanged As EventHandler
public:
 event EventHandler^ ImageAcquisitionGuidChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ImageMarker Class


ImageMarker.ImageAcquisitionGuidValidating Event

Fired while validating the new value for ImageAcquisitionGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ImageAcquisitionGuidValidating
Public Event ImageAcquisitionGuidValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ImageAcquisitionGuidValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ImageMarker Class


ImageMarker.ImageAcquisitionValidating Event

Fired while validating the new value for ImageAcquisition.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ImageAcquisitionValidating
Public Event ImageAcquisitionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ImageAcquisitionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ImageMarker Class


ImageMarker.LiveChanged Event

Fired when the Live is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LiveChanged
Public Event LiveChanged As EventHandler
public:
 event EventHandler^ LiveChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ImageMarker Class


ImageMarker.LiveValidating Event

Fired while validating the new value for Live.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LiveValidating
Public Event LiveValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LiveValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ImageMarker Class


ImageMarker.UpdateImage Event

Raise, if there is a new image

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<BitmapArgs> UpdateImage
Public Event UpdateImage As EventHandler(Of BitmapArgs)
public:
 event EventHandler<BitmapArgs^>^ UpdateImage {
    void add (EventHandler<BitmapArgs^>^ value);
    void remove (EventHandler<BitmapArgs^>^ value);
}

Value

Type: SystemEventHandler BitmapArgs
See Also

Reference

ImageMarker Class


ImageMarker.UpdateOverviewImage Event

Raise, if there is a new image

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<BitmapArgs> UpdateOverviewImage
Public Event UpdateOverviewImage As EventHandler(Of BitmapArgs)
public:
 event EventHandler<BitmapArgs^>^ UpdateOverviewImage {
    void add (EventHandler<BitmapArgs^>^ value);
    void remove (EventHandler<BitmapArgs^>^ value);
}

Value

Type: SystemEventHandler BitmapArgs
See Also

Reference

ImageMarker Class


ImageMarker.DelShowLiveOverview Delegate

Ask view member, if the overview is live and open

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public delegate bool DelShowLiveOverview()
Public Delegate Function DelShowLiveOverview As Boolean
public delegate bool DelShowLiveOverview()

Return Value

Type: Boolean
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ImageSize Class

Represents the Image Settings of an Acquisition
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelImageSize

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ImageSize : ScopeMemberBase
Public Class ImageSize
    Inherits ScopeMemberBase
public ref class ImageSize : public ScopeMemberBase

The ImageSize type exposes the following members.

Constructors
 | Name | Description
Public method | ImageSize | Creates an instanct of ImageSize
Public method | ImageSize(ImageSize) | Creates an instanct of ImageSize
Top
Properties
 | Name | Description
Public property | Channels | Gets or Sets the Channels.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DataSize | Gets or Sets the DataSize.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | ElementType | Gets or Sets the ElementType.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | ImageHeight | Gets or Sets the ImageHeight.
Public property | ImageWidth | Gets or Sets the ImageWidth.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Gets a String, which contins member information (Overrides ObjectToString.)
Public method | UpdatePropertyAttributes | Updates the Attributes of alle Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ChannelsChanged | Fired when the Channels is changed.
Public event | ChannelsValidating | Fired while validating the new value for Channels.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DataSizeChanged | Fired when the DataSize is changed.
Public event | DataSizeValidating | Fired while validating the new value for DataSize.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ElementTypeChanged | Fired when the ElementType is changed.
Public event | ElementTypeValidating | Fired while validating the new value for ElementType.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | ImageHeightChanged | Fired when the ImageHeight is changed.
Public event | ImageHeightValidating | Fired while validating the new value for ImageHeight.
Public event | ImageWidthChanged | Fired when the ImageWidth is changed.
Public event | ImageWidthValidating | Fired while validating the new value for ImageWidth.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ImageSize Constructor

Overload List
 | Name | Description
Public method | ImageSize | Creates an instanct of ImageSize
Public method | ImageSize(ImageSize) | Creates an instanct of ImageSize
Top
See Also

Reference

ImageSize Class


ImageSize Constructor

Creates an instanct of ImageSize

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ImageSize()
Public Sub New
public:
ImageSize()
See Also

Reference

ImageSize Class
ImageSize Overload


ImageSize Constructor (ImageSize)

Creates an instanct of ImageSize

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ImageSize(
    ImageSize ImageSize
)
Public Sub New (
    ImageSize As ImageSize
)
public:
ImageSize(
    ImageSize^ ImageSize
)

Parameters

ImageSize
Type: TwinCAT.Measurement.Scope.API.ModelImageSize
See Also

Reference

ImageSize Class
ImageSize Overload


ImageSize Properties

The ImageSize type exposes the following members.

Properties
 | Name | Description
Public property | Channels | Gets or Sets the Channels.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DataSize | Gets or Sets the DataSize.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | ElementType | Gets or Sets the ElementType.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | ImageHeight | Gets or Sets the ImageHeight.
Public property | ImageWidth | Gets or Sets the ImageWidth.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ImageSize Class


ImageSize.Channels Property

Gets or Sets the Channels.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public int Channels { get; set; }
<BrowsableAttribute(false)>
Public Property Channels As Integer
    Get
    Set
public:
[BrowsableAttribute(false)]
property int Channels {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ImageSize Class


ImageSize.DataSize Property

Gets or Sets the DataSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public ulong DataSize { get; set; }
<BrowsableAttribute(false)>
Public Property DataSize As ULong
    Get
    Set
public:
[BrowsableAttribute(false)]
property unsigned long long DataSize {
    unsigned long long get ();
    void set (unsigned long long value);
}

Property Value

Type: UInt64
See Also

Reference

ImageSize Class


ImageSize.ElementType Property

Gets or Sets the ElementType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public int ElementType { get; set; }
<BrowsableAttribute(false)>
Public Property ElementType As Integer
    Get
    Set
public:
[BrowsableAttribute(false)]
property int ElementType {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ImageSize Class


ImageSize.ImageHeight Property

Gets or Sets the ImageHeight.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public uint ImageHeight { get; set; }
<BrowsableAttribute(true)>
Public Property ImageHeight As UInteger
    Get
    Set
public:
[BrowsableAttribute(true)]
property unsigned int ImageHeight {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ImageSize Class


ImageSize.ImageWidth Property

Gets or Sets the ImageWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public uint ImageWidth { get; set; }
<BrowsableAttribute(true)>
Public Property ImageWidth As UInteger
    Get
    Set
public:
[BrowsableAttribute(true)]
property unsigned int ImageWidth {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ImageSize Class


ImageSize Methods

The ImageSize type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Gets a String, which contins member information (Overrides ObjectToString.)
Public method | UpdatePropertyAttributes | Updates the Attributes of alle Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ImageSize Class


ImageSize.ToString Method

Gets a String, which contins member information

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
See Also

Reference

ImageSize Class


ImageSize.UpdatePropertyAttributes Method

Updates the Attributes of alle Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ImageSize Class


ImageSize Events

The ImageSize type exposes the following members.

Events
 | Name | Description
Public event | ChannelsChanged | Fired when the Channels is changed.
Public event | ChannelsValidating | Fired while validating the new value for Channels.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DataSizeChanged | Fired when the DataSize is changed.
Public event | DataSizeValidating | Fired while validating the new value for DataSize.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ElementTypeChanged | Fired when the ElementType is changed.
Public event | ElementTypeValidating | Fired while validating the new value for ElementType.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | ImageHeightChanged | Fired when the ImageHeight is changed.
Public event | ImageHeightValidating | Fired while validating the new value for ImageHeight.
Public event | ImageWidthChanged | Fired when the ImageWidth is changed.
Public event | ImageWidthValidating | Fired while validating the new value for ImageWidth.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ImageSize Class


ImageSize.ChannelsChanged Event

Fired when the Channels is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ChannelsChanged
Public Event ChannelsChanged As EventHandler
public:
 event EventHandler^ ChannelsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ImageSize Class


ImageSize.ChannelsValidating Event

Fired while validating the new value for Channels.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ChannelsValidating
Public Event ChannelsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ChannelsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ImageSize Class


ImageSize.DataSizeChanged Event

Fired when the DataSize is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DataSizeChanged
Public Event DataSizeChanged As EventHandler
public:
 event EventHandler^ DataSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ImageSize Class


ImageSize.DataSizeValidating Event

Fired while validating the new value for DataSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DataSizeValidating
Public Event DataSizeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DataSizeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ImageSize Class


ImageSize.ElementTypeChanged Event

Fired when the ElementType is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ElementTypeChanged
Public Event ElementTypeChanged As EventHandler
public:
 event EventHandler^ ElementTypeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ImageSize Class


ImageSize.ElementTypeValidating Event

Fired while validating the new value for ElementType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ElementTypeValidating
Public Event ElementTypeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ElementTypeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ImageSize Class


ImageSize.ImageHeightChanged Event

Fired when the ImageHeight is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ImageHeightChanged
Public Event ImageHeightChanged As EventHandler
public:
 event EventHandler^ ImageHeightChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ImageSize Class


ImageSize.ImageHeightValidating Event

Fired while validating the new value for ImageHeight.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ImageHeightValidating
Public Event ImageHeightValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ImageHeightValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ImageSize Class


ImageSize.ImageWidthChanged Event

Fired when the ImageWidth is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ImageWidthChanged
Public Event ImageWidthChanged As EventHandler
public:
 event EventHandler^ ImageWidthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ImageSize Class


ImageSize.ImageWidthValidating Event

Fired while validating the new value for ImageWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ImageWidthValidating
Public Event ImageWidthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ImageWidthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ImageSize Class


ImageStreamStyle Class

Class of the Image Marker Style
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelImageStreamStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ImageStreamStyle : ScopeMemberBase
Public Class ImageStreamStyle
    Inherits ScopeMemberBase
public ref class ImageStreamStyle : public ScopeMemberBase

The ImageStreamStyle type exposes the following members.

Constructors
 | Name | Description
Public method | ImageStreamStyle | Creates an instance of the ImageStreamStyle Class
Public method | ImageStreamStyle(ImageStreamStyle) | Creates an instance of the ImageStreamStyle Class
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | MagnifierPictureAmount | Gets or Sets the MagnifierPictureAmount {1, 3, 5}.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Property Attributes in the PropertyPage (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MagnifierPictureAmountChanged | Fired when the MagnifierPictureAmount is changed.
Public event | MagnifierPictureAmountChanging | Fired while changing the MagnifierPictureAmount.
Public event | MagnifierPictureAmountValidating | Fired while validating the new value for MagnifierPictureAmount.
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ImageStreamStyle Constructor

Overload List
 | Name | Description
Public method | ImageStreamStyle | Creates an instance of the ImageStreamStyle Class
Public method | ImageStreamStyle(ImageStreamStyle) | Creates an instance of the ImageStreamStyle Class
Top
See Also

Reference

ImageStreamStyle Class


ImageStreamStyle Constructor

Creates an instance of the ImageStreamStyle Class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ImageStreamStyle()
Public Sub New
public:
ImageStreamStyle()
See Also

Reference

ImageStreamStyle Class
ImageStreamStyle Overload


ImageStreamStyle Constructor (ImageStreamStyle)

Creates an instance of the ImageStreamStyle Class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ImageStreamStyle(
    ImageStreamStyle imageStreamStyle
)
Public Sub New (
    imageStreamStyle As ImageStreamStyle
)
public:
ImageStreamStyle(
    ImageStreamStyle^ imageStreamStyle
)

Parameters

imageStreamStyle
Type: TwinCAT.Measurement.Scope.API.ModelImageStreamStyle
See Also

Reference

ImageStreamStyle Class
ImageStreamStyle Overload


ImageStreamStyle Properties

The ImageStreamStyle type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | MagnifierPictureAmount | Gets or Sets the MagnifierPictureAmount {1, 3, 5}.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ImageStreamStyle Class


ImageStreamStyle.DisplayColor Property

Gets or Sets the DisplayColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public override Color DisplayColor { get; set; }
<BrowsableAttribute(true)>
Public Overrides Property DisplayColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property Color DisplayColor {
    Color get () override;
    void set (Color value) override;
}

Property Value

Type: Color
See Also

Reference

ImageStreamStyle Class


ImageStreamStyle.MagnifierPictureAmount Property

Gets or Sets the MagnifierPictureAmount {1, 3, 5}.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public int MagnifierPictureAmount { get; set; }
<BrowsableAttribute(false)>
Public Property MagnifierPictureAmount As Integer
    Get
    Set
public:
[BrowsableAttribute(false)]
property int MagnifierPictureAmount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ImageStreamStyle Class


ImageStreamStyle Methods

The ImageStreamStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Property Attributes in the PropertyPage (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ImageStreamStyle Class


ImageStreamStyle.UpdatePropertyAttributes Method

Update the Property Attributes in the PropertyPage

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ImageStreamStyle Class


ImageStreamStyle Events

The ImageStreamStyle type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MagnifierPictureAmountChanged | Fired when the MagnifierPictureAmount is changed.
Public event | MagnifierPictureAmountChanging | Fired while changing the MagnifierPictureAmount.
Public event | MagnifierPictureAmountValidating | Fired while validating the new value for MagnifierPictureAmount.
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ImageStreamStyle Class


ImageStreamStyle.MagnifierPictureAmountChanged Event

Fired when the MagnifierPictureAmount is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler MagnifierPictureAmountChanged
Public Event MagnifierPictureAmountChanged As EventHandler
public:
 event EventHandler^ MagnifierPictureAmountChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ImageStreamStyle Class


ImageStreamStyle.MagnifierPictureAmountChanging Event

Fired while changing the MagnifierPictureAmount.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler MagnifierPictureAmountChanging
Public Event MagnifierPictureAmountChanging As EventHandler
public:
 event EventHandler^ MagnifierPictureAmountChanging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ImageStreamStyle Class


ImageStreamStyle.MagnifierPictureAmountValidating Event

Fired while validating the new value for MagnifierPictureAmount.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> MagnifierPictureAmountValidating
Public Event MagnifierPictureAmountValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ MagnifierPictureAmountValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ImageStreamStyle Class


IndexAxis Class

Model class for Index Axis
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAxis
TwinCAT.Measurement.Scope.API.ModelMinMaxRangeAxis
TwinCAT.Measurement.Scope.API.ModelIndexAxis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class IndexAxis : MinMaxRangeAxis
Public Class IndexAxis
    Inherits MinMaxRangeAxis
public ref class IndexAxis : public MinMaxRangeAxis

The IndexAxis type exposes the following members.

Constructors
 | Name | Description
Public method | IndexAxis | Create a new IndexAxis
Public method | IndexAxis(IndexAxis) | Create a new Index Axis by copying Properties from another IndexAxis
Top
Properties
 | Name | Description
Public property | ActualTitle | Gets or Sets the ActualTitle. (Inherited from Axis.)
Public property | AspectRatioScaleFactor | Gets or Sets the AspectRatioScaleFactor. (Inherited from Axis.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetDisplayRange | Get or Set the GetDisplayRange (Inherited from MinMaxRangeAxis.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Inverted | Gets or Sets the Inverted. (Inherited from Axis.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Logarithmic | Gets or Sets the Logarithmic. (Inherited from Axis.)
Public property | ManualMax | Gets or Sets the ManualMax. (Inherited from Axis.)
Public property | ManualMin | Gets or Sets the ManualMin. (Inherited from Axis.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Axis.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScalingMode | Gets or Sets the ScalingMode. (Inherited from Axis.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | (Inherited from Axis.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from Axis.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserSettingsAxisInstance | (Overrides AxisGetUserSettingsAxisInstance.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Axis.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ActualTitleChanged | Fired when the ActualTitle is changed. (Inherited from Axis.)
Public event | ActualTitleValidating | Fired while validating the new value for ActualTitle. (Inherited from Axis.)
Public event | AspectRatioScaleFactorChanged | Fired when the AspectRatioScaleFactor is changed. (Inherited from Axis.)
Public event | AspectRatioScaleFactorValidating | Fired while validating the new value for AspectRatioScaleFactor. (Inherited from Axis.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DefaultRescale | Fired if the axis should rescale to default values (Inherited from Axis.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InvertedChanged | Fired when the Inverted is changed. (Inherited from Axis.)
Public event | InvertedValidating | Fired while validating the new value for Inverted. (Inherited from Axis.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LogarithmicChanged | Fired when the Logarithmic is changed. (Inherited from Axis.)
Public event | LogarithmicValidating | Fired while validating the new value for Logarithmic. (Inherited from Axis.)
Public event | ManualMaxChanged | Fired when the ManualMax is changed. (Inherited from Axis.)
Public event | ManualMaxValidating | Fired while validating the new value for ManualMax. (Inherited from Axis.)
Public event | ManualMinChanged | Fired when the ManualMin is changed. (Inherited from Axis.)
Public event | ManualMinValidating | Fired while validating the new value for ManualMin. (Inherited from Axis.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Axis.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Axis.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScalingModeChanged | Fired when the ScalingMode is changed. (Inherited from Axis.)
Public event | ScalingModeValidating | Fired while validating the new value for ScalingMode. (Inherited from Axis.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


IndexAxis Constructor

Overload List
 | Name | Description
Public method | IndexAxis | Create a new IndexAxis
Public method | IndexAxis(IndexAxis) | Create a new Index Axis by copying Properties from another IndexAxis
Top
See Also

Reference

IndexAxis Class


IndexAxis Constructor

Create a new IndexAxis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IndexAxis()
Public Sub New
public:
IndexAxis()
See Also

Reference

IndexAxis Class
IndexAxis Overload


IndexAxis Constructor (IndexAxis)

Create a new Index Axis by copying Properties from another IndexAxis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IndexAxis(
    IndexAxis Axis
)
Public Sub New (
    Axis As IndexAxis
)
public:
IndexAxis(
    IndexAxis^ Axis
)

Parameters

Axis
Type: TwinCAT.Measurement.Scope.API.ModelIndexAxis
Index Axis to copy from
See Also

Reference

IndexAxis Class
IndexAxis Overload


IndexAxis Properties

The IndexAxis type exposes the following members.

Properties
 | Name | Description
Public property | ActualTitle | Gets or Sets the ActualTitle. (Inherited from Axis.)
Public property | AspectRatioScaleFactor | Gets or Sets the AspectRatioScaleFactor. (Inherited from Axis.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetDisplayRange | Get or Set the GetDisplayRange (Inherited from MinMaxRangeAxis.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Inverted | Gets or Sets the Inverted. (Inherited from Axis.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Logarithmic | Gets or Sets the Logarithmic. (Inherited from Axis.)
Public property | ManualMax | Gets or Sets the ManualMax. (Inherited from Axis.)
Public property | ManualMin | Gets or Sets the ManualMin. (Inherited from Axis.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Axis.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScalingMode | Gets or Sets the ScalingMode. (Inherited from Axis.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | (Inherited from Axis.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from Axis.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

IndexAxis Class


IndexAxis Methods

The IndexAxis type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserSettingsAxisInstance | (Overrides AxisGetUserSettingsAxisInstance.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Axis.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

IndexAxis Class


IndexAxis.GetUserSettingsAxisInstance Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override Axis GetUserSettingsAxisInstance()
Public Overrides Function GetUserSettingsAxisInstance As Axis
public:
virtual Axis^ GetUserSettingsAxisInstance() override

Return Value

Type: Axis
See Also

Reference

IndexAxis Class


IndexAxis Events

The IndexAxis type exposes the following members.

Events
 | Name | Description
Public event | ActualTitleChanged | Fired when the ActualTitle is changed. (Inherited from Axis.)
Public event | ActualTitleValidating | Fired while validating the new value for ActualTitle. (Inherited from Axis.)
Public event | AspectRatioScaleFactorChanged | Fired when the AspectRatioScaleFactor is changed. (Inherited from Axis.)
Public event | AspectRatioScaleFactorValidating | Fired while validating the new value for AspectRatioScaleFactor. (Inherited from Axis.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DefaultRescale | Fired if the axis should rescale to default values (Inherited from Axis.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InvertedChanged | Fired when the Inverted is changed. (Inherited from Axis.)
Public event | InvertedValidating | Fired while validating the new value for Inverted. (Inherited from Axis.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LogarithmicChanged | Fired when the Logarithmic is changed. (Inherited from Axis.)
Public event | LogarithmicValidating | Fired while validating the new value for Logarithmic. (Inherited from Axis.)
Public event | ManualMaxChanged | Fired when the ManualMax is changed. (Inherited from Axis.)
Public event | ManualMaxValidating | Fired while validating the new value for ManualMax. (Inherited from Axis.)
Public event | ManualMinChanged | Fired when the ManualMin is changed. (Inherited from Axis.)
Public event | ManualMinValidating | Fired while validating the new value for ManualMin. (Inherited from Axis.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Axis.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Axis.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScalingModeChanged | Fired when the ScalingMode is changed. (Inherited from Axis.)
Public event | ScalingModeValidating | Fired while validating the new value for ScalingMode. (Inherited from Axis.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

IndexAxis Class


IndexScaling Class

Class defining Scaling Properties for Index value of ArrayBar Chart
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelIndexScaling

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class IndexScaling : ScopeMemberBase
Public Class IndexScaling
    Inherits ScopeMemberBase
public ref class IndexScaling : public ScopeMemberBase

The IndexScaling type exposes the following members.

Constructors
 | Name | Description
Public method | IndexScaling | Create a new IndexScaling
Public method | IndexScaling(IndexScaling) | Create a new IndexScaling by copying Properties
Top
Properties
 | Name | Description
Public property | ArrayIndiecees | Gets the ArrayIndicees for this Index Orientation
Public property | ArrayLength |
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | MaxIndex | Get or Set the Max Index
Public property | MinIndex | Get or Set the MinIndex
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Offset | Gets or Sets the Offset.
Public property | Orientation | Gets or Sets the Orientation.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScaleFactor | Gets or Sets the ScaleFactor.
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of the Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OffsetChanged | Fired when the Offset is changed.
Public event | OffsetValidating | Fired while validating the new value for Offset.
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed.
Public event | OrientationValidating | Fired while validating the new value for Orientation.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScaleFactorChanged | Fired when the ScaleFactor is changed.
Public event | ScaleFactorValidating | Fired while validating the new value for ScaleFactor.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


IndexScaling Constructor

Overload List
 | Name | Description
Public method | IndexScaling | Create a new IndexScaling
Public method | IndexScaling(IndexScaling) | Create a new IndexScaling by copying Properties
Top
See Also

Reference

IndexScaling Class


IndexScaling Constructor

Create a new IndexScaling

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IndexScaling()
Public Sub New
public:
IndexScaling()
See Also

Reference

IndexScaling Class
IndexScaling Overload


IndexScaling Constructor (IndexScaling)

Create a new IndexScaling by copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IndexScaling(
    IndexScaling org
)
Public Sub New (
    org As IndexScaling
)
public:
IndexScaling(
    IndexScaling^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelIndexScaling
IndexScaling to copy from
See Also

Reference

IndexScaling Class
IndexScaling Overload


IndexScaling Properties

The IndexScaling type exposes the following members.

Properties
 | Name | Description
Public property | ArrayIndiecees | Gets the ArrayIndicees for this Index Orientation
Public property | ArrayLength |
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | MaxIndex | Get or Set the Max Index
Public property | MinIndex | Get or Set the MinIndex
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Offset | Gets or Sets the Offset.
Public property | Orientation | Gets or Sets the Orientation.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScaleFactor | Gets or Sets the ScaleFactor.
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

IndexScaling Class


IndexScaling.ArrayIndiecees Property

Gets the ArrayIndicees for this Index Orientation

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public long[] ArrayIndiecees { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property ArrayIndiecees As Long()
    Get
public:
[BrowsableAttribute(false)]
property array<long long>^ ArrayIndiecees {
    array<long long>^ get ();
}

Property Value

Type: Int64
See Also

Reference

IndexScaling Class


IndexScaling.ArrayLength Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public int ArrayLength { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property ArrayLength As Integer
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property int ArrayLength {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IndexScaling Class


IndexScaling.MaxIndex Property

Get or Set the Max Index

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public double MaxIndex { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property MaxIndex As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property double MaxIndex {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IndexScaling Class


IndexScaling.MinIndex Property

Get or Set the MinIndex

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public double MinIndex { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property MinIndex As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property double MinIndex {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IndexScaling Class


IndexScaling.Offset Property

Gets or Sets the Offset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double Offset { get; set; }
<BrowsableAttribute(true)>
Public Property Offset As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double Offset {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IndexScaling Class


IndexScaling.Orientation Property

Gets or Sets the Orientation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public AxisOrientation Orientation { get; set; }
<BrowsableAttribute(false)>
Public Property Orientation As AxisOrientation
    Get
    Set
public:
[BrowsableAttribute(false)]
property AxisOrientation Orientation {
    AxisOrientation get ();
    void set (AxisOrientation value);
}

Property Value

Type: AxisOrientation
See Also

Reference

IndexScaling Class


IndexScaling.ScaleFactor Property

Gets or Sets the ScaleFactor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double ScaleFactor { get; set; }
<BrowsableAttribute(true)>
Public Property ScaleFactor As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double ScaleFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IndexScaling Class


IndexScaling Methods

The IndexScaling type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of the Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

IndexScaling Class


IndexScaling.UpdatePropertyAttributes Method

Update Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

IndexScaling Class


IndexScaling Events

The IndexScaling type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OffsetChanged | Fired when the Offset is changed.
Public event | OffsetValidating | Fired while validating the new value for Offset.
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed.
Public event | OrientationValidating | Fired while validating the new value for Orientation.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScaleFactorChanged | Fired when the ScaleFactor is changed.
Public event | ScaleFactorValidating | Fired while validating the new value for ScaleFactor.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

IndexScaling Class


IndexScaling.OffsetChanged Event

Fired when the Offset is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OffsetChanged
Public Event OffsetChanged As EventHandler
public:
 event EventHandler^ OffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IndexScaling Class


IndexScaling.OffsetValidating Event

Fired while validating the new value for Offset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> OffsetValidating
Public Event OffsetValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ OffsetValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IndexScaling Class


IndexScaling.OrientationChanged Event

Fired when the Orientation is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OrientationChanged
Public Event OrientationChanged As EventHandler
public:
 event EventHandler^ OrientationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IndexScaling Class


IndexScaling.OrientationValidating Event

Fired while validating the new value for Orientation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> OrientationValidating
Public Event OrientationValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ OrientationValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IndexScaling Class


IndexScaling.ScaleFactorChanged Event

Fired when the ScaleFactor is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ScaleFactorChanged
Public Event ScaleFactorChanged As EventHandler
public:
 event EventHandler^ ScaleFactorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IndexScaling Class


IndexScaling.ScaleFactorValidating Event

Fired while validating the new value for ScaleFactor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ScaleFactorValidating
Public Event ScaleFactorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ScaleFactorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IndexScaling Class


InteractionShape Class

Shape class for interactive items in charting. The shape form and size is based on the interaction, only the center point can be set.
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeShape
TwinCAT.Measurement.Scope.API.ModelInteractionShape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class InteractionShape : ScopeShape
Public Class InteractionShape
    Inherits ScopeShape
public ref class InteractionShape : public ScopeShape

The InteractionShape type exposes the following members.

Constructors
 | Name | Description
Public method | InteractionShape | Creates a new InteractionShape
Public method | InteractionShape(InteractionShape) | Initializes a new InteractionShape with properties copied from another shape.
Top
Properties
 | Name | Description
Public property | Center | Gets the Center of the shape. Set the X or Y Properties to set the center.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from ScopeShape.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Interaction | Gets or Sets the Interaction.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShapePoints | Gets the ShapePoints. Contains the center point in the first index. (Overrides ScopeShapeShapePoints.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | Gets a underlying Style Object (Inherited from ScopeShape.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | Highlight the Shape (Inherited from ScopeShape.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | Save | Saves this Shape to a file (Inherited from ScopeShape.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Property Attributes in the PropertyPage (Inherited from ScopeShape.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | Hightlight | Raise to highlight the shape (Inherited from ScopeShape.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InteractionChanged | Fired when the Interaction is changed.
Public event | InteractionValidating | Fired while validating the new value for Interaction.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPoints | Raise to refresh the points in the view (Inherited from ScopeShape.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


InteractionShape Constructor

Overload List
 | Name | Description
Public method | InteractionShape | Creates a new InteractionShape
Public method | InteractionShape(InteractionShape) | Initializes a new InteractionShape with properties copied from another shape.
Top
See Also

Reference

InteractionShape Class


InteractionShape Constructor

Creates a new InteractionShape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public InteractionShape()
Public Sub New
public:
InteractionShape()
See Also

Reference

InteractionShape Class
InteractionShape Overload


InteractionShape Constructor (InteractionShape)

Initializes a new InteractionShape with properties copied from another shape.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public InteractionShape(
    InteractionShape shape
)
Public Sub New (
    shape As InteractionShape
)
public:
InteractionShape(
    InteractionShape^ shape
)

Parameters

shape
Type: TwinCAT.Measurement.Scope.API.ModelInteractionShape
Shape to copy from.
See Also

Reference

InteractionShape Class
InteractionShape Overload


InteractionShape Properties

The InteractionShape type exposes the following members.

Properties
 | Name | Description
Public property | Center | Gets the Center of the shape. Set the X or Y Properties to set the center.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from ScopeShape.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Interaction | Gets or Sets the Interaction.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShapePoints | Gets the ShapePoints. Contains the center point in the first index. (Overrides ScopeShapeShapePoints.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | Gets a underlying Style Object (Inherited from ScopeShape.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

InteractionShape Class


InteractionShape.Center Property

Gets the Center of the shape. Set the X or Y Properties to set the center.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ShapeXYPoint Center { get; }
Public ReadOnly Property Center As ShapeXYPoint
    Get
public:
property ShapeXYPoint^ Center {
    ShapeXYPoint^ get ();
}

Property Value

Type: ShapeXYPoint
See Also

Reference

InteractionShape Class


InteractionShape.Interaction Property

Gets or Sets the Interaction.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public InteractionTypes Interaction { get; set; }
Public Property Interaction As InteractionTypes
    Get
    Set
public:
property InteractionTypes Interaction {
    InteractionTypes get ();
    void set (InteractionTypes value);
}

Property Value

Type: InteractionTypes
See Also

Reference

InteractionShape Class


InteractionShape.ShapePoints Property

Gets the ShapePoints. Contains the center point in the first index.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override ReadOnlyCollection<double[]> ShapePoints { get; }
Public Overrides ReadOnly Property ShapePoints As ReadOnlyCollection(Of Double())
    Get
public:
virtual property ReadOnlyCollection<array<double>^>^ ShapePoints {
    ReadOnlyCollection<array<double>^>^ get () override;
}

Property Value

Type: ReadOnlyCollection Double
See Also

Reference

InteractionShape Class


InteractionShape Methods

The InteractionShape type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | Highlight the Shape (Inherited from ScopeShape.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | Save | Saves this Shape to a file (Inherited from ScopeShape.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Property Attributes in the PropertyPage (Inherited from ScopeShape.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

InteractionShape Class


InteractionShape Events

The InteractionShape type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | Hightlight | Raise to highlight the shape (Inherited from ScopeShape.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InteractionChanged | Fired when the Interaction is changed.
Public event | InteractionValidating | Fired while validating the new value for Interaction.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPoints | Raise to refresh the points in the view (Inherited from ScopeShape.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

InteractionShape Class


InteractionShape.InteractionChanged Event

Fired when the Interaction is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler InteractionChanged
Public Event InteractionChanged As EventHandler
public:
 event EventHandler^ InteractionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

InteractionShape Class


InteractionShape.InteractionValidating Event

Fired while validating the new value for Interaction.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> InteractionValidating
Public Event InteractionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ InteractionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

InteractionShape Class


IotFileAcquisition Class

Acquisition to order data from IotFile
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisition
TwinCAT.Measurement.Scope.API.ModelHistoricalAcquisition
TwinCAT.Measurement.Scope.API.ModelIotFileAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class IotFileAcquisition : HistoricalAcquisition
Public Class IotFileAcquisition
    Inherits HistoricalAcquisition
public ref class IotFileAcquisition : public HistoricalAcquisition

The IotFileAcquisition type exposes the following members.

Constructors
 | Name | Description
Public method | IotFileAcquisition | Create a new empty IotFileAcquisition
Public method | IotFileAcquisition(IotFileAcquisition) | Create a new IotFileAcquisition and Copy Properties from another one
Top
Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName. (Overrides AcquisitionDescription.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | Path | Gets or Sets the Path.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | Records | Gets or Sets the Records. (Overrides HistoricalAcquisitionRecords.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | TimeRangeId | Gets or Sets the TimeRangeId. (Overrides HistoricalAcquisitionTimeRangeId.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UpdateOtherAcq | If this property is true all other Acquisitions with the same Target get updated without a question. (Inherited from HistoricalAcquisition.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | ValueByteOffset | Gets or Sets the ValueByteOffset.
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Overrides AcquisitionGetFullName.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AcquisitionGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides HistoricalAcquisitionHasSameTarget(Acquisition).)
Public method | HasSameTargetExceptRecords | Determines wether the two Acquisition will acquire the same Data (Overrides HistoricalAcquisitionHasSameTargetExceptRecords(HistoricalAcquisition).)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateDataAccessTimes | Sets the time property of the DataAccess based on the Records. (Inherited from HistoricalAcquisition.)
Public method | UpdatePropertyAttributes | Updates the Attributes of alle Properties (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | PathChanged | Fired when the Path is changed.
Public event | PathValidating | Fired while validating the new value for Path.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RecordsChanged | Fired when the Records is changed. (Inherited from HistoricalAcquisition.)
Public event | RecordsValidating | Fired while validating the new value for Records. (Inherited from HistoricalAcquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TimeRangeIdChanged | Fired when the TimeRangeId is changed. (Inherited from HistoricalAcquisition.)
Public event | TimeRangeIdValidating | Fired while validating the new value for TimeRangeId. (Inherited from HistoricalAcquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateOtherAcqChanged | Fired when the UpdateOtherAcq is changed. (Inherited from HistoricalAcquisition.)
Public event | UpdateOtherAcqValidating | Fired while validating the new value for UpdateOtherAcq. (Inherited from HistoricalAcquisition.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | ValueByteOffsetChanged | Fired when the ValueByteOffset is changed.
Public event | ValueByteOffsetValidating | Fired while validating the new value for ValueByteOffset.
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


IotFileAcquisition Constructor

Overload List
 | Name | Description
Public method | IotFileAcquisition | Create a new empty IotFileAcquisition
Public method | IotFileAcquisition(IotFileAcquisition) | Create a new IotFileAcquisition and Copy Properties from another one
Top
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition Constructor

Create a new empty IotFileAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IotFileAcquisition()
Public Sub New
public:
IotFileAcquisition()
See Also

Reference

IotFileAcquisition Class
IotFileAcquisition Overload


IotFileAcquisition Constructor (IotFileAcquisition)

Create a new IotFileAcquisition and Copy Properties from another one

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IotFileAcquisition(
    IotFileAcquisition iotFileAcq
)
Public Sub New (
    iotFileAcq As IotFileAcquisition
)
public:
IotFileAcquisition(
    IotFileAcquisition^ iotFileAcq
)

Parameters

iotFileAcq
Type: TwinCAT.Measurement.Scope.API.ModelIotFileAcquisition
See Also

Reference

IotFileAcquisition Class
IotFileAcquisition Overload


IotFileAcquisition Properties

The IotFileAcquisition type exposes the following members.

Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName. (Overrides AcquisitionDescription.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | Path | Gets or Sets the Path.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | Records | Gets or Sets the Records. (Overrides HistoricalAcquisitionRecords.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | TimeRangeId | Gets or Sets the TimeRangeId. (Overrides HistoricalAcquisitionTimeRangeId.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UpdateOtherAcq | If this property is true all other Acquisitions with the same Target get updated without a question. (Inherited from HistoricalAcquisition.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | ValueByteOffset | Gets or Sets the ValueByteOffset.
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.Description Property

A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override ChannelDescription Description { get; }
Public Overrides ReadOnly Property Description As ChannelDescription
    Get
public:
virtual property ChannelDescription^ Description {
    ChannelDescription^ get () override;
}

Property Value

Type: ChannelDescription
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.Path Property

Gets or Sets the Path.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.Records Property

Gets or Sets the Records.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override RecordsContainer Records { get; set; }
Public Overrides Property Records As RecordsContainer
    Get
    Set
public:
virtual property RecordsContainer^ Records {
    RecordsContainer^ get () override;
    void set (RecordsContainer^ value) override;
}

Property Value

Type: RecordsContainer
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.SymbolName Property

Gets or Sets the SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string SymbolName { get; set; }
Public Property SymbolName As String
    Get
    Set
public:
property String^ SymbolName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.TimeRangeId Property

Gets or Sets the TimeRangeId.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override ulong TimeRangeId { get; set; }
Public Overrides Property TimeRangeId As ULong
    Get
    Set
public:
virtual property unsigned long long TimeRangeId {
    unsigned long long get () override;
    void set (unsigned long long value) override;
}

Property Value

Type: UInt64
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.ValueByteOffset Property

Gets or Sets the ValueByteOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public uint ValueByteOffset { get; set; }
Public Property ValueByteOffset As UInteger
    Get
    Set
public:
property unsigned int ValueByteOffset {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition Methods

The IotFileAcquisition type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Overrides AcquisitionGetFullName.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AcquisitionGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides HistoricalAcquisitionHasSameTarget(Acquisition).)
Public method | HasSameTargetExceptRecords | Determines wether the two Acquisition will acquire the same Data (Overrides HistoricalAcquisitionHasSameTargetExceptRecords(HistoricalAcquisition).)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateDataAccessTimes | Sets the time property of the DataAccess based on the Records. (Inherited from HistoricalAcquisition.)
Public method | UpdatePropertyAttributes | Updates the Attributes of alle Properties (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.GetFullName Method

Gets the complete identifier of this acqusition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string GetFullName()
Public Overrides Function GetFullName As String
public:
virtual String^ GetFullName() override

Return Value

Type: String
The full name
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.GetHashCode Method

Serves as a hash function for a particular type.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.HasSameTarget Method

Determines wether the two Acquisition will acquire the same Data

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool HasSameTarget(
    Acquisition Acquisition
)
Public Overrides Function HasSameTarget (
    Acquisition As Acquisition
) As Boolean
public:
virtual bool HasSameTarget(
    Acquisition^ Acquisition
) override

Parameters

Acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
The Acquisition to compare with

Return Value

Type: Boolean
True if the Acquisitions have the Same Target
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.HasSameTargetExceptRecords Method

Determines wether the two Acquisition will acquire the same Data

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool HasSameTargetExceptRecords(
    HistoricalAcquisition Acquisition
)
Public Overrides Function HasSameTargetExceptRecords (
    Acquisition As HistoricalAcquisition
) As Boolean
public:
virtual bool HasSameTargetExceptRecords(
    HistoricalAcquisition^ Acquisition
) override

Parameters

Acquisition
Type: TwinCAT.Measurement.Scope.API.ModelHistoricalAcquisition
The Acquisition to compare with

Return Value

Type: Boolean
True if the Acquisitions have the Same Target
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.UpdatePropertyAttributes Method

Updates the Attributes of alle Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition Events

The IotFileAcquisition type exposes the following members.

Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | PathChanged | Fired when the Path is changed.
Public event | PathValidating | Fired while validating the new value for Path.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RecordsChanged | Fired when the Records is changed. (Inherited from HistoricalAcquisition.)
Public event | RecordsValidating | Fired while validating the new value for Records. (Inherited from HistoricalAcquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TimeRangeIdChanged | Fired when the TimeRangeId is changed. (Inherited from HistoricalAcquisition.)
Public event | TimeRangeIdValidating | Fired while validating the new value for TimeRangeId. (Inherited from HistoricalAcquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateOtherAcqChanged | Fired when the UpdateOtherAcq is changed. (Inherited from HistoricalAcquisition.)
Public event | UpdateOtherAcqValidating | Fired while validating the new value for UpdateOtherAcq. (Inherited from HistoricalAcquisition.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | ValueByteOffsetChanged | Fired when the ValueByteOffset is changed.
Public event | ValueByteOffsetValidating | Fired while validating the new value for ValueByteOffset.
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.PathChanged Event

Fired when the Path is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PathChanged
Public Event PathChanged As EventHandler
public:
 event EventHandler^ PathChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.PathValidating Event

Fired while validating the new value for Path.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PathValidating
Public Event PathValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PathValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.SymbolNameChanged Event

Fired when the SymbolName is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SymbolNameChanged
Public Event SymbolNameChanged As EventHandler
public:
 event EventHandler^ SymbolNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.SymbolNameValidating Event

Fired while validating the new value for SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SymbolNameValidating
Public Event SymbolNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SymbolNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.ValueByteOffsetChanged Event

Fired when the ValueByteOffset is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ValueByteOffsetChanged
Public Event ValueByteOffsetChanged As EventHandler
public:
 event EventHandler^ ValueByteOffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition.ValueByteOffsetValidating Event

Fired while validating the new value for ValueByteOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ValueByteOffsetValidating
Public Event ValueByteOffsetValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ValueByteOffsetValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IotFileAcquisition Class


IotFileAcquisition Fields

The IotFileAcquisition type exposes the following members.

Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

IotFileAcquisition Class


IotFileSequence Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisition
TwinCAT.Measurement.Scope.API.ModelSequence
TwinCAT.Measurement.Scope.API.ModelIotFileSequence

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class IotFileSequence : Sequence
Public Class IotFileSequence
    Inherits Sequence
public ref class IotFileSequence : public Sequence

The IotFileSequence type exposes the following members.

Constructors
 | Name | Description
Public method | IotFileSequence | Initializes a new instance of the IotFileSequence class
Public method | IotFileSequence(IotFileSequence) | Initializes a new instance of the IotFileSequence class
Top
Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | Data | Gets the Data of this acquisition. (Inherited from Sequence.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataFilePath | Gets or Sets the DataFilePath. (Inherited from Sequence.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | (Inherited from Sequence.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | ExportOptions | Gets or Sets the ExportOptions. (Inherited from Sequence.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LastEndTime | Gets or Sets the LastEndTime.
Public property | LastStartTime | Gets or Sets the LastStartTime.
Public property | LocalData | Gets or Sets the LocalData. If true the Data will be saved in its own analytics file, otherwise the data will be loaded from the RefFilePath.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | RefFilePath | Gets or Sets the RefFilePath.
Public property | SampleCount | Gets or Sets the SampleCount. (Inherited from Sequence.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
Methods
 | Name | Description
Public method | AddData | Adds a list of samples to the end. (Inherited from Sequence.)
Public method | AddFromTimeRange | Adds all data of the referenced record to this acquisition.
Public method | AddFromTimeRange(Int64, Int64) | Orders samples from the reference and adds them to this acquistion.
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CopyData | (Overrides SequenceCopyData(Sequence).)
Public method | DeleteDataFiles | Deletes the data file(s) at the DataFilePath. (Overrides SequenceDeleteDataFiles.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportToAlyFile | (Inherited from Sequence.)
Public method | ExtendDataEnd | Adds samples to the end. (Overrides SequenceExtendDataEnd(Int64).)
Public method | ExtendDataEndTimeStamp | Orders samples from the reference and adds them to the end.
Public method | ExtendDataStart | Adds samples at the start. (Overrides SequenceExtendDataStart(Int64).)
Public method | ExtendDataStartTimeStamp | Orders samples from the reference and adds them to the start.
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllFileInfos | Get all files which are used in this sequence (Inherited from Sequence.)
Public method | GetAllFilePathes | Get all files which are used in this sequence (Inherited from Sequence.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAlyFilePath | (Overrides SequenceGetAlyFilePath(Boolean).)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | (Inherited from Sequence.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Inherited from Acquisition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Acquisition.)
Public method | GetIotType | (Inherited from Sequence.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTasPath | (Inherited from Sequence.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Get the data from the timestamp First Value = Timestamp == 0 (Inherited from Sequence.)
Public method | GetValueConverter | (Inherited from Sequence.)
Public method | HasSameTarget | (Inherited from Sequence.)
Public method | Import(IotFileSequenceData) | (Inherited from Sequence.)
Public method | Import(RefAcquisitionSequenceData) | (Inherited from Sequence.)
Public method | Import(SequenceDataSource) | (Inherited from Sequence.)
Public method | InsertData | Inserts a list of data at the given index. (Inherited from Sequence.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | LoadData | (Overrides SequenceLoadData.)
Public method | LoadData(String) | (Inherited from Sequence.)
Public method | MaxEndIndex | Gets the largest possible end index relative to the current end. (Overrides SequenceMaxEndIndex.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MinStartIndex | Gets the smallest possible start index relative to the current start. (Overrides SequenceMinStartIndex.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | NewDataAlyFilePath | (Inherited from Sequence.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ReplaceData | Replaces a part of the data. (Inherited from Sequence.)
Public method | SaveData | Saves the data to the DataFilePath. The data is stored in the aly file format. (Overrides SequenceSaveData.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | (Overrides SequenceToString.)
Public method | TrimData | Removes data from the acquisition. (Inherited from Sequence.)
Public method | TrimDataEnd | Removes samples at the end. (Overrides SequenceTrimDataEnd(Int64).)
Public method | TrimDataStart | Removes samples from the start. (Overrides SequenceTrimDataStart(Int64).)
Public method | UpdatePropertyAttributes | (Inherited from Sequence.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | (Inherited from Sequence.)
Top
Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataFilePathChanged | Fired when the DataFilePath is changed. (Inherited from Sequence.)
Public event | DataFilePathValidating | Fired while validating the new value for DataFilePath. (Inherited from Sequence.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DataUpdated | Raised when data is added to Data. (Inherited from Sequence.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | ExportOptionsChanged | Fired when the ExportOptions is changed. (Inherited from Sequence.)
Public event | ExportOptionsValidating | Fired while validating the new value for ExportOptions. (Inherited from Sequence.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | LastEndTimeChanged | Fired when the LastEndTime is changed.
Public event | LastEndTimeValidating | Fired while validating the new value for LastEndTime.
Public event | LastStartTimeChanged | Fired when the LastStartTime is changed.
Public event | LastStartTimeValidating | Fired while validating the new value for LastStartTime.
Public event | LocalDataChanged | Fired when the LocalData is changed.
Public event | LocalDataValidating | Fired while validating the new value for LocalData.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RefFilePathChanged | Fired when the RefFilePath is changed.
Public event | RefFilePathValidating | Fired while validating the new value for RefFilePath.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SampleCountChanged | Fired when the SampleCount is changed. (Inherited from Sequence.)
Public event | SampleCountValidating | Fired while validating the new value for SampleCount. (Inherited from Sequence.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


IotFileSequence Constructor

Overload List
 | Name | Description
Public method | IotFileSequence | Initializes a new instance of the IotFileSequence class
Public method | IotFileSequence(IotFileSequence) | Initializes a new instance of the IotFileSequence class
Top
See Also

Reference

IotFileSequence Class


IotFileSequence Constructor

Initializes a new instance of the IotFileSequence class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IotFileSequence()
Public Sub New
public:
IotFileSequence()
See Also

Reference

IotFileSequence Class
IotFileSequence Overload


IotFileSequence Constructor (IotFileSequence)

Initializes a new instance of the IotFileSequence class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IotFileSequence(
    IotFileSequence iotSequence
)
Public Sub New (
    iotSequence As IotFileSequence
)
public:
IotFileSequence(
    IotFileSequence^ iotSequence
)

Parameters

iotSequence
Type: TwinCAT.Measurement.Scope.API.ModelIotFileSequence
See Also

Reference

IotFileSequence Class
IotFileSequence Overload


IotFileSequence Properties

The IotFileSequence type exposes the following members.

Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | Data | Gets the Data of this acquisition. (Inherited from Sequence.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataFilePath | Gets or Sets the DataFilePath. (Inherited from Sequence.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | (Inherited from Sequence.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | ExportOptions | Gets or Sets the ExportOptions. (Inherited from Sequence.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LastEndTime | Gets or Sets the LastEndTime.
Public property | LastStartTime | Gets or Sets the LastStartTime.
Public property | LocalData | Gets or Sets the LocalData. If true the Data will be saved in its own analytics file, otherwise the data will be loaded from the RefFilePath.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | RefFilePath | Gets or Sets the RefFilePath.
Public property | SampleCount | Gets or Sets the SampleCount. (Inherited from Sequence.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

IotFileSequence Class


IotFileSequence.LastEndTime Property

Gets or Sets the LastEndTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public long LastEndTime { get; set; }
<BrowsableAttribute(false)>
Public Property LastEndTime As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
property long long LastEndTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

IotFileSequence Class


IotFileSequence.LastStartTime Property

Gets or Sets the LastStartTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public long LastStartTime { get; set; }
<BrowsableAttribute(false)>
Public Property LastStartTime As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
property long long LastStartTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

IotFileSequence Class


IotFileSequence.LocalData Property

Gets or Sets the LocalData. If true the Data will be saved in its own analytics file, otherwise the data will be loaded from the RefFilePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool LocalData { get; set; }
<BrowsableAttribute(true)>
Public Property LocalData As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool LocalData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IotFileSequence Class


IotFileSequence.RefFilePath Property

Gets or Sets the RefFilePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string RefFilePath { get; set; }
<BrowsableAttribute(true)>
Public Property RefFilePath As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ RefFilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IotFileSequence Class


IotFileSequence.SymbolName Property

Gets or Sets the SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string SymbolName { get; set; }
<BrowsableAttribute(true)>
Public Property SymbolName As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ SymbolName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IotFileSequence Class


IotFileSequence Methods

The IotFileSequence type exposes the following members.

Methods
 | Name | Description
Public method | AddData | Adds a list of samples to the end. (Inherited from Sequence.)
Public method | AddFromTimeRange | Adds all data of the referenced record to this acquisition.
Public method | AddFromTimeRange(Int64, Int64) | Orders samples from the reference and adds them to this acquistion.
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CopyData | (Overrides SequenceCopyData(Sequence).)
Public method | DeleteDataFiles | Deletes the data file(s) at the DataFilePath. (Overrides SequenceDeleteDataFiles.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportToAlyFile | (Inherited from Sequence.)
Public method | ExtendDataEnd | Adds samples to the end. (Overrides SequenceExtendDataEnd(Int64).)
Public method | ExtendDataEndTimeStamp | Orders samples from the reference and adds them to the end.
Public method | ExtendDataStart | Adds samples at the start. (Overrides SequenceExtendDataStart(Int64).)
Public method | ExtendDataStartTimeStamp | Orders samples from the reference and adds them to the start.
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllFileInfos | Get all files which are used in this sequence (Inherited from Sequence.)
Public method | GetAllFilePathes | Get all files which are used in this sequence (Inherited from Sequence.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAlyFilePath | (Overrides SequenceGetAlyFilePath(Boolean).)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | (Inherited from Sequence.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Inherited from Acquisition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Acquisition.)
Public method | GetIotType | (Inherited from Sequence.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTasPath | (Inherited from Sequence.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Get the data from the timestamp First Value = Timestamp == 0 (Inherited from Sequence.)
Public method | GetValueConverter | (Inherited from Sequence.)
Public method | HasSameTarget | (Inherited from Sequence.)
Public method | Import(IotFileSequenceData) | (Inherited from Sequence.)
Public method | Import(RefAcquisitionSequenceData) | (Inherited from Sequence.)
Public method | Import(SequenceDataSource) | (Inherited from Sequence.)
Public method | InsertData | Inserts a list of data at the given index. (Inherited from Sequence.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | LoadData | (Overrides SequenceLoadData.)
Public method | LoadData(String) | (Inherited from Sequence.)
Public method | MaxEndIndex | Gets the largest possible end index relative to the current end. (Overrides SequenceMaxEndIndex.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MinStartIndex | Gets the smallest possible start index relative to the current start. (Overrides SequenceMinStartIndex.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | NewDataAlyFilePath | (Inherited from Sequence.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ReplaceData | Replaces a part of the data. (Inherited from Sequence.)
Public method | SaveData | Saves the data to the DataFilePath. The data is stored in the aly file format. (Overrides SequenceSaveData.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | (Overrides SequenceToString.)
Public method | TrimData | Removes data from the acquisition. (Inherited from Sequence.)
Public method | TrimDataEnd | Removes samples at the end. (Overrides SequenceTrimDataEnd(Int64).)
Public method | TrimDataStart | Removes samples from the start. (Overrides SequenceTrimDataStart(Int64).)
Public method | UpdatePropertyAttributes | (Inherited from Sequence.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | (Inherited from Sequence.)
Top
See Also

Reference

IotFileSequence Class


IotFileSequence.AddFromTimeRange Method

Overload List
 | Name | Description
Public method | AddFromTimeRange | Adds all data of the referenced record to this acquisition.
Public method | AddFromTimeRange(Int64, Int64) | Orders samples from the reference and adds them to this acquistion.
Top
See Also

Reference

IotFileSequence Class


IotFileSequence.AddFromTimeRange Method

Adds all data of the referenced record to this acquisition.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void AddFromTimeRange()
Public Sub AddFromTimeRange
public:
void AddFromTimeRange()
See Also

Reference

IotFileSequence Class
AddFromTimeRange Overload


IotFileSequence.AddFromTimeRange Method (Int64, Int64)

Orders samples from the reference and adds them to this acquistion.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void AddFromTimeRange(
    long start,
    long end
)
Public Sub AddFromTimeRange (
    start As Long,
    end As Long
)
public:
void AddFromTimeRange(
    long long start,
    long long end
)

Parameters

start
Type: SystemInt64
Ordrer start timestamp.
end
Type: SystemInt64
Order end timestamp.
See Also

Reference

IotFileSequence Class
AddFromTimeRange Overload


IotFileSequence.CopyData Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void CopyData(
    Sequence acquisition
)
Public Overrides Sub CopyData (
    acquisition As Sequence
)
public:
virtual void CopyData(
    Sequence^ acquisition
) override

Parameters

acquisition
Type: TwinCAT.Measurement.Scope.API.ModelSequence
See Also

Reference

IotFileSequence Class


IotFileSequence.DeleteDataFiles Method

Deletes the data file(s) at the DataFilePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void DeleteDataFiles()
Public Overrides Sub DeleteDataFiles
public:
virtual void DeleteDataFiles() override
See Also

Reference

IotFileSequence Class


IotFileSequence.ExtendDataEnd Method

Adds samples to the end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void ExtendDataEnd(
    long numSamples
)
Public Overrides Sub ExtendDataEnd (
    numSamples As Long
)
public:
virtual void ExtendDataEnd(
    long long numSamples
) override

Parameters

numSamples
Type: SystemInt64
The number of samples to add.
See Also

Reference

IotFileSequence Class


IotFileSequence.ExtendDataEndTimeStamp Method

Orders samples from the reference and adds them to the end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void ExtendDataEndTimeStamp(
    long to
)
Public Sub ExtendDataEndTimeStamp (
    to As Long
)
public:
void ExtendDataEndTimeStamp(
    long long to
)

Parameters

to
Type: SystemInt64
Samples are ordered between the LastEndTime timestamp and this parameter.
See Also

Reference

IotFileSequence Class


IotFileSequence.ExtendDataStart Method

Adds samples at the start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void ExtendDataStart(
    long numSamples
)
Public Overrides Sub ExtendDataStart (
    numSamples As Long
)
public:
virtual void ExtendDataStart(
    long long numSamples
) override

Parameters

numSamples
Type: SystemInt64
The number of samples to add.
See Also

Reference

IotFileSequence Class


IotFileSequence.ExtendDataStartTimeStamp Method

Orders samples from the reference and adds them to the start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void ExtendDataStartTimeStamp(
    long to
)
Public Sub ExtendDataStartTimeStamp (
    to As Long
)
public:
void ExtendDataStartTimeStamp(
    long long to
)

Parameters

to
Type: SystemInt64
Samples are ordered between the LastStartTime timestamp and this parameter.
See Also

Reference

IotFileSequence Class


IotFileSequence.GetAlyFilePath Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string GetAlyFilePath(
    bool fullTasPath
)
Public Overrides Function GetAlyFilePath (
    fullTasPath As Boolean
) As String
public:
virtual String^ GetAlyFilePath(
    bool fullTasPath
) override

Parameters

fullTasPath
Type: SystemBoolean

Return Value

Type: String
See Also

Reference

IotFileSequence Class


IotFileSequence.LoadData Method

Overload List
 | Name | Description
Public method | LoadData | (Overrides SequenceLoadData.)
Public method | LoadData(String) | (Inherited from Sequence.)
Top
See Also

Reference

IotFileSequence Class


IotFileSequence.LoadData Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void LoadData()
Public Overrides Sub LoadData
public:
virtual void LoadData() override
See Also

Reference

IotFileSequence Class
LoadData Overload


IotFileSequence.MaxEndIndex Method

Gets the largest possible end index relative to the current end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override double MaxEndIndex()
Public Overrides Function MaxEndIndex As Double
public:
virtual double MaxEndIndex() override

Return Value

Type: Double
See Also

Reference

IotFileSequence Class


IotFileSequence.MinStartIndex Method

Gets the smallest possible start index relative to the current start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override double MinStartIndex()
Public Overrides Function MinStartIndex As Double
public:
virtual double MinStartIndex() override

Return Value

Type: Double
See Also

Reference

IotFileSequence Class


IotFileSequence.SaveData Method

Saves the data to the DataFilePath. The data is stored in the aly file format.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void SaveData()
Public Overrides Sub SaveData
public:
virtual void SaveData() override
See Also

Reference

IotFileSequence Class


IotFileSequence.ToString Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
See Also

Reference

IotFileSequence Class


IotFileSequence.TrimDataEnd Method

Removes samples at the end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void TrimDataEnd(
    long numSamples
)
Public Overrides Sub TrimDataEnd (
    numSamples As Long
)
public:
virtual void TrimDataEnd(
    long long numSamples
) override

Parameters

numSamples
Type: SystemInt64
The number of samples to remove.
See Also

Reference

IotFileSequence Class


IotFileSequence.TrimDataStart Method

Removes samples from the start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void TrimDataStart(
    long numSamples
)
Public Overrides Sub TrimDataStart (
    numSamples As Long
)
public:
virtual void TrimDataStart(
    long long numSamples
) override

Parameters

numSamples
Type: SystemInt64
The number of samples to remove.
See Also

Reference

IotFileSequence Class


IotFileSequence Events

The IotFileSequence type exposes the following members.

Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataFilePathChanged | Fired when the DataFilePath is changed. (Inherited from Sequence.)
Public event | DataFilePathValidating | Fired while validating the new value for DataFilePath. (Inherited from Sequence.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DataUpdated | Raised when data is added to Data. (Inherited from Sequence.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | ExportOptionsChanged | Fired when the ExportOptions is changed. (Inherited from Sequence.)
Public event | ExportOptionsValidating | Fired while validating the new value for ExportOptions. (Inherited from Sequence.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | LastEndTimeChanged | Fired when the LastEndTime is changed.
Public event | LastEndTimeValidating | Fired while validating the new value for LastEndTime.
Public event | LastStartTimeChanged | Fired when the LastStartTime is changed.
Public event | LastStartTimeValidating | Fired while validating the new value for LastStartTime.
Public event | LocalDataChanged | Fired when the LocalData is changed.
Public event | LocalDataValidating | Fired while validating the new value for LocalData.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RefFilePathChanged | Fired when the RefFilePath is changed.
Public event | RefFilePathValidating | Fired while validating the new value for RefFilePath.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SampleCountChanged | Fired when the SampleCount is changed. (Inherited from Sequence.)
Public event | SampleCountValidating | Fired while validating the new value for SampleCount. (Inherited from Sequence.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

IotFileSequence Class


IotFileSequence.LastEndTimeChanged Event

Fired when the LastEndTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LastEndTimeChanged
Public Event LastEndTimeChanged As EventHandler
public:
 event EventHandler^ LastEndTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IotFileSequence Class


IotFileSequence.LastEndTimeValidating Event

Fired while validating the new value for LastEndTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LastEndTimeValidating
Public Event LastEndTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LastEndTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IotFileSequence Class


IotFileSequence.LastStartTimeChanged Event

Fired when the LastStartTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LastStartTimeChanged
Public Event LastStartTimeChanged As EventHandler
public:
 event EventHandler^ LastStartTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IotFileSequence Class


IotFileSequence.LastStartTimeValidating Event

Fired while validating the new value for LastStartTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LastStartTimeValidating
Public Event LastStartTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LastStartTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IotFileSequence Class


IotFileSequence.LocalDataChanged Event

Fired when the LocalData is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LocalDataChanged
Public Event LocalDataChanged As EventHandler
public:
 event EventHandler^ LocalDataChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IotFileSequence Class


IotFileSequence.LocalDataValidating Event

Fired while validating the new value for LocalData.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LocalDataValidating
Public Event LocalDataValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LocalDataValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IotFileSequence Class


IotFileSequence.RefFilePathChanged Event

Fired when the RefFilePath is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler RefFilePathChanged
Public Event RefFilePathChanged As EventHandler
public:
 event EventHandler^ RefFilePathChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IotFileSequence Class


IotFileSequence.RefFilePathValidating Event

Fired while validating the new value for RefFilePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> RefFilePathValidating
Public Event RefFilePathValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ RefFilePathValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IotFileSequence Class


IotFileSequence.SymbolNameChanged Event

Fired when the SymbolName is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SymbolNameChanged
Public Event SymbolNameChanged As EventHandler
public:
 event EventHandler^ SymbolNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IotFileSequence Class


IotFileSequence.SymbolNameValidating Event

Fired while validating the new value for SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SymbolNameValidating
Public Event SymbolNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SymbolNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IotFileSequence Class


IotFileSequence Fields

The IotFileSequence type exposes the following members.

Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

IotFileSequence Class


IotFileSequenceData Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelSequenceDataSource
TwinCAT.Measurement.Scope.API.ModelIotFileSequenceData
TwinCAT.Measurement.Scope.API.ModelIotMultiSequenceData
TwinCAT.Measurement.Scope.API.ModelRefAcquisitionSequenceData

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class IotFileSequenceData : SequenceDataSource
Public Class IotFileSequenceData
    Inherits SequenceDataSource
public ref class IotFileSequenceData : public SequenceDataSource

The IotFileSequenceData type exposes the following members.

Constructors
 | Name | Description
Public method | IotFileSequenceData | Initializes a new instance of the IotFileSequenceData class
Public method | IotFileSequenceData(String) | Initializes a new instance of the IotFileSequenceData class
Public method | IotFileSequenceData(IotFileSequenceData) | Initializes a new instance of the IotFileSequenceData class
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Folder | Gets or Sets the Folder.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | TasFile | Gets or Sets the TasFile.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FolderChanged | Fired when the Folder is changed.
Public event | FolderValidating | Fired while validating the new value for Folder.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TasFileChanged | Fired when the TasFile is changed.
Public event | TasFileValidating | Fired while validating the new value for TasFile.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


IotFileSequenceData Constructor

Overload List
 | Name | Description
Public method | IotFileSequenceData | Initializes a new instance of the IotFileSequenceData class
Public method | IotFileSequenceData(String) | Initializes a new instance of the IotFileSequenceData class
Public method | IotFileSequenceData(IotFileSequenceData) | Initializes a new instance of the IotFileSequenceData class
Top
See Also

Reference

IotFileSequenceData Class


IotFileSequenceData Constructor

Initializes a new instance of the IotFileSequenceData class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IotFileSequenceData()
Public Sub New
public:
IotFileSequenceData()
See Also

Reference

IotFileSequenceData Class
IotFileSequenceData Overload


IotFileSequenceData Constructor (String)

Initializes a new instance of the IotFileSequenceData class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IotFileSequenceData(
    string tasFile
)
Public Sub New (
    tasFile As String
)
public:
IotFileSequenceData(
    String^ tasFile
)

Parameters

tasFile
Type: SystemString
See Also

Reference

IotFileSequenceData Class
IotFileSequenceData Overload


IotFileSequenceData Constructor (IotFileSequenceData)

Initializes a new instance of the IotFileSequenceData class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IotFileSequenceData(
    IotFileSequenceData org
)
Public Sub New (
    org As IotFileSequenceData
)
public:
IotFileSequenceData(
    IotFileSequenceData^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelIotFileSequenceData
See Also

Reference

IotFileSequenceData Class
IotFileSequenceData Overload


IotFileSequenceData Properties

The IotFileSequenceData type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Folder | Gets or Sets the Folder.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | TasFile | Gets or Sets the TasFile.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

IotFileSequenceData Class


IotFileSequenceData.Folder Property

Gets or Sets the Folder.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string Folder { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Folder As String
    Get
public:
[BrowsableAttribute(false)]
property String^ Folder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IotFileSequenceData Class


IotFileSequenceData.TasFile Property

Gets or Sets the TasFile.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string TasFile { get; set; }
<BrowsableAttribute(false)>
Public Property TasFile As String
    Get
    Set
public:
[BrowsableAttribute(false)]
property String^ TasFile {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IotFileSequenceData Class


IotFileSequenceData Methods

The IotFileSequenceData type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

IotFileSequenceData Class


IotFileSequenceData Events

The IotFileSequenceData type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FolderChanged | Fired when the Folder is changed.
Public event | FolderValidating | Fired while validating the new value for Folder.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TasFileChanged | Fired when the TasFile is changed.
Public event | TasFileValidating | Fired while validating the new value for TasFile.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

IotFileSequenceData Class


IotFileSequenceData.FolderChanged Event

Fired when the Folder is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler FolderChanged
Public Event FolderChanged As EventHandler
public:
 event EventHandler^ FolderChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IotFileSequenceData Class


IotFileSequenceData.FolderValidating Event

Fired while validating the new value for Folder.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> FolderValidating
Public Event FolderValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ FolderValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IotFileSequenceData Class


IotFileSequenceData.TasFileChanged Event

Fired when the TasFile is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TasFileChanged
Public Event TasFileChanged As EventHandler
public:
 event EventHandler^ TasFileChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IotFileSequenceData Class


IotFileSequenceData.TasFileValidating Event

Fired while validating the new value for TasFile.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TasFileValidating
Public Event TasFileValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TasFileValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IotFileSequenceData Class


IotMultiSequenceData Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelSequenceDataSource
TwinCAT.Measurement.Scope.API.ModelIotFileSequenceData
TwinCAT.Measurement.Scope.API.ModelIotMultiSequenceData

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class IotMultiSequenceData : IotFileSequenceData
Public Class IotMultiSequenceData
    Inherits IotFileSequenceData
public ref class IotMultiSequenceData : public IotFileSequenceData

The IotMultiSequenceData type exposes the following members.

Constructors
 | Name | Description
Public method | IotMultiSequenceData | Initializes a new instance of the IotMultiSequenceData class
Public method | IotMultiSequenceData(IotMultiSequenceData) | Initializes a new instance of the IotMultiSequenceData class
Public method | IotMultiSequenceData(Sequence, String, String) | Initializes a new instance of the IotMultiSequenceData class
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Exported | Gets or Sets the Exported.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Folder | Gets or Sets the Folder. (Inherited from IotFileSequenceData.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | TasFile | Gets or Sets the TasFile. (Inherited from IotFileSequenceData.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ExportedChanged | Fired when the Exported is changed.
Public event | ExportedValidating | Fired while validating the new value for Exported.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FolderChanged | Fired when the Folder is changed. (Inherited from IotFileSequenceData.)
Public event | FolderValidating | Fired while validating the new value for Folder. (Inherited from IotFileSequenceData.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | TasFileChanged | Fired when the TasFile is changed. (Inherited from IotFileSequenceData.)
Public event | TasFileValidating | Fired while validating the new value for TasFile. (Inherited from IotFileSequenceData.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


IotMultiSequenceData Constructor

Overload List
 | Name | Description
Public method | IotMultiSequenceData | Initializes a new instance of the IotMultiSequenceData class
Public method | IotMultiSequenceData(IotMultiSequenceData) | Initializes a new instance of the IotMultiSequenceData class
Public method | IotMultiSequenceData(Sequence, String, String) | Initializes a new instance of the IotMultiSequenceData class
Top
See Also

Reference

IotMultiSequenceData Class


IotMultiSequenceData Constructor

Initializes a new instance of the IotMultiSequenceData class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IotMultiSequenceData()
Public Sub New
public:
IotMultiSequenceData()
See Also

Reference

IotMultiSequenceData Class
IotMultiSequenceData Overload


IotMultiSequenceData Constructor (IotMultiSequenceData)

Initializes a new instance of the IotMultiSequenceData class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IotMultiSequenceData(
    IotMultiSequenceData org
)
Public Sub New (
    org As IotMultiSequenceData
)
public:
IotMultiSequenceData(
    IotMultiSequenceData^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelIotMultiSequenceData
See Also

Reference

IotMultiSequenceData Class
IotMultiSequenceData Overload


IotMultiSequenceData Constructor (Sequence, String, String)

Initializes a new instance of the IotMultiSequenceData class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IotMultiSequenceData(
    Sequence exported,
    string symbolName,
    string tasFile
)
Public Sub New (
    exported As Sequence,
    symbolName As String,
    tasFile As String
)
public:
IotMultiSequenceData(
    Sequence^ exported,
    String^ symbolName,
    String^ tasFile
)

Parameters

exported
Type: TwinCAT.Measurement.Scope.API.ModelSequence
symbolName
Type: SystemString
tasFile
Type: SystemString
See Also

Reference

IotMultiSequenceData Class
IotMultiSequenceData Overload


IotMultiSequenceData Properties

The IotMultiSequenceData type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Exported | Gets or Sets the Exported.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Folder | Gets or Sets the Folder. (Inherited from IotFileSequenceData.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | TasFile | Gets or Sets the TasFile. (Inherited from IotFileSequenceData.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

IotMultiSequenceData Class


IotMultiSequenceData.Exported Property

Gets or Sets the Exported.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public Sequence Exported { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property Exported As Sequence
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property Sequence^ Exported {
    Sequence^ get ();
    void set (Sequence^ value);
}

Property Value

Type: Sequence
See Also

Reference

IotMultiSequenceData Class


IotMultiSequenceData.SymbolName Property

Gets or Sets the SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string SymbolName { get; set; }
<BrowsableAttribute(true)>
Public Property SymbolName As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ SymbolName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IotMultiSequenceData Class


IotMultiSequenceData Methods

The IotMultiSequenceData type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

IotMultiSequenceData Class


IotMultiSequenceData Events

The IotMultiSequenceData type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ExportedChanged | Fired when the Exported is changed.
Public event | ExportedValidating | Fired while validating the new value for Exported.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FolderChanged | Fired when the Folder is changed. (Inherited from IotFileSequenceData.)
Public event | FolderValidating | Fired while validating the new value for Folder. (Inherited from IotFileSequenceData.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | TasFileChanged | Fired when the TasFile is changed. (Inherited from IotFileSequenceData.)
Public event | TasFileValidating | Fired while validating the new value for TasFile. (Inherited from IotFileSequenceData.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

IotMultiSequenceData Class


IotMultiSequenceData.ExportedChanged Event

Fired when the Exported is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ExportedChanged
Public Event ExportedChanged As EventHandler
public:
 event EventHandler^ ExportedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IotMultiSequenceData Class


IotMultiSequenceData.ExportedValidating Event

Fired while validating the new value for Exported.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ExportedValidating
Public Event ExportedValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ExportedValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IotMultiSequenceData Class


IotMultiSequenceData.SymbolNameChanged Event

Fired when the SymbolName is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SymbolNameChanged
Public Event SymbolNameChanged As EventHandler
public:
 event EventHandler^ SymbolNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IotMultiSequenceData Class


IotMultiSequenceData.SymbolNameValidating Event

Fired while validating the new value for SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SymbolNameValidating
Public Event SymbolNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SymbolNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

IotMultiSequenceData Class


IScopeMember Interface

Interface witch all ScopeMembers should Implement

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public interface IScopeMember
Public Interface IScopeMember
public interface class IScopeMember

The IScopeMember type exposes the following members.

Properties
 | Name | Description
Public property | HelpString | Gets the HelpString
Public property | ScopeState | The ProjectState as ScopeViewState Enum
Public property | SuppressMessages | Get or Set the SuppressMessages
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


IScopeMember Properties

The IScopeMember type exposes the following members.

Properties
 | Name | Description
Public property | HelpString | Gets the HelpString
Public property | ScopeState | The ProjectState as ScopeViewState Enum
Public property | SuppressMessages | Get or Set the SuppressMessages
Top
See Also

Reference

IScopeMember Interface


IScopeMember.HelpString Property

Gets the HelpString

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
string HelpString { get; }
ReadOnly Property HelpString As String
    Get
property String^ HelpString {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IScopeMember Interface


IScopeMember.ScopeState Property

The ProjectState as ScopeViewState Enum

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
ScopeViewState ScopeState { get; }
ReadOnly Property ScopeState As ScopeViewState
    Get
property ScopeViewState ScopeState {
    ScopeViewState get ();
}

Property Value

Type: ScopeViewState
See Also

Reference

IScopeMember Interface


IScopeMember.SuppressMessages Property

Get or Set the SuppressMessages

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
bool SuppressMessages { get; set; }
Property SuppressMessages As Boolean
    Get
    Set
property bool SuppressMessages {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IScopeMember Interface


ITreeElementItem Interface

Interface for an Tree Element Item

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public interface ITreeElementItem
Public Interface ITreeElementItem
public interface class ITreeElementItem

The ITreeElementItem type exposes the following members.

Properties
 | Name | Description
Public property | Bmp | Bitmap name
Public property | CanExpand | Gets or Sets CanExpand
Public property | Children | Gets or sets the Children collection
Public property | DisplayName | Gets or sets the DisplayName
Public property | IsEnabled | Gets or sets IsEnabled
Public property | IsExpanded | Gets or sets IsExpanded
Public property | IsSelectable | Gets or Sets IsSelecable
Public property | IsSelected | Get or Sets IsSelected
Public property | SortPriority | Gets or Sets the SortPriority
Public property | Visibility | Gets or Sets Visibility
Public property | VisibleStateUpdater | Gets or Sets the Visible State Updater
Top
Methods
 | Name | Description
Public method | FindParent | Find the parent of an element
Public method | UpdateCanExpand | Update CanExpand state
Public method | UpdateFullVisual | Update all Visual Settings
Public method | UpdateIsEnable | Update IsEnabled state
Public method | UpdateIsSelected | Update IsSelected state
Public method | UpdateIsVisible | Update IsVisible state
Top
Events
 | Name | Description
Public event | SubChildrenChanged | Fired if an child is added in the tree
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ITreeElementItem Properties

The ITreeElementItem type exposes the following members.

Properties
 | Name | Description
Public property | Bmp | Bitmap name
Public property | CanExpand | Gets or Sets CanExpand
Public property | Children | Gets or sets the Children collection
Public property | DisplayName | Gets or sets the DisplayName
Public property | IsEnabled | Gets or sets IsEnabled
Public property | IsExpanded | Gets or sets IsExpanded
Public property | IsSelectable | Gets or Sets IsSelecable
Public property | IsSelected | Get or Sets IsSelected
Public property | SortPriority | Gets or Sets the SortPriority
Public property | Visibility | Gets or Sets Visibility
Public property | VisibleStateUpdater | Gets or Sets the Visible State Updater
Top
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.Bmp Property

Bitmap name

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
string Bmp { get; set; }
Property Bmp As String
    Get
    Set
property String^ Bmp {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.CanExpand Property

Gets or Sets CanExpand

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
bool CanExpand { get; set; }
Property CanExpand As Boolean
    Get
    Set
property bool CanExpand {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.Children Property

Gets or sets the Children collection

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
ObservableCollection<ITreeElementItem> Children { get; set; }
Property Children As ObservableCollection(Of ITreeElementItem)
    Get
    Set
property ObservableCollection<ITreeElementItem^>^ Children {
    ObservableCollection<ITreeElementItem^>^ get ();
    void set (ObservableCollection<ITreeElementItem^>^ value);
}

Property Value

Type: ObservableCollection ITreeElementItem
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.DisplayName Property

Gets or sets the DisplayName

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
string DisplayName { get; set; }
Property DisplayName As String
    Get
    Set
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.IsEnabled Property

Gets or sets IsEnabled

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
bool IsEnabled { get; set; }
Property IsEnabled As Boolean
    Get
    Set
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.IsExpanded Property

Gets or sets IsExpanded

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
bool IsExpanded { get; set; }
Property IsExpanded As Boolean
    Get
    Set
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.IsSelectable Property

Gets or Sets IsSelecable

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
bool IsSelectable { get; set; }
Property IsSelectable As Boolean
    Get
    Set
property bool IsSelectable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.IsSelected Property

Get or Sets IsSelected

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
bool IsSelected { get; set; }
Property IsSelected As Boolean
    Get
    Set
property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.SortPriority Property

Gets or Sets the SortPriority

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
int SortPriority { get; set; }
Property SortPriority As Integer
    Get
    Set
property int SortPriority {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.Visibility Property

Gets or Sets Visibility

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
bool Visibility { get; set; }
Property Visibility As Boolean
    Get
    Set
property bool Visibility {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.VisibleStateUpdater Property

Gets or Sets the Visible State Updater

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
IVisibleStateUpdater VisibleStateUpdater { get; set; }
Property VisibleStateUpdater As IVisibleStateUpdater
    Get
    Set
property IVisibleStateUpdater^ VisibleStateUpdater {
    IVisibleStateUpdater^ get ();
    void set (IVisibleStateUpdater^ value);
}

Property Value

Type: IVisibleStateUpdater
See Also

Reference

ITreeElementItem Interface


ITreeElementItem Methods

The ITreeElementItem type exposes the following members.

Methods
 | Name | Description
Public method | FindParent | Find the parent of an element
Public method | UpdateCanExpand | Update CanExpand state
Public method | UpdateFullVisual | Update all Visual Settings
Public method | UpdateIsEnable | Update IsEnabled state
Public method | UpdateIsSelected | Update IsSelected state
Public method | UpdateIsVisible | Update IsVisible state
Top
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.FindParent Method

Find the parent of an element

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
bool FindParent(
    ITreeElementItem containingChild,
    out ITreeElementItem parent
)
Function FindParent (
    containingChild As ITreeElementItem,
    <OutAttribute> ByRef parent As ITreeElementItem
) As Boolean
bool FindParent(
    ITreeElementItem^ containingChild,
    [OutAttribute] ITreeElementItem^% parent
)

Parameters

containingChild
Type: TwinCAT.Measurement.Scope.API.ModelITreeElementItem
parent
Type: TwinCAT.Measurement.Scope.API.ModelITreeElementItem

Return Value

Type: Boolean
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.UpdateCanExpand Method

Update CanExpand state

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
void UpdateCanExpand()
Sub UpdateCanExpand
void UpdateCanExpand()
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.UpdateFullVisual Method

Update all Visual Settings

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
void UpdateFullVisual()
Sub UpdateFullVisual
void UpdateFullVisual()
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.UpdateIsEnable Method

Update IsEnabled state

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
void UpdateIsEnable()
Sub UpdateIsEnable
void UpdateIsEnable()
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.UpdateIsSelected Method

Update IsSelected state

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
void UpdateIsSelected()
Sub UpdateIsSelected
void UpdateIsSelected()
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.UpdateIsVisible Method

Update IsVisible state

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
void UpdateIsVisible()
Sub UpdateIsVisible
void UpdateIsVisible()
See Also

Reference

ITreeElementItem Interface


ITreeElementItem Events

The ITreeElementItem type exposes the following members.

Events
 | Name | Description
Public event | SubChildrenChanged | Fired if an child is added in the tree
Top
See Also

Reference

ITreeElementItem Interface


ITreeElementItem.SubChildrenChanged Event

Fired if an child is added in the tree

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
event EventHandler<NotifyCollectionChangedEventArgs> SubChildrenChanged
Event SubChildrenChanged As EventHandler(Of NotifyCollectionChangedEventArgs)
 event EventHandler<NotifyCollectionChangedEventArgs^>^ SubChildrenChanged {
    void add (EventHandler<NotifyCollectionChangedEventArgs^>^ value);
    void remove (EventHandler<NotifyCollectionChangedEventArgs^>^ value);
}

Value

Type: SystemEventHandler NotifyCollectionChangedEventArgs
See Also

Reference

ITreeElementItem Interface


IValueToTimestampCollector Interface

Interface for members that can collect data

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public interface IValueToTimestampCollector
Public Interface IValueToTimestampCollector
public interface class IValueToTimestampCollector

The IValueToTimestampCollector type exposes the following members.

Methods
 | Name | Description
Public method | GetMemberValue | Get data from the member
Public method | GetSubInterpreterValue | Get Data from an Interpreter inside the parent member
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


IValueToTimestampCollector Methods

The IValueToTimestampCollector type exposes the following members.

Methods
 | Name | Description
Public method | GetMemberValue | Get data from the member
Public method | GetSubInterpreterValue | Get Data from an Interpreter inside the parent member
Top
See Also

Reference

IValueToTimestampCollector Interface


IValueToTimestampCollector.GetMemberValue Method

Get data from the member

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
Object GetMemberValue(
    MeasurementMemberBase member
)
Function GetMemberValue (
    member As MeasurementMemberBase
) As Object
Object^ GetMemberValue(
    MeasurementMemberBase^ member
)

Parameters

member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase

Return Value

Type: Object
See Also

Reference

IValueToTimestampCollector Interface


IValueToTimestampCollector.GetSubInterpreterValue Method

Get Data from an Interpreter inside the parent member

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
Object GetSubInterpreterValue(
    MeasurementMemberBase member,
    AcquisitionInterpreter subAcquisitionInterpreter
)
Function GetSubInterpreterValue (
    member As MeasurementMemberBase,
    subAcquisitionInterpreter As AcquisitionInterpreter
) As Object
Object^ GetSubInterpreterValue(
    MeasurementMemberBase^ member,
    AcquisitionInterpreter^ subAcquisitionInterpreter
)

Parameters

member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
subAcquisitionInterpreter
Type: TwinCAT.Measurement.Scope.API.ModelAcquisitionInterpreter

Return Value

Type: Object
See Also

Reference

IValueToTimestampCollector Interface


IVisibleStateUpdater Interface

Interface for an Visible State Updater

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public interface IVisibleStateUpdater
Public Interface IVisibleStateUpdater
public interface class IVisibleStateUpdater

The IVisibleStateUpdater type exposes the following members.

Methods
 | Name | Description
Public method | UpdateCanExpand | Update CanExpand
Public method | UpdateFull | Update the full visible state
Public method | UpdateIsEnable | Update IsEnable
Public method | UpdateIsExpanded | Update IsExpanded
Public method | UpdateIsSelectable | Update IsSelectable
Public method | UpdateIsSelected | Update IsSelected
Public method | UpdateIsVisible | Update IsVisible
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


IVisibleStateUpdater Methods

The IVisibleStateUpdater type exposes the following members.

Methods
 | Name | Description
Public method | UpdateCanExpand | Update CanExpand
Public method | UpdateFull | Update the full visible state
Public method | UpdateIsEnable | Update IsEnable
Public method | UpdateIsExpanded | Update IsExpanded
Public method | UpdateIsSelectable | Update IsSelectable
Public method | UpdateIsSelected | Update IsSelected
Public method | UpdateIsVisible | Update IsVisible
Top
See Also

Reference

IVisibleStateUpdater Interface


IVisibleStateUpdater.UpdateCanExpand Method

Update CanExpand

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
void UpdateCanExpand(
    ITreeElementItem item
)
Sub UpdateCanExpand (
    item As ITreeElementItem
)
void UpdateCanExpand(
    ITreeElementItem^ item
)

Parameters

item
Type: TwinCAT.Measurement.Scope.API.ModelITreeElementItem
See Also

Reference

IVisibleStateUpdater Interface


IVisibleStateUpdater.UpdateFull Method

Update the full visible state

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
void UpdateFull(
    ITreeElementItem item
)
Sub UpdateFull (
    item As ITreeElementItem
)
void UpdateFull(
    ITreeElementItem^ item
)

Parameters

item
Type: TwinCAT.Measurement.Scope.API.ModelITreeElementItem
See Also

Reference

IVisibleStateUpdater Interface


IVisibleStateUpdater.UpdateIsEnable Method

Update IsEnable

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
void UpdateIsEnable(
    ITreeElementItem item
)
Sub UpdateIsEnable (
    item As ITreeElementItem
)
void UpdateIsEnable(
    ITreeElementItem^ item
)

Parameters

item
Type: TwinCAT.Measurement.Scope.API.ModelITreeElementItem
See Also

Reference

IVisibleStateUpdater Interface


IVisibleStateUpdater.UpdateIsExpanded Method

Update IsExpanded

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
void UpdateIsExpanded(
    ITreeElementItem item
)
Sub UpdateIsExpanded (
    item As ITreeElementItem
)
void UpdateIsExpanded(
    ITreeElementItem^ item
)

Parameters

item
Type: TwinCAT.Measurement.Scope.API.ModelITreeElementItem
See Also

Reference

IVisibleStateUpdater Interface


IVisibleStateUpdater.UpdateIsSelectable Method

Update IsSelectable

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
void UpdateIsSelectable(
    ITreeElementItem item
)
Sub UpdateIsSelectable (
    item As ITreeElementItem
)
void UpdateIsSelectable(
    ITreeElementItem^ item
)

Parameters

item
Type: TwinCAT.Measurement.Scope.API.ModelITreeElementItem
See Also

Reference

IVisibleStateUpdater Interface


IVisibleStateUpdater.UpdateIsSelected Method

Update IsSelected

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
void UpdateIsSelected(
    ITreeElementItem item
)
Sub UpdateIsSelected (
    item As ITreeElementItem
)
void UpdateIsSelected(
    ITreeElementItem^ item
)

Parameters

item
Type: TwinCAT.Measurement.Scope.API.ModelITreeElementItem
See Also

Reference

IVisibleStateUpdater Interface


IVisibleStateUpdater.UpdateIsVisible Method

Update IsVisible

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
void UpdateIsVisible(
    ITreeElementItem item
)
Sub UpdateIsVisible (
    item As ITreeElementItem
)
void UpdateIsVisible(
    ITreeElementItem^ item
)

Parameters

item
Type: TwinCAT.Measurement.Scope.API.ModelITreeElementItem
See Also

Reference

IVisibleStateUpdater Interface


LinestateIndexPair Class

Class defining an LinestateIndex Pair
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.API.ModelLinestateIndexPair

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class LinestateIndexPair
Public Class LinestateIndexPair
public ref class LinestateIndexPair

The LinestateIndexPair type exposes the following members.

Constructors
 | Name | Description
Public method | LinestateIndexPair | Create a new Linestate IndexPair
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Index | Gets or sets the Index
Public field | LineState | Gets or sets the LinestateArray
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


LinestateIndexPair Constructor

Create a new Linestate IndexPair

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public LinestateIndexPair(
    int index,
    params Linestate[] lst
)
Public Sub New (
    index As Integer,
    ParamArray lst As Linestate()
)
public:
LinestateIndexPair(
    int index,
    ... array<Linestate>^ lst
)

Parameters

index
Type: SystemInt32
The Index
lst
Type: TwinCAT.Measurement.Scope.APILinestate
The Linestate
See Also

Reference

LinestateIndexPair Class


LinestateIndexPair Methods

The LinestateIndexPair type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinestateIndexPair Class


LinestateIndexPair Fields

The LinestateIndexPair type exposes the following members.

Fields
 | Name | Description
Public field | Index | Gets or sets the Index
Public field | LineState | Gets or sets the LinestateArray
Top
See Also

Reference

LinestateIndexPair Class


LinestateIndexPair.Index Field

Gets or sets the Index

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int Index
Public Index As Integer
public:
int Index

Field Value

Type: Int32
See Also

Reference

LinestateIndexPair Class


LinestateIndexPair.LineState Field

Gets or sets the LinestateArray

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Linestate[] LineState
Public LineState As Linestate()
public:
array<Linestate>^ LineState

Field Value

Type: Linestate
See Also

Reference

LinestateIndexPair Class


LineStateSettings Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.API.ModelLineStateSettings

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class LineStateSettings
Public Class LineStateSettings
public ref class LineStateSettings

The LineStateSettings type exposes the following members.

Constructors
 | Name | Description
Public method | LineStateSettings | Initializes a new instance of the LineStateSettings class
Public method | LineStateSettings(LineStateSettings) | Initializes a new instance of the LineStateSettings class
Public method | LineStateSettings(Linestate, Linestate, Linestate) | Initializes a new instance of the LineStateSettings class
Top
Properties
 | Name | Description
Public property | FillState |
Public property | LineState |
Public property | MarkState |
Top
Methods
 | Name | Description
Public method | CloneSettings |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual(Linestate) |
Public method | IsEqual(LineStateSettings) |
Public method | ResetStates |
Public method | ToArray |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


LineStateSettings Constructor

Overload List
 | Name | Description
Public method | LineStateSettings | Initializes a new instance of the LineStateSettings class
Public method | LineStateSettings(LineStateSettings) | Initializes a new instance of the LineStateSettings class
Public method | LineStateSettings(Linestate, Linestate, Linestate) | Initializes a new instance of the LineStateSettings class
Top
See Also

Reference

LineStateSettings Class


LineStateSettings Constructor

Initializes a new instance of the LineStateSettings class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public LineStateSettings()
Public Sub New
public:
LineStateSettings()
See Also

Reference

LineStateSettings Class
LineStateSettings Overload


LineStateSettings Constructor (LineStateSettings)

Initializes a new instance of the LineStateSettings class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public LineStateSettings(
    LineStateSettings cloneSettings
)
Public Sub New (
    cloneSettings As LineStateSettings
)
public:
LineStateSettings(
    LineStateSettings^ cloneSettings
)

Parameters

cloneSettings
Type: TwinCAT.Measurement.Scope.API.ModelLineStateSettings
See Also

Reference

LineStateSettings Class
LineStateSettings Overload


LineStateSettings Constructor (Linestate, Linestate, Linestate)

Initializes a new instance of the LineStateSettings class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public LineStateSettings(
    Linestate lineState,
    Linestate markState,
    Linestate fillState
)
Public Sub New (
    lineState As Linestate,
    markState As Linestate,
    fillState As Linestate
)
public:
LineStateSettings(
    Linestate lineState,
    Linestate markState,
    Linestate fillState
)

Parameters

lineState
Type: TwinCAT.Measurement.Scope.APILinestate
markState
Type: TwinCAT.Measurement.Scope.APILinestate
fillState
Type: TwinCAT.Measurement.Scope.APILinestate
See Also

Reference

LineStateSettings Class
LineStateSettings Overload


LineStateSettings Properties

The LineStateSettings type exposes the following members.

Properties
 | Name | Description
Public property | FillState |
Public property | LineState |
Public property | MarkState |
Top
See Also

Reference

LineStateSettings Class


LineStateSettings.FillState Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Linestate FillState { get; set; }
Public Property FillState As Linestate
    Get
    Set
public:
property Linestate FillState {
    Linestate get ();
    void set (Linestate value);
}

Property Value

Type: Linestate
See Also

Reference

LineStateSettings Class


LineStateSettings.LineState Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Linestate LineState { get; set; }
Public Property LineState As Linestate
    Get
    Set
public:
property Linestate LineState {
    Linestate get ();
    void set (Linestate value);
}

Property Value

Type: Linestate
See Also

Reference

LineStateSettings Class


LineStateSettings.MarkState Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Linestate MarkState { get; set; }
Public Property MarkState As Linestate
    Get
    Set
public:
property Linestate MarkState {
    Linestate get ();
    void set (Linestate value);
}

Property Value

Type: Linestate
See Also

Reference

LineStateSettings Class


LineStateSettings Methods

The LineStateSettings type exposes the following members.

Methods
 | Name | Description
Public method | CloneSettings |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual(Linestate) |
Public method | IsEqual(LineStateSettings) |
Public method | ResetStates |
Public method | ToArray |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LineStateSettings Class


LineStateSettings.CloneSettings Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void CloneSettings(
    LineStateSettings cloneSettings
)
Public Sub CloneSettings (
    cloneSettings As LineStateSettings
)
public:
void CloneSettings(
    LineStateSettings^ cloneSettings
)

Parameters

cloneSettings
Type: TwinCAT.Measurement.Scope.API.ModelLineStateSettings
See Also

Reference

LineStateSettings Class


LineStateSettings.IsEqual Method

Overload List
 | Name | Description
Public method | IsEqual(Linestate) |
Public method | IsEqual(LineStateSettings) |
Top
See Also

Reference

LineStateSettings Class


LineStateSettings.IsEqual Method (Linestate[])

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool IsEqual(
    Linestate[] lineStates
)
Public Function IsEqual (
    lineStates As Linestate()
) As Boolean
public:
bool IsEqual(
    array<Linestate>^ lineStates
)

Parameters

lineStates
Type: TwinCAT.Measurement.Scope.APILinestate

Return Value

Type: Boolean
See Also

Reference

LineStateSettings Class
IsEqual Overload


LineStateSettings.IsEqual Method (LineStateSettings)

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool IsEqual(
    LineStateSettings settings
)
Public Function IsEqual (
    settings As LineStateSettings
) As Boolean
public:
bool IsEqual(
    LineStateSettings^ settings
)

Parameters

settings
Type: TwinCAT.Measurement.Scope.API.ModelLineStateSettings

Return Value

Type: Boolean
See Also

Reference

LineStateSettings Class
IsEqual Overload


LineStateSettings.ResetStates Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void ResetStates()
Public Sub ResetStates
public:
void ResetStates()
See Also

Reference

LineStateSettings Class


LineStateSettings.ToArray Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Linestate[] ToArray()
Public Function ToArray As Linestate()
public:
array<Linestate>^ ToArray()

Return Value

Type: Linestate
See Also

Reference

LineStateSettings Class


Marker Class

Model class for Scope Marker
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelMarker
TwinCAT.Measurement.Scope.API.ModelTimeMarker

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class Marker : ScopeMemberContainerBase, IValueToTimestampCollector
Public Class Marker
    Inherits ScopeMemberContainerBase
    Implements IValueToTimestampCollector
public ref class Marker : public ScopeMemberContainerBase,
    IValueToTimestampCollector

The Marker type exposes the following members.

Constructors
 | Name | Description
Public method | Marker | Create a new Marker with default Values
Public method | Marker(Marker) | Create a new Marker by Copying Properties from another Marker
Top
Properties
 | Name | Description
Public property | AttachToAxis | Gets or Sets the AttachToAxis. If AttachToAxis is True --> The position is an absolut value of this axis. If AttachToAxis is False --> The position is an relative value of the displayed axis.
Public property | AttachToAxisBrowsable |
Public property | Bandwidth | Gets or Sets the Bandwidth.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetNearestPosition | Get Field for GetNearestPosition Delegate
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineStyle | Gets or Sets the LineStyle.
Public property | Locked | Gets or Sets the Locked.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation.
Public property | Position | Gets or Sets the Position.
Public property | PositionPropertyUpdater |
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowPosition | Gets or Sets the ShowPosition.
Public property | ShowTitle | Gets or Sets the ShowTitle.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimePosition | Gets or Sets the TimePosition.
Public property | Title | Gets or Sets the Title (Overrides MeasurementMemberBaseTitle.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | ValuePrecision | Gets or Sets the ValuePrecision.
Public property | Visible | Gets or Sets the Visible.
Public property | Width | Gets or Sets the Width.
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddValue |
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | CalcTimePosition | Calculate the current timeposition with the given position
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ContainsChannelValue | Obsolete. Check if the Marker has an value from the channel
Public method | ContainsMemberValue | Check if the Marker has an value from the member
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllValues | Returns a copy of the ValueDictionary
Public method | GetChannelValue | Obsolete. Gets the channelvalue of the Marker
Public method | GetCommands | Gets the possible commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberValue | Gets the membervalue of the Marker
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubInterpreterValue |
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Get the Values for this Marker as string
Public method | Highlight | Highlight the Graph of this channel
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RefreshValue |
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts a Marker to string (Overrides ObjectToString.)
Public method | UpdatePropertyAttributes | Updates the Attributes of all Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | UpdateTimePosition | Calculate the current timeposition with the given position
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AttachToAxisChanged | Fired when the AttachToAxis is changed.
Public event | AttachToAxisValidating | Fired while validating the new value for AttachToAxis.
Public event | BandwidthChanged | Fired when the Bandwidth is changed.
Public event | BandwidthValidating | Fired while validating the new value for Bandwidth.
Public event | BeforePositionChanged | Fired before the position changed
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightEvent | Event fired when the marker should be highlighted
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineStyleChanged | Fired when the LineStyle is changed.
Public event | LineStyleValidating | Fired while validating the new value for LineStyle.
Public event | LockedChanged | Fired when the Locked is changed.
Public event | LockedValidating | Fired while validating the new value for Locked.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NewMarkerValues | Event fired when Values has Changed
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed.
Public event | OrientationValidating | Fired while validating the new value for Orientation.
Public event | PositionChanged | Fired when the Position is changed.
Public event | PositionValidating | Fired while validating the new value for Position.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowPositionChanged | Fired when the ShowPosition is changed.
Public event | ShowPositionValidating | Fired while validating the new value for ShowPosition.
Public event | ShowTitleChanged | Fired when the ShowTitle is changed.
Public event | ShowTitleValidating | Fired while validating the new value for ShowTitle.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimePositionChanged | Fired when the TimePosition is changed.
Public event | TimePositionValidating | Fired while validating the new value for TimePosition.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | ValueDictChanged | Fired when the ValueDict is changed.
Public event | ValueDictValidating | Fired while validating the new value for ValueDict.
Public event | ValuePrecisionChanged | Fired when the ValuePrecision is changed.
Public event | ValuePrecisionValidating | Fired while validating the new value for ValuePrecision.
Public event | VisibleChanged | Fired when the Visible is changed.
Public event | VisibleValidating | Fired while validating the new value for Visible.
Public event | WidthChanged | Fired when the Width is changed.
Public event | WidthValidating | Fired while validating the new value for Width.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


Marker Constructor

Overload List
 | Name | Description
Public method | Marker | Create a new Marker with default Values
Public method | Marker(Marker) | Create a new Marker by Copying Properties from another Marker
Top
See Also

Reference

Marker Class


Marker Constructor

Create a new Marker with default Values

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Marker()
Public Sub New
public:
Marker()
See Also

Reference

Marker Class
Marker Overload


Marker Constructor (Marker)

Create a new Marker by Copying Properties from another Marker

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Marker(
    Marker marker
)
Public Sub New (
    marker As Marker
)
public:
Marker(
    Marker^ marker
)

Parameters

marker
Type: TwinCAT.Measurement.Scope.API.ModelMarker
Marker to Copy from
See Also

Reference

Marker Class
Marker Overload


Marker Properties

The Marker type exposes the following members.

Properties
 | Name | Description
Public property | AttachToAxis | Gets or Sets the AttachToAxis. If AttachToAxis is True --> The position is an absolut value of this axis. If AttachToAxis is False --> The position is an relative value of the displayed axis.
Public property | AttachToAxisBrowsable |
Public property | Bandwidth | Gets or Sets the Bandwidth.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetNearestPosition | Get Field for GetNearestPosition Delegate
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineStyle | Gets or Sets the LineStyle.
Public property | Locked | Gets or Sets the Locked.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation.
Public property | Position | Gets or Sets the Position.
Public property | PositionPropertyUpdater |
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowPosition | Gets or Sets the ShowPosition.
Public property | ShowTitle | Gets or Sets the ShowTitle.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimePosition | Gets or Sets the TimePosition.
Public property | Title | Gets or Sets the Title (Overrides MeasurementMemberBaseTitle.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | ValuePrecision | Gets or Sets the ValuePrecision.
Public property | Visible | Gets or Sets the Visible.
Public property | Width | Gets or Sets the Width.
Top
See Also

Reference

Marker Class


Marker.AttachToAxis Property

Gets or Sets the AttachToAxis. If AttachToAxis is True --> The position is an absolut value of this axis. If AttachToAxis is False --> The position is an relative value of the displayed axis.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool AttachToAxis { get; set; }
<BrowsableAttribute(true)>
Public Property AttachToAxis As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool AttachToAxis {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Marker Class


Marker.AttachToAxisBrowsable Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool AttachToAxisBrowsable { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property AttachToAxisBrowsable As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool AttachToAxisBrowsable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Marker Class


Marker.Bandwidth Property

Gets or Sets the Bandwidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double Bandwidth { get; set; }
<BrowsableAttribute(true)>
Public Property Bandwidth As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double Bandwidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Marker Class


Marker.DisplayColor Property

Gets or Sets the DisplayColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public override Color DisplayColor { get; set; }
<BrowsableAttribute(true)>
Public Overrides Property DisplayColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property Color DisplayColor {
    Color get () override;
    void set (Color value) override;
}

Property Value

Type: Color
See Also

Reference

Marker Class


Marker.GetNearestPosition Property

Get Field for GetNearestPosition Delegate

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public DelGetNearestPosition GetNearestPosition { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property GetNearestPosition As DelGetNearestPosition
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property DelGetNearestPosition^ GetNearestPosition {
    DelGetNearestPosition^ get ();
    void set (DelGetNearestPosition^ value);
}

Property Value

Type: DelGetNearestPosition
See Also

Reference

Marker Class


Marker.LineStyle Property

Gets or Sets the LineStyle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public DashStyle LineStyle { get; set; }
<BrowsableAttribute(true)>
Public Property LineStyle As DashStyle
    Get
    Set
public:
[BrowsableAttribute(true)]
property DashStyle LineStyle {
    DashStyle get ();
    void set (DashStyle value);
}

Property Value

Type: DashStyle
See Also

Reference

Marker Class


Marker.Locked Property

Gets or Sets the Locked.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Locked { get; set; }
<BrowsableAttribute(true)>
Public Property Locked As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Locked {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Marker Class


Marker.Orientation Property

Gets or Sets the Orientation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public CursorAlignment Orientation { get; set; }
<BrowsableAttribute(false)>
Public Property Orientation As CursorAlignment
    Get
    Set
public:
[BrowsableAttribute(false)]
property CursorAlignment Orientation {
    CursorAlignment get ();
    void set (CursorAlignment value);
}

Property Value

Type: CursorAlignment
See Also

Reference

Marker Class


Marker.Position Property

Gets or Sets the Position.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double Position { get; set; }
<BrowsableAttribute(true)>
Public Property Position As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double Position {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Marker Class


Marker.PositionPropertyUpdater Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public PropertyUpdater PositionPropertyUpdater { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property PositionPropertyUpdater As PropertyUpdater
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property PropertyUpdater^ PositionPropertyUpdater {
    PropertyUpdater^ get ();
}

Property Value

Type: PropertyUpdater
See Also

Reference

Marker Class


Marker.ShowPosition Property

Gets or Sets the ShowPosition.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowPosition { get; set; }
<BrowsableAttribute(true)>
Public Property ShowPosition As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowPosition {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Marker Class


Marker.ShowTitle Property

Gets or Sets the ShowTitle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowTitle { get; set; }
<BrowsableAttribute(true)>
Public Property ShowTitle As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowTitle {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Marker Class


Marker.TimePosition Property

Gets or Sets the TimePosition.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long TimePosition { get; set; }
<BrowsableAttribute(true)>
Public Property TimePosition As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long TimePosition {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

Marker Class


Marker.Title Property

Gets or Sets the Title

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string Title { get; set; }
Public Overrides Property Title As String
    Get
    Set
public:
virtual property String^ Title {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
See Also

Reference

Marker Class


Marker.ValuePrecision Property

Gets or Sets the ValuePrecision.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int ValuePrecision { get; set; }
<BrowsableAttribute(true)>
Public Property ValuePrecision As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int ValuePrecision {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Marker Class


Marker.Visible Property

Gets or Sets the Visible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Visible { get; set; }
<BrowsableAttribute(true)>
Public Property Visible As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Visible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Marker Class


Marker.Width Property

Gets or Sets the Width.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int Width { get; set; }
<BrowsableAttribute(true)>
Public Property Width As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int Width {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Marker Class


Marker Methods

The Marker type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddValue |
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | CalcTimePosition | Calculate the current timeposition with the given position
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ContainsChannelValue | Obsolete. Check if the Marker has an value from the channel
Public method | ContainsMemberValue | Check if the Marker has an value from the member
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllValues | Returns a copy of the ValueDictionary
Public method | GetChannelValue | Obsolete. Gets the channelvalue of the Marker
Public method | GetCommands | Gets the possible commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberValue | Gets the membervalue of the Marker
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubInterpreterValue |
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Get the Values for this Marker as string
Public method | Highlight | Highlight the Graph of this channel
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RefreshValue |
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts a Marker to string (Overrides ObjectToString.)
Public method | UpdatePropertyAttributes | Updates the Attributes of all Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | UpdateTimePosition | Calculate the current timeposition with the given position
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

Marker Class


Marker.AddValue Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void AddValue(
    Channel channel,
    Object value
)
Public Overridable Sub AddValue (
    channel As Channel,
    value As Object
)
public:
virtual void AddValue(
    Channel^ channel,
    Object^ value
)

Parameters

channel
Type: TwinCAT.Measurement.Scope.API.ModelChannel
value
Type: SystemObject
See Also

Reference

Marker Class


Marker.CalcTimePosition Method

Calculate the current timeposition with the given position

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long CalcTimePosition(
    long startPosition,
    long displayWidth
)
Public Function CalcTimePosition (
    startPosition As Long,
    displayWidth As Long
) As Long
public:
long long CalcTimePosition(
    long long startPosition,
    long long displayWidth
)

Parameters

startPosition
Type: SystemInt64
StartPosition for the percentage position
displayWidth
Type: SystemInt64
DisplayWidth for the percentage position

Return Value

Type: Int64
Time Position
See Also

Reference

Marker Class


Marker.ContainsChannelValue Method

Note: This API is now obsolete.

Check if the Marker has an value from the channel

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the Method ContainsMemberValue.", false)]
public bool ContainsChannelValue(
    Channel channel
)
<ObsoleteAttribute("Please use the Method ContainsMemberValue.", false)>
Public Function ContainsChannelValue (
    channel As Channel
) As Boolean
public:
[ObsoleteAttribute(L"Please use the Method ContainsMemberValue.", false)]
bool ContainsChannelValue(
    Channel^ channel
)

Parameters

channel
Type: TwinCAT.Measurement.Scope.API.ModelChannel

Return Value

Type: Boolean
See Also

Reference

Marker Class


Marker.ContainsMemberValue Method

Check if the Marker has an value from the member

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool ContainsMemberValue(
    MeasurementMemberBase member
)
Public Function ContainsMemberValue (
    member As MeasurementMemberBase
) As Boolean
public:
bool ContainsMemberValue(
    MeasurementMemberBase^ member
)

Parameters

member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase

Return Value

Type: Boolean
See Also

Reference

Marker Class


Marker.GetAllValues Method

Returns a copy of the ValueDictionary

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Dictionary<MeasurementMemberBase, Object> GetAllValues()
Public Function GetAllValues As Dictionary(Of MeasurementMemberBase, Object)
public:
Dictionary<MeasurementMemberBase^, Object^>^ GetAllValues()

Return Value

Type: Dictionary MeasurementMemberBase, Object
See Also

Reference

Marker Class


Marker.GetChannelValue Method

Note: This API is now obsolete.

Gets the channelvalue of the Marker

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[ObsoleteAttribute("Please use the Method GetMemberValue.", false)]
public Object GetChannelValue(
    Channel channel
)
<ObsoleteAttribute("Please use the Method GetMemberValue.", false)>
Public Function GetChannelValue (
    channel As Channel
) As Object
public:
[ObsoleteAttribute(L"Please use the Method GetMemberValue.", false)]
Object^ GetChannelValue(
    Channel^ channel
)

Parameters

channel
Type: TwinCAT.Measurement.Scope.API.ModelChannel

Return Value

Type: Object
See Also

Reference

Marker Class


Marker.GetCommands Method

Gets the possible commands

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
See Also

Reference

Marker Class


Marker.GetMemberValue Method

Gets the membervalue of the Marker

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Object GetMemberValue(
    MeasurementMemberBase member
)
Public Function GetMemberValue (
    member As MeasurementMemberBase
) As Object
public:
virtual Object^ GetMemberValue(
    MeasurementMemberBase^ member
) sealed

Parameters

member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase

Return Value

Type: Object

Implements

IValueToTimestampCollectorGetMemberValue(MeasurementMemberBase)
See Also

Reference

Marker Class


Marker.GetSubInterpreterValue Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Object GetSubInterpreterValue(
    MeasurementMemberBase member,
    AcquisitionInterpreter subAcquisitionInterpreter
)
Public Function GetSubInterpreterValue (
    member As MeasurementMemberBase,
    subAcquisitionInterpreter As AcquisitionInterpreter
) As Object
public:
virtual Object^ GetSubInterpreterValue(
    MeasurementMemberBase^ member,
    AcquisitionInterpreter^ subAcquisitionInterpreter
) sealed

Parameters

member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
subAcquisitionInterpreter
Type: TwinCAT.Measurement.Scope.API.ModelAcquisitionInterpreter

Return Value

Type: Object

Implements

IValueToTimestampCollectorGetSubInterpreterValue(MeasurementMemberBase, AcquisitionInterpreter)
See Also

Reference

Marker Class


Marker.GetValues Method

Get the Values for this Marker as string

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string GetValues()
Public Function GetValues As String
public:
String^ GetValues()

Return Value

Type: String
See Also

Reference

Marker Class


Marker.Highlight Method

Highlight the Graph of this channel

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Highlight()
Public Sub Highlight
public:
virtual void Highlight() sealed
See Also

Reference

Marker Class


Marker.RefreshValue Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void RefreshValue(
    PropertyUpdater propertyUpdater,
    Object setter
)
Public Sub RefreshValue (
    propertyUpdater As PropertyUpdater,
    setter As Object
)
public:
void RefreshValue(
    PropertyUpdater^ propertyUpdater,
    Object^ setter
)

Parameters

propertyUpdater
Type: TwinCAT.Measurement.Scope.APIPropertyUpdater
setter
Type: SystemObject
See Also

Reference

Marker Class


Marker.ToString Method

Converts a Marker to string

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
The Name of the Marker
See Also

Reference

Marker Class


Marker.UpdatePropertyAttributes Method

Updates the Attributes of all Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

Marker Class


Marker.UpdateTimePosition Method

Calculate the current timeposition with the given position

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void UpdateTimePosition(
    long startPosition,
    long displayWidth
)
Public Sub UpdateTimePosition (
    startPosition As Long,
    displayWidth As Long
)
public:
void UpdateTimePosition(
    long long startPosition,
    long long displayWidth
)

Parameters

startPosition
Type: SystemInt64
StartPosition for the percentage position
displayWidth
Type: SystemInt64
DisplayWidth for the percentage position
See Also

Reference

Marker Class


Marker Events

The Marker type exposes the following members.

Events
 | Name | Description
Public event | AttachToAxisChanged | Fired when the AttachToAxis is changed.
Public event | AttachToAxisValidating | Fired while validating the new value for AttachToAxis.
Public event | BandwidthChanged | Fired when the Bandwidth is changed.
Public event | BandwidthValidating | Fired while validating the new value for Bandwidth.
Public event | BeforePositionChanged | Fired before the position changed
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightEvent | Event fired when the marker should be highlighted
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineStyleChanged | Fired when the LineStyle is changed.
Public event | LineStyleValidating | Fired while validating the new value for LineStyle.
Public event | LockedChanged | Fired when the Locked is changed.
Public event | LockedValidating | Fired while validating the new value for Locked.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NewMarkerValues | Event fired when Values has Changed
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed.
Public event | OrientationValidating | Fired while validating the new value for Orientation.
Public event | PositionChanged | Fired when the Position is changed.
Public event | PositionValidating | Fired while validating the new value for Position.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowPositionChanged | Fired when the ShowPosition is changed.
Public event | ShowPositionValidating | Fired while validating the new value for ShowPosition.
Public event | ShowTitleChanged | Fired when the ShowTitle is changed.
Public event | ShowTitleValidating | Fired while validating the new value for ShowTitle.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimePositionChanged | Fired when the TimePosition is changed.
Public event | TimePositionValidating | Fired while validating the new value for TimePosition.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | ValueDictChanged | Fired when the ValueDict is changed.
Public event | ValueDictValidating | Fired while validating the new value for ValueDict.
Public event | ValuePrecisionChanged | Fired when the ValuePrecision is changed.
Public event | ValuePrecisionValidating | Fired while validating the new value for ValuePrecision.
Public event | VisibleChanged | Fired when the Visible is changed.
Public event | VisibleValidating | Fired while validating the new value for Visible.
Public event | WidthChanged | Fired when the Width is changed.
Public event | WidthValidating | Fired while validating the new value for Width.
Top
See Also

Reference

Marker Class


Marker.AttachToAxisChanged Event

Fired when the AttachToAxis is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AttachToAxisChanged
Public Event AttachToAxisChanged As EventHandler
public:
 event EventHandler^ AttachToAxisChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.AttachToAxisValidating Event

Fired while validating the new value for AttachToAxis.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AttachToAxisValidating
Public Event AttachToAxisValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AttachToAxisValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Marker Class


Marker.BandwidthChanged Event

Fired when the Bandwidth is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BandwidthChanged
Public Event BandwidthChanged As EventHandler
public:
 event EventHandler^ BandwidthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.BandwidthValidating Event

Fired while validating the new value for Bandwidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> BandwidthValidating
Public Event BandwidthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ BandwidthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Marker Class


Marker.BeforePositionChanged Event

Fired before the position changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforePositionChanged
Public Event BeforePositionChanged As EventHandler
public:
 event EventHandler^ BeforePositionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.HighlightEvent Event

Event fired when the marker should be highlighted

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler HighlightEvent
Public Event HighlightEvent As EventHandler
public:
 event EventHandler^ HighlightEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.LineStyleChanged Event

Fired when the LineStyle is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LineStyleChanged
Public Event LineStyleChanged As EventHandler
public:
 event EventHandler^ LineStyleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.LineStyleValidating Event

Fired while validating the new value for LineStyle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LineStyleValidating
Public Event LineStyleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LineStyleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Marker Class


Marker.LockedChanged Event

Fired when the Locked is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LockedChanged
Public Event LockedChanged As EventHandler
public:
 event EventHandler^ LockedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.LockedValidating Event

Fired while validating the new value for Locked.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LockedValidating
Public Event LockedValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LockedValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Marker Class


Marker.NewMarkerValues Event

Event fired when Values has Changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler NewMarkerValues
Public Event NewMarkerValues As EventHandler
public:
 event EventHandler^ NewMarkerValues {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.OrientationChanged Event

Fired when the Orientation is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OrientationChanged
Public Event OrientationChanged As EventHandler
public:
 event EventHandler^ OrientationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.OrientationValidating Event

Fired while validating the new value for Orientation.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> OrientationValidating
Public Event OrientationValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ OrientationValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Marker Class


Marker.PositionChanged Event

Fired when the Position is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PositionChanged
Public Event PositionChanged As EventHandler
public:
 event EventHandler^ PositionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.PositionValidating Event

Fired while validating the new value for Position.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PositionValidating
Public Event PositionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PositionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Marker Class


Marker.ShowPositionChanged Event

Fired when the ShowPosition is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowPositionChanged
Public Event ShowPositionChanged As EventHandler
public:
 event EventHandler^ ShowPositionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.ShowPositionValidating Event

Fired while validating the new value for ShowPosition.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowPositionValidating
Public Event ShowPositionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowPositionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Marker Class


Marker.ShowTitleChanged Event

Fired when the ShowTitle is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowTitleChanged
Public Event ShowTitleChanged As EventHandler
public:
 event EventHandler^ ShowTitleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.ShowTitleValidating Event

Fired while validating the new value for ShowTitle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowTitleValidating
Public Event ShowTitleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowTitleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Marker Class


Marker.TimePositionChanged Event

Fired when the TimePosition is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TimePositionChanged
Public Event TimePositionChanged As EventHandler
public:
 event EventHandler^ TimePositionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.TimePositionValidating Event

Fired while validating the new value for TimePosition.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TimePositionValidating
Public Event TimePositionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TimePositionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Marker Class


Marker.ValueDictChanged Event

Fired when the ValueDict is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ValueDictChanged
Public Event ValueDictChanged As EventHandler
public:
 event EventHandler^ ValueDictChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.ValueDictValidating Event

Fired while validating the new value for ValueDict.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ValueDictValidating
Public Event ValueDictValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ValueDictValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Marker Class


Marker.ValuePrecisionChanged Event

Fired when the ValuePrecision is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ValuePrecisionChanged
Public Event ValuePrecisionChanged As EventHandler
public:
 event EventHandler^ ValuePrecisionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.ValuePrecisionValidating Event

Fired while validating the new value for ValuePrecision.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ValuePrecisionValidating
Public Event ValuePrecisionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ValuePrecisionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Marker Class


Marker.VisibleChanged Event

Fired when the Visible is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler VisibleChanged
Public Event VisibleChanged As EventHandler
public:
 event EventHandler^ VisibleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.VisibleValidating Event

Fired while validating the new value for Visible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> VisibleValidating
Public Event VisibleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ VisibleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Marker Class


Marker.WidthChanged Event

Fired when the Width is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler WidthChanged
Public Event WidthChanged As EventHandler
public:
 event EventHandler^ WidthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Marker Class


Marker.WidthValidating Event

Fired while validating the new value for Width.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> WidthValidating
Public Event WidthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ WidthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Marker Class


MarkerContainer Class

Container for all marker in a AxisGroup
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelMarkerContainer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class MarkerContainer : ScopeMemberContainerBase
Public Class MarkerContainer
    Inherits ScopeMemberContainerBase
public ref class MarkerContainer : public ScopeMemberContainerBase

The MarkerContainer type exposes the following members.

Constructors
 | Name | Description
Public method | MarkerContainer | Create a new MarkerContainer
Public method | MarkerContainer(MarkerContainer) | Create a new MarkerContainer by copying properties from another MarkerContainer
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Get the Commands for the ContextMenu (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnlockedUserUsableMarker |
Public method | GetUserUsableMarker |
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MarkerContainer Constructor

Overload List
 | Name | Description
Public method | MarkerContainer | Create a new MarkerContainer
Public method | MarkerContainer(MarkerContainer) | Create a new MarkerContainer by copying properties from another MarkerContainer
Top
See Also

Reference

MarkerContainer Class


MarkerContainer Constructor

Create a new MarkerContainer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerContainer()
Public Sub New
public:
MarkerContainer()
See Also

Reference

MarkerContainer Class
MarkerContainer Overload


MarkerContainer Constructor (MarkerContainer)

Create a new MarkerContainer by copying properties from another MarkerContainer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerContainer(
    MarkerContainer mc
)
Public Sub New (
    mc As MarkerContainer
)
public:
MarkerContainer(
    MarkerContainer^ mc
)

Parameters

mc
Type: TwinCAT.Measurement.Scope.API.ModelMarkerContainer
See Also

Reference

MarkerContainer Class
MarkerContainer Overload


MarkerContainer Properties

The MarkerContainer type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MarkerContainer Class


MarkerContainer Methods

The MarkerContainer type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Get the Commands for the ContextMenu (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnlockedUserUsableMarker |
Public method | GetUserUsableMarker |
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MarkerContainer Class


MarkerContainer.GetCommands Method

Get the Commands for the ContextMenu

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
An Array of MenuCommands
See Also

Reference

MarkerContainer Class


MarkerContainer.GetUnlockedUserUsableMarker Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<Marker> GetUnlockedUserUsableMarker()
Public Function GetUnlockedUserUsableMarker As IEnumerable(Of Marker)
public:
IEnumerable<Marker^>^ GetUnlockedUserUsableMarker()

Return Value

Type: IEnumerable Marker
See Also

Reference

MarkerContainer Class


MarkerContainer.GetUserUsableMarker Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<Marker> GetUserUsableMarker()
Public Function GetUserUsableMarker As IEnumerable(Of Marker)
public:
IEnumerable<Marker^>^ GetUserUsableMarker()

Return Value

Type: IEnumerable Marker
See Also

Reference

MarkerContainer Class


MarkerContainer.UpdatePropertyAttributes Method

Sets the value off Propertyattributes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

MarkerContainer Class


MarkerContainer Events

The MarkerContainer type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MarkerContainer Class


MarkerControlStyle Class

MarkerControlStyle Class - Modelclass of an Marker Table
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelMarkerControlStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class MarkerControlStyle : ScopeMemberContainerBase
Public Class MarkerControlStyle
    Inherits ScopeMemberContainerBase
public ref class MarkerControlStyle : public ScopeMemberContainerBase

The MarkerControlStyle type exposes the following members.

Constructors
 | Name | Description
Public method | MarkerControlStyle | Create a new MarkerControlStyle
Public method | MarkerControlStyle(MarkerControlStyle) | Create a new MarkerControls Style by Copying Properties from another MarkerControlStyle
Top
Properties
 | Name | Description
Public property | AutoMarkerDiffs | Gets or Sets the AutoMarkerDiffs.
Public property | BindMarkerInRows | Gets or Sets the Bindable Property of MarkerInRows
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | MarkerInRows | Gets or Sets the MarkerInRows.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReferencedMember | Gets or Sets the ReferencedMember.
Public property | ReferencedMemberGuid | Gets or Sets the ReferencedMemberGuid.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowAbsoluteTimes | Gets or Sets the ShowAbsoluteTimes.
Public property | ShowColoredDot | Gets or Sets the ShowColoredDot.
Public property | ShowColoredText | Gets or Sets the ShowColoredText.
Public property | ShowHexValues | Gets or Sets the ShowHexValues.
Public property | ShowUnits | Gets or Sets the ShowUnits.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | WidthValues | Gets or Sets the WidthValues.
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AutoFill | Auto fill the Table with all values from the referenced Member
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AutoMarkerDiffsChanged | Fired when the AutoMarkerDiffs is changed.
Public event | AutoMarkerDiffsValidating | Fired while validating the new value for AutoMarkerDiffs.
Public event | BeforeReferencedMemberChanged | Fired before the ReferencedMember Changed
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MarkerInRowsChanged | Fired when the MarkerInRows is changed.
Public event | MarkerInRowsValidating | Fired while validating the new value for MarkerInRows.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReferencedMemberChanged | Fired when the ReferencedMember is changed.
Public event | ReferencedMemberGuidChanged | Fired when the ReferencedMemberGuid is changed.
Public event | ReferencedMemberGuidValidating | Fired while validating the new value for ReferencedMemberGuid.
Public event | ReferencedMemberValidating | Fired while validating the new value for ReferencedMember.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowAbsoluteTimesChanged | Fired when the ShowAbsoluteTimes is changed.
Public event | ShowAbsoluteTimesValidating | Fired while validating the new value for ShowAbsoluteTimes.
Public event | ShowColoredDotChanged | Fired when the ShowColoredDot is changed.
Public event | ShowColoredDotValidating | Fired while validating the new value for ShowColoredDot.
Public event | ShowColoredTextChanged | Fired when the ShowColoredText is changed.
Public event | ShowColoredTextValidating | Fired while validating the new value for ShowColoredText.
Public event | ShowHexValuesChanged | Fired when the ShowHexValues is changed.
Public event | ShowHexValuesValidating | Fired while validating the new value for ShowHexValues.
Public event | ShowUnitsChanged | Fired when the ShowUnits is changed.
Public event | ShowUnitsValidating | Fired while validating the new value for ShowUnits.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | WidthValuesChanged | Fired when the WidthValues is changed.
Public event | WidthValuesValidating | Fired while validating the new value for WidthValues.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MarkerControlStyle Constructor

Overload List
 | Name | Description
Public method | MarkerControlStyle | Create a new MarkerControlStyle
Public method | MarkerControlStyle(MarkerControlStyle) | Create a new MarkerControls Style by Copying Properties from another MarkerControlStyle
Top
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle Constructor

Create a new MarkerControlStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerControlStyle()
Public Sub New
public:
MarkerControlStyle()
See Also

Reference

MarkerControlStyle Class
MarkerControlStyle Overload


MarkerControlStyle Constructor (MarkerControlStyle)

Create a new MarkerControls Style by Copying Properties from another MarkerControlStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerControlStyle(
    MarkerControlStyle markerControlStyle
)
Public Sub New (
    markerControlStyle As MarkerControlStyle
)
public:
MarkerControlStyle(
    MarkerControlStyle^ markerControlStyle
)

Parameters

markerControlStyle
Type: TwinCAT.Measurement.Scope.API.ModelMarkerControlStyle
See Also

Reference

MarkerControlStyle Class
MarkerControlStyle Overload


MarkerControlStyle Properties

The MarkerControlStyle type exposes the following members.

Properties
 | Name | Description
Public property | AutoMarkerDiffs | Gets or Sets the AutoMarkerDiffs.
Public property | BindMarkerInRows | Gets or Sets the Bindable Property of MarkerInRows
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | MarkerInRows | Gets or Sets the MarkerInRows.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReferencedMember | Gets or Sets the ReferencedMember.
Public property | ReferencedMemberGuid | Gets or Sets the ReferencedMemberGuid.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowAbsoluteTimes | Gets or Sets the ShowAbsoluteTimes.
Public property | ShowColoredDot | Gets or Sets the ShowColoredDot.
Public property | ShowColoredText | Gets or Sets the ShowColoredText.
Public property | ShowHexValues | Gets or Sets the ShowHexValues.
Public property | ShowUnits | Gets or Sets the ShowUnits.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | WidthValues | Gets or Sets the WidthValues.
Top
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.AutoMarkerDiffs Property

Gets or Sets the AutoMarkerDiffs.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool AutoMarkerDiffs { get; set; }
<BrowsableAttribute(true)>
Public Property AutoMarkerDiffs As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool AutoMarkerDiffs {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.BindMarkerInRows Property

Gets or Sets the Bindable Property of MarkerInRows

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool BindMarkerInRows { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property BindMarkerInRows As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool BindMarkerInRows {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.MarkerInRows Property

Gets or Sets the MarkerInRows.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool MarkerInRows { get; set; }
<BrowsableAttribute(false)>
Public Property MarkerInRows As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool MarkerInRows {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ReferencedMember Property

Gets or Sets the ReferencedMember.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
public MeasurementMemberBase ReferencedMember { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(true)>
Public Property ReferencedMember As MeasurementMemberBase
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
property MeasurementMemberBase^ ReferencedMember {
    MeasurementMemberBase^ get ();
    void set (MeasurementMemberBase^ value);
}

Property Value

Type: MeasurementMemberBase
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ReferencedMemberGuid Property

Gets or Sets the ReferencedMemberGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Guid ReferencedMemberGuid { get; set; }
<BrowsableAttribute(true)>
Public Property ReferencedMemberGuid As Guid
    Get
    Set
public:
[BrowsableAttribute(true)]
property Guid ReferencedMemberGuid {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowAbsoluteTimes Property

Gets or Sets the ShowAbsoluteTimes.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowAbsoluteTimes { get; set; }
<BrowsableAttribute(true)>
Public Property ShowAbsoluteTimes As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowAbsoluteTimes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowColoredDot Property

Gets or Sets the ShowColoredDot.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowColoredDot { get; set; }
<BrowsableAttribute(true)>
Public Property ShowColoredDot As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowColoredDot {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowColoredText Property

Gets or Sets the ShowColoredText.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowColoredText { get; set; }
<BrowsableAttribute(true)>
Public Property ShowColoredText As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowColoredText {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowHexValues Property

Gets or Sets the ShowHexValues.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowHexValues { get; set; }
<BrowsableAttribute(true)>
Public Property ShowHexValues As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowHexValues {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowUnits Property

Gets or Sets the ShowUnits.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowUnits { get; set; }
<BrowsableAttribute(true)>
Public Property ShowUnits As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowUnits {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.WidthValues Property

Gets or Sets the WidthValues.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlElementAttribute(typeof(List<double>))]
[BrowsableAttribute(false)]
public List<double> WidthValues { get; set; }
<XmlElementAttribute(GetType(List(Of Double)))>
<BrowsableAttribute(false)>
Public Property WidthValues As List(Of Double)
    Get
    Set
public:
[XmlElementAttribute(typeof(List<double>))]
[BrowsableAttribute(false)]
property List<double>^ WidthValues {
    List<double>^ get ();
    void set (List<double>^ value);
}

Property Value

Type: List Double
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle Methods

The MarkerControlStyle type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AutoFill | Auto fill the Table with all values from the referenced Member
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.AutoFill Method

Auto fill the Table with all values from the referenced Member

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void AutoFill()
Public Sub AutoFill
public:
void AutoFill()
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle Events

The MarkerControlStyle type exposes the following members.

Events
 | Name | Description
Public event | AutoMarkerDiffsChanged | Fired when the AutoMarkerDiffs is changed.
Public event | AutoMarkerDiffsValidating | Fired while validating the new value for AutoMarkerDiffs.
Public event | BeforeReferencedMemberChanged | Fired before the ReferencedMember Changed
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MarkerInRowsChanged | Fired when the MarkerInRows is changed.
Public event | MarkerInRowsValidating | Fired while validating the new value for MarkerInRows.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReferencedMemberChanged | Fired when the ReferencedMember is changed.
Public event | ReferencedMemberGuidChanged | Fired when the ReferencedMemberGuid is changed.
Public event | ReferencedMemberGuidValidating | Fired while validating the new value for ReferencedMemberGuid.
Public event | ReferencedMemberValidating | Fired while validating the new value for ReferencedMember.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowAbsoluteTimesChanged | Fired when the ShowAbsoluteTimes is changed.
Public event | ShowAbsoluteTimesValidating | Fired while validating the new value for ShowAbsoluteTimes.
Public event | ShowColoredDotChanged | Fired when the ShowColoredDot is changed.
Public event | ShowColoredDotValidating | Fired while validating the new value for ShowColoredDot.
Public event | ShowColoredTextChanged | Fired when the ShowColoredText is changed.
Public event | ShowColoredTextValidating | Fired while validating the new value for ShowColoredText.
Public event | ShowHexValuesChanged | Fired when the ShowHexValues is changed.
Public event | ShowHexValuesValidating | Fired while validating the new value for ShowHexValues.
Public event | ShowUnitsChanged | Fired when the ShowUnits is changed.
Public event | ShowUnitsValidating | Fired while validating the new value for ShowUnits.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | WidthValuesChanged | Fired when the WidthValues is changed.
Public event | WidthValuesValidating | Fired while validating the new value for WidthValues.
Top
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.AutoMarkerDiffsChanged Event

Fired when the AutoMarkerDiffs is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoMarkerDiffsChanged
Public Event AutoMarkerDiffsChanged As EventHandler
public:
 event EventHandler^ AutoMarkerDiffsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.AutoMarkerDiffsValidating Event

Fired while validating the new value for AutoMarkerDiffs.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoMarkerDiffsValidating
Public Event AutoMarkerDiffsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoMarkerDiffsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.BeforeReferencedMemberChanged Event

Fired before the ReferencedMember Changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeReferencedMemberChanged
Public Event BeforeReferencedMemberChanged As EventHandler
public:
 event EventHandler^ BeforeReferencedMemberChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.MarkerInRowsChanged Event

Fired when the MarkerInRows is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler MarkerInRowsChanged
Public Event MarkerInRowsChanged As EventHandler
public:
 event EventHandler^ MarkerInRowsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.MarkerInRowsValidating Event

Fired while validating the new value for MarkerInRows.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> MarkerInRowsValidating
Public Event MarkerInRowsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ MarkerInRowsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ReferencedMemberChanged Event

Fired when the ReferencedMember is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReferencedMemberChanged
Public Event ReferencedMemberChanged As EventHandler
public:
 event EventHandler^ ReferencedMemberChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ReferencedMemberGuidChanged Event

Fired when the ReferencedMemberGuid is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReferencedMemberGuidChanged
Public Event ReferencedMemberGuidChanged As EventHandler
public:
 event EventHandler^ ReferencedMemberGuidChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ReferencedMemberGuidValidating Event

Fired while validating the new value for ReferencedMemberGuid.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReferencedMemberGuidValidating
Public Event ReferencedMemberGuidValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReferencedMemberGuidValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ReferencedMemberValidating Event

Fired while validating the new value for ReferencedMember.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReferencedMemberValidating
Public Event ReferencedMemberValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReferencedMemberValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowAbsoluteTimesChanged Event

Fired when the ShowAbsoluteTimes is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowAbsoluteTimesChanged
Public Event ShowAbsoluteTimesChanged As EventHandler
public:
 event EventHandler^ ShowAbsoluteTimesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowAbsoluteTimesValidating Event

Fired while validating the new value for ShowAbsoluteTimes.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowAbsoluteTimesValidating
Public Event ShowAbsoluteTimesValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowAbsoluteTimesValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowColoredDotChanged Event

Fired when the ShowColoredDot is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowColoredDotChanged
Public Event ShowColoredDotChanged As EventHandler
public:
 event EventHandler^ ShowColoredDotChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowColoredDotValidating Event

Fired while validating the new value for ShowColoredDot.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowColoredDotValidating
Public Event ShowColoredDotValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowColoredDotValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowColoredTextChanged Event

Fired when the ShowColoredText is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowColoredTextChanged
Public Event ShowColoredTextChanged As EventHandler
public:
 event EventHandler^ ShowColoredTextChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowColoredTextValidating Event

Fired while validating the new value for ShowColoredText.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowColoredTextValidating
Public Event ShowColoredTextValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowColoredTextValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowHexValuesChanged Event

Fired when the ShowHexValues is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowHexValuesChanged
Public Event ShowHexValuesChanged As EventHandler
public:
 event EventHandler^ ShowHexValuesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowHexValuesValidating Event

Fired while validating the new value for ShowHexValues.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowHexValuesValidating
Public Event ShowHexValuesValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowHexValuesValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowUnitsChanged Event

Fired when the ShowUnits is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowUnitsChanged
Public Event ShowUnitsChanged As EventHandler
public:
 event EventHandler^ ShowUnitsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.ShowUnitsValidating Event

Fired while validating the new value for ShowUnits.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowUnitsValidating
Public Event ShowUnitsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowUnitsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.WidthValuesChanged Event

Fired when the WidthValues is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler WidthValuesChanged
Public Event WidthValuesChanged As EventHandler
public:
 event EventHandler^ WidthValuesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerControlStyle Class


MarkerControlStyle.WidthValuesValidating Event

Fired while validating the new value for WidthValues.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> WidthValuesValidating
Public Event WidthValuesValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ WidthValuesValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerControlStyle Class


MarkerTable_Container Class

Abstract class of the Container Models
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelMarkerTable_Container
TwinCAT.Measurement.Scope.API.ModelMarkerTable_PairContainer
TwinCAT.Measurement.Scope.API.ModelMarkerTable_SingleContainer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class MarkerTable_Container : ScopeMemberBase
Public MustInherit Class MarkerTable_Container
    Inherits ScopeMemberBase
public ref class MarkerTable_Container abstract : public ScopeMemberBase

The MarkerTable_Container type exposes the following members.

Constructors
 | Name | Description
Public method | MarkerTable_Container | Ctor of MarkerTable_Container
Public method | MarkerTable_Container(MarkerTable_Container) | Ctor of MarkerTable_Container
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | Type | Gets or Sets the Type.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMissingElements |
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MissingElements |
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetElementForGuid |
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | SetRemainingElements |
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ElementGuidChanged |
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TypeChanged | Fired when the Type is changed.
Public event | TypeValidating | Fired while validating the new value for Type.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateRelatedValue |
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MarkerTable_Container Constructor

Overload List
 | Name | Description
Public method | MarkerTable_Container | Ctor of MarkerTable_Container
Public method | MarkerTable_Container(MarkerTable_Container) | Ctor of MarkerTable_Container
Top
See Also

Reference

MarkerTable_Container Class


MarkerTable_Container Constructor

Ctor of MarkerTable_Container

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerTable_Container()
Public Sub New
public:
MarkerTable_Container()
See Also

Reference

MarkerTable_Container Class
MarkerTable_Container Overload


MarkerTable_Container Constructor (MarkerTable_Container)

Ctor of MarkerTable_Container

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerTable_Container(
    MarkerTable_Container markerTable_Container
)
Public Sub New (
    markerTable_Container As MarkerTable_Container
)
public:
MarkerTable_Container(
    MarkerTable_Container^ markerTable_Container
)

Parameters

markerTable_Container
Type: TwinCAT.Measurement.Scope.API.ModelMarkerTable_Container
See Also

Reference

MarkerTable_Container Class
MarkerTable_Container Overload


MarkerTable_Container Properties

The MarkerTable_Container type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | Type | Gets or Sets the Type.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MarkerTable_Container Class


MarkerTable_Container.Type Property

Gets or Sets the Type.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public MarkerTable_ChooserType Type { get; set; }
<BrowsableAttribute(true)>
Public Property Type As MarkerTable_ChooserType
    Get
    Set
public:
[BrowsableAttribute(true)]
property MarkerTable_ChooserType Type {
    MarkerTable_ChooserType get ();
    void set (MarkerTable_ChooserType value);
}

Property Value

Type: MarkerTable_ChooserType
See Also

Reference

MarkerTable_Container Class


MarkerTable_Container Methods

The MarkerTable_Container type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMissingElements |
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MissingElements |
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetElementForGuid |
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | SetRemainingElements |
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MarkerTable_Container Class


MarkerTable_Container.HasMissingElements Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool HasMissingElements()
Public Function HasMissingElements As Boolean
public:
bool HasMissingElements()

Return Value

Type: Boolean
See Also

Reference

MarkerTable_Container Class


MarkerTable_Container.MissingElements Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract IEnumerable<Guid> MissingElements()
Public MustOverride Function MissingElements As IEnumerable(Of Guid)
public:
virtual IEnumerable<Guid>^ MissingElements() abstract

Return Value

Type: IEnumerable Guid
See Also

Reference

MarkerTable_Container Class


MarkerTable_Container.SetElementForGuid Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract void SetElementForGuid(
    MeasurementMemberBase member
)
Public MustOverride Sub SetElementForGuid (
    member As MeasurementMemberBase
)
public:
virtual void SetElementForGuid(
    MeasurementMemberBase^ member
) abstract

Parameters

member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
See Also

Reference

MarkerTable_Container Class


MarkerTable_Container.SetRemainingElements Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool SetRemainingElements(
    MeasurementMemberBase member
)
Public Function SetRemainingElements (
    member As MeasurementMemberBase
) As Boolean
public:
bool SetRemainingElements(
    MeasurementMemberBase^ member
)

Parameters

member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase

Return Value

Type: Boolean
See Also

Reference

MarkerTable_Container Class


MarkerTable_Container Events

The MarkerTable_Container type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ElementGuidChanged |
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TypeChanged | Fired when the Type is changed.
Public event | TypeValidating | Fired while validating the new value for Type.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateRelatedValue |
Top
See Also

Reference

MarkerTable_Container Class


MarkerTable_Container.ElementGuidChanged Event

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ElementGUIDEventArgs> ElementGuidChanged
Public Event ElementGuidChanged As EventHandler(Of ElementGUIDEventArgs)
public:
 event EventHandler<ElementGUIDEventArgs^>^ ElementGuidChanged {
    void add (EventHandler<ElementGUIDEventArgs^>^ value);
    void remove (EventHandler<ElementGUIDEventArgs^>^ value);
}

Value

Type: SystemEventHandler ElementGUIDEventArgs
See Also

Reference

MarkerTable_Container Class


MarkerTable_Container.TypeChanged Event

Fired when the Type is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TypeChanged
Public Event TypeChanged As EventHandler
public:
 event EventHandler^ TypeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerTable_Container Class


MarkerTable_Container.TypeValidating Event

Fired while validating the new value for Type.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TypeValidating
Public Event TypeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TypeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerTable_Container Class


MarkerTable_Container.UpdateRelatedValue Event

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UpdateRelatedValue
Public Event UpdateRelatedValue As EventHandler
public:
 event EventHandler^ UpdateRelatedValue {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerTable_Container Class


MarkerTable_PairContainer Class

Contains the Model a Paircontainer
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelMarkerTable_Container
TwinCAT.Measurement.Scope.API.ModelMarkerTable_PairContainer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class MarkerTable_PairContainer : MarkerTable_Container
Public Class MarkerTable_PairContainer
    Inherits MarkerTable_Container
public ref class MarkerTable_PairContainer : public MarkerTable_Container

The MarkerTable_PairContainer type exposes the following members.

Constructors
 | Name | Description
Public method | MarkerTable_PairContainer | CTOR of MarkerTable_PairContainer
Public method | MarkerTable_PairContainer(MarkerTable_PairContainer) | CTOR of MarkerTable_Paircontainer
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FirstElement | Gets or Sets the FirstElement.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | GuidFirstElement | Gets or Sets the GuidFirstElement.
Public property | GuidSecondElement | Gets or Sets the GuidSecondElement.
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SecondElement | Gets or Sets the SecondElement.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | Type | Gets or Sets the Type. (Inherited from MarkerTable_Container.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMissingElements | (Inherited from MarkerTable_Container.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MissingElements | (Overrides MarkerTable_ContainerMissingElements.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetElementForGuid | (Overrides MarkerTable_ContainerSetElementForGuid(MeasurementMemberBase).)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | SetRemainingElements | (Inherited from MarkerTable_Container.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | BeforeFirstElementChanged | Fired before the FirstElementChanged
Public event | BeforeSecondElementChanged | Fired before the SecondElementChanged
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ElementGuidChanged | (Inherited from MarkerTable_Container.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FirstElementChanged | Fired when the FirstElement is changed.
Public event | FirstElementValidating | Fired while validating the new value for FirstElement.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidFirstElementChanged | Fired when the GuidFirstElement is changed.
Public event | GuidFirstElementValidating | Fired while validating the new value for GuidFirstElement.
Public event | GuidSecondElementChanged | Fired when the GuidSecondElement is changed.
Public event | GuidSecondElementValidating | Fired while validating the new value for GuidSecondElement.
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SecondElementChanged | Fired when the SecondElement is changed.
Public event | SecondElementValidating | Fired while validating the new value for SecondElement.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TypeChanged | Fired when the Type is changed. (Inherited from MarkerTable_Container.)
Public event | TypeValidating | Fired while validating the new value for Type. (Inherited from MarkerTable_Container.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateRelatedValue | (Inherited from MarkerTable_Container.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MarkerTable_PairContainer Constructor

Overload List
 | Name | Description
Public method | MarkerTable_PairContainer | CTOR of MarkerTable_PairContainer
Public method | MarkerTable_PairContainer(MarkerTable_PairContainer) | CTOR of MarkerTable_Paircontainer
Top
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer Constructor

CTOR of MarkerTable_PairContainer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerTable_PairContainer()
Public Sub New
public:
MarkerTable_PairContainer()
See Also

Reference

MarkerTable_PairContainer Class
MarkerTable_PairContainer Overload


MarkerTable_PairContainer Constructor (MarkerTable_PairContainer)

CTOR of MarkerTable_Paircontainer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerTable_PairContainer(
    MarkerTable_PairContainer markerTable_PairContainer
)
Public Sub New (
    markerTable_PairContainer As MarkerTable_PairContainer
)
public:
MarkerTable_PairContainer(
    MarkerTable_PairContainer^ markerTable_PairContainer
)

Parameters

markerTable_PairContainer
Type: TwinCAT.Measurement.Scope.API.ModelMarkerTable_PairContainer
See Also

Reference

MarkerTable_PairContainer Class
MarkerTable_PairContainer Overload


MarkerTable_PairContainer Properties

The MarkerTable_PairContainer type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FirstElement | Gets or Sets the FirstElement.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | GuidFirstElement | Gets or Sets the GuidFirstElement.
Public property | GuidSecondElement | Gets or Sets the GuidSecondElement.
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SecondElement | Gets or Sets the SecondElement.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | Type | Gets or Sets the Type. (Inherited from MarkerTable_Container.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.FirstElement Property

Gets or Sets the FirstElement.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
public MeasurementMemberBase FirstElement { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(true)>
Public Property FirstElement As MeasurementMemberBase
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
property MeasurementMemberBase^ FirstElement {
    MeasurementMemberBase^ get ();
    void set (MeasurementMemberBase^ value);
}

Property Value

Type: MeasurementMemberBase
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.GuidFirstElement Property

Gets or Sets the GuidFirstElement.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Guid GuidFirstElement { get; set; }
<BrowsableAttribute(true)>
Public Property GuidFirstElement As Guid
    Get
    Set
public:
[BrowsableAttribute(true)]
property Guid GuidFirstElement {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.GuidSecondElement Property

Gets or Sets the GuidSecondElement.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Guid GuidSecondElement { get; set; }
<BrowsableAttribute(true)>
Public Property GuidSecondElement As Guid
    Get
    Set
public:
[BrowsableAttribute(true)]
property Guid GuidSecondElement {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.SecondElement Property

Gets or Sets the SecondElement.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
public MeasurementMemberBase SecondElement { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(true)>
Public Property SecondElement As MeasurementMemberBase
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
property MeasurementMemberBase^ SecondElement {
    MeasurementMemberBase^ get ();
    void set (MeasurementMemberBase^ value);
}

Property Value

Type: MeasurementMemberBase
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer Methods

The MarkerTable_PairContainer type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMissingElements | (Inherited from MarkerTable_Container.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MissingElements | (Overrides MarkerTable_ContainerMissingElements.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetElementForGuid | (Overrides MarkerTable_ContainerSetElementForGuid(MeasurementMemberBase).)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | SetRemainingElements | (Inherited from MarkerTable_Container.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.MissingElements Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override IEnumerable<Guid> MissingElements()
Public Overrides Function MissingElements As IEnumerable(Of Guid)
public:
virtual IEnumerable<Guid>^ MissingElements() override

Return Value

Type: IEnumerable Guid
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.SetElementForGuid Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void SetElementForGuid(
    MeasurementMemberBase member
)
Public Overrides Sub SetElementForGuid (
    member As MeasurementMemberBase
)
public:
virtual void SetElementForGuid(
    MeasurementMemberBase^ member
) override

Parameters

member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer Events

The MarkerTable_PairContainer type exposes the following members.

Events
 | Name | Description
Public event | BeforeFirstElementChanged | Fired before the FirstElementChanged
Public event | BeforeSecondElementChanged | Fired before the SecondElementChanged
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ElementGuidChanged | (Inherited from MarkerTable_Container.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FirstElementChanged | Fired when the FirstElement is changed.
Public event | FirstElementValidating | Fired while validating the new value for FirstElement.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidFirstElementChanged | Fired when the GuidFirstElement is changed.
Public event | GuidFirstElementValidating | Fired while validating the new value for GuidFirstElement.
Public event | GuidSecondElementChanged | Fired when the GuidSecondElement is changed.
Public event | GuidSecondElementValidating | Fired while validating the new value for GuidSecondElement.
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SecondElementChanged | Fired when the SecondElement is changed.
Public event | SecondElementValidating | Fired while validating the new value for SecondElement.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TypeChanged | Fired when the Type is changed. (Inherited from MarkerTable_Container.)
Public event | TypeValidating | Fired while validating the new value for Type. (Inherited from MarkerTable_Container.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateRelatedValue | (Inherited from MarkerTable_Container.)
Top
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.BeforeFirstElementChanged Event

Fired before the FirstElementChanged

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeFirstElementChanged
Public Event BeforeFirstElementChanged As EventHandler
public:
 event EventHandler^ BeforeFirstElementChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.BeforeSecondElementChanged Event

Fired before the SecondElementChanged

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeSecondElementChanged
Public Event BeforeSecondElementChanged As EventHandler
public:
 event EventHandler^ BeforeSecondElementChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.FirstElementChanged Event

Fired when the FirstElement is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler FirstElementChanged
Public Event FirstElementChanged As EventHandler
public:
 event EventHandler^ FirstElementChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.FirstElementValidating Event

Fired while validating the new value for FirstElement.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> FirstElementValidating
Public Event FirstElementValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ FirstElementValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.GuidFirstElementChanged Event

Fired when the GuidFirstElement is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler GuidFirstElementChanged
Public Event GuidFirstElementChanged As EventHandler
public:
 event EventHandler^ GuidFirstElementChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.GuidFirstElementValidating Event

Fired while validating the new value for GuidFirstElement.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> GuidFirstElementValidating
Public Event GuidFirstElementValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ GuidFirstElementValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.GuidSecondElementChanged Event

Fired when the GuidSecondElement is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler GuidSecondElementChanged
Public Event GuidSecondElementChanged As EventHandler
public:
 event EventHandler^ GuidSecondElementChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.GuidSecondElementValidating Event

Fired while validating the new value for GuidSecondElement.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> GuidSecondElementValidating
Public Event GuidSecondElementValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ GuidSecondElementValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.SecondElementChanged Event

Fired when the SecondElement is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SecondElementChanged
Public Event SecondElementChanged As EventHandler
public:
 event EventHandler^ SecondElementChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_PairContainer.SecondElementValidating Event

Fired while validating the new value for SecondElement.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SecondElementValidating
Public Event SecondElementValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SecondElementValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerTable_PairContainer Class


MarkerTable_RowVM Class

ViewModel of the Row in the Markerwindow
Inheritance Hierarchy
SystemObject
ModelBase
TwinCAT.Measurement.Scope.API.ModelMarkerTable_RowVM

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class MarkerTable_RowVM : ModelBase
Public Class MarkerTable_RowVM
    Inherits ModelBase
public ref class MarkerTable_RowVM : public ModelBase

The MarkerTable_RowVM type exposes the following members.

Constructors
 | Name | Description
Public method | MarkerTable_RowVM | Ctor of MarkerTable_RowVM
Top
Properties
 | Name | Description
Public property | ElementSelector | Gets or Sets the ElementSelector.
Public property | Values | Gets or Sets the Values.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MarkerTable_RowVM Constructor

Ctor of MarkerTable_RowVM

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerTable_RowVM()
Public Sub New
public:
MarkerTable_RowVM()
See Also

Reference

MarkerTable_RowVM Class


MarkerTable_RowVM Properties

The MarkerTable_RowVM type exposes the following members.

Properties
 | Name | Description
Public property | ElementSelector | Gets or Sets the ElementSelector.
Public property | Values | Gets or Sets the Values.
Top
See Also

Reference

MarkerTable_RowVM Class


MarkerTable_RowVM.ElementSelector Property

Gets or Sets the ElementSelector.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ElementSelectionVM ElementSelector { get; set; }
Public Property ElementSelector As ElementSelectionVM
    Get
    Set
public:
property ElementSelectionVM^ ElementSelector {
    ElementSelectionVM^ get ();
    void set (ElementSelectionVM^ value);
}

Property Value

Type: ElementSelectionVM
See Also

Reference

MarkerTable_RowVM Class


MarkerTable_RowVM.Values Property

Gets or Sets the Values.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ObservableCollection<CellValue> Values { get; set; }
Public Property Values As ObservableCollection(Of CellValue)
    Get
    Set
public:
property ObservableCollection<CellValue^>^ Values {
    ObservableCollection<CellValue^>^ get ();
    void set (ObservableCollection<CellValue^>^ value);
}

Property Value

Type: ObservableCollection CellValue
See Also

Reference

MarkerTable_RowVM Class


MarkerTable_RowVM Methods

The MarkerTable_RowVM type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MarkerTable_RowVM Class


MarkerTable_RowVM Events

The MarkerTable_RowVM type exposes the following members.

Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

MarkerTable_RowVM Class


MarkerTable_SingleContainer Class

MarkerTable_SingleContainer
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelMarkerTable_Container
TwinCAT.Measurement.Scope.API.ModelMarkerTable_SingleContainer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class MarkerTable_SingleContainer : MarkerTable_Container
Public Class MarkerTable_SingleContainer
    Inherits MarkerTable_Container
public ref class MarkerTable_SingleContainer : public MarkerTable_Container

The MarkerTable_SingleContainer type exposes the following members.

Constructors
 | Name | Description
Public method | MarkerTable_SingleContainer | CTOR to create an Instance of MarkerTableSingleContainer
Public method | MarkerTable_SingleContainer(MarkerTable_SingleContainer) | CTOR to create an Instance of MarkerTableSingleContainer
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | GuidUsedValue | Gets or Sets the GuidUsedValue.
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | Type | Gets or Sets the Type. (Inherited from MarkerTable_Container.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UsedValue | Gets or Sets the UsedValue.
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMissingElements | (Inherited from MarkerTable_Container.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MissingElements | (Overrides MarkerTable_ContainerMissingElements.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetElementForGuid | (Overrides MarkerTable_ContainerSetElementForGuid(MeasurementMemberBase).)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | SetRemainingElements | (Inherited from MarkerTable_Container.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | BeforeUsedValueChanged | Called before the new value set to UsedValue. Release resources like event-Handler here.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ElementGuidChanged | (Inherited from MarkerTable_Container.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidUsedValueChanged | Fired when the GuidUsedValue is changed.
Public event | GuidUsedValueValidating | Fired while validating the new value for GuidUsedValue.
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TypeChanged | Fired when the Type is changed. (Inherited from MarkerTable_Container.)
Public event | TypeValidating | Fired while validating the new value for Type. (Inherited from MarkerTable_Container.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateRelatedValue | (Inherited from MarkerTable_Container.)
Public event | UsedValueChanged | Fired when the UsedValue is changed.
Public event | UsedValueValidating | Fired while validating the new value for UsedValue.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MarkerTable_SingleContainer Constructor

Overload List
 | Name | Description
Public method | MarkerTable_SingleContainer | CTOR to create an Instance of MarkerTableSingleContainer
Public method | MarkerTable_SingleContainer(MarkerTable_SingleContainer) | CTOR to create an Instance of MarkerTableSingleContainer
Top
See Also

Reference

MarkerTable_SingleContainer Class


MarkerTable_SingleContainer Constructor

CTOR to create an Instance of MarkerTableSingleContainer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerTable_SingleContainer()
Public Sub New
public:
MarkerTable_SingleContainer()
See Also

Reference

MarkerTable_SingleContainer Class
MarkerTable_SingleContainer Overload


MarkerTable_SingleContainer Constructor (MarkerTable_SingleContainer)

CTOR to create an Instance of MarkerTableSingleContainer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerTable_SingleContainer(
    MarkerTable_SingleContainer markerTable_SingleContainer
)
Public Sub New (
    markerTable_SingleContainer As MarkerTable_SingleContainer
)
public:
MarkerTable_SingleContainer(
    MarkerTable_SingleContainer^ markerTable_SingleContainer
)

Parameters

markerTable_SingleContainer
Type: TwinCAT.Measurement.Scope.API.ModelMarkerTable_SingleContainer
See Also

Reference

MarkerTable_SingleContainer Class
MarkerTable_SingleContainer Overload


MarkerTable_SingleContainer Properties

The MarkerTable_SingleContainer type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | GuidUsedValue | Gets or Sets the GuidUsedValue.
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | Type | Gets or Sets the Type. (Inherited from MarkerTable_Container.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UsedValue | Gets or Sets the UsedValue.
Top
See Also

Reference

MarkerTable_SingleContainer Class


MarkerTable_SingleContainer.GuidUsedValue Property

Gets or Sets the GuidUsedValue.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Guid GuidUsedValue { get; set; }
<BrowsableAttribute(true)>
Public Property GuidUsedValue As Guid
    Get
    Set
public:
[BrowsableAttribute(true)]
property Guid GuidUsedValue {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

MarkerTable_SingleContainer Class


MarkerTable_SingleContainer.UsedValue Property

Gets or Sets the UsedValue.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
public MeasurementMemberBase UsedValue { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(true)>
Public Property UsedValue As MeasurementMemberBase
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
property MeasurementMemberBase^ UsedValue {
    MeasurementMemberBase^ get ();
    void set (MeasurementMemberBase^ value);
}

Property Value

Type: MeasurementMemberBase
See Also

Reference

MarkerTable_SingleContainer Class


MarkerTable_SingleContainer Methods

The MarkerTable_SingleContainer type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMissingElements | (Inherited from MarkerTable_Container.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MissingElements | (Overrides MarkerTable_ContainerMissingElements.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetElementForGuid | (Overrides MarkerTable_ContainerSetElementForGuid(MeasurementMemberBase).)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | SetRemainingElements | (Inherited from MarkerTable_Container.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MarkerTable_SingleContainer Class


MarkerTable_SingleContainer.MissingElements Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override IEnumerable<Guid> MissingElements()
Public Overrides Function MissingElements As IEnumerable(Of Guid)
public:
virtual IEnumerable<Guid>^ MissingElements() override

Return Value

Type: IEnumerable Guid
See Also

Reference

MarkerTable_SingleContainer Class


MarkerTable_SingleContainer.SetElementForGuid Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void SetElementForGuid(
    MeasurementMemberBase member
)
Public Overrides Sub SetElementForGuid (
    member As MeasurementMemberBase
)
public:
virtual void SetElementForGuid(
    MeasurementMemberBase^ member
) override

Parameters

member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
See Also

Reference

MarkerTable_SingleContainer Class


MarkerTable_SingleContainer Events

The MarkerTable_SingleContainer type exposes the following members.

Events
 | Name | Description
Public event | BeforeUsedValueChanged | Called before the new value set to UsedValue. Release resources like event-Handler here.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ElementGuidChanged | (Inherited from MarkerTable_Container.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidUsedValueChanged | Fired when the GuidUsedValue is changed.
Public event | GuidUsedValueValidating | Fired while validating the new value for GuidUsedValue.
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TypeChanged | Fired when the Type is changed. (Inherited from MarkerTable_Container.)
Public event | TypeValidating | Fired while validating the new value for Type. (Inherited from MarkerTable_Container.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateRelatedValue | (Inherited from MarkerTable_Container.)
Public event | UsedValueChanged | Fired when the UsedValue is changed.
Public event | UsedValueValidating | Fired while validating the new value for UsedValue.
Top
See Also

Reference

MarkerTable_SingleContainer Class


MarkerTable_SingleContainer.BeforeUsedValueChanged Event

Called before the new value set to UsedValue. Release resources like event-Handler here.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeUsedValueChanged
Public Event BeforeUsedValueChanged As EventHandler
public:
 event EventHandler^ BeforeUsedValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerTable_SingleContainer Class


MarkerTable_SingleContainer.GuidUsedValueChanged Event

Fired when the GuidUsedValue is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler GuidUsedValueChanged
Public Event GuidUsedValueChanged As EventHandler
public:
 event EventHandler^ GuidUsedValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerTable_SingleContainer Class


MarkerTable_SingleContainer.GuidUsedValueValidating Event

Fired while validating the new value for GuidUsedValue.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> GuidUsedValueValidating
Public Event GuidUsedValueValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ GuidUsedValueValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerTable_SingleContainer Class


MarkerTable_SingleContainer.UsedValueChanged Event

Fired when the UsedValue is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UsedValueChanged
Public Event UsedValueChanged As EventHandler
public:
 event EventHandler^ UsedValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerTable_SingleContainer Class


MarkerTable_SingleContainer.UsedValueValidating Event

Fired while validating the new value for UsedValue.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UsedValueValidating
Public Event UsedValueValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UsedValueValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MarkerTable_SingleContainer Class


MarkerTableBoardVM Class

ViewModel of the MarkerTableBoard
Inheritance Hierarchy
SystemObject
ModelBase
TwinCAT.Measurement.Scope.API.ModelMarkerTableBoardVM

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class MarkerTableBoardVM : ModelBase
Public Class MarkerTableBoardVM
    Inherits ModelBase
public ref class MarkerTableBoardVM : public ModelBase

The MarkerTableBoardVM type exposes the following members.

Constructors
 | Name | Description
Public method | MarkerTableBoardVM | CTOR of the MarkerTableBoardVM
Public method | MarkerTableBoardVM(ScopeProjectBase) | CTOR of the MarkerTableBoardVM
Top
Properties
 | Name | Description
Public property | BackgroundColor | Gets or Sets the BackgroundColor.
Public property | ComAddMarkerTable | Command to add a MarkerTable
Public property | ComRemoveMarkerTable | Command to ComRemoveSelectedMarkerTable
Public property | ComRemoveSelected | Gets the ComRemoveSelected.
Public property | ForegroundColor | Gets or Sets the ForegroundColor.
Public property | HotColor | Gets or Sets the HotColor.
Public property | LightControlColor | Gets or Sets the LightControlColor.
Public property | RefElements | Gets or Sets the RefElements.
Public property | ScopeProject | Gets or Sets the ScopeProject.
Public property | SelectedColor | Gets or Sets the SelectedColor
Public property | Tables | Gets or Sets the Tables.
Public property | TextBoxBackColor | Gets or Sets the TextBoxBackColor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetClipboardString | Gets a String, which represents all Values of all Tables
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetColors | Set the Control Colors
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MarkerTableBoardVM Constructor

Overload List
 | Name | Description
Public method | MarkerTableBoardVM | CTOR of the MarkerTableBoardVM
Public method | MarkerTableBoardVM(ScopeProjectBase) | CTOR of the MarkerTableBoardVM
Top
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM Constructor

CTOR of the MarkerTableBoardVM

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerTableBoardVM()
Public Sub New
public:
MarkerTableBoardVM()
See Also

Reference

MarkerTableBoardVM Class
MarkerTableBoardVM Overload


MarkerTableBoardVM Constructor (ScopeProjectBase)

CTOR of the MarkerTableBoardVM

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerTableBoardVM(
    ScopeProjectBase scopeProject
)
Public Sub New (
    scopeProject As ScopeProjectBase
)
public:
MarkerTableBoardVM(
    ScopeProjectBase^ scopeProject
)

Parameters

scopeProject
Type: TwinCAT.Measurement.Scope.API.ModelScopeProjectBase
See Also

Reference

MarkerTableBoardVM Class
MarkerTableBoardVM Overload


MarkerTableBoardVM Properties

The MarkerTableBoardVM type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Gets or Sets the BackgroundColor.
Public property | ComAddMarkerTable | Command to add a MarkerTable
Public property | ComRemoveMarkerTable | Command to ComRemoveSelectedMarkerTable
Public property | ComRemoveSelected | Gets the ComRemoveSelected.
Public property | ForegroundColor | Gets or Sets the ForegroundColor.
Public property | HotColor | Gets or Sets the HotColor.
Public property | LightControlColor | Gets or Sets the LightControlColor.
Public property | RefElements | Gets or Sets the RefElements.
Public property | ScopeProject | Gets or Sets the ScopeProject.
Public property | SelectedColor | Gets or Sets the SelectedColor
Public property | Tables | Gets or Sets the Tables.
Public property | TextBoxBackColor | Gets or Sets the TextBoxBackColor.
Top
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.BackgroundColor Property

Gets or Sets the BackgroundColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.ComAddMarkerTable Property

Command to add a MarkerTable

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ICommand ComAddMarkerTable { get; set; }
Public Property ComAddMarkerTable As ICommand
    Get
    Set
public:
property ICommand^ ComAddMarkerTable {
    ICommand^ get ();
    void set (ICommand^ value);
}

Property Value

Type: ICommand
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.ComRemoveMarkerTable Property

Command to ComRemoveSelectedMarkerTable

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ICommand ComRemoveMarkerTable { get; set; }
Public Property ComRemoveMarkerTable As ICommand
    Get
    Set
public:
property ICommand^ ComRemoveMarkerTable {
    ICommand^ get ();
    void set (ICommand^ value);
}

Property Value

Type: ICommand
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.ComRemoveSelected Property

Gets the ComRemoveSelected.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ICommand ComRemoveSelected { get; }
Public ReadOnly Property ComRemoveSelected As ICommand
    Get
public:
property ICommand^ ComRemoveSelected {
    ICommand^ get ();
}

Property Value

Type: ICommand
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.ForegroundColor Property

Gets or Sets the ForegroundColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color ForegroundColor { get; set; }
Public Property ForegroundColor As Color
    Get
    Set
public:
property Color ForegroundColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.HotColor Property

Gets or Sets the HotColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color HotColor { get; set; }
Public Property HotColor As Color
    Get
    Set
public:
property Color HotColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.LightControlColor Property

Gets or Sets the LightControlColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color LightControlColor { get; set; }
Public Property LightControlColor As Color
    Get
    Set
public:
property Color LightControlColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.RefElements Property

Gets or Sets the RefElements.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ObservableCollection<RefElementItem> RefElements { get; set; }
Public Property RefElements As ObservableCollection(Of RefElementItem)
    Get
    Set
public:
property ObservableCollection<RefElementItem^>^ RefElements {
    ObservableCollection<RefElementItem^>^ get ();
    void set (ObservableCollection<RefElementItem^>^ value);
}

Property Value

Type: ObservableCollection RefElementItem
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.ScopeProject Property

Gets or Sets the ScopeProject.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeProjectBase ScopeProject { get; set; }
Public Property ScopeProject As ScopeProjectBase
    Get
    Set
public:
property ScopeProjectBase^ ScopeProject {
    ScopeProjectBase^ get ();
    void set (ScopeProjectBase^ value);
}

Property Value

Type: ScopeProjectBase
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.SelectedColor Property

Gets or Sets the SelectedColor

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color SelectedColor { get; set; }
Public Property SelectedColor As Color
    Get
    Set
public:
property Color SelectedColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.Tables Property

Gets or Sets the Tables.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ObservableCollection<MarkerTableVM> Tables { get; set; }
Public Property Tables As ObservableCollection(Of MarkerTableVM)
    Get
    Set
public:
property ObservableCollection<MarkerTableVM^>^ Tables {
    ObservableCollection<MarkerTableVM^>^ get ();
    void set (ObservableCollection<MarkerTableVM^>^ value);
}

Property Value

Type: ObservableCollection MarkerTableVM
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.TextBoxBackColor Property

Gets or Sets the TextBoxBackColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color TextBoxBackColor { get; set; }
Public Property TextBoxBackColor As Color
    Get
    Set
public:
property Color TextBoxBackColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM Methods

The MarkerTableBoardVM type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetClipboardString | Gets a String, which represents all Values of all Tables
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetColors | Set the Control Colors
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.GetClipboardString Method

Gets a String, which represents all Values of all Tables

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string GetClipboardString()
Public Function GetClipboardString As String
public:
String^ GetClipboardString()

Return Value

Type: String
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM.SetColors Method

Set the Control Colors

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void SetColors(
    Color selectedColor,
    Color textColor,
    Color backgroundOuter,
    Color lightControlColor,
    Color textBoxBackground,
    Color hotColor
)
Public Sub SetColors (
    selectedColor As Color,
    textColor As Color,
    backgroundOuter As Color,
    lightControlColor As Color,
    textBoxBackground As Color,
    hotColor As Color
)
public:
void SetColors(
    Color selectedColor,
    Color textColor,
    Color backgroundOuter,
    Color lightControlColor,
    Color textBoxBackground,
    Color hotColor
)

Parameters

selectedColor
Type: System.DrawingColor
textColor
Type: System.DrawingColor
backgroundOuter
Type: System.DrawingColor
lightControlColor
Type: System.DrawingColor
textBoxBackground
Type: System.DrawingColor
hotColor
Type: System.DrawingColor
See Also

Reference

MarkerTableBoardVM Class


MarkerTableBoardVM Events

The MarkerTableBoardVM type exposes the following members.

Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

MarkerTableBoardVM Class


MarkerTableVM Class

ViewModel for a single MarkerTable of the Markerwindow
Inheritance Hierarchy
SystemObject
ModelBase
TwinCAT.Measurement.Scope.API.ModelMarkerTableVM

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class MarkerTableVM : ModelBase
Public Class MarkerTableVM
    Inherits ModelBase
public ref class MarkerTableVM : public ModelBase

The MarkerTableVM type exposes the following members.

Constructors
 | Name | Description
Public method | MarkerTableVM | CTOR of MarkerTableVM
Top
Properties
 | Name | Description
Public property | AddMultiColumn | Command a Add a MultiColumn
Public property | AddMultiRow | Command to Add a Multirow
Public property | AddSingleColumn | Command to Add a SingleColumn
Public property | AddSingleRow | Command to Add a SingleRow
Public property | BackgroundColor | Gets or Sets the BackgroundColor.
Public property | ClearSelection | Gets the ClearSelection.
Public property | Columns | Gets or Sets the Columns.
Public property | ComRemoveSelected | Command to remove the selected Row
Public property | ContextMenuActions | Gets or Sets the ContextMenuActions.
Public property | controlStyle | Gets or Sets the controlStyle.
Public property | ForegroundColor | Gets or Sets the ForegroundColor.
Public property | HotColor | Gets or Sets the HotColor.
Public property | IsSelected | Gets or Sets the IsSelected.
Public property | LightControlColor | Gets or Sets the LightControlColor.
Public property | RefState | Gets or Sets the RefState.
Public property | Rows | Gets or Sets the Rows.
Public property | ScopeProject | Gets or Sets the ScopeProject.
Public property | SelectedColor | Gets or Sets the SelectedColor
Public property | TextBoxBackground | Gets or Sets the TextBoxBackground.
Public property | WaitingCursor | Gets or Sets the WaitingCursor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetClipboardString | Generates a String which contains all information of the shown Table
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | IsSelectedChanged | Fired when IsSelected Changed
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
Fields
 | Name | Description
Public field | RemoveMemberQuestion |
Public field | UseMultiselect |
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MarkerTableVM Constructor

CTOR of MarkerTableVM

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerTableVM(
    ScopeProjectBase scopeProject,
    MarkerControlStyle controlStyle
)
Public Sub New (
    scopeProject As ScopeProjectBase,
    controlStyle As MarkerControlStyle
)
public:
MarkerTableVM(
    ScopeProjectBase^ scopeProject,
    MarkerControlStyle^ controlStyle
)

Parameters

scopeProject
Type: TwinCAT.Measurement.Scope.API.ModelScopeProjectBase
controlStyle
Type: TwinCAT.Measurement.Scope.API.ModelMarkerControlStyle
See Also

Reference

MarkerTableVM Class


MarkerTableVM Properties

The MarkerTableVM type exposes the following members.

Properties
 | Name | Description
Public property | AddMultiColumn | Command a Add a MultiColumn
Public property | AddMultiRow | Command to Add a Multirow
Public property | AddSingleColumn | Command to Add a SingleColumn
Public property | AddSingleRow | Command to Add a SingleRow
Public property | BackgroundColor | Gets or Sets the BackgroundColor.
Public property | ClearSelection | Gets the ClearSelection.
Public property | Columns | Gets or Sets the Columns.
Public property | ComRemoveSelected | Command to remove the selected Row
Public property | ContextMenuActions | Gets or Sets the ContextMenuActions.
Public property | controlStyle | Gets or Sets the controlStyle.
Public property | ForegroundColor | Gets or Sets the ForegroundColor.
Public property | HotColor | Gets or Sets the HotColor.
Public property | IsSelected | Gets or Sets the IsSelected.
Public property | LightControlColor | Gets or Sets the LightControlColor.
Public property | RefState | Gets or Sets the RefState.
Public property | Rows | Gets or Sets the Rows.
Public property | ScopeProject | Gets or Sets the ScopeProject.
Public property | SelectedColor | Gets or Sets the SelectedColor
Public property | TextBoxBackground | Gets or Sets the TextBoxBackground.
Public property | WaitingCursor | Gets or Sets the WaitingCursor.
Top
See Also

Reference

MarkerTableVM Class


MarkerTableVM.AddMultiColumn Property

Command a Add a MultiColumn

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ICommand AddMultiColumn { get; set; }
Public Property AddMultiColumn As ICommand
    Get
    Set
public:
property ICommand^ AddMultiColumn {
    ICommand^ get ();
    void set (ICommand^ value);
}

Property Value

Type: ICommand
See Also

Reference

MarkerTableVM Class


MarkerTableVM.AddMultiRow Property

Command to Add a Multirow

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ICommand AddMultiRow { get; set; }
Public Property AddMultiRow As ICommand
    Get
    Set
public:
property ICommand^ AddMultiRow {
    ICommand^ get ();
    void set (ICommand^ value);
}

Property Value

Type: ICommand
See Also

Reference

MarkerTableVM Class


MarkerTableVM.AddSingleColumn Property

Command to Add a SingleColumn

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ICommand AddSingleColumn { get; set; }
Public Property AddSingleColumn As ICommand
    Get
    Set
public:
property ICommand^ AddSingleColumn {
    ICommand^ get ();
    void set (ICommand^ value);
}

Property Value

Type: ICommand
See Also

Reference

MarkerTableVM Class


MarkerTableVM.AddSingleRow Property

Command to Add a SingleRow

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ICommand AddSingleRow { get; set; }
Public Property AddSingleRow As ICommand
    Get
    Set
public:
property ICommand^ AddSingleRow {
    ICommand^ get ();
    void set (ICommand^ value);
}

Property Value

Type: ICommand
See Also

Reference

MarkerTableVM Class


MarkerTableVM.BackgroundColor Property

Gets or Sets the BackgroundColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MarkerTableVM Class


MarkerTableVM.ClearSelection Property

Gets the ClearSelection.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ICommand ClearSelection { get; }
Public ReadOnly Property ClearSelection As ICommand
    Get
public:
property ICommand^ ClearSelection {
    ICommand^ get ();
}

Property Value

Type: ICommand
See Also

Reference

MarkerTableVM Class


MarkerTableVM.Columns Property

Gets or Sets the Columns.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ObservableCollection<ColumnConfig> Columns { get; set; }
Public Property Columns As ObservableCollection(Of ColumnConfig)
    Get
    Set
public:
property ObservableCollection<ColumnConfig^>^ Columns {
    ObservableCollection<ColumnConfig^>^ get ();
    void set (ObservableCollection<ColumnConfig^>^ value);
}

Property Value

Type: ObservableCollection ColumnConfig
See Also

Reference

MarkerTableVM Class


MarkerTableVM.ComRemoveSelected Property

Command to remove the selected Row

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ICommand ComRemoveSelected { get; set; }
Public Property ComRemoveSelected As ICommand
    Get
    Set
public:
property ICommand^ ComRemoveSelected {
    ICommand^ get ();
    void set (ICommand^ value);
}

Property Value

Type: ICommand
See Also

Reference

MarkerTableVM Class


MarkerTableVM.ContextMenuActions Property

Gets or Sets the ContextMenuActions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ObservableCollection<CommandMember> ContextMenuActions { get; set; }
Public Property ContextMenuActions As ObservableCollection(Of CommandMember)
    Get
    Set
public:
property ObservableCollection<CommandMember^>^ ContextMenuActions {
    ObservableCollection<CommandMember^>^ get ();
    void set (ObservableCollection<CommandMember^>^ value);
}

Property Value

Type: ObservableCollection CommandMember
See Also

Reference

MarkerTableVM Class


MarkerTableVM.controlStyle Property

Gets or Sets the controlStyle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerControlStyle controlStyle { get; set; }
Public Property controlStyle As MarkerControlStyle
    Get
    Set
public:
property MarkerControlStyle^ controlStyle {
    MarkerControlStyle^ get ();
    void set (MarkerControlStyle^ value);
}

Property Value

Type: MarkerControlStyle
See Also

Reference

MarkerTableVM Class


MarkerTableVM.ForegroundColor Property

Gets or Sets the ForegroundColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color ForegroundColor { get; set; }
Public Property ForegroundColor As Color
    Get
    Set
public:
property Color ForegroundColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MarkerTableVM Class


MarkerTableVM.HotColor Property

Gets or Sets the HotColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color HotColor { get; set; }
Public Property HotColor As Color
    Get
    Set
public:
property Color HotColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MarkerTableVM Class


MarkerTableVM.IsSelected Property

Gets or Sets the IsSelected.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MarkerTableVM Class


MarkerTableVM.LightControlColor Property

Gets or Sets the LightControlColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color LightControlColor { get; set; }
Public Property LightControlColor As Color
    Get
    Set
public:
property Color LightControlColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MarkerTableVM Class


MarkerTableVM.RefState Property

Gets or Sets the RefState.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string RefState { get; set; }
Public Property RefState As String
    Get
    Set
public:
property String^ RefState {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MarkerTableVM Class


MarkerTableVM.Rows Property

Gets or Sets the Rows.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ObservableCollection<MarkerTable_RowVM> Rows { get; set; }
Public Property Rows As ObservableCollection(Of MarkerTable_RowVM)
    Get
    Set
public:
property ObservableCollection<MarkerTable_RowVM^>^ Rows {
    ObservableCollection<MarkerTable_RowVM^>^ get ();
    void set (ObservableCollection<MarkerTable_RowVM^>^ value);
}

Property Value

Type: ObservableCollection MarkerTable_RowVM
See Also

Reference

MarkerTableVM Class


MarkerTableVM.ScopeProject Property

Gets or Sets the ScopeProject.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeProjectBase ScopeProject { get; set; }
Public Property ScopeProject As ScopeProjectBase
    Get
    Set
public:
property ScopeProjectBase^ ScopeProject {
    ScopeProjectBase^ get ();
    void set (ScopeProjectBase^ value);
}

Property Value

Type: ScopeProjectBase
See Also

Reference

MarkerTableVM Class


MarkerTableVM.SelectedColor Property

Gets or Sets the SelectedColor

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color SelectedColor { get; set; }
Public Property SelectedColor As Color
    Get
    Set
public:
property Color SelectedColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MarkerTableVM Class


MarkerTableVM.TextBoxBackground Property

Gets or Sets the TextBoxBackground.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color TextBoxBackground { get; set; }
Public Property TextBoxBackground As Color
    Get
    Set
public:
property Color TextBoxBackground {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

MarkerTableVM Class


MarkerTableVM.WaitingCursor Property

Gets or Sets the WaitingCursor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool WaitingCursor { get; set; }
Public Property WaitingCursor As Boolean
    Get
    Set
public:
property bool WaitingCursor {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MarkerTableVM Class


MarkerTableVM Methods

The MarkerTableVM type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetClipboardString | Generates a String which contains all information of the shown Table
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MarkerTableVM Class


MarkerTableVM.GetClipboardString Method

Generates a String which contains all information of the shown Table

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string GetClipboardString(
    bool selectedOnly = false
)
Public Function GetClipboardString (
    Optional selectedOnly As Boolean = false
) As String
public:
String^ GetClipboardString(
    bool selectedOnly = false
)

Parameters

selectedOnly (Optional)
Type: SystemBoolean
True - only gets the selected Rows

Return Value

Type: String
See Also

Reference

MarkerTableVM Class


MarkerTableVM Events

The MarkerTableVM type exposes the following members.

Events
 | Name | Description
Public event | IsSelectedChanged | Fired when IsSelected Changed
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

MarkerTableVM Class


MarkerTableVM.IsSelectedChanged Event

Fired when IsSelected Changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IsSelectedChanged
Public Event IsSelectedChanged As EventHandler
public:
 event EventHandler^ IsSelectedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MarkerTableVM Class


MarkerTableVM Fields

The MarkerTableVM type exposes the following members.

Fields
 | Name | Description
Public field | RemoveMemberQuestion |
Public field | UseMultiselect |
Top
See Also

Reference

MarkerTableVM Class


MarkerTableVM.RemoveMemberQuestion Field

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerTableVMDelRemoveMemberQuestion RemoveMemberQuestion
Public RemoveMemberQuestion As MarkerTableVMDelRemoveMemberQuestion
public:
MarkerTableVMDelRemoveMemberQuestion^ RemoveMemberQuestion

Field Value

Type: MarkerTableVMDelRemoveMemberQuestion
See Also

Reference

MarkerTableVM Class


MarkerTableVM.UseMultiselect Field

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerTableVMDelUseMultiselect UseMultiselect
Public UseMultiselect As MarkerTableVMDelUseMultiselect
public:
MarkerTableVMDelUseMultiselect^ UseMultiselect

Field Value

Type: MarkerTableVMDelUseMultiselect
See Also

Reference

MarkerTableVM Class


MarkerTableVM.DelRemoveMemberQuestion Delegate

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public delegate MarkerWindow_RemoveOptions? DelRemoveMemberQuestion()
Public Delegate Function DelRemoveMemberQuestion As MarkerWindow_RemoveOptions?
public delegate Nullable<MarkerWindow_RemoveOptions> DelRemoveMemberQuestion()

Return Value

Type: Nullable MarkerWindow_RemoveOptions
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MarkerTableVM.DelUseMultiselect Delegate

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public delegate bool DelUseMultiselect()
Public Delegate Function DelUseMultiselect As Boolean
public delegate bool DelUseMultiselect()

Return Value

Type: Boolean
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MarkerTreeItem Class

Marker TreeElement Item
Inheritance Hierarchy
SystemObject
ModelBase
TreeElementItem
MemberTreeElementItem
TwinCAT.Measurement.Scope.API.ModelMarkerTreeItem

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class MarkerTreeItem : MemberTreeElementItem
Public Class MarkerTreeItem
    Inherits MemberTreeElementItem
public ref class MarkerTreeItem : public MemberTreeElementItem

The MarkerTreeItem type exposes the following members.

Constructors
 | Name | Description
Public method | MarkerTreeItem | Initializes a new instance of the MarkerTreeItem class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MarkerTreeItem Constructor

Initializes a new instance of the MarkerTreeItem class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerTreeItem(
    Marker marker
)
Public Sub New (
    marker As Marker
)
public:
MarkerTreeItem(
    Marker^ marker
)

Parameters

marker
Type: TwinCAT.Measurement.Scope.API.ModelMarker
See Also

Reference

MarkerTreeItem Class


MarkerTreeItem Methods

The MarkerTreeItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Top
See Also

Reference

MarkerTreeItem Class


MarkerTreeItem Events

The MarkerTreeItem type exposes the following members.

Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

MarkerTreeItem Class


MarkerWindow_RemoveOptions Enumeration

MarkerWindow Remove Answer Enumeration

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[FlagsAttribute]
public enum MarkerWindow_RemoveOptions
<FlagsAttribute>
Public Enumeration MarkerWindow_RemoveOptions
[FlagsAttribute]
public enum class MarkerWindow_RemoveOptions
Members
Member name | Value | Description
Rows | 1 | Rows
Columns | 2 | Columns
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MinMaxRangeAxis Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAxis
TwinCAT.Measurement.Scope.API.ModelMinMaxRangeAxis
TwinCAT.Measurement.Scope.API.ModelIndexAxis
TwinCAT.Measurement.Scope.API.ModelValueAxis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class MinMaxRangeAxis : Axis
Public MustInherit Class MinMaxRangeAxis
    Inherits Axis
public ref class MinMaxRangeAxis abstract : public Axis

The MinMaxRangeAxis type exposes the following members.

Constructors
 | Name | Description
Public method | MinMaxRangeAxis | Initializes a new instance of the MinMaxRangeAxis class
Public method | MinMaxRangeAxis(MinMaxRangeAxis) | Initializes a new instance of the MinMaxRangeAxis class
Top
Properties
 | Name | Description
Public property | ActualTitle | Gets or Sets the ActualTitle. (Inherited from Axis.)
Public property | AspectRatioScaleFactor | Gets or Sets the AspectRatioScaleFactor. (Inherited from Axis.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetDisplayRange | Get or Set the GetDisplayRange
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Inverted | Gets or Sets the Inverted. (Inherited from Axis.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Logarithmic | Gets or Sets the Logarithmic. (Inherited from Axis.)
Public property | ManualMax | Gets or Sets the ManualMax. (Inherited from Axis.)
Public property | ManualMin | Gets or Sets the ManualMin. (Inherited from Axis.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Axis.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScalingMode | Gets or Sets the ScalingMode. (Inherited from Axis.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | (Inherited from Axis.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from Axis.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserSettingsAxisInstance | (Inherited from Axis.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Axis.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ActualTitleChanged | Fired when the ActualTitle is changed. (Inherited from Axis.)
Public event | ActualTitleValidating | Fired while validating the new value for ActualTitle. (Inherited from Axis.)
Public event | AspectRatioScaleFactorChanged | Fired when the AspectRatioScaleFactor is changed. (Inherited from Axis.)
Public event | AspectRatioScaleFactorValidating | Fired while validating the new value for AspectRatioScaleFactor. (Inherited from Axis.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DefaultRescale | Fired if the axis should rescale to default values (Inherited from Axis.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InvertedChanged | Fired when the Inverted is changed. (Inherited from Axis.)
Public event | InvertedValidating | Fired while validating the new value for Inverted. (Inherited from Axis.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LogarithmicChanged | Fired when the Logarithmic is changed. (Inherited from Axis.)
Public event | LogarithmicValidating | Fired while validating the new value for Logarithmic. (Inherited from Axis.)
Public event | ManualMaxChanged | Fired when the ManualMax is changed. (Inherited from Axis.)
Public event | ManualMaxValidating | Fired while validating the new value for ManualMax. (Inherited from Axis.)
Public event | ManualMinChanged | Fired when the ManualMin is changed. (Inherited from Axis.)
Public event | ManualMinValidating | Fired while validating the new value for ManualMin. (Inherited from Axis.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Axis.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Axis.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScalingModeChanged | Fired when the ScalingMode is changed. (Inherited from Axis.)
Public event | ScalingModeValidating | Fired while validating the new value for ScalingMode. (Inherited from Axis.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MinMaxRangeAxis Constructor

Overload List
 | Name | Description
Public method | MinMaxRangeAxis | Initializes a new instance of the MinMaxRangeAxis class
Public method | MinMaxRangeAxis(MinMaxRangeAxis) | Initializes a new instance of the MinMaxRangeAxis class
Top
See Also

Reference

MinMaxRangeAxis Class


MinMaxRangeAxis Constructor

Initializes a new instance of the MinMaxRangeAxis class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MinMaxRangeAxis()
Public Sub New
public:
MinMaxRangeAxis()
See Also

Reference

MinMaxRangeAxis Class
MinMaxRangeAxis Overload


MinMaxRangeAxis Constructor (MinMaxRangeAxis)

Initializes a new instance of the MinMaxRangeAxis class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MinMaxRangeAxis(
    MinMaxRangeAxis axis
)
Public Sub New (
    axis As MinMaxRangeAxis
)
public:
MinMaxRangeAxis(
    MinMaxRangeAxis^ axis
)

Parameters

axis
Type: TwinCAT.Measurement.Scope.API.ModelMinMaxRangeAxis
See Also

Reference

MinMaxRangeAxis Class
MinMaxRangeAxis Overload


MinMaxRangeAxis Properties

The MinMaxRangeAxis type exposes the following members.

Properties
 | Name | Description
Public property | ActualTitle | Gets or Sets the ActualTitle. (Inherited from Axis.)
Public property | AspectRatioScaleFactor | Gets or Sets the AspectRatioScaleFactor. (Inherited from Axis.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetDisplayRange | Get or Set the GetDisplayRange
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Inverted | Gets or Sets the Inverted. (Inherited from Axis.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Logarithmic | Gets or Sets the Logarithmic. (Inherited from Axis.)
Public property | ManualMax | Gets or Sets the ManualMax. (Inherited from Axis.)
Public property | ManualMin | Gets or Sets the ManualMin. (Inherited from Axis.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Axis.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScalingMode | Gets or Sets the ScalingMode. (Inherited from Axis.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | (Inherited from Axis.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from Axis.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MinMaxRangeAxis Class


MinMaxRangeAxis.GetDisplayRange Property

Get or Set the GetDisplayRange

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public MinMaxRangeAxisGetRange GetDisplayRange { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property GetDisplayRange As MinMaxRangeAxisGetRange
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property MinMaxRangeAxisGetRange^ GetDisplayRange {
    MinMaxRangeAxisGetRange^ get ();
    void set (MinMaxRangeAxisGetRange^ value);
}

Property Value

Type: MinMaxRangeAxisGetRange
See Also

Reference

MinMaxRangeAxis Class


MinMaxRangeAxis Methods

The MinMaxRangeAxis type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserSettingsAxisInstance | (Inherited from Axis.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Axis.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MinMaxRangeAxis Class


MinMaxRangeAxis Events

The MinMaxRangeAxis type exposes the following members.

Events
 | Name | Description
Public event | ActualTitleChanged | Fired when the ActualTitle is changed. (Inherited from Axis.)
Public event | ActualTitleValidating | Fired while validating the new value for ActualTitle. (Inherited from Axis.)
Public event | AspectRatioScaleFactorChanged | Fired when the AspectRatioScaleFactor is changed. (Inherited from Axis.)
Public event | AspectRatioScaleFactorValidating | Fired while validating the new value for AspectRatioScaleFactor. (Inherited from Axis.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DefaultRescale | Fired if the axis should rescale to default values (Inherited from Axis.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InvertedChanged | Fired when the Inverted is changed. (Inherited from Axis.)
Public event | InvertedValidating | Fired while validating the new value for Inverted. (Inherited from Axis.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LogarithmicChanged | Fired when the Logarithmic is changed. (Inherited from Axis.)
Public event | LogarithmicValidating | Fired while validating the new value for Logarithmic. (Inherited from Axis.)
Public event | ManualMaxChanged | Fired when the ManualMax is changed. (Inherited from Axis.)
Public event | ManualMaxValidating | Fired while validating the new value for ManualMax. (Inherited from Axis.)
Public event | ManualMinChanged | Fired when the ManualMin is changed. (Inherited from Axis.)
Public event | ManualMinValidating | Fired while validating the new value for ManualMin. (Inherited from Axis.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Axis.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Axis.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScalingModeChanged | Fired when the ScalingMode is changed. (Inherited from Axis.)
Public event | ScalingModeValidating | Fired while validating the new value for ScalingMode. (Inherited from Axis.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MinMaxRangeAxis Class


MinMaxRangeAxis.GetRange Delegate

Delegate to get an ValueRange

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public delegate void GetRange(
    out double Min,
    out double Max
)
Public Delegate Sub GetRange (
    <OutAttribute> ByRef Min As Double,
    <OutAttribute> ByRef Max As Double
)
public delegate void GetRange(
    [OutAttribute] double% Min,
    [OutAttribute] double% Max
)

Parameters

Min
Type: SystemDouble
Max
Type: SystemDouble
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MinMaxStyle Class

MinMax Style for Channel
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelMinMaxStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class MinMaxStyle : ScopeMemberBase
Public Class MinMaxStyle
    Inherits ScopeMemberBase
public ref class MinMaxStyle : public ScopeMemberBase

The MinMaxStyle type exposes the following members.

Constructors
 | Name | Description
Public method | MinMaxStyle | Create a new MinMaxStyle
Public method | MinMaxStyle(MinMaxStyle) | Create a new MinMaxStyle by copying Properties
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | ShowMax | Gets or Sets the ShowMax.
Public property | ShowMin | Gets or Sets the ShowMin.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update propertys in propertygrid (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowMaxChanged | Fired when the ShowMax is changed.
Public event | ShowMaxValidating | Fired while validating the new value for ShowMax.
Public event | ShowMinChanged | Fired when the ShowMin is changed.
Public event | ShowMinValidating | Fired while validating the new value for ShowMin.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MinMaxStyle Constructor

Overload List
 | Name | Description
Public method | MinMaxStyle | Create a new MinMaxStyle
Public method | MinMaxStyle(MinMaxStyle) | Create a new MinMaxStyle by copying Properties
Top
See Also

Reference

MinMaxStyle Class


MinMaxStyle Constructor

Create a new MinMaxStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MinMaxStyle()
Public Sub New
public:
MinMaxStyle()
See Also

Reference

MinMaxStyle Class
MinMaxStyle Overload


MinMaxStyle Constructor (MinMaxStyle)

Create a new MinMaxStyle by copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MinMaxStyle(
    MinMaxStyle org
)
Public Sub New (
    org As MinMaxStyle
)
public:
MinMaxStyle(
    MinMaxStyle^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelMinMaxStyle
MinMaxStyle to copy from
See Also

Reference

MinMaxStyle Class
MinMaxStyle Overload


MinMaxStyle Properties

The MinMaxStyle type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | ShowMax | Gets or Sets the ShowMax.
Public property | ShowMin | Gets or Sets the ShowMin.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MinMaxStyle Class


MinMaxStyle.ShowMax Property

Gets or Sets the ShowMax.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowMax { get; set; }
<BrowsableAttribute(true)>
Public Property ShowMax As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowMax {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MinMaxStyle Class


MinMaxStyle.ShowMin Property

Gets or Sets the ShowMin.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowMin { get; set; }
<BrowsableAttribute(true)>
Public Property ShowMin As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowMin {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MinMaxStyle Class


MinMaxStyle Methods

The MinMaxStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update propertys in propertygrid (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MinMaxStyle Class


MinMaxStyle.UpdatePropertyAttributes Method

Update propertys in propertygrid

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

MinMaxStyle Class


MinMaxStyle Events

The MinMaxStyle type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowMaxChanged | Fired when the ShowMax is changed.
Public event | ShowMaxValidating | Fired while validating the new value for ShowMax.
Public event | ShowMinChanged | Fired when the ShowMin is changed.
Public event | ShowMinValidating | Fired while validating the new value for ShowMin.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MinMaxStyle Class


MinMaxStyle.ShowMaxChanged Event

Fired when the ShowMax is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowMaxChanged
Public Event ShowMaxChanged As EventHandler
public:
 event EventHandler^ ShowMaxChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MinMaxStyle Class


MinMaxStyle.ShowMaxValidating Event

Fired while validating the new value for ShowMax.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowMaxValidating
Public Event ShowMaxValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowMaxValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MinMaxStyle Class


MinMaxStyle.ShowMinChanged Event

Fired when the ShowMin is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowMinChanged
Public Event ShowMinChanged As EventHandler
public:
 event EventHandler^ ShowMinChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MinMaxStyle Class


MinMaxStyle.ShowMinValidating Event

Fired while validating the new value for ShowMin.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowMinValidating
Public Event ShowMinValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowMinValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MinMaxStyle Class


MqttAcquisition Class

Acquisition class to order data via MQTT
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisition
TwinCAT.Measurement.Scope.API.ModelHistoricalAcquisition
TwinCAT.Measurement.Scope.API.ModelMqttAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class MqttAcquisition : HistoricalAcquisition
Public Class MqttAcquisition
    Inherits HistoricalAcquisition
public ref class MqttAcquisition : public HistoricalAcquisition

The MqttAcquisition type exposes the following members.

Constructors
 | Name | Description
Public method | MqttAcquisition | Create a new empty MqttAcquisition
Public method | MqttAcquisition(MqttAcquisition) | Create a new empty MqttAcquisition and copy Properties from another one
Top
Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | CmdTopic | Gets or Sets the CmdTopic.
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ConnectionSettings | Gets or Sets the ConnectionSettings.
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | CycleTime | Gets or Sets the CycleTime.
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName. (Overrides AcquisitionDescription.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Host | Gets or Sets the Host.
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Layout | Gets or Sets the Layout.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | Records | Gets or Sets the Records. (Overrides HistoricalAcquisitionRecords.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StreamAlias | Gets or Sets the StreamAlias.
Public property | StreamTopic | Gets or Sets the StreamTopic.
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | TimeRangeId | Gets or Sets the TimeRangeId. (Overrides HistoricalAcquisitionTimeRangeId.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | Topic | Gets or Sets the Topic.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UpdateOtherAcq | If this property is true all other Acquisitions with the same Target get updated without a question. (Inherited from HistoricalAcquisition.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | ValueByteOffset | Gets or Sets the ValueByteOffset.
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Overrides AcquisitionGetFullName.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AcquisitionGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides HistoricalAcquisitionHasSameTarget(Acquisition).)
Public method | HasSameTargetExceptRecords | Determines wether the two Acquisition will acquire the same Data except the selected Records (Overrides HistoricalAcquisitionHasSameTargetExceptRecords(HistoricalAcquisition).)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateDataAccessTimes | Sets the time property of the DataAccess based on the Records. (Inherited from HistoricalAcquisition.)
Public method | UpdatePropertyAttributes | Updates the Attributes of alle Properties (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CmdTopicChanged | Fired when the CmdTopic is changed.
Public event | CmdTopicValidating | Fired while validating the new value for CmdTopic.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ConnectionSettingsChanged | Fired when the ConnectionSettings is changed.
Public event | ConnectionSettingsValidating | Fired while validating the new value for ConnectionSettings.
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | CycleTimeChanged | Fired when the CycleTime is changed.
Public event | CycleTimeValidating | Fired while validating the new value for CycleTime.
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HostChanged | Fired when the Host is changed.
Public event | HostValidating | Fired while validating the new value for Host.
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | LayoutChanged | Fired when the Layout is changed.
Public event | LayoutValidating | Fired while validating the new value for Layout.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RecordsChanged | Fired when the Records is changed. (Inherited from HistoricalAcquisition.)
Public event | RecordsValidating | Fired while validating the new value for Records. (Inherited from HistoricalAcquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StreamAliasChanged | Fired when the StreamAlias is changed.
Public event | StreamAliasValidating | Fired while validating the new value for StreamAlias.
Public event | StreamTopicChanged | Fired when the StreamTopic is changed.
Public event | StreamTopicValidating | Fired while validating the new value for StreamTopic.
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TimeRangeIdChanged | Fired when the TimeRangeId is changed. (Inherited from HistoricalAcquisition.)
Public event | TimeRangeIdValidating | Fired while validating the new value for TimeRangeId. (Inherited from HistoricalAcquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TopicChanged | Fired when the Topic is changed.
Public event | TopicValidating | Fired while validating the new value for Topic.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateOtherAcqChanged | Fired when the UpdateOtherAcq is changed. (Inherited from HistoricalAcquisition.)
Public event | UpdateOtherAcqValidating | Fired while validating the new value for UpdateOtherAcq. (Inherited from HistoricalAcquisition.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | ValueByteOffsetChanged | Fired when the ValueByteOffset is changed.
Public event | ValueByteOffsetValidating | Fired while validating the new value for ValueByteOffset.
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


MqttAcquisition Constructor

Overload List
 | Name | Description
Public method | MqttAcquisition | Create a new empty MqttAcquisition
Public method | MqttAcquisition(MqttAcquisition) | Create a new empty MqttAcquisition and copy Properties from another one
Top
See Also

Reference

MqttAcquisition Class


MqttAcquisition Constructor

Create a new empty MqttAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MqttAcquisition()
Public Sub New
public:
MqttAcquisition()
See Also

Reference

MqttAcquisition Class
MqttAcquisition Overload


MqttAcquisition Constructor (MqttAcquisition)

Create a new empty MqttAcquisition and copy Properties from another one

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MqttAcquisition(
    MqttAcquisition mqttAcquisition
)
Public Sub New (
    mqttAcquisition As MqttAcquisition
)
public:
MqttAcquisition(
    MqttAcquisition^ mqttAcquisition
)

Parameters

mqttAcquisition
Type: TwinCAT.Measurement.Scope.API.ModelMqttAcquisition
See Also

Reference

MqttAcquisition Class
MqttAcquisition Overload


MqttAcquisition Properties

The MqttAcquisition type exposes the following members.

Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | CmdTopic | Gets or Sets the CmdTopic.
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ConnectionSettings | Gets or Sets the ConnectionSettings.
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | CycleTime | Gets or Sets the CycleTime.
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName. (Overrides AcquisitionDescription.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Host | Gets or Sets the Host.
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Layout | Gets or Sets the Layout.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | Records | Gets or Sets the Records. (Overrides HistoricalAcquisitionRecords.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StreamAlias | Gets or Sets the StreamAlias.
Public property | StreamTopic | Gets or Sets the StreamTopic.
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | TimeRangeId | Gets or Sets the TimeRangeId. (Overrides HistoricalAcquisitionTimeRangeId.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | Topic | Gets or Sets the Topic.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UpdateOtherAcq | If this property is true all other Acquisitions with the same Target get updated without a question. (Inherited from HistoricalAcquisition.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | ValueByteOffset | Gets or Sets the ValueByteOffset.
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

MqttAcquisition Class


MqttAcquisition.CmdTopic Property

Gets or Sets the CmdTopic.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string CmdTopic { get; set; }
Public Property CmdTopic As String
    Get
    Set
public:
property String^ CmdTopic {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MqttAcquisition Class


MqttAcquisition.ConnectionSettings Property

Gets or Sets the ConnectionSettings.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ConnectionSettings ConnectionSettings { get; set; }
Public Property ConnectionSettings As ConnectionSettings
    Get
    Set
public:
property ConnectionSettings^ ConnectionSettings {
    ConnectionSettings^ get ();
    void set (ConnectionSettings^ value);
}

Property Value

Type: ConnectionSettings
See Also

Reference

MqttAcquisition Class


MqttAcquisition.CycleTime Property

Gets or Sets the CycleTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ulong CycleTime { get; set; }
Public Property CycleTime As ULong
    Get
    Set
public:
property unsigned long long CycleTime {
    unsigned long long get ();
    void set (unsigned long long value);
}

Property Value

Type: UInt64
See Also

Reference

MqttAcquisition Class


MqttAcquisition.Description Property

A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override ChannelDescription Description { get; }
Public Overrides ReadOnly Property Description As ChannelDescription
    Get
public:
virtual property ChannelDescription^ Description {
    ChannelDescription^ get () override;
}

Property Value

Type: ChannelDescription
See Also

Reference

MqttAcquisition Class


MqttAcquisition.Host Property

Gets or Sets the Host.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Host { get; set; }
Public Property Host As String
    Get
    Set
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MqttAcquisition Class


MqttAcquisition.Layout Property

Gets or Sets the Layout.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Guid Layout { get; set; }
Public Property Layout As Guid
    Get
    Set
public:
property Guid Layout {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

MqttAcquisition Class


MqttAcquisition.Records Property

Gets or Sets the Records.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override RecordsContainer Records { get; set; }
Public Overrides Property Records As RecordsContainer
    Get
    Set
public:
virtual property RecordsContainer^ Records {
    RecordsContainer^ get () override;
    void set (RecordsContainer^ value) override;
}

Property Value

Type: RecordsContainer
See Also

Reference

MqttAcquisition Class


MqttAcquisition.StreamAlias Property

Gets or Sets the StreamAlias.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string StreamAlias { get; set; }
Public Property StreamAlias As String
    Get
    Set
public:
property String^ StreamAlias {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MqttAcquisition Class


MqttAcquisition.StreamTopic Property

Gets or Sets the StreamTopic.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string StreamTopic { get; set; }
Public Property StreamTopic As String
    Get
    Set
public:
property String^ StreamTopic {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MqttAcquisition Class


MqttAcquisition.SymbolName Property

Gets or Sets the SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string SymbolName { get; set; }
Public Property SymbolName As String
    Get
    Set
public:
property String^ SymbolName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MqttAcquisition Class


MqttAcquisition.TimeRangeId Property

Gets or Sets the TimeRangeId.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override ulong TimeRangeId { get; set; }
Public Overrides Property TimeRangeId As ULong
    Get
    Set
public:
virtual property unsigned long long TimeRangeId {
    unsigned long long get () override;
    void set (unsigned long long value) override;
}

Property Value

Type: UInt64
See Also

Reference

MqttAcquisition Class


MqttAcquisition.Topic Property

Gets or Sets the Topic.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string Topic { get; set; }
Public Property Topic As String
    Get
    Set
public:
property String^ Topic {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MqttAcquisition Class


MqttAcquisition.ValueByteOffset Property

Gets or Sets the ValueByteOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public uint ValueByteOffset { get; set; }
Public Property ValueByteOffset As UInteger
    Get
    Set
public:
property unsigned int ValueByteOffset {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

MqttAcquisition Class


MqttAcquisition Methods

The MqttAcquisition type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Overrides AcquisitionGetFullName.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AcquisitionGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides HistoricalAcquisitionHasSameTarget(Acquisition).)
Public method | HasSameTargetExceptRecords | Determines wether the two Acquisition will acquire the same Data except the selected Records (Overrides HistoricalAcquisitionHasSameTargetExceptRecords(HistoricalAcquisition).)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateDataAccessTimes | Sets the time property of the DataAccess based on the Records. (Inherited from HistoricalAcquisition.)
Public method | UpdatePropertyAttributes | Updates the Attributes of alle Properties (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

MqttAcquisition Class


MqttAcquisition.GetFullName Method

Gets the complete identifier of this acqusition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string GetFullName()
Public Overrides Function GetFullName As String
public:
virtual String^ GetFullName() override

Return Value

Type: String
The full name
See Also

Reference

MqttAcquisition Class


MqttAcquisition.GetHashCode Method

Serves as a hash function for a particular type.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

MqttAcquisition Class


MqttAcquisition.HasSameTarget Method

Determines wether the two Acquisition will acquire the same Data

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool HasSameTarget(
    Acquisition Acquisition
)
Public Overrides Function HasSameTarget (
    Acquisition As Acquisition
) As Boolean
public:
virtual bool HasSameTarget(
    Acquisition^ Acquisition
) override

Parameters

Acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
The Acquisition to compare with

Return Value

Type: Boolean
True if the Acquisitions have the Same Target
See Also

Reference

MqttAcquisition Class


MqttAcquisition.HasSameTargetExceptRecords Method

Determines wether the two Acquisition will acquire the same Data except the selected Records

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool HasSameTargetExceptRecords(
    HistoricalAcquisition acquisition
)
Public Overrides Function HasSameTargetExceptRecords (
    acquisition As HistoricalAcquisition
) As Boolean
public:
virtual bool HasSameTargetExceptRecords(
    HistoricalAcquisition^ acquisition
) override

Parameters

acquisition
Type: TwinCAT.Measurement.Scope.API.ModelHistoricalAcquisition
The Acquisition to compare with

Return Value

Type: Boolean
True if the Acquisitions have the Same Target
See Also

Reference

MqttAcquisition Class


MqttAcquisition.UpdatePropertyAttributes Method

Updates the Attributes of alle Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

MqttAcquisition Class


MqttAcquisition Events

The MqttAcquisition type exposes the following members.

Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CmdTopicChanged | Fired when the CmdTopic is changed.
Public event | CmdTopicValidating | Fired while validating the new value for CmdTopic.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ConnectionSettingsChanged | Fired when the ConnectionSettings is changed.
Public event | ConnectionSettingsValidating | Fired while validating the new value for ConnectionSettings.
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | CycleTimeChanged | Fired when the CycleTime is changed.
Public event | CycleTimeValidating | Fired while validating the new value for CycleTime.
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HostChanged | Fired when the Host is changed.
Public event | HostValidating | Fired while validating the new value for Host.
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | LayoutChanged | Fired when the Layout is changed.
Public event | LayoutValidating | Fired while validating the new value for Layout.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RecordsChanged | Fired when the Records is changed. (Inherited from HistoricalAcquisition.)
Public event | RecordsValidating | Fired while validating the new value for Records. (Inherited from HistoricalAcquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StreamAliasChanged | Fired when the StreamAlias is changed.
Public event | StreamAliasValidating | Fired while validating the new value for StreamAlias.
Public event | StreamTopicChanged | Fired when the StreamTopic is changed.
Public event | StreamTopicValidating | Fired while validating the new value for StreamTopic.
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TimeRangeIdChanged | Fired when the TimeRangeId is changed. (Inherited from HistoricalAcquisition.)
Public event | TimeRangeIdValidating | Fired while validating the new value for TimeRangeId. (Inherited from HistoricalAcquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TopicChanged | Fired when the Topic is changed.
Public event | TopicValidating | Fired while validating the new value for Topic.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateOtherAcqChanged | Fired when the UpdateOtherAcq is changed. (Inherited from HistoricalAcquisition.)
Public event | UpdateOtherAcqValidating | Fired while validating the new value for UpdateOtherAcq. (Inherited from HistoricalAcquisition.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | ValueByteOffsetChanged | Fired when the ValueByteOffset is changed.
Public event | ValueByteOffsetValidating | Fired while validating the new value for ValueByteOffset.
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

MqttAcquisition Class


MqttAcquisition.CmdTopicChanged Event

Fired when the CmdTopic is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CmdTopicChanged
Public Event CmdTopicChanged As EventHandler
public:
 event EventHandler^ CmdTopicChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MqttAcquisition Class


MqttAcquisition.CmdTopicValidating Event

Fired while validating the new value for CmdTopic.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> CmdTopicValidating
Public Event CmdTopicValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ CmdTopicValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MqttAcquisition Class


MqttAcquisition.ConnectionSettingsChanged Event

Fired when the ConnectionSettings is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ConnectionSettingsChanged
Public Event ConnectionSettingsChanged As EventHandler
public:
 event EventHandler^ ConnectionSettingsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MqttAcquisition Class


MqttAcquisition.ConnectionSettingsValidating Event

Fired while validating the new value for ConnectionSettings.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ConnectionSettingsValidating
Public Event ConnectionSettingsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ConnectionSettingsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MqttAcquisition Class


MqttAcquisition.CycleTimeChanged Event

Fired when the CycleTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CycleTimeChanged
Public Event CycleTimeChanged As EventHandler
public:
 event EventHandler^ CycleTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MqttAcquisition Class


MqttAcquisition.CycleTimeValidating Event

Fired while validating the new value for CycleTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> CycleTimeValidating
Public Event CycleTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ CycleTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MqttAcquisition Class


MqttAcquisition.HostChanged Event

Fired when the Host is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler HostChanged
Public Event HostChanged As EventHandler
public:
 event EventHandler^ HostChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MqttAcquisition Class


MqttAcquisition.HostValidating Event

Fired while validating the new value for Host.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> HostValidating
Public Event HostValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ HostValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MqttAcquisition Class


MqttAcquisition.LayoutChanged Event

Fired when the Layout is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LayoutChanged
Public Event LayoutChanged As EventHandler
public:
 event EventHandler^ LayoutChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MqttAcquisition Class


MqttAcquisition.LayoutValidating Event

Fired while validating the new value for Layout.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LayoutValidating
Public Event LayoutValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LayoutValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MqttAcquisition Class


MqttAcquisition.StreamAliasChanged Event

Fired when the StreamAlias is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StreamAliasChanged
Public Event StreamAliasChanged As EventHandler
public:
 event EventHandler^ StreamAliasChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MqttAcquisition Class


MqttAcquisition.StreamAliasValidating Event

Fired while validating the new value for StreamAlias.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> StreamAliasValidating
Public Event StreamAliasValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ StreamAliasValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MqttAcquisition Class


MqttAcquisition.StreamTopicChanged Event

Fired when the StreamTopic is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StreamTopicChanged
Public Event StreamTopicChanged As EventHandler
public:
 event EventHandler^ StreamTopicChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MqttAcquisition Class


MqttAcquisition.StreamTopicValidating Event

Fired while validating the new value for StreamTopic.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> StreamTopicValidating
Public Event StreamTopicValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ StreamTopicValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MqttAcquisition Class


MqttAcquisition.SymbolNameChanged Event

Fired when the SymbolName is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SymbolNameChanged
Public Event SymbolNameChanged As EventHandler
public:
 event EventHandler^ SymbolNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MqttAcquisition Class


MqttAcquisition.SymbolNameValidating Event

Fired while validating the new value for SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SymbolNameValidating
Public Event SymbolNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SymbolNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MqttAcquisition Class


MqttAcquisition.TopicChanged Event

Fired when the Topic is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TopicChanged
Public Event TopicChanged As EventHandler
public:
 event EventHandler^ TopicChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MqttAcquisition Class


MqttAcquisition.TopicValidating Event

Fired while validating the new value for Topic.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TopicValidating
Public Event TopicValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TopicValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MqttAcquisition Class


MqttAcquisition.ValueByteOffsetChanged Event

Fired when the ValueByteOffset is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ValueByteOffsetChanged
Public Event ValueByteOffsetChanged As EventHandler
public:
 event EventHandler^ ValueByteOffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MqttAcquisition Class


MqttAcquisition.ValueByteOffsetValidating Event

Fired while validating the new value for ValueByteOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ValueByteOffsetValidating
Public Event ValueByteOffsetValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ValueByteOffsetValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

MqttAcquisition Class


MqttAcquisition Fields

The MqttAcquisition type exposes the following members.

Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

MqttAcquisition Class


NegateFunction Class

Function with NOT Operator
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.API.ModelFunction
TwinCAT.Measurement.Scope.API.ModelNegateFunction

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class NegateFunction : Function
Public Class NegateFunction
    Inherits Function
public ref class NegateFunction : public Function

The NegateFunction type exposes the following members.

Constructors
 | Name | Description
Public method | NegateFunction | Create a new NegateFunction
Top
Properties
 | Name | Description
Public property | Value | The result of the Function (Overrides FunctionValue.)
Top
Methods
 | Name | Description
Public method | Contains | Test if the Function contains the Input Condition (Inherited from Function.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


NegateFunction Constructor

Create a new NegateFunction

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public NegateFunction(
    ICondition Input
)
Public Sub New (
    Input As ICondition
)
public:
NegateFunction(
    ICondition^ Input
)

Parameters

Input
Type: TwinCAT.Measurement.Scope.API.ModelICondition
The Input Condition
See Also

Reference

NegateFunction Class


NegateFunction Properties

The NegateFunction type exposes the following members.

Properties
 | Name | Description
Public property | Value | The result of the Function (Overrides FunctionValue.)
Top
See Also

Reference

NegateFunction Class


NegateFunction.Value Property

The result of the Function

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool Value { get; }
Public Overrides ReadOnly Property Value As Boolean
    Get
public:
virtual property bool Value {
    bool get () override;
}

Property Value

Type: Boolean

Implements

IConditionValue
See Also

Reference

NegateFunction Class


NegateFunction Methods

The NegateFunction type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Test if the Function contains the Input Condition (Inherited from Function.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NegateFunction Class


OpcAcquisition Class

Acquisition to order data via OPC UA
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisition
TwinCAT.Measurement.Scope.API.ModelOpcAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class OpcAcquisition : Acquisition
Public Class OpcAcquisition
    Inherits Acquisition
public ref class OpcAcquisition : public Acquisition

The OpcAcquisition type exposes the following members.

Constructors
 | Name | Description
Public method | OpcAcquisition | Create a new empty OPCAcquisition
Public method | OpcAcquisition(OpcAcquisition) | Create a new OPCAcquisition and copy Properties from another one
Top
Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | BaseType | Gets or Sets the BaseType.
Public property | BitSize | Gets or Sets the BitSize.
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName. (Overrides AcquisitionDescription.)
Public property | Dimensions | Gets or Sets the Dimensions.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | EndPointName | Gets or Sets the EndPointName.
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IdentityType | Gets or Sets the IdentityType.
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMatrix | Gets or Sets the IsMatrix.
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | NodeClass | Gets or Sets the NodeClass.
Public property | NodeID | Gets or Sets the NodeID.
Public property | OPCNamespaceName | Gets or Sets the OPCNamespaceName.
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SecurityPolicyUri | Gets or Sets the SecurityPolicyUri.
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | ServerURL | Gets or Sets the ServerURL.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | SymbolPath | Gets or Sets the SymbolPath.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UserName | Gets or Sets the UserName.
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Overrides AcquisitionGetFullName.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AcquisitionGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides AcquisitionHasSameTarget(Acquisition).)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of alle Properties (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | BaseTypeChanged | Fired when the BaseType is changed.
Public event | BaseTypeValidating | Fired while validating the new value for BaseType.
Public event | BitSizeChanged | Fired when the BitSize is changed.
Public event | BitSizeValidating | Fired while validating the new value for BitSize.
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DimensionsChanged | Fired when the Dimensions is changed.
Public event | DimensionsValidating | Fired while validating the new value for Dimensions.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | EndPointNameChanged | Fired when the EndPointName is changed.
Public event | EndPointNameValidating | Fired while validating the new value for EndPointName.
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IdentityTypeChanged | Fired when the IdentityType is changed.
Public event | IdentityTypeValidating | Fired while validating the new value for IdentityType.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | IsMatrixChanged | Fired when the IsMatrix is changed.
Public event | IsMatrixValidating | Fired while validating the new value for IsMatrix.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NodeClassChanged | Fired when the NodeClass is changed.
Public event | NodeClassValidating | Fired while validating the new value for NodeClass.
Public event | NodeIDChanged | Fired when the NodeID is changed.
Public event | NodeIDValidating | Fired while validating the new value for NodeID.
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OPCNamespaceNameChanged | Fired when the OPCNamespaceName is changed.
Public event | OPCNamespaceNameValidating | Fired while validating the new value for OPCNamespaceName.
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | SecurityPolicyUriChanged | Fired when the SecurityPolicyUri is changed.
Public event | SecurityPolicyUriValidating | Fired while validating the new value for SecurityPolicyUri.
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | ServerURLChanged | Fired when the ServerURL is changed.
Public event | ServerURLValidating | Fired while validating the new value for ServerURL.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | SymbolPathChanged | Fired when the SymbolPath is changed.
Public event | SymbolPathValidating | Fired while validating the new value for SymbolPath.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UserNameChanged | Fired when the UserName is changed.
Public event | UserNameValidating | Fired while validating the new value for UserName.
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


OpcAcquisition Constructor

Overload List
 | Name | Description
Public method | OpcAcquisition | Create a new empty OPCAcquisition
Public method | OpcAcquisition(OpcAcquisition) | Create a new OPCAcquisition and copy Properties from another one
Top
See Also

Reference

OpcAcquisition Class


OpcAcquisition Constructor

Create a new empty OPCAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public OpcAcquisition()
Public Sub New
public:
OpcAcquisition()
See Also

Reference

OpcAcquisition Class
OpcAcquisition Overload


OpcAcquisition Constructor (OpcAcquisition)

Create a new OPCAcquisition and copy Properties from another one

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public OpcAcquisition(
    OpcAcquisition acq
)
Public Sub New (
    acq As OpcAcquisition
)
public:
OpcAcquisition(
    OpcAcquisition^ acq
)

Parameters

acq
Type: TwinCAT.Measurement.Scope.API.ModelOpcAcquisition
See Also

Reference

OpcAcquisition Class
OpcAcquisition Overload


OpcAcquisition Properties

The OpcAcquisition type exposes the following members.

Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | BaseType | Gets or Sets the BaseType.
Public property | BitSize | Gets or Sets the BitSize.
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName. (Overrides AcquisitionDescription.)
Public property | Dimensions | Gets or Sets the Dimensions.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | EndPointName | Gets or Sets the EndPointName.
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IdentityType | Gets or Sets the IdentityType.
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMatrix | Gets or Sets the IsMatrix.
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | NodeClass | Gets or Sets the NodeClass.
Public property | NodeID | Gets or Sets the NodeID.
Public property | OPCNamespaceName | Gets or Sets the OPCNamespaceName.
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SecurityPolicyUri | Gets or Sets the SecurityPolicyUri.
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | ServerURL | Gets or Sets the ServerURL.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | SymbolPath | Gets or Sets the SymbolPath.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UserName | Gets or Sets the UserName.
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

OpcAcquisition Class


OpcAcquisition.BaseType Property

Gets or Sets the BaseType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string BaseType { get; set; }
<BrowsableAttribute(false)>
Public Property BaseType As String
    Get
    Set
public:
[BrowsableAttribute(false)]
property String^ BaseType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OpcAcquisition Class


OpcAcquisition.BitSize Property

Gets or Sets the BitSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int BitSize { get; set; }
<BrowsableAttribute(true)>
Public Property BitSize As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int BitSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

OpcAcquisition Class


OpcAcquisition.Description Property

A description of the channels-connecting properties. TargetPort, dataType, indexGroup, indexOffset, variableSize, filename, symbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override ChannelDescription Description { get; }
Public Overrides ReadOnly Property Description As ChannelDescription
    Get
public:
virtual property ChannelDescription^ Description {
    ChannelDescription^ get () override;
}

Property Value

Type: ChannelDescription
See Also

Reference

OpcAcquisition Class


OpcAcquisition.Dimensions Property

Gets or Sets the Dimensions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public int Dimensions { get; set; }
<BrowsableAttribute(false)>
Public Property Dimensions As Integer
    Get
    Set
public:
[BrowsableAttribute(false)]
property int Dimensions {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

OpcAcquisition Class


OpcAcquisition.EndPointName Property

Gets or Sets the EndPointName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string EndPointName { get; set; }
<BrowsableAttribute(true)>
Public Property EndPointName As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ EndPointName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OpcAcquisition Class


OpcAcquisition.IdentityType Property

Gets or Sets the IdentityType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public OpcUaIdentityType IdentityType { get; set; }
<BrowsableAttribute(false)>
Public Property IdentityType As OpcUaIdentityType
    Get
    Set
public:
[BrowsableAttribute(false)]
property OpcUaIdentityType IdentityType {
    OpcUaIdentityType get ();
    void set (OpcUaIdentityType value);
}

Property Value

Type: OpcUaIdentityType
See Also

Reference

OpcAcquisition Class


OpcAcquisition.IsMatrix Property

Gets or Sets the IsMatrix.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool IsMatrix { get; set; }
<BrowsableAttribute(false)>
Public Property IsMatrix As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool IsMatrix {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

OpcAcquisition Class


OpcAcquisition.NodeClass Property

Gets or Sets the NodeClass.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string NodeClass { get; set; }
<BrowsableAttribute(true)>
Public Property NodeClass As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ NodeClass {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OpcAcquisition Class


OpcAcquisition.NodeID Property

Gets or Sets the NodeID.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string NodeID { get; set; }
<BrowsableAttribute(true)>
Public Property NodeID As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ NodeID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OpcAcquisition Class


OpcAcquisition.OPCNamespaceName Property

Gets or Sets the OPCNamespaceName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string OPCNamespaceName { get; set; }
<BrowsableAttribute(true)>
Public Property OPCNamespaceName As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ OPCNamespaceName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OpcAcquisition Class


OpcAcquisition.SecurityPolicyUri Property

Gets or Sets the SecurityPolicyUri.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string SecurityPolicyUri { get; set; }
<BrowsableAttribute(true)>
Public Property SecurityPolicyUri As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ SecurityPolicyUri {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OpcAcquisition Class


OpcAcquisition.ServerURL Property

Gets or Sets the ServerURL.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string ServerURL { get; set; }
<BrowsableAttribute(true)>
Public Property ServerURL As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ ServerURL {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OpcAcquisition Class


OpcAcquisition.SymbolName Property

Gets or Sets the SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string SymbolName { get; set; }
<BrowsableAttribute(true)>
Public Property SymbolName As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ SymbolName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OpcAcquisition Class


OpcAcquisition.SymbolPath Property

Gets or Sets the SymbolPath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string SymbolPath { get; set; }
<BrowsableAttribute(true)>
Public Property SymbolPath As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ SymbolPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OpcAcquisition Class


OpcAcquisition.UserName Property

Gets or Sets the UserName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string UserName { get; set; }
<BrowsableAttribute(false)>
Public Property UserName As String
    Get
    Set
public:
[BrowsableAttribute(false)]
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OpcAcquisition Class


OpcAcquisition Methods

The OpcAcquisition type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Overrides AcquisitionGetFullName.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides AcquisitionGetHashCode.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides AcquisitionHasSameTarget(Acquisition).)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of alle Properties (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

OpcAcquisition Class


OpcAcquisition.GetFullName Method

Gets the complete identifier of this acqusition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string GetFullName()
Public Overrides Function GetFullName As String
public:
virtual String^ GetFullName() override

Return Value

Type: String
The full name
See Also

Reference

OpcAcquisition Class


OpcAcquisition.GetHashCode Method

Serves as a hash function for a particular type.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current object.
See Also

Reference

OpcAcquisition Class


OpcAcquisition.HasSameTarget Method

Determines wether the two Acquisition will acquire the same Data

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool HasSameTarget(
    Acquisition Acquisition
)
Public Overrides Function HasSameTarget (
    Acquisition As Acquisition
) As Boolean
public:
virtual bool HasSameTarget(
    Acquisition^ Acquisition
) override

Parameters

Acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
The Acquisition to compare with

Return Value

Type: Boolean
True if the Acquisitions have the Same Target
See Also

Reference

OpcAcquisition Class


OpcAcquisition.UpdatePropertyAttributes Method

Update Attributes of alle Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

OpcAcquisition Class


OpcAcquisition Events

The OpcAcquisition type exposes the following members.

Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | BaseTypeChanged | Fired when the BaseType is changed.
Public event | BaseTypeValidating | Fired while validating the new value for BaseType.
Public event | BitSizeChanged | Fired when the BitSize is changed.
Public event | BitSizeValidating | Fired while validating the new value for BitSize.
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DimensionsChanged | Fired when the Dimensions is changed.
Public event | DimensionsValidating | Fired while validating the new value for Dimensions.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | EndPointNameChanged | Fired when the EndPointName is changed.
Public event | EndPointNameValidating | Fired while validating the new value for EndPointName.
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IdentityTypeChanged | Fired when the IdentityType is changed.
Public event | IdentityTypeValidating | Fired while validating the new value for IdentityType.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | IsMatrixChanged | Fired when the IsMatrix is changed.
Public event | IsMatrixValidating | Fired while validating the new value for IsMatrix.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NodeClassChanged | Fired when the NodeClass is changed.
Public event | NodeClassValidating | Fired while validating the new value for NodeClass.
Public event | NodeIDChanged | Fired when the NodeID is changed.
Public event | NodeIDValidating | Fired while validating the new value for NodeID.
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OPCNamespaceNameChanged | Fired when the OPCNamespaceName is changed.
Public event | OPCNamespaceNameValidating | Fired while validating the new value for OPCNamespaceName.
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | SecurityPolicyUriChanged | Fired when the SecurityPolicyUri is changed.
Public event | SecurityPolicyUriValidating | Fired while validating the new value for SecurityPolicyUri.
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | ServerURLChanged | Fired when the ServerURL is changed.
Public event | ServerURLValidating | Fired while validating the new value for ServerURL.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | SymbolPathChanged | Fired when the SymbolPath is changed.
Public event | SymbolPathValidating | Fired while validating the new value for SymbolPath.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UserNameChanged | Fired when the UserName is changed.
Public event | UserNameValidating | Fired while validating the new value for UserName.
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

OpcAcquisition Class


OpcAcquisition.BaseTypeChanged Event

Fired when the BaseType is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BaseTypeChanged
Public Event BaseTypeChanged As EventHandler
public:
 event EventHandler^ BaseTypeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.BaseTypeValidating Event

Fired while validating the new value for BaseType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> BaseTypeValidating
Public Event BaseTypeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ BaseTypeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition.BitSizeChanged Event

Fired when the BitSize is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BitSizeChanged
Public Event BitSizeChanged As EventHandler
public:
 event EventHandler^ BitSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.BitSizeValidating Event

Fired while validating the new value for BitSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> BitSizeValidating
Public Event BitSizeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ BitSizeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition.DimensionsChanged Event

Fired when the Dimensions is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DimensionsChanged
Public Event DimensionsChanged As EventHandler
public:
 event EventHandler^ DimensionsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.DimensionsValidating Event

Fired while validating the new value for Dimensions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DimensionsValidating
Public Event DimensionsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DimensionsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition.EndPointNameChanged Event

Fired when the EndPointName is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EndPointNameChanged
Public Event EndPointNameChanged As EventHandler
public:
 event EventHandler^ EndPointNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.EndPointNameValidating Event

Fired while validating the new value for EndPointName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EndPointNameValidating
Public Event EndPointNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EndPointNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition.IdentityTypeChanged Event

Fired when the IdentityType is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IdentityTypeChanged
Public Event IdentityTypeChanged As EventHandler
public:
 event EventHandler^ IdentityTypeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.IdentityTypeValidating Event

Fired while validating the new value for IdentityType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IdentityTypeValidating
Public Event IdentityTypeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IdentityTypeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition.IsMatrixChanged Event

Fired when the IsMatrix is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IsMatrixChanged
Public Event IsMatrixChanged As EventHandler
public:
 event EventHandler^ IsMatrixChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.IsMatrixValidating Event

Fired while validating the new value for IsMatrix.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IsMatrixValidating
Public Event IsMatrixValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IsMatrixValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition.NodeClassChanged Event

Fired when the NodeClass is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler NodeClassChanged
Public Event NodeClassChanged As EventHandler
public:
 event EventHandler^ NodeClassChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.NodeClassValidating Event

Fired while validating the new value for NodeClass.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> NodeClassValidating
Public Event NodeClassValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ NodeClassValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition.NodeIDChanged Event

Fired when the NodeID is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler NodeIDChanged
Public Event NodeIDChanged As EventHandler
public:
 event EventHandler^ NodeIDChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.NodeIDValidating Event

Fired while validating the new value for NodeID.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> NodeIDValidating
Public Event NodeIDValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ NodeIDValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition.OPCNamespaceNameChanged Event

Fired when the OPCNamespaceName is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OPCNamespaceNameChanged
Public Event OPCNamespaceNameChanged As EventHandler
public:
 event EventHandler^ OPCNamespaceNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.OPCNamespaceNameValidating Event

Fired while validating the new value for OPCNamespaceName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> OPCNamespaceNameValidating
Public Event OPCNamespaceNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ OPCNamespaceNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition.SecurityPolicyUriChanged Event

Fired when the SecurityPolicyUri is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SecurityPolicyUriChanged
Public Event SecurityPolicyUriChanged As EventHandler
public:
 event EventHandler^ SecurityPolicyUriChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.SecurityPolicyUriValidating Event

Fired while validating the new value for SecurityPolicyUri.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SecurityPolicyUriValidating
Public Event SecurityPolicyUriValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SecurityPolicyUriValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition.ServerURLChanged Event

Fired when the ServerURL is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ServerURLChanged
Public Event ServerURLChanged As EventHandler
public:
 event EventHandler^ ServerURLChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.ServerURLValidating Event

Fired while validating the new value for ServerURL.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ServerURLValidating
Public Event ServerURLValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ServerURLValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition.SymbolNameChanged Event

Fired when the SymbolName is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SymbolNameChanged
Public Event SymbolNameChanged As EventHandler
public:
 event EventHandler^ SymbolNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.SymbolNameValidating Event

Fired while validating the new value for SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SymbolNameValidating
Public Event SymbolNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SymbolNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition.SymbolPathChanged Event

Fired when the SymbolPath is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SymbolPathChanged
Public Event SymbolPathChanged As EventHandler
public:
 event EventHandler^ SymbolPathChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.SymbolPathValidating Event

Fired while validating the new value for SymbolPath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SymbolPathValidating
Public Event SymbolPathValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SymbolPathValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition.UserNameChanged Event

Fired when the UserName is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UserNameChanged
Public Event UserNameChanged As EventHandler
public:
 event EventHandler^ UserNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OpcAcquisition Class


OpcAcquisition.UserNameValidating Event

Fired while validating the new value for UserName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UserNameValidating
Public Event UserNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UserNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OpcAcquisition Class


OpcAcquisition Fields

The OpcAcquisition type exposes the following members.

Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

OpcAcquisition Class


OrFunction Class

Function with OR Operator
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.API.ModelFunction
TwinCAT.Measurement.Scope.API.ModelDoubleInputFunction
TwinCAT.Measurement.Scope.API.ModelOrFunction

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class OrFunction : DoubleInputFunction
Public Class OrFunction
    Inherits DoubleInputFunction
public ref class OrFunction : public DoubleInputFunction

The OrFunction type exposes the following members.

Constructors
 | Name | Description
Public method | OrFunction | Create a new OR Function
Top
Properties
 | Name | Description
Public property | Value | The result of the Function (Overrides FunctionValue.)
Top
Methods
 | Name | Description
Public method | Contains | Test if the Function contains the ICodition (Inherited from DoubleInputFunction.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


OrFunction Constructor

Create a new OR Function

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public OrFunction(
    ICondition Input1,
    ICondition Input2
)
Public Sub New (
    Input1 As ICondition,
    Input2 As ICondition
)
public:
OrFunction(
    ICondition^ Input1,
    ICondition^ Input2
)

Parameters

Input1
Type: TwinCAT.Measurement.Scope.API.ModelICondition
The First Condition
Input2
Type: TwinCAT.Measurement.Scope.API.ModelICondition
The Second Condition
See Also

Reference

OrFunction Class


OrFunction Properties

The OrFunction type exposes the following members.

Properties
 | Name | Description
Public property | Value | The result of the Function (Overrides FunctionValue.)
Top
See Also

Reference

OrFunction Class


OrFunction.Value Property

The result of the Function

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool Value { get; }
Public Overrides ReadOnly Property Value As Boolean
    Get
public:
virtual property bool Value {
    bool get () override;
}

Property Value

Type: Boolean

Implements

IConditionValue
See Also

Reference

OrFunction Class


OrFunction Methods

The OrFunction type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Test if the Function contains the ICodition (Inherited from DoubleInputFunction.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OrFunction Class


OverviewBase Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelOverviewBase
TwinCAT.Measurement.Scope.API.ModelOverviewChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class OverviewBase : ScopeMemberBase
Public Class OverviewBase
    Inherits ScopeMemberBase
public ref class OverviewBase : public ScopeMemberBase

The OverviewBase type exposes the following members.

Constructors
 | Name | Description
Public method | OverviewBase | Initializes a new instance of the OverviewBase class
Public method | OverviewBase(OverviewBase) | Initializes a new instance of the OverviewBase class
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | OverviewVisible | Gets or Sets the OverviewVisible.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Config from XML-Reader (Overrides MeasurementMemberBaseReadXml(XmlReader).)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed.
Public event | ForeColorValidating | Fired while validating the new value for ForeColor.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OverviewVisibleChanged | Fired when the OverviewVisible is changed.
Public event | OverviewVisibleValidating | Fired while validating the new value for OverviewVisible.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Fields
Name | Description
DefaultDisplayColor | Get or Set the DefaultBackColor
DefaultForeColor | Get or Set the Default ForeColor
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


OverviewBase Constructor

Overload List
 | Name | Description
Public method | OverviewBase | Initializes a new instance of the OverviewBase class
Public method | OverviewBase(OverviewBase) | Initializes a new instance of the OverviewBase class
Top
See Also

Reference

OverviewBase Class


OverviewBase Constructor

Initializes a new instance of the OverviewBase class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public OverviewBase()
Public Sub New
public:
OverviewBase()
See Also

Reference

OverviewBase Class
OverviewBase Overload


OverviewBase Constructor (OverviewBase)

Initializes a new instance of the OverviewBase class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public OverviewBase(
    OverviewBase overview
)
Public Sub New (
    overview As OverviewBase
)
public:
OverviewBase(
    OverviewBase^ overview
)

Parameters

overview
Type: TwinCAT.Measurement.Scope.API.ModelOverviewBase
See Also

Reference

OverviewBase Class
OverviewBase Overload


OverviewBase Properties

The OverviewBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | OverviewVisible | Gets or Sets the OverviewVisible.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

OverviewBase Class


OverviewBase.DisplayColor Property

Gets or Sets the DisplayColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public override Color DisplayColor { get; set; }
<BrowsableAttribute(true)>
Public Overrides Property DisplayColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property Color DisplayColor {
    Color get () override;
    void set (Color value) override;
}

Property Value

Type: Color
See Also

Reference

OverviewBase Class


OverviewBase.ForeColor Property

Gets or Sets the ForeColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Color ForeColor { get; set; }
<BrowsableAttribute(true)>
Public Property ForeColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
property Color ForeColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

OverviewBase Class


OverviewBase.OverviewVisible Property

Gets or Sets the OverviewVisible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool OverviewVisible { get; set; }
<BrowsableAttribute(false)>
Public Property OverviewVisible As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool OverviewVisible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

OverviewBase Class


OverviewBase Methods

The OverviewBase type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Config from XML-Reader (Overrides MeasurementMemberBaseReadXml(XmlReader).)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

OverviewBase Class


OverviewBase.ReadXml Method

Read Element Config from XML-Reader

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void ReadXml(
    XmlReader reader
)
Public Overrides Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) override

Parameters

reader
Type: System.XmlXmlReader
Reader

Implements

IXmlSerializableReadXml(XmlReader)
See Also

Reference

OverviewBase Class


OverviewBase.UpdatePropertyAttributes Method

Updates the Attributes of Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

OverviewBase Class


OverviewBase Events

The OverviewBase type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed.
Public event | ForeColorValidating | Fired while validating the new value for ForeColor.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OverviewVisibleChanged | Fired when the OverviewVisible is changed.
Public event | OverviewVisibleValidating | Fired while validating the new value for OverviewVisible.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

OverviewBase Class


OverviewBase.ForeColorChanged Event

Fired when the ForeColor is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ForeColorChanged
Public Event ForeColorChanged As EventHandler
public:
 event EventHandler^ ForeColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OverviewBase Class


OverviewBase.ForeColorValidating Event

Fired while validating the new value for ForeColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ForeColorValidating
Public Event ForeColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ForeColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OverviewBase Class


OverviewBase.OverviewVisibleChanged Event

Fired when the OverviewVisible is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OverviewVisibleChanged
Public Event OverviewVisibleChanged As EventHandler
public:
 event EventHandler^ OverviewVisibleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OverviewBase Class


OverviewBase.OverviewVisibleValidating Event

Fired while validating the new value for OverviewVisible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> OverviewVisibleValidating
Public Event OverviewVisibleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ OverviewVisibleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OverviewBase Class


OverviewBase Fields

The OverviewBase type exposes the following members.

Fields
Name | Description
DefaultDisplayColor | Get or Set the DefaultBackColor
DefaultForeColor | Get or Set the Default ForeColor
Top
See Also

Reference

OverviewBase Class


OverviewBase.DefaultDisplayColor Field

Get or Set the DefaultBackColor

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static Color DefaultDisplayColor
Public Shared DefaultDisplayColor As Color
public:
static Color DefaultDisplayColor

Field Value

Type: Color
See Also

Reference

OverviewBase Class


OverviewBase.DefaultForeColor Field

Get or Set the Default ForeColor

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static Color DefaultForeColor
Public Shared DefaultForeColor As Color
public:
static Color DefaultForeColor

Field Value

Type: Color
See Also

Reference

OverviewBase Class


OverviewChart Class

Model class for an OverviewChart
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelOverviewBase
TwinCAT.Measurement.Scope.API.ModelOverviewChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class OverviewChart : OverviewBase
Public Class OverviewChart
    Inherits OverviewBase
public ref class OverviewChart : public OverviewBase

The OverviewChart type exposes the following members.

Constructors
 | Name | Description
Public method | OverviewChart | Create a new OverviewChart with default settings
Public method | OverviewChart(OverviewChart) | Create a new OverviewChart by copying Settings from another OverivewChart
Top
Properties
 | Name | Description
Public property | Channels | The List of Channels in this OverviewChart
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from OverviewBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from OverviewBase.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | InvertedTimeAxis | Gets or Sets the InvertedTimeAxis.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Markers | The List of Markers in this OverviewChart
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | OverviewVisible | Gets or Sets the OverviewVisible. (Inherited from OverviewBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | Resolution | Gets or Sets the Resolution.
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SourceID | Get the ID of the Source
Public property | StartTime | Gets or Sets the StartTime.
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | SuspendGetData | Suspend the GetData
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetDisplay | Refreshes the Display
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Config from XML-Reader (Inherited from OverviewBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartDisplay | Starts the overviewDisplay
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopDisplay | Stops the Display
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of Properties (Inherited from OverviewBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ChannelAdded | Fired when an Channel was Added
Public event | ChannelRemoved | Fired when an Channel was Removed
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from OverviewBase.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from OverviewBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InvertedTimeAxisChanged | Fired when the InvertedTimeAxis is changed.
Public event | InvertedTimeAxisValidating | Fired while validating the new value for InvertedTimeAxis.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MarkerAdded | Fired when a Marker was added
Public event | MarkerRemoved | Fired when a Marker was removed
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OverviewVisibleChanged | Fired when the OverviewVisible is changed. (Inherited from OverviewBase.)
Public event | OverviewVisibleValidating | Fired while validating the new value for OverviewVisible. (Inherited from OverviewBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RecordTimeChanged | Fired when the RecordTime Changed
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed.
Public event | ResolutionValidating | Fired while validating the new value for Resolution.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SourceIDChanged | Fired, when the SourceID Changed
Public event | StartTimeChanged | Fired when the StartTime is changed.
Public event | StartTimeValidating | Fired while validating the new value for StartTime.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


OverviewChart Constructor

Overload List
 | Name | Description
Public method | OverviewChart | Create a new OverviewChart with default settings
Public method | OverviewChart(OverviewChart) | Create a new OverviewChart by copying Settings from another OverivewChart
Top
See Also

Reference

OverviewChart Class


OverviewChart Constructor

Create a new OverviewChart with default settings

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public OverviewChart()
Public Sub New
public:
OverviewChart()
See Also

Reference

OverviewChart Class
OverviewChart Overload


OverviewChart Constructor (OverviewChart)

Create a new OverviewChart by copying Settings from another OverivewChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public OverviewChart(
    OverviewChart iCont
)
Public Sub New (
    iCont As OverviewChart
)
public:
OverviewChart(
    OverviewChart^ iCont
)

Parameters

iCont
Type: TwinCAT.Measurement.Scope.API.ModelOverviewChart
OverviewChart to copy from
See Also

Reference

OverviewChart Class
OverviewChart Overload


OverviewChart Properties

The OverviewChart type exposes the following members.

Properties
 | Name | Description
Public property | Channels | The List of Channels in this OverviewChart
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from OverviewBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from OverviewBase.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | InvertedTimeAxis | Gets or Sets the InvertedTimeAxis.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Markers | The List of Markers in this OverviewChart
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | OverviewVisible | Gets or Sets the OverviewVisible. (Inherited from OverviewBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | Resolution | Gets or Sets the Resolution.
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SourceID | Get the ID of the Source
Public property | StartTime | Gets or Sets the StartTime.
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | SuspendGetData | Suspend the GetData
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

OverviewChart Class


OverviewChart.Channels Property

The List of Channels in this OverviewChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public ReadOnlyCollection<Channel> Channels { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property Channels As ReadOnlyCollection(Of Channel)
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property ReadOnlyCollection<Channel^>^ Channels {
    ReadOnlyCollection<Channel^>^ get ();
}

Property Value

Type: ReadOnlyCollection Channel
See Also

Reference

OverviewChart Class


OverviewChart.GetRecordTime Property

Delegate Property to ask for RecordTime from Scope Project

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public delRecordTime GetRecordTime { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property GetRecordTime As delRecordTime
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property delRecordTime^ GetRecordTime {
    delRecordTime^ get ();
    void set (delRecordTime^ value);
}

Property Value

Type: delRecordTime
See Also

Reference

OverviewChart Class


OverviewChart.InvertedTimeAxis Property

Gets or Sets the InvertedTimeAxis.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool InvertedTimeAxis { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property InvertedTimeAxis As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool InvertedTimeAxis {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

OverviewChart Class


OverviewChart.Markers Property

The List of Markers in this OverviewChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public ReadOnlyCollection<TimeMarker> Markers { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property Markers As ReadOnlyCollection(Of TimeMarker)
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property ReadOnlyCollection<TimeMarker^>^ Markers {
    ReadOnlyCollection<TimeMarker^>^ get ();
}

Property Value

Type: ReadOnlyCollection TimeMarker
See Also

Reference

OverviewChart Class


OverviewChart.Resolution Property

Gets or Sets the Resolution.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public uint Resolution { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property Resolution As UInteger
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property unsigned int Resolution {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

OverviewChart Class


OverviewChart.SourceID Property

Get the ID of the Source

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public int SourceID { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property SourceID As Integer
    Get
public:
[BrowsableAttribute(false)]
property int SourceID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

OverviewChart Class


OverviewChart.StartTime Property

Gets or Sets the StartTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public long StartTime { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property StartTime As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property long long StartTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

OverviewChart Class


OverviewChart.SuspendGetData Property

Suspend the GetData

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public bool SuspendGetData { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property SuspendGetData As Boolean
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property bool SuspendGetData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

OverviewChart Class


OverviewChart Methods

The OverviewChart type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetDisplay | Refreshes the Display
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Config from XML-Reader (Inherited from OverviewBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartDisplay | Starts the overviewDisplay
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopDisplay | Stops the Display
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of Properties (Inherited from OverviewBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

OverviewChart Class


OverviewChart.GetDisplay Method

Refreshes the Display

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void GetDisplay()
Public Sub GetDisplay
public:
void GetDisplay()
See Also

Reference

OverviewChart Class


OverviewChart.StartDisplay Method

Starts the overviewDisplay

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void StartDisplay()
Public Sub StartDisplay
public:
void StartDisplay()
See Also

Reference

OverviewChart Class


OverviewChart.StopDisplay Method

Stops the Display

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void StopDisplay()
Public Sub StopDisplay
public:
void StopDisplay()
See Also

Reference

OverviewChart Class


OverviewChart Events

The OverviewChart type exposes the following members.

Events
 | Name | Description
Public event | ChannelAdded | Fired when an Channel was Added
Public event | ChannelRemoved | Fired when an Channel was Removed
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from OverviewBase.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from OverviewBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InvertedTimeAxisChanged | Fired when the InvertedTimeAxis is changed.
Public event | InvertedTimeAxisValidating | Fired while validating the new value for InvertedTimeAxis.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MarkerAdded | Fired when a Marker was added
Public event | MarkerRemoved | Fired when a Marker was removed
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OverviewVisibleChanged | Fired when the OverviewVisible is changed. (Inherited from OverviewBase.)
Public event | OverviewVisibleValidating | Fired while validating the new value for OverviewVisible. (Inherited from OverviewBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RecordTimeChanged | Fired when the RecordTime Changed
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed.
Public event | ResolutionValidating | Fired while validating the new value for Resolution.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SourceIDChanged | Fired, when the SourceID Changed
Public event | StartTimeChanged | Fired when the StartTime is changed.
Public event | StartTimeValidating | Fired while validating the new value for StartTime.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

OverviewChart Class


OverviewChart.ChannelAdded Event

Fired when an Channel was Added

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<Channel> ChannelAdded
Public Event ChannelAdded As EventHandler(Of Channel)
public:
 event EventHandler<Channel^>^ ChannelAdded {
    void add (EventHandler<Channel^>^ value);
    void remove (EventHandler<Channel^>^ value);
}

Value

Type: SystemEventHandler Channel
See Also

Reference

OverviewChart Class


OverviewChart.ChannelRemoved Event

Fired when an Channel was Removed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<Channel> ChannelRemoved
Public Event ChannelRemoved As EventHandler(Of Channel)
public:
 event EventHandler<Channel^>^ ChannelRemoved {
    void add (EventHandler<Channel^>^ value);
    void remove (EventHandler<Channel^>^ value);
}

Value

Type: SystemEventHandler Channel
See Also

Reference

OverviewChart Class


OverviewChart.DisplayFrameEnded Event

Fired when DisplayFramehandling is completed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DisplayFrameEnded
Public Event DisplayFrameEnded As EventHandler
public:
 event EventHandler^ DisplayFrameEnded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OverviewChart Class


OverviewChart.InvertedTimeAxisChanged Event

Fired when the InvertedTimeAxis is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler InvertedTimeAxisChanged
Public Event InvertedTimeAxisChanged As EventHandler
public:
 event EventHandler^ InvertedTimeAxisChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OverviewChart Class


OverviewChart.InvertedTimeAxisValidating Event

Fired while validating the new value for InvertedTimeAxis.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> InvertedTimeAxisValidating
Public Event InvertedTimeAxisValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ InvertedTimeAxisValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OverviewChart Class


OverviewChart.MarkerAdded Event

Fired when a Marker was added

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<TimeMarker> MarkerAdded
Public Event MarkerAdded As EventHandler(Of TimeMarker)
public:
 event EventHandler<TimeMarker^>^ MarkerAdded {
    void add (EventHandler<TimeMarker^>^ value);
    void remove (EventHandler<TimeMarker^>^ value);
}

Value

Type: SystemEventHandler TimeMarker
See Also

Reference

OverviewChart Class


OverviewChart.MarkerRemoved Event

Fired when a Marker was removed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<TimeMarker> MarkerRemoved
Public Event MarkerRemoved As EventHandler(Of TimeMarker)
public:
 event EventHandler<TimeMarker^>^ MarkerRemoved {
    void add (EventHandler<TimeMarker^>^ value);
    void remove (EventHandler<TimeMarker^>^ value);
}

Value

Type: SystemEventHandler TimeMarker
See Also

Reference

OverviewChart Class


OverviewChart.RecordTimeChanged Event

Fired when the RecordTime Changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<long> RecordTimeChanged
Public Event RecordTimeChanged As EventHandler(Of Long)
public:
 event EventHandler<long long>^ RecordTimeChanged {
    void add (EventHandler<long long>^ value);
    void remove (EventHandler<long long>^ value);
}

Value

Type: SystemEventHandler Int64
See Also

Reference

OverviewChart Class


OverviewChart.ResolutionChanged Event

Fired when the Resolution is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ResolutionChanged
Public Event ResolutionChanged As EventHandler
public:
 event EventHandler^ ResolutionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OverviewChart Class


OverviewChart.ResolutionValidating Event

Fired while validating the new value for Resolution.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ResolutionValidating
Public Event ResolutionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ResolutionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OverviewChart Class


OverviewChart.SourceIDChanged Event

Fired, when the SourceID Changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SourceIDChanged
Public Event SourceIDChanged As EventHandler
public:
 event EventHandler^ SourceIDChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OverviewChart Class


OverviewChart.StartTimeChanged Event

Fired when the StartTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StartTimeChanged
Public Event StartTimeChanged As EventHandler
public:
 event EventHandler^ StartTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

OverviewChart Class


OverviewChart.StartTimeValidating Event

Fired while validating the new value for StartTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> StartTimeValidating
Public Event StartTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ StartTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

OverviewChart Class


PointsCollection Class

Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection ShapeXYPoint
System.Collections.ObjectModelObservableCollection ShapeXYPoint
ScopeObservableCollectionShapeXYPoint
TwinCAT.Measurement.Scope.API.ModelPointsCollection

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class PointsCollection : ScopeObservableCollection<ShapeXYPoint>
Public Class PointsCollection
    Inherits ScopeObservableCollection(Of ShapeXYPoint)
public ref class PointsCollection : public ScopeObservableCollection<ShapeXYPoint^>

The PointsCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PointsCollection | Initializes a new instance of the PointsCollection class
Public method | PointsCollection(IEnumerableShapeXYPoint) | Initializes a new instance of the PointsCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection ShapeXYPoint .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | ClonePointsOnly |
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection ShapeXYPoint .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection ShapeXYPoint .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection ShapeXYPoint .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection ShapeXYPoint .)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


PointsCollection Constructor

Overload List
 | Name | Description
Public method | PointsCollection | Initializes a new instance of the PointsCollection class
Public method | PointsCollection(IEnumerableShapeXYPoint) | Initializes a new instance of the PointsCollection class
Top
See Also

Reference

PointsCollection Class


PointsCollection Constructor

Initializes a new instance of the PointsCollection class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public PointsCollection()
Public Sub New
public:
PointsCollection()
See Also

Reference

PointsCollection Class
PointsCollection Overload


PointsCollection Constructor (IEnumerable(ShapeXYPoint))

Initializes a new instance of the PointsCollection class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public PointsCollection(
    IEnumerable<ShapeXYPoint> Points
)
Public Sub New (
    Points As IEnumerable(Of ShapeXYPoint)
)
public:
PointsCollection(
    IEnumerable<ShapeXYPoint^>^ Points
)

Parameters

Points
Type: System.Collections.GenericIEnumerable ShapeXYPoint
See Also

Reference

PointsCollection Class
PointsCollection Overload


PointsCollection Properties

The PointsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection ShapeXYPoint .)
Top
See Also

Reference

PointsCollection Class


PointsCollection Methods

The PointsCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | ClonePointsOnly |
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection ShapeXYPoint .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection ShapeXYPoint .)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection ShapeXYPoint .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection ShapeXYPoint .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PointsCollection Class


PointsCollection.ClonePointsOnly Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public PointsCollection ClonePointsOnly()
Public Function ClonePointsOnly As PointsCollection
public:
PointsCollection^ ClonePointsOnly()

Return Value

Type: PointsCollection
See Also

Reference

PointsCollection Class


PointsCollection Events

The PointsCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection ShapeXYPoint .)
Top
See Also

Reference

PointsCollection Class


PropertyUpdaterMarker Class

Makrer to update the PropertyUpdate VAlues
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelMarker
TwinCAT.Measurement.Scope.API.ModelTimeMarker
TwinCAT.Measurement.Scope.API.ModelPropertyUpdaterMarker

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class PropertyUpdaterMarker : TimeMarker
Public Class PropertyUpdaterMarker
    Inherits TimeMarker
public ref class PropertyUpdaterMarker : public TimeMarker

The PropertyUpdaterMarker type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyUpdaterMarker | Creates an Instance of PropertyUpdaterMarker
Public method | PropertyUpdaterMarker(PropertyUpdaterMarker) | Creates a copy of the parameter
Top
Properties
 | Name | Description
Public property | AttachToAxis | Gets or Sets the AttachToAxis. If AttachToAxis is True --> The position is an absolut value of this axis. If AttachToAxis is False --> The position is an relative value of the displayed axis. (Inherited from Marker.)
Public property | AttachToAxisBrowsable | (Inherited from Marker.)
Public property | Bandwidth | Gets or Sets the Bandwidth. (Inherited from Marker.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Marker.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetNearestPosition | Get Field for GetNearestPosition Delegate (Inherited from Marker.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineStyle | Gets or Sets the LineStyle. (Inherited from Marker.)
Public property | Locked | Gets or Sets the Locked. (Inherited from Marker.)
Public property | Marker3DType | Gets or Sets the Marker3DType. (Inherited from TimeMarker.)
Public property | MarkerType | Gets or Sets the MarkerType. (Inherited from TimeMarker.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Marker.)
Public property | Position | Gets or Sets the Position. (Inherited from Marker.)
Public property | PositionPropertyUpdater | (Inherited from Marker.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowFullArray | Gets or Sets the ShowFullArray. (Inherited from TimeMarker.)
Public property | ShowPosition | Gets or Sets the ShowPosition. (Inherited from Marker.)
Public property | ShowTitle | Gets or Sets the ShowTitle. (Inherited from Marker.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimePosition | Gets or Sets the TimePosition. (Inherited from Marker.)
Public property | Title | Gets or Sets the Title (Inherited from Marker.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | ValuePrecision | Gets or Sets the ValuePrecision. (Inherited from Marker.)
Public property | Visible | Gets or Sets the Visible. (Inherited from Marker.)
Public property | Width | Gets or Sets the Width. (Inherited from Marker.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddValue | (Inherited from Marker.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | CalcTimePosition | Calculate the current timeposition with the given position (Inherited from Marker.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ContainsChannelValue | Obsolete. Check if the Marker has an value from the channel (Inherited from Marker.)
Public method | ContainsMemberValue | Check if the Marker has an value from the member (Inherited from Marker.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllValues | Returns a copy of the ValueDictionary (Inherited from Marker.)
Public method | GetChannelValue | Obsolete. Gets the channelvalue of the Marker (Inherited from Marker.)
Public method | GetCommands | Gets the possible commands (Inherited from TimeMarker.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberValue | Gets the membervalue of the Marker (Inherited from Marker.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubInterpreterValue | (Inherited from Marker.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Get the Values for this Marker as string (Inherited from Marker.)
Public method | Highlight | Highlight the Graph of this channel (Inherited from Marker.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RefreshValue | (Inherited from Marker.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts a Marker to string (Inherited from Marker.)
Public method | UpdatePropertyAttributes | Updates the Attributes of all Properties (Inherited from TimeMarker.)
Public method | UpdateTimePosition | Calculate the current timeposition with the given position (Inherited from Marker.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AttachToAxisChanged | Fired when the AttachToAxis is changed. (Inherited from Marker.)
Public event | AttachToAxisValidating | Fired while validating the new value for AttachToAxis. (Inherited from Marker.)
Public event | BandwidthChanged | Fired when the Bandwidth is changed. (Inherited from Marker.)
Public event | BandwidthValidating | Fired while validating the new value for Bandwidth. (Inherited from Marker.)
Public event | BeforePositionChanged | Fired before the position changed (Inherited from Marker.)
Public event | CenterToScreen | Event fired to Center the Marker to Screen (Inherited from TimeMarker.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightEvent | Event fired when the marker should be highlighted (Inherited from Marker.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineStyleChanged | Fired when the LineStyle is changed. (Inherited from Marker.)
Public event | LineStyleValidating | Fired while validating the new value for LineStyle. (Inherited from Marker.)
Public event | LockedChanged | Fired when the Locked is changed. (Inherited from Marker.)
Public event | LockedValidating | Fired while validating the new value for Locked. (Inherited from Marker.)
Public event | Marker3DTypeChanged | Fired when the Marker3DType is changed. (Inherited from TimeMarker.)
Public event | Marker3DTypeValidating | Fired while validating the new value for Marker3DType. (Inherited from TimeMarker.)
Public event | MarkerTypeChanged | Fired when the MarkerType is changed. (Inherited from TimeMarker.)
Public event | MarkerTypeValidating | Fired while validating the new value for MarkerType. (Inherited from TimeMarker.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NewMarkerValues | Event fired when Values has Changed (Inherited from Marker.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Marker.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Marker.)
Public event | PositionChanged | Fired when the Position is changed. (Inherited from Marker.)
Public event | PositionValidating | Fired while validating the new value for Position. (Inherited from Marker.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshClientTimePosition | Event fired to check, if the Chart is running or stopped (Inherited from TimeMarker.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowFullArrayChanged | Fired when the ShowFullArray is changed. (Inherited from TimeMarker.)
Public event | ShowFullArrayChanging | Fired while changing the ShowFullArray. (Inherited from TimeMarker.)
Public event | ShowFullArrayValidating | Fired while validating the new value for ShowFullArray. (Inherited from TimeMarker.)
Public event | ShowPositionChanged | Fired when the ShowPosition is changed. (Inherited from Marker.)
Public event | ShowPositionValidating | Fired while validating the new value for ShowPosition. (Inherited from Marker.)
Public event | ShowTitleChanged | Fired when the ShowTitle is changed. (Inherited from Marker.)
Public event | ShowTitleValidating | Fired while validating the new value for ShowTitle. (Inherited from Marker.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimePositionChanged | Fired when the TimePosition is changed. (Inherited from Marker.)
Public event | TimePositionValidating | Fired while validating the new value for TimePosition. (Inherited from Marker.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | ValueDictChanged | Fired when the ValueDict is changed. (Inherited from Marker.)
Public event | ValueDictValidating | Fired while validating the new value for ValueDict. (Inherited from Marker.)
Public event | ValuePrecisionChanged | Fired when the ValuePrecision is changed. (Inherited from Marker.)
Public event | ValuePrecisionValidating | Fired while validating the new value for ValuePrecision. (Inherited from Marker.)
Public event | VisibleChanged | Fired when the Visible is changed. (Inherited from Marker.)
Public event | VisibleValidating | Fired while validating the new value for Visible. (Inherited from Marker.)
Public event | WidthChanged | Fired when the Width is changed. (Inherited from Marker.)
Public event | WidthValidating | Fired while validating the new value for Width. (Inherited from Marker.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


PropertyUpdaterMarker Constructor

Overload List
 | Name | Description
Public method | PropertyUpdaterMarker | Creates an Instance of PropertyUpdaterMarker
Public method | PropertyUpdaterMarker(PropertyUpdaterMarker) | Creates a copy of the parameter
Top
See Also

Reference

PropertyUpdaterMarker Class


PropertyUpdaterMarker Constructor

Creates an Instance of PropertyUpdaterMarker

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public PropertyUpdaterMarker()
Public Sub New
public:
PropertyUpdaterMarker()
See Also

Reference

PropertyUpdaterMarker Class
PropertyUpdaterMarker Overload


PropertyUpdaterMarker Constructor (PropertyUpdaterMarker)

Creates a copy of the parameter

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public PropertyUpdaterMarker(
    PropertyUpdaterMarker propertyUpdaterMarker
)
Public Sub New (
    propertyUpdaterMarker As PropertyUpdaterMarker
)
public:
PropertyUpdaterMarker(
    PropertyUpdaterMarker^ propertyUpdaterMarker
)

Parameters

propertyUpdaterMarker
Type: TwinCAT.Measurement.Scope.API.ModelPropertyUpdaterMarker
See Also

Reference

PropertyUpdaterMarker Class
PropertyUpdaterMarker Overload


PropertyUpdaterMarker Properties

The PropertyUpdaterMarker type exposes the following members.

Properties
 | Name | Description
Public property | AttachToAxis | Gets or Sets the AttachToAxis. If AttachToAxis is True --> The position is an absolut value of this axis. If AttachToAxis is False --> The position is an relative value of the displayed axis. (Inherited from Marker.)
Public property | AttachToAxisBrowsable | (Inherited from Marker.)
Public property | Bandwidth | Gets or Sets the Bandwidth. (Inherited from Marker.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Marker.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetNearestPosition | Get Field for GetNearestPosition Delegate (Inherited from Marker.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineStyle | Gets or Sets the LineStyle. (Inherited from Marker.)
Public property | Locked | Gets or Sets the Locked. (Inherited from Marker.)
Public property | Marker3DType | Gets or Sets the Marker3DType. (Inherited from TimeMarker.)
Public property | MarkerType | Gets or Sets the MarkerType. (Inherited from TimeMarker.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Marker.)
Public property | Position | Gets or Sets the Position. (Inherited from Marker.)
Public property | PositionPropertyUpdater | (Inherited from Marker.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowFullArray | Gets or Sets the ShowFullArray. (Inherited from TimeMarker.)
Public property | ShowPosition | Gets or Sets the ShowPosition. (Inherited from Marker.)
Public property | ShowTitle | Gets or Sets the ShowTitle. (Inherited from Marker.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimePosition | Gets or Sets the TimePosition. (Inherited from Marker.)
Public property | Title | Gets or Sets the Title (Inherited from Marker.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | ValuePrecision | Gets or Sets the ValuePrecision. (Inherited from Marker.)
Public property | Visible | Gets or Sets the Visible. (Inherited from Marker.)
Public property | Width | Gets or Sets the Width. (Inherited from Marker.)
Top
See Also

Reference

PropertyUpdaterMarker Class


PropertyUpdaterMarker Methods

The PropertyUpdaterMarker type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddValue | (Inherited from Marker.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | CalcTimePosition | Calculate the current timeposition with the given position (Inherited from Marker.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ContainsChannelValue | Obsolete. Check if the Marker has an value from the channel (Inherited from Marker.)
Public method | ContainsMemberValue | Check if the Marker has an value from the member (Inherited from Marker.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllValues | Returns a copy of the ValueDictionary (Inherited from Marker.)
Public method | GetChannelValue | Obsolete. Gets the channelvalue of the Marker (Inherited from Marker.)
Public method | GetCommands | Gets the possible commands (Inherited from TimeMarker.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberValue | Gets the membervalue of the Marker (Inherited from Marker.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubInterpreterValue | (Inherited from Marker.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Get the Values for this Marker as string (Inherited from Marker.)
Public method | Highlight | Highlight the Graph of this channel (Inherited from Marker.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RefreshValue | (Inherited from Marker.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts a Marker to string (Inherited from Marker.)
Public method | UpdatePropertyAttributes | Updates the Attributes of all Properties (Inherited from TimeMarker.)
Public method | UpdateTimePosition | Calculate the current timeposition with the given position (Inherited from Marker.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

PropertyUpdaterMarker Class


PropertyUpdaterMarker Events

The PropertyUpdaterMarker type exposes the following members.

Events
 | Name | Description
Public event | AttachToAxisChanged | Fired when the AttachToAxis is changed. (Inherited from Marker.)
Public event | AttachToAxisValidating | Fired while validating the new value for AttachToAxis. (Inherited from Marker.)
Public event | BandwidthChanged | Fired when the Bandwidth is changed. (Inherited from Marker.)
Public event | BandwidthValidating | Fired while validating the new value for Bandwidth. (Inherited from Marker.)
Public event | BeforePositionChanged | Fired before the position changed (Inherited from Marker.)
Public event | CenterToScreen | Event fired to Center the Marker to Screen (Inherited from TimeMarker.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightEvent | Event fired when the marker should be highlighted (Inherited from Marker.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineStyleChanged | Fired when the LineStyle is changed. (Inherited from Marker.)
Public event | LineStyleValidating | Fired while validating the new value for LineStyle. (Inherited from Marker.)
Public event | LockedChanged | Fired when the Locked is changed. (Inherited from Marker.)
Public event | LockedValidating | Fired while validating the new value for Locked. (Inherited from Marker.)
Public event | Marker3DTypeChanged | Fired when the Marker3DType is changed. (Inherited from TimeMarker.)
Public event | Marker3DTypeValidating | Fired while validating the new value for Marker3DType. (Inherited from TimeMarker.)
Public event | MarkerTypeChanged | Fired when the MarkerType is changed. (Inherited from TimeMarker.)
Public event | MarkerTypeValidating | Fired while validating the new value for MarkerType. (Inherited from TimeMarker.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NewMarkerValues | Event fired when Values has Changed (Inherited from Marker.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Marker.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Marker.)
Public event | PositionChanged | Fired when the Position is changed. (Inherited from Marker.)
Public event | PositionValidating | Fired while validating the new value for Position. (Inherited from Marker.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshClientTimePosition | Event fired to check, if the Chart is running or stopped (Inherited from TimeMarker.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowFullArrayChanged | Fired when the ShowFullArray is changed. (Inherited from TimeMarker.)
Public event | ShowFullArrayChanging | Fired while changing the ShowFullArray. (Inherited from TimeMarker.)
Public event | ShowFullArrayValidating | Fired while validating the new value for ShowFullArray. (Inherited from TimeMarker.)
Public event | ShowPositionChanged | Fired when the ShowPosition is changed. (Inherited from Marker.)
Public event | ShowPositionValidating | Fired while validating the new value for ShowPosition. (Inherited from Marker.)
Public event | ShowTitleChanged | Fired when the ShowTitle is changed. (Inherited from Marker.)
Public event | ShowTitleValidating | Fired while validating the new value for ShowTitle. (Inherited from Marker.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimePositionChanged | Fired when the TimePosition is changed. (Inherited from Marker.)
Public event | TimePositionValidating | Fired while validating the new value for TimePosition. (Inherited from Marker.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | ValueDictChanged | Fired when the ValueDict is changed. (Inherited from Marker.)
Public event | ValueDictValidating | Fired while validating the new value for ValueDict. (Inherited from Marker.)
Public event | ValuePrecisionChanged | Fired when the ValuePrecision is changed. (Inherited from Marker.)
Public event | ValuePrecisionValidating | Fired while validating the new value for ValuePrecision. (Inherited from Marker.)
Public event | VisibleChanged | Fired when the Visible is changed. (Inherited from Marker.)
Public event | VisibleValidating | Fired while validating the new value for Visible. (Inherited from Marker.)
Public event | WidthChanged | Fired when the Width is changed. (Inherited from Marker.)
Public event | WidthValidating | Fired while validating the new value for Width. (Inherited from Marker.)
Top
See Also

Reference

PropertyUpdaterMarker Class


RefAcquisitionSequenceData Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelSequenceDataSource
TwinCAT.Measurement.Scope.API.ModelIotFileSequenceData
TwinCAT.Measurement.Scope.API.ModelRefAcquisitionSequenceData

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class RefAcquisitionSequenceData : IotFileSequenceData
Public Class RefAcquisitionSequenceData
    Inherits IotFileSequenceData
public ref class RefAcquisitionSequenceData : public IotFileSequenceData

The RefAcquisitionSequenceData type exposes the following members.

Constructors
 | Name | Description
Public method | RefAcquisitionSequenceData | Initializes a new instance of the RefAcquisitionSequenceData class
Public method | RefAcquisitionSequenceData(RefAcquisitionSequenceData) | Initializes a new instance of the RefAcquisitionSequenceData class
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Folder | Gets or Sets the Folder. (Inherited from IotFileSequenceData.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | Reference | Gets or Sets the Reference.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | TasFile | Gets or Sets the TasFile. (Inherited from IotFileSequenceData.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FolderChanged | Fired when the Folder is changed. (Inherited from IotFileSequenceData.)
Public event | FolderValidating | Fired while validating the new value for Folder. (Inherited from IotFileSequenceData.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReferenceChanged | Fired when the Reference is changed.
Public event | ReferenceValidating | Fired while validating the new value for Reference.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TasFileChanged | Fired when the TasFile is changed. (Inherited from IotFileSequenceData.)
Public event | TasFileValidating | Fired while validating the new value for TasFile. (Inherited from IotFileSequenceData.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


RefAcquisitionSequenceData Constructor

Overload List
 | Name | Description
Public method | RefAcquisitionSequenceData | Initializes a new instance of the RefAcquisitionSequenceData class
Public method | RefAcquisitionSequenceData(RefAcquisitionSequenceData) | Initializes a new instance of the RefAcquisitionSequenceData class
Top
See Also

Reference

RefAcquisitionSequenceData Class


RefAcquisitionSequenceData Constructor

Initializes a new instance of the RefAcquisitionSequenceData class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public RefAcquisitionSequenceData()
Public Sub New
public:
RefAcquisitionSequenceData()
See Also

Reference

RefAcquisitionSequenceData Class
RefAcquisitionSequenceData Overload


RefAcquisitionSequenceData Constructor (RefAcquisitionSequenceData)

Initializes a new instance of the RefAcquisitionSequenceData class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public RefAcquisitionSequenceData(
    RefAcquisitionSequenceData export
)
Public Sub New (
    export As RefAcquisitionSequenceData
)
public:
RefAcquisitionSequenceData(
    RefAcquisitionSequenceData^ export
)

Parameters

export
Type: TwinCAT.Measurement.Scope.API.ModelRefAcquisitionSequenceData
See Also

Reference

RefAcquisitionSequenceData Class
RefAcquisitionSequenceData Overload


RefAcquisitionSequenceData Properties

The RefAcquisitionSequenceData type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Folder | Gets or Sets the Folder. (Inherited from IotFileSequenceData.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | Reference | Gets or Sets the Reference.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | TasFile | Gets or Sets the TasFile. (Inherited from IotFileSequenceData.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

RefAcquisitionSequenceData Class


RefAcquisitionSequenceData.Reference Property

Gets or Sets the Reference.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public Acquisition Reference { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property Reference As Acquisition
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property Acquisition^ Reference {
    Acquisition^ get ();
    void set (Acquisition^ value);
}

Property Value

Type: Acquisition
See Also

Reference

RefAcquisitionSequenceData Class


RefAcquisitionSequenceData Methods

The RefAcquisitionSequenceData type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

RefAcquisitionSequenceData Class


RefAcquisitionSequenceData Events

The RefAcquisitionSequenceData type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FolderChanged | Fired when the Folder is changed. (Inherited from IotFileSequenceData.)
Public event | FolderValidating | Fired while validating the new value for Folder. (Inherited from IotFileSequenceData.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReferenceChanged | Fired when the Reference is changed.
Public event | ReferenceValidating | Fired while validating the new value for Reference.
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TasFileChanged | Fired when the TasFile is changed. (Inherited from IotFileSequenceData.)
Public event | TasFileValidating | Fired while validating the new value for TasFile. (Inherited from IotFileSequenceData.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

RefAcquisitionSequenceData Class


RefAcquisitionSequenceData.ReferenceChanged Event

Fired when the Reference is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReferenceChanged
Public Event ReferenceChanged As EventHandler
public:
 event EventHandler^ ReferenceChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

RefAcquisitionSequenceData Class


RefAcquisitionSequenceData.ReferenceValidating Event

Fired while validating the new value for Reference.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReferenceValidating
Public Event ReferenceValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReferenceValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

RefAcquisitionSequenceData Class


RefDataCollector Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelRefDataCollector

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class RefDataCollector : MeasurementMemberContainerBase
Public Class RefDataCollector
    Inherits MeasurementMemberContainerBase
public ref class RefDataCollector : public MeasurementMemberContainerBase

The RefDataCollector type exposes the following members.

Constructors
 | Name | Description
Public method | RefDataCollector | Initializes a new instance of the RefDataCollector class
Public method | RefDataCollector(RefDataCollector) | Initializes a new instance of the RefDataCollector class
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshData |
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


RefDataCollector Constructor

Overload List
 | Name | Description
Public method | RefDataCollector | Initializes a new instance of the RefDataCollector class
Public method | RefDataCollector(RefDataCollector) | Initializes a new instance of the RefDataCollector class
Top
See Also

Reference

RefDataCollector Class


RefDataCollector Constructor

Initializes a new instance of the RefDataCollector class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public RefDataCollector()
Public Sub New
public:
RefDataCollector()
See Also

Reference

RefDataCollector Class
RefDataCollector Overload


RefDataCollector Constructor (RefDataCollector)

Initializes a new instance of the RefDataCollector class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public RefDataCollector(
    RefDataCollector refDataCollector
)
Public Sub New (
    refDataCollector As RefDataCollector
)
public:
RefDataCollector(
    RefDataCollector^ refDataCollector
)

Parameters

refDataCollector
Type: TwinCAT.Measurement.Scope.API.ModelRefDataCollector
See Also

Reference

RefDataCollector Class
RefDataCollector Overload


RefDataCollector Properties

The RefDataCollector type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

RefDataCollector Class


RefDataCollector Methods

The RefDataCollector type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

RefDataCollector Class


RefDataCollector Events

The RefDataCollector type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshData |
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

RefDataCollector Class


RefDataCollector.RefreshData Event

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler RefreshData
Public Event RefreshData As EventHandler
public:
 event EventHandler^ RefreshData {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

RefDataCollector Class


RefElementItem Class

ViewModel of an ChartItem
Inheritance Hierarchy
SystemObject
ModelBase
TwinCAT.Measurement.Scope.API.ModelRefElementItem

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class RefElementItem : ModelBase
Public Class RefElementItem
    Inherits ModelBase
public ref class RefElementItem : public ModelBase

The RefElementItem type exposes the following members.

Constructors
 | Name | Description
Public method | RefElementItem | CTOR of ChartItem
Top
Properties
 | Name | Description
Public property | Children | Gets or Sets the Children.
Public property | IsSelected | Gets or Sets the IsSelected.
Public property | ReferencedMember | Gets or Sets the ReferencedMember.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


RefElementItem Constructor

CTOR of ChartItem

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public RefElementItem(
    MeasurementMemberBase chart
)
Public Sub New (
    chart As MeasurementMemberBase
)
public:
RefElementItem(
    MeasurementMemberBase^ chart
)

Parameters

chart
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
See Also

Reference

RefElementItem Class


RefElementItem Properties

The RefElementItem type exposes the following members.

Properties
 | Name | Description
Public property | Children | Gets or Sets the Children.
Public property | IsSelected | Gets or Sets the IsSelected.
Public property | ReferencedMember | Gets or Sets the ReferencedMember.
Top
See Also

Reference

RefElementItem Class


RefElementItem.Children Property

Gets or Sets the Children.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ObservableCollection<RefElementItem> Children { get; set; }
Public Property Children As ObservableCollection(Of RefElementItem)
    Get
    Set
public:
property ObservableCollection<RefElementItem^>^ Children {
    ObservableCollection<RefElementItem^>^ get ();
    void set (ObservableCollection<RefElementItem^>^ value);
}

Property Value

Type: ObservableCollection RefElementItem
See Also

Reference

RefElementItem Class


RefElementItem.IsSelected Property

Gets or Sets the IsSelected.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

RefElementItem Class


RefElementItem.ReferencedMember Property

Gets or Sets the ReferencedMember.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MeasurementMemberBase ReferencedMember { get; set; }
Public Property ReferencedMember As MeasurementMemberBase
    Get
    Set
public:
property MeasurementMemberBase^ ReferencedMember {
    MeasurementMemberBase^ get ();
    void set (MeasurementMemberBase^ value);
}

Property Value

Type: MeasurementMemberBase
See Also

Reference

RefElementItem Class


RefElementItem Methods

The RefElementItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RefElementItem Class


RefElementItem Events

The RefElementItem type exposes the following members.

Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

RefElementItem Class


RepeatDataCollector Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAnchorTimeBase
TwinCAT.Measurement.Scope.API.ModelRepeatDataCollector

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class RepeatDataCollector : AnchorTimeBase
Public Class RepeatDataCollector
    Inherits AnchorTimeBase
public ref class RepeatDataCollector : public AnchorTimeBase

The RepeatDataCollector type exposes the following members.

Constructors
 | Name | Description
Public method | RepeatDataCollector | Initializes a new instance of the RepeatDataCollector class
Public method | RepeatDataCollector(RepeatDataCollector) | Initializes a new instance of the RepeatDataCollector class
Top
Properties
 | Name | Description
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowFullGraph | Gets or Sets the ShowFullGraph.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowFullGraphChanged | Fired when the ShowFullGraph is changed.
Public event | ShowFullGraphValidating | Fired while validating the new value for ShowFullGraph.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


RepeatDataCollector Constructor

Overload List
 | Name | Description
Public method | RepeatDataCollector | Initializes a new instance of the RepeatDataCollector class
Public method | RepeatDataCollector(RepeatDataCollector) | Initializes a new instance of the RepeatDataCollector class
Top
See Also

Reference

RepeatDataCollector Class


RepeatDataCollector Constructor

Initializes a new instance of the RepeatDataCollector class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public RepeatDataCollector()
Public Sub New
public:
RepeatDataCollector()
See Also

Reference

RepeatDataCollector Class
RepeatDataCollector Overload


RepeatDataCollector Constructor (RepeatDataCollector)

Initializes a new instance of the RepeatDataCollector class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public RepeatDataCollector(
    RepeatDataCollector repeatDataCollector
)
Public Sub New (
    repeatDataCollector As RepeatDataCollector
)
public:
RepeatDataCollector(
    RepeatDataCollector^ repeatDataCollector
)

Parameters

repeatDataCollector
Type: TwinCAT.Measurement.Scope.API.ModelRepeatDataCollector
See Also

Reference

RepeatDataCollector Class
RepeatDataCollector Overload


RepeatDataCollector Properties

The RepeatDataCollector type exposes the following members.

Properties
 | Name | Description
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowFullGraph | Gets or Sets the ShowFullGraph.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

RepeatDataCollector Class


RepeatDataCollector.ShowFullGraph Property

Gets or Sets the ShowFullGraph.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ShowFullGraph { get; set; }
<BrowsableAttribute(true)>
Public Property ShowFullGraph As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ShowFullGraph {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

RepeatDataCollector Class


RepeatDataCollector Methods

The RepeatDataCollector type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberContainerBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

RepeatDataCollector Class


RepeatDataCollector Events

The RepeatDataCollector type exposes the following members.

Events
 | Name | Description
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowFullGraphChanged | Fired when the ShowFullGraph is changed.
Public event | ShowFullGraphValidating | Fired while validating the new value for ShowFullGraph.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

RepeatDataCollector Class


RepeatDataCollector.ShowFullGraphChanged Event

Fired when the ShowFullGraph is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowFullGraphChanged
Public Event ShowFullGraphChanged As EventHandler
public:
 event EventHandler^ ShowFullGraphChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

RepeatDataCollector Class


RepeatDataCollector.ShowFullGraphValidating Event

Fired while validating the new value for ShowFullGraph.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowFullGraphValidating
Public Event ShowFullGraphValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowFullGraphValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

RepeatDataCollector Class


RoundShape Class

Represents the round scope shapes
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeShape
TwinCAT.Measurement.Scope.API.ModelRoundShape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class RoundShape : ScopeShape
Public Class RoundShape
    Inherits ScopeShape
public ref class RoundShape : public ScopeShape

The RoundShape type exposes the following members.

Constructors
 | Name | Description
Public method | RoundShape | Creates a new instance of RoundShape
Public method | RoundShape(RoundShape) | Creates a new instance of RoundShape and copy content from roundShape
Top
Properties
 | Name | Description
Public property | Aperture | Gets or Sets the Aperture.
Public property | Center | Gets or Sets the Center.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from ScopeShape.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShapePoints | Gets the ShapePoints 1. Value: Center 2. Value: right point 3. Value: top point 4. Value: left point 5. Value: bottom point 6. Value: Startpoint 7. Value: Endpoint (Overrides ScopeShapeShapePoints.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartDegree | Gets or Sets the StartDegree.
Public property | Style | Gets a underlying Style Object (Inherited from ScopeShape.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | XRadius | Gets or Sets the XRadius.
Public property | YRadius | Gets or Sets the YRadius.
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | Highlight the Shape (Inherited from ScopeShape.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | Save | Saves this Shape to a file (Inherited from ScopeShape.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Property Attributes (Overrides ScopeShapeUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ApertureChanged | Fired when the Aperture is changed.
Public event | ApertureValidating | Fired while validating the new value for Aperture.
Public event | CenterChanged | Fired when the Center is changed.
Public event | CenterValidating | Fired while validating the new value for Center.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | Hightlight | Raise to highlight the shape (Inherited from ScopeShape.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPoints | Raise to refresh the points in the view (Inherited from ScopeShape.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartDegreeChanged | Fired when the StartDegree is changed.
Public event | StartDegreeValidating | Fired while validating the new value for StartDegree.
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | XRadiusChanged | Fired when the XRadius is changed.
Public event | XRadiusValidating | Fired while validating the new value for XRadius.
Public event | YRadiusChanged | Fired when the YRadius is changed.
Public event | YRadiusValidating | Fired while validating the new value for YRadius.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


RoundShape Constructor

Overload List
 | Name | Description
Public method | RoundShape | Creates a new instance of RoundShape
Public method | RoundShape(RoundShape) | Creates a new instance of RoundShape and copy content from roundShape
Top
See Also

Reference

RoundShape Class


RoundShape Constructor

Creates a new instance of RoundShape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public RoundShape()
Public Sub New
public:
RoundShape()
See Also

Reference

RoundShape Class
RoundShape Overload


RoundShape Constructor (RoundShape)

Creates a new instance of RoundShape and copy content from roundShape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public RoundShape(
    RoundShape roundShape
)
Public Sub New (
    roundShape As RoundShape
)
public:
RoundShape(
    RoundShape^ roundShape
)

Parameters

roundShape
Type: TwinCAT.Measurement.Scope.API.ModelRoundShape
See Also

Reference

RoundShape Class
RoundShape Overload


RoundShape Properties

The RoundShape type exposes the following members.

Properties
 | Name | Description
Public property | Aperture | Gets or Sets the Aperture.
Public property | Center | Gets or Sets the Center.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from ScopeShape.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShapePoints | Gets the ShapePoints 1. Value: Center 2. Value: right point 3. Value: top point 4. Value: left point 5. Value: bottom point 6. Value: Startpoint 7. Value: Endpoint (Overrides ScopeShapeShapePoints.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartDegree | Gets or Sets the StartDegree.
Public property | Style | Gets a underlying Style Object (Inherited from ScopeShape.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | XRadius | Gets or Sets the XRadius.
Public property | YRadius | Gets or Sets the YRadius.
Top
See Also

Reference

RoundShape Class


RoundShape.Aperture Property

Gets or Sets the Aperture.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double Aperture { get; set; }
<BrowsableAttribute(true)>
Public Property Aperture As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double Aperture {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

RoundShape Class


RoundShape.Center Property

Gets or Sets the Center.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double[] Center { get; set; }
<BrowsableAttribute(true)>
Public Property Center As Double()
    Get
    Set
public:
[BrowsableAttribute(true)]
property array<double>^ Center {
    array<double>^ get ();
    void set (array<double>^ value);
}

Property Value

Type: Double
See Also

Reference

RoundShape Class


RoundShape.ShapePoints Property

Gets the ShapePoints 1. Value: Center 2. Value: right point 3. Value: top point 4. Value: left point 5. Value: bottom point 6. Value: Startpoint 7. Value: Endpoint

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override ReadOnlyCollection<double[]> ShapePoints { get; }
Public Overrides ReadOnly Property ShapePoints As ReadOnlyCollection(Of Double())
    Get
public:
virtual property ReadOnlyCollection<array<double>^>^ ShapePoints {
    ReadOnlyCollection<array<double>^>^ get () override;
}

Property Value

Type: ReadOnlyCollection Double
See Also

Reference

RoundShape Class


RoundShape.StartDegree Property

Gets or Sets the StartDegree.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double StartDegree { get; set; }
<BrowsableAttribute(true)>
Public Property StartDegree As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double StartDegree {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

RoundShape Class


RoundShape.XRadius Property

Gets or Sets the XRadius.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double XRadius { get; set; }
<BrowsableAttribute(true)>
Public Property XRadius As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double XRadius {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

RoundShape Class


RoundShape.YRadius Property

Gets or Sets the YRadius.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double YRadius { get; set; }
<BrowsableAttribute(true)>
Public Property YRadius As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double YRadius {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

RoundShape Class


RoundShape Methods

The RoundShape type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeShape.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | Highlight the Shape (Inherited from ScopeShape.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | Save | Saves this Shape to a file (Inherited from ScopeShape.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Property Attributes (Overrides ScopeShapeUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

RoundShape Class


RoundShape.UpdatePropertyAttributes Method

Update the Property Attributes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

RoundShape Class


RoundShape Events

The RoundShape type exposes the following members.

Events
 | Name | Description
Public event | ApertureChanged | Fired when the Aperture is changed.
Public event | ApertureValidating | Fired while validating the new value for Aperture.
Public event | CenterChanged | Fired when the Center is changed.
Public event | CenterValidating | Fired while validating the new value for Center.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | Hightlight | Raise to highlight the shape (Inherited from ScopeShape.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPoints | Raise to refresh the points in the view (Inherited from ScopeShape.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartDegreeChanged | Fired when the StartDegree is changed.
Public event | StartDegreeValidating | Fired while validating the new value for StartDegree.
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | XRadiusChanged | Fired when the XRadius is changed.
Public event | XRadiusValidating | Fired while validating the new value for XRadius.
Public event | YRadiusChanged | Fired when the YRadius is changed.
Public event | YRadiusValidating | Fired while validating the new value for YRadius.
Top
See Also

Reference

RoundShape Class


RoundShape.ApertureChanged Event

Fired when the Aperture is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ApertureChanged
Public Event ApertureChanged As EventHandler
public:
 event EventHandler^ ApertureChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

RoundShape Class


RoundShape.ApertureValidating Event

Fired while validating the new value for Aperture.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ApertureValidating
Public Event ApertureValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ApertureValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

RoundShape Class


RoundShape.CenterChanged Event

Fired when the Center is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CenterChanged
Public Event CenterChanged As EventHandler
public:
 event EventHandler^ CenterChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

RoundShape Class


RoundShape.CenterValidating Event

Fired while validating the new value for Center.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> CenterValidating
Public Event CenterValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ CenterValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

RoundShape Class


RoundShape.StartDegreeChanged Event

Fired when the StartDegree is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StartDegreeChanged
Public Event StartDegreeChanged As EventHandler
public:
 event EventHandler^ StartDegreeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

RoundShape Class


RoundShape.StartDegreeValidating Event

Fired while validating the new value for StartDegree.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> StartDegreeValidating
Public Event StartDegreeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ StartDegreeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

RoundShape Class


RoundShape.XRadiusChanged Event

Fired when the XRadius is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler XRadiusChanged
Public Event XRadiusChanged As EventHandler
public:
 event EventHandler^ XRadiusChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

RoundShape Class


RoundShape.XRadiusValidating Event

Fired while validating the new value for XRadius.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> XRadiusValidating
Public Event XRadiusValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ XRadiusValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

RoundShape Class


RoundShape.YRadiusChanged Event

Fired when the YRadius is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler YRadiusChanged
Public Event YRadiusChanged As EventHandler
public:
 event EventHandler^ YRadiusChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

RoundShape Class


RoundShape.YRadiusValidating Event

Fired while validating the new value for YRadius.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> YRadiusValidating
Public Event YRadiusValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ YRadiusValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

RoundShape Class


SavedExternalInformation Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelSavedExternalInformation

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class SavedExternalInformation : ScopeMemberBase
Public Class SavedExternalInformation
    Inherits ScopeMemberBase
public ref class SavedExternalInformation : public ScopeMemberBase

The SavedExternalInformation type exposes the following members.

Constructors
 | Name | Description
Public method | SavedExternalInformation | Initializes a new instance of the SavedExternalInformation class
Public method | SavedExternalInformation(SavedExternalInformation) | Initializes a new instance of the SavedExternalInformation class
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DataAmount | Gets or Sets the DataAmount.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Endtime | Gets or Sets the Endtime.
Public property | ExternalFilePath | Gets or Sets the ExternalFilePath.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IgnoreMissingFullRecord | Gets or Sets the IgnoreMissingFullRecord.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | MissingFullRecord | Gets or Sets the MissingFullRecord.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Starttime | Gets or Sets the Starttime.
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAllFilePathes | Get all files which are used in this external information
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DataAmountChanged | Fired when the DataAmount is changed.
Public event | DataAmountValidating | Fired while validating the new value for DataAmount.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EndtimeChanged | Fired when the Endtime is changed.
Public event | EndtimeValidating | Fired while validating the new value for Endtime.
Public event | ExternalFilePathChanged | Fired when the ExternalFilePath is changed.
Public event | ExternalFilePathValidating | Fired while validating the new value for ExternalFilePath.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IgnoreMissingFullRecordChanged | Fired when the IgnoreMissingFullRecord is changed.
Public event | IgnoreMissingFullRecordValidating | Fired while validating the new value for IgnoreMissingFullRecord.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MissingFullRecordChanged | Fired when the MissingFullRecord is changed.
Public event | MissingFullRecordValidating | Fired while validating the new value for MissingFullRecord.
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StarttimeChanged | Fired when the Starttime is changed.
Public event | StarttimeValidating | Fired while validating the new value for Starttime.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


SavedExternalInformation Constructor

Overload List
 | Name | Description
Public method | SavedExternalInformation | Initializes a new instance of the SavedExternalInformation class
Public method | SavedExternalInformation(SavedExternalInformation) | Initializes a new instance of the SavedExternalInformation class
Top
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation Constructor

Initializes a new instance of the SavedExternalInformation class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SavedExternalInformation()
Public Sub New
public:
SavedExternalInformation()
See Also

Reference

SavedExternalInformation Class
SavedExternalInformation Overload


SavedExternalInformation Constructor (SavedExternalInformation)

Initializes a new instance of the SavedExternalInformation class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SavedExternalInformation(
    SavedExternalInformation savedExternalInformation
)
Public Sub New (
    savedExternalInformation As SavedExternalInformation
)
public:
SavedExternalInformation(
    SavedExternalInformation^ savedExternalInformation
)

Parameters

savedExternalInformation
Type: TwinCAT.Measurement.Scope.API.ModelSavedExternalInformation
See Also

Reference

SavedExternalInformation Class
SavedExternalInformation Overload


SavedExternalInformation Properties

The SavedExternalInformation type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DataAmount | Gets or Sets the DataAmount.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Endtime | Gets or Sets the Endtime.
Public property | ExternalFilePath | Gets or Sets the ExternalFilePath.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IgnoreMissingFullRecord | Gets or Sets the IgnoreMissingFullRecord.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | MissingFullRecord | Gets or Sets the MissingFullRecord.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Starttime | Gets or Sets the Starttime.
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.DataAmount Property

Gets or Sets the DataAmount.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public long DataAmount { get; set; }
<BrowsableAttribute(false)>
Public Property DataAmount As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
property long long DataAmount {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.Endtime Property

Gets or Sets the Endtime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public long Endtime { get; set; }
<BrowsableAttribute(false)>
Public Property Endtime As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
property long long Endtime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.ExternalFilePath Property

Gets or Sets the ExternalFilePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string ExternalFilePath { get; }
<BrowsableAttribute(true)>
Public ReadOnly Property ExternalFilePath As String
    Get
public:
[BrowsableAttribute(true)]
property String^ ExternalFilePath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.IgnoreMissingFullRecord Property

Gets or Sets the IgnoreMissingFullRecord.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool IgnoreMissingFullRecord { get; set; }
<BrowsableAttribute(true)>
Public Property IgnoreMissingFullRecord As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool IgnoreMissingFullRecord {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.MissingFullRecord Property

Gets or Sets the MissingFullRecord.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public bool MissingFullRecord { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property MissingFullRecord As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property bool MissingFullRecord {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.Starttime Property

Gets or Sets the Starttime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public long Starttime { get; set; }
<BrowsableAttribute(false)>
Public Property Starttime As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
property long long Starttime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation Methods

The SavedExternalInformation type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetAllFilePathes | Get all files which are used in this external information
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.GetAllFilePathes Method

Get all files which are used in this external information

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<string> GetAllFilePathes()
Public Function GetAllFilePathes As IEnumerable(Of String)
public:
IEnumerable<String^>^ GetAllFilePathes()

Return Value

Type: IEnumerable String
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation Events

The SavedExternalInformation type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DataAmountChanged | Fired when the DataAmount is changed.
Public event | DataAmountValidating | Fired while validating the new value for DataAmount.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EndtimeChanged | Fired when the Endtime is changed.
Public event | EndtimeValidating | Fired while validating the new value for Endtime.
Public event | ExternalFilePathChanged | Fired when the ExternalFilePath is changed.
Public event | ExternalFilePathValidating | Fired while validating the new value for ExternalFilePath.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IgnoreMissingFullRecordChanged | Fired when the IgnoreMissingFullRecord is changed.
Public event | IgnoreMissingFullRecordValidating | Fired while validating the new value for IgnoreMissingFullRecord.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MissingFullRecordChanged | Fired when the MissingFullRecord is changed.
Public event | MissingFullRecordValidating | Fired while validating the new value for MissingFullRecord.
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StarttimeChanged | Fired when the Starttime is changed.
Public event | StarttimeValidating | Fired while validating the new value for Starttime.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.DataAmountChanged Event

Fired when the DataAmount is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DataAmountChanged
Public Event DataAmountChanged As EventHandler
public:
 event EventHandler^ DataAmountChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.DataAmountValidating Event

Fired while validating the new value for DataAmount.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DataAmountValidating
Public Event DataAmountValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DataAmountValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.EndtimeChanged Event

Fired when the Endtime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EndtimeChanged
Public Event EndtimeChanged As EventHandler
public:
 event EventHandler^ EndtimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.EndtimeValidating Event

Fired while validating the new value for Endtime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EndtimeValidating
Public Event EndtimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EndtimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.ExternalFilePathChanged Event

Fired when the ExternalFilePath is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ExternalFilePathChanged
Public Event ExternalFilePathChanged As EventHandler
public:
 event EventHandler^ ExternalFilePathChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.ExternalFilePathValidating Event

Fired while validating the new value for ExternalFilePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ExternalFilePathValidating
Public Event ExternalFilePathValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ExternalFilePathValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.IgnoreMissingFullRecordChanged Event

Fired when the IgnoreMissingFullRecord is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IgnoreMissingFullRecordChanged
Public Event IgnoreMissingFullRecordChanged As EventHandler
public:
 event EventHandler^ IgnoreMissingFullRecordChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.IgnoreMissingFullRecordValidating Event

Fired while validating the new value for IgnoreMissingFullRecord.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IgnoreMissingFullRecordValidating
Public Event IgnoreMissingFullRecordValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IgnoreMissingFullRecordValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.MissingFullRecordChanged Event

Fired when the MissingFullRecord is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler MissingFullRecordChanged
Public Event MissingFullRecordChanged As EventHandler
public:
 event EventHandler^ MissingFullRecordChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.MissingFullRecordValidating Event

Fired while validating the new value for MissingFullRecord.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> MissingFullRecordValidating
Public Event MissingFullRecordValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ MissingFullRecordValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.StarttimeChanged Event

Fired when the Starttime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StarttimeChanged
Public Event StarttimeChanged As EventHandler
public:
 event EventHandler^ StarttimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SavedExternalInformation Class


SavedExternalInformation.StarttimeValidating Event

Fired while validating the new value for Starttime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> StarttimeValidating
Public Event StarttimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ StarttimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SavedExternalInformation Class


ScopeMemberBase Class

Base Class for Scope Members without SubElements
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
More...

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class ScopeMemberBase : MeasurementMemberBase,
    IScopeMember
Public MustInherit Class ScopeMemberBase
    Inherits MeasurementMemberBase
    Implements IScopeMember
public ref class ScopeMemberBase abstract : public MeasurementMemberBase,
    IScopeMember

The ScopeMemberBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Overrides MeasurementMemberBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides MeasurementMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelAspectRatioScalingStyle
TwinCAT.Measurement.Scope.API.ModelAxisStyle
TwinCAT.Measurement.Scope.API.ModelCapStyle
TwinCAT.Measurement.Scope.API.ModelChartMenuStyle
TwinCAT.Measurement.Scope.API.ModelChartPositionStyle
TwinCAT.Measurement.Scope.API.ModelChartZoomStyle
TwinCAT.Measurement.Scope.API.ModelDigitalStyle
TwinCAT.Measurement.Scope.API.ModelImageSize
TwinCAT.Measurement.Scope.API.ModelImageStreamStyle
TwinCAT.Measurement.Scope.API.ModelIndexScaling
TwinCAT.Measurement.Scope.API.ModelMarkerTable_Container
TwinCAT.Measurement.Scope.API.ModelMinMaxStyle
TwinCAT.Measurement.Scope.API.ModelOverviewBase
TwinCAT.Measurement.Scope.API.ModelSavedExternalInformation
TwinCAT.Measurement.Scope.API.ModelSeriesStyle
TwinCAT.Measurement.Scope.API.ModelShapeStyle
TwinCAT.Measurement.Scope.API.ModelTimeShiftStyle
TwinCAT.Measurement.Scope.API.ModelTriggerReleaseInfo
TwinCAT.Measurement.Scope.API.ModelTriggerTimeOffset


ScopeMemberBase Properties

The ScopeMemberBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ScopeMemberBase Class


ScopeMemberBase.DisableNameCheck Property

Get or Set DisableNameCheck

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public bool DisableNameCheck { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property DisableNameCheck As Boolean
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property bool DisableNameCheck {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean
See Also

Reference

ScopeMemberBase Class


ScopeMemberBase.HelpString Property

Get the HelpString

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public string HelpString { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property HelpString As String
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property String^ HelpString {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IScopeMemberHelpString
See Also

Reference

ScopeMemberBase Class


ScopeMemberBase.ScopeState Property

Gets the State of the Scope Project

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public ScopeViewState ScopeState { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property ScopeState As ScopeViewState
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property ScopeViewState ScopeState {
    ScopeViewState get () sealed;
}

Property Value

Type: ScopeViewState

Implements

IScopeMemberScopeState
See Also

Reference

ScopeMemberBase Class


ScopeMemberBase.SuppressMessages Property

Supress Question Manager Messages

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public bool SuppressMessages { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property SuppressMessages As Boolean
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property bool SuppressMessages {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IScopeMemberSuppressMessages
See Also

Reference

ScopeMemberBase Class


ScopeMemberBase Methods

The ScopeMemberBase type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Overrides MeasurementMemberBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides MeasurementMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ScopeMemberBase Class


ScopeMemberBase.GetCommands Method

Gets a List of possible Commands for this Element

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
An Array of Commands
See Also

Reference

ScopeMemberBase Class


ScopeMemberBase.UpdatePropertyAttributes Method

Sets the value off Propertyattributes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ScopeMemberBase Class


ScopeMemberBase Events

The ScopeMemberBase type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ScopeMemberBase Class


ScopeMemberContainerBase Class

Base class for Scope Members with SubMembers
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
More...

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class ScopeMemberContainerBase : MeasurementMemberContainerBase,
    IScopeMember
Public MustInherit Class ScopeMemberContainerBase
    Inherits MeasurementMemberContainerBase
    Implements IScopeMember
public ref class ScopeMemberContainerBase abstract : public MeasurementMemberContainerBase,
    IScopeMember

The ScopeMemberContainerBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Overrides MeasurementMemberBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides MeasurementMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisition
TwinCAT.Measurement.Scope.API.ModelAcquisitionInterpreter
TwinCAT.Measurement.Scope.API.ModelAnchorTimeBase
TwinCAT.Measurement.Scope.API.ModelAxis
TwinCAT.Measurement.Scope.API.ModelAxisGroup
TwinCAT.Measurement.Scope.API.ModelChannel
TwinCAT.Measurement.Scope.API.ModelChannelLayer
TwinCAT.Measurement.Scope.API.ModelChannelStyle
TwinCAT.Measurement.Scope.API.ModelChartLayerBase
TwinCAT.Measurement.Scope.API.ModelChartStyle
TwinCAT.Measurement.Scope.API.ModelCondition
TwinCAT.Measurement.Scope.API.ModelDataPool
TwinCAT.Measurement.Scope.API.ModelDynamicStyle
TwinCAT.Measurement.Scope.API.ModelDynamicStyleContainer
TwinCAT.Measurement.Scope.API.ModelMarker
TwinCAT.Measurement.Scope.API.ModelMarkerContainer
TwinCAT.Measurement.Scope.API.ModelMarkerControlStyle
TwinCAT.Measurement.Scope.API.ModelScopeShape
TwinCAT.Measurement.Scope.API.ModelTriggerGroup
TwinCAT.Measurement.Scope.API.ModelTriggerModule
TwinCAT.Measurement.Scope.API.ModelTriggerSet
TwinCAT.Measurement.Scope.APIPropertyUpdater


ScopeMemberContainerBase Properties

The ScopeMemberContainerBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ScopeMemberContainerBase Class


ScopeMemberContainerBase.DisableNameCheck Property

Get or Set DisableNameCheck

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public bool DisableNameCheck { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property DisableNameCheck As Boolean
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property bool DisableNameCheck {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean
See Also

Reference

ScopeMemberContainerBase Class


ScopeMemberContainerBase.HelpString Property

Get the HelpString

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public string HelpString { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property HelpString As String
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property String^ HelpString {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IScopeMemberHelpString
See Also

Reference

ScopeMemberContainerBase Class


ScopeMemberContainerBase.ScopeState Property

Gets the current state of the ScopeProject

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public ScopeViewState ScopeState { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property ScopeState As ScopeViewState
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property ScopeViewState ScopeState {
    ScopeViewState get () sealed;
}

Property Value

Type: ScopeViewState

Implements

IScopeMemberScopeState
See Also

Reference

ScopeMemberContainerBase Class


ScopeMemberContainerBase.SuppressMessages Property

Supress Question Manager Messages

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public bool SuppressMessages { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property SuppressMessages As Boolean
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property bool SuppressMessages {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IScopeMemberSuppressMessages
See Also

Reference

ScopeMemberContainerBase Class


ScopeMemberContainerBase Methods

The ScopeMemberContainerBase type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Overrides MeasurementMemberBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides MeasurementMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ScopeMemberContainerBase Class


ScopeMemberContainerBase.GetCommands Method

Gets a List of possible Commands for this Element

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
An Array of Commands
See Also

Reference

ScopeMemberContainerBase Class


ScopeMemberContainerBase.Move Method

Overload List
 | Name | Description
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Top
See Also

Reference

ScopeMemberContainerBase Class


ScopeMemberContainerBase.Move Method (Guid, Int32)

Moves an Element from the Source Parent to this Element

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Move(
    Guid elementGuid,
    int SortPriority = -1
)
Public Sub Move (
    elementGuid As Guid,
    Optional SortPriority As Integer = -1
)
public:
void Move(
    Guid elementGuid,
    int SortPriority = -1
)

Parameters

elementGuid
Type: SystemGuid
Guid of the Element to Move
SortPriority (Optional)
Type: SystemInt32
The SortPriority
See Also

Reference

ScopeMemberContainerBase Class
Move Overload


ScopeMemberContainerBase.Move Method (List(Guid), Boolean, Int32)

Moves Elements from Source Parent to this Element

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Move(
    List<Guid> Elements,
    bool UseOneParent = false,
    int SortPriority = -1
)
Public Sub Move (
    Elements As List(Of Guid),
    Optional UseOneParent As Boolean = false,
    Optional SortPriority As Integer = -1
)
public:
void Move(
    List<Guid>^ Elements,
    bool UseOneParent = false,
    int SortPriority = -1
)

Parameters

Elements
Type: System.Collections.GenericList Guid
Member to Move
UseOneParent (Optional)
Type: SystemBoolean
Use One SubParent for all Elements
SortPriority (Optional)
Type: SystemInt32
The SortPriority
See Also

Reference

ScopeMemberContainerBase Class
Move Overload


ScopeMemberContainerBase.UpdatePropertyAttributes Method

Sets the value off Propertyattributes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ScopeMemberContainerBase Class


ScopeMemberContainerBase Events

The ScopeMemberContainerBase type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ScopeMemberContainerBase Class


ScopeProject Class

TwinCAT 3 Scope Project Model
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.ProjectBaseMeasurementProjectBase
TwinCAT.Measurement.Scope.API.ModelScopeProjectBase
TwinCAT.Measurement.Scope.API.ModelScopeProject

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ScopeProject : ScopeProjectBase
Public Class ScopeProject
    Inherits ScopeProjectBase
public ref class ScopeProject : public ScopeProjectBase

The ScopeProject type exposes the following members.

Constructors
 | Name | Description
Public method | ScopeProject | Create an empty Scope Project
Public method | ScopeProject(ScopeProject) | Copy project to new object
Top
Properties
 | Name | Description
Public property | AnalyticsEngineConfig | Gets or sets the AnalyticsEngineConfig.
Public property | AnalyticsWorkDir | Gets or sets the AnalyticsWorkDir.
Public property | AutoConnectCharts | Get or Set the AutoConnectCharts
Public property | AutoDeleteCapacity | Gets or Sets the AutoDeleteCapacity.
Public property | AutoDeleteMode | Gets or Sets the AutoDeleteMode.
Public property | AutoDeleteOlderThan | Gets or Sets the AutoDeleteOlderThan.
Public property | AutoLoadSVDXData | Gets or Sets the AutoLoadSVDXData.
Public property | AutoRestartRecord | Gets or Sets the AutoRestartRecord.
Public property | AutoSaveExportConfiguration | Gets or Sets the AutoSaveExportConfiguration.
Public property | AutoSaveExportConfigurationString | Gets or Sets the AutoSaveExportConfigurationString.
Public property | AutoSaveFileNameMask | Gets or Sets the AutoSaveFileNameMask.
Public property | AutoSaveMode | Gets or Sets the AutoSaveMode.
Public property | AutoSavePath | Gets or Sets the AutoSavePath.
Public property | AvoidAdsComPool | Gets or Sets the AvoidAdsComPool.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ContainsData | Gets or Sets the ContainsData.
Public property | DataPool | Gets the DataPool (Inherited from ScopeProjectBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | Disposed | Indicates weather this instance is disposed or not. (Inherited from ScopeProjectBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | EnabledUndoRedoStack | Gets or Sets the EnabledUndoRedoStack. (Inherited from MeasurementProjectBase.)
Public property | EndRecordTime | Gets or Sets the EndRecordTime.
Public property | FileName | Get the FileName (Inherited from ScopeProjectBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FullPath | Get the FullPath of the ScopeProject-File (Inherited from ScopeProjectBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HeadlessServer | Gets or Sets the HeadlessServer. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the HeadLessServerExchange.
Public property | HeadlessServerConnectionId | Gets or Sets the HeadlessServerConnectionId.
Public property | HeadLessServerExchange | Gets or sets the targets of the HeadLessServer from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll
Public property | HelpString | Get the HelpString (Inherited from ScopeProjectBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | ImageAutoDeleteCapacity | Gets or Sets the ImageAutoDeleteCapacity.
Public property | ImageAutoDeleteOlderThan | Gets or Sets the ImageAutoDeleteOlderThan.
Public property | ImagesDeleteMode | Gets or Sets the ImagesDeleteMode.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Layout | Gets or Sets the Layout. (Inherited from ScopeProjectBase.)
Public property | MainServer | Gets or Sets the MainServer. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the MainServerExchange.
Public property | MainServerExchange | Gets or sets the targets of the MainServer from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReceivedBytes | Gets or Sets the ReceivedBytes.
Public property | RecordTime | Gets or Sets the RecordTime.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
 | ScopeConfigFileExtention | File extension for ScopeConfig Files.
 | ScopeDataFileExtention | File extension for Datafiles including configuration.
 | ScopeExportBinaryExtention | File extension for binary formated export-files.
 | ScopeExportCSVExtention | File extension for ASCI formated export-files.
 | ScopeExportDatExtention | File extention for DAT formated export-file.
 | ScopeExportTdmsExtension | File extention for TDMS format export-file.
 | ScopeExportTXTExtention | File extention for ASCI formated export-files.
 | ScopeExtendedDataFileExtention | File extension for new extended Datafiles including configuration.
 | ScopeProjectFileExtention | File extension for ScopeProject files.
Public property | ScopeState | Get the Current ProjectState as ScopeViewState (Inherited from ScopeProjectBase.)
 | ScopeViewControlFileExtention | File extension of old ScopeViewControl files.
Public property | ServerVersions | Gets or Sets the ServerVersions.
Public property | ShowProgress | Gets or Sets delegate Property for showing Progress
Public property | ShowRemainingTrigger | Gets or Sets delegate Property for RemainingTrigger
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartMode | Gets or Sets the StartMode.
Public property | StartRecordTime | Gets or Sets the StartRecordTime.
Public property | StartRunTime | Gets or Sets the StartRunTime.
Public property | StopMode | Gets or Sets the StopMode.
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeProjectBase.)
Public property | SynchronisationMode | Gets or Sets the SynchronisationMode.
Public property | TargetConnectionIds | Gets or Sets the TargetConnectionIds.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerCount | Gets or Sets the TriggerCount.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseAutoSave | Gets or Sets the UseAutoSave.
Public property | UseFileStore | Gets or Sets the UseFileStore.
Public property | UseRecordTime | Gets or Sets the RecordTime.
Public property | Version | Gets or Sets the Version. (Inherited from MeasurementProjectBase.)
Public property | ViewDetailLevel | Gets or Sets the ViewDetailLevel. (Inherited from ScopeProjectBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from ScopeProjectBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AttachClient(Boolean) | Reattach client to Server
Public method | AttachClient(Boolean, Boolean) | Reattach the Client
Public method | ChangeAmsNetID | Changes the AmsNetID of all Acquisitions (Overrides ScopeProjectBaseChangeAmsNetID(AmsNetId).)
Public method | CheckCommandExecuteable | Checks if the command can be executed. (Overrides ScopeProjectBaseCheckCommandExecuteable(String).)
Public method | CheckScopeState | Check the Scope State
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConnectChart | Connect a single Chart, use only if AutoConnectCharts is false
Public method | ConnectHeadlessServer | Connect ShaddowClient
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateRecord | Create a Record for the recorded Data. Only possible for connected SVDX-Files.
Public method | Detach | If Client is Connected Detach client. If Client is Detached, Reattach client.
Public method | DetachClient | Detach the Client from the Server
Public method | Disconnect | Disconnect current Project from Server
Public method | Disconnect(Boolean) | Disconnect currentProject from Server
Public method | DisconnectChart | Disconnect a single Chart, use only if AutoConnectCharts is false
Public method | DisconnectHeadlessServer | Disconnect ShadowClient
Public method | Dispose | Releases all resources of this Instance. (Inherited from ScopeProjectBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export(String) | Exports data to the FilePath
Public method | Export(ExportConfiguration) | Exports data to external Formats
Public method | ExtractConfiguration | Extract the Configuration from a SVDX-File (Inherited from ScopeProjectBase.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAcquistionOrInterpreter | Get the Acquistion or AcquisitionInterpreter with the specific GUID (Inherited from ScopeProjectBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands (Overrides ScopeProjectBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageDataFiles | Get all images pathes
Public method | GetMailAttachments | (Overrides ScopeProjectBaseGetMailAttachments.)
Public method | GetRecordData | Get a Stream to collect data for an SVDX from. Collect all data before Disconnecting the Project.
Public method | GetRecordData(String) | Get a Stream to collect data for an SVDX from. Collect all data before Disconnecting the Project.
Public method | GetRecordData(IListChart) | Get a Stream to collect data for an SVDX from. Collect all data before Disconnecting the Project.
Public method | GetReferenceFiles | (Overrides ScopeProjectBaseGetReferenceFiles.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSequenceDataFiles | Get all sequence pathes
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTriggerImageFiles | Get all TriggerImage Pathes
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GotoMarker | Goto Markerposition
Public method | LayoutContainsMember | Checks if an object is in the Layout. (Inherited from ScopeProjectBase.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | LoadData | Loads a dataset from the given file. Use only in Config-mode. If succeed the state will change to Reply.
 | LoadScopeProject | Load a ScopeProject form the configuration.
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseProjectMessage | (Inherited from ScopeProjectBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ResetAnalyticsModules | Reset multiple Analytics Modules
Public method | SaveData | Saves the actual dataset to the given File. Use only in Reply-Mode.
Public method | SaveToFile | Save Project To File (Overrides MeasurementMemberBaseSaveToFile(String).)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from ScopeProjectBase.)
Public method | SetFromString | Loads the scope from xml-string. (Inherited from ScopeProjectBase.)
Public method | StartAllCharts |
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartRecord | Starts the Record
Public method | StopAllCharts |
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopRecord | Stops the actual Record
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCheckScopeState | Try to Check the ScopeState
Public method | TryClose | Tries to clean up the project for closing. (Overrides ScopeProjectBaseTryClose(Boolean).)
Public method | TryDisconnect | Trys to Disconnect if Scope is in Reply or StoppedState
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides ScopeProjectBaseUpdatePropertyAttributes.)
Public method | WriteAnalyticsParameter | Write Analytics Parameter
Public method | WriteMultipleAnalyticsParameter | Write Multiple Analyitcs Parameter, during Engine Pause
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AutoDeleteCapacityChanged | Fired when the AutoDeleteCapacity is changed.
Public event | AutoDeleteCapacityValidating | Fired while validating the new value for AutoDeleteCapacity.
Public event | AutoDeleteFileLoss | Event fired when a change to the AutoDelete propterties would delete files.
Public event | AutoDeleteModeChanged | Fired when the AutoDeleteMode is changed.
Public event | AutoDeleteModeValidating | Fired while validating the new value for AutoDeleteMode.
Public event | AutoDeleteOlderThanChanged | Fired when the AutoDeleteOlderThan is changed.
Public event | AutoDeleteOlderThanValidating | Fired while validating the new value for AutoDeleteOlderThan.
Public event | AutoLoadSVDXDataChanged | Fired when the AutoLoadSVDXData is changed.
Public event | AutoLoadSVDXDataValidating | Fired while validating the new value for AutoLoadSVDXData.
Public event | AutoRestartRecordChanged | Fired when the AutoRestartRecord is changed.
Public event | AutoRestartRecordValidating | Fired while validating the new value for AutoRestartRecord.
Public event | AutoSaveExportConfigurationChanged | Fired when the AutoSaveExportConfiguration is changed.
Public event | AutoSaveExportConfigurationStringChanged | Fired when the AutoSaveExportConfigurationString is changed.
Public event | AutoSaveExportConfigurationStringValidating | Fired while validating the new value for AutoSaveExportConfigurationString.
Public event | AutoSaveExportConfigurationValidating | Fired while validating the new value for AutoSaveExportConfiguration.
Public event | AutoSaveFileNameMaskChanged | Fired when the AutoSaveFileNameMask is changed.
Public event | AutoSaveFileNameMaskValidating | Fired while validating the new value for AutoSaveFileNameMask.
Public event | AutoSaveModeChanged | Fired when the AutoSaveMode is changed.
Public event | AutoSaveModeValidating | Fired while validating the new value for AutoSaveMode.
Public event | AutoSavePathChanged | Fired when the AutoSavePath is changed.
Public event | AutoSavePathValidating | Fired while validating the new value for AutoSavePath.
Public event | AvoidAdsComPoolChanged | Fired when the AvoidAdsComPool is changed.
Public event | AvoidAdsComPoolValidating | Fired while validating the new value for AvoidAdsComPool.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ContainsDataChanged | Fired when the ContainsData is changed.
Public event | ContainsDataValidating | Fired while validating the new value for ContainsData.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EndRecordTimeChanged | Fired when the EndRecordTime is changed.
Public event | EndRecordTimeValidating | Fired while validating the new value for EndRecordTime.
Public event | ExportEvent | Fired during the Export to event (Inherited from ScopeProjectBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HeadlessServerChanged | Fired when the HeadlessServer is changed.
Public event | HeadlessServerConnectionIdChanged | Fired when the HeadlessServerConnectionId is changed.
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | ImageAutoDeleteCapacityChanged | Fired when the ImageAutoDeleteCapacity is changed.
Public event | ImageAutoDeleteCapacityValidating | Fired while validating the new value for ImageAutoDeleteCapacity.
Public event | ImageAutoDeleteOlderThanChanged | Fired when the ImageAutoDeleteOlderThan is changed.
Public event | ImageAutoDeleteOlderThanValidating | Fired while validating the new value for ImageAutoDeleteOlderThan.
Public event | ImagesDeleteModeChanged | Fired when the ImagesDeleteMode is changed.
Public event | ImagesDeleteModeValidating | Fired while validating the new value for ImagesDeleteMode.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LayoutChanged | Fired when the Layout is changed. (Inherited from ScopeProjectBase.)
Public event | LayoutValidating | Fired while validating the new value for Layout. (Inherited from ScopeProjectBase.)
Public event | MainServerChanged | Fired when the MainServer is changed.
Public event | MainServerValidating | Fired while validating the new value for MainServer.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReceivedBytesChanged | Fired when the ReceivedBytes is changed.
Public event | RecordTimeChanged | Fired when the RecordTime is changed.
Public event | RecordTimeValidating | Fired while validating the new value for RecordTime.
Public event | RefreshLayout | Fired to Ask for a Refresh of the LayoutString (Inherited from ScopeProjectBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | RequestClearErrorList | Event fired to clear the errors.
Public event | SaveToSVDX | Event fired to Save Data from Package
Public event | SelectDictionary | Fired to open the Folder Explorer (Inherited from ScopeProjectBase.)
Public event | ServerVersionsChanged | Fired when the ServerVersions is changed.
Public event | ServerVersionsValidating | Fired while validating the new value for ServerVersions.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartModeChanged | Fired when the StartMode is changed.
Public event | StartModeValidating | Fired while validating the new value for StartMode.
Public event | StartRecordTimeChanged | Fired when the StartRecordTime is changed.
Public event | StartRecordTimeValidating | Fired while validating the new value for StartRecordTime.
Public event | StartRunTimeChanged | Fired when the StartRunTime is changed.
Public event | StartRunTimeValidating | Fired while validating the new value for StartRunTime.
Public event | StopModeChanged | Fired when the StopMode is changed.
Public event | StopModeValidating | Fired while validating the new value for StopMode.
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SynchronisationModeChanged | Fired when the SynchronisationMode is changed.
Public event | SynchronisationModeValidating | Fired while validating the new value for SynchronisationMode.
Public event | TargetConnectionIdsChanged | Fired when the TargetConnectionIds is changed.
Public event | TargetConnectionIdsValidating | Fired while validating the new value for TargetConnectionIds.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerCountChanged | Fired when the TriggerCount is changed.
Public event | TriggerCountValidating | Fired while validating the new value for TriggerCount.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseAutoSaveChanged | Fired when the UseAutoSave is changed.
Public event | UseAutoSaveValidating | Fired while validating the new value for UseAutoSave.
Public event | UseFileStoreChanged | Fired when the UseFileStore is changed.
Public event | UseFileStoreValidating | Fired while validating the new value for UseFileStore.
Public event | VersionChanged | Fired when the Version is changed. (Inherited from MeasurementProjectBase.)
Public event | VersionValidating | Fired while validating the new value for Version. (Inherited from MeasurementProjectBase.)
Public event | ViewDetailLevelChanged | Fired when the ViewDetailLevel is changed. (Inherited from ScopeProjectBase.)
Public event | ViewDetailLevelValidating | Fired while validating the new value for ViewDetailLevel. (Inherited from ScopeProjectBase.)
Top
Fields
 | Name | Description
Public field | TryGetFilePath | Gets or Sets the delegate Property for getting a new FilePath;
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ScopeProject Constructor

Overload List
 | Name | Description
Public method | ScopeProject | Create an empty Scope Project
Public method | ScopeProject(ScopeProject) | Copy project to new object
Top
See Also

Reference

ScopeProject Class


ScopeProject Constructor

Create an empty Scope Project

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeProject()
Public Sub New
public:
ScopeProject()
See Also

Reference

ScopeProject Class
ScopeProject Overload


ScopeProject Constructor (ScopeProject)

Copy project to new object

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeProject(
    ScopeProject org
)
Public Sub New (
    org As ScopeProject
)
public:
ScopeProject(
    ScopeProject^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelScopeProject
Project to Copy
See Also

Reference

ScopeProject Class
ScopeProject Overload


ScopeProject Properties

The ScopeProject type exposes the following members.

Properties
 | Name | Description
Public property | AnalyticsEngineConfig | Gets or sets the AnalyticsEngineConfig.
Public property | AnalyticsWorkDir | Gets or sets the AnalyticsWorkDir.
Public property | AutoConnectCharts | Get or Set the AutoConnectCharts
Public property | AutoDeleteCapacity | Gets or Sets the AutoDeleteCapacity.
Public property | AutoDeleteMode | Gets or Sets the AutoDeleteMode.
Public property | AutoDeleteOlderThan | Gets or Sets the AutoDeleteOlderThan.
Public property | AutoLoadSVDXData | Gets or Sets the AutoLoadSVDXData.
Public property | AutoRestartRecord | Gets or Sets the AutoRestartRecord.
Public property | AutoSaveExportConfiguration | Gets or Sets the AutoSaveExportConfiguration.
Public property | AutoSaveExportConfigurationString | Gets or Sets the AutoSaveExportConfigurationString.
Public property | AutoSaveFileNameMask | Gets or Sets the AutoSaveFileNameMask.
Public property | AutoSaveMode | Gets or Sets the AutoSaveMode.
Public property | AutoSavePath | Gets or Sets the AutoSavePath.
Public property | AvoidAdsComPool | Gets or Sets the AvoidAdsComPool.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ContainsData | Gets or Sets the ContainsData.
Public property | DataPool | Gets the DataPool (Inherited from ScopeProjectBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | Disposed | Indicates weather this instance is disposed or not. (Inherited from ScopeProjectBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | EnabledUndoRedoStack | Gets or Sets the EnabledUndoRedoStack. (Inherited from MeasurementProjectBase.)
Public property | EndRecordTime | Gets or Sets the EndRecordTime.
Public property | FileName | Get the FileName (Inherited from ScopeProjectBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FullPath | Get the FullPath of the ScopeProject-File (Inherited from ScopeProjectBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HeadlessServer | Gets or Sets the HeadlessServer. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the HeadLessServerExchange.
Public property | HeadlessServerConnectionId | Gets or Sets the HeadlessServerConnectionId.
Public property | HeadLessServerExchange | Gets or sets the targets of the HeadLessServer from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll
Public property | HelpString | Get the HelpString (Inherited from ScopeProjectBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | ImageAutoDeleteCapacity | Gets or Sets the ImageAutoDeleteCapacity.
Public property | ImageAutoDeleteOlderThan | Gets or Sets the ImageAutoDeleteOlderThan.
Public property | ImagesDeleteMode | Gets or Sets the ImagesDeleteMode.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Layout | Gets or Sets the Layout. (Inherited from ScopeProjectBase.)
Public property | MainServer | Gets or Sets the MainServer. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the MainServerExchange.
Public property | MainServerExchange | Gets or sets the targets of the MainServer from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReceivedBytes | Gets or Sets the ReceivedBytes.
Public property | RecordTime | Gets or Sets the RecordTime.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
 | ScopeConfigFileExtention | File extension for ScopeConfig Files.
 | ScopeDataFileExtention | File extension for Datafiles including configuration.
 | ScopeExportBinaryExtention | File extension for binary formated export-files.
 | ScopeExportCSVExtention | File extension for ASCI formated export-files.
 | ScopeExportDatExtention | File extention for DAT formated export-file.
 | ScopeExportTdmsExtension | File extention for TDMS format export-file.
 | ScopeExportTXTExtention | File extention for ASCI formated export-files.
 | ScopeExtendedDataFileExtention | File extension for new extended Datafiles including configuration.
 | ScopeProjectFileExtention | File extension for ScopeProject files.
Public property | ScopeState | Get the Current ProjectState as ScopeViewState (Inherited from ScopeProjectBase.)
 | ScopeViewControlFileExtention | File extension of old ScopeViewControl files.
Public property | ServerVersions | Gets or Sets the ServerVersions.
Public property | ShowProgress | Gets or Sets delegate Property for showing Progress
Public property | ShowRemainingTrigger | Gets or Sets delegate Property for RemainingTrigger
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartMode | Gets or Sets the StartMode.
Public property | StartRecordTime | Gets or Sets the StartRecordTime.
Public property | StartRunTime | Gets or Sets the StartRunTime.
Public property | StopMode | Gets or Sets the StopMode.
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeProjectBase.)
Public property | SynchronisationMode | Gets or Sets the SynchronisationMode.
Public property | TargetConnectionIds | Gets or Sets the TargetConnectionIds.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerCount | Gets or Sets the TriggerCount.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseAutoSave | Gets or Sets the UseAutoSave.
Public property | UseFileStore | Gets or Sets the UseFileStore.
Public property | UseRecordTime | Gets or Sets the RecordTime.
Public property | Version | Gets or Sets the Version. (Inherited from MeasurementProjectBase.)
Public property | ViewDetailLevel | Gets or Sets the ViewDetailLevel. (Inherited from ScopeProjectBase.)
Top
See Also

Reference

ScopeProject Class


ScopeProject.AnalyticsEngineConfig Property

Gets or sets the AnalyticsEngineConfig.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public string AnalyticsEngineConfig { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property AnalyticsEngineConfig As String
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property String^ AnalyticsEngineConfig {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.AnalyticsWorkDir Property

Gets or sets the AnalyticsWorkDir.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public string AnalyticsWorkDir { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property AnalyticsWorkDir As String
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property String^ AnalyticsWorkDir {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.AutoConnectCharts Property

Get or Set the AutoConnectCharts

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public bool AutoConnectCharts { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property AutoConnectCharts As Boolean
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property bool AutoConnectCharts {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ScopeProject Class


ScopeProject.AutoDeleteCapacity Property

Gets or Sets the AutoDeleteCapacity.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int AutoDeleteCapacity { get; set; }
<BrowsableAttribute(true)>
Public Property AutoDeleteCapacity As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int AutoDeleteCapacity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ScopeProject Class


ScopeProject.AutoDeleteMode Property

Gets or Sets the AutoDeleteMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public AutoDeleteMode AutoDeleteMode { get; set; }
<BrowsableAttribute(true)>
Public Property AutoDeleteMode As AutoDeleteMode
    Get
    Set
public:
[BrowsableAttribute(true)]
property AutoDeleteMode AutoDeleteMode {
    AutoDeleteMode get ();
    void set (AutoDeleteMode value);
}

Property Value

Type: AutoDeleteMode
See Also

Reference

ScopeProject Class


ScopeProject.AutoDeleteOlderThan Property

Gets or Sets the AutoDeleteOlderThan.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long AutoDeleteOlderThan { get; set; }
<BrowsableAttribute(true)>
Public Property AutoDeleteOlderThan As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long AutoDeleteOlderThan {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

ScopeProject Class


ScopeProject.AutoLoadSVDXData Property

Gets or Sets the AutoLoadSVDXData.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool AutoLoadSVDXData { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property AutoLoadSVDXData As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool AutoLoadSVDXData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ScopeProject Class


ScopeProject.AutoRestartRecord Property

Gets or Sets the AutoRestartRecord.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool AutoRestartRecord { get; set; }
<BrowsableAttribute(true)>
Public Property AutoRestartRecord As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool AutoRestartRecord {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ScopeProject Class


ScopeProject.AutoSaveExportConfiguration Property

Gets or Sets the AutoSaveExportConfiguration.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public ExportConfiguration AutoSaveExportConfiguration { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property AutoSaveExportConfiguration As ExportConfiguration
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property ExportConfiguration^ AutoSaveExportConfiguration {
    ExportConfiguration^ get ();
    void set (ExportConfiguration^ value);
}

Property Value

Type: ExportConfiguration
See Also

Reference

ScopeProject Class


ScopeProject.AutoSaveExportConfigurationString Property

Gets or Sets the AutoSaveExportConfigurationString.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string AutoSaveExportConfigurationString { get; set; }
<BrowsableAttribute(false)>
Public Property AutoSaveExportConfigurationString As String
    Get
    Set
public:
[BrowsableAttribute(false)]
property String^ AutoSaveExportConfigurationString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.AutoSaveFileNameMask Property

Gets or Sets the AutoSaveFileNameMask.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string AutoSaveFileNameMask { get; set; }
<BrowsableAttribute(true)>
Public Property AutoSaveFileNameMask As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ AutoSaveFileNameMask {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.AutoSaveMode Property

Gets or Sets the AutoSaveMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public AutoSaveModes AutoSaveMode { get; set; }
<BrowsableAttribute(true)>
Public Property AutoSaveMode As AutoSaveModes
    Get
    Set
public:
[BrowsableAttribute(true)]
property AutoSaveModes AutoSaveMode {
    AutoSaveModes get ();
    void set (AutoSaveModes value);
}

Property Value

Type: AutoSaveModes
See Also

Reference

ScopeProject Class


ScopeProject.AutoSavePath Property

Gets or Sets the AutoSavePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string AutoSavePath { get; set; }
<BrowsableAttribute(true)>
Public Property AutoSavePath As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ AutoSavePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.AvoidAdsComPool Property

Gets or Sets the AvoidAdsComPool.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool AvoidAdsComPool { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property AvoidAdsComPool As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool AvoidAdsComPool {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ScopeProject Class


ScopeProject.ContainsData Property

Gets or Sets the ContainsData.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool ContainsData { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property ContainsData As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool ContainsData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ScopeProject Class


ScopeProject.EndRecordTime Property

Gets or Sets the EndRecordTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public long EndRecordTime { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property EndRecordTime As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property long long EndRecordTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

ScopeProject Class


ScopeProject.HeadlessServer Property

Gets or Sets the HeadlessServer. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the HeadLessServerExchange.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public AmsNetId HeadlessServer { get; set; }
<BrowsableAttribute(false)>
Public Property HeadlessServer As AmsNetId
    Get
    Set
public:
[BrowsableAttribute(false)]
property AmsNetId^ HeadlessServer {
    AmsNetId^ get ();
    void set (AmsNetId^ value);
}

Property Value

Type: AmsNetId
See Also

Reference

ScopeProject Class


ScopeProject.HeadlessServerConnectionId Property

Gets or Sets the HeadlessServerConnectionId.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public Guid HeadlessServerConnectionId { get; set; }
<BrowsableAttribute(false)>
Public Property HeadlessServerConnectionId As Guid
    Get
    Set
public:
[BrowsableAttribute(false)]
property Guid HeadlessServerConnectionId {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

ScopeProject Class


ScopeProject.HeadLessServerExchange Property

Gets or sets the targets of the HeadLessServer from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public string HeadLessServerExchange { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property HeadLessServerExchange As String
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property String^ HeadLessServerExchange {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.ImageAutoDeleteCapacity Property

Gets or Sets the ImageAutoDeleteCapacity.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int ImageAutoDeleteCapacity { get; set; }
<BrowsableAttribute(true)>
Public Property ImageAutoDeleteCapacity As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int ImageAutoDeleteCapacity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ScopeProject Class


ScopeProject.ImageAutoDeleteOlderThan Property

Gets or Sets the ImageAutoDeleteOlderThan.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long ImageAutoDeleteOlderThan { get; set; }
<BrowsableAttribute(true)>
Public Property ImageAutoDeleteOlderThan As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long ImageAutoDeleteOlderThan {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

ScopeProject Class


ScopeProject.ImagesDeleteMode Property

Gets or Sets the ImagesDeleteMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public ImagesAutoDeleteMode ImagesDeleteMode { get; set; }
<BrowsableAttribute(true)>
Public Property ImagesDeleteMode As ImagesAutoDeleteMode
    Get
    Set
public:
[BrowsableAttribute(true)]
property ImagesAutoDeleteMode ImagesDeleteMode {
    ImagesAutoDeleteMode get ();
    void set (ImagesAutoDeleteMode value);
}

Property Value

Type: ImagesAutoDeleteMode
See Also

Reference

ScopeProject Class


ScopeProject.MainServer Property

Gets or Sets the MainServer. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the MainServerExchange.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public AmsNetId MainServer { get; set; }
<BrowsableAttribute(true)>
Public Property MainServer As AmsNetId
    Get
    Set
public:
[BrowsableAttribute(true)]
property AmsNetId^ MainServer {
    AmsNetId^ get ();
    void set (AmsNetId^ value);
}

Property Value

Type: AmsNetId
See Also

Reference

ScopeProject Class


ScopeProject.MainServerExchange Property

Gets or sets the targets of the MainServer from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public string MainServerExchange { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property MainServerExchange As String
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property String^ MainServerExchange {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.ReceivedBytes Property

Gets or Sets the ReceivedBytes.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public long ReceivedBytes { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property ReceivedBytes As Long
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property long long ReceivedBytes {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

ScopeProject Class


ScopeProject.RecordTime Property

Gets or Sets the RecordTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long RecordTime { get; set; }
<BrowsableAttribute(true)>
Public Property RecordTime As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long RecordTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

ScopeProject Class


ScopeProject.ScopeConfigFileExtention Property

File extension for ScopeConfig Files.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeConfigFileExtention { get; }
Public Shared ReadOnly Property ScopeConfigFileExtention As String
    Get
public:
static property String^ ScopeConfigFileExtention {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.ScopeDataFileExtention Property

File extension for Datafiles including configuration.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeDataFileExtention { get; }
Public Shared ReadOnly Property ScopeDataFileExtention As String
    Get
public:
static property String^ ScopeDataFileExtention {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.ScopeExportBinaryExtention Property

File extension for binary formated export-files.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeExportBinaryExtention { get; }
Public Shared ReadOnly Property ScopeExportBinaryExtention As String
    Get
public:
static property String^ ScopeExportBinaryExtention {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.ScopeExportCSVExtention Property

File extension for ASCI formated export-files.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeExportCSVExtention { get; }
Public Shared ReadOnly Property ScopeExportCSVExtention As String
    Get
public:
static property String^ ScopeExportCSVExtention {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.ScopeExportDatExtention Property

File extention for DAT formated export-file.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeExportDatExtention { get; }
Public Shared ReadOnly Property ScopeExportDatExtention As String
    Get
public:
static property String^ ScopeExportDatExtention {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.ScopeExportTdmsExtension Property

File extention for TDMS format export-file.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeExportTdmsExtension { get; }
Public Shared ReadOnly Property ScopeExportTdmsExtension As String
    Get
public:
static property String^ ScopeExportTdmsExtension {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.ScopeExportTXTExtention Property

File extention for ASCI formated export-files.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeExportTXTExtention { get; }
Public Shared ReadOnly Property ScopeExportTXTExtention As String
    Get
public:
static property String^ ScopeExportTXTExtention {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.ScopeExtendedDataFileExtention Property

File extension for new extended Datafiles including configuration.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeExtendedDataFileExtention { get; }
Public Shared ReadOnly Property ScopeExtendedDataFileExtention As String
    Get
public:
static property String^ ScopeExtendedDataFileExtention {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.ScopeProjectFileExtention Property

File extension for ScopeProject files.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeProjectFileExtention { get; }
Public Shared ReadOnly Property ScopeProjectFileExtention As String
    Get
public:
static property String^ ScopeProjectFileExtention {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.ScopeViewControlFileExtention Property

File extension of old ScopeViewControl files.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeViewControlFileExtention { get; }
Public Shared ReadOnly Property ScopeViewControlFileExtention As String
    Get
public:
static property String^ ScopeViewControlFileExtention {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.ServerVersions Property

Gets or Sets the ServerVersions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public VersionCollection ServerVersions { get; set; }
<BrowsableAttribute(false)>
Public Property ServerVersions As VersionCollection
    Get
    Set
public:
[BrowsableAttribute(false)]
property VersionCollection^ ServerVersions {
    VersionCollection^ get ();
    void set (VersionCollection^ value);
}

Property Value

Type: VersionCollection
See Also

Reference

ScopeProject Class


ScopeProject.ShowProgress Property

Gets or Sets delegate Property for showing Progress

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public DelShowProgress ShowProgress { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property ShowProgress As DelShowProgress
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property DelShowProgress^ ShowProgress {
    DelShowProgress^ get ();
    void set (DelShowProgress^ value);
}

Property Value

Type: DelShowProgress
See Also

Reference

ScopeProject Class


ScopeProject.ShowRemainingTrigger Property

Gets or Sets delegate Property for RemainingTrigger

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public ScopeProjectDelRemainingTrigger ShowRemainingTrigger { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property ShowRemainingTrigger As ScopeProjectDelRemainingTrigger
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property ScopeProjectDelRemainingTrigger^ ShowRemainingTrigger {
    ScopeProjectDelRemainingTrigger^ get ();
    void set (ScopeProjectDelRemainingTrigger^ value);
}

Property Value

Type: ScopeProjectDelRemainingTrigger
See Also

Reference

ScopeProject Class


ScopeProject.StartMode Property

Gets or Sets the StartMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public RunMode StartMode { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property StartMode As RunMode
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property RunMode StartMode {
    RunMode get ();
    void set (RunMode value);
}

Property Value

Type: RunMode
See Also

Reference

ScopeProject Class


ScopeProject.StartRecordTime Property

Gets or Sets the StartRecordTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public long StartRecordTime { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property StartRecordTime As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property long long StartRecordTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

ScopeProject Class


ScopeProject.StartRunTime Property

Gets or Sets the StartRunTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public long StartRunTime { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property StartRunTime As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property long long StartRunTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

ScopeProject Class


ScopeProject.StopMode Property

Gets or Sets the StopMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public StopMode StopMode { get; set; }
<BrowsableAttribute(true)>
Public Property StopMode As StopMode
    Get
    Set
public:
[BrowsableAttribute(true)]
property StopMode StopMode {
    StopMode get ();
    void set (StopMode value);
}

Property Value

Type: StopMode
See Also

Reference

ScopeProject Class


ScopeProject.SynchronisationMode Property

Gets or Sets the SynchronisationMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public TimeSynchronisationModes SynchronisationMode { get; set; }
<BrowsableAttribute(true)>
Public Property SynchronisationMode As TimeSynchronisationModes
    Get
    Set
public:
[BrowsableAttribute(true)]
property TimeSynchronisationModes SynchronisationMode {
    TimeSynchronisationModes get ();
    void set (TimeSynchronisationModes value);
}

Property Value

Type: TimeSynchronisationModes
See Also

Reference

ScopeProject Class


ScopeProject.TargetConnectionIds Property

Gets or Sets the TargetConnectionIds.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public List<TargetConnectionId> TargetConnectionIds { get; set; }
<BrowsableAttribute(false)>
Public Property TargetConnectionIds As List(Of TargetConnectionId)
    Get
    Set
public:
[BrowsableAttribute(false)]
property List<TargetConnectionId^>^ TargetConnectionIds {
    List<TargetConnectionId^>^ get ();
    void set (List<TargetConnectionId^>^ value);
}

Property Value

Type: List TargetConnectionId
See Also

Reference

ScopeProject Class


ScopeProject.TriggerCount Property

Gets or Sets the TriggerCount.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public uint TriggerCount { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property TriggerCount As UInteger
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property unsigned int TriggerCount {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ScopeProject Class


ScopeProject.UseAutoSave Property

Gets or Sets the UseAutoSave.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool UseAutoSave { get; set; }
<BrowsableAttribute(false)>
Public Property UseAutoSave As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool UseAutoSave {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ScopeProject Class


ScopeProject.UseFileStore Property

Gets or Sets the UseFileStore.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool UseFileStore { get; set; }
<BrowsableAttribute(true)>
Public Property UseFileStore As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool UseFileStore {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ScopeProject Class


ScopeProject.UseRecordTime Property

Gets or Sets the RecordTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public long UseRecordTime { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property UseRecordTime As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property long long UseRecordTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

ScopeProject Class


ScopeProject Methods

The ScopeProject type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from ScopeProjectBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AttachClient(Boolean) | Reattach client to Server
Public method | AttachClient(Boolean, Boolean) | Reattach the Client
Public method | ChangeAmsNetID | Changes the AmsNetID of all Acquisitions (Overrides ScopeProjectBaseChangeAmsNetID(AmsNetId).)
Public method | CheckCommandExecuteable | Checks if the command can be executed. (Overrides ScopeProjectBaseCheckCommandExecuteable(String).)
Public method | CheckScopeState | Check the Scope State
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConnectChart | Connect a single Chart, use only if AutoConnectCharts is false
Public method | ConnectHeadlessServer | Connect ShaddowClient
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateRecord | Create a Record for the recorded Data. Only possible for connected SVDX-Files.
Public method | Detach | If Client is Connected Detach client. If Client is Detached, Reattach client.
Public method | DetachClient | Detach the Client from the Server
Public method | Disconnect | Disconnect current Project from Server
Public method | Disconnect(Boolean) | Disconnect currentProject from Server
Public method | DisconnectChart | Disconnect a single Chart, use only if AutoConnectCharts is false
Public method | DisconnectHeadlessServer | Disconnect ShadowClient
Public method | Dispose | Releases all resources of this Instance. (Inherited from ScopeProjectBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Export(String) | Exports data to the FilePath
Public method | Export(ExportConfiguration) | Exports data to external Formats
Public method | ExtractConfiguration | Extract the Configuration from a SVDX-File (Inherited from ScopeProjectBase.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAcquistionOrInterpreter | Get the Acquistion or AcquisitionInterpreter with the specific GUID (Inherited from ScopeProjectBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands (Overrides ScopeProjectBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetImageDataFiles | Get all images pathes
Public method | GetMailAttachments | (Overrides ScopeProjectBaseGetMailAttachments.)
Public method | GetRecordData | Get a Stream to collect data for an SVDX from. Collect all data before Disconnecting the Project.
Public method | GetRecordData(String) | Get a Stream to collect data for an SVDX from. Collect all data before Disconnecting the Project.
Public method | GetRecordData(IListChart) | Get a Stream to collect data for an SVDX from. Collect all data before Disconnecting the Project.
Public method | GetReferenceFiles | (Overrides ScopeProjectBaseGetReferenceFiles.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSequenceDataFiles | Get all sequence pathes
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTriggerImageFiles | Get all TriggerImage Pathes
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GotoMarker | Goto Markerposition
Public method | LayoutContainsMember | Checks if an object is in the Layout. (Inherited from ScopeProjectBase.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | LoadData | Loads a dataset from the given file. Use only in Config-mode. If succeed the state will change to Reply.
 | LoadScopeProject | Load a ScopeProject form the configuration.
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseProjectMessage | (Inherited from ScopeProjectBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ResetAnalyticsModules | Reset multiple Analytics Modules
Public method | SaveData | Saves the actual dataset to the given File. Use only in Reply-Mode.
Public method | SaveToFile | Save Project To File (Overrides MeasurementMemberBaseSaveToFile(String).)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from ScopeProjectBase.)
Public method | SetFromString | Loads the scope from xml-string. (Inherited from ScopeProjectBase.)
Public method | StartAllCharts |
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartRecord | Starts the Record
Public method | StopAllCharts |
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopRecord | Stops the actual Record
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCheckScopeState | Try to Check the ScopeState
Public method | TryClose | Tries to clean up the project for closing. (Overrides ScopeProjectBaseTryClose(Boolean).)
Public method | TryDisconnect | Trys to Disconnect if Scope is in Reply or StoppedState
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides ScopeProjectBaseUpdatePropertyAttributes.)
Public method | WriteAnalyticsParameter | Write Analytics Parameter
Public method | WriteMultipleAnalyticsParameter | Write Multiple Analyitcs Parameter, during Engine Pause
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ScopeProject Class


ScopeProject.AttachClient Method

Overload List
 | Name | Description
Public method | AttachClient(Boolean) | Reattach client to Server
Public method | AttachClient(Boolean, Boolean) | Reattach the Client
Top
See Also

Reference

ScopeProject Class


ScopeProject.AttachClient Method (Boolean)

Reattach client to Server

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void AttachClient(
    bool isShaddow = false
)
Public Sub AttachClient (
    Optional isShaddow As Boolean = false
)
public:
void AttachClient(
    bool isShaddow = false
)

Parameters

isShaddow (Optional)
Type: SystemBoolean
See Also

Reference

ScopeProject Class
AttachClient Overload


ScopeProject.AttachClient Method (Boolean, Boolean)

Reattach the Client

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool AttachClient(
    bool WriteConfig,
    bool isShaddow = false
)
Public Function AttachClient (
    WriteConfig As Boolean,
    Optional isShaddow As Boolean = false
) As Boolean
public:
bool AttachClient(
    bool WriteConfig,
    bool isShaddow = false
)

Parameters

WriteConfig
Type: SystemBoolean
Determines wether to write the Config to the Connected Client
isShaddow (Optional)
Type: SystemBoolean
Determines wether the current instance is a Shadow

Return Value

Type: Boolean
See Also

Reference

ScopeProject Class
AttachClient Overload


ScopeProject.ChangeAmsNetID Method

Changes the AmsNetID of all Acquisitions

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void ChangeAmsNetID(
    AmsNetId NetID
)
Public Overrides Sub ChangeAmsNetID (
    NetID As AmsNetId
)
public:
virtual void ChangeAmsNetID(
    AmsNetId^ NetID
) override

Parameters

NetID
Type: AmsNetId
The new AmsNetID
See Also

Reference

ScopeProject Class


ScopeProject.CheckCommandExecuteable Method

Checks if the command can be executed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool CheckCommandExecuteable(
    string command
)
Public Overrides Function CheckCommandExecuteable (
    command As String
) As Boolean
public:
virtual bool CheckCommandExecuteable(
    String^ command
) override

Parameters

command
Type: SystemString
Identification string of the command.

Return Value

Type: Boolean
True if the command can be executed, otherwise false.
See Also

Reference

ScopeProject Class


ScopeProject.CheckScopeState Method

Check the Scope State

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void CheckScopeState()
Public Overridable Sub CheckScopeState
public:
virtual void CheckScopeState()
Exceptions
Exception | Condition
InvalidOperationException | Thrown if TargetConnectionIds, HeadlessServer, HeadlessServerConnectionId or ServerHandle not set correctly
WrongScopeStateException | Thrown if State is not Config or Detached
See Also

Reference

ScopeProject Class


ScopeProject.ConnectChart Method

Connect a single Chart, use only if AutoConnectCharts is false

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void ConnectChart(
    Chart chart
)
Public Sub ConnectChart (
    chart As Chart
)
public:
void ConnectChart(
    Chart^ chart
)

Parameters

chart
Type: TwinCAT.Measurement.Scope.API.ModelChart
The Chart to Connect
See Also

Reference

ScopeProject Class


ScopeProject.ConnectHeadlessServer Method

Connect ShaddowClient

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void ConnectHeadlessServer()
Public Sub ConnectHeadlessServer
public:
void ConnectHeadlessServer()
See Also

Reference

ScopeProject Class


ScopeProject.CreateRecord Method

Create a Record for the recorded Data. Only possible for connected SVDX-Files.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Record CreateRecord(
    int ID = 0
)
Public Function CreateRecord (
    Optional ID As Integer = 0
) As Record
public:
Record^ CreateRecord(
    int ID = 0
)

Parameters

ID (Optional)
Type: SystemInt32

Return Value

Type: Record
See Also

Reference

ScopeProject Class


ScopeProject.Detach Method

If Client is Connected Detach client. If Client is Detached, Reattach client.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void Detach()
Public Overridable Sub Detach
public:
virtual void Detach()
See Also

Reference

ScopeProject Class


ScopeProject.DetachClient Method

Detach the Client from the Server

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void DetachClient()
Public Sub DetachClient
public:
void DetachClient()

Return Value

Type:
True if Detach succeded
See Also

Reference

ScopeProject Class


ScopeProject.Disconnect Method

Overload List
 | Name | Description
Public method | Disconnect | Disconnect current Project from Server
Public method | Disconnect(Boolean) | Disconnect currentProject from Server
Top
See Also

Reference

ScopeProject Class


ScopeProject.Disconnect Method

Disconnect current Project from Server

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Disconnect()
Public Sub Disconnect
public:
void Disconnect()
See Also

Reference

ScopeProject Class
Disconnect Overload


ScopeProject.Disconnect Method (Boolean)

Disconnect currentProject from Server

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Disconnect(
    bool Validate
)
Public Sub Disconnect (
    Validate As Boolean
)
public:
void Disconnect(
    bool Validate
)

Parameters

Validate
Type: SystemBoolean
If true all Data will be discarded without any dialog
See Also

Reference

ScopeProject Class
Disconnect Overload


ScopeProject.DisconnectChart Method

Disconnect a single Chart, use only if AutoConnectCharts is false

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void DisconnectChart(
    Chart chart
)
Public Sub DisconnectChart (
    chart As Chart
)
public:
void DisconnectChart(
    Chart^ chart
)

Parameters

chart
Type: TwinCAT.Measurement.Scope.API.ModelChart
The Chart to Disconnect
See Also

Reference

ScopeProject Class


ScopeProject.DisconnectHeadlessServer Method

Disconnect ShadowClient

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void DisconnectHeadlessServer()
Public Sub DisconnectHeadlessServer
public:
void DisconnectHeadlessServer()
See Also

Reference

ScopeProject Class


ScopeProject.Export Method

Overload List
 | Name | Description
Public method | Export(String) | Exports data to the FilePath
Public method | Export(ExportConfiguration) | Exports data to external Formats
Top
See Also

Reference

ScopeProject Class


ScopeProject.Export Method (String)

Exports data to the FilePath

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual bool Export(
    string filePath
)
Public Overridable Function Export (
    filePath As String
) As Boolean
public:
virtual bool Export(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The destination FilePath

Return Value

Type: Boolean
True if the Export was successful
See Also

Reference

ScopeProject Class
Export Overload


ScopeProject.Export Method (ExportConfiguration)

Exports data to external Formats

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool Export(
    ExportConfiguration exportConfig
)
Public Function Export (
    exportConfig As ExportConfiguration
) As Boolean
public:
bool Export(
    ExportConfiguration^ exportConfig
)

Parameters

exportConfig
Type: ExportConfiguration
Konfiguration of the Export

Return Value

Type: Boolean
True if the Export was successful
See Also

Reference

ScopeProject Class
Export Overload


ScopeProject.GetCommands Method

Gets a List of possible Commands

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
The List of Commands
See Also

Reference

ScopeProject Class


ScopeProject.GetImageDataFiles Method

Get all images pathes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<string> GetImageDataFiles()
Public Function GetImageDataFiles As IEnumerable(Of String)
public:
IEnumerable<String^>^ GetImageDataFiles()

Return Value

Type: IEnumerable String
See Also

Reference

ScopeProject Class


ScopeProject.GetMailAttachments Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override List<Attachment> GetMailAttachments()
Public Overrides Function GetMailAttachments As List(Of Attachment)
public:
virtual List<Attachment^>^ GetMailAttachments() override

Return Value

Type: List Attachment
See Also

Reference

ScopeProject Class


ScopeProject.GetRecordData Method

Overload List
 | Name | Description
Public method | GetRecordData | Get a Stream to collect data for an SVDX from. Collect all data before Disconnecting the Project.
Public method | GetRecordData(String) | Get a Stream to collect data for an SVDX from. Collect all data before Disconnecting the Project.
Public method | GetRecordData(IListChart) | Get a Stream to collect data for an SVDX from. Collect all data before Disconnecting the Project.
Top
See Also

Reference

ScopeProject Class


ScopeProject.GetRecordData Method

Get a Stream to collect data for an SVDX from. Collect all data before Disconnecting the Project.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual Stream GetRecordData()
Public Overridable Function GetRecordData As Stream
public:
virtual Stream^ GetRecordData()

Return Value

Type: Stream
See Also

Reference

ScopeProject Class
GetRecordData Overload


ScopeProject.GetRecordData Method (String)

Get a Stream to collect data for an SVDX from. Collect all data before Disconnecting the Project.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual Stream GetRecordData(
    string alternativeConfig
)
Public Overridable Function GetRecordData (
    alternativeConfig As String
) As Stream
public:
virtual Stream^ GetRecordData(
    String^ alternativeConfig
)

Parameters

alternativeConfig
Type: SystemString

Return Value

Type: Stream
See Also

Reference

ScopeProject Class
GetRecordData Overload


ScopeProject.GetRecordData Method (IList(Chart))

Get a Stream to collect data for an SVDX from. Collect all data before Disconnecting the Project.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual Stream GetRecordData(
    IList<Chart> selectedCharts
)
Public Overridable Function GetRecordData (
    selectedCharts As IList(Of Chart)
) As Stream
public:
virtual Stream^ GetRecordData(
    IList<Chart^>^ selectedCharts
)

Parameters

selectedCharts
Type: System.Collections.GenericIList Chart
Charts to be contained in the configuration or null if all charts should be included

Return Value

Type: Stream
See Also

Reference

ScopeProject Class
GetRecordData Overload


ScopeProject.GetReferenceFiles Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override List<string> GetReferenceFiles()
Public Overrides Function GetReferenceFiles As List(Of String)
public:
virtual List<String^>^ GetReferenceFiles() override

Return Value

Type: List String
See Also

Reference

ScopeProject Class


ScopeProject.GetSequenceDataFiles Method

Get all sequence pathes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<string> GetSequenceDataFiles()
Public Function GetSequenceDataFiles As IEnumerable(Of String)
public:
IEnumerable<String^>^ GetSequenceDataFiles()

Return Value

Type: IEnumerable String
See Also

Reference

ScopeProject Class


ScopeProject.GetTriggerImageFiles Method

Get all TriggerImage Pathes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public List<string> GetTriggerImageFiles()
Public Function GetTriggerImageFiles As List(Of String)
public:
List<String^>^ GetTriggerImageFiles()

Return Value

Type: List String
See Also

Reference

ScopeProject Class


ScopeProject.GotoMarker Method

Goto Markerposition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void GotoMarker(
    TimeMarker timeMarker
)
Public Sub GotoMarker (
    timeMarker As TimeMarker
)
public:
void GotoMarker(
    TimeMarker^ timeMarker
)

Parameters

timeMarker
Type: TwinCAT.Measurement.Scope.API.ModelTimeMarker
Time Marker
See Also

Reference

ScopeProject Class


ScopeProject.LoadData Method

Loads a dataset from the given file. Use only in Config-mode. If succeed the state will change to Reply.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void LoadData()
Public Sub LoadData
public:
void LoadData()
See Also

Reference

ScopeProject Class


ScopeProject.LoadScopeProject Method

Load a ScopeProject form the configuration.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static ScopeProject LoadScopeProject(
    string filePath
)
Public Shared Function LoadScopeProject (
    filePath As String
) As ScopeProject
public:
static ScopeProject^ LoadScopeProject(
    String^ filePath
)

Parameters

filePath
Type: SystemString

Return Value

Type: ScopeProject
See Also

Reference

ScopeProject Class


ScopeProject.ResetAnalyticsModules Method

Reset multiple Analytics Modules

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool ResetAnalyticsModules(
    List<string> Modules
)
Public Function ResetAnalyticsModules (
    Modules As List(Of String)
) As Boolean
public:
bool ResetAnalyticsModules(
    List<String^>^ Modules
)

Parameters

Modules
Type: System.Collections.GenericList String
The Name of the Modules

Return Value

Type: Boolean
True if the reset was successful, otherwise false
See Also

Reference

ScopeProject Class


ScopeProject.SaveData Method

Saves the actual dataset to the given File. Use only in Reply-Mode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void SaveData(
    string path
)
Public Overridable Sub SaveData (
    path As String
)
public:
virtual void SaveData(
    String^ path
)

Parameters

path
Type: SystemString
The path of the folder to store the dataset and configuration in. Extension must be ".svdx"
See Also

Reference

ScopeProject Class


ScopeProject.SaveToFile Method

Save Project To File

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void SaveToFile(
    string filePath
)
Public Overrides Sub SaveToFile (
    filePath As String
)
public:
virtual void SaveToFile(
    String^ filePath
) override

Parameters

filePath
Type: SystemString
See Also

Reference

ScopeProject Class


ScopeProject.StartAllCharts Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void StartAllCharts(
    bool onlyAutoStartCharts
)
Public Sub StartAllCharts (
    onlyAutoStartCharts As Boolean
)
public:
void StartAllCharts(
    bool onlyAutoStartCharts
)

Parameters

onlyAutoStartCharts
Type: SystemBoolean
See Also

Reference

ScopeProject Class


ScopeProject.StartRecord Method

Starts the Record

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void StartRecord()
Public Sub StartRecord
public:
void StartRecord()
Exceptions
Exception | Condition
OpcServerNotTrustedException | Scope Server must be trusted from OPCServer
OpcWrongCredentialsException | Opc Credentials are wrong. Please try to log in again.
See Also

Reference

ScopeProject Class


ScopeProject.StopAllCharts Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void StopAllCharts()
Public Sub StopAllCharts
public:
void StopAllCharts()
See Also

Reference

ScopeProject Class


ScopeProject.StopRecord Method

Stops the actual Record

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void StopRecord()
Public Overridable Sub StopRecord
public:
virtual void StopRecord()
See Also

Reference

ScopeProject Class


ScopeProject.TryCheckScopeState Method

Try to Check the ScopeState

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool TryCheckScopeState()
Public Function TryCheckScopeState As Boolean
public:
bool TryCheckScopeState()

Return Value

Type: Boolean
True if Check succedded otherwise false
See Also

Reference

ScopeProject Class


ScopeProject.TryClose Method

Tries to clean up the project for closing.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool TryClose(
    bool dispose
)
Public Overrides Function TryClose (
    dispose As Boolean
) As Boolean
public:
virtual bool TryClose(
    bool dispose
) override

Parameters

dispose
Type: SystemBoolean

Return Value

Type: Boolean
True if clean up was successfull, otherwise false.
See Also

Reference

ScopeProject Class


ScopeProject.TryDisconnect Method

Trys to Disconnect if Scope is in Reply or StoppedState

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool TryDisconnect()
Public Function TryDisconnect As Boolean
public:
bool TryDisconnect()

Return Value

Type: Boolean
Returns true if Scope is in ConfigState afterwards
See Also

Reference

ScopeProject Class


ScopeProject.UpdatePropertyAttributes Method

Sets the value off Propertyattributes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ScopeProject Class


ScopeProject.WriteAnalyticsParameter Method

Write Analytics Parameter

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string WriteAnalyticsParameter(
    string symbol,
    string setValue
)
Public Function WriteAnalyticsParameter (
    symbol As String,
    setValue As String
) As String
public:
String^ WriteAnalyticsParameter(
    String^ symbol,
    String^ setValue
)

Parameters

symbol
Type: SystemString
Symbol
setValue
Type: SystemString
Value

Return Value

Type: String
See Also

Reference

ScopeProject Class


ScopeProject.WriteMultipleAnalyticsParameter Method

Write Multiple Analyitcs Parameter, during Engine Pause

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool WriteMultipleAnalyticsParameter(
    List<string> Parameters,
    List<string> Values
)
Public Function WriteMultipleAnalyticsParameter (
    Parameters As List(Of String),
    Values As List(Of String)
) As Boolean
public:
bool WriteMultipleAnalyticsParameter(
    List<String^>^ Parameters,
    List<String^>^ Values
)

Parameters

Parameters
Type: System.Collections.GenericList String
Parameter to write to
Values
Type: System.Collections.GenericList String
Values to Write

Return Value

Type: Boolean
True if write was successful, otherwise false
See Also

Reference

ScopeProject Class


ScopeProject Events

The ScopeProject type exposes the following members.

Events
 | Name | Description
Public event | AutoDeleteCapacityChanged | Fired when the AutoDeleteCapacity is changed.
Public event | AutoDeleteCapacityValidating | Fired while validating the new value for AutoDeleteCapacity.
Public event | AutoDeleteFileLoss | Event fired when a change to the AutoDelete propterties would delete files.
Public event | AutoDeleteModeChanged | Fired when the AutoDeleteMode is changed.
Public event | AutoDeleteModeValidating | Fired while validating the new value for AutoDeleteMode.
Public event | AutoDeleteOlderThanChanged | Fired when the AutoDeleteOlderThan is changed.
Public event | AutoDeleteOlderThanValidating | Fired while validating the new value for AutoDeleteOlderThan.
Public event | AutoLoadSVDXDataChanged | Fired when the AutoLoadSVDXData is changed.
Public event | AutoLoadSVDXDataValidating | Fired while validating the new value for AutoLoadSVDXData.
Public event | AutoRestartRecordChanged | Fired when the AutoRestartRecord is changed.
Public event | AutoRestartRecordValidating | Fired while validating the new value for AutoRestartRecord.
Public event | AutoSaveExportConfigurationChanged | Fired when the AutoSaveExportConfiguration is changed.
Public event | AutoSaveExportConfigurationStringChanged | Fired when the AutoSaveExportConfigurationString is changed.
Public event | AutoSaveExportConfigurationStringValidating | Fired while validating the new value for AutoSaveExportConfigurationString.
Public event | AutoSaveExportConfigurationValidating | Fired while validating the new value for AutoSaveExportConfiguration.
Public event | AutoSaveFileNameMaskChanged | Fired when the AutoSaveFileNameMask is changed.
Public event | AutoSaveFileNameMaskValidating | Fired while validating the new value for AutoSaveFileNameMask.
Public event | AutoSaveModeChanged | Fired when the AutoSaveMode is changed.
Public event | AutoSaveModeValidating | Fired while validating the new value for AutoSaveMode.
Public event | AutoSavePathChanged | Fired when the AutoSavePath is changed.
Public event | AutoSavePathValidating | Fired while validating the new value for AutoSavePath.
Public event | AvoidAdsComPoolChanged | Fired when the AvoidAdsComPool is changed.
Public event | AvoidAdsComPoolValidating | Fired while validating the new value for AvoidAdsComPool.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ContainsDataChanged | Fired when the ContainsData is changed.
Public event | ContainsDataValidating | Fired while validating the new value for ContainsData.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EndRecordTimeChanged | Fired when the EndRecordTime is changed.
Public event | EndRecordTimeValidating | Fired while validating the new value for EndRecordTime.
Public event | ExportEvent | Fired during the Export to event (Inherited from ScopeProjectBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HeadlessServerChanged | Fired when the HeadlessServer is changed.
Public event | HeadlessServerConnectionIdChanged | Fired when the HeadlessServerConnectionId is changed.
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | ImageAutoDeleteCapacityChanged | Fired when the ImageAutoDeleteCapacity is changed.
Public event | ImageAutoDeleteCapacityValidating | Fired while validating the new value for ImageAutoDeleteCapacity.
Public event | ImageAutoDeleteOlderThanChanged | Fired when the ImageAutoDeleteOlderThan is changed.
Public event | ImageAutoDeleteOlderThanValidating | Fired while validating the new value for ImageAutoDeleteOlderThan.
Public event | ImagesDeleteModeChanged | Fired when the ImagesDeleteMode is changed.
Public event | ImagesDeleteModeValidating | Fired while validating the new value for ImagesDeleteMode.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LayoutChanged | Fired when the Layout is changed. (Inherited from ScopeProjectBase.)
Public event | LayoutValidating | Fired while validating the new value for Layout. (Inherited from ScopeProjectBase.)
Public event | MainServerChanged | Fired when the MainServer is changed.
Public event | MainServerValidating | Fired while validating the new value for MainServer.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReceivedBytesChanged | Fired when the ReceivedBytes is changed.
Public event | RecordTimeChanged | Fired when the RecordTime is changed.
Public event | RecordTimeValidating | Fired while validating the new value for RecordTime.
Public event | RefreshLayout | Fired to Ask for a Refresh of the LayoutString (Inherited from ScopeProjectBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | RequestClearErrorList | Event fired to clear the errors.
Public event | SaveToSVDX | Event fired to Save Data from Package
Public event | SelectDictionary | Fired to open the Folder Explorer (Inherited from ScopeProjectBase.)
Public event | ServerVersionsChanged | Fired when the ServerVersions is changed.
Public event | ServerVersionsValidating | Fired while validating the new value for ServerVersions.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartModeChanged | Fired when the StartMode is changed.
Public event | StartModeValidating | Fired while validating the new value for StartMode.
Public event | StartRecordTimeChanged | Fired when the StartRecordTime is changed.
Public event | StartRecordTimeValidating | Fired while validating the new value for StartRecordTime.
Public event | StartRunTimeChanged | Fired when the StartRunTime is changed.
Public event | StartRunTimeValidating | Fired while validating the new value for StartRunTime.
Public event | StopModeChanged | Fired when the StopMode is changed.
Public event | StopModeValidating | Fired while validating the new value for StopMode.
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SynchronisationModeChanged | Fired when the SynchronisationMode is changed.
Public event | SynchronisationModeValidating | Fired while validating the new value for SynchronisationMode.
Public event | TargetConnectionIdsChanged | Fired when the TargetConnectionIds is changed.
Public event | TargetConnectionIdsValidating | Fired while validating the new value for TargetConnectionIds.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerCountChanged | Fired when the TriggerCount is changed.
Public event | TriggerCountValidating | Fired while validating the new value for TriggerCount.
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseAutoSaveChanged | Fired when the UseAutoSave is changed.
Public event | UseAutoSaveValidating | Fired while validating the new value for UseAutoSave.
Public event | UseFileStoreChanged | Fired when the UseFileStore is changed.
Public event | UseFileStoreValidating | Fired while validating the new value for UseFileStore.
Public event | VersionChanged | Fired when the Version is changed. (Inherited from MeasurementProjectBase.)
Public event | VersionValidating | Fired while validating the new value for Version. (Inherited from MeasurementProjectBase.)
Public event | ViewDetailLevelChanged | Fired when the ViewDetailLevel is changed. (Inherited from ScopeProjectBase.)
Public event | ViewDetailLevelValidating | Fired while validating the new value for ViewDetailLevel. (Inherited from ScopeProjectBase.)
Top
See Also

Reference

ScopeProject Class


ScopeProject.AutoDeleteCapacityChanged Event

Fired when the AutoDeleteCapacity is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoDeleteCapacityChanged
Public Event AutoDeleteCapacityChanged As EventHandler
public:
 event EventHandler^ AutoDeleteCapacityChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.AutoDeleteCapacityValidating Event

Fired while validating the new value for AutoDeleteCapacity.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoDeleteCapacityValidating
Public Event AutoDeleteCapacityValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoDeleteCapacityValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.AutoDeleteFileLoss Event

Event fired when a change to the AutoDelete propterties would delete files.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoDeleteFileLoss
Public Event AutoDeleteFileLoss As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoDeleteFileLoss {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.AutoDeleteModeChanged Event

Fired when the AutoDeleteMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoDeleteModeChanged
Public Event AutoDeleteModeChanged As EventHandler
public:
 event EventHandler^ AutoDeleteModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.AutoDeleteModeValidating Event

Fired while validating the new value for AutoDeleteMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoDeleteModeValidating
Public Event AutoDeleteModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoDeleteModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.AutoDeleteOlderThanChanged Event

Fired when the AutoDeleteOlderThan is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoDeleteOlderThanChanged
Public Event AutoDeleteOlderThanChanged As EventHandler
public:
 event EventHandler^ AutoDeleteOlderThanChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.AutoDeleteOlderThanValidating Event

Fired while validating the new value for AutoDeleteOlderThan.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoDeleteOlderThanValidating
Public Event AutoDeleteOlderThanValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoDeleteOlderThanValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.AutoLoadSVDXDataChanged Event

Fired when the AutoLoadSVDXData is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoLoadSVDXDataChanged
Public Event AutoLoadSVDXDataChanged As EventHandler
public:
 event EventHandler^ AutoLoadSVDXDataChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.AutoLoadSVDXDataValidating Event

Fired while validating the new value for AutoLoadSVDXData.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoLoadSVDXDataValidating
Public Event AutoLoadSVDXDataValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoLoadSVDXDataValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.AutoRestartRecordChanged Event

Fired when the AutoRestartRecord is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoRestartRecordChanged
Public Event AutoRestartRecordChanged As EventHandler
public:
 event EventHandler^ AutoRestartRecordChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.AutoRestartRecordValidating Event

Fired while validating the new value for AutoRestartRecord.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoRestartRecordValidating
Public Event AutoRestartRecordValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoRestartRecordValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.AutoSaveExportConfigurationChanged Event

Fired when the AutoSaveExportConfiguration is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoSaveExportConfigurationChanged
Public Event AutoSaveExportConfigurationChanged As EventHandler
public:
 event EventHandler^ AutoSaveExportConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.AutoSaveExportConfigurationStringChanged Event

Fired when the AutoSaveExportConfigurationString is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoSaveExportConfigurationStringChanged
Public Event AutoSaveExportConfigurationStringChanged As EventHandler
public:
 event EventHandler^ AutoSaveExportConfigurationStringChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.AutoSaveExportConfigurationStringValidating Event

Fired while validating the new value for AutoSaveExportConfigurationString.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoSaveExportConfigurationStringValidating
Public Event AutoSaveExportConfigurationStringValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoSaveExportConfigurationStringValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.AutoSaveExportConfigurationValidating Event

Fired while validating the new value for AutoSaveExportConfiguration.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoSaveExportConfigurationValidating
Public Event AutoSaveExportConfigurationValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoSaveExportConfigurationValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.AutoSaveFileNameMaskChanged Event

Fired when the AutoSaveFileNameMask is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoSaveFileNameMaskChanged
Public Event AutoSaveFileNameMaskChanged As EventHandler
public:
 event EventHandler^ AutoSaveFileNameMaskChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.AutoSaveFileNameMaskValidating Event

Fired while validating the new value for AutoSaveFileNameMask.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoSaveFileNameMaskValidating
Public Event AutoSaveFileNameMaskValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoSaveFileNameMaskValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.AutoSaveModeChanged Event

Fired when the AutoSaveMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoSaveModeChanged
Public Event AutoSaveModeChanged As EventHandler
public:
 event EventHandler^ AutoSaveModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.AutoSaveModeValidating Event

Fired while validating the new value for AutoSaveMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoSaveModeValidating
Public Event AutoSaveModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoSaveModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.AutoSavePathChanged Event

Fired when the AutoSavePath is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoSavePathChanged
Public Event AutoSavePathChanged As EventHandler
public:
 event EventHandler^ AutoSavePathChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.AutoSavePathValidating Event

Fired while validating the new value for AutoSavePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoSavePathValidating
Public Event AutoSavePathValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoSavePathValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.AvoidAdsComPoolChanged Event

Fired when the AvoidAdsComPool is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AvoidAdsComPoolChanged
Public Event AvoidAdsComPoolChanged As EventHandler
public:
 event EventHandler^ AvoidAdsComPoolChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.AvoidAdsComPoolValidating Event

Fired while validating the new value for AvoidAdsComPool.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AvoidAdsComPoolValidating
Public Event AvoidAdsComPoolValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AvoidAdsComPoolValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.ContainsDataChanged Event

Fired when the ContainsData is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ContainsDataChanged
Public Event ContainsDataChanged As EventHandler
public:
 event EventHandler^ ContainsDataChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.ContainsDataValidating Event

Fired while validating the new value for ContainsData.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ContainsDataValidating
Public Event ContainsDataValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ContainsDataValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.EndRecordTimeChanged Event

Fired when the EndRecordTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EndRecordTimeChanged
Public Event EndRecordTimeChanged As EventHandler
public:
 event EventHandler^ EndRecordTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.EndRecordTimeValidating Event

Fired while validating the new value for EndRecordTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EndRecordTimeValidating
Public Event EndRecordTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EndRecordTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.HeadlessServerChanged Event

Fired when the HeadlessServer is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler HeadlessServerChanged
Public Event HeadlessServerChanged As EventHandler
public:
 event EventHandler^ HeadlessServerChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.HeadlessServerConnectionIdChanged Event

Fired when the HeadlessServerConnectionId is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler HeadlessServerConnectionIdChanged
Public Event HeadlessServerConnectionIdChanged As EventHandler
public:
 event EventHandler^ HeadlessServerConnectionIdChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.ImageAutoDeleteCapacityChanged Event

Fired when the ImageAutoDeleteCapacity is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ImageAutoDeleteCapacityChanged
Public Event ImageAutoDeleteCapacityChanged As EventHandler
public:
 event EventHandler^ ImageAutoDeleteCapacityChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.ImageAutoDeleteCapacityValidating Event

Fired while validating the new value for ImageAutoDeleteCapacity.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ImageAutoDeleteCapacityValidating
Public Event ImageAutoDeleteCapacityValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ImageAutoDeleteCapacityValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.ImageAutoDeleteOlderThanChanged Event

Fired when the ImageAutoDeleteOlderThan is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ImageAutoDeleteOlderThanChanged
Public Event ImageAutoDeleteOlderThanChanged As EventHandler
public:
 event EventHandler^ ImageAutoDeleteOlderThanChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.ImageAutoDeleteOlderThanValidating Event

Fired while validating the new value for ImageAutoDeleteOlderThan.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ImageAutoDeleteOlderThanValidating
Public Event ImageAutoDeleteOlderThanValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ImageAutoDeleteOlderThanValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.ImagesDeleteModeChanged Event

Fired when the ImagesDeleteMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ImagesDeleteModeChanged
Public Event ImagesDeleteModeChanged As EventHandler
public:
 event EventHandler^ ImagesDeleteModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.ImagesDeleteModeValidating Event

Fired while validating the new value for ImagesDeleteMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ImagesDeleteModeValidating
Public Event ImagesDeleteModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ImagesDeleteModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.MainServerChanged Event

Fired when the MainServer is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler MainServerChanged
Public Event MainServerChanged As EventHandler
public:
 event EventHandler^ MainServerChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.MainServerValidating Event

Fired while validating the new value for MainServer.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> MainServerValidating
Public Event MainServerValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ MainServerValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.ReceivedBytesChanged Event

Fired when the ReceivedBytes is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReceivedBytesChanged
Public Event ReceivedBytesChanged As EventHandler
public:
 event EventHandler^ ReceivedBytesChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.RecordTimeChanged Event

Fired when the RecordTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler RecordTimeChanged
Public Event RecordTimeChanged As EventHandler
public:
 event EventHandler^ RecordTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.RecordTimeValidating Event

Fired while validating the new value for RecordTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> RecordTimeValidating
Public Event RecordTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ RecordTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.RequestClearErrorList Event

Event fired to clear the errors.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler RequestClearErrorList
Public Event RequestClearErrorList As EventHandler
public:
 event EventHandler^ RequestClearErrorList {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.SaveToSVDX Event

Event fired to Save Data from Package

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<CancelEventArgs> SaveToSVDX
Public Event SaveToSVDX As EventHandler(Of CancelEventArgs)
public:
 event EventHandler<CancelEventArgs^>^ SaveToSVDX {
    void add (EventHandler<CancelEventArgs^>^ value);
    void remove (EventHandler<CancelEventArgs^>^ value);
}

Value

Type: SystemEventHandler CancelEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.ServerVersionsChanged Event

Fired when the ServerVersions is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ServerVersionsChanged
Public Event ServerVersionsChanged As EventHandler
public:
 event EventHandler^ ServerVersionsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.ServerVersionsValidating Event

Fired while validating the new value for ServerVersions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ServerVersionsValidating
Public Event ServerVersionsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ServerVersionsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.StartModeChanged Event

Fired when the StartMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StartModeChanged
Public Event StartModeChanged As EventHandler
public:
 event EventHandler^ StartModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.StartModeValidating Event

Fired while validating the new value for StartMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> StartModeValidating
Public Event StartModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ StartModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.StartRecordTimeChanged Event

Fired when the StartRecordTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StartRecordTimeChanged
Public Event StartRecordTimeChanged As EventHandler
public:
 event EventHandler^ StartRecordTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.StartRecordTimeValidating Event

Fired while validating the new value for StartRecordTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> StartRecordTimeValidating
Public Event StartRecordTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ StartRecordTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.StartRunTimeChanged Event

Fired when the StartRunTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StartRunTimeChanged
Public Event StartRunTimeChanged As EventHandler
public:
 event EventHandler^ StartRunTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.StartRunTimeValidating Event

Fired while validating the new value for StartRunTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> StartRunTimeValidating
Public Event StartRunTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ StartRunTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.StopModeChanged Event

Fired when the StopMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler StopModeChanged
Public Event StopModeChanged As EventHandler
public:
 event EventHandler^ StopModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.StopModeValidating Event

Fired while validating the new value for StopMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> StopModeValidating
Public Event StopModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ StopModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.SynchronisationModeChanged Event

Fired when the SynchronisationMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SynchronisationModeChanged
Public Event SynchronisationModeChanged As EventHandler
public:
 event EventHandler^ SynchronisationModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.SynchronisationModeValidating Event

Fired while validating the new value for SynchronisationMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SynchronisationModeValidating
Public Event SynchronisationModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SynchronisationModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.TargetConnectionIdsChanged Event

Fired when the TargetConnectionIds is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TargetConnectionIdsChanged
Public Event TargetConnectionIdsChanged As EventHandler
public:
 event EventHandler^ TargetConnectionIdsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.TargetConnectionIdsValidating Event

Fired while validating the new value for TargetConnectionIds.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TargetConnectionIdsValidating
Public Event TargetConnectionIdsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TargetConnectionIdsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.TriggerCountChanged Event

Fired when the TriggerCount is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TriggerCountChanged
Public Event TriggerCountChanged As EventHandler
public:
 event EventHandler^ TriggerCountChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.TriggerCountValidating Event

Fired while validating the new value for TriggerCount.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TriggerCountValidating
Public Event TriggerCountValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TriggerCountValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.UseAutoSaveChanged Event

Fired when the UseAutoSave is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UseAutoSaveChanged
Public Event UseAutoSaveChanged As EventHandler
public:
 event EventHandler^ UseAutoSaveChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.UseAutoSaveValidating Event

Fired while validating the new value for UseAutoSave.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UseAutoSaveValidating
Public Event UseAutoSaveValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UseAutoSaveValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject.UseFileStoreChanged Event

Fired when the UseFileStore is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UseFileStoreChanged
Public Event UseFileStoreChanged As EventHandler
public:
 event EventHandler^ UseFileStoreChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProject Class


ScopeProject.UseFileStoreValidating Event

Fired while validating the new value for UseFileStore.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UseFileStoreValidating
Public Event UseFileStoreValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UseFileStoreValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProject Class


ScopeProject Fields

The ScopeProject type exposes the following members.

Fields
 | Name | Description
Public field | TryGetFilePath | Gets or Sets the delegate Property for getting a new FilePath;
Top
See Also

Reference

ScopeProject Class


ScopeProject.TryGetFilePath Field

Gets or Sets the delegate Property for getting a new FilePath;

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public DelTryGetFilePath TryGetFilePath
Public TryGetFilePath As DelTryGetFilePath
public:
DelTryGetFilePath^ TryGetFilePath

Field Value

Type: DelTryGetFilePath
See Also

Reference

ScopeProject Class


ScopeProject.DelRemainingTrigger Delegate

Delegete Type to show RemainingTrigger

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public delegate uint DelRemainingTrigger(
    string header,
    WorkDelegate work
)
Public Delegate Function DelRemainingTrigger (
    header As String,
    work As WorkDelegate
) As UInteger
public delegate unsigned int DelRemainingTrigger(
    String^ header,
    WorkDelegate^ work
)

Parameters

header
Type: SystemString
The header of the box
work
Type: WorkDelegate
Work to show Remaining Trigger

Return Value

Type: UInt32
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ScopeProjectBase Class

Base class for ScopeProject
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.ProjectBaseMeasurementProjectBase
TwinCAT.Measurement.Scope.API.ModelScopeProjectBase
TwinCAT.Measurement.Scope.API.ModelScopeProject

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class ScopeProjectBase : MeasurementProjectBase,
    IScopeMember, IDisposable
Public MustInherit Class ScopeProjectBase
    Inherits MeasurementProjectBase
    Implements IScopeMember, IDisposable
public ref class ScopeProjectBase abstract : public MeasurementProjectBase,
    IScopeMember, IDisposable

The ScopeProjectBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DataPool | Gets the DataPool
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | Disposed | Indicates weather this instance is disposed or not.
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | EnabledUndoRedoStack | Gets or Sets the EnabledUndoRedoStack. (Inherited from MeasurementProjectBase.)
Public property | FileName | Get the FileName
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FullPath | Get the FullPath of the ScopeProject-File
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Layout | Gets or Sets the Layout.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
 | ScopeProjectFolderReplace |
 | ScopeServerFunctionsFolder | Get the FunctionsFolder, where TwinCAT 3 Scope Server was installed
Public property | ScopeState | Get the Current ProjectState as ScopeViewState
 | ScopeUserSettingsFolder | Gets the FolderPath of the UserSettings
 | ScopeViewFunctionsFolder | Get the FunctionFolder, where TwinCAT 3 Scope View was installed;
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
 | UseUserSettings | Determines wether the Default Value should be Loaded from UserSettings
 | ValidationMode | Get or Set the TestMode
Public property | Version | Gets or Sets the Version. (Inherited from MeasurementProjectBase.)
Public property | ViewDetailLevel | Gets or Sets the ViewDetailLevel.
Top
Methods
 | Name | Description
 | AddElementToMultiSelectList | Add an Element to the MultiSelectList
Public method | AddMember | Add a Member to the SubMemberCollection (Overrides MeasurementMemberContainerBaseAddMember(MeasurementMemberBase).)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ChangeAmsNetID | Changes the AmsNetID of all Acquisitions
Public method | CheckCommandExecuteable | Checks if the command can be executed.
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
 | ContainsElementInMultiSelectList | Determine, wether the MultiSelectList Contains the Element
 | ContainsElementOrParentInMultiSelectList | Determine, wether the Element or an Parent of the Element is contained in the MultiSelectList
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Dispose | Releases all resources of this Instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExtractConfiguration | Extract the Configuration from a SVDX-File
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAcquistionOrInterpreter | Get the Acquistion or AcquisitionInterpreter with the specific GUID
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Overrides MeasurementMemberBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMailAttachments | Gets all attachments for mails.
Public method | GetReferenceFiles |
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
 | GetScopeLicense | Gets the current license used to validate scope features.
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutContainsMember | Checks if an object is in the Layout.
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseProjectMessage |
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
 | RemoveElementFromMultiSelectList | Remove an Element from the MultiSelectList
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Overrides MeasurementProjectBaseSetFromStream(Stream).)
Public method | SetFromString | Loads the scope from xml-string. (Overrides MeasurementProjectBaseSetFromString(String).)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | Tries to clean up the project for closing.
 | TryValidateFeature | Validate a Feature
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides MeasurementMemberBaseUpdatePropertyAttributes.)
 | ValidateFeature | Validate a Feature
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ExportEvent | Fired during the Export to event
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LayoutChanged | Fired when the Layout is changed.
Public event | LayoutValidating | Fired while validating the new value for Layout.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshLayout | Fired to Ask for a Refresh of the LayoutString
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SelectDictionary | Fired to open the Folder Explorer
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | VersionChanged | Fired when the Version is changed. (Inherited from MeasurementProjectBase.)
Public event | VersionValidating | Fired while validating the new value for Version. (Inherited from MeasurementProjectBase.)
Public event | ViewDetailLevelChanged | Fired when the ViewDetailLevel is changed.
Public event | ViewDetailLevelValidating | Fired while validating the new value for ViewDetailLevel.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ScopeProjectBase Properties

The ScopeProjectBase type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DataPool | Gets the DataPool
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | Disposed | Indicates weather this instance is disposed or not.
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | EnabledUndoRedoStack | Gets or Sets the EnabledUndoRedoStack. (Inherited from MeasurementProjectBase.)
Public property | FileName | Get the FileName
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FullPath | Get the FullPath of the ScopeProject-File
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Layout | Gets or Sets the Layout.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
 | ScopeProjectFolderReplace |
 | ScopeServerFunctionsFolder | Get the FunctionsFolder, where TwinCAT 3 Scope Server was installed
Public property | ScopeState | Get the Current ProjectState as ScopeViewState
 | ScopeUserSettingsFolder | Gets the FolderPath of the UserSettings
 | ScopeViewFunctionsFolder | Get the FunctionFolder, where TwinCAT 3 Scope View was installed;
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
 | UseUserSettings | Determines wether the Default Value should be Loaded from UserSettings
 | ValidationMode | Get or Set the TestMode
Public property | Version | Gets or Sets the Version. (Inherited from MeasurementProjectBase.)
Public property | ViewDetailLevel | Gets or Sets the ViewDetailLevel.
Top
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.DataPool Property

Gets the DataPool

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public DataPool DataPool { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property DataPool As DataPool
    Get
public:
[BrowsableAttribute(false)]
property DataPool^ DataPool {
    DataPool^ get ();
}

Property Value

Type: DataPool
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.Disposed Property

Indicates weather this instance is disposed or not.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool Disposed { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Disposed As Boolean
    Get
public:
[BrowsableAttribute(false)]
property bool Disposed {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.FileName Property

Get the FileName

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string FileName { get; }
<BrowsableAttribute(true)>
Public ReadOnly Property FileName As String
    Get
public:
[BrowsableAttribute(true)]
property String^ FileName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.FullPath Property

Get the FullPath of the ScopeProject-File

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string FullPath { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property FullPath As String
    Get
public:
[BrowsableAttribute(false)]
property String^ FullPath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.HelpString Property

Get the HelpString

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public string HelpString { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property HelpString As String
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property String^ HelpString {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IScopeMemberHelpString
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.Layout Property

Gets or Sets the Layout.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string Layout { get; set; }
<BrowsableAttribute(false)>
Public Property Layout As String
    Get
    Set
public:
[BrowsableAttribute(false)]
property String^ Layout {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ScopeProjectFolderReplace Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeProjectFolderReplace { get; }
Public Shared ReadOnly Property ScopeProjectFolderReplace As String
    Get
public:
static property String^ ScopeProjectFolderReplace {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ScopeServerFunctionsFolder Property

Get the FunctionsFolder, where TwinCAT 3 Scope Server was installed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeServerFunctionsFolder { get; }
Public Shared ReadOnly Property ScopeServerFunctionsFolder As String
    Get
public:
static property String^ ScopeServerFunctionsFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ScopeState Property

Get the Current ProjectState as ScopeViewState

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public ScopeViewState ScopeState { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property ScopeState As ScopeViewState
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property ScopeViewState ScopeState {
    ScopeViewState get () sealed;
}

Property Value

Type: ScopeViewState

Implements

IScopeMemberScopeState
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ScopeUserSettingsFolder Property

Gets the FolderPath of the UserSettings

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeUserSettingsFolder { get; }
Public Shared ReadOnly Property ScopeUserSettingsFolder As String
    Get
public:
static property String^ ScopeUserSettingsFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ScopeViewFunctionsFolder Property

Get the FunctionFolder, where TwinCAT 3 Scope View was installed;

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static string ScopeViewFunctionsFolder { get; }
Public Shared ReadOnly Property ScopeViewFunctionsFolder As String
    Get
public:
static property String^ ScopeViewFunctionsFolder {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.SuppressMessages Property

Supress Question Manager Messages

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public bool SuppressMessages { get; set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Property SuppressMessages As Boolean
    Get
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
virtual property bool SuppressMessages {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IScopeMemberSuppressMessages
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.UseUserSettings Property

Determines wether the Default Value should be Loaded from UserSettings

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool UseUserSettings { get; set; }
Public Shared Property UseUserSettings As Boolean
    Get
    Set
public:
static property bool UseUserSettings {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ValidationMode Property

Get or Set the TestMode

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public static string ValidationMode { set; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public Shared WriteOnly Property ValidationMode As String
    Set
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
static property String^ ValidationMode {
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ViewDetailLevel Property

Gets or Sets the ViewDetailLevel.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public ScopeViewDetailLevel ViewDetailLevel { get; set; }
<BrowsableAttribute(true)>
Public Property ViewDetailLevel As ScopeViewDetailLevel
    Get
    Set
public:
[BrowsableAttribute(true)]
property ScopeViewDetailLevel ViewDetailLevel {
    ScopeViewDetailLevel get ();
    void set (ScopeViewDetailLevel value);
}

Property Value

Type: ScopeViewDetailLevel
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase Methods

The ScopeProjectBase type exposes the following members.

Methods
 | Name | Description
 | AddElementToMultiSelectList | Add an Element to the MultiSelectList
Public method | AddMember | Add a Member to the SubMemberCollection (Overrides MeasurementMemberContainerBaseAddMember(MeasurementMemberBase).)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ChangeAmsNetID | Changes the AmsNetID of all Acquisitions
Public method | CheckCommandExecuteable | Checks if the command can be executed.
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
 | ContainsElementInMultiSelectList | Determine, wether the MultiSelectList Contains the Element
 | ContainsElementOrParentInMultiSelectList | Determine, wether the Element or an Parent of the Element is contained in the MultiSelectList
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Dispose | Releases all resources of this Instance.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExtractConfiguration | Extract the Configuration from a SVDX-File
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAcquistionOrInterpreter | Get the Acquistion or AcquisitionInterpreter with the specific GUID
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Overrides MeasurementMemberBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMailAttachments | Gets all attachments for mails.
Public method | GetReferenceFiles |
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
 | GetScopeLicense | Gets the current license used to validate scope features.
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LayoutContainsMember | Checks if an object is in the Layout.
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseProjectMessage |
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
 | RemoveElementFromMultiSelectList | Remove an Element from the MultiSelectList
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Overrides MeasurementProjectBaseSetFromStream(Stream).)
Public method | SetFromString | Loads the scope from xml-string. (Overrides MeasurementProjectBaseSetFromString(String).)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClose | Tries to clean up the project for closing.
 | TryValidateFeature | Validate a Feature
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides MeasurementMemberBaseUpdatePropertyAttributes.)
 | ValidateFeature | Validate a Feature
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.AddElementToMultiSelectList Method

Add an Element to the MultiSelectList

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static void AddElementToMultiSelectList(
    MeasurementMemberBase Member
)
Public Shared Sub AddElementToMultiSelectList (
    Member As MeasurementMemberBase
)
public:
static void AddElementToMultiSelectList(
    MeasurementMemberBase^ Member
)

Parameters

Member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
The Member to Add
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.AddMember Method

Add a Member to the SubMemberCollection

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void AddMember(
    MeasurementMemberBase add
)
Public Overrides Sub AddMember (
    add As MeasurementMemberBase
)
public:
virtual void AddMember(
    MeasurementMemberBase^ add
) override

Parameters

add
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ChangeAmsNetID Method

Changes the AmsNetID of all Acquisitions

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void ChangeAmsNetID(
    AmsNetId NetID
)
Public Overridable Sub ChangeAmsNetID (
    NetID As AmsNetId
)
public:
virtual void ChangeAmsNetID(
    AmsNetId^ NetID
)

Parameters

NetID
Type: AmsNetId
The new AmsNetID
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.CheckCommandExecuteable Method

Checks if the command can be executed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual bool CheckCommandExecuteable(
    string command
)
Public Overridable Function CheckCommandExecuteable (
    command As String
) As Boolean
public:
virtual bool CheckCommandExecuteable(
    String^ command
)

Parameters

command
Type: SystemString
Identification string of the command.

Return Value

Type: Boolean
True if the command can be executed, otherwise false.
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ContainsElementInMultiSelectList Method

Determine, wether the MultiSelectList Contains the Element

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool ContainsElementInMultiSelectList(
    MeasurementMemberBase Member
)
Public Shared Function ContainsElementInMultiSelectList (
    Member As MeasurementMemberBase
) As Boolean
public:
static bool ContainsElementInMultiSelectList(
    MeasurementMemberBase^ Member
)

Parameters

Member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
The Member to Check

Return Value

Type: Boolean
True if the List Contains the Element
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ContainsElementOrParentInMultiSelectList Method

Determine, wether the Element or an Parent of the Element is contained in the MultiSelectList

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool ContainsElementOrParentInMultiSelectList(
    MeasurementMemberBase Member
)
Public Shared Function ContainsElementOrParentInMultiSelectList (
    Member As MeasurementMemberBase
) As Boolean
public:
static bool ContainsElementOrParentInMultiSelectList(
    MeasurementMemberBase^ Member
)

Parameters

Member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
The Member to check

Return Value

Type: Boolean
True if the List Contains the Element or one of its Parents
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.Dispose Method

Releases all resources of this Instance.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ExtractConfiguration Method

Extract the Configuration from a SVDX-File

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void ExtractConfiguration(
    string path
)
Public Sub ExtractConfiguration (
    path As String
)
public:
void ExtractConfiguration(
    String^ path
)

Parameters

path
Type: SystemString
The Path to Save the Configuration
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.GetAcquistionOrInterpreter Method

Get the Acquistion or AcquisitionInterpreter with the specific GUID

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MeasurementMemberBase GetAcquistionOrInterpreter(
    Guid guid
)
Public Function GetAcquistionOrInterpreter (
    guid As Guid
) As MeasurementMemberBase
public:
MeasurementMemberBase^ GetAcquistionOrInterpreter(
    Guid guid
)

Parameters

guid
Type: SystemGuid
Guid of the Element

Return Value

Type: MeasurementMemberBase
An Acquistion or an AcquisitionInterpreter
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.GetCommands Method

Gets a List of possible Commands for this Element

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
An Array of Commands
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.GetMailAttachments Method

Gets all attachments for mails.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual List<Attachment> GetMailAttachments()
Public Overridable Function GetMailAttachments As List(Of Attachment)
public:
virtual List<Attachment^>^ GetMailAttachments()

Return Value

Type: List Attachment
A list of attachments to send via mail.
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.GetReferenceFiles Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual List<string> GetReferenceFiles()
Public Overridable Function GetReferenceFiles As List(Of String)
public:
virtual List<String^>^ GetReferenceFiles()

Return Value

Type: List String
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.GetScopeLicense Method

Gets the current license used to validate scope features.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static ScopeLicense GetScopeLicense()
Public Shared Function GetScopeLicense As ScopeLicense
public:
static ScopeLicense GetScopeLicense()

Return Value

Type: ScopeLicense
Returns a ScopeLicense representing the current scope license.
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.LayoutContainsMember Method

Checks if an object is in the Layout.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool LayoutContainsMember(
    MeasurementMemberBase member
)
Public Function LayoutContainsMember (
    member As MeasurementMemberBase
) As Boolean
public:
bool LayoutContainsMember(
    MeasurementMemberBase^ member
)

Parameters

member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
The object to check.

Return Value

Type: Boolean
True if the object guid was found in the layout otherwise false.
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.RaiseProjectMessage Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void RaiseProjectMessage(
    string message,
    MessageType type
)
Public Sub RaiseProjectMessage (
    message As String,
    type As MessageType
)
public:
void RaiseProjectMessage(
    String^ message,
    MessageType type
)

Parameters

message
Type: SystemString
type
Type: MessageType
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.RemoveElementFromMultiSelectList Method

Remove an Element from the MultiSelectList

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static void RemoveElementFromMultiSelectList(
    MeasurementMemberBase Member
)
Public Shared Sub RemoveElementFromMultiSelectList (
    Member As MeasurementMemberBase
)
public:
static void RemoveElementFromMultiSelectList(
    MeasurementMemberBase^ Member
)

Parameters

Member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
The Member to Remove
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.SetFromStream Method

Set Element from Stream

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void SetFromStream(
    Stream stream
)
Public Overrides Sub SetFromStream (
    stream As Stream
)
public:
virtual void SetFromStream(
    Stream^ stream
) override

Parameters

stream
Type: System.IOStream
Stream to Set from
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.SetFromString Method

Loads the scope from xml-string.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void SetFromString(
    string document
)
Public Overrides Sub SetFromString (
    document As String
)
public:
virtual void SetFromString(
    String^ document
) override

Parameters

document
Type: SystemString
The scope config string.
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.TryClose Method

Tries to clean up the project for closing.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual bool TryClose(
    bool dispose
)
Public Overridable Function TryClose (
    dispose As Boolean
) As Boolean
public:
virtual bool TryClose(
    bool dispose
)

Parameters

dispose
Type: SystemBoolean
Set if the project should be disposed afterwards.

Return Value

Type: Boolean
True if clean up was successfull, otherwise false.
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.TryValidateFeature Method

Validate a Feature

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool TryValidateFeature(
    Features Feature
)
Public Shared Function TryValidateFeature (
    Feature As Features
) As Boolean
public:
static bool TryValidateFeature(
    Features Feature
)

Parameters

Feature
Type: Features

Return Value

Type: Boolean
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.UpdatePropertyAttributes Method

Sets the value off Propertyattributes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ValidateFeature Method

Validate a Feature

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static bool ValidateFeature(
    Features Feature
)
Public Shared Function ValidateFeature (
    Feature As Features
) As Boolean
public:
static bool ValidateFeature(
    Features Feature
)

Parameters

Feature
Type: Features

Return Value

Type: Boolean
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase Events

The ScopeProjectBase type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | ExportEvent | Fired during the Export to event
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LayoutChanged | Fired when the Layout is changed.
Public event | LayoutValidating | Fired while validating the new value for Layout.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshLayout | Fired to Ask for a Refresh of the LayoutString
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SelectDictionary | Fired to open the Folder Explorer
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | VersionChanged | Fired when the Version is changed. (Inherited from MeasurementProjectBase.)
Public event | VersionValidating | Fired while validating the new value for Version. (Inherited from MeasurementProjectBase.)
Public event | ViewDetailLevelChanged | Fired when the ViewDetailLevel is changed.
Public event | ViewDetailLevelValidating | Fired while validating the new value for ViewDetailLevel.
Top
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ExportEvent Event

Fired during the Export to event

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ExportEventArgs> ExportEvent
Public Event ExportEvent As EventHandler(Of ExportEventArgs)
public:
 event EventHandler<ExportEventArgs^>^ ExportEvent {
    void add (EventHandler<ExportEventArgs^>^ value);
    void remove (EventHandler<ExportEventArgs^>^ value);
}

Value

Type: SystemEventHandler ExportEventArgs
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.LayoutChanged Event

Fired when the Layout is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LayoutChanged
Public Event LayoutChanged As EventHandler
public:
 event EventHandler^ LayoutChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.LayoutValidating Event

Fired while validating the new value for Layout.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LayoutValidating
Public Event LayoutValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LayoutValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.RefreshLayout Event

Fired to Ask for a Refresh of the LayoutString

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler RefreshLayout
Public Event RefreshLayout As EventHandler
public:
 event EventHandler^ RefreshLayout {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.SelectDictionary Event

Fired to open the Folder Explorer

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<DirectoryDiagArgs> SelectDictionary
Public Event SelectDictionary As EventHandler(Of DirectoryDiagArgs)
public:
 event EventHandler<DirectoryDiagArgs^>^ SelectDictionary {
    void add (EventHandler<DirectoryDiagArgs^>^ value);
    void remove (EventHandler<DirectoryDiagArgs^>^ value);
}

Value

Type: SystemEventHandler DirectoryDiagArgs
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ViewDetailLevelChanged Event

Fired when the ViewDetailLevel is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ViewDetailLevelChanged
Public Event ViewDetailLevelChanged As EventHandler
public:
 event EventHandler^ ViewDetailLevelChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeProjectBase Class


ScopeProjectBase.ViewDetailLevelValidating Event

Fired while validating the new value for ViewDetailLevel.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ViewDetailLevelValidating
Public Event ViewDetailLevelValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ViewDetailLevelValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ScopeProjectBase Class


ScopeShape Class

Represents the base class of the ScopeShapes
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeShape
TwinCAT.Measurement.Scope.API.ModelAngularShape
TwinCAT.Measurement.Scope.API.ModelInteractionShape
TwinCAT.Measurement.Scope.API.ModelRoundShape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class ScopeShape : ScopeMemberContainerBase
Public MustInherit Class ScopeShape
    Inherits ScopeMemberContainerBase
public ref class ScopeShape abstract : public ScopeMemberContainerBase

The ScopeShape type exposes the following members.

Constructors
 | Name | Description
Public method | ScopeShape | Creates an instance of ScopeShape
Public method | ScopeShape(ScopeShape) | Creates a copy from scopeShape
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShapePoints | Gets the Points of the Shape
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | Gets a underlying Style Object
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | Highlight the Shape
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | Save | Saves this Shape to a file
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Property Attributes in the PropertyPage (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | Hightlight | Raise to highlight the shape
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPoints | Raise to refresh the points in the view
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ScopeShape Constructor

Overload List
 | Name | Description
Public method | ScopeShape | Creates an instance of ScopeShape
Public method | ScopeShape(ScopeShape) | Creates a copy from scopeShape
Top
See Also

Reference

ScopeShape Class


ScopeShape Constructor

Creates an instance of ScopeShape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeShape()
Public Sub New
public:
ScopeShape()
See Also

Reference

ScopeShape Class
ScopeShape Overload


ScopeShape Constructor (ScopeShape)

Creates a copy from scopeShape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeShape(
    ScopeShape scopeShape
)
Public Sub New (
    scopeShape As ScopeShape
)
public:
ScopeShape(
    ScopeShape^ scopeShape
)

Parameters

scopeShape
Type: TwinCAT.Measurement.Scope.API.ModelScopeShape
See Also

Reference

ScopeShape Class
ScopeShape Overload


ScopeShape Properties

The ScopeShape type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShapePoints | Gets the Points of the Shape
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | Gets a underlying Style Object
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ScopeShape Class


ScopeShape.DisplayColor Property

Gets or Sets the DisplayColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public override Color DisplayColor { get; set; }
<BrowsableAttribute(true)>
Public Overrides Property DisplayColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property Color DisplayColor {
    Color get () override;
    void set (Color value) override;
}

Property Value

Type: Color
See Also

Reference

ScopeShape Class


ScopeShape.ShapePoints Property

Gets the Points of the Shape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public abstract ReadOnlyCollection<double[]> ShapePoints { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public MustOverride ReadOnly Property ShapePoints As ReadOnlyCollection(Of Double())
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
virtual property ReadOnlyCollection<array<double>^>^ ShapePoints {
    ReadOnlyCollection<array<double>^>^ get () abstract;
}

Property Value

Type: ReadOnlyCollection Double
See Also

Reference

ScopeShape Class


ScopeShape.Style Property

Gets a underlying Style Object

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public ShapeStyle Style { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property Style As ShapeStyle
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property ShapeStyle^ Style {
    ShapeStyle^ get ();
}

Property Value

Type: ShapeStyle
See Also

Reference

ScopeShape Class


ScopeShape Methods

The ScopeShape type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Highlight | Highlight the Shape
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | Save | Saves this Shape to a file
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update the Property Attributes in the PropertyPage (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ScopeShape Class


ScopeShape.GetCommands Method

Gets a List of possible Commands for this Element

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
An Array of Commands
See Also

Reference

ScopeShape Class


ScopeShape.Highlight Method

Highlight the Shape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Highlight()
Public Sub Highlight
public:
virtual void Highlight() sealed
See Also

Reference

ScopeShape Class


ScopeShape.Save Method

Saves this Shape to a file

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Save(
    string FilePath,
    bool KeepColor = true,
    string Name = ""
)
Public Sub Save (
    FilePath As String,
    Optional KeepColor As Boolean = true,
    Optional Name As String = ""
)
public:
void Save(
    String^ FilePath,
    bool KeepColor = true,
    String^ Name = L""
)

Parameters

FilePath
Type: SystemString
The Path where the Shape should be saved
KeepColor (Optional)
Type: SystemBoolean
If false the color is not Saved to the File
Name (Optional)
Type: SystemString
The Name of the Shape saved
See Also

Reference

ScopeShape Class


ScopeShape.UpdatePropertyAttributes Method

Update the Property Attributes in the PropertyPage

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ScopeShape Class


ScopeShape Events

The ScopeShape type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | Hightlight | Raise to highlight the shape
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPoints | Raise to refresh the points in the view
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ScopeShape Class


ScopeShape.Hightlight Event

Raise to highlight the shape

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler Hightlight
Public Event Hightlight As EventHandler
public:
 event EventHandler^ Hightlight {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeShape Class


ScopeShape.RefreshPoints Event

Raise to refresh the points in the view

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler RefreshPoints
Public Event RefreshPoints As EventHandler
public:
 event EventHandler^ RefreshPoints {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScopeShape Class


SelectableMember Class

Inheritance Hierarchy
SystemObject
ModelBase
TwinCAT.Measurement.Scope.API.ModelSelectableMember

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class SelectableMember : ModelBase
Public MustInherit Class SelectableMember
    Inherits ModelBase
public ref class SelectableMember abstract : public ModelBase

The SelectableMember type exposes the following members.

Properties
 | Name | Description
Public property | IsSelected | Gets or Sets the IsSelected.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


SelectableMember Properties

The SelectableMember type exposes the following members.

Properties
 | Name | Description
Public property | IsSelected | Gets or Sets the IsSelected.
Top
See Also

Reference

SelectableMember Class


SelectableMember.IsSelected Property

Gets or Sets the IsSelected.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SelectableMember Class


SelectableMember Methods

The SelectableMember type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SelectableMember Class


SelectableMember Events

The SelectableMember type exposes the following members.

Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

SelectableMember Class


Sequence Class

Base class for acquisition that do not store their data in the scope server.
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisition
TwinCAT.Measurement.Scope.API.ModelSequence
TwinCAT.Measurement.Scope.API.ModelAcquisitionSequence
TwinCAT.Measurement.Scope.API.ModelCustomSequence
TwinCAT.Measurement.Scope.API.ModelIotFileSequence

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class Sequence : Acquisition
Public MustInherit Class Sequence
    Inherits Acquisition
public ref class Sequence abstract : public Acquisition

The Sequence type exposes the following members.

Constructors
 | Name | Description
Public method | Sequence | Creates a new empty Sequence.
Public method | Sequence(Sequence) | Initialize Properties with values copied from other Acquisition
Top
Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | Data | Gets the Data of this acquisition.
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataFilePath | Gets or Sets the DataFilePath.
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | (Overrides AcquisitionDescription.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | ExportOptions | Gets or Sets the ExportOptions.
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleCount | Gets or Sets the SampleCount.
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
Methods
 | Name | Description
Public method | AddData | Adds a list of samples to the end.
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CopyData |
Public method | DeleteDataFiles | Deletes the data file(s) at the DataFilePath.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportToAlyFile |
Public method | ExtendDataEnd | Adds samples to the end.
Public method | ExtendDataStart | Adds samples at the start.
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllFileInfos | Get all files which are used in this sequence
Public method | GetAllFilePathes | Get all files which are used in this sequence
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAlyFilePath |
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | (Overrides AcquisitionGetCommands.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Inherited from Acquisition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Acquisition.)
Public method | GetIotType |
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTasPath |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Get the data from the timestamp First Value = Timestamp == 0
Public method | GetValueConverter |
Public method | HasSameTarget | (Overrides AcquisitionHasSameTarget(Acquisition).)
Public method | Import(IotFileSequenceData) |
Public method | Import(RefAcquisitionSequenceData) |
Public method | Import(SequenceDataSource) |
Public method | InsertData | Inserts a list of data at the given index.
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | LoadData | Trys to load the data from the DataFilePath.
Public method | LoadData(String) |
Public method | MaxEndIndex | Gets the largest possible end index relative to the current end.
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MinStartIndex | Gets the smallest possible start index relative to the current start.
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | NewDataAlyFilePath |
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ReplaceData | Replaces a part of the data.
Public method | SaveData | Saves the data to the DataFilePath. The data is stored in the aly file format.
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | (Overrides ObjectToString.)
Public method | TrimData | Removes data from the acquisition.
Public method | TrimDataEnd | Removes samples at the end.
Public method | TrimDataStart | Removes samples from the start.
Public method | UpdatePropertyAttributes | (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | (Overrides MeasurementMemberBaseWriteXml(XmlWriter).)
Top
Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataFilePathChanged | Fired when the DataFilePath is changed.
Public event | DataFilePathValidating | Fired while validating the new value for DataFilePath.
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DataUpdated | Raised when data is added to Data.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | ExportOptionsChanged | Fired when the ExportOptions is changed.
Public event | ExportOptionsValidating | Fired while validating the new value for ExportOptions.
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SampleCountChanged | Fired when the SampleCount is changed.
Public event | SampleCountValidating | Fired while validating the new value for SampleCount.
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
Fields
 | Name | Description
 | MaxSampleCount |
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


Sequence Constructor

Overload List
 | Name | Description
Public method | Sequence | Creates a new empty Sequence.
Public method | Sequence(Sequence) | Initialize Properties with values copied from other Acquisition
Top
See Also

Reference

Sequence Class


Sequence Constructor

Creates a new empty Sequence.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Sequence()
Public Sub New
public:
Sequence()
See Also

Reference

Sequence Class
Sequence Overload


Sequence Constructor (Sequence)

Initialize Properties with values copied from other Acquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Sequence(
    Sequence acquisition
)
Public Sub New (
    acquisition As Sequence
)
public:
Sequence(
    Sequence^ acquisition
)

Parameters

acquisition
Type: TwinCAT.Measurement.Scope.API.ModelSequence
Acquisition to copy from
See Also

Reference

Sequence Class
Sequence Overload


Sequence Properties

The Sequence type exposes the following members.

Properties
 | Name | Description
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | Data | Gets the Data of this acquisition.
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataFilePath | Gets or Sets the DataFilePath.
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | (Overrides AcquisitionDescription.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | ExportOptions | Gets or Sets the ExportOptions.
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleCount | Gets or Sets the SampleCount.
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

Sequence Class


Sequence.Data Property

Gets the Data of this acquisition.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
public List<Object> Data { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(false)>
Public ReadOnly Property Data As List(Of Object)
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(false)]
property List<Object^>^ Data {
    List<Object^>^ get ();
}

Property Value

Type: List Object
See Also

Reference

Sequence Class


Sequence.DataFilePath Property

Gets or Sets the DataFilePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string DataFilePath { get; set; }
<BrowsableAttribute(false)>
Public Property DataFilePath As String
    Get
    Set
public:
[BrowsableAttribute(false)]
property String^ DataFilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Sequence Class


Sequence.Description Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override ChannelDescription Description { get; }
Public Overrides ReadOnly Property Description As ChannelDescription
    Get
public:
virtual property ChannelDescription^ Description {
    ChannelDescription^ get () override;
}

Property Value

Type: ChannelDescription
See Also

Reference

Sequence Class


Sequence.ExportOptions Property

Gets or Sets the ExportOptions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public SequenceExportOptions ExportOptions { get; set; }
<BrowsableAttribute(false)>
Public Property ExportOptions As SequenceExportOptions
    Get
    Set
public:
[BrowsableAttribute(false)]
property SequenceExportOptions ExportOptions {
    SequenceExportOptions get ();
    void set (SequenceExportOptions value);
}

Property Value

Type: SequenceExportOptions
See Also

Reference

Sequence Class


Sequence.SampleCount Property

Gets or Sets the SampleCount.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
public int SampleCount { get; }
<XmlIgnoreAttribute>
<BrowsableAttribute(true)>
Public ReadOnly Property SampleCount As Integer
    Get
public:
[XmlIgnoreAttribute]
[BrowsableAttribute(true)]
property int SampleCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Sequence Class


Sequence Methods

The Sequence type exposes the following members.

Methods
 | Name | Description
Public method | AddData | Adds a list of samples to the end.
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CopyData |
Public method | DeleteDataFiles | Deletes the data file(s) at the DataFilePath.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExportToAlyFile |
Public method | ExtendDataEnd | Adds samples to the end.
Public method | ExtendDataStart | Adds samples at the start.
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllFileInfos | Get all files which are used in this sequence
Public method | GetAllFilePathes | Get all files which are used in this sequence
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAlyFilePath |
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | (Overrides AcquisitionGetCommands.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Inherited from Acquisition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Acquisition.)
Public method | GetIotType |
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTasPath |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Get the data from the timestamp First Value = Timestamp == 0
Public method | GetValueConverter |
Public method | HasSameTarget | (Overrides AcquisitionHasSameTarget(Acquisition).)
Public method | Import(IotFileSequenceData) |
Public method | Import(RefAcquisitionSequenceData) |
Public method | Import(SequenceDataSource) |
Public method | InsertData | Inserts a list of data at the given index.
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | LoadData | Trys to load the data from the DataFilePath.
Public method | LoadData(String) |
Public method | MaxEndIndex | Gets the largest possible end index relative to the current end.
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MinStartIndex | Gets the smallest possible start index relative to the current start.
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | NewDataAlyFilePath |
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ReplaceData | Replaces a part of the data.
Public method | SaveData | Saves the data to the DataFilePath. The data is stored in the aly file format.
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | (Overrides ObjectToString.)
Public method | TrimData | Removes data from the acquisition.
Public method | TrimDataEnd | Removes samples at the end.
Public method | TrimDataStart | Removes samples from the start.
Public method | UpdatePropertyAttributes | (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | (Overrides MeasurementMemberBaseWriteXml(XmlWriter).)
Top
See Also

Reference

Sequence Class


Sequence.AddData Method

Adds a list of samples to the end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void AddData(
    List<Object> data
)
Public Overridable Sub AddData (
    data As List(Of Object)
)
public:
virtual void AddData(
    List<Object^>^ data
)

Parameters

data
Type: System.Collections.GenericList Object
The data to add.
See Also

Reference

Sequence Class


Sequence.CopyData Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void CopyData(
    Sequence acquisition
)
Public Overridable Sub CopyData (
    acquisition As Sequence
)
public:
virtual void CopyData(
    Sequence^ acquisition
)

Parameters

acquisition
Type: TwinCAT.Measurement.Scope.API.ModelSequence
See Also

Reference

Sequence Class


Sequence.DeleteDataFiles Method

Deletes the data file(s) at the DataFilePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void DeleteDataFiles()
Public Overridable Sub DeleteDataFiles
public:
virtual void DeleteDataFiles()
See Also

Reference

Sequence Class


Sequence.ExportToAlyFile Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual bool ExportToAlyFile(
    string path
)
Public Overridable Function ExportToAlyFile (
    path As String
) As Boolean
public:
virtual bool ExportToAlyFile(
    String^ path
)

Parameters

path
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

Sequence Class


Sequence.ExtendDataEnd Method

Adds samples to the end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract void ExtendDataEnd(
    long numSamples
)
Public MustOverride Sub ExtendDataEnd (
    numSamples As Long
)
public:
virtual void ExtendDataEnd(
    long long numSamples
) abstract

Parameters

numSamples
Type: SystemInt64
The number of samples to add.
See Also

Reference

Sequence Class


Sequence.ExtendDataStart Method

Adds samples at the start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract void ExtendDataStart(
    long numSamples
)
Public MustOverride Sub ExtendDataStart (
    numSamples As Long
)
public:
virtual void ExtendDataStart(
    long long numSamples
) abstract

Parameters

numSamples
Type: SystemInt64
The number of samples to add.
See Also

Reference

Sequence Class


Sequence.GetAllFileInfos Method

Get all files which are used in this sequence

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<FileInfo> GetAllFileInfos()
Public Function GetAllFileInfos As IEnumerable(Of FileInfo)
public:
IEnumerable<FileInfo^>^ GetAllFileInfos()

Return Value

Type: IEnumerable FileInfo
See Also

Reference

Sequence Class


Sequence.GetAllFilePathes Method

Get all files which are used in this sequence

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<string> GetAllFilePathes()
Public Function GetAllFilePathes As IEnumerable(Of String)
public:
IEnumerable<String^>^ GetAllFilePathes()

Return Value

Type: IEnumerable String
See Also

Reference

Sequence Class


Sequence.GetAlyFilePath Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual string GetAlyFilePath(
    bool fullTasPath
)
Public Overridable Function GetAlyFilePath (
    fullTasPath As Boolean
) As String
public:
virtual String^ GetAlyFilePath(
    bool fullTasPath
)

Parameters

fullTasPath
Type: SystemBoolean

Return Value

Type: String
See Also

Reference

Sequence Class


Sequence.GetCommands Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
See Also

Reference

Sequence Class


Sequence.GetIotType Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string GetIotType()
Public Function GetIotType As String
public:
String^ GetIotType()

Return Value

Type: String
See Also

Reference

Sequence Class


Sequence.GetTasPath Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string GetTasPath(
    string path,
    bool folderPath
)
Public Function GetTasPath (
    path As String,
    folderPath As Boolean
) As String
public:
String^ GetTasPath(
    String^ path,
    bool folderPath
)

Parameters

path
Type: SystemString
folderPath
Type: SystemBoolean

Return Value

Type: String
See Also

Reference

Sequence Class


Sequence.GetValue Method

Get the data from the timestamp First Value = Timestamp == 0

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Object GetValue(
    long timestamp
)
Public Function GetValue (
    timestamp As Long
) As Object
public:
Object^ GetValue(
    long long timestamp
)

Parameters

timestamp
Type: SystemInt64

Return Value

Type: Object
See Also

Reference

Sequence Class


Sequence.GetValueConverter Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Func<Object, byte[]> GetValueConverter()
Public Function GetValueConverter As Func(Of Object, Byte())
public:
Func<Object^, array<unsigned char>^>^ GetValueConverter()

Return Value

Type: Func Object, Byte
See Also

Reference

Sequence Class


Sequence.HasSameTarget Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool HasSameTarget(
    Acquisition Acquisition
)
Public Overrides Function HasSameTarget (
    Acquisition As Acquisition
) As Boolean
public:
virtual bool HasSameTarget(
    Acquisition^ Acquisition
) override

Parameters

Acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition

Return Value

Type: Boolean
See Also

Reference

Sequence Class


Sequence.Import Method

Overload List
 | Name | Description
Public method | Import(IotFileSequenceData) |
Public method | Import(RefAcquisitionSequenceData) |
Public method | Import(SequenceDataSource) |
Top
See Also

Reference

Sequence Class


Sequence.Import Method (IotFileSequenceData)

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void Import(
    IotFileSequenceData export
)
Public Overridable Sub Import (
    export As IotFileSequenceData
)
public:
virtual void Import(
    IotFileSequenceData^ export
)

Parameters

export
Type: TwinCAT.Measurement.Scope.API.ModelIotFileSequenceData
See Also

Reference

Sequence Class
Import Overload


Sequence.Import Method (RefAcquisitionSequenceData)

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void Import(
    RefAcquisitionSequenceData export
)
Public Overridable Sub Import (
    export As RefAcquisitionSequenceData
)
public:
virtual void Import(
    RefAcquisitionSequenceData^ export
)

Parameters

export
Type: TwinCAT.Measurement.Scope.API.ModelRefAcquisitionSequenceData
See Also

Reference

Sequence Class
Import Overload


Sequence.Import Method (SequenceDataSource)

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void Import(
    SequenceDataSource export
)
Public Overridable Sub Import (
    export As SequenceDataSource
)
public:
virtual void Import(
    SequenceDataSource^ export
)

Parameters

export
Type: TwinCAT.Measurement.Scope.API.ModelSequenceDataSource
See Also

Reference

Sequence Class
Import Overload


Sequence.InsertData Method

Inserts a list of data at the given index.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void InsertData(
    int index,
    List<Object> data
)
Public Overridable Sub InsertData (
    index As Integer,
    data As List(Of Object)
)
public:
virtual void InsertData(
    int index,
    List<Object^>^ data
)

Parameters

index
Type: SystemInt32
The position where the data should be added.
data
Type: System.Collections.GenericList Object
The data to add.
See Also

Reference

Sequence Class


Sequence.LoadData Method

Overload List
 | Name | Description
Public method | LoadData | Trys to load the data from the DataFilePath.
Public method | LoadData(String) |
Top
See Also

Reference

Sequence Class


Sequence.LoadData Method

Trys to load the data from the DataFilePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void LoadData()
Public Overridable Sub LoadData
public:
virtual void LoadData()
See Also

Reference

Sequence Class
LoadData Overload


Sequence.LoadData Method (String)

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void LoadData(
    string path
)
Public Overridable Sub LoadData (
    path As String
)
public:
virtual void LoadData(
    String^ path
)

Parameters

path
Type: SystemString
See Also

Reference

Sequence Class
LoadData Overload


Sequence.MaxEndIndex Method

Gets the largest possible end index relative to the current end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual double MaxEndIndex()
Public Overridable Function MaxEndIndex As Double
public:
virtual double MaxEndIndex()

Return Value

Type: Double
See Also

Reference

Sequence Class


Sequence.MinStartIndex Method

Gets the smallest possible start index relative to the current start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual double MinStartIndex()
Public Overridable Function MinStartIndex As Double
public:
virtual double MinStartIndex()

Return Value

Type: Double
See Also

Reference

Sequence Class


Sequence.NewDataAlyFilePath Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string NewDataAlyFilePath(
    string folder
)
Public Function NewDataAlyFilePath (
    folder As String
) As String
public:
String^ NewDataAlyFilePath(
    String^ folder
)

Parameters

folder
Type: SystemString

Return Value

Type: String
See Also

Reference

Sequence Class


Sequence.ReplaceData Method

Replaces a part of the data.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void ReplaceData(
    int index,
    List<Object> data
)
Public Overridable Sub ReplaceData (
    index As Integer,
    data As List(Of Object)
)
public:
virtual void ReplaceData(
    int index,
    List<Object^>^ data
)

Parameters

index
Type: SystemInt32
The start index of the data to replace.
data
Type: System.Collections.GenericList Object
The substitute data.
See Also

Reference

Sequence Class


Sequence.SaveData Method

Saves the data to the DataFilePath. The data is stored in the aly file format.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void SaveData()
Public Overridable Sub SaveData
public:
virtual void SaveData()
See Also

Reference

Sequence Class


Sequence.ToString Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
See Also

Reference

Sequence Class


Sequence.TrimData Method

Removes data from the acquisition.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual void TrimData(
    int index,
    int samples
)
Public Overridable Sub TrimData (
    index As Integer,
    samples As Integer
)
public:
virtual void TrimData(
    int index,
    int samples
)

Parameters

index
Type: SystemInt32
The starting index.
samples
Type: SystemInt32
The number of samples to remove.
See Also

Reference

Sequence Class


Sequence.TrimDataEnd Method

Removes samples at the end.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract void TrimDataEnd(
    long numSamples
)
Public MustOverride Sub TrimDataEnd (
    numSamples As Long
)
public:
virtual void TrimDataEnd(
    long long numSamples
) abstract

Parameters

numSamples
Type: SystemInt64
The number of samples to remove.
See Also

Reference

Sequence Class


Sequence.TrimDataStart Method

Removes samples from the start.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract void TrimDataStart(
    long numSamples
)
Public MustOverride Sub TrimDataStart (
    numSamples As Long
)
public:
virtual void TrimDataStart(
    long long numSamples
) abstract

Parameters

numSamples
Type: SystemInt64
The number of samples to remove.
See Also

Reference

Sequence Class


Sequence.UpdatePropertyAttributes Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

Sequence Class


Sequence.WriteXml Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void WriteXml(
    XmlWriter writer
)
Public Overrides Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) override

Parameters

writer
Type: System.XmlXmlWriter

Implements

IXmlSerializableWriteXml(XmlWriter)
See Also

Reference

Sequence Class


Sequence Events

The Sequence type exposes the following members.

Events
 | Name | Description
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataFilePathChanged | Fired when the DataFilePath is changed.
Public event | DataFilePathValidating | Fired while validating the new value for DataFilePath.
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DataUpdated | Raised when data is added to Data.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | ExportOptionsChanged | Fired when the ExportOptions is changed.
Public event | ExportOptionsValidating | Fired while validating the new value for ExportOptions.
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SampleCountChanged | Fired when the SampleCount is changed.
Public event | SampleCountValidating | Fired while validating the new value for SampleCount.
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

Sequence Class


Sequence.DataFilePathChanged Event

Fired when the DataFilePath is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DataFilePathChanged
Public Event DataFilePathChanged As EventHandler
public:
 event EventHandler^ DataFilePathChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Sequence Class


Sequence.DataFilePathValidating Event

Fired while validating the new value for DataFilePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DataFilePathValidating
Public Event DataFilePathValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DataFilePathValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Sequence Class


Sequence.DataUpdated Event

Raised when data is added to Data.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<UpdateDataSequenceEventArgs> DataUpdated
Public Event DataUpdated As EventHandler(Of UpdateDataSequenceEventArgs)
public:
 event EventHandler<UpdateDataSequenceEventArgs^>^ DataUpdated {
    void add (EventHandler<UpdateDataSequenceEventArgs^>^ value);
    void remove (EventHandler<UpdateDataSequenceEventArgs^>^ value);
}

Value

Type: SystemEventHandler UpdateDataSequenceEventArgs
See Also

Reference

Sequence Class


Sequence.ExportOptionsChanged Event

Fired when the ExportOptions is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ExportOptionsChanged
Public Event ExportOptionsChanged As EventHandler
public:
 event EventHandler^ ExportOptionsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Sequence Class


Sequence.ExportOptionsValidating Event

Fired while validating the new value for ExportOptions.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ExportOptionsValidating
Public Event ExportOptionsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ExportOptionsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Sequence Class


Sequence.SampleCountChanged Event

Fired when the SampleCount is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SampleCountChanged
Public Event SampleCountChanged As EventHandler
public:
 event EventHandler^ SampleCountChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

Sequence Class


Sequence.SampleCountValidating Event

Fired while validating the new value for SampleCount.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SampleCountValidating
Public Event SampleCountValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SampleCountValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

Sequence Class


Sequence Fields

The Sequence type exposes the following members.

Fields
 | Name | Description
 | MaxSampleCount |
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

Sequence Class


Sequence.MaxSampleCount Field

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public const int MaxSampleCount = 100000
Public Const MaxSampleCount As Integer = 100000
public:
literal int MaxSampleCount = 100000

Field Value

Type: Int32
See Also

Reference

Sequence Class


SequenceDataSource Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelSequenceDataSource
TwinCAT.Measurement.Scope.API.ModelIotFileSequenceData

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class SequenceDataSource : MeasurementMemberBase
Public MustInherit Class SequenceDataSource
    Inherits MeasurementMemberBase
public ref class SequenceDataSource abstract : public MeasurementMemberBase

The SequenceDataSource type exposes the following members.

Constructors
 | Name | Description
Public method | SequenceDataSource | Initializes a new instance of the SequenceDataSource class
Public method | SequenceDataSource(SequenceDataSource) | Initializes a new instance of the SequenceDataSource class
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


SequenceDataSource Constructor

Overload List
 | Name | Description
Public method | SequenceDataSource | Initializes a new instance of the SequenceDataSource class
Public method | SequenceDataSource(SequenceDataSource) | Initializes a new instance of the SequenceDataSource class
Top
See Also

Reference

SequenceDataSource Class


SequenceDataSource Constructor

Initializes a new instance of the SequenceDataSource class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SequenceDataSource()
Public Sub New
public:
SequenceDataSource()
See Also

Reference

SequenceDataSource Class
SequenceDataSource Overload


SequenceDataSource Constructor (SequenceDataSource)

Initializes a new instance of the SequenceDataSource class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SequenceDataSource(
    SequenceDataSource org
)
Public Sub New (
    org As SequenceDataSource
)
public:
SequenceDataSource(
    SequenceDataSource^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelSequenceDataSource
See Also

Reference

SequenceDataSource Class
SequenceDataSource Overload


SequenceDataSource Properties

The SequenceDataSource type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

SequenceDataSource Class


SequenceDataSource Methods

The SequenceDataSource type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Get all MenuCommands (Inherited from MeasurementMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Inherited from MeasurementMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

SequenceDataSource Class


SequenceDataSource Events

The SequenceDataSource type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

SequenceDataSource Class


SeriesStyle Class

Class describing the Style of the Marks
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelSeriesStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class SeriesStyle : ScopeMemberBase
Public Class SeriesStyle
    Inherits ScopeMemberBase
public ref class SeriesStyle : public ScopeMemberBase

The SeriesStyle type exposes the following members.

Constructors
 | Name | Description
Public method | SeriesStyle | Create a new MarkStyle
Public method | SeriesStyle(SeriesStyle) | Create a new MarkStyle by copying Properties
Top
Properties
 | Name | Description
Public property | Antialias | Gets or Sets the Antialias.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FillColor | Gets or Sets the FillColor.
Public property | FillMode | Gets or Sets the FillMode.
Public property | FillTransparency | Gets or Sets the FillTransparency.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineWidth | Gets or Sets the LineWidth.
Public property | MarkColor | Gets or Sets the MarkColor.
Public property | MarkSize | Gets or Sets the MarkSize.
Public property | MarkState | Gets or Sets the MarkState.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SeriesType | Gets or Sets the SeriesType.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of all public Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AntialiasChanged | Fired when the Antialias is changed.
Public event | AntialiasValidating | Fired while validating the new value for Antialias.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FillColorChanged | Fired when the FillColor is changed.
Public event | FillColorValidating | Fired while validating the new value for FillColor.
Public event | FillModeChanged | Fired when the FillMode is changed.
Public event | FillModeValidating | Fired while validating the new value for FillMode.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineWidthChanged | Fired when the LineWidth is changed.
Public event | LineWidthValidating | Fired while validating the new value for LineWidth.
Public event | MarkColorChanged | Fired when the MarkColor is changed.
Public event | MarkColorValidating | Fired while validating the new value for MarkColor.
Public event | MarkSizeChanged | Fired when the MarkSize is changed.
Public event | MarkSizeValidating | Fired while validating the new value for MarkSize.
Public event | MarkStateChanged | Fired when the MarkState is changed.
Public event | MarkStateValidating | Fired while validating the new value for MarkState.
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SeriesTypeChanged | Fired when the SeriesType is changed.
Public event | SeriesTypeValidating | Fired while validating the new value for SeriesType.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


SeriesStyle Constructor

Overload List
 | Name | Description
Public method | SeriesStyle | Create a new MarkStyle
Public method | SeriesStyle(SeriesStyle) | Create a new MarkStyle by copying Properties
Top
See Also

Reference

SeriesStyle Class


SeriesStyle Constructor

Create a new MarkStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SeriesStyle()
Public Sub New
public:
SeriesStyle()
See Also

Reference

SeriesStyle Class
SeriesStyle Overload


SeriesStyle Constructor (SeriesStyle)

Create a new MarkStyle by copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SeriesStyle(
    SeriesStyle org
)
Public Sub New (
    org As SeriesStyle
)
public:
SeriesStyle(
    SeriesStyle^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelSeriesStyle
MarkStyle to copy from
See Also

Reference

SeriesStyle Class
SeriesStyle Overload


SeriesStyle Properties

The SeriesStyle type exposes the following members.

Properties
 | Name | Description
Public property | Antialias | Gets or Sets the Antialias.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FillColor | Gets or Sets the FillColor.
Public property | FillMode | Gets or Sets the FillMode.
Public property | FillTransparency | Gets or Sets the FillTransparency.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineWidth | Gets or Sets the LineWidth.
Public property | MarkColor | Gets or Sets the MarkColor.
Public property | MarkSize | Gets or Sets the MarkSize.
Public property | MarkState | Gets or Sets the MarkState.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SeriesType | Gets or Sets the SeriesType.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

SeriesStyle Class


SeriesStyle.Antialias Property

Gets or Sets the Antialias.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Antialias { get; set; }
<BrowsableAttribute(true)>
Public Property Antialias As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Antialias {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SeriesStyle Class


SeriesStyle.FillColor Property

Gets or Sets the FillColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Color FillColor { get; set; }
<BrowsableAttribute(true)>
Public Property FillColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
property Color FillColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

SeriesStyle Class


SeriesStyle.FillMode Property

Gets or Sets the FillMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public GraphFillMode FillMode { get; set; }
<BrowsableAttribute(true)>
Public Property FillMode As GraphFillMode
    Get
    Set
public:
[BrowsableAttribute(true)]
property GraphFillMode FillMode {
    GraphFillMode get ();
    void set (GraphFillMode value);
}

Property Value

Type: GraphFillMode
See Also

Reference

SeriesStyle Class


SeriesStyle.FillTransparency Property

Gets or Sets the FillTransparency.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public int FillTransparency { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property FillTransparency As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property int FillTransparency {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SeriesStyle Class


SeriesStyle.LineWidth Property

Gets or Sets the LineWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public float LineWidth { get; set; }
<BrowsableAttribute(true)>
Public Property LineWidth As Single
    Get
    Set
public:
[BrowsableAttribute(true)]
property float LineWidth {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SeriesStyle Class


SeriesStyle.MarkColor Property

Gets or Sets the MarkColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Color MarkColor { get; set; }
<BrowsableAttribute(true)>
Public Property MarkColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
property Color MarkColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

SeriesStyle Class


SeriesStyle.MarkSize Property

Gets or Sets the MarkSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int MarkSize { get; set; }
<BrowsableAttribute(true)>
Public Property MarkSize As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int MarkSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SeriesStyle Class


SeriesStyle.MarkState Property

Gets or Sets the MarkState.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkConfiguration MarkState { get; set; }
Public Property MarkState As MarkConfiguration
    Get
    Set
public:
property MarkConfiguration MarkState {
    MarkConfiguration get ();
    void set (MarkConfiguration value);
}

Property Value

Type: MarkConfiguration
See Also

Reference

SeriesStyle Class


SeriesStyle.SeriesType Property

Gets or Sets the SeriesType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public SeriesTypes SeriesType { get; set; }
<BrowsableAttribute(true)>
Public Property SeriesType As SeriesTypes
    Get
    Set
public:
[BrowsableAttribute(true)]
property SeriesTypes SeriesType {
    SeriesTypes get ();
    void set (SeriesTypes value);
}

Property Value

Type: SeriesTypes
See Also

Reference

SeriesStyle Class


SeriesStyle Methods

The SeriesStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of all public Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

SeriesStyle Class


SeriesStyle.UpdatePropertyAttributes Method

Update Attributes of all public Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

SeriesStyle Class


SeriesStyle Events

The SeriesStyle type exposes the following members.

Events
 | Name | Description
Public event | AntialiasChanged | Fired when the Antialias is changed.
Public event | AntialiasValidating | Fired while validating the new value for Antialias.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FillColorChanged | Fired when the FillColor is changed.
Public event | FillColorValidating | Fired while validating the new value for FillColor.
Public event | FillModeChanged | Fired when the FillMode is changed.
Public event | FillModeValidating | Fired while validating the new value for FillMode.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineWidthChanged | Fired when the LineWidth is changed.
Public event | LineWidthValidating | Fired while validating the new value for LineWidth.
Public event | MarkColorChanged | Fired when the MarkColor is changed.
Public event | MarkColorValidating | Fired while validating the new value for MarkColor.
Public event | MarkSizeChanged | Fired when the MarkSize is changed.
Public event | MarkSizeValidating | Fired while validating the new value for MarkSize.
Public event | MarkStateChanged | Fired when the MarkState is changed.
Public event | MarkStateValidating | Fired while validating the new value for MarkState.
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SeriesTypeChanged | Fired when the SeriesType is changed.
Public event | SeriesTypeValidating | Fired while validating the new value for SeriesType.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

SeriesStyle Class


SeriesStyle.AntialiasChanged Event

Fired when the Antialias is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AntialiasChanged
Public Event AntialiasChanged As EventHandler
public:
 event EventHandler^ AntialiasChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SeriesStyle Class


SeriesStyle.AntialiasValidating Event

Fired while validating the new value for Antialias.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AntialiasValidating
Public Event AntialiasValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AntialiasValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SeriesStyle Class


SeriesStyle.FillColorChanged Event

Fired when the FillColor is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler FillColorChanged
Public Event FillColorChanged As EventHandler
public:
 event EventHandler^ FillColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SeriesStyle Class


SeriesStyle.FillColorValidating Event

Fired while validating the new value for FillColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> FillColorValidating
Public Event FillColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ FillColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SeriesStyle Class


SeriesStyle.FillModeChanged Event

Fired when the FillMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler FillModeChanged
Public Event FillModeChanged As EventHandler
public:
 event EventHandler^ FillModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SeriesStyle Class


SeriesStyle.FillModeValidating Event

Fired while validating the new value for FillMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> FillModeValidating
Public Event FillModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ FillModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SeriesStyle Class


SeriesStyle.LineWidthChanged Event

Fired when the LineWidth is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LineWidthChanged
Public Event LineWidthChanged As EventHandler
public:
 event EventHandler^ LineWidthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SeriesStyle Class


SeriesStyle.LineWidthValidating Event

Fired while validating the new value for LineWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LineWidthValidating
Public Event LineWidthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LineWidthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SeriesStyle Class


SeriesStyle.MarkColorChanged Event

Fired when the MarkColor is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler MarkColorChanged
Public Event MarkColorChanged As EventHandler
public:
 event EventHandler^ MarkColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SeriesStyle Class


SeriesStyle.MarkColorValidating Event

Fired while validating the new value for MarkColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> MarkColorValidating
Public Event MarkColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ MarkColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SeriesStyle Class


SeriesStyle.MarkSizeChanged Event

Fired when the MarkSize is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler MarkSizeChanged
Public Event MarkSizeChanged As EventHandler
public:
 event EventHandler^ MarkSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SeriesStyle Class


SeriesStyle.MarkSizeValidating Event

Fired while validating the new value for MarkSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> MarkSizeValidating
Public Event MarkSizeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ MarkSizeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SeriesStyle Class


SeriesStyle.MarkStateChanged Event

Fired when the MarkState is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler MarkStateChanged
Public Event MarkStateChanged As EventHandler
public:
 event EventHandler^ MarkStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SeriesStyle Class


SeriesStyle.MarkStateValidating Event

Fired while validating the new value for MarkState.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> MarkStateValidating
Public Event MarkStateValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ MarkStateValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SeriesStyle Class


SeriesStyle.SeriesTypeChanged Event

Fired when the SeriesType is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SeriesTypeChanged
Public Event SeriesTypeChanged As EventHandler
public:
 event EventHandler^ SeriesTypeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SeriesStyle Class


SeriesStyle.SeriesTypeValidating Event

Fired while validating the new value for SeriesType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SeriesTypeValidating
Public Event SeriesTypeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SeriesTypeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SeriesStyle Class


ServerTriggerSet Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelTriggerSet
TwinCAT.Measurement.Scope.API.ModelServerTriggerSet
TwinCAT.Measurement.Scope.API.ModelChannelTriggerSet
TwinCAT.Measurement.Scope.API.ModelTimeTriggerSet

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class ServerTriggerSet : TriggerSet
Public MustInherit Class ServerTriggerSet
    Inherits TriggerSet
public ref class ServerTriggerSet abstract : public TriggerSet

The ServerTriggerSet type exposes the following members.

Constructors
 | Name | Description
Public method | ServerTriggerSet | Creates an instance of a ChannelTriggerSet
Public method | ServerTriggerSet(ServerTriggerSet) | Creates an instance of a ChannelTriggerSet and copy values from org
Top
Properties
 | Name | Description
Public property | ClientTriggerHandle | Gets or Sets the ClientTriggerHandle. (Inherited from TriggerSet.)
Public property | CombineOption | Gets or Sets the CombineOption.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from TriggerSet.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GroupHandle | Gets or Sets the GroupHandle. (Inherited from TriggerSet.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsReleased | Gets or Sets the IsReleased. (Inherited from TriggerSet.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | BindToGroup | bind this instance to a TriggerGroup
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Menucommands for thie Element (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | ManualSetReleased | Release Trigger manual
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides TriggerSetUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ClientTriggerHandleChanged | Fired when the ClientTriggerHandle is changed. (Inherited from TriggerSet.)
Public event | ClientTriggerHandleValidating | Fired while validating the new value for ClientTriggerHandle. (Inherited from TriggerSet.)
Public event | CombineOptionChanged | Fired when the CombineOption is changed.
Public event | CombineOptionValidating | Fired while validating the new value for CombineOption.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from TriggerSet.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from TriggerSet.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GroupHandleChanged | Fired when the GroupHandle is changed. (Inherited from TriggerSet.)
Public event | GroupHandleValidating | Fired while validating the new value for GroupHandle. (Inherited from TriggerSet.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsReleasedChanged | Fired when the IsReleased is changed. (Inherited from TriggerSet.)
Public event | IsReleasedValidating | Fired while validating the new value for IsReleased. (Inherited from TriggerSet.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ServerTriggerSet Constructor

Overload List
 | Name | Description
Public method | ServerTriggerSet | Creates an instance of a ChannelTriggerSet
Public method | ServerTriggerSet(ServerTriggerSet) | Creates an instance of a ChannelTriggerSet and copy values from org
Top
See Also

Reference

ServerTriggerSet Class


ServerTriggerSet Constructor

Creates an instance of a ChannelTriggerSet

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ServerTriggerSet()
Public Sub New
public:
ServerTriggerSet()
See Also

Reference

ServerTriggerSet Class
ServerTriggerSet Overload


ServerTriggerSet Constructor (ServerTriggerSet)

Creates an instance of a ChannelTriggerSet and copy values from org

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ServerTriggerSet(
    ServerTriggerSet org
)
Public Sub New (
    org As ServerTriggerSet
)
public:
ServerTriggerSet(
    ServerTriggerSet^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelServerTriggerSet
See Also

Reference

ServerTriggerSet Class
ServerTriggerSet Overload


ServerTriggerSet Properties

The ServerTriggerSet type exposes the following members.

Properties
 | Name | Description
Public property | ClientTriggerHandle | Gets or Sets the ClientTriggerHandle. (Inherited from TriggerSet.)
Public property | CombineOption | Gets or Sets the CombineOption.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from TriggerSet.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GroupHandle | Gets or Sets the GroupHandle. (Inherited from TriggerSet.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsReleased | Gets or Sets the IsReleased. (Inherited from TriggerSet.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ServerTriggerSet Class


ServerTriggerSet.CombineOption Property

Gets or Sets the CombineOption.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public TriggerCombineOptions CombineOption { get; set; }
<BrowsableAttribute(true)>
Public Property CombineOption As TriggerCombineOptions
    Get
    Set
public:
[BrowsableAttribute(true)]
property TriggerCombineOptions CombineOption {
    TriggerCombineOptions get ();
    void set (TriggerCombineOptions value);
}

Property Value

Type: TriggerCombineOptions
See Also

Reference

ServerTriggerSet Class


ServerTriggerSet Methods

The ServerTriggerSet type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | BindToGroup | bind this instance to a TriggerGroup
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Menucommands for thie Element (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | ManualSetReleased | Release Trigger manual
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides TriggerSetUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ServerTriggerSet Class


ServerTriggerSet.BindToGroup Method

bind this instance to a TriggerGroup

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract void BindToGroup(
    IClientTriggerGroup TriggerGroup,
    bool reattach = false
)
Public MustOverride Sub BindToGroup (
    TriggerGroup As IClientTriggerGroup,
    Optional reattach As Boolean = false
)
public:
virtual void BindToGroup(
    IClientTriggerGroup^ TriggerGroup,
    bool reattach = false
) abstract

Parameters

TriggerGroup
Type: IClientTriggerGroup
TriggerGroup to attach to
reattach (Optional)
Type: SystemBoolean
Determines wether the TriggerSet should be reattached to an active client
See Also

Reference

ServerTriggerSet Class


ServerTriggerSet.GetCommands Method

Gets a List of Menucommands for thie Element

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
An Array of MenuCommands
See Also

Reference

ServerTriggerSet Class


ServerTriggerSet.ManualSetReleased Method

Release Trigger manual

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void ManualSetReleased(
    bool Released
)
Public Sub ManualSetReleased (
    Released As Boolean
)
public:
void ManualSetReleased(
    bool Released
)

Parameters

Released
Type: SystemBoolean
See Also

Reference

ServerTriggerSet Class


ServerTriggerSet.UpdatePropertyAttributes Method

Sets the value off Propertyattributes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ServerTriggerSet Class


ServerTriggerSet Events

The ServerTriggerSet type exposes the following members.

Events
 | Name | Description
Public event | ClientTriggerHandleChanged | Fired when the ClientTriggerHandle is changed. (Inherited from TriggerSet.)
Public event | ClientTriggerHandleValidating | Fired while validating the new value for ClientTriggerHandle. (Inherited from TriggerSet.)
Public event | CombineOptionChanged | Fired when the CombineOption is changed.
Public event | CombineOptionValidating | Fired while validating the new value for CombineOption.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from TriggerSet.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from TriggerSet.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GroupHandleChanged | Fired when the GroupHandle is changed. (Inherited from TriggerSet.)
Public event | GroupHandleValidating | Fired while validating the new value for GroupHandle. (Inherited from TriggerSet.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsReleasedChanged | Fired when the IsReleased is changed. (Inherited from TriggerSet.)
Public event | IsReleasedValidating | Fired while validating the new value for IsReleased. (Inherited from TriggerSet.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ServerTriggerSet Class


ServerTriggerSet.CombineOptionChanged Event

Fired when the CombineOption is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CombineOptionChanged
Public Event CombineOptionChanged As EventHandler
public:
 event EventHandler^ CombineOptionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ServerTriggerSet Class


ServerTriggerSet.CombineOptionValidating Event

Fired while validating the new value for CombineOption.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> CombineOptionValidating
Public Event CombineOptionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ CombineOptionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ServerTriggerSet Class


ShapePoint Class

Point Class for Shape Editor
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.API.ModelShapePoint
TwinCAT.Measurement.Scope.API.ModelShapeXYPoint

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ShapePoint : INotifyPropertyChanged, INotifyPropertyChanging
Public Class ShapePoint
    Implements INotifyPropertyChanged, INotifyPropertyChanging
public ref class ShapePoint : INotifyPropertyChanged,
    INotifyPropertyChanging

The ShapePoint type exposes the following members.

Constructors
 | Name | Description
Public method | ShapePoint | Initializes a new instance of the ShapePoint class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Raised after a Property has changed
Public event | PropertyChanging | Raised before a Property has changed
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ShapePoint Constructor

Initializes a new instance of the ShapePoint class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ShapePoint()
Public Sub New
public:
ShapePoint()
See Also

Reference

ShapePoint Class


ShapePoint Methods

The ShapePoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ShapePoint Class


ShapePoint Events

The ShapePoint type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Raised after a Property has changed
Public event | PropertyChanging | Raised before a Property has changed
Top
See Also

Reference

ShapePoint Class


ShapePoint.PropertyChanged Event

Raised after a Property has changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

ShapePoint Class


ShapePoint.PropertyChanging Event

Raised before a Property has changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event PropertyChangingEventHandler PropertyChanging
Public Event PropertyChanging As PropertyChangingEventHandler
public:
virtual  event PropertyChangingEventHandler^ PropertyChanging {
    void add (PropertyChangingEventHandler^ value);
    void remove (PropertyChangingEventHandler^ value);
}

Value

Type: System.ComponentModelPropertyChangingEventHandler

Implements

INotifyPropertyChangingPropertyChanging
See Also

Reference

ShapePoint Class


ShapeStyle Class

Represents the Shape Style
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelShapeStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ShapeStyle : ScopeMemberBase
Public Class ShapeStyle
    Inherits ScopeMemberBase
public ref class ShapeStyle : public ScopeMemberBase

The ShapeStyle type exposes the following members.

Constructors
 | Name | Description
Public method | ShapeStyle | Creates a new instance of ShapeStyle
Public method | ShapeStyle(ShapeStyle) | Creates a new instance of ShapeStyle and copy attributes from shapeStyle
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FillColor | Gets or Sets the FillColor.
Public property | FillMode | Gets or Sets the FillMode.
Public property | FillTransparency | Gets or Sets the FillTransparency.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineWidth | Gets or Sets the LineWidth.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | Visible | Gets or Sets the Visible.
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update properties in Propertypage (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FillColorChanged | Fired when the FillColor is changed.
Public event | FillColorValidating | Fired while validating the new value for FillColor.
Public event | FillModeChanged | Fired when the FillMode is changed.
Public event | FillModeValidating | Fired while validating the new value for FillMode.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineWidthChanged | Fired when the LineWidth is changed.
Public event | LineWidthValidating | Fired while validating the new value for LineWidth.
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | VisibleChanged | Fired when the Visible is changed.
Public event | VisibleValidating | Fired while validating the new value for Visible.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ShapeStyle Constructor

Overload List
 | Name | Description
Public method | ShapeStyle | Creates a new instance of ShapeStyle
Public method | ShapeStyle(ShapeStyle) | Creates a new instance of ShapeStyle and copy attributes from shapeStyle
Top
See Also

Reference

ShapeStyle Class


ShapeStyle Constructor

Creates a new instance of ShapeStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ShapeStyle()
Public Sub New
public:
ShapeStyle()
See Also

Reference

ShapeStyle Class
ShapeStyle Overload


ShapeStyle Constructor (ShapeStyle)

Creates a new instance of ShapeStyle and copy attributes from shapeStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ShapeStyle(
    ShapeStyle shapeStyle
)
Public Sub New (
    shapeStyle As ShapeStyle
)
public:
ShapeStyle(
    ShapeStyle^ shapeStyle
)

Parameters

shapeStyle
Type: TwinCAT.Measurement.Scope.API.ModelShapeStyle
See Also

Reference

ShapeStyle Class
ShapeStyle Overload


ShapeStyle Properties

The ShapeStyle type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FillColor | Gets or Sets the FillColor.
Public property | FillMode | Gets or Sets the FillMode.
Public property | FillTransparency | Gets or Sets the FillTransparency.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineWidth | Gets or Sets the LineWidth.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | Visible | Gets or Sets the Visible.
Top
See Also

Reference

ShapeStyle Class


ShapeStyle.FillColor Property

Gets or Sets the FillColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public Color FillColor { get; set; }
<BrowsableAttribute(true)>
Public Property FillColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
property Color FillColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ShapeStyle Class


ShapeStyle.FillMode Property

Gets or Sets the FillMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public ShapeFillMode FillMode { get; set; }
<BrowsableAttribute(true)>
Public Property FillMode As ShapeFillMode
    Get
    Set
public:
[BrowsableAttribute(true)]
property ShapeFillMode FillMode {
    ShapeFillMode get ();
    void set (ShapeFillMode value);
}

Property Value

Type: ShapeFillMode
See Also

Reference

ShapeStyle Class


ShapeStyle.FillTransparency Property

Gets or Sets the FillTransparency.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public int FillTransparency { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property FillTransparency As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property int FillTransparency {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ShapeStyle Class


ShapeStyle.LineWidth Property

Gets or Sets the LineWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int LineWidth { get; set; }
<BrowsableAttribute(true)>
Public Property LineWidth As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int LineWidth {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ShapeStyle Class


ShapeStyle.Visible Property

Gets or Sets the Visible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Visible { get; set; }
<BrowsableAttribute(true)>
Public Property Visible As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Visible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ShapeStyle Class


ShapeStyle Methods

The ShapeStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update properties in Propertypage (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ShapeStyle Class


ShapeStyle.UpdatePropertyAttributes Method

Update properties in Propertypage

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ShapeStyle Class


ShapeStyle Events

The ShapeStyle type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FillColorChanged | Fired when the FillColor is changed.
Public event | FillColorValidating | Fired while validating the new value for FillColor.
Public event | FillModeChanged | Fired when the FillMode is changed.
Public event | FillModeValidating | Fired while validating the new value for FillMode.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineWidthChanged | Fired when the LineWidth is changed.
Public event | LineWidthValidating | Fired while validating the new value for LineWidth.
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | VisibleChanged | Fired when the Visible is changed.
Public event | VisibleValidating | Fired while validating the new value for Visible.
Top
See Also

Reference

ShapeStyle Class


ShapeStyle.FillColorChanged Event

Fired when the FillColor is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler FillColorChanged
Public Event FillColorChanged As EventHandler
public:
 event EventHandler^ FillColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ShapeStyle Class


ShapeStyle.FillColorValidating Event

Fired while validating the new value for FillColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> FillColorValidating
Public Event FillColorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ FillColorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ShapeStyle Class


ShapeStyle.FillModeChanged Event

Fired when the FillMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler FillModeChanged
Public Event FillModeChanged As EventHandler
public:
 event EventHandler^ FillModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ShapeStyle Class


ShapeStyle.FillModeValidating Event

Fired while validating the new value for FillMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> FillModeValidating
Public Event FillModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ FillModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ShapeStyle Class


ShapeStyle.LineWidthChanged Event

Fired when the LineWidth is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LineWidthChanged
Public Event LineWidthChanged As EventHandler
public:
 event EventHandler^ LineWidthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ShapeStyle Class


ShapeStyle.LineWidthValidating Event

Fired while validating the new value for LineWidth.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LineWidthValidating
Public Event LineWidthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LineWidthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ShapeStyle Class


ShapeStyle.VisibleChanged Event

Fired when the Visible is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler VisibleChanged
Public Event VisibleChanged As EventHandler
public:
 event EventHandler^ VisibleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ShapeStyle Class


ShapeStyle.VisibleValidating Event

Fired while validating the new value for Visible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> VisibleValidating
Public Event VisibleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ VisibleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ShapeStyle Class


ShapeXYPoint Class

Shape Point Class for XY-Points
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.API.ModelShapePoint
TwinCAT.Measurement.Scope.API.ModelShapeXYPoint

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ShapeXYPoint : ShapePoint
Public Class ShapeXYPoint
    Inherits ShapePoint
public ref class ShapeXYPoint : public ShapePoint

The ShapeXYPoint type exposes the following members.

Constructors
 | Name | Description
Public method | ShapeXYPoint | Create a new Instance of ShapeXYPoint
Public method | ShapeXYPoint(Double) | Create a new Instance of ShapeXYPoint
Public method | ShapeXYPoint(Double, Double) | Create a new Instance of ShapeXYPoint
Top
Properties
 | Name | Description
Public property | X | Gets or Sets the X.
Public property | XPropertyUpdater |
Public property | Y | Gets or Sets the Y.
Public property | YPropertyUpdater |
Top
Methods
 | Name | Description
Public method | ClonePointOnly |
Public method | EqualPoint |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToDoubleArray | Converts the Point to a Double Array
Public method | ToString | Converts the Point to String (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Raised after a Property has changed (Inherited from ShapePoint.)
Public event | PropertyChanging | Raised before a Property has changed (Inherited from ShapePoint.)
Public event | XChanged | Fired when the X is changed.
Public event | XValidating | Fired while validating the new value for X.
Public event | YChanged | Fired when the Y is changed.
Public event | YValidating | Fired while validating the new value for Y.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ShapeXYPoint Constructor

Overload List
 | Name | Description
Public method | ShapeXYPoint | Create a new Instance of ShapeXYPoint
Public method | ShapeXYPoint(Double) | Create a new Instance of ShapeXYPoint
Public method | ShapeXYPoint(Double, Double) | Create a new Instance of ShapeXYPoint
Top
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint Constructor

Create a new Instance of ShapeXYPoint

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ShapeXYPoint()
Public Sub New
public:
ShapeXYPoint()
See Also

Reference

ShapeXYPoint Class
ShapeXYPoint Overload


ShapeXYPoint Constructor (Double[])

Create a new Instance of ShapeXYPoint

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ShapeXYPoint(
    double[] XY
)
Public Sub New (
    XY As Double()
)
public:
ShapeXYPoint(
    array<double>^ XY
)

Parameters

XY
Type: SystemDouble
The Coordinates as Array
See Also

Reference

ShapeXYPoint Class
ShapeXYPoint Overload


ShapeXYPoint Constructor (Double, Double)

Create a new Instance of ShapeXYPoint

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ShapeXYPoint(
    double X,
    double Y
)
Public Sub New (
    X As Double,
    Y As Double
)
public:
ShapeXYPoint(
    double X,
    double Y
)

Parameters

X
Type: SystemDouble
The X Coordinate
Y
Type: SystemDouble
The Y Coordiante
See Also

Reference

ShapeXYPoint Class
ShapeXYPoint Overload


ShapeXYPoint Properties

The ShapeXYPoint type exposes the following members.

Properties
 | Name | Description
Public property | X | Gets or Sets the X.
Public property | XPropertyUpdater |
Public property | Y | Gets or Sets the Y.
Public property | YPropertyUpdater |
Top
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint.X Property

Gets or Sets the X.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double X { get; set; }
<BrowsableAttribute(true)>
Public Property X As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double X {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint.XPropertyUpdater Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public PropertyUpdater XPropertyUpdater { get; set; }
Public Property XPropertyUpdater As PropertyUpdater
    Get
    Set
public:
property PropertyUpdater^ XPropertyUpdater {
    PropertyUpdater^ get ();
    void set (PropertyUpdater^ value);
}

Property Value

Type: PropertyUpdater
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint.Y Property

Gets or Sets the Y.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double Y { get; set; }
<BrowsableAttribute(true)>
Public Property Y As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double Y {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint.YPropertyUpdater Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public PropertyUpdater YPropertyUpdater { get; set; }
Public Property YPropertyUpdater As PropertyUpdater
    Get
    Set
public:
property PropertyUpdater^ YPropertyUpdater {
    PropertyUpdater^ get ();
    void set (PropertyUpdater^ value);
}

Property Value

Type: PropertyUpdater
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint Methods

The ShapeXYPoint type exposes the following members.

Methods
 | Name | Description
Public method | ClonePointOnly |
Public method | EqualPoint |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToDoubleArray | Converts the Point to a Double Array
Public method | ToString | Converts the Point to String (Overrides ObjectToString.)
Top
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint.ClonePointOnly Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ShapeXYPoint ClonePointOnly()
Public Function ClonePointOnly As ShapeXYPoint
public:
ShapeXYPoint^ ClonePointOnly()

Return Value

Type: ShapeXYPoint
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint.EqualPoint Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool EqualPoint(
    ShapeXYPoint comparePoint
)
Public Function EqualPoint (
    comparePoint As ShapeXYPoint
) As Boolean
public:
bool EqualPoint(
    ShapeXYPoint^ comparePoint
)

Parameters

comparePoint
Type: TwinCAT.Measurement.Scope.API.ModelShapeXYPoint

Return Value

Type: Boolean
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint.ToDoubleArray Method

Converts the Point to a Double Array

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual double[] ToDoubleArray()
Public Overridable Function ToDoubleArray As Double()
public:
virtual array<double>^ ToDoubleArray()

Return Value

Type: Double
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint.ToString Method

Converts the Point to String

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint Events

The ShapeXYPoint type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Raised after a Property has changed (Inherited from ShapePoint.)
Public event | PropertyChanging | Raised before a Property has changed (Inherited from ShapePoint.)
Public event | XChanged | Fired when the X is changed.
Public event | XValidating | Fired while validating the new value for X.
Public event | YChanged | Fired when the Y is changed.
Public event | YValidating | Fired while validating the new value for Y.
Top
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint.XChanged Event

Fired when the X is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler XChanged
Public Event XChanged As EventHandler
public:
 event EventHandler^ XChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint.XValidating Event

Fired while validating the new value for X.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> XValidating
Public Event XValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ XValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint.YChanged Event

Fired when the Y is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler YChanged
Public Event YChanged As EventHandler
public:
 event EventHandler^ YChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ShapeXYPoint Class


ShapeXYPoint.YValidating Event

Fired while validating the new value for Y.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> YValidating
Public Event YValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ YValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ShapeXYPoint Class


SingleValuesChart Class

SingleValueChart class
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAnchorTimeBase
TwinCAT.Measurement.Scope.API.ModelChart
TwinCAT.Measurement.Scope.API.ModelConnectableChart
TwinCAT.Measurement.Scope.API.ModelSingleValuesChart
TwinCAT.Measurement.Scope.API.ModelArrayBarChart
TwinCAT.Measurement.Scope.API.ModelBarChart
TwinCAT.Measurement.Scope.API.ModelDigitalChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class SingleValuesChart : ConnectableChart
Public MustInherit Class SingleValuesChart
    Inherits ConnectableChart
public ref class SingleValuesChart abstract : public ConnectableChart

The SingleValuesChart type exposes the following members.

Constructors
 | Name | Description
Public method | SingleValuesChart | Create a new SingleValuesChart Type Class
Public method | SingleValuesChart(SingleValuesChart) | Create a new SingleValuesChart Type Class and copy properties from old svc Chart
Top
Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Overrides ChartCanContainsChartLayer.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Inherited from Chart.)
Public property | ChartType | (Inherited from Chart.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | PreferredSendTime | Gets or Sets the PreferredSendTime.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartDisplayWithoutOverview |
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Chart.)
Public method | Validate | Validates the Chart Configuration and adds an ChartStyle, if not exists. (Inherited from Chart.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | PreferredSendTimeChanged | Fired when the PreferredSendTime is changed.
Public event | PreferredSendTimeValidating | Fired while validating the new value for PreferredSendTime.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


SingleValuesChart Constructor

Overload List
 | Name | Description
Public method | SingleValuesChart | Create a new SingleValuesChart Type Class
Public method | SingleValuesChart(SingleValuesChart) | Create a new SingleValuesChart Type Class and copy properties from old svc Chart
Top
See Also

Reference

SingleValuesChart Class


SingleValuesChart Constructor

Create a new SingleValuesChart Type Class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SingleValuesChart()
Public Sub New
public:
SingleValuesChart()
See Also

Reference

SingleValuesChart Class
SingleValuesChart Overload


SingleValuesChart Constructor (SingleValuesChart)

Create a new SingleValuesChart Type Class and copy properties from old svc Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SingleValuesChart(
    SingleValuesChart svc
)
Public Sub New (
    svc As SingleValuesChart
)
public:
SingleValuesChart(
    SingleValuesChart^ svc
)

Parameters

svc
Type: TwinCAT.Measurement.Scope.API.ModelSingleValuesChart
See Also

Reference

SingleValuesChart Class
SingleValuesChart Overload


SingleValuesChart Properties

The SingleValuesChart type exposes the following members.

Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Overrides ChartCanContainsChartLayer.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Inherited from Chart.)
Public property | ChartType | (Inherited from Chart.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | PreferredSendTime | Gets or Sets the PreferredSendTime.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

SingleValuesChart Class


SingleValuesChart.CanContainsChartLayer Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool CanContainsChartLayer { get; }
Public Overrides ReadOnly Property CanContainsChartLayer As Boolean
    Get
public:
virtual property bool CanContainsChartLayer {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

SingleValuesChart Class


SingleValuesChart.PreferredSendTime Property

Gets or Sets the PreferredSendTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long PreferredSendTime { get; set; }
<BrowsableAttribute(true)>
Public Property PreferredSendTime As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long PreferredSendTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

SingleValuesChart Class


SingleValuesChart Methods

The SingleValuesChart type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartDisplayWithoutOverview |
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Inherited from Chart.)
Public method | Validate | Validates the Chart Configuration and adds an ChartStyle, if not exists. (Inherited from Chart.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
See Also

Reference

SingleValuesChart Class


SingleValuesChart.StartDisplayWithoutOverview Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void StartDisplayWithoutOverview()
Public Sub StartDisplayWithoutOverview
public:
void StartDisplayWithoutOverview()
See Also

Reference

SingleValuesChart Class


SingleValuesChart Events

The SingleValuesChart type exposes the following members.

Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | PreferredSendTimeChanged | Fired when the PreferredSendTime is changed.
Public event | PreferredSendTimeValidating | Fired while validating the new value for PreferredSendTime.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

SingleValuesChart Class


SingleValuesChart.PreferredSendTimeChanged Event

Fired when the PreferredSendTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PreferredSendTimeChanged
Public Event PreferredSendTimeChanged As EventHandler
public:
 event EventHandler^ PreferredSendTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SingleValuesChart Class


SingleValuesChart.PreferredSendTimeValidating Event

Fired while validating the new value for PreferredSendTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PreferredSendTimeValidating
Public Event PreferredSendTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PreferredSendTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SingleValuesChart Class


SingleValuesChart Fields

The SingleValuesChart type exposes the following members.

Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

SingleValuesChart Class


SvdxAcquisition Class

Acquistion to acquire data from an old SVDX File
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAcquisition
TwinCAT.Measurement.Scope.API.ModelHistoricalAcquisition
TwinCAT.Measurement.Scope.API.ModelSvdxAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class SvdxAcquisition : HistoricalAcquisition
Public Class SvdxAcquisition
    Inherits HistoricalAcquisition
public ref class SvdxAcquisition : public HistoricalAcquisition

The SvdxAcquisition type exposes the following members.

Constructors
 | Name | Description
Public method | SvdxAcquisition | Create a mew SvdxAcquistions
Public method | SvdxAcquisition(SvdxAcquisition) | Create a new SvdxAcquisition
Top
Properties
 | Name | Description
Public property | AdditionalDataFolder | Gets or Sets the AdditionalDataFolder.
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayIndex | Gets or Sets the ArrayIndex.
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataIncluded | Gets or Sets the DataIncluded.
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | Get the Desciption (Overrides AcquisitionDescription.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | NotInFile | Gets or Sets the NotInFile. If true the method RefreshSymbolInfo will not update this acquisition.
Public property | OriginalArrayLength | Gets or Sets the OriginalArrayLength.
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | Path | Gets or Sets the Path.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | Records | Gets or Sets the Records. (Overrides HistoricalAcquisitionRecords.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SvdxFileHandle | Gets or Sets the SvdxFileHandle.
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | TimeRangeId | Gets or Sets the TimeRangeId. (Inherited from HistoricalAcquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UpdateOtherAcq | If this property is true all other Acquisitions with the same Target get updated without a question. (Inherited from HistoricalAcquisition.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Inherited from Acquisition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Acquisition.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides HistoricalAcquisitionHasSameTarget(Acquisition).)
Public method | HasSameTargetExceptRecords | Determines wether the two Acquisition will acquire the same Data except the selected Records (Inherited from HistoricalAcquisition.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RefreshSymbolInfo | Refresh the Symbol Information
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateDataAccessTimes | Sets the time property of the DataAccess based on the Records. (Inherited from HistoricalAcquisition.)
Public method | UpdatePropertyAttributes | Update the Property Attributes (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AdditionalDataFolderChanged | Fired when the AdditionalDataFolder is changed.
Public event | AdditionalDataFolderValidating | Fired while validating the new value for AdditionalDataFolder.
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayIndexChanged | Fired when the ArrayIndex is changed.
Public event | ArrayIndexValidating | Fired while validating the new value for ArrayIndex.
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataIncludedChanged | Fired when the DataIncluded is changed.
Public event | DataIncludedValidating | Fired while validating the new value for DataIncluded.
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NotInFileChanged | Fired when the NotInFile is changed.
Public event | NotInFileValidating | Fired while validating the new value for NotInFile.
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OriginalArrayLengthChanged | Fired when the OriginalArrayLength is changed.
Public event | OriginalArrayLengthValidating | Fired while validating the new value for OriginalArrayLength.
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | PathChanged | Fired when the Path is changed.
Public event | PathValidating | Fired while validating the new value for Path.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RecordsChanged | Fired when the Records is changed. (Inherited from HistoricalAcquisition.)
Public event | RecordsValidating | Fired while validating the new value for Records. (Inherited from HistoricalAcquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SvdxFileHandleChanged | Fired when the SvdxFileHandle is changed.
Public event | SvdxFileHandleValidating | Fired while validating the new value for SvdxFileHandle.
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TimeRangeIdChanged | Fired when the TimeRangeId is changed. (Inherited from HistoricalAcquisition.)
Public event | TimeRangeIdValidating | Fired while validating the new value for TimeRangeId. (Inherited from HistoricalAcquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateOtherAcqChanged | Fired when the UpdateOtherAcq is changed. (Inherited from HistoricalAcquisition.)
Public event | UpdateOtherAcqValidating | Fired while validating the new value for UpdateOtherAcq. (Inherited from HistoricalAcquisition.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


SvdxAcquisition Constructor

Overload List
 | Name | Description
Public method | SvdxAcquisition | Create a mew SvdxAcquistions
Public method | SvdxAcquisition(SvdxAcquisition) | Create a new SvdxAcquisition
Top
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition Constructor

Create a mew SvdxAcquistions

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SvdxAcquisition()
Public Sub New
public:
SvdxAcquisition()
See Also

Reference

SvdxAcquisition Class
SvdxAcquisition Overload


SvdxAcquisition Constructor (SvdxAcquisition)

Create a new SvdxAcquisition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public SvdxAcquisition(
    SvdxAcquisition org
)
Public Sub New (
    org As SvdxAcquisition
)
public:
SvdxAcquisition(
    SvdxAcquisition^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelSvdxAcquisition
See Also

Reference

SvdxAcquisition Class
SvdxAcquisition Overload


SvdxAcquisition Properties

The SvdxAcquisition type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalDataFolder | Gets or Sets the AdditionalDataFolder.
Public property | AmsNetId | Gets or Sets the AmsNetId. To avoid type-exception using different versions of TwinCAT.Ads.dll consider to use the AmsNetIdExchange. (Inherited from Acquisition.)
Public property | AmsNetIdExchange | Gets or sets the targets AmsNetId from a given string. Use this to avoid type-exception using different versions of TwinCAT.Ads.dll (Inherited from Acquisition.)
Public property | Area | Gets or Sets the Area. (Inherited from Acquisition.)
Public property | ArrayIndex | Gets or Sets the ArrayIndex.
Public property | ArrayLength | Gets or Sets the ArrayLength. (Inherited from Acquisition.)
Public property | BaseSampleTime | Gets or Sets the BaseSampleTime. (Inherited from Acquisition.)
Public property | ChannelStyleInformation | Gets or Sets the ChannelStyleInformation. (Inherited from Acquisition.)
Public property | Comment | (Inherited from Acquisition.)
Public property | CompressionMode | Gets or Sets the CompressionMode. (Inherited from Acquisition.)
Public property | ContextMask | Gets or Sets the ContextMask. (Inherited from Acquisition.)
Public property | DataAccess | Gets or Sets the DataAccess. (Inherited from Acquisition.)
Public property | DataIncluded | Gets or Sets the DataIncluded.
Public property | DataType | Gets or Sets the DataType. (Inherited from Acquisition.)
Public property | Description | Get the Desciption (Overrides AcquisitionDescription.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Acquisition.)
Public property | FileHandle | Gets or Sets the FileHandle. (Inherited from Acquisition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForceOversampling | Gets or Sets the ForceOversampling. (Inherited from Acquisition.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsArray | Gets or Sets the IsArray. (Inherited from Acquisition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsHistorical | Gets or Sets the IsHistorical. (Inherited from Acquisition.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | NotInFile | Gets or Sets the NotInFile. If true the method RefreshSymbolInfo will not update this acquisition.
Public property | OriginalArrayLength | Gets or Sets the OriginalArrayLength.
Public property | Oversample | Gets or Sets the Oversample. (Inherited from Acquisition.)
Public property | Path | Gets or Sets the Path.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RawUnit | Gets or Sets the RawUnit. (Inherited from Acquisition.)
Public property | Records | Gets or Sets the Records. (Overrides HistoricalAcquisitionRecords.)
Public property | ReferenceCount | Get the number of Times this Acquisition is used (Inherited from Acquisition.)
Public property | SampleTime | Gets or Sets the SampleTime. (Inherited from Acquisition.)
Public property | SaveOption | Gets or Sets the SaveOption. (Inherited from Acquisition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeClientChannel | Gets or Sets the ScopeClientChannel. (Inherited from Acquisition.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ServerHandle | Gets or Sets the ServerHandle. (Inherited from Acquisition.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SvdxFileHandle | Gets or Sets the SvdxFileHandle.
Public property | SymbolName | Gets or Sets the SymbolName.
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from Acquisition.)
Public property | TimeRangeId | Gets or Sets the TimeRangeId. (Inherited from HistoricalAcquisition.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UpdateOtherAcq | If this property is true all other Acquisitions with the same Target get updated without a question. (Inherited from HistoricalAcquisition.)
Public property | UseLocalServer | Gets or Sets the UseLocalServer. (Inherited from Acquisition.)
Public property | UseTaskSampleTime | Gets or Sets the UseTaskSampleTime. (Inherited from Acquisition.)
Public property | UTF8Encoding | Gets or Sets the UTF8Encoding. (Inherited from Acquisition.)
Public property | VariableSize | Gets or Sets the VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.AdditionalDataFolder Property

Gets or Sets the AdditionalDataFolder.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string AdditionalDataFolder { get; set; }
<BrowsableAttribute(true)>
Public Property AdditionalDataFolder As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ AdditionalDataFolder {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.ArrayIndex Property

Gets or Sets the ArrayIndex.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int ArrayIndex { get; set; }
Public Property ArrayIndex As Integer
    Get
    Set
public:
property int ArrayIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.DataIncluded Property

Gets or Sets the DataIncluded.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool DataIncluded { get; set; }
<BrowsableAttribute(true)>
Public Property DataIncluded As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool DataIncluded {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.Description Property

Get the Desciption

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override ChannelDescription Description { get; }
Public Overrides ReadOnly Property Description As ChannelDescription
    Get
public:
virtual property ChannelDescription^ Description {
    ChannelDescription^ get () override;
}

Property Value

Type: ChannelDescription
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.NotInFile Property

Gets or Sets the NotInFile. If true the method RefreshSymbolInfo will not update this acquisition.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool NotInFile { get; set; }
<BrowsableAttribute(false)>
Public Property NotInFile As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool NotInFile {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.OriginalArrayLength Property

Gets or Sets the OriginalArrayLength.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int OriginalArrayLength { get; set; }
Public Property OriginalArrayLength As Integer
    Get
    Set
public:
property int OriginalArrayLength {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.Path Property

Gets or Sets the Path.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string Path { get; set; }
<BrowsableAttribute(true)>
Public Property Path As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.Records Property

Gets or Sets the Records.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override RecordsContainer Records { get; set; }
Public Overrides Property Records As RecordsContainer
    Get
    Set
public:
virtual property RecordsContainer^ Records {
    RecordsContainer^ get () override;
    void set (RecordsContainer^ value) override;
}

Property Value

Type: RecordsContainer
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.SvdxFileHandle Property

Gets or Sets the SvdxFileHandle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int SvdxFileHandle { get; set; }
<BrowsableAttribute(true)>
Public Property SvdxFileHandle As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int SvdxFileHandle {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.SymbolName Property

Gets or Sets the SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string SymbolName { get; set; }
<BrowsableAttribute(true)>
Public Property SymbolName As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ SymbolName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition Methods

The SvdxAcquisition type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetByteSize | Used to update VariableSize, return uint.Max to supress update in overloaded Acquisition (Inherited from Acquisition.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from Acquisition.)
Public method | GetDataSize | (Inherited from Acquisition.)
Public method | GetFullName | Gets the complete identifier of this acqusition (Inherited from Acquisition.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Acquisition.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasSameTarget | Determines wether the two Acquisition will acquire the same Data (Overrides HistoricalAcquisitionHasSameTarget(Acquisition).)
Public method | HasSameTargetExceptRecords | Determines wether the two Acquisition will acquire the same Data except the selected Records (Inherited from HistoricalAcquisition.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | OrderValues | (Inherited from Acquisition.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from Acquisition.)
Public method | RefreshSymbolInfo | Refresh the Symbol Information
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateDataAccessTimes | Sets the time property of the DataAccess based on the Records. (Inherited from HistoricalAcquisition.)
Public method | UpdatePropertyAttributes | Update the Property Attributes (Overrides AcquisitionUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.HasSameTarget Method

Determines wether the two Acquisition will acquire the same Data

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool HasSameTarget(
    Acquisition Acquisition
)
Public Overrides Function HasSameTarget (
    Acquisition As Acquisition
) As Boolean
public:
virtual bool HasSameTarget(
    Acquisition^ Acquisition
) override

Parameters

Acquisition
Type: TwinCAT.Measurement.Scope.API.ModelAcquisition
The Acquisition to compare with

Return Value

Type: Boolean
True if the Acquisitions have the Same Target
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.RefreshSymbolInfo Method

Refresh the Symbol Information

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void RefreshSymbolInfo()
Public Sub RefreshSymbolInfo
public:
void RefreshSymbolInfo()
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.UpdatePropertyAttributes Method

Update the Property Attributes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition Events

The SvdxAcquisition type exposes the following members.

Events
 | Name | Description
Public event | AdditionalDataFolderChanged | Fired when the AdditionalDataFolder is changed.
Public event | AdditionalDataFolderValidating | Fired while validating the new value for AdditionalDataFolder.
Public event | AmsNetIdChanged | Fired when the AmsNetId is changed. (Inherited from Acquisition.)
Public event | AmsNetIdValidating | Fired while validating the new value for AmsNetId. (Inherited from Acquisition.)
Public event | AreaChanged | Fired when the Area is changed. (Inherited from Acquisition.)
Public event | AreaValidating | Fired while validating the new value for Area. (Inherited from Acquisition.)
Public event | ArrayIndexChanged | Fired when the ArrayIndex is changed.
Public event | ArrayIndexValidating | Fired while validating the new value for ArrayIndex.
Public event | ArrayLengthChanged | Fired when the ArrayLength is changed. (Inherited from Acquisition.)
Public event | ArrayLengthValidating | Fired while validating the new value for ArrayLength. (Inherited from Acquisition.)
Public event | BaseSampleTimeChanged | Fired when the BaseSampleTime is changed. (Inherited from Acquisition.)
Public event | BaseSampleTimeValidating | Fired while validating the new value for BaseSampleTime. (Inherited from Acquisition.)
Public event | ChannelStyleInformationChanged | Fired when the ChannelStyleInformation is changed. (Inherited from Acquisition.)
Public event | ChannelStyleInformationValidating | Fired while validating the new value for ChannelStyleInformation. (Inherited from Acquisition.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | CompressionModeChanged | Fired when the CompressionMode is changed. (Inherited from Acquisition.)
Public event | CompressionModeValidating | Fired while validating the new value for CompressionMode. (Inherited from Acquisition.)
Public event | ContextMaskChanged | Fired when the ContextMask is changed. (Inherited from Acquisition.)
Public event | ContextMaskValidating | Fired while validating the new value for ContextMask. (Inherited from Acquisition.)
Public event | DataAccessChanged | Fired when the DataAccess is changed. (Inherited from Acquisition.)
Public event | DataAccessValidating | Fired while validating the new value for DataAccess. (Inherited from Acquisition.)
Public event | DataIncludedChanged | Fired when the DataIncluded is changed.
Public event | DataIncludedValidating | Fired while validating the new value for DataIncluded.
Public event | DataTypeChanged | Fired when the DataType is changed. (Inherited from Acquisition.)
Public event | DataTypeValidating | Fired while validating the new value for DataType. (Inherited from Acquisition.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Acquisition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Acquisition.)
Public event | FileHandleChanged | Fired when the FileHandle is changed. (Inherited from Acquisition.)
Public event | FileHandleValidating | Fired while validating the new value for FileHandle. (Inherited from Acquisition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForceOversamplingChanged | Fired when the ForceOversampling is changed. (Inherited from Acquisition.)
Public event | ForceOversamplingValidating | Fired while validating the new value for ForceOversampling. (Inherited from Acquisition.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsHistoricalChanged | Fired when the IsHistorical is changed. (Inherited from Acquisition.)
Public event | IsHistoricalValidating | Fired while validating the new value for IsHistorical. (Inherited from Acquisition.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NotInFileChanged | Fired when the NotInFile is changed.
Public event | NotInFileValidating | Fired while validating the new value for NotInFile.
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrderData | (Inherited from Acquisition.)
Public event | OriginalArrayLengthChanged | Fired when the OriginalArrayLength is changed.
Public event | OriginalArrayLengthValidating | Fired while validating the new value for OriginalArrayLength.
Public event | OversampleChanged | Fired when the Oversample is changed. (Inherited from Acquisition.)
Public event | OversampleValidating | Fired while validating the new value for Oversample. (Inherited from Acquisition.)
Public event | PathChanged | Fired when the Path is changed.
Public event | PathValidating | Fired while validating the new value for Path.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RawUnitChanged | Fired when the RawUnit is changed. (Inherited from Acquisition.)
Public event | RawUnitValidating | Fired while validating the new value for RawUnit. (Inherited from Acquisition.)
Public event | RecordsChanged | Fired when the Records is changed. (Inherited from HistoricalAcquisition.)
Public event | RecordsValidating | Fired while validating the new value for Records. (Inherited from HistoricalAcquisition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SaveOptionChanged | Fired when the SaveOption is changed. (Inherited from Acquisition.)
Public event | SaveOptionValidating | Fired while validating the new value for SaveOption. (Inherited from Acquisition.)
Public event | ServerHandleChanged | Fired when the ServerHandle is changed. (Inherited from Acquisition.)
Public event | ServerHandleValidating | Fired while validating the new value for ServerHandle. (Inherited from Acquisition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SvdxFileHandleChanged | Fired when the SvdxFileHandle is changed.
Public event | SvdxFileHandleValidating | Fired while validating the new value for SvdxFileHandle.
Public event | SymbolNameChanged | Fired when the SymbolName is changed.
Public event | SymbolNameValidating | Fired while validating the new value for SymbolName.
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from Acquisition.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from Acquisition.)
Public event | TimeRangeIdChanged | Fired when the TimeRangeId is changed. (Inherited from HistoricalAcquisition.)
Public event | TimeRangeIdValidating | Fired while validating the new value for TimeRangeId. (Inherited from HistoricalAcquisition.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UpdateOtherAcqChanged | Fired when the UpdateOtherAcq is changed. (Inherited from HistoricalAcquisition.)
Public event | UpdateOtherAcqValidating | Fired while validating the new value for UpdateOtherAcq. (Inherited from HistoricalAcquisition.)
Public event | UseLocalServerChanged | Fired when the UseLocalServer is changed. (Inherited from Acquisition.)
Public event | UseLocalServerValidating | Fired while validating the new value for UseLocalServer. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeChanged | Fired when the UseTaskSampleTime is changed. (Inherited from Acquisition.)
Public event | UseTaskSampleTimeValidating | Fired while validating the new value for UseTaskSampleTime. (Inherited from Acquisition.)
Public event | UTF8EncodingChanged | Fired when the UTF8Encoding is changed. (Inherited from Acquisition.)
Public event | UTF8EncodingValidating | Fired while validating the new value for UTF8Encoding. (Inherited from Acquisition.)
Public event | VariableSizeChanged | Fired when the VariableSize is changed. (Inherited from Acquisition.)
Public event | VariableSizeValidating | Fired while validating the new value for VariableSize. (Inherited from Acquisition.)
Top
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.AdditionalDataFolderChanged Event

Fired when the AdditionalDataFolder is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AdditionalDataFolderChanged
Public Event AdditionalDataFolderChanged As EventHandler
public:
 event EventHandler^ AdditionalDataFolderChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.AdditionalDataFolderValidating Event

Fired while validating the new value for AdditionalDataFolder.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AdditionalDataFolderValidating
Public Event AdditionalDataFolderValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AdditionalDataFolderValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.ArrayIndexChanged Event

Fired when the ArrayIndex is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ArrayIndexChanged
Public Event ArrayIndexChanged As EventHandler
public:
 event EventHandler^ ArrayIndexChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.ArrayIndexValidating Event

Fired while validating the new value for ArrayIndex.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ArrayIndexValidating
Public Event ArrayIndexValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ArrayIndexValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.DataIncludedChanged Event

Fired when the DataIncluded is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DataIncludedChanged
Public Event DataIncludedChanged As EventHandler
public:
 event EventHandler^ DataIncludedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.DataIncludedValidating Event

Fired while validating the new value for DataIncluded.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DataIncludedValidating
Public Event DataIncludedValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DataIncludedValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.NotInFileChanged Event

Fired when the NotInFile is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler NotInFileChanged
Public Event NotInFileChanged As EventHandler
public:
 event EventHandler^ NotInFileChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.NotInFileValidating Event

Fired while validating the new value for NotInFile.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> NotInFileValidating
Public Event NotInFileValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ NotInFileValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.OriginalArrayLengthChanged Event

Fired when the OriginalArrayLength is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OriginalArrayLengthChanged
Public Event OriginalArrayLengthChanged As EventHandler
public:
 event EventHandler^ OriginalArrayLengthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.OriginalArrayLengthValidating Event

Fired while validating the new value for OriginalArrayLength.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> OriginalArrayLengthValidating
Public Event OriginalArrayLengthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ OriginalArrayLengthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.PathChanged Event

Fired when the Path is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PathChanged
Public Event PathChanged As EventHandler
public:
 event EventHandler^ PathChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.PathValidating Event

Fired while validating the new value for Path.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PathValidating
Public Event PathValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PathValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.SvdxFileHandleChanged Event

Fired when the SvdxFileHandle is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SvdxFileHandleChanged
Public Event SvdxFileHandleChanged As EventHandler
public:
 event EventHandler^ SvdxFileHandleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.SvdxFileHandleValidating Event

Fired while validating the new value for SvdxFileHandle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SvdxFileHandleValidating
Public Event SvdxFileHandleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SvdxFileHandleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.SymbolNameChanged Event

Fired when the SymbolName is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SymbolNameChanged
Public Event SymbolNameChanged As EventHandler
public:
 event EventHandler^ SymbolNameChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition.SymbolNameValidating Event

Fired while validating the new value for SymbolName.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SymbolNameValidating
Public Event SymbolNameValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SymbolNameValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

SvdxAcquisition Class


SvdxAcquisition Fields

The SvdxAcquisition type exposes the following members.

Fields
 | Name | Description
Public field | TargetBrowserXML | (Inherited from Acquisition.)
Top
See Also

Reference

SvdxAcquisition Class


ThresholdCondition Class

Dynamic Style condition with one Threshold to compare value with
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelCondition
TwinCAT.Measurement.Scope.API.ModelThresholdCondition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ThresholdCondition : Condition
Public Class ThresholdCondition
    Inherits Condition
public ref class ThresholdCondition : public Condition

The ThresholdCondition type exposes the following members.

Constructors
 | Name | Description
Public method | ThresholdCondition | Create a new ThresholdCondition
Public method | ThresholdCondition(ThresholdCondition) | Create a new ThresholdCondition by copying Properties
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Condition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | InterpreterGUID | Gets or Sets the InterpreterGUID. (Inherited from Condition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Operator | Gets or Sets the Operator.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReferenceAcquisitionInterpreter | Gets or Sets the ReferenceAcquisitionInterpreter. (Inherited from Condition.)
Public property | ReusedAcquisitionOrInterpreter | Gets or Sets the ReusedAcquisitionOrInterpreter. (Inherited from Condition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Threshold | Gets or Sets the Threshold.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseChannelData | Gets or Sets the UseChannelData. (Inherited from Condition.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Commands (Inherited from Condition.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Udates the Attributes of the Properties (Inherited from Condition.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Condition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Condition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InterpreterGUIDChanged | Fired when the InterpreterGUID is changed. (Inherited from Condition.)
Public event | InterpreterGUIDValidating | Fired while validating the new value for InterpreterGUID. (Inherited from Condition.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OperatorChanged | Fired when the Operator is changed.
Public event | OperatorValidating | Fired while validating the new value for Operator.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReferenceAcquisitionInterpreterChanged | Fired when the ReferenceAcquisitionInterpreterChanged is changed. (Inherited from Condition.)
Public event | ReferenceAcquisitionInterpreterChanging | Fired before Changing the value of ReferenceAcquisitionInterpreter. (Inherited from Condition.)
Public event | ReferenceAcquisitionInterpreterValidating | Fired while validating the new value for ReferenceAcquisitionInterpreter. (Inherited from Condition.)
Public event | RefreshDisplay | Fired to Refresh Display (Inherited from Condition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReusedAcquisitionOrInterpreterChanged | Fired when the ReusedAcquisitionOrInterpreter is changed. (Inherited from Condition.)
Public event | ReusedAcquisitionOrInterpreterValidating | Fired while validating the new value for ReusedAcquisitionOrInterpreter. (Inherited from Condition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | ThresholdChanged | Fired when the Threshold is changed.
Public event | ThresholdValidating | Fired while validating the new value for Threshold.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseChannelDataChanged | Fired when the UseChannelData is changed. (Inherited from Condition.)
Public event | UseChannelDataValidating | Fired while validating the new value for UseChannelData. (Inherited from Condition.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ThresholdCondition Constructor

Overload List
 | Name | Description
Public method | ThresholdCondition | Create a new ThresholdCondition
Public method | ThresholdCondition(ThresholdCondition) | Create a new ThresholdCondition by copying Properties
Top
See Also

Reference

ThresholdCondition Class


ThresholdCondition Constructor

Create a new ThresholdCondition

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ThresholdCondition()
Public Sub New
public:
ThresholdCondition()
See Also

Reference

ThresholdCondition Class
ThresholdCondition Overload


ThresholdCondition Constructor (ThresholdCondition)

Create a new ThresholdCondition by copying Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ThresholdCondition(
    ThresholdCondition org
)
Public Sub New (
    org As ThresholdCondition
)
public:
ThresholdCondition(
    ThresholdCondition^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelThresholdCondition
ThresholdCondition to copy from
See Also

Reference

ThresholdCondition Class
ThresholdCondition Overload


ThresholdCondition Properties

The ThresholdCondition type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from Condition.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | InterpreterGUID | Gets or Sets the InterpreterGUID. (Inherited from Condition.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Operator | Gets or Sets the Operator.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReferenceAcquisitionInterpreter | Gets or Sets the ReferenceAcquisitionInterpreter. (Inherited from Condition.)
Public property | ReusedAcquisitionOrInterpreter | Gets or Sets the ReusedAcquisitionOrInterpreter. (Inherited from Condition.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Threshold | Gets or Sets the Threshold.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseChannelData | Gets or Sets the UseChannelData. (Inherited from Condition.)
Top
See Also

Reference

ThresholdCondition Class


ThresholdCondition.Operator Property

Gets or Sets the Operator.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public CompareOperators Operator { get; set; }
<BrowsableAttribute(true)>
Public Property Operator As CompareOperators
    Get
    Set
public:
[BrowsableAttribute(true)]
property CompareOperators Operator {
    CompareOperators get ();
    void set (CompareOperators value);
}

Property Value

Type: CompareOperators
See Also

Reference

ThresholdCondition Class


ThresholdCondition.Threshold Property

Gets or Sets the Threshold.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public double Threshold { get; set; }
<BrowsableAttribute(true)>
Public Property Threshold As Double
    Get
    Set
public:
[BrowsableAttribute(true)]
property double Threshold {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ThresholdCondition Class


ThresholdCondition Methods

The ThresholdCondition type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Commands (Inherited from Condition.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Udates the Attributes of the Properties (Inherited from Condition.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ThresholdCondition Class


ThresholdCondition Events

The ThresholdCondition type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from Condition.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from Condition.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InterpreterGUIDChanged | Fired when the InterpreterGUID is changed. (Inherited from Condition.)
Public event | InterpreterGUIDValidating | Fired while validating the new value for InterpreterGUID. (Inherited from Condition.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OperatorChanged | Fired when the Operator is changed.
Public event | OperatorValidating | Fired while validating the new value for Operator.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | ReferenceAcquisitionInterpreterChanged | Fired when the ReferenceAcquisitionInterpreterChanged is changed. (Inherited from Condition.)
Public event | ReferenceAcquisitionInterpreterChanging | Fired before Changing the value of ReferenceAcquisitionInterpreter. (Inherited from Condition.)
Public event | ReferenceAcquisitionInterpreterValidating | Fired while validating the new value for ReferenceAcquisitionInterpreter. (Inherited from Condition.)
Public event | RefreshDisplay | Fired to Refresh Display (Inherited from Condition.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReusedAcquisitionOrInterpreterChanged | Fired when the ReusedAcquisitionOrInterpreter is changed. (Inherited from Condition.)
Public event | ReusedAcquisitionOrInterpreterValidating | Fired while validating the new value for ReusedAcquisitionOrInterpreter. (Inherited from Condition.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | ThresholdChanged | Fired when the Threshold is changed.
Public event | ThresholdValidating | Fired while validating the new value for Threshold.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseChannelDataChanged | Fired when the UseChannelData is changed. (Inherited from Condition.)
Public event | UseChannelDataValidating | Fired while validating the new value for UseChannelData. (Inherited from Condition.)
Top
See Also

Reference

ThresholdCondition Class


ThresholdCondition.OperatorChanged Event

Fired when the Operator is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OperatorChanged
Public Event OperatorChanged As EventHandler
public:
 event EventHandler^ OperatorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ThresholdCondition Class


ThresholdCondition.OperatorValidating Event

Fired while validating the new value for Operator.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> OperatorValidating
Public Event OperatorValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ OperatorValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ThresholdCondition Class


ThresholdCondition.ThresholdChanged Event

Fired when the Threshold is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ThresholdChanged
Public Event ThresholdChanged As EventHandler
public:
 event EventHandler^ ThresholdChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ThresholdCondition Class


ThresholdCondition.ThresholdValidating Event

Fired while validating the new value for Threshold.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ThresholdValidating
Public Event ThresholdValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ThresholdValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

ThresholdCondition Class


TimeAxis Class

Model class for Time Axis
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAxis
TwinCAT.Measurement.Scope.API.ModelTimeAxis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TimeAxis : Axis
Public Class TimeAxis
    Inherits Axis
public ref class TimeAxis : public Axis

The TimeAxis type exposes the following members.

Constructors
 | Name | Description
Public method | TimeAxis | Create a new TimeAxis with an default Orientation
Public method | TimeAxis(TimeAxis) | Create a new TimeAxis by copying Properties from anther TimeAxis
Top
Properties
 | Name | Description
Public property | ActualTitle | Gets or Sets the ActualTitle. (Inherited from Axis.)
Public property | AspectRatioScaleFactor | Gets or Sets the AspectRatioScaleFactor. (Inherited from Axis.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Inverted | Gets or Sets the Inverted. (Inherited from Axis.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Logarithmic | Gets or Sets the Logarithmic. (Inherited from Axis.)
Public property | ManualMax | Gets or Sets the ManualMax. (Inherited from Axis.)
Public property | ManualMin | Gets or Sets the ManualMin. (Inherited from Axis.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Axis.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScalingMode | Gets or Sets the ScalingMode. (Inherited from Axis.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | (Inherited from Axis.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from Axis.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserSettingsAxisInstance | (Overrides AxisGetUserSettingsAxisInstance.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates Attributes of all Properties (Overrides AxisUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ActualTitleChanged | Fired when the ActualTitle is changed. (Inherited from Axis.)
Public event | ActualTitleValidating | Fired while validating the new value for ActualTitle. (Inherited from Axis.)
Public event | AspectRatioScaleFactorChanged | Fired when the AspectRatioScaleFactor is changed. (Inherited from Axis.)
Public event | AspectRatioScaleFactorValidating | Fired while validating the new value for AspectRatioScaleFactor. (Inherited from Axis.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DefaultRescale | Fired if the axis should rescale to default values (Inherited from Axis.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InvertedChanged | Fired when the Inverted is changed. (Inherited from Axis.)
Public event | InvertedValidating | Fired while validating the new value for Inverted. (Inherited from Axis.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LogarithmicChanged | Fired when the Logarithmic is changed. (Inherited from Axis.)
Public event | LogarithmicValidating | Fired while validating the new value for Logarithmic. (Inherited from Axis.)
Public event | ManualMaxChanged | Fired when the ManualMax is changed. (Inherited from Axis.)
Public event | ManualMaxValidating | Fired while validating the new value for ManualMax. (Inherited from Axis.)
Public event | ManualMinChanged | Fired when the ManualMin is changed. (Inherited from Axis.)
Public event | ManualMinValidating | Fired while validating the new value for ManualMin. (Inherited from Axis.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Axis.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Axis.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScalingModeChanged | Fired when the ScalingMode is changed. (Inherited from Axis.)
Public event | ScalingModeValidating | Fired while validating the new value for ScalingMode. (Inherited from Axis.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


TimeAxis Constructor

Overload List
 | Name | Description
Public method | TimeAxis | Create a new TimeAxis with an default Orientation
Public method | TimeAxis(TimeAxis) | Create a new TimeAxis by copying Properties from anther TimeAxis
Top
See Also

Reference

TimeAxis Class


TimeAxis Constructor

Create a new TimeAxis with an default Orientation

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TimeAxis()
Public Sub New
public:
TimeAxis()
See Also

Reference

TimeAxis Class
TimeAxis Overload


TimeAxis Constructor (TimeAxis)

Create a new TimeAxis by copying Properties from anther TimeAxis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TimeAxis(
    TimeAxis Axis
)
Public Sub New (
    Axis As TimeAxis
)
public:
TimeAxis(
    TimeAxis^ Axis
)

Parameters

Axis
Type: TwinCAT.Measurement.Scope.API.ModelTimeAxis
See Also

Reference

TimeAxis Class
TimeAxis Overload


TimeAxis Properties

The TimeAxis type exposes the following members.

Properties
 | Name | Description
Public property | ActualTitle | Gets or Sets the ActualTitle. (Inherited from Axis.)
Public property | AspectRatioScaleFactor | Gets or Sets the AspectRatioScaleFactor. (Inherited from Axis.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Inverted | Gets or Sets the Inverted. (Inherited from Axis.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Logarithmic | Gets or Sets the Logarithmic. (Inherited from Axis.)
Public property | ManualMax | Gets or Sets the ManualMax. (Inherited from Axis.)
Public property | ManualMin | Gets or Sets the ManualMin. (Inherited from Axis.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Axis.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScalingMode | Gets or Sets the ScalingMode. (Inherited from Axis.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | (Inherited from Axis.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from Axis.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TimeAxis Class


TimeAxis Methods

The TimeAxis type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserSettingsAxisInstance | (Overrides AxisGetUserSettingsAxisInstance.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates Attributes of all Properties (Overrides AxisUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TimeAxis Class


TimeAxis.GetUserSettingsAxisInstance Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override Axis GetUserSettingsAxisInstance()
Public Overrides Function GetUserSettingsAxisInstance As Axis
public:
virtual Axis^ GetUserSettingsAxisInstance() override

Return Value

Type: Axis
See Also

Reference

TimeAxis Class


TimeAxis.UpdatePropertyAttributes Method

Updates Attributes of all Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

TimeAxis Class


TimeAxis Events

The TimeAxis type exposes the following members.

Events
 | Name | Description
Public event | ActualTitleChanged | Fired when the ActualTitle is changed. (Inherited from Axis.)
Public event | ActualTitleValidating | Fired while validating the new value for ActualTitle. (Inherited from Axis.)
Public event | AspectRatioScaleFactorChanged | Fired when the AspectRatioScaleFactor is changed. (Inherited from Axis.)
Public event | AspectRatioScaleFactorValidating | Fired while validating the new value for AspectRatioScaleFactor. (Inherited from Axis.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DefaultRescale | Fired if the axis should rescale to default values (Inherited from Axis.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InvertedChanged | Fired when the Inverted is changed. (Inherited from Axis.)
Public event | InvertedValidating | Fired while validating the new value for Inverted. (Inherited from Axis.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LogarithmicChanged | Fired when the Logarithmic is changed. (Inherited from Axis.)
Public event | LogarithmicValidating | Fired while validating the new value for Logarithmic. (Inherited from Axis.)
Public event | ManualMaxChanged | Fired when the ManualMax is changed. (Inherited from Axis.)
Public event | ManualMaxValidating | Fired while validating the new value for ManualMax. (Inherited from Axis.)
Public event | ManualMinChanged | Fired when the ManualMin is changed. (Inherited from Axis.)
Public event | ManualMinValidating | Fired while validating the new value for ManualMin. (Inherited from Axis.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Axis.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Axis.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScalingModeChanged | Fired when the ScalingMode is changed. (Inherited from Axis.)
Public event | ScalingModeValidating | Fired while validating the new value for ScalingMode. (Inherited from Axis.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TimeAxis Class


TimeMarker Class

Model class for Scope Time Marker
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelMarker
TwinCAT.Measurement.Scope.API.ModelTimeMarker
TwinCAT.Measurement.Scope.API.ModelImageMarker
TwinCAT.Measurement.Scope.API.ModelPropertyUpdaterMarker

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TimeMarker : Marker
Public Class TimeMarker
    Inherits Marker
public ref class TimeMarker : public Marker

The TimeMarker type exposes the following members.

Constructors
 | Name | Description
Public method | TimeMarker | Create a new TimeMarker with default Values
Public method | TimeMarker(TimeMarker) | Create a new TimeMarker by copying properties from another marker
Top
Properties
 | Name | Description
Public property | AttachToAxis | Gets or Sets the AttachToAxis. If AttachToAxis is True --> The position is an absolut value of this axis. If AttachToAxis is False --> The position is an relative value of the displayed axis. (Inherited from Marker.)
Public property | AttachToAxisBrowsable | (Inherited from Marker.)
Public property | Bandwidth | Gets or Sets the Bandwidth. (Inherited from Marker.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Marker.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetNearestPosition | Get Field for GetNearestPosition Delegate (Inherited from Marker.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineStyle | Gets or Sets the LineStyle. (Inherited from Marker.)
Public property | Locked | Gets or Sets the Locked. (Inherited from Marker.)
Public property | Marker3DType | Gets or Sets the Marker3DType.
Public property | MarkerType | Gets or Sets the MarkerType.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Marker.)
Public property | Position | Gets or Sets the Position. (Inherited from Marker.)
Public property | PositionPropertyUpdater | (Inherited from Marker.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowFullArray | Gets or Sets the ShowFullArray.
Public property | ShowPosition | Gets or Sets the ShowPosition. (Inherited from Marker.)
Public property | ShowTitle | Gets or Sets the ShowTitle. (Inherited from Marker.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimePosition | Gets or Sets the TimePosition. (Inherited from Marker.)
Public property | Title | Gets or Sets the Title (Inherited from Marker.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | ValuePrecision | Gets or Sets the ValuePrecision. (Inherited from Marker.)
Public property | Visible | Gets or Sets the Visible. (Inherited from Marker.)
Public property | Width | Gets or Sets the Width. (Inherited from Marker.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddValue | (Inherited from Marker.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | CalcTimePosition | Calculate the current timeposition with the given position (Inherited from Marker.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ContainsChannelValue | Obsolete. Check if the Marker has an value from the channel (Inherited from Marker.)
Public method | ContainsMemberValue | Check if the Marker has an value from the member (Inherited from Marker.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllValues | Returns a copy of the ValueDictionary (Inherited from Marker.)
Public method | GetChannelValue | Obsolete. Gets the channelvalue of the Marker (Inherited from Marker.)
Public method | GetCommands | Gets the possible commands (Overrides MarkerGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberValue | Gets the membervalue of the Marker (Inherited from Marker.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubInterpreterValue | (Inherited from Marker.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Get the Values for this Marker as string (Inherited from Marker.)
Public method | Highlight | Highlight the Graph of this channel (Inherited from Marker.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RefreshValue | (Inherited from Marker.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts a Marker to string (Inherited from Marker.)
Public method | UpdatePropertyAttributes | Updates the Attributes of all Properties (Overrides MarkerUpdatePropertyAttributes.)
Public method | UpdateTimePosition | Calculate the current timeposition with the given position (Inherited from Marker.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AttachToAxisChanged | Fired when the AttachToAxis is changed. (Inherited from Marker.)
Public event | AttachToAxisValidating | Fired while validating the new value for AttachToAxis. (Inherited from Marker.)
Public event | BandwidthChanged | Fired when the Bandwidth is changed. (Inherited from Marker.)
Public event | BandwidthValidating | Fired while validating the new value for Bandwidth. (Inherited from Marker.)
Public event | BeforePositionChanged | Fired before the position changed (Inherited from Marker.)
Public event | CenterToScreen | Event fired to Center the Marker to Screen
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightEvent | Event fired when the marker should be highlighted (Inherited from Marker.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineStyleChanged | Fired when the LineStyle is changed. (Inherited from Marker.)
Public event | LineStyleValidating | Fired while validating the new value for LineStyle. (Inherited from Marker.)
Public event | LockedChanged | Fired when the Locked is changed. (Inherited from Marker.)
Public event | LockedValidating | Fired while validating the new value for Locked. (Inherited from Marker.)
Public event | Marker3DTypeChanged | Fired when the Marker3DType is changed.
Public event | Marker3DTypeValidating | Fired while validating the new value for Marker3DType.
Public event | MarkerTypeChanged | Fired when the MarkerType is changed.
Public event | MarkerTypeValidating | Fired while validating the new value for MarkerType.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NewMarkerValues | Event fired when Values has Changed (Inherited from Marker.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Marker.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Marker.)
Public event | PositionChanged | Fired when the Position is changed. (Inherited from Marker.)
Public event | PositionValidating | Fired while validating the new value for Position. (Inherited from Marker.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshClientTimePosition | Event fired to check, if the Chart is running or stopped
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowFullArrayChanged | Fired when the ShowFullArray is changed.
Public event | ShowFullArrayChanging | Fired while changing the ShowFullArray.
Public event | ShowFullArrayValidating | Fired while validating the new value for ShowFullArray.
Public event | ShowPositionChanged | Fired when the ShowPosition is changed. (Inherited from Marker.)
Public event | ShowPositionValidating | Fired while validating the new value for ShowPosition. (Inherited from Marker.)
Public event | ShowTitleChanged | Fired when the ShowTitle is changed. (Inherited from Marker.)
Public event | ShowTitleValidating | Fired while validating the new value for ShowTitle. (Inherited from Marker.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimePositionChanged | Fired when the TimePosition is changed. (Inherited from Marker.)
Public event | TimePositionValidating | Fired while validating the new value for TimePosition. (Inherited from Marker.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | ValueDictChanged | Fired when the ValueDict is changed. (Inherited from Marker.)
Public event | ValueDictValidating | Fired while validating the new value for ValueDict. (Inherited from Marker.)
Public event | ValuePrecisionChanged | Fired when the ValuePrecision is changed. (Inherited from Marker.)
Public event | ValuePrecisionValidating | Fired while validating the new value for ValuePrecision. (Inherited from Marker.)
Public event | VisibleChanged | Fired when the Visible is changed. (Inherited from Marker.)
Public event | VisibleValidating | Fired while validating the new value for Visible. (Inherited from Marker.)
Public event | WidthChanged | Fired when the Width is changed. (Inherited from Marker.)
Public event | WidthValidating | Fired while validating the new value for Width. (Inherited from Marker.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


TimeMarker Constructor

Overload List
 | Name | Description
Public method | TimeMarker | Create a new TimeMarker with default Values
Public method | TimeMarker(TimeMarker) | Create a new TimeMarker by copying properties from another marker
Top
See Also

Reference

TimeMarker Class


TimeMarker Constructor

Create a new TimeMarker with default Values

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TimeMarker()
Public Sub New
public:
TimeMarker()
See Also

Reference

TimeMarker Class
TimeMarker Overload


TimeMarker Constructor (TimeMarker)

Create a new TimeMarker by copying properties from another marker

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TimeMarker(
    TimeMarker timeMarker
)
Public Sub New (
    timeMarker As TimeMarker
)
public:
TimeMarker(
    TimeMarker^ timeMarker
)

Parameters

timeMarker
Type: TwinCAT.Measurement.Scope.API.ModelTimeMarker
Marker to copy from
See Also

Reference

TimeMarker Class
TimeMarker Overload


TimeMarker Properties

The TimeMarker type exposes the following members.

Properties
 | Name | Description
Public property | AttachToAxis | Gets or Sets the AttachToAxis. If AttachToAxis is True --> The position is an absolut value of this axis. If AttachToAxis is False --> The position is an relative value of the displayed axis. (Inherited from Marker.)
Public property | AttachToAxisBrowsable | (Inherited from Marker.)
Public property | Bandwidth | Gets or Sets the Bandwidth. (Inherited from Marker.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Marker.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetNearestPosition | Get Field for GetNearestPosition Delegate (Inherited from Marker.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | LineStyle | Gets or Sets the LineStyle. (Inherited from Marker.)
Public property | Locked | Gets or Sets the Locked. (Inherited from Marker.)
Public property | Marker3DType | Gets or Sets the Marker3DType.
Public property | MarkerType | Gets or Sets the MarkerType.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Marker.)
Public property | Position | Gets or Sets the Position. (Inherited from Marker.)
Public property | PositionPropertyUpdater | (Inherited from Marker.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowFullArray | Gets or Sets the ShowFullArray.
Public property | ShowPosition | Gets or Sets the ShowPosition. (Inherited from Marker.)
Public property | ShowTitle | Gets or Sets the ShowTitle. (Inherited from Marker.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | TimePosition | Gets or Sets the TimePosition. (Inherited from Marker.)
Public property | Title | Gets or Sets the Title (Inherited from Marker.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | ValuePrecision | Gets or Sets the ValuePrecision. (Inherited from Marker.)
Public property | Visible | Gets or Sets the Visible. (Inherited from Marker.)
Public property | Width | Gets or Sets the Width. (Inherited from Marker.)
Top
See Also

Reference

TimeMarker Class


TimeMarker.Marker3DType Property

Gets or Sets the Marker3DType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[TypeConverterAttribute(typeof(Marker3DPartsConverter))]
public Marker3DParts Marker3DType { get; set; }
<TypeConverterAttribute(GetType(Marker3DPartsConverter))>
Public Property Marker3DType As Marker3DParts
    Get
    Set
public:
[TypeConverterAttribute(typeof(Marker3DPartsConverter))]
property Marker3DParts Marker3DType {
    Marker3DParts get ();
    void set (Marker3DParts value);
}

Property Value

Type: Marker3DParts
See Also

Reference

TimeMarker Class


TimeMarker.MarkerType Property

Gets or Sets the MarkerType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MarkerType MarkerType { get; set; }
Public Property MarkerType As MarkerType
    Get
    Set
public:
property MarkerType MarkerType {
    MarkerType get ();
    void set (MarkerType value);
}

Property Value

Type: MarkerType
See Also

Reference

TimeMarker Class


TimeMarker.ShowFullArray Property

Gets or Sets the ShowFullArray.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool ShowFullArray { get; set; }
Public Property ShowFullArray As Boolean
    Get
    Set
public:
property bool ShowFullArray {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TimeMarker Class


TimeMarker Methods

The TimeMarker type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddValue | (Inherited from Marker.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | CalcTimePosition | Calculate the current timeposition with the given position (Inherited from Marker.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ContainsChannelValue | Obsolete. Check if the Marker has an value from the channel (Inherited from Marker.)
Public method | ContainsMemberValue | Check if the Marker has an value from the member (Inherited from Marker.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllValues | Returns a copy of the ValueDictionary (Inherited from Marker.)
Public method | GetChannelValue | Obsolete. Gets the channelvalue of the Marker (Inherited from Marker.)
Public method | GetCommands | Gets the possible commands (Overrides MarkerGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberValue | Gets the membervalue of the Marker (Inherited from Marker.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubInterpreterValue | (Inherited from Marker.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Get the Values for this Marker as string (Inherited from Marker.)
Public method | Highlight | Highlight the Graph of this channel (Inherited from Marker.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RefreshValue | (Inherited from Marker.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts a Marker to string (Inherited from Marker.)
Public method | UpdatePropertyAttributes | Updates the Attributes of all Properties (Overrides MarkerUpdatePropertyAttributes.)
Public method | UpdateTimePosition | Calculate the current timeposition with the given position (Inherited from Marker.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TimeMarker Class


TimeMarker.GetCommands Method

Gets the possible commands

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
See Also

Reference

TimeMarker Class


TimeMarker.UpdatePropertyAttributes Method

Updates the Attributes of all Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

TimeMarker Class


TimeMarker Events

The TimeMarker type exposes the following members.

Events
 | Name | Description
Public event | AttachToAxisChanged | Fired when the AttachToAxis is changed. (Inherited from Marker.)
Public event | AttachToAxisValidating | Fired while validating the new value for AttachToAxis. (Inherited from Marker.)
Public event | BandwidthChanged | Fired when the Bandwidth is changed. (Inherited from Marker.)
Public event | BandwidthValidating | Fired while validating the new value for Bandwidth. (Inherited from Marker.)
Public event | BeforePositionChanged | Fired before the position changed (Inherited from Marker.)
Public event | CenterToScreen | Event fired to Center the Marker to Screen
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightEvent | Event fired when the marker should be highlighted (Inherited from Marker.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LineStyleChanged | Fired when the LineStyle is changed. (Inherited from Marker.)
Public event | LineStyleValidating | Fired while validating the new value for LineStyle. (Inherited from Marker.)
Public event | LockedChanged | Fired when the Locked is changed. (Inherited from Marker.)
Public event | LockedValidating | Fired while validating the new value for Locked. (Inherited from Marker.)
Public event | Marker3DTypeChanged | Fired when the Marker3DType is changed.
Public event | Marker3DTypeValidating | Fired while validating the new value for Marker3DType.
Public event | MarkerTypeChanged | Fired when the MarkerType is changed.
Public event | MarkerTypeValidating | Fired while validating the new value for MarkerType.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | NewMarkerValues | Event fired when Values has Changed (Inherited from Marker.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Marker.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Marker.)
Public event | PositionChanged | Fired when the Position is changed. (Inherited from Marker.)
Public event | PositionValidating | Fired while validating the new value for Position. (Inherited from Marker.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshClientTimePosition | Event fired to check, if the Chart is running or stopped
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ShowFullArrayChanged | Fired when the ShowFullArray is changed.
Public event | ShowFullArrayChanging | Fired while changing the ShowFullArray.
Public event | ShowFullArrayValidating | Fired while validating the new value for ShowFullArray.
Public event | ShowPositionChanged | Fired when the ShowPosition is changed. (Inherited from Marker.)
Public event | ShowPositionValidating | Fired while validating the new value for ShowPosition. (Inherited from Marker.)
Public event | ShowTitleChanged | Fired when the ShowTitle is changed. (Inherited from Marker.)
Public event | ShowTitleValidating | Fired while validating the new value for ShowTitle. (Inherited from Marker.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimePositionChanged | Fired when the TimePosition is changed. (Inherited from Marker.)
Public event | TimePositionValidating | Fired while validating the new value for TimePosition. (Inherited from Marker.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | ValueDictChanged | Fired when the ValueDict is changed. (Inherited from Marker.)
Public event | ValueDictValidating | Fired while validating the new value for ValueDict. (Inherited from Marker.)
Public event | ValuePrecisionChanged | Fired when the ValuePrecision is changed. (Inherited from Marker.)
Public event | ValuePrecisionValidating | Fired while validating the new value for ValuePrecision. (Inherited from Marker.)
Public event | VisibleChanged | Fired when the Visible is changed. (Inherited from Marker.)
Public event | VisibleValidating | Fired while validating the new value for Visible. (Inherited from Marker.)
Public event | WidthChanged | Fired when the Width is changed. (Inherited from Marker.)
Public event | WidthValidating | Fired while validating the new value for Width. (Inherited from Marker.)
Top
See Also

Reference

TimeMarker Class


TimeMarker.CenterToScreen Event

Event fired to Center the Marker to Screen

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CenterToScreen
Public Event CenterToScreen As EventHandler
public:
 event EventHandler^ CenterToScreen {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TimeMarker Class


TimeMarker.Marker3DTypeChanged Event

Fired when the Marker3DType is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler Marker3DTypeChanged
Public Event Marker3DTypeChanged As EventHandler
public:
 event EventHandler^ Marker3DTypeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TimeMarker Class


TimeMarker.Marker3DTypeValidating Event

Fired while validating the new value for Marker3DType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> Marker3DTypeValidating
Public Event Marker3DTypeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ Marker3DTypeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TimeMarker Class


TimeMarker.MarkerTypeChanged Event

Fired when the MarkerType is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler MarkerTypeChanged
Public Event MarkerTypeChanged As EventHandler
public:
 event EventHandler^ MarkerTypeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TimeMarker Class


TimeMarker.MarkerTypeValidating Event

Fired while validating the new value for MarkerType.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> MarkerTypeValidating
Public Event MarkerTypeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ MarkerTypeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TimeMarker Class


TimeMarker.RefreshClientTimePosition Event

Event fired to check, if the Chart is running or stopped

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> RefreshClientTimePosition
Public Event RefreshClientTimePosition As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ RefreshClientTimePosition {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TimeMarker Class


TimeMarker.ShowFullArrayChanged Event

Fired when the ShowFullArray is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowFullArrayChanged
Public Event ShowFullArrayChanged As EventHandler
public:
 event EventHandler^ ShowFullArrayChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TimeMarker Class


TimeMarker.ShowFullArrayChanging Event

Fired while changing the ShowFullArray.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ShowFullArrayChanging
Public Event ShowFullArrayChanging As EventHandler
public:
 event EventHandler^ ShowFullArrayChanging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TimeMarker Class


TimeMarker.ShowFullArrayValidating Event

Fired while validating the new value for ShowFullArray.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ShowFullArrayValidating
Public Event ShowFullArrayValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ShowFullArrayValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TimeMarker Class


TimeShiftStyle Class

Class to Store a TimeShift for an YT-Channel
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelTimeShiftStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TimeShiftStyle : ScopeMemberBase
Public Class TimeShiftStyle
    Inherits ScopeMemberBase
public ref class TimeShiftStyle : public ScopeMemberBase

The TimeShiftStyle type exposes the following members.

Constructors
 | Name | Description
Public method | TimeShiftStyle | Create a new TimeShiftStyle
Public method | TimeShiftStyle(TimeShiftStyle) | Create a new TimeShiftStyle by Copying Properties from another TimeShiftStyle
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | TimeShift | Gets or Sets the TimeShift.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of all Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | BeforeTimeShiftChanged | Fired before the TimeShift changed
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TimeShiftChanged | Fired when the TimeShift is changed.
Public event | TimeShiftValidating | Fired while validating the new value for TimeShift.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


TimeShiftStyle Constructor

Overload List
 | Name | Description
Public method | TimeShiftStyle | Create a new TimeShiftStyle
Public method | TimeShiftStyle(TimeShiftStyle) | Create a new TimeShiftStyle by Copying Properties from another TimeShiftStyle
Top
See Also

Reference

TimeShiftStyle Class


TimeShiftStyle Constructor

Create a new TimeShiftStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TimeShiftStyle()
Public Sub New
public:
TimeShiftStyle()
See Also

Reference

TimeShiftStyle Class
TimeShiftStyle Overload


TimeShiftStyle Constructor (TimeShiftStyle)

Create a new TimeShiftStyle by Copying Properties from another TimeShiftStyle

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TimeShiftStyle(
    TimeShiftStyle org
)
Public Sub New (
    org As TimeShiftStyle
)
public:
TimeShiftStyle(
    TimeShiftStyle^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelTimeShiftStyle
See Also

Reference

TimeShiftStyle Class
TimeShiftStyle Overload


TimeShiftStyle Properties

The TimeShiftStyle type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | TimeShift | Gets or Sets the TimeShift.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TimeShiftStyle Class


TimeShiftStyle.TimeShift Property

Gets or Sets the TimeShift.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long TimeShift { get; set; }
<BrowsableAttribute(true)>
Public Property TimeShift As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long TimeShift {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

TimeShiftStyle Class


TimeShiftStyle Methods

The TimeShiftStyle type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Updates the Attributes of all Properties (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TimeShiftStyle Class


TimeShiftStyle.UpdatePropertyAttributes Method

Updates the Attributes of all Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

TimeShiftStyle Class


TimeShiftStyle Events

The TimeShiftStyle type exposes the following members.

Events
 | Name | Description
Public event | BeforeTimeShiftChanged | Fired before the TimeShift changed
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TimeShiftChanged | Fired when the TimeShift is changed.
Public event | TimeShiftValidating | Fired while validating the new value for TimeShift.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TimeShiftStyle Class


TimeShiftStyle.BeforeTimeShiftChanged Event

Fired before the TimeShift changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeTimeShiftChanged
Public Event BeforeTimeShiftChanged As EventHandler
public:
 event EventHandler^ BeforeTimeShiftChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TimeShiftStyle Class


TimeShiftStyle.TimeShiftChanged Event

Fired when the TimeShift is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TimeShiftChanged
Public Event TimeShiftChanged As EventHandler
public:
 event EventHandler^ TimeShiftChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TimeShiftStyle Class


TimeShiftStyle.TimeShiftValidating Event

Fired while validating the new value for TimeShift.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TimeShiftValidating
Public Event TimeShiftValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TimeShiftValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TimeShiftStyle Class


TimeTriggerSet Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelTriggerSet
TwinCAT.Measurement.Scope.API.ModelServerTriggerSet
TwinCAT.Measurement.Scope.API.ModelTimeTriggerSet

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TimeTriggerSet : ServerTriggerSet
Public Class TimeTriggerSet
    Inherits ServerTriggerSet
public ref class TimeTriggerSet : public ServerTriggerSet

The TimeTriggerSet type exposes the following members.

Constructors
 | Name | Description
Public method | TimeTriggerSet | Initializes a new instance of the TimeTriggerSet class
Public method | TimeTriggerSet(TimeTriggerSet) | Initializes a new instance of the TimeTriggerSet class
Top
Properties
 | Name | Description
Public property | ClientTriggerHandle | Gets or Sets the ClientTriggerHandle. (Inherited from TriggerSet.)
Public property | CombineOption | Gets or Sets the CombineOption. (Inherited from ServerTriggerSet.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from TriggerSet.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GroupHandle | Gets or Sets the GroupHandle. (Inherited from TriggerSet.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Interval | Gets or Sets the Interval.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsReleased | Gets or Sets the IsReleased. (Inherited from TriggerSet.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | BindToGroup | (Overrides ServerTriggerSetBindToGroup(IClientTriggerGroup, Boolean).)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Menucommands for thie Element (Inherited from ServerTriggerSet.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | ManualSetReleased | Release Trigger manual (Inherited from ServerTriggerSet.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | (Overrides ServerTriggerSetUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ClientTriggerHandleChanged | Fired when the ClientTriggerHandle is changed. (Inherited from TriggerSet.)
Public event | ClientTriggerHandleValidating | Fired while validating the new value for ClientTriggerHandle. (Inherited from TriggerSet.)
Public event | CombineOptionChanged | Fired when the CombineOption is changed. (Inherited from ServerTriggerSet.)
Public event | CombineOptionValidating | Fired while validating the new value for CombineOption. (Inherited from ServerTriggerSet.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from TriggerSet.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from TriggerSet.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GroupHandleChanged | Fired when the GroupHandle is changed. (Inherited from TriggerSet.)
Public event | GroupHandleValidating | Fired while validating the new value for GroupHandle. (Inherited from TriggerSet.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IntervalChanged | Fired when the Interval is changed.
Public event | IntervalValidating | Fired while validating the new value for Interval.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsReleasedChanged | Fired when the IsReleased is changed. (Inherited from TriggerSet.)
Public event | IsReleasedValidating | Fired while validating the new value for IsReleased. (Inherited from TriggerSet.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


TimeTriggerSet Constructor

Overload List
 | Name | Description
Public method | TimeTriggerSet | Initializes a new instance of the TimeTriggerSet class
Public method | TimeTriggerSet(TimeTriggerSet) | Initializes a new instance of the TimeTriggerSet class
Top
See Also

Reference

TimeTriggerSet Class


TimeTriggerSet Constructor

Initializes a new instance of the TimeTriggerSet class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TimeTriggerSet()
Public Sub New
public:
TimeTriggerSet()
See Also

Reference

TimeTriggerSet Class
TimeTriggerSet Overload


TimeTriggerSet Constructor (TimeTriggerSet)

Initializes a new instance of the TimeTriggerSet class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TimeTriggerSet(
    TimeTriggerSet org
)
Public Sub New (
    org As TimeTriggerSet
)
public:
TimeTriggerSet(
    TimeTriggerSet^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelTimeTriggerSet
See Also

Reference

TimeTriggerSet Class
TimeTriggerSet Overload


TimeTriggerSet Properties

The TimeTriggerSet type exposes the following members.

Properties
 | Name | Description
Public property | ClientTriggerHandle | Gets or Sets the ClientTriggerHandle. (Inherited from TriggerSet.)
Public property | CombineOption | Gets or Sets the CombineOption. (Inherited from ServerTriggerSet.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled. (Inherited from TriggerSet.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GroupHandle | Gets or Sets the GroupHandle. (Inherited from TriggerSet.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Interval | Gets or Sets the Interval.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsReleased | Gets or Sets the IsReleased. (Inherited from TriggerSet.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TimeTriggerSet Class


TimeTriggerSet.Interval Property

Gets or Sets the Interval.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long Interval { get; set; }
<BrowsableAttribute(true)>
Public Property Interval As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long Interval {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

TimeTriggerSet Class


TimeTriggerSet Methods

The TimeTriggerSet type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | BindToGroup | (Overrides ServerTriggerSetBindToGroup(IClientTriggerGroup, Boolean).)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Menucommands for thie Element (Inherited from ServerTriggerSet.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | ManualSetReleased | Release Trigger manual (Inherited from ServerTriggerSet.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | (Overrides ServerTriggerSetUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TimeTriggerSet Class


TimeTriggerSet.BindToGroup Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void BindToGroup(
    IClientTriggerGroup TriggerGroup,
    bool reattach = false
)
Public Overrides Sub BindToGroup (
    TriggerGroup As IClientTriggerGroup,
    Optional reattach As Boolean = false
)
public:
virtual void BindToGroup(
    IClientTriggerGroup^ TriggerGroup,
    bool reattach = false
) override

Parameters

TriggerGroup
Type: IClientTriggerGroup
reattach (Optional)
Type: SystemBoolean
See Also

Reference

TimeTriggerSet Class


TimeTriggerSet.UpdatePropertyAttributes Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

TimeTriggerSet Class


TimeTriggerSet Events

The TimeTriggerSet type exposes the following members.

Events
 | Name | Description
Public event | ClientTriggerHandleChanged | Fired when the ClientTriggerHandle is changed. (Inherited from TriggerSet.)
Public event | ClientTriggerHandleValidating | Fired while validating the new value for ClientTriggerHandle. (Inherited from TriggerSet.)
Public event | CombineOptionChanged | Fired when the CombineOption is changed. (Inherited from ServerTriggerSet.)
Public event | CombineOptionValidating | Fired while validating the new value for CombineOption. (Inherited from ServerTriggerSet.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed. (Inherited from TriggerSet.)
Public event | EnabledValidating | Fired while validating the new value for Enabled. (Inherited from TriggerSet.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GroupHandleChanged | Fired when the GroupHandle is changed. (Inherited from TriggerSet.)
Public event | GroupHandleValidating | Fired while validating the new value for GroupHandle. (Inherited from TriggerSet.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IntervalChanged | Fired when the Interval is changed.
Public event | IntervalValidating | Fired while validating the new value for Interval.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsReleasedChanged | Fired when the IsReleased is changed. (Inherited from TriggerSet.)
Public event | IsReleasedValidating | Fired while validating the new value for IsReleased. (Inherited from TriggerSet.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TimeTriggerSet Class


TimeTriggerSet.IntervalChanged Event

Fired when the Interval is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IntervalChanged
Public Event IntervalChanged As EventHandler
public:
 event EventHandler^ IntervalChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TimeTriggerSet Class


TimeTriggerSet.IntervalValidating Event

Fired while validating the new value for Interval.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IntervalValidating
Public Event IntervalValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IntervalValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TimeTriggerSet Class


TriggerGroup Class

Trigger Group Class in TwinCAT 3 Scope API Model
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelTriggerGroup

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TriggerGroup : ScopeMemberContainerBase
Public Class TriggerGroup
    Inherits ScopeMemberContainerBase
public ref class TriggerGroup : public ScopeMemberContainerBase

The TriggerGroup type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerGroup | Create a new TriggerGroup
Public method | TriggerGroup(TriggerGroup) | Copy Properties of a TriggerGroup to a new object
Top
Properties
 | Name | Description
Public property | AbsoluteSinglePicturePath |
Public property | AutoDeleteCapacity | Gets or Sets the AutoDeleteCapacity.
Public property | AutoDeleteMode | Gets or Sets the AutoDeleteMode.
Public property | AutoDeleteOlderThan | Gets or Sets the AutoDeleteOlderThan.
Public property | Category | Gets or Sets the Category.
Public property | CategoryContentValue | Gets or Sets the CategoryContentValue.
Public property | ClearChart | Gets or Sets the ClearChart.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ConnectedCharts | Gets or Sets the ConnectedCharts.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisconnectedChartGuids | Gets or Sets the DisconnectedChartGuids.
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled.
Public property | ExportConfiguration | Gets or Sets the ExportConfiguration.
Public property | ExportConfigurationString | Gets or Sets the ExportConfigurationString.
Public property | ExportFileNameMask | Gets or Sets the ExportFileNameMask.
Public property | ExportPath | Gets or Sets the ExportPath.
Public property | ExportTimeMode | Gets or Sets the ExportTimeMode.
Public property | ExportTimeRange | Gets or Sets the ExportTimeRange.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FolderPath | Gets or Sets the FolderPath.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | ImageDirPath |
Public property | ImageSize | Gets or Sets the ImageSize.
Public property | IncludeMarkerWindow | Gets or Sets the IncludeMarkerWindow.
Public property | IncludeTriggerWindow | Gets or Sets the IncludeTriggerWindow.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsReleased | Gets or Sets the IsReleased.
Public property | IsSilent | Gets or Sets the IsSilent.
Public property | LastRelease | Gets or Sets the LastRelease.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PosttriggerTime | Gets or Sets the PosttriggerTime.
Public property | PretriggerTime | Gets or Sets the PretriggerTime.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReleaseInfoCapacity | Gets or Sets the ReleaseInfoCapacity.
Public property | ReportChartBackground | Gets or Sets the ReportChartBackground.
Public property | ReportingTimeMode | Gets or Sets the ReportingTimeMode.
Public property | ReportingTimeRange | Gets or Sets the ReportingTimeRange.
Public property | ReportingTriggerConfigAlias | Gets or Sets the ReportingTriggerConfigAlias.
Public property | ReportingTripletValue | Gets or Sets the ReportingTripletValue.
Public property | RestartRecord | Gets or Sets the RestartRecord.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SeparateDirectoryPerExport | Gets or Sets the SeparateDirectoryPerExport.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | SubSaveLength | Gets or Sets the SubSaveLength.
Public property | SubSaveNameMask | Gets or Sets the SubSaveNameMask.
Public property | SubSaveOnlyConnectedCharts | Gets or Sets the SubSaveOnlyConnectedCharts.
Public property | SubSavePath | Gets or Sets the SubSavePath.
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerAction | Gets or Sets the TriggerAction.
Public property | TriggerPrePercent | Gets or Sets the TriggerPrePercent.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UsePostTrigger | Gets or Sets the UsePostTrigger.
Public property | UsePreTrigger | Gets or Sets the UsePreTrigger.
Public property | UseServerFileSystem | Gets or Sets the UseServerFileSystem.
Public property | Visible | Gets or Sets the Visible.
Public property | VisibleReleaseInfoCapacity | Gets or Sets the VisibleReleaseInfoCapacity.
Top
Methods
 | Name | Description
Public method | AddMember | Adds a new Member to the TriggerGroup (Overrides MeasurementMemberContainerBaseAddMember(MeasurementMemberBase).)
Public method | AddMemberRange | Adds a Range of Member to the SubMemberList (Overrides MeasurementMemberContainerBaseAddMemberRange(MeasurementMemberBase).)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | ClearTriggerReleaseInfos | Removes all Trigger ReleaseInfos
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | DehighlightTriggerInfos | Dehighlight all TriggerReleaseInfos
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Menucommands for thie Element (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetLatestImage |
Public method | GetReleaseInfoRange | Return a range of ReleaseInfos which are realesed in the Time Range
Public method | GetReportAutomaticArgs |
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTriggerReleaseInfos | Return all TriggerReleaseInfos
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReportingTriggerEventAction | Return if Trigger Action is a Reporting Trigger Action
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseDehighlightAllTriggerInfos | Dehighlight all TriggerReleaseInfos in the full project
Public method | RaiseTriggerInfoSelected | Raises the TriggerReleaseInfoSelected event
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Removes a Member from the SubMemberlist (Overrides MeasurementMemberContainerBaseRemoveMember(MeasurementMemberBase).)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimmTriggerRealesInfos | Removes all TriggerReleaseInfos outside the given TimeRange
Public method | UpdatePropertyAttributes | Update PropertyAttributes in dhe PropertyGrid (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | AutoDeleteCapacityChanged | Fired when the AutoDeleteCapacity is changed.
Public event | AutoDeleteCapacityValidating | Fired while validating the new value for AutoDeleteCapacity.
Public event | AutoDeleteFileLoss | Event fired when a change to the AutoDelete propterties would delete files.
Public event | AutoDeleteModeChanged | Fired when the AutoDeleteMode is changed.
Public event | AutoDeleteModeValidating | Fired while validating the new value for AutoDeleteMode.
Public event | AutoDeleteOlderThanChanged | Fired when the AutoDeleteOlderThan is changed.
Public event | AutoDeleteOlderThanValidating | Fired while validating the new value for AutoDeleteOlderThan.
Public event | BeforeConnectedChartsChanged | Fired before the ConnectedCharts changed
Public event | BeforeDisconnectedChartGuidsChanged | Fired before DisconnectedChartGuids changed
Public event | CategoryChanged | Fired when the Category is changed.
Public event | CategoryContentValueChanged | Fired when the CategoryContentValue is changed.
Public event | CategoryContentValueValidating | Fired while validating the new value for CategoryContentValue.
Public event | CategoryValidating | Fired while validating the new value for Category.
Public event | ClearChartChanged | Fired when the ClearChart is changed.
Public event | ClearChartValidating | Fired while validating the new value for ClearChart.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedChartsChanged | Fired when the ConnectedCharts is changed.
Public event | ConnectedChartsValidating | Fired while validating the new value for ConnectedCharts.
Public event | DisconnectedChartGuidsChanged | Fired when the DisconnectedChartGuids is changed.
Public event | DisconnectedChartGuidsValidating | Fired while validating the new value for DisconnectedChartGuids.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | ExportConfigurationChanged | Fired when the ExportConfiguration is changed.
Public event | ExportConfigurationStringChanged | Fired when the ExportConfigurationString is changed.
Public event | ExportConfigurationStringValidating | Fired while validating the new value for ExportConfigurationString.
Public event | ExportConfigurationValidating | Fired while validating the new value for ExportConfiguration.
Public event | ExportData | Fired when the Export Trigger released
Public event | ExportFileNameMaskChanged | Fired when the ExportFileNameMask is changed.
Public event | ExportFileNameMaskValidating | Fired while validating the new value for ExportFileNameMask.
Public event | ExportPathChanged | Fired when the ExportPath is changed.
Public event | ExportPathValidating | Fired while validating the new value for ExportPath.
Public event | ExportTimeModeChanged | Fired when the ExportTimeMode is changed.
Public event | ExportTimeModeValidating | Fired while validating the new value for ExportTimeMode.
Public event | ExportTimeRangeChanged | Fired when the ExportTimeRange is changed.
Public event | ExportTimeRangeValidating | Fired while validating the new value for ExportTimeRange.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FolderPathChanged | Fired when the FolderPath is changed.
Public event | FolderPathValidating | Fired while validating the new value for FolderPath.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | ImageSizeChanged | Fired when the ImageSize is changed.
Public event | ImageSizeValidating | Fired while validating the new value for ImageSize.
Public event | IncludeMarkerWindowChanged | Fired when the IncludeMarkerWindow is changed.
Public event | IncludeMarkerWindowValidating | Fired while validating the new value for IncludeMarkerWindow.
Public event | IncludeTriggerWindowChanged | Fired when the IncludeTriggerWindow is changed.
Public event | IncludeTriggerWindowValidating | Fired while validating the new value for IncludeTriggerWindow.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsReleasedChanged | Fired when the IsReleased is changed.
Public event | IsReleasedValidating | Fired while validating the new value for IsReleased.
Public event | IsSilentChanged | Fired when the IsSilent is changed.
Public event | IsSilentValidating | Fired while validating the new value for IsSilent.
Public event | LastReleaseChanged | Fired when the LastRelease is changed.
Public event | LastReleaseValidating | Fired while validating the new value for LastRelease.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PosttriggerTimeChanged | Fired when the PosttriggerTime is changed.
Public event | PosttriggerTimeValidating | Fired while validating the new value for PosttriggerTime.
Public event | PretriggerTimeChanged | Fired when the PretriggerTime is changed.
Public event | PretriggerTimeValidating | Fired while validating the new value for PretriggerTime.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReleaseInfoCapacityChanged | Fired when the ReleaseInfoCapacity is changed.
Public event | ReleaseInfoCapacityValidating | Fired while validating the new value for ReleaseInfoCapacity.
Public event | ReportChartBackgroundChanged | Fired when the ReportChartBackground is changed.
Public event | ReportChartBackgroundValidating | Fired while validating the new value for ReportChartBackground.
Public event | ReportingTimeModeChanged | Fired when the ReportingTimeMode is changed.
Public event | ReportingTimeModeValidating | Fired while validating the new value for ReportingTimeMode.
Public event | ReportingTimeRangeChanged | Fired when the ReportingTimeRange is changed.
Public event | ReportingTimeRangeValidating | Fired while validating the new value for ReportingTimeRange.
Public event | ReportingTriggerConfigAliasChanged | Fired when the ReportingTriggerConfigAlias is changed.
Public event | ReportingTriggerConfigAliasValidating | Fired while validating the new value for ReportingTriggerConfigAlias.
Public event | ReportingTripletValueChanged | Fired when the ReportingTripletValue is changed.
Public event | ReportingTripletValueValidating | Fired while validating the new value for ReportingTripletValue.
Public event | RestartRecordChanged | Fired when the RestartRecord is changed.
Public event | RestartRecordValidating | Fired while validating the new value for RestartRecord.
Public event | SeparateDirectoryPerExportChanged | Fired when the SeparateDirectoryPerExport is changed.
Public event | SeparateDirectoryPerExportValidating | Fired while validating the new value for SeparateDirectoryPerExport.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StoreSubSave | Invoke the StoreSubSave Method of the current Project
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SubSaveLengthChanged | Fired when the SubSaveLength is changed.
Public event | SubSaveLengthValidating | Fired while validating the new value for SubSaveLength.
Public event | SubSaveNameMaskChanged | Fired when the SubSaveNameMask is changed.
Public event | SubSaveNameMaskValidating | Fired while validating the new value for SubSaveNameMask.
Public event | SubSaveOnlyConnectedChartsChanged | Fired when the SubSaveOnlyConnectedCharts is changed.
Public event | SubSaveOnlyConnectedChartsValidating | Fired while validating the new value for SubSaveOnlyConnectedCharts.
Public event | SubSavePathChanged | Fired when the SubSavePath is changed.
Public event | SubSavePathChanging | Fired while the SubSavePath is Changing
Public event | SubSavePathValidating | Fired while validating the new value for SubSavePath.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerActionChanged | Fired when the TriggerAction is changed.
Public event | TriggerActionChanging | Fired during the Change of the TriggerAction
Public event | TriggerActionValidating | Fired while validating the new value for TriggerAction.
Public event | TriggerPrePercentChanged | Fired when the TriggerPrePercent is changed.
Public event | TriggerPrePercentValidating | Fired while validating the new value for TriggerPrePercent.
Public event | TriggerReleasedEvent | Fired when Trigger Group Releases
Public event | TriggerReleaseInfoSelected | Fired when a TriggerReleaseInfo is selected in the trigger window
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UsePostTriggerChanged | Fired when the UsePostTrigger is changed.
Public event | UsePostTriggerValidating | Fired while validating the new value for UsePostTrigger.
Public event | UsePreTriggerChanged | Fired when the UsePreTrigger is changed.
Public event | UsePreTriggerValidating | Fired while validating the new value for UsePreTrigger.
Public event | UseServerFileSystemChanged | Fired when the UseServerFileSystem is changed.
Public event | UseServerFileSystemValidating | Fired while validating the new value for UseServerFileSystem.
Public event | VisibleChanged | Fired when the Visible is changed.
Public event | VisibleReleaseInfoCapacityChanged | Fired when the VisibleReleaseInfoCapacity is changed.
Public event | VisibleReleaseInfoCapacityValidating | Fired while validating the new value for VisibleReleaseInfoCapacity.
Public event | VisibleValidating | Fired while validating the new value for Visible.
Top
Fields
Name | Description
SupportedImageFormats |
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


TriggerGroup Constructor

Overload List
 | Name | Description
Public method | TriggerGroup | Create a new TriggerGroup
Public method | TriggerGroup(TriggerGroup) | Copy Properties of a TriggerGroup to a new object
Top
See Also

Reference

TriggerGroup Class


TriggerGroup Constructor

Create a new TriggerGroup

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerGroup()
Public Sub New
public:
TriggerGroup()
See Also

Reference

TriggerGroup Class
TriggerGroup Overload


TriggerGroup Constructor (TriggerGroup)

Copy Properties of a TriggerGroup to a new object

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerGroup(
    TriggerGroup org
)
Public Sub New (
    org As TriggerGroup
)
public:
TriggerGroup(
    TriggerGroup^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelTriggerGroup
TriggerGroup to copy
See Also

Reference

TriggerGroup Class
TriggerGroup Overload


TriggerGroup Properties

The TriggerGroup type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteSinglePicturePath |
Public property | AutoDeleteCapacity | Gets or Sets the AutoDeleteCapacity.
Public property | AutoDeleteMode | Gets or Sets the AutoDeleteMode.
Public property | AutoDeleteOlderThan | Gets or Sets the AutoDeleteOlderThan.
Public property | Category | Gets or Sets the Category.
Public property | CategoryContentValue | Gets or Sets the CategoryContentValue.
Public property | ClearChart | Gets or Sets the ClearChart.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ConnectedCharts | Gets or Sets the ConnectedCharts.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisconnectedChartGuids | Gets or Sets the DisconnectedChartGuids.
Public property | DisplayColor | Gets or Sets the DisplayColor. (Overrides MeasurementMemberBaseDisplayColor.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled.
Public property | ExportConfiguration | Gets or Sets the ExportConfiguration.
Public property | ExportConfigurationString | Gets or Sets the ExportConfigurationString.
Public property | ExportFileNameMask | Gets or Sets the ExportFileNameMask.
Public property | ExportPath | Gets or Sets the ExportPath.
Public property | ExportTimeMode | Gets or Sets the ExportTimeMode.
Public property | ExportTimeRange | Gets or Sets the ExportTimeRange.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FolderPath | Gets or Sets the FolderPath.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | ImageDirPath |
Public property | ImageSize | Gets or Sets the ImageSize.
Public property | IncludeMarkerWindow | Gets or Sets the IncludeMarkerWindow.
Public property | IncludeTriggerWindow | Gets or Sets the IncludeTriggerWindow.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsReleased | Gets or Sets the IsReleased.
Public property | IsSilent | Gets or Sets the IsSilent.
Public property | LastRelease | Gets or Sets the LastRelease.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PosttriggerTime | Gets or Sets the PosttriggerTime.
Public property | PretriggerTime | Gets or Sets the PretriggerTime.
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReleaseInfoCapacity | Gets or Sets the ReleaseInfoCapacity.
Public property | ReportChartBackground | Gets or Sets the ReportChartBackground.
Public property | ReportingTimeMode | Gets or Sets the ReportingTimeMode.
Public property | ReportingTimeRange | Gets or Sets the ReportingTimeRange.
Public property | ReportingTriggerConfigAlias | Gets or Sets the ReportingTriggerConfigAlias.
Public property | ReportingTripletValue | Gets or Sets the ReportingTripletValue.
Public property | RestartRecord | Gets or Sets the RestartRecord.
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SeparateDirectoryPerExport | Gets or Sets the SeparateDirectoryPerExport.
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | SubSaveLength | Gets or Sets the SubSaveLength.
Public property | SubSaveNameMask | Gets or Sets the SubSaveNameMask.
Public property | SubSaveOnlyConnectedCharts | Gets or Sets the SubSaveOnlyConnectedCharts.
Public property | SubSavePath | Gets or Sets the SubSavePath.
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerAction | Gets or Sets the TriggerAction.
Public property | TriggerPrePercent | Gets or Sets the TriggerPrePercent.
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UsePostTrigger | Gets or Sets the UsePostTrigger.
Public property | UsePreTrigger | Gets or Sets the UsePreTrigger.
Public property | UseServerFileSystem | Gets or Sets the UseServerFileSystem.
Public property | Visible | Gets or Sets the Visible.
Public property | VisibleReleaseInfoCapacity | Gets or Sets the VisibleReleaseInfoCapacity.
Top
See Also

Reference

TriggerGroup Class


TriggerGroup.AbsoluteSinglePicturePath Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public string AbsoluteSinglePicturePath { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property AbsoluteSinglePicturePath As String
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property String^ AbsoluteSinglePicturePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerGroup Class


TriggerGroup.AutoDeleteCapacity Property

Gets or Sets the AutoDeleteCapacity.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int AutoDeleteCapacity { get; set; }
<BrowsableAttribute(true)>
Public Property AutoDeleteCapacity As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int AutoDeleteCapacity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TriggerGroup Class


TriggerGroup.AutoDeleteMode Property

Gets or Sets the AutoDeleteMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public AutoDeleteMode AutoDeleteMode { get; set; }
<BrowsableAttribute(true)>
Public Property AutoDeleteMode As AutoDeleteMode
    Get
    Set
public:
[BrowsableAttribute(true)]
property AutoDeleteMode AutoDeleteMode {
    AutoDeleteMode get ();
    void set (AutoDeleteMode value);
}

Property Value

Type: AutoDeleteMode
See Also

Reference

TriggerGroup Class


TriggerGroup.AutoDeleteOlderThan Property

Gets or Sets the AutoDeleteOlderThan.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long AutoDeleteOlderThan { get; set; }
<BrowsableAttribute(true)>
Public Property AutoDeleteOlderThan As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long AutoDeleteOlderThan {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

TriggerGroup Class


TriggerGroup.Category Property

Gets or Sets the Category.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerCategory Category { get; set; }
Public Property Category As TriggerCategory
    Get
    Set
public:
property TriggerCategory Category {
    TriggerCategory get ();
    void set (TriggerCategory value);
}

Property Value

Type: TriggerCategory
See Also

Reference

TriggerGroup Class


TriggerGroup.CategoryContentValue Property

Gets or Sets the CategoryContentValue.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[TypeConverterAttribute(typeof(StringConverter))]
public string CategoryContentValue { get; set; }
<BrowsableAttribute(true)>
<TypeConverterAttribute(GetType(StringConverter))>
Public Property CategoryContentValue As String
    Get
    Set
public:
[BrowsableAttribute(true)]
[TypeConverterAttribute(typeof(StringConverter))]
property String^ CategoryContentValue {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerGroup Class


TriggerGroup.ClearChart Property

Gets or Sets the ClearChart.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool ClearChart { get; set; }
<BrowsableAttribute(true)>
Public Property ClearChart As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool ClearChart {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.ConnectedCharts Property

Gets or Sets the ConnectedCharts.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public ObservableValidateCollection<Chart> ConnectedCharts { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property ConnectedCharts As ObservableValidateCollection(Of Chart)
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property ObservableValidateCollection<Chart^>^ ConnectedCharts {
    ObservableValidateCollection<Chart^>^ get ();
    void set (ObservableValidateCollection<Chart^>^ value);
}

Property Value

Type: ObservableValidateCollectionChart
See Also

Reference

TriggerGroup Class


TriggerGroup.DisconnectedChartGuids Property

Gets or Sets the DisconnectedChartGuids.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public ObservableValidateCollection<Guid> DisconnectedChartGuids { get; set; }
<BrowsableAttribute(false)>
Public Property DisconnectedChartGuids As ObservableValidateCollection(Of Guid)
    Get
    Set
public:
[BrowsableAttribute(false)]
property ObservableValidateCollection<Guid>^ DisconnectedChartGuids {
    ObservableValidateCollection<Guid>^ get ();
    void set (ObservableValidateCollection<Guid>^ value);
}

Property Value

Type: ObservableValidateCollectionGuid
See Also

Reference

TriggerGroup Class


TriggerGroup.DisplayColor Property

Gets or Sets the DisplayColor.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public override Color DisplayColor { get; set; }
<BrowsableAttribute(true)>
Public Overrides Property DisplayColor As Color
    Get
    Set
public:
[BrowsableAttribute(true)]
virtual property Color DisplayColor {
    Color get () override;
    void set (Color value) override;
}

Property Value

Type: Color
See Also

Reference

TriggerGroup Class


TriggerGroup.Enabled Property

Gets or Sets the Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Enabled { get; set; }
<BrowsableAttribute(true)>
Public Property Enabled As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportConfiguration Property

Gets or Sets the ExportConfiguration.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
public ExportConfiguration ExportConfiguration { get; set; }
<BrowsableAttribute(true)>
<XmlIgnoreAttribute>
Public Property ExportConfiguration As ExportConfiguration
    Get
    Set
public:
[BrowsableAttribute(true)]
[XmlIgnoreAttribute]
property ExportConfiguration^ ExportConfiguration {
    ExportConfiguration^ get ();
    void set (ExportConfiguration^ value);
}

Property Value

Type: ExportConfiguration
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportConfigurationString Property

Gets or Sets the ExportConfigurationString.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public string ExportConfigurationString { get; set; }
<BrowsableAttribute(false)>
Public Property ExportConfigurationString As String
    Get
    Set
public:
[BrowsableAttribute(false)]
property String^ ExportConfigurationString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportFileNameMask Property

Gets or Sets the ExportFileNameMask.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string ExportFileNameMask { get; set; }
<BrowsableAttribute(true)>
Public Property ExportFileNameMask As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ ExportFileNameMask {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportPath Property

Gets or Sets the ExportPath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string ExportPath { get; set; }
<BrowsableAttribute(true)>
Public Property ExportPath As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ ExportPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportTimeMode Property

Gets or Sets the ExportTimeMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public TriggerExportTimeModes ExportTimeMode { get; set; }
<BrowsableAttribute(true)>
Public Property ExportTimeMode As TriggerExportTimeModes
    Get
    Set
public:
[BrowsableAttribute(true)]
property TriggerExportTimeModes ExportTimeMode {
    TriggerExportTimeModes get ();
    void set (TriggerExportTimeModes value);
}

Property Value

Type: TriggerExportTimeModes
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportTimeRange Property

Gets or Sets the ExportTimeRange.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long ExportTimeRange { get; set; }
<BrowsableAttribute(true)>
Public Property ExportTimeRange As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long ExportTimeRange {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

TriggerGroup Class


TriggerGroup.FolderPath Property

Gets or Sets the FolderPath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public string FolderPath { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property FolderPath As String
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property String^ FolderPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerGroup Class


TriggerGroup.ImageDirPath Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public string ImageDirPath { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property ImageDirPath As String
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property String^ ImageDirPath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

TriggerGroup Class


TriggerGroup.ImageSize Property

Gets or Sets the ImageSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int ImageSize { get; set; }
<BrowsableAttribute(true)>
Public Property ImageSize As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int ImageSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TriggerGroup Class


TriggerGroup.IncludeMarkerWindow Property

Gets or Sets the IncludeMarkerWindow.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool IncludeMarkerWindow { get; set; }
<BrowsableAttribute(true)>
Public Property IncludeMarkerWindow As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool IncludeMarkerWindow {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.IncludeTriggerWindow Property

Gets or Sets the IncludeTriggerWindow.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool IncludeTriggerWindow { get; set; }
<BrowsableAttribute(true)>
Public Property IncludeTriggerWindow As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool IncludeTriggerWindow {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.IsReleased Property

Gets or Sets the IsReleased.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool IsReleased { get; set; }
<BrowsableAttribute(false)>
Public Property IsReleased As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool IsReleased {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.IsSilent Property

Gets or Sets the IsSilent.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool IsSilent { get; set; }
<BrowsableAttribute(true)>
Public Property IsSilent As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool IsSilent {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.LastRelease Property

Gets or Sets the LastRelease.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public long LastRelease { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property LastRelease As Long
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property long long LastRelease {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

TriggerGroup Class


TriggerGroup.PosttriggerTime Property

Gets or Sets the PosttriggerTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long PosttriggerTime { get; set; }
<BrowsableAttribute(true)>
Public Property PosttriggerTime As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long PosttriggerTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

TriggerGroup Class


TriggerGroup.PretriggerTime Property

Gets or Sets the PretriggerTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long PretriggerTime { get; set; }
<BrowsableAttribute(true)>
Public Property PretriggerTime As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long PretriggerTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

TriggerGroup Class


TriggerGroup.ReleaseInfoCapacity Property

Gets or Sets the ReleaseInfoCapacity.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int ReleaseInfoCapacity { get; set; }
<BrowsableAttribute(true)>
Public Property ReleaseInfoCapacity As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int ReleaseInfoCapacity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportChartBackground Property

Gets or Sets the ReportChartBackground.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
[TypeConverterAttribute(typeof(EnumConverter))]
public ReportChartBackground ReportChartBackground { get; set; }
<BrowsableAttribute(true)>
<TypeConverterAttribute(GetType(EnumConverter))>
Public Property ReportChartBackground As ReportChartBackground
    Get
    Set
public:
[BrowsableAttribute(true)]
[TypeConverterAttribute(typeof(EnumConverter))]
property ReportChartBackground ReportChartBackground {
    ReportChartBackground get ();
    void set (ReportChartBackground value);
}

Property Value

Type: ReportChartBackground
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportingTimeMode Property

Gets or Sets the ReportingTimeMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public TriggerExportTimeModes ReportingTimeMode { get; set; }
<BrowsableAttribute(true)>
Public Property ReportingTimeMode As TriggerExportTimeModes
    Get
    Set
public:
[BrowsableAttribute(true)]
property TriggerExportTimeModes ReportingTimeMode {
    TriggerExportTimeModes get ();
    void set (TriggerExportTimeModes value);
}

Property Value

Type: TriggerExportTimeModes
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportingTimeRange Property

Gets or Sets the ReportingTimeRange.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long ReportingTimeRange { get; set; }
<BrowsableAttribute(true)>
Public Property ReportingTimeRange As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long ReportingTimeRange {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportingTriggerConfigAlias Property

Gets or Sets the ReportingTriggerConfigAlias.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string ReportingTriggerConfigAlias { get; set; }
<BrowsableAttribute(true)>
Public Property ReportingTriggerConfigAlias As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ ReportingTriggerConfigAlias {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportingTripletValue Property

Gets or Sets the ReportingTripletValue.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeObservableCollection<ReportingConfigTriplet> ReportingTripletValue { get; set; }
Public Property ReportingTripletValue As ScopeObservableCollection(Of ReportingConfigTriplet)
    Get
    Set
public:
property ScopeObservableCollection<ReportingConfigTriplet^>^ ReportingTripletValue {
    ScopeObservableCollection<ReportingConfigTriplet^>^ get ();
    void set (ScopeObservableCollection<ReportingConfigTriplet^>^ value);
}

Property Value

Type: ScopeObservableCollectionReportingConfigTriplet
See Also

Reference

TriggerGroup Class


TriggerGroup.RestartRecord Property

Gets or Sets the RestartRecord.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool RestartRecord { get; set; }
<BrowsableAttribute(true)>
Public Property RestartRecord As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool RestartRecord {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.SeparateDirectoryPerExport Property

Gets or Sets the SeparateDirectoryPerExport.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool SeparateDirectoryPerExport { get; set; }
<BrowsableAttribute(true)>
Public Property SeparateDirectoryPerExport As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool SeparateDirectoryPerExport {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.SubSaveLength Property

Gets or Sets the SubSaveLength.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long SubSaveLength { get; set; }
<BrowsableAttribute(true)>
Public Property SubSaveLength As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long SubSaveLength {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

TriggerGroup Class


TriggerGroup.SubSaveNameMask Property

Gets or Sets the SubSaveNameMask.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string SubSaveNameMask { get; set; }
<BrowsableAttribute(true)>
Public Property SubSaveNameMask As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ SubSaveNameMask {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerGroup Class


TriggerGroup.SubSaveOnlyConnectedCharts Property

Gets or Sets the SubSaveOnlyConnectedCharts.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool SubSaveOnlyConnectedCharts { get; set; }
<BrowsableAttribute(true)>
Public Property SubSaveOnlyConnectedCharts As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool SubSaveOnlyConnectedCharts {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.SubSavePath Property

Gets or Sets the SubSavePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string SubSavePath { get; set; }
<BrowsableAttribute(true)>
Public Property SubSavePath As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ SubSavePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerGroup Class


TriggerGroup.TriggerAction Property

Gets or Sets the TriggerAction.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public TriggerEventAction TriggerAction { get; set; }
<BrowsableAttribute(true)>
Public Property TriggerAction As TriggerEventAction
    Get
    Set
public:
[BrowsableAttribute(true)]
property TriggerEventAction TriggerAction {
    TriggerEventAction get ();
    void set (TriggerEventAction value);
}

Property Value

Type: TriggerEventAction
See Also

Reference

TriggerGroup Class


TriggerGroup.TriggerPrePercent Property

Gets or Sets the TriggerPrePercent.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int TriggerPrePercent { get; set; }
<BrowsableAttribute(true)>
Public Property TriggerPrePercent As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int TriggerPrePercent {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TriggerGroup Class


TriggerGroup.UsePostTrigger Property

Gets or Sets the UsePostTrigger.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool UsePostTrigger { get; set; }
<BrowsableAttribute(true)>
Public Property UsePostTrigger As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool UsePostTrigger {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.UsePreTrigger Property

Gets or Sets the UsePreTrigger.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool UsePreTrigger { get; set; }
<BrowsableAttribute(true)>
Public Property UsePreTrigger As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool UsePreTrigger {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.UseServerFileSystem Property

Gets or Sets the UseServerFileSystem.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool UseServerFileSystem { get; set; }
<BrowsableAttribute(true)>
Public Property UseServerFileSystem As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool UseServerFileSystem {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.Visible Property

Gets or Sets the Visible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Visible { get; set; }
<BrowsableAttribute(true)>
Public Property Visible As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Visible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.VisibleReleaseInfoCapacity Property

Gets or Sets the VisibleReleaseInfoCapacity.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public int VisibleReleaseInfoCapacity { get; set; }
<BrowsableAttribute(true)>
Public Property VisibleReleaseInfoCapacity As Integer
    Get
    Set
public:
[BrowsableAttribute(true)]
property int VisibleReleaseInfoCapacity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TriggerGroup Class


TriggerGroup Methods

The TriggerGroup type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Adds a new Member to the TriggerGroup (Overrides MeasurementMemberContainerBaseAddMember(MeasurementMemberBase).)
Public method | AddMemberRange | Adds a Range of Member to the SubMemberList (Overrides MeasurementMemberContainerBaseAddMemberRange(MeasurementMemberBase).)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | ClearTriggerReleaseInfos | Removes all Trigger ReleaseInfos
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | DehighlightTriggerInfos | Dehighlight all TriggerReleaseInfos
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of Menucommands for thie Element (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetLatestImage |
Public method | GetReleaseInfoRange | Return a range of ReleaseInfos which are realesed in the Time Range
Public method | GetReportAutomaticArgs |
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTriggerReleaseInfos | Return all TriggerReleaseInfos
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsReportingTriggerEventAction | Return if Trigger Action is a Reporting Trigger Action
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseDehighlightAllTriggerInfos | Dehighlight all TriggerReleaseInfos in the full project
Public method | RaiseTriggerInfoSelected | Raises the TriggerReleaseInfoSelected event
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Removes a Member from the SubMemberlist (Overrides MeasurementMemberContainerBaseRemoveMember(MeasurementMemberBase).)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimmTriggerRealesInfos | Removes all TriggerReleaseInfos outside the given TimeRange
Public method | UpdatePropertyAttributes | Update PropertyAttributes in dhe PropertyGrid (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TriggerGroup Class


TriggerGroup.AddMember Method

Adds a new Member to the TriggerGroup

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void AddMember(
    MeasurementMemberBase add
)
Public Overrides Sub AddMember (
    add As MeasurementMemberBase
)
public:
virtual void AddMember(
    MeasurementMemberBase^ add
) override

Parameters

add
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
Member to add
See Also

Reference

TriggerGroup Class


TriggerGroup.AddMemberRange Method

Adds a Range of Member to the SubMemberList

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void AddMemberRange(
    MeasurementMemberBase[] add
)
Public Overrides Sub AddMemberRange (
    add As MeasurementMemberBase()
)
public:
virtual void AddMemberRange(
    array<MeasurementMemberBase^>^ add
) override

Parameters

add
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
Members to add
See Also

Reference

TriggerGroup Class


TriggerGroup.ClearTriggerReleaseInfos Method

Removes all Trigger ReleaseInfos

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void ClearTriggerReleaseInfos()
Public Sub ClearTriggerReleaseInfos
public:
void ClearTriggerReleaseInfos()
See Also

Reference

TriggerGroup Class


TriggerGroup.DehighlightTriggerInfos Method

Dehighlight all TriggerReleaseInfos

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void DehighlightTriggerInfos()
Public Sub DehighlightTriggerInfos
public:
void DehighlightTriggerInfos()
See Also

Reference

TriggerGroup Class


TriggerGroup.GetCommands Method

Gets a List of Menucommands for thie Element

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
An Array of MenuCommands
See Also

Reference

TriggerGroup Class


TriggerGroup.GetLatestImage Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static FileInfo GetLatestImage(
    string directoryPath
)
Public Shared Function GetLatestImage (
    directoryPath As String
) As FileInfo
public:
static FileInfo^ GetLatestImage(
    String^ directoryPath
)

Parameters

directoryPath
Type: SystemString

Return Value

Type: FileInfo
See Also

Reference

TriggerGroup Class


TriggerGroup.GetReleaseInfoRange Method

Return a range of ReleaseInfos which are realesed in the Time Range

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<TriggerReleaseInfo> GetReleaseInfoRange(
    long StartTime,
    long EndTime
)
Public Function GetReleaseInfoRange (
    StartTime As Long,
    EndTime As Long
) As IEnumerable(Of TriggerReleaseInfo)
public:
IEnumerable<TriggerReleaseInfo^>^ GetReleaseInfoRange(
    long long StartTime,
    long long EndTime
)

Parameters

StartTime
Type: SystemInt64
Starte Time of the TimeRange
EndTime
Type: SystemInt64
End Time of the TimeRange

Return Value

Type: IEnumerable TriggerReleaseInfo
ReleaseInfos in the Time Range
See Also

Reference

TriggerGroup Class


TriggerGroup.GetReportAutomaticArgs Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ReportAutomaticArgs GetReportAutomaticArgs(
    long releaseTime,
    long recordTime
)
Public Function GetReportAutomaticArgs (
    releaseTime As Long,
    recordTime As Long
) As ReportAutomaticArgs
public:
ReportAutomaticArgs^ GetReportAutomaticArgs(
    long long releaseTime,
    long long recordTime
)

Parameters

releaseTime
Type: SystemInt64
recordTime
Type: SystemInt64

Return Value

Type: ReportAutomaticArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.GetTriggerReleaseInfos Method

Return all TriggerReleaseInfos

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<TriggerReleaseInfo> GetTriggerReleaseInfos()
Public Function GetTriggerReleaseInfos As IEnumerable(Of TriggerReleaseInfo)
public:
IEnumerable<TriggerReleaseInfo^>^ GetTriggerReleaseInfos()

Return Value

Type: IEnumerable TriggerReleaseInfo
See Also

Reference

TriggerGroup Class


TriggerGroup.IsReportingTriggerEventAction Method

Return if Trigger Action is a Reporting Trigger Action

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool IsReportingTriggerEventAction()
Public Function IsReportingTriggerEventAction As Boolean
public:
bool IsReportingTriggerEventAction()

Return Value

Type: Boolean
See Also

Reference

TriggerGroup Class


TriggerGroup.RaiseDehighlightAllTriggerInfos Method

Dehighlight all TriggerReleaseInfos in the full project

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void RaiseDehighlightAllTriggerInfos()
Public Sub RaiseDehighlightAllTriggerInfos
public:
void RaiseDehighlightAllTriggerInfos()
See Also

Reference

TriggerGroup Class


TriggerGroup.RaiseTriggerInfoSelected Method

Raises the TriggerReleaseInfoSelected event

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void RaiseTriggerInfoSelected(
    TriggerReleaseInfo info
)
Public Sub RaiseTriggerInfoSelected (
    info As TriggerReleaseInfo
)
public:
void RaiseTriggerInfoSelected(
    TriggerReleaseInfo^ info
)

Parameters

info
Type: TwinCAT.Measurement.Scope.API.ModelTriggerReleaseInfo
See Also

Reference

TriggerGroup Class


TriggerGroup.RemoveMember Method

Removes a Member from the SubMemberlist

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void RemoveMember(
    MeasurementMemberBase rem
)
Public Overrides Sub RemoveMember (
    rem As MeasurementMemberBase
)
public:
virtual void RemoveMember(
    MeasurementMemberBase^ rem
) override

Parameters

rem
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
Member to Remove
See Also

Reference

TriggerGroup Class


TriggerGroup.TrimmTriggerRealesInfos Method

Removes all TriggerReleaseInfos outside the given TimeRange

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void TrimmTriggerRealesInfos(
    long StartTime,
    long EndTime
)
Public Sub TrimmTriggerRealesInfos (
    StartTime As Long,
    EndTime As Long
)
public:
void TrimmTriggerRealesInfos(
    long long StartTime,
    long long EndTime
)

Parameters

StartTime
Type: SystemInt64
Start Time of the TimeRange
EndTime
Type: SystemInt64
End Time of the TimeRange
See Also

Reference

TriggerGroup Class


TriggerGroup.UpdatePropertyAttributes Method

Update PropertyAttributes in dhe PropertyGrid

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

TriggerGroup Class


TriggerGroup Events

The TriggerGroup type exposes the following members.

Events
 | Name | Description
Public event | AutoDeleteCapacityChanged | Fired when the AutoDeleteCapacity is changed.
Public event | AutoDeleteCapacityValidating | Fired while validating the new value for AutoDeleteCapacity.
Public event | AutoDeleteFileLoss | Event fired when a change to the AutoDelete propterties would delete files.
Public event | AutoDeleteModeChanged | Fired when the AutoDeleteMode is changed.
Public event | AutoDeleteModeValidating | Fired while validating the new value for AutoDeleteMode.
Public event | AutoDeleteOlderThanChanged | Fired when the AutoDeleteOlderThan is changed.
Public event | AutoDeleteOlderThanValidating | Fired while validating the new value for AutoDeleteOlderThan.
Public event | BeforeConnectedChartsChanged | Fired before the ConnectedCharts changed
Public event | BeforeDisconnectedChartGuidsChanged | Fired before DisconnectedChartGuids changed
Public event | CategoryChanged | Fired when the Category is changed.
Public event | CategoryContentValueChanged | Fired when the CategoryContentValue is changed.
Public event | CategoryContentValueValidating | Fired while validating the new value for CategoryContentValue.
Public event | CategoryValidating | Fired while validating the new value for Category.
Public event | ClearChartChanged | Fired when the ClearChart is changed.
Public event | ClearChartValidating | Fired while validating the new value for ClearChart.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedChartsChanged | Fired when the ConnectedCharts is changed.
Public event | ConnectedChartsValidating | Fired while validating the new value for ConnectedCharts.
Public event | DisconnectedChartGuidsChanged | Fired when the DisconnectedChartGuids is changed.
Public event | DisconnectedChartGuidsValidating | Fired while validating the new value for DisconnectedChartGuids.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | ExportConfigurationChanged | Fired when the ExportConfiguration is changed.
Public event | ExportConfigurationStringChanged | Fired when the ExportConfigurationString is changed.
Public event | ExportConfigurationStringValidating | Fired while validating the new value for ExportConfigurationString.
Public event | ExportConfigurationValidating | Fired while validating the new value for ExportConfiguration.
Public event | ExportData | Fired when the Export Trigger released
Public event | ExportFileNameMaskChanged | Fired when the ExportFileNameMask is changed.
Public event | ExportFileNameMaskValidating | Fired while validating the new value for ExportFileNameMask.
Public event | ExportPathChanged | Fired when the ExportPath is changed.
Public event | ExportPathValidating | Fired while validating the new value for ExportPath.
Public event | ExportTimeModeChanged | Fired when the ExportTimeMode is changed.
Public event | ExportTimeModeValidating | Fired while validating the new value for ExportTimeMode.
Public event | ExportTimeRangeChanged | Fired when the ExportTimeRange is changed.
Public event | ExportTimeRangeValidating | Fired while validating the new value for ExportTimeRange.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FolderPathChanged | Fired when the FolderPath is changed.
Public event | FolderPathValidating | Fired while validating the new value for FolderPath.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | ImageSizeChanged | Fired when the ImageSize is changed.
Public event | ImageSizeValidating | Fired while validating the new value for ImageSize.
Public event | IncludeMarkerWindowChanged | Fired when the IncludeMarkerWindow is changed.
Public event | IncludeMarkerWindowValidating | Fired while validating the new value for IncludeMarkerWindow.
Public event | IncludeTriggerWindowChanged | Fired when the IncludeTriggerWindow is changed.
Public event | IncludeTriggerWindowValidating | Fired while validating the new value for IncludeTriggerWindow.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsReleasedChanged | Fired when the IsReleased is changed.
Public event | IsReleasedValidating | Fired while validating the new value for IsReleased.
Public event | IsSilentChanged | Fired when the IsSilent is changed.
Public event | IsSilentValidating | Fired while validating the new value for IsSilent.
Public event | LastReleaseChanged | Fired when the LastRelease is changed.
Public event | LastReleaseValidating | Fired while validating the new value for LastRelease.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PosttriggerTimeChanged | Fired when the PosttriggerTime is changed.
Public event | PosttriggerTimeValidating | Fired while validating the new value for PosttriggerTime.
Public event | PretriggerTimeChanged | Fired when the PretriggerTime is changed.
Public event | PretriggerTimeValidating | Fired while validating the new value for PretriggerTime.
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReleaseInfoCapacityChanged | Fired when the ReleaseInfoCapacity is changed.
Public event | ReleaseInfoCapacityValidating | Fired while validating the new value for ReleaseInfoCapacity.
Public event | ReportChartBackgroundChanged | Fired when the ReportChartBackground is changed.
Public event | ReportChartBackgroundValidating | Fired while validating the new value for ReportChartBackground.
Public event | ReportingTimeModeChanged | Fired when the ReportingTimeMode is changed.
Public event | ReportingTimeModeValidating | Fired while validating the new value for ReportingTimeMode.
Public event | ReportingTimeRangeChanged | Fired when the ReportingTimeRange is changed.
Public event | ReportingTimeRangeValidating | Fired while validating the new value for ReportingTimeRange.
Public event | ReportingTriggerConfigAliasChanged | Fired when the ReportingTriggerConfigAlias is changed.
Public event | ReportingTriggerConfigAliasValidating | Fired while validating the new value for ReportingTriggerConfigAlias.
Public event | ReportingTripletValueChanged | Fired when the ReportingTripletValue is changed.
Public event | ReportingTripletValueValidating | Fired while validating the new value for ReportingTripletValue.
Public event | RestartRecordChanged | Fired when the RestartRecord is changed.
Public event | RestartRecordValidating | Fired while validating the new value for RestartRecord.
Public event | SeparateDirectoryPerExportChanged | Fired when the SeparateDirectoryPerExport is changed.
Public event | SeparateDirectoryPerExportValidating | Fired while validating the new value for SeparateDirectoryPerExport.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StoreSubSave | Invoke the StoreSubSave Method of the current Project
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | SubSaveLengthChanged | Fired when the SubSaveLength is changed.
Public event | SubSaveLengthValidating | Fired while validating the new value for SubSaveLength.
Public event | SubSaveNameMaskChanged | Fired when the SubSaveNameMask is changed.
Public event | SubSaveNameMaskValidating | Fired while validating the new value for SubSaveNameMask.
Public event | SubSaveOnlyConnectedChartsChanged | Fired when the SubSaveOnlyConnectedCharts is changed.
Public event | SubSaveOnlyConnectedChartsValidating | Fired while validating the new value for SubSaveOnlyConnectedCharts.
Public event | SubSavePathChanged | Fired when the SubSavePath is changed.
Public event | SubSavePathChanging | Fired while the SubSavePath is Changing
Public event | SubSavePathValidating | Fired while validating the new value for SubSavePath.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerActionChanged | Fired when the TriggerAction is changed.
Public event | TriggerActionChanging | Fired during the Change of the TriggerAction
Public event | TriggerActionValidating | Fired while validating the new value for TriggerAction.
Public event | TriggerPrePercentChanged | Fired when the TriggerPrePercent is changed.
Public event | TriggerPrePercentValidating | Fired while validating the new value for TriggerPrePercent.
Public event | TriggerReleasedEvent | Fired when Trigger Group Releases
Public event | TriggerReleaseInfoSelected | Fired when a TriggerReleaseInfo is selected in the trigger window
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UsePostTriggerChanged | Fired when the UsePostTrigger is changed.
Public event | UsePostTriggerValidating | Fired while validating the new value for UsePostTrigger.
Public event | UsePreTriggerChanged | Fired when the UsePreTrigger is changed.
Public event | UsePreTriggerValidating | Fired while validating the new value for UsePreTrigger.
Public event | UseServerFileSystemChanged | Fired when the UseServerFileSystem is changed.
Public event | UseServerFileSystemValidating | Fired while validating the new value for UseServerFileSystem.
Public event | VisibleChanged | Fired when the Visible is changed.
Public event | VisibleReleaseInfoCapacityChanged | Fired when the VisibleReleaseInfoCapacity is changed.
Public event | VisibleReleaseInfoCapacityValidating | Fired while validating the new value for VisibleReleaseInfoCapacity.
Public event | VisibleValidating | Fired while validating the new value for Visible.
Top
See Also

Reference

TriggerGroup Class


TriggerGroup.AutoDeleteCapacityChanged Event

Fired when the AutoDeleteCapacity is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoDeleteCapacityChanged
Public Event AutoDeleteCapacityChanged As EventHandler
public:
 event EventHandler^ AutoDeleteCapacityChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.AutoDeleteCapacityValidating Event

Fired while validating the new value for AutoDeleteCapacity.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoDeleteCapacityValidating
Public Event AutoDeleteCapacityValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoDeleteCapacityValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.AutoDeleteFileLoss Event

Event fired when a change to the AutoDelete propterties would delete files.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoDeleteFileLoss
Public Event AutoDeleteFileLoss As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoDeleteFileLoss {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.AutoDeleteModeChanged Event

Fired when the AutoDeleteMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoDeleteModeChanged
Public Event AutoDeleteModeChanged As EventHandler
public:
 event EventHandler^ AutoDeleteModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.AutoDeleteModeValidating Event

Fired while validating the new value for AutoDeleteMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoDeleteModeValidating
Public Event AutoDeleteModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoDeleteModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.AutoDeleteOlderThanChanged Event

Fired when the AutoDeleteOlderThan is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler AutoDeleteOlderThanChanged
Public Event AutoDeleteOlderThanChanged As EventHandler
public:
 event EventHandler^ AutoDeleteOlderThanChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.AutoDeleteOlderThanValidating Event

Fired while validating the new value for AutoDeleteOlderThan.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> AutoDeleteOlderThanValidating
Public Event AutoDeleteOlderThanValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ AutoDeleteOlderThanValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.BeforeConnectedChartsChanged Event

Fired before the ConnectedCharts changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeConnectedChartsChanged
Public Event BeforeConnectedChartsChanged As EventHandler
public:
 event EventHandler^ BeforeConnectedChartsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.BeforeDisconnectedChartGuidsChanged Event

Fired before DisconnectedChartGuids changed

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeDisconnectedChartGuidsChanged
Public Event BeforeDisconnectedChartGuidsChanged As EventHandler
public:
 event EventHandler^ BeforeDisconnectedChartGuidsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.CategoryChanged Event

Fired when the Category is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CategoryChanged
Public Event CategoryChanged As EventHandler
public:
 event EventHandler^ CategoryChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.CategoryContentValueChanged Event

Fired when the CategoryContentValue is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CategoryContentValueChanged
Public Event CategoryContentValueChanged As EventHandler
public:
 event EventHandler^ CategoryContentValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.CategoryContentValueValidating Event

Fired while validating the new value for CategoryContentValue.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> CategoryContentValueValidating
Public Event CategoryContentValueValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ CategoryContentValueValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.CategoryValidating Event

Fired while validating the new value for Category.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> CategoryValidating
Public Event CategoryValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ CategoryValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ClearChartChanged Event

Fired when the ClearChart is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ClearChartChanged
Public Event ClearChartChanged As EventHandler
public:
 event EventHandler^ ClearChartChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ClearChartValidating Event

Fired while validating the new value for ClearChart.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ClearChartValidating
Public Event ClearChartValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ClearChartValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ConnectedChartsChanged Event

Fired when the ConnectedCharts is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ConnectedChartsChanged
Public Event ConnectedChartsChanged As EventHandler
public:
 event EventHandler^ ConnectedChartsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ConnectedChartsValidating Event

Fired while validating the new value for ConnectedCharts.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ConnectedChartsValidating
Public Event ConnectedChartsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ConnectedChartsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.DisconnectedChartGuidsChanged Event

Fired when the DisconnectedChartGuids is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DisconnectedChartGuidsChanged
Public Event DisconnectedChartGuidsChanged As EventHandler
public:
 event EventHandler^ DisconnectedChartGuidsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.DisconnectedChartGuidsValidating Event

Fired while validating the new value for DisconnectedChartGuids.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DisconnectedChartGuidsValidating
Public Event DisconnectedChartGuidsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DisconnectedChartGuidsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.EnabledChanged Event

Fired when the Enabled is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EnabledChanged
Public Event EnabledChanged As EventHandler
public:
 event EventHandler^ EnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.EnabledValidating Event

Fired while validating the new value for Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EnabledValidating
Public Event EnabledValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EnabledValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportConfigurationChanged Event

Fired when the ExportConfiguration is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ExportConfigurationChanged
Public Event ExportConfigurationChanged As EventHandler
public:
 event EventHandler^ ExportConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportConfigurationStringChanged Event

Fired when the ExportConfigurationString is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ExportConfigurationStringChanged
Public Event ExportConfigurationStringChanged As EventHandler
public:
 event EventHandler^ ExportConfigurationStringChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportConfigurationStringValidating Event

Fired while validating the new value for ExportConfigurationString.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ExportConfigurationStringValidating
Public Event ExportConfigurationStringValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ExportConfigurationStringValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportConfigurationValidating Event

Fired while validating the new value for ExportConfiguration.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ExportConfigurationValidating
Public Event ExportConfigurationValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ExportConfigurationValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportData Event

Fired when the Export Trigger released

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ExportConfiguration> ExportData
Public Event ExportData As EventHandler(Of ExportConfiguration)
public:
 event EventHandler<ExportConfiguration^>^ ExportData {
    void add (EventHandler<ExportConfiguration^>^ value);
    void remove (EventHandler<ExportConfiguration^>^ value);
}

Value

Type: SystemEventHandler ExportConfiguration
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportFileNameMaskChanged Event

Fired when the ExportFileNameMask is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ExportFileNameMaskChanged
Public Event ExportFileNameMaskChanged As EventHandler
public:
 event EventHandler^ ExportFileNameMaskChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportFileNameMaskValidating Event

Fired while validating the new value for ExportFileNameMask.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ExportFileNameMaskValidating
Public Event ExportFileNameMaskValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ExportFileNameMaskValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportPathChanged Event

Fired when the ExportPath is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ExportPathChanged
Public Event ExportPathChanged As EventHandler
public:
 event EventHandler^ ExportPathChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportPathValidating Event

Fired while validating the new value for ExportPath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ExportPathValidating
Public Event ExportPathValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ExportPathValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportTimeModeChanged Event

Fired when the ExportTimeMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ExportTimeModeChanged
Public Event ExportTimeModeChanged As EventHandler
public:
 event EventHandler^ ExportTimeModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportTimeModeValidating Event

Fired while validating the new value for ExportTimeMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ExportTimeModeValidating
Public Event ExportTimeModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ExportTimeModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportTimeRangeChanged Event

Fired when the ExportTimeRange is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ExportTimeRangeChanged
Public Event ExportTimeRangeChanged As EventHandler
public:
 event EventHandler^ ExportTimeRangeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ExportTimeRangeValidating Event

Fired while validating the new value for ExportTimeRange.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ExportTimeRangeValidating
Public Event ExportTimeRangeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ExportTimeRangeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.FolderPathChanged Event

Fired when the FolderPath is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler FolderPathChanged
Public Event FolderPathChanged As EventHandler
public:
 event EventHandler^ FolderPathChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.FolderPathValidating Event

Fired while validating the new value for FolderPath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> FolderPathValidating
Public Event FolderPathValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ FolderPathValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ImageSizeChanged Event

Fired when the ImageSize is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ImageSizeChanged
Public Event ImageSizeChanged As EventHandler
public:
 event EventHandler^ ImageSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ImageSizeValidating Event

Fired while validating the new value for ImageSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ImageSizeValidating
Public Event ImageSizeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ImageSizeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.IncludeMarkerWindowChanged Event

Fired when the IncludeMarkerWindow is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IncludeMarkerWindowChanged
Public Event IncludeMarkerWindowChanged As EventHandler
public:
 event EventHandler^ IncludeMarkerWindowChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.IncludeMarkerWindowValidating Event

Fired while validating the new value for IncludeMarkerWindow.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IncludeMarkerWindowValidating
Public Event IncludeMarkerWindowValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IncludeMarkerWindowValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.IncludeTriggerWindowChanged Event

Fired when the IncludeTriggerWindow is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IncludeTriggerWindowChanged
Public Event IncludeTriggerWindowChanged As EventHandler
public:
 event EventHandler^ IncludeTriggerWindowChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.IncludeTriggerWindowValidating Event

Fired while validating the new value for IncludeTriggerWindow.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IncludeTriggerWindowValidating
Public Event IncludeTriggerWindowValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IncludeTriggerWindowValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.IsReleasedChanged Event

Fired when the IsReleased is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IsReleasedChanged
Public Event IsReleasedChanged As EventHandler
public:
 event EventHandler^ IsReleasedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.IsReleasedValidating Event

Fired while validating the new value for IsReleased.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IsReleasedValidating
Public Event IsReleasedValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IsReleasedValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.IsSilentChanged Event

Fired when the IsSilent is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IsSilentChanged
Public Event IsSilentChanged As EventHandler
public:
 event EventHandler^ IsSilentChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.IsSilentValidating Event

Fired while validating the new value for IsSilent.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IsSilentValidating
Public Event IsSilentValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IsSilentValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.LastReleaseChanged Event

Fired when the LastRelease is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler LastReleaseChanged
Public Event LastReleaseChanged As EventHandler
public:
 event EventHandler^ LastReleaseChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.LastReleaseValidating Event

Fired while validating the new value for LastRelease.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> LastReleaseValidating
Public Event LastReleaseValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ LastReleaseValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.PosttriggerTimeChanged Event

Fired when the PosttriggerTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PosttriggerTimeChanged
Public Event PosttriggerTimeChanged As EventHandler
public:
 event EventHandler^ PosttriggerTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.PosttriggerTimeValidating Event

Fired while validating the new value for PosttriggerTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PosttriggerTimeValidating
Public Event PosttriggerTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PosttriggerTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.PretriggerTimeChanged Event

Fired when the PretriggerTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler PretriggerTimeChanged
Public Event PretriggerTimeChanged As EventHandler
public:
 event EventHandler^ PretriggerTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.PretriggerTimeValidating Event

Fired while validating the new value for PretriggerTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> PretriggerTimeValidating
Public Event PretriggerTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ PretriggerTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ReleaseInfoCapacityChanged Event

Fired when the ReleaseInfoCapacity is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReleaseInfoCapacityChanged
Public Event ReleaseInfoCapacityChanged As EventHandler
public:
 event EventHandler^ ReleaseInfoCapacityChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ReleaseInfoCapacityValidating Event

Fired while validating the new value for ReleaseInfoCapacity.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReleaseInfoCapacityValidating
Public Event ReleaseInfoCapacityValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReleaseInfoCapacityValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportChartBackgroundChanged Event

Fired when the ReportChartBackground is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReportChartBackgroundChanged
Public Event ReportChartBackgroundChanged As EventHandler
public:
 event EventHandler^ ReportChartBackgroundChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportChartBackgroundValidating Event

Fired while validating the new value for ReportChartBackground.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReportChartBackgroundValidating
Public Event ReportChartBackgroundValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReportChartBackgroundValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportingTimeModeChanged Event

Fired when the ReportingTimeMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReportingTimeModeChanged
Public Event ReportingTimeModeChanged As EventHandler
public:
 event EventHandler^ ReportingTimeModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportingTimeModeValidating Event

Fired while validating the new value for ReportingTimeMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReportingTimeModeValidating
Public Event ReportingTimeModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReportingTimeModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportingTimeRangeChanged Event

Fired when the ReportingTimeRange is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReportingTimeRangeChanged
Public Event ReportingTimeRangeChanged As EventHandler
public:
 event EventHandler^ ReportingTimeRangeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportingTimeRangeValidating Event

Fired while validating the new value for ReportingTimeRange.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReportingTimeRangeValidating
Public Event ReportingTimeRangeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReportingTimeRangeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportingTriggerConfigAliasChanged Event

Fired when the ReportingTriggerConfigAlias is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReportingTriggerConfigAliasChanged
Public Event ReportingTriggerConfigAliasChanged As EventHandler
public:
 event EventHandler^ ReportingTriggerConfigAliasChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportingTriggerConfigAliasValidating Event

Fired while validating the new value for ReportingTriggerConfigAlias.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReportingTriggerConfigAliasValidating
Public Event ReportingTriggerConfigAliasValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReportingTriggerConfigAliasValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportingTripletValueChanged Event

Fired when the ReportingTripletValue is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReportingTripletValueChanged
Public Event ReportingTripletValueChanged As EventHandler
public:
 event EventHandler^ ReportingTripletValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.ReportingTripletValueValidating Event

Fired while validating the new value for ReportingTripletValue.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReportingTripletValueValidating
Public Event ReportingTripletValueValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReportingTripletValueValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.RestartRecordChanged Event

Fired when the RestartRecord is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler RestartRecordChanged
Public Event RestartRecordChanged As EventHandler
public:
 event EventHandler^ RestartRecordChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.RestartRecordValidating Event

Fired while validating the new value for RestartRecord.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> RestartRecordValidating
Public Event RestartRecordValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ RestartRecordValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.SeparateDirectoryPerExportChanged Event

Fired when the SeparateDirectoryPerExport is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SeparateDirectoryPerExportChanged
Public Event SeparateDirectoryPerExportChanged As EventHandler
public:
 event EventHandler^ SeparateDirectoryPerExportChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.SeparateDirectoryPerExportValidating Event

Fired while validating the new value for SeparateDirectoryPerExport.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SeparateDirectoryPerExportValidating
Public Event SeparateDirectoryPerExportValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SeparateDirectoryPerExportValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.StoreSubSave Event

Invoke the StoreSubSave Method of the current Project

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<long> StoreSubSave
Public Event StoreSubSave As EventHandler(Of Long)
public:
 event EventHandler<long long>^ StoreSubSave {
    void add (EventHandler<long long>^ value);
    void remove (EventHandler<long long>^ value);
}

Value

Type: SystemEventHandler Int64
See Also

Reference

TriggerGroup Class


TriggerGroup.SubSaveLengthChanged Event

Fired when the SubSaveLength is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SubSaveLengthChanged
Public Event SubSaveLengthChanged As EventHandler
public:
 event EventHandler^ SubSaveLengthChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.SubSaveLengthValidating Event

Fired while validating the new value for SubSaveLength.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SubSaveLengthValidating
Public Event SubSaveLengthValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SubSaveLengthValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.SubSaveNameMaskChanged Event

Fired when the SubSaveNameMask is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SubSaveNameMaskChanged
Public Event SubSaveNameMaskChanged As EventHandler
public:
 event EventHandler^ SubSaveNameMaskChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.SubSaveNameMaskValidating Event

Fired while validating the new value for SubSaveNameMask.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SubSaveNameMaskValidating
Public Event SubSaveNameMaskValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SubSaveNameMaskValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.SubSaveOnlyConnectedChartsChanged Event

Fired when the SubSaveOnlyConnectedCharts is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SubSaveOnlyConnectedChartsChanged
Public Event SubSaveOnlyConnectedChartsChanged As EventHandler
public:
 event EventHandler^ SubSaveOnlyConnectedChartsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.SubSaveOnlyConnectedChartsValidating Event

Fired while validating the new value for SubSaveOnlyConnectedCharts.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SubSaveOnlyConnectedChartsValidating
Public Event SubSaveOnlyConnectedChartsValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SubSaveOnlyConnectedChartsValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.SubSavePathChanged Event

Fired when the SubSavePath is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SubSavePathChanged
Public Event SubSavePathChanged As EventHandler
public:
 event EventHandler^ SubSavePathChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.SubSavePathChanging Event

Fired while the SubSavePath is Changing

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler SubSavePathChanging
Public Event SubSavePathChanging As EventHandler
public:
 event EventHandler^ SubSavePathChanging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.SubSavePathValidating Event

Fired while validating the new value for SubSavePath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> SubSavePathValidating
Public Event SubSavePathValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ SubSavePathValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.TriggerActionChanged Event

Fired when the TriggerAction is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TriggerActionChanged
Public Event TriggerActionChanged As EventHandler
public:
 event EventHandler^ TriggerActionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.TriggerActionChanging Event

Fired during the Change of the TriggerAction

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TriggerActionChanging
Public Event TriggerActionChanging As EventHandler
public:
 event EventHandler^ TriggerActionChanging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.TriggerActionValidating Event

Fired while validating the new value for TriggerAction.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TriggerActionValidating
Public Event TriggerActionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TriggerActionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.TriggerPrePercentChanged Event

Fired when the TriggerPrePercent is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TriggerPrePercentChanged
Public Event TriggerPrePercentChanged As EventHandler
public:
 event EventHandler^ TriggerPrePercentChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.TriggerPrePercentValidating Event

Fired while validating the new value for TriggerPrePercent.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TriggerPrePercentValidating
Public Event TriggerPrePercentValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TriggerPrePercentValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.TriggerReleasedEvent Event

Fired when Trigger Group Releases

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<TriggerReleaseInfo> TriggerReleasedEvent
Public Event TriggerReleasedEvent As EventHandler(Of TriggerReleaseInfo)
public:
 event EventHandler<TriggerReleaseInfo^>^ TriggerReleasedEvent {
    void add (EventHandler<TriggerReleaseInfo^>^ value);
    void remove (EventHandler<TriggerReleaseInfo^>^ value);
}

Value

Type: SystemEventHandler TriggerReleaseInfo
See Also

Reference

TriggerGroup Class


TriggerGroup.TriggerReleaseInfoSelected Event

Fired when a TriggerReleaseInfo is selected in the trigger window

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<TriggerReleaseInfo> TriggerReleaseInfoSelected
Public Event TriggerReleaseInfoSelected As EventHandler(Of TriggerReleaseInfo)
public:
 event EventHandler<TriggerReleaseInfo^>^ TriggerReleaseInfoSelected {
    void add (EventHandler<TriggerReleaseInfo^>^ value);
    void remove (EventHandler<TriggerReleaseInfo^>^ value);
}

Value

Type: SystemEventHandler TriggerReleaseInfo
See Also

Reference

TriggerGroup Class


TriggerGroup.UsePostTriggerChanged Event

Fired when the UsePostTrigger is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UsePostTriggerChanged
Public Event UsePostTriggerChanged As EventHandler
public:
 event EventHandler^ UsePostTriggerChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.UsePostTriggerValidating Event

Fired while validating the new value for UsePostTrigger.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UsePostTriggerValidating
Public Event UsePostTriggerValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UsePostTriggerValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.UsePreTriggerChanged Event

Fired when the UsePreTrigger is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UsePreTriggerChanged
Public Event UsePreTriggerChanged As EventHandler
public:
 event EventHandler^ UsePreTriggerChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.UsePreTriggerValidating Event

Fired while validating the new value for UsePreTrigger.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UsePreTriggerValidating
Public Event UsePreTriggerValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UsePreTriggerValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.UseServerFileSystemChanged Event

Fired when the UseServerFileSystem is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UseServerFileSystemChanged
Public Event UseServerFileSystemChanged As EventHandler
public:
 event EventHandler^ UseServerFileSystemChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.UseServerFileSystemValidating Event

Fired while validating the new value for UseServerFileSystem.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UseServerFileSystemValidating
Public Event UseServerFileSystemValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UseServerFileSystemValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.VisibleChanged Event

Fired when the Visible is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler VisibleChanged
Public Event VisibleChanged As EventHandler
public:
 event EventHandler^ VisibleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.VisibleReleaseInfoCapacityChanged Event

Fired when the VisibleReleaseInfoCapacity is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler VisibleReleaseInfoCapacityChanged
Public Event VisibleReleaseInfoCapacityChanged As EventHandler
public:
 event EventHandler^ VisibleReleaseInfoCapacityChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerGroup Class


TriggerGroup.VisibleReleaseInfoCapacityValidating Event

Fired while validating the new value for VisibleReleaseInfoCapacity.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> VisibleReleaseInfoCapacityValidating
Public Event VisibleReleaseInfoCapacityValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ VisibleReleaseInfoCapacityValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup.VisibleValidating Event

Fired while validating the new value for Visible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> VisibleValidating
Public Event VisibleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ VisibleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerGroup Class


TriggerGroup Fields

The TriggerGroup type exposes the following members.

Fields
Name | Description
SupportedImageFormats |
Top
See Also

Reference

TriggerGroup Class


TriggerGroup.SupportedImageFormats Field

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public static List<string> SupportedImageFormats
Public Shared SupportedImageFormats As List(Of String)
public:
static List<String^>^ SupportedImageFormats

Field Value

Type: List String
See Also

Reference

TriggerGroup Class


TriggerModule Class

TriggerModule Class of the TwinCAT 3 Scope API
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelTriggerModule

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TriggerModule : ScopeMemberContainerBase
Public Class TriggerModule
    Inherits ScopeMemberContainerBase
public ref class TriggerModule : public ScopeMemberContainerBase

The TriggerModule type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerModule | Creats an instance of TriggerModule
Public method | TriggerModule(TriggerModule) | Creates an instance of TriggerModule and copy the properties from org
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Adds a Member to the SubMemberList (Overrides MeasurementMemberContainerBaseAddMember(MeasurementMemberBase).)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | DehighlightAllTriggerInfos | Dehighlight all TriggerReleaseInfos
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Called to get all possible Commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTriggerReleaseInfos |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Removes a Member from the TriggerGroup (Overrides MeasurementMemberContainerBaseRemoveMember(MeasurementMemberBase).)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


TriggerModule Constructor

Overload List
 | Name | Description
Public method | TriggerModule | Creats an instance of TriggerModule
Public method | TriggerModule(TriggerModule) | Creates an instance of TriggerModule and copy the properties from org
Top
See Also

Reference

TriggerModule Class


TriggerModule Constructor

Creats an instance of TriggerModule

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerModule()
Public Sub New
public:
TriggerModule()
See Also

Reference

TriggerModule Class
TriggerModule Overload


TriggerModule Constructor (TriggerModule)

Creates an instance of TriggerModule and copy the properties from org

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerModule(
    TriggerModule org
)
Public Sub New (
    org As TriggerModule
)
public:
TriggerModule(
    TriggerModule^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelTriggerModule
See Also

Reference

TriggerModule Class
TriggerModule Overload


TriggerModule Properties

The TriggerModule type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TriggerModule Class


TriggerModule Methods

The TriggerModule type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Adds a Member to the SubMemberList (Overrides MeasurementMemberContainerBaseAddMember(MeasurementMemberBase).)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | DehighlightAllTriggerInfos | Dehighlight all TriggerReleaseInfos
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Called to get all possible Commands (Overrides ScopeMemberContainerBaseGetCommands.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetTriggerReleaseInfos |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Removes a Member from the TriggerGroup (Overrides MeasurementMemberContainerBaseRemoveMember(MeasurementMemberBase).)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update Attributes of Properties (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TriggerModule Class


TriggerModule.AddMember Method

Adds a Member to the SubMemberList

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void AddMember(
    MeasurementMemberBase add
)
Public Overrides Sub AddMember (
    add As MeasurementMemberBase
)
public:
virtual void AddMember(
    MeasurementMemberBase^ add
) override

Parameters

add
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
Member to add
See Also

Reference

TriggerModule Class


TriggerModule.DehighlightAllTriggerInfos Method

Dehighlight all TriggerReleaseInfos

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void DehighlightAllTriggerInfos()
Public Sub DehighlightAllTriggerInfos
public:
void DehighlightAllTriggerInfos()
See Also

Reference

TriggerModule Class


TriggerModule.GetCommands Method

Called to get all possible Commands

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override MenuCommand[] GetCommands()
Public Overrides Function GetCommands As MenuCommand()
public:
virtual array<MenuCommand^>^ GetCommands() override

Return Value

Type: MenuCommand
See Also

Reference

TriggerModule Class


TriggerModule.GetTriggerReleaseInfos Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public IEnumerable<TriggerReleaseInfoReporting> GetTriggerReleaseInfos()
Public Function GetTriggerReleaseInfos As IEnumerable(Of TriggerReleaseInfoReporting)
public:
IEnumerable<TriggerReleaseInfoReporting^>^ GetTriggerReleaseInfos()

Return Value

Type: IEnumerable TriggerReleaseInfoReporting
See Also

Reference

TriggerModule Class


TriggerModule.RemoveMember Method

Removes a Member from the TriggerGroup

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void RemoveMember(
    MeasurementMemberBase rem
)
Public Overrides Sub RemoveMember (
    rem As MeasurementMemberBase
)
public:
virtual void RemoveMember(
    MeasurementMemberBase^ rem
) override

Parameters

rem
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
See Also

Reference

TriggerModule Class


TriggerModule.UpdatePropertyAttributes Method

Update Attributes of Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

TriggerModule Class


TriggerModule Events

The TriggerModule type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TriggerModule Class


TriggerReleaseInfo Class

TriggerReleaseInfo contains all information about the released trigger
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelTriggerReleaseInfo

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TriggerReleaseInfo : ScopeMemberBase,
    IValueToTimestampCollector
Public Class TriggerReleaseInfo
    Inherits ScopeMemberBase
    Implements IValueToTimestampCollector
public ref class TriggerReleaseInfo : public ScopeMemberBase,
    IValueToTimestampCollector

The TriggerReleaseInfo type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerReleaseInfo | Creates an instance of TriggerReleaseInfo
Public method | TriggerReleaseInfo(TriggerReleaseInfo) | Creates an instance of TriggerReleaseInfo and copy values from org
Top
Properties
 | Name | Description
Public property | AbsoluteContentValue |
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ContentValue | Gets or Sets the ContentValue.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FolderPath | Gets or Sets the FolderPath.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Highlight | Gets or Sets the Highlight.
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | ImageSize | Gets or Sets the ImageSize.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReleaseCount | Gets or Sets the ReleaseCount.
Public property | ReleaseTime | Gets or Sets the ReleaseTime.
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | ThumbnailFilename | Gets the Thumbnail Filename
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | Visible | Gets or Sets the Visible.
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberValue |
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubInterpreterValue |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImageMissing | Called to Report Missing Image at the Path or refresh the Thumbnail
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | (Overrides ObjectToString.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ContentValueChanged | Fired when the ContentValue is changed.
Public event | ContentValueValidating | Fired while validating the new value for ContentValue.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FolderPathChanged | Fired when the FolderPath is changed.
Public event | FolderPathValidating | Fired while validating the new value for FolderPath.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightChanged | Fired when the Highlight is changed.
Public event | HighlightValidating | Fired while validating the new value for Highlight.
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | ImageMissingEvent | Event fired to when an Missing Image ist detected in ViewModel
Public event | ImageSizeChanged | Fired when the ImageSize is changed.
Public event | ImageSizeValidating | Fired while validating the new value for ImageSize.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReleaseCountChanged | Fired when the ReleaseCount is changed.
Public event | ReleaseCountValidating | Fired while validating the new value for ReleaseCount.
Public event | ReleaseTimeChanged | Fired when the ReleaseTime is changed.
Public event | ReleaseTimeValidating | Fired while validating the new value for ReleaseTime.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | VisibleChanged | Fired when the Visible is changed.
Public event | VisibleValidating | Fired while validating the new value for Visible.
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


TriggerReleaseInfo Constructor

Overload List
 | Name | Description
Public method | TriggerReleaseInfo | Creates an instance of TriggerReleaseInfo
Public method | TriggerReleaseInfo(TriggerReleaseInfo) | Creates an instance of TriggerReleaseInfo and copy values from org
Top
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo Constructor

Creates an instance of TriggerReleaseInfo

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerReleaseInfo()
Public Sub New
public:
TriggerReleaseInfo()
See Also

Reference

TriggerReleaseInfo Class
TriggerReleaseInfo Overload


TriggerReleaseInfo Constructor (TriggerReleaseInfo)

Creates an instance of TriggerReleaseInfo and copy values from org

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerReleaseInfo(
    TriggerReleaseInfo org
)
Public Sub New (
    org As TriggerReleaseInfo
)
public:
TriggerReleaseInfo(
    TriggerReleaseInfo^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelTriggerReleaseInfo
See Also

Reference

TriggerReleaseInfo Class
TriggerReleaseInfo Overload


TriggerReleaseInfo Properties

The TriggerReleaseInfo type exposes the following members.

Properties
 | Name | Description
Public property | AbsoluteContentValue |
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | ContentValue | Gets or Sets the ContentValue.
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | FolderPath | Gets or Sets the FolderPath.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Highlight | Gets or Sets the Highlight.
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | ImageSize | Gets or Sets the ImageSize.
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ReleaseCount | Gets or Sets the ReleaseCount.
Public property | ReleaseTime | Gets or Sets the ReleaseTime.
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | ThumbnailFilename | Gets the Thumbnail Filename
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | Visible | Gets or Sets the Visible.
Top
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.AbsoluteContentValue Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
public string AbsoluteContentValue { get; }
<XmlIgnoreAttribute>
Public ReadOnly Property AbsoluteContentValue As String
    Get
public:
[XmlIgnoreAttribute]
property String^ AbsoluteContentValue {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ContentValue Property

Gets or Sets the ContentValue.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public string ContentValue { get; set; }
<BrowsableAttribute(true)>
Public Property ContentValue As String
    Get
    Set
public:
[BrowsableAttribute(true)]
property String^ ContentValue {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.FolderPath Property

Gets or Sets the FolderPath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public string FolderPath { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property FolderPath As String
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property String^ FolderPath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.Highlight Property

Gets or Sets the Highlight.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool Highlight { get; set; }
<BrowsableAttribute(false)>
Public Property Highlight As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool Highlight {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ImageSize Property

Gets or Sets the ImageSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public int ImageSize { get; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public ReadOnly Property ImageSize As Integer
    Get
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property int ImageSize {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ReleaseCount Property

Gets or Sets the ReleaseCount.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public int ReleaseCount { get; set; }
Public Property ReleaseCount As Integer
    Get
    Set
public:
property int ReleaseCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ReleaseTime Property

Gets or Sets the ReleaseTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public long ReleaseTime { get; set; }
Public Property ReleaseTime As Long
    Get
    Set
public:
property long long ReleaseTime {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ThumbnailFilename Property

Gets the Thumbnail Filename

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[XmlIgnoreAttribute]
public string ThumbnailFilename { get; }
<XmlIgnoreAttribute>
Public ReadOnly Property ThumbnailFilename As String
    Get
public:
[XmlIgnoreAttribute]
property String^ ThumbnailFilename {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.Visible Property

Gets or Sets the Visible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool Visible { get; set; }
<BrowsableAttribute(true)>
Public Property Visible As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool Visible {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo Methods

The TriggerReleaseInfo type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberValue |
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubInterpreterValue |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImageMissing | Called to Report Missing Image at the Path or refresh the Thumbnail
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | (Overrides ObjectToString.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Inherited from ScopeMemberBase.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.GetMemberValue Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Object GetMemberValue(
    MeasurementMemberBase member
)
Public Function GetMemberValue (
    member As MeasurementMemberBase
) As Object
public:
virtual Object^ GetMemberValue(
    MeasurementMemberBase^ member
) sealed

Parameters

member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase

Return Value

Type: Object

Implements

IValueToTimestampCollectorGetMemberValue(MeasurementMemberBase)
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.GetSubInterpreterValue Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Object GetSubInterpreterValue(
    MeasurementMemberBase member,
    AcquisitionInterpreter subAcquisitionInterpreter
)
Public Function GetSubInterpreterValue (
    member As MeasurementMemberBase,
    subAcquisitionInterpreter As AcquisitionInterpreter
) As Object
public:
virtual Object^ GetSubInterpreterValue(
    MeasurementMemberBase^ member,
    AcquisitionInterpreter^ subAcquisitionInterpreter
) sealed

Parameters

member
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
subAcquisitionInterpreter
Type: TwinCAT.Measurement.Scope.API.ModelAcquisitionInterpreter

Return Value

Type: Object

Implements

IValueToTimestampCollectorGetSubInterpreterValue(MeasurementMemberBase, AcquisitionInterpreter)
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ImageMissing Method

Called to Report Missing Image at the Path or refresh the Thumbnail

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool ImageMissing(
    string Path
)
Public Function ImageMissing (
    Path As String
) As Boolean
public:
bool ImageMissing(
    String^ Path
)

Parameters

Path
Type: SystemString
The path were the Image should be.

Return Value

Type: Boolean
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ToString Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo Events

The TriggerReleaseInfo type exposes the following members.

Events
 | Name | Description
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ContentValueChanged | Fired when the ContentValue is changed.
Public event | ContentValueValidating | Fired while validating the new value for ContentValue.
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | FolderPathChanged | Fired when the FolderPath is changed.
Public event | FolderPathValidating | Fired while validating the new value for FolderPath.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | HighlightChanged | Fired when the Highlight is changed.
Public event | HighlightValidating | Fired while validating the new value for Highlight.
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | ImageMissingEvent | Event fired to when an Missing Image ist detected in ViewModel
Public event | ImageSizeChanged | Fired when the ImageSize is changed.
Public event | ImageSizeValidating | Fired while validating the new value for ImageSize.
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ReleaseCountChanged | Fired when the ReleaseCount is changed.
Public event | ReleaseCountValidating | Fired while validating the new value for ReleaseCount.
Public event | ReleaseTimeChanged | Fired when the ReleaseTime is changed.
Public event | ReleaseTimeValidating | Fired while validating the new value for ReleaseTime.
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | VisibleChanged | Fired when the Visible is changed.
Public event | VisibleValidating | Fired while validating the new value for Visible.
Top
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ContentValueChanged Event

Fired when the ContentValue is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ContentValueChanged
Public Event ContentValueChanged As EventHandler
public:
 event EventHandler^ ContentValueChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ContentValueValidating Event

Fired while validating the new value for ContentValue.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ContentValueValidating
Public Event ContentValueValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ContentValueValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.FolderPathChanged Event

Fired when the FolderPath is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler FolderPathChanged
Public Event FolderPathChanged As EventHandler
public:
 event EventHandler^ FolderPathChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.FolderPathValidating Event

Fired while validating the new value for FolderPath.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> FolderPathValidating
Public Event FolderPathValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ FolderPathValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.HighlightChanged Event

Fired when the Highlight is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler HighlightChanged
Public Event HighlightChanged As EventHandler
public:
 event EventHandler^ HighlightChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.HighlightValidating Event

Fired while validating the new value for Highlight.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> HighlightValidating
Public Event HighlightValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ HighlightValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ImageMissingEvent Event

Event fired to when an Missing Image ist detected in ViewModel

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<string> ImageMissingEvent
Public Event ImageMissingEvent As EventHandler(Of String)
public:
 event EventHandler<String^>^ ImageMissingEvent {
    void add (EventHandler<String^>^ value);
    void remove (EventHandler<String^>^ value);
}

Value

Type: SystemEventHandler String
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ImageSizeChanged Event

Fired when the ImageSize is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ImageSizeChanged
Public Event ImageSizeChanged As EventHandler
public:
 event EventHandler^ ImageSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ImageSizeValidating Event

Fired while validating the new value for ImageSize.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ImageSizeValidating
Public Event ImageSizeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ImageSizeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ReleaseCountChanged Event

Fired when the ReleaseCount is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReleaseCountChanged
Public Event ReleaseCountChanged As EventHandler
public:
 event EventHandler^ ReleaseCountChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ReleaseCountValidating Event

Fired while validating the new value for ReleaseCount.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReleaseCountValidating
Public Event ReleaseCountValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReleaseCountValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ReleaseTimeChanged Event

Fired when the ReleaseTime is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ReleaseTimeChanged
Public Event ReleaseTimeChanged As EventHandler
public:
 event EventHandler^ ReleaseTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.ReleaseTimeValidating Event

Fired while validating the new value for ReleaseTime.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ReleaseTimeValidating
Public Event ReleaseTimeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ReleaseTimeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.VisibleChanged Event

Fired when the Visible is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler VisibleChanged
Public Event VisibleChanged As EventHandler
public:
 event EventHandler^ VisibleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfo.VisibleValidating Event

Fired while validating the new value for Visible.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> VisibleValidating
Public Event VisibleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ VisibleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerReleaseInfo Class


TriggerReleaseInfoReporting Class

Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.API.ModelTriggerReleaseInfoReporting

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TriggerReleaseInfoReporting
Public Class TriggerReleaseInfoReporting
public ref class TriggerReleaseInfoReporting

The TriggerReleaseInfoReporting type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerReleaseInfoReporting | Initializes a new instance of the TriggerReleaseInfoReporting class
Top
Properties
 | Name | Description
Public property | TriggerGroupName |
Public property | TriggerReleaseInfo |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


TriggerReleaseInfoReporting Constructor

Initializes a new instance of the TriggerReleaseInfoReporting class

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerReleaseInfoReporting(
    TriggerReleaseInfo info,
    string triggerGroupName
)
Public Sub New (
    info As TriggerReleaseInfo,
    triggerGroupName As String
)
public:
TriggerReleaseInfoReporting(
    TriggerReleaseInfo^ info,
    String^ triggerGroupName
)

Parameters

info
Type: TwinCAT.Measurement.Scope.API.ModelTriggerReleaseInfo
triggerGroupName
Type: SystemString
See Also

Reference

TriggerReleaseInfoReporting Class


TriggerReleaseInfoReporting Properties

The TriggerReleaseInfoReporting type exposes the following members.

Properties
 | Name | Description
Public property | TriggerGroupName |
Public property | TriggerReleaseInfo |
Top
See Also

Reference

TriggerReleaseInfoReporting Class


TriggerReleaseInfoReporting.TriggerGroupName Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public string TriggerGroupName { get; set; }
Public Property TriggerGroupName As String
    Get
    Set
public:
property String^ TriggerGroupName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TriggerReleaseInfoReporting Class


TriggerReleaseInfoReporting.TriggerReleaseInfo Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerReleaseInfo TriggerReleaseInfo { get; set; }
Public Property TriggerReleaseInfo As TriggerReleaseInfo
    Get
    Set
public:
property TriggerReleaseInfo^ TriggerReleaseInfo {
    TriggerReleaseInfo^ get ();
    void set (TriggerReleaseInfo^ value);
}

Property Value

Type: TriggerReleaseInfo
See Also

Reference

TriggerReleaseInfoReporting Class


TriggerReleaseInfoReporting Methods

The TriggerReleaseInfoReporting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TriggerReleaseInfoReporting Class


TriggerSet Class

abstract TriggerSet Class in TwinCAT 3 Scope API Model
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelTriggerSet
TwinCAT.Measurement.Scope.API.ModelDirectoryTriggerSet
TwinCAT.Measurement.Scope.API.ModelServerTriggerSet

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class TriggerSet : ScopeMemberContainerBase
Public MustInherit Class TriggerSet
    Inherits ScopeMemberContainerBase
public ref class TriggerSet abstract : public ScopeMemberContainerBase

The TriggerSet type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerSet | Creates an instance of a TriggerSet
Public method | TriggerSet(TriggerSet) | Creates an instance of a TriggerSet and copy values from org
Top
Properties
 | Name | Description
Public property | ClientTriggerHandle | Gets or Sets the ClientTriggerHandle.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GroupHandle | Gets or Sets the GroupHandle.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsReleased | Gets or Sets the IsReleased.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ClientTriggerHandleChanged | Fired when the ClientTriggerHandle is changed.
Public event | ClientTriggerHandleValidating | Fired while validating the new value for ClientTriggerHandle.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GroupHandleChanged | Fired when the GroupHandle is changed.
Public event | GroupHandleValidating | Fired while validating the new value for GroupHandle.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsReleasedChanged | Fired when the IsReleased is changed.
Public event | IsReleasedValidating | Fired while validating the new value for IsReleased.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


TriggerSet Constructor

Overload List
 | Name | Description
Public method | TriggerSet | Creates an instance of a TriggerSet
Public method | TriggerSet(TriggerSet) | Creates an instance of a TriggerSet and copy values from org
Top
See Also

Reference

TriggerSet Class


TriggerSet Constructor

Creates an instance of a TriggerSet

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerSet()
Public Sub New
public:
TriggerSet()
See Also

Reference

TriggerSet Class
TriggerSet Overload


TriggerSet Constructor (TriggerSet)

Creates an instance of a TriggerSet and copy values from org

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerSet(
    TriggerSet org
)
Public Sub New (
    org As TriggerSet
)
public:
TriggerSet(
    TriggerSet^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelTriggerSet
See Also

Reference

TriggerSet Class
TriggerSet Overload


TriggerSet Properties

The TriggerSet type exposes the following members.

Properties
 | Name | Description
Public property | ClientTriggerHandle | Gets or Sets the ClientTriggerHandle.
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | Enabled | Gets or Sets the Enabled.
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GroupHandle | Gets or Sets the GroupHandle.
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsReleased | Gets or Sets the IsReleased.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TriggerSet Class


TriggerSet.ClientTriggerHandle Property

Gets or Sets the ClientTriggerHandle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public uint ClientTriggerHandle { get; set; }
<BrowsableAttribute(false)>
Public Property ClientTriggerHandle As UInteger
    Get
    Set
public:
[BrowsableAttribute(false)]
property unsigned int ClientTriggerHandle {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

TriggerSet Class


TriggerSet.Enabled Property

Gets or Sets the Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool Enabled { get; set; }
<BrowsableAttribute(false)>
Public Property Enabled As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerSet Class


TriggerSet.GroupHandle Property

Gets or Sets the GroupHandle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public uint GroupHandle { get; set; }
<BrowsableAttribute(false)>
Public Property GroupHandle As UInteger
    Get
    Set
public:
[BrowsableAttribute(false)]
property unsigned int GroupHandle {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

TriggerSet Class


TriggerSet.IsReleased Property

Gets or Sets the IsReleased.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
public bool IsReleased { get; set; }
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
Public Property IsReleased As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
property bool IsReleased {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TriggerSet Class


TriggerSet Methods

The TriggerSet type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Sets the value off Propertyattributes (Overrides ScopeMemberContainerBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TriggerSet Class


TriggerSet.UpdatePropertyAttributes Method

Sets the value off Propertyattributes

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

TriggerSet Class


TriggerSet Events

The TriggerSet type exposes the following members.

Events
 | Name | Description
Public event | ClientTriggerHandleChanged | Fired when the ClientTriggerHandle is changed.
Public event | ClientTriggerHandleValidating | Fired while validating the new value for ClientTriggerHandle.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | EnabledChanged | Fired when the Enabled is changed.
Public event | EnabledValidating | Fired while validating the new value for Enabled.
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GroupHandleChanged | Fired when the GroupHandle is changed.
Public event | GroupHandleValidating | Fired while validating the new value for GroupHandle.
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsReleasedChanged | Fired when the IsReleased is changed.
Public event | IsReleasedValidating | Fired while validating the new value for IsReleased.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TriggerSet Class


TriggerSet.ClientTriggerHandleChanged Event

Fired when the ClientTriggerHandle is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ClientTriggerHandleChanged
Public Event ClientTriggerHandleChanged As EventHandler
public:
 event EventHandler^ ClientTriggerHandleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerSet Class


TriggerSet.ClientTriggerHandleValidating Event

Fired while validating the new value for ClientTriggerHandle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> ClientTriggerHandleValidating
Public Event ClientTriggerHandleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ ClientTriggerHandleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerSet Class


TriggerSet.EnabledChanged Event

Fired when the Enabled is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler EnabledChanged
Public Event EnabledChanged As EventHandler
public:
 event EventHandler^ EnabledChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerSet Class


TriggerSet.EnabledValidating Event

Fired while validating the new value for Enabled.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> EnabledValidating
Public Event EnabledValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ EnabledValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerSet Class


TriggerSet.GroupHandleChanged Event

Fired when the GroupHandle is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler GroupHandleChanged
Public Event GroupHandleChanged As EventHandler
public:
 event EventHandler^ GroupHandleChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerSet Class


TriggerSet.GroupHandleValidating Event

Fired while validating the new value for GroupHandle.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> GroupHandleValidating
Public Event GroupHandleValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ GroupHandleValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerSet Class


TriggerSet.IsReleasedChanged Event

Fired when the IsReleased is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler IsReleasedChanged
Public Event IsReleasedChanged As EventHandler
public:
 event EventHandler^ IsReleasedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerSet Class


TriggerSet.IsReleasedValidating Event

Fired while validating the new value for IsReleased.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> IsReleasedValidating
Public Event IsReleasedValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ IsReleasedValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerSet Class


TriggerTimeOffset Class

TriggerTimeOffset Class in TwinCAT 3 Scope API
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberBase
TwinCAT.Measurement.Scope.API.ModelTriggerTimeOffset

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TriggerTimeOffset : ScopeMemberBase
Public Class TriggerTimeOffset
    Inherits ScopeMemberBase
public ref class TriggerTimeOffset : public ScopeMemberBase

The TriggerTimeOffset type exposes the following members.

Constructors
 | Name | Description
Public method | TriggerTimeOffset | Creates a new TriggerTimeOffset Instance
Public method | TriggerTimeOffset(TriggerTimeOffset) | Creates a new TriggerTimeOffset Instance and copy properties from tsc to new instance
Top
Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update PropertyAttributes in dhe PropertyGrid (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | BeforeTimeOffsetChanged | Fired when the TimeOffset is changed.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed.
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


TriggerTimeOffset Constructor

Overload List
 | Name | Description
Public method | TriggerTimeOffset | Creates a new TriggerTimeOffset Instance
Public method | TriggerTimeOffset(TriggerTimeOffset) | Creates a new TriggerTimeOffset Instance and copy properties from tsc to new instance
Top
See Also

Reference

TriggerTimeOffset Class


TriggerTimeOffset Constructor

Creates a new TriggerTimeOffset Instance

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerTimeOffset()
Public Sub New
public:
TriggerTimeOffset()
See Also

Reference

TriggerTimeOffset Class
TriggerTimeOffset Overload


TriggerTimeOffset Constructor (TriggerTimeOffset)

Creates a new TriggerTimeOffset Instance and copy properties from tsc to new instance

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TriggerTimeOffset(
    TriggerTimeOffset tsc
)
Public Sub New (
    tsc As TriggerTimeOffset
)
public:
TriggerTimeOffset(
    TriggerTimeOffset^ tsc
)

Parameters

tsc
Type: TwinCAT.Measurement.Scope.API.ModelTriggerTimeOffset
See Also

Reference

TriggerTimeOffset Class
TriggerTimeOffset Overload


TriggerTimeOffset Properties

The TriggerTimeOffset type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | ScopeState | Gets the State of the Scope Project (Inherited from ScopeMemberBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberBase.)
Public property | TimeOffset | Gets or Sets the TimeOffset.
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TriggerTimeOffset Class


TriggerTimeOffset.TimeOffset Property

Gets or Sets the TimeOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public long TimeOffset { get; set; }
<BrowsableAttribute(true)>
Public Property TimeOffset As Long
    Get
    Set
public:
[BrowsableAttribute(true)]
property long long TimeOffset {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

TriggerTimeOffset Class


TriggerTimeOffset Methods

The TriggerTimeOffset type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberBase.)
Public method | StartMoving | (Inherited from MeasurementMemberBase.)
Public method | StopMoving | (Inherited from MeasurementMemberBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | Update PropertyAttributes in dhe PropertyGrid (Overrides ScopeMemberBaseUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TriggerTimeOffset Class


TriggerTimeOffset.UpdatePropertyAttributes Method

Update PropertyAttributes in dhe PropertyGrid

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

TriggerTimeOffset Class


TriggerTimeOffset Events

The TriggerTimeOffset type exposes the following members.

Events
 | Name | Description
Public event | BeforeTimeOffsetChanged | Fired when the TimeOffset is changed.
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed.
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset.
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TriggerTimeOffset Class


TriggerTimeOffset.BeforeTimeOffsetChanged Event

Fired when the TimeOffset is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler BeforeTimeOffsetChanged
Public Event BeforeTimeOffsetChanged As EventHandler
public:
 event EventHandler^ BeforeTimeOffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerTimeOffset Class


TriggerTimeOffset.TimeOffsetChanged Event

Fired when the TimeOffset is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TimeOffsetChanged
Public Event TimeOffsetChanged As EventHandler
public:
 event EventHandler^ TimeOffsetChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

TriggerTimeOffset Class


TriggerTimeOffset.TimeOffsetValidating Event

Fired while validating the new value for TimeOffset.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> TimeOffsetValidating
Public Event TimeOffsetValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ TimeOffsetValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

TriggerTimeOffset Class


TwoElementSelection_VM Class

ViewModel of the TwoElementSelection
Inheritance Hierarchy
SystemObject
ModelBase
TwinCAT.Measurement.Scope.API.ModelSelectableMember
ElementSelectionVM
TwinCAT.Measurement.Scope.API.ModelTwoElementSelection_VM

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class TwoElementSelection_VM : ElementSelectionVM
Public Class TwoElementSelection_VM
    Inherits ElementSelectionVM
public ref class TwoElementSelection_VM : public ElementSelectionVM

The TwoElementSelection_VM type exposes the following members.

Constructors
 | Name | Description
Public method | TwoElementSelection_VM | CTOR of TwoElementSelection_VM
Top
Properties
 | Name | Description
Public property | FirstMembers | Gets or Sets the FirstMembers.
Public property | FirstSelectedMember | Gets or Sets the FirstSelectedMember.
Public property | IsSelected | Gets or Sets the IsSelected. (Inherited from SelectableMember.)
Public property | SecondMembers | Gets or Sets the SecondMembers.
Public property | SecondSelectedMember | Gets or Sets the SecondSelectedMember.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | ToString (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


TwoElementSelection_VM Constructor

CTOR of TwoElementSelection_VM

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public TwoElementSelection_VM()
Public Sub New
public:
TwoElementSelection_VM()
See Also

Reference

TwoElementSelection_VM Class


TwoElementSelection_VM Properties

The TwoElementSelection_VM type exposes the following members.

Properties
 | Name | Description
Public property | FirstMembers | Gets or Sets the FirstMembers.
Public property | FirstSelectedMember | Gets or Sets the FirstSelectedMember.
Public property | IsSelected | Gets or Sets the IsSelected. (Inherited from SelectableMember.)
Public property | SecondMembers | Gets or Sets the SecondMembers.
Public property | SecondSelectedMember | Gets or Sets the SecondSelectedMember.
Top
See Also

Reference

TwoElementSelection_VM Class


TwoElementSelection_VM.FirstMembers Property

Gets or Sets the FirstMembers.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ObservableCollection<ITreeElementItem> FirstMembers { get; set; }
Public Property FirstMembers As ObservableCollection(Of ITreeElementItem)
    Get
    Set
public:
property ObservableCollection<ITreeElementItem^>^ FirstMembers {
    ObservableCollection<ITreeElementItem^>^ get ();
    void set (ObservableCollection<ITreeElementItem^>^ value);
}

Property Value

Type: ObservableCollection ITreeElementItem
See Also

Reference

TwoElementSelection_VM Class


TwoElementSelection_VM.FirstSelectedMember Property

Gets or Sets the FirstSelectedMember.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MemberTreeElementItem FirstSelectedMember { get; set; }
Public Property FirstSelectedMember As MemberTreeElementItem
    Get
    Set
public:
property MemberTreeElementItem^ FirstSelectedMember {
    MemberTreeElementItem^ get ();
    void set (MemberTreeElementItem^ value);
}

Property Value

Type: MemberTreeElementItem
See Also

Reference

TwoElementSelection_VM Class


TwoElementSelection_VM.SecondMembers Property

Gets or Sets the SecondMembers.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ObservableCollection<ITreeElementItem> SecondMembers { get; set; }
Public Property SecondMembers As ObservableCollection(Of ITreeElementItem)
    Get
    Set
public:
property ObservableCollection<ITreeElementItem^>^ SecondMembers {
    ObservableCollection<ITreeElementItem^>^ get ();
    void set (ObservableCollection<ITreeElementItem^>^ value);
}

Property Value

Type: ObservableCollection ITreeElementItem
See Also

Reference

TwoElementSelection_VM Class


TwoElementSelection_VM.SecondSelectedMember Property

Gets or Sets the SecondSelectedMember.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MemberTreeElementItem SecondSelectedMember { get; set; }
Public Property SecondSelectedMember As MemberTreeElementItem
    Get
    Set
public:
property MemberTreeElementItem^ SecondSelectedMember {
    MemberTreeElementItem^ get ();
    void set (MemberTreeElementItem^ value);
}

Property Value

Type: MemberTreeElementItem
See Also

Reference

TwoElementSelection_VM Class


TwoElementSelection_VM Methods

The TwoElementSelection_VM type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | ToString (Overrides ObjectToString.)
Top
See Also

Reference

TwoElementSelection_VM Class


TwoElementSelection_VM.ToString Method

ToString

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Return Value

Type: String
See Also

Reference

TwoElementSelection_VM Class


TwoElementSelection_VM Events

The TwoElementSelection_VM type exposes the following members.

Events
 | Name | Description
Public event | MessageEvent | (Inherited from ModelBase.)
Public event | PropertyChanged | (Inherited from ModelBase.)
Public event | PropertyChanging | (Inherited from ModelBase.)
Top
See Also

Reference

TwoElementSelection_VM Class


ValueAxis Class

Model class for Value Axis
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAxis
TwinCAT.Measurement.Scope.API.ModelMinMaxRangeAxis
TwinCAT.Measurement.Scope.API.ModelValueAxis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ValueAxis : MinMaxRangeAxis
Public Class ValueAxis
    Inherits MinMaxRangeAxis
public ref class ValueAxis : public MinMaxRangeAxis

The ValueAxis type exposes the following members.

Constructors
 | Name | Description
Public method | ValueAxis | Create a new Axis with and default Orientation
Public method | ValueAxis(AxisOrientation) | Create new Value Axis with a custom Orientation
Public method | ValueAxis(ValueAxis) | Create a new Value Axis by Copying Properties from another Value Axis
Top
Properties
 | Name | Description
Public property | ActualTitle | Gets or Sets the ActualTitle. (Inherited from Axis.)
Public property | AspectRatioScaleFactor | Gets or Sets the AspectRatioScaleFactor. (Inherited from Axis.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetDisplayRange | Get or Set the GetDisplayRange (Inherited from MinMaxRangeAxis.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Inverted | Gets or Sets the Inverted. (Inherited from Axis.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Logarithmic | Gets or Sets the Logarithmic. (Inherited from Axis.)
Public property | ManualMax | Gets or Sets the ManualMax. (Inherited from Axis.)
Public property | ManualMin | Gets or Sets the ManualMin. (Inherited from Axis.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Axis.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScalingMode | Gets or Sets the ScalingMode. (Inherited from Axis.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | (Inherited from Axis.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from Axis.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserSettingsAxisInstance | (Overrides AxisGetUserSettingsAxisInstance.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | (Overrides AxisUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
Events
 | Name | Description
Public event | ActualTitleChanged | Fired when the ActualTitle is changed. (Inherited from Axis.)
Public event | ActualTitleValidating | Fired while validating the new value for ActualTitle. (Inherited from Axis.)
Public event | AspectRatioScaleFactorChanged | Fired when the AspectRatioScaleFactor is changed. (Inherited from Axis.)
Public event | AspectRatioScaleFactorValidating | Fired while validating the new value for AspectRatioScaleFactor. (Inherited from Axis.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DefaultRescale | Fired if the axis should rescale to default values (Inherited from Axis.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InvertedChanged | Fired when the Inverted is changed. (Inherited from Axis.)
Public event | InvertedValidating | Fired while validating the new value for Inverted. (Inherited from Axis.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LogarithmicChanged | Fired when the Logarithmic is changed. (Inherited from Axis.)
Public event | LogarithmicValidating | Fired while validating the new value for Logarithmic. (Inherited from Axis.)
Public event | ManualMaxChanged | Fired when the ManualMax is changed. (Inherited from Axis.)
Public event | ManualMaxValidating | Fired while validating the new value for ManualMax. (Inherited from Axis.)
Public event | ManualMinChanged | Fired when the ManualMin is changed. (Inherited from Axis.)
Public event | ManualMinValidating | Fired while validating the new value for ManualMin. (Inherited from Axis.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Axis.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Axis.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScalingModeChanged | Fired when the ScalingMode is changed. (Inherited from Axis.)
Public event | ScalingModeValidating | Fired while validating the new value for ScalingMode. (Inherited from Axis.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


ValueAxis Constructor

Overload List
 | Name | Description
Public method | ValueAxis | Create a new Axis with and default Orientation
Public method | ValueAxis(AxisOrientation) | Create new Value Axis with a custom Orientation
Public method | ValueAxis(ValueAxis) | Create a new Value Axis by Copying Properties from another Value Axis
Top
See Also

Reference

ValueAxis Class


ValueAxis Constructor

Create a new Axis with and default Orientation

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ValueAxis()
Public Sub New
public:
ValueAxis()
See Also

Reference

ValueAxis Class
ValueAxis Overload


ValueAxis Constructor (AxisOrientation)

Create new Value Axis with a custom Orientation

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ValueAxis(
    AxisOrientation Orientation
)
Public Sub New (
    Orientation As AxisOrientation
)
public:
ValueAxis(
    AxisOrientation Orientation
)

Parameters

Orientation
Type: TwinCAT.Measurement.Scope.APIAxisOrientation
See Also

Reference

ValueAxis Class
ValueAxis Overload


ValueAxis Constructor (ValueAxis)

Create a new Value Axis by Copying Properties from another Value Axis

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ValueAxis(
    ValueAxis org
)
Public Sub New (
    org As ValueAxis
)
public:
ValueAxis(
    ValueAxis^ org
)

Parameters

org
Type: TwinCAT.Measurement.Scope.API.ModelValueAxis
Axis to copy from
See Also

Reference

ValueAxis Class
ValueAxis Overload


ValueAxis Properties

The ValueAxis type exposes the following members.

Properties
 | Name | Description
Public property | ActualTitle | Gets or Sets the ActualTitle. (Inherited from Axis.)
Public property | AspectRatioScaleFactor | Gets or Sets the AspectRatioScaleFactor. (Inherited from Axis.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from MeasurementMemberBase.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | GetDisplayRange | Get or Set the GetDisplayRange (Inherited from MinMaxRangeAxis.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | Inverted | Gets or Sets the Inverted. (Inherited from Axis.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | Logarithmic | Gets or Sets the Logarithmic. (Inherited from Axis.)
Public property | ManualMax | Gets or Sets the ManualMax. (Inherited from Axis.)
Public property | ManualMin | Gets or Sets the ManualMin. (Inherited from Axis.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | Orientation | Gets or Sets the Orientation. (Inherited from Axis.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScalingMode | Gets or Sets the ScalingMode. (Inherited from Axis.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | Style | (Inherited from Axis.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | Title | Gets or Sets the Title. (Inherited from Axis.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ValueAxis Class


ValueAxis Methods

The ValueAxis type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetCommands | Gets a List of possible Commands for this Element (Inherited from ScopeMemberContainerBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserSettingsAxisInstance | (Overrides AxisGetUserSettingsAxisInstance.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdatePropertyAttributes | (Overrides AxisUpdatePropertyAttributes.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ValueAxis Class


ValueAxis.GetUserSettingsAxisInstance Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override Axis GetUserSettingsAxisInstance()
Public Overrides Function GetUserSettingsAxisInstance As Axis
public:
virtual Axis^ GetUserSettingsAxisInstance() override

Return Value

Type: Axis
See Also

Reference

ValueAxis Class


ValueAxis.UpdatePropertyAttributes Method

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

ValueAxis Class


ValueAxis Events

The ValueAxis type exposes the following members.

Events
 | Name | Description
Public event | ActualTitleChanged | Fired when the ActualTitle is changed. (Inherited from Axis.)
Public event | ActualTitleValidating | Fired while validating the new value for ActualTitle. (Inherited from Axis.)
Public event | AspectRatioScaleFactorChanged | Fired when the AspectRatioScaleFactor is changed. (Inherited from Axis.)
Public event | AspectRatioScaleFactorValidating | Fired while validating the new value for AspectRatioScaleFactor. (Inherited from Axis.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | DefaultRescale | Fired if the axis should rescale to default values (Inherited from Axis.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | InvertedChanged | Fired when the Inverted is changed. (Inherited from Axis.)
Public event | InvertedValidating | Fired while validating the new value for Inverted. (Inherited from Axis.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | LogarithmicChanged | Fired when the Logarithmic is changed. (Inherited from Axis.)
Public event | LogarithmicValidating | Fired while validating the new value for Logarithmic. (Inherited from Axis.)
Public event | ManualMaxChanged | Fired when the ManualMax is changed. (Inherited from Axis.)
Public event | ManualMaxValidating | Fired while validating the new value for ManualMax. (Inherited from Axis.)
Public event | ManualMinChanged | Fired when the ManualMin is changed. (Inherited from Axis.)
Public event | ManualMinValidating | Fired while validating the new value for ManualMin. (Inherited from Axis.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | OrientationChanged | Fired when the Orientation is changed. (Inherited from Axis.)
Public event | OrientationValidating | Fired while validating the new value for Orientation. (Inherited from Axis.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ScalingModeChanged | Fired when the ScalingMode is changed. (Inherited from Axis.)
Public event | ScalingModeValidating | Fired while validating the new value for ScalingMode. (Inherited from Axis.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

ValueAxis Class


XORFunction Class

Function object with XOR Comparer
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.Scope.API.ModelFunction
TwinCAT.Measurement.Scope.API.ModelDoubleInputFunction
TwinCAT.Measurement.Scope.API.ModelXORFunction

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class XORFunction : DoubleInputFunction
Public Class XORFunction
    Inherits DoubleInputFunction
public ref class XORFunction : public DoubleInputFunction

The XORFunction type exposes the following members.

Constructors
 | Name | Description
Public method | XORFunction | Create a new XOR Function
Top
Properties
 | Name | Description
Public property | Value | The Result of the 2 Comapred Values (Overrides FunctionValue.)
Top
Methods
 | Name | Description
Public method | Contains | Test if the Function contains the ICodition (Inherited from DoubleInputFunction.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


XORFunction Constructor

Create a new XOR Function

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public XORFunction(
    ICondition Input1,
    ICondition Input2
)
Public Sub New (
    Input1 As ICondition,
    Input2 As ICondition
)
public:
XORFunction(
    ICondition^ Input1,
    ICondition^ Input2
)

Parameters

Input1
Type: TwinCAT.Measurement.Scope.API.ModelICondition
The First Condition
Input2
Type: TwinCAT.Measurement.Scope.API.ModelICondition
The Second Condition
See Also

Reference

XORFunction Class


XORFunction Properties

The XORFunction type exposes the following members.

Properties
 | Name | Description
Public property | Value | The Result of the 2 Comapred Values (Overrides FunctionValue.)
Top
See Also

Reference

XORFunction Class


XORFunction.Value Property

The Result of the 2 Comapred Values

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool Value { get; }
Public Overrides ReadOnly Property Value As Boolean
    Get
public:
virtual property bool Value {
    bool get () override;
}

Property Value

Type: Boolean

Implements

IConditionValue
See Also

Reference

XORFunction Class


XORFunction Methods

The XORFunction type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Test if the Function contains the ICodition (Inherited from DoubleInputFunction.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XORFunction Class


XYChart Class

Scope Project XY-Chart class
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAnchorTimeBase
TwinCAT.Measurement.Scope.API.ModelChart
TwinCAT.Measurement.Scope.API.ModelConnectableChart
TwinCAT.Measurement.Scope.API.ModelXYChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class XYChart : ConnectableChart
Public Class XYChart
    Inherits ConnectableChart
public ref class XYChart : public ConnectableChart

The XYChart type exposes the following members.

Constructors
 | Name | Description
Public method | XYChart | Create a new Empty XY-Chart
Public method | XYChart(XYChart) | Create an XY-Chart and copy Properties from other XY-Chart
Top
Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Inherited from Chart.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | (Overrides ChartChannelDimensions.)
Public property | ChartType | (Overrides ChartChartType.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | MaxResolution | Gets or Sets the MaxResolution.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ChartUpdatePropertyAttributes.)
Public method | Validate | Validate the current Configuration (Overrides ChartValidate.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MaxResolutionChanged | Fired when the MaxResolution is changed.
Public event | MaxResolutionValidating | Fired while validating the new value for MaxResolution.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


XYChart Constructor

Overload List
 | Name | Description
Public method | XYChart | Create a new Empty XY-Chart
Public method | XYChart(XYChart) | Create an XY-Chart and copy Properties from other XY-Chart
Top
See Also

Reference

XYChart Class


XYChart Constructor

Create a new Empty XY-Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public XYChart()
Public Sub New
public:
XYChart()
See Also

Reference

XYChart Class
XYChart Overload


XYChart Constructor (XYChart)

Create an XY-Chart and copy Properties from other XY-Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public XYChart(
    XYChart Chart
)
Public Sub New (
    Chart As XYChart
)
public:
XYChart(
    XYChart^ Chart
)

Parameters

Chart
Type: TwinCAT.Measurement.Scope.API.ModelXYChart
See Also

Reference

XYChart Class
XYChart Overload


XYChart Properties

The XYChart type exposes the following members.

Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Inherited from Chart.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | (Overrides ChartChannelDimensions.)
Public property | ChartType | (Overrides ChartChartType.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | MaxResolution | Gets or Sets the MaxResolution.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

XYChart Class


XYChart.ChannelDimensions Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override int ChannelDimensions { get; }
Public Overrides ReadOnly Property ChannelDimensions As Integer
    Get
public:
virtual property int ChannelDimensions {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

XYChart Class


XYChart.ChartType Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public override ChartType ChartType { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ChartType As ChartType
    Get
public:
[BrowsableAttribute(false)]
virtual property ChartType ChartType {
    ChartType get () override;
}

Property Value

Type: ChartType
See Also

Reference

XYChart Class


XYChart.MaxResolution Property

Gets or Sets the MaxResolution.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public uint MaxResolution { get; set; }
<BrowsableAttribute(true)>
Public Property MaxResolution As UInteger
    Get
    Set
public:
[BrowsableAttribute(true)]
property unsigned int MaxResolution {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

XYChart Class


XYChart Methods

The XYChart type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ChartUpdatePropertyAttributes.)
Public method | Validate | Validate the current Configuration (Overrides ChartValidate.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
See Also

Reference

XYChart Class


XYChart.UpdatePropertyAttributes Method

Update the Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

XYChart Class


XYChart.Validate Method

Validate the current Configuration

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void Validate()
Public Overrides Sub Validate
public:
virtual void Validate() override
See Also

Reference

XYChart Class


XYChart Events

The XYChart type exposes the following members.

Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MaxResolutionChanged | Fired when the MaxResolution is changed.
Public event | MaxResolutionValidating | Fired while validating the new value for MaxResolution.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

XYChart Class


XYChart.MaxResolutionChanged Event

Fired when the MaxResolution is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler MaxResolutionChanged
Public Event MaxResolutionChanged As EventHandler
public:
 event EventHandler^ MaxResolutionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

XYChart Class


XYChart.MaxResolutionValidating Event

Fired while validating the new value for MaxResolution.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> MaxResolutionValidating
Public Event MaxResolutionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ MaxResolutionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

XYChart Class


XYChart Fields

The XYChart type exposes the following members.

Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

XYChart Class


XYZChart Class

Chart Class for XYZ-Charts
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAnchorTimeBase
TwinCAT.Measurement.Scope.API.ModelChart
TwinCAT.Measurement.Scope.API.ModelConnectableChart
TwinCAT.Measurement.Scope.API.ModelXYZChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class XYZChart : ConnectableChart
Public Class XYZChart
    Inherits ConnectableChart
public ref class XYZChart : public ConnectableChart

The XYZChart type exposes the following members.

Constructors
 | Name | Description
Public method | XYZChart | Create a new Empty XY-Chart
Public method | XYZChart(XYZChart) | Create an XY-Chart and copy Properties from other XY-Chart
Top
Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Overrides ChartCanContainsChartLayer.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Overrides ChartChannelDimensions.)
Public property | ChartType | (Overrides ChartChartType.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | MaxResolution | Gets or Sets the MaxResolution.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseDefaultOrbit | Gets or Sets the UseDefaultOrbit.
Public property | UsePointZoom | Gets or Sets the UsePointZoom.
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ChartUpdatePropertyAttributes.)
Public method | Validate | Validate the current Configuration (Overrides ChartValidate.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MaxResolutionChanged | Fired when the MaxResolution is changed.
Public event | MaxResolutionValidating | Fired while validating the new value for MaxResolution.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseDefaultOrbitChanged | Fired when the UseDefaultOrbit is changed.
Public event | UseDefaultOrbitValidating | Fired while validating the new value for UseDefaultOrbit.
Public event | UsePointZoomChanged | Fired when the UsePointZoom is changed.
Public event | UsePointZoomValidating | Fired while validating the new value for UsePointZoom.
Top
Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


XYZChart Constructor

Overload List
 | Name | Description
Public method | XYZChart | Create a new Empty XY-Chart
Public method | XYZChart(XYZChart) | Create an XY-Chart and copy Properties from other XY-Chart
Top
See Also

Reference

XYZChart Class


XYZChart Constructor

Create a new Empty XY-Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public XYZChart()
Public Sub New
public:
XYZChart()
See Also

Reference

XYZChart Class
XYZChart Overload


XYZChart Constructor (XYZChart)

Create an XY-Chart and copy Properties from other XY-Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public XYZChart(
    XYZChart Chart
)
Public Sub New (
    Chart As XYZChart
)
public:
XYZChart(
    XYZChart^ Chart
)

Parameters

Chart
Type: TwinCAT.Measurement.Scope.API.ModelXYZChart
See Also

Reference

XYZChart Class
XYZChart Overload


XYZChart Properties

The XYZChart type exposes the following members.

Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Overrides ChartCanContainsChartLayer.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Overrides ChartChannelDimensions.)
Public property | ChartType | (Overrides ChartChartType.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | MaxResolution | Gets or Sets the MaxResolution.
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public property | UseDefaultOrbit | Gets or Sets the UseDefaultOrbit.
Public property | UsePointZoom | Gets or Sets the UsePointZoom.
Top
See Also

Reference

XYZChart Class


XYZChart.CanContainsChartLayer Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override bool CanContainsChartLayer { get; }
Public Overrides ReadOnly Property CanContainsChartLayer As Boolean
    Get
public:
virtual property bool CanContainsChartLayer {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

XYZChart Class


XYZChart.ChannelDimensions Property

Get the ChannelDimensions

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override int ChannelDimensions { get; }
Public Overrides ReadOnly Property ChannelDimensions As Integer
    Get
public:
virtual property int ChannelDimensions {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

XYZChart Class


XYZChart.ChartType Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public override ChartType ChartType { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ChartType As ChartType
    Get
public:
[BrowsableAttribute(false)]
virtual property ChartType ChartType {
    ChartType get () override;
}

Property Value

Type: ChartType
See Also

Reference

XYZChart Class


XYZChart.MaxResolution Property

Gets or Sets the MaxResolution.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public uint MaxResolution { get; set; }
<BrowsableAttribute(true)>
Public Property MaxResolution As UInteger
    Get
    Set
public:
[BrowsableAttribute(true)]
property unsigned int MaxResolution {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

XYZChart Class


XYZChart.UseDefaultOrbit Property

Gets or Sets the UseDefaultOrbit.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool UseDefaultOrbit { get; set; }
<BrowsableAttribute(false)>
Public Property UseDefaultOrbit As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool UseDefaultOrbit {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

XYZChart Class


XYZChart.UsePointZoom Property

Gets or Sets the UsePointZoom.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public bool UsePointZoom { get; set; }
<BrowsableAttribute(false)>
Public Property UsePointZoom As Boolean
    Get
    Set
public:
[BrowsableAttribute(false)]
property bool UsePointZoom {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

XYZChart Class


XYZChart Methods

The XYZChart type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update the Attributes of the Properties (Overrides ChartUpdatePropertyAttributes.)
Public method | Validate | Validate the current Configuration (Overrides ChartValidate.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
See Also

Reference

XYZChart Class


XYZChart.UpdatePropertyAttributes Method

Update the Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

XYZChart Class


XYZChart.Validate Method

Validate the current Configuration

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void Validate()
Public Overrides Sub Validate
public:
virtual void Validate() override
See Also

Reference

XYZChart Class


XYZChart Events

The XYZChart type exposes the following members.

Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MaxResolutionChanged | Fired when the MaxResolution is changed.
Public event | MaxResolutionValidating | Fired while validating the new value for MaxResolution.
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Public event | UseDefaultOrbitChanged | Fired when the UseDefaultOrbit is changed.
Public event | UseDefaultOrbitValidating | Fired while validating the new value for UseDefaultOrbit.
Public event | UsePointZoomChanged | Fired when the UsePointZoom is changed.
Public event | UsePointZoomValidating | Fired while validating the new value for UsePointZoom.
Top
See Also

Reference

XYZChart Class


XYZChart.MaxResolutionChanged Event

Fired when the MaxResolution is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler MaxResolutionChanged
Public Event MaxResolutionChanged As EventHandler
public:
 event EventHandler^ MaxResolutionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

XYZChart Class


XYZChart.MaxResolutionValidating Event

Fired while validating the new value for MaxResolution.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> MaxResolutionValidating
Public Event MaxResolutionValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ MaxResolutionValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

XYZChart Class


XYZChart.UseDefaultOrbitChanged Event

Fired when the UseDefaultOrbit is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UseDefaultOrbitChanged
Public Event UseDefaultOrbitChanged As EventHandler
public:
 event EventHandler^ UseDefaultOrbitChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

XYZChart Class


XYZChart.UseDefaultOrbitValidating Event

Fired while validating the new value for UseDefaultOrbit.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UseDefaultOrbitValidating
Public Event UseDefaultOrbitValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UseDefaultOrbitValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

XYZChart Class


XYZChart.UsePointZoomChanged Event

Fired when the UsePointZoom is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler UsePointZoomChanged
Public Event UsePointZoomChanged As EventHandler
public:
 event EventHandler^ UsePointZoomChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

XYZChart Class


XYZChart.UsePointZoomValidating Event

Fired while validating the new value for UsePointZoom.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> UsePointZoomValidating
Public Event UsePointZoomValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ UsePointZoomValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

XYZChart Class


XYZChart Fields

The XYZChart type exposes the following members.

Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

XYZChart Class


YTChart Class

Scope YT-Chart Class
Inheritance Hierarchy
SystemObject
TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
TwinCAT.Measurement.ProjectBaseMeasurementMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelScopeMemberContainerBase
TwinCAT.Measurement.Scope.API.ModelAnchorTimeBase
TwinCAT.Measurement.Scope.API.ModelChart
TwinCAT.Measurement.Scope.API.ModelConnectableChart
TwinCAT.Measurement.Scope.API.ModelYTChart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class YTChart : ConnectableChart
Public Class YTChart
    Inherits ConnectableChart
public ref class YTChart : public ConnectableChart

The YTChart type exposes the following members.

Constructors
 | Name | Description
Public method | YTChart | Create a new Empty YT-Chart
Public method | YTChart(YTChart) | Create a new YT-Chart by copying Properties from other YT-Chart
Top
Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Inherited from Chart.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Inherited from Chart.)
Public property | ChartType | (Overrides ChartChartType.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayOverwriteMode | Gets or Sets the DisplayOverwriteMode.
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update Attributes of the Properties (Overrides ChartUpdatePropertyAttributes.)
Public method | Validate | Validate the Configuration of the Chart (Overrides ChartValidate.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayOverwriteModeChanged | Fired when the DisplayOverwriteMode is changed.
Public event | DisplayOverwriteModeValidating | Fired while validating the new value for DisplayOverwriteMode.
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.API.Model Namespace


YTChart Constructor

Overload List
 | Name | Description
Public method | YTChart | Create a new Empty YT-Chart
Public method | YTChart(YTChart) | Create a new YT-Chart by copying Properties from other YT-Chart
Top
See Also

Reference

YTChart Class


YTChart Constructor

Create a new Empty YT-Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public YTChart()
Public Sub New
public:
YTChart()
See Also

Reference

YTChart Class
YTChart Overload


YTChart Constructor (YTChart)

Create a new YT-Chart by copying Properties from other YT-Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public YTChart(
    YTChart Chart
)
Public Sub New (
    Chart As YTChart
)
public:
YTChart(
    YTChart^ Chart
)

Parameters

Chart
Type: TwinCAT.Measurement.Scope.API.ModelYTChart
YT-Chart to copy from
See Also

Reference

YTChart Class
YTChart Overload


YTChart Properties

The YTChart type exposes the following members.

Properties
 | Name | Description
Public property | ActiveMouseMode | Gets or Sets the ActiveMouseMode. (Inherited from Chart.)
Public property | AnchorTimestamp | Gets or Sets the AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public property | AssignedCore | Gets or Sets the AssignedCore. (Inherited from Chart.)
Public property | AutoStart | Gets or Sets the AutoStart. (Inherited from Chart.)
Public property | CanContainsChartLayer | (Inherited from Chart.)
Public property | CanCopyToClipboard | Gets or Sets the CanCopyToClipboard. True if the CopyToClipboard event has any event handler, otherwise false. (Inherited from Chart.)
Public property | ChannelDimensions | Get the ChannelDimensions (Inherited from Chart.)
Public property | ChartType | (Overrides ChartChartType.)
Public property | CMasterChart | Gets or Sets the CMasterChart. (Inherited from Chart.)
Public property | Comment | Gets or Sets the Comment. (Inherited from MeasurementMemberBase.)
Public property | Connected | Get the ConnectionState (Inherited from ConnectableChart.)
Public property | ConnectedTimeMember | Gets or Sets the ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public property | ConnectedTimeMemberGuid | Gets or Sets the ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public property | ContainsImageAcquisition | Delegate Property to get the Contains Image Acquisition Information (Inherited from Chart.)
Public property | DefaultDisplayWidth | Gets or Sets the DefaultDisplayWidth. (Inherited from Chart.)
Public property | DisableNameCheck | Get or Set DisableNameCheck (Inherited from ScopeMemberContainerBase.)
Public property | DisplayColor | Gets or Sets the DisplayColor. (Inherited from Chart.)
Public property | DisplayOverwriteMode | Gets or Sets the DisplayOverwriteMode.
Public property | DisplayWidth | Gets or Sets the DisplayWidth. (Inherited from Chart.)
Public property | DragData | Gets the drag data. (Inherited from MeasurementMemberBase.)
Public property | DurationLength | Gets or Sets the DurationLength. (Inherited from AnchorTimeBase.)
Public property | EndTime | Gets or Sets the EndTime. (Inherited from Chart.)
Public property | FilePath | Gets or Sets the FilePath. (Inherited from MeasurementMemberBase.)
Public property | ForeColor | Gets or Sets the ForeColor. (Inherited from Chart.)
Public property | GetMarkerContainerFromProject | /Delegate Property to ask for the MarkerContainer from ScopeProject (Inherited from Chart.)
Public property | GetMarkerImageSpace | Delegate Property to ask for MaxImageSize from Scope Project (Inherited from Chart.)
Public property | GetRecordTime | Delegate Property to ask for RecordTime from Scope Project (Inherited from Chart.)
Public property | GetTriggerGroupsFromProject | Delegate Property to ask for all TriggerGroups from Scope Project (Inherited from Chart.)
Public property | GraphicLibrary | Gets the GraphicLibrary of the Chart. This Property does not have an effect on the Charting. Use ScopePanel.GraphicLib or ChartPanel.GraphicLib instead. (Inherited from Chart.)
Public property | Guid | Gets or Sets the Guid. (Inherited from MeasurementMemberBase.)
Public property | HandleException | Gets or Sets the HandleException. (Inherited from MeasurementMemberBase.)
Public property | HasIcon | Determines wether the Icon is initialized (Inherited from MeasurementMemberBase.)
Public property | HasPanel | Gets or sets a value indicating whether this instance has panel. (Inherited from Chart.)
Public property | HelpString | Get the HelpString (Inherited from ScopeMemberContainerBase.)
Public property | Icon | Get or Set the Icon (Inherited from MeasurementMemberBase.)
Public property | IsFileBased | Gets or Sets the IsFilebased. (Inherited from MeasurementMemberBase.)
Public property | IsMoving | (Inherited from MeasurementMemberBase.)
Public property | IsUpdating | Gets or Sets the IsUpdating. (Inherited from Chart.)
Public property | Live | Gets or Sets the Live. (Inherited from Chart.)
Public property | MasterChart | Gets or Sets the MasterChart. (Inherited from Chart.)
Public property | Name | Gets or Sets the Name. (Inherited from MeasurementMemberBase.)
Public property | Namespace | Gets or Sets the Namespace. (Inherited from MeasurementMemberBase.)
Public property | PositionAbsolute | Gets or Sets the PositionAbsolute. (Inherited from Chart.)
Public property | PositionOffset | Gets or Sets the PositionOffset. (Inherited from Chart.)
Public property | ProjectState | Gets or Sets the ProjectState. (Inherited from MeasurementMemberBase.)
Public property | RedoPossible | Gets or Sets the RedoPossible. (Inherited from Chart.)
Public property | RefreshChartTimes | Delegate Property to call Controls RefreshChartScreen Method (Inherited from Chart.)
Public property | Resolution | Gets or Sets the Resolution. (Inherited from Chart.)
Public property | SaveSubMember | Gets or Sets the SaveSubMember. (Inherited from MeasurementMemberContainerBase.)
Public property | ScopeState | Gets the current state of the ScopeProject (Inherited from ScopeMemberContainerBase.)
Public property | ShowImageChart | Gets or Sets the ShowImageChart. (Inherited from Chart.)
Public property | SortPriority | Gets or Sets the SortPriority. (Inherited from MeasurementMemberBase.)
Public property | StartTime | Gets or Sets the StartTime. (Inherited from Chart.)
Public property | Style | Returns the first Style object found in the SubMemberCollection (Inherited from Chart.)
Public property | SubMember | Get all SubMember (Inherited from MeasurementMemberContainerBase.)
Public property | Suffix | Gets or sets the Suffix. (Inherited from MeasurementMemberBase.)
Public property | SuppressMessages | Supress Question Manager Messages (Inherited from ScopeMemberContainerBase.)
Public property | SuspendGetData | Suspend the GetData (Inherited from Chart.)
Public property | TimeOffset | Gets or Sets the TimeOffset. (Inherited from AnchorTimeBase.)
Public property | TimeRefreshMode | Gets or Sets the TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public property | Title | Gets or Sets the Title. (Inherited from MeasurementMemberBase.)
Public property | TriggerGroupOffset | Gets or Sets the TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public property | UndoPossible | Gets or Sets the UndoPossible. (Inherited from Chart.)
Public property | UnsavedChanges | Gets or Sets the UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

YTChart Class


YTChart.ChartType Property

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public override ChartType ChartType { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ChartType As ChartType
    Get
public:
[BrowsableAttribute(false)]
virtual property ChartType ChartType {
    ChartType get () override;
}

Property Value

Type: ChartType
See Also

Reference

YTChart Class


YTChart.DisplayOverwriteMode Property

Gets or Sets the DisplayOverwriteMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(true)]
public bool DisplayOverwriteMode { get; set; }
<BrowsableAttribute(true)>
Public Property DisplayOverwriteMode As Boolean
    Get
    Set
public:
[BrowsableAttribute(true)]
property bool DisplayOverwriteMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

YTChart Class


YTChart Methods

The YTChart type exposes the following members.

Methods
 | Name | Description
Public method | AddMember | Add a Member to the SubMemberCollection (Inherited from MeasurementMemberContainerBase.)
Public method | AddMemberRange | Add a Range of Member to the SubMember Collection (Inherited from MeasurementMemberContainerBase.)
Public method | AddTimestampImageTrigger | Adds a Trigger with a path of an Image with an Timestamp in the name. (Inherited from Chart.)
Public method | AnyT | Returns true if at least one SubMember of Type T contained in SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | AnyT(FuncT, Boolean) | Determine wether any SubMember of Type T fullfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | AppandDisplayWidthAndPositionCommand | Add an command to the Undo Redo Stack to Undo Position to Before Position and Before DisplayWidth (Inherited from Chart.)
Public method | ClearSubMember | Remove all SubMembers (Inherited from MeasurementMemberContainerBase.)
Public method | Clone | Clone the Current Element (Inherited from MeasurementMemberBase.)
Public method | CloneRecursive | Clone this element recursive (Inherited from MeasurementMemberBase.)
Public method | Contains | Determine wether the Member is Contained in SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | ConvertT | Convert a Value from String (Inherited from MeasurementMemberBase.)
Public method | Copy | Copy Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | CreateChartRefLayer | Create autogenerated RefLayer and copy channels to seperated class (Inherited from Chart.)
Public method | EndPositionMultiCommand | Start MultiCommand on Position Stack (Inherited from Chart.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Errorhandler | Used to catch errors from Controls (Inherited from Chart.)
Public method | FindT | Find the first SubMember of Type T, which fulfils the predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT | Get the First SubElement of Type T (Inherited from MeasurementMemberContainerBase.)
Public method | FirstOrDefaultT(FuncT, Boolean) | Get the First SubElement of Type T, which fulfils the predicate (Inherited from MeasurementMemberContainerBase.)
Public method | ForceDisplay | (Inherited from ConnectableChart.)
Public method | GetAcquisitionData | Gets the Acquisition Data from the timestamp (Inherited from ConnectableChart.)
Public method | GetAllSubmember | (Inherited from MeasurementMemberContainerBase.)
Public method | GetChartLayers | Return all ChartLayers (Inherited from Chart.)
Public method | GetCommands | Gets an Array of possible Commands (Inherited from Chart.)
Public method | GetConnectedTriggerGroups | Get Connected TriggerGroups (Inherited from Chart.)
Public method | GetDisplay | Refreshes the values of the actual Chart (Inherited from ConnectableChart.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLayerLicenseState | Get the loaded layer license state (Inherited from Chart.)
Public method | GetSchema | Get the XML-Schema (Inherited from MeasurementMemberBase.)
Public method | GetSubMemberT | Get all Submember of a specific type (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT(FuncT, Boolean) | Filter GetSubMemberT by predicate. (Inherited from MeasurementMemberContainerBase.)
Public method | GetSubMemberT1, T2(FuncT2, Boolean) | Get all SubMember from the Second Layer (Inherited from MeasurementMemberContainerBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HighlightTriggerGroup | Highlight the TriggerGroup --> Center the tatest TriggerRelease in the Center of the Chart (Inherited from ConnectableChart.)
Public method | JumpToWithOffset | Jump to timestamp with small offset. Only if the timestamp is outside of the current chart (Inherited from Chart.)
Public method | Link | Link the List of Elements to this Member (Inherited from MeasurementMemberBase.)
Public method | MeasurementMemberContainerBase_MemberContentChanged | Used to Handle MemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | MeasurementMemberContainerBase_SubMemberContentChanged | Used to Handle SubMemberContentChanged-Event of an SubMember (Inherited from MeasurementMemberContainerBase.)
Public method | Move(Guid, Int32) | Moves an Element from the Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListGuid, Boolean, Int32) | Moves Elements from Source Parent to this Element (Inherited from ScopeMemberContainerBase.)
Public method | Move(ListTupleMeasurementMemberContainerBase, MeasurementMemberBase, Boolean, Int32) | Move Elements to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | Move(MeasurementMemberContainerBase, MeasurementMemberBase, Int32) | Move Element to this Container (Inherited from MeasurementMemberContainerBase.)
Public method | PrepaireInteraction | Prepairs an Interaction (Drag/Drop or Copy/Paste) with an List of Elements (Inherited from MeasurementMemberBase.)
Public method | RaiseCopyToClipboard | Raises the CopyToClipboard event. (Inherited from Chart.)
Public method | RaiseMessage | Raise the Message Event and log it in the Trace (Inherited from Chart.)
Public method | RaiseSelected | Raises Selection (Inherited from Chart.)
Public method | ReadXml | Read Element Configuration from XML (Inherited from MeasurementMemberBase.)
Public method | RedoPosition | Redo 1 Position Setting (Inherited from Chart.)
Public method | RemoveMember | Remove a Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RemoveMemberRange | Remove a Range of Member from the SubMemberList (Inherited from MeasurementMemberContainerBase.)
Public method | RenewDisplay | Renew the actual Display (Inherited from ConnectableChart.)
Public method | ReorderLayers | (Inherited from Chart.)
Public method | Rescale | Rescale the actual Display (Inherited from Chart.)
Public method | SaveToFile | Save the Member to File. Save is not undoable (Inherited from MeasurementMemberBase.)
Public method | SaveToStream | Save the Project to Current Position of the Stream (Inherited from MeasurementMemberBase.)
Public method | SaveToString | Saves the actual configuration to a xml-string. (Inherited from MeasurementMemberBase.)
Public method | Scroll(Direction) | Scrolls the Display 10% of the DisplayWidth (Inherited from Chart.)
Public method | Scroll(Direction, Int64) | Scrolls the chart in the given direction and by the given interval. (Inherited from ConnectableChart.)
Public method | ScrollBig | Scrolls the Diplay on DisplayWidth (Inherited from Chart.)
Public method | SetCopy | Copy Properties from another member (Inherited from MeasurementMemberContainerBase.)
Public method | SetFromFile | Set Member Properties from File (Inherited from MeasurementMemberBase.)
Public method | SetFromStream | Set Element from Stream (Inherited from MeasurementMemberBase.)
Public method | SetFromString | Set the Member Properties from XML-String (Inherited from MeasurementMemberContainerBase.)
Public method | StartDisplay | Restarts the Display (Inherited from Chart.)
Public method | StartDisplay_Async | Restarts the Display (Inherited from Chart.)
Public method | StartMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | StartPositionMultiCommand | Start a new MultiCommand on Position Stack (Inherited from Chart.)
Public method | StopDisplay | Stops the Display (Inherited from Chart.)
Public method | StopMoving | (Inherited from MeasurementMemberContainerBase.)
Public method | ToString | Converts the Chart to a representive String (Inherited from Chart.)
Public method | UndoPosition | Undo 1 Position Setting (Inherited from Chart.)
Public method | UpdatePropertyAttributes | Update Attributes of the Properties (Overrides ChartUpdatePropertyAttributes.)
Public method | Validate | Validate the Configuration of the Chart (Overrides ChartValidate.)
Public method | WriteToString | Write this SubMember to String (Inherited from MeasurementMemberBase.)
Public method | WriteXml | Wrtie Element to XML (Inherited from MeasurementMemberBase.)
Public method | ZoomOutMax | Zooms out max (Inherited from Chart.)
Top
See Also

Reference

YTChart Class


YTChart.UpdatePropertyAttributes Method

Update Attributes of the Properties

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void UpdatePropertyAttributes()
Public Overrides Sub UpdatePropertyAttributes
public:
virtual void UpdatePropertyAttributes() override
See Also

Reference

YTChart Class


YTChart.Validate Method

Validate the Configuration of the Chart

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public override void Validate()
Public Overrides Sub Validate
public:
virtual void Validate() override
See Also

Reference

YTChart Class


YTChart Events

The YTChart type exposes the following members.

Events
 | Name | Description
Public event | ActiveMouseModeChanged | Fired when the ActiveMouseMode is changed. (Inherited from Chart.)
Public event | ActiveMouseModeValidating | Fired while validating the new value for ActiveMouseMode. (Inherited from Chart.)
Public event | AddToMarkerWindow | Fired, when the Chart should be add to the MarkerWindow. (Inherited from Chart.)
Public event | AnchorTimestampChanged | Fired when the AnchorTimestamp is changed. (Inherited from AnchorTimeBase.)
Public event | AnchorTimestampValidating | Fired while validating the new value for AnchorTimestamp. (Inherited from AnchorTimeBase.)
Public event | AssignedCoreChanged | Fired when the AssignedCore is changed. (Inherited from Chart.)
Public event | AssignedCoreValidating | Fired while validating the new value for AssignedCore. (Inherited from Chart.)
Public event | AutoStartChanged | Fired when the AutoStart is changed. (Inherited from Chart.)
Public event | AutoStartValidating | Fired while validating the new value for AutoStart. (Inherited from Chart.)
Public event | BeforeConnectedTimeMemberChanged | Fired before the connected timemember changed. (Inherited from AnchorTimeBase.)
Public event | CanCopyToClipboardChanged | Fired when the CanCopyToClipboard is changed. (Inherited from Chart.)
Public event | CanCopyToClipboardValidating | Fired while validating the new value for CanCopyToClipboard. (Inherited from Chart.)
Public event | ChartPositionChanged | Fired when the ChartPosition has Changed (Inherited from Chart.)
Public event | ClearDisplay | Event fired, when the Display needs to be cleared. (Inherited from Chart.)
Public event | CMasterChartBeforeChanging | Fired before CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartChanged | Fired when the CMasterChart is changed. (Inherited from Chart.)
Public event | CMasterChartValidating | Fired while validating the new value for CMasterChart. (Inherited from Chart.)
Public event | CommentChanged | Fired when the Comment is changed. (Inherited from MeasurementMemberBase.)
Public event | CommentValidating | Fired while validating the new value for Comment. (Inherited from MeasurementMemberBase.)
Public event | ConnectedTimeMemberChanged | Fired when the ConnectedTimeMember is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidChanged | Fired when the ConnectedTimeMemberGuid is changed. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberGuidValidating | Fired while validating the new value for ConnectedTimeMemberGuid. (Inherited from AnchorTimeBase.)
Public event | ConnectedTimeMemberValidating | Fired while validating the new value for ConnectedTimeMember. (Inherited from AnchorTimeBase.)
Public event | CopyToClipboard | Fired, when the reporting to should be shown for this chart. (Inherited from Chart.)
Public event | DefaultDisplayWidthChanged | Fired when the DefaultDisplayWidth is changed. (Inherited from Chart.)
Public event | DefaultDisplayWidthValidating | Fired while validating the new value for DefaultDisplayWidth. (Inherited from Chart.)
Public event | DisplayColorChanged | Fired when the DisplayColor is changed. (Inherited from MeasurementMemberBase.)
Public event | DisplayColorValidating | Fired while validating the new value for DisplayColor. (Inherited from MeasurementMemberBase.)
Public event | DisplayFrameEnded | Fired when DisplayFramehandling is completed (Inherited from Chart.)
Public event | DisplayOverwriteModeChanged | Fired when the DisplayOverwriteMode is changed.
Public event | DisplayOverwriteModeValidating | Fired while validating the new value for DisplayOverwriteMode.
Public event | DisplayWidthChanged | Fired when the DisplayWidth is changed. (Inherited from Chart.)
Public event | DisplayWidthValidating | Fired while validating the new value for DisplayWidth. (Inherited from Chart.)
Public event | DoRescale | Fired to Control should Rescale (Inherited from Chart.)
Public event | DurationLengthChanged | Fired when the DurationLength is changed. (Inherited from AnchorTimeBase.)
Public event | DurationLengthValidating | Fired while validating the new value for DurationLength. (Inherited from AnchorTimeBase.)
Public event | EndTimeChanged | Fired when the EndTime is changed. (Inherited from Chart.)
Public event | EndTimeValidating | Fired while validating the new value for EndTime. (Inherited from Chart.)
Public event | FilePathChanged | Fired when the FilePath is changed. (Inherited from MeasurementMemberBase.)
Public event | FilePathValidating | Fired while validating the new value for FilePath. (Inherited from MeasurementMemberBase.)
Public event | ForeColorChanged | Fired when the ForeColor is changed. (Inherited from Chart.)
Public event | ForeColorValidating | Fired while validating the new value for ForeColor. (Inherited from Chart.)
Public event | GuidChanged | Fired when the Guid is changed. (Inherited from MeasurementMemberBase.)
Public event | GuidValidating | Fired while validating the new value for Guid. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionChanged | Fired when the HandleException is changed. (Inherited from MeasurementMemberBase.)
Public event | HandleExceptionValidating | Fired while validating the new value for HandleException. (Inherited from MeasurementMemberBase.)
Public event | IconChanged | Called when the Icon has Changed (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedChanged | Fired when the IsFilebased is changed. (Inherited from MeasurementMemberBase.)
Public event | IsFilebasedValidating | Fired while validating the new value for IsFilebased. (Inherited from MeasurementMemberBase.)
Public event | IsUpdatingChanged | Fired when the IsUpdating is changed. (Inherited from Chart.)
Public event | LiveChanged | Fired when the Live is changed. (Inherited from Chart.)
Public event | LiveValidating | Fired while validating the new value for Live. (Inherited from Chart.)
Public event | MarkerContainerBindingsChanged | Fired, when a MarkerContainer is Added or Removed from ScopeProject (Inherited from Chart.)
Public event | MasterChartChanged | Fired when the MasterChart is changed. (Inherited from Chart.)
Public event | MasterChartValidating | Fired while validating the new value for MasterChart. (Inherited from Chart.)
Public event | MaxMarkerImageSizeChanged | Fired, when the MaxMarkerImageSize Changed (Inherited from Chart.)
Public event | MemberContentChanged | Fired after memberContent has changed (Inherited from MeasurementMemberContainerBase.)
Public event | NameChanged | Fired when the Name is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceChanged | Fired when the Namespace is changed. (Inherited from MeasurementMemberBase.)
Public event | NamespaceValidating | Fired while validating the new value for Namespace. (Inherited from MeasurementMemberBase.)
Public event | NameValidating | Fired while validating the new value for Name. (Inherited from MeasurementMemberBase.)
Public event | OnSaving | Fired on Before Saving the Member (Inherited from MeasurementMemberBase.)
Public event | PositionAbsoluteChanged | Fired when the PositionAbsolute is changed. (Inherited from Chart.)
Public event | PositionAbsoluteValidating | Fired while validating the new value for PositionAbsolute. (Inherited from Chart.)
Public event | PositionOffsetChanged | Fired when the PositionOffset is changed. (Inherited from Chart.)
Public event | PositionOffsetValidating | Fired while validating the new value for PositionOffset. (Inherited from Chart.)
Public event | ProjectStateChanged | Fired when the ProjectState is changed. (Inherited from MeasurementMemberBase.)
Public event | ProjectStateValidating | Fired while validating the new value for ProjectState. (Inherited from MeasurementMemberBase.)
Public event | PropertyChanged | Fired on PropertyChanged (Inherited from MeasurementMemberBase.)
Public event | PropertyChanging | Fired on Before Property Changed (Inherited from MeasurementMemberBase.)
Public event | RedoPossibleChanged | Fired when the RedoPossible is changed. (Inherited from Chart.)
Public event | RedoPossibleValidating | Fired while validating the new value for RedoPossible. (Inherited from Chart.)
Public event | RefreshPropertyGrid | Fired to Invalidate the PropertyGrid (Inherited from MeasurementMemberBase.)
Public event | ResolutionChanged | Fired when the Resolution is changed. (Inherited from Chart.)
Public event | ResolutionValidating | Fired while validating the new value for Resolution. (Inherited from Chart.)
Public event | ShowImageChartChanged | Fired when the ShowImageChart is changed. (Inherited from Chart.)
Public event | ShowImageChartValidating | Fired while validating the new value for ShowImageChart. (Inherited from Chart.)
Public event | SortPriorityChanged | Fired when the SortPriority is changed. (Inherited from MeasurementMemberBase.)
Public event | SortPriorityValidating | Fired while validating the new value for SortPriority. (Inherited from MeasurementMemberBase.)
Public event | StartTimeChanged | Fired when the StartTime is changed. (Inherited from Chart.)
Public event | StartTimeValidating | Fired while validating the new value for StartTime. (Inherited from Chart.)
Public event | StatusTimesChanged | Event fired, when the StatusTimes have been changed (Inherited from Chart.)
Public event | SubMemberContentChanged | Event fired, when an element was added to an SubMember (Inherited from MeasurementMemberContainerBase.)
Public event | TimeOffsetChanged | Fired when the TimeOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TimeOffsetValidating | Fired while validating the new value for TimeOffset. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeChanged | Fired when the TimeRefreshMode is changed. (Inherited from AnchorTimeBase.)
Public event | TimeRefreshModeValidating | Fired while validating the new value for TimeRefreshMode. (Inherited from AnchorTimeBase.)
Public event | TitleChanged | Fired when the Title is changed. (Inherited from MeasurementMemberBase.)
Public event | TitleValidating | Fired while validating the new value for Title. (Inherited from MeasurementMemberBase.)
Public event | TriggerGroupBindingsChanged | Fired, when a TriggerGroup is Added or Removed From ScopeProject (Inherited from Chart.)
Public event | TriggerGroupOffsetChanged | Fired when the TriggerGroupOffset is changed. (Inherited from AnchorTimeBase.)
Public event | TriggerGroupOffsetValidating | Fired while validating the new value for TriggerGroupOffset. (Inherited from AnchorTimeBase.)
Public event | UndoPossibleChanged | Fired when the UndoPossible is changed. (Inherited from Chart.)
Public event | UndoPossibleValidating | Fired while validating the new value for UndoPossible. (Inherited from Chart.)
Public event | UnsavedChangesChanged | Fired when the UnsavedChanges is changed. (Inherited from MeasurementMemberBase.)
Public event | UnsavedChangesValidating | Fired while validating the new value for UnsavedChanges. (Inherited from MeasurementMemberBase.)
Top
See Also

Reference

YTChart Class


YTChart.DisplayOverwriteModeChanged Event

Fired when the DisplayOverwriteMode is changed.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler DisplayOverwriteModeChanged
Public Event DisplayOverwriteModeChanged As EventHandler
public:
 event EventHandler^ DisplayOverwriteModeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

YTChart Class


YTChart.DisplayOverwriteModeValidating Event

Fired while validating the new value for DisplayOverwriteMode.

Namespace: TwinCAT.Measurement.Scope.API.Model
Assembly: TwinCAT.Measurement.Scope.API (in TwinCAT.Measurement.Scope.API.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<ValidatingEventArgs> DisplayOverwriteModeValidating
Public Event DisplayOverwriteModeValidating As EventHandler(Of ValidatingEventArgs)
public:
 event EventHandler<ValidatingEventArgs^>^ DisplayOverwriteModeValidating {
    void add (EventHandler<ValidatingEventArgs^>^ value);
    void remove (EventHandler<ValidatingEventArgs^>^ value);
}

Value

Type: SystemEventHandler ValidatingEventArgs
See Also

Reference

YTChart Class


YTChart Fields

The YTChart type exposes the following members.

Fields
 | Name | Description
Public field | RefControlStyle | ///gets the ControlStyle (Inherited from Chart.)
Top
See Also

Reference

YTChart Class


TwinCAT.Measurement.Scope.Control Namespace

Classes
 | Class | Description
Public class | ActiveChartChangedEventArgs | Event Args Fired by ActiveChartChanged
Public class | ActiveScopeMemberChangedEventArgs | Event Args Fired by ActiveScopeMemberChanged
Public class | ChartControlBase |
Public class | ChartPanel |
Public class | ChartSynchronisationControl | Interaction logic for ChartSynchronisationControl.xaml
Public class | ScopeProjectPanel |
Public class | ScopeServerOpcConfiguration |


ActiveChartChangedEventArgs Class

Event Args Fired by ActiveChartChanged
Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.ControlActiveChartChangedEventArgs

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ActiveChartChangedEventArgs : EventArgs
Public Class ActiveChartChangedEventArgs
    Inherits EventArgs
public ref class ActiveChartChangedEventArgs : public EventArgs

The ActiveChartChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveChartChangedEventArgs | Create a new Instance of ActiveChartChangedEventArgs
Top
Properties
 | Name | Description
Public property | Chart | The active Chart
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.Control Namespace


ActiveChartChangedEventArgs Constructor

Create a new Instance of ActiveChartChangedEventArgs

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ActiveChartChangedEventArgs(
    Chart Chart
)
Public Sub New (
    Chart As Chart
)
public:
ActiveChartChangedEventArgs(
    Chart^ Chart
)

Parameters

Chart
Type: TwinCAT.Measurement.Scope.API.ModelChart
The acitve Chart
See Also

Reference

ActiveChartChangedEventArgs Class
TwinCAT.Measurement.Scope.Control Namespace


ActiveChartChangedEventArgs Properties

The ActiveChartChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Chart | The active Chart
Top
See Also

Reference

ActiveChartChangedEventArgs Class
TwinCAT.Measurement.Scope.Control Namespace


ActiveChartChangedEventArgs.Chart Property

The active Chart

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Chart Chart { get; }
Public ReadOnly Property Chart As Chart
    Get
public:
property Chart^ Chart {
    Chart^ get ();
}

Property Value

Type: Chart
See Also

Reference

ActiveChartChangedEventArgs Class
TwinCAT.Measurement.Scope.Control Namespace


ActiveChartChangedEventArgs Methods

The ActiveChartChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActiveChartChangedEventArgs Class
TwinCAT.Measurement.Scope.Control Namespace


ActiveScopeMemberChangedEventArgs Class

Event Args Fired by ActiveScopeMemberChanged
Inheritance Hierarchy
SystemObject
SystemEventArgs
TwinCAT.Measurement.Scope.ControlActiveScopeMemberChangedEventArgs

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ActiveScopeMemberChangedEventArgs : EventArgs
Public Class ActiveScopeMemberChangedEventArgs
    Inherits EventArgs
public ref class ActiveScopeMemberChangedEventArgs : public EventArgs

The ActiveScopeMemberChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveScopeMemberChangedEventArgs | Create a new Instance of ActiveChartChangedEventArgs
Top
Properties
 | Name | Description
Public property | ScopeMember | The active Chart
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.Control Namespace


ActiveScopeMemberChangedEventArgs Constructor

Create a new Instance of ActiveChartChangedEventArgs

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ActiveScopeMemberChangedEventArgs(
    MeasurementMemberBase scopeMember
)
Public Sub New (
    scopeMember As MeasurementMemberBase
)
public:
ActiveScopeMemberChangedEventArgs(
    MeasurementMemberBase^ scopeMember
)

Parameters

scopeMember
Type: TwinCAT.Measurement.ProjectBaseMeasurementMemberBase
The acitve scope member
See Also

Reference

ActiveScopeMemberChangedEventArgs Class
TwinCAT.Measurement.Scope.Control Namespace


ActiveScopeMemberChangedEventArgs Properties

The ActiveScopeMemberChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ScopeMember | The active Chart
Top
See Also

Reference

ActiveScopeMemberChangedEventArgs Class
TwinCAT.Measurement.Scope.Control Namespace


ActiveScopeMemberChangedEventArgs.ScopeMember Property

The active Chart

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public MeasurementMemberBase ScopeMember { get; }
Public ReadOnly Property ScopeMember As MeasurementMemberBase
    Get
public:
property MeasurementMemberBase^ ScopeMember {
    MeasurementMemberBase^ get ();
}

Property Value

Type: MeasurementMemberBase
See Also

Reference

ActiveScopeMemberChangedEventArgs Class
TwinCAT.Measurement.Scope.Control Namespace


ActiveScopeMemberChangedEventArgs Methods

The ActiveScopeMemberChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActiveScopeMemberChangedEventArgs Class
TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase Class

Inheritance Hierarchy
SystemObject
BasePresenter
TwinCAT.Measurement.Scope.ControlChartControlBase

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract class ChartControlBase : BasePresenter
Public MustInherit Class ChartControlBase
    Inherits BasePresenter
public ref class ChartControlBase abstract : public BasePresenter

The ChartControlBase type exposes the following members.

Properties
 | Name | Description
Public property | CanTransform | Gets or Sets the CanTransform.
Public property | Chart | Gets or Sets the Chart.
Public property | SuppressInvoke |
Public property | UserControl |
Top
Methods
 | Name | Description
Public method | DrawToBitmap |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | CanTransformChanged | Fired when the CanTransform is changed.
Public event | ChartChanged | Fired when the Chart is changed.
Public event | ChartChanging | Fired when the Chart is changed.
Public event | DragDrop |
Public event | DragOver |
Top
See Also

Reference

TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase Properties

The ChartControlBase type exposes the following members.

Properties
 | Name | Description
Public property | CanTransform | Gets or Sets the CanTransform.
Public property | Chart | Gets or Sets the Chart.
Public property | SuppressInvoke |
Public property | UserControl |
Top
See Also

Reference

ChartControlBase Class
TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase.CanTransform Property

Gets or Sets the CanTransform.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool CanTransform { get; set; }
Public Property CanTransform As Boolean
    Get
    Set
public:
property bool CanTransform {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartControlBase Class
TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase.Chart Property

Gets or Sets the Chart.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Chart Chart { get; set; }
Public Property Chart As Chart
    Get
    Set
public:
property Chart^ Chart {
    Chart^ get ();
    void set (Chart^ value);
}

Property Value

Type: Chart
See Also

Reference

ChartControlBase Class
TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase.SuppressInvoke Property

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool SuppressInvoke { get; set; }
Public Property SuppressInvoke As Boolean
    Get
    Set
public:
property bool SuppressInvoke {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartControlBase Class
TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase.UserControl Property

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public abstract UserControl UserControl { get; }
Public MustOverride ReadOnly Property UserControl As UserControl
    Get
public:
virtual property UserControl^ UserControl {
    UserControl^ get () abstract;
}

Property Value

Type: UserControl
See Also

Reference

ChartControlBase Class
TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase Methods

The ChartControlBase type exposes the following members.

Methods
 | Name | Description
Public method | DrawToBitmap |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChartControlBase Class
TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase.DrawToBitmap Method

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public virtual Bitmap DrawToBitmap(
    double xDpi = 96,
    double yDpi = 96
)
Public Overridable Function DrawToBitmap (
    Optional xDpi As Double = 96,
    Optional yDpi As Double = 96
) As Bitmap
public:
virtual Bitmap^ DrawToBitmap(
    double xDpi = 96,
    double yDpi = 96
)

Parameters

xDpi (Optional)
Type: SystemDouble
yDpi (Optional)
Type: SystemDouble

Return Value

Type: Bitmap
See Also

Reference

ChartControlBase Class
TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase Events

The ChartControlBase type exposes the following members.

Events
 | Name | Description
Public event | CanTransformChanged | Fired when the CanTransform is changed.
Public event | ChartChanged | Fired when the Chart is changed.
Public event | ChartChanging | Fired when the Chart is changed.
Public event | DragDrop |
Public event | DragOver |
Top
See Also

Reference

ChartControlBase Class
TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase.CanTransformChanged Event

Fired when the CanTransform is changed.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler CanTransformChanged
Public Event CanTransformChanged As EventHandler
public:
 event EventHandler^ CanTransformChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartControlBase Class
TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase.ChartChanged Event

Fired when the Chart is changed.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ChartChanged
Public Event ChartChanged As EventHandler
public:
 event EventHandler^ ChartChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartControlBase Class
TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase.ChartChanging Event

Fired when the Chart is changed.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ChartChanging
Public Event ChartChanging As EventHandler
public:
 event EventHandler^ ChartChanging {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartControlBase Class
TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase.DragDrop Event

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<DragEventArgs> DragDrop
Public Event DragDrop As EventHandler(Of DragEventArgs)
public:
 event EventHandler<DragEventArgs^>^ DragDrop {
    void add (EventHandler<DragEventArgs^>^ value);
    void remove (EventHandler<DragEventArgs^>^ value);
}

Value

Type: SystemEventHandler DragEventArgs
See Also

Reference

ChartControlBase Class
TwinCAT.Measurement.Scope.Control Namespace


ChartControlBase.DragOver Event

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<DragEventArgs> DragOver
Public Event DragOver As EventHandler(Of DragEventArgs)
public:
 event EventHandler<DragEventArgs^>^ DragOver {
    void add (EventHandler<DragEventArgs^>^ value);
    void remove (EventHandler<DragEventArgs^>^ value);
}

Value

Type: SystemEventHandler DragEventArgs
See Also

Reference

ChartControlBase Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
TwinCAT.Measurement.Scope.ControlChartPanel

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChartPanel : UserControl
Public Class ChartPanel
    Inherits UserControl
public ref class ChartPanel : public UserControl

The ChartPanel type exposes the following members.

Constructors
 | Name | Description
Public method | ChartPanel | Initializes a new instance of the ChartPanel class
Public method | ChartPanel(Chart, GraphicLibrary, ActionException) | Initializes a new instance of the ChartPanel class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoInvokeDisplayControl |
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | CurrentTransformation | Gets or Sets the CurrentTransformation.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GraphicLibrary | Get or Set the GraphicLibrary witch is used for rendering the charts. Set GraphicLibrary is only possible before binding the model.
Public property | GridSplitColor | Gets or Sets the GridSplitColor.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | HotColor | Gets or Sets the HotColor.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | ModelChart |
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedColor | Gets or Sets the SelectedColor.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SplitterColor | Gets or Sets the SplitterColor.
Public property | SupportWPFRefresh |
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from UserControl.)
Public property | TextBoxBackColor | Gets or Sets the TextBoxBackColor.
Public property | TextColor | Gets or Sets the TextColor.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetBitmapOfChart |
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LogicalToDeviceUnits | Converts a Logical DPI value to it's equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RefreshControlColors |
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetOverviewSize |
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | ButtonSizeChanged | Fired when the ButtonSize is changed.
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | Member_Clicked | Throws if a member inside this panel was clicked
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | OpenCurveEditor | Throws if a new color view model base needs the current color theme.
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | TimeStripFontSizeChanged | Fired when the TimeStripFontSize is changed.
Public event | ToolStripFontSizeChanged | Fired when the ToolStripFontSize is changed.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.Control Namespace


ChartPanel Constructor

Overload List
 | Name | Description
Public method | ChartPanel | Initializes a new instance of the ChartPanel class
Public method | ChartPanel(Chart, GraphicLibrary, ActionException) | Initializes a new instance of the ChartPanel class
Top
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel Constructor

Initializes a new instance of the ChartPanel class

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartPanel()
Public Sub New
public:
ChartPanel()
See Also

Reference

ChartPanel Class
ChartPanel Overload
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel Constructor (Chart, GraphicLibrary, Action(Exception))

Initializes a new instance of the ChartPanel class

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartPanel(
    Chart chart,
    GraphicLibrary GraphicLib = GraphicLibrary.GDI_Plus,
    Action<Exception> DXMemoryError = null
)
Public Sub New (
    chart As Chart,
    Optional GraphicLib As GraphicLibrary = GraphicLibrary.GDI_Plus,
    Optional DXMemoryError As Action(Of Exception) = Nothing
)
public:
ChartPanel(
    Chart^ chart,
    GraphicLibrary GraphicLib = GraphicLibrary::GDI_Plus,
    Action<Exception^>^ DXMemoryError = nullptr
)

Parameters

chart
Type: TwinCAT.Measurement.Scope.API.ModelChart
GraphicLib (Optional)
Type: GraphicLibrary
DXMemoryError (Optional)
Type: SystemAction Exception
See Also

Reference

ChartPanel Class
ChartPanel Overload
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel Properties

The ChartPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoInvokeDisplayControl |
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | CurrentTransformation | Gets or Sets the CurrentTransformation.
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | GraphicLibrary | Get or Set the GraphicLibrary witch is used for rendering the charts. Set GraphicLibrary is only possible before binding the model.
Public property | GridSplitColor | Gets or Sets the GridSplitColor.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | HotColor | Gets or Sets the HotColor.
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | ModelChart |
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SelectedColor | Gets or Sets the SelectedColor.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | SplitterColor | Gets or Sets the SplitterColor.
Public property | SupportWPFRefresh |
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from UserControl.)
Public property | TextBoxBackColor | Gets or Sets the TextBoxBackColor.
Public property | TextColor | Gets or Sets the TextColor.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.AutoInvokeDisplayControl Property

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[DefaultValueAttribute(false)]
public bool AutoInvokeDisplayControl { get; set; }
<DefaultValueAttribute(false)>
Public Property AutoInvokeDisplayControl As Boolean
    Get
    Set
public:
[DefaultValueAttribute(false)]
property bool AutoInvokeDisplayControl {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.CurrentTransformation Property

Gets or Sets the CurrentTransformation.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Transformations CurrentTransformation { get; set; }
Public Property CurrentTransformation As Transformations
    Get
    Set
public:
property Transformations CurrentTransformation {
    Transformations get ();
    void set (Transformations value);
}

Property Value

Type: Transformations
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.GraphicLibrary Property

Get or Set the GraphicLibrary witch is used for rendering the charts. Set GraphicLibrary is only possible before binding the model.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public GraphicLibrary GraphicLibrary { get; set; }
Public Property GraphicLibrary As GraphicLibrary
    Get
    Set
public:
property GraphicLibrary GraphicLibrary {
    GraphicLibrary get ();
    void set (GraphicLibrary value);
}

Property Value

Type: GraphicLibrary
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.GridSplitColor Property

Gets or Sets the GridSplitColor.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color GridSplitColor { get; set; }
Public Property GridSplitColor As Color
    Get
    Set
public:
property Color GridSplitColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.HotColor Property

Gets or Sets the HotColor.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color HotColor { get; set; }
Public Property HotColor As Color
    Get
    Set
public:
property Color HotColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.ModelChart Property

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[BrowsableAttribute(false)]
public Chart ModelChart { get; set; }
<BrowsableAttribute(false)>
Public Property ModelChart As Chart
    Get
    Set
public:
[BrowsableAttribute(false)]
property Chart^ ModelChart {
    Chart^ get ();
    void set (Chart^ value);
}

Property Value

Type: Chart
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.SelectedColor Property

Gets or Sets the SelectedColor.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color SelectedColor { get; set; }
Public Property SelectedColor As Color
    Get
    Set
public:
property Color SelectedColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.SplitterColor Property

Gets or Sets the SplitterColor.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color SplitterColor { get; set; }
Public Property SplitterColor As Color
    Get
    Set
public:
property Color SplitterColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.SupportWPFRefresh Property

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
[DefaultValueAttribute(false)]
public bool SupportWPFRefresh { get; set; }
<DefaultValueAttribute(false)>
Public Property SupportWPFRefresh As Boolean
    Get
    Set
public:
[DefaultValueAttribute(false)]
property bool SupportWPFRefresh {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.TextBoxBackColor Property

Gets or Sets the TextBoxBackColor.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color TextBoxBackColor { get; set; }
Public Property TextBoxBackColor As Color
    Get
    Set
public:
property Color TextBoxBackColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.TextColor Property

Gets or Sets the TextColor.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Color TextColor { get; set; }
Public Property TextColor As Color
    Get
    Set
public:
property Color TextColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel Methods

The ChartPanel type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetBitmapOfChart |
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LogicalToDeviceUnits | Converts a Logical DPI value to it's equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RefreshControlColors |
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetOverviewSize |
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from UserControl.)
Top
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.GetBitmapOfChart Method

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public Bitmap GetBitmapOfChart(
    bool chartcontrolOnly = false
)
Public Function GetBitmapOfChart (
    Optional chartcontrolOnly As Boolean = false
) As Bitmap
public:
Bitmap^ GetBitmapOfChart(
    bool chartcontrolOnly = false
)

Parameters

chartcontrolOnly (Optional)
Type: SystemBoolean

Return Value

Type: Bitmap
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.RefreshControlColors Method

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void RefreshControlColors(
    Color textcolor,
    Color background
)
Public Sub RefreshControlColors (
    textcolor As Color,
    background As Color
)
public:
void RefreshControlColors(
    Color textcolor,
    Color background
)

Parameters

textcolor
Type: System.DrawingColor
background
Type: System.DrawingColor
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.SetOverviewSize Method

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void SetOverviewSize(
    float percent = 0,1f
)
Public Sub SetOverviewSize (
    Optional percent As Single = 0,1F
)
public:
void SetOverviewSize(
    float percent = 0,1f
)

Parameters

percent (Optional)
Type: SystemSingle
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel Events

The ChartPanel type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | ButtonSizeChanged | Fired when the ButtonSize is changed.
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | Member_Clicked | Throws if a member inside this panel was clicked
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | OpenCurveEditor | Throws if a new color view model base needs the current color theme.
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | TimeStripFontSizeChanged | Fired when the TimeStripFontSize is changed.
Public event | ToolStripFontSizeChanged | Fired when the ToolStripFontSize is changed.
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.ButtonSizeChanged Event

Fired when the ButtonSize is changed.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ButtonSizeChanged
Public Event ButtonSizeChanged As EventHandler
public:
 event EventHandler^ ButtonSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.Member_Clicked Event

Throws if a member inside this panel was clicked

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<MeasurementMemberBase> Member_Clicked
Public Event Member_Clicked As EventHandler(Of MeasurementMemberBase)
public:
 event EventHandler<MeasurementMemberBase^>^ Member_Clicked {
    void add (EventHandler<MeasurementMemberBase^>^ value);
    void remove (EventHandler<MeasurementMemberBase^>^ value);
}

Value

Type: SystemEventHandler MeasurementMemberBase
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.OpenCurveEditor Event

Throws if a new color view model base needs the current color theme.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler OpenCurveEditor
Public Event OpenCurveEditor As EventHandler
public:
 event EventHandler^ OpenCurveEditor {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.TimeStripFontSizeChanged Event

Fired when the TimeStripFontSize is changed.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler TimeStripFontSizeChanged
Public Event TimeStripFontSizeChanged As EventHandler
public:
 event EventHandler^ TimeStripFontSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartPanel.ToolStripFontSizeChanged Event

Fired when the ToolStripFontSize is changed.

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler ToolStripFontSizeChanged
Public Event ToolStripFontSizeChanged As EventHandler
public:
 event EventHandler^ ToolStripFontSizeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ChartPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ChartSynchronisationControl Class

Interaction logic for ChartSynchronisationControl.xaml
ChartSynchronisationControl
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
TwinCAT.Measurement.Scope.ControlChartSynchronisationControl

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ChartSynchronisationControl : Window,
    IComponentConnector
Public Class ChartSynchronisationControl
    Inherits Window
    Implements IComponentConnector
public ref class ChartSynchronisationControl : public Window,
    IComponentConnector

The ChartSynchronisationControl type exposes the following members.

Constructors
 | Name | Description
Public method | ChartSynchronisationControl | Initializes a new instance of the ChartSynchronisationControl class
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.Control Namespace


ChartSynchronisationControl Constructor

Initializes a new instance of the ChartSynchronisationControl class

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ChartSynchronisationControl(
    ScopeProject scope,
    Chart[] selectedCharts
)
Public Sub New (
    scope As ScopeProject,
    selectedCharts As Chart()
)
public:
ChartSynchronisationControl(
    ScopeProject^ scope,
    array<Chart^>^ selectedCharts
)

Parameters

scope
Type: TwinCAT.Measurement.Scope.API.ModelScopeProject
selectedCharts
Type: TwinCAT.Measurement.Scope.API.ModelChart
See Also

Reference

ChartSynchronisationControl Class
TwinCAT.Measurement.Scope.Control Namespace


ChartSynchronisationControl Properties

The ChartSynchronisationControl type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Top
See Also

Reference

ChartSynchronisationControl Class
TwinCAT.Measurement.Scope.Control Namespace


ChartSynchronisationControl Methods

The ChartSynchronisationControl type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
See Also

Reference

ChartSynchronisationControl Class
TwinCAT.Measurement.Scope.Control Namespace


ChartSynchronisationControl.InitializeComponent Method

InitializeComponent

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void InitializeComponent()
Public Sub InitializeComponent
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

ChartSynchronisationControl Class
TwinCAT.Measurement.Scope.Control Namespace


ChartSynchronisationControl Events

The ChartSynchronisationControl type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DpiChanged | Occurs after the DPI of the screen on which the Window is displayed changes. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from (or undefined) to . (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

ChartSynchronisationControl Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeProjectPanel Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
ScopeProjectBasePanel
TwinCAT.Measurement.Scope.ControlScopeProjectPanel

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ScopeProjectPanel : ScopeProjectBasePanel
Public Class ScopeProjectPanel
    Inherits ScopeProjectBasePanel
public ref class ScopeProjectPanel : public ScopeProjectBasePanel

The ScopeProjectPanel type exposes the following members.

Constructors
 | Name | Description
Public method | ScopeProjectPanel | Initializes a new instance of the ScopeProjectPanel class
Public method | ScopeProjectPanel(ScopeProject, GraphicLibrary, ActionException) | Initializes a new instance of the ScopeProjectPanel class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | ScopeProject |
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LogicalToDeviceUnits | Converts a Logical DPI value to it's equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(ImageMarker) | Brings the SelectedImage to the fron
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from UserControl.)
Top
Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | Start_CopyToClipboard | Fired when the Copy To Clipboard button was clicked
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

TwinCAT.Measurement.Scope.Control Namespace


ScopeProjectPanel Constructor

Overload List
 | Name | Description
Public method | ScopeProjectPanel | Initializes a new instance of the ScopeProjectPanel class
Public method | ScopeProjectPanel(ScopeProject, GraphicLibrary, ActionException) | Initializes a new instance of the ScopeProjectPanel class
Top
See Also

Reference

ScopeProjectPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeProjectPanel Constructor

Initializes a new instance of the ScopeProjectPanel class

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeProjectPanel()
Public Sub New
public:
ScopeProjectPanel()
See Also

Reference

ScopeProjectPanel Class
ScopeProjectPanel Overload
TwinCAT.Measurement.Scope.Control Namespace


ScopeProjectPanel Constructor (ScopeProject, GraphicLibrary, Action(Exception))

Initializes a new instance of the ScopeProjectPanel class

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeProjectPanel(
    ScopeProject project,
    GraphicLibrary graphicLibrary = GraphicLibrary.GDI_Plus,
    Action<Exception> DXMemoryError = null
)
Public Sub New (
    project As ScopeProject,
    Optional graphicLibrary As GraphicLibrary = GraphicLibrary.GDI_Plus,
    Optional DXMemoryError As Action(Of Exception) = Nothing
)
public:
ScopeProjectPanel(
    ScopeProject^ project,
    GraphicLibrary graphicLibrary = GraphicLibrary::GDI_Plus,
    Action<Exception^>^ DXMemoryError = nullptr
)

Parameters

project
Type: TwinCAT.Measurement.Scope.API.ModelScopeProject
graphicLibrary (Optional)
Type: GraphicLibrary
DXMemoryError (Optional)
Type: SystemAction Exception
See Also

Reference

ScopeProjectPanel Class
ScopeProjectPanel Overload
TwinCAT.Measurement.Scope.Control Namespace


ScopeProjectPanel Properties

The ScopeProjectPanel type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | ScopeProject |
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from UserControl.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ScopeProjectPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeProjectPanel.ScopeProject Property

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeProject ScopeProject { get; set; }
Public Property ScopeProject As ScopeProject
    Get
    Set
public:
property ScopeProject^ ScopeProject {
    ScopeProject^ get ();
    void set (ScopeProject^ value);
}

Property Value

Type: ScopeProject
See Also

Reference

ScopeProjectPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeProjectPanel Methods

The ScopeProjectPanel type exposes the following members.

Methods
 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LogicalToDeviceUnits | Converts a Logical DPI value to it's equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(ImageMarker) | Brings the SelectedImage to the fron
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from UserControl.)
Top
See Also

Reference

ScopeProjectPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeProjectPanel.Show Method

Overload List
 | Name | Description
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(ImageMarker) | Brings the SelectedImage to the fron
Top
See Also

Reference

ScopeProjectPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeProjectPanel.Show Method (ImageMarker)

Brings the SelectedImage to the fron

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public void Show(
    ImageMarker imageMarker
)
Public Sub Show (
    imageMarker As ImageMarker
)
public:
void Show(
    ImageMarker^ imageMarker
)

Parameters

imageMarker
Type: TwinCAT.Measurement.Scope.API.ModelImageMarker
The Image to show
See Also

Reference

ScopeProjectPanel Class
Show Overload
TwinCAT.Measurement.Scope.Control Namespace


ScopeProjectPanel Events

The ScopeProjectPanel type exposes the following members.

Events
 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | Start_CopyToClipboard | Fired when the Copy To Clipboard button was clicked
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ScopeProjectPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeProjectPanel.Start_CopyToClipboard Event

Fired when the Copy To Clipboard button was clicked

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public event EventHandler<MeasurementMemberBase> Start_CopyToClipboard
Public Event Start_CopyToClipboard As EventHandler(Of MeasurementMemberBase)
public:
 event EventHandler<MeasurementMemberBase^>^ Start_CopyToClipboard {
    void add (EventHandler<MeasurementMemberBase^>^ value);
    void remove (EventHandler<MeasurementMemberBase^>^ value);
}

Value

Type: SystemEventHandler MeasurementMemberBase
See Also

Reference

ScopeProjectPanel Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeServerOpcConfiguration Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
TwinCAT.Measurement.Scope.ControlScopeServerOpcConfiguration

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public class ScopeServerOpcConfiguration : Form
Public Class ScopeServerOpcConfiguration
    Inherits Form
public ref class ScopeServerOpcConfiguration : public Form

The ScopeServerOpcConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | ScopeServerOpcConfiguration | Initializes a new instance of the ScopeServerOpcConfiguration class
Public method | ScopeServerOpcConfiguration(OpcUaAddress) | Initializes a new instance of the ScopeServerOpcConfiguration class
Public method | ScopeServerOpcConfiguration(OpcServerNotTrustedException) | Initializes a new instance of the ScopeServerOpcConfiguration class
Public method | ScopeServerOpcConfiguration(OpcWrongCredentialsException) | Initializes a new instance of the ScopeServerOpcConfiguration class
Public method | ScopeServerOpcConfiguration(OpcUaAddress, Boolean, String, String, String, String, String) | Initializes a new instance of the ScopeServerOpcConfiguration class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits | Converts a Logical DPI value to it's equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Fields
 | Name | Description
Public field | cancelClicked |
Public field | userData |
Top
See Also

Reference

TwinCAT.Measurement.Scope.Control Namespace


ScopeServerOpcConfiguration Constructor

Overload List
 | Name | Description
Public method | ScopeServerOpcConfiguration | Initializes a new instance of the ScopeServerOpcConfiguration class
Public method | ScopeServerOpcConfiguration(OpcUaAddress) | Initializes a new instance of the ScopeServerOpcConfiguration class
Public method | ScopeServerOpcConfiguration(OpcServerNotTrustedException) | Initializes a new instance of the ScopeServerOpcConfiguration class
Public method | ScopeServerOpcConfiguration(OpcWrongCredentialsException) | Initializes a new instance of the ScopeServerOpcConfiguration class
Public method | ScopeServerOpcConfiguration(OpcUaAddress, Boolean, String, String, String, String, String) | Initializes a new instance of the ScopeServerOpcConfiguration class
Top
See Also

Reference

ScopeServerOpcConfiguration Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeServerOpcConfiguration Constructor

Initializes a new instance of the ScopeServerOpcConfiguration class

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeServerOpcConfiguration()
Public Sub New
public:
ScopeServerOpcConfiguration()
See Also

Reference

ScopeServerOpcConfiguration Class
ScopeServerOpcConfiguration Overload
TwinCAT.Measurement.Scope.Control Namespace


ScopeServerOpcConfiguration Constructor (OpcUaAddress)

Initializes a new instance of the ScopeServerOpcConfiguration class

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeServerOpcConfiguration(
    OpcUaAddress addr
)
Public Sub New (
    addr As OpcUaAddress
)
public:
ScopeServerOpcConfiguration(
    OpcUaAddress^ addr
)

Parameters

addr
Type: OpcUaAddress
See Also

Reference

ScopeServerOpcConfiguration Class
ScopeServerOpcConfiguration Overload
TwinCAT.Measurement.Scope.Control Namespace


ScopeServerOpcConfiguration Constructor (OpcServerNotTrustedException)

Initializes a new instance of the ScopeServerOpcConfiguration class

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeServerOpcConfiguration(
    OpcServerNotTrustedException exception
)
Public Sub New (
    exception As OpcServerNotTrustedException
)
public:
ScopeServerOpcConfiguration(
    OpcServerNotTrustedException^ exception
)

Parameters

exception
Type: TwinCAT.Measurement.Scope.APIOpcServerNotTrustedException
See Also

Reference

ScopeServerOpcConfiguration Class
ScopeServerOpcConfiguration Overload
TwinCAT.Measurement.Scope.Control Namespace


ScopeServerOpcConfiguration Constructor (OpcWrongCredentialsException)

Initializes a new instance of the ScopeServerOpcConfiguration class

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeServerOpcConfiguration(
    OpcWrongCredentialsException exception
)
Public Sub New (
    exception As OpcWrongCredentialsException
)
public:
ScopeServerOpcConfiguration(
    OpcWrongCredentialsException^ exception
)

Parameters

exception
Type: TwinCAT.Measurement.Scope.APIOpcWrongCredentialsException
See Also

Reference

ScopeServerOpcConfiguration Class
ScopeServerOpcConfiguration Overload
TwinCAT.Measurement.Scope.Control Namespace


ScopeServerOpcConfiguration Constructor (OpcUaAddress, Boolean, String, String, String, String, String)

Initializes a new instance of the ScopeServerOpcConfiguration class

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public ScopeServerOpcConfiguration(
    OpcUaAddress addr,
    bool useLocalServer,
    string amsNetId,
    string commonName,
    string thumbprint,
    string validFrom,
    string validTo
)
Public Sub New (
    addr As OpcUaAddress,
    useLocalServer As Boolean,
    amsNetId As String,
    commonName As String,
    thumbprint As String,
    validFrom As String,
    validTo As String
)
public:
ScopeServerOpcConfiguration(
    OpcUaAddress^ addr,
    bool useLocalServer,
    String^ amsNetId,
    String^ commonName,
    String^ thumbprint,
    String^ validFrom,
    String^ validTo
)

Parameters

addr
Type: OpcUaAddress
useLocalServer
Type: SystemBoolean
amsNetId
Type: SystemString
commonName
Type: SystemString
thumbprint
Type: SystemString
validFrom
Type: SystemString
validTo
Type: SystemString
See Also

Reference

ScopeServerOpcConfiguration Class
ScopeServerOpcConfiguration Overload
TwinCAT.Measurement.Scope.Control Namespace


ScopeServerOpcConfiguration Properties

The ScopeServerOpcConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ScopeServerOpcConfiguration Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeServerOpcConfiguration Methods

The ScopeServerOpcConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits | Converts a Logical DPI value to it's equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Top
See Also

Reference

ScopeServerOpcConfiguration Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeServerOpcConfiguration Events

The ScopeServerOpcConfiguration type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ScopeServerOpcConfiguration Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeServerOpcConfiguration Fields

The ScopeServerOpcConfiguration type exposes the following members.

Fields
 | Name | Description
Public field | cancelClicked |
Public field | userData |
Top
See Also

Reference

ScopeServerOpcConfiguration Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeServerOpcConfiguration.cancelClicked Field

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool cancelClicked
Public cancelClicked As Boolean
public:
bool cancelClicked

Field Value

Type: Boolean
See Also

Reference

ScopeServerOpcConfiguration Class
TwinCAT.Measurement.Scope.Control Namespace


ScopeServerOpcConfiguration.userData Field

Namespace: TwinCAT.Measurement.Scope.Control
Assembly: TwinCAT.Measurement.Scope.Control (in TwinCAT.Measurement.Scope.Control.dll) Version: 3.4.3147.0
Syntax
C#
VB
C++
Copy
public bool userData
Public userData As Boolean
public:
bool userData

Field Value

Type: Boolean
See Also

Reference

ScopeServerOpcConfiguration Class
TwinCAT.Measurement.Scope.Control Namespace