AX5000 TwinCAT Drive Manager - Documentation issue status

BECKHOFF AX5000 - TwinCAT驱动管理器：前言

文档发行状态

版本号 | 说明
2.1 | 更新 : 综述 --> 概览 工具条 --> 概览 工作区 --> 概览 工作区--> 树形图 工作区 --> 工作表--> 设备--> 范围 最新 : 前言--> 文档编制说明 前言 --> 安全说明 前言 --> 文档发行状态 附录 --> 技术支持和技术服务 一般例行修订
2.0 | 第一版
1.0 | 内部版


概览-工具栏

BECKHOFF AX5000 - TwinCAT 驱动管理器：工具栏

概览 - 工具栏（toolbar）

循环更新工作区内的参数实际值 。
通过手动点击更新工作区内的参数实际值 。
工作区内显示或隐藏树形图（2）。当按钮（1）处于激活状态，树形图（2）将始终在工作区左侧显示；当按钮（3）处于非激活状态，则树形图将被隐藏 。

显示树形图 隐藏树形图

显示或隐藏状态栏（2）。当按钮（1）处于激活状态，状态栏（2）将始终在工作区底部显示；当按钮（3）处于非激活状态，则状态栏将被隐藏 。
显示状态栏
隐藏状态栏

返回上一对话。
转至下一对话。

注意 		管理员模式

下列标志仅在管理员模式下显示 。

比较xml 描述文件和设备中定义的参数属性，如名称、属性、最小/最大值、默认值、单位等。比较结果在下图所示的窗口中显示 。

在通道 A 与通道B 之间切换。

为选定的电机选择一个驱动器。
输入（1）失速电流之后，必须点击按钮（2）。然后，区域（3）中将列出合适的驱动器。同时可在区域（4）内输入失速电流允许公差下限

调用启动项列表 。

固定参数，不可修改和删除 。
非电机/反馈数据库提供的参数 。
非电机/反馈数据库提供的且被禁用的参数。当EtherCAT处于运行（Op）状态时，不能将这些参数下载到设备中 。
非电机/反馈数据库提供的且还未列入启动项列表的新参数 。
非电机/反馈数据库提供的参数，其设定值与启动项列表和驱动管理器中的值不同 。
电机/反馈数据库提供的参数 。
电机/反馈数据库提供的但被禁用的参数。当 EtherCAT 处于运行（Op）状态时，不能将这些参数下载到设备中 。
电机/反馈数据库提供的且还未列入启动项列表的参数 。
电机/反馈数据库提供的参数，其设定值与启动项列表和驱动管理器中的值不同 。
电机/反馈数据库提供的用户自定义参数。这类参数取决于应用，且必须经过验证 。
电机/反馈数据库提供的但被禁用的用户自定义参数。当EtherCAT 处于运行（Op）状态时，不能将这些参数下载到设备中 。
电机/反馈数据库提供的且还未列入启动项列表的用户自定义参数 。
电机/反馈数据库提供的用户自定义参数，其设定值与启动项列表和驱动管理器中的值不同 。

启动项列表对话框是生成和编辑参数列表的地方，当EtherCAT 切换到安全运行（Safe-Op）或运行（Op）状态时，可将所列参数的设定值下载到设备中。该对话框包含两个部分 ：

  • 上半部分为启动项列表。列表旁边设有“通道切换”、“启用/禁用”、“删除”、“添加一个参数”、“清空列表”、“将列表中的数据导出为 xml 文件”或“导入一个 xml 文件以生成一个列表”等功能按钮。若要激活列表，必须按下确定（OK）按钮 。

  • 下半部分为参数列表，所列参数的设定值已经在驱动管理器（Drive Manager）的工作区内进行了修改。通过按下接受（Accept）或全部接受（Accept All）按钮可将选定的参数或全部参数添加到上半部分的启动项列表中 。

显示状态配置（Status Configuration）窗口，可在此窗口中决定在状态栏内显示哪些参数 。

一旦按下此按钮，工作区内的文本编辑器中将显示实际值（ActValue），否则将显示设定值（Set-value） 。

显示关于（About）窗口，该窗口提供有关驱动管理器和字典文件的版本情况信息。点击帮助（Help）按钮则显示此文档 。

用于修改EtherCAT 状态 。


Device info working sheet

BECKHOFF 驱动技术：TwinCAT驱动管理器

设备信息（Device info）工作表

设备信息（Device info）工作表用于列出固件信息和硬件信息的重要数据，例如厂方版本号。这些数据既可导出为电子文件，也可打印，当您联系技术服务中心时需要提供这些数据。


Display working sheet

BECKHOFF 驱动技术：TwinCAT驱动管理器

显示（Display）工作表

利用显示（Display）工作表可以确定设备前部文字显示面板上的显示内容。只要没有出现设备故障，即可显示所需设置的实际值 。


AX5000 TwinCAT Drive Manager - TwinCAT Scope View

BECKHOFF AX5000 - TwinCAT驱动管理器：工作区 -- 工作表 -- 设备

TwinCAT Scope View

综述

使用 TwinCAT Scope View能够轻松诊断设备参数。在启动 Scope View 前，必须首先激活过程映像（Process Image）（1）上的“ADS”（2）和“启用 ADS 服务器（Enable ADS server）(3)”，同时通过按下按钮（4）让系统管理器的配置生效。

启动TwinCAT Scope View

TwinCAT 驱动管理器中不再集成 TwinCAT Scope View, 因此后者必须单独启动。下图可能因操作系统及软件配置的不同而变化。

有关TwinCAT Scope View 详细信息，请访问 Beckhoff 官方网站 www.Beckhoff.com.cn上的“Download(1) --> Documentation(2) --> TwinCAT (3) --> TwinCAT Scope View(4)”


Controller overview working sheet

BECKHOFF 驱动技术：TwinCAT驱动管理器

控制器（Controller）概览工作表

该工作表给出了 AX5000 控制器的结构概览。您可按下相应的按钮直接进入电源管理（Power Management）、控制器单元（Controller Unit）或电机和反馈装置1（Motor and Feedback 1）工作表 。


Error reaction, drive halt working sheet

BECKHOFF 驱动技术：TwinCAT 驱动管理器

错误响应/驱动停止（Error reaction/drive halt）工作表

可在该工作表中确定错误响应以及驱动停止。


Position controller unit working sheet

BECKHOFF 驱动技术：TwinCAT 驱动管理器

位置控制器单元（Position controller unit）工作表

该工作表更详细地显示了AX5000位置控制器单元的概念。通常情况下，可在编辑器中直接给定设定值，比如位置回路kv 系数 。


Velocity controller unit working sheet

BECKHOFF 驱动技术 ：TwinCAT 驱动管理器

速度控制器单元（Velocity controller unit）工作表

该工作表更详细地显示了AX5000 速度控制器单元的概念。通常情况下，可在编辑器中直接给定设定值，如速度回路总作用时间。


Current controller unit working sheet

BECKHOFF 驱动技术：TwinCAT 驱动管理器

电流控制器单元（Current controller unit）工作表

该工作表更详细地显示了AX5000 电流控制器单元的概念。通常情况下，可在编辑器内直接给定设定值，如电流回路总作用时间 。


Motor and feedback 1 working sheet

BECKHOFF 驱动技术： TwinCAT 驱动管理器

电机和反馈装置1（Motor and feedback 1）工作表

该工作表用于显示所选电机的数据集列表 。

按下按钮 [image] ，可以跳转到上层工作表 “电机和反馈（Motor and Feedback）”。


Feedback 1 working sheet

BECKHOFF 驱动技术： TwinCAT 驱动管理器

反馈装置 1 （Feedback 1）工作表

该工作表用于显示所选反馈装置 1 的各项参数 。

若探测装置1 中Mux 2 内的信号的逻辑配置被选定为“8：参考信号反馈装置前”，则可为探测装置（Probe Unit）设置参考信号

按下按钮 [image] ，可以跳转到上层工作表“电机和反馈装置（Motor and Feedback）” 。


Feedback 2 working sheet

BECKHOFF 驱动技术：TwinCAT驱动管理器

反馈装置2 （Feedback 2）工作表

该工作表用于显示所选定反馈装置2的各项参数。显然，反馈装置 1 和反馈装置2 具有相同的数据结构。

若探测装置1 中Mux 2 内的信号的逻辑配置被选定为“8：参考信号反馈装置前”，则可为探测装置（Probe Unit）设置参考信号 。

按下按钮 [image] ，可以跳转到上层工作表“电机和反馈装置（Motor and Feedback）”。


Digital I/O working sheet

BECKHOFF 驱动技术：TwinCAT驱动管理器

数字量 I/O（Digital I/O）工作表

该工作表用于显示数字量 I/O 状态。一旦有I/O 端口被激活，相关端口号的 LED 灯将呈绿色背景，否则，呈红色背景。

除数字量 I/O 端口 7 外，所有 I/O 端口均为输入端口。数字量I/O 端口 7也可配置成输入端口。复选框用于设置“设定值”，上方的标签可显示端口 7 的实际值。


Manual operation working sheet

BECKHOFF 驱动技术：TwinCAT 驱动管理器

手动操作（Manual operation）工作表

可在手动操作（Manual Operation）工作表中手动激活/停用电机制动器。


Diagnostics working sheet

BECKHOFF 驱动技术：TwinCAT 驱动管理器

诊断（Diagnostics）工作表

诊断（Diagnostics）工作表用于列表显示当前错误和和错误历史记录 。

点击按钮“ [image] ”可以显示内容更详尽的“诊断信息（Diagnostics Info）”对话框 。


IDN debugger working sheet

BECKHOFF 驱动技术：TwinCAT 驱动管理器

IDN调试工具（IDN debugger）工作表

IDN 调试工具（IDN debugger）工作表中可以用“SOE 列格式”格式载入和下载参数。其结果将不会参照 IDN 描述文件 。


Easy CHM - Create your first CHM help or CHM ebook files in 10 seconds with Easy CHM

This CHM was compiled by an UNREGISTERED version of Easy CHM.
Registered version doesn't compile this page into CHM!

Easy CHM Written by: GuohuaSoft |  | Screen Shot
 | File Size: 2989k - 2.84MB | Type: Shareware
Keywords: make chm, create chm, chm converter, html2chm, htm2chm, txt2chm, generate chm, chm maker, convert chm, create Microsoft Htmlhelp, generate Html help, help file generator, chm creation tool, create compressed html-help

Description:
Create your first CHM help or CHM ebook files in 10 seconds with Easy CHM.

Key features:

  • Make CHM (Html Help) file by importing folders and all sub folders in a fast speed.
  • Automatically generate TOC and Index Items by parsing from Html title/file name/text of a specific line.
  • Easy to use TOC editor and support 'Search and replace in TOC items', etc.
  • Fully Multi-Selection support, it's very convenient when Moving/Replacing/Deleting/Drag-Dropping Topics and Batch change icons, etc.
  • Easy CHM can drag-drop or move multiple topics at a time, and there're many handy options like 'Move UP/Down', 'Move Top/Bottom' and 'Move Sibling UP/Down' for you to choose.
  • Fully Keyboard support.
  • With the internal fast Virtual Tree, it's very fast and stable when editing a very large TOC tree.
  • Convert HTM, HTML, MHT, Picture and other files to CHM.
  • Automatically create a Context-Sensitive Html Help.
  • Automatically output Alias and Map files for developers to use.
  • EasyCHM can save/load project file, it's easy for the content developers for documentation to manage or edit their documents.
  • Convert any CHM files to html freely.
  • Plenty of customized options.
  • Multilanguage support, the interface of the program can be changed to Arabic, English, French, German, Korean, Polish, Portuguese, Russian, Simplified Chinese, Spanish, Swedish, Traditional Chinese, Turkish, Ukrainian.
  • Built-in CHM files decompiler.
  • Easy-to-use interface.
Contact Info:

Via Web:

Zipghost website: http://www.zipghost.com

eTextWizard website: http://www.etextwizard.com

Via E-mail:

webmaster@etextwizard.com
Order Online:

http://www.zipghost.com/order_easychm.html

http://www.etextwizard.com/order_easychm.html

Download URLs:

Supported Operating Systems: Win98,WinME,WinXP,Windows2000,WinVista
System Requirements:
Install Support: Install and Uninstall


AX5000-TwinCAT驱动管理器

BECKHOFF 驱动技术

操作手册

AX5000 - TwinCAT 驱动管理器

版本号: 2.1
日期: 2008.9.22


AX5000 TwinCAT驱动管理器

BECKHOFF 驱动技术

操作手册

AX5000 - TwinCAT 驱动管理器

版本号: 2.1
日期: 2008.09.22