AX51xx, AX52xx - Digital servo drives

BECKHOFF Drive Technology

Operating instructions

Servo Drives AX5000

Version: 2.4

Date: 2009-11-03


AX5000 - Table of contents

BECKHOFF Automation: AX5000 - Digital servo drives

目录

章节

封面
目录

前言

文档编制说明
安全说明
关于AX5000的特别安全说明
正确使用
准则和标准
版权
文档执行状态

产品概况

简介
概览
技术参数
类型代码和名称板
设备
尺寸

安装

运输与存储
机械安装
安装
电气安装
概况
供电
EtherCAT
数字量 I/O
I/O 插拔式连接器 — ZS4500
反馈
电机

调试

基本原理
参数处理
第一步
运行模式
驱动功能
参考运动
探针装置
回零点
硬件终端位置特性
探针装置功能
电机制动管理
通信方法
维护

集成安全

安全卡AX5801

关闭

关机

附件

AX-Bridge 快速连接系统
直流母线扩展模块 AX5001
AX5021 制动模块
外部制动电阻器-AX2090-BW5x
能量恢复
选择性译码器卡-AX5701 / AX5702
电缆
电机与反馈电缆的指令键
电机电缆
电机电缆扩展
用于 Beckhoff 电机的反馈电缆
用于 Beckhoff 电机的反馈电缆扩展
特殊电机接口

附录

故障管理
Beckhoff自动化系统
概况
EtherCAT-系统结构
EtherCAT-系统特性
EtherCAT-布线
EtherCAT-状态机
EtherCAT用作驱动总线
支持和服务


AX5000 - Copyright

BECKHOFF AX5000: Foreword

版权

©本手册受版权保护，未经Beckhoff自动化有限公司书面允许，禁止任何复制或第三方使用，不管是全部还是部分。

  • Windows是微软公司的注册商标。
  • HIPERFACE是Max Stegmann公司的注册商标。
  • EnDat是Dr. Johannes Heidenhain公司的注册商标。
  • SERCOS接口是SERCOS接口e.V的注册商标。


AX5000 - General overview

BECKHOFF AX5000: Product overview

概览

如下为最大设计电流为12A的两通道伺服驱动器。仅适用于第二个通道的组件可在条目说明中鉴别出来。尽管连接图相同，但18A和25A的单元宽度相差两倍。

条目说明：

No. | 说明
1 | X11 - 反馈连接, 编码器
2 | X12 - 反馈连接, 旋转变压器
3 | X21 - 反馈连接, 编码器 通道B (仅对于两通道单元)
4 | X22 - 反馈连接, 旋转变压器 通道B (仅对于两通道单元)
5 | X3x - 安全卡选择槽 X4x - 扩展卡选择槽
6 | 导航摇杆
7 | EtherCAT输出的LED状态灯
8 | 标签区
9 | X05 - EtherCAT输出接口
10 | X03 - 24V直流电源输入接口
11 | X14 - 电机温度传感器和制动器
12 | X24 - 电机温度传感器和制动器 通道B (仅对于两通道单元)
13 | X23 - 电机连接 (U, V, W, PE) 通道B (仅对于两通道单元)
14 | X13 - 电机连接(U, V, W, PE)
15 | X01 -电源100 – 480 V
16 | X02 - 直流连接输出 (890 V直流电压) 连接外部制动电阻
17 | WARNING | 直流连接端子中890 V直流电压。当关闭设备后，这个危险的电压或许还会存在至少3分钟。
18 | X04 - EtherCAT输入接口
19 | 标签区
20 | EtherCAT输如的LED状态灯
21 | 显示
22 | X06 -数字输入输出连接


AX5000 - Type code and Name plates

BECKHOFF AX5000: Product overview

类型码和铭牌

类型码

AX5xyz-a b c d
AX | Beckhoff 产品线： 伺服驱动器
5 | 系列： 5000
X | 通道编号： 1 = 单通道 2 = 双通道
YZ | 每个通道的额定电流： 单通道设备： 01, 03, 06, 12, 18, 25, 40, 60, 72, 90 or: 91 = 110 A 92 = 143 A 93 = 170 A 双通道设备： 01, 03, 06
-a | ---
bc | 硬件特点： 00 = 标准 01 = 封闭式外壳冷板设计 02 = 为供货时通常不带风扇的设备准备的辅助风扇（例如：AX5201）
d | 版本： 0 = 标准版本 1 = 客户版本（见密钥）

铭牌

伺服驱动器配备两块铭牌。

  • 大铭牌
  • 小铭牌

大铭牌安装在伺服驱动器的侧面，包含以下信息：

第二个铭牌安装在上部安装法兰上，用于显示主要信息，即使将多个 AX5000 直接并排安装在一起。小铭牌包含以下信息：

1 | 目录编号 | 6 | 输出额定电压 | 11 | 用户定制
2 | 最大环境温度 | 7 | 输出额定电流 | 12 | 仅有Y字形接口
3 | 输入额定电压 | 8 | 输出频率范围 | 13 | 符合CE认证
4 | 输入额定电流 | 9 | 防护等级 | 14 | 符合UL认证
5 | 输入频率 | 10 | 序列号 |  |


AX5000 equipment

BECKHOFF AX5000: Product overview

设备

供货范围

AX5000 供货方式如下：

  • AX5000 根据订单选择性能等级
  • 插拔式连接器
    X01: 用于主电源输入
    X02: 用于直流母线
    X03: 用于 DC 电源（24 V）
    X06: 用于数字量输入与输出
  • 简短描述（快速入门）
  • 光盘文档

Note 		连接器
D-Sub 连接器 X11, X12, X21, X22 （用于反馈电缆与旋转变压器/霍尔传感器）与电机和传感连接器 X13, X14, X23, X24 并不属于伺服驱动器的供货范围内。

附件

UL认证的附件!
如果你希望将AX5000用于需要UL认证的经济领域，请确认附件也得到UL认证。

可提供以下可选附件（参见 Beckhoff 产品选型手册或登录 www.beckhoff.de）：

  • 电机与反馈电缆 (预制)
  • 以米为单位销售的电机与反馈电缆
  • D-Sub 连接器 X11, X12, X21, X22 （用于反馈电缆与旋转变压器/霍尔传感器）
  • 电机与传感器连接器 X13, X14, X23, X24
  • EtherCAT 总线电缆，预制或以米为单位销售
  • 同步伺服电机（直线或旋转式）
  • 外部平稳电阻
  • 扩展卡
  • 附加模块


AX5000 - Dimensions

BECKHOFF AX5000: Product overview

外形尺寸

AX5000 作为单一设备

所有尺寸均以毫米为单位。


AX5000 - Mechanical installation

BECKHOFF AX5000: Installation

机械安装

WARNING 		警告– 有受伤的危险!
  • 必须由合格的专业人员来安装伺服驱动器。安装人员必须了解并遵守本国的突发事件预防准则。
  • 必须穿安全靴。

WARNING 		警告 - 有电击受伤的危险!
在开始安装或拆卸前，对所有的电器组件（伺服驱动器、控制柜等）断电。

CAUTION 		会破坏伺服驱动器!
  • 垂直安装伺服驱动器。
  • 以确保伺服驱动器中的空气流通。在“技术参数”部分介绍了所允许的环境条件。
  • 要保持要求的距离。(看下图)

安装示例

WARNING 		警告 - 有遭受电击的危险!
注意安装板要合理的接地。


AX5000 - Electrical installation - EtherCAT

BECKHOFF AX5000: Installation

EtherCAT

X04, X05: EtherCAT接口

AX5000 通过 X04 与 X05 RJ45 插口集成在 EtherCAT 中。

RJ45 | 信号
X04 (IN) | 引入 EtherCAT线
X05 (OUT) | 引出 EtherCAT线


AX5000 - Feedback

BECKHOFF AX5000: Installation

反馈

在 "调试-->通信方法"章节中你可以看到有关通信的信息。

有关极限频率的信息可参看下文，接口说明处！

Note 		绝对编码器
当使用绝对编码器时，在移动轴之前，必须j检测行程范围内反馈系统所提供的特别位置的预期位置-‘START’和‘MID’和‘END’的数据–重启AX5000后(Bootstrap -> OP)这些位置数据能够保留。

编码器

AX5000 编码器的测试与发布

旋转型编码器

Heidenhain:

Heidenhain公司提供了2种版本的‘EnDat 2.2’ 反馈接口。其中一个版本没有提供模拟信号，另一个版本提供了‘1Vss’模拟信号。迄今为止，Beckhoff自动化有限公司只支持带有模拟信号的EnDat 2.1。由于EnDat 2.2接口支持所有的EnDat 2.1命令，所以只需注意带有EnDat 2.2反馈接口中是否提供的模拟信号1Vss。即必须注明带有Heidenhain ‘EnDat02’指令 。

型号 | 系统 | 每转的线数/正余弦周期数 | 电源电压 | 接口 | 扫描
ECI 1118 | 单圈 | 16 | 5 V | EnDat 2.1 | 电感应
ECI 1319 | 单圈 | 32 | 5 V or 7 - 10 V | EnDat 2.1 | 电感应
ECN 413 | 单圈 | 512 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | 光学
ECN 413 | 单圈 | 2048 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | 光学
ECN 1113 | 单圈 | 512 | 5 V | EnDat 2.1 + 1 Vpp | 光学
ECN 1313 | 单圈 | 2048 | 5 V | EnDat 2.1 + 1 Vpp | 光学
EQI 1130 | 多圈 | 16 | 5 V | EnDat 2.1 | 电感应
EQI 1331 | 多圈 | 32 | 5 V or 7 - 10 V | EnDat 2.1 | 电感应
EQN 425 | 多圈 | 512 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | 光学
EQN 425 | 多圈 | 2048 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | 光学
EQN 1125 | 多圈 | 512 | 5 V | EnDat 2.1 + 1 Vpp | 光学
EQN 1325 | 多圈 | 512 | 5 V | EnDat 2.1 + 1 Vpp | 光学
EQN 1325 | 多圈 | 2048 | 5 V | EnDat 2.1 + 1 Vpp | 光学
RCN 829 | 单圈 | 32768 | 3,6 V - 5,25 V | EnDat 2.2 + 1 Vpp | 光学
ROQ 425 | 多圈 | 512 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | 光学
ROQ 425 | 多圈 | 2048 | 3,6 V - 14 V | EnDat 2.1 + 1 Vpp | 光学
ERN 180 | 增量 | 1024 | 5 V | 1 Vpp | 光学
ERN 180 | 增量 | 2048 | 5 V | 1 Vpp | 光学
ERN 180 | 增量 | 5000 | 5 V | 1 Vpp | 光学
ERN 480 | 增量 | 2048 | 5 V | 1 Vpp | 光学
ERM 280 | 增量 | 1200 | 5 V | 1 Vpp | 磁感应

Hengstler:

型号 | 系统 | 每转的线数/正余弦周期数 | 电源电压 | 接口 | 扫描
AD 34 | 单圈 | 2048 | 5 V | BiSS + 1 Vpp | 光学
AD 36 | 单圈 | 2048 | 5 V | BiSS + 1 Vpp | 光学
AD 36 | 多圈 | 2048 | 5 V | BiSS + 1 Vpp | 光学
AD 58 | 单圈 | 2048 | 5 V | BiSS + 1 Vpp | 光学
AD 58 | 多圈 | 2048 | 5 V | BiSS + 1 Vpp | 光学

Kübler:

型号 | 系统 | 每转的线数/正余弦周期数 | 电源电压 | 接口 | 扫描
8.5853 | 单圈 | 2048 | 5 V | BiSS + 1 Vpp | 光学

Sick Stegmann:

型号 | 系统 | 每转的线数/正余弦周期数 | 电源电压 | 接口 | 扫描
SEK 37 | 单圈 | 16 | 7 V - 12 V | HIPERFACE | 电容式
SEK 52 | 单圈 | 16 | 7 V - 12 V | HIPERFACE | 电容式
SRS 50 | 单圈 | 512 | 7 V - 12 V | HIPERFACE + 1 Vpp | 光学
SRM 50 | 多圈 | 512 | 7 V - 12 V | HIPERFACE + 1 Vpp | 光学

通用旋转编码器:

型号 | 系统 | 每转的线数/正余弦周期数 | 电源电压 | 接口 | 扫描
1 |  | 512 | 5 V | 1 Vpp |

直线编码器

Heidenhain:

型号 | 系统 | 测量步长 | 电源电压 | 接口 | 扫描
LS 388C | 增量 | 20 µm | 5 V | 1 Vpp | 光学
LS 486 | 增量 | 20 µm | 5 V | 1 Vpp | 光学
LS 487 | 增量 | 20 µm | 5 V | 1 Vpp | 光学
LC 483 | 增量 | 20 µm | 3,6 V - 5,25 V | Endat 2.1 + 1 Vpp | 光学
LIDA 483 | 增量 | 20 µm | 5 V | 1 Vpp | 光学
LIDA 287 | 增量 | 200 µm | 5 V | 1 Vpp | 光学

HIWIN:

型号 | 系统 | 测量步长 | 电源电压 | 接口 | 扫描
Magic | 增量 | 1 mm | 5 V | 1 Vpp | 磁感应

lika:

型号 | 系统 | 测量步长 | 电源电压 | 接口 | 扫描
SMS | 增量 | 1 mm | 5 V | 1 Vpp | 磁感应

Numerik Jena:

型号 | 系统 | 测量步长 | 电源电压 | 接口 | 扫描
LIA20 | 增量 | 20 µm | 5 V | 1 Vpp | 光学

Siko:

型号 | 系统 | 测量步长 | 电源电压 | 接口 | 扫描
LE100/1 | 增量 | 1 mm | 5 V | 1 Vpp | 磁感应

通用线性编码器:

型号 | 系统 | 测量步长 | 电源电压 | 接口 | 扫描
1 | 增量 | 20 µm | 5 V | 1 Vpp |
2 | 增量 | 1 mm | 5 V | 1 Vpp |
3 | 增量 | 20 µm | 5 V - 无控制 | 1 Vpp |
4 | 增量 | 1 mm | 5 V - 无控制 | 1 Vpp |

Note 		电机反馈数据库
如果此处没有列出你的反馈系统，请点击Beckhoff download area. 通过下载和安装‘AX5000 setup’ ，你会获得TwinCAT Drive Manager、最新的固件和最新的电机反馈数据库。

X11 and X21: 反馈，高分辨率编码器

X11与X21的D-SUB接口可用于连接高分辨率反馈系统。使用时，X11分配给轴1，X21分配给轴2。

插针 | EnDAT / BiSS | Hiperface | 正弦 / 余弦 1Vpp | TTL | 输出电流
1 | SIN | SIN | SIN | n.c. | 最大250 mA
2 | GND_5 V | GND_9 V | GND_5 V | GND_5 V
3 | COS | COS | COS | n.c.
4 | Us_5 V | n.c. | Us_5 V | Us_5 V
5 | DX+ (Data) | DX+ (Data) | n.c. | B+
6 | n.c. | Us_9V | n.c. | n.c.
7 | n.c. | n.c. | REF Z | REF Z
8 | CLK+ (Clock) | n.c. | n.c. | A+
9 | REFSIN | REFSIN | REFSIN | n.c.
10 | GND_Sense | n.c. | GND_Sense | GND_Sense
11 | REFCOS | REFCOS | REFCOS | n.c.
12 | Us_5 V_Sense | n.c. | Us_5 V_Sense | Us_5 V_Sense
13 | DX- (Data) | DX- (Data) | n.c. | B-
14 | n.c. | n.c. | Z | Z
15 | CLK- (Clock) | n.c. | n.c. | A-

限制频率:

1Vpp = 270 kHz
TTL = 10 MHz
MES = 300 Hz

旋转变压器

通用旋转变压器：

型号 | 极数 | 频率 | 速比 | 相位差
1 | 2 | 8 kHz | 0,5 phi | 0 °
2 | 6 | 8 kHz | 0,5 phi | 0 °
3 | 8 | 8 kHz | 0,5 phi | 0 °

X12 与 X22：反馈，旋转变压器/霍尔传感器

X12 与 X22的 D-SUB 接口可用于旋转变压器或霍尔传感器。X12 在使用中分配给轴 1，X22 分配给轴 2。

旋转变压器规格:

引脚
 | 旋转变压器 | 模拟霍耳传感器
1 | 温度（只有PTC，Klixon或双金属！） 开关点 1178 W | n.c.
2 | AGND | n.c.
3 | COS - (S3) | n.c.
4 | SIN - (S4) | n.c.
5 | REF - (R2) | n.c.
6 | n.c. | SIN 1 Vpp
7 | n.c. | -120° or -90° 1 Vpp *
8 | n.c. | Us_9 V （电源）
9 | Temp. _ GND | n.c.
10 | COS + (S1) | n.c.
11 | SIN + (S2) | n.c.
12 | REF + (R1) | n.c.
13 | n.c. | REFSIN 1 Vpp
14 | n.c. | REF -120° or -90° 1 Vpp *
15 | n.c. | GND （电源）

*) 必须对角度进行配置

限制频率：

旋转变压器 = 300 Hz


AX5000 - Commutation Methods

BECKHOFF AX5000: Commissioning

Commutation methods

The important characteristics of a servomotor, such as its very smooth running, high efficiency and optimum thermal utilization, are strongly influenced by the commutation. Commutation refers to the transfer of current from one winding to the next. The moment at which commutation takes place must be harmonized with the magnetic field of the rotor if the servomotor is to operate most effectively.

Rotary servomotors

Mechanical commutation

These motors, which use brushes, generate the alternating fields necessary for operation of the motor through sliding contacts, whose geometrical arrangement switches the current paths. Brush losses and wear are disadvantages of this simple, mechanical commutation method.

Electronic commutation

These modern motors generate the alternating field needed for operation of the motor by means of an electronic circuit which is not subject to either wear or friction. The type of motor and the encoder system in use determine the commutation method.

Absolute encoder system (motor feedback) within one rotation

Samples of this type of encoder system includes: Resolver, EnDat, BiSS and HIPERFACE

Two different commutation methods are involved here:

Mechanical adjustment of the encoder

The motor's encoder system is mechanically adjusted at the factory (the encoder and rotor are matched to one another), but the rotor position is unknown.
The commutation angle is determined once by the P160 command, using the IDN "P0-0-165_Command mode_Static current vector" and the IDN "P-0-057 "Electrical commutation offset". This means that the corresponding mechanical angle coming from the encoder system is displayed and read out in P-0-0058, and is saved in the IDN "P-0-0150_Parameter chanel_Adjustable commutation offset" (motor database). In order for the parameter to be used, the IDN "P-0-0150_Parameter chanel_Commutation mode" (motor database) must be set to 3: "Adjustable offset". The associated value of the IDN "P-0-057 "Electrical commutation offset" is also saved in the motor database.

Electronic adjustment of the encoder system

Note 		Synchronous motors!
Electronic adjustment is only required for synchronous motors. In the case of a synchronous motor, the magnetic field of the rotor is generated electronically, and therefore can be set appropriately for the electromagnetic field of the winding.

Depending on the encoder system there are, again, two different commutation methods:

  1. The encoder is always attached to the rotor by the manufacturer in the same rotary position, but the rotor position is not known.
    The commutation angle is determined once by the P160 command, using the IDN "P0-0-165_Command mode_Static current vector" and the IDN "P-0-057 "Electrical commutation offset". This means that the corresponding mechanical angle coming from the encoder system is displayed and read out in P-0-0058, and is saved in the encoder system's data store (exceptionally) and in the IDN "P-0-0150_Parameter chanel_Adjustable commutation offset" (motor database). In order for the parameter to be used, the IDN "P-0-0150_Parameter chanel_Commutation mode" (motor database) must be set to 3: "Adjustable offset". The associated value of the IDN "P-0-057 "Electrical commutation offset" is also saved in the motor database. This method requires a encoder system having a data store and a data line.
  2. The angle between the encoder system and the rotor is determined by the motor manufacturer using a command that is specific to the encoder, and is communicated to the encoder system. The encoder system stores this angle, using it for internal calculation, but the rotor position is unknown.
    The commutation angle is determined once by the P160 command, using the IDN "P0-0-165_Command mode_Static current vector" and the IDN "P-0-057 "Electrical commutation offset". This means that the corresponding mechanical angle coming from the encoder system is displayed and read out in P-0-0058, and is saved in the encoder system's data store (exceptionally) and in the IDN "P-0-0150_Parameter chanel_Adjustable commutation offset" (motor database). In order for the parameter to be used, the IDN "P-0-0150_Parameter chanel_Commutation mode" (motor database) must be set to 3: "Adjustable offset". This angle is always included in internal calculation processes. This method requires an intelligent encoder system.

Non-absolute encoder system (feedback) within one rotation

Samples of this type of encoder system includes: SIN / COS 1Vss, TTL

In this case, a special commutation procedure (wake&shake) must be run in order to determine the commutation angle. This angle is stored internally, and is taken into account during operation. If the AX5000 is switched off, or if the "EtherCAT-State machine" is switched into "Pre-op" or a lower state, the commutation angle will be lost because the encoder system is not absolute. "Wake&shake" can only operate without error when the drive system is running steadily; in other words there must not be any vibrations affecting the motor from outside. In addition, a stability investigation using the default values of the "IDN P-0-0165" is necessary the first time the system is operated.

Stability investigation

Note 		Oscillatory system!
It is important for this stability investigation to examine the application in advance and to determine the oscillation that is potentially most problematic. This case can occur under load conditions, or may be found when unloaded.

WARNING 		Warning, risk of injury from uncontrolled movements!
In the method described below, the motor shaft is brought directly to a certain position. Make sure that your application permits this movement, secure the surroundings to prevent unintentional entry, and make sure that nobody is in the hazardous area.

Oscillatory system

It is necessary to analyze the vibration pattern of an oscillating system, and to take appropriate damping measures. Oscillations always have their effect in Phase 2 of "wake&shake"; oscillations are not particularly critical in Phase 1.

Decaying oscillation

The amplitude (k) and the decay time (l) of this kind of oscillation must be found. The parameters IDN-P-0-0165 "Commutation pos control: Kp" can affect both the amplitude (k) and the decay time (l). The parameter IDN-P-0-0165 " Second phase duration" should be greater than the decay time (l).

Constant oscillation

This kind of oscillation is unacceptable, as a stable regulation process is not established. The parameters IDN-P-0-0165 "Commutation pos control: Kp" must be checked, and modified if necessary. If this does not achieve the desired result, you must damp the vibration mechanically.

Rising oscillation

This kind of oscillation is unacceptable, as a stable regulation process is not established. The parameters IDN-P-0-0165 "Commutation pos control: Kp" must be checked, and modified if necessary. If this does not achieve the desired result, you must damp the vibration mechanically.

The motor shaft is brought to freely definable electrical positions by impressing an appropriate current in the course of this investigation. When this injected current is switched off, the motor should remain in the position that it has reached. BECKHOFF recommends positions of 0°, 90°, 180° and 270°. In critical applications, eight positions (0°, 45°, 90°, 135° ...315°) should be selected instead of four. The current injection is parameterized in the IDN P-0-0165 under "Static current vector", while the freely selectable electrical position is set in the IDN P-0-0057. "Wake&shake" should be carried out in each position; stability of the system is only ensured when this has been done successfully.

Wake&shake

Note 		Oscillating system!
A mechanical remedy must be provided if the application oscillates. You can carry out the commutation up to a degree using wake&shake, but should carefully select the parameters for the IDN "P-0-0165" to make the effect of the oscillation as small as possible, since too much post-pulse oscillation will cause a commutation error. This is because the angle measured after completing the command will be entered as the commutation angle.

WARNING 		Warning, risk of injury from uncontrolled movements!
The motor shaft will be moved in steps during the process described below. In Phase 1 the maximum electrical movement is 8 x (the value from "P-0-0-0165_Fist phase position monitoring limit"). In Phase 2 it is 0.5 x (the value from "P-0-0-0165_Fist phase step width"). This formula can only be applied if the previous investigation of stability has been concluded satisfactorily. Make sure that your application permits this movement, secure the surroundings to prevent unintentional entry, and make sure that nobody is in the hazardous area.

The wake&shake commutation function consists of two phases. An approximate determination of the rotor position is carried out in Phase 1, while Phase 2 determines the position more precisely. The aim of the commutation function is to determine the precise position of the rotor with a minimum amount of movement.

Due to the pairs of poles, servomotors exhibit a direct relationship between the electrical and mechanical rotation. One electrical rotation always corresponds to one mechanical rotation divided by the number of pole pairs. A motor with a single pair of poles is illustrated in the following example for the sake of simplifying the calculation.

Parameterization is carried out using the IDN P-0-0165 "Commutation offset calibration parameter". The quoted angles always refer to electrical rotations!

IDN P-0-0165 - Commutation offset calibration parameter

Parameter | Default | Description
Command mode | 0: Static current vector | Selection between two commutation methods
Activation | 0: manual | Selection of when the commutation process is started
Static current vector |  | Commutation methods
Current level | Stationary current in % | Current intensity of the current vector (value = 100% x P0-0093 / P0-0092)
Duration | 3000 ms | Period for which the parameterized current is maintained so that any oscillations that may be present can settle, allowing an optimum commutation angle to be reached
Wake and shake |  | Commutation methods
First phase current vector | Stationary current in % | Current intensity of the current vector (value = 100% x P0-0093 / P0-0092)
First phase ramp up time | 100 ms | Time for the current vector "a" to reach its parameterized magnitude
Second phase current level | Stationary current in % | Current intensity of the current vector (value = 100% x P0-0093 / P0-0092)
Second phase ramp up time | 500 ms | Time for the current vector "g" to reach its parameterized magnitude
Commutation pos control: Kp | 0,04 | Amplification factor. Warning: If "0" then Variant 2 will be carried out in Phase 2
Wake and shake expert |  | Warning: Only experienced users should change the following parameters!
First phase pos monitoring limit | 0.5 degrees | Minimum angle of rotation of the rotor required to detect movement
First phase step width | 22.5 degrees | Current vector offset or segment detection angle
First phase waiting time after step | 150 ms | The time from detection of movement and the next step in Phase 1 or between Phase 1 and Phase 2 (any oscillations in the system have time to settle)
Second phase duration | 3000 ms | Period for which the parameterized current is maintained so that any oscillations that may be present can settle, allowing an optimum commutation angle to be reached
Error monitoring (range of motion) | 90 degrees | The maximum movement of the rotor before it is switched off, since there would otherwise be a risk that the motor would make an uncontrolled movement.

= identifying characters for the description below

Motor with 3 pole pairs | Motor with one pair of poles
Phase 1 - approximate determination of the rotor position (motor shaft)

Step 1

= see the parameter description for IDN P-0-0165 above

= flux vector of the rotor with permanent magnet.

Sequence:
A current vector "a" is developed during the time "b". Due to the rising magnetic force, the rotor "c" is turned in the direction of the current vector "a". The direction of rotation "d" is transmitted to the feedback system and the AX5000, where it is stored.

Step 2

= see the parameter description for IDN P-0-0165 above

= flux vector of the rotor with permanent magnet.

Sequence:
A current vector "a" is developed during the time "b". Due to the rising magnetic force, the rotor "c" is turned in the direction of the current vector "a". The direction of rotation "d" is transmitted to the feedback system and the AX5000, where it is stored and analysed. If the analysis shows that the direction of rotation "d" of the rotor "c" has not changed when compared with that of the previous impressed current, the process continues.

Step 3

= see the parameter description for IDN P-0-0165 above

= flux vector of the rotor with permanent magnet.

Sequence:
The current vector "a" is again set to the magnitude "e" in the direction of the rotor "c".
The current vector "a" is now again developed during the time "b". Due to the rising magnetic force, the rotor "c" is turned in the direction of the current vector "a". The direction of rotation "d" is transmitted to the feedback system and the AX5000, where it is stored and analysed. In this case, the analysis shows that the direction of rotation "d" of the rotor "c" has changed when compared with that of the previous impressed current. As a result, the sector in which the rotor "c" is located has been found, and Phase 1 is therefore completed.

Example of an oscilloscope display of Phase 1
Phase 2 - precise determination of the rotor position (motor shaft)

There are two variants of the precise localization that may be used in Phase 2. In the first variant, the rotor only makes minimal movement, but this does require a very stable system with only a slight tendency to oscillate. In the second variant, the rotor can move by up to a maximum of half the sector [image], but this method is much more tolerant against oscillation.

The value set in the parameter IDN-P-0-0165 "Commutation pos control: Kp" controls which variant is used:
IDN-P-0-0165 "Commutation pos control: Kp" > 0 --> Variant 1
IDN-P-0-0165 "Commutation pos control: Kp" = 0 --> Variant 2

Variant 1 (IDN-P-0-0165 "Commutation pos control: Kp" > 0 )

= see the parameter description for IDN P-0-0165 above

= flux vector of the rotor with permanent magnet.

= movement of the rotor

Sequence:
The current vector "g" is developed starting from the final position of the current vector "a" in Phase 1. Due to the rising magnetic force, the rotor "c" is turned in the direction of the current vector "g". The movement is passed through the feedback system to the AX5000, and supplied to a control loop. This control loop immediately corrects the direction of the current vector. This algorithm is executed until the parameterized current intensity is achieved, and the current vector approximately coincides with the flux vector. The current is now maintained over the period "h" which ensures that optimum commutation takes place. In this control algorithm, the rotor only moves minimally through "i".

Variant 2 (IDN-P-0-0165 "Commutation pos control: Kp" = 0 )

= see the parameter description for IDN P-0-0165 above

= flux vector of the rotor with permanent magnet.

= movement of the rotor

Sequence:
After determining the sector "e" in Phase 1, the current vector "g" is placed exactly in the centre of the sector "e", and this current is developed. Due to the rising magnetic force, the rotor "c" is turned in the direction of the current vector "g" until they coincide. In this static alignment, the rotor cannot move more than half the width of the sector "e".

Using IDN P-0-0165 to affect wake&shake
Parameter | Default | Possible causes that might require a change in the default value
First phase current level | Stationary current in % | Sluggish system, high damping --> increase value Easy-running system, low damping --> reduce value
First phase ramp up time | 100 ms | Sluggish system, high damping --> increase value Easy-running system, low damping --> reduce value
First phase pos monitoring limit | 0.5 degrees | Application only permits very limited uncontrolled changes in the movement --> reduce value The system has a small amount of damping --> reduce value The loading relationships require more overshoot --> increase value
First phase step width | 22.5 degrees |
First phase waiting time after step | 150 ms | Decay behaviour of the system: Long settling time --> increase value Short settling time --> reduce value
Second phase current level | Stationary current in % |
Second phase ramp up time | 500 ms |
Second phase duration | 3000 ms |
Error monitoring (range of motion) | 90 degrees | Application only permits very limited uncontrolled changes in the movement --> reduce value The system has a small amount of damping --> reduce value The loading relationships require more overshoot --> increase value
Commutation pos control: Kp | 0,04 | High load stiffness --> increase value Low load stiffness --> reduce value A special case "0": Variant 2 is carried out in Phase 2

Linear motors

The above description of the commutation process applies equally to rotary motors and to linear motors. Depending on the construction, there are merely some differences of nomenclature (e.g. motor shaft (rotor) @ primary assembly; "degree" @ "mm" (recalculation is needed))

WARNING 		Warning, risk of injury from uncontrolled movements!
The primary assembly is moved in steps during "wake&shake". In Phase 1 the maximum electrical movement is 8 x (the value from "P-0-0-0165_Fist phase position monitoring limit"). In Phase 2 it is 0.5 x (the value from "P-0-0-0165_Fist phase step width"). This formula can only be applied if the previous investigation of stability has been concluded satisfactorily. Make sure that your application permits this movement, secure the surroundings to prevent unintentional entry, and make sure that nobody is in the hazardous area.

Linear motors consist of a secondary assembly, whose position is fixed, onto which permanent magnets are attached with alternating polarity and regular spacing. A primary assembly can undergo translatory movement above this magnetic field. This movement is created by generating an electromagnetic field in the primary assembly. Linear motors always have only one pair of poles, and the distance between the poles therefore corresponds to one electrical rotation.

The "Electronic Commutation" section above can be applied to linear motors.


AX5000 Maintenance

BECKHOFF AX5000: Commissioning

维护

维修服务

  • 免维护型设备
  • 擅自打开设备会造成设备保修条款的失效

清理

  • 机箱污物：使用异丙醇或类似物质清理 •
    请勿浸泡或喷洒!
  • 设备内部污物：由制造商负责清理
  • 风扇防护罩污物：使用（干燥）毛刷清理


AX5000 - Brake module AX5021

BECKHOFF AX5000: Accessories

AX5021 制动模块

（研发中）

制动模块由内部制动电阻（Prms = 250 W）与主动散热装置构成。该系统集成了一个用于连接外部制动电阻（电容高达 Prms = 6 kW）的制动斩波器。与 AX5000 系列伺服驱动器的连接是通过 AX bridge 连接模块建立的。

性能指标

内部电阻连续制动功率 Prms [W] | 内部电阻峰值功率 Ppeak [W] | 外部电阻最小值 [Ω | 外部电阻连续制动功率 Prms [W] | 外部电阻峰值功率 Ppeak [W]
250 | - | 15 | 6.000 | max. 47.600


AX5000 - AX2090-BW5x-xxxx

BECKHOFF AX5000: Accessories

External Brake Resistor - AX2090-BW5x-xxxx

Appropriate use

The brake resistors from the AX2090-BW5x-xxxx series are exclusively designed for direct application with an AX5000 series servo drive or the AX5021 brake module. They are designed for installation as components in electrical installations and machines together with the servo drive or the brake module, and this is their only purpose.

Scope of supply

The scope of supply includes the following components:

  • Brake resistor from the required performance class
  • Technical documentation
  • Packaging

If one of the components is damaged please notify the logistics company and Beckhoff Automation GmbH immediately.

Safety rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations and guidelines.

DANGER 		Caution – Danger of death!
Even when the AX5000 is disconnected from the mains voltage, dangerous voltage continues to be present at the "X02" terminals of the DC link for at least 5 minutes. Never touch the terminals within this period.

WARNING 		Caution - Risk of injury through hot surfaces!
The temperature of the brake resistor housing surface may reach over 200 °C. Please ensure that the housing has cooled down below 40 °C before touching it.
UL-Listing!
It is essential to observe chapter "Product overview-->Guidelines and Standards-->UL-Listing" if you wish to operate an AX5000 in an economic area that requires a UL-Listing.

Product description

Attention 		Caution - Destruction of the equipment
The brake resistor may only be connected to individual AX5000 devices or AX5021 brake modules. It must never be used in a drive system without the AX5021 brake module, since this may lead to its destruction through overload.

The external brake resistors of the AX2090-BW5x-xxxx series are able to convert the dynamic energy generated during braking of a servomotor into heat. The series covers a wide continuous power and peak power range. The built-in temperature switch enables the system to respond immediately to any overload of the brake resistor through analysis in the AX5000 or the PLC. All brake resistors of the AX2090-BW5x-xxxx series are UL and CSA approved.

Attention 		Caution - Destruction of the brake resistor and consequential damage
The built-in temperature switch must be monitored, so that the machine can be stopped in a controlled manner and switched off in the event of an overloading of the brake resistor.

Type key

Mechanical installation

Dimensions and technical data

Type | Nominal capacity [W] * at 40 °C | Resistance [W] | O [mm] | R [mm] | H [mm] | M [mm] | U [mm] | Weight [kg] | AX5000
AX2090-BW50-0300 | 300 | 47 | 349 | 92 | 120 | 230 | 64 | 2 | AX5x01-AX5112
AX2090-BW50-0600 | 600 | 47 | 549 | 92 | 120 | 430 | 64 | 3 | AX5x01-AX5112
AX2090-BW50-1600 | 1600 | 47 | 649 | 185 | 120 | 530 | 150 | 5,8 | AX5x01-AX5112
AX2090-BW51-1000 | 1000 | 23 | 749 | 92 | 120 | 630 | 64 | 4 | AX5118, AX5125
AX2090-BW51-3000 | 3000 | 23,4 | 490 | 355 | 255 | 380 | 270 | 8 | AX5118, AX5125
AX2090-BW51-6000 | 6000 | 23,2 | 490 | 455 | 255 | 380 | 370 | 12 | AX5118, AX5125

*) 4% output reduction per 10 K temperature difference

Mounting positions and distances

(A) = vertical installation is only permitted according to the diagram (terminal box facing downwards).
(B) = horizontal installation

For all mounting positions the following minimum distances must be adhered to:

200 mm to adjacent components, walls etc. and 300 mm to components, ceilings etc. above. If the device is installed vertically (A), the minimum distance to components, floors etc. below is 200 mm in order to allow unobstructed flow of air to the brake resistor.

Electrical installation

DANGER 		Caution – Danger of death!
Disconnect the AX5000 from the mains before installing the brake resistor!
Even when the AX5000 is disconnected from the mains voltage, dangerous voltage continues to be present at the "X02" terminals of the DC link for at least 5 minutes. Never touch the terminals within this period.

Remove the two screws (1) and remove the cover (2) in direction of the arrow. Connect an adequately dimensioned cable (see section Cables) to the terminals (3) of the resistor and the earthing stud (5) and take it out of the terminal box through the strain-relief assembly (9). Ensure adequate strain relief with the two screws (8). Connect the other side of the cable to the DC link contact connector X2 (10) of the AX5000. The connector is supplied with the AX5000. Connect the earthing cable to the earthing conductor of the control cabinet.

Connect an adequately dimensioned cable to the potential-free N/C contact (4) of the temperature switch and take it out of the terminal box through the strain-relief assembly (7) (see section Temperature switch). Ensure adequate strain relief with the nut (6).

Install the cover (2) in reverse order.

Cables

We recommend Beckhoff motor cables for connecting the brake resistors.

WARNING 		Caution - Fire hazard!
The brake resistors become very hot. Only use cables with adequate heat resistance.

Attention 		EMC-Safety
Use only shielded cables.
Type | Brake resistor |  | Temperature switch
 | [mm2] | [AWG] | [mm2] | [AWG]
AX2090-BW50-0300 | 1,5 | 16 | 0,75 | 18
AX2090-BW50-0600 | 1,5 | 16 | 0,75 | 18
AX2090-BW50-1600 | 1,5 | 16 | 0,75 | 18
AX2090-BW51-1000 | 2,5 | 12 | 0,75 | 18
AX2090-BW51-3000 | 2,5 | 12 | 0,75 | 18
AX2090-BW51-6000 | 2,5 | 12 | 0,75 | 18

We recommend wire end sleeves.

Temperature switch

Attention 		Destruction of the brake resistor
The temperature switch is only used for temperature monitoring. The brake resistor is not switched off.

The temperature switch has a potential-free N/C contact, which enables immediate response to any overload of the brake resistor through analysis in the AX5000 or the PLC. Connect the cable directly to a free input of plug "X06". Then parameterise it such that the AX5000 stops the motor(s) with an emergency ramp or the PLC reads and processes this input.

Type | Switching temperature | Switching current 24 VDC er 230 VAC
 | [°C] | [A]
AX2090-BW50-0300 | 180 | 2
AX2090-BW50-0600 | 180 | 2
AX2090-BW50-1600 | 180 | 2
AX2090-BW51-1000 | 180 | 2
AX2090-BW51-3000 | 85 | 2
AX2090-BW51-6000 | 85 | 2

Short-term capacity

Brake resistors are usually not operated continuously, but only exposed to short-time duty. In the following section the permitted short-term capacity is calculated based on the continuous power, overload factor and duty cycle.

Duty cycle

The duty cycle is a relative value that depends on the switch-on time (ton)and the cycle time. Cycle times up to 120 sec. are used directly in the calculation. Should the cycle time exceed 120 sec., the maximum relevant cycle time of 120 sec. is used in the calculation.

Example 1

ton = 60 s

Cycle time = 280 s

Duty cycle = 50 %

Example 2

ton = 40 s

Cycle time = 180 s

Duty cycle = 40 %

Overload factor

Calculation formula:

Short-term capacity = continuous power x overload factor

Overtemperature and continuous power at 100% duty cycle

If your application requires a higher continuous power than the specified nominal capacity, you can accept this state if a higher brake resistor temperature is permitted. The following diagram shows the overtemperature v. the continuous power.

Normal operating range, max. 130%:
This operating range is recommended for maximum service life and error-free operation.

Permitted operating range, max. 160%:
This operating range is still permitted, although it results in shorter service life with higher failure probability.

Inadmissible operating range, more than 160%:
In this operating range there is a risk of destruction of the brake resistor through overheating. Due to the high temperatures the adjacent components are also at risk.

Attention 		Destruction of the brake resistor and adjacent components
Always ensure adequate ventilation of the brake resistor, since the temperatures of the housing surface may exceed 200 °C.


AX5000 - Energy recovery

BECKHOFF AX5000: Accessories

能量恢复

（研发中）

电源变换器，用于将制动能量反馈回供电电网


AX5000 - AX5701 / AX5702

BECKHOFF AX5000: Accessories

Optional encoder card - AX5701 / AX5702

Appropriate use

The optional encoder cards are exclusively intended for application in the optional rear slot of a servo drive from the AX5000 series. The cards are installed together with the servo drive as components in electrical systems and machinery and may only be used in this way.

Scope of supply

The scope of supply includes the following components:

  • Optional encoder card AX570x
  • Technical documentation
  • Packaging

If one of the components is damaged please notify the logistics company and Beckhoff Automation GmbH immediately.

Safety rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations and guidelines.

DANGER 		Caution – Danger of death!
Even when the AX5000 is disconnected from the mains voltage, dangerous voltage continues to be present at the "X02" terminals of the DC link for at least 5 minutes. Never touch the terminals within this period.

WARNING 		Caution – Risk of injury!
Electronic equipment is not fail-safe. The machine manufacturer is responsible for ensuring that the connected motors and the machine are brought into a safe state in the event of a fault in the drive system.

Attention 		Caution – Destruction of the optional encoder card through electrostatic charging!
The optional encoder card is an ESD-sensitive component. Follow the usual ESD safety procedures when handling the card (anti-static wrist straps, earthing of the relevant components, etc.).
UL-Listing!
It is essential to observe chapter "Product overview-->Guidelines and Standards-->UL-Listing" if you wish to operate an AX5000 in an economic area that requires a UL-Listing.

Product description

The optional encoder card enables connection of an additional feedback systems per channel. The system parameters match the standard parameters that are analysed via inputs X11 and X21. Through simple configuration via jumpers up to six further digital inputs (In “A” to In “F”) can be analysed, which are provided through special feedback systems via parameter channels. The X41 and X42 sockets are compatible with the plugs of the X11 and X21 front sockets of the AX5000, which means that the tried and tested cables from the ZK4510 series can be used. To analyse the additional digital inputs you simply have to insert an adapter or establish a suitable wiring.

Firmware-version

Operation of the optional encoder card requires firmware version 1.7 b01xx or higher on the AX5000.

Type key

Note 		Operation of the optional encoder card
The AX5701 can only be used in single-channel servo drives, the AX5702 can only be used in two-channel servo drives.

AX5701 – optional encoder card for single-channel servo drives

AX5702 – optional encoder card for two-channel servo drives

Description of the digital inputs

Note 		Functional reliability
Ensure that the ground potentials of the digital inputs “A” to “D” are connected with the ground potential of the AX5000.

Inputs “A” to “D” are “single-wire” inputs (single-ended). They have a certain potential to ground, which is analysed.
Inputs “E” and “F” are “two-wire inputs” (differential). They require (+) and (-) and analyse the voltage difference between the conductors.

Overview of sockets X41 (channel A) and X42 (channel B)

Pin | EnDAT / BiSS | Hiperface | Sin / Cos 1Vpp | TTL | In "A" | In "B" | In "C" | In "D" | In "E" | In "F"
1 | SIN + | SIN + | SIN + | n.c. | X |  |  |  | X (+) |
2 | GND_5 V | GND_9 V | GND_5 V | GND_5 V |  |  |  |  |  |
3 | COS + | COS + | COS + | n.c. |  |  | X |  |  | X (+)
4 | Us_5 V | n.c. | Us_5 V | Us_5 V |  |  |  |  |  |
5 | DX + (Data) | DX + (Data) | n.c. | B + |  |  | Y |  |  |
6 | n.c. | Us_9 V | n.c. | n.c. |  |  |  |  |  |
7 | n.c. | n.c. | REF Z | REF Z |  |  |  |  |  |
8 | CLK + (Clock) | n.c. | n.c. | A + | Y |  |  |  |  |
9 | REF SIN | REF SIN | REF SIN | n.c. |  | X |  |  | X (-) |
10 | GND_Sense | n.c. | n.c. | GND_Sense |  |  |  |  |  |
11 | REF COS | REF COS | REF COS | n.c. |  |  |  | X |  | X (-)
12 | Us_5 V Sense | n.c. | Us_5 V Sense | Us_5 V Sense |  |  |  |  |  |
13 | DX - (Data) | DX - (Data) | n.c. | n.c. |  |  |  | Y |  |
14 | n.c. | n.c. | Z + | Z + |  |  |  |  |  |
15 | CLK - (Clock) | n.c. | n.c. | n.c. |  | Y |  |  |  |

The digital inputs “A” to “D” can be connected to X or Y.
The digital inputs “E” and “F” must be connected to X (+) and X (-).

Configuration of jumpers J-“A” for channel “A” and J-“B” for channel “B”

Jumpers J-“A” and J-“B” (1) are located at the centre of the printed circuit board near the front panel of the card. For each channel there are 2 row of jumpers, each with 20 pins. The default setting without analysis of the additional inputs is shown in the following figure.

The opposite figure shows the basic jumper configuration, which is the same for channel A and channel B. The pins of input sockets X41 and X42 are wired firmly to the corresponding pins of the jumpers rows. The non-configurable pins are not shown. To use the additional inputs proceed as follows:

  • Reposition the relevant jumpers und set IDN P-0-0180-->Feedback options-->Digital Inputs “Input A” to “Input D” to “used” or set IDN P-0-0180-->Feedback options-->Digital Inputs “Input E” or “Input F” to “used” without repositioning the jumpers.

  • Connect the encoder cable as required for the relevant inputs or use an adapter.

The following table shows a selection of combination options.

Feedback system | Input "A" | Input "B" | Input "C" | Input "D" | Input "E" | Input "F"
EnDat | not available
BiSS | not available
Hiperface | X | X |  |  |  |
Sin / Cos 1 Vpp | X | X | X | X |  |
TTL | X1 | X1 | X2 | X2 | X1 | X2

1) Either inputs “A” and “B” or input “E” can be used
2) Either inputs “C” and “D” or input “F” can be used.

Technical Data

Digital inputs “A” to “D” (single-ended) | Open collector max. 1 mA
Digital inputs “E” to “F” (differential) | 0 - 5 V Inp. resistance: 120 W

Installation of the optional encoder card

DANGER 		Caution – Danger of death!
Even when the AX5000 is disconnected from the mains voltage, dangerous voltage continues to be present at the "X02" terminals of the DC link for at least 5 minutes. Never touch the terminals within this period.

Attention 		Caution – Destruction of the optional encoder card through electrostatic charging!
The optional encoder card is an ESD-sensitive component. Follow the usual ESD safety procedures when handling the card (anti-static wrist straps, earthing of the relevant components, etc.).
  1. Fully release the bolt (1).
  2. Remove the panel (2).
  3. Carefully insert the optional card (3) into the opening in the direction of the arrow. The slot has guides for the card on the short sides. Ensure that the card is inserted into these guides.
  4. Tighten the bolt (4).

Example: Renishaw RGH 22Z30D00 (TTL encoder with 2 parameter channels)

Configuration via TCDrivemanager (IDN-P-0-0180)

Encoders and inputs

Scaling

Overview of socket X41 (channel A) and jumper configuration

Socket X41

Jumper configuration

Pin | Renishaw | In "C" | In "E"
1 | Alarm + |  | X +
2 | GND_5 V |  |
3 | Limit switch | X |
4 | Us_5 V |  |
5 | B + |  |
6 | n.c. |  |
7 | REF Z |  |
8 | A + |  |
9 | Alarm - |  | X -
10 | GND_Sense |  |
11 | n.c. |  |
12 | Us_5 V Sense |  |
13 | B - |  |
14 | Z + |  |
15 | A - |  |


AX5000 - Order key for motor and feedback cables

BECKHOFF AX5000: Accessories

电机与反馈电缆的指令键

Z K 4 t u v - w w x y - z z z z
t | 伺服驱动器系列 |  |  |
 |  | 5 | = | AX5000
u | 功能 |  |  |
 |  | 0 | = | 电机电缆
 |  | 1 | = | EnDat、Hiperface、BiSS 编码器电缆
 |  | 2 | = | TTL、带有零脉冲的 Sin/Cos 编码器电缆
 |  | 3 | = | 旋转变压器电缆
 |  | 4 | = | 温度电缆 AL2000
 |  | 5 | = | AL2000 用霍尔传感器电缆
v | 功能 |  |  |
 |  | 0 | = | 电机 — 驱动器
 |  | 1 | = | 扩展电缆
 |  | 2 | = | 电机 — 电抗器
 |  | 3 | = | 电抗器 — 驱动器
 |  | 4 | = | 电机 — 另一侧 钝形切口
 |  | 5 | = | 驱动器 — 另一侧 钝形切口
 |  | 9 | = | 原材料
ww | 电机系列 |  |  |
 |  | 0 0 | = | AL2000/AM2000/AM3000/AM3500
 |  | 0 1 to 1 9 | = | Beckhoff
 |  | 2 0 to 2 9 | = | Alpha EnDat / Alpha 旋转变压器
 |  | 3 0 to 3 9 | = | Lenze
 |  | 4 0 to 4 9 | = | SEW
 |  | 5 0 to 5 9 | = | Siemens
 |  | 6 0 to 9 9 | = | 其它
x | 品质 |  |  |
 |  | 0 | = | 固定安装/无运动
 |  | 1 | = | 动态/拖链
 |  | 2 | = | 高动态/高速链
y | 横截面积 [mm2] |  |  |
 |  | 0 | = | 反馈
 |  | 1 to 8 | = | 0.75=1 / 1.0=2 / 1.5=3 / 2.5=4 / 4.0=5 / 6.0=6 / 10=7 / 16=8
 |  | 9 | = | 特殊
z z z z | 长度，单位：dm |  |  |
 |  | 0001 to 9999 | = | 0.1 to 999.9 m


AX5000 Motor cables

BECKHOFF AX5000: Accessories

电机电缆

用于AL2000 / AM2000 / AM3000 / AM3500的电机电缆

1.5 mm² and 2,5 mm²

货号 | 导线数量与横截面积 | 安装方式
ZK4500-0003-xxxx | 4x1.5 + 2x(2x0.75) mm² | 固定安装
ZK4500-0004-xxxx | 4x2.5 + 2x(2x0.75) mm² | 固定安装
ZK4500-0023-xxxx | 4x1.5 + 2x(2x0.75) mm² | 高动态安装
ZK4500-0024-xxxx | 4x2.5 + 2x(2x0.75) mm² | 高动态安装
插拔式连接器 | 触点 | 功能 | 芯线标识 | 触点 | 插拔式连接器
视图 X | 1 | U | 黑色，带白色标签“1” | U | see "Y"
 | 2 / PE | PE | 绿色/黄色 | PE
 | 3 | W | 黑色，带白色标签“3” | W
 | 4 | V | 黑色，带白色标签“2” | V
 | A | 制动+ | 5 | 1
 | B | 制动- | 6 | 2
 |  | 屏蔽 | 屏蔽 | 3
 | C | Temp. + | 7 | 4
 | D | Temp. - | 8 | 5

4 mm²

货号 | 导线数量与横截面积 | 安装方式
ZK4500-0015-xxxx | 4x2 + 2x1 +2x1,5 mm² | 高动态安装
ZK4502-0015-xxxx | 4x2 + 2x1 +2x1,5 mm² | 高动态安装
插拔式连接器 | 触点 | 功能 | 芯线标识 | 触点 | 插拔式连接器
视图 X | U | U | 黑色，带白色标签“1” | U | see "Y"
 | PE | PE | 绿色/黄色 | PE
 | W | W | 黑色，带白色标签“3” | W
 | V | V | 黑色，带白色标签“2” | V
 | + | 制动+ | 5 | 1
 | - | 制动- | 6 | 2
 |  | 屏蔽 | 屏蔽 | 3
 | 1 | Temp. + | 7 | 4
 | 2 | Temp. - | 8 | 5


AX5000 - Extension for motor cables

BECKHOFF AX5000: Accessories

电机电缆扩展

使用扩展电缆后，可在控制柜、拖链与高动态型拖链之间使用一个固定接口。拖链属于耐磨部件，这表示，如有需要可以通过磨损电缆予以替代。

AL2000 / AM2000 / AM3000 / AM3500的电机电缆拓展

货号 | 导线数量与横截面积 | 安装方式
ZK4501-0003-xxxx | 4x1.5 + 2x(2x0.75) mm² | 固定安装
ZK4501-0004-xxxx | 4x2.5 + 2x(2x0.75) mm² | 固定安装
ZK4501-0023-xxxx | 4x1.5 + 2x(2x0.75) mm² | 高动态安装
ZK4501-0024-xxxx | 4x2.5 + 2x(2x0.75) mm² | 高动态安装

插拔式连接器 | 触点 | 功能 | 芯线标识 | 触点 | 插拔式连接器
View X | 1 | U | 黑色，带白色标签 | 1 | 视图 Y
 | 2 / PE | PE | 绿色/黄色 | 2 / PE
 | 3 | W | 黑色，带白色标签 | 3
 | 4 | V | 黑色，带白色标签 | 4
 | A | 制动 + |  | A
 | B | 制动 - |  | B
 |  | 屏蔽 | 屏蔽 |
 | C | Temp. + |  | C
 | D | Temp. - |  | D


AX5000 - Feedback cables for Beckhoff motors

BECKHOFF AX5000: Accessories

用于 Beckhoff 电机的反馈电缆

CAUTION 		EMC — 安全!
所有的电缆都不得与标有“n.c.”的导线相连接。

用于AL2000 / AM3000 / AM3500的编码器电缆，带有EnDat、BiSS或Hiperface编码器接口与零脉冲的正弦/余弦编码器接口

货号 | 导线数量与横截面积 | 安装方式
ZK4510-0000-xxxx | 7x(2x0.14) + 2x0.5 mm² | 固定安装
ZK4510-0020-xxxx | 7x(2x0.14) + 2x0.5 mm² | 高动态安装

用于连接电机的 17 针圆形插头 | 触点 | 功能 | 芯线标识 |  | 触点 | 用 于 连 接 AX5000 的 15 针 D-sub 插头
 |  |  |  | 修订版 . 02 2008.06.05
View X (female) | 1 | REFSIN | 白 | 红/蓝 | 9 | View Y (male)
 | 2 | GND_5 V / 9 V | 红/蓝 | 白0,5 mm2 | 2
 | 3 | REFCOS | 绿 | 绿 | 11
 | 4 | Us_5 V | 灰/粉 | 棕 0,5 mm2 | 4
 | 5 | DX+ Data | 灰 | 灰 | 5
 | 6 | Us_9 V | 棕/绿 | 棕/绿 | 6
 | 7 | n.c. |  |  | n.c.
 | 8 | CLK+ Clock | 蓝 | 蓝<0 | 8
 | 9 | SIN | 棕 | 灰/粉 | 1
 | 10 | GND_Sense | 紫 | 紫 | 10
 | 11 | COS | 黄 | 黄 | 3
 | 12 | Us_5 V_Sense | 黑 | 黑 | 12
 | 13 | DX- Data | 粉 | 粉 | 13
 | 14 | n.c. |  |  | n.c.
 | 15 | CLK- Clock | 红 | 红 | 15
 | 16 | n.c. |  |  | n.c.
 | 17 | n.c. |  |  | n.c.

编码器电缆，用于带零脉冲正弦/余弦编码器的 AL2000

货号 | 导线数量与横截面积 | 安装方式
ZK4520-0020-xxxx | 7x(2x0.14) + 2x0.5 mm² | 高动态安装

 |  | 功能 |  |  |  |
用于连接电机的 17 针圆形插头 | 触点 | SIN / COS | TTL | 芯线标识 | 触点 | 用 于 连 接 AX5000 的15针 D-sub 插头
View X (female) | 1 | REFSIN | --- | 红/蓝 | 9 | 视图Y （公插）
 | 2 | GND_5 V / 9 V | GND_5 V / 9 V | 白0,5 mm2 | 2
 | 3 | REFCOS | --- | 绿 | 11
 | 4 | Us_5 V | Us_5 V | 棕0,5 mm2 | 4
 | 5 | --- | B + | 灰 | 5
 | 6 | Us_9 V | Us_9 V | 棕 / 绿 | 6
 | 7 | REF Z | REF Z | 白/黄 | 7
 | 8 | --- | A + | 蓝 | 8
 | 9 | SIN + | --- | 灰/粉 | 1
 | 10 | GND_Sense | GND_Sense | 紫 | 10
 | 11 | COS + | --- | 黄 | 3
 | 12 | Us_5 V_Sense | Us_5 V_Sense | 黑 | 12
 | 13 | --- | B - | 粉 | 13
 | 14 | Z + | Z + | 棕 / 黄 | 14
 | 15 | --- | A - | 红 | 15
 | 16 | n.c. | n.c. |  | ---
 | 17 | n.c. | n.c. |  | ---

用于 AM2000 / AM3000 / AM3500 的旋转变压器电缆

货号 | 导线数量与横截面积 | 安装方式
ZK4530-0010-xxxx | 4x2x0,25 mm² | 动态安装

用于连接电机的 12 针圆形插头 | 触点 | 功能 | 芯线标识 | 触点 | 用于连接 AX5000 的 15 针 D-sub 插头
View X (female) | 1 | n.c. |  | n.c. | View Y (female)
 | 2 | 温度（仅 PTC、Klixon 或 Bimetal！）开关点：1178 Ω | 蓝 | 1
 | 3 | COS - (S3) | 黄 | 3
 | 4 | SIN - (S4) | 棕 | 4
 | 5 | REF - (R2) | 粉 | 5
 | 6 | GND_Temp. | 红 | 9
 | 7 | COS + (S1) | 绿 | 10
 | 8 | SIN + (S2) | 白 | 11
 | 9 | REF + (R1) | 灰 | 12
 | 10 | n.c. |  | n.c.
 | 11 | n.c. |  | n.c.
 | 12 | n.c. |  | n.c.


AX5000 - Extension for feedback cables for Beckhoff motors

BECKHOFF AX5000: Accessories

用于 Beckhoff电机的反馈电缆扩展

使用扩展电缆后，可在控制柜、拖链与高动态型拖链之间使用一个固定接口。拖链属于耐磨零件，这就表示，如有需要可以通过磨损电缆代替。

AL2000/AM2000/AM3000编码器电缆扩展

商品代码 | 导线数量与横截面积 | 安装
ZK4511-0000-xxxx | 7x(2x0.14) + 2x0.5 mm² | 固定安装
ZK4511-0020-xxxx | 7x(2x0.14) + 2x0.5 mm² | 高灵活安装

插拔式连接器 | 触点 | 功能 | 芯线标识 | 触点 | 插拔式连接器
视图X （母插） | 1 | 1 : 1 连接 在扩展电缆之中 |  | 1 | 视图 Y （公插）
 | 2 |  |  | 2
 | 3 |  |  | 3
 | 4 |  |  | 4
 | 5 |  |  | 5
 | 6 |  |  | 6
 | 7 |  |  | 7
 | 8 |  |  | 8
 | 9 |  |  | 9
 | 10 |  |  | 10
 | 11 |  |  | 11
 | 12 |  |  | 12
 | 13 |  |  | 13
 | 14 |  |  | 14
 | 15 |  |  | 15
 | 16 |  |  | 16
 | 17 | n.c. |  | 17

用于 AL2000/AM2000/AM3000 的旋转变压器与霍尔传感器电缆的扩展

商品代码 | 导线数量与横截面积 | 安装
ZK4531-0000-xxxx |  | 固定安装
ZK4531-0020-xxxx |  | 高动态安装

电机侧连接器 | 触点 | 功能 | 芯线标识 | 触点 | 接头导管侧
视图X （母插） | 1 | 1 : 1 连接 在扩展电缆之中 |  | 1 | 视图 Y （公插）
 | 2 |  |  | 2
 | 3 |  |  | 3
 | 4 |  |  | 4
 | 5 |  |  | 5
 | 6 |  |  | 6
 | 7 |  |  | 7
 | 8 |  |  | 8
 | 9 |  |  | 9
 | 10 |  |  | 10
 | 11 |  |  | 11
 | 12 |  |  | 12


AX5000 - The Beckhoff automation system

BECKHOFF AX5000: System description

Beckhoff自动化系统

More and more customers are looking for automation systems from one source in order to

  • have a single contact,
  • simplify the interfaces between the components,
  • ensure fast and trouble-free commissioning, and
  • have access to worldwide service and support from one source.

Beckhoff offers this solution:

- Industrial PC as real-time automation platform
- Real-time software packages
 | TwinCAT NC PTP for point-to-point movements
 | TwinCAT NC I for interpolated movements of up to 3 axes
 | TwinCAT CNC for interpolated movements of up to 32 axes
- High-end servo drive
 | AX2000: single-axis drive, up to 70 A rated current AX2500: multi-axis system, up to 8 axes AX5000: EtherCAT Drive
- Rotational and linear servo motors
 | AM2000: Servomotors AM3000: Servomotors, pole-wound AM3500: Servomotors with high moment of inertia AL2000: Linear motors AL3000: Ironless linear motors

The AX5000 servo drive is a component of the Beckhoff automation system. It is not designed for stand-alone operation. The AX5000 is the first drive developed specifically for EtherCAT. This enables the outstanding features of EtherCAT to be fully utilised:

  • Outstanding performance
  • Low-cost
  • Simple diagnosis
  • Safety over EtherCAT


System structure

In analogy to the Beckhoff Bus Terminals the EtherCAT terminal system is a modular I/O system consisting of electronic terminal blocks. An I/O station consists of an EtherCAT coupler and almost any number of terminals. Since up to 65535 devices can be connected, the size of the network is almost unlimited.

EtherCAT is designed for operation without switch. In this case the EK1100 coupler is used. For applications requiring a switch Beckhoff will shortly provide a solution in the form of the EK1000 that can process the EtherCAT UDP protocol in passing.

The electronic terminal blocks are attached to the EtherCAT coupler. The contacts are made as the terminal clicks into place, without any other manipulation. This means that each electronic terminal block can be individually exchanged. It can be placed on a standard mounting rail.

Suitable EtherCAT terminals are available for common digital and analog signal types encountered in the world of automation. Fieldbus devices, e.g. for PROFIBUS, CANopen or DeviceNet, are integrated via local fieldbus master/slave terminals. Removal of the fieldbus master saves PCI slots in the PC. Any Ethernet devices can be connected decentralised via switch terminals.

The fine granularity of the EtherCAT terminals enables bit-precise composition of the required I/O channels. The digital EtherCAT terminals are designed as 2-, 4-, or 8-channel terminals. The standard analog signals of ± 10 V, 0 ... 10 V, 0 ... 20 mA and 4 ... 20 mA are all available as 1-, 2-, 4-, and 8-channel variants within a standard housing. The EtherCAT Terminal system offers different connection options for optimum adaptation to the respective application. The ELxxxx EtherCAT terminals include electronics and connection level in a single enclosure. The ESxxxx type EtherCAT terminals feature a pluggable connection level. The ES series Bus Terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.

Free choice of topology – maximum wiring flexibility: with or without switch, line or tree topologies, can be freely selected and combined. Address assignment is automatic, no IP address setting is required.


System Properties

Protocol

The EtherCAT protocol is optimized for process data and is transported directly within the Ethernet frame thanks to a special Ether-type. It may consist of several sub-telegrams, each serving a particular memory area of the logical process images that can be up to 4 gigabytes in size. The data sequence is independent of the physical order of the Ethernet terminals in the network; addressing can be in any order. Broadcast, Multicast and communication between slaves are possible. Transfer directly in the Ethernet frame is used in cases where EtherCAT components are operated in the same subnet as the control computer.

However, EtherCAT applications are not limited to a subnet: EtherCAT UDP packs the EtherCAT protocol into UDP/IP datagrams. This enables any control with Ethernet protocol stack to address EtherCAT systems. Even communication across routers into other subnets is possible. In this variant, system performance obviously depends on the real-time characteristics of the control and its Ethernet protocol implementation. The response times of the EtherCAT network itself are hardly restricted at all: the UDP datagram only has to be unpacked in the first station.

Protocol structure: The process image allocation is freely configurable. Data are copied directly in the I/O terminal to the desired location within the process image: no additional mapping is required. The available logical address space is with very large (4 GB).

Topology

Line, tree or star: EtherCAT supports almost any topology. The bus or line structure known from the fieldbusses thus also becomes available for Ethernet. Particularly useful for system wiring is the combination of line and branches or stubs. The required interfaces exist on the couplers; no additional switches are required. Naturally, the classic switch-based Ethernet star topology can also be used.

Maximum wiring flexibility:
with or without switch, line or tree topologies, can be freely selected and combined. The complete bandwidth of the Ethernet network - such as different optical fibers and copper cables - can be used in combination with switches or media converters.

Distributed Clocks

Accurate synchronization is particularly important in cases where spatially distributed processes require simultaneous actions. This may be the case, for example, in applications where several servo axes carry out coordinated movements simultaneously.

The most powerful approach for synchronization is the accurate alignment of distributed clocks, as described in the new IEEE 1588 standard. In contrast to fully synchronous communication, where synchronization quality suffers immediately in the event of a communication fault, distributed aligned clocks have a high degree of tolerance vis-à-vis possible fault-related delays within the communication system.

With EtherCAT, the data exchange is fully based on a pure hardware machine. Since the communication utilizes a logical (and thanks to full-duplex Fast Ethernet also physical) ring structure, the mother clock can determine the run-time offset to the individual daughter clocks simply and accurately - and vice versa. The distributed clocks are adjusted based on this value, which means that a very precise network-wide timebase with a jitter of significantly less then 1 microsecond is available.

However, high-resolution distributed clocks are not only used for synchronization, but can also provide accurate information about the local timing of the data acquisition. For example, controls frequently calculate velocities from sequentially measured positions. Particularly with very short sampling times, even a small temporal jitter in the displacement measurement leads to large step changes in velocity. With EtherCAT new, extended data types are introduced as a logical extension (time stamp and oversampling data type). The local time is linked to the measured value with a resolution of up to 10 ns, which is made possible by the large bandwidth offered by Ethernet. The accuracy of a velocity calculation then no longer depends on the jitter of the communication system. It is orders of magnitude better than that of measuring techniques based on jitter-free communication.

Performance

EtherCAT reaches new dimensions in network performance. Protocol processing is purely hardware-based through an FMMU chip in the terminal and DMA access to the network card of the master. It is thus independent of protocol stack run-times, CPU performance and software implementation. The update time for 1000 I/Os is only 30 µs - including terminal cycle time. Up to 1486 bytes of process data can be exchanged with a single Ethernet frame - this is equivalent to almost 12000 digital inputs and outputs. The transfer of this data quantity only takes 300 µs.

The communication with 100 servo axes only takes 100 µs. During this time, all axes are provided with set values and control data and report their actual position and status. Distributed clocks enable the axes to be synchronised with a deviation of significantly less than 1 microsecond.

The extremely high performance of the EtherCAT technology enables control concepts that could not be realized with classic fieldbus systems. For example, the Ethernet system can now not only deal with velocity control, but also with the current control of distributed drives. The tremendous bandwidth enables status information to be transferred with each data item. With EtherCAT, a communication technology is available that matches the superior computing capacity of modern Industrial PCs. The bus system is no longer the bottleneck of the control concept. Distributed I/Os are recorded faster than is possible with most local I/O interfaces. The EtherCAT technology principle is scalable and not bound to the baud rate of 100 MBaud – extension to GBit Ethernet is possible.

Diagnostics

Experience with fieldbus systems shows that availability and commissioning times crucially depend on the diagnostic capability. Only faults that are detected quickly and accurately and which can be precisely located can be corrected quickly. Therefore, special attention was paid to exemplary diagnostic features during the development of EtherCAT.

During commissioning, the actual configuration of the I/O terminals should be checked for consistency with the specified configuration. The topology should also match the saved configuration. Due to the built-in topology recognition down to the individual terminals, this verification can not only take place during system start-up, automatic reading in of the network is also possible (configuration upload).

Bit faults during the transfer are reliably detected through evaluation of the CRC checksum: The 32 bit CRC polynomial has a minimum hamming distance of 4. Apart from breaking point detection and localization, the protocol, physical transfer behavior and topology of the EtherCAT system enable individual quality monitoring of each individual transmission segment. The automatic evaluation of the associated error counters enables precise localization of critical network sections. Gradual or changing sources of error such as EMC influences, defective push-in connectors or cable damage are detected and located, even if they do not yet overstrain the self-healing capacity of the network.

Integration of standard Bus Terminals from Beckhoff

In addition to the new Bus Terminals with E-Bus connection (ELxxxx), all Bus Terminals from the familiar standard range with K-Bus connection (KLxxxx) can be connected via the BK1120 or BK1250 Bus Coupler. This ensures compatibility and continuity with the existing Beckhoff Bus Terminal systems. Existing investments are protected.


EtherCAT Wiring

The cable length between two EtherCAT devices must not exceed 100 m.

Cables and connectors

For connecting EtherCAT devices only Ethernet cables that meet at least the requirements of category 5 (CAT5) according to EN 50173 or ISO/IEC 11801 should be used. EtherCAT uses 4 wires for signal transfer.

EtherCAT uses RJ45 connectors. The pin assignment is compatible with the Ethernet standard (ISO/IEC 8802-3).

Pin | Core coloring | Signal | Description
1 | yellow | TD + | Transmission Data +
2 | orange | TD - | Transmission Data -
3 | white | RD + | Receiver Data +
6 | blue | RD - | Receiver Data -

Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.

The following Beckhoff cables are suitable for cabling of EtherCAT systems:

  • ZB9010 (industrial Ethernet/EtherCAT cable, fixed installation, CAT5e, 4-wires)
  • ZB9020 (industrial Ethernet/EtherCAT cable, drag chain suitable, CAT5e, 4-wires)
  • ZS1090-0003 (RJ 45 connector, 4-pin, IP 20, for field-assembly)
  • ZS1090-0005 (RJ 45 connector, 8-pin, (GigaBit suitable), IP 20, for field-assembly)
  • ZK1090-9191-0001 (0.17m EtherCAT patch cable)
  • ZK1090-9191-0005 (0.5m EtherCAT patch cable)
  • ZK1090-9191-0010 (1.0m EtherCAT patch cable)
  • ZK1090-9191-0020 (2.0m EtherCAT patch cable)
  • ZK1090-9191-0030 (3.0m EtherCAT patch cable)
  • ZK1090-9191-0050 (5.0m EtherCAT patch cable)

E-Bus supply

Attention 		Attention! Malfunction possible!
The same ground potential must be used for the E-Bus supply of all EtherCAT terminals in a terminal block!


EtherCAT State Machine

The state of the EtherCAT slave is controlled via the EtherCAT State Machine (ESM). A distinction is made between the following states (see. Fig. 1):

  • Init
  • Pre-Operational
  • Safe-Operational and
  • Operational
  • Boot

Init

After switch-on the EtherCAT slave in the Init state. No mailbox or process data communication is possible. The EtherCAT master initializes sync manager channels 0 and 1 for mailbox communication.

Pre-Operational (Pre-Op)

During the transition between Init and Pre-Op the EtherCAT slave checks whether the mailbox was initialized correctly.

In Pre-Op state mailbox communication is possible, but not process data communication. The EtherCAT master initializes the sync manager channels for process data (from sync manager channel 2), the FMMU channels and, if the slave supports configurable mapping, PDO mapping or the sync manager PDO assignment. In this state the settings for the process data transfer and perhaps terminal-specific parameters that may differ from the default settings are also transferred.

Safe-Operational (Safe-Op)

During transition between Pre-Op and Safe-Op the EtherCAT slave checks whether the sync manager channels for process data communication and, if required, the distributed clocks settings are correct. Before it acknowledges the change of state, the EtherCAT slave copies current input data into the associated DP-RAM areas of the EtherCAT slave controller (ECSC).

In Safe-Op state mailbox and process data communication is possible, although the slave keeps its outputs in a safe state, while the input data are updated cyclically.

Operational (Op)

Before the EtherCAT master switches the EtherCAT slave from Safe-Op to Op it must transfer valid output data.

In the Op state the slave copies the output data of the masters to its outputs. Process data and mailbox communication is possible.

Boot

In the Boot state the slave firmware can be updated. The Boot state can only be reached via the Init state.

In the Boot state mailbox communication via the file access over EtherCAT (FoE) protocol is possible, but no other mailbox communication and no process data communication.


AX5000 - EtherCAT

BECKHOFF AX5000: EtherCAT

EtherCAT as drive bus

EtherCAT technology overcomes these inherent limitations of other Ethernet solutions: the Ethernet packet is no longer received, then interpreted and copied as process data at every connection. The EtherCAT devices read the data addressed to them while the telegram passes through the device. Similarly, input data are inserted while the telegram passes through. The telegrams are only delayed by a few nanoseconds. Since an Ethernet frame reaches the data of many devices both in send and receive direction, the usable data rate increases to over 90%. The full-duplex features of 100BaseTx are fully utilised, so that effective data rates of > 100 Mbit/s (>90% of 2 x 100 Mbit/s) can be achieved.

The option of being able to use EtherCAT both for drive applications and for fast I/O signals was one of its main development aims right from the start. In existing systems, short cycle times and high synchronicity (as required for control loops that are closed via the bus) could only be realised with special drive buses. The SERCOS profile for servo drives according to IEC61491 was implemented in order to make the drive functionality compatible with existing standards and facilitate commissioning and optimised operation of the AX5000 through the user.

Special drive technology requirements

  • Cycle time

  • Synchronicity

  • Simultaneity

Typical values for the necessary cycle times lie between 1 and 4 milliseconds when position is specified cyclically, with position control in the drive. One microsecond is often quoted as an adequate value for synchronicity in drive technology.

While synchronicity describes the temporal jitter during processing of the functions in the device involved (drives and controllers), simultaneity defines the measure of temporal offset of these functions. Synchronicity is important for the individual devices, so that their own subordinate control loops can synchronise with the cyclic signal with the required precision. Simultaneity moreover enables distributed devices to work on a common task with absolutely identical timebase.

Distributed clocks - EtherCAT slave controller features

EtherCAT uses an approach based on distributed clocks for synchronisation control: All devices have an independent clock as a basis for running local cycles and events. The crucial factor is that all clocks run at the same speed and have the same base time. A special control integrated in the EtherCAT Slave Controller (ESC) ensures that all clocks are guided by a reference clock and are synchronised irrespective of temperature and production tolerances.

Multi-protocol capability

Further important criteria for a fieldbus system that is to support drive technology are the communications protocol and profile used, which are responsible for compatibility and efficient data exchange between the controller and the drive. Instead of re-inventing the wheel, EtherCAT uses proven technology for this purpose.

None of the available protocols on their own support all communication requirements of modern fieldbuses (process data, parameter data, parallel TCP/IP, firmware updates, routing to subordinate bus systems, etc.). EtherCAT therefore introduces multi-protocol capability, consolidating the different protocols in a standardised mailbox. This enables quick and full conversion of existing devices to EtherCAT. The protocols relevant for drive technology are CANopen over EtherCAT (CoE) and Servo Profile over EtherCAT (SoE). They enable the advantages of EtherCAT in terms of transfer characteristics to be combined with proven, profile-specific drive functions. The Ethernet over EtherCAT (EoE) and File Access over EtherCAT (FoE) protocols provide options for integrating a web server in the drive, for example, or for efficiently exchanging firmware or cam plate tables via the bus.

Servo Profile over EtherCAT

The Servo Profile over EtherCAT (SoE) protocol enables the proven SERCOS device profile to be used, which is tailored for demanding drive technology and standardised in IEC 61491. The SERCOS service channel, and therefore access to all parameters and functions residing in the drive, is mapped to the EtherCAT mailbox. Here too, the focus is on compatibility with the existing protocol (access to value, attribute, name, units etc. of the SERCOS identifiers) and expandability with regard to data length limitation. The process data (for SERCOS in the form of AT and MDT data) are transferred via the EtherCAT Slave Controller. The associated mapping is done SERCOS-compliant via the identifiers S- 0-0015, S-0-0016 and S-0-0024. For synchronisation - like for the CoE protocol - the synchronisation features of the EtherCAT Slave Controller are utilised as described above. This also includes - with associated quality improvements - those of standard SERCOS, so that implementation is correspondingly easy. The EtherCAT Slave State Machine explained above can also be mapped easily to the phases of the SERCOS protocol. "Pre-operational" corresponds to SERCOS, phase 2, and enables service channel communication without process data exchange. "Safe operational" is comparable with phase 3. Synchronisation is carried out as required, although for EtherCAT inputs that are already valid have to be transferred. "Operational" exactly corresponds to phase 4 for normal, cyclic data exchange. As the name suggests, the EtherCAT Slave State Machine refers to a slave and - unlike SERCOS - therefore enables individual drives to be parameterised and started up independent of other devices.

Conclusions

While EtherCAT is not a pure drive bus, it meets the associated requirements at least one order of magnitude better than familiar, specialised systems. Drive, I/O and communication buses therefore no longer have to be separated. Even demanding tasks, such as measurement technology applications, can be integrated and enable new functionalities to be utilised with classic control technology. Because proven communication profiles are used, migration of existing devices and applications can easily be accomplished. For drive technology in particular, a small number of profiles have been developed and tried and tested over years. It also means that the complete tool chain and existing experience with the parameterisation of associated drives is maintained.

IDNs used

This is a example for the structure and description of an IDN. A list and description of all relevant IDNs can be found in the separate IDN description (chm).

S-0-0001, Control unit cycle time (TNcyc)

Description:
The control unit cycle time defines the cyclic intervals during which the control unit makes new command values available. The control unit cycle time shall be transferred from the master to the slave during CP2 and becomes active in the slave during CP3. The control unit cycle time should be an integer multiple of the communication cycle time. tNcyc = tScyc * n [n =1,2,3,4...]

Parameter structure:

Attributes:
Unit: | us
Default value: | 500
Min value: | 62
Max value: | 20000
Data length: | 16
Format: | binary
Cyclic transfer: | No
Write protected: | SafeOp, Op
Decimal point: | 0
Device parameter: | Yes


AX5000 - Functionality of the optional AX5805 card

BECKHOFF AX5000: Integrated safety

Functionality of the optional AX5805 card

The optional AX5805 card offers additional safety functions such as safe velocity, safe direction of rotation, etc.

The card is still in development and the description is in preparation.


AX5000 - Integrated safety - Introduction

BECKHOFF AX5000: Integrated safety

Introduction

Machine movements create a range of hazards for machine operators and maintenance personnel. Anyone coming into contact with the machine therefore has to be protected from injuries at all times and during all operating phases, from commissioning to decommissioning. Integrated control and safety technology is a prerequisite for safe and economic automation. With the integration of safety and drive technology, Beckhoff consistently developed the TwinSAFE system philosophy further. TwinSAFE enables integrated automation, ranging from digital inputs and logic systems to drives or digital outputs. Simple handling, diagnostic and support functions help the user to implement the required application quickly and safely.

FailSafe over EtherCAT (FSoE)

The FSoE protocol developed according to IEC61508 can be transferred via EtherCAT or even across gateways. In addition to EtherCAT, fieldbus systems such as PROFIBUS, CANopen or Ethernet can be used as the transport layer. In conjunction with the TwinSAFE product family, safety technology can be implemented without sophisticated safety control.

Optional FSoE cards for AX5000

(in preparation)

In the AX5000 drive safety functions are realised via optional cards. The optional cards offer different functionalities and are inserted in slot 1 at the top of the AX5000.

Parameterisation is described in a separate manual for the optional FSoE card (in preparation).