BK11x0, BK1250 - EtherCAT Bus Coupler for Standard Bus Terminals

倍福 现场总线组件

本文档用于

BK1120, BK1150 - 标准端子模块 EtherCAT 总线耦合器

BK1250 - 连接 E-Bus 和 K-Bus 端子模块的紧凑型耦合器

版本：2.5
日期：2012-01-05

EtherCAT® 注册商标及专利技术，持有者为倍福自动化公司，德国。


BK11x0, BK1250 - Documentation issue status

倍福BK11x0, BK1250: 前言

文件资料发布状态

版本 | 注释
2.5 | 增加BK1150
2.4 | 增编耦合器表
2.3 | 更正诊断LED指示灯
2.2 | CoE 访问, AoE
2.1 | 添加对象的描述
2.0 | 增加BK1250；增加了技术数据以及对象描述
1.0 | 添加对象的描述
0.2 | 增加了技术数据
0.1 | BK1120的第一份文件

Firm- und 硬件版本

文件版本 | BK1120 |  | BK1150
 | 固件 | 硬件 | 固件 | 硬件
2.5 | 12 (C1) | 12 | 00 | 00
2.4 | 12 (C1) | 11 | - | -
2.3 | 11 (C0) | 11 | - | -
2.2 | 09 (B9) | 09 | - | -
2.1 | 08 (B8) | 05 | - | -
2.0 | 08 (B8) | 03 | - | -
1.0 | 06 | 02 | - | -
0.2 | 06 | 02 | - | -
0.1 | 06 | 02 | - | -
文件版本 | BK1250
 | 固件 | 硬件
2.5 | 04 | 05
2.4 | 04 | 05
2.3 | 04 | 05
2.2 | 03 | 03
2.1 | 02 | 01
2.0 | 01 | 01

固件和硬件版本 (交货状态) 能在印在耦合器侧面的编号中查看。

编号规则：

编号的结构: KK YY FF HH

KK - 生产的周次
(CW,日历上的周次)
YY -生产的年份
FF - 固件版本 HH - 硬件版本

例如 no.: 12 06 3A 02:

12 - 12周生产
06 - 2006年产
3A - 固件 版本 3A
02 - 硬件 版本 02


CoE-Interface

BECKHOFF EtherCAT: 基础通信

CoE-接口

CoE接口是EtherCAT设备的参数管理机构。在CAN-over-EtherCAT (CoE)的管理机构中，EtherCAT特定的固件参数可以在线获取或者离线参数化。

CoE接口的详细信息可以在倍福网站上的EtherCAT 系统文件 里获得。
.


BK1120, BK1250 - Technical data

倍福 BK11x0, BK1250: 产品概述

技术数据

技术数据 | BK1120, BK1150 | BK1250
EtherCAT系统中的任务 | 将K总线端子模块(KLxxxx) 与100BASE-TX EtherCAT网络耦合
K总线端子模块数量 | 64 (255 使用K总线扩展KL9020和KL9050)
最大现场总线字节数 | 1024字节输入和1024字节输出
数字外设信号 | 8192输入/输出
模拟外设信号 | 256输入/输出
协议 | EtherCAT (直接模式)
波特率 | 100 MBaud
配置 | 配置软件KS2000, TwinCAT 系统管理器或者EtherCAT (ADS)
总线连接 | 2 x RJ45 | 通过K总线触点
电源 | 24 VDC (-15%/+20%)
输入电流 | 70 mA + (K-Bus current)/4, 最大 500 mA | 70 mA + (K-Bus current)/4, 最大 200 mA
K总线电源电源电流(5 V) | 最大 1750 mA | 最大 500 mA
电源触点 | 最大 24 VDC, maximal 10 A
绝缘强度 | 500 Vrms (电源触点/电源电压/以太网)
重量 | 大约 170 g | 大约 55 g
操作温度 | 0°C ... + 55°C
储存温度 | -25°C ... + 85°C
相对湿度 | 95%,无冷凝
尺寸 (W x H x D) | 大约 49 mm x 100 mm x 70 mm | 大约 15 mm x 100 mm x 70 mm (对齐宽度：12 mm)
安装 | 35 mm 安装导轨(符合 EN 50022)
抗震、抗冲击性能 | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC防爆性/ESD | 符合 EN 61000-6-2 / EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认证 | CE Ex UL


ELxxxx, KLxxxx - Installation on mounting rails

倍福 现场总线组件：安装及布线

在导轨上的安装方法

WARNING 		小心触电和设备损坏！
在开始安装，拆卸或为总线端口接线之前，使终端系统处于安全断电的状态

安装

总线耦合器和总线终端只需轻轻按压即可安装在35mm轨道(依据EN 50022的DIN轨道)上：

1. 首先将现场总线耦合器连接在安装轨道上。

2. 现在，总线端子安装在现场总线耦合器的右边。通过卡槽将组件与端子连接并按在安装轨道上，直到将锁扣扣在轨道上。

如果先将终端夹在安装轨道上然后再连接到一起，且不使用卡槽连接，这样的连接无法正常工作！模块之间没有可见的缝隙才是正确的连接。

在安装总线端子的时候，注意不要让端子碰到固定导轨的螺丝。

拆卸

端子依靠卡锁固定在导轨上，在拆卸端子的时候要释放卡锁:

1. 小心地把橙色的拉杆拉出大约1cm，底部的卡锁就会释放，只需很小的力就可以把端子从导轨分离。

2. 用拇指和食指抓住模块的上部和下部的外壳向外拉，把模块彻底从导轨上拆下来。

总线端子模块的连接

总线耦合器和端子之间的电气连接在安装模块的时候自动完成：

  • 六个传输数据和为端子模块供电的K/E总线弹簧连接片。
  • 为现场总线供电的电源触点在端子模块链的内部就相当于组成了一个电源链。可通过总线耦合器上的端子(最高24伏)电源触点供电或者可通过供电端子提供更高的电压。

注意 		电源触点
在总线端子块的设计过程中，必须考虑独立总线端子的引脚分配，因为某些类型的端子（譬如模拟量总线端子或者数字量4通道的总线端子）不能或者不能完全通过这些电源触点形成回路。

供电端子（KL91xx, KL92xx or EL91xx, EL92xx）中断电源连接，就意味开始了一个新的电源链。

PE 电源触片

有PE标示的电源触片可用作保护接地。出于安全因素这个触片要先连接在一起，并且可接地的最大短路电流是125A。

注意 		设备可能损坏
考虑到电磁兼容性，PE触点与安装轨道之间是电容耦合的。这可能会在安装测试时导致错误的结果或损坏端子（例如：在客户用230V的标准电压进行安装测试时会击穿PE层）。

在安装测试时，不要将PE电源线与总线耦合器或供电端子连接！为了解耦更多的供电触点用来测试，这些供电端子可以从端子组释放并且至少拉出10mm。

警告 		触电危险！
PE不能用来接其它的电位！

警告

电绞线可以通过八个连接点接到总线端子。端口都采用弹簧技术。可根据下面的步骤来接线：

1. 用螺丝刀或者小棒轻轻推动位于接口上方的方形孔来打开安装有弹簧接线端子。

2. 无需任何外力，电线可以直接插入圆形孔。

3. 当撤去外力的时候端口会自动合上，接线将会稳固并永久。

Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
电线尺寸 | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
剥线长度 | 8 ... 9 mm | 9 ... 10 mm

注意 		屏蔽
模拟传感器和执行器总是用屏蔽双绞线相连。


BK11x0, BK1250 - Object description

倍福 BK11x0, BK1250: TwinCAT 系统管理器

对象描述

标准对象

1000标号 设备类型

EtherCAT从站的设备类型(只读)。

1008标号 设备名称

EtherCAT从站设备名称(只读，例如：BK1120- 0000 - 0000)。

1009标号 硬件版本

EtherCAT从站的硬件版本(只读)。

100A标号 软件版本

EtherCAT从站的固件(I / O信号的处理)版本(只读，例如07 (B7))。

标号 1018 特征对象
标号 | 名称 | 含义 | 标志 | 默认
1018:0 | 特征对象 | 对象长度 | RO | 4
1018:01 | 供应商ID | EtherCAT从站的供应商ID | RO | 0x00000002 (2dec)
1018:02 | 产品代码 | EtherCAT从站的产品代码 | RO | 0x04602C22 (73411618dec)
1018:03 | 修订号 | EtherCAT从站的修订号 | RO | 0x00000000 (0dec)
1018:04 | 系列号 | EtherCAT从站的系列号 | RO | 0x00000000 (0dec)
标号 16kk RxPDO 映像端子模块
取值范围:
(kk = 00..FE)hex ,
[(hh = 01..FF)hex ,(ddd = 001..255)]dec
标号 | 名称 | 含义 | 标志 | 默认
16kk:0 | RxPDO 映像端子模块 | 对象长度 | RW | -
16kk:01 | 输出映像区 001 | 该端子的第一个输出变量(分类标号001) | RW | 例如 0x7kk0:01, 1
... | ... | ... | ... | ...
16kk:hh | 输出映像区 ddd | 该端子的最后一个输出变量(分类标号ddd) | RW | 例如 0x7kk0:hh, 1
标号 16FF 控制 PDO
标号 | 名称 | 含义 | 标示 | 默认
16FF:0 | 控制 PDO | 对象长度 | RW | -
16FF:01 | 输出映像区 | 控制字 | RW | 0xF200:01, 16
标号 1701 RxPDO 数字对齐
标号 | 名称 | 含义 | 标示 | 默认
1701:0 | RxPDO 数字对齐 | 对象长度 | RW | -
1701:01 | PDO 对齐 | 数字 RxPDOs 对齐预留字 | RW | 0x0000:00, 00
标号 1Akk TxPDO 映像端子
取值范围：
(kk = 00..FE)hex ,
[(hh = 01..FF)hex ,(ddd = 001..255)dec]
标号 | 名称 | 含义 | 标示 | 默认
1Akk:0 | TxPDO 映像端子 | 对象长度 | RW | -
1Akk:01 | 输入映像区 001 | 该端子的第一个输出变量(分类标号001) | RW | 例如 0x6kk0:01, 1
... | ... | ... | ... | ...
1Akk:hh | Input Mapping Area ddd | 该端子的最后一个输出变量(分类标号001) | RW | 例如 0x6kk0:hh, 1
标号 1AFF 状态 PDO
标号 | 名称 | 含义 | 标示 | 默认
16FF:0 | 状态 PDO | 对象长度 | RW | -
16FF:01 | 输入映像区 | 状态字 | RW | 0xF100:01, 16
标号 1B01 TxPDO 数字对齐
标号 | 名称 | 含义 | 标示 | 默认
1B01:0 | TxPDO 数字对齐 | 对象长度 | RW | -
1B01:01 | PDO 对齐 | 数字 TxPDOs 对齐预留字 | RW | 0x0000:00, 00
标号 1C12 RxPDO 分配
Value range:
[(hh = 01..FF)hex ,(ddd = 001..255)dec]
标号 | 名称 | 含义 | 标示 | 默认
1C12:0 | RxPDO 分配 | 对象长度 | RW | -
1C12:01 | 分类标号 001 | 控制 PDO 分配 | RW | 0x16FF(5887dec)
1C12:02 | 分类标号 002 | 模拟端子 1. RxPDO 分配 | RW | 例如 0x1603 (5635dec)
... | ... | ... | ... | ...
1C12:nn | 分类标号 nnn | 模拟端子 n. RxPDO 分配 | RW | 例如 0x1605 (5637dec)
1C12:(nn+1) | 分类标号 (nnn+1) | 模拟端子 (n+1). RxPDO 分配 | RW | 例如 0x1600 (5632dec)
... | ... | ... | ... | ....
1C12:hh | 分类标号 ddd | 模拟端子 (n+1). RxPDO 预留分配字对齐 | RW | 0x1701(5889dec)
标号 1C13 TxPDO 分配
Value range:
[(hh = 01..FF)hex ,(ddd = 001..255)dec]
标号 | 名称 | 含义 | 标示 | 默认
1C13:0 | TxPDO 分配 | 对象长度 | RW | -
1C13:01 | 子标号 001 | 控制 PDO 分配 | RW | 0x1AFF(6911dec)
1C13:02 | 子标号 002 | 模拟端子1. TxPDO 分配 | RW | 例如 0x1A03 (6659dec)
... | ... | ... | ... | ...
1C13:nn | 子标号 nnn | 模拟端子 (n+1). TxPDO 分配 | RW | 例如 0x1A05 (6661dec)
1C13:(nn+1) | 子标号 (nnn+1) | 模拟端子 (n+1). TxPDO 分配 | RW | 例如 0x1A01 (6657dec)
... | ... | ... | ... | ....
1C13:hh | 子标号 ddd | 模拟端子 (n+1). TxPDO 预留分配字对齐 | RW | 0x1B01(6913dec)
标号 1C00 SM 型
标号 | 名称 | 含义 | 标示 | 默认
1C00:0 | SM 型 | 对象长度 | RO | 4
1C00:01 | 子标号 001 | 同步管理器，参数1 | RO | 0x01 (1dec)
1C00:02 | 子标号 002 | 同步管理器，参数2 | RO | 0x02 (2dec)
1C00:03 | 子标号 003 | 同步管理器，参数3 | RO | 0x03 (3dec)
1C00:04 | 子标号 004 | 同步管理器，参数4 | RO | 0x04 (4dec)
标号 4000 耦合器表 0 [LO]: 总线耦合器的一般配置
标号 | 名称 | 含义 | 标示 | 默认
4000:0 | 耦合器表 0 [LO] | 对象长度 | RW | 128
4000:01 | 子标号 001 | 寄存器 0 | RW |
4000:02 | 子标号 002 | 寄存器 1 | RW |
... | ... | ... | ... | ...
4000:80 | 子标号128 | 寄存器 127 | RW |

设备特定对象

标号 4001 耦合器表 0 [HI]: 总线耦合器的一般配置(续)
标号 | 名称 | 含义 | 标示 | 默认
4001:0 | 耦合器表 0 [HI] | 对象长度 | RW | 128
4001:01 | 子标号 001 | 寄存器 128 | RW |
4001:02 | 子标号 002 | 寄存器129 | RW |
... | ... | ... | ... | ...
4001:80 | 子标号128 | 寄存器 256 | RW |
标号 4012 耦合器表 9 [LO]: 端子排结构
标号 | 名称 | 含义 | 标示 | 默认
4012:0 | 耦合器表 9 [LO] | 对象长度 | RO | 最大 128
4012:01 | 子标号 001 | 寄存器 0：总线耦合器识别 | RO | 0x0460 (1120dec1)
4012:02 | 子标号 002 | 寄存器 1：第1个端子模块识别 | RO | 例如 0x8201 (33281dec2)
4012:03 | 子标号 003 | 寄存器 2：第2个端子模块识别 | RO | 例如 0x0BBA (3002dec1)
4012:04 | 子标号 004 | 寄存器 3：第3个端子模块识别 | RO | 例如 0x0C84 (3204dec1)
... | ... | ... | ... | ...
4012:80 | 子标号128 | 寄存器 127：第127个端子模块识别 | RO |

1）总线耦合器和智能终端(如模拟)端子标识显示为纯文本；
例如0x0C84(3204dec)代表手段KL3204。
2）对于非智能(数字)终端，下面的编码是必不可少的：

位 | 值 | 含义
15 | 0bin | 智能(例如，模拟)端子
1bin | 非智能(数字)端子
14...8 | xxxxxxbin | 端子位大小 (范围： 0 到 63 位)
7 | 1bin | 移位寄存器控制面板的扩展
6...3 | 0bin | 保留
2 | 1bin | KL1212
1 | 1bin | 输出端子 | 特别情况: 00bin 代表 KL1202 或者KL2212 (有输入和输出数据的数字端子模块)
0 | 1bin | 输入端子
标号 4013 耦合器表号 9 [HI]: 端子排结构 (如果超过127个端子，可作为后续)
标号 | 名称 | 含义 | 标示 | 默认
4013:0 | 端子排结构 9 [HI] | 对象长度 | RO | 最大128dec
4013:01 | 子标号 001 | 寄存器 128：第128个端子模块识别 | RO |
4013:02 | 子标号 002 | 寄存器 129：第129个端子模块识别 | RO |
... | ... | ... | ... |
4013:04 | 子标号128 | 寄存器 255：第255个端子模块识别 | RO |
标号 40B4 耦合器表号 90 [LO]: 总线耦合器的内部逻辑信息
标号 | 名称 | 含义 | 标示 | 默认
40B4:0 | 端子排结构 90 [LO] | 对象长度 | RO | 128dec
40B4:01 | 子标号 001 | 寄存器 0：保留 | RO |
40B4:02 | 子标号 002 | 寄存器 1：保留 | RO |
... | ... | ... | ... | ...
40B4:04 | 子标号128 | 寄存器 127：保留 | RO |
标号 40B5 耦合器表 90 [HI]: 总线耦合器的内部诊断信息
标号 | 名称 | 含义 | 标示 | 默认
40B5:0 | 耦合器表 90 [HI] | 对象长度 | RO | 128dec
40B5:01 | 子标号 001 | 寄存器 128：保留 | RO |
40B5:02 | 子标号 002 | 寄存器 129：保留 | RO |
... | ... | ... | ... | ...
40B5:04 | 子标号128 | 寄存器 255：保留 | RO |
标号 40C4 耦合器表 98 [LO]: Pd 刷新时间 (µs)
标号 | 名称 | 含义 | 标示 | 默认
40C4:0 | 耦合器表 98 Pd 刷新时间 (µs) | 对象长度 | RW | 5
40C4:01 | 最小时间 | 最小K总线刷新时间 | RW | 0x0355 (853dec)
40C4:02 | 最大时间 | 最大K总线刷新时间 | RW | 0x059A (1434dec)
40C4:03 | 当前时间 | 当前K总线刷新时间 | RW | 0x036A (874dec)
40C4:04 | - | 保留 | RW | 0x0000 (0dec)
40C4:50 | - | 保留 | RW | 0x09F8 (2552dec)
标号 40C5 耦合器表 98 [HI]: Pd 刷新时间 (µs) (续)
标号 | 名称 | 含义 | 标示 | 默认
40C5:0 | 耦合器表 98 Pd 刷新时间 (µs) | 对象长度 | RW | 0
标号 40C8 耦合器表 100 [LO]: 内部现场总线特别调整保留
标号 | 名称 | 含义 | 标示 | 默认
40C8:0 | 耦合器表 100 [LO] | 对象长度 | RO | 128dec
40C8:01 | 子标号 001 | 寄存器 0：保留 | RO |
40C8:02 | 子标号 002 | 寄存器 1：保留 | RO |
... | ... | ... | ... | ...
40C8:04 | 子标号128 | 寄存器 127：保留 | RO |
标号 40C9 耦合器表 100 [HI]: 内部现场总线特别调整保留 (续)
标号 | 名称 | 含义 | 标示 | 默认
40C9:0 | 耦合器表 100 [HI] | 对象长度 | RO | 128dec
40C9:01 | 子标号 001 | 寄存器 128：保留 | RO |
40C9:02 | 子标号 002 | 寄存器 129：保留 | RO |
... | ... | ... | ... | ...
40C9:04 | 子标号128 | 寄存器 255：保留 | RO |
标号 40FE 耦合器表 127 [LO]: 内部调整保留
标号 | 名称 | 含义 | 标示 | 默认
40FE:0 | 耦合器表 100 [LO] | 对象长度 | RO | 128dec
40FE:01 | 子标号 001 | 寄存器 0：保留 | RO |
40FE:02 | 子标号 002 | 寄存器 1：保留 | RO |
... | ... | ... | ... | ...
40FE:04 | 子标号128 | 寄存器 127：保留 | RO |
标号 40FF 耦合器表 127 [HI]: 内部调整保留 (续)
标号 | 名称 | 含义 | 标示 | 默认
40FF:0 | 耦合器表 100 [HI] | 对象长度 | RO | 128dec
40FF:01 | 子标号 001 | 寄存器 128：保留 | RO |
40FF:02 | 子标号 002 | 寄存器 129：保留 | RO |
... | ... | ... | ... | ...
40FF:04 | 子标号128 | 寄存器 255：保留 | RO |
标号 427F 端子号
标号 | 名称 | 含义 | 标示 | 默认
427F:0 | 端子号 | 端子排中的端子数量可以根据以下4个表格确定(对象 4280 - 4287) 例如：端子排中耦合器的名称是“0”。与耦合器相连的第一个端子是“1”，以此类推。 只有只能端子模块才可以被参数化！ | RO | 3
标号 4280 端子表 0 [LO]: 指定端子的对象参数化 427F
标号 | 名称 | 含义 | 标示 | 默认
4280:0 | 端子表 0 | 对象长度 | RW | 64
4280:01 | 子标号 001 | 寄存器 0 | RW | 0x0000 (0dec)
4280:02 | 子标号 002 | 寄存器 1 | RW | 0x0000 (0dec)
... | ... | ... | ... | ...
4280:40 | 子标号064 | 寄存器 63 | RW | 0x0000 (0dec)
标号 4281 端子表 0 [HI]: 指定端子的对象参数化 427F (续)
标号 | 名称 | 含义 | 标示 | 默认
4081:0 | Terminal Table 0 | 对象长度 | RW | 0
标号 4282 端子表 1 [LO]: 指定端子的对象参数化 427F
标号 | 名称 | 含义 | 标示 | 默认
4282:0 | 端子表 1 | 对象长度 | RW | 64
4282:01 | 子标号 001 | 寄存器 0 | RW | 0x0000 (0dec)
4282:02 | 子标号 002 | 寄存器 1 | RW | 0x0000 (0dec)
... | ... | ... | ... | ...
4282:40 | 子标号064 | 寄存器 63 | RW | 0x0000 (0dec)
标号 4283 端子表 1 [HI]: 指定端子的对象参数化 427F (续)
标号 | 名称 | 含义 | 标示 | 默认
4083:0 | 端子表 1 | 对象长度 | RW | 0
标号 4284 端子表 2 [LO]: 指定端子的对象参数化 427F
标号 | 名称 | 含义 | 标示 | 默认
4284:0 | 端子表 2 | 对象长度 | RW | 64
4284:01 | 子标号 001 | 寄存器 0 | RW | 0x0000 (0dec)
4284:02 | 子标号 002 | 寄存器 1 | RW | 0x0000 (0dec)
... | ... | ... | ... | ...
4284:40 | 子标号064 | 寄存器 63 | RW | 0x0000 (0dec)
标号 4285 端子表 2 [HI]: 指定端子的对象参数化 427F (续)
标号 | 名称 | 含义 | 标示 | 默认
4085:0 | 端子表 2 | 对象长度 | RW | 0
标号 4286 端子表 3 [LO]: 指定端子的对象参数化 427F
标号 | 名称 | 含义 | 标示 | 默认
4286:0 | 端子表 3 | 对象长度 | RW | 64
4286:01 | 子标号 001 | 寄存器 0 | RW | 0x0000 (0dec)
4286:02 | 子标号 002 | 寄存器 1 | RW | 0x0000 (0dec)
... | ... | ... | ... | ...
4286:40 | 子标号064 | 寄存器 63 | RW | 0x0000 (0dec)
标号 4287 端子表 3 [HI]: 指定端子的对象参数化 427F (续)
标号 | 名称 | 含义 | 标示 | 默认
4087:0 | 端子表 3 | 对象长度 | RW | 0
标号 6kk0 端子输入数据
Note 输入输出变量 "kk"，"hh"，"ddd"的取值范围如下所述。
动态生成的输入输出对象取决于端子排中端子模块的顺序。

端子排配置示例
BK1120 - KL1408 - KL2032 - K3403 - KL4032

所分配的 PDOs(标号6000) 的映像:
标号 | 名称 | 含义
6000:0 | KL1408 | KL1408，最大子标号 (8) | 耦合器 KL1408 后第1个位置 | 端子输入数据
6000:01 | 通道 1 | 1. 通道，KL1408
6000:02 | 通道 2 | 2. 通道，KL1408
6000:03 | 通道 3 | 3. 通道，KL1408
6000:04 | 通道 4 | 4. 通道，KL1408
6000:05 | 通道 5 | 5. 通道，KL1408
6000:06 | 通道 6 | 6. 通道，KL1408
6000:07 | 通道 7 | 7. 通道，KL1408
6000:08 | 通道 8 | 8. 通道，KL1408
6010:0 |  | 未映像，无输入 | 耦合器 KL2032 后第2个位置
6020:0 | KL3403 | KL3403，最大子标号 (9) | 耦合器 KL3403 后第3个位置
6020:01 | 通道1状态 | 1. 通道，状态，KL3403
6020:02 | 通道1字对齐 | 1.通道，字对齐，KL3403
6020:03 | 通道1数据 | 1. 通道，数据，KL3403
6020:04 | 通道2状态 | 2. 通道，状态，KL3403
6020:05 | 通道2字对齐 | 2.通道，字对齐，KL3403
6020:06 | 通道2数据 | 2. 通道，数据，KL3403
6020:07 | 通道3状态 | 3.通道，状态，KL3403
6020:08 | 通道3字对齐 | 3.通道，字对齐，KL3403
6020:09 | 通道3数据 | 3. 通道，数据，KL3403
6030:0 | KL4032 | KL4032，最大子标号 (6) | 耦合器 KL4032 后第4个位置
6030:01 | 通道1状态 | 1. 通道，状态，KL4032
6030:02 | 通道1字对齐 | 1.通道，字对齐，KL4032
6030:03 | 通道1数据 | 1. 通道，数据，KL4032
6030:04 | 通道2状态 | 2. 通道，状态，KL4032
6030:05 | 通道2字对齐 | 2.通道，字对齐，KL4032
6030:06 | 通道2数据 | 2. 通道，数据，KL4032
7000:0 |  | 未映像，无输出 | 耦合器 KL1408 后第1个位置 | 端子输出数据
7010:0 | KL2032 | KL2032，最大子标号 (2) | 耦合器 KL2032 后第2个位置
7010:01 | 通道1 | 1. 通道，KL2032
7010:02 | 通道2 | 2. 通道，KL2032
7020:0 | KL3403 | KL3403，最大子标号 (9) | 耦合器 KL3403 后第3个位置
7020:01 | 通道1状态 | 1. 通道，状态，KL3403
7020:02 | 通道1字对齐 | 1.通道，字对齐，KL3403
7020:03 | 通道1数据 | 1. 通道，数据，KL3403
7020:04 | 通道2状态 | 2. 通道，状态，KL3403
7020:05 | 通道2字对齐 | 2.通道，字对齐，KL3403
7020:06 | 通道2数据 | 2. 通道，数据，KL3403
7020:07 | 通道3状态 | 3. 通道，状态，KL3403
7020:08 | 通道3字对齐 | 3.通道，字对齐，KL3403
7020:09 | 通道3数据 | 3. 通道，数据，KL3403
7030:0 | KL4032 | KL4032，最大子标号 (6) | 耦合器 KL4032 后第4个位置
7030:01 | 通道1状态 | 1. 通道，状态，KL4032
7030:02 | 通道1字对齐 | 1.通道，字对齐，KL4032
7030:03 | 通道1数据 | 1. 通道，数据，KL4032
7030:04 | 通道2状态 | 2. 通道，状态，KL4032
7030:05 | 通道2字对齐 | 2.通道，字对齐，KL4032
7030:06 | 通道2数据 | 2. 通道，数据，KL4032

数字端子：
取值范围：
(kk = 00..FF)hex ,
[(hh = 01..FF)hex ,(ddd = 001..255)dec]
标号 | 名称 | 含义 | 标示 | 默认
6kk0:0 | 端子输入数据 | [端子描述] | RO P | -
6kk0:01 | 通道 001 | 通道 001 | RO P | -
... | ... | ... | ... | ...
6kk0:hh | 通道 ddd | 通道 ddd | RO P | -
非数字端子 (hh ≥ 03; ddd ≥ 003):

取值范围：
(kk = 00..FF)hex,
[(hh = 01..FF)hex, (ddd = 001..255)dec] hh 给 resp. ddd 的值必须除以3
标号 | 名称 | 含义 | 标示 | 默认
6kk0:0 | 端子输入数据 | [端子描述] | RO P | -
6kk0:01 | 通道001状态 | 通道001：状态 | RO P | -
6kk0:02 | 通道001字对齐 | 通道001：字对齐 | RO P | -
6kk0:03 | 通道001数据 | 通道001：数据 | RO P | -
... | ... | ... | ... | ...
6kk0:hh-2 | 通道 ddd/3 | 通道 ddd/3：状态 | RO P | -
6kk0:hh-1 | 通道 ddd/3 | 通道 ddd/3：字对齐 | RO P | -
6kk0:hh | 通道 ddd/3 | 通道 ddd/3：数据 | RO P | -
标号 7kk0 端子输出数据

数字端子：

取值范围：
(kk = 00..FF)hex ,
[(hh = 01..FF)hex ,(ddd = 001..255)dec]
标号 | 名称 | 含义 | 标示 | 默认
7kk0:0 | 端子输出数据 | [端子描述] | RO P | -
7kk0:01 | 通道 001 | 通道 001 | RO P | -
... | ... | ... | ... | ...
7kk0:hh | 通道 ddd | 通道 ddd | RO P | -
非数字端子 (for hh ≥ 03; ddd ≥ 003):

取值范围：
(kk = 00..FF)hex,
[(hh = 01..FF)hex, (ddd = 001..255)dec] 给 resp. ddd 的值必须除以3
标号 | 名称 | 含义 | 标示 | 默认
7kk0:0 | 端子输入数据 | [端子描述] | RO P | -
7kk0:01 | 通道 001 控制 | 通道 001 ：控制 | RO P | -
7kk0:02 | 通道 001 字对齐 | 通道 001 ：字对齐 | RO P | -
7kk0:03 | 通道 001 数据 | 通道 001 ：数据 | RO P | -
... | ... | ... | ... | ...
7kk0:hh-2 | 通道 ddd/3 控制 | 通道 ddd/3 ：控制 | RO P | -
7kk0:hh-1 | 通道 ddd/3 字对齐 | 通道 ddd/3 ：字对齐 | RO P | -
7kk0:hh | 通道 ddd/3 数据 | 通道 ddd/3 ：数据 | RO P | -
标号 9kk0 从站信息数据

取值范围：
(kk = 00..FF)hex
标号 | 名称 | 含义 | 标示 | 默认
9kk0:0 | 从站信息数据 | [端子描述] | RO | -
9kk0:01 | 位置 | Modul eposition in the terminal block | RO | -
9kk0:09 | 模块 PDO 组 | 模块 PDO 组 •非数字端子：组1 • 数字端子：组2 | RO | -
9kk0:0A | 模块标识 | 端子描述 | RO | -
标号 F000 模块化设备资料
标号 | 名称 | 含义 | 标示 | 默认
F000:0 | 模块化设备资料 | 对象长度 | RO | 5
F000:01 | 模块标号距离 | 模块标号距离 | RO | 0x0010 (16dec)
F000:02 | 最大模块数 | 最大模块数 | RO | 0x00FF (255dec)
F000:03 | 0x8yy0 中的标准条目 | 0x8kk0 中的可用条目 | RO | 0x0000000 (0dec)
F000:04 | 0x9yy0 中的标准条目 | 0x9kk0 中的可用条目 | RO | 0x0000000 (0dec)
F000:04 | 模块 PDO 组 | 设备的模块 PDO 组 = 0， 因为过程数据中控制和状态数据将在所有的端子之前分配 | RO | 0x00 (0dec)
标号 F00E 组对齐 PDO
标号 | 名称 | 含义 | 标示 | 默认
F00E:0 | 组对齐 PDO | 对象长度(3 个模块 PDO 组) | RO | 3
F00E:01 | 子标号 001 | PDO 组 0： 模块之后不需要对齐(设备的状态或者控制) | RO | 0x0000 (0dec)
F00E:02 | 子标号 002 | PDO 组1: PDO 257被用在模块 PDO 组 1 之后的对齐 (非数字端子) | RO | 0x0100 (256dec)
F00E:03 | 子标号 003 | PDO 组 2: PDO 258 被用在模块 PDO 组 2 之后的对齐 (数字端子) | RO | 0x0101 (257dec)
标号 F00F 模块组映像对齐
标号 | 名称 | 含义 | 标示 | 默认
F00F:0 | 组对齐 PDO | 对象长度 | RO | 3
F00F:01 | 子标号 001 | 组 0: 模块 PDO 0 组之后不需要对齐(设备的状态或者控制) The size of the Status Data and Control Data is fixed and already aligned | RO | 0x0000 (0dec)
F00F:02 | 子标号 002 | 组 1: 模块 PDO 1 组之后需要一个字对齐 (非数字端子) 数字终端的过程数据始终位于偶字节地址 | RO | 0x0002 (2dec)
F00F:03 | 子标号 003 | 组 2: 模块 PDO 2组之后需要一个字对齐 (数字端子) 过程数据的大小始终是偶数。 | RO | 0x0002 (2dec)
标号 F010 模块列表

取值范围：
(hh = 01..FF)hex ,(ddd = 001..255)dec
标号 | 名称 | 含义 | 标示 | 默认
F010:0 | 模块列表 | 对象长度 | RO | -
F010:01 | 子标号 001 | 端子描述模块 001 | RO | -
... | ... | ... | ... | ...
F010:hh | 子标号 ddd | 端子描述模块 ddd | RO | -
标号 F030 配置模块列表

取值范围：
(hh = 01..FF)hex ,(ddd = 001..255)dec
标号 | 名称 | 含义 | 标示 | 默认
F030:0 | 模块列表 | 对象长度 | RW | -
F030:01 | 子标号 001 | 位置1上配置的模块的ModuleIdent (与 0x8kk0:0A 值相同) | RW | -
... | ... | ... | ... | ...
F030:hh | 子标号 ddd | 最后一个位置上配置的模块的KModuleIdent (与0x8kk0:0A 值相同) | RW | -
标号 F040 被检测地址列表

取值范围：
(hh = 01..FF)hex ,(ddd = 001..255)dec
标号 | 名称 | 含义 | 标示 | 默认
F040:0 | 模块列表 | 对象长度 | RO | -
F040:01 | 子标号 001 | 位置1上检测的模块的地址 (与 9kk0:0A 值相同) | RO | -
... | ... | ... | ... | ...
F040:hh | 子标号 ddd | 最后一个位置上检测的模块的地址 (与 9kk0:0A 值相同) | RO | -
标号 F050 被检测模块列表

取值范围：
(hh = 01..FF)hex ,(ddd = 001..255)dec
标号 | 名称 | 含义 | 标示 | 默认
F050:0 | 模块列表 | 对象长度 | RO | -
F050:01 | 子标号 001 | 位置1上检测的模块的ModuleIdent (与 9kk0:0A 值相同) | RO | -
... | ... | ... | ... | ...
F050:hh | 子标号 ddd | 最后一个位置上检测的模块的KModuleIdent (与 9kk0:0A 值相同) | RO | -
标号 F100 状态 PDO
标号 | 名称 | 含义 | 标示 | 默认
F100:0 | 状态 PDO | 对象长度 | RO | 1
F100:01 | 耦合器状态 | 控制状态字 | RO P | 0x0000 (0dec)
标号 F200 控制 PDO
标号 | 名称 | 含义 | 标示 | 默认
F100:0 | 控制PDO | 对象长度 | RO | 1
F100:01 | CouplerCtrl | Koppler 控制字 | RO P | 0x0000 (0dec)


Mapping of the Bus Terminals

倍福 现场总线组件: 配置

总线端子模块映像

面向字节的总线端子模块的详细情况可以从特殊总线端子的的配置向导中找到。这个文档可以从倍福CD产品和解决方案或者网站http://www.beckhoff.com上找到。

面向字节的总线端子模块 | 面向位的总线端子模块
KL15x1 | KL10xx, KL11xx, KL12xx, KL17xx, KM1xxx
KL25xx | KL20xx, KL21xx, KL22xx, KL26xx, KL27xx, KM2xxx
KL3xxx |
KL4xxx |
KL5xxx |
KL6xxx |
KL7xxx |
KL8xxx |
 | KL9110, KL9160, KL9210, KL9260


Process image example

倍福 BK11x0, BK1250: TwinCAT 系统管理器

过程映像示例

以下示例说明了总线端子排的过程映像。

总线端子排的示例中包括与总线耦合器相连的KL2012，KL1408，KL3062，KL1104，KL1408和KL9010(见图片)。对于字对齐的复杂映像(出厂设置)，所有非数字端子模块显示在过程输入和输出映像。请参考相关终端方面的文件映射的详细信息。非数字端子模块先进行映像，然后数字端子模块再进行映像。过程映像的首16位被保留给状态字(过程输入映像)和控制字(过程输出映像)。

过程输入映像

状态字(SW)位于输出过程映像，并从端子模块传送到控制器。

字偏移 |  | 高字节 |  |  |  |  |  |  |  | 低字节
 |  | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
0 | 状态 |  |  |  |  |  |  | K总线过载. | 无法输出 |  |  |  |  |  |  | 配置错误 | K总线错误
1 | KL3062 (非数字) | 字对齐保留位 |  |  |  |  |  |  |  | 状态字节通道1
2 |  | 过程通道1
3 |  | 字对齐保留位 |  |  |  |  |  |  |  | 状态字节通道2
4 |  | 过程通道2
5 | 数字端子 | KL1408 (2) |  |  |  | KL1104 |  |  |  | KL1408 (1)
6 |  |  |  |  |  |  |  |  |  |  |  |  |  | KL1408 (2)

过程输出映像

控制字(CW)位于输出过程映像，并从控制器传输到端子模块。

Word-Offset |  | 高字节 |  |  |  |  |  |  |  | 低字节
 |  | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
0 | 控制 |  |  |  |  |  |  | K总线过载 | 无法输出 |
1 | KL3062 (非数字) | 字对齐保留位 |  |  |  |  |  |  |  | 控制字节通道1
2 |  | 寄存器通信数据通道1
3 |  | 字对齐保留位 |  |  |  |  |  |  |  | 控制字节通道2
4 |  | 寄存器通信数据通道2
5 | 数字端子
 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  | KL2012


Notes

倍福 BK11x0, BK1250: TwinCAT 系统管理器

注意

过程数据错误

根据已配置的KL端子模块，EtherCAT主站基于EtherCAT过程数据偏差度对BK11x0/BK1250进行设置。在那之前，耦合器扫描它的KL端子模块并依据它们的信息建立内部过程数据映像。

如果这两个过程中的数据不匹配，系统会报告一个SyncManager错误，见图1。

图1：SM 错误

例如，使用KS2000软件或正确的CoE启动项以确保KL端子模块不会报告一个与TwinCAT配置不同的过程数据类型。


Approvals

倍福 现场总线组件: 附录

认证

UL E172151

合格标志

CE

防护等级

IP20 in accordance with EN60529


Test Standards for Device Testing

倍福 现场总线组件: 附录

设备测试的测试标准

电磁兼容性

EN 61000-6-2

EN 61000-6-4

抗震性能

EN 60068-2-6 Vibration Testing

EN 60068-2-27/29 Shock Testing