BK3xx0 - Bus Coupler for PROFIBUS-DP

BECKHOFF Fieldbus Components

Documentation about Bus Couplers for PROFIBUS-DP

BK3010, BK3110, BK3120, BK3150, BK3500, BK3520 and LC3100

Version: 3.5.1
Date: 2006-02-10


Safety Instructions

BECKHOFF Automation: Foreword

安全说明

安全条例

请参考以下安全说明书的内容和描述!
产品特殊安全说明会在后几页出现或在安装、接线、调试过程中进行描述.

免责声明

所有组件应用于特定的软硬件环境中，不按照说明对软硬件修改是不允许的，BECKHOFF电气有限公司不承担由此造成的损失。

人员资格

此说明仅供符合国家标准的控制技术,自动化技术和驱动技术培训使用.

符号说明

在这个文件中包含符号及安全说明,请您务必要仔细阅读!

Danger 危险

Warning 警告

Note 重要信息


BK3xx0 - Documentation Issue Status

BECKHOFF Fieldbus Components: Foreword

文件版本说明

Version | Status
3.5.1 | 有关UL认证补充说明
3.5 | 添加固件版本为B0的BK3150
3.03 | 更改翻译语境中的语言为英语
3.02 | GSD 文件更新 BK3110, BK3120, BK3520
3.01 | 在西门子S7扩展下的操作和配置案例
3.0 | BK3010 固件版本 B9 BK3110 固件版本 B9 BK3120 固件版本 B9 BK3500 固件版本 B9 BK3520 固件版本 B9 LC3100 固件版本 B9


BK3xx0 - Technical Data

BECKHOFF Fieldbus Coupler: Product Overview

技术参数

Technical data BK3000, BK3010, BK3100, BK3110, BK3120, LC3100
Type | BK3000, BK3010 | BK3100, BK3110 | BK3120 | LC3100
总线端子数 | 64 |  | 64 (255 K-Bus拓展) | 64
数字量外围信号 | 512 输入/输出 |  | 最大. 1020 输入/输出 | 256 输入/输出
模拟量外围信号 | 128 输入/输出 (BK3x00) |  | 最大. 64 输入/输出 | -
配置方式 | 通过KS2000 组态软件或控制器
最高字节数(输入/输出) | BK3000: 244 字节 | BK3100: 64 bytes (DP 以及 FMS 操作) 128 bytes (DP操作) | 128 字节 | 32 字节
 | BK3010: 32 字节 | BK3110: 32 bytes
波特率(自动检测) | 最大. 1.5 M波特 | up to max. 12 MBaud
总线连接 | 1 x D-sub 插头, 9-pin 屏蔽线 |  |  | 弹簧端子
电源供电 | 24 VDC (-15 % /+20 %)
输入电流 | 70 mA + (K-Bus 电流)/4, 最大500 mA (BK3x00) 70 mA + (K-Bus 电流)/4, 最大200 mA (BK3x10) |  | 70 mA + (K-Bus电流)/4, 最大500 mA | 70 mA + (K-Bus电流)/4,最大 200 mA
启动电流 | 2.5 x 连续电流
最大K-Bus电流 | 1750 mA (BK3x00) 500 mA (BK3x10) |  | 1750 mA | 500 mA
电源电压 (Up) | 最大值 24 VDC
电源连接负载电压 (Up) | 最大值 10 A
推荐保险丝电流 (Up) | 最大10 A
电隔离 | 电源连接/ 供电/ 总线 |  |  | 电源供电/ 总线
绝缘强度 | 500 Vrms (电源连接/ 供电/ 总线) |  |  | 500 Vrms (supply / fieldbus)
重量 | 约170 g | 约150 g | 约170 g | 约100 g
操作温度 | 0 °C … +55 °C
允许环境温度 | -25 °C … +85 °C
允许相对湿度 | 95 % (无冷凝)
振动/局部阻力 | 符合EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC 电阻/ ESD | 符合EN 61000-6-2 (EN 50082) / EN 61000-6-4 (EN 50081)
防护等级 | IP 20
安装位置 | 变量

Technical data BK3150
Type | BK3150
总线端子数 | 64 (255 K-Bus 扩展)
数字量外围信号 | max. 1020 输入/输出
模拟量外围信号 | max. 64 输入/输出
配置方式 | 通过KS2000组态软件或控制器
最高字节数(输入/输出) | 128 Byte (DP 操作)
波特率(自动检测) | 最大max. 12 M波特
总线连接 | 1 x D-sub 插头 9-pin 屏蔽线
电源供电 | 24 VDC (-15 % /+20 %) 满足UL 要求使用 4 A 保险丝或电源供应器满足 NEC class 2!
输入电流(UP) | 70 mA + (K bus 电流)/4, max. 320 mA
启动电流(UP) | 2,5 x 持续电流
推荐保险丝电流(UP) | 最大 10 A
最大K-Bus 电源 | 1000 mA
最大连接 | 最大 24 VDC
电源连接负载电压 (Up) | 最大 10 A
电隔离 | 电源连接 / 供电/总线
绝缘强度 | 500 Vrms (电源连接 /供电/ 总线)
重量 | 约100 g
操作温度 | 0 °C … +55 °C
允许环境温度 | -25 °C … +85 °C
允许相对湿度 | 95 % (无冷凝)
振动/局部阻力 | 符合EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC 电阻/ ESD | 符合EN 61000-6-2 / EN 61000-6-4
防护等级 | IP 20
安装位置 | 变量


Technical Data (Optical Fibres)

BECKHOFF Fieldbus Components: Product Overview

技术参数(光学纤维)

技术参数
Type | BK3500 | BK3520
总线端子数 | 64 | 64 (255 K-Bus扩展)
数字外围设备 | 最大512输入/输出 | 最大1020输入/输出
模拟外围设备 | 最大64 输入/输出 | 最大64 输入/输出
配置方式 | 通过KS2000组态软件以及控制器
最高字节数(输入/输出) | 128 bytes | 128 bytes
波特率 | 最大 1.5 接口速度(手动设置) | 最大12 接口速度(自动检测)
总线连接 | 1 x 光学 纤维 以及2 HP 单一连接器 | 2 x 纤维以及2 HP 每个单一连接器
电源供电 | 24 VDC (-15 %/+20 %)
输入电流 | 70 mA + (K-Bus 总电流)/4, 500 mA, 最大500 mA
启动电流 | 2.5 x 持续电流
推荐保险丝电流 | 最大 10 A
最大K-Bus电流 | 1750 mA
电源电压 | 最大24 VDC
电源连接负载电压 | 最大 10 A
电隔离 | 电源连接/ 供电/ 总线
绝缘强度 | 500 Vrms (电源连接/ 供电/ 总线)
重量 | 约170 g | 约170 g
操作温度 | 0 °C … +55 °C
允许环境温度 | -25 °C … +85 °C
允许相对湿度 | 95 % (无冷凝)
振动/局部阻力 | 符合EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC电阻/ ESD | 符合EN 61000-6-2 (EN 50082) / EN 61000-6-4 (EN 50081)
防护等级 | IP 20
安装位置 | 变量


BK3xx0 - Dimensions

BECKHOFF Fieldbus Components: Mounting and Wiring

产品规格

Beckhoff 总线端子系统具有物理体积小且高度模块化的特性。当规划一个项目时，必须假定使用至少一个总线耦合器和若干总线端子。总线耦合器的机械尺寸与现场总线系统无关。

耦合器在实际的案例中的总宽度包括总线连接器的宽度,总线端子的宽度和终端的宽度,根据功能的不同,总线端子宽度在12或者24毫米间不等,前端接线高度为68毫米,增加5到10毫米,这是根据接线密度来决定的.

Mechanical data | BK30x0, BK35x0, KL3110, BK3120 | BK3150 | LC3100
原料 | 聚碳酸酯,聚酰胺(PA 6.6)
尺寸 (W x H x D) | 50 mm x 100 mm x 68 mm | 44 mm x 100 mm x 68 mm | 21 mm x 100 mm x 68 mm
安装 | on 35 mm C-rail conforming to EN50022 with lock
Side by side mount. by means of | double slot and key connection
注释 | 在侧面有标准端子模块注释以及清晰的文字说明(8 mm x 47 mm, not BK3150)


The Bus Coupler's UserPrmData

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

总线耦合器的 UserPrmData

在总线耦合器的UserPrmData中可以进行以下设置，在90%的应用中可获得的 GSD文件 都是很好理解的，但是一些设置只包含在 GSD扩展文件 中并且显示在Extended的最后一行。标准设置同时包含在 扩展 GSD 文件 中

Byte | Bit | Value | Description | GSD file
0 | 7 | 0bin | MSAC_C1 未连接(默认) | Standard(标准)
 |  | 1bin | MSAC_C1 已连接 (见DPV1)
1 | 0 | 0bin | CfgData 检测启动 (默认) | Extended(扩展)
 |  | 1bin | CfgData 检测未启动 (见 停止 CfgData 检测)
2 | 3 | 0bin | 与BK3100兼容的形式传送诊断数据 | Extended
 |  | 1bin | 与DPV1兼容的形式传送诊断数据(默认)
3 | 3 | 0bin | K-Bus 循环计数器没有运行 (默认) | Extended
 |  | 1bin | K-Bus 循环计数器运行 (见 K-Bus cycle)
3 | 4 | 0bin | Multi-配置模式 未启动 (默认) | Extended
 |  | 1bin | Multi-配置模式 已启动 (见 Multi-配置模式)
3 | 5 | 0bin | 虚拟输出字节未激活(默认) | Extended
 |  | 1bin | 虚拟输出字节 已激活 (见 K-Bus cycle)
3 | 6 | 0bin | MCM 启动 "静态诊断" 在 multi-配置模式下,如果配置不正常,则 耦合器在诊断数据中设置Stat_Diag bit, 并且不会进行数据交换 (默认). | Extended
 |  | 1bin | MCM启动“没有K-Bus的数据交换” 在多配置模式下，即使配置不一致，K-Bus循环尚未执行，耦合器也会进入数据交换 (见 Multi-配置模式)
5 | 0 | 0bin | 2-byte PLC 接口未启动 (默认) | Extended
 |  | 1bin | 2-byte PLC 接口已启动 (见 2-byte PLC 接口)
7 | 0 | 0bin | K-Bus 错误: 手动K-Bus 重置(默认) (见 K-Bus interruption) | Standard
 |  | 1bin | K-Bus 错误: 自动 K-Bus 重置
7 | 1 | 0bin | 端子模块诊断 未启动 (默认) (见 端子模块诊断) | Standard
 |  | 1bin | 端子模块诊断 已启动
7 | 4 | 0bin | 包括图像处理的数字模块诊断数据(默认) (见 端子模块诊断) | Standard
 |  | 1bin | 不包括图像处理的数字模块诊断数据(默认)
9 | 2 | 0bin | 模拟模块映射到紧凑的形式（只显示输入和/或输出用户数据）（这是默认的，只用当CfgData没有激活时有用，否则终端通过CfgData设置）(见 CfgData非激活检查) | Extended
 |  | 1bin | 模拟模块映射到复杂的形式（与控制/寄存器访问状态和在输入输出中相同的数据长度）（只用当CfgData没有激活时有用，否则终端通过CfgData设置）
9 | 3 | 0bin | 表示在INTEL 格式 | Standard
 |  | 1bin | 回应Motorola 格式 (默认)
9 | 4 | 0bin | K-Bus 缓慢reeRun 模式(默认) (见 K-Bus cycle) | Standard
 |  | 1bin | K-Bus 快速FreeRun模式
9 | 5 | 0bin | WORD 未对齐(默认) | Extended
 |  | 1bin | WORD 对齐 (见 WORD alignment)
9 | 6 | 0bin | K-Bus 模式被同步 (见 K-Bus cycle) | Standard
 |  | 1bin | K-Bus模式FreeRun (默认)
10 | 0-1 | 00bin | 响应PROFIBUS错误：K总线循环被禁止（默认情况下，数字输出变成0，复杂的输出设置为配置的替代值） (见响应 PROFIBUS 错误) | Standard
 |  | 01bin | 回应 PROFIBUS 错误: K-Bus 输出为0
 |  | 10bin | 回应 PROFIBUS 错误: K-Bus 输出维持不变
10 | 2-3 | 00bin | 回应K-Bus 错误: DP 数据交换终止 (默认) (见 K-Bus interruption) | Standard
 |  | 01bin | 回应K-Bus错误: DP 输入被置为0
 |  | 10bin | 回应K-Bus 错误: DP 输入维持不变
11 | 3-6 | X | 最大诊断数据长度,允许值: 16, 24, 32, 40, 48, 56, 64 (见 端子模块诊断) | Extended
12 | 0-1 | 0bin | 如果 K-Bus 模式被同步的: 标准同步模式 (默认) (见 K-Bus cycle) | Extended
 |  | 01bin | 如果K-Bus为同步模式：带优化输入更新的同步模式（一个周期）
 |  | 10bin | 如果K-Bus为同步模式：带优化输入更新的同步模式（二个周期）
12 | 4-7 | 0bin | 最大DP缓冲不改变 | Extended
12 | 4-7 | 15 | 最大的DP缓存区长度的改变方法是使用 UserPrmData 的值37-40 (见 Multi-配置模式) | Extended
13 | 0-7 | X | 延迟 (in µs) 高位字节 (见 K-Bus cycle) | Extended
14 | 0-7 | X | 延迟(in µs) 低位字节 (见 K-Bus cycle) | Extended
15-30 | 0-7 | X | 总线端子模块分配 1 to 64 (见 Multi-配置模式) | Extended
31-36 | 0-7 | - | 预留值 | Extended
37 | 0-7 | X | 最大输入数据的长度 (见 Multi-配置模式) | Extended
38 | 0-7 | X | 最大输出数据的长度 (见 Multi-配置模式) | Extended
39 | 0-7 | X | 最大诊断数据长度 (见 Multi-配置模式) | Extended
40 | 0-7 | X | 最大配置数据长度 (见 Multi-配置模式) | Extended
41-56 | 0-7 | X | 端子模块分配 65 to 128 (见 Multi-配置模式) | Extended


Technical Data - Summary

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

技术参数-概要

技术参数
Description | BK3010 | BK3110 | BK3120 | BK3150 | BK3500 | BK3520 | LC3100 | BC3100
总线端子数目 | 64 | 64 | 255 | 255 | 64 | 255 | 64 | 64
波特率 | 1.5 | 12 | 12 | 12 | 1.5 | 12 | 12 | 12
物理依据 | RS 485 | RS 485 | RS 485 | RS 485 | Optical fibres | Optical fibres | RS 485 | RS 485
UserPrm Data
DPV1 Services | x | x | x | x | x | x | x | x
Multi-configuration 模式 | x | x | x | x | x | x | x |
Word Align |  |  | x | x | x | x |  |
Byte oriented Bus Terminals |  |  | x | x | x | x |  | x
分配控制
PLC IEC 6 1131-3 |  |  |  |  |  |  |  | x


Configuration - CfgData

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

配置- CfgData

在DP配置工具中CfgData是从嵌入式模块中形成的. 当模块被加载后, 必须遵守以下规则:

一系列DP模块被加载到DP配置设备中
耦合器型功能模块
复杂型功能模块
数字量型功能模块

TwinCAT 应用软件, 这些规定会紧跟在TwinCAT system manager后面, 它会在这些设备中加载端子或者IE模块,并且如果这些模块所带有的功能合适的话,这些模块将会自动地被加载进去。


Configuration of the Coupler Modules

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

耦合器模块配置

相关功能启动后,以下总线耦合器的DP模块功能会被加载到DP 配置工具中去.如果连接功能成功(如果不成功,那么相应的DP模块不会被加载):

功能模块 | 功能Active
2字节PLC接口 | 2字节接口通过UserPrmData（byte 5, bit 0）被激活.默认是非激活.
K-Bus总线周期计数器 | K-Bus总线周期计数器通过UserPrmData （byte 3, bit 3）被激活.默认是非激活.
虚拟输出字节 | 虚拟输出字节通过UserPrmData （byte 3, bit 3）被激活.默认是非激活 .


Configuration of Complex Modules

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

复杂型模块配置

在DP配置工具中,当DP模块加载到总线耦合器后,下一步就是将复杂型端子(KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx)加载进去, 不管是在复杂型端子间加多少数字量型端子，它们都会被加载.

复杂型功能模块 | 说明 | 连接 CfgData (十六进制)
KL1501 | KL1501 | 0xB4 (in GSD file)
 |  | 0xB5 (alternatively)
 |  | 0xF2 (alternatively)
KL2502 | KL2502 | 0xB5 (in GSD file)
 |  | 0xB2, 0xB2 (alternatively)
 |  | 0xF2 (alternatively)
KL2521 | KL2521 | 0xB2 (in GSD file)
 |  | 0xF1 (alternatively)
KL3351 紧凑型 | KL3351 - 只有 16 bit 的输入量被发送 | 0x51 (in GSD file)
 |  | 0x50, 0x50 (alternatively)
KL3351 复杂型 | KL3351 - 可以有24 bits 输入/输出被传送,,除了十六bits输入值外，还能访问端子寄存器. | 0xB5 (in GSD file)
 |  | 0xB2, 0xB2 (alternatively)
 |  | 0xF2 (alternatively)
KL3361 | KL3361 | 0xFB (in GSD file)
KL3xx2 紧凑型 | 所有KL3xx2 - 每个通道只能传送16 bit 输入数值 | 0x51 (in GSD file)
 |  | 0x50, 0x50 (alternatively)
KL3xx2 复杂型 | 旧型号的KL3xx2- 除了能够传送16 bit的输入值外,每个通道还能够传送24bits的输入/输出值用于寄存器连接访问. | 0xB5 (in GSD file)
 |  | 0xB2, 0xB2 (alternatively)
 |  | 0xF2 (alternatively)
KL3xx4 紧凑型 | 所有KL3xx4 -端子模块每个通道只能传送16bits的输入值. | 0x53 (in GSD file)
 |  | 0x51, 0x51(alternatively)
 |  | 0x50, 0x50, 0x50, 0x50 (alternatively)
KL3xx4 复杂型 | 旧型号的KL3xx4 - 除了能够传送16 bit的输入值外,每个通道还能够传送24bits的输入/输出值用于寄存器连接访问. | 0xBB (in GSD file)
 |  | 0xB5, 0xB5 (alternatively)
 |  | 0xB2, 0xB2, 0xB2, 0xB2 (alternatively)
 |  | 0xF5 (alternatively)
KL4xx2 紧凑型 | 所有KL4xx2 - 端子模块每个通道只能传送16bits的输出值. | 0x61 (in GSD file)
 |  | 0x60, 0x60 (alternatively)
KL4xx2 复杂型 | 旧型号的 KL4xx2 - 24 除了能够传送16 bit的输入值外,每个通道还能够传送24bits的输入/输出值用于寄存器连接访问. | 0xB5 (in GSD file)
 |  | 0xB2, 0xB2 (alternatively)
 |  | 0xF2 (alternatively)
KL4xx4 紧凑型 | 所有KL4xx4 - 端子模块每个通道只能传送16bits的输出值. | 0x63 (in GSD file)
 |  | 0x61, 0x61 (alternatively)
 |  | 0x60, 0x60, 0x60, 0x60 (alternatively)
KL4xx4 复杂型 | 旧型号的KL4xx4 - 除了能够传送16 bit的输入值外,每个通道还能够传送24bits的输入/输出值用于寄存器连接访问. | 0xBB (in GSD file)
 |  | 0xB5, 0xB5 (alternatively)
 |  | 0xB2, 0xB2, 0xB2, 0xB2 (alternatively)
 |  | 0xF5 (alternatively)
KL5001 紧凑型 | KL5001 - 端子模块每个通道只能传送32bits的输出值. | 0x93 (in GSD file)
 |  | 0xD1 (alternatively)
KL5001 复杂型 | KL5001 - 可以传送40 bits的输入/输出值,除此之外还能够传送40bit的输入值用于端子模块寄存器的访问连接. | 0xB4 (in GSD file)
 |  | 0xB5 (alternatively)
 |  | 0xF2 (alternatively)
KL5051 | KL5051 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL5101 | KL5101 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL5111 | KL5111 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL5121 | KL5121 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL5151 | KL5151 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL5302 | KL5302 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL6001 | KL6001 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL6011 | KL6011 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL6021 | KL6021 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL6051 紧凑型 | KL6051 - 只能够传送32位的输入bits和32位的输出bits. | 0xB3 (in GSD file)
 |  | 0xF1 (alternatively)
KL6051 复杂型 | KL6051 - 48位的输入bits和48位的输出bits传送, 除此之外还有40输入bits和40输出bits用于寄存器的连接访问. | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL6061 | KL6061 | 0xBA (in GSD file)
 |  | 0xF5 (alternatively)
KL6201 (PAB 6) | KL6201 - 6 bytes 输入和输出的进程数据的传送(ASI slaves 1-11) | 0x35 (in GSD file)
KL6201 (PRM PAB 6) | KL6201 - 6 bytes 参数接口和6 bytes输入和输出的进程数据的传送 (ASI slaves 1-11) | 0xF2,0x35 (in GSD file)
KL6201 (PAB 16) | KL6201 - 16 bytes输入和输出的进程数据的传送 (ASI slaves 1-31) | 0x3F (in GSD file)
KL6201 (PRM PAB 16) | KL6201 - 6bytes 参数接口和16 bytes输入和输出的进程数据的传送 (ASI slaves 1-31) | 0xF2,0x3F (in GSD file)
KL6801 | KL6801 | 0xB5 (in GSD file)
 |  | 0xF2 (alternatively)
KL8001 | KL8001 | 0xBB (in GSD file)
 |  | 0xF5 (alternatively)


Configuration of Digital Modules

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

数字化模块的配置

在复杂型端子模块(KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx) 已经被加载到总线耦合器(DP配置工具)中后,紧接着就是数字量模块,在加载数字量模块的情况下,只需要让数字量输入和输出的总和与实际所需通道的总和符合即可.

例:

4 x KL1408 = 32 digital input bits

2 x KL2408 = 16 digital output bits

3 x KL1114 = 12 digital input bits

2 x KL2114 = 8 digital output bits

4 x KL1012 = 8 digital input bits

1 x KL2012 = 2 digital output bits

=> 52 digital input bits and 26 digital output bits

下面是一些DP模块组合的可能情况,例如,现在将配置工具加载到总线耦合器中:

选择 1

8 digital input bits

8 digital input bits

8 digital input bits

8 digital input bits

8 digital input bits

8 digital input bits

8 digital input bits

8 digital output bits

8 digital output bits

8 digital output bits

8 digital output bits

选择 2

56 digital input bits

32 digital output bits

还有其他多种可能性,保证总的数字量输入为56(8的倍数大于52),以及数字量输入的总和为32bits(8的倍数大于26).


GSD Files

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

GSD 文件

GSD 文件的使用,一般是为了在DP配置工具中连接到 PROFIBUS 耦合器.

标准 GSD 文件

标准GSD文件包含了所有主站的重要的基本操作资料,总线耦合器能够通过GSD文件被参数化.

Bus Coupler | German | English | as from firmware
BK3000 | BK30becf.GSD | BK30becf.GSE | BN
BK3010 | BK3010.GSD | BK3010.GSE | B9
BK3100 | BK31bece.GSD | BK31bece.GSE | BT
BK3110 | BK3110.GSD | BK3110.GSE | B9
BK3120 | BK3120.GSG | BK3120.GSE | B9
BK3150 | BK3150.GSG | BK3150.GSE | B0
BK3500 | BK3500.GSD | BK3500.GSE | B9
BK3520 | BK3520.GSD | BK3520.GSE | B9
LC3100 | LC3100.GSD | LC3100.GSE | B9
BC3100 | BC3100.GSD | BC3100.GSE | C3

GSD 文件扩展

附加设置对某些应用来说是必须的,这些扩展的GSD文件包含了大量的参数化选项,应当指出的是,熟悉主站控制器以及beckhoff总线端子系统的知识是很有必要的.

Bus Coupler | German | English | as from firmware
BK3010 | BK3010x.GSD | BK3010x.GSE | B9
BK3110 | BK3110x.GSD | BK3110x.GSE | B9
BK3120 | BK3120x.GSG | BK3120x.GSE | B9
BK3150 | BK3150x.GSG | BK3150x.GSE | B0
BK3500 | BK3500x.GSD | BK3500x.GSE | B9
BK3520 | BK3520x.GSD | BK3520x.GSE | B9
LC3100 | LC3100x.GSD | LC3100x.GSE | B9
BC3100 | BC3100x.GSD | BC3100x.GSE | C3

注意 扩展 GSD 文件上的注释:

GSD 文件包含了最多244字节的输入, 输出和配置数据,这些是最大值,在默认值的下方有设置选项.

DP 缓存 | Default | Maximum size
Inputs | 128 | 244
Outputs | 128 | 244
Diagnostic Data | 64 | 64
Configuration data | 64 | 244

可以通过PrmData来调节尺寸大小, 长度修正为8字节.

Example:

如果需要增加输入数据的大小,那么其他的数据的大小就要减小来进行补偿.
如果有 20 x 4 通道的 KL3314 热电偶,那么在这个协议中有: 20 Bus Terminals * 4 channels * 2 bytes per channel = 20 * 4 * 2 = 160 bytes
160 字节比128 字节大,因此必须补偿.
Set PrmData 字节从12 bits 4-7 到15 dec或者0xF hex, 设置字节从37 到 160 (input data)以及 字节38 到96 (output data).


Configuration: Siemens S7 Controller

BECKHOFF Fieldbus Components: Configuration

Configuration: 西门子S7控制器

插入图像

为了在Siemens软件中将每一个映像分配给设备，以下的图像必须复制到Step7\S7Data\ncbmp 目录下。

Busklemn.bmp

Busklems.bmp

安装 GSD 文件

  • 在Step7 hardware 配置窗口 安装新的GSD文件。
  • 选择BECKHOFF GSD所在的目录，并且导入文件。
  • 你会在硬件目录Profibus DP\Other field devices\I/O下找到他们。


Configuration: Siemens S7 Controller BK3120

BECKHOFF Fieldbus Components: Configuration

配置: 西门子 S7 控制器 BK3120

BK3120参数

设置

参数 | Denomination
DPV1 service (类1) | DPV1 Services
Reaction to Bus Terminal 错误 | Reaction to Bus Terminal error
Terminal bus 诊断 | PROFIBUS diagnosis
Digital terminal 诊断数据 | Digital Bus Terminal diagnostics
Data 格式 | Data format
K-Bus 模式 | K-Bus update
Fast FreeRun 模式 | Fast FreeRun mode
Reaction DP 错误 | Reaction to fieldbus error
Reaction K-Bus 错误 | Reaction to K-Bus errors

BK3120模块配置 (数字量输入/输出)

例1:
1 x BK3120
10 x KL1xx4
1 x KL9100 (没有输入，因为这是完全被动型的总线端子)
11 x KL2xx4
1 x KL9010 (不必被加载, 因为这是一个终端,是完全被动的)
数字量字节的总和必须被遗弃加载进去.
数字量输入
10 x KL1xx4, i.e. 10 x 4 bits = 40 bits
40 bits / 8 = 5 bytes, i.e. 5 x 8 bits entered or 1 x 40 bits or 1 x 8 bits + 1 x 32 bits etc. (see Fig. 2 and Fig. 3)

数字量输出
11 x KL2xx4, i.e. 10 x 4 bits = 44 bits
44 bits / 8 = 5.5 bytes - rounded up to 6 bytes, i.e. 6 x 8 bits entered or 1 x 48 bits or 1 x 8 bits + 1 x 40 bits etc. (see Fig. 2 and Fig. 3)

Fig. 2: 单个字节的输入例程。 注：每单个字节需要一个字节的ConfigData.在 BK3120中最大可有64个字节的配置数据。

Fig. 3: 相关字节组输入例程。

BK3120模块配置 (复杂型和数字型输入/输出)

面向字节模块是第一个被映射近过程映像中的模块,因此所有的复杂型模块必须塞进一个总线耦合器中,有一些面向字节总线端子模块,能够在紧凑型和复杂型映射中区别开来.
复杂型-用户数据外加数据(诊断)以及控制数据(用于寄存器通讯)

最后，数字型号输入并四舍五入到整个字节。

Example 2.a:
1 x BK3120
2 x KL1012
1 x KL2022
1 x KL3312 compact mapping
1 x KL9010

Fig. 2a: Example of the KL3312 紧凑型总线端子

Example 2.b:
1 x BK3120
2 x KL1012
1 x KL2022
1 x KL3312 complex mapping
1 x KL9010

KL3312 复杂型总线端子例子


DPV1 Interface

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

DPV1 接口

在默认情况下, 一个MSAC_C1连接和一个带52数据字节的MSAC_C2连接(4 bytes DPV1 数据头加上 48 bytes 的用户数据) 是被支持的. MSAC_C1 连接是和循环连接一同被建立的, 它们可以通过UserPrmData被激活:

Byte | Bit | Value: 说明
0 | 7 | 1: MSAC_C1 连接建立

MSAC_C2 连接不仅能够被 C1 主站所操控 (与从站循环通讯) 还可以被C2 主站所操控(只能与从站循环通讯), 并且它有自己独立的连接建立, MSAC_C2连接的建立参数(Feature_Supported, Profile_Feature_Supported, Profile_Ident_Number, etc.)被进行检测.请求参数在回应中是对称的.

Slot_Number = 0 发送地址到 PROFIBUS 耦合器, Slot_Number > 0 则发送到功能模块上.

PROFIBUS 耦合器数据 (Slot_Number = 0)

耦合器相连接的数据通过索引被定位.

Index | Access | Description
1-2 | R/W | multi-configuration 模式下的模块分配
5 | R | 固件信息
9-19 | R/W | 设备配置 (Table 9)
90 | R | K-Bus情况(Table 90)
98 | R/W | 网络循环时间
99 | W | 命令: local bus reset, starting or stopping the internal cycle time measurement

功能模块数据 (Slot_Number > 0)

依据功能模块的类型,连接寄存器(最大4通道,每一个包含64寄存器)或参数 (只被一些功能模块所支持,这些数据的数目对于寄存器模块来说是不够的)

Accessing 寄存器

Index | Access | Length | Description
0-63 | R(/W) | 2 | 功能模块1通道中0-63寄存器
64-127 | R(/W) | 2 | 功能模块2通道中0-63寄存器
128-191 | R(/W) | 2 | 功能模块3通道中0-63寄存器
192-254 | R(/W) | 2 | 功能模块4通道中0-63寄存器

Accessing 参数

Index | Access | Length | Description
0 | R(/W) | 4-32 (必须被4整除) | 功能模块中参数0x0000-0x0007
1 | R(/W) | 4-32 (必须被4整除) | 功能模块中参数0x0008-0x000F
... | ... | ... |
127 | R(/W) | 4-32 (必须被4整除) | 功能模块中参数0x03F8-0x03FF


Assignment of the DPV1 Slot Number

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

the DPV1 Slot Number 分配

Slot_Number = 0 确定总线耦合器的数据地址, Slot_Number > 0 确定复杂型端子模块的数据地址 (寄存器或参数 (KL6201) :

Device | Slot number = 0 | Slot number > 0
BK3x20, BK3500 | 总线耦合器中的数据 | Slot_Number = 1: 第一个复杂型端子模块被安装在总线耦合器中(KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx) Slot_Number = 2: 第二个复杂型端子模块被安装在总线耦合器中 (KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx) etc.
BK3x10/LC3100 | 总线耦合器中的数据 | 不存在, 因为不论是BK3x10或者是LC3100 都不支持复杂型端子模块.


Module Assignment

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

模块分配

multi-配置模式最大能够配置128个模块 (端子模块, IE 模块等等.).这些被插入的模块在CfgData中配置的详细信息可以在被DPV1写和DPV1读.

Slot number | Index | Length | Data | Description
0 | 1 | 1-15 | Byte 0 (bit 0,1) | 单元 1分配 0: DP数据交换 (默认) 2: 禁止 (配置模块丢失)
 |  |  | Byte 0 (bit 2,3) | 单元 2分配 0: DP 数据交换 (默认) 2: 禁止 (配置模块丢失)
 |  |  | Byte 0 (bit 4,5) | 单元 3分配 0: DP数据交换 (默认) 2: 禁止 (配置模块丢失)
 |  |  | Byte 0 (bit 6,7) | 单元 4分配 0: DP数据交换 (默认) 2: 禁止 (配置模块丢失)
 |  |  | Byte 1 (bit 0,1) | 单元 5分配 0: DP数据交换 (默认) 2: 禁止 (配置模块丢失)
 |  |  | ... |
 |  |  | Byte 15 (bit 6,7) | 单元 64分配 0: DP数据交换 (默认) 2: 禁止 (配置模块丢失)
 | 2 | 1-15 | Byte 0 (bit 0,1) | 单元 65分配 0: DP数据交换 (默认) 2: 禁止 (配置模块丢失)
 |  |  | Byte 0 (bit 2,3) | 单元 66分配 0: DP数据交换 (默认) 2: 禁止 (配置模块丢失)
 |  |  | Byte 0 (bit 4,5) | 单元 67分配 0: DP数据交换 (默认) 2: 禁止 (配置模块丢失)
 |  |  | Byte 0 (bit 6,7) | 单元 68分配 0: DP数据交换 (默认) 2: 禁止 (配置模块丢失)
 |  |  | Byte 1 (bit 0,1) | 单元 69分配 0: DP数据交换 (默认) 2: 禁止 (配置模块丢失)
 |  |  | ... |
 |  |  | Byte 15 (bit 6,7) | 单元 128分配 0: DP数据交换 (默认) 2: 禁止 (配置模块丢失)


Firmware Information

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

固件信息

下面的固件信息,可以通过DPV1来读取,数据以Intel格式传送(低字节在前):

Slot number | Index | Byte | Description
0 | 5 | 0-1 | 总线耦合器号
 |  | 2-3 | 软件版本
 |  | 4-5 | 制造商 (table 0, register 245)
 |  | 6-7 | 耦合器类型 (table 0, register 246)
 |  | 8-9 | 总线耦合器类型 (table 0, register 247)
 |  | 10-11 | 预留


Terminal Composition

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

端子模块组成

该端子模块的组成可以通过DPV1来读取. 每个端子传送一个字，这个字中包含每个端子模块中包含复杂型模块(KL15xx, KL25xx, KL3xxx, KL4xxx, KL5xxx, KL6xxx, KL8xxx)的端子号,和一些数字类型的端子模块的长度和类型信息:

Bit | Value | Description
0 | 1bin | 数字量模块含有输入
1 | 1bin | 数字量模块含有输出
2-7 | - | 预留
8-14 | X | bits长度
15 | 1bin | 通常为1 1bin (指该模块为数字量模块)

读取端子模块组成

该终端组成在DPV1中如下:

Slot number | Index | Byte | Description
0 | 9 | 0-1 | 总线耦合器号
 |  | 2-3 | 端子1数值
 |  | ... | ...
 |  | 46-47 | 端子23数值
 | 10 | 0-1 | 端子24数值
 |  | ... | ...
 |  | 46-47 | 端子47数值
 | 11 | 0-1 | 端子48数值
 | ... | ... | ...
 | 18 | 46-47 | 端子239数值
 | 19 | 0-1 | 端子240数值
 |  | ... | ...
 |  | 30-31 | 端子255数值

端子模块组成检查

通过DPV1 Write来访问同样的数据，此时，总线耦合器拿写入的这个值和真值进行比较，如果数据不被采纳则返回一个负 DPV1 写响应，通过检查CfgData 可以使得端子配置的检查更精确 。这个长度必须符合table 9的标准。每一个包含进程数据2byte的端子模块必须被计算,不考虑表9的寄存器0的总线耦合器的确认。.

写入响应中的错误代码

Error_Code_1 | Error_Code_2
0xBE | 端子数
0xBF | 数据字节首字节错误


K-Bus Status

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

K-Bus 数据

K-Bus数据可以通过DPV1来读取,数据以Intel格式传送(低字节优先):

Slot number | Index | Byte | 说明
0 | 90 | 0-1 | Bit 0: Fieldbus errors
 |  |  | Bit 1: K-Bus error
 |  |  | Bit 2: Error on the Bus Terminal
 |  |  | Bit 3: Coupler error
 |  | 2-3 | In the presence of a coupler error: Error code
 |  | 4-5 | K-Bus error = 0: Bit length of the K-Bus
 |  |  | K-Bus error = 1: K-Bus error code (-> 诊断数据)
 |  | 6-7 | K-Bus error = 0: 端子数量
 |  |  | K-Bus error = 1: 跟随的总线端子号的K-Bus的错误时被检测. (-> 诊断数据)


Cycle Time Measuring

BECKHOFF Fieldbus Components: Parameterisation and Commissioning

循环时间测量

通过DPV1可以读取 process data cycle 的持续时间.

周期时间的测量通过DPV1启动和停止的.

Slot number | Index | Length | Data | Description
0 | 99 | 4 | Byte 0: 0x04 | 开始周期时间的测量
 |  |  | Byte 1: 0x01
 |  |  | Byte 2: 0x01
 |  |  | Byte 3: 0x00
0 | 99 | 4 | Byte 0: 0x04 | 停止周期时间的测量
 |  |  | Byte 1: 0x01
 |  |  | Byte 2: 0x00
 |  |  | Byte 3: 0x00

最大值,最小值,平均值(最后200周期)和电流循环周期能够通过DPV1来读取,或者通过DPV1的写来重置:

Slot number | Index | Length | Data | Description
0 | 98 | 8 | Byte 0, 1 | 最小循环周期 µs (INTEL 格式, 从低字节开始)
 |  |  | Byte 2, 3 | 最大循环周期 µs (INTEL 格式, 从低字节开始)
 |  |  | Byte 4, 5 | 平均循环周期 µs (INTEL 格式, 从低字节开始)
 |  |  | Byte 6, 7 | 电流循环周期 µs (INTEL 格式, 从低字节开始)


Reaction to PROFIBUS Error

BECKHOFF Fieldbus Components: Diagnosis and Error Handling

PROFIBUS的错误响应

DP看门狗溢出（一般在100毫秒，除非在主站使它无效化）或者总线超时后（波特率的监督时间设置为10秒），检测PROFIBUS错误（主站错误，PROFIBUS插头被拔出等）。

耦合器输出数据的反应可以在UserPrmData设置：

Byte | Bit | Value | Description
10 | 0-1 | 00bin | PROFIBUS错误响应：K总线周期遗失（默认情况下，数字输出变成0，复杂的输 出为设置的值）
 |  | 01bin | PROFIBUS错误响应：K总线输出变为0
 |  | 10bin | PROFIBUS错误响应：K总线输出保持不变


K-Bus Interruption

BECKHOFF Fieldbus Components: Diagnosis and Error Handling

K-Bus 中断

如果K-Bus中断，或经历一个长时间的故障，耦合器进入K-Bus错误状态。根据在UserPrmData中设置的K-Bus错误响应，耦合器禁止DP数据交换，并在下次DP启动阶段在诊断数据中把Stat_Diag位置位（与DP数据交换的结果不执行），设置DP输入为0，或保持DP输入不变。

Byte | Bit | Value | Description
10 | 2-3 | 00bin | K-Bus错误响应：DP数据交换是被禁止的（默认）
 |  | 01bin | K-Bus错误响应：DP输入设置为0
 |  | 10bin | K-Bus错误响应：DP输入保持不变

当中断或在K-Bus故障已得到纠正时，在UserPrmData中K-Bus错误响应的设置决定是否K-Bus错误状态是手动（通过K-Bus总线复位方式），或自动：

Byte | Bit | Value | Description
7 | 0 | 0bin | K总线错误响应：手动K-Bus复位（默认）
 |  | 1bin | K总线错误响应：自动K-Bus复位

K-Bus错误信号

K-Bus错误在I/O错误指示灯和在 DP 诊断数据中DPV1状态报文中（字节11-13）都有显示。

Byte | Bit | Description
11 | 0 | 太多的K-Bus命令错误
11 | 1 | 太多的K-bus超时
11 | 2 | 太多的K-bus接收错误
11 | 3 | 太多的K-bus传输错误
11 | 4 | K-Bus复位错误
11 | 5 | 一般的K-Bus错误
12 | 0-7 | K-Bus错误代码
13 | 0-7 | K-Bus错误参数

K-Bus复位

K-Bus可以通过写DPV1的方式手动复位：

Slot number | Index | Byte | Value
0 | 99 | 0 | 2
 |  | 1 | 1
 |  | 2 | 0
 |  | 3 | 0


Approvals

BECKHOFF Fieldbus Components: Appendix

认证

UL E172151

依据标准

CE

防护等级

IP20 in accordance with EN60529


Bibliography

BECKHOFF Fieldbus Components: Appendix

参考文献

德文版

PROFIBUS

  • PROFIBUS-DP/DPV1
    Grundlagen, Tipps und Tricks für Anwender (Principles, Tips for Users)
    by Manfred Popp
    ISBN: 3778527819

一般现场总线技术

  • Gerhard Gruhler (Pub.): Feldbusse und Geräte-Kommunikationssysteme (Fieldbus and Device Communication Systems)
    Praktisches Know-How mit Vergleichsmöglichkeiten (Practical Know-how with Comparative Resources)
    Franzis Verlag, 2001
    244 pages
    ISBN 3-7723-5745-8

英文版

(in preparation)

PROFIBUS-DP 标准

  • IEC 61158 and IEC 61784
  • DIN 19245, Part 3
  • Euronorm EN 50 170

Web sites

  • http://www.profibus.com


Support and Service

BECKHOFF Automation: Appendix

技术支持和服务

Beckhoff 及其合作伙伴活跃于世界各地，提供全方位的技术服务和技术支持，确保快速协助解决与 Beckhoff产品和系统解决方案相关的所有问题。

Beckhoff 的分支机构及代表处

有关 Beckhoff 产品的任何问题，请与负责本地技术支持与技术服务的 Beckhoff 分支机构或代表处联系!

有关 Beckhoff 分布在世界各地的分支机构及代表处的地址，请见公司官方网页：http://www.beckhoff.com.cn

公司网站还提供更多有关Beckhoff 组件信息的文档资料。

Beckhoff 总部

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com

Beckhoff 技术支持

Beckhoff 可为您提供全面的技术支持，除了Beckhoff 具体产品的应用之外，还提供更广泛的服务：

  • 全球技术支持
  • 复杂自动化系统的设计、编程和调试
  • Beckhoff 系统组件培训方案
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心为您提供的售后服务：

  • 现场服务
  • 维修服务
  • 备件服务
  • 热线服务
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


BECKHOFF Fieldbus Components: Product Overview

The principle of the Bus Terminal


DPV1 Functionality

BECKHOFF Fieldbus Components: DPV1

Assignment of the DPV1 Slot_Number

Slot_Number = 0 addresses IL/IP coupler data, Slot_Number > 0 addresses the registers of the function module(s).

Device | Slot number = 0 | Slot number > 0
ILxxxx-B310 | Data in the IL coupler | Slot_Number = 1: first complex IE module to be inserted into the optical fibre ring (IE15xx, IE25xx, IE3xxx, IE4xxx, IE5xxx, IE6xxx, IE8xxx) Slot_Number = 2: second complex IE module to be inserted into the optical fibre ring (IE15xx, IE25xx, IE3xxx, IE4xxx, IE5xxx, IE6xxx, IE8xxx) etc.
IP15xx-B310, IP25xx-B310, IP3xxx-B310, IP4xxx-B310, IP5xxx-B310, IP6xxx-B310 | Data in the IP coupler | Slot_Number = 1: Function module registers
IP10xx-B310, IP20xx-B310, IP23xx-B310, IP24xx-B310 | Data in Bus Coupler | Not present, since function modules do not have any registers


PROFIBUS Cabling

A PROFIBUS cable (or a cable segment when using repeaters) can be checked with a few simple resistance measurements. The cable should meanwhile be removed from all stations:

  1. Resistance between A and B at the start of the lead: approx. 110 Ohm
  2. Resistance between A and B at the end of the lead: approx. 110 Ohm
  3. Resistance between A at the start and A at the end of the lead: approx. 0 Ohm
  4. Resistance between B at the start and B at the end of the lead: approx. 0 Ohm
  5. Resistance between screen at the start and screen at the end of the lead: approx. 0 Ohm

If these measurements are successful, the cable is okay. If bus errors still occur, however, these will generally be due to EMC interference, in which case refer to the PROFIBUS user organisation installation instructions (www.profibus.com).


DPV1 Functionality

BECKHOFF Fieldbus Components: DPV1

Other Commands

Manufacturer's setting

The manufacturer's settings are made with DPV1 (write) with the following DPV1 parameters:

Slot number | Index | Byte | Value
0 | 99 | 0 | 1
 |  | 1 | 4
 |  | 2 | 0
 |  | 3 | 0


BECKHOFF Fieldbus components: Parameterisation and commissioning

Configuration with S7

In development.