标题

BECKHOFF CX1100-09xx: CX10x0系统的UPS模块

说明书：

CX10x0系统的UPS模块

CX1100-0900 (550 mA / 20 As)

CX1100-0910 (1.1 A / 20 As)

CX1100-0920 (1.1 A / 40 As)

CX1100-0930 (2.0 A / 40 As)

版本: 1.4
日期: 2009-03-23


文档说明

本说明书仅供那些在控制与自动化工程方面受过适当培训且熟悉各种适用国家标准的专业人士使用。
在安装和调试这些组件时，操作人员必须严格遵循下列说明和解释。

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

责任条款

尽管本文档经过精心编制， 但由于其中所描述的产品仍处于不断更新换代中，
我们可能不会在每次更新后都检查文档中所描述的产品性能数据、标准或其它特性总是与实际产品相一致。
本文档中难免会出现一些技术或者编辑错误，我们保留随时对文档信息作出修改之权力，恕不另行通知。
对于已经变更的产品，如果本文档中的数据、图表以及文字描述没有修改，我们将不再特别加以声明。

商标

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® 已为Beckhoff 自动化有限公司的注册商标
本手册中所使用的其它名称可能是商标名称，任何第三方为其自身目的而引用，都可能触犯商标所有者的权利。

申请中的专利

TwinCAT 技术受下列专利申请书和专利权（包括但不限于）的保护：
在许多其他国家有关EP0851348, US6167425的相关申请和注册。

版权声明

© 德国倍福自动化有限公司.
未经德国倍福自动化有限公司书面许可，任何人不得部分或整个复制或者允许第三方使用本手册。
若发生违反行为 , 须履行损失赔偿义务。 德国倍福自动化有限公司保留所有发明、实用新型和外观设计专利权。


安全说明

安全规程

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

配送状态

所有组件在供货前均针对其具体应用进行了特定的软、硬件配置。 任何人不得对软、硬件配置进行文本档中规定之外的修改，德国倍福自动化有限公司对因此而造成的一切后果不承担任何责任。

人员资质

本说明书仅供那些在控制与自动化工程方面受过适当培训且熟悉各种适用国家标准的专业人士使用。

安全标志的说明

下列安全标志使用本操作手册。提醒读者相关的安全说明。

危险

这个标志是为了突出个人生命和健康的风险。

警告

这个标志是为了突出设备，材料或环境的风险。

说明

该标志表示这些信息能够帮助您更好地理解安全说明。


说明书版本说明

版本 | 变化
1.4 | 添加新的UPS CX1100-0930
1.3 | 新添加的CX系统的使用
1.2 | 负责更正技术数据
1.1 | CX1100-0900和CX1020的使用说明
1.0 | 发布 版本
0.4 | 添加许可证及修订放电图
0.3 | 采取/小修正
0.2 | 修订版
0.1 | 初步 版本


正确使用

CX10x0设备系列是采用顶部导轨安装设计的模块化控制系统。该系统具有可扩展性，可以使所需模块组装和安装在控制柜或符合要求的接线盒上。

UPS模块用于支持CX10x0嵌入式PC及其总站。


CX1100-09xx: 系统概览

BECKHOFF CX1100-09xx: 系统概览

系统概览

UPS模块有四个版本。

  • CX1100-0900
  • CX1100-0910
  • CX1100-0920
  • CX1100-0930

UPS 模块用于给 CX CPU 及其连接的 CX 组件提供不间断电源。 在外部电源出现故障时，该模块可确保应用软件能够保存重要的数据，例如保存在 CF 卡或 NOVRAM 上，或者通过网络保存在数据库中。 在 UPS 保持供电期间，机器或过程将被转为一个设定状态，此时可以关闭操作系统。 UPS 的保持时间可通过旋转开关或软件来设置。 与采用其它电池供电技术不同，该 UPS 模块采用了最新的电容器，绝对免维护，并能快速充电。 该模块与 CX 系统的连接也非常简便，只需一根 24 V DC 电源线。 UPS 的 24 V DC 输出具有过载和短路保护功能。 CX1100-09x0 可以在现场进行调整。 DPRAM 用户接口可用于设置选项和 UPS 状态信息。 UPS 的功能与所使用的操作系统无关。 不需要驱动软件。TwinCAT 系统管理器可自动识别 UPS 模块，并将 UPS 信号提供给 PLC 编程人员。 需要一个最小输出电流为 4 A 的 24 V DC 电源模块。

UPS模块的设置：

样例配置1：

样例配置2：


CX1100-09xx: 技术参数

BECKHOFF CX1100-09xx: Vorwort
BECKHOFF CX1100-09xx: 技术参数

技术数据CX1100-0900, CX1100-0910, CX1100-0920, CX1100-0930

UPS的模块有四个版本。用户可以根据需要选择合适的版本。该表显示了不同点和相同点：

技术 数据 | CX1100-0900 | CX1100-0910 | CX1100-0920 | CX1100-0930
电源供电 | 24 V DC （ -15 %/+20 % ）
存储技术 | 电容式
电容 | 20 As | 20 As | 40 As | 40 As
保持时间 | 可调负载
输出电流最大。 | 24 V DC) | 24 V DC) | 24 V DC) | 24 V DC)
充电电流 | 最大值 4 A
诊断 LED | 24 V直流输入，24 V直流输出，充电
系统总线 | 16位ISA（PC104标准）
最大功耗 | 2 W
尺寸 (W x H x D) | 57 mm x 100 mm x 91 mm | 76 mm x 100 mm x 91 mm | 95 mm x 100 mm x 91 mm | 95 mm x 100 mm x 91 mm
重量 | 大约 345 g | 大约 465 g | 大约 617 g | 大约 650 g
工作温度 | 0 °C ... +55 °C
储藏温度 | -25 °C ... +85 °C
相对湿度 | 95%，无冷凝
抗振 / 抗冲击性能 | 符合 EN 60068-2-6/EN 60068-2-27/29 标准
EMC 防爆性 / ESD | 符合 EN 61000-6-2/EN 61000-6-4 标准
防护等级 | IP 20

说明

CX1100-0900U中UPS模块的最大输出电流为550毫安！

可使用UPS模块（CX1100-0910/ CX1100-0920）来获得更高的输出电流。

对CX1020嵌入式PC来说需要更大输出电流所以强烈推荐使用UPS模块（CX1100-0910/ CX1100-0920），来获得更大的输出电流。


连接

BECKHOFF CX1100-09xx: 连接

CX1100-09xx 连接

UPS模块由5个引脚供电 “开放式可插拔连接器”。嵌入式系统的其他组件由PC104 24V直流总线供电。（-15％至+20％的公差）

引脚分配 ：

引脚 | 分配
5 | 0 V直流输出（UPS输出电流）
4 | 24 V直流输出（UPS 输出电流）
3 | PWR故障（数字输出）
2 | 0 V直流输入（UPS进电 ）
1 | 24 V直流输入（UPS进电）

连接电源

与K总线/ E总线相连的电源（CX1100-0002，CX1100-0003 和 CX1100-004）供电如下：

因为CX1100-0001电源没有终端总线接口，只有连接到模块上的输入接口（24V）。 旧版本电源标记为UPS -/+。其他输入接口不需要接线。该图显示了正确的连接方法。

电源故障信号连接

UPS模块也可以给其他总线耦合器供电。电源接到UPS模块再连到总线耦合器。给端子模块的电源必须另外供电。这取决于端子模块的负载。数字输入端应与电源故障相连。（见下图）

万一电源发生故障，UPS模块会发出电源故障信号。PLC程序通过端子模块读取输入并且关闭设备。在这种模式下，UPS模块的控制由模块前面的旋钮开关控制。


技术参数

BECKHOFF CX1100-09xx: 技术参数

技术数据CX1100-0900, CX1100-0910, CX1000-0920, CX1100-0930

根据不同的性能和操作系统，CX系统中不同的CPU模块需要不同的UPS模块。下表显示了推荐的CPU和UPS模块组合只包括了CPU模块和系统接口，端子模块不包括在范围内。

CX System | CX1100-0900 | CX1100-0910 | CX1100-0920 | CX1100-0930
CX9000 (with WINDOWS CE) | 有* | 有* | 有* | 有*
CX9010 (with WINDOWS CE) | 有* | 有* | 有* | 有*
CX1000 (with WINDOWS CE) | 有 | 有 | 有 | 有
CX1000 (with WINDOWS XP) | 有 | 有 | 有 | 有
CX1010 (with WINDOWS CE) | 有 | 有 | 有 | 有
CX1010 (with WINDOWS XP) | 有 | 有 | 有 | 有
CX1020 (with WINDOWS CE) | 不可以 | 不可以 | 有 | 有
CX1020 (with WINDOWS XP) | 不可以 | 不可以 | 有 | 有
CX1030 (with WINDOWS CE) | 不可以 | 不可以 | 不可以 | 有
CX1030 (with WINDOWS XP) | 不可以 | 不可以 | 不可以 | 有

*此时只 发出失败信号 （参见连接）

说明

CX1100-092中UPS模块最大 输出功率 是1.1A！

对于CX1030系列嵌入式PC来说需要更大的输出功率 。
如果CPU需要UPS，此时只需要给UPS提供标准电源。


拆箱，安装和运输

必须遵守特定的的储存条件（见“技术数据”）。

各模块的尺寸和重量：

模块 | CX1100-0900 | CX1100-0910 | CX1100-0920 | CX1100-0930
尺寸 (W x H x D) | 57 mm x 100 mm x 91 mm | 76 mm x 100 mm x 91 mm | 95 mm x 100 mm x 91 mm | 95 mm x 100 mm x 91 mm
重量 | 345 g | 465 g | 617 g | 650 g

开箱

拆封如下单位：
1. 拆开包装。
2. 请勿丢弃原包装。为将来的运输保存它。
3. 通过对比您手中的订单，检查配送是正确。
4. 请保存相关文书。它包含设备的重要信息。
5. 检查内容，是否有明显的运输损坏。
6. 如果您发现任何运输损坏或与您的订单有不一致的内容，您应该通知Beckhoff。

警告 |
 | 设备损坏的危险！

在寒冷条件下运输，或者如果单位将遭受极端温度的变化，必须避免设备内部凝露。
操作之前，必须允许设备慢慢调整到室温。若设备内部已凝露，应至少经过12小时才将设备通电。

安装方式

此设备安装在控制柜中。 你会发现机械安装一章中有安装说明。

运输

尽管有着可靠的包装，但是部件还是经受不起剧烈冲击。因此，在运输过程中，您的计算机应该被保护免受过度的机械应力。因此，请使用原包装。


外形尺寸

CX10x0产品的特点是体积小和高度模块化。一个完整的配置包括CPU模块，电源及相关的系统接口和现场总线接口。设备的总宽由多个模块组合而成。高度为100毫米，与Beckhoff端子模块一样。再加上连接器的高度，可以装在高度为120毫米的标准接线盒。

CX10x0系列中的三个UPS模块尺寸不相同：

CX1100-0900 UPS Module:

CX1100-0910 UPS Module:

CX1100-0920 UPS Module:

CX1100-0930 UPS Module:


接头和配线

BECKHOFF CX1100-09xx: 接头和配线

UPS模块的机械安装

UPS模块可以在任何位置与嵌入式PC系统相连。建议将它放在CPU基本模块和电源设备之间。系统概述（见图片）

0. 关闭和断开电源

在拆除CX10x0系统前，应关闭该系统，并断开电源。

1. 从导轨卸下：

在CX10x0模块断开前，整个CX1020硬件块应从导轨拆下。步骤如下：

1.1. 拆除在电源模块旁的第一个端子。

首先去除电源模块和电源模块旁端子模块的所有接线。如果接线将重复用于另一个系统，最好做一个连接说明。拉动橙色拉条并将其拉出（见箭头）将端子解锁。

1.2. 拆下CX10x0系统

为了拆下CX10x0块，在底部的模块中的箭头方向拉的白色锁扣。他们将锁定在拉出的位置中。当拉动的锁扣将电源解锁后，就可以小心地 将模块从导轨拆下。

1.3 分离电源模块，CX10x0的CPU和其他部件

将CX10x0模块正面朝下放置。然后将一字形螺丝刀（尺寸为1.0×5.5×150毫米）插入到锁定机制中，转动约90度，移动滑块。模块间将会出现2-3毫米缝隙。然后可以小心地拉开PC104接口的插头。

2 CPU基本模块，UPS和电源的装配

2.1 CX10x0系统模块的装配

各个模块简单地插在一起。PC104连接器的插头应小心处理，以避免损坏。正确的连接是模块之间没有可见的缝隙。

2.2 装在导轨上

在导轨顶部上装上系统模块之前，用户应推进所有白色锁扣。用户应留有端子模块和嵌入式PC系统之间的空间。 必须要保证能够重新安装拆除的端子模块。

然后使用锁扣固定CX1020在导轨上。你会听到轻轻的咔嗒声。

不要对模块施加过大的压力！

只需外壳边沿施加一点压力。不要将压力作用于CX10x0系统的显示器，按钮和移动部件。

成功固定在导轨上后，白色锁扣要推进去。

2.3 将嵌入式PC连接到端子模块总线

重新安装拆掉的端子模块后，系统将连接到总线上。

最后重新接线。拆掉的端子模块像以前一样重新连接。现在通过UPS连接电源。（详见本章连接）


CX1100-09xx: 充电时间

BECKHOFF CX1100-09xx: 充电时间

充电时间

UPS模块的充电时间取决于实际使用情况，并不能准确测量。可以估算“最大的充电时间”。这个时间是指，经过完全放电后存储单元的充电时间。这个测试系统经过了一整晚的放电。然后对系统启动的时间进行了测量。下表显示测量结果。

充电时间
模型 | 充电时间
CX1100-0900 | 42秒
CX1100-0910 | 46秒
CX1100-0920 | 116秒
CX1100-0930 | 65秒

说明 |
 | 此时间是平均值。在操作过程中必须添加放电时的时间。在"No Abort"模式中，例如：在开始充电前，存储单元将先放电。


CX1100_09xx放电性能

BECKHOFF CX1100-09xx: 放电时间

放电时间

不同UPS模块放电时间的测试 ，UPS与一个负载相连。此时间的测试取决于负载和开关设置。下方图片显示了所测试的配置。

开始测试程序。模块完全充电后发出30秒长的信号（充电时发出绿光）。通过断开开关，UPS电源断开。在同一时间，触发时钟。当模块前方的LED灯熄灭时，停止测试。已经完成了几个系列的测试下图显示了与开关设置相关的时间。当CX1100-0900满负荷运行。

说明

UPS模块CX1100-0900的最大输出电流为550毫安！

对于更高的输出电流需使用UPS模块（CX1100-0910/ CX1100-0920）。

CX1020嵌入式PC需要更大的输出电流。所以推荐使用UPS模块（CX1100-0910/ CX1100-0920），以获得更大的输出电流。

UPS模块有一个1100毫安的最大负荷。结果如下所示。

开关设置为0的时间。

为了最大限度放电，开关需设置为0。按步骤，此负载增加了50毫安。曲线显示了测得的持续时间。

实例配置与测量

对一个实际负载来说，一些嵌入式PC的配置已经过测试。测量与开关设置有关的持续时间。第一次测试是采用CX1000系统（CX1000-0111）的典型配置。只有系统接口N001与基本系统相连。K总线也由UPS供电。一个数字输入和一个数字输出端子模块连接到总线上。系统配置 如图所示。

持续时间是：

第二次测试是嵌入式PC的最大配置。CX1000系统（CX1000-0122）与系统接口N001 (2个USB接口, DIV)，N002（2个RS232接口），N003（音频）的M200（IP-Link的主站）和M319（Profibus主站）。键盘与集线器和大容量存储设备连接到USB端口作为负载。系统配置如下所示。

光导总线由光纤电缆短路。PROFIBUS主站连接到端子模块BK3100。测量与开关设置相关的持续时间。

第三次测试是一个包括CX1020系统（CX1020-0120）。典型配置。只有系统接口N010与基本模块相连。端子模块总线是一个E-bus。一个数字输出端子模块连接到总线上。

结果如下：

接下来测试CX1020系统的最大配置。此测试连接与测试2相同。

持续时间是：

最后测试的是CX900系统（CX9000-0002）。典型配置。视频，USB和串行接口与基本系统相连。连接到USB端口的负载和以前一样。

持续时间是：


CX1100-09xx: UPS模块的持续时间

BECKHOFF CX1100-09xx: 持续时间

设置保留时间

通过力矩开关设定保留时间。

开关/位置 | 持续时间
0 | 100 %
9 | 90 %
8 | 80 %
7 | 70 %
6 | 60 %
5 | 50 %
4 | 40 %
3 | 30 %
2 | 20 %
1 | 10 %

位置为0（= 100％），表示UPS可满负荷运行。根据所连接的负载，可以确保电源正常供电几分钟。如果所连系统快速关闭，时间就会缩短。如果系统快速关闭，可以加速重启。

说明
持续时间应该比系统关闭时间持续更长。

建议预留安全运行的时间（在XPE关机时间上加20-30％）

也可以在TwinCAT系统管理器中设置持续时间。

“在系统管理器中的UPS模块设置”中可以找到帮助说明。


CX1100-09xx: 寄存器

BECKHOFF CX1100-09xx: 寄存器

寄存器设置CX1100-09xx

 |  | 7位 | 6位 | 5位 | 4位 | 3位 | 2位 | 1位 | 0位
0x0D1010 | 输入-寄存器 | State_3 | State_2 | State_1 | State_0 | 保留 | 保留 | 24V_IN_OK | 24V_OUT_OK
+1 | 充电状态 | C7 | C6 | C5 | C4 | C3 | C2 | C1 | C0
+2 | 输出-寄存器 | IRQ3 | IRQ2 | IRQ1 | IRQ0 | AUTO_RES | DIP_DIS | 保留 | 关闭输出
+3 | DIP-数据 | D7 | D6 | D5 | D4 | D3 | D2 | D1 | D0
+4 | 标识符0 | "C" (ASCII)
+5 | 标示符1 | "X" (ASCII)
+6 | 标示符2 | "11" (DEC)
+7 | 标示符3 | "90" (DEC)

段基址0D1010

C =充电状态 0% = 00h, 100% = FFh

IRQ =IRQ二进制数表示; 0000 = 禁用

DIP_DIS = 1 : DIP-DATA关闭DIP开关

AUTO_RES = 1 : 自动重启（断电后关闭）

警告

系统关闭前， AUTO_RES 位必须重置为“0”！。

四位状态位的含义：

值 | 状态
0 | 没有功能
1 | 充电
2 | 充满电
3 | 放电
4 | 放电并且重启
5 | 关闭输出
6 | 过载
7 | 不使用
8 | 不使用
9 | 不使用


CX1100-09xx: 启动UPS模块-系统管理器

BECKHOFF CX1100-09xx: 配置UPS模块-系统管理器

在系统管理器中设置

将CX1100-0900 UPS模块作为"Box"插入在下CX1100模块下。如何添加硬件的详细说明，请看TwinCAT系统管理器的说明。

当TwinCAT在配置模式下自动将模块扫描上来后，UPS将自动添加进去。

"General" tab:

显示所选设备的常规信息。UPS模块的输入和输出将显示在左侧的浏览器窗口中。可以用于处理来自PLC的UPS。

在TwinCAT系统管理器的文件中，可以看到设置选项的详细说明。

有两种完全不同的控制UPS模块的方法。第一种方式是直接在TwinCAT系统管理器中进行操作设置。在这种情况下，不需要从PLC程序中进行任何其他控制。在程序中，可从UPS的状态信号进行评估。另一种方式，可以从PLC程序中进行控制。在是题为“从PLC控制的UPS”一节中有详尽的描述。通过TwinCAT系统管理器的操作，如下所述。

用TwinCAT系统管理器操作UPS。

两种操作UPS的配置在系统管理中：

配置1:

激活"Enable Automatic Shutdown"，但 不激活 "No Abort"：

“CX1190 UPS”选项卡：

Enable Automatic Shut Down:

如果此开关被选中，经过了可调的持续时间后TwinCAT将停止，“Windows XPe”将关闭。当经过持续时间后，设备1（这里CX1100）将被关闭。即使电源故障的时间很短（<<10s）系统和CX也将关闭。

故障：在TwinCAT停止后，如果电压恢复，“Windows XPe”仍在关停的过程中，CX仍在运行，“Windows XPe”将会保持在关闭状态。

UPS又进入充电状态。长为了使UPS有足够长的时间关掉，必须关闭电压，只有如此才能重启系统。

配置2：

激活"Enable Automatic Shutdown"和 "No Abort" ：

“CX1190 UPS”选项卡：

Enable Automatic Shut Down:

如果此开关被选中，经过了可调的持续时间后TwinCAT将停止，“Windows XPe”将关闭。当经过保留时间后，设备1（这里CX1100）将被关闭。即使电源故障的时间很短（<<10）系统和CX也将关闭。

不退出：

在TwinCAT停止后，如果电压恢复，“Windows XPe”仍将关闭，CX10x0仍将重启。

如果STAYING是OFF，如上（选项1）不会被激活。一旦UPS再次充满电,CX将再次启动。

故障： 不论何种情况，即使停电时间极短，CX10x0也将重启。

使用系统管理器去设置持续时间

通过UPS面板前的旋转开关设置UPS的持续时间。关于这个细节可以查阅开关的技术说明。可以忽略此设置，并通过系统管理器设置UPS的持续时间。这是通过选择 "Override DIP Switch"对话框来实现的。这里的 "DIP Switch"复选框被激活。可以选择从0到9这些值。此值对应旋转开关的设置。旋转开关的位置不会有任何影响。

激活设置

一旦作出所有所需设置，配置必须通过系统管理器激活。在TwinCAT系统管理器的文档中，你会看到进一步的解释。


通过PLC程序控制

BECKHOFF CX1100-09xx:通过PLC程序控制。

PLC程序控制UPS 。

可以用PLC程序控制UPS模块。有两个TwinCAT功能块可以控制。允许PLC程序处理电源故障。首先要在TwinCAT系统管理器中做一些设置，使UPS包括进来。UPS模块集成在TwinCAT系统管理器中，在在系统管理器中设置。做一些必要的设置使PLC可以得到控制。控制器先在系统管理器中停掉。把UPS硬件的输入和输出连接到PLC程序中相应变量。输入和输出必须在程序中声明为全局变量。（进一步详情如下。）首先要对系统管理器中的设置进行说明。

必要的系统管理器中设置：

- 每个都必须设置为OFF！换句话说，CX1190的UPS“选项卡上，既不启用 "Enable Automatic Shutdown" ，也不启用 "No Abort"。

- 此外，系统管理器中的两个输入 (24V State and Charge State)和输出(Control and DIP Control) ，必须在PLC中与相应变量的UPS块相连接。

插图显示了在系统管理中的UPS。UPS的输入和输出，将在过程映像和硬件树形列表中看到。

通过双击关联的信号。连接是为了功能块在PLC程序中正常运行。只有在程序被编译完以后，才会有PLC过程变量。在连接UPS控制块前 ，必须先导入PLC程序。

连接信号的方法，详见TwinCAT系统管理器的文档中。

将UPS控制块链接到PLC程序中：

UPS是由 TC CX1000System.lib中的FB_CX1000SimpleUps功能块控制的。如果这项工作已经完成，该块可作为一个功能块。在程序的声明部分它作为实例。

PROGRAM MAIN_UPS VAR UPS : FB_CX1000SimpleUps; END_VAR

然后程序同其参数一起被调用。此功能块有三个参数：

  • bDIPDisable : BOOL;
  • iDischargeLevel : USINT;
  • tDelay : TIME;

"tDelay" 设置在UPS关闭PLC前最大持续时间。这里允许的条目在0到10秒之间。布尔表达“bDIPDisable”允许忽略UPS上的旋转开关设置。如果值是"TRUE"，则由“iDischargeLevel”设置的值被用作有效的持续时间。调用如示：

UPS（bDIPDisable：= TRUE时，（* DIP开关为TRUE*）iDischargeLevel：= 30，（*值从0.1...9*）TDELAY：=t#5S（*关机前的持续时间 t#0..t#10*））;

为了功能块运行，与TwinCAT系统管理器中相连的信号必须被创建成变量。当过程映像被读入到系统管理器中时，这是自动完成的。在连接过程中，将地址存储到“TwinCAT配置”文件中，下次调用编译器时将其引入。（在TwinCAT的描述中，可以看到更详细的描述。）另外，可以手动分配地址。编译完成后，将显示丢失配置的警告。通过"Insert -> All instances"菜单项，信号被插入到“变量配置”文件中。这里的信号是能够访问地址的。(例如 MAIN.UPS.Li24VState AT %IB0 : BYTE for memory address 0).

VAR MAIN.UPS.Ii24VState AT %IB0 : BYTE; MAIN.UPS.IiChargeState AT %IB1 : BYTE; MAIN.UPS.QiControl AT %QB0 : BYTE; MAIN.UPS.QiDipControl AT %QB1 : BYTE; END_VAR

该块提供了几个状态信号去评估程序环境。这些可以被用于控制，例如：将过程数据保存在NVRAM中，或者设置定义的状态和轴的位置。详细地，块提供了下列信号：

  • bPowerFailure : BOOL;
  • bShutdownActive : BOOL;
  • bUpsReady : BOOL;
  • b24VInOK : BOOL;
  • bHolding : BOOL;
  • tTimeUntilShutdown : 时间;
  • eUpsState : E_UPS_STATE

当电源电压被检测出故障时，“bPowerFailure”返回“真”。当输入电压恢复时，信号变回“FALSE”。

"bShutdownActive"表示，正在执行停止或关闭。

"bUpsReady"表示，UPS正在提供输出电压。

“b24VInOK”表示，UPS正在使用24V输入电压。

当电源电压发生故障时，持续时间尚未结束，“bHolding”返回“TRUE”。

“tTimeUntilShutdown”表示直至关机为止，还剩余的保留时间。

“eUpsState”显示UPS的|充电|带电|放电|放电复位| 关闭输出|超负荷|等状态。

说明

功能块短时间断电不会关机，但更长时间的供电故障将引起TwinCAT停止，并且操作系统关闭。

  • 当CX10x0达到放电的极限时，UPS会将其关闭。此时，即使再有电流流入也不能让其重新运行。
  • 一旦UPS完全充电，将再次启动CX10x0。

UPS可以采取不同的操作行为，例如具有更长的持续时间，复位总线，或重新启动PLC，即使停电时间很短。可以使用TC CX1000System.lib 中的FB_CX1000UPSHANDLING功能块。然而，这个库必须由库管理进行整合。如果这项工作已经完成，该块就可以作为一个功能块来使用。它是实例，例如在程序的声明部分。

PROGRAM MAIN_UPS VAR UPS : FB_CX1000UPSHANDLING; END_VAR

然后从程序及其参数中被调用。这个功能块有七个参数。

  • bAutoReset : BOOL;
  • bDIPDisable : BOOL;
  • bShutdown24V : BOOL;
  • bShutdown5V : BOOL;
  • iDischargeLevel : USINT;
  • bTcStopOnly : BOOL;
  • tDelay : 时间;

只要电源电压及时恢复，“bAutoReset”就不会关闭CX10x0的系统，（这是根据“TDELAY”设置的）。如果想要执行这个操作，输入必须设置为“TRUE”。在其他模块的情况下下，“bDIPDisable”可以用来忽略旋转开关的设置（输入设置为“TRUE”）。再次在这种情况下，用“iDischargeLevel”设定值。“bShutdown24V”关闭24V电压。警告! “bShutdown5V”目前没有使用。此输入必须总是设置为“ FALSE，”！当其被初始化成"FALSE"时，只需忽略它。“iDischargeLevel”表示UPS的放电容量。根据值的范围从0到9，例如：将相应的开关设置成3时，表示当UPS失去其电量的30％后，将会关闭。“TDELAY”表示停止或关闭激活之前的保留时间“bTcStopOnly”是用来写“Windows CE”操作系统下的保持性数据的。关机将使系统重新启动。需要停止TwinCAT去写入保持性数据。停止信号由“bTCStopOnly”设置（“bTcStopOnly”：=“真”）。当“微软的Windows XP Embedded”关闭时，保持性数据将被写入。因此开关是不需要的(bTcStopOnly = FALSE)。

调用如示：

UPS( bAutoReset := TRUE; （* TRUE，当电源恢复时，如果操作继续执行）bDIPDisable：= TRUE;（* DIP开关为TURE时*）bShutdown24V：= FALSE，（*如果关闭开关，那只能选TRUE - >所有都关闭！！*）bShutdown5V：= FALSE，（*请勿使用--->保留功能*）iDischargeLevel：= 3（*值从0.1...9 *) bTcStopOnly := TRUE; （* 在Windows CE下，用来保存保持性数据，否则为FALSE*）TDELAY：= T＃5S;（*关闭*前的持续时间））;

如需使用此功能块，还需要更多的变量。他们与UPS中的信号一同连入TwinCAT系统管理器中。这些变量仍需创建。当过程映像时读入系统管理中，这是自动完成的。当下次调用编译器时，链接过程中存储在“TwinCAT_Configuration”文件中的地址将被导入。（更详细的描述可以在TwinCAT的描述中看到。）另外，可以手动分配地址。编译完成后，将显示丢失配置的警告。通过"Insert -> All instances"菜单项，信号被插入到“变量配置”文件中。这里的信号是能够访问地址的。(例如 MAIN.UPS.Li24VState AT %IB0 : BYTE for memory address 0).

VAR MAIN.UPS.Ii24VState AT %IB0 : BYTE; MAIN.US.IiChargeState AT %IB1 : USINT; MAIN.UPS.QiControl AT %QB0 : BYTE; MAIN.UPS.QiDipControl AT %QB1 : USINT; MAIN.UPS.IbPowerFault AT %I : BOOL; END_VAR

该块提供了几个状态信号去评估程序环境。这些可以被用于控制，例如：将过程数据保存在NVRAM中，或者设置定义的状态和轴的位置。详细地，块提供了下列信号：

  • bPowerFailure : BOOL;
  • bShutdownActive : BOOL;
  • bUpsReady : BOOL;
  • b24VInOK : BOOL;

当电源电压被检测出故障时，“bPowerFailure”返回“真”。当输入电压恢复时，信号变回“FALSE”。

"bShutdownActive"表示，正在执行停止或关闭。

"UPS 输出电压.

“b24VInOK”表示，UPS正在使用24V输入电压。

说明

功能块使PLC程序能完全控制UPS。根据运行模式，开发人员必须知道当其关闭时，该系统是在预定状态，当其重启时，系统会正常运行。可能出现的问题，例如：

  • 当系统停止时，UPS若再次供电->即使此时通电，系统仍将保持关闭。
  • 系统再次重新启动时，若UPS仍在放电阶段，将会等UPS放电完成以后才将其关闭。 - >系统启动时，将在没有警告提示的情况下断电。


LEDs UPS-Modules CX1100-09xx

BECKHOFF CX1100-09xx: 错误处理和诊断

LEDs CX1100-09xx

通过状态指示灯，UPS模块显示其运行状态。LEDs在模块的前面。下表显示可能的状态及其含义。

Display | LED | 意义
 | 24V IN | 电源(输入) 如果 输入电压（>21.5 V），绿灯亮，否则红灯亮。
 | 24 V OUT | 电源（输出） 如果负载已连接到电源输出（>21.5V），绿灯亮，否则红灯亮。 在短路情况下LED红灯开始闪烁。
 | CHARGE（充电状态） | - 充电：黄 - 充满电：绿 - 放电：红色


拆卸

BECKHOFF CX1100-09xx: 拆卸和报废

拆卸和报废

CX10x0硬件分2个阶段拆除：

0. 断开电源

拆除CX10x0系统前，应先关闭该系统，并断开电源。

1. 从导轨上卸下：

在各个CX10x0模块断开前，整个CX10x0硬件组应从导轨上拆下。步骤如下：

1.1. 释放并拆除在导轨上电源模块旁的第一个端子模块。

先拆除电源上的接线，然后拆除电源旁导轨上第一个端子模块的接线。如果接线将重复用于另一个系统，最好做一个接线记号。拉动橙色端子并将其拉出（见箭头）将端子拆下。

1.2. 拆下CX10x0系统

为了拆下CX10x0块，在箭头方向处，拉动模块底部的白色锁扣。把它拉出来并锁定。可以小心地将导轨上的模块拆下。

2. 将各个模块分离

2.1. 分离电源模块，CX10x0的CPU和其他部件

将CX10x0模块正面朝下放置。然后将一字形螺丝刀（尺寸为1.0×5.5×150毫米）插入到锁定机构中，转动约90度，移动滑块。模块会产生约2-3毫米间隙。然后可以小心地拉开PC104接口的插头。

只有具有锁定机构的模块（如：CPU，现场总线连接和UPS模块）可以完好地分离。不能分离的模块，其标记为（有或没有红色油漆密封）。对这些模块强制拆卸将毁坏他们。

警告 |
 | 强行打开模块外壳（例如卸下主机盖），将毁坏外壳。

报废

为了处理该设备，必须完全将其拆除。

电子零件，必须按照国家电子废料法规处置。


认证

嵌入式PC系列的所有产品均通过CE，UL的GOST-R认证。由于产品系列不断进一步发展，我们在这里无法提供完整的列表。目前认证的产品名单，可以在嵌入式PC证书网页或 www.beckhoff.com上看到。


技术支持与售后

Beckhof f 及其合作伙伴遍布世界各地，可为您提供全方位的技术支持与服务，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff 分公司及代表处

有关 Beckhoff 产品的本地技术支持和服务信息，请联系当地的 Beckhoff 分公司和代表处！

有关 Beckhoff 在全球各地分公司和代理商的地址，您可以登录Beckhoff 的官方网站：
http://www.beckhoff.com

此外，您也可以在该网站上查看更多关于 Beckhoff 组件的文档资料。

Beckhoff 总部

德国倍福自动化有限公司

Eiserstr. 5
33415 Verl
德国

电话 ： | +49(0)5246/963-0
传真： | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff 技术支持

Beckhoff为您提供全面的技术支持，除了Beckhoff 具体产品的应用以外，还包括更广泛的服务：

  • 技术支持
  • 复杂自动化系统的设计、编程和调试
  • 各种 Beckhoff 系统组件培训方案
热线： | +49(0)5246/963-157
传真： | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 技术服务

Beckhoff 服务中心提供全方位的售后技术服务:

  • 现场服务
  • 维修服务
  • 零部件服务
  • 热线服务
热线： | +49(0)5246/963-460
传真： | +49(0)5246/963-479
e-mail: | service@beckhoff.com


CX1100-09xx: 调试步骤

BECKHOFF CX1100-09xx: 调试步骤

开启或关闭UPS

开启

基本CPU模块的电来自电源单元。当电源供应器连接到主电源时，基本CPU模块自动启动。如果存储单元被充电，那么嵌入式PC系统将供电。

关闭

如果关闭电源，UPS会认为是电源故障。只要设置了保留时间，UPS将继续为系统供电，当UPS中没有充电电流流过，它将关闭系统并且完全放电。