Title

BECKHOFF CX90x0: Ethernet 控制器

Hardware documentation

for CX90x0 Ethernet controller

CX900x-xxxx

CX9010-xxxx

CX90x0-Nxxx

version: 2.6
date: 2010-03-01


Notes on the documentation

BECKHOFF 自动化: 前言

文档编制说明

本说明书仅供那些在控制与自动化工程方面受过适当培训且熟悉各种适用国家标准的专业人士使用。在安装和调试这些组件时，操作人员必须严格遵循下列说明和解释。

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

免责声明

尽管本文档经过精心编制，但由于其中所描述的产品仍处于不断更新换代中，我们可能不会在每次更新后都检查文档中所描述的产品性能数据、标准或其它特性总是与实际产品相一致。本文档中难免会出现一些技术或者编辑错误，我们保留随时对

文档信息作出修改之权力，恕不另行通知。对于已经变更的产品，如果本文档中的数据、图表以及文字描述没有修改，我们将不再特别加以声明。

商标

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® 和 XFC® 的注册商标,由倍福自动化有限公司授权。
在公共场合其他名称中使用的商标，可能是为了私人的目的向第三方组织使用，这有可能侵犯版权。

专利申请

TwinCAT 技术是覆盖,包括但不局限于下列专利申请与专利：

:在许多其它国家注册或有相关应用的EP0851348, US6167425 专利。

版权

© Beckhoff Automation GmbH.
未经德国倍福自动化有限公司书面许可，任何人不得部分或整个复制或者允许第三方使用交流本手册。
违者将承担带来损失的赔偿。保留所有出现的专利，实用新型的模型和外观设计的版权。


Safety instructions

BECKHOFF 自动化: 前言

安全说明

安全规程

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

交货状态

所有组件在供货前均针对其具体应用进行了特定的软、硬件配置。任何人不得对软、硬件配置进行本文档中规定之外的修改，德国倍福自动化有限公司对因此而造成的一切后果不承担任何责任。

人员资质

本手册仅供那些受过适当培训，熟悉各种适用国家标准的控制、自动化和驱动工程领域专业人员使用。

安全标志说明

本操作手册中用到了下列安全标志。安全标志用于提醒读者注意相关的安全说明。

危险 |
 | 该标志用于强调存在对人员生命或健康产生威胁的风险。

警告 |
 | 该标志用于强调存在对设备、材料或环境产生威胁的风险。

注意 |
 | 该标志表示这些信息能够帮助您更好地理解安全说明。

操作员注意事项

操作员必须确保
· 产品只用于其本身的用途。
· 产品须在良好的条件和工作状态下运行。
· 确保说明书完好无损, 并能及时查到产品所需的参考。
· 本产品只能由有资格的合适的授权人员操作。
· 操作人员需定期进行经过相关职业安全和环境保护方面的指导, 并且熟悉手动操作特别是在此包含的安全指示。

根据机器型号的国家法规

根据本产品所用于的机器和装置的型号，关于这些机器控制的相关国家法规需要得到应用且由操作者遵守。这些法规覆盖了如控制器的安全检查期间的其他事件。操作者必须及时的进行安全检查。

操作要求

阅读操作指导

所有使用本产品的用户务必阅读系统的操作指导。

系统技术

所有用户必须熟悉本产品可使用的全部功能。


Documentation issue status

BECKHOFF CX9000:前言

文档发行说明

版本 | 改变
2.6 | 增加了电池回收的注释
2.5 | 更新了对图片更新的说明
2.4 | 移除了系统接口 CX1200-xxxx 的说明
2.3 | 增加了新的安装位置
2.2 | 修改了系统接口CX90x0-N070的名称 ，并加入了CX90x0-N080
2.1 | 增加了对新的系统接口 CX90x0-N070 和CX90x0-N080 的说明
2.0 | 增加了对 CX9010 的说明, 修改了对电池使用和更新步骤的说明
1.9 | 修改了指示信息
1.8 | 增加了对 K-Bus 总线诊断的说明
1.7 | 增加了对USV 和 CF 卡 操作的说明并改变了标题画面
1.6 | 增加了对通过软件进行图像更新的说明
1.5 | 修正了DVI 线缆长度
1.4 | 增加了 CX9000-A001 功耗值的说明
1.3 | 增加了对拨动开关和图像更新的说明
1.2 | 增加了对 CF卡 的说明, 修正了模块的数量
1.1 | 增加了对系统接口N010 的说明
1.0 | 修正版本
0.0.1 | 最初版本


Appropriate Use

BECKHOFF CX-System: 产品概览

正确使用

CX系列是一种以顶帽型安装在导轨上的模块化的控制系统。该系统扩展性强,可以按照实际需求把所需模块组装及安装在控制柜或端子盒。

只在关闭软件后再关闭PC

在嵌入式控制器关闭之前，如果软件正在运行，应该正确地使其停止以避免硬盘上数据的丢失。请阅读章节 “Switching off”.

如果PC没有被用做控制目的，请关闭所有的系统部件并将该系统与工业PC分开。例如在功能测试期间，必须确认已经关闭的系统避免被再启动。

嵌入式控制器的电源是24 V DC.

危险 |
 | 不要在通电状态下更换任何硬件！

在安装或移出组件时，必须关闭电压。

软件知识

警告 |
 | 熟悉软件的指令知识！

使用者必须熟悉安装在PC上的软件的功能。


CX90x0 Product overview

BECKHOFF CX90x0: 产品概览

系统概览

Ethernet控制器 CX90x0

基于 Ethernet 控制器 CX9000，Beckhoff 对一系列新的CX型嵌入式控制器的进行了扩展。CX90x0 是一个安装在 30毫米导轨上的紧凑型、高性能、高效的 PLC 和运动控制器 。在Beckhoff 控制领域中它被安装在总线端子控制器系列BX 和嵌入式 PC CX1000之间。这个装置的主要特征是具有一个节能的基于XScale® 架构的266 MHz 或者 533 MHz Intel® IXP420 CPU 并能在 Microsoft Windows CE 操作系统下运行。这样它提供了足够的计算能力，足以应付复杂的自动化任务。CX90x0 不需要外部存储媒介 – 设备通过内部的闪存启动操作系统 。由于低功耗，在特定的操作范围内不需要风扇。因此CX90x0不需要旋转部件。与其他的CX 系列相同，该装置是一个模块化的机械设计。这个小型的装置基本的构型只有58 x 100 x 91 mm.

EtherCAT 用作快速的 I/O系统 / K-Bus 作为可供选择的 I/O系统

CX90x0可以在两个版本中应用: 以 K-bus 为直接连接的总线端子，以及以 E-bus版本 为直接连接的EtherCAT 端子。在基本的配置中，两个 RJ 45以太网接口与一个内置交换机相连，可以作为接口使用。这简化了几个CX90x0 的线型拓扑结构。没有单独的开关硬件。两个外部的 Ethernet 接口独立于 EtherCAT 接口，由CPU提供的第二个媒体存取控制器 (media access controller) 来驱动。

基本模块和系统接口

由于出厂前的要求我们进一步增加了接口: 显示器可以使用 CX90x0-N001 设备，例如，一个将 DVI/ VGA + 2 x USB 2.0结合在一起的模块。 DVI 和 USB 的结合使得所有类型的带有DVI/USB接口的Beckhoff 控制面板都能使用。触摸功能通过USB连接。作为进一步的选择，2个 RS232 模块或者两个 RS422/RS485 模块 可以 配置为 COM1 和 COM2。所有串行接口都有机电解耦的功能。海量存储器可以以闪存的形式通过CX90x0-A000 模块来使用，可以提供几个G的物理存储容量。

SPS, 运动控制及可视化

与Beckhoff 所有的控制器一样，TwinCAT 用来为CX90x0设备进行编程。设备本身包含了PLC 和运动控制的run-time环境。两个 Ethernet 接口的其中一个被作为编程接口。

软件

Microsoft Windows CE 可以创建用户的全图像程序，在CX90x0中集成的图形芯片可以满足更高的需求。

总之，CX90x0 是一个紧凑型的以太网控制器，结合了 EtherCAT I/O使其 允许非常快速的 I/O 控制循环。Windows CE 和 TwinCAT CE 构成了这个控制器强大的软件结构。


CX90x0 Product overview

BECKHOFF CX90x0: 产品概览

技术数据

Ethernet-Controller CX9000

Ethernet-Controller CX9000 提供四个版本:

  • CX9000-0000 @266 MHz with E-bus connection
  • CX9000-1000 @266 MHz with K-bus connection
  • CX9010-0000 @533 MHz with E-bus connection
  • CX9010-1000 @533 MHz with K-bus connection

由于连接终端的不同，这两个系列的技术数据也有差异。


CX9000-0000: Technical data

BECKHOFF CX9000-0000: 产品概览

技术数据

CX9000是一个紧凑型的高帽型安装在导轨上的以太网控制器，可以直接连接到防护等级为IP20的beckhoff的I/O系统。CX9000有两个基本版本：一个版本带 K-bus总线，用以连接总线端子；另一个版本使用 E-bus总线，用于连接EtherCAT端子模块 。 CX9000包括CPU，有两个配置选项的内部闪存，主内存 (RAM) (两种尺寸可选),和作为非易失性存储器的NOVRAM。两个以太网RJ 45 接口也是基本配置的一部分。这两个接口与一个内置交换机相连，提供了一个不需要额外以太网交换机创建一个线性拓扑的选择。小巧的闪存记忆模块 I 和 II 作为可选择模块 (只与CX9000-N010连接)。操作系统是Microsoft Windows CE。 TwinCAT 自动化软件把CX9000系统转化为一个强大的PLC和运动控制系统，可以在可视或者不可视情况下操作。在出厂前可以将更多的系统模块连接在CPU模块上。CX9000-N010可通过DVI或者VGA输入经由DVI 或者USB接口连接到Beckhoff控制面板或者标准显示器上。像打印机，扫描仪，鼠标，键盘，海量存储器，CD-RW等装置可以通过USB2.0接口连接。CX9000-N030组件 提供两个 最大传输速率为115Kb的RS232 串口 。这两个接口可以成对换成RS422/RS485，在这种情况下,订货标志为CX9000-N031。

技术数据 | CX9000-0000
处理器 | 基于XScale® 技术Intel® IXP420，266-MHz 时钟频率
闪存 | 16 MByte 闪存 (内置，可扩展到 32 MByte)
主内存 | 64 MByte RAM (内置，可扩展到 128 MByte)
接口 | 2 x RJ 45 (内置交换机), 10/100 MBit
诊断 LEDs | 1 x 电源, 2 x LAN, 1 x L/A, 1 x 闪卡存取
时钟 | 由内部电池供电的时钟，用于显示时间和日期
操作系统 | Microsoft Windows CE
控制软件 | TwinCAT-CE-PLC-Runtime 或者 TwinCAT-CE-NC-PTP-Runtime
电源 | 24 VDC (-15%/+20%)以满足 UL 要求，使用一个 4A 的熔断器或电源来满足 NEC 2级！
介电强度 | 500 Vrms (外供/内置电子)
I/O 连接 | E-bus (EtherCAT 终端)
NOVRAM | 128 kByte
I/O-DPRAM | -
I/O电源终端 | 2 A
最大功耗 | 6 W (包含 CX9000-xxxx 系统接口)
尺寸 (W x H x D) | 59 mm x 100 mm x 91 mm
重量 | 约 250 g
工作温度/储藏温度 | 0° C ... +50° C / -25° C ... +85° C
相对湿度 | 95% 无冷凝
抗振动/抗冲击性 | 符合 EN 60068-2-6 / EN 60068-2-27/29
抗电磁及瞬时脉冲干扰/静电放电 | 符合 EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20


CX9000-1000: Technische Daten

BECKHOFF CX9000-1000: 产品概览

技术数据

CX9000是一个紧凑型的高帽型安装在导轨上的以太网控制器，可以直接连接到防护等级为IP20的beckhoff的I/O系统。CX9000有两个基本版本：一个版本带 K-bus总线，用以连接总线端子；另一个版本使用 E-bus总线，用于连接EtherCAT端子模块 。 CX9000包括CPU，有两个配置选项的内部闪存，主内存 (RAM) (两种尺寸可选),和作为非易失性存储器的NOVRAM。两个以太网RJ 45 接口也是基本配置的一部分。这两个接口与一个内置交换机相连，提供了一个不需要额外以太网交换机创建一个线性拓扑的选择。小巧的闪存记忆模块 I 和 II 作为可选择模块 (只与CX9000-N010连接)。操作系统是Microsoft Windows CE。 TwinCAT 自动化软件把CX9000系统转化为一个强大的PLC和运动控制系统，可以在可视或者不可视情况下操作。在出厂前可以将更多的系统模块连接在CPU模块上。CX9000-N010可通过DVI或者VGA输入经由DVI 或者USB接口连接到Beckhoff控制面板或者标准显示器上。像打印机，扫描仪，鼠标，键盘，海量存储器，CD-RW等装置可以通过USB2.0接口连接。CX9000-N030组件 提供两个 最大传输速率为115Kb的RS232 串口 。这两个接口可以成对换成RS422/RS485，在这种情况下,订货标志为CX9000-N031。

技术数据 | CX9000-1000
处理器 | 基于XScale® 技术Intel® IXP420，266-MHz 时钟频率
闪存 | 16 MByte 闪存 (内置，可以扩展至 32 MByte)
主内存 | 64 MByte RAM (内置，可以扩展至 128 MByte)
接口 | 2 x RJ 45 (内置交换机), 10/100 MBit
诊断 LEDs | 1 x电源， 2 x LAN, 1 x K-Bus, 1 x 闪存存取
时钟 | 由内部电池供电的时钟，用于显示时间和日期
操作系统 | Microsoft Windows CE
控制软件 | TwinCAT-CE-PLC-Runtime 或者TwinCAT-CE-NC-PTP-Runtime
电源 | 24 VDC (-15%/+20%) 以满足 UL 要求，使用一个 4A 的熔断器或电源来满足 NEC 2级！
介电强度 | 500 Vrms (外供/内置电子)
I/O 连接 | K-bus (Bus Terminals)
NOVRAM | 128 kByte
I/O-DPRAM | 4 kByte
I/O电源终端 | 2 A
最大功耗 | 6 W (包含 CX9000-xxxx 系统接口)
尺寸 (W x H x D) | 59 mm x 100 mm x 91 mm
重量 | 约 250 g
工作温度/储藏温度 | 0° C ... +50° C / -25° C ... +85° C
相对湿度 | 95% 无冷凝
抗振动/抗冲击性 | 符合 EN 60068-2-6 / EN 60068-2-27/29
抗电磁及瞬时脉冲干扰/静电放电 | 符合 EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20


CX9010-0000: Technical data

BECKHOFF CX9010-0000: 产品概览

技术数据

CX9010是一个紧凑型的高帽型安装在导轨上的以太网控制器，可以直接连接到防护等级为IP20的beckhoff的I/O系统。CX9010有两个基本版本：一个版本带 K-bus总线，用以连接总线端子；另一个版本使用 E-bus总线，用于连接EtherCAT端子模块 。与CX9000相反，CX9010只带有 32M 闪存，128M 主内存 (RAM) ,和作为非易失性存储器的NOVRAM。两个以太网RJ 45 接口也是基本配置的一部分。这两个接口与一个内置交换机相连，提供了一个不需要额外以太网交换机创建一个线性拓扑的选择。小巧的闪存记忆模块 I 和 II 作为可选择模块 (只与CX9010-N010连接)。操作系统是Microsoft Windows CE。 TwinCAT 自动化软件把CX9010系统转化为一个强大的PLC和运动控制系统，可以在可视或者不可视情况下操作。在出厂前可以将更多的系统模块连接在CPU模块上。CX9010-N010选件可通过DVI或者VGA输入经由DVI 或者USB接口连接到Beckhoff控制面板或者标准显示器上。像打印机，扫描仪，鼠标，键盘，海量存储器，CD-RW等装置可以通过USB2.0接口连接。CX9000-N030组件 提供两个 最大传输速率为115Kb的RS232 串口 。这两个接口可以成对换成RS422/RS485，在这种情况下,订货标志为CX9010-N031。

技术数据 | CX9010-0000
处理器 | 基于XScale® 技术Intel® IXP420，533-MHz 时钟频率
闪存 | 32 MByte 闪存(内置)
主内存 | 128 MByte RAM (内置)
接口 | 2 x RJ 45 (内置交换机), 10/100 MBit
诊断 LEDs | 1 x 电源, 2 x LAN, 1 x L/A, 1 x 闪存
时钟 | 由内部电池供电的时钟，用于显示时间和日期
操作系统 | Microsoft Windows CE
控制软件 | TwinCAT-CE-PLC-Runtime 或者 TwinCAT-CE-NC-PTP-Runtime
电源 | 24 VDC (-15%/+20%) 以满足 UL 要求，使用一个 4A 的熔断器或电源来满足 NEC 2级！
介电强度 | 500 Vrms (电源/内部电子元器件)
I/O 连接 | E-bus (EtherCAT端子模块)
NOVRAM | 128 kByte
I/O-DPRAM | -
I/O电源终端 | 2 A
最大功耗 | 6.5 W (包含 CX9010-xxxx 系统接口)
尺寸 (W x H x D) | 59 mm x 100 mm x 91 mm
重量 | 约 250 g
工作温度/储藏温度 | 0° C ... +50° C / -25° C ... +85° C
相对湿度 | 95% 无冷凝
抗振动/抗冲击性 | 符合 EN 60068-2-6 / EN 60068-2-27/29
抗电磁及瞬时脉冲干扰/静电放电 | 符合 EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20


CX9000-1000: Technische Daten

BECKHOFF CX9010-1000: 产品概览

技术数据

CX9010是一个紧凑型的高帽型安装在导轨上的以太网控制器，可以直接连接到防护等级为IP20的beckhoff的I/O系统。CX9010有两个基本版本：一个版本带 K-bus总线，用以连接总线端子；另一个版本使用 E-bus总线，用于连接EtherCAT端子模块 。与CX9000相反，CX9010只带有 32M 闪存，128M 主内存 (RAM) ,和作为非易失性存储器的NOVRAM。两个以太网RJ 45 接口也是基本配置的一部分。这两个接口与一个内置交换机相连，提供了一个不需要额外以太网交换机创建一个线性拓扑的选择。小巧的闪存记忆模块 I 和 II 作为可选择模块 (只与CX9010-N010连接)。操作系统是Microsoft Windows CE。 TwinCAT 自动化软件把CX9010系统转化为一个强大的PLC和运动控制系统，可以在可视或者不可视情况下操作。在出厂前可以将更多的系统模块连接在CPU模块上。CX9010-N010选件可通过DVI或者VGA输入经由DVI 或者USB接口连接到Beckhoff控制面板或者标准显示器上。像打印机，扫描仪，鼠标，键盘，海量存储器，CD-RW等装置可以通过USB2.0接口连接。CX9000-N030组件 提供两个 最大传输速率为115Kb的RS232 串口 。这两个接口可以成对换成RS422/RS485，在这种情况下,订货标志为CX9010-N031。

技术数据 | CX9010-1000
处理器 | 基于XScale® 技术Intel® IXP420，533-MHz 时钟频率
闪存 | 32 MByte 闪存(内置)
主内存 | 128 MByte RAM (内置)
接口 | 2 x RJ 45 (内置交换机), 10/100 MBit
诊断 LEDs | 1 x 电源, 2 x LAN, 1 x K-Bus, 1 x Flash-Zugriff
时钟 | 由内部电池供电的时钟，用于显示时间和日期
操作系统 | Microsoft Windows CE
控制软件 | TwinCAT-CE-PLC-Runtime 或者TwinCAT-CE-NC-PTP-Runtime
电源 | 24 VDC (-15%/+20%) 以满足 UL 要求，使用一个 4A 的熔断器或电源来满足 NEC 2级！
介电强度 | 500 Vrms (电源/内部电子元器件)
I/O 连接 | K-bus (总线端子模块)
NOVRAM | 128 kByte
I/O-DPRAM | 4 kByte
I/O电源终端 | 2 A
最大功耗 | 6.5 W (包含 CX9010-xxxx 系统接口)
尺寸 (W x H x D) | 59 mm x 100 mm x 91 mm
重量 | 约 250 g
工作温度/储藏温度 | 0° C ... +50° C / -25° C ... +85° C
相对湿度 | 95% 无冷凝
抗振动/抗冲击性 | 符合 EN 60068-2-6 / EN 60068-2-27/29
抗电磁及瞬时脉冲干扰/静电放电 | 符合 EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20


CX9000: Configurations

BECKHOFF CX9000: 产品概览

配置

基本 CPU 模块的订货标识如下：

Bestellbezeichnung des CPU-Grundmoduls

以下CX9000 配置可用：

订货信息 | 16 MB Flash 64 MB RAM | 32 MB Flash 128 MB RAM | E-Bus | K-Bus | DVI, 2 x USB | 不带 TwinCAT | TwinCAT- PLC-Runtime | TwinCAT- NC-Runtime
CX9000-0000 | x | - | x | - | - | x | - | -
CX9000-0001 | x | - | x | - | - | - | x | -
CX9000-1000 | x | - | - | x | - | x | - | -
CX9000-1001 | x | - | - | x | - | - | x | -
CX9001-0000 | - | x | x | - | - | x | - | -
CX9001-0001 | - | x | x | - | - | - | x | -
CX9001-0002 | - | x | x | - | - | - | x | x
CX9001-0100 | - | x | x | - | x | x | - | -
CX9001-0101 | - | x | x | - | x | - | x | -
CX9001-0102 | - | x | x | - | x | - | x | x
CX9001-1000 | - | x | - | x | - | x | - | -
CX9001-1001 | - | x | - | x | - | - | x | -
CX9001-1002 | - | x | - | x | - | - | x | x
CX9001-1100 | - | x | - | x | x | x | - | -
CX9001-1101 | - | x | - | x | x | - | x | -
CX9001-1102 | - | x | - | x | x | - | x | x


CX9010: Configurations

BECKHOFF CX9010: 产品概览

配置

基本 CPU 模块的订货标识如下：

Bestellbezeichnung des CPU-Grundmoduls

以下CX9000 配置可用：

订货信息 | E-Bus | K-Bus | DVI, 2 x USB | 不带 TwinCAT | TwinCAT- PLC-Runtime | TwinCAT- NC-Runtime
CX9010-0000 | x | - | - | x | - | -
CX9010-0001 | x | - | - | - | x | -
CX9010-0002 | x | - | - | - | x | x
CX9010-0100 | x | - | x | x | - | -
CX9010-0101 | x | - | x | - | x | -
CX9010-0102 | x | - | x | - | x | x
CX9010-1000 | - | x | - | x | - | -
CX9010-1001 | - | x | - | - | x | -
CX9010-1002 | - | x | - | - | x | x
CX9010-1100 | - | x | x | x | - | -
CX9010-1101 | - | x | x | - | x | -
CX9010-1102 | - | x | x | - | x | x


CX90x0: Connections

BECKHOFF CX90x0: 产品概览

接线

系统由集成的供电系统提供电源。接线如下图所示：

基本模块通过上面的接口由24V DC供电。总线由下面的接口进行供电。

UL 要求

危险

为了符合UL需求，则需要CX型的控制器的供电只有以下两种方式

  • 通过24 VDC 电压供电，由一个绝缘的电源供给并且通过保险丝 (符合 UL248)保护, 额定最大电流 4 Amp.
  • 通过24 VDC 电源供电，其必须满足 NEC 等级2。
    NEC     等级2 电源不应与另一个相同等级的电源串联或并联！

这个 UL 的要求适用于所有CX型控制器的电源！

为了符合UL需求， CX型控制器绝不能连接在无限制的电源上！

基本CPU模块（带有2个以太网 RJ 45 接口）:

RJ 45 接口 (插口):

RJ45 接口的引脚分配，端口 1:

引脚 | 信号 | 描述
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | not used
5
6 | RD - | Receive -
7 | connected | not used
8

TD 和RD信号在.集线器或者在两个PC之间进行交换。

RJ45 接口的引脚分配，端口 2:

引脚 | 信号 | 描述
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | not used
5
6 | RD - | Receive -
7 | connected | not used
8

TD 和RD信号在.集线器或者在两个PC之间进行交换。

以太网端口的接线：

警告 |
 | 基本CPU模块的两个以太网端口不得连接到同一外部交换机！

注意

仅适用于局域网，不适用于与电信线路的连接。

网络组件的图式结构：

CX90x0 具有两个MAC模块。第一个模块（MAC1）负责以太网端口的网络接口。 这两个输出通过一个交换机连接。这样，可以形成一个如下所述的线性结构。从操作系统的角度来看这代表一个单一的连接。第二个模块(MAC2) 负责扩展的PC104总线，第二个物理网络接线用来运行E-bus连接 。 (在 CX900x-0xxx版本中) 信号连接到FPGA。本单元将以太网信号转换为E-bus信号。所以EtherCAT的终端可以连接到系统上。

如果K-bus用作终端总线（CX900x-1xxx），那么第二个MAC接口不再连接。

操作系统观点:

操作系统只参照网络接口的一个接线。状态总是连接的，因为交换机是直接连接的。

这些接口连接到一个内部3端口交换机，并提供了用于创建一个线路拓扑结构的选择，且此结构无需额外的以太网交换机。

基本CPU模块（带DVI/USB 接口）:

除了这两个以太网端口，这个基本模块也带有DVI/USB接口。这个带有 2 个USB和 1 个DVI-I接口的基本CPU模块的引脚分配，请参照相关产品 CX90x0-N010 系统接口。

对所有基本CPU模块都均适用：

LED

绿色电源指示灯 (PWR)指示CPU的供电状态

CF插槽

详见 CF插槽.


CX-System: battery

BECKHOFF CX System: 产品概览

电池盒

电池盒位于CPU模块的左侧，两个以太网端口之间。可以利用螺丝刀将它打开（操作时要注意以防损坏）。

电池的型号是日本松下的CR2032

特性如下：

电池型号 | 电气属性 (在 20° C时) |  | 标准负载 | 尺寸
 | 标称电压 | 容量 | 连续负载 | 直径 | 高度 | 重量
CR2032 | 3.0 V | 225 mAh | 0.20 mA | 20.0 mm | 3.20 mm | 3.1 g

危险 |
 | 更换的电池部件只能使用由Sanyo或Panasonic生产的标准CR2032型号电池。使用其它电池可能导致着火或爆炸。 警告，错误的使用电池可能会引起爆炸，请勿充电，拆解或投入火中。

说明 |
 | 每5年电池必须更换一次。 备用电池可以从Beckhoff Service订购。 电池回收: 废电池的处理必须按照国家电子废料法规。 废电池可能含有有害物质或重金属，会危害环境和健康。应回收电池。 它们含有铁，锌，镍和锰等重要物质。 环境和Beckhoff感谢您的理解。


CX90x0: Update Image

BECKHOFF CX90x0: 开关设置

CX90x0 : 拨动开关设置

总述

警告

一般来说没有必要去改变拨动开关的设置。 此开关是用来在发生重大故障时重置系统，提供调试信息，使TwinCAT循环启动和更新图像。

请勿改变一个运行中的系统！

如果想要找到拨动开关，我们必须先打开电池盒。它在CX90x0-N000模块前端的两个以太网接口之间。打开盖子的方法如下：

1. 关闭 CX90x0

2. 打开电池盒 (在两个以太网接口之间)
可以使用螺丝刀将其打开(小心操作以防损坏)。

电池盒打开后，您就能看到四个拨动开关 。他们位于电池座的左侧。在正常运行模式下所有开关都拨向OFF。(所有开关往下拨)。

为了改变拨动开关的设置，建议使用带小刀口的螺丝刀 (2.5 mm x 7.5 cm 长度 和 平行轴，Beckhoff 订单号： ZB8700)。 小心地使用螺丝刀拨动开关。

该开关有四个功能：

1. 重置CX90x0系统于默认状态

2. 将调试代码传输到COM1 (如果处于连接状态)

3. 更新模式以通过PC服务器获得新的图像 (通过 COM1的启动菜单)

4. 使 TwinCAT 以配置模式启动

功能详细描述如下：

重置到出厂设置:

1. 将拨动开关1拨至ON (将开关1往上拨)。

1. 将 CX系统连接到电源和启动系统。在一个完整的启动过后，注册表会重新生成。

2. 将拨动开关1拨至 OFF (将开关1往下拨)并关好盖子。

将调试代码传输到COM1:

1. 将拨动开关2拨至ON (将开关2往上拨)。

2. 连接串行监测设备（打印机或终端）到COM 1端口。接口设置为：38400 波特, 8 位 , 无奇偶校验位和一个停止位 (38400,8,N,1)。

3. 将 CX系统连接到电源和启动系统。调试代码即会被送到监测装置。

4. 在完成测试之后，将开关2拨至OFF(将开关2往下拨)并关好盖子。

更新引导模式:

引导模式用于图像的更新。该过程比较复杂，这部分内容在 own part of the documentation.得以描述。请参考这个过程的说明。

在配置模式下启动TwinCAT:

对于一些情况 (例如启动项错误) 需要在配置模式下启动 TwinCAT。所以启动项可以被修改或者可以重新进行其他设置。

1. 将拨动开关4拨至ON(将开关4往上拨).

2. 将 CX系统连接到电源和启动系统。

3. 在PLC中进行修改。

4. 关闭系统，将开关2拨至OFF(将开关4往下拨)并关好盖子。


CX90x0-Nxxx: Technical Data

BECKHOFF CX90x0: 系统接口

技术资料

尺寸:

与CX系列中其他产品一样，基本 CX90x0 CPU 模块有多种可选的接口模块（可在出厂前安装）。

下列为可用的接口：:

  • CX90x0-N010 DVI / USB 模块
  • CX90x0-N030 RS323 串口模块
  • CX90x0-N031 RS422 / RS485 串口模块

CX90x0-N010 选件可以利用DVI或者 USB 接口，实现通过DVI或者VGA输入以便与 Beckhoff 控制面板或标准监视器相连接。诸如打印机、扫描仪、鼠标、键盘、海量存储器，CD-RW 等设备可通过 USB 2.0 接口连接。CX90x0-N030 模块提供两个串行 RS232 接口，其最大传输速度为 115 kbaud。这些接口可以成对的作为 RS422/RS485运行，在这种情况下，他们分别被认为是CX90x0-N031。系统接口不能在现场进行改装或者扩展。它们在出厂前进行了特定配置，不能和 CPU 模块分离。系统接口通过内部 PC/104 总线运行，因而，还可连接更多的 CX 组件。系统接口模块通过内部 PC/104 总线供电。

技术数据 | CX90x0-N010 | CX90x0-N030 | CX90x0-N031
接口 | 1 x DVI + 2 x USB 2.0 （每个端口最大 100mA） | 1 x COM1+2, RS232 1 x COM3+4, RS232 | 1 x COM1+2, RS422/RS485 1 x COM3+4,RS422/RS485
接口类型 | DVI-I 29针接口 + 2 USB 端口，A 型 | 2 x D型接口，9 针 | 2 x D型端子插头，9针
特性 | DVI-I 接口也可执行 VGA 信号 (DVI-A) | 最大数据传输率为 115 kbaud, 不能与 N031/N041 同时使用 | 最大数据传输率为 115 kbaud, 不能与 N030/N040 同时使用
电源 | 通过系统总线供电（通过CX90x0电源模块）
尺寸 | 19 mm x 100 mm x 51 mm
工作温度 | 0 °C ... +55 °C
储藏温度 | -25 °C ... +85 °C
相对湿度 | 95% 无冷凝
抗振动/抗冲击性能 | 符合 EN 60068-2-6 / EN 60068-2-27/29 标准
抗电磁及瞬时脉冲干扰/静电放电 | 符合 EN 61000-6-2/EN 61000-6-4 标准
防护等级 | IP 20
重量 | 约 80 g


Connections CX90x0-N010

BECKHOFF CX90x0: 系统接口

CX90x0-N010 接线

除了两个 Ethernet 接口外，这个模块包含一个 DVI-I 和两个 USB 接口。

注意 |
 | 系统接口 CX90x0-N010 只能使用在CX90x0 大记忆系统中 (CX9001-x00x)。

DVI-I 接口

DVI-I接口对模拟量和数字量进行转换，并且可以用15引脚 D-Sub接头连接模拟图形卡，用DVI-D输出连接数字图形卡。屏幕或Beckhoff控制面板的分辨率取决于距离大小（最长 5米）。

DVI接口 采用VGA信号，所以用DVI至VGA的适配器将CRT VGA显示器连接到CX1000系统是可以的。

此适配器具体信息可参考accessory。

DVI-I 插座:

针脚 | 信号 | 针脚 | 信号 | 针脚 | 信号
1 | TMDS Data 2- | 9 | TMDS Data 1- | 17 | TMDS Data 0-
2 | TMDS Data 2+ | 10 | TMDS Data 1+ | 18 | TMDS Data 0+
3 | TMDS Data 2/4 Shield | 11 | TMDS Data 1/3 Shield | 19 | TMDS Data 0/5 Shield
4 | not connected | 12 | not connected | 20 | not connected
5 | not connected | 13 | not connected | 21 | not connected
6 | DDC Clock | 14 | + 5V Power | 22 | TMDS Clock Shield
7 | DDC Data | 15 | Ground ( +5V, Analog H/V Sync) | 23 | TMDS Clock +
8 | Analog Vertical Sync | 16 | Hot Plug Detect | 24 | TMDA Clock -

引脚分配(交叉)

针脚 | 信号
C1 | 模拟红色信号输出
C2 | 模拟绿色信号输出
C3 | 模拟蓝色信号输出
C4 | 模拟水平同步信号

显示分辨率:

分辨率 | 接口与显示器间的距离
1600 x 1200 | 5 m
1280 x 1024 | 5 m
1024 x 768 | 5 m
800 x 600 | 5 m
640 x 480 | 5 m

USB 接口:

USB接口为A型插座. USB 2.0标准

针脚 | 信号 | 信号颜色
1 | VBUS | 红色
2 | D- | 白色
3 | D+ | 绿色
4 | GND | 黑色
Shell | Shield | 地线


Connections CX90x0-N030

BECKHOFF CX90x0: 系统接口

CX90x0-N030 接线

CX90x0-N030 提供2个RS232 接口， COM1和COM2 (9 引脚 Sub-D 插头)。

所有通道的最大波特率为115 kB/s。所有针脚的定义是均等的且如下所示。接口变量可在操作系统或者PLC程序中设置。

RS232 COM 接口 (接头):

COM接口引脚定义:

引脚 | 信号 | 类型 | 描述
1 | DCD | 信号输入 | 载波检测
2 | RxD | 信号输入 | 接收数据
3 | TxD | 信号输出 | 发送数据
4 | DTR | 信号输出 | 数据终端准备
5 | GND | 接地 | 接地
6 | DSR | 信号输入 | 通讯设备准备
7 | RTS | 信号输出 | 发送请求
8 | CTS | 信号输入 | 发送允许
9 | RI | 信号输入 | 响铃指示器

注意 |
 | CX90x0-N030的只能用来被CX90x0-N031更换，而不能与CX90x0-N031同时使用。 CX90x0-N031的只能用来被CX90x0-N030更换，而不能与CX90x0-N030同时使用。


Connections CX90x0-N031

BECKHOFF CX90x0: 系统接口

CX90x0-N031 接线

CX90x0-N031 提供2个RS422 / RS485 接口， COM1 和COM2 (9 引脚 Sub-D 插头)。

所有通道的最大波特率为115 kB/s。所有接口的引脚分配是均等的且如下所示。接口变量可以在操作系统和PLC程序中设置，所有针脚的定义如下所示。

RS232 COM接口 (接头):

COM 接口引脚分配 :

引脚 | 信号 | 类型 | 描述
2 | TxD+ | 数据输出 | 422发送
3 | RxD+ | 数据输入+ | 422接受
5 | GND | 接地 | 信号接地
6 | VCC | VCC | +5V
7 | TxD- | 数据输出 | 422发送
8 | RxD- | 数据输入 | 422接受

如果采用RS 485通讯方式， 2号和3号脚( Data +) 必须短接，同时7号和8号脚( Data -) 必须短接。

设定接口参数

如果系统接口 CX90x0-N031 位于CX90x0系统块的末端，就很容易调节DIP开关。为RS485/422接口配置的DIP开关在模块的左侧。掀开左侧的灰色盖板就可以看到开关。

上下2组开关分别设置对应的上下2组串口。开关参数改变时系统必须断电！订货时需要确认默认的设置。

DIP开关RS485的设置：

无回音RS485 , End-Point ( 终端的) 默认设置

DIP | 状态 | Function
1 | off | Echo on
2 | on | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | on | Auto receive on
6 | off | Always receive on
7 | on | Term on
8 | on | Term on

有回音RS485，End-Point(终端)

DIP | 状态 | 功能
1 | on | Echo on
2 | off | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | on | Term on
8 | on | Term on

RS485 无回音, Drop-Point ( 无终端)

DIP | 状态 | 功能
1 | off | Echo on
2 | on | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | off | Term on
8 | off | Term on

有回音RS485, Drop-Point ( 无终端)

DIP | 状态 | 功能
1 | on | Echo on
2 | off | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | off | Term on
8 | off | Term on

设定DIP开关RS422:

RS422 全双工

DIP | 状态 | 功能
1 | on | Echo on
2 | off | Echo off
3 | off | Auto send on
4 | on | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | on | Term on
8 | on | Term on

注意 |
 | CX90x0-N030的只能用来被CX90x0-N031更换，而不能与CX90x0-N031同时使用。 CX90x0-N031的只能用来被CX90x0-N030更换，而不能与CX90x0-N030同时使用。


Unpacking, installation and transport

BECKHOFF CX90x0: Transport

拆解，安装及运输

必须遵照规定的贮存条件(参见 "Technical data").

单个模块的尺寸和重量:

尺寸 (W x H x D): 19 x 100 x 91 mm (系统接口), 58 x 100 x 91 mm (基本模块)

重量: 80 g (系统接口) 至 250 g (基本模块)

拆解

按照如下操作拆解装置:
1. 移走包装材料.
2. 不要丢弃原始包装材料，保存起来为再布置所用。
3. 对比定单核实发送的货物是否完全.
4. 请保存好相关的书面材料，里面包含处理装置的重要信息。
5. 检查产品以防明显的运输损坏。.
6. 如果发现运输损坏或与你订购的不一致，请通知 Beckhoff 售后服务。

警告 |
 | 对单元有危险损害！

在寒冷的环境下运输，或者装置遭受极端温度变化时，必须避免装置内外冷凝。
在运行之前，必须缓慢调整装置以适应空间温度。

如果出现冷凝，那么在装置启动之前必须有将近12小时的延迟时间。

安装

设备都是安装在控制柜的，安装指南可以在机械装备一章查询。

运输和再布置

尽管装置健全的设计，部件在强烈震动和碰撞时易受到损害。所以，在运输时应该保护计算机免受过分的机械压力。因此，请使用最初的包装材料。


CX90x0: Dimensions

BECKHOFF CX90x0: 安装与布线

尺寸

CX90x0 系列产品具有小型整体性和高模块化。针对项目规划的用途，提供了1 个CPU模块、一个电源供应单元和相关系统接口及现场总线接口。应用的总体范围由单个模块组成。 具有高度 100 mm,的模块的尺寸与Beckhoff 总线终端设备完全符合。再加上较低的连接端口，这意味着它可以用在高度为 120mm 的标准接线盒。

警告

为了确保在运行时设备冷却，保持安全间距很重要。

CX90x0-x000 CPU 基本模块:

不带散热器：

带散热器

CX90x0-N0x0系统接口:

CX1100-09x0 不间断电源（UPS）模块:

CX1100-0900

CX1100-0910

CX1100-0920


CX90x0: Mechanical assembly

BECKHOFF CX90x0: 装配与接线

基本模块的机械装配

该模块的安装位置经过三个步骤：

1. 模块排列顺序

带有系统接口的CPU模块安装在左侧，扩展时电源在右侧，现场总线接线（主或从）在左侧（如果可用）。

2. 啮合在导轨上

在模块的底部，有一个白色锁扣与一个闭锁装置连接。在装到导轨上之前，这些锁扣必须被拉下。这可以通过使用一个普通的螺丝刀并轻微的旋转就可以做到。

然后使用锁闩带将CX9000模块固定在导轨上。您应该可以听到轻微的卡嗒声。

不要强制推动或者施加过大的压力在组件上！

只在外壳（边缘）不敏感的地方用力。 决不能在屏幕、按钮或CX系统的可动部件处施加压力。

在成功閂在高级轨道上以后，应把皮带推回到最初的位置。

注意:

这种锁定机制防止单个外壳再次脱落。 有关从高级轨道拆卸CX系统的详细信息可以在"Removal and disposal"中找到。

安装位置:

警告 |
 | 安装在轨道上CPU模块的最高环境温度为 55 ° C。该设备的安装朝向的选择，必须使冷空气垂直的流过通风孔。图8显示正确的安装位置，且图9和10显示不正确的安装位置。 遵守最低限度的间隙! 安装时必须在CX90xx设备组合的上方和下方提供 30mm 的间隙，以保证CPU模块和电源模块足够的通风。
正确的安装位置:

高性能CX9000系统产生了大量的热量，并且通过被动的通风系统来驱散。通风装置必须正确安装。通风开口位于外壳的顶端和底端。因此，必须水平安装系统，以确保最适宜的气流。

不正确的安装位置:


Mechanischer Zusammenbau CX9000 mit USV

BECKHOFF CX90x0: 安装与接线

不间断电源（UPS）模块的机械装配

注意 |
 | CX90x0 的UPS模块并不完全支持 TwinCAT 。 UPS 模块应该如描述一样连接。断电信号 (UPS模块上的针脚3) 必须连接在数字量输入终端上。这样的话PLC就能得到断电信号，存储数据并且关闭系统。关闭时间只能由在UPS前端的选择器设置（最好是0）。 以防突然断电，UPS会在断电后重启系统。

0. 关闭及断电

在CX90x0系统拆除之前，系统应该先关闭，电源应该断开。

1. 从导轨上拆卸下来:

在单个 CX90x0 模块断开之前，整个CX90x0硬件模块应该从导轨上拆卸下来。步骤如下：

1.1. 解开并移除在导轨上紧接着电源的第一个端子。

首先移除所有供电单元的电线，然后移除从高帽型导轨上的第一个端子到电源装置上的电线。如果这些电线会被另一个系统再次使用，建议给连接处做标记。接着拉动橙色终端（箭头所示）将其解开，将其拔出来。

1.2. 移除 CX90x0 系统

为了移除CX模块，朝着箭头的方向拉动模块底端的白色拉力带。他们将会被锁住在扩展的位置，在从电源单元拉出终端后，这个模块就能冲高帽型导轨顶端小心的移除了。

2 带有UPS模块的CPU基本模块的装配

2.1 装配 CX90x0 系统

为了将UPS模块连接到基本的CX90x0 模块上，先要移除基本模块的盖子。施加一个细小的压力就可以将盖子去除。单个模块只是简单的互相插在一起。PC104插头应当谨慎处理以防损坏。当模块安装正确时，在连接座处没有明显缝隙。如果模块装配完毕，就可以把盖子再装回去了。

2.2 装配到顶部导轨上

在将系统装配到导轨上之前，用户必须确保所有的白色拉力带都已经被拉下来。并且保证在端子和嵌入式PC之间有足够的空间。必须保证有移除端子的空间以防重新安装端子。

然后用锁带将 CX90x0 模块安装到导轨上。你将听到一个轻巧的卡扣声。

不要强压模块或施加过大的压力！

只在边缘不敏感处施加压力。切勿在CX10x0系统的的屏幕、按钮、移动部件上施加压力。

当成功将模块安装在导轨上之后，拉力带应拉回到原来的位置。

2.3 将嵌入式PC连接到总线端子上

通过重新安装一次被移除的端子，系统被连接到总线上。

最后必须重新接线。被移除的端子像之前一样重新连接。电源现在就可以通过UPS连接器连接到系统中。（具体请参阅连接章节）


Switching the PC on and off

BECKHOFF CX System: 启动步骤

打开和关闭PC

打开

CPU模块的电源由供电设备提供。当供电设备连到主通道时，CPU模块自动启动。

初次启动

当第一次启动PC时，预安装操作系统（可选）将被启动。

关闭

当供电设备关闭时，嵌入式PC将关闭。应正确关闭或停止运行在嵌入式PC上正常运行的控制软件。 在没有关闭软件时，用户不能关闭嵌入式PC，因为在软件运行时关闭开关会导致硬盘上的数据丢失。

一旦软件停止，操作系统就可以关闭。只有在这时电源才能中断。


LEDs CPU-Module (E-Bus)

BECKHOFF CX900x-0xxx: 故障处理及诊断

基本CPU模块 (E-Bus)的LED

CX9000 和 CX9010的情况是一致的 。CX9000的LED状态情况如下。

显示 | 指示灯 |  | 含义
 | PWR | 红色 | TwinCAT 在停止状态
 |  | 绿色 | TwinCAT 在运行状态
 |  | 蓝色 | TwinCAT 在配置状态
 |  | 关闭 | 系统离线
 | LAN 1 |  | LAN 连接 , (绿色) 切换局域网端口1：连接/活动 (CX9000_N000)
 | LAN 2 |  | LAN 连接, (绿色) 切换局域网端口2：连接/活动 (CX9000_N000)
 | L / A |  | (连接活动) 在E-bus连接时闪烁
 | HDD |  | Read/Write CF卡 (红色) 指示存取到 CF卡。


LEDs CPU-Grundmodul

BECKHOFF CX900x-1xxx: 故障处理及诊断

LED基本CPU模块 (K-Bus)

CX9000 和 CX9010的情况是一致的 。CX9000的LED状态情况如下。

显示 | 指示灯 |  | 含义
 | PWR | 红色 | TwinCAT 在停止状态
 |  | 绿色 | TwinCAT 在运行状态
 |  | 蓝色 | TwinCAT 在配置状态
 |  | 关闭 | 系统离线
 | LAN 1 |  | LAN 连接 , (绿色) 切换局域网端口1：连接/活动 (CX9000_N000)
 | LAN 2 |  | LAN 连接, (绿色) 切换局域网端口2：连接/活动 (CX9000_N000)
 | K-Bus |  | 闪烁， K-bus / 错误报告 K-Bus 没有激活 (off) K-Bus 运行 (flashes green) K-Bus 错误(red)
 | HDD |  | Read/Write CF卡 (红色) 指示存取到 CF卡。

K-Bus I/O错误LED闪烁代码

快速闪烁 | 起始的错误代码
First slow sequence | 错误代码
Second slow sequence | 错误代码参数

K-Bus 诊断LE

错误代码 | 错误代码参数 | 描述 | 措施
持续不断地闪烁 |  | EMC 问题 | - 检查供电的峰值 - 采取电磁兼容措施 - 如果k-bus有错误存在，它可以局部的重新启动电源（通过先关闭在打开的方法）
1 个脉冲 | 0 | EE PROM校验错误 | 改回到制造商的设置
 | 1 | 代码缓冲区溢出 | 插入少一些总线终端。编程配置中有太多的表中的条目
 | 2 | 未知的数据类型 | 更新软件所需的电源
2 个脉冲 | 0 | 编程配置有一个不正确的表项 | 检查程序配置的正确性
 | n (n > 0) | 表比较（总线终端N） | 不正确的表项
3 个脉冲 | 0 | k-bus命令错误 | - 没有总线端子插入 - 一个总线端子有缺陷； 减少一半的总线端子并检查其余的总线中是否仍然存在错误。 重复直到有缺陷的总线终端的位置被查出
4 个脉冲 | 0 | k-bus数据错误，破坏了电源 | 检查n + 1的总线端子是否连接正确；如有必要进行更换
 | n | Break behind Bus Terminal n | 检查总线端子9010是否连接
5 个脉冲 | n | k-bus寄存器与总线终端n通信错误 | 交换第n个总线端子
9 个脉冲 | 0 | 校验程序中的错误 | 改回到制造商的设置
 | n (n>0) | 当启动项被建立时，总线端子n与配置不相同 | 改回到制造商的设置置零启动项
14 个脉冲 | n | 第n个总线端子格式错误 | 重启电源，如问题仍旧存在更换总线端子
15 个脉冲 | n | 总线端子的数目不再正确 | 重启电源
16 个脉冲 | n | K-Bus数据长度不再正确 | 重启电源

错误代码参数

脉冲的数字表明发生错误之前最后一个总线端子的位置，被动的总线端子，例如电源终端，并不包括在计数内。

对于一些情况的错误，校正并不能使得电源脱离闪烁状态。只能通过开关电源来重启供电。


Errorhandling and Diagnose in PLC-Program

CX90xx-1xxx: PLC程序的错误处理及诊断

PLC程序的总线端子分析

为了分析总线端子 (K-Bus) ，程序员可以利用结构中描述的寄存器。通过TwinCAT实现对PLC程序的获取。在总线端子连接器的结构中中对寄存器里进行了描述 (CX1100-000x)。

四个信号/变量用于分析：

  • BusState (描述总线状态: 0 -> 无错误, 1 -> 总线错误)
  • ErrorCode (与LED闪烁代码相同的错误代码)
  • ErrorArg (同LED闪烁代码相同的参数代码)
  • Request[0] (输出以要求错误代码/重置总线)

在PLC程序中一些外部的变量必须定义：

VAR

       k_bus_request AT %QX0.0        : BOOL;

       k_bus_err_code AT %IB0         : USINT;
       k_bus_err_arg AT %IB1  : USINT;
       k_bus_state AT %IB2    : USINT;

END_VAR

在PLC程序中可以做以下分析：(这只是虚拟码)

....

IF k_bus_state = 1     THEN          (* an error occured on K-Bus*)

   k_bus_request := TRUE;             (* request vaules for ErrCode and ErrArg *)

   CASE k_bus_err_code OF
     0 : return;                      (* should not happen, though an error occured *)
     1 : CASE k_bus_arg OF
         0 : report error;    (* EEPROM checksum error *)
         1 : report error;    (* overflow in code buffer *)
         2 : report error;    (* unknown datatype *)
       END_CASE;
     2 : CASE k_bus_arg OF
         0 : report error;    (* programmed configuration, wrong table entry *)
         ELSE report error;   (* wrong table entry *)
       END_CASE;
     3 : report error         (* K-Bus command error *)
     4 : CASE k_bus_arg OF
         0 : report error;    (* break after power supply *)
         ELSE report error;   (* break after terminal 'k_bus_arg' *)
       END_CASE;
     5 : report error         (* K-Bus-error during register-communication with terminal 'k_bus_arg' *)
     9 : CASE k_bus_arg OF
         0 : report error;    (* checksum error in program flash *)
         ELSE report error;   (* terminal 'k_bus_arg' does not exist in boot configuration *)
       END_CASE;
    14 : report error         (* 'k_bus_arg'-th terminal has wrong format *)
    15 : report error         (* wrong number of bus terminals *)
    16 : report error         (* length of K-Bus data is invalid *)
   END_CASE

   k_bus_request := TRUE;             (* reset bus, if reason for error is removed, bus starts again *)

....

为了达到控制目的，寄存器和程序必须连接到系统管理器. 如果PLC程序能连接到 System Manager ，就能得到以下信号：

总线端子的寄存器模拟在系统管理器中显示：

连接信号与变量 :

k_bus_err_code with ErrorCode

k_bus_err_arg with ErrorArg

k_bus_state with BusState

and

k_bus_request with Request[0]

如果所有信号已连接，程序员可以将配置和PLC程序载入系统中。


Decomissioning CX90x0

BECKHOFF CX-System: 安装与接线

拆卸与处理

分2个阶段拆卸cx90x0硬件配置：

0. 关闭并断开电源

系统拆卸之前，应将系统关闭并断开电源。

1. 从高帽型导轨上拆下:

在单个CX模块拆开前，首先需要把整个CX硬件块从导轨上拆下。步骤如下：

1.1. 拆卸移除高帽型导轨上紧靠着电源装置的第一个端子。

首先拆除所有电源模块上的接线，接着拆除导轨上紧靠着电源装置的第一个端子上的所有接线。如果拆下的接线还要再次使用，建议在接线上做上记号，方便下次使用。然后拉出橙色的拉力带（如箭头所示）将端子松开并拉出。

1.2. 松开CX-System

为了松开CX块，沿箭头方向所示拉出模块底端的白色拉力带。这部分将会在扩展位置锁住。在将电源装置的端子拉力带拉出后，就可以将模块从高帽型导轨上小心地移除了。

2. 拆分模块

2.1. 拆分电源装置，CX系统 CPU和其他模块

将CX10x0正面朝下，放置在一个合适的支架上。翻开CX10x0底部。 用螺丝刀（尺寸规格为1.0 x 5.5 x 150 mm）插入解锁机构，然后旋转90度。后面的 解锁机构将会使模块之间产生2-3 mm的间隙，将它们推开，然后就可以小心的将PC104接口的插头拉出来了。

只有能够无损坏的拆开的模块(CPU, 现场总线模块和UPS模块)具有释放装置 。其他的不能强行拆开模块只有一个标记点（带有或没有红色印条），强行拆除的话这些模块会被损坏。

警告 |
 | 强行拆开（如卸下外盖）将造成外壳损坏

废弃物处理

该设备必须完全拆除，以便处理。

电子器件的处理必须按照国家电子废料法规。


CX90x0: Update Image

BECKHOFF CX90x0: 更新版本

CX90x0 : 更新版本

概述

警告

一般来说更新版本是不需要的：TwinCAT和TwinCAT PLC都在正常运行。

更新版本只适用于倍福的自动化产品。不要去改变一个运行的系统！

如果需要一个更新版本，这里有一些基本信息可供参考：

这些框图展现了更新流程。主要有三个步骤：

1. 选择正确的版本

2. 安装版本

3. 把文件复制到硬盘上

每一步都能用不同方法完成。

选择正确的版本

BECKHOFF FTP 服务器版本

Beckhoff 自动化有限公司的FTP服务器新版本：

ftp.beckhoff.de/Software/embPC-Control/

后面的方框图展现了FTP服务器的视角。

FTP-Directory /Software/embPC-Control/ auf ftp.beckhoff.de.

Beckhoff FTP Server ftp.beckhoff.com
    No unauthorised access to our systems is allowed!
    Please report operational problems to webadmin@beckhoff.com
                          <DIR>
11/23/07 12:00          <DIR> CE
04/04/07 12:00          <DIR> CP62xx_C69xx
09/26/08 07:21          <DIR> CP6608
09/26/08 07:23          <DIR> CP66xx
09/22/08 12:26          <DIR> CPx7xx-0000
09/22/08 12:32          <DIR> CPx7xx-0010
03/31/07 12:00          <DIR> CX1000
03/31/07 12:00          <DIR> CX1001
03/31/07 12:00          <DIR> CX1010
03/31/07 12:00          <DIR> CX1020
01/03/08 11:39          <DIR> CX1030
03/31/07 12:00          <DIR> CX9000
09/22/08 12:32          <DIR> CX90xx
04/14/08 04:42          <DIR> Solution

For CX9000 select Link CX9000.

FTP-Directory /Software/embPC-Control/CX9000/CE/ auf ftp.beckhoff.de.

Beckhoff FTP Server ftp.beckhoff.com
    No unauthorised access to our systems is allowed!
    Please report operational problems to webadmin@beckhoff.com
                          <DIR> ..
09/26/08 07:39      6,643,961 CX9000_CE500_LF_v220e.zip
09/26/08 07:38      8,745,416 CX9000_CE600_LF_v306e.zip
03/31/07 12:00         89,050 CX9000_ImageUpdate.zip
07/24/08 12:04         50,830 Cx9ImageUpdate_V1007.zip
09/26/08 07:39          <DIR> History

CX9000_CE500_LF_v220e.zip

CE5.0版本

CX9000_CE600_LF_v306e.zip

CE6.0版本

CX9000_ImageUpdate.zip

通过更新服务器利用更新工具更新

Cx9ImageUpdate_V1007.zip

直接更新的更新工具

For CX9001 and CX9010 select link CX90xx.

FTP-Directory /Software/embPC-Control/CX90xx/CE/ auf ftp.beckhoff.de.

Beckhoff FTP Server ftp.beckhoff.com
    No unauthorised access to our systems is allowed!
    Please report operational problems to webadmin@beckhoff.com
                          <DIR>..
09/22/08 12:32         89,050 CX9000_ImageUpdate.zip
09/22/08 12:32      5,278,516 CX90x0_NoHive_32MB_Flash.zip
09/26/08 07:39     15,801,289 CX90xx_CE500_HMI_v220e.zip
09/26/08 07:40     18,863,643 CX90xx_CE600_HPS_v306e.zip
09/22/08 12:32         50,830 Cx9ImageUpdate_V1007.zip
09/26/08 07:40          <DIR> History

CX90xx_CE500_HMI_v220e.zip

CE5.0版本

CX90xx_CE600_HPS_v306e.zip

CE6.0版本

CX90x0_NoHive_32MB-Flash.zip

清空硬盘

CX9000_ImageUpdate.zip

通过更新服务器利用更新工具更新

Cx9ImageUpdate_V1007.zip

直接更新的更新工具

Flashing operating system

Interactive tool on CX90x0:

首先程序 "Cx9ImageUpdate.exe"必须从 BECKHOFF FTP服务器上下载下来。如果 CX90x0 没有 USB 工具可以传输。使用 CERHOST-Tools 通过以太网来控制 CX90x0。激活CX系统的FTP服务器。如果不行，那么就需要进行如下配置：

可以把 "\Temp" 和 "\Public" 作为目标目录，虽然这个范围映射到内存区域，而不是映射到闪存硬盘上。为了操作，系统须重新启动。按照下面的指示做。重启CX90x0后，程序就能轻松地拷到CX90x0上了：

如果CX90x0 有足够的空余空间(大容量记忆)，那么版本可以一起复制过来。不然的话版本文件需通过网络获得，在这种情况下，你需要驱动映射CX90x0。

如果图像复制到cx90x0或可以通过双击图标将网络驱动器映射到系统更新工具。程序会需要图像的文件名。必须输入完整文件路径。根据不同的网络配置密码再次请求输入。

点击 "FLASH IMAGE" 按钮会弹出一个对话框需确认这个图像文件 。这是最后能中止更新过程的机会。

当确认图像文件之后，一条警告会出现在屏幕上。

过程的状态会出现在工具栏的底部。

当更新完成了，状态栏会出现以下状态：

CX90x0 可以重启了。如果系统重启了最后一步就完成了。

主机的图像服务器

1.准备 Image-Server (一次)

在主机上提供版本服务器，需如下组件：

  • 两个 batch文件 "CxImgSrv_HMI.bat" 和 "CxImgSrv_LF.bat"
    请注意cx90x0是有不同的硬件环境的（例如或多或少的闪存）。
  • 文件夹 "\Tools"包含了版本服务器本身：CxImageSrv.exe
  • 文件夹"\Images" 包含了 HMI 和 LF 子文件夹有所需的文件 "Boot.bin"
    如果你接收到一个新的 NK.BIN 文件，只需重命名为 "Boot.bin" 然后放到正确的子文件夹下。

2. 准备 CX90x0

将CX90x0准备到 "Boot-Strap Mode" 。 有两种方法可以将 CX90x0 设置为 "Boot-Strap Mode":

首先拨动开关的方法如下。

1. 关闭 CX90x0

2. 打开电池盒 (在两个以太网接口之间)
可以用螺丝刀打开 (小心打开以免损坏).

3. 找到拨动开关 1,2,3,4 ，将开关 3 从 OFF 拨到 ON

另外，管理员可以启动CX系统的工具将CX90x0 设置为 "Boot-Strap Mode"。首先程序必须从 BECKHOFF FTP服务器下载。如果 CX90x0 没有 USB 工具可以传输。使用 CERHOST-Tools 通过以太网来控制 CX90x0。激活CX系统的FTP服务器。如果不行，那么就需要进行如下配置：

可以把 "\Temp" 和 "\Public" 作为目标目录，虽然这个范围映射到内存区域，而不是映射到闪存硬盘上。为了操作，系统须重新启动。按照下面的指示做。重启CX90x0后，程序就能轻松地拷到CX90x0上了：

警告

通过 CERHOST 程序可以通过双击图标启动。警告：不要在没有版本服务器或者正确版本的情况下启动程序！

该cx90x0在更新前不再是可用的PLC！

如果更新已经发生，重置操作将自动完成。

3. 将 CX90x0 连到以太网上

注意

图像服务器将通过cx90x0响应完整的网络联系。
确保你只是更新了CX90x0 .... 而不是网络里的其他组件 ！

(细节参照以下的网络注意点)

4. 启动图像服务器

启动主机的图像服务器：

  • 启动正确的 batch文件 "CxImgSrv_HMI.bat" 或 "CxImgSrv_LF.bat" (to let image-server provide the HMI or the LF image in network)

    batch    文件会弹出一个命令框并提示: "Waiting for download request..."

5. 在图像更新阶段

启动CX90x0 开始下载步骤：

  • 开始阶段：

启动CX90x0 开始下载步骤：启动CX90x0
CX90x0 会尝试在图像服务器上找到一个图像并下载。

  • 下载阶段：
    如果图像被下载到cx90x0，图像服务器会提示一个消息命令。

    消息如下：
    Boot image request from device CX90x0_BA23
    Working directory is Image\HMI
    Calling TFTP.exe -i <CX90x0-IP> PUT boot.bin

    CX90x0     的HDD led 会亮：CX装置会消除并复制新的图像。
  • 重组阶段：
    图像服务器会提示一个消息，说下载新图像已经完成。

现在，关闭命令框。（按<CTRL> + <c> 或关闭窗口）

· 设置系统至运作模式；避免系统运行更新程序了。
将拨动开关3拨为“关闭”并关闭电池盒。

网络配置注意点：

  • 图像服务器将通过cx90x0响应完整的网络联系。
    确保你只是更新了CX90x0 .... 而不是网络里的其他组件 ！

1a.
提供一个子网 (如同主机的第二个网卡)

或

1b.
连接主机和cx90x0且没有涉及其他网络

或

2.
图像服务器可以配置使CX直接从特定的IP地址发出图像请求。
Step 1 : 将CX90x0 连到 PC上，得到PC的IP地址，如 192.16.18.123
Step 2 : 编辑图像-服务器-批处理-文件并添加地址的命令行。 (例如： Tools\CxImageSrv Images\HMI 192.16.18.123 )
Step 3 : 继续将 CX90x0 处在开机模式。现在CX 将会尝试从IP地址192.16.18.123获取图像请求。

将文件拷贝至硬盘

为了让新的版本工作，我们需要新的配置和程序。他们必须复制到内存里去。有两种方法可以使系统得到文件。如果系统由CX9000-N010 或 CX9000-N070接口组成，那么一个U盘上就能容纳文件。系统接口 CX9000-A001可以通过 CF卡来获得文件。如果没有上述的系统接口文件必须通过网络驱动来获得。

下一步是删除内存里的文件。只需删除 "/Hard Disk"里面的所有文件。不能删除的文件必须重命名。

现在所有的文件可以从档案被复制到“硬盘”。当所有文件复制完毕，重新启动系统。

所有重命名的文件可以被删除，更新完成。


Zubehör

BECKHOFF CX System: 附录

附件

CF卡

代替64MBCF卡

订单号 | 描述
CX1900-0023 | 1 G I型CF卡
CX1900-0025 | 2 G I型CF卡
CX1900-0027 | 4 G I型CF卡
CX1900-0029 | 8 G I型CF卡
CX1900-0031 | 16 G I型CF卡

spare compact flash cards

订单号 | 描述
CX1900-0022 | 64MB I型CF卡
CX1900-0024 | 1 G I型CF卡
CX1900-0026 | 2 G I型CF卡
CX1900-0028 | 4 G I型CF卡
CX1900-0030 | 8 G I型CF卡
CX1900-0032 | 16 G I型CF卡

格式化选项

订单号 | 描述
CX1900-0010 | 格式化闪存卡（启动） FAT16
CX1900-0012 | 格式化闪存卡（启动） NTFS

内存扩展 RAM

订单号 | 描述
CX1900-0201 | 512 MB DDR RAM for CX1020/CX1030 instead of 265 MB
CX1900-0202 | 1 GB DDR RAM for CX1020/CX1030 instead of 265 MB

接头与适配器

订单号 | 描述
CX1900-0101 | DVI-VGA 转接头，用于连接CX1000系统与VGA显示器的转换头 – CX10x0 - N001模块的DVI -I 接口的VGA信号 – 29针DVI-A 接头 (底部) 接到15针的插座接头 (顶部) – 重量大约为40克 – 尺寸 (W x H x D) 40 x 42 x 15 mm

标签

订单号 | 描述
CX1900-0200 | CX1000 系统的塑料标签 (包装含有1000标签) – 贴在到CX1000组件上 – 标签可以用于X-Y绘图仪。 – 标签尺寸为 15 x 5 mm – 材料： 白色塑料 – Murrplastik KMR 5/15型，订单号 86401014

CX系统替换电池

订单号 | 描述
CX1900-0102 | CX -系统的电池 - 原产品型号：Panasonic type CR2032 3V/225mAh

CX1030备用风扇盒

订单号 | 描述
CX1900-0103 | CX1030备用风扇盒 – 包括底盘和40毫米风扇 – 利用无线装置进行简单变换 – 重量大约 30 g – 尺寸 (W x H x D) 57 x 14 x 60 mm


Approvals

BECKHOFF Automation: 附录

认证

嵌入式控制器系列的所有产品均有CE、UL认证和GOST-R认证。由于该产品系列不断更新，我们无法提供一个完整列表在这里。通过认证的产品的最新列表，可在网页嵌入式控制器认证 或在www.beckhoff.com的嵌入式控制器部分找到 。


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


Compact Flash Einschub

BECKHOFF CX System: Product overview

Compact Flash slot

A Compact Flash slot is provided at the front of module. This enables an additional Compact Flash memory medium (format I or II) to be operated. The change - in case of the Basic CPU module CF slot - is only allowed while the system is powered down - otherwise the system could crash. In case of using the CF-slot extension (CXxxxx-A001) the CF card can be removed after signing out the media from the system. The card can be removed for maintenance or to extend the system storage capacity. The Compact Flash cards (CF cards) are available as accessories with different storage capacities.

As example the following pictures show the handling of the CF cards with a CX1000 system. Activating the eject mechanism below the slot with a screwdriver causes the card to be ejected by approx. 4 mm (FIGURE 1), so that it can be pulled out (FIGURE 2). If the card is pushed in (FIGURE 3), the eject mechanism will re-engage. The card is positioned correctly, if it is located approx. 1 mm lower than the front of the housing.

FIG1: Ejecting the CF card FIG2: Removing the CF card FIG3: Inserting the CF card

Warning

The Compact Flash slot is a memory interface, not an I/O type CF slot.


Compact Flash Karte

BECKHOFF CX System: Product overview

Compact-Flash card

The Compact Flash card (CF card) is a non-volatile memory medium.

Data to be retained in the event of a power failure should be saved on the CF card. The CF card operates similar to a hard disk.

Warning

It is recommended only use CF cards supplied by Beckhoff Automation GmbH.

The CF cards are made for industrial use. They possess a higher number of read / write cycles and an enhance temperature range (up to + 85°C).

A proper operation of the CX-System can only be guaranteed with the use of CF cards from Beckhoff Automation GmbH!


LEDs CF card reader CX90x0-A001

BECKHOFF CX90x0-A001: Error handling and diagnostics

LEDs CF-card reader

Display | LED | Meaning
 | PWR | Power supply The Power LED comes on when the device is connected to a live power supply unit.
 | LOCK | Lights up if a CF card is inserted correcty (physical and electrical).
 | CF | Read/Write Compact Flash Indicates access to the CF card.


Anschlüsse CX90x0-A001

BECKHOFF CX90x0: System interfaces

CX90x0-A001 connections

This module features a further Compact-Flash card reader/writer. It can be mounted to the system in the field. A removable media can be added to the CX-system in this way. In contradiction to the system CF card slot, this slot is 'hot-pluggable' - the media can be changed during system runtime. The function of the LEDs is described in the chapter diagnostics.

Warning

Only the CF card of the extension module CX90x0-A001 is 'hot-pluggable'.

The system CF-slot must NOT be removed during operation!

The used CF cards should be form the same type as the CF cards for the system cards. The handling is the same as the handling of the system slot. Though the case of the module matches the CX-system cases the handling (installation and decommissioning) is the equal.

Power consumption

The current and power consumption depend on the inserted memory media. The following table shows the consumption values.

Media | Condition | Current consumption | Power consumption
none | Standby | 2 mA | 10 mW
CF card | Idle | 1 mA | 5 mW
CF card | Access | 20 mA | 100 mW
Micro Drive | Idle | 1 mA | 5 mW
Micro Drive | Access | 30 mA | 150 mW

Note |
 | The CX90x0-A001 system interface can only be used in stead of the CX90x0-N070 USB 2.0 Hub or CX90x0-N080 network connector, not at the same time.