26 通道继电器输出端子模块 2V AC

BECKHOFF 现场总线组件

文件：

EL2602

（2 通道继电器输出端子模块 230V AC，2个连接电源触点的常开触点）

EL2612

（2 通道继电器输出端子模块 230V AC，2个转换触点）

EL2622

（2 通道继电器输出端子模块 230V AC，2个常开触点）

EL2624

（4 通道继电器输出端子模块 125V AC，4个常开触点）

版本: 1.4
日期 2011-02-09

EtherCAT® 是经过注册的专利技术，版本归 Beckhoff Automation GmbH, Germany所有.


文档说明

本手册仅供那些受过适当培训，熟悉各种适用国家标准的“控制、自动化和驱动工程”领域专业人员使用。
在安装和调试这些组件时，操作人员必须严格遵循下列说明和解释。

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

免责声明

尽管本文档经过精心编制， 但由于其中所描述的产品仍处于不断更新换代中，
我们可能不会在每次更新后都检查文档中所描述的产品性能数据、标准或其它特性总是与实际产品相一致。
本文档中难免会出现一些技术或者编辑错误，我们保留随时对文档信息作出修改之权力，恕不另行通知。
对于已经变更的产品，如果本文档中的数据、图表以及文字描述没有修改，我们将不再特别加以声明。

商标

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® 已为Beckhoff 自动化有限公司的注册商标
本出版物中的相关名称若被第三方出于个人目的，用作商标，将侵犯其拥有者的权利。

申请中的专利

已包含EtherCAT技术但不局限于如下专利申请和专利:
EP1590927, EP1789857, DE102004044764, DE102007017835
在许多其他国家有关EP0851348, US6167425的相关申请和注册。

已包含TwinCAT技术但不局限于如下专利申请和专利:
在许多其他国家有关EP0851348, US6167425的相关申请和注册。

版权

© 德国倍福自动化有限公司.
未经许可，任何人不得复制、分发和使用本手册以及内容传播。
违者将追究损害赔偿 保留所有出现的专利，实用新型的模型和外观设计的版权。


安全说明

安全规程

请仔细阅读下列安全说明 及相关描述！
有关产品特定安全规程，请见后面页或有关安装，接线及调试等章节。

免责声明

所有组件在供货前均针对其具体应用进行了特定的软、硬件配置。 任何人不得对软、硬件配置进行文本档中规定之外的修改，德国倍福自动化有限公司对因此而造成的一切后果不承担任何责任。

人员资质

本手册仅供那些受过适当培训，熟悉各种适用国家标准的“控制、自动化和驱动工程”领域专业人员使用。

安全标志说明

本操作手册中用到了下列安全标志及相应的安全说明。 请仔细阅读并严格遵守。

危险 		有严重人身伤害危险!
不遵守本标志相关的安全说明将直接危及个人生命和健康安全!

警告 		受伤的危险
不遵守本标志相关的安全说明将危及个人生命和健康安全!

小心 		危害个人
不遵守本标志相关的安全说明可能明显危害个人安全!

注意 		对环境和设备有危险
不遵守本标志相关安全说明可能明显危害环境和设备安全.

说明 		说明或提示
该标志表示这些信息能够帮助您更好地理解安全说明。
UL 说明
这个标志用于表示有关UL标准的重要信息。.


文档版本说明

版本 | 意见
1.4 | 增加了固件兼容性说明以及技术要点说明
1.3 | 增加了商标说明及固件更新说明
1.2 | 增加了EL2624
1.1 | 增加了技术数据
1.0 | 增加了技术数据
0.1 | - EL26xx 的第一个临时说明文档


版本说明

BECKHOFF: 前言

EtherCAT设备名称版本说明

命名方法

一个Beckhoff EtherCAT设备有14位数字名称组成

  • 系列关键字
  • 类型
  • 版本
  • 子版本
例子 | 系列 | Type | 版本 | 子版本
EL3314-0000-0016 | EL 端子模块 (12 mm, 非可插拔式连接) | 3314 (4-通道 热电偶端子模块) | 0000 (基本类型) | 0016
CU2008-0000-0000 | CU 设备 | 2008（8端口高速以太网交换机） | 0000 (基本类型) | 0000
ES3602-0010-0017 | ES 端子模块 (12 mm, 可插拔式连接) | 3602 (2-通道电压测量) | 0010 (高精度版本) | 0017

说明

  • 订货号由以下组成
    - 系列关键字
    - 类型
    - 版本
  • 子版本 表示技术改进过程
    原则上，更高版本的设备可以取代较低版本的设备，除非有特殊规定。
    每个修订版通常有一个相关XML的描述（ESI,EtherCAT Slave信息），可以在Beckhoff官网下载。
  • 类型，版本，子版本都以十进制数表示

序列号

Beckhoff EtherCAT 设备有一个8位数的序列号, 印刷在设备上或标签上。 序列号标明了出厂时的状态

序列号说明

序列号结构 KK YY FF HH

KK - 生产周 (CW, 日历周)
YY - 生产年
FF - 固件版本
HH - 硬件版本

例如序列号： 12 06 3A 02:

12 - 第 12周生产
06 - 2006 年生产
3A - 固件版本 3A
02 - 硬件版本 02

序列号举例

图 1: EL6688 EL 端子模块

图 2: CU2016 交换机

图 3: EK1100 EtherCAT 耦合器


介绍

BECKHOFF EL26xx: 产品概述

EL2602, EL2612, EL2622; EL2624 -介绍

2 通道继电器输出端子模块 230V AC
4 通道继电器输出端子模块 125V AC

EL2602（2个连接电源触点的常开触点），EL2612（2个转换触点）和EL2622（两个常开触点）输出端子模块带有两个继电器，每个继电器有一个单一触点。 EL2624输出端子模块带有四个继电器，每个继电器有一个单一触点（4个常开触点）。 EL2602的继电器触点直接连接电源触点，最大可以用到 230V AC，它通常用来控制需要电源的开关设备。 EtherCAT端子模块的信号状态由发光二极管指示。 EtherCAT 端子模块 EL2612, EL2622 和 EL2624 带有无源触点。 电源触点非闭环连通。

快速连接

• EtherCAT 基础
• 连接
• 调试


技术数据

BECKHOFF EL26xx: 产品概述

EL2602, EL2612, EL2622, EL2624 - 技术数据

技术数据 | EL2602 | EL2612 | EL2622 | EL2624
输出点数 | 2个连接电源触点的常开触点 | 2个转换触点 | 2个常开触点 | 4个常开触点
额定负载电压 | 230 V AC/30 V DC | 125 V AC/30 V DC | 230 V AC/30 V DC | 125 V AC/30 V DC
电阻式开关电流 | 5 A AC/DC | 0.5 A AC/ 2 A DC | 5 A AC/DC | 0.5 A AC/ 2 A DC
电感式开关电流 | 2 A AC/DC | - | 2 A AC/DC | -
最小允许负载 | 10 mA at 5 V DC | 10 µA at 10 mV DC | 10 mA at 5 V DC | 10 µA at 10 mV DC
指示灯测试，电子镇流器 | 4 x 58 W | - | 4 x 58 W | -
机械寿命 (min.) | 2 x 107 | 1 x 108 | 2 x 107 | 1 x 108
电气寿命 (min.) | 1 x 105 (5 A/30 V DC) | 2 x 105 (1 A/30 V DC) | 1 x 105 (5 A/30 V DC) | 2 x 105 (1 A/30 V DC)
电源供电 | 通过 E-Bus
E-bus(5 V)电流消耗 | 典型 170 mA | 典型 150 mA | 典型 170 mA | 典型 200 mA
电气隔离 | 500 Veff (E-Bus/Field 电压)
过程印象中的位宽 | 2个输出位 |  |  | 4个输出位
组态 | 无地址或组态设置
重量 | 大约 50 g | 大约 50 g | 大约 50 g | 大约 50 g
允许的运行环境温度范围 | 0 °C ... + 55 °C
允许的存储环境温度范围 | -25 °C ... + 85 °C
允许相对湿度 | 95%，无冷凝
尺寸 (W x H x D) | 大约 15 mm x 100 mm x 70 mm (对齐宽度: 12 mm)
安装 | 安装在 35 mm 导轨上 根据 EN 50022标准
抗振/抗冲击性能 | 根据 EN 60068-2-6/EN 60068-2-27/29标准
EMC 防爆性 / ESD | 根据 EN 61000-6-2/EN 61000-6-4标准
防护等级 | IP 20
安装位置 | 任意
认证 | CE UL |  |  | CE


启动

调试：

  • 如章节"安装与接线"中所示，安装 EL26xx
  • 如章节 “调试”中所示，在TwinCAT中配置EL26xx。


EtherCAT 基础

请参考 "EtherCAT System Documentation"EtherCAT现场总线基础章节。


EtherCAT 接线

BECKHOFF EtherCAT: 通信基础

EtherCAT 布线 – 接线

两台EtherCAT设备间电缆长度不能超过100米。 这与快速以太网技术一致，因为超过这个电缆的长度，会使信号衰减。允许的最长连接长度是5 + 90 + 5米。 详见 对 EtherCAT/Ethernet的设计建议.

电缆和接头

只有以太网连接器（电缆+插头）符合EN 50173 或ISO/IEC 11801至少category 5（CAt5)才可以连接EtherCAT设备。 EtherCAT用4根线来进行信号传输。

例如，EtherCAT用RJ45插头。 其引线分配符合以太网标准(ISO/IEC 8802-3)。

针脚 | 导体颜色 | 信号 | 描述
1 | 黄 | TD + | Transmission Data +
2 | 橙 | TD - | Transmission Data -
3 | 白 | RD + | Receiver Data +
6 | 蓝 | RD - | Receiver Data -

由于实现自动电缆检测，可以在Beckhoff的EtherCAT设备之间，使用对称或交叉电缆。

说明 		推荐电缆
适于连接EtherCAT设备的电缆可以在 Beckhoff 官网上找到!

E-Bus 电源供给

总线耦合器可以通过E-bus系统将5V电压供给EL端子； 一个耦合器可以提供2A电流（详细信息请查阅各个设备各自的文档）。
每个EL端子要消耗多少E-bus电流，可以从网站或样本里得到资料。 如果增加的端子所需的电流大于铜导线能提供的电流，那么供电端子 (例如 EL9400) 必须安装在模块组中合适的位置。

在TwinCAT 系统管理中会显示出E-bus预先计算好的电流理论最大值。 如果电流不足将会显示一个感叹号； 那么就需要在这个位置之前加一个电源模块。

图 1: 系统管理中电流的计算值

注意 		小心! 可能故障
在同一个端子模块组中，所有的EtherCAT端子的E-bus供电必须有相同的对地电势。


看门狗设置说明

ELxxxx 总线端子模块装有一个安全装置（看门狗）在发生数据传输中断一定时间后关闭输出。
EL2xxx总线端子模块的EtherCAT从站控制器(ESC)装有2个看门狗：

  • SM 看门狗（默认值 100 ms）
  • PDI 看门狗（默认值 100 ms）

SM 看门狗 (SyncManager 看门狗)

SyncManager 看门狗将会在每次EtherCAT成功通讯之后复位。 如果和终端模块没有EtherCAT数据传输的时间长于SM看门狗的设定时间，例如：在发生线路中断时，看门狗会触发并将输出设为FALSE。 端子模块的 OP状态不受影响 设置上述监视时间。

SyncManager看门狗在EtherCAT方面，监视ESC过程数据通讯的正确性。

PDI 看门狗 (过程数据看门狗)

如果EtherCAT从站控制器(ESC)与PDI看门狗没有数据传输的时间长于PDI看门狗的设定时间，就会激活PDI看门狗。
PDI (Process Data Interface) 是ESC和本地EtherCAT从站处理器之间的内部接口。 PDI 看门狗可用于监视此通信是否成功。

PDI看门狗在应用方面，监视ESC过程数据通讯的正确性。

图 1 EtherCAT tab -> Advanced Settings -> Behavior

倍增器

每个看门狗通过本地端子循环接收脉冲，由监视倍增器拆分。

1/25 MHz * (看门狗倍增器 + 2) = 100 µs (倍增器默认设置为 2498)

SM看门狗默认设置是1000相当于释放时间是100ms。

倍增数值+2相当于40ns倍数代表了看门狗的时间。
倍增器可以修改，以适应在更大范围内的看门狗时间。

例子"设定 SM 看门狗"

复选框使能手动设定看门狗时间。 如果设定了输出且EtherCAT通信中断，SM 看门狗将在设定时候到后复位输出。 修改这个设置以适应较慢的EtherCAT主站或更长的扫描周期。 默认SM看门狗设定为100 ms. 设定范围 0..65535. 加上倍增器范围是1~65535涵盖了看门狗0~170秒的周期。

计算

倍增数 = 2498 → 看门狗基准时间 = 1 / 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM 看门狗 = 10000 → 10000 * 100 µs = 1 second 看门狗监视时间

小心 		小心! 可能出现未定义状态!
只能在端子版本-0016上实现通过设定SM看门狗=0 来关闭SM看门狗功能。
在之前的版本这项功能不能使用。

小心 		小心! 设备损坏和可能出现未定义状态！
如果在SM看门狗激活之后，输入数字0，看门狗就会关闭。
这时如果通信中断了那么输出就不会被复位。


EtherCAT状态机

EtherCAT从站的状态由EtherCAT状态机（EMS）控制。 依据不同的状态，可以在EtherCAT从站中得到或执行不同的功能。 EtherCAT主站必须发送特殊指令来控制设备的每个状态，尤其是启动从站的时候。

有以下几种状态

  • Init
  • Pre-Operational
  • Safe-Operational
  • Operational
  • Boot

启动后每个EtherCAT从站的最终状态是OP状态。

Init

通电后EtherCAT为Init状态。 mailbox和过程数据无法通讯 。 EtherCAT主站初始化通道0和1同步管理器，为mailbox 通讯准备。

Pre-Operational (Pre-Op)

在 Init 和 Pre-Op的过渡过程中，EtherCAT从站检查mailbox是否正确初始化。

在 Pre-Op 状态 mailbox可以通讯, 但是过程数据无法通讯。 EtherCAT主站初始化过程数据的同步管理器通道 (来自于同步管理器通道2), FMMU通道和, 如果从站支持可调整映射，PDO映射或同步管理器PDO分配。 在这个状态，过程数据的传输设置和端子模块特殊设置也会被传输。

Safe-Operational (Safe-Op)

在 Pre-Op 和 Safe-Op的过渡过程中，EtherCAT从站检查是否过程数据通信的同步管理器通道和分布式时钟设置是否正确。 在确认状态转换之前，EtherCAT从站会将当前输入数据复制到EtherCAT从站控制器（ECSC）中的DP-RAM区域。

在Safe-Op状态可以进行mailbox和过程数据通讯，尽管从站的输出处于安全状态，但是输入数据可以循环更新。

Operational (Op)

在EtherCAT主站切换它的从站从Safe-Op到 Op 状态之前，必须传递有效的输出数据。

在 Op状态，从站复制主站输出数据到从站的输出。 可以进行mailbox和过程数据通讯

Boot

在 Boot 状态，可以更新从站的固件 Boot 状态只能从 Init 状态转换过来。

在 Boot状态，mailbox通讯可以通过file access over EtherCAT (FoE) 协议实现, 但是其他形式的mailbox和过程数据通讯不支持。


CoE-接口

CoE接口是 EtherCAT 设备的参数设定接口。 在CAN-over-EtherCAT (CoE)的管理机构中，特定的固件参数可以在网上或EtherCAT的离线参数中获得。

CoE接口的详细信息可以在Beckhoff 网站上 EtherCAT system documentation 中找到。


分布式时钟

分布式时钟代为EtherCAT从站控制器（ESC)中的本地时钟，有如下的特性：

• 单位 1 ns
• 零点1.1.2000 00:00
• 大小 64 字 (足够提供584年; 然而，有些EtherCAT只提供32字节的支持 即大约4.2秒）
• EtherCAT主站会自动同步主站时钟和EhterCAT总线中的本地时钟，精度达< 100 ns。

更详细的信息参考EtherCAT system description.


ELxxxx, KLxxxx - Installation on mounting rails

BECKHOFF 现场总线组件: 安装和接线

安装到导轨上

警告 		小心电击危险和损坏设备！
在安装，拆卸和连线之前确保总线终端处于安全的断开状态!

安装

总线耦合和总线终端都可以毫不费力地安装在35mm导轨上。这个导轨可以在市场上买到 (DIN 轨道依据 EN 50022标准)：

  1. 首先将现场总线耦合器安装在导轨上。
  2. 总线端子模块安装在总线耦合器的右侧。 通过卡槽将元件连接在一起且将端子按在导轨上，直到将锁扣扣在轨道上。
    如果先将终端模块夹在安装导轨上然后再连接到一起，且不使用卡槽连接，这样连接将不会运转！ 正确的连接是模块之间没有可见的缝隙。

说明 		固定安装导轨
在总线终端模块安装完之后，总线端子模块的锁定机构不能与安装轨道上的固定螺丝相碰。

拆卸

每个端子都用锁扣固定在安装轨道上，在拆卸的时候必须解开锁扣：
  1. 将端子模块上的橘黄色卡扣从安装轨道上拉出大约1cm。 这样做端子模块底部的导轨锁就松开了，然后你可以毫不费力的把端子模块模块拔出来。
  2. 同时用拇指和食指抓住总线端子模块上、下槽表面并拉出总线端子模块。

总线端子模块组合

总线耦合器和总线端子模块组合在一起后就自动完成了电气连接。

  • K-Bus/E-Bus的6个弹簧连接点负责数据传输和和总线端子模块的供电。
  • 电源触点负责给现场传感器供电，并在总线端子模块组中形成供电链。 总线耦合器电源触点供电最高为 24 V，如要更高的电压需要另外的电源供电模块。

说明 		电源触点
在设计总线端子模块时，必须计算总线端子的引脚分配，因为有些型号不会或不完全通过电源连接。（例如：模拟总线端子模块或4通道的数字总线端子模块）。
供电端子模块 (KL91xx, KL92xx or EL91xx, EL92xx) 中断电源并重新开始一个电源供应链路。

PE 电源触点

有PE标示的电源触片是用来接地保护的。 出于安全因素这个触片要先连接在一起，对地的最大短路电流是125 A。

注意 		可能损坏设备
考虑到电磁兼容性，PE触点与安装轨道之间是电容耦合的。 这可能会在绝缘测试时导致错误或损坏端子（例如：客户在绝缘测试时把230V放电到PE短路）。

如果要进行绝缘测试， 断开总线耦合器或供电端子模块的PE！ 为了完全断开供电触点, 把供电端子模块从导轨上拉出至少10mm。

警告 		小心触电
PE连接不能用来接其他的电位！


KLxxxx, KSxxxx, ELxxxx, ESxxxx - 连接系统

BECKHOFF 现场总线组件: 安装和接线

连接系统

警告 		小心电击危险和损坏设备！
在安装，拆卸和连线之前确保总线终端处于安全的断开状态!

概述

总线端子系统为不同的设备提供不同的最优连接：

  • KLxxx和ELxxxx系列接线端子模块连接器和电子元件封装在同一个外壳中。
  • KSxxxx 和 ESxxxx系列接线端子模块采用可插拔的连接器使更换时不需要接线。
  • 高密度端子模块系列 (HD Terminals)连接器和电子元件封装在同一个外壳中，封装密度更高。

标准接线

KLxxx和Elxxx端子系列经过多年测试。
集成无螺丝弹簧压紧技术，提供了快速简单的装配。

可插拔式接线

KSxxx和ESxxx端子系列的特点是可插拔式连接。
KS系列的安装和接线方式与KLxxxx 和 ELxxxx 系列类似。
KS/ES端子系列可以使插拔式连接器从外壳上完整移走便于维护。
拉起 解锁条可以把下部的模块从导轨上移除.
插入新的模块装上带线的连接器
节省安装时间减少接线错误

端子模块的尺寸基本相同，只有很小的变化。 新的连接器增加了约3mm 端子模块的最大高度保持不变

扎线环有助于扎紧电线，避免电线在拔下连接器时缠绕。

线径位于 0.08 mm2 和 2.5 mm2 都可以用弹簧连接器.

KSxxxx 和 ESxxxx 系列模块的型号命名方式 KLxxxx 和 ELxxxx 系列相同.

高密度端子模块 (HD Terminals)

KLx8xx 系列总线端子模块有16个连接点，是特别紧凑的设计，是传统12 mm 总线端子模块连接点数量的2倍。 硬导线和压了线套的导线可以直接插入弹簧接线孔而不需要工具。

说明 		高密度模块接线
高密度端子模块KLx8xx 和 ELx8xx 系列没有对应的可插拔连接器系列。

说明 		超声 “焊接" 导线
可以使用超声波“粘合”（超声波焊接）导体来连接标准或高密度端子模块。
在这种情况下, 请注意 下面线径说明表!

接线

连接 ELxxxx / KLxxxx 标准接线端子和 ESxxxx / KSxxxx可插拔式连接器

最多可以连接8根线到总线端子模块，把线扎在总线端子模块连接器上。 端子连接采用弹簧力连接技术。 根据下面的步骤来接线：

  1. 用螺丝刀插入位于接口上方的方形孔来打开弹簧接线端子。
  2. 现在电线可以毫不费力的直接插入圆形孔。
  3. 当拔掉螺丝刀后弹簧端口会自动合上，将接线永久牢固的接上。

端子模块外壳 | ELxxxx, KLxxxx | ESxxxx, KSxxxx
线径 | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
剥线长度 | 8 ... 9 mm | 9 ... 10 mm

高密度端子模块 ELx8xx, KLx8xx (HD)

单芯硬线连接HD端子模块的接点只需要剥线之后直接插入即可，不需要额外的工具。 导线可以用螺丝刀卸下。 下表为对线径的要求。

端子模块外壳 | ELx8xx, KLx8xx (HD)
线径 (导体两端有套筒） | 0.14... 0.75 mm2
线径 (单芯硬线) | 0.08 ... 1.5 mm2
线径 (细导线) | 0.25 ... 1.5 mm2
线径 (超声 “焊接" 导线) | 只能 1.5 mm2 (见 说明!)
剥线长度 | 8 ... 9 mm

屏蔽

说明 		屏蔽
模拟传感器和执行器总是用屏蔽双绞线相连。


安装辅助端子模块

说明 		安装辅助端子模块注意点
EtherCAT 总线端子模块 (ELxxxx / ESxxxx), 不担任数据传输任务的模块称为辅助端子模块。
辅助端子模块不消耗 E-bus电流
为确保最优的数据传输，不能连续连接超过两个接线端子模块。
辅助接线端子模块的实例（高亮部分）

例子 1 正确的配置

例子 2 错误的配置


LED 和连接

小心 		受伤的危险
在安装，拆卸和连线之前确保总线终端处于安全的断开状态!

注意 		可能会对设备造成的伤害！
当设计与电源触点不同电位的总线端子模块时 (e.g. 230 V AC 和 24 V DC),请注意必须使用电压分离模块 (EL9080)!

EL2602, EL2612, EL2622

LEDs

LED | 颜色 | 含义
OUTPUT 1 OUTPUT 2 | 绿色 | off | EL2602: 在output 1 resp. output 2 无输出电压 EL2612: 触点2-3 (Ch. 1) resp. 6-7 (Ch. 2) 闭合 EL2622: 触点1-2 (Ch. 1) resp. 5-6 (Ch. 2) 断开
 |  | on | EL2602: 在 output 1 resp. output 2的输出电压 (≤ 230 V AC resp. ≤ 30 V DC>) 在 output 1 resp. output 2 EL2612: 触点 2-1 (6-5) 闭合 EL2622: 触点 1-2 (Ch. 1) resp. 5-6 (Ch. 2) 闭合

连接 EL2612

端子模块 |  | 含义
描述 | No.
继电器 1 | 1 | Output 1
...230 V AC / DC | 2 | ≤ 230 V AC resp. ≤ 30 V DC (内部连接到端点 6 和 L 电源触点)
N / 0 V | 3 | 中性线 / 0 V (内部连接到端点 7 和 N 电源触点)
PE | 4 | PE (内部连接到端点 8)
继电器 2 | 5 | Output 2
...230 V AC / DC | 6 | ≤ 230 V AC resp. ≤ 30 V DC (内部连接到端点 2 和 L 电源触点)
N / 0 V | 7 | 中性线 / 0 V (内部连接到端点 3 和 N 电源触点)
PE | 8 | PE (内部连接到端点 4)

连接 EL2612

端子模块 |  | 状态
描述 | No.
继电器 1，13 | 1 | 继电器 1, NO contact
继电器 1, 11 | 2 | 继电器 1, Common contact
继电器 1, 12 | 3 | 继电器 1, NC contact
PE | 4 | PE (内部连接到端点 8)
继电器 2, 13 | 5 | 继电器 2, NO contact
继电器 2, 11 | 6 | 继电器 2, Common contact
继电器 2, 12 | 7 | 继电器 2, NC contac
PE | 8 | PE (内部连接到端点 4)

连接 EL2622

端子模块 |  | 状态
描述 | No.
继电器 1 | 1 | 继电器 1, NO contact
...230 V AC / DC | 2 | 继电器 1, ≤ 230 V AC resp. ≤ 30 V DC
- | 3 | 未连接
PE | 4 | PE (内部连接到端点 8)
继电器 2 | 5 | 继电器 2, NO contact
....230 V AC / DC | 6 | 继电器 2, ≤ 230 V AC resp. ≤ 30 V DC
- | 7 | 未连接
PE | 8 | PE (内部连接到端点 4)

EL2624

LEDs

LED | 颜色 | 状态
OUTPUT 1-4 | 绿色 | off | EL2624: 触点 1-2 (Ch. 1), 5-6 (Ch. 2), 3-4 (Ch. 3) resp.7-8 (Ch. 4) 断开
 |  | on | EL2624: 触点 1-2 (Ch. 1), 5-6 (Ch. 2), 3-4 (Ch. 3) resp.7-8 (Ch. 4) 闭合

连接 EL2624

端子模块 |  | 状态
描述 | No.
11 | 1 | 继电器 1, NO contact
13 | 2 | 继电器 1, ≤ 125 V AC resp. ≤ 30 V DC
31 | 3 | 继电器 3, NO contact
34 | 4 | 继电器 3, ≤ 125 V AC resp. ≤ 30 V DC
21 | 5 | 继电器 2, NO contact
23 | 6 | 继电器 2, ≤ 125 V AC resp. ≤ 30 V DC
41 | 7 | 继电器 4, NO contact
44 | 8 | 继电器 4 ,≤ 125 V AC resp. ≤ 30 V DC


配置

BECKHOFF EL26xx: 配置

在EtherCAT网络中插入端子

(主站: TwinCAT 2.1x)

说明 		最新XML设备描述的安装
请确保你已经在TwinCAT中安装了最新的XML设备描述 可以从 Beckhoff 主页上下载 (http://www.beckhoff.de/english/default.htm?download/elconfg.htm) 然后按照安装向导安装。

端子自动扫描

• | •总线端子系统必须按照 安装导轨章节中介绍的那样在插入端子网络前切为安全、断电状态。
• | •连上工作电压，启动TwinCAT System Manager (Config mode)，并扫描端子 (见 Fig. 1). 用 "OK"确认所有的对话框, 使配置在 "FreeRun" 状态下。

图 1: 在EtherCAT配置中进行扫描 (I/O Devices-> right-click -> Scan Devices...

手动添加一个端子模块

• | •总线端子系统必须按照 安装导轨章节中介绍的那样在插入端子网络前切为安全、断电状态。
• | •连上工作电压，启动TwinCAT System Manager (Config mode)
• | 添加一个新的 I/O 设备 (见 图. 2). 在出现的对话框中选择 device EtherCAT (Direct Mode), 见 图. 3 并确认 OK.

图 2: 添加新的 I/O 设备 (I/O Devices-> right-click -> Append Device... ) )

图 3: 选择 device EtherCAT (Direct Mode)

• 添加一个新的 box (见 图. 4). 在出现的对话框中选择 e.g. EK1100 系统耦合器，例如 (见 图. 5), 并确认 OK.

图 4: 添加一个新的box(Device -> right-click -> Append Box... ) )

图 5: 选择系统耦合器 (例如 EK1100)
• | 添加一个新的 box (见 图. 6). 在出现的对话框中选择 e.g. EL2624（见 图. 7), 并确认 OK.
• | 端子模块已经插入到 TwinCAT tree中（图 8).

图 6: 添加一个新的box(Device -> right-click -> Append Box... ) )

图 7: 选择端子模块 EL26xx

图 8: 在 TwinCAT tree 中的EL26xx端子模块


TwinCAT System Manager -配置

BECKHOFF TwinCAT System Manager: 配置

TwinCAT System Manager进行配置

(TwinCAT 2.10.0版本 (Build 1305), 06固件版本中EL1014模块)

在TwinCAT System manager左手边的窗口，点击你想要设置的模块（如例：EL1014 Terminal 4: EL1014 Terminal 4).

在TwinCAT System manager右手边的窗口，有多个用来设置端子的标签。

General tab

Name | EtherCAT 设备名称
Id | EtherCAT 设备编号
Type | EtherCAT 设备说明
意见 | 这里你可以添加注释(比如，关于系统)。
Disabled | 你可以在这里停止使用EtherCAT设备。
Create symbols | 如果选中复选框，可以通过ADS连接这个EtherCAT从站

EtherCAT tab

Type | EtherCAT 设备说明
Product/Revision | EtherCAT 设备的型号和版本
Auto Inc Addr. | EtherCAT设备的地址自动增量。 自动增量地址可以通过EtherCAT设备的物理地址在通信环中定位它的地址。 自动增量地址更据EtherCAT设备在通信环中的物理位置排列。 在通信环中的第一个EtherCAT从站的地址就是0000hex. 之后的从站地址减 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | 固定 EtherCAT 从站地址。 此地址由EtherCAT 主站启动时分配。 选中左侧的复选框后即可修改。
Previous Port | 已连接的前一个EtherCAT设备的名字和端口。 这里可以通过不改变EtherCAT通讯环来选择这个设备与另一个设备的连接，下拉框里列出可以选择的EtherCAT设备。
Advanced Settings | 点击这个按钮 打开高级设置对话框。

底部的链接指向网站上的产品页面

Process Data tab

为过程数据的设置。 EtherCAT 从站的输入输出数据是用CANopen数据对象(PDO)来表示。 数字量输入端子模块（EL10xx)和数字量输入端子模块（EL20xx)中固定的PDO配置.

Sync Manager

列出Sync Manager（SM）的设置。
相应的PDO设置会在下面的PDO Assignment内容中有详细说明。

PDO Assignment

所选 Sync Manager的PDO分配 当前Sync Manager 类型所定义的所有PDOs 都显示在这里. 选择的PDOs将确定过程数据的传输。 在System Manager的树形列表中，这些PDOs以EtherCAT从站变量的形式显示。 变量名和在PDO列表中的PDO的参数名 完全一样。

PDO list

列出EtherCAT 设备所支持的所有PDO。 所选择PDO的内容会在 PDO Content 列表中显示出来。 可以通过双击来修改PDO配置。

列 | 描述
Index | PDO 索引
Size | PDO的 byte数
Name | PDO名称 如果这个PDO 分配到Sync Manager，从站的变量名即为此参数。
Flags | F | 固定内容: 这个PDO的内容被固定，且不能用System Manager修改。
 | M | 管理 PDO. 这个PDO是强制的必须分配到Sync Manager! 因此这个PDO不能从 PDO Assignment列表中删除
SM | 显示这个PDO 与哪个Sync Manager 关联。 如果是空的，那么就说明这个PDO不在过程数据中。
SU | 显示这个PDO与哪个Sync unit关联

PDO Content

显示PDO内容

Download

PDO Assignment, PDO Configuration

PDO Assignment and PDO Configuration 下载功能仅支持与智能端子模块中。

Online tab

状态机

Init | 这个按钮将EtherCAT 从站设为Init 状态。
Pre-Op | 这个按钮将EtherCAT 从站设为 pre-operational状态
Op | 这个按钮将EtherCAT 从站设为 operational状态
Bootstrap | 这个按钮将EtherCAT 从站设为Bootstrap 状态。
Safe-Op | 这个按钮将EtherCAT 从站设为 safe-operational状态
Clear Error | 这个按钮将删除显示中的错误信息。 如果EtherCAT从站在状态转换中出错了，它就会设定一个出错标志位. 例子: 一个EtherCAT从站处于PREOP状态 (pre-operational)。 主站现在请求它进入SAFEOP状态（safe-operational). 如果从站在状态转换中出错，那么它就会设置错误标志。 当前状态就会显示为ERR PREOP。 当点过 Clear Error按钮后错误标志清楚, 然后状态变为 PREOP。
Current State | 显示EtherCAT从站的当前状态。
Requested State | EtherCAT 从站被要求的状态。

DLL 状态

表明EtherCAT从站独立端口的的DLL状态 (数据链路层状态) DLL有四种不同的状态：

状态 | 描述
No Carrier / Open | 端口无载波信号, 但是端口开放。
No Carrier / Closed | 端口无载波信号, 但是端口是关闭的。
Carrier / Open | 端口有载波信号，但是端口是开放的
Carrier / Closed | 端口有载波信号，但是端口是关闭的。

File Access over EtherCAT

Download | 无智能功能端子模块无法实现。
Upload | 无智能功能端子模块无法实现。


正确使用继电器端子模块的注意事项

遵守技术规范对于保证无故障运行来说是极为重要的。 一旦超过了规定的参数，可能会导致从过早老化到触点烧断的不同程度损坏。

若要在控制系统中使用继电器，所期望的运行条件必须仔细分析。 开关容量，服务寿命（运行周期）和每分钟的开关次数。 应当使用适当的保护电路来保护继电器触点不受开关感性负载（触点、电机等）时产生的过高的电压峰值的损害。 这使开关频率近似等于适当的电阻负载所达到的值。

相同的交流电压相比，当开关直流负载时电弧时间与相同的交流电压相比大大延长（有零电势过度） 可能导致材料融化。 如果端子模块是用来改变感性负载的方向，应在开关过程中留有足够的死区时间，以避免临时的电路短路。

说明 		经济寿命
选择端子模块时，预期的最大值相对正常运行时的技术参数更为重要。


UL 需求

BECKHOFF EKxxxx, ELxxxx: 附录

UL 说明

应用
Beckhoff EtherCAT 模块仅适用于Beckhoff UL 列表中的EtherCAT系统。
测试
更据cULus 测试, Beckhoff I/O 系统仅进行了防火和电击测试 has only been investigated for risk of fire and electrical shock (更据 UL508 和 CSA C22.2 No. 142. 142).
对于以太网接口设备
不适用于连接通信线路

基本原理

倍福EtherCAT产品的两个UL认证，因产品而异：

  • 符合UL508标准的UL认证
    拥有该认证的设备会有这样的标记：

  • 符合限制电源消耗UL508标准的UL认证
    由设备所消耗的电流被限制到最大，可能能达到4 A 。 拥有该认证的设备会有这样的标记：

几乎所有的EtherCAT产品（截止到2010/5）都是非限制的UL认证。

应用

如果端子模块通过 限制认证 , 那么24 V DC 电流消耗必须受到电源限制。

  • 从一个由最大保险丝保护的独立来源 4A (按照 UL248) 或者
  • 由一个符合 NEC class 2的电源供电。
    符合 NEC class 2 的电源不能与另一个 NEC class 2 电源串联或并联使用!

这些要求适用于所有的EtherCAT总线耦合器电源，电源适配器端子模块，总线端子模块以及它们的电源触点。


BECKHOFF EL26xx: 附录

固件兼容性

EL26xx系列无固件更新。


ELxxxx - 固件

BECKHOFF ELxxxx: 设备升级

固件 EL/ES/EMxxxx

这部分描述了Beckhoff EtherCAT从站 EL/ES, EM, EK和EP系列的版本升级。. 固件的升级只能在咨询Beckhoff技术支持之后才能执行。

目录
• 存储位置
• ESI版本定义
• 设备描述升级 ESI/*.xml
• 固件版本描述
• 固件升级文件 *.efw
• 固件升级文件 *.rbf
• 批量更新

存储位置

EtherCAT从站在3个地方存储运行数据：

  • 更据功能和性能EtherCAT从站有一个或几个本地控制器用于传输I/O数据。 所对应的程序称为 固件 为 *.efw 格式。
  • 某些EtherCAT从站的EtherCAT通讯功能也集成在控制器中。 这种情况的控制器叫做 FPGA 芯片使用 *.rbf 格式的固件。
  • 另外每个EtherCAT从站有存储芯片保持设备参数叫做 EEPROM. 通电后自动加载参数，EtherCAT通信也相应设定。 设备描述可以从 http://www.beckhoff.com 下载区下载。 所有 ESI 文件(EtherCAT Slave Information) 压缩成ZIP格式。

客户可以通过 EtherCAT 现场总线和其通信机制访问数据。 ESC读写来实现异步mailbox通讯或访问寄存器。

TwinCAT System Manager提供配置所有这3部分数据的方法，如果从站支持这些数据。 通常从站不会检查新数据是否适合，例如，数据不适合的话从站就再也无法工作。

注意 		小心设备损坏!
当下载新的设备文件时注意如下几点
  • 下载固件到EtherCAT设备时不能被打断
  • 确保EtherCAT通信稳定。 不能有CRC错误或 LostFrames。
  • 供电必须稳定。 信号等级必须达到规范。

设备更新数据时发生故障可能使模块不能使用，需要返厂修复。

设备描述 ESI文件/XML

注意 		关于ESI说明/EEPROM的更新的注意事项
一些从站在产品的EEPROM中存储了标度和配置的数据。 这些在数据更新中被覆盖。

ESI设备描述存储在本机，并且启动时载入。 每个设备描述为唯一的从站名（10个字符数）和版本号（4个数字） 每个从站的名称都在System Manager的 EtherCAT 页面显示:

图 1: 设备识别符号由名称EL3204-0000和修订号-0016组成

配置识别符号必须与实际的硬件设备兼容。在启动时读取从站型号（如EL3204)。 通常配置的修订号必须等于或高于端子模块的版本 。

说明 		更新 XML/ESI 描述文件
用于硬件设备的固件版本是紧密联系在一起的。 不相容的组合会导致故障或设备关机。
相应的更新只能在咨询Beckhoff技术支持之后才能进行。

显示 ESI从站型号

最简单的确定实际设备描述与配置的设备描述是否一致的方法是在 TwinCAT Config/Freerun 模式下扫描EtherCAT 设备：

图 2: 在Config/FreeRun模式下右键EtherCAT device 然后 Scan Boxes

如果实际与配置相符，则显示下

图 3: 配置相同

否则就显示修改对话框来修改配置

图 4: 修改对话框

在图4中所示的例子中 当 EL3201-0000-0016 配置完成时，EL3201-0000-0017 被发现。 这种情况下可用CopyBefore按钮来修改配置。 ExtendedInformation复选框必须勾上才能显示版本信息。

修改 ESI 从站版本

ESI/EEPROM 版本可以通过 TwinCAT更新:

  • EtherCAT从站通讯不能中断.
  • 从站的状态不重要。
  • 在online标签中右键从站以打开 EEPROM Update 对话框，图 5

图 5: EEPROM 更新

在对话框中选择新ESI 描述文件, 见图 6. ShowHiddenDevices 复选框钩上可以显示老的版本号，默认不显示。

图 6: 选择新ESI 描述文件

System Manager中的进度条显示当前进度。 数据写入后再进行校验。

说明 		重启后更新生效
大多数EtherCAT立刻读取修改的ESI说明或者在初始化启动之后。 一些通讯设置比如分布式时钟仅在电源打开后读取。
因此为了使修改后的参数生效，EtherCAT从站必须断电重启。

确定固件版本

通过序列号确定固件版本

Beckhoff EtherCAT从站的序列号是用激光刻上的。 序列号的结构如下： KK YY FF HH

KK - 生产周 (CW, 日历周)
YY - 生产年
FF - 固件版本
HH - 硬件版本

以下面的序号为例： 12 10 03 02:

12 - 第 12周生产
10 - 2010 年生产
03 - 固件版本 03
02 - 硬件版本 02

通过System Manager查看版本

主站和从站通信上之后TwinCAT System Manager 即可显示从站控制器的固件版本。 选中你想查看的那个E-Bus端子模块 (本例terminal 2 (EL3204))然后选择CoE Online (CAN over EtherCAT).

说明 		CoE Online和 Offline CoE
有2个CoE 目录：
  • online: 如果从站支持的话，由EtherCAT从站控制器提供。
    只有从站处于连接和运行的状态这个CoE目录才会被显示。
  • offline: EtherCAT 从站信息文件 ESI/XML包含 CoE默认数据.
    CoE目录只显示包含在ESI文件中的信息 (e.g. "Beckhoff EL5xxx.xml. "Beckhoff EL5xxx.xml").

Advanced 按钮用于切换这两种显示。

在图. 7中 CoE索引x100A EL3204的固件版本为03

图 7: 显示 EL3204固件版本

(A) TwinCAT 2.11 指示当前显示 Online CoE 目录 如果当前不是这样, 可以进入 Advanced Settings (B) Online选项 然后双击 AllObjects. 显示所有的Online目录。

升级控制器固件 *.efw

说明 		CoE 目录
由控制器管理的Online CoE目录存储在专用的EEPROM中，这个目录通常在固件更新时不会被改变。

为了更新从站控制固件，选中 Online， 见图8 8.

图 8: 固件更新

如果没有Beckhoff技术支持指导话，请按如下步骤进行。

  • 切换从站到 INIT (A)
  • 切换从站到BOOTSTRAP
  • 检查当前状态 (B, C)
  • 下载新 *efw 文件
  • 下载完成后切换到 INIT状态，然后切换到 OP状态
  • 从站重上电一次

FPGA 固件文件 *.rbf

如果是 FPGA芯片负责处理EtherCAT通讯，可以通过更新 *.rbf文件来完成升级。.

  • 控制器固件 处理 I/O信号
  • FPGA 固件 处理EtherCAT 通信 (仅针对采用 FPGA芯片的端子模块)

包括在端子模块的序列号的固件版本号包含这两个固件组件。 如果其中一个固件更新，那这个版本号就会被更新。

通过System Manager查看版本

在TwinCAT System Manager查看FPGA固件版本。 选中EtherCAT 卡 (本例中的 Device 2) 然后选择 Online 标签

Reg:0002 列分别用十六进制和十进制显示了每个EtherCAT设备的固件版本。

图 9: FPGA固件版本确认

如果 Reg:0002列不显示，在表格中右键然后选择Properties...

图 10: 弹出菜单Properties

Advanced Settings对话框显示哪些列可以被显示。 在 Diagnosis/Online View下 '0002 ETxxxx Build'选中复选框，使FPGA固件版本可以显示。

图 11: 高级设置对话框

更新

更新 FPGA固件

  • EtherCAT耦合器 FPGA固件版本为11或以上;
  • E-bus端子模块FPGA固件版本为10或以上。

更早的固件件版本只能由制造商来更新！

升级EtherCAT设备

在TwinCAT System Manager中选择端子，并且你想将这个端子的FPGA固件更新（在这个例子中的端子5： EL5001) 和
点击Advanced Settings in the EtherCAT tab。

图 12: 选择高级设置对话框

Advanced Settings对话框显示。 在 ESC Access/E²PROM/FPGA点击 Write FPGA 按钮,

图 13: 选择写FPGA对话框

选择新 FPGA固件文件 (*.rbf) 然后下载到 EtherCAT设备。

注意 		小心设备损坏!
EtherCAT设备的固件更新过程中不能中断！

如果下载过程被取消，电源断开或是Ethernet连接中断，那此EtherCAT设备只能由制造商来修复！

为了激活新的FPGA固件，EtherCAT设备必须重启（将电源关闭再启动）。

同时更新数台 EtherCAT 设备

如果设备有相同的固件文件/ESI，那么几台设备的固件和ESI描述可以同步更新。

图 14: 多重选择和固件更新

选择需要的从站然后在BOOTSTRAP模式下执行固件的更新。


技术支持与售后

Beckhof f 及其合作伙伴遍布世界各地，可为您提供全方位的技术支持与服务，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff 分公司及代表处

有关 Beckhoff 产品的本地技术支持和服务信息，请联系当地的 Beckhoff 分公司和代表处！

有关 Beckhoff 在全球各地分公司和代理商的地址，您可以登录Beckhoff 的官方网站：
http://www.beckhoff.com

此外，您也可以在该网站上查看更多关于 Beckhoff 组件的文档资料。

Beckhoff 总部

德国倍福自动化有限公司

Eiserstr. 5
33415 Verl
德国

电话 | +49(0)5246/963-0
传真： | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff 技术支持

Beckhoff为您提供全面的技术支持，除了Beckhoff 具体产品的应用以外，还包括更广泛的服务：

  • 技术支持
  • 复杂自动化系统的设计、编程和调试
  • 各种 Beckhoff 系统组件培训方案
热线： | +49(0)5246/963-157
传真： | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心提供全方位的售后技术服务:

  • 现场服务
  • 维修服务
  • 零部件服务
  • 热线服务
热线： | +49(0)5246/963-460
传真： | +49(0)5246/963-479
e-mail: | service@beckhoff.com


KLxxxx, ELxxxx 安装位置

BECKHOFF 现场总线部件: 安装和接线

安装位置

注意 		相关安装位置的约束条件和工作温度
请参考各端子模块技术数据，确保相关安装的位置和工作温度是符合规定的。

当安装大功率损耗的端子模块时确保其他部件上方和模块下方有足够的空间以保证设备空气流通顺畅。

最佳的安装位置（标准）

最佳的安装位置需要安装导轨平坦地放置，EL/KL端子模块的连接表面面向前方（参看图 1. 1). 端子模块是从下面通风的，通过空气对流使电子设备处在一个最佳的温度中。 从下面可以获得相关的重力加速度。

图 1: 标准安装位置的推荐距离

按照图中显示的距离， 推荐为1.

其它安装的位置

所有其他安装位置的特点是由安装导轨上端子不同的空间排列所决定的-参看图 2.

如上所规定的四周最小距离也同样适用于这些安装位置中。

图 2: 其它安装的位置