EL30xx - Analog Input Terminals (12 bit, single-ended)

BECKHOFF Fieldbus Components

文档

模拟输入端子模块 (12 bit, single-ended)

EL3001, EL3002, EL3004, EL3008

1, 2, 4 and 8 通道, -10 V to +10 V

EL3041, EL3042, EL3044, EL3048

1, 2, 4 and 8 通道, 0 to 20 mA

EL3051, EL3052, EL3058

1, 2 and 8 通道, 4 to 20 mA

EL3054

4 通道, 4 to 20 mA, 单端, 电路回路馈电传感器电源

EL3061, EL3062, EL3064, EL3068

1, 2, 4 and 8 通道, 0 to 10 V

EL3062-0030

2 通道, 0 to 30 V

Version: 1.6
Date: 2011-08-25

EtherCAT®是注册商标和专利技术，由德国倍福自动化有限公司授权


BECKHOFF 自动化: 前言

文档说明

本手册仅供那些受过适当培训，熟悉各种适用国家标准的“控制、自动化和驱动工程”领域专业人员使用。
在安装和调试这些组件时，操作人员必须严格遵循下列说明和解释。

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

免责声明

尽管本文档经过精心编制，但由于其中所描述的产品仍处于不断更新换代中，我们可能不会在每次更新后都检查文档中所描述的产品性能数据、标准或其它特性总是与实际产品相一致。
本文档中难免会出现一些技术或者编辑错误，我们保留随时对文档信息作出修改之权力，恕不另行通知。对于已经变更的产品，如果本文档中的数据、图表以及文字描述没有修改，我们将不再特别加以声明。

商标

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® 已为Beckhoff 自动化有限公司的注册商标
本出版物中的相关名称若被第三方出于个人目的，用作商标，将侵犯其拥有者的权利。

申请中的专利

已包含EtherCAT技术但不局限于如下专利申请和专利:
在许多其他国家有关EP1590927, EP1789857, DE102004044764, DE102007017835的相关申请和注册。

已包含TwinCAT技术但不局限于如下专利申请和专利:
在许多其他国家有关EP0851348, US6167425的相关申请和注册。

版权

© 德国倍福自动化有限公司.
未经许可，任何人不得复制、分发和使用本手册以及内容传播。
违者将追究损害赔偿 版权所有，包括实用新型的模型和外观设计的版权。


安全说明

安全规程

请仔细阅读下列安全说明及相关描述！
有关产品特定安全规程，请见后面页或有关安装，接线及调试等章节。

免责声明

所有组件在供货前均针对其具体应用进行了特定的软、硬件配置。 任何人不得对软、硬件配置进行文本档中规定之外的修改，德国倍福自动化有限公司对因此而造成的一切后果不承担任何责任。

人员资质

本手册仅供那些受过适当培训，熟悉各种适用国家标准的“控制、自动化和驱动工程”领域专业人员使用。

安全标志说明

本操作手册中用到了下列安全标志及相应的安全说明。 请仔细阅读并严格遵守。

危险 		有严重人身伤害危险!
不遵守本标志相关的安全说明将直接危及个人生命和健康安全。

警告 		受伤的危险
不遵守本标志相关的安全说明将危及个人生命和健康安全。

小心 		危害个人
不遵守本标志相关的安全说明可能明显危害个人安全。

注意 		对环境和设备有危险
不遵守本标志相关安全说明可能明显危害环境和设备安全。

说明 		说明或提示
该标志表示这些信息能够帮助您更好地理解安全说明。
UL 说明
这个标志用于表示有关UL标准的重要信息。.


EL30xx - Documentation issue status

BECKHOFF EL30xx: Foreword

文档版本

版本 | 注释
1.6 | - 小的更正
1.5 | - 改善LED描述
1.4 | - 改善图片处理，增加商标参考，更新章节“固件”
1.3 | - 增加技术提示
1.2 | - 增加技术提示
1.1 | - 增加技术数据
1.0 | - 首次公开发行
0.1 | - EL3602的第一个临时文件

固件和硬件版本

文件版本 | EL3001 |  | EL3002 |  | EL3004 |  | EL3008
 | 固件 | 硬件 | 固件 | 硬件 | 固件 | 硬件 | 固件 | 硬件
1.6 | 04 | 04 | 04 | 04 | 04 | 04 | 04 | 03
1.5 | 04 | 04 | 04 | 04 | 04 | 04 | 04 | 03
1.4 | 04 | 03 | 04 | 03 | 04 | 03 | 04 | 02
1.3 | 02 | 03 | 02 | 03 | 02 | 03 | 02 | 02
1.2 | 02 | 03 | 02 | 03 | 02 | 03 | 02 | 02
1.1 | 01 | 02 | 01 | 02 | 01 | 02 | 01 | 02
1.0 | 01 | 02 | 01 | 02 | 01 | 02 | 01 | 02
0.1 | 01 | 02 | 01 | 02 | 01 | 02 | 01 | 02
文件版本 | EL3041 |  | EL3042 |  | EL3044 |  | EL3048
 | 固件 | 硬件 | 固件 | 硬件 | 固件 | 硬件 | 固件 | 硬件
1.6 | 04 | 03 | 04 | 03 | 05 | 03 | 05 | 03
1.5 | 04 | 03 | 04 | 03 | 05 | 03 | 05 | 03
1.4 | 04 | 02 | 04 | 02 | 04 | 02 | 04 | 02
1.3 | 02 | 02 | 02 | 02 | 02 | 02 | 02 | 02
1.2 | 02 | 02 | 02 | 02 | 02 | 02 | 02 | 02
1.1 | 01 | 02 | 01 | 02 | 01 | 02 | 01 | 02
1.0 | 01 | 02 | 01 | 02 | 01 | 02 | 01 | 02
0.1 | 01 | 02 | 01 | 02 | 01 | 02 | 01 | 02
文件版本 | EL3051 |  | EL3052 |  | EL3054 |  | EL3058
 | 固件 | 硬件 | 固件 | 硬件 | 固件 | 硬件 | 固件 | 硬件
1.6 | 04 | 03 | 04 | 03 | 05 | 04 | 05 | 04
1.5 | 04 | 03 | 04 | 03 | 05 | 04 | 05 | 04
1.4 | 04 | 02 | 04 | 02 | 04 | 02 | 04 | 02
1.3 | 02 | 02 | 02 | 02 | 02 | 02 | 02 | 02
1.2 | 02 | 02 | 02 | 02 | 02 | 02 | 02 | 02
1.1 | 01 | 02 | 01 | 02 | 01 | 02 | 01 | 02
1.0 | 01 | 02 | 01 | 02 | 01 | 02 | 01 | 02
0.1 | 01 | 02 | 01 | 02 | 01 | 02 | 01 | 02
文件版本 | EL3061 |  | EL3062 |  | EL3064 |  | EL3068
 | 固件 | 硬件 | 固件 | 硬件 | 固件 | 硬件 | 固件 | 硬件
1.6 | 03 | 04 | 03 | 04 | 05 | 05 | 05 | 04
1.5 | 03 | 04 | 03 | 03 | 05 | 05 | 05 | 04
1.4 | 03 | 03 | 03 | 03 | 04 | 03 | 04 | 02
1.3 | 02 | 03 | 02 | 03 | 02 | 03 | 02 | 02
1.2 | 02 | 03 | 02 | 03 | 02 | 03 | 02 | 02
1.1 | 01 | 02 | 01 | 02 | 01 | 02 | 01 | 02
1.0 | 01 | 02 | 01 | 02 | 01 | 02 | 01 | 02
0.1 | 01 | 02 | 01 | 02 | 01 | 02 | 01 | 02
文件版本 | EL3062-0030
 | 固件 | 硬件
1.6 | 03 | 04
1.5 | 03 | 04
1.4 | 03 | 02
1.3 | 02 | 02
1.2 | 02 | 02
1.1 | 01 | 02
1.0 | 01 | 02
0.1 | 01 | 02

在终端的侧面印有序列号，可以看到固件和硬件版本（出厂状态）。

序列号

序列号结构: KK YY FF HH

KK - 生产周
(CW, 日立周)
YY - 生产年份
FF - 固件版本 HH - 硬件版本

例如.: 12 06 3A 02:

12 - 生产周12
06 - 生产年份 2006
3A - 固件版本 3A
02 - 硬件版本 02


EL3001, EL3002 - Introduction

BECKHOFF EL3001, EL3002: Product Overview

EL3001, EL3002 - 介绍

1/ 2 通道模拟量输入端子模块，-10…+10 V，单端输入，12位

EL3001 和 EL3002 模拟量输入端子模块用于处理 -10 到 +10 V 范围内的信号。电压被数字化后的分辨率为 12 位，并在电隔离的状态下被传送到上一级自动化设备。总线端子模块的输入通道有差分输入，并具有一个公共的内部接地电位端。EL3001 是带差分输入的单通道型端子模块，具有精细分级和电气隔离的特点。而 EL3002 型端子模块则有 2 个通道。总线耦合器的数据交换通过 LED 指示。

快速链接

• EtherCAT 基础功能
• 数据处理和操作模式
• Object的描述和参数化


EL3004, EL3008 - Introduction

BECKHOFF EL3004, EL3008: Product Overview

EL3004, EL3008 - 介绍

4/ 8 通道模拟量输入端子模块，-10…+10 V，单端输入，12位

EL3004 和 EL3008 模拟量输入端子模块用于处理 -10 到 +10 V 范围内的信号。电压被数字化后的分辨率为 12 位，并在电隔离的状态下被传送到上一级自动化设备。EL3004总线端子模块的输入通道有4个差分输入，并具有一个公共的内部接地电位端。而 EL3002 型端子模块则有 8 个通道，连接了电源触点，所有输入端的接地端是电源的0V触点。总线耦合器的数据交换通过 LED 指示。

快速链接

• EtherCAT 基础功能
• 数据处理和操作模式
• Object的描述和参数化


EL300x - Technical data

BECKHOFF EL300x: Product Overview

EL300x - 技术数据

技术数据 | EL3001 | EL3002 | EL3004 | EL3008
输入点数 | 1 | 2 | 4 | 8
信号电压 | -10 V ... +10 V
内部电阻 | > 130 kΩ
分辨率 | 12 位（显示分辨率为 16位）
转换时间（默认设置：50Hz滤波） | 一般为0,625 ms |  |  | 一般为1,25 ms
最低滤波输入频率 | 1 kHz
测量误差 | < ± 0,3 % (相当于满刻度值)
内部E bus电路的电源电压 | 通过E-bus
E-bus的电流消耗 | 一般130 mA
分布式时钟 | 不支持
电气隔离 | 500 Veff (E-Bus/信号电压)
过电压能力 | 最大30 V
过程映像位宽 | 4 位输入 | 8位输入 | 16位输入 | 32位输入
配置 | 通过TwinCAT System Manager
重量 | 大约70 g
工作温度 | 0°C ... + 55°C
存储温度 | -25°C ... + 85°C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm (width aligned: 12 mm)
安装 | 35毫米的安装导轨符合EN 50022标准
抗振动/抗冲击性能 | 符合EN 60068-2-6/EN 60068-2-27/29
EMC防电阻爆裂 | 符合EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认可 | CE Ex UL


EL3041, EL3042 - Introduction

BECKHOFF EL3041, EL3042 Product Overview

EL3041, EL3042 - 介绍

1/2 通道回路供电输入端子模块，0…20 mA，单端输入，12位

EL3041 和 EL3042 模拟量输入端子模块用于给现场测量传感器供电，并将模拟量测量信号在电隔离的状态下传送到自动化设备。端子模块通过电源触点为传感器供电。电源触点既可以标准方式供电，也可通过电气隔离的电源馈电端子模块（EL9xxx）供电。输入电子电路与电源触点的供电电压分离。0 V 导轨作为输入的基准电位。运行 LED 指示总线耦合器的数据交换状态。故障 LED 指示过载和断线状态。

快速链接

• EtherCAT 基础功能
• 数据处理和操作模式
• Object的描述和参数化


EL3044, EL3048 - Introduction

BECKHOFF EL3044, EL3048: Product Overview

EL3044, EL3048 - 介绍

4/8 通道模拟量输入端子模块，0…20 mA，单端输入，12位

EL3044和EL3048模拟量输入端子模块用于处理 -10 到 +10 V 范围内的信号。电压被数字化后的分辨率为 12 位，并在电隔离的状态下被传送到上一级自动化设备。接地点作为输入的基准电位。EL3044总线端子模块的输入通道有4个单端输入，并具有一个公共的内部接地电位端。而 EL3048 型端子模块则有 8 个通道，连接了电源触点，所有输入端的接地端是电源的0V触点。总线耦合器的数据交换通过 LED 指示。

快速链接

• EtherCAT 基础功能
• 数据处理和操作模式
• Object的描述和参数化


EL304x- Technical data

BECKHOFF EL304x: Product Overview

EL304x - 技术数据

技术数据 | EL3041 | EL3042 | EL3044 | EL3048
输入点数 | 1 | 2 | 4 | 8
信号电压 | 0 mA ... 20 mA
内部电阻 | 一般为85 Ω
分辨率 | 12位(显示分辨率为16 bit)
转换时间（默认设置：50Hz滤波） | 一般为0,625 ms |  |  | 一般为1,25 ms
最低滤波输入频率 | 1 kHz
测量误差 | < ± 0,3 % (相当于满刻度值)
内部E bus电路的电源电压 | 通过E-Bus
E-bus的电流消耗 | 一般130 mA
分布式时钟 | 不支持
电气隔离 | 500 Veff (E-Bus/励磁电压)
过电压能力 | 最大30 V
过程映像位宽 | 4位输入 | 8位输入 | 16位输入 | 32位输入
配置 | 通过TwinCAT System Manager
重量 | 大约60 g
工作温度 | 0°C ... + 55°C
存储温度 | -25°C ... + 85°C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm (width aligned: 12 mm)
安装 | 35毫米的安装导轨符合EN 50022标准
抗振动/抗冲击性能 | 符合EN 60068-2-6/EN 60068-2-27/29
EMC防电阻爆裂 | 符合EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认可 | CE Ex UL


EL3051, EL3052 - Introduction

BECKHOFF EL3051, EL3052: Product Overview

EL3051, EL3052 - 介绍

1/2 通道回路供电输入端子模块，4…20 mA，单端输入，12位

EL3051 和 EL3052 模拟量输入端子模块用于给现场测量传感器供电，并将模拟量测量信号在电隔离的状态下传送到自动化设备。端子模块通过电源触点为传感器供电。电源触点既可以标准方式供电，也可通过电气隔离的电源馈电端子模块（EL9xxx）供电。输入电子电路与电源触点的供电电压分离。0 V 导轨作为输入的基准电位。运行 LED 指示总线耦合器的数据交换状态。故障 LED 指示过载和断线状态。

快速链接

• EtherCAT 基础功能
• 数据处理和操作模式
• Object的描述和参数化


EL3054, EL3058 - Introduction

BECKHOFF EL3054, EL3058: Product Overview

EL3054, EL3058 - 介绍

4/8 通道模拟量输入端子模块，0…20 mA，单端输入，12位

EL3044和EL3048模拟量输入端子模块用于处理 -10 到 +10 V 范围内的信号。电压被数字化后的分辨率为 12 位，并在电隔离的状态下被传送到上一级自动化设备。接地点作为输入的基准电位。EL3044总线端子模块的输入通道有4个单端输入， 并连接24V电源触点。而 EL3058 型端子模块则有 8 个通道，连接了电源触点，所有输入端的接地端是电源的0V触点。总线耦合器的数据交换通过 LED 指示。错误的LED显示表明过载或者线路损坏。

快速链接

• EtherCAT 基础功能
• 数据处理和操作模式
• Object的描述和参数化


EL305x- Technical data

BECKHOFF EL305x: Product Overview

EL305x - 技术数据

技术数据 | EL3051 | EL3052 | EL3054 | EL3058
输入点数 | 1 | 2 | 4 | 8
信号电压 | 4 mA ... 20 mA
内部电阻 | 一般为85 Ω
分辨率 | 12 bit (显示分辨率为16位)
转换时间（默认设置：50Hz滤波） | 一般为0,625 ms |  |  | 一般为1,25 ms
最低滤波输入频率 | 1 kHz
测量误差 | < ± 0,3 % (相当于满刻度值)
内部E bus电路的电源电压 | 通过E-Bus
E-bus的电流消耗 | 一般130 mA
分布式时钟 | 不支持
电气隔离 | 500 Veff (E-Bus/励磁电压)
过电压能力 | 最大30 V
过程映像位宽 | 4位输入 | 8位输入 | 16位输入 | 32位输入
配置 | 通过TwinCAT System Manager
重量 | 大约60 g
工作温度 | 0°C ... + 55°C
存储温度 | -25°C ... + 85°C
相对湿度 | 95%,无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm (width aligned: 12 mm)
安装 | 35毫米的安装导轨符合EN 50022标准
抗振动/抗冲击性能 | 符合EN 60068-2-6/EN 60068-2-27/29
EMC防电阻爆裂 | 符合EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认可 | CE Ex UL


EL3061, EL3062 - Introduction

BECKHOFF EL3061, EL3062: Product Overview

EL3061, EL3062 - 介绍

1/2 通道模拟量输入端子模块， 0…10 V，单端输入，12位

EL3061 和 EL3062 模拟量输入端子模块用于处理 0 到 10 V 范围内的信号。电流被数字化后的分辨率为 12 位，并在电隔离的状态下被传送到上一级自动化设备。总线端子模块的输入通道具有一个公共的接地电位端，即基准接地。EL3061 是单通道型端子模块，具有精细分级和电气隔离的特点。而 EL3062 型端子模块则有 2 个通道。运行 LED 指示总线耦合器的数据交换状态。

EL3062-0030是能处理0到30V范围内德信号，并有2个通道的特殊类型。

快速链接

• EtherCAT 基础功能
• 数据处理和操作模式
• Object的描述和参数化


EL3064, EL3068 - Introduction

BECKHOFF EL3064, EL3068: Product Overview

EL3064, EL3068 - 介绍

4/8 通道模拟量输入端子模块 0…10 V，单端输入，12位

EL3064和EL3068 模拟量输入端子模块用于处理 0 到 10 V 范围内的信号。电流被数字化后的分辨率为 12 位，并在电隔离的状态下被传送到上一级自动化设备。KL3064 型端子模块有 4 个通道，并具有一个公共的接地电位端。而 EL3068 型端子模块则有 2 个通道，连接了电源触点，所有输入端的接地端是电源的0V触点。运行 LED 指示总线耦合器的数据交换状态。

快速链接

• EtherCAT 基础功能
• 数据处理和操作模式
• Object的描述和参数化


EL306x - Technical data

BECKHOFF EL306x: Product Overview

EL306x - 技术数据

技术数据 | EL3061 | EL3062 | EL3062-0030 | EL3064 | EL3068
输入点数 | 1 | 2 | 2 | 4 | 8
信号电压 | 0 V ... +10 V |  | 0 V ... +30 V | 0 V ... +10 V
内部电阻 | > 130 kΩ
分辨率 | 12 位(显示分辨率为16位)
转换时间（默认设置：50Hz滤波） | 一般为0,625 ms |  |  |  | 一般为1,25 ms
最低滤波输入频率 | 1 kHz
测量误差 | < ± 0,3 % (满刻度值)
内部E bus电路的电源电压 | 通过E-Bus
E-bus的电流消耗 | 一般130 mA
分布式时钟 | 不支持
电气隔离 | 500 Veff (E-Bus/励磁电压)
过电压能力 | 最大30 V
过程映像位宽 | 4位输入 | 8位输入 | 8位输入 | 16位输入 | 32位输入
配置 | 通过TwinCAT System Manager
重量 | 大约60 g
工作温度 | 0°C ... + 55°C
存储温度 | -25°C ... + 85°C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm (width aligned: 12 mm)
安装 | 35毫米的安装导轨符合EN 50022标准
抗振动/抗冲击性能 | 符合EN 60068-2-6/EN 60068-2-27/29
EMC防电阻爆裂 | 符合EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认可 | CE Ex UL


KLxxxx, KSxxxx, ELxxxx, ESxxxx - Connection system

BECKHOFF Fieldbus Components: Mounting and wiring

连接系统

警告 		触电和设备损坏的风险!
总线端子系统带入一个安全，断电状态，然后开始安装，拆卸或接线总线端子！

总线端子模块系统提供相应应用程序的不同连接选项:

  • KLxxxx和ELxxxx系列标准接线端子，包括在单一机箱内的电子设备和连接水平。
  • KSxxxx和ESxxxx系列端子模块功能的可插拔连接水平，同时在更换时能稳定地布线。

标准接线

KLxxxx和ELxxxx系列端子模块已经经过多年尝试和测试。
它们的特点是快速和简单地整合无螺纹弹簧力技术。

可插拔接线

KSxxxx和ESxxxx系列端子模块功能的可插拔连接水平。
KS系列的组装和接线过程与KLxxxx和ELxxxx系列相同。
KS/ES系列允许完整布线。
较低的部分可以通过拉解锁标签 从端子模块拦截。
在接线的连接器中插入新的组件和插件。
这样就减少了安装时间并消除了电线混乱的风险。

端子模块的尺寸仅略有改变。新的连接器增加了约3毫米。端子模块的最大高度保持不变。

在许多应用中，为了简化装配和防止混乱，个别的连接线需要被被删除。

导线截面在0.08 mm2到2.5 mm2之间，可以继续使用弹簧力技术。

KSxxxx和ESxxxx系列产品名称的概述和 命名一直从KLxxxx和ELxxxx系列保留下来。

注意 		接线高密度端子模块
KLx8xx和ELx8xx系列的高密度端子模块只适合标准接线。

2


EL300x - Connection

BECKHOFF EL30xx: Mounting and Wiring

EL300x - LED和连接

内容
• EL3001, EL3002

- LEDs
- EL3001连接
- EL3002连接

• EL3004, EL3008

- LEDs
- EL3004连接
- EL3008连接

• 连接范例EL3002

EL3001, EL3002

LEDs

LED | 颜色 | 含义
运行 | 绿 | 本LED反映终端的运行状态:
 |  | 暗 | EtherCAT State Machine的状态: INIT = 终端初始化 或 BOOTSTRAP = 终端的固件升级功能。
 |  | 闪烁 | EtherCAT State Machine的状态: PREOP = mailbox通讯的设置和不同的标准设置。
 |  | 一闪而过 | EtherCAT State Machine的状态: SAFEOP = 同步管理 和 分布时钟的通道检测。 在安全模式下输出。
 |  | 亮 | EtherCAT State Machine的状态: OP = 普通操作模式，能进行过程数据通讯和mailbox通讯 。

如果有大于1盏指示灯亮起，那么所有的指示灯拥有相同的功能。

EL3001连接

端子 | 编号 | 介绍
Input 1 | 1 | 输入通道1
0 V | 2 | 0 V (与电源负极触点内部连接)
GND | 3 | 接地(与端子7内部连接)
Shield | 4 | Shield
- | 5 | 连接
24 V | 6 | 24 V
GND | 7 | 接地(与端子3内部连接)
Shield | 8 | 屏蔽

EL3002连接

端子 | 编号 | 介绍
Input 1 | 1 | 输入通道1
0 V | 2 | 0 V (与电源负极触点内部连接)
GND | 3 | 接地(与端子7内部连接)
Shield | 4 | 屏蔽
Input 2 | 5 | 输入通道2
24 V | 6 | 24 V
GND | 7 | 接地(与端子3内部连接)
Shield | 8 | 屏蔽

EL3004, EL3008

LEDs

LED | 颜色 | 含义
运行 | 绿 | 本LED反映终端的运行状态:
 |  | 暗 | EtherCAT State Machine的状态: INIT = 终端初始化 或 BOOTSTRAP = 终端的固件升级功能。
 |  | 闪烁 | EtherCAT State Machine的状态: PREOP = mailbox通讯的设置和不同的标准设置。
 |  | 一闪而过 | EtherCAT State Machine的状态: SAFEOP = 同步管理 和 分布时钟的通道检测。 在安全模式下输出。
 |  | 亮 | EtherCAT State Machine的状态: OP = 普通操作模式，能进行过程数据通讯和mailbox通讯 。

如果有大于1盏指示灯亮起，那么所有的指示灯拥有相同的功能。

EL3004连接

端子 | 编号 | 介绍
Input 1 | 1 | 输入通道1
GND | 2 | 接地(与端子4,6,8内部连接)
Input 3 | 3 | 输入通道3
GND | 4 | 接地(与端子2,6,8内部连接)
Input 2 | 5 | 输入通道2
GND | 6 | 接地(与端子2,4,8内部连接)
Input 4 | 7 | 输入通道4
GND | 8 | 接地(与端子2,4,6内部连接)

EL3008连接

端子 | 编号 | 介绍
Input 1 | 1 | Input 1
Input 3 | 2 | Input 3
Input 5 | 3 | Input 5
Input 7 | 4 | Input 7
Input 2 | 5 | Input 2
Input 4 | 6 | Input 4
Input 6 | 7 | Input 6
Input 8 | 8 | Input 8

连接范例EL3002

图中的可变的电压源 (通道 2)是传感器和测量传感器的等效电路(通道1)。


EL304x - Connection

BECKHOFF EL30xx: Mounting and Wiring

EL304x - LED和连接

内容
• EL3041, EL3042

- LEDs
- EL3041连接
- EL3042连接

• EL3044, EL3048

- LEDs
- EL3044连接
- EL3048连接

• 连接范例EL3042

EL3041, EL3042

LEDs

LED | 颜色 | 含义
运行 | 绿 | 本LED反映终端的运行状态:
 |  | 暗 | EtherCAT State Machine的状态: INIT = 终端初始化 或 BOOTSTRAP = 终端的固件升级功能。
 |  | 闪烁 | EtherCAT State Machine的状态: PREOP = mailbox通讯的设置和不同的标准设置。
 |  | 一闪而过 | EtherCAT State Machine的状态: SAFEOP = 同步管理 和 分布时钟的通道检测。 在安全模式下输出。
 |  | 亮 | EtherCAT State Machine的状态: OP = 普通操作模式，能进行过程数据通讯和mailbox通讯 。

如果有大于1盏指示灯亮起，那么所有的指示灯拥有相同的功能。

EL3041连接

端子 | 编号 | 介绍
Input 1 | 1 | 输入通道1
24 V | 2 | 24 V (与端子6和电源正极触点内部连接)
0 V | 3 | 0 V (与端子7和电源负极触点内部连接)
Shield | 4 | 屏蔽
- | 5 | 未连接
24 V | 6 | 24 V (与端子2和电源正极触点内部连接)
0 V | 7 | 0 V (与端子3和电源负极触点内部连接)
Shield | 8 | 屏蔽

EL3042连接

端子 | 编号 | 介绍
Input 1 | 1 | 输入通道1
24 V | 2 | 24 V (与端子6和电源正极触点内部连接)
0 V | 3 | 0 V (与端子7和电源负极触点内部连接)
Shield | 4 | 屏蔽
Input 2 | 5 | 输入通道2
24 V | 6 | 24 V (与端子2和电源正极触点内部连接)
0 V | 7 | 0 V (与端子3和电源负极触点内部连接)
Shield | 8 | 屏蔽

EL3044, EL3048

LEDs

LED | 颜色 | 含义
运行* | 绿 | 本LED反映终端的运行状态:
 |  | 暗 | EtherCAT State Machine的状态: INIT = 终端初始化 或 BOOTSTRAP = 终端的固件升级功能。
 |  | 闪烁 | EtherCAT State Machine的状态: PREOP = mailbox通讯的设置和不同的标准设置。
 |  | 一闪而过 | EtherCAT State Machine的状态: SAFEOP = 同步管理 和 分布时钟的通道检测。 在安全模式下输出。
 |  | 亮 | EtherCAT State Machine的状态: OP = 普通操作模式，能进行过程数据通讯和mailbox通讯 。

* 只适用于 EL3044

如果有大于1盏指示灯亮起，那么所有的指示灯拥有相同的功能。

EL3044连接

端子 | 编号 | 介绍
Input 1 | 1 | 输入通道1
GND | 2 | 接地(与端子4,6,8内部连接)
Input 3 | 3 | 输入通道3
GND | 4 | 接地(与端子2,6,8内部连接)
Input 2 | 5 | 输入通道2
GND | 6 | 接地(与端子2,4,8内部连接)
Input 4 | 7 | 输入通道4
GND | 8 | 接地(与端子2,4,6内部连接)

EL3048连接

端子 | 编号 | 介绍
Input 1 | 1 | Input 1
Input 3 | 2 | Input 3
Input 5 | 3 | Input 5
Input 7 | 4 | Input 7
Input 2 | 5 | Input 2
Input 4 | 6 | Input 4
Input 6 | 7 | Input 6
Input 8 | 8 | Input 8

连接范例EL3042

图中的可变的电流源 (通道 2)是传感器的等效电路(通道1)。


EL305x - Connection

BECKHOFF EL30xx: Mounting and Wiring

EL305x - LED和连接

Contents
• EL3051, EL3052

- LEDs
- EL3051连接
- EL3052连接

• EL3054, EL3058

- LEDs
- EL3054连接
- EL3058连接

• 连接范例EL3052

EL3051, EL3052

LEDs

LED | 颜色 | 含义
运行 | 绿 | 本LED反映终端的运行状态:
 |  | 暗 | EtherCAT State Machine的状态: INIT = 终端初始化 或 BOOTSTRAP = 终端的固件升级功能。
 |  | 闪烁 | EtherCAT State Machine的状态: PREOP = mailbox通讯的设置和不同的标准设置。
 |  | 一闪而过 | EtherCAT State Machine的状态: SAFEOP = 同步管理 和 分布时钟的通道检测。 在安全模式下输出。
 |  | 亮 | EtherCAT State Machine的状态: OP = 普通操作模式，能进行过程数据通讯和mailbox通讯 。
错误1,2 | 红 | 表示超过（过高或过低）该通道的测量范围

如果有大于1盏指示灯亮起，那么所有的指示灯拥有相同的功能。

EL3051连接

端子 | 编号 | 介绍
Input 1 | 1 | 输入通道1
24 V | 2 | 24 V (与端子6和电源正极触点内部连接)
0 V | 3 | 0 V (与端子7和电源负极触点内部连接)
Shield | 4 | 屏蔽
- | 5 | 未连接
24 V | 6 | 24 V (与端子2和电源正极触点内部连接)
0 V | 7 | 0 V (与端子3和电源正极触点内部连接)
Shield | 8 | 屏蔽

EL3052连接

端子 | 编号 | 介绍
Input 1 | 1 | 输入通道1
24 V | 2 | 24 V (与端子6和电源正极触点内部连接)
0 V | 3 | 0 V (与端子7和电源负极触点内部连接)
Shield | 4 | 屏蔽
Input 2 | 5 | 输入通道2
24 V | 6 | 24 V (与端子2和电源正极触点内部连接)
0 V | 7 | 0 V (与端子3和电源正极触点内部连接)
Shield | 8 | 屏蔽

EL3054, EL3058

LEDs

LED | 颜色 | 含义
运行* | 绿 | 本LED反映终端的运行状态:
 |  | 暗 | EtherCAT State Machine的状态: INIT = 终端初始化 或 BOOTSTRAP = 终端的固件升级功能。
 |  | 闪烁 | EtherCAT State Machine的状态: PREOP = mailbox通讯的设置和不同的标准设置。
 |  | 一闪而过 | EtherCAT State Machine的状态: SAFEOP = 同步管理 和 分布时钟的通道检测。 在安全模式下输出。
 |  | 亮 | EtherCAT State Machine的状态: OP = 普通操作模式，能进行过程数据通讯和mailbox通讯 。
错误1-8 | 红 | 表示超过（过高或过低）该通道的测量范围并且线路损坏

* 只适用于 EL3054

如果有大于1盏指示灯亮起，那么所有的指示灯拥有相同的功能。

EL3054连接

端子 | 编号 | 介绍
Input 1 | 1 | 输入通道1
24 V | 2 | 24V(与端子4,6,8内部连接)
Input 3 | 3 | 输入通道3
24 V | 4 | 24V(与端子2,6,8内部连接)
Input 2 | 5 | 输入通道2
24 V | 6 | 24V(与端子2,4,8内部连接)
Input 4 | 7 | 输入通道4
24 V | 8 | 24V(与端子2,4,6内部连接)

EL3058连接

端子 | 编号 | 介绍
Input 1 | 1 | Input 1
Input 3 | 2 | Input 3
Input 5 | 3 | Input 5
Input 7 | 4 | Input 7
Input 2 | 5 | Input 2
Input 4 | 6 | Input 4
Input 6 | 7 | Input 6
Input 8 | 8 | Input 8

连接范例EL3052

图中的可变的电流源 (通道 2)是传感器的等效电路(通道1)。


EL306x - Connection

BECKHOFF EL30xx: Mounting and Wiring

EL306x - LED和连接

Contents
• EL3061, EL3062

- LEDs
- EL3061连接
- EL3062连接

• EL3064, EL3068

- LEDs
- EL3064连接
- EL3068连接

• 连接范例EL3062

EL3061, EL3062

LEDs

LED | 颜色 | 含义
运行 | 绿 | 本LED反映终端的运行状态:
 |  | 暗 | EtherCAT State Machine的状态: INIT = 终端初始化 或 BOOTSTRAP = 终端的固件升级功能。
 |  | 闪烁 | EtherCAT State Machine的状态: PREOP = mailbox通讯的设置和不同的标准设置。
 |  | 一闪而过 | EtherCAT State Machine的状态: SAFEOP = 同步管理 和 分布时钟的通道检测。 在安全模式下输出。
 |  | 亮 | EtherCAT State Machine的状态: OP = 普通操作模式，能进行过程数据通讯和mailbox通讯 。

如果有大于1盏指示灯亮起，那么所有的指示灯拥有相同的功能。

EL3061连接

端子 | 编号 | 介绍
Input 1 | 1 | 输入通道1
0 V | 2 | 0 V (与电源负极触点内部连接)
GND | 3 | 接地(与端子7内部连接)
Shield | 4 | Shield
- | 5 | 连接
24 V | 6 | 24 V
GND | 7 | 接地(与端子3内部连接)
Shield | 8 | 屏蔽

EL3062连接

端子 | 编号 | 介绍
Input 1 | 1 | 输入通道1
0 V | 2 | 0 V (与电源负极触点内部连接)
GND | 3 | 接地(与端子7内部连接)
Shield | 4 | 屏蔽
Input 2 | 5 | 输入通道2
24 V | 6 | 24 V
GND | 7 | 接地(与端子3内部连接)
Shield | 8 | 屏蔽

EL3064, EL3068

LEDs

LED | 颜色 | 含义
运行 | 绿 | 本LED反映终端的运行状态:
 |  | 暗 | EtherCAT State Machine的状态: INIT = 终端初始化 或 BOOTSTRAP = 终端的固件升级功能。
 |  | 闪烁 | EtherCAT State Machine的状态: PREOP = mailbox通讯的设置和不同的标准设置。
 |  | 一闪而过 | EtherCAT State Machine的状态: SAFEOP = 同步管理 和 分布时钟的通道检测。 在安全模式下输出。
 |  | 亮 | EtherCAT State Machine的状态: OP = 普通操作模式，能进行过程数据通讯和mailbox通讯 。

如果有大于1盏指示灯亮起，那么所有的指示灯拥有相同的功能。

EL3064连接

端子 | 编号 | 介绍
Input 1 | 1 | 输入通道1
GND | 2 | 接地(与端子4,6,8内部连接)
Input 3 | 3 | 输入通道3
GND | 4 | 接地(与端子2,6,8内部连接)
Input 2 | 5 | 输入通道2
GND | 6 | 接地(与端子2,4,8内部连接)
Input 4 | 7 | 输入通道4
GND | 8 | 接地(与端子2,4,6内部连接)

EL3068连接

端子 | 编号 | 介绍
Input 1 | 1 | Input 1
Input 3 | 2 | Input 3
Input 5 | 3 | Input 5
Input 7 | 4 | Input 7
Input 2 | 5 | Input 2
Input 4 | 6 | Input 4
Input 6 | 7 | Input 6
Input 8 | 8 | Input 8

连接范例EL3062

图中的可变的电压源 (通道 2)是传感器和测量传感器的等效电路(通道1)。


CoE-接口

CoE接口是 EtherCAT 设备的参数设定接口。 在CAN-over-EtherCAT (CoE)的管理机构中，特定的固件参数可以在网上或EtherCAT的离线参数中获得。

CoE接口的详细信息可以在Beckhoff 网站上 EtherCAT system documentation 中找到。


EtherCAT状态机

EtherCAT从站的状态由EtherCAT状态机（EMS）控制。 依据不同的状态，可以在EtherCAT从站中得到或执行不同的功能。 EtherCAT主站必须发送特殊指令来控制设备的每个状态，尤其是启动从站的时候。

有以下几种状态

  • Init
  • Pre-Operational
  • Safe-Operational
  • Operational
  • Boot

启动后每个EtherCAT从站的最终状态是OP状态。

Init

通电后EtherCAT为Init状态。 mailbox和过程数据无法通讯 。 EtherCAT主站初始化通道0和1同步管理器，为mailbox 通讯准备。

Pre-Operational (Pre-Op)

在 Init 和 Pre-Op的过渡过程中，EtherCAT从站检查mailbox是否正确初始化。

在 Pre-Op 状态 mailbox可以通讯, 但是过程数据无法通讯。 EtherCAT主站初始化过程数据的同步管理器通道 (来自于同步管理器通道2), FMMU通道和, 如果从站支持可调整映射，PDO映射或同步管理器PDO分配。 在这个状态，过程数据的传输设置和端子模块特殊设置也会被传输。

Safe-Operational (Safe-Op)

在 Pre-Op 和 Safe-Op的过渡过程中，EtherCAT从站检查是否过程数据通信的同步管理器通道和分布式时钟设置是否正确。 在确认状态转换之前，EtherCAT从站会将当前输入数据复制到EtherCAT从站控制器（ECSC）中的DP-RAM区域。

在Safe-Op状态可以进行mailbox和过程数据通讯，尽管从站的输出处于安全状态，但是输入数据可以循环更新。

Operational (Op)

在EtherCAT主站切换它的从站从Safe-Op到 Op 状态之前，必须传递有效的输出数据。

在 Op状态，从站复制主站输出数据到从站的输出。 可以进行mailbox和过程数据通讯

Boot

在 Boot 状态，可以更新从站的固件 Boot 状态只能从 Init 状态转换过来。

在 Boot状态，mailbox通讯可以通过file access over EtherCAT (FoE) 协议实现, 但是其他形式的mailbox和过程数据通讯不支持。


TwinCAT System Manager -配置

BECKHOFF TwinCAT System Manager: 配置

TwinCAT System Manager进行配置

(以TwinCAT 2.10.0 (Build 1241)版本, 和EL5001 固件版本 0.7以上 为例)

在TwinCAT System manager左手边的窗口，点击你想要设置的模块（如例：EL5001 Terminal 6 ）。

在TwinCAT System manager右手边的窗口，有多个用来设置端子的标签。

General tab

Name | EtherCAT 设备名称
Id | EtherCAT 设备编号
Type | EtherCAT 设备说明
Comment | 这里你可以添加注释(比如，关于系统)。
Disabled | 你可以在这里停止使用EtherCAT设备。
Create symbols | 如果选中复选框，可以通过ADS连接这个EtherCAT从站

EtherCAT tab

Type | EtherCAT 设备说明
Product/Revision | EtherCAT 设备的型号和版本
Auto Inc Addr. | EtherCAT设备的地址自动增量。 自动增量地址可以通过EtherCAT设备的物理地址在通信环中定位它的地址。 自动增量地址更据EtherCAT设备在通信环中的物理位置排列。 在通信环中的第一个EtherCAT从站的地址就是0000hex. 之后的从站地址减 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | 固定 EtherCAT 从站地址。 此地址由EtherCAT 主站启动时分配。 选中左侧的复选框后即可修改。
Previous Port | 已连接的前一个EtherCAT设备的名字和端口。 这里可以通过不改变EtherCAT通讯环来选择这个设备与另一个设备的连接，下拉框里列出可以选择的EtherCAT设备。
Advanced Settings | 点击这个按钮 打开高级设置对话框。

底部的链接指向网站上的产品页面

Process Data tab

为过程数据的设置。 EtherCAT 从站的输入输出数据是用CANopen数据对象(PDO)来表示。 如果EtherCAT从站支持这个功能，可以通过这个对话框修改PDO选项。

Sync Manager

列出Sync Manager（SM）的设置。
如果EtherCAT从站有mailbox，SM0用于mailbox输出(MbxOut)， SM1用于mailbox输入(MbxIn)。
SM2用于输出过程数据 (outputs) ， SM3 (inputs)用于输入过程数据。

如果选定输入, 在下面 PDO Assignment 的列表中显示对应的PDO分配。

PDO Assignment

所选 Sync Manager的PDO分配 当前Sync Manager 类型所定义的所有PDOs 都显示在这里：

  • 如果Sync Manager列表中选择输出Sync Manager (outputs)，所有的RxPDOs都显示在下面。
  • 如果Sync Manager列表中选择输入Sync Manager (inputs)，所有的TxPDOs都显示在下面。

选择的PDOs将确定过程数据的传输。 在System Manager的树形列表中，这些PDOs以EtherCAT从站变量的形式显示。 变量名和在PDO列表中的PDO的参数名 完全一样。 如果PDO分配列表中的条目被禁用，（未被选择并呈灰色），这表示输入被排除在PDO分配之外了。 为了能够选择这个灰色的PDO，首先就要先取消选择当前的PDO。

说明 		激活 PDO 配置
改变PDO配置后，为了使新的PDO配置生效，
  • EtherCAT从站需要通过 PS状态转换循环 (从 pre-operational 到 safe-operational) 一次 (见 Online tab),
  • 然后在System Manager中点击( [image] reload ) EtherCAT 从站按钮

PDO list

列出EtherCAT 设备所支持的所有PDO。 所选择PDO的内容会在 PDO Content 列表中显示出来。 可以通过双击来修改PDO配置。

列 | 描述
Index | PDO 索引
Size | PDO的 byte数
Name | PDO名称 如果这个PDO 分配到Sync Manager，从站的变量名即为此参数。
Flags | F | 固定内容: 这个PDO的内容被固定，且不能用System Manager修改。
 | M | 管理 PDO. 这个PDO是强制的必须分配到Sync Manager! 因此这个PDO不能从 PDO Assignment列表中删除
SM | 显示这个PDO 与哪个Sync Manager 关联。 如果是空的，那么就说明这个PDO不在过程数据中。
SU | 显示这个PDO与哪个Sync unit关联

PDO Content

显示PDO内容 如果这个PDO的 flag 不为F (固定内容) 那么就可以修改它的内容。

Download

对于智能从站且具备mailbox，PDO配置和PDO关联可以下载到从站中。 这是一个可选项不是所有的EtherCAT从站都支持。

PDO Assignment

如果选中此复选框，PDO Assignment列表中的PDO关联会在启动时下载到从站中。 需要的命令会被传输到从站中，并在 Startup中显示。

PDO Configuration

如果选中此复选框，相应的PDO配置(如图中PDO list和PDO Content)将会下载到EtherCAT从站中

Startup tab

Startup 显示 EtherCAT从站是否有mailbox ，是否支持CANopen over EtherCAT (CoE) 或 Servo drive over EtherCAT协议。 此表显示哪个下载请求在启动阶段被发送到mailbox 也可以列表中添加新的mailbox请求。 下载请求以他们在列表中的顺序依次发送到从站。

列 | 描述
Transition 请求发送到哪里。 这可以是
  • 从pre-operational 传输到 safe-operational (PS), 或
  • 从safe-operational 传输到 operational (SO).

如果传输用 "<>" 括起来(e.g. <PS>), 这mailbox请求是固定的，不能修改和删除。

Protocol | mailbox协议类型
Index | 对象的索引
Data | 下载对象的数据
Comment | 发送到mailbox请求的描述
Move Up | 把请求的位置向上移一位。
Move Down | 把请求的位置向下移一位。
New | 添加一个新的mailbox启动下载请求。
Delete | 删除一个选中的项
Edit | 编辑现有的请求

CoE - Online tab

如果EtherCAT从站支持 CANopen over EtherCAT (CoE) 那么CoE - Online 就会显示。 这个对话框列出了从站对象表中的内容(SDO upload)并且使用户能够从这个表中修改对象的内容。 可以在特定设备的对象描述中找到每个 EtherCAT 从站的对象详细信息。

对象列表显示
列 | 描述
Index | 对象的索引和子索引
Name | 对象的名称
Flags | RW | 对象可读可写(read/write)
 | RO | 对象只读(read only)
 | P | P表示此对象为过程数据对象。
Value | 对象的值
Update List | Update list按钮更新显示列表中的所有对象。
Auto Update | 如果这个复选框勾上，表格中的所有数据自动更新。
Advanced | Advanced按钮打开Advanced Settings 对话框。 选择在列表中显示的对象。

Online - via SDO Information | 如果这个单选框被选中，那么包括在从站对象列表中的对象列表将通过SDO信息的方式上载。 列表显示哪些对象类型可以上载。
Offline - via EDS File | 如果这个单选框被选中，在从站对象列表中的对象列表将从EDS文件中读取。

Online tab

状态机

Init | 这个按钮将EtherCAT 从站设为Init 状态。
Pre-Op | 这个按钮将EtherCAT 从站设为 pre-operational状态
Op | 这个按钮将EtherCAT 从站设为operational状态
Bootstrap | 这个按钮将EtherCAT 从站设为Bootstrap 状态
Safe-Op | 这个按钮将EtherCAT 从站设为 safe-operational 状态
Clear Error | 清空错误提示。 如果EtherCAT从站在状态转换中出错了，它就会设定一个出错标志位。 例子: 一个EtherCAT从站处于PREOP状态 (pre-operational)。 主站要求它进入SAFEOP 状态(safe-operational)。 如果从站在状态转换中出错，那么它就会设置错误标志。 当前状态就会显示为ERR PREOP。 当点过 Clear Error按钮后错误标志清楚, 然后状态变为 PREOP。
Current State | 显示EtherCAT从站的当前状态。
Requested State | EtherCAT 从站被要求的状态。

DLL 状态

显示每个 EtherCAT从站端口的DLL 状态 (data link layer 状态) 。 DLL有4种不同的状态:

状态 | 描述
No Carrier / Open | 端口无载波信号, 但是端口开放。
No Carrier / Closed | 端口无载波信号, 且端口是关闭的。
Carrier / Open | 端口有载波信号，且是端口开放。
Carrier / Closed | 端口有载波信号，但是端口关闭。

File Access over EtherCAT

Download | 文件写入EtherCAT从站。
Upload | 从EtherCAT从站读取文件。


EL30xx - Object description and parameterization

BECKHOFF EL30xx: Configuration

Object的描述及参数化

说明 		EtherCAT XML 设备描述
设备描述符合于EtherCAT XML 设备描述的显示。推荐到倍福官方网站(http://www.beckhoff.com/english/default.htm?download/elconfg.htm) 上下载相应XML文件的最新修订版，并根据该文件进行安装。

说明 		参数化说明
在对应对象上双击CoE选项，准确地说，过程数据选项(PDO接口分类中)，端子模块就会进行参数化。

简介

CoE概述包括了各种应用面的对象:

  • 参数化调试所需对象
  • 常规操作中存在的对象，如：通过ADS的连接
  • 显示内部设置的对象(可能固化的)

以下部分先介绍常规操作中所需对象，然后完整地概述其他对象。

调试所需对象

索引号1011 默认还原参数
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1011:0 | 还原默认参数 | 在EtherCAT从站中还原默认的设置 | UINT8 | RO | 0x01 (1dec)
1011:01 | 分索引号001 | 若在该对象的设值对话框中输入"0x64616F6C" ，则所有备份对象将处于发送状态。 | UINT32 | RW | 0x00000000 (0dec)
索引号 80n0 AI设定(for 0 ≤ n ≤ 7)
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
80n0:0 | AI 设定 | 最大分索引号 | UINT8 | RO | 0x18 (24dec)
80n0:01 | 使能用户比例 | 该位设置后，启用用户比例 | BOOLEAN | RW | 0x00 (0dec)
8000:02 | 描述 | 0: 有符号描述 1: 无符号描述 2: 以MSB(最高有效位)为符号位的绝对值描述 | BIT3 | RW | 0x00 (0dec)
80n0:05 | 西门子位表达方式 | 在低三位显示S5位信息 | BOOLEAN | RW | 0x00 (0dec)
80n0:06 | 使能滤波器 | 使能滤波器，同时停止交换周期同步的数据 | BOOLEAN | RW | 0x01 (1dec)
80n0:07 | 使能限制值1 | 启用限制值1 | BOOLEAN | RW | 0x00 (0dec)
80n0:08 | 使能限制值1 | 启用限制值2 | BOOLEAN | RW | 0x00 (0dec)
80n0:0A | 使能用户校准 | 该位设置后，用户可进行校准 | BOOLEAN | RW | 0x00 (0dec)
80n0:0B | 使能供应商校准 | 该位设置后，供应商可进行校准 | BOOLEAN | RW | 0x01 (1dec)
80n0:11 | 用户比例偏移量 | 用户比例偏移量 | INT16 | RW | 0x0000 (0dec)
80n0:12 | 用户比例增益 | 用户比例增益 该增益采用定点格式，最低位为2-16。 1值表示该增益为65535dec (0x00010000hex)。另一方面，该增益限制值为+/- 0x7FFFF | INT32 | RW | 0x00010000 (65536dec)
80n0:13 | 限制值1 | 状态位设置限制值1 | INT16 | RW | 0x0000 (0dec)
80n0:14 | 限制值2 | 状态位设置限制值2 | INT16 | RW | 0x0000 (0dec)
80n0:15 | 滤波器设置 | 当使能滤波器(索引号80n0:06) 启用时，该对象确定了数字滤波器的设置T、 滤波器设置都是连续编号。 0: 50 Hz FIR(Finite Impulse Response) 1: 60 Hz FIR 2: IIR(Infinite Impulse Response) 1 3: IIR 2 4: IIR 3 5: IIR 4 6: IIR 5 7: IIR 6 8: IIR 7 9: IIR 8 | UINT16 | RW | 0x0000 (0dec)
80n0:17 | 用户校准偏移量 | 用户校准偏移量 | INT16 | RW | 0x0000 (0dec)
80n0:18 | 用户校准增益 | 用户校准增益 | INT16 | RW | 0x4000 (16384dec)

常规操作中存在的对象

EL30xx 系列中不存在该种对象。

其他对象概述

标准对象(0x1000-0x1FFF)

所有EtherCAT从站的标准对象具有相同的定义。

索引号1000 设备类型
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1000:0 | 设备类型 | EtherCAT从站设备类型: 低位字包括了正在使用的CoE介绍(5001)。高位字包括了模块化设备的模块介绍。 | UINT32 | RO | 0x012C1389(19665801dec)
索引号1008 设备名称
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1008:0 | 设备名称 | EtherCAT从站的设备名称 | STRING | RO | EL30xx
索引号1009 硬件版本
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1009:0 | 硬件版本 | EtherCAT从站的硬件版本 | STRING | RO | 00
索引号100A 软件版本
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
100A:0 | 软件版本 | EtherCAT从站的固件版本 | STRING | RO | 01
索引号1018 认证
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1018:0 | 认证 | 识别EtherCAT从站的信息 | UINT8 | RO | 0x04 (4dec)
1018:01 | 供应商ID | EtherCAT从站供应商的ID | UINT32 | RO | 0x00000002 (2dec)
1018:02 | 产品代码 | EtherCAT从站的产品代码 | UINT32 | RO | 0x0BC03052 (197144658dec)
1018:03 | 修订码 | EtherCAT从站的修订码，低位字(0-15位)表示了具有特殊功能的端子数量：高位字(16-31位)标识了设备描述。 | UINT32 | RO | 0x00100000 (1048576dec)
1018:04 | 序列号 | EtherCAT从站的序列号，低位字中的低位字节(0-7位)包含了生产年份，低位字的高位字节(8-15位)包含了生产月份，高位字(16-31位)为0。 | UINT32 | RO | 0x00000000 (0dec)
索引号10F0 备份参数处理
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
10F0:0 | 备份参数处理 | 标准装载的信息和备份条目的保存 | UINT8 | RO | 0x01 (1dec)
10F0:01 | 校验 | 对所有备份条目进行检验 | UINT32 | RO | 0x00000000 (0dec)
索引号1800 AI TxPDO-Par Standard Ch.1
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1800:0 | AI TxPDO-Par Standard Ch.1 | PDO参数TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1800:06 | 特殊TxPDO | 这里将说明不与TxPDO 1一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 01 1A
1800:07 | TxPDO状态 | 若不能正常读入输入数据，TxPDO状态会被设置 | BOOLEAN | RO | 0x00 (0dec)
1800:09 | TxPDO切换 | TxPDO切换将随着相应输入数据的更新不断切换 | BOOLEAN | RO | 0x00 (0dec)
索引号1801 AI TxPDO-Par Compact Ch.1
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1801:0 | AI TxPDO-Par Compact Ch.1 | PDO参数TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1801:06 | 特殊TxPDOs | 这里将说明不与TxPDO2一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 00 1A
索引号1802 AI TxPDO-Par Standard Ch.2
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1802:0 | AI TxPDO-Par Standard Ch.2 | PDO参数TxPDO 3 | UINT8 | RO | 0x09 (9dec)
1802:06 | 特殊TxPDOs | 这里将说明不与TxPDO3一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 01 1A
1802:07 | TxPDO状态 | 若不能正常读入输入数据，TxPDO状态会被设置 | BOOLEAN | RO | 0x00 (0dec)
1802:09 | TxPDO切换 | TxPDO切换将随着相应输入数据的更新不断切换 | BOOLEAN | RO | 0x00 (0dec)
索引号1803 AI TxPDO-Par Compact Ch.2
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1803:0 | AI TxPDO-Par Compact Ch.2 | PDO参数TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | 特殊TxPDOs | 这里将说明不与TxPDO4一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 00 1A
索引号1804 AI TxPDO-Par Standard Ch.3
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1804:0 | AI TxPDO-Par Standard Ch.3 | PDO参数TxPDO 5 | UINT8 | RO | 0x09 (9dec)
1804:06 | 特殊TxPDOs | 这里将说明不与TxPDO5一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 01 1A
1804:07 | TxPDO状态 | 若不能正常读入输入数据，TxPDO状态会被设置 | BOOLEAN | RO | 0x00 (0dec)
1804:09 | TxPDO切换 | TxPDO切换将随着相应输入数据的更新不断切换 | BOOLEAN | RO | 0x00 (0dec)
索引号1805 AI TxPDO-Par Compact Ch.3
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1805:0 | AI TxPDO-Par Compact Ch.3 | PDO参数TxPDO 6 | UINT8 | RO | 0x06 (6dec)
1805:06 | 特殊TxPDOs | 这里将说明不与TxPDO6一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 00 1A
索引号1806 AI TxPDO-Par Standard Ch.4
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1806:0 | AI TxPDO-Par Standard Ch.4 | PDO参数TxPDO 7 | UINT8 | RO | 0x09 (9dec)
1806:06 | 特殊TxPDOs | 这里将说明不与TxPDO7一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 01 1A
1806:07 | TxPDO状态 | 若不能正常读入输入数据，TxPDO状态会被设置 | BOOLEAN | RO | 0x00 (0dec)
1806:09 | TxPDO 切换 | TxPDO切换将随着相应输入数据的更新不断切换 | BOOLEAN | RO | 0x00 (0dec)
索引号1807 AI TxPDO-Par Compact Ch.4
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1807:0 | AI TxPDO-Par Compact Ch.4 | PDO参数TxPDO 8 | UINT8 | RO | 0x06 (6dec)
1807:06 | 特殊TxPDOs | 这里将说明不与TxPDO8一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 00 1A
索引号1808 AI TxPDO-Par Standard Ch.5
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1808:0 | AI TxPDO-Par Standard Ch.5 | PDO参数TxPDO 9 | UINT8 | RO | 0x09 (9dec)
1808:06 | 特殊TxPDOs | 这里将说明不与TxPDO9一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 01 1A
1808:07 | TxPDO状态 | 若不能正常读入输入数据，TxPDO状态会被设置 | BOOLEAN | RO | 0x00 (0dec)
1808:09 | TxPDO切换 | TxPDO切换将随着相应输入数据的更新不断切换 | BOOLEAN | RO | 0x00 (0dec)
索引号1809 AI TxPDO-Par Compact Ch.5
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1809:0 | AI TxPDO-Par Compact Ch.5 | PDO参数TxPDO 10 | UINT8 | RO | 0x06 (6dec)
1809:06 | 特殊TxPDOs | 这里将说明不与TxPDO10一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 00 1A
索引号180A AI TxPDO-Par Standard Ch.6
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
180A:0 | AI TxPDO-Par Standard Ch.6 | PDO参数TxPDO 11 | UINT8 | RO | 0x09 (9dec)
180A:06 | 特殊TxPDOs | 这里将说明不与TxPDO11一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 01 1A
180A:07 | TxPDO状态 | 若不能正常读入输入数据，TxPDO状态会被设置 | BOOLEAN | RO | 0x00 (0dec)
180A:09 | TxPDO切换 | TxPDO切换将随着相应输入数据的更新不断切换 | BOOLEAN | RO | 0x00 (0dec)
索引号180B AI TxPDO-Par Compact Ch.6
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
180B:0 | AI TxPDO-Par Compact Ch.6 | PDO参数TxPDO 12 | UINT8 | RO | 0x06 (6dec)
180B:06 | 特殊TxPDOs | 这里将说明不与TxPDO12一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 00 1A
索引号180C AI TxPDO-Par Standard Ch.7
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
180C:0 | AI TxPDO-Par Standard Ch.7 | PDO参数TxPDO 13 | UINT8 | RO | 0x09 (9dec)
180C:06 | 特殊TxPDOs | 这里将说明不与TxPDO13一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 01 1A
180C:07 | TxPDO状态 | 若不能正常读入输入数据，TxPDO状态会被设置 | BOOLEAN | RO | 0x00 (0dec)
180C:09 | TxPDO切换 | TxPDO切换将随着相应输入数据的更新不断切换 | BOOLEAN | RO | 0x00 (0dec)
索引号180D AI TxPDO-Par Compact Ch.7
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
180D:0 | AI TxPDO-Par Compact Ch.7 | PDO参数TxPDO 14 | UINT8 | RO | 0x06 (6dec)
180D:06 | 特殊TxPDOs | 这里将说明不与TxPDO14一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 00 1A
索引号180E AI TxPDO-Par Standard Ch.8
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
180E:0 | AI TxPDO-Par Standard Ch.8 | PDO参数TxPDO 15 | UINT8 | RO | 0x09 (9dec)
180E:06 | 特殊TxPDOs | 这里将说明不与TxPDO15一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 01 1A
180E:07 | TxPDO状态 | 若不能正常读入输入数据，TxPDO状态会被设置 | BOOLEAN | RO | 0x00 (0dec)
180E:09 | TxPDO切换 | TxPDO切换将随着相应输入数据的更新不断切换 | BOOLEAN | RO | 0x00 (0dec)
索引号180F AI TxPDO-Par Compact Ch.8
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
180F:0 | AI TxPDO-Par Compact Ch.8 | PDO参数TxPDO 16 | UINT8 | RO | 0x06 (6dec)
180F:06 | 特殊TxPDOs | 这里将说明不与TxPDO16一起传输的TxPDO(TxPDO映射对象索引) | OCTET-STRING[2] | RO | 00 1A
索引号1A00 AI TxPDO-Map Standard Ch.1
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A00:0 | AI TxPDO-Map Standard Ch.1 | PDO映射TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1A00:01 | 分索引号 001 | 1. PDO映射条目(对象0x6000 (AI输入), 条目0x01 (映射范围内)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | 分索引号 002 | 2. PDO映射条目(对象0x6000 (AI输入), 条目0x02 (映射范围外)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | 分索引号 003 | 3. PDO映射条目(对象0x6000 (AI输入), 条目0x03 (限制值1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | 分索引号 004 | 4. PDO隐射条目(对象0x6000 (AI输入), 条目0x05 (限制2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | 分索引号 005 | 5. PDO映射条目(2位对齐) | UINT32 | RO | 0x0000:00, 2
1A00:06 | 分索引号 006 | 6. PDO映射条目(6位对齐) | UINT32 | RO | 0x0000:00, 6
1A00:07 | 分索引号 007 | 7. PDO映射条目(对象0x1800 (AI TxPDO-Par Standard Ch.1), 条目0x07 (TxPDO状态)) | UINT32 | RO | 0x1800:07, 1
1A00:08 | 分索引号 008 | 8. PDO映射条目(对象0x1800 (AI TxPDO-Par Standard Ch.1), 条目0x09 (TxPDO切换)) | UINT32 | RO | 0x1800:09, 1
1A00:09 | 分索引号 009 | 9. PDO映射条目(对象0x6000 (AI输入),条目0x11(定值)) | UINT32 | RO | 0x6000:11, 16
索引号1A01 AI TxPDO-Map Compact Ch.1
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A01:0 | AI TxPDO-Map Compact Ch.1 | PDO映射TxPDO2 | UINT8 | RO | 0x01 (1dec)
1A01:01 | 分索引号 001 | 1. PDO映射条目(对象0x6000 (AI输入),条目0x11 (定值)) | UINT32 | RO | 0x6000:11, 16
索引号1A02 AI TxPDO-Map Standard Ch.2
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A02:0 | AI TxPDO-Map Standard Ch.2 | PDO映射TxPDO3 | UINT8 | RO | 0x09 (9dec)
1A02:01 | 分索引号 001 | 1. PDO映射条目(对象0x6010 (AI输入),条目0x01 (映射范围内)) | UINT32 | RO | 0x6010:01, 1
1A02:02 | 分索引号 002 | 2. PDO映射条目(对象0x6010 (AI输入), 条目0x02 (映射范围外)) | UINT32 | RO | 0x6010:02, 1
1A02:03 | 分索引号 003 | 3. PDO映射条目(对象0x6010 (AI输入), 条目0x03 (限制值1)) | UINT32 | RO | 0x6010:03, 2
1A02:04 | 分索引号 004 | 4. PDO映射条目(对象0x6010 (AI输入), 条目0x05 (限制2)) | UINT32 | RO | 0x6010:05, 2
1A02:05 | 分索引号 005 | 5. PDO映射条目(2位对齐) | UINT32 | RO | 0x0000:00, 2
1A02:06 | 分索引号 006 | 6. PDO 映射条目(6位对齐) | UINT32 | RO | 0x0000:00, 6
1A02:07 | 分索引号 007 | 7. PDO映射条目(对象0x1802 (AI TxPDO-Par Standard Ch.2), 条目0x07 (TxPDO状态)) | UINT32 | RO | 0x1802:07, 1
1A02:08 | 分索引号 008 | 8. PDO映射条目(对象0x1802 (AI TxPDO-Par Standard Ch.2),条目0x09 (TxPDO切换)) | UINT32 | RO | 0x1802:09, 1
1A02:09 | 分索引号 009 | 9. PDO映射条目(对象0x6010 (AI输入), 条目0x11 (定值)) | UINT32 | RO | 0x6010:11, 16
索引号1A03 AI TxPDO-Map Compact Ch.2
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A03:0 | AI TxPDO-Map Compact Ch.2 | PDO映射TxPDO 4 | UINT8 | RO | 0x01 (1dec)
1A03:01 | 分索引号 001 | 1. PDO映射条目(对象0x6010 (AI输入), 条目0x11 (定值)) | UINT32 | RO | 0x6010:11, 16
索引号1A04 AI TxPDO-Map Standard Ch.3
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A04:0 | AI TxPDO-Map Standard Ch.3 | PDO映射TxPDO 5 | UINT8 | RO | 0x09 (9dec)
1A04:01 | 分索引号 001 | 1. PDO映射条目(对象0x6020 (AI输入), 条目0x01 (映射范围内)) | UINT32 | RO | 0x6020:01, 1
1A04:02 | 分索引号 002 | 2. PDO映射条目(对象0x6020 (AI输入), 条目0x02 (映射范围外)) | UINT32 | RO | 0x6020:02, 1
1A04:03 | 分索引号 003 | 3. PDO映射条目(对象0x6020 (AI输入), 条目0x03 (限制值1)) | UINT32 | RO | 0x6020:03, 2
1A04:04 | 分索引号 004 | 4. PDO映射条目(对象0x6020 (AI输入), 条目0x05 (限制2)) | UINT32 | RO | 0x6020:05, 2
1A04:05 | 分索引号 005 | 5. PDO映射条目(2位对齐) | UINT32 | RO | 0x0000:00, 2
1A04:06 | 分索引号 006 | 6. PDO映射条目(6位对齐) | UINT32 | RO | 0x0000:00, 6
1A04:07 | 分索引号 007 | 7. PDO映射条目(对象0x1804 (AI TxPDO-Par Standard Ch.3),条目0x07 (TxPDO 状态)) | UINT32 | RO | 0x1804:07, 1
1A04:08 | 分索引号 008 | 8. PDO映射条目(对象0x1804 (AI TxPDO-Par Standard Ch.3), 条目0x09 (TxPDO转换)) | UINT32 | RO | 0x1804:09, 1
1A04:09 | 分索引号 009 | 9. PDO映射条目(对象0x6020 (AI输入), 条目0x11 (定值)) | UINT32 | RO | 0x6020:11, 16
索引号1A05 AI TxPDO-Map Compact Ch.3
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A05:0 | AI TxPDO-Map Compact Ch.3 | PDO映射TxPDO6 | UINT8 | RO | 0x01 (1dec)
1A05:01 | 分索引号 001 | 1. PDO映射(对象0x6020 (AI输入), 条目0x11 (定值)) | UINT32 | RO | 0x6020:11, 16
索引号 1A06 AI TxPDO-Map Standard Ch.4
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A06:0 | AI TxPDO-Map Standard Ch.4 | PDO映射TxPDO 7 | UINT8 | RO | 0x09 (9dec)
1A06:01 | 分索引号 001 | 1. PDO映射条目(对象0x6030 (AI输入), 条目0x01 (映射范围内)) | UINT32 | RO | 0x6030:01, 1
1A06:02 | 分索引号 002 | 2. PDO映射条目(对象0x6030 (AI输入), 条目0x02 (映射范围外)) | UINT32 | RO | 0x6030:02, 1
1A06:03 | 分索引号 003 | 3. PDO映射条目(对象0x6030 (AI输入), 条目0x03 (限制值1)) | UINT32 | RO | 0x6030:03, 2
1A06:04 | 分索引号 004 | 4. PDO映射条目(对象0x6030 (AI输入), 条目0x05 (限制2)) | UINT32 | RO | 0x6030:05, 2
1A06:05 | 分索引号 005 | 5. PDO映射条目(2位对齐) | UINT32 | RO | 0x0000:00, 2
1A06:06 | 分索引号 006 | 6. PDO映射条目(6位对齐) | UINT32 | RO | 0x0000:00, 6
1A06:07 | 分索引号 007 | 7. PDO映射条目(对齐0x1806 (AI TxPDO-Par Standard Ch.4),条目0x07 (TxPDO状态)) | UINT32 | RO | 0x1806:07, 1
1A06:08 | 分索引号 008 | 8. PDO映射条目(对象0x1806 (AI TxPDO-Par Standard Ch.4),条目0x09 (TxPDO 切换)) | UINT32 | RO | 0x1806:09, 1
1A06:09 | 分索引号 009 | 9. PDO映射条目(对象0x6030 (AI输入),条目0x11 (定值)) | UINT32 | RO | 0x6030:11, 16
索引号 1A07 AI TxPDO-Map Compact Ch.4
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A07:0 | AI TxPDO-Map Compact Ch.4 | PDO映射TxPDO 8 | UINT8 | RO | 0x01 (1dec)
1A07:01 | 分索引号 001 | 1. PDO映射条目(对象0x6030 (AI输入), 条目0x11 (定值)) | UINT32 | RO | 0x6030:11, 16
索引号 1A08 AI TxPDO-Map Standard Ch.5
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A08:0 | AI TxPDO-Map Standard Ch.5 | PDO映射TxPDO 9 | UINT8 | RO | 0x09 (9dec)
1A08:01 | 分索引号 001 | 1. PDO映射条目(对象0x6040 (AI输入), 条目0x01 (映射范围内)) | UINT32 | RO | 0x6040:01, 1
1A08:02 | 分索引号 002 | 2. PDO映射条目(对象0x6040 (AI输入), 条目0x02 (映射范围外)) | UINT32 | RO | 0x6040:02, 1
1A08:03 | 分索引号 003 | 3. PDO映射条目(对象0x6040 (AI输入), 条目0x03 (限制值1)) | UINT32 | RO | 0x6040:03, 2
1A08:04 | 分索引号 004 | 4. PDO映射条目(对象0x6040 (AI输入), 条目0x05 (限制2)) | UINT32 | RO | 0x6040:05, 2
1A08:05 | 分索引号 005 | 5. PDO映射条目(2位对齐) | UINT32 | RO | 0x0000:00, 2
1A08:06 | 分索引号 006 | 6. PDO映射条目(6位对齐) | UINT32 | RO | 0x0000:00, 6
1A08:07 | 分索引号 007 | 7. PDO映射条目(对象0x1808 (AI TxPDO-Par Standard Ch.5), 条目0x07 (TxPDO状态)) | UINT32 | RO | 0x1808:07, 1
1A08:08 | 分索引号 008 | 8. PDO映射条目(对象0x1808 (AI TxPDO-Par Standard Ch.5), 条目0x09 (TxPDO切换)) | UINT32 | RO | 0x1808:09, 1
1A08:09 | 分索引号 009 | 9. PDO映射条目(对象0x6040 (AI输入), 条目0x11 (定值)) | UINT32 | RO | 0x6040:11, 16
索引号 1A09 AI TxPDO-Map Compact Ch.5
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A09:0 | AI TxPDO-Map Compact Ch.5 | PDO映射TxPDO 10 | UINT8 | RO | 0x01 (1dec)
1A09:01 | 分索引号 001 | 1. PDO映射条目(对象0x6040 (AI输入), 条目0x11 (定值)) | UINT32 | RO | 0x6040:11, 16
索引号 1A0A AI TxPDO-Map Standard Ch.6
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A0A:0 | AI TxPDO-Map Standard Ch.6 | PDO映射TxPDO 11 | UINT8 | RO | 0x09 (9dec)
1A0A:01 | 分索引号 001 | 1. PDO映射条目(对象0x6050 (AI输入), 条目0x01 (映射范围内)) | UINT32 | RO | 0x6050:01, 1
1A0A:02 | 分索引号 002 | 2. PDO映射条目(对象0x6050 (AI输入), 条目0x02 (映射范围外)) | UINT32 | RO | 0x6050:02, 1
1A0A:03 | 分索引号 003 | 3. PDO映射条目(对象0x6050 (AI输入), 条目0x03 (限制值1)) | UINT32 | RO | 0x6050:03, 2
1A0A:04 | 分索引号 004 | 4. PDO映射条目(对象0x6050 (AI输入), 条目0x05 (限制2)) | UINT32 | RO | 0x6050:05, 2
1A0A:05 | 分索引号 005 | 5. PDO映射条目(2位对齐) | UINT32 | RO | 0x0000:00, 2
1A0A:06 | 分索引号 006 | 6. PDO映射条目(6位对齐) | UINT32 | RO | 0x0000:00, 6
1A0A:07 | 分索引号 007 | 7. PDO映射条目(对象0x180A (AI TxPDO-Par Standard Ch.6),条目0x07 (TxPDO 状态)) | UINT32 | RO | 0x180A:07, 1
1A0A:08 | 分索引号 008 | 8. PDO映射条目(对象0x180A (AI TxPDO-Par Standard Ch.6),条目0x09 (TxPDO 转换)) | UINT32 | RO | 0x180A:09, 1
1A0A:09 | 分索引号 009 | 9. PDO映射条目(对象0x6050 (AI输入), 条目0x11 (定值)) | UINT32 | RO | 0x6050:11, 16
索引号 1A0B AI TxPDO-Map Compact Ch.6
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A0B:0 | AI TxPDO-Map Compact Ch.6 | PDO映射TxPDO 12 | UINT8 | RO | 0x01 (1dec)
1A0B:01 | 分索引号 001 | 1. PDO映射条目(对象0x6050 (AI输入), 条目0x11 (定值)) | UINT32 | RO | 0x6050:11, 16
索引号 1A0C AI TxPDO-Map Standard Ch.7
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A0C:0 | AI TxPDO-Map Standard Ch.7 | PDO映射TxPDO 13 | UINT8 | RO | 0x09 (9dec)
1A0C:01 | 分索引号 001 | 1. PDO映射条目(对象0x6060 (AI输入), 条目0x01 (映射范围内)) | UINT32 | RO | 0x6060:01, 1
1A0C:02 | 分索引号 002 | 2. PDO映射条目(对象0x6060 (AI输入), 条目0x02 (映射范围外)) | UINT32 | RO | 0x6060:02, 1
1A0C:03 | 分索引号 003 | 3. PDO映射条目(对象0x6060 (AI输入), 条目0x03 (限制值1)) | UINT32 | RO | 0x6060:03, 2
1A0C:04 | 分索引号 004 | 4. PDO映射条目(对象0x6060 (AI输入), 条目0x05 (限制2)) | UINT32 | RO | 0x6060:05, 2
1A0C:05 | 分索引号 005 | 5. PDO映射条目(2位对齐) | UINT32 | RO | 0x0000:00, 2
1A0C:06 | 分索引号 006 | 6. PDO映射条目(6位对齐) | UINT32 | RO | 0x0000:00, 6
1A0C:07 | 分索引号 007 | 7. PDO映射条目(映射条目0x180C (AI TxPDO-Par Standard Ch.7), 条目 0x07 (TxPDO状态)) | UINT32 | RO | 0x180C:07, 1
1A0C:08 | 分索引号 008 | 8. PDO映射条目(对象0x180C (AI TxPDO-Par Standard Ch.7), 条目0x09 (TxPDO切换)) | UINT32 | RO | 0x180C:09, 1
1A0C:09 | 分索引号 009 | 9. PDO映射条目(对象0x6060 (AI输入), 条目0x11 (定值)) | UINT32 | RO | 0x6060:11, 16
索引号 1A0D AI TxPDO-Map Compact Ch.7
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A0D:0 | AI TxPDO-Map Compact Ch.7 | PDO映射TxPDO 14 | UINT8 | RO | 0x01 (1dec)
1A0D:01 | 分索引号 001 | 1. PDO映射条目(对象0x6060 (AI输入), 条目0x11 (定值)) | UINT32 | RO | 0x6060:11, 16
索引号 1A0E AI TxPDO-Map Standard Ch.8
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A0E:0 | AI TxPDO-Map Standard Ch.8 | PDO 映射TxPDO15 | UINT8 | RO | 0x09 (9dec)
1A0E:01 | 分索引号 001 | 1. PDO 映射条目(对象0x6070 (AI对象), 条目0x01 (映射范围内)) | UINT32 | RO | 0x6070:01, 1
1A0E:02 | 分索引号 002 | 2. PDO 映射条目(对象0x6070 (AI输入), 条目0x02 (映射范围外)) | UINT32 | RO | 0x6070:02, 1
1A0E:03 | 分索引号 003 | 3. PDO 映射条目(对象0x6070 (AI输入), 条目0x03 (限制值1)) | UINT32 | RO | 0x6070:03, 2
1A0E:04 | 分索引号 004 | 4. PDO 映射条目(对象0x6070 (AI输入), 条目0x05 (限制2)) | UINT32 | RO | 0x6070:05, 2
1A0E:05 | 分索引号 005 | 5. PDO 映射条目(2位对齐) | UINT32 | RO | 0x0000:00, 2
1A0E:06 | 分索引号 006 | 6. PDO 映射条目(6位对齐) | UINT32 | RO | 0x0000:00, 6
1A0E:07 | 分索引号 007 | 7. PDO 映射条目(对象0x180E (AI TxPDO-Par Standard Ch.8), 条目0x07 (TxPDO状态)) | UINT32 | RO | 0x180E:07, 1
1A0E:08 | 分索引号 008 | 8. PDO映射条目(对象0x180E (AI TxPDO-Par Standard Ch.8), 条目0x09 (TxPDO转换)) | UINT32 | RO | 0x180E:09, 1
1A0E:09 | 分索引号 009 | 9. PDO映射条目(对象0x6070 (AI输入), 条目0x11 (定值)) | UINT32 | RO | 0x6070:11, 16
索引号 1A0F AI TxPDO-Map Compact Ch.8
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1A0F:0 | AI TxPDO-Map Compact Ch.8 | PDO映射TxPDO 16 | UINT8 | RO | 0x01 (1dec)
1A0F:01 | 分索引号 001 | 1. PDO映射条目(对象0x6070 (AI输入), 条目0x11 (定值)) | UINT32 | RO | 0x6070:11, 16
索引号 1C00 同步管理程序类型
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1C00:0 | 同步管理程序类型 | 同步管理程序的应用 | UINT8 | RO | 0x04 (4dec)
1C00:01 | 分索引号 001 | 同步管理程序类型通道1：写邮箱 | UINT8 | RO | 0x01 (1dec)
1C00:02 | 分索引号 002 | 同步管理程序类型通道2：读邮箱 | UINT8 | RO | 0x02 (2dec)
1C00:03 | 分索引号 003 | 同步管理程序类型通道3：写过程数据(输出) | UINT8 | RO | 0x03 (3dec)
1C00:04 | 分索引号 004 | 同步管理程序类型通道4：读过程数据(输入) | UINT8 | RO | 0x04 (4dec)
索引号 1C12 RxPDO配置
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1C12:0 | RxPDO配置 | PDO配置输出 | UINT8 | RW | 0x00 (0dec)
索引号 1C13 TxPDO配置
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1C13:0 | TxPDO 配置 | PDO配置输入 | UINT8 | RW | 0x08 (8dec)
1C13:01 | 分索引号 001 | 1.已分配TxPDO(包含了相应TxPDO映射对象的索引号) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | 分索引号 002 | 2. 已分配TxPDO(包含了相应TxPDO映射对象的索引号) | UINT16 | RW | 0x1A02 (6658dec)
1C13:03 | 分索引号 003 | 3. 已分配TxPDO(包含了相应TxPDO映射对象的索引号) | UINT16 | RW | 0x1A04 (6660dec)
1C13:04 | 分索引号 004 | 4. 已分配TxPDO(包含了相应TxPDO映射对象的索引号) | UINT16 | RW | 0x1A06 (6662dec)
1C13:05 | 分索引号 005 | 5. 已分配TxPDO(包含了相应TxPDO映射对象的索引号) | UINT16 | RW | 0x1A08 (6664dec)
1C13:06 | 分索引号 006 | 6. 已分配TxPDO(包含了相应TxPDO映射对象的索引号) | UINT16 | RW | 0x1A0A (6666dec)
1C13:07 | 分索引号 007 | 7. 已分配TxPDO(包含了相应TxPDO映射对象的索引号) | UINT16 | RW | 0x1A0C (6668dec)
1C13:08 | 分索引号 008 | 8. 已分配TxPDO(包含了相应TxPDO映射对象的索引号) | UINT16 | RW | 0x1A0E (6670dec)
索引号 1C33 SM输入参量
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
1C33:0 | SM输入参量 | 输入同步参量 | UINT8 | RO | 0x07 (7dec)
1C33:01 同步模式(Sync mode) 实际中的同步模式:
  • Bit 0 = 0: 自由运行模式
  • Bit 0 = 1: 包含SM2种事件的同步模式
  • Bit 15 = 0: 标准模式
  • Bit 15 = 1: 简易设备模式(禁用CoE)
 UINT16 RW 0x0000 (0dec)
1C33:02 周期时间 周期时间(单位:ns):
  • 自由运行模式: 本地时钟的周期时间
  • 包含SM的2种事件的同步模式: 主机周期时间
  • DC模式: SYNC0/SYNC1的周期时间
 UINT32 RW 0x00000000 (0dec)
1C33:03 | 漂移时间 | SYNC0种事件到锁存输入所用时间(单位:ns,仅在DC模式下) | UINT32 | RW | 0x00000000 (0dec)
1C33:04 可用同步模式 可用同步模式:
  • Bit 0: 支持自由运行模式
  • Bit 1: 支持带有SM2种事件的同步模式(输出可用)
  • Bit 1: 支持带有SM3种事件的同步模式(无可用输出)
  • Bit 2-3 = 01: 支持DC模式
  • Bit 4-5 = 01: 带本地事件的输入漂移(输出可用)
  • Bit 4-5 = 10: 带SYNC1事件的输入漂移(无可用输出)
  • Bit 14 = 1: 动态时间(通过写入1C33:08后可测量)
 UINT16 RO 0xC003 (49155dec)
1C33:05 | 最小周期时间 | 最小周期时间(单位:ns) | UINT32 | RO | 0x00000000 (0dec)
1C33:06 | 运算与下载时间 | 输入锁存到输入对主机可用过程所用时间(单位:ns,仅在DC模式下) | UINT32 | RO | 0x00000000 (0dec)
1C33:08 命令 通过以下输入，可执行过程数据传输时间的测量
  • 0: 中止本地周期时间的测量
  • 1: 开始本地周期时间的测量

1C33:03, 1C33:06, 1C33:09三条条目会被更新为测量出的最大值。同时，被测值一旦被测，将立即复位。

UINT16 RW 0x0000 (0dec)
1C33:09 | 延迟时间 | SYNC1种事件到锁存输入所用时间(单位:ns, 仅在DC模式下) | UINT32 | RO | 0x00000000 (0dec)
1C33:0B | SM丢失事件计数器 | 运行状态下丢失的SM事件的数量(仅发生在DC模式) | UINT16 | RO | 0x0000 (0dec)
1C33:0C | 周期故障计数器 | 运行状态下发生故障的周期数量(周期没有正常运行，如下一周期提前运行) | UINT16 | RO | 0x0000 (0dec)
1C33:0D | 超短距离计数器 | SYNC0事件和SYNC1事件间的超短距离计数器(仅在DC模式下) | UINT16 | RO | 0x0000 (0dec)
1C33:20 | 同步错误 | 上一周期发生同步错误(输出耗时过长,仅在DC模式下) | BOOLEAN | RO | 0x00 (0dec)

面向文件对象(0x6000-0xFFFF)

对于所用支持文件5001的EtherCAT从站，面向文件对象意义相同。

索引号 60n0 AI输入(for 0 ≤ n ≤ 7)
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
60n0:0 | AI输入 | 最大分索引号 | UINT8 | RO | 0x11 (17dec)
60n0:01 | 未超出范围 | 测量范围内 | BOOLEAN | RO | 0x00 (0dec)
60n0:02 | 超出范围 | 测量范围外 | BOOLEAN | RO | 0x00 (0dec)
60n0:03 | 限制值1 | 限制值监测—限制值1 0: 未监测 1: 监测值小于限制值1 2: 监测值大于限制值1 3: 监测值等于限制值1 | BIT2 | RO | 0x00 (0dec)
60n0:05 | 限制值2 | 限制值监测—限制值2 0: 未监测 1: 监测值小于限制值2 2: 监测值大于限制值2 3: 监测值等于限制值2 | BIT2 | RO | 0x00 (0dec)
60n0:07 | 错误 | 若数据无效(超出范围)，则设置错误位 | BOOLEAN | RO | 0x00 (0dec)
60n0:0F | TxPDO状态 | 已分配TxPDO数据的有效性(0=有效, 1=无效) | BOOLEAN | RO | 0x00 (0dec)
60n0:10 | TxPDO切换 | 若相应PDO的数据已更新，从站将切换TxPDO切换 | BOOLEAN | RO | 0x00 (0dec)
60n0:11 | 输入量 | 模拟输入量 | INT32 | RO | 0x0000 (0dec)
索引号 80nE AI内部数据(for 0 ≤ n ≤ 7)
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
80nE:0 | AI内部数据第一章 | 最大分索引号 | UINT8 | RO | 0x01 (1dec)
80nE:01 | ADC初始值 | ADC初始值 | UINT32 | RO | 0x00000000 (0dec)
索引号 80nF AI供应商数据(for 0 ≤ n ≤ 7)
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
800F:0 | AI供应商数据 | 最大分索引号 | UINT8 | RO | 0x02 (2dec)
800F:01 | 校准偏移 | 偏移量(供货商校准) | INT32 | RW | 0x0000 (0dec)
800F:02 | 校准增益 | 增益量(供货商校准) | UINT32 | RW | 0x4000 (16384dec)
索引号 F000 模块化设备简介
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
F000:0 | 模块化设备简介 | 模块化设备文件概述 | UINT8 | RO | 0x02 (2dec)
F000:01 | 模块索引距离 | 不同频道的对象间的索引距离 | UINT16 | RO | 0x0010 (16dec)
F000:02 | 模块最大数量 | 频道数量 | UINT16 | RO | 0x0004 (4dec)
索引号 F008 码字
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
F008:0 | 码字 | 制造商保留了终端基本校准的著作权。因此当前的制造商码字得以保存。 | UINT32 | RW | 0x00000000 (0dec)
索引号 F010 模块列表
索引号 | 名称 | 解释 | 数据类型 | 标志 | 默认值
F010:0 | 模块列表 | 最大分索引号 | UINT8 | RW | 0x02 (2dec)
F010:01 | 分索引号 001 | 模拟输入文件(300) | UINT32 | RW | 0x0000012C (300dec)
F010:02 | 分索引号 002 | 模拟输入文件(300) | UINT32 | RW | 0x0000012C (300dec)
F010:03 | 分索引号 003 | 模拟输入文件(300) | UINT32 | RW | 0x0000012C (300dec)
F010:04 | 分索引号 004 | 模拟输入文件(300) | UINT32 | RW | 0x0000012C (300dec)
F010:05 | 分索引号 005 | 模拟输入文件(300) | UINT32 | RW | 0x0000012C (300dec)
F010:06 | 分索引号 006 | 模拟输入文件(300) | UINT32 | RW | 0x0000012C (300dec)
F010:07 | 分索引号 007 | 模拟输入文件(300) | UINT32 | RW | 0x0000012C (300dec)
F010:08 | 分索引号 008 | 模拟输入文件(300) | UINT32 | RW | 0x0000012C (300dec)

129


ELxxxx - 恢复出厂设置

BECKHOFF ELxxxx: 配置

恢复出厂设置

恢复ELxxxx端子模块的出厂设置, 在TwinCAT System Manager的CoE对象 "Restore default parameters"中, 选择SubIndex 001 子项 (配置模式) (见图1)

图 1 选择 "Restore default parameters" PDO

双击SubIndex 001进入参数设定对话框。 输入 1684107116十进制或0x64616F6C十六进制，并点击 OK (图2).
所有数据恢复出厂设置

图 2 在设置值对话框中输入复位码

说明 		其他复位码

某些老端子模块请使用以下复位码：

十进制： "1819238756"

十六进制： "0x6C6F6164"

输入错误的复位码无效。


UL 需求

BECKHOFF EKxxxx, ELxxxx: 附录

UL 说明

应用
Beckhoff EtherCAT 模块仅适用于Beckhoff UL 列表中的EtherCAT系统。
测试
更据cULus 测试, Beckhoff I/O 系统仅进行了防火和电击测试 has only been investigated for risk of fire and electrical shock (更据 UL508 和 CSA C22.2 No. 142).
对于以太网接口设备
不适用于连接通信线路

基本原理

倍福EtherCAT产品的两个UL认证，因产品而异：

  • 符合UL508标准的UL认证
    拥有该认证的设备会有这样的标记：

  • 符合限制电源消耗UL508标准的UL认证
    设备消耗的最大电流限制为4A。拥有该认证的设备会有这样的标记。

几乎所有的EtherCAT产品（截止到2010/5）都是非限制的UL认证。

应用

如果端子模块通过 限制认证 , 那么24 V DC 电流消耗必须受到电源限制。

  • 由一个拥有最大电流为4A的保险丝保护的独立电源供电（根据UL248）或者
  • 由一个符合 NEC class 2的电源供电。
    符合 NEC class 2 的电源不能与另一个 NEC class 2 电源串联或并联使用!

这些要求适用于所有的EtherCAT总线耦合器电源，电源适配器端子模块，总线端子模块以及它们的电源触点。


ELxxxx - 固件

BECKHOFF ELxxxx: 设备升级

固件 EL/ES/EMxxxx

这部分描述了Beckhoff EtherCAT从站 EL/ES, EM, EK和EP系列的版本升级。. 固件的升级只能在咨询Beckhoff技术支持之后才能执行。

目录
• 存储位置
• ESI版本定义
• 设备描述升级 ESI/*.xml
• 固件版本描述
• 固件升级文件 *.efw
• 固件升级文件 *.rbf
• 批量更新

存储位置

EtherCAT从站在3个地方存储运行数据：

  • 更据功能和性能EtherCAT从站有一个或几个本地控制器用于传输I/O数据。 所对应的程序称为 固件 为 *.efw 格式。
  • 某些EtherCAT从站的EtherCAT通讯功能也集成在控制器中。 这种情况的控制器叫做 FPGA 芯片使用 *.rbf 格式的固件。
  • 另外每个EtherCAT从站有存储芯片保持设备参数叫做 EEPROM. 通电后自动加载参数，EtherCAT通信也相应设定。 设备描述可以从 http://www.beckhoff.com 下载区下载。 所有 ESI 文件(EtherCAT Slave Information) 压缩成ZIP格式。

客户可以通过 EtherCAT 现场总线和其通信机制访问数据。 ESC读写来实现异步mailbox通讯或访问寄存器。

TwinCAT System Manager提供配置所有这3部分数据的方法，如果从站支持这些数据。 通常从站不会检查新数据是否适合，例如，数据不适合的话从站就再也无法工作。

注意 		小心设备损坏!
当下载新的设备文件时注意如下几点
  • 下载固件到EtherCAT设备时不能被打断
  • 确保EtherCAT通信稳定。 不能有CRC错误或 LostFrames。
  • 供电必须稳定。 信号等级必须达到规范。

设备更新数据时发生故障可能使模块不能使用，需要返厂修复。

设备描述 ESI文件/XML

注意 		关于ESI说明/EEPROM的更新的注意事项
一些从站在产品的EEPROM中存储了标度和配置的数据。 这些在数据更新中被覆盖。

ESI设备描述存储在本机，并且启动时载入。 每个设备描述为唯一的从站名（10个字符数）和版本号（4个数字） 每个从站的名称都在System Manager的 EtherCAT 页面显示:

图 1: 设备识别符号由名称EL3204-0000和修订号-0016组成

配置识别符号必须与实际的硬件设备兼容。在启动时读取从站型号（如EL3204)。 通常配置的修订号必须等于或高于端子模块的版本 。

说明 		更新 XML/ESI 描述文件
用于硬件设备的固件版本是紧密联系在一起的。 不相容的组合会导致故障或设备关机。
相应的更新只能在咨询Beckhoff技术支持之后才能进行。

显示 ESI从站型号

最简单的确定实际设备描述与配置的设备描述是否一致的方法是在 TwinCAT Config/Freerun 模式下扫描EtherCAT 设备：

图 2: 在Config/FreeRun模式下右键EtherCAT device 然后 Scan Boxes

如果实际与配置相符，则显示下

图 3: 配置相同

否则就显示修改对话框来修改配置

图 4: 修改对话框

在图4例子中。实际为 EL3201-0000-0017 ，原来的配置为 EL3201-0000-0016 。 这种情况下可用CopyBefore按钮来修改配置。 ExtendedInformation复选框必须勾上才能显示版本信息。

修改 ESI 从站版本

ESI/EEPROM 版本可以通过 TwinCAT更新:

  • EtherCAT从站通讯不能中断.
  • 从站的状态不重要。
  • 在online标签中右键从站以打开 EEPROM Update 对话框，图 5

图 5: EEPROM 更新

在对话框中选择新ESI 描述文件, 见图 6. ShowHiddenDevices 复选框钩上可以显示老的版本号，默认不显示。

图 6: 选择新ESI 描述文件

System Manager中的进度条显示当前进度。 数据写入后再进行校验。

说明 		重启后更新生效
大多数EtherCAT立刻读取修改的ESI说明或者在初始化启动之后。 一些通讯设置比如分布式时钟仅在电源打开后读取。
因此为了使修改后的参数生效，EtherCAT从站必须断电重启。

确定固件版本

通过序列号确定固件版本

Beckhoff EtherCAT从站的序列号是用激光刻上的。 序列号的结构如下： KK YY FF HH

KK - 生产周 (CW, 日历周)
YY - 生产年
FF - 固件版本
HH - 硬件版本

12 10 03 02:

12 - 第 12周生产
10 - 2010 年生产
03 - 固件版本 03
02 - 硬件版本 02

System Manager确定版本

主站和从站通信上之后TwinCAT System Manager 即可显示从站控制器的固件版本。 选中你想查看的那个E-Bus端子模块 (本例terminal 2 (EL3204))然后选择CoE Online (CAN over EtherCAT).

说明 		CoE Online和 Offline CoE
有2个CoE 目录：
  • online: 如果从站支持的话，由EtherCAT从站控制器提供。
    只有从站处于连接和运行的状态这个CoE目录才会被显示。
  • offline: EtherCAT 从站信息文件 ESI/XML包含 CoE默认数据.
    CoE目录只显示包含在ESI文件中的信息 (e.g. "Beckhoff EL5xxx.xml")。

Advanced 按钮用于切换这两种显示。

在图7中 CoE索引x100A EL3204的固件版本为03

图 7: 显示 EL3204固件版本

(A) TwinCAT 2.11 指示当前显示 Online CoE 目录 如果当前不是这样, 可以进入 Advanced Settings (B) Online选项 然后双击 AllObjects. 显示所有的Online目录。

升级控制器固件 *.efw

说明 		CoE 目录
由控制器管理的Online CoE目录存储在专用的EEPROM中，这个目录通常在固件更新时不会被改变。

为了更新从站控制固件，选中 Online， 见图8

图 8: 固件更新

如果没有Beckhoff技术支持指导话，请按如下步骤进行。

  • 切换从站到 INIT (A)
  • 切换从站到BOOTSTRAP
  • 检查当前状态 (B, C)
  • 下载新 *efw 文件
  • 下载完成后切换到 INIT状态，然后切换到 OP状态
  • 从站重上电一次

FPGA 固件文件 *.rbf

如果是 FPGA芯片负责处理EtherCAT通讯，可以通过更新 *.rbf文件来完成升级。.

  • 控制器固件 处理 I/O信号
  • FPGA 固件 处理EtherCAT 通信 (仅针对采用 FPGA芯片的端子模块)

包括在端子模块的序列号的固件版本号包含这两个固件组件。 如果其中一个固件更新，那这个版本号就会被更新。

通过System Manager查看版本

在TwinCAT System Manager查看FPGA固件版本。 选中EtherCAT 卡 (本例中的 Device 2) 然后选择 Online 标签

Reg:0002 列分别用十六进制和十进制显示了每个EtherCAT设备的固件版本。

图 9: FPGA固件版本确认

如果 Reg:0002列不显示，在表格中右键然后选择Properties...

图 10: 弹出菜单Properties

Advanced Settings对话框显示哪些列可以被显示。 在 Diagnosis/Online View下 '0002 ETxxxx Build'选中复选框，使FPGA固件版本可以显示。

图 11: 高级设置对话框

更新

更新 FPGA固件

  • EtherCAT耦合器 FPGA固件版本为11或以上;
  • E-bus端子模块FPGA固件版本为10或以上。

更早的固件件版本只能由制造商来更新！

升级EtherCAT设备

在TwinCAT System Manager中选择你想升级FPGA固件的端子模块 (本例 terminal 5: EL5001) 然后
点击EtherCAT中的 Advanced Settings按钮。

图 12: 选择高级设置对话框

Advanced Settings对话框显示。 在 ESC Access/E²PROM/FPGA点击 Write FPGA 按钮,

图 13: 选择写FPGA对话框

选择新 FPGA固件文件 (*.rbf) 然后下载到 EtherCAT设备。

注意 		小心设备损坏!
EtherCAT设备的固件更新过程中不能中断！

如果下载过程被取消，电源断开或是Ethernet连接中断，那此EtherCAT设备只能由制造商来修复！

为了激活新的FPGA固件，EtherCAT设备必须重启（将电源关闭再启动）。

同时更新数台 EtherCAT 设备

如果设备有相同的固件文件/ESI，那么几台设备的固件和ESI描述可以同步更新。

图 14: 多重选择和固件更新

选择需要的从站然后在BOOTSTRAP模式下执行固件的更新。


技术支持与售后

Beckhof f 及其合作伙伴遍布世界各地，可为您提供全方位的技术支持与服务，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff 分公司及代表处

有关 Beckhoff 产品的本地技术支持和服务信息，请联系当地的 Beckhoff 分公司和代表处！

有关 Beckhoff 在全球各地分公司和代理商的地址，您可以登录Beckhoff 的官方网站：
http://www.beckhoff.com

此外，您也可以在该网站上查看更多关于 Beckhoff 组件的文档资料。

Beckhoff 总部

德国倍福自动化有限公司

Eiserstr. 5
33415 Verl
德国

电话 | +49(0)5246/963-0
传真： | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff 技术支持

Beckhoff为您提供全面的技术支持，除了Beckhoff 具体产品的应用以外，还包括更广泛的服务：

  • 技术支持
  • 复杂自动化系统的设计、编程和调试
  • 各种 Beckhoff 系统组件培训方案
热线： | +49(0)5246/963-157
传真： | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心提供全方位的售后技术服务:

  • 现场服务
  • 维修服务
  • 零部件服务
  • 热线服务
热线： | +49(0)5246/963-460
传真： | +49(0)5246/963-479
e-mail: | service@beckhoff.com


TwinCAT System Manager - Configuration

BECKHOFF TwinCAT系统管理器: 配置

通过TwinCAT system manager配置

(TwinCAT 版本 2.10.0 (Build 1241), 使用EL5001 ，以固件版本 0.7 为例)

在TwinCAT system manager的左边窗口中, 点击你需要的配置 (例如： EL5001 终端6).

在TwinCAT system manager的右边窗口 可以看到不同的选项卡。.

General 选项卡

名称 | EtherCAT 设备的名称
Id | EtherCAT 设备的数量
Type | EtherCAT 设备类型
Comment | 添加评论
Disabled | 停用EtherCAT 设备
Create symbols | 仅当控制柜是激活的，才有权通过ADS进入到EtherCAT从站

EtherCAT 选项卡

Type | EtherCAT 设备类型
Product/Revision | EtherCAT 设备的产品号和版本号
Auto Inc Addr. | EtherCAT 设备的自动增加. 通过物理位置，这可以用来访问每个EtherCAT 设备。当Ethercat主机给设备分配地址时，将在启动阶段使用自动增加地址。第一个EtherCAT从站将拥有地址 0000hex.。其他从站地址将依次减1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | EtherCAT 从站的固定地址.。这地址由EtherCAT主站在启动阶段分配。要修改默认值，将控制柜标记于输入区域的左侧。
Previous Port | 连接着的 EtherCAT 设备的名称和端口。如果在不改变设备顺序的情况下，能通过另一个设备连接该设备I，那么这个结合区域将被激活，并且将选择连接着的EtherCAT设备。
Advanced Settings | 这个按钮能打开高级设置

底下的链接能连上EtherCAT设备的主页。

Process Data 选项卡

过程数据的配置。从站的输入和输出数据将被表示成硬件协议PDO.如果EtherCAT从站支持的话，用户可以通过PDO分配来选择PDO并且修改独立的PDO内容 。

同步管理

列出同步管理的配置。
如果EtherCAT 设备有mailbox, SM0将被用于mailbox输出(MbxOut) ， SM1 为mailbox输入(MbxIn).
SM2 为输出过程数据(outputs) ，SM3 (inputs) 为输入过程数据。

选择了一个输入后，相应的PDO分配将在PDO 分配 显示

PDO 分配

PDO的分配选定的同步管理器。这里列出了此同步管理器类型中定义的所有的PDO:

  • 如果输出的同步管理器（输出）在同步管理器列表中选择，显示所有RxPDOs。
  • 如果输入的同步管理器（输入）在同步管理器列表中选择，显示所有TxPDOs。

所选条目是参与的过程中数据传输的PDO。在系统管理器的树形图显示这些PDO的EtherCAT设备的变量。 在PDO列表中变量的名称和PDO参数的名称相同。如果PDO分配列表中的条目无效（未选中，灰色），这表明是从PDO分配中排除的输入。为了能够做选择一个灰色显示的PDO，先要取消当前选定的PDO。

注意 		激活PDO的分配
如果你更改了PDO分配，为了激活新的PDO分配，
  • EtherCAT从站需要通过PS状态过渡周期运行(运行前安全业务) (请参阅 联机选项卡),
  • 系统管理器中重新载入EtherCAT从站( [image] 按钮)

PDO 列表

这EtherCAT设备支持所有的PDO列表。选定的PDO的内容显示在PDO的内容列表。 PDO的配置可以通过双击一个条目进行修改。

列 | 描述
Index | PDO 索引
Size | PDO 的尺寸（以字节为单位）
Name | PDO的名称 如果这个PDO被分配到同步管理器, 它显示为一个从站变量。
Flag | F | 固定内容：本PDO的内容是固定的，不能被系统管理员改动。
 | M | 强制性的PDO. PDO是强制性的，因此必须被分配到同步管理器! 因此，此PDO不能从PDO分配列表中删除
SM | 同步管理PDO分配。如果这个项目是空的，这个PDO将不是数据流量的一部分。
SU | 同步分配的PDO单元。

PDO 的内容

表示PDO的内容。如果PDO未设置标志F,则可以修改内容。

下载

如果该设备是智能mailbox，PDO的配置和PDO的分配可以下载到设备中。 这是一项可选功能，不是所有的EtherCAT从站都支持。

PDO 的分配

如果此复选框被选中，在PDO分配列表中以配置的PDO分配将会下载到设备上启动。需要发送到设备的命令，请查看 启动 选项卡。

PDO 的配置

如果此复选框被选中，各自的PDO（如PDO的列表和PDO的内容所示）的配置将下载到EtherCAT从站。

Startup 选项卡

EtherCAT从站如果有一个mailbox，并支持在EtherCAT（CoE）或EtherCAT协议的伺服驱动器的CANopen“启动”选项卡上显示。此标签表明下载请求在启动期间被发送到mailbox。它也可以添加新的mailbox并在列表中显示。下载请求被发送到从站的顺序与在列表中的顺序相同

列 | 描述
Transition 过渡到该请求被发送。这可以是：
  • 提前运行过渡到安全运行 (PS)
  • 安全运行过渡到运行(SO)

如果过渡是在封闭的“<>”（如：<PS>），mailbox要求是固定的，不能修改或删除用户.
Protocol | mailbox协议类型
Index | 对象的索引
Data | 下载此对象的日期
Comment | 对于请求的描述将被发送至mailbox
Move Up | 将选定的请求上移一位
Move Down | 将选定的请求下移一位
New | 在启动时添加一个新的下载请求
Delete | 删除所选条目
Edit | 编辑一个已存在的请求

CoE - Online 选项卡

额外CoE - 如果EtherCAT从站在CoE协议中支持CANopen，将显示 Online 选项卡。此对话框列出的从站对象（SDO上传）的内容，使用户能够在这个名单中修改对象的内容。独立的EtherCAT设备对象的详细信息，可以在设备中特定对象的描述中发现。

对象列表显示
列 | 描述
Index | 对象的索引和子索引
Name | 对象的名称
Flag | RW | 对象可读，并且数据可以写入对象（读/写）
 | RO | 对象可读，但是数据不能写入（只读）
 | P | 增设一个P标志识别过程数据对象
Value | 对象的值
Update List | 更新列表中所有对象
Auto Update | 如果此复选框被选中时，对象的内容会自动更新。
Advanced | “高级”按钮打开“高级设置”对话框。在这里您可以指定哪些对象在列表中显示.

Online - via SDO Information | 如果选择此按钮，包含在从站的对象列表中的对象通过SDO将从从站上传。下面的列表可用于指定哪些对象类型需要上传。
Offline - via EDS File | 如果选择此按钮，在对象列表中的对象将从用户提供的EDS文件读取。

Online 选项卡

状态机

Init | 此按钮尝试设置EtherCAT设备的初始状态。
Pre-Op | 此按钮尝试设置EtherCAT设备到 预操作状态。
Op | 此按钮尝试设置EtherCAT设备的操作状态。
Bootstrap | 此按钮尝试设置EtherCAT设备的引导状态。
Safe-Op | 此按钮尝试设置EtherCAT设备的安全运行状态。
Clear Error | 此按钮尝试删除故障显示. 如果EtherCAT从站在状态变化过程中失败，它 将设置一个错误标志。 例如: EtherCAT从站处于 PREOP状态 (操作前). 主站请求SAFEOP状态 (安全运行). 如果从站在改变状态过程中失败，它将设置一个错误标志。当前状态将显示成 ERR PREOP. 当按下Clear Error 按钮，错误标志被删除，当前状态将重新变为 PREOP。
Current State | 指示EtherCAT设备的当前状态。
Requested State | 指示EtherCAT设备要求的状态。

DLL 的状态

指示 EtherCAT从机的独立端口的DLL状态。DLL有以下四种不同的状态：

状态 | 描述
No Carrier / Open | 无载波信号在端口可用，但该端口是开放的
No Carrier / Closed | 无载波信号在端口可用，但该端口是关闭的
Carrier / Open | 载波信号在端口可用，但该端口是开放的
Carrier / Closed | 载波信号在端口可用，但该端口是关闭的

在EtherCAT的文件访问

Download | 点击这个按钮，一个文件可以被写入到EtherCAT设备
Upload | 点击这个按钮，一个文件可以从EtherCAT设备读出.

184