EL31x2 - 2 Channel Analog Input Terminals

BECKHOFF 现场总线组件

2通道的模拟输入端子的参数

EL3102 (-10 V to +10 V)

EL3112, EL3142-0000 (0 mA to 20 mA)

EL3142-0010 (-10 mA to +10 mA)

EL3122, EL3152 (4 mA to 20 mA)

EL3162 (0 V to 10 V)

版本: 2.3
日期: 2011-08-22


EL31x2 - Documentation issue status

BECKHOFF EL31x2: 前言

文档版本说明

版本 | 注释
2.3 | - 更新LED 描述
2.2 | - 增加技术数据和安全指令
2.1 | - 增加基本功能原理
2.0 | - 增加技术数据，更新的 FW/HW版本
1.1 | - 增加EL3142-0010描述和技术数据
1.0 | - 增加过滤器设置描述(对象描述)
0.1 | - EL31x2的首个临时文件

固件/硬件 版本

文档版本 | EL3102 |  | EL3112 |  | EL3122 |  | EL3142 |  | EL3142-0010
 | 固件 | 硬件 | 固件 | 硬件 | 固件 | 硬件 | 固件 | 硬件 | 固件 | 硬件
2.3 | 08 | 11 | 08 | 04 | 08 | 03 | 08 | 11 | 00 | 03
2.2 | 06 | 06 | 00 | 00 | 06 | 00 | 05 | 06 | 00 | 00
2.1 | 06 | 06 | 00 | 00 | 06 | 00 | 05 | 06 | 00 | 00
2.0 | 06 | 06 | 00 | 00 | 06 | 00 | 05 | 06 | 00 | 00
1.1 | 06 | 06 | 00 | 00 | 06 | 00 | 05 | 06 | 00 | 00
1.0 | 06 | 06 | 00 | 00 | 06 | 00 | 05 | 06 | 00 | 00
0.1 | 06 | 06 | 00 | 00 | 06 | 00 | 05 | 06 | 00 | 00

文档版本 | EL3152 |  | EL3162
 | 固件 | 硬件 | 固件 | 硬件
2.3 | 09 | 10 | 08 | 11
2.2 | 02 | 05 | 03 | 04
2.1 | 02 | 05 | 03 | 04
2.0 | 02 | 05 | 03 | 04
1.1 | 02 | 05 | 03 | 04
1.0 | 02 | 05 | 03 | 04
0.1 | 02 | 05 | 03 | 04

这些固件/硬件版本（传递状态）可以在终端的一侧找到打印在上面序列号

序列号的排列

序列号的结构r: KK YY FF HH

KK - 产品的星期
(CW, 阳历的星期)
YY - 产品的年份
FF - 固件版本
HH - 硬件版本

序列号的例子.: 12 06 3A 02:

12 - 产品的星期 12
06 - 产品年份 2006
3A - 固件版本 3A
02 - 硬件版本 02


EL3102 - Technical data

BECKHOFF EL3102:产品概述

EL3102 - 技术参数

技术参数 | EL3102
输入点数 | 2
信号电压 | -10 V ... +10 V
内阻 | > 200 kΩ
共模电压 UCM | 最大值30 V
分辨率 | 15 Bit + 一位符号位
转换时间 | 大约60 µs (快速模式: 大约40 µs)
尺寸误差（总误差范围） | < ± 0,3 % (满量程)
内部E bus电路供给电源 | 通过E bus
通过E-BUS电流消耗 | typ.180 mA
电气隔离 | 500 Veff (E-Bus/现场电位)
过程映像的位宽 | 输入: 2 x 16 bit (2 x 8 Bit 可选状态)
设置 | 不需要设置地址，可通过TwinCAT System Manager进行配置
重量 | 大约 55 g
工作温度 | 0 °C ... + 55 °C
储存温度 | -25 °C ... + 85 °C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm (匹配宽度: 12 mm)
安装 | 在35 mm 的安装导轨 上 符合EN 50022
抗振动/抗冲击性能 | 符合EN 60068-2-6/EN 60068-2-27/29
抗电磁干扰/抗电磁辐射性能 | 符合 EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认证 | CE UL


EL3112, EL3122 - Technical data

BECKHOFF EL3112, EL3122: 产品概述

EL3112, EL3122 - 技术参数

技术参数 | EL3112 | EL3122
输入点数 | 2
信号电压 | 0 mA ... 20 mA | 4 ... 20 mA
内阻 | typ. 33 Ω + 二极管电压(0.7 V)
共模电压 UCM | 最大值10 V
浪涌电压保护 | 最大值130 V
分辨率 | 16 bit
转换时间 | 大约50 µs (快速模式: 大概35 µs)
尺寸误差（总误差范围） | < ± 0,3 % (满量程)
内部E bus电路供给电源 | 通过E bus
通过E-BUS电流消耗 | typ.180 mA
电气隔离 | 500 Veff (E-Bus/现场电位 )
过程映像的位宽 | 输入: 2 x 16 bit (2 x 8 Bit 状态可选)
配置 | 不需要设置地址，可通过TwinCAT System Manager进行配置
重量 | 大约55 g
工作温度 | 0 °C ... + 55 °C
储存温度 | -25 °C ... + 85 °C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm (匹配宽度: 12 mm)
安装 | 在35 mm 的安装导轨 上 符合EN 50022
抗振动/抗冲击性能 | 符合EN 60068-2-6/EN 60068-2-27/29
抗电磁干扰/抗电磁辐射性能 | 符合 EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认证 | CE UL


EL3142, EL3152 - Technical data

BECKHOFF EL3142, EL3152: 产品概述

EL3142-0000, EL3142-0010, EL3152 - 技术参数

技术参数 | EL3142-0000 | EL3142-0010 | EL3152
输入点数 | 2
信号电压 | 0 mA ... 20 mA | -10 mA ... +10 mA | 4 mA ... 20 mA
内阻 | typ. 33 Ω + 二极管电压 | typ. 50 Ω + 二极管电压 | typ. 33 Ω + 二极管电压
冲击电压 | 最大值 30 V
分辨率 | 16 位
转换时间 | 大约60 µs (快速模式: 大约 40 µs)
尺寸误差（总误差范围） | < ± 0,3 % (满量程)
内部E bus电路供给电源 | 通过E bus
传感器供给电压 | 通过 24 V 电源触片
通过E-BUS电流消耗 | typ.180 mA
电气隔离 | 500 Veff (E-Bus/现场电位)
过程映像的位宽 | 输入: 2 x 16 bit (2 x 8 Bit 状态可选)
配置 | 不需要设置地址，可通过TwinCAT System Manager进行配置
重量 | 大约 55 g
工作温度 | 0 °C ... + 55 °C
储存温度 | -25 °C ... + 85 °C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm (匹配宽度: 12 mm)
安装 | 在35 mm 的安装导轨 上 符合EN 50022
抗振动/抗冲击性能 | 符合 EN 60068-2-6/EN 60068-2-27/29
抗电磁干扰/抗电磁辐射性能 | 符合 EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认证 | CE UL


EL3162 - Technical data

BECKHOFF EL3162: 产品概述

EL3162 - 技术参数

技术参数 | EL3162
输入点数 | 2
信号电压 | 0 V ... +10 V
内阻 | > 200 kΩ
共模电压UCM | 最大值30 V
分辨率 | 16 bit
转换时间 | 大约50 µs (快速模式: ca. 35 µs)
尺寸误差（总误差范围） | < ± 0,3 % (满量程)
内部E bus电路供给电源 | 通过E-bus
通过E-BUS电流消耗 | typ.180 mA
电气隔离 | 500 Veff (E-Bus/现场电位)
过程映像的位宽 | 输入 2 x 16 bit (2 x 8 Bit 状态可选)
配置 | 不需要设置地址，可通过TwinCAT System Manager进行配置
重量 | 大约55 g
工作温度 | 0 °C ... + 55 °C
储存温度 | -25 °C ... + 85 °C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm (匹配宽度: 12 mm)
安装 | 在35 mm 的安装导轨 上 符合EN 50022
抗振动/抗冲击性能 | 符合EN 60068-2-6/EN 60068-2-27/29
抗电磁干扰/抗电磁辐射性能 | 符合 EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认证 | CE UL


EL3102 - Mounting and Wiring

BECKHOFF EL3102: 安装与接线

EL3102 - 接线

输入电气隔离

接线

端子 | 号码 | 注释
+ Input 1 | 1 | + 输入通道1
- Input 1 | 2 | - 输入通道1
GND | 3 | 内部接地(内部连接端子7)
Shield | 4 | PE 接线 (内部连接端子8)
+ Input 2 | 5 | +输入通道2
- Input 2 | 6 | - 输入通道2
GND | 7 | 内部接地(内部接线端子3）
Shield | 8 | PE 连接 (内部连接端子 4)

例子: EL3102 -接线

变化的电压源(通道2)如图2，等价于一个传感器以及一个测量放大器的电路图（通道1）.


EL3112, EL3122 - Mounting and Wiring

BECKHOFF EL3112, EL3122: 安装和接线

EL3112, EL3122 - 接线

输入电气隔离

连接

端子号 | 号码 | 注释
+ Input 1 | 1 | + 输入1通道
- Input 1 | 2 | - 输入1通道
GND | 3 | 内部接地(内部连接端子7和负电极)
Shield | 4 | PE 连接 (内部连接端子8)
+ Input 2 | 5 | +输入2通道
- Input 2 | 6 | -输入2通道
GND | 7 | 内部接地(内部连接端子3）
Shield | 8 | PE 连接 (内部连接端子4)

Example: EL3112, EL3122 - 接线

变化的电流源(通道2)如图2，等价于一个传感器的电路图（通道1）.


EL3142, EL3152 - Mounting and Wiring

BECKHOFF EL3142, EL3152: 安装和接线

EL3142-0000, EL3142-0010, EL3152 - 接线

输入电气隔离

连接

端子 | 号码 | 注释
+ Input 1 | 1 | + 输入1通道
+24 V | 2 | +24 V (内部连接端子6和正电极）
0 V | 3 | 内部接地(内部连接端子7和负电极)
Shield | 4 | PE 连接 (内部连接端子8)
+ Input 2 | 5 | +输入2通道
+24 V | 6 | +24 V (内部连接端子2和正电极)
0 V | 7 | 内部接地(内部连接端子3和负电极）
Shield | 8 | PE 连接 (内部连接端子 4)


EL3162 - Mounting and Wiring

BECKHOFF EL3162: 安装和接线

EL3162 - 接线

输入电气隔离

连接

端子 | 号码 | 注释
+ Input 1 | 1 | + 输入1通道
+24 V | 2 | +24 V (内部连接端子6和正电极）
0 V | 3 | 内部接地(内部连接端子7和负电极)
Shield | 4 | PE 连接 (内部连接端子8)
+ Input 2 | 5 | +输入2通道
+24 V | 6 | +24 V (内部连接端子2和正电极)
0 V | 7 | 内部接地(内部连接端子3和负电极）
Shield | 8 | PE 连接 (内部连接端子 4)


EL31x2 - Objects (CoE)

BECKHOFF EL31x2: 配置

Objects (CoE)

CoE-Online tab EL3102
CoE-Online tab EL3112
CoE-Online tab EL3122
CoE-Online tab EL3142-0000
CoE-Online tab EL3142-0010
CoE-Online tab EL3152
CoE-Online tab EL3162

CoE-Online tab EL3102

CoE-Online tab EL3112

CoE-Online tab EL3122

CoE-Online tab EL3142-0000

CoE-Online tab EL3142-0010

CoE-Online tab EL3152

CoE-Online tab EL3162


EL31x2 - Object Overview

BECKHOFF EL31x2: 配置

Object概述

Note 		EtherCAT XML 设备描述
这个描述对应来自EtherCAT XML 设备描述中的CoE对象显示。我们建议您从倍福网站下载最新版本的相应的XML 文件(http://www.beckhoff.com/english/default.htm?download/elconfg.htm)并且遵循安装手册来操作。
Index |  | 名称 | 标识 | 值
1000 |  | 设备类别 | RO | 0x00000000 (0dec)
1008 |  | 设备名称 | RO | EL3102: | EL3102-0000
 |  |  |  | EL3112: | EL3112-0000
 |  |  |  | EL3122: | EL3122-0000
 |  |  |  | EL3142-0000: | EL3142-0000
 |  |  |  | EL3142-0010: | EL3142-0010
 |  |  |  | EL3152: | EL3152-0000
 |  |  |  | EL3162 | EL3162-0000
1009 |  | 硬件版本 | RO | e.g. V00.01
100A |  | 软件版本 | RO | e.g. V00.06
1011:0 | Subindex | 恢复默认参数 | RW | >1<
 | 1011:01 | Subindex 001 | RW | 0
1018:0 | Subindex | Identity object | RO | >4<
 | 1018:01 | Vendor id | RO | 0x00000002 (2dec)
 | 1018:02 | 产品码 | RO | EL3102: | 0x0C1E3052 (203305042dec)
 |  |  |  | EL3112: | 0x0C283052 (203960402dec)
 |  |  |  | EL3122: | 0x0C323052 (204615762dec)
 |  |  |  | EL3142-0000: | 0x0C463052 (205926482dec)
 |  |  |  | EL3142-0010: | 0x0C463052 (205926482dec)
 |  |  |  | EL3152: | 0x0C503052 (206581842dec)
 |  |  |  | EL3162: | 0x0C5A3052 (207237202dec)
 | 1018:03 | 修正号 | RO | 0x00000000 (0dec)
 | 1018:04 | 序列号 | RO | 0x00000001 (1dec)
1800:0 | Subindex | TxPDO 001 参数 | RO | >6<
 | 1800:06 | Excluded PDO's | RO | 10 1A 00 00
1801:0 | Subindex | TxPDO 002 参数 | RO | >6<
 | 1801:06 | Excluded PDO's | RO | 10 1A 00 00
1810:0 | Subindex | TxPDO 017 参数 | RO | >6<
 | 1810:06 | Excluded PDO's | RO | 00 1A 01 1A
1A00:0 | Subindex | TxPDO 001 映射 | RO | >2<
 | 1A00:01 | Subindex 001 | RO | 0x3101:01, 8
 | 1A00:02 | Subindex 002 | RO | 0x3101:02, 16
1A01:0 | Subindex | TxPDO 002 映射 | RO | >2<
 | 1A01:01 | Subindex 001 | RO | 0x3102:01, 8
 | 1A01:02 | Subindex 002 | RO | 0x3102:02, 16
1A10:0 | Subindex | TxPDO 017 映射 | RO | >2<
 | 1A10:01 | Subindex 001 | RO | 0x6401:01, 16
 | 1A10:02 | Subindex 002 | RO | 0x6401:02, 16
1C00:0 | Subindex | SM 类型 | RO | >4<
 | 1C00:01 | Subindex 001 | RO | 0x01 (1dec)
 | 1C00:02 | Subindex 002 | RO | 0x02 (2dec)
 | 1C00:03 | Subindex 003 | RO | 0x03 (3dec)
 | 1C00:04 | Subindex 004 | RO | 0x04 (4dec)
1C13:0 | Subindex | SM 3 PDO assign (输入) | RW | >3<
 | 1C13:01 | Subindex 001 | RW | 0x1A00 (6656dec)
 | 1C13:02 | Subindex 002 | RW | 0x1A01 (6657dec)
 | 1C13:03 | Subindex 003 | RW | [0x1A10 (6672dec)]
3101:0 | Subindex | 输入 | RO P | >2<
 | 3101:01 | 状态 | RO P | EL3102, EL3112, EL3142-0000, EL3142-0010, EL3162: | 0x00 (0dec)
 |  |  |  | EL3122, EL3152: | 0x41 (65dec)
 | 3101:02 | 值 | RO P | 0dec
3102:0 | Subindex | 输入 | RO P | >2<
 | 3102:01 | 状态 | RO P | EL3102, EL3112, EL3142-0000, EL3142-0010, EL3162: | 0x00 (0dec)
 |  |  |  | EL3122, EL3152: | 0x41 (65dec)
 | 3102:02 | 值 | RO P | 0dec
4040 |  | 厂家代码 | RW | 0x0000 (0dec)
4041:0 | Subindex | ADC 原始值 | RO | >1<
 | 4041:01 | Subindex 001 | RO | 0dec
4042:0 | Subindex | 校准数据 | RW | >2<
 | 4042:01 | 偏移 | RW | 请看 计算例子
 | 4042:02 | 增益 | RW | 请看 计算例子
4061:0 | Subindex | 特征位 | RW | >3<
 | 4061:01 | 用户规格化使能 | RW | FALSE
 | 4061:02 | Enable absolute value with MSB as sign | RW | FALSE
 | 4061:03 | 过滤器使能 (异步模式) | RW | FALSE
4062:0 | Subindex | 用户规格化 | RW | >2<
 | 4062:01 | 偏移 | RW | 请看 计算例子
 | 4062:02 | 增益 | RW | 请看 计算例子
4065 |  | 过滤器设定 | RW | 50 Hz FIR (0dec)
4080 |  | 产家代码 | RW | 0x0000 (0dec)
4081:0 | Subindex | ADC原始值 | RO | >1<
 | 4081:01 | Subindex 001 | RO | 0dec
4082:0 | Subindex | 校准数据 | RW | >2<
 | 4082:01 | 偏移 | RW | 请看 计算例子
 | 4082:02 | 增益 | RW | 请看 计算例子
40A1:0 | Subindex | 特征位 | RW | >2<
 | 40A1:01 | Enable absolute value with MSB as sign | RW | FALSE
 | 40A1:02 | Enable absolute value with MSB as sign | RW | FALSE
40A2:0 | Subindex | 用户规格化 | RW | >2<
 | 40A2:01 | 偏移 | RW | 请看 计算例子
 | 40A2:02 | 增益 | RW | 请看 计算例子
6401:0 | Subindex | 输入 | RO P | >2<
 | 6401:01 | Subindex 001 | RO P | 0dec
 | 6401:02 | Subindex 002 | RO P | 0dec
说明

标志:
RO = 只读
RO P = 只读过程数据
RW = 读写


EL31x2 - Object description

BECKHOFF EL31x2:配置

Object的描述以及参数

Note 		参数化
端子的参数化将可以通过 CoE tab（双击可以得到相关信息）或者Process data tab (PDO分配)来实施。
特征位 (来自Object0x4061)

Object 0x1000: 设备字节

EtherCAT从站的设备字节 (只读) .

Object 0x1008 设备名称

EtherCAT从站的设备名称 (只读,值: EL31x2-xxxx) .

Object 0x1009 硬件版本

EtherCAT从站的硬件版本(只读) .

Object 0x100A 软件版本

EtherCAT从站的软件版本中的(只读) PIC固件 (处理 I/O 信号)

Object 0x1011 负荷设置默认值

Index | 名称 | 含义 | 标志 | 默认值
1011:0 | 恢复参数 | Object长度 | RO | 1
1011:01 | 恢复全部 | 如果Object被设置为"0x6C6F6164" ，所有特定端子Object将会根据他们传递状态来重新设置。 | RO | 0bin
Object 1018 Identity Object
Index | 名称 | 含义 | 标志 | 默认值
1018:0 | 识别Object | Object长度 | RO | 4dec
1018:01 | 供应商ID | EtherCAT 从站供应商的ID | RO | 2dec
1018:02 | 产品码 | EtherCAT从站的产品码 | RO | e.g. 0x0C1E3052 (203305042dec)
1018:03 | 修正号 | EtherCAT从站的修正号 | RO | e.g. 0x00000000
1018:04 | 序列号 | 修订号 | RO | e.g. 1dec
Object 1800 TxPDO 001 参数
Index | 名称 | 含义 | 标志 | 默认值
1800:0 | Tx PDO 001 参数 | Object长度 | RO | 6dec
1800:01 | 不包括PDO's | 指示当映射列表0x1A00 被激活后，显示映射列表0x1A10 被隐藏 | RO | 10 1A 00 00
Object 1801 TxPDO 002 参数
Index | 名称 | 含义 | 标志 | 默认值
1800:0 | Tx PDO 001 参数 | Object长度 | RO | 6dec
1800:01 | 不包括 PDO's | 指示当映射列表0x1A10 被激活后，显示映射列表0x1A01 被隐藏. | RO | 10 1A 00 00
Object 1810 TxPDO 017 参数
Index | 名称 | 含义 | 标志 | 默认值
1810:0 | Tx PDO 017 参数 | Object长度 | RO | 6dec
1810:01 | 不包括 PDO's | 指示当映射列表0x1A10 被激活后，映射列表0x1A00 and 0x1A01 被隐藏. | RO | 00 1A 01 1A
Object 1A00 TxPDO 001 参数
Index | 名称 | 含义 | 标志 | 默认值
1A00:0 | TxPDO 001 映射 | Object长度 | RO | 2dec
1A00:01 | SB Index | PDO Index的状态字节 (通道1) | RO | 0x3101:01, 8
1A00:02 | 输入Object Index 1 | PDO Index的输入数据(通道1) | RO | 0x3101:02, 16
Object 1A01 TxPDO 002 参数
Index | 名称 | 含义 | 标志 | 默认值
1A01:0 | TxPDO 002 映射 | Object长度 | RO | 2dec
1A01:01 | SB Index | PDO Index的状态字节 (通道2) | RO | 0x3102:01, 8
1A01:02 | 输入Object Index 1 | PDO Index的输入数据(通道2) | RO | 0x3102:02, 16
Object 1A10 TxPDO 017 参数
Index | 名称 | 含义 | 标志 | 默认值
1A10:0 | TxPDO 017映射 | Object长度 | RO | 2dec
1A10:01 | 输入Object Index 1 | PDO Index的输入数据(通道1) | RO | 0x6401:01,16
1A10:02 | 输入 Object Index 2 | PDO Index的输入数据(通道2) | RO | 0x6401:02, 16
Object 1C00 SM 类型
Index | 名称 | 含义 | 标志 | 默认值
1C00:0 | SM类别 | Object长度 | RO | 4dec
1C00:01 | SM-参数 1 | 同步管理, 参数 1 | RO | 0x01 (1dec)
1C00:02 | SM-参数2 | 同步管理, 参数 2 | RO | 0x02 (2dec)
1C00:03 | SM-参数 3 | 同步管理, 参数 3 | RO | 0x03 (3dec)
1C00:04 | SM-参数4 | 同步管理, 参数 4 | RO | 0x04 (4dec)
Object 1C13 SM 3 PDO 分配

PDO对于输入的分配

Index | 名称 | 含义 | 标志 | 默认值
1C13:0 | SM 3 PDO 分配 (输入) | Object长度 | RW | 3dec
1C13:01 | PDO-分配 1 | 激活映射列表的Index获得输入数据。激活的输入列表决定了输入过程图像的大小。这个PDO的分配1排除了PDO分配3（Object0x1A10）。 | RW | 0x1A00 (6656dec)
1C13:02 | PDO-分配 2 | 激活映射列表的Index获得输入数据。激活的输入列表决定了输入过程图像的大小。这个PDO的分配2排除了PDO分配3（Object0x1A10）。 | RW | 0x1A01 (6657dec)
1C13:03 | PDO-分配 3 | 激活映射列表的Index获得输入数据。激活的输入列表决定了输入过程图像的大小。这个PDO的分配3排除了PDO分配1+2（Object0x1A00和Object 0x1A01)。 | RW | [0x1A10 (6672dec)]
Object 3101输入 (通道1)
Index | 名称 | 含义 | 标志 | 默认值
3101:0 | 输入 | Object长度 | RO | 2dec
3101:01 | 状态 | 状态字节 (通道1) | RO | -
3101:02 | 值 | 输入过程数据 (通道1) | RO | -
Object 3102 输入(通道2)
Index | 名称 | 含义 | 标志 | 默认值
3101:0 | 输入 | Object长度 | RO | 2dec
3102:01 | 状态 | 状态字节 (通道2) | RO | -
3102:02 | 值 | 输入过程数据 (通道2) | RO | -
Object 4040 产品代码 (通道1)

Note 		产品代码
厂商保留端子的基本标度权利。产品代码目前保留。
Object 4041 ADC未被处理的值 (通道1)
Index | 名称 | 含义 | 标志 | 默认值
4041:0 | ADC 原始数据 | Object长度 | RO | 1dec
4041:01 | ADC 原始数据 | 这个是电路的未被处理的ADC值。它可以通过标度的增益和偏移的计算来转换为测量值。 | RO | 0dec
Object 4042 标度数据 (通道 1)
Index | 名称 | 含义 |  | 标志 | 默认值
4042:0 | 校准数据 | Object长度 |  | RW | 2dec
4042:01 | 16为带符号型整数偏移量 | 这些Object是用来调整组件的容差值来决定测量值。只有在生产代号(Object 4040)被设定后，这些值才能被修改。 | 偏移调整通道1 | RW | 0xXXXX
4042:02 | 16为无符号型整数增益量 |  | 增益调整通道1 | RW | 0xXXXX
Object 4061 特征位(通道 1)
Index | 名称 | 含义 |  |  |  | 标志 | 默认值
4061:0 | 特征位 | Object长度 |  |  |  | RW | 3dec
4061:01 | 用户规模使能 | TRUE | 用户缩放被激活(Object4062) ；输出值随后以计算例子中描述的方法来计算。 |  |  | RW | FALSE
 |  | FALSE | 用户缩放未被激活。
4061:02 | MSB标志绝对值使能 | TRUE | 测量值以磁极符号形式输出 | EL3102 | +10 V = 0x7FFF -10 V = 0xFFFF | RW | FALSE
 |  |  |  | EL3142-0010 | +10 mA = 0x7FFF -10 mA = 0xFFFF
 |  | FALSE | 测量值会以有符号整数补码形式输出 | EL3102 | +10 V = 0x7FFF -10 V = 0x8001
 |  |  |  | EL3142-0010 | +10 mA = 0x7FFF -10 mA = 0x8001
4061:03 | 滤波器使能 | TRUE | 数字滤波器（Object4065， 滤波器设定）被激活，模拟量的值就不会随着过程数据的交换而同步转换，但是与滤波器设定一致。 |  |  | RW | FALSE
 |  | FALSE | 模拟量的值随着过程数据的交换而同步转换；数字滤波器没有被激活。
Object 4062 User scale (通道 1)
(特征位 4061:01 启动)
Index | 名称 | 含义 |  | 标志 | 默认值
4062:0 | 用户规模 | Object长度 |  | RW | 2dec
4062:01 | 16为带符号型整数偏移量 | Object包含了用户缩放。缩放通过40A1:01激活。输出值随后以计算例子中描述的方法来计算 | 偏移调整, 用户缩放通道1 | RW | 0x0000
4062:02 | 16为带符号型整数增益量 |  | 增益调整，用户缩放通道1 增益以固定点的形式与系数2-16一起显示 符合65535dec (0x00010000) | RW | 0x00010000
Object 4065 滤波器设定(通道 1)
(特征位 4061:03 启动)
Enum value | Decimal value | Description | 默认值
50 Hz FIR | 0 | 50Hz的FIR超过32个值；50Hz的干扰要用60dB来抑制 | 50 Hz FIR (0dec)
60 Hz FIR | 1 | 60Hz的FIR超过32个值；60Hz的干扰要用40dB来抑制
IIR Level 1 | 2 | 循环滤波器, trise_90%** = 0,72 ms
IIR Level 2 | 3 | 循环滤波器, trise_90% = 1,62 ms
IIR Level 3 | 4 | 循环滤波器, trise_90% = 3,24 ms
IIR Level 4 | 5 | 循环滤波器, trise_90% = 6,48 ms
IIR Level 5 | 6 | 循环滤波器, trise_90% = 12,96 ms
IIR Level 6 | 7 | 循环滤波器, trise_90% = 25,92 ms
IIR Level 7 | 8 | 循环滤波器, trise_90% = 51,84 ms
IIR Level 8 | 9 | 循环滤波器,r, trise_90% = 103,68 ms
** 上升时间[t_rise_90%]

Object4080 产品代码 （通道 2)

Note 		产品代码
厂商保留端子的基本标度权利。产品代码目前保留。
Object4081 ADC 未处理值通道 2)
Index | 名称 | 含义 | 标志 | 默认值
4081:0 | ADC 原始数据 | Object长度 | RO | 1dec
4081:01 | ADC 原始数据 | 这是电路的未处理的ADC值。通过增益和标度偏移的计算，它会被转换为测量模式 | RO | 0dec
Object 4082 未被处理的数据 (通道2)
Index | 名称 | 含义 |  | 标志 | 默认值
4082:0 | 校准数据 | Object长度 |  | RW | 2dec
4082:01 | 16为带符号型整数偏移量 | 这些Object是用来调整组件的容差值来决定测量值。只有在生产代号(Object 4080)被设定后，这些值才能被修改。 | 偏移调整通道2 | RW | 0xXXXX
4082:02 | 16为无符号型整数增益量 |  | 增益调整通道2 | RW | 0xXXXX
Object 40A1 特征位(通道2)
Index | 名称 | 含义 |  |  |  | 标志 | 默认值
40A1:0 | 特征位 | Object长度 |  |  |  | RW | 2dec
40A1:01 | 用户规模使能 | TRUE | 用户缩放被激活(Object40A2) ；输出值随后以计算例子中描述的方法来计算。 |  |  | RW | FALSE
 |  | FALSE | 用户缩放未被激活。
40A1:02 | MSB标志绝对值使能 | TRUE | 测量值以磁极符号形式输出 | EL3102 | +10 V = 0x7FFF -10 V = 0xFFFF | RW | FALSE
 |  |  |  | EL3142-0010 | +10 mA = 0x7FFF -10 mA = 0xFFFF
 |  | FALSE | 测量值会以有符号整数补码形式输出 | EL3102 | +10 V = 0x7FFF -10 V = 0x8001
 |  |  |  | EL3142-0010 | +10 mA = 0x7FFF -10 mA = 0x8001
Object 40A2 User scale (通道2)
(特征位 40A1:01 启动)
Index | 名称 | 含义 |  | 标志 | 默认值
40A2:0 | 用户规模 | Object长度 |  | RW | 2dec
40A2:01 | 16位偏移有符号整数 | Object包含了用户缩放。缩放通过40A1:01激活。输出值随后以计算例子中描述的方法来计算。 | 偏移调整, 用户缩放通道2 | RW | 0x0000
40A2:02 | 32位增益有符号整数 |  | 增益调整，用户缩放通道2 增益以固定点的形式与系数2-16一起显示 符合65535dec (0x00010000) | RW | 0x00010000
Object 6401 输入 (通道 1 + 2)
Index | 名称 | 含义 | 标志 | 默认值
6401:0 | 输入 | Object长度 | RO | 2dec
6401:01 | 通道1的值 | 通道1输入过程数据 | RO | -
6401:02 | 通道2的值 | 通道2输入过程数据 | RO | -


EL31x2 - Control- and Status byte

BECKHOFF EL31x2: 配置

控制和状态字节

状态字节

状态字节（sb）位于输入过程映像中，将从端子传入控制器中:

位 | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
名称 | - | 错误 | - | - | - | - | 大于量程上限 | 小于量程下限
说明
位 | 名称 | 含义
SB.7 | - | 0bin | 保留
SB.6 | Error | 1bin | 总错误位，显示超量程（小于下限，或高于上限）
SB.5 | - | 0bin | 保留
SB.4 | - | 0bin | 保留
SB.3 | - | 0bin | 保留
SB.2 | - | 0bin | 保留
SB.1 | Overrange | 1bin | 输入测量值超量程 | EL3102: | 测量值> 10 V
 |  |  |  | EL3112: | 测量值> 20 mA
 |  |  |  | EL3122: | 测量值> 20 mA
 |  |  |  | EL3142-0000: | 测量值> 20 mA
 |  |  |  | EL3142-0010: | 测量值> 10 mA
 |  |  |  | EL3152: | 测量值> 20 mA
 |  |  |  | EL3162: | 测量值> 10 V
SB.0 | Underrange | 1bin | 输入测量值在欠范围 | EL3102: | 测量值< -10 V
 |  |  |  | EL3112: | 保留
 |  |  |  | EL3122: | 测量值< 大约3,5 mA
 |  |  |  | EL3142-0000: | 保留
 |  |  |  | EL3142-0010: | 测量值 < -10 mA
 |  |  |  | EL3152: | 测量值< 大约,5 mA
 |  |  |  | EL3162: | 保留

控制字节

EL31x2.没有控制字节


技术支持与售后

Beckhof f 及其合作伙伴遍布世界各地，可为您提供全方位的技术支持与服务，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff 分公司及代表处

有关 Beckhoff 产品的本地技术支持和服务信息，请联系当地的 Beckhoff 分公司和代表处！

有关 Beckhoff 在全球各地分公司和代理商的地址，您可以登录Beckhoff 的官方网站：
http://www.beckhoff.com

此外，您也可以在该网站上查看更多关于 Beckhoff 组件的文档资料。

Beckhoff 总部

德国倍福自动化有限公司

Eiserstr. 5
33415 Verl
德国

电话 | +49(0)5246/963-0
传真： | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff 技术支持

Beckhoff为您提供全面的技术支持，除了Beckhoff 具体产品的应用以外，还包括更广泛的服务：

  • 技术支持
  • 复杂自动化系统的设计、编程和调试
  • 各种 Beckhoff 系统组件培训方案
热线： | +49(0)5246/963-157
传真： | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心提供全方位的售后技术服务:

  • 现场服务
  • 维修服务
  • 零部件服务
  • 热线服务
热线： | +49(0)5246/963-460
传真： | +49(0)5246/963-479
e-mail: | service@beckhoff.com