EL3403 - 3-phase power measurement terminal

BECKHOFF 现场总线的组成部分

EL3403文档

3-电源测量端子模块

版本: 1.8
基准: 2012-01-18

EtherCAT® is 已经被德国Beckhoff自动化有限公司注册为商标 和技术专利 。


BECKHOFF 自动化: 前言

文档说明

本手册仅供那些受过适当培训，熟悉各种适用国家标准的“控制、自动化和驱动工程”领域专业人员使用。
在安装和调试这些组件时，操作人员必须严格遵循下列说明和解释。

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

免责声明

尽管本文档经过精心编制，但由于其中所描述的产品仍处于不断更新换代中，我们可能不会在每次更新后都检查文档中所描述的产品性能数据、标准或其它特性总是与实际产品相一致。
本文档中难免会出现一些技术或者编辑错误，我们保留随时对文档信息作出修改之权力，恕不另行通知。对于已经变更的产品，如果本文档中的数据、图表以及文字描述没有修改，我们将不再特别加以声明。

商标

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® 已为Beckhoff 自动化有限公司的注册商标
本出版物中的相关名称若被第三方出于个人目的，用作商标，将侵犯其拥有者的权利。

申请中的专利

已包含EtherCAT技术但不局限于如下专利申请和专利:
在许多其他国家有关EP1590927, EP1789857, DE102004044764, DE102007017835的相关申请和注册。

已包含TwinCAT技术但不局限于如下专利申请和专利:
在许多其他国家有关EP0851348, US6167425的相关申请和注册。

版权

© 德国倍福自动化有限公司.
未经许可，任何人不得复制、分发和使用本手册以及内容传播。
违者将追究损害赔偿 版权所有，包括实用新型的模型和外观设计的版权。


安全说明

安全规程

请仔细阅读下列安全说明及相关描述！
有关产品特定安全规程，请见后面页或有关安装，接线及调试等章节。

免责声明

所有组件在供货前均针对其具体应用进行了特定的软、硬件配置。 任何人不得对软、硬件配置进行文本档中规定之外的修改，德国倍福自动化有限公司对因此而造成的一切后果不承担任何责任。

人员资质

本手册仅供那些受过适当培训，熟悉各种适用国家标准的“控制、自动化和驱动工程”领域专业人员使用。

安全标志说明

本操作手册中用到了下列安全标志及相应的安全说明。 请仔细阅读并严格遵守。

危险 		有严重人身伤害危险!
不遵守本标志相关的安全说明将直接危及个人生命和健康安全。

警告 		受伤的危险
不遵守本标志相关的安全说明将危及个人生命和健康安全。

小心 		危害个人
不遵守本标志相关的安全说明可能明显危害个人安全。

注意 		对环境和设备有危险
不遵守本标志相关安全说明可能明显危害环境和设备安全。

说明 		说明或提示
该标志表示这些信息能够帮助您更好地理解安全说明。
UL 说明
这个标志用于表示有关UL标准的重要信息。.


EL3403 - 文档版本说明

BECKHOFF EL3403: 前言

文档版本说明

版本 | 说明
1.8 | 增加应用案例
1.7 | 添加比例参数这章。新结构
1.6 | 添加4象限图
1.5 | 添加和更正
1.4 | 添加和更正
1.3 | 技术数据更正，增加EL3403-0010
1.2 | 技术数据更正
1.1 | 技术数据更正
1.0 | - 首次公开发行,技术数据更正
0.4 | - PDO 说明添加 "负能量"
0.3 | - 小修改
0.2 | - 技术数据添加, CoE 对象添加
0.1 | - EL3403准备文档


版本说明

BECKHOFF: 前言

EtherCAT 设备版本说明

命名方法

BECKHOFF EtherCAT

  • 系列关键字
  • 类型
  • 版本
  • 子版本
例子 | 系列 | 类型 | 版本 | 子版本
EL3314-0000-0016 | EL 端子模块 (12 mm, 非可插拔式连接) | 3314 (4-通道 热电偶端子模块) | 0000 (基本类型) | 0016
CU2008-0000-0000 | CU 设备 | 2008（8口快速以太网交换机) | 0000 (基本类型) | 0000
ES3602-0010-0017 | ES 端子模块 (12 mm, 非可插拔式连接) | 3602 (2-通道电压测量) | 0010 (高精度版本) | 0017

说明

  • 订货号由以下组成
    - 系列关键字
    - 类型
    - 版本
  • 子版本 表示技术改进过程
    原则上高子版本兼容底子版本，特殊除外
    每个修订版通常有一个相关XML的描述（ESI,EtherCAT Slave信息），可以在Beckhoff官网下载。
  • 类型，版本，子版本都以十进制数表示

序列号

Beckhoff EtherCAT 设备有一个8位数的序列号, 印刷在设备上或标签上。 序列号标明了出厂时的状态

序列号说明

序列号结构 KK YY FF HH

KK - 生产周 (CW, 日历周)
YY - 生产年
FF - 固件版本
HH - 硬件版本

序列号例子: 12 06 3A 02:

12 - 第 12周生产
06 - 2006 年生产
3A - 固件版本 3A
02 - 硬件版本 02

序列号举例

图 1: EL6688 EL 端子模块

图 2: CU2016 交换机

图 3: EK1100 EtherCAT 耦合器


EL3403 - 技术数据

技术数据 | EL3403-0000 | EL3403-0010
测量值 | 电流, 电压,有功功率, 示在功率, 频率
计算值 | 无功功率, 能耗, 功率因数 (cosj)
测量电压 | 最大 500 V AC 3~ (ULX-N: 最大 288 V AC)
测量电流 | 最大 1 A (AC), 通过电流互感器 x A / 1 A | 最大 5 A (AC), 通过电流互感器 x A / 5 A
输入电压电路内阻(typ.) | 500 kW
输入电压电路内阻 (typ.) | 220 mW
分辨率 | 1 µA, 0,1 mV, 10 mW | 5 µA, 0,1 mV, 50 mW
测量精度 | 0.5 %相对于满量程 (U/I), 1 % 计算值 (P) | 1 % 相对于满量程 (U/I), 1.5 % 计算值 (I/P)
过程映像位宽 | 64 字节输入， 3 字节输出
频率范围 | 45 Hz ..65 Hz
截止频率 | 大约 260 Hz
信号波形 | 任何 (需要考虑频率范围和截止频率)
测量过程 | 真有效值 64000次采样
测量周期 | 默认每个测量值200ms，可以修改，网络同步
绝缘强度 | 1500 V有效值 (terminal/E-bus)
内部 E-bus电路供电 | 通过E-bus
E-bus电流消耗 | 典型 120 mA
配置 | 通过 TwinCAT System Manager
重量 | 约. 75 g
工作温度范围 | 0 °C ... +55 °C
存储温度 | -25 °C ... +85 °C
相对湿度 | 95%, 无冷凝
尺寸 | 大约 15 mm x 100 mm x 70 mm (对齐宽度: 12 mm)
安装 | 安装在35 mm导轨上，根据 EN 50022标准
抗振动/抗冲击性能 | 根据 EN 60068-2-6/EN 60068-2-27/29
抗电磁干扰/抗电磁辐射性能 | 根据 EN 61000-6-2/EN 61000-6-4
保护等级/安装位置 | IP 20/任意
认证 | CE


Start

BECKHOFF EL3403: 产品概述

启动

调试:

  • 安装EL3403会在“安装与接线”章节中说明
  • 用TwinCAT 调试EL3403会在“调试”章节中说明


EtherCAT 基础

请参考 "EtherCAT System Documentation"EtherCAT现场总线基础章节。


EtherCAT 接线

BECKHOFF EtherCAT: 通信基础

EtherCAT 布线 – 接线

两台EtherCAT设备间电缆长度不能超过100米。 这与快速以太网技术一致，因为超过这个电缆的长度，会使信号衰减。允许的最长连接长度是5 + 90 + 5米。 详见 对 EtherCAT/Ethernet的设计建议.

电缆和接头

只有以太网连接器（电缆+插头）符合EN 50173 或ISO/IEC 11801至少category 5（CAt5)才可以连接EtherCAT设备。 EtherCAT用4根线来进行信号传输。

例如，EtherCAT用RJ45插头。 其引线分配符合以太网标准(ISO/IEC 8802-3)。

针脚 | 导体颜色 | 信号 | 描述
1 | 黄 | TD + | Transmission Data +
2 | 橙 | TD - | Transmission Data -
3 | 白 | RD + | Receiver Data +
6 | 蓝 | RD - | Receiver Data -

由于实现自动电缆检测，可以在Beckhoff的EtherCAT设备之间，使用对称或交叉电缆。

说明 		推荐电缆
适于连接EtherCAT设备的电缆可以在 Beckhoff 官网上找到!

E-Bus 电源供给

总线耦合器可以通过E-bus系统将5V电压供给EL端子； 一个耦合器可以提供2A电流。 每个EL端子要消耗多少E-bus电流，可以从网站或样本里得到资料。 如果所用的端子模块的电流总和大于耦合器的提供能力，那么就需要增加E-bus电源模块(例如 EL9400) 在端子模块中的合适位置。

在TwinCAT 系统管理中会显示出E-bus预先计算好的电流理论最大值。 如果电流不足将会显示一个感叹号； 那么就需要在这个位置之前加一个电源模块。

图 1: 系统管理中电流的计算值

注意 		小心! 可能故障
在同一个端子模块组中，所有的EtherCAT端子的E-bus供电必须有相同的对地电势。


看门狗设置说明

ELxxxx 总线端子模块装有一个安全装置（看门狗）在发生数据传输中断一定时间后关闭输出。
EL2xxx总线端子模块的EtherCAT从站控制器(ESC)装有2个看门狗：

  • SM 看门狗 (默认: 100 ms)
  • PDI 看门狗 (默认: 100 ms)

SM 看门狗 (SyncManager 看门狗)

SyncManager 看门狗将会在每次EtherCAT成功通讯之后复位。 如果和终端模块没有EtherCAT数据传输的时间长于SM看门狗的设定时间，例如：在发生线路中断时，看门狗会触发并将输出设为FALSE。 端子模块的 OP状态不受影响 看门狗只会在成功进行EtherCAT数据传输之后复位。 设置上述的监视时间。

SyncManager看门狗在EtherCAT方面，监视ESC过程数据通讯的正确性。

PDI 看门狗 (过程数据看门狗)

如果EtherCAT从站控制器(ESC)与PDI看门狗没有数据传输的时间长于PDI看门狗的设定时间，就会激活PDI看门狗。
PDI (Process Data Interface) 是ESC和本地EtherCAT从站处理器之间的内部接口。 PDI 看门狗可用于监视此通信是否成功。

PDI看门狗在应用方面，监视ESC过程数据通讯的正确性。

图 1 EtherCAT tab -> Advanced Settings -> Behavior

倍增器

每个看门狗通过本地端子循环接收脉冲，由监视倍增器拆分。

1/25 MHz * (看门狗倍增器 + 2) = 100 µs (倍增器默认设置为 2498)

SM看门狗默认设置是1000相当于释放时间是100ms。

倍增数值+2相当于40ns倍数代表了看门狗的时间。
倍增器可以修改，以适应在更大范围内的看门狗时间。

例子"设定 SM 看门狗"

复选框使能手动设定看门狗时间。 如果设定了输出且EtherCAT通信中断，SM 看门狗将在设定时候到后复位输出。 修改这个设置以适应较慢的EtherCAT主站或更长的扫描周期。 默认SM看门狗设定为100 ms. 设定范围 0..65535. 加上倍增器范围是1~65535涵盖了看门狗0~170秒的周期。

计算

倍增数 = 2498 → 看门狗基准时间 = 1 / 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM 看门狗 = 10000 → 10000 * 100 µs = 1 second 看门狗监视时间

小心 		小心! 可能出现未定义状态!
只能在端子版本-0016上实现通过设定SM看门狗=0 来关闭SM看门狗功能。
在之前的版本这项功能不能使用。

小心 		小心! 设备损坏和可能出现未定义状态！
如果在SM看门狗激活之后，输入数字0，看门狗就会关闭。
这时如果通信中断了那么输出就不会被复位。


EtherCAT状态机

EtherCAT从站的状态由EtherCAT状态机（EMS）控制。 依据不同的状态，可以在EtherCAT从站中得到或执行不同的功能。 EtherCAT主站必须发送特殊指令来控制设备的每个状态，尤其是启动从站的时候。

有以下几种状态

  • Init
  • Pre-Operational
  • Safe-Operational
  • Operational
  • Boot

启动后每个EtherCAT从站的最终状态是OP状态。

Init

通电后EtherCAT为Init状态。 mailbox和过程数据无法通讯 。 EtherCAT主站初始化通道0和1同步管理器，为mailbox 通讯准备。

Pre-Operational (Pre-Op)

在 Init 和 Pre-Op的过渡过程中，EtherCAT从站检查mailbox是否正确初始化。

在 Pre-Op 状态 mailbox可以通讯, 但是过程数据无法通讯。 EtherCAT主站初始化过程数据的同步管理器通道 (来自于同步管理器通道2), FMMU通道和, 如果从站支持可调整映射，PDO映射或同步管理器PDO分配。 在这个状态，过程数据的传输设置和端子模块特殊设置也会被传输。

Safe-Operational (Safe-Op)

在 Pre-Op 和 Safe-Op的过渡过程中，EtherCAT从站检查是否过程数据通信的同步管理器通道和分布式时钟设置是否正确。 在确认状态转换之前，EtherCAT从站会将当前输入数据复制到EtherCAT从站控制器（ECSC）中的DP-RAM区域。

在Safe-Op状态可以进行mailbox和过程数据通讯，尽管从站的输出处于安全状态，但是输入数据可以循环更新。

Operational (Op)

在EtherCAT主站切换它的从站从Safe-Op到 Op 状态之前，必须传递有效的输出数据。

在 Op状态，从站复制主站输出数据到从站的输出。 可以进行mailbox和过程数据通讯

Boot

在 Boot 状态，可以更新从站的固件 Boot 状态只能从 Init 状态转换过来。

在 Boot状态，mailbox通讯可以通过file access over EtherCAT (FoE) 协议实现, 但是其他形式的mailbox和过程数据通讯不支持。


CoE-接口

CoE接口是 EtherCAT 设备的参数设定接口。 在CAN-over-EtherCAT (CoE)的管理机构中，特定的固件参数可以在网上或EtherCAT的离线参数中获得。

CoE接口的详细信息可以在Beckhoff 网站上 EtherCAT system documentation 中找到。


分布时钟

分布式时钟代为EtherCAT从站控制器（ESC)中的本地时钟，有如下的特性：

• 单位 1 ns
• 零点1.1.2000 00:00
• 大小 64 位 (最多支持 584 年; 有些 EtherCAT 从站只提供对32位的支持, 即大约4.2S)
• EtherCAT主站会自动同步主站时钟和EhterCAT总线中的本地时钟，精度达< 100 ns。

更详细的信息参考EtherCAT system description.


ELxxxx, KLxxxx - Installation on mounting rails

Beckhoff 现场总线组件: 安装和接线

安装到导轨上

警告 		小心电击危险和损坏设备！
在安装，拆卸和连线之前确保总线终端处于安全的断开状态!

安装

总线耦合和总线终端都可以毫不费力地安装在35mm导轨上。这个导轨可以在市场上买到 (DIN 轨道依据 EN 50022标准)：

  1. 首先将现场总线耦合器安装在导轨上。
  2. 总线端子模块安装在现场总线耦合器的右边。 通过卡槽将元件连接在一起且将端子按在导轨上，直到将锁扣扣在轨道上。
    如果先将终端模块夹在安装导轨上然后再连接到一起，且不使用卡槽连接，这样连接将不会运转！ 正确的连接是模块之间没有可见的缝隙。

说明 		固定安装导轨
在总线终端模块安装完之后，总线端子模块的锁定机构不能与安装轨道上的固定螺丝相碰。

拆卸

每个端子都用锁扣固定在安装轨道上，在拆卸的时候必须解开锁扣：
  1. 将端子模块上的橘黄色卡扣从安装轨道上拉出大约1cm。 这样做，端子的安装轨道锁就可以解开，然后你就可以将总线端子模块轻松的拔出。
  2. 大拇指和食指同时抓住端子模块的上部和下部，然后拉出总线端子模块。

总线端子模块内部连接

总线耦合器和总线端子模块间的电气连接是通过连接的组件自动接通的：

  • K-Bus/E-Bus的六个弹簧触点用来传输数据和供电给总线端子。
  • 电源触点用于现场设备供电，并通过总线端子模块内部进行传递。 通过总线耦合器给电源触点供电（最高24V），或者通过供电端子模块提供更高的电压。

说明 		电源触点
在设计总线端子模块时，必须计算总线端子的引脚分配，因为有些型号不会或不完全通过电源连接。（例如：模拟总线端子模块或4通道的数字总线端子模块）
供电端子模块 (KL91xx, KL92xx or EL91xx, EL92xx) 中断电源并重新开始一个电源供应链路。

PE 电源触点

有PE标示的电源触片是用来接地保护的。 出于安全因素这个触片要先连接在一起，对地的最大短路电流是125 A。

注意 		可能损坏设备
考虑到电磁兼容性，PE触点与安装轨道之间是电容耦合的。 这可能会在绝缘测试时导致错误或损坏端子（例如：客户在绝缘测试时把230V放电到PE短路）

如果要进行绝缘测试， 断开总线耦合器或供电端子模块的PE！ 为了完全断开供电触点, 把供电端子模块从导轨上拉出至少10mm。

警告 		小心触电
PE连接不能用来接其他的电位！


KLxxxx, KSxxxx, ELxxxx, ESxxxx - 连接系统

BECKHOFF 现场总线组件: 安装和接线

连接系统

警告 		小心电击危险和损坏设备！
在安装，拆卸和连线之前确保总线终端处于安全的断开状态!

概述

总线端子系统为不同的设备提供不同的最优连接：

  • KLxxx和ELxxxx系列接线端子模块连接器和电子元件封装在同一个外壳中。
  • KSxxxx 和 ESxxxx系列接线端子模块采用可插拔的连接器使更换时不需要接线。
  • 高密度端子模块系列 (HD Terminals)连接器和电子元件封装在同一个外壳中，封装密度更高。

标准接线

KLxxx和Elxxx端子系列经过多年测试。
集成无螺丝弹簧压紧技术，提供了快速简单的装配。

可插拔式接线

KSxxx和ESxxx端子系列的特点是可插拔式连接。
KS系列的安装和接线方式与KLxxxx 和 ELxxxx 系列类似。
KS/ES端子系列可以使插拔式连接器从外壳上完整移走便于维护。
拉起 解锁条可以把下部的模块从导轨上移除.
插入新的模块装上带线的连接器
节省安装时间减少接线错误

端子模块的尺寸基本相同，只有很小的变化。 新的连接器增加了约3mm 端子模块的最大高度保持不变

扎线环有助于扎紧电线，避免电线在拔下连接器时缠绕。

线径位于 0.08 mm2 和 2.5 mm2 都可以用弹簧连接器.

KSxxxx 和 ESxxxx 系列模块的型号命名方式 KLxxxx 和 ELxxxx 系列相同.

高密度端子模块 (HD Terminals)

KLx8xx 系列总线端子模块有16个连接点，是特别紧凑的设计，是传统12 mm 总线端子模块连接点数量的2倍。 硬导线和压了线套的导线可以直接插入弹簧接线孔而不需要工具。

说明 		高密度模块接线
高密度端子模块KLx8xx 和 ELx8xx 系列没有对应的可插拔连接器系列。

说明 		超声 “焊接" 导线
可以使用超声波“粘合”（超声波焊接）导体来连接标准或高密度端子模块。
在这种情况下, 请注意 下面线径说明表!

接线

连接 ELxxxx / KLxxxx 标准接线端子和 ESxxxx / KSxxxx可插拔式连接器

最多可以连接8根线到总线端子模块，把线扎在总线端子模块连接器上。 端子连接采用弹簧力连接技术。 根据下面的步骤来接线：

  1. 用螺丝刀插入位于接口上方的方形孔来打开弹簧接线端子。
  2. 现在电线可以毫不费力的直接插入圆形孔。
  3. 当拔掉螺丝刀后弹簧端口会自动合上，将接线永久牢固的接上。

端子模块外壳 | ELxxxx, KLxxxx | ESxxxx, KSxxxx
线径 | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
剥线长度 | 8 ... 9 mm | 9 ... 10 mm

高密度端子模块 ELx8xx, KLx8xx (HD)

单芯硬线连接HD端子模块的接点只需要剥线之后直接插入即可，不需要额外的工具。 导线可以用螺丝刀卸下。 下表为对线径的要求。

端子模块外壳 | ELx8xx, KLx8xx (HD)
线径 (conductors with a wire end sleeve) | 0.14... 0.75 mm2
线径 (单芯硬线) | 0.08 ... 1.5 mm2
线径 (细导线) | 0.25 ... 1.5 mm2
线径 (超声 “焊接" 导线) | 只能 1.5 mm2 (见 说明!)
剥线长度 | 8 ... 9 mm

Shielding

说明 		屏蔽
模拟传感器和执行器总是用屏蔽双绞线相连。


安装辅助端子模块

说明 		安装辅助端子模块注意点
EtherCAT 总线端子模块 (ELxxxx / ESxxxx), 不担任数据传输任务的模块称为辅助端子模块。
辅助端子模块不消耗 E-bus电流
为确保最优的数据传输，不能连续连接超过两个接线端子模块。
辅助接线端子模块的实例（高亮部分）

例子 1: 正确的配置

例子 2: 错误的配置


TwinCAT System Manager -配置

BECKHOFF TwinCAT System Manager: 配置

TwinCAT System Manager进行配置

(以TwinCAT 2.10.0 (Build 1241)版本, 和EL5001 固件版本 0.7以上 为例)

在TwinCAT System manager左手边的窗口，点击你想要设置的模块（如例：EL5001 Terminal 6 ）。

在TwinCAT System manager右手边的窗口，有多个用来设置端子的标签。

General tab

Name | EtherCAT 设备名称
Id | EtherCAT 设备编号
Type | EtherCAT 设备说明
Comment | 这里你可以添加注释(比如，关于系统)。
Disabled | 你可以在这里停止使用EtherCAT设备。
Create symbols | 如果选中复选框，可以通过ADS连接这个EtherCAT从站

EtherCAT tab

Type | EtherCAT 设备说明
Product/Revision | EtherCAT 设备的型号和版本
Auto Inc Addr. | EtherCAT设备的地址自动增量。 自动增量地址可以通过EtherCAT设备的物理地址在通信环中定位它的地址。 自动增量地址更据EtherCAT设备在通信环中的物理位置排列。 在通信环中的第一个EtherCAT从站的地址就是0000hex. 之后的从站地址减 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | 固定 EtherCAT 从站地址。 此地址由EtherCAT 主站启动时分配。 选中左侧的复选框后即可修改。
Previous Port | 已连接的前一个EtherCAT设备的名字和端口。 这里可以通过不改变EtherCAT通讯环来选择这个设备与另一个设备的连接，下拉框里列出可以选择的EtherCAT设备。
Advanced Settings | 点击这个按钮 打开高级设置对话框。

底部的链接指向网站上的产品页面

Process Data tab

为过程数据的设置。 EtherCAT 从站的输入输出数据是用CANopen数据对象(PDO)来表示。 如果EtherCAT从站支持这个功能，可以通过这个对话框修改PDO选项。

Sync Manager

列出Sync Manager（SM）的设置。
如果EtherCAT从站有mailbox，SM0用于mailbox输出(MbxOut)， SM1用于mailbox输入(MbxIn)。
SM2用于输出过程数据 (outputs) ， SM3 (inputs)用于输入过程数据。

如果选定输入, 在下面 PDO Assignment 的列表中显示对应的PDO分配。

PDO Assignment

所选 Sync Manager的PDO分配 当前Sync Manager 类型所定义的所有PDOs 都显示在这里：

  • 如果Sync Manager列表中选择输出Sync Manager (outputs)，所有的RxPDOs都显示在下面。
  • 如果Sync Manager列表中选择输入Sync Manager (inputs)，所有的TxPDOs都显示在下面。

选择的PDOs将确定过程数据的传输。 在System Manager的树形列表中，这些PDOs以EtherCAT从站变量的形式显示。 变量名和在PDO列表中的PDO的参数名 完全一样。 如果PDO分配列表中的条目被禁用，（未被选择并呈灰色），这表示输入被排除在PDO分配之外了。 为了能够选择这个灰色的PDO，首先就要先取消选择当前的PDO。

说明 		激活 PDO 配置
改变PDO配置后，为了使新的PDO配置生效，
  • EtherCAT从站需要通过 PS状态转换循环 (从 pre-operational 到 safe-operational) 一次 (见 Online tab),
  • 然后在System Manager中点击( [image] reload ) EtherCAT 从站按钮

PDO list

列出EtherCAT 设备所支持的所有PDO。 所选择PDO的内容会在 PDO Content 列表中显示出来。 可以通过双击来修改PDO配置。

列 | 描述
Index | PDO 索引
Size | PDO的 byte数
Name | PDO名称 如果这个PDO 分配到Sync Manager，从站的变量名即为此参数。
Flags | F | 固定内容: 这个PDO的内容被固定，且不能用System Manager修改。
 | M | 管理 PDO. 这个PDO是强制的必须分配到Sync Manager! 因此这个PDO不能从 PDO Assignment列表中删除
SM | 显示这个PDO 与哪个Sync Manager 关联。 如果是空的，那么就说明这个PDO不在过程数据中。
SU | 显示这个PDO与哪个Sync unit关联

PDO Content

显示PDO内容 如果这个PDO的 flag 不为F (固定内容) 那么就可以修改它的内容。

Download

对于智能从站且具备mailbox，PDO配置和PDO关联可以下载到从站中。 这是一个可选项不是所有的EtherCAT从站都支持。

PDO Assignment

如果选中此复选框，PDO Assignment列表中的PDO关联会在启动时下载到从站中。 需要的命令会被传输到从站中，并在 Startup中显示。

PDO Configuration

如果选中此复选框，相应的PDO配置(如图中PDO list和PDO Content)将会下载到EtherCAT从站中

Startup tab

Startup 显示 EtherCAT从站是否有mailbox ，是否支持CANopen over EtherCAT (CoE) 或 Servo drive over EtherCAT协议。 此表显示哪个下载请求在启动阶段被发送到mailbox 也可以列表中添加新的mailbox请求。 下载请求以他们在列表中的顺序依次发送到从站。

列 | 描述
Transition 请求发送到哪里。 这可以是
  • 从pre-operational 传输到 safe-operational (PS), 或
  • 从safe-operational 传输到 operational (SO).

如果传输用 "<>" 括起来(e.g. <PS>), 这mailbox请求是固定的，不能修改和删除。

Protocol | mailbox协议类型
Index | 对象的索引
Data | 下载对象的数据
Comment | 发送到mailbox请求的描述
Move Up | 把请求的位置向上移一位。
Move Down | 把请求的位置向下移一位。
New | 添加一个新的mailbox启动下载请求。
Delete | 删除一个选中的项
Edit | 编辑现有的请求

CoE - Online tab

如果EtherCAT从站支持 CANopen over EtherCAT (CoE) 那么CoE - Online 就会显示。 这个对话框列出了从站对象表中的内容(SDO upload)并且使用户能够从这个表中修改对象的内容。 可以在特定设备的对象描述中找到每个 EtherCAT 从站的对象详细信息。

对象列表显示
列 | 描述
Index | 对象的索引和子索引
Name | 对象的名称
Flags | RW | 对象可读可写(read/write)
 | RO | 对象只读(read only)
 | P | P表示此对象为过程数据对象。
Value | 对象的值
Update List | Update list按钮更新显示列表中的所有对象。
Auto Update | 如果这个复选框勾上，表格中的所有数据自动更新。
Advanced | Advanced按钮打开Advanced Settings 对话框。 选择在列表中显示的对象。

Online - via SDO Information | 如果这个单选框被选中，那么包括在从站对象列表中的对象列表将通过SDO信息的方式上载。 列表显示哪些对象类型可以上载。
Offline - via EDS File | 如果这个单选框被选中，在从站对象列表中的对象列表将从EDS文件中读取。

Online tab

状态机

Init | 这个按钮将EtherCAT 从站设为Init 状态。
Pre-Op | 这个按钮将EtherCAT 从站设为 pre-operational状态
Op | 这个按钮将EtherCAT 从站设为operational状态
Bootstrap | 这个按钮将EtherCAT 从站设为Bootstrap 状态
Safe-Op | 这个按钮将EtherCAT 从站设为 safe-operational 状态
Clear Error | 清空错误提示。 如果EtherCAT从站在状态转换中出错了，它就会设定一个出错标志位。 例子: 一个EtherCAT从站处于PREOP状态 (pre-operational)。 主站要求它进入SAFEOP 状态(safe-operational)。 如果从站在状态转换中出错，那么它就会设置错误标志。 当前状态就会显示为ERR PREOP。 当点过 Clear Error按钮后错误标志清楚, 然后状态变为 PREOP。
Current State | 显示EtherCAT从站的当前状态。
Requested State | EtherCAT 从站被要求的状态。

DLL 状态

显示每个 EtherCAT从站端口的DLL 状态 (data link layer 状态) 。 DLL有4种不同的状态:

状态 | 描述
No Carrier / Open | 端口无载波信号, 但是端口开放。
No Carrier / Closed | 端口无载波信号, 且端口是关闭的。
Carrier / Open | 端口有载波信号，且是端口开放。
Carrier / Closed | 端口有载波信号，但是端口关闭。

File Access over EtherCAT

Download | 文件写入EtherCAT从站。
Upload | 从EtherCAT从站读取文件。


EL3403 - Object description

BECKHOFF EL3403: Configuration

对象描述和参数

Note 		EtherCAT XML设备描述
本描述和EtherCAT XML设备上显示的CoE对象描述是一致的。强烈推荐从Beckhoff网站(http://www.beckhoff.com/english/default.htm?download/elconfg.htm) 上下载相应最新的XML文件版本并遵循安装说明书。

Note 		参数
CoE tab（双击相关的对象）或Process data tab （PDO设置）里可以进行端子的参数设置。

简介

本CoE概述包含了不同的准备应用的对象描述：

  • Objects required for parameterization 在调试过程中。
  • Objects intended for regular operation, 比如：通过ADS进入。
  • Objects for indicating internal settings (可能是准备好的)。
  • Profile specific objects, 显示输入和输出数据。

.如下部分受限描述了对象的正常运行，根据对象的完整概述。

调试所需对象

Index 1011 恢复默认参数。
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1011:0 | 恢复默认参数 | 在EtherCAT从站内恢复默认设置 。 | UINT8 | RO | 0x01 (1dec)
1011:01 | 副Index 001 | 如果对象设置成 "0x64616F6C" ("数值设置对话框")所有terminal-specific对象重新恢复成出厂设置。 | UINT32 | RW | 0x00000000 (0dec)
Index F800 PM 设置
Index | 命名 | 注释 |  |  | 数据类型 | 标志 | 默认值
F800:0 | PM 设置 |  | 数值 | 注释 | UINT8 | RO | 0x26 (38dec)
F800:01 | 低通滤波 | 低通滤波 | On | 有源滤波器 | BIT1 | RW | 0x01 (1dec)
F800:02 | 高通滤波 | 高通滤波 | On | 有源滤波器 | BIT1 | RW | 0x01 (1dec)
F800:03 | 测量模式 | 测量模式 | 0 | 3-线 三角形, 4-线 Wye | BIT2 | RW | 0x00 (0dec)
 |  |  | 1 | 保留
 |  |  | 2 | 保留
F800:05 | 频率通道 | 频率测量通道 | 0 | L1相 | BIT2 | RW | 0x00 (0dec)
 |  |  | 1 | L2相
 |  |  | 2 | L3相
F800:0E | 循环累积 | 功率/电功测量通道 | 0 | L1相 | BIT2 | RW | 0x00 (0dec)
 |  |  | 1 | L2相
 |  |  | 2 | L3相
F800:21 | 零交叉超时 | 零交叉超时 | 单位: 1 时期 |  | UNIT16 | RW | 0x0005 (5dec)
F800:22 | 线循环 | 循环时间测量 | 单位: 1 时期 |  | UNIT16 | RW | 0x00A (10dec)

常规操作中的对象

Index FB00 PM 命令

命令对象在端子模块中用来触发动作。 通过写subindex 1（要求）来开启命令指令。直到当前指令完成，才能够执行写操作。

Index | 命名 | 注释 |  | 数据类型 | 标志 | 默认值
FB00:0 | PM 命令 | 最大. subindex |  | UNIT8 | RO | 0x03 (3dec)
FB00:01 | 要求 | Byte 0 - 服务要求数据 |  | OCTA-SPRING [2] | RW | 0x0000 (0dec)
 |  | 4hex | Delete energy value
 |  | 14hex | Store energy value
 |  | Byte 1 - 通道部分
 |  | 00hex | 所有通道
 |  | 01hex | Ch. 1
 |  | 02hex | Ch. 2
 |  | 03hex | Ch. 3
FB00:02 | 状态 | Byte 0 |  | UNIT8 | RW | 0x00 (0dec)
 |  | 保留
FB00:03 | 响应 | Byte 0 |  | OCTA-SPRING[4] | RW | 0x00000000 (0dec)
 |  | 保留
 |  | Byte 1
 |  | 保留
 |  | Byte 2-n
 |  | 保留

完整的概述

对象标准 (0x1000-0x1FFF)

所有EtherCAT从站对象标准都有相同的注释。

Index 1000 Device type
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1000:0 | 设备类型 | EtherCAT从站的设备类型: Lo-Word 可以支持CoE Profile (5001). | UNIT32 | RO | 0x01541389 (22287241dec)
Index 1008 设备名字
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1008:0 | 设备名字 | EtherCAT 从站设备名称 | SPRING | RO | EL3403
Index 1009 硬件版本
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1009:0 | 硬件版本 | EtherCAT 从站硬件版本 | SPRING | RO | 01
Index 100A 软件版本
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
100A:0 | 软件版本 | EtherCAT从站固件版本 | SPRING | RO | 01
Index 1018 特性
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1018:0 | 认证 | 识别EtherCAT从站的信息 | UNIT8 | RO | 0x04 (4dec)
1018:01 | 供应商 ID | EtherCAT从站供应商的ID | UNIT32 | RO | 0x00000002 (2dec)
1018:02 | 产品条码 | EtherCAT从站的产品条码 | UNITT32 | RO | 0x0D4B3052 (223031378dec)
1018:03 | 修订码 | EtherCAT从站的修订码，低位字(0-15位)表示了具有特殊功能的端子数量：高位字(16-31位)标识了设备描述。 | UNIT32 | RO | 0x00100000 (1048576dec)
1018:04 | 序号 | EtherCAT从站的序列号，低位字中的低位字节(0-7位)包含了生产年份，低位字的高位字节(8-15位)包含了生产月份，高位字(16-31位)为0。 | UNIT32 | RO | e.g. 0x00001E06 (KW 30/2006)
Index 10F0 Backup 参数
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
10F0:0 | 备份参数处理 | 标准装载的信息和备份条目的保存 | UINT8 | RO | 0x01 (1dec)
10F0:01 | 检验 | 对所有备份条目进行检验 | UINT32 | RW | 0x00000000 (0dec)
Index 1600 RxPDO-Map Ch.1
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1600:0 | RxPDO-Map Ch.1 | PDO 映像RxPDO 1 | UINT8 | RO | 0x01 (1dec)
1600:01 | SubIndex 001 | 1. PDO 映像条目 (对象 0x7010 (PWM 输出 Ch.1),条目 0x11 (PWM 输出)) | UINT32 | RW | 0x7000:01, 8
Index 1601 RxPDO-Map Ch.2
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1601:0 | RxPDO-Map Ch.2 | PDO 映像 RxPDO 2 | UINT8 | RO | 0x01 (1dec)
1601:01 | 副Index 001 | 1. PDO 映像条目(对象 0x7010 (PWM 输出 Ch.2), 条目 0x11 (PWM 输出)) | UINT32 | RW | 0x7010:01, 8
Index 1602 RxPDO-Map Ch.3
Index | 命名 | 注释 | 数据类型 | Flags | 默认值
1602:0 | RxPDO-Map Ch.3 | PDO 映像 RxPDO 3 | UINT8 | RO | 0x01 (1dec)
1602:01 | 副Index 001 | 1. PDO 映像条目 (对象 0x7020 (PM 输出 Ch.3), 条目 0x01 (Index)) | UINT32 | RW | 0x7020:01, 8
Index 1A00 TxPDO-Map Ch.1
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1A00:0 | TxPDO-Map Ch.1 | PDO 映像 TxPDO 1 | UINT8 | RO | 0x0A (10dec)
1A00:01 | 副Index 001 | 1. PDO 映像条目 (定值) | UINT32 | RW | 0x0000:00, 13
1A00:02 | 副Index 002 | 2. PDO 映像条目 (对象0x1C32 (SM 输出参数), 条目 0x20 (同步错误 )) | UINT32 | RW | 0x1C32:20, 1
1A00:03 | 副Index 003 | 3. PDO 映像条目 (定值) | UINT32 | RW | 0x0000:00, 1
1A00:04 | 副Index 004 | 4. PDO映像条目 () | UINT32 | RW | 0x1800:09, 1
1A00:05 | 副Index005 | 5. PDO 映像条目 (对象0x6000 (PM 输入Ch.1), 条目 0x11 (电流)) | UINT32 | RW | 0x6000:11, 32
1A00:06 | 副Index 006 | 6. PDO 映像条目 对象 0x6000 (PM 输入Ch.1), 条目 0x12 (电压)) | UINT32 | RW | 0x6000:12, 32
1A00:07 | 副Index 007 | 7. PDO 映像条目 (对象 0x6000 (PM 输入Ch.1), 条目 0x13 (有功功率 )) | UINT32 | RW | 0x6000:13, 32
1A00:08 | 副Index 008 | 8. PDO 映像条目 (对象 0x6000 (PM 输入Ch.1), 条目 0x14 (Index)) | UINT32 | RW | 0x6000:14, 8
1A00:09 | 副Index 009 | 9. PDO 映像条目(定值) | UINT32 | RW | 0x0000:00, 8
1A00:0A | 副Index 010 | 10. PDO 映像条目 (对象 0x6000 (PM 输入Ch.1), 条目 0x1D (不定值)) | UINT32 | RW | 0x6000:1D, 32
Index 1A01 TxPDO-Map Ch.2
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1A01:0 | TxPDO-Map Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0A (10dec)
1A01:01 | 副Index 001 | 1. PDO 映像条目 (定值) | UINT32 | RW | 0x0000:00, 13
1A01:02 | 副Index 002 | 2. PDO 映像条目 (对象 0x1C32 (SM 输出参数), 条目 0x20 (同步错误 )) | UINT32 | RW | 0x1C32:20, 1
1A01:03 | 副Index 003 | 3. PDO 映像条目 (定值) | UINT32 | RW | 0x0000:00, 1
1A01:04 | 副Index 004 | 4. PDO 映像条目 () | UINT32 | RW | 0x1801:09, 1
1A01:05 | 副Index 005 | 5. PDO 映像条目 (对象 0x6010 (PM 输入Ch.2), 条目0x11 (电流)) | UINT32 | RW | 0x6010:11, 32
1A01:06 | 副Index 006 | 6. PDO 映像条目 (对象0x6010 (PM 输入Ch.2), 条目 0x12 (电压)) | UINT32 | RW | 0x6010:12, 32
1A01:07 | 副Index 007 | 7. PDO 映像条目 (对象0x6010 (PM 输入Ch.2), 条目 0x13 (有功功率 )) | UINT32 | RW | 0x6010:13, 32
1A01:08 | 副Index 008 | 8. PDO 映像条目 (对象 0x6010 (PM 输入Ch.2), 条目0x14 (Index)) | UINT32 | RW | 0x6010:14, 8
1A01:09 | 副Index 009 | 9. PDO 映像条目 (定值) | UINT32 | RW | 0x0000:00, 8
1A01:0A | 副Index 010 | 10. PDO 映像条目(对象0x6010 (PM 输入Ch.2), 条目 0x1D (不定值)) | UINT32 | RW | 0x6010:1D, 32
Index 1A02 TxPDO-Map Ch.3
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1A02:0 | TxPDO-Map Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0A (10dec)
1A02:01 | 副Index 001 | 1. PDO 映像条目 (定值) | UINT32 | RW | 0x0000:00, 13
1A02:02 | 副Index 002 | 2. PDO 映像条目 (对象 0x1C32 (SM 输出参数), 条目 0x20 (同步错误)) | UINT32 | RW | 0x1C32:20, 1
1A02:03 | 副Index 003 | 3. PDO 映像条目 定值) | UINT32 | RW | 0x0000:00, 1
1A02:04 | 副Index 004 | 4. PDO映像条目 () | UINT32 | RW | 0x1802:09, 1
1A02:05 | 副Index 005 | 5. PDO 映像条目(对象0x6020 (PM 输入Ch.3), 条目 0x11 (电流)) | UINT32 | RW | 0x6020:11, 32
1A02:06 | 副Index 006 | 6. PDO 映像条目 (对象 0x6020 (PM 输入Ch.3), 条目 0x12 (电压)) | UINT32 | RW | 0x6020:12, 32
1A02:07 | 副Index 007 | 7. PDO 映像条目 (对象 0x6020 (PM 输入Ch.3), 条目0x13 (有功功率)) | UINT32 | RW | 0x6020:13, 32
1A02:08 | 副Index 008 | 8. PDO 映像条目 (对象0x6020 (PM 输入Ch.3), 条目 0x14 (Index)) | UINT32 | RW | 0x6020:14, 8
1A02:09 | 副Index 009 | 9. PDO 映像条目 (定值) | UINT32 | RW | 0x0000:00, 8
1A02:0A | 副Index 010 | 10. PDO 映像条目 (对象 0x6020 (PM 输入 Ch.3), 条目 0x1D (不定值)) | UINT32 | RW | 0x6020:1D, 32
Index 1A03 TxPDO-Map Status
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1A03:0 | TxPDO-Map Status | PDO Mapping TxPDO 4 | UINT8 | RO | 0x09 (9dec)
1A03:01 | 副Index001 | 1. PDO 映像条目 （定值) | UINT32 | RW | 0x0000:00, 3
1A03:02 | 副Index 002 | 2. PDO 映像条目 () | UINT32 | RW | 0xF130:04, 1
1A03:03 | 副Index 003 | 3. PDO 映像条目 () | UINT32 | RW | 0xF130:05, 1
1A03:04 | 副Index 004 | 4. PDO 映像条目 () | UINT32 | RW | 0xF130:06, 1
1A03:05 | 副Index 005 | 5. PDO 映像条目 (定值) | UINT32 | RW | 0x0000:00, 2
1A03:06 | 副Index 006 | 6. PDO 映像条目y () | UINT32 | RW | 0xF130:09, 1
1A03:07 | 副Index 007 | 7. PDO M映像条目 (定值) | UINT32 | RW | 0x0000:00, 4
1A03:08 | 副Index 008 | 8. PDO 映像条目 (对象 0x1C32 (SM 输出参数), 条目0x20 (同步错误)) | UINT32 | RW | 0x1C32:20, 1
1A03:09 | 副Index 009 | 9. PDO 映像条目 (定值) | UINT32 | RW | 0x0000:00, 2
Index 1C00 Sync manager type
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1C00:0 | 同步管理类型 | 同步管理程序的应用 | UINT8 | RO | 0x04 (4dec)
1C00:01 | 副Indexx 001 | 同步管理程序类型通道1: 写邮箱 | UINT8 | RW | 0x01 (1dec)
1C00:02 | 副Index 002 | 同步管理程序类型通道 2: 度邮箱 | UINT8 | RW | 0x02 (2dec)
1C00:03 | 副Index 003 | 同步管理程序类型通道 3: 写过程数据 (输出) | UINT8 | RW | 0x03 (3dec)
1C00:04 | 副Index 004 | 同步管理程序类型通道 4: 读过程数据(输入) | UINT8 | RW | 0x04 (4dec)
Index 1C12 RxPDO 配置
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1C12:0 | RxPDO 配置 | PDO 配置输出 | UINT8 | RO | 0x03 (3dec)
1C12:01 | 副Index 001 | 1. 配置 RxPDO (RxPDO-映像 Ch.1 (RxPDO 1)) | UINT16 | RO | 0x1600 (5632dec)
1C12:02 | 副Index 002 | 2. 配置 RxPDO (RxPDO-映像 Ch.2 (RxPDO 2)) | UINT16 | RO | 0x1601 (5633dec)
1C12:03 | 副Index 003 | 3. 配置 RxPDO (RxPDO-映像 Ch.3 (RxPDO 3)) | UINT16 | RW | 0x1602 (5634dec)
Index 1C13 TxPDO 配置
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1C13:0 | TxPDO 配置 | PDO 配置输入 | UINT8 | RO | 0x04 (4dec)
1C13:01 | 副Index 001 | 1. 配置 PDO (TxPDO-映像 Ch.1 (TxPDO 1)) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | 副Index 002 | 2. 配置 PDO (TxPDO-映像 Ch.2 (TxPDO 2)) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | 副Index 003 | 3. 配置 PDO (TxPDO-映像 Ch.3 (TxPDO 3)) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | 副Index 004 | 4. 配置 PDO (TxPDO-映像 状态 (TxPDO 4)) | UINT16 | RW | 0x1A03 (6659dec)
Index 1C32 SM 输出参数
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1C32:0 | SM 输出参数 | 输出同步参数 | UINT8 | RO | 0x07 (7dec)
1C32:01 同步模式(Sync mode) 实际中同步模式:
  • 0: 自由运行模式
  • 1: 包含 SM 2种事件同步模式
  • 2: DC-模式 - 包含SYNC0 事件同步模式
  • 3: DC-模式 - with包含SYNC1 事件同步模式
 UINT16 RW 0x0001 (1dec)
1C32:02 周期时间 周期时间 (in ns):
  • 自由运行模式 : 本地时钟周期时间
  • 包含 SM 2种事件同步模式 : 主机周期时间
  • DC-模式: SYNC0/SYNC1周期时间
 UINT32 RW 0x000AAE60 (700000dec)
1C32:03 | 漂移时间 | SYNC0种事件到锁存输出所用时间 (单位 ns, 仅在 DC-模式下) | UINT32 | RW | 0x00000000 (0dec)
1C32:04 可用同步模式 可用同步模式:
  • Bit 0 = 1: 支持自由运行模式
  • Bit 1 = 1: 支持带有SM2种事件的同步模式
  • Bit 2-3 = 01: 支持DC模式
  • Bit 4-5 = 10:带SYNC1事件的输出漂移 (仅在 DC模式)
  • Bit 14 = 1: 动态时间(通过写入1C33:08后可测量)
UINT16 RW 0x8007 (32775dec)
1C32:05 | 最小周期时间 | 最小周期时间(单位:ns) | UINT32 | RW | 0x000AAE60 (700000dec)
1C32:06 | 运算和下载时间 | SYNC0 和 SYNC1事件间最小周期时间(单位 ns, 仅在 DC-模式) | UINT32 | RW | 0x00000000 (0dec)
1C32:08 命令
  • 0: 中止本地周期时间的测量
  • 1: 开始本地周期时间的测量

1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 会被更新为测量出的最大值。

UINT16 RW 0x0000 (0dec)
1C32:09 | 延迟时间 | SYNC1种事件到锁存输出所用时间(单位:ns, 仅在DC模式下) | UINT32 | RW | 0x00000000 (0dec)
1C32:0B | SM 丢失事件计数器 | 运行状态下丢失的SM事件的数量(仅发生在DC模式) | UINT16 | RW | 0x0000 (0dec)
1C32:0C | 周期故障计算器 | 运行状态下发生故障的周期数量Number of the exceeded cycles in state OPERATIONAL | UINT16 | RW | 0x0000 (0dec)
1C32:0D | 超短转移计数器 | SYNC0事件和SYNC1事件间的超短距离计数器(仅在DC模式下 | UINT16 | RW | 0x0000 (0dec)
1C32:20 | 同步错误 | 正确:上一周期期发生同步错误 （仅在 DC 下) | BOOLEAN | RW | 0x00 (0dec)
Index 1C33 SM 输入参数
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
1C33:0 | SM输入参数 | 输入同步参量 | UINT8 | RO | 0x07 (7dec)
1C33:01 同步模式 实际中的同步模式:
  • 0: 自由运行模式
  • 1: 包含SM 3中事件同步模式 (无输出可用 )
  • 2: DC - 包含SYNC0事件同步模式
  • 3: DC - 包含SYNC1 事件同步模式
  • 34: 包含 SM 2种事件同步模式 (输出可用 )
 UINT16 RW 0x0022 (34dec)
1C33:02 | 周期时间 | 与1C32:02一样 | UINT32 | RW | 0x000AAE60 (700000dec)
1C33:03 | 漂移时间 | SYNC0种事件到锁存输入所用时间(单位 ns, 仅在DC-模式下) | UINT32 | RW | 0x00000000 (0dec)
1C33:04 可用同步模式 可用同步模式:
  • Bit 0: 支持自由运行模式
  • Bit 1: 支持带有SM2种事件的同步模式(输出可用)
  • Bit 1: 支持带有SM3种事件的同步模式(无可用输出)
  • Bit 2-3 = 01: 支持DC模式
  • Bit 4-5 = 01: 带本地事件的输入漂移 (输出可用)
  • Bit 4-5 = 10: 带SYNC1事件的输入漂移(无可用输出)
  • Bit 14 = 1: 动态时间 (通过写入 1C32:08 或 1C33:08可测量)
 UINT16 RW 0x8007 (32775dec)
1C33:05 | 最小周期时间 | 与1C32:05一样 | UINT32 | RW | 0x000AAE60 (700000dec)
1C33:06 | 运算和下载时间 | 输入锁存到输入对主机可用过程所用时间(单位:ns,仅在DC模式下) | UINT32 | RW | 0x00000000 (0dec)
1C33:08 | 命令 | 与1C32:08一样 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | 延迟时间 | SYNC0种事件到锁存输入所用时间(单位 ns, 仅在DC-模式下) | UINT32 | RW | 0x00000000 (0dec)
1C33:0B | SM 丢失事件计算器 | 与1C32:0B一样 | UINT16 | RW | 0x0000 (0dec)
1C33:0C | 周期溢出 | 与 1C32:0C一样 | UINT16 | RW | 0x0000 (0dec)
1C33:0D | 最短转移计算器 | 与1C32:0D一样 | UINT16 | RW | 0x0000 (0dec)
1C33:20 | 同步错误 | 与 1C32:20一样 | BOOLEAN | RW | 0x00 (0dec)

Profile特定对象(0x6000-0xFFFF)

对于所用支持文件5001的EtherCAT从站，面向文件对象意义相同。

Index 6000 PM 输入 Ch.1
Index | 命名 | 注释 |  |  |  | 数据类型 | 标志 | 默认值
6000:0 | PM 输入 Ch.1 | 最大. 副Index |  |  |  | UINT8 | RO | 0x1D (29dec)
6000:0E | 同步错误 | 保留 |  |  |  | BOOLEAN | RW | 0x00 (0dec)
6000:10 | TxPDO 开关 | 任何零交叉开关 (Ch. 1) |  |  |  | BOOLEAN | RW | 0x00 (0dec)
6000:11 | 电流 | 电流 Ch. 1 | Unit: 0,000001 A |  |  | INT32 | RW | 0x00000000 (0dec)
6000:12 | 电压 | 电压 Ch. 1 | Unit: 0,0001 V |  |  | INT32 | RW | 0x00000000 (0dec)
6000:13 | 有功功率 | 有功功率 Ch. 1 | Unit: 0,01 W |  |  | INT32 | RW | 0x00000000 (0dec)
6000:14 | Index | 响应变量值 Ch. 1 | Index (dec) | 注释 | 单元 | UINT8 | RW | 0x00 (0dec)
 |  |  | 0 | 视在功率 | 0,01 VA
 |  |  | 1 | 无功功率 | 0,01 VAR
 |  |  | 2 | 电功 | 0,001 Wh
 |  |  | 3 | cosPhi | 0,001
 |  |  | 4 | 频率 | 0,1 Hz
 |  |  | 5 | 电功 (负) | 0,001 Wh
 |  |  | 6-99 | 保留 | -
 |  |  | 100 | 分布式时钟时间戳 | 1 ns
 |  |  | 101-255 | 保留 | -
6000:1D | 变量值 | 不同数值 Ch. 1 (参看Index 6000:14) |  |  |  | INT32 | RW | 0x00000000 (0dec)
Index 6010 PM 输入 Ch.2
Index | 命名 | 注释 |  |  |  | 数据类型 | 标志 | 默认值
6010:0 | PM 输入 Ch.2 | 最大. subindex |  |  |  | UINT8 | RO | 0x1D (29dec)
6010:0E | 同步错误 | 保留 |  |  |  | BOOLEAN | RW | 0x00 (0dec)
6010:10 | TxPDO Toggle | Toggled with any zero crossing (Ch. 2) |  |  |  | BOOLEAN | RW | 0x00 (0dec)
6010:11 | 电流 | 电流 Ch. 2 | Unit: 0,000001 A |  |  | INT32 | RW | 0x00000000 (0dec)
6010:12 | 电压 | 电压 Ch. 2 | Unit: 0,0001 V |  |  | INT32 | RW | 0x00000000 (0dec)
6010:13 | 有功功率 | 有功功率 Ch. 2 | Unit: 0,01 W |  |  | INT32 | RW | 0x00000000 (0dec)
6010:14 | Index | 响应变量值 Ch. 2 | Index (dec) | 注释 | Unit | UINT8 | RW | 0x00 (0dec)
 |  |  | 0 | 视在功率 | 0,01 VA
 |  |  | 1 | 无功功率 | 0,01 VAR
 |  |  | 2 | 电功 | 0,001 Wh
 |  |  | 3 | cosPhi | 0,001
 |  |  | 4 | 频率 | 0,1 Hz
 |  |  | 5 | 电功 | 0,001 Wh
 |  |  | 6-99 | 保留 | -
 |  |  | 100 | 分布式时钟时间戳 | 1 ns
 |  |  | 101-255 | 保留 | -
6010:1D | 变量值 | 不同数值 Ch. 1 (参看Index 6010:14) |  |  |  | INT32 | RW | 0x00000000 (0dec)
Index 6020 PM 输入 Ch.3
Index | 命名 | 注释 |  |  |  | 数据类型 | 标志 | 默认值
6020:0 | PM 输入 Ch.3 | 最大. 副Index |  |  |  | UINT8 | RO | 0x1D (29dec)
6020:0E | 同步错误 | 保留 |  |  |  | BOOLEAN | RW | 0x00 (0dec)
6020:10 | TxPDO Toggle | Toggled with any zero crossing (Ch. 3) |  |  |  | BOOLEAN | RW | 0x00 (0dec)
6020:11 | 电流 | 电流 Ch. 3 | Unit: 0,000001 A |  |  | INT32 | RW | 0x00000000 (0dec)
6020:12 | 电压 | 电压 Ch. 3 | Unit: 0,0001 V |  |  | INT32 | RW | 0x00000000 (0dec)
6020:13 | 有功功率 | 有功功率 Ch. 3 | Unit: 0,01 W |  |  | INT32 | RW | 0x00000000 (0dec)
6020:14 | Index | 可以得到不同数值 Ch. 3 | Index(dec) | 注释 | 单元 | UINT8 | RW | 0x00 (0dec)
 |  |  | 0 | 视在功率 | 0,01 VA
 |  |  | 1 | 无功功率 | 0,01 VAR
 |  |  | 2 | 电功 | 0,001 Wh
 |  |  | 3 | cosPhi | 0,001
 |  |  | 4 | 频率 | 0,1 Hz
 |  |  | 5 | 电功 | 0,001 Wh
 |  |  | 6-99 | 保留 | -
 |  |  | 100 | 分布式时钟时间戳 | 1 ns
 |  |  | 101-255 | 保留 | -
6020:1D | 变量值 | 不同数值 Ch. 1 (参看Index 6020:14) |  |  |  | INT32 | RW | 0x00000000 (0dec)
Index 7000 PM 输出 Ch.1
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
7000:0 | PM 输出 Ch.1 | 最大.副Index | UINT8 | RO | 0x01 (1dec)
7000:01 | Index | 不同数值的要求Ch. 1 (参看Index 6000:14) | UINT8 | RW | 0x00 (0dec)
Index 7010 PM 输出 Ch.2
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
7010:0 | PM 输出 Ch.2 | 最大. 副Index | UINT8 | RO | 0x01 (1dec)
7010:01 | Index | 不同数值的要求 Ch. 2 (参看Index 6010:14) | UINT8 | RW | 0x00 (0dec)
Index 7020 PM 输出 Ch.3
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
7020:0 | PM 输出 Ch.3 | 最大.副Index | UINT8 | RO | 0x01 (1dec)
7020:01 | Index | 不同数值的要求 Ch. 3 (参看Index 6020:14) | UINT8 | RW | 0x00 (0dec)
Index 800F PM Vendor 数据 Ch.1
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
800F:0 | PM Vendor 数据 Ch.1 | 最大.副Index | UINT8 | RO | 0x09 (9dec)
800F:01 | 电流补偿标准 | 供应商 标准: 电流补偿Ch. 1 | INT16 | RW | 0x0000 (0dec)
800F:02 | 电流增益标准 | 供应商 标准: 电流增益 Ch. 1 | UINT16 | RW | 0x0000 (0dec)
800F:03 | 电压补偿标准 | 供应商 标准: 电压补偿 Ch. 1 | INT16 | RW | 0x0000 (0dec)
800F:04 | 电压增益标准 | 供应商 标准:电压增益 Ch. 1 | UINT16 | RW | 0x0000 (0dec)
800F:05 | W 功率补偿标准 | 供应商标准: 有功功率补偿 Ch. 1 | INT16 | RW | 0x0000 (0dec)
800F:06 | VAR 功率补偿标准 | 供应商标准: 无功功率补偿 Ch. 1 | INT16 | RW | 0x0000 (0dec)
800F:07 | W 功率增益标准 | 供应商标准: 有功功率增益 Ch. 1 | UINT16 | RW | 0xF800 (63488dez)
800F:08 | VA 功率增益标准 | 供应商标准: 实在功率增益 Ch. 1 | UINT16 | RW | 0xF800 (63488dez)
800F:09 | VAR 功率增益标准 | 供应商标准: 闲置电工增益 Ch. 1 | UINT16 | RW | 0xF800 (63488dez)
Index 801F PM Vendor 数据 Ch.2
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
801F:0 | PM Vendor数据Ch.2 | 最大. 副Index | UINT8 | RO | 0x09 (9dec)
801F:01 | 电流补偿标准 | 供应商标准: 电流补偿Ch. 2 | INT16 | RW | 0x0000 (0dec)
801F:02 | 电流增益标准 | 供应商标准: 电流增益 Ch. 2 | UINT16 | RW | 0x0000 (0dec)
801F:03 | 电压补偿标准 | 供应商标准: 电压补偿 Ch. 2 | INT16 | RW | 0x0000 (0dec)
801F:04 | 电压增益标准 | 供应商标准: 电压增益 Ch. 2 | UINT16 | RW | 0x0000 (0dec)
801F:05 | W 功率补偿标准 | 供应商标准: 有功功率补偿 Ch. 2 | INT16 | RW | 0x0000 (0dec)
801F:06 | VAR 功率补偿标准 | 供应商标准: 无功功率补偿 Ch. 2 | INT16 | RW | 0x0000 (0dec)
801F:07 | W 功率增益标准 | 供应商标准: 有功功率增益 Ch. 2 | UINT16 | RW | 0xF800 (63488dez)
801F:08 | VA 功率增益标准 | 供应商标准: 视在功率增益 Ch. 2 | UINT16 | RW | 0xF800 (63488dez)
801F:09 | VAR 功率增益标准 | 供应商标准: 无功功率增益r Ch. 2 | UINT16 | RW | 0xF800 (63488dez)
Index 802F PM Vendor 数据 Ch.3
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
802F:0 | PM Vendor数据 Ch.3 | 最大. 副Index | UINT8 | RO | 0x09 (9dec)
802F:01 | 电流补偿标准 | 供应商标准: 电流补偿 Ch. 3 | INT16 | RW | 0x0000 (0dec)
802F:02 | 电流增益标准 | 供应商标准: 电流增益 Ch. 3 | UINT16 | RW | 0x0000 (0dec)
802F:03 | 电压补偿标准 | 供应商标准: 电压补偿 Ch. 3 | INT16 | RW | 0x0000 (0dec)
802F:04 | 电压增益标准 | 供应商标准: 电压增益 Ch. 3 | UINT16 | RW | 0x0000 (0dec)
802F:05 | W 功率补偿标准 | 供应商标准: 有功功率补偿 Ch. 3 | INT16 | RW | 0x0000 (0dec)
802F:06 | VAR 功率补偿标准 | 供应商标准: 无功功率补偿Ch. 3 | INT16 | RW | 0x0000 (0dec)
802F:07 | W 功率增益标准 | 供应商标准: 有功功率增益 Ch. 3 | UINT16 | RW | 0xF800 (63488dez)
802F:08 | VA 功率增益标准 | 供应商标准: 视在功率增益 Ch. 3 | UINT16 | RW | 0xF800 (63488dez)
802F:09 | VAR 功率增益标准 | 供应商标准: 无功功率增益 Ch. 3 | UINT16 | RW | 0xF800 (63488dez)
Index F000 模块化设备简介
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
F000:0 | 模块化设备简介 | 模块化设备文件概述 | UINT8 | RO | 0x02 (2dec)
F000:01 | 模块Index距离 | 不同通道的对象间的Index距离 | UINT16 | RW | 0x0010 (16dec)
F000:02 | 模块最大数量 | 通道数量 | UINT16 | RW | 0x0003 (3dec)
Index F008 字码
Index | 命名 | 注释 | 数据类型 | 标志 | 默认值
F008:0 | 字码 | 保留 | UINT32 | RW | 0x00000000 (0dec)

Note 		字码
制造商保留有端子模块基本校验权利。. 因此目前都保留了制造商的字码。
Index F100 PM 状态数据
Index | 命名 | 注释 |  | 数据类型 | 标志 | Default
F100:0 | PM 状态数据 | 最大. 副Index |  | UINT8 | RO | 0x0E (14dec)
F100:04 | 丢失的零交叉 A | 0bin | 零交叉可识别 | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | 无零交叉可识别 (超时后: 参看Index F800:21)
F100:05 | 丢失的零交叉 B | 参看Index F100:04 |  | BOOLEAN | RW | 0x00 (0dec)
F100:06 | 丢失的零交叉 C | 参看Index F100:04 |  | BOOLEAN | RW | 0x00 (0dec)
F100:09 | 相序错误 | 0bin | 更正相位旋转 L1 - L3 - L2 (在3-相 ccw 旋转网络中) | BOOLEAN | RW | 0x00 (0dec)
 |  | 1bin | 更正相位旋转 L1 - L2 - L3 (在3-相 cw 旋转网络中) 并且有一相导体没有连接。
F100:0E | 同步错误 | 保留 |  | BOOLEAN | RW | 0x00 (0dec)
Index F801 PM 参数数据
Index | 命名 | 注释 |  | 数据类型 | 标志 | Default
F801:0 | PM 不变数据 | 最大. 副Index |  | UINT8 | RO | 0x03 (3dec)
F801:01 | 电功相 A | 存储的电功值 Ch. 1 (1) | Unit: 0,001 Wh | UINT32 | RW | 0x00000000 (0dec)
F801:02 | 电功相 B | 存储的电功值 Ch. 2 (1) | Unit: 0,001 Wh | UINT32 | RW | 0x00000000 (0dec)
F801:03 | 电功相 C | 存储的电功值 Ch. 3 (1) | Unit: 0,001 Wh | UINT32 | RW | 0x00000000 (0dec)
F801:04 | 电功相 A | 存储的负功值Ch. 1 (1) | Unit: 0,001 Wh | UINT32 | RW | 0x00000000 (0dec)
F801:05 | 电功相 B | 存储的负功值 of Ch. 2 (1) | Unit: 0,001 Wh | UINT32 | RW | 0x00000000 (0dec)
F801:06 | 电功相 C | 存储的负功值 of Ch. 3 (1) | Unit: 0,001 Wh | UINT32 | RW | 0x00000000 (0dec)

(1) 通过控制对象(参看Index FB00)可以手动保存电功值。负功率（再生操作）会产生负功值。电 能值 (subindex 01 - 03) 是由再生能量和消耗能量两部分组成的。再生运作时这个值减少。计算正能量时，必须汇总这两部分。

Index F80F PM Vendor line数据
Index | 命名 | 注释 | 数据类型 | 标志 | Default
F80F:0 | PM 供应商数据 | 最大. 副Index | UINT8 | RO | 0x14 (29dec)
F80F:11 | PGA 控制 | 使用者不能修改内部转换因素。 | UINT8 | RW | 0x20 (32dec)
F80F:13 | 电工因素 |  | UINT16 | RW | 0x02D0 (720dec)
F80F:14 | 线循环因素 |  | UINT16 | RW | 0x0032 (50dec)


EL3403 - Process data

BECKHOFF EL3403: 进入使用者程序

过程数据

• 同步管理器
• 运行模式和设置
• 分布式时钟时间戳

同步管理器 (SM)

通过“数据进程”表可以查看数字进程使用情况。(参看 图. 1+2).

图. 1 数据进程表 SM2, EL13403

图. 2 数据进程表 SM3, EL3403

PDO 的分配

SM2, PDO 分配 0x1C12
Index | 不包括PDOs Index | 大小 (字节，字) | 名称 | PDO 内容
0x1600 (默认值) | - | 1.0 | PM 输出通道 1 | Index 0x7000:01 - Index
0x1601(默认值) | - | 1.0 | PM 输出通道 2 | Index 0x7010:01 - Index
0x1602 (默认值） | - | 1.0 | PM 输出通道 2 | Index 0x7020:01 - Index
SM3, PDO 分配 0x1C13
Index | 不包括PDOs Index | 大小 （字节，字) | 名称 | PDO 内容
0x1A00 (t默认值) | - | 20.0 | PM 输入通道 1 | Index 0x1C32:20 - 同步错误 Index 0x1800:09 - TxPDO 开关 Index 0x6000:11 - 电流 Index 0x6000:12 - 电压 Index 0x6000:13 - 有功功率 Index 0x6000:14 - Index Index 0x6000:1D - 变化值
0x1A01(默认值) | - | 20.0 | PM 输入通道 2 | Index 0x1C32:20 - 同步错误 Index 0x1801:09 - TxPDO 开关 Index 0x6010:11 - 电流 Index 0x6010:12 - 电压 Index 0x6010:13 - 有功功率 Index 0x6010:14 - Index Index 0x6010:1D - 变化值
0x1A02 (默认值) | - | 20.0 | PM 输入通道 3 | Index 0x1C32:20 - 同步错误 Index 0x1802:09 - TxPDO 开关 Index 0x6020:11 - 电流 Index 0x6020:12 - 电压 Index 0x6020:13 - 有功功率 Index 0x6020:14 - Index Index 0x6020:1D - 变化值
0x1A02 (默认值) | - | 2.0 | TxPDO-地图状态 | Index 0xF100:04 - 缺少零交叉 A Index 0xF100:05 - 缺少零交叉 B Index 0xF100:06 - 缺少零交叉 C Index 0xF100:09 - 相序错误 Index 0x1C32:20 - 同步错误

Table 1: 同步管理 PDO 的分配

运行模式和设置

确认通道 1 - 3上可变的输出值 (Index 6000:14, 6010:14, 6020:14)

可以从Index 6000:1D (通道 1)输出计算值，或 6020:1D (通道 3) (参看对象描述).
为此，进入“数值设置”Index窗口 7000:01, 7010:01 和 7020:01 ("CoE Online" 表)中参考相关联的输出值 (参看 6000:14, 6010:14, 6020:14)。

数值 (dec), 进入Index 7000:01, 7010:01, 7020:01 | 名称 | 单位
0 | 视在功率 | 0.01 VA
1 | 无功功率 | 0.01 VAR
2 | 电功 | 0.001 Wh
3 | cosPhi | 0.001
4 | 频率 | 0.01 Hz
5 | 电功 (负) | 0.001 Wh
6-99 | 保留 | -
100 | 分布式时钟时间戳 | 1 ns
101-255 | 保留 | -

标准输出值是视在功率。

频率测量和功率/电功测量参考通道 (Index F800:05 和 Index F800:0E)

EL3403中三个通道必须参考频率和功率/电工测量选择通道。这一项被用来作为所有功率/电功相的暂时参考。参考项的频率测量值被复制到其它两个相中。比如：只能测量被选择的相能够。

默认t: L1相

零交点暂停(Index F800:21)

连同通道 1 - 3 (Index F100:04, F100:05, F100:06) 的零交叉检测，可以在此设定延迟 (单元： 1 周期) ,直到在相关Index(F100:04, F100:05, F100:06)中 缺少的零交叉显示为逻辑“1”。

默认: 5个周期

周期测量 (Index F800:22)

输入通道的测量频率设置。输出值越一致数值就越高。

默认值: 周期10

持久性数据 (Index F801:01, F801:02, F801:03)

1-3通道的电能值可以保存（比如：在系统关闭前，可以尽可能地精确地存储电能值），如果有必要，可以通过清零来重置的电能值。 可以通过command-object（IndexFB00:01 ) 来触发该操作。
举例 1
如果要手动保存通道2的电能值，需要在Index FB00:01.中进入 0214hex 。
举例 2
在Index FB00:01进入0004hex . 手动删除所有通道的电能值。

分布式时钟时间戳

如果按照相应的Index6000:14, 6010:14或6020:14设置，端子模块传输ADC的过程数据作为目标6000:1D (通道 1), 6010:1D (通道 2) 或6020:1D (通道 3)的时间戳。


EL3403 - Skalierungsfaktoren

BECKHOFF EL3403: Configuration

比例系数

.在下列的概述中你可以找到相应的比例系数从原始值计算出实际值。

EL3403-0000比例系数

数值 | 计算
电流 | 原值x 0.000001 A x 电流互感系数
电压 | 原值 x 0.0001 V x 变压系数
有功功率 | 原值 x 0.01 W x 电流互感系数
视在功率 | 原值 x 0.01 VA x 电流互感系数
无功功率 | 原值 x 0.01 VAr x 电流互感系数
电源 | 原值 x 0.001 Wh x 电流互感系数
cosPhi | 原值 x 0.001
频率 | 原值 x 0.1 Hz

EL3403-0010比例系数

数值 | 计算
电流 | 原值 x 0.000005 A x 电流互感系数
电压 | 原值 x 0.0001 V x 变压系数
有功功率 | 原值 x 0.01 W x 电流互感系数
视在功率 | 原值 x 0.01 VA x 电流互感系数
无功功率 | 原值 x 0.01 VAr x 电流互感系数
电源 | 原值 x 0.001 Wh x 电流互感系数
cosPhi | 原值 x 0.001
频率 | 原值 x 0.1 Hz

标记. 1a + 1b: 通过比例系数从原始过程数据计算出实际有效值。


UL 需求

BECKHOFF EKxxxx, ELxxxx: 附录

UL 说明

应用
Beckhoff EtherCAT 模块仅适用于Beckhoff UL 列表中的EtherCAT系统。
测试
更据cULus 测试, Beckhoff I/O 系统仅进行了防火和电击测试 has only been investigated for risk of fire and electrical shock (更据 UL508 和 CSA C22.2 No. 142).
对于以太网接口设备
不适用于连接通信线路

基本原理

倍福EtherCAT产品的两个UL认证，因产品而异：

  • 符合UL508标准的UL认证
    拥有该认证的设备会有这样的标记：

  • 符合限制电源消耗UL508标准的UL认证
    设备消耗的最大电流限制为4A。拥有该认证的设备会有这样的标记。

几乎所有的EtherCAT产品（截止到2010/5）都是非限制的UL认证。

应用

如果端子模块通过 限制认证 , 那么24 V DC 电流消耗必须受到电源限制。

  • 由一个拥有最大电流为4A的保险丝保护的独立电源供电（根据UL248）或者
  • 由一个符合 NEC class 2的电源供电。
    符合 NEC class 2 的电源不能与另一个 NEC class 2 电源串联或并联使用!

这些要求适用于所有的EtherCAT总线耦合器电源，电源适配器端子模块，总线端子模块以及它们的电源触点。


Firmware Kompatibilität

BECKHOFF EL3403: Appendix

固件兼容性

Beckhoff EtherCAT设备在交付时装备了最新的固件。固件和硬件之间存在一定的依赖性，不是所有的组合都能兼容。
下面是固件与硬件兼容的概述

注意

  • 强烈建议在特殊的硬件上使用最新有效的固件。
  • 倍福公司先前交付的免费产品没有固件升级的客户权限。

注意 		设备可能的危险!
请在special page注意关于固件升级的细节。
如果在引导程序模式运行设备来给固件升级，可能未校验固件的兼容性。
这可能有设备损坏的危险!
请确保固件适合的硬件设备状态！
EL3403-0000
硬件 (HW) | 固件(FW) | 文件名，发布日期
01 - 03 | 02 | EL3403_02.efw, 2008/07/09
 | 03 | EL3403_03.efw, 2008/09/30
 | 04 | EL3403_04.efw, 2009/01/09
 | 05 | EL3403_05.efw, 2009/07/16
04 - 05 | 06 | EL3403_06.efw, 2010/10/20
 | 07 | EL3403_07.efw, 2010/11/19
 | 08 | EL3403_08.efw, 2010/12/10
06* | 09 | EL3403_09.efw, 2011/05/13
 | 10* | EL3403_10.efw, 2011/06/09
EL3403-0010
硬件 (HW) | 固件 (FW) | 文件名，发布日期
01 - 02 | 03 | EL3403_03.efw, 200812/10/
 | 04 | EL3403_04.efw, 2009/01/09
 | 05 | EL3403_05.efw, 2009/07/16
03 - 05 | 06 | EL3403_06.efw, 2010/10/20
 | 07 | EL3403_07.efw, 2010/11/19
 | 08 | EL3403_08.efw, 2010/12/10
06* | 09 | EL3403_09.efw, 2011/05/13
 | 10* | EL3403_10.efw, 2011/06/09

*) 在创建这个文件时兼容硬件的状态。请查阅 Beckhoff的最近文件的页面。


ELxxxx - 固件

BECKHOFF ELxxxx: 设备升级

固件 EL/ES/EMxxxx

这部分描述了Beckhoff EtherCAT从站 EL/ES, EM, EK和EP系列的版本升级。. 固件的升级只能在咨询Beckhoff技术支持之后才能执行。

目录
• 存储位置
• ESI版本定义
• 设备描述升级 ESI/*.xml
• 固件版本描述
• 固件升级文件 *.efw
• 固件升级文件 *.rbf
• 批量更新

存储位置

EtherCAT从站在3个地方存储运行数据：

  • 更据功能和性能EtherCAT从站有一个或几个本地控制器用于传输I/O数据。 所对应的程序称为 固件 为 *.efw 格式。
  • 某些EtherCAT从站的EtherCAT通讯功能也集成在控制器中。 这种情况的控制器叫做 FPGA 芯片使用 *.rbf 格式的固件。
  • 另外每个EtherCAT从站有存储芯片保持设备参数叫做 EEPROM. 通电后自动加载参数，EtherCAT通信也相应设定。 设备描述可以从 http://www.beckhoff.com 下载区下载。 所有 ESI 文件(EtherCAT Slave Information) 压缩成ZIP格式。

客户可以通过 EtherCAT 现场总线和其通信机制访问数据。 ESC读写来实现异步mailbox通讯或访问寄存器。

TwinCAT System Manager提供配置所有这3部分数据的方法，如果从站支持这些数据。 通常从站不会检查新数据是否适合，例如，数据不适合的话从站就再也无法工作。

注意 		小心设备损坏!
当下载新的设备文件时注意如下几点
  • 下载固件到EtherCAT设备时不能被打断
  • 确保EtherCAT通信稳定。 不能有CRC错误或 LostFrames。
  • 供电必须稳定。 信号等级必须达到规范。

设备更新数据时发生故障可能使模块不能使用，需要返厂修复。

设备描述 ESI文件/XML

注意 		关于ESI说明/EEPROM的更新的注意事项
一些从站在产品的EEPROM中存储了标度和配置的数据。 这些在数据更新中被覆盖。

ESI设备描述存储在本机，并且启动时载入。 每个设备描述为唯一的从站名（10个字符数）和版本号（4个数字） 每个从站的名称都在System Manager的 EtherCAT 页面显示:

图 1: 设备识别符号由名称EL3204-0000和修订号-0016组成

配置识别符号必须与实际的硬件设备兼容。在启动时读取从站型号（如EL3204)。 通常配置的修订号必须等于或高于端子模块的版本 。

说明 		更新 XML/ESI 描述文件
用于硬件设备的固件版本是紧密联系在一起的。 不相容的组合会导致故障或设备关机。
相应的更新只能在咨询Beckhoff技术支持之后才能进行。

显示 ESI从站型号

最简单的确定实际设备描述与配置的设备描述是否一致的方法是在 TwinCAT Config/Freerun 模式下扫描EtherCAT 设备：

图 2: 在Config/FreeRun模式下右键EtherCAT device 然后 Scan Boxes

如果实际与配置相符，则显示下

图 3: 配置相同

否则就显示修改对话框来修改配置

图 4: 修改对话框

在图4例子中。实际为 EL3201-0000-0017 ，原来的配置为 EL3201-0000-0016 。 这种情况下可用CopyBefore按钮来修改配置。 ExtendedInformation复选框必须勾上才能显示版本信息。

修改 ESI 从站版本

ESI/EEPROM 版本可以通过 TwinCAT更新:

  • EtherCAT从站通讯不能中断.
  • 从站的状态不重要。
  • 在online标签中右键从站以打开 EEPROM Update 对话框，图 5

图 5: EEPROM 更新

在对话框中选择新ESI 描述文件, 见图 6. ShowHiddenDevices 复选框钩上可以显示老的版本号，默认不显示。

图 6: 选择新ESI 描述文件

System Manager中的进度条显示当前进度。 数据写入后再进行校验。

说明 		重启后更新生效
大多数EtherCAT立刻读取修改的ESI说明或者在初始化启动之后。 一些通讯设置比如分布式时钟仅在电源打开后读取。
因此为了使修改后的参数生效，EtherCAT从站必须断电重启。

确定固件版本

通过序列号确定固件版本

Beckhoff EtherCAT从站的序列号是用激光刻上的。 序列号的结构如下： KK YY FF HH

KK - 生产周 (CW, 日历周)
YY - 生产年
FF - 固件版本
HH - 硬件版本

12 10 03 02:

12 - 第 12周生产
10 - 2010 年生产
03 - 固件版本 03
02 - 硬件版本 02

System Manager确定版本

主站和从站通信上之后TwinCAT System Manager 即可显示从站控制器的固件版本。 选中你想查看的那个E-Bus端子模块 (本例terminal 2 (EL3204))然后选择CoE Online (CAN over EtherCAT).

说明 		CoE Online和 Offline CoE
有2个CoE 目录：
  • online: 如果从站支持的话，由EtherCAT从站控制器提供。
    只有从站处于连接和运行的状态这个CoE目录才会被显示。
  • offline: EtherCAT 从站信息文件 ESI/XML包含 CoE默认数据.
    CoE目录只显示包含在ESI文件中的信息 (e.g. "Beckhoff EL5xxx.xml")。

Advanced 按钮用于切换这两种显示。

在图7中 CoE索引x100A EL3204的固件版本为03

图 7: 显示 EL3204固件版本

(A) TwinCAT 2.11 指示当前显示 Online CoE 目录 如果当前不是这样, 可以进入 Advanced Settings (B) Online选项 然后双击 AllObjects. 显示所有的Online目录。

升级控制器固件 *.efw

说明 		CoE 目录
由控制器管理的Online CoE目录存储在专用的EEPROM中，这个目录通常在固件更新时不会被改变。

为了更新从站控制固件，选中 Online， 见图8

图 8: 固件更新

如果没有Beckhoff技术支持指导话，请按如下步骤进行。

  • 切换从站到 INIT (A)
  • 切换从站到BOOTSTRAP
  • 检查当前状态 (B, C)
  • 下载新 *efw 文件
  • 下载完成后切换到 INIT状态，然后切换到 OP状态
  • 从站重上电一次

FPGA 固件文件 *.rbf

如果是 FPGA芯片负责处理EtherCAT通讯，可以通过更新 *.rbf文件来完成升级。.

  • 控制器固件 处理 I/O信号
  • FPGA 固件 处理EtherCAT 通信 (仅针对采用 FPGA芯片的端子模块)

包括在端子模块的序列号的固件版本号包含这两个固件组件。 如果其中一个固件更新，那这个版本号就会被更新。

通过System Manager查看版本

在TwinCAT System Manager查看FPGA固件版本。 选中EtherCAT 卡 (本例中的 Device 2) 然后选择 Online 标签

Reg:0002 列分别用十六进制和十进制显示了每个EtherCAT设备的固件版本。

图 9: FPGA固件版本确认

如果 Reg:0002列不显示，在表格中右键然后选择Properties...

图 10: 弹出菜单Properties

Advanced Settings对话框显示哪些列可以被显示。 在 Diagnosis/Online View下 '0002 ETxxxx Build'选中复选框，使FPGA固件版本可以显示。

图 11: 高级设置对话框

更新

更新 FPGA固件

  • EtherCAT耦合器 FPGA固件版本为11或以上;
  • E-bus端子模块FPGA固件版本为10或以上。

更早的固件件版本只能由制造商来更新！

升级EtherCAT设备

在TwinCAT System Manager中选择你想升级FPGA固件的端子模块 (本例 terminal 5: EL5001) 然后
点击EtherCAT中的 Advanced Settings按钮。

图 12: 选择高级设置对话框

Advanced Settings对话框显示。 在 ESC Access/E²PROM/FPGA点击 Write FPGA 按钮,

图 13: 选择写FPGA对话框

选择新 FPGA固件文件 (*.rbf) 然后下载到 EtherCAT设备。

注意 		小心设备损坏!
EtherCAT设备的固件更新过程中不能中断！

如果下载过程被取消，电源断开或是Ethernet连接中断，那此EtherCAT设备只能由制造商来修复！

为了激活新的FPGA固件，EtherCAT设备必须重启（将电源关闭再启动）。

同时更新数台 EtherCAT 设备

如果设备有相同的固件文件/ESI，那么几台设备的固件和ESI描述可以同步更新。

图 14: 多重选择和固件更新

选择需要的从站然后在BOOTSTRAP模式下执行固件的更新。


ELxxxx - 恢复出厂设置

BECKHOFF ELxxxx: 配置

恢复出厂设置

恢复ELxxxx端子模块的出厂设置, 在TwinCAT System Manager的CoE对象 "Restore default parameters"中, 选择SubIndex 001 子项 (配置模式) (见图1)

图 1 选择 "Restore default parameters" PDO

双击SubIndex 001进入参数设定对话框。 输入 1684107116十进制或0x64616F6C十六进制，并点击 OK (图2).
所有数据恢复出厂设置

图 2 在设置值对话框中输入复位码

说明 		其他复位码

某些老端子模块请使用以下复位码：

十进制： "1819238756"

十六进制： "0x6C6F6164"

输入错误的复位码无效。


技术支持与售后

Beckhof f 及其合作伙伴遍布世界各地，可为您提供全方位的技术支持与服务，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff 分公司及代表处

有关 Beckhoff 产品的本地技术支持和服务信息，请联系当地的 Beckhoff 分公司和代表处！

有关 Beckhoff 在全球各地分公司和代理商的地址，您可以登录Beckhoff 的官方网站：
http://www.beckhoff.com

此外，您也可以在该网站上查看更多关于 Beckhoff 组件的文档资料。

Beckhoff 总部

德国倍福自动化有限公司

Eiserstr. 5
33415 Verl
德国

电话 | +49(0)5246/963-0
传真： | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff 技术支持

Beckhoff为您提供全面的技术支持，除了Beckhoff 具体产品的应用以外，还包括更广泛的服务：

  • 技术支持
  • 复杂自动化系统的设计、编程和调试
  • 各种 Beckhoff 系统组件培训方案
热线： | +49(0)5246/963-157
传真： | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心提供全方位的售后技术服务:

  • 现场服务
  • 维修服务
  • 零部件服务
  • 热线服务
热线： | +49(0)5246/963-460
传真： | +49(0)5246/963-479
e-mail: | service@beckhoff.com