84

BECKHOFF Fieldbus 组件

文档

EL4001, EL4002, EL4004, EL4008

1-, 2-, 4-, 8 通道模拟输出端子, 0..10 V, 12 bit

EL4011, EL4012, EL4014, EL4018

1-, 2-, 4-, 8 通道模拟输出端子, 0..20 mA, 12 bit

EL4021, EL4022, EL4044, EL4028

1-, 2-, 4-, 8 通道模拟输出端子, 4..20 mA, 12 bit

EL4031, EL4032, EL4034, EL4038

1-, 2-, 4-, 8 通道模拟输出端子, -10..+10 V, 12 bit

Version: 1.2
Date: 2011-08-18

EtherCAT®是注册商标和专利技术，由德国倍福自动化有限公司授权


BECKHOFF 自动化: 前言

文档说明

本手册仅供那些受过适当培训，熟悉各种适用国家标准的“控制、自动化和驱动工程”领域专业人员使用。
在安装和调试这些组件时，操作人员必须严格遵循下列说明和解释。

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

免责声明

尽管本文档经过精心编制，但由于其中所描述的产品仍处于不断更新换代中，我们可能不会在每次更新后都检查文档中所描述的产品性能数据、标准或其它特性总是与实际产品相一致。
本文档中难免会出现一些技术或者编辑错误，我们保留随时对文档信息作出修改之权力，恕不另行通知。对于已经变更的产品，如果本文档中的数据、图表以及文字描述没有修改，我们将不再特别加以声明。

商标

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® 已为Beckhoff 自动化有限公司的注册商标
本出版物中的相关名称若被第三方出于个人目的，用作商标，将侵犯其拥有者的权利。

申请中的专利

已包含EtherCAT技术但不局限于如下专利申请和专利:
在许多其他国家有关EP1590927, EP1789857, DE102004044764, DE102007017835的相关申请和注册。

已包含TwinCAT技术但不局限于如下专利申请和专利:
在许多其他国家有关EP0851348, US6167425的相关申请和注册。

版权

© 德国倍福自动化有限公司.
未经许可，任何人不得复制、分发和使用本手册以及内容传播。
违者将追究损害赔偿 版权所有，包括实用新型的模型和外观设计的版权。


安全说明

安全规程

请仔细阅读下列安全说明及相关描述！
有关产品特定安全规程，请见后面页或有关安装，接线及调试等章节。

免责声明

所有组件在供货前均针对其具体应用进行了特定的软、硬件配置。 任何人不得对软、硬件配置进行文本档中规定之外的修改，德国倍福自动化有限公司对因此而造成的一切后果不承担任何责任。

人员资质

本手册仅供那些受过适当培训，熟悉各种适用国家标准的“控制、自动化和驱动工程”领域专业人员使用。

安全标志说明

本操作手册中用到了下列安全标志及相应的安全说明。 请仔细阅读并严格遵守。

危险 		有严重人身伤害危险!
不遵守本标志相关的安全说明将直接危及个人生命和健康安全。

警告 		受伤的危险
不遵守本标志相关的安全说明将危及个人生命和健康安全。

小心 		危害个人
不遵守本标志相关的安全说明可能明显危害个人安全。

注意 		对环境和设备有危险
不遵守本标志相关安全说明可能明显危害环境和设备安全。

说明 		说明或提示
该标志表示这些信息能够帮助您更好地理解安全说明。
UL 说明
这个标志用于表示有关UL标准的重要信息。.


EL40xx - Documentation issue status

BECKHOFF EL40xx: 前言

文档版本说明

版本 | 评论
1.2 | - 电流输出的技术数据，优化的对象描述
1.1 | - 增加技术数据，安全指示
1.0 | - 增加EL401x; EL402x , 首次公开发行
0.5 | - 增加EL403x
0.4 | - 小的更正
0.3 | - 增加技术数据
0.2 | - 增加技术数据
0.1 | - EL400x的初步文档

固件和硬件版本

在终端的侧面印有序列号，可以看到固件和硬件版本（交付状态）。

序列号

序列号结构: KK YY FF HH

KK - 生产周
(CW, 日立周)
YY - 生产年份
FF - 固件版本 HH - 硬件版本

例如.: 12 06 3A 02:

12 - 生产周12
06 - 生产年份 2006
3A - 固件版本 3A
02 - 硬件版本 02

204


79

BECKHOFF EL400x: 产品概述

EL400x - 介绍

1-, 2-, 4-, 8 通道模拟输出端子, 0…10 V, 12 bits

EL4001，EL4002，EL4004和EL4008模拟输出端子在0到10 V范围内产生信号. 电压分辨率为12位，并且电气绝缘. EtherCAT端子输出通道有一个共同接地电位。当单通道的EL4001与EL95xx结合，特别适合电隔离的接地电位信号。输出级由24 V电源供电。 EtherCAT端子模块的信号状态由发光二极管指示。

EL400x支持分布式时钟，输入数据可以被其他与分布式时钟终端连接的数据进行同步监测。整个系统的精度小于100 ns。

快速链接

• EtherCAT 基础功能
• 调试
• EL40xx基础功能
• CoE对象的描述和参数化


EL400x - Technical data

BECKHOFF EL400x: 产品概述

EL400x - 技术数据

技术数据 | EL4001 | EL4002 | EL4004 | EL4008
输出的数量 | 1 | 2 | 4 | 8
电源 | 通过电源触点的24伏直流电
信号电压 | 0..10 V
负载 | > 5 kΩ (短路保护)
测量误差 | < 0,1 % (相对于满刻度值)
分辨率 | 12 Bit
转换时间 | ~ 100 µs | ~ 150 µs | ~ 250 µs | ~ 400 µs
内部E-Bus电路的电源电压 | 通过E-Bus
分布式时钟 | 是
E-Bus的电流消耗 | typ. 190 mA
电气隔离 | 500 Vrms (E-Bus/信号电压)
过程映像的位宽 | 1 x 16 bit AO 输出 | 2 x 16 bit AO 输出 | 4 x 16 bit AO 输出 | 8 x 16 bit AO 输出
配置 | 无地址设置，通过TwinCAT系统管理器配置
重量 | 大约60 g
工作温度 | 0°C ... + 55°C
存储温度 | -25°C ... + 85°C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm
安装 | 35毫米的安装导轨符合EN 50022标准
抗振动/抗冲击性能 | 符合EN60068-2-6/EN 60068-2-27/29
EMC防电阻爆裂/防静电 | 符合EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认可 | CE Ex UL

161


91

BECKHOFF EL401x: 产品概述

EL401x - 介绍

1-, 2-, 4-, 8 通道模拟输出端子 0..20 mA, 12 bits

EL4011，EL4012，EL4014和EL4018模拟输出端子产生0到20mA之间的信号。电压分辨率12位，并且电气绝缘。EtherCAT端子的输出通道都有共同接地电位。输出级由24 V电源供电。EtherCAT端子模块的信号状态由发光二极管指示。
EL401x支持分布式时钟，输入数据可以被其他与分布式时钟终端连接的数据进行同步监测。整个系统的精度小于100 ns。

快速链接

• EtherCAT 基础功能
• 调试
• EL40xx的基本功能
• CoE 对象的描述和参数化


EL401x - Technical data

BECKHOFF EL401x: 产品概述

EL401x - 技术数据

技术数据
输出个数 | 1 | 2 | 4 | 8
电源 | 通过电源触点的24伏直流电
信号电流 | 0..20 mA
负载 | < 500 Ω (短路保护) | < 500 Ω (短路保护) | < 350 Ω (短路保护) | < 150 Ω
测量误差 | < 0,1 % (相对于满刻度值)
分辨率 | 12 Bit
转换时间 | ~ 100 µs | ~ 150 µs | ~ 250 µs | ~ 400 µs
内部E-Bus电路的电源电压 | 通过E-Bus
分布式时钟 | 是
E-Bus的电流消耗 | typ. 190 mA
电气隔离 | 500 Vrms (E-Bus/信号 电压)
过程映像的位宽 | 1 x 16 位 AO 输出 | 2 x 16 位 AO 输出 | 4 x 16 位AO 输出 | 8 x 16 位AO 输出
配置 | 无地址设置，通过TwinCAT系统管理器配置
重量 | 大约 60 g
工作温度 | 0°C ... + 55°C
存储温度 | -25°C ... + 85°C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm
安装 | 35毫米的安装导轨符合EN 50022标准
抗振动/抗冲击性能 | 符合 EN 60068-2-6/EN 60068-2-27/29
EMC防电阻爆裂/防静电 | 符合 EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认可 | CE Ex UL

35


EL402x - Introduction

BECKHOFF EL402x: 产品概述

EL402x - 介绍

1-, 2-, 4-, 8 通道模拟输出端子 4..20 mA, 12 bits

EL4021，EL4022，EL4024和EL4028模拟输出端子在4到20mA之间生成信号。电压分辨率为12位，并且电气绝缘。EtherCAT端子的输出通道都有共同接地电位。输出级由24 V电源供电。EtherCAT端子模块的信号状态由发光二极管指示。
EL402x 支持分布式时钟，输入数据可以被其他与分布式时钟终端连接的数据进行同步监测。整个系统的精度小于100 ns。

快速链接

• EtherCAT 基础功能
• 调试
• EL40xx的基本功能
• CoE 对象的描述和参数化

85


102

BECKHOFF EL402x: 产品概述

EL402x - 技术数据

技术数据 | EL4021 | EL4022 | EL4024 | EL4028
输出个数 | 1 | 2 | 4 | 8
电源 | 通过电源触点的24伏直流电
信号电流 | 4..20 mA
负载 | < 500 Ω (短路保护) | < 500 Ω (短路保护) | < 350 Ω (短路保护) | < 150 Ω
测量误差 | < 0,1 % (相对于满刻度值)
分辨率 | 12 Bit
转换时间 | ~ 100 µs | ~ 150 µs | ~ 250 µs | ~ 400 µs
内部E-Bus电路的电源电压 | 通过E-Bus
分布式时钟 | 是
E-Bus的电流消耗 | typ. 190 mA
电气隔离 | 500 Vrms (E-Bus/信号 电压)
过程映像的位宽 | 1 x 16 位AO 输出 | 2 x 16 位AO 输出 | 4 x 16 位AO 输出 | 8 x 16 位AO 输出
配置 | 无地址设置，通过TwinCAT系统管理器配置
重量 | 大约60 g
工作温度 | 0°C ... + 55°C
存储温度 | -25°C ... + 85°C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm
安装 | 35毫米的安装导轨符合EN 50022标准
抗振动/抗冲击性能 | 符合 EN 60068-2-6/EN 60068-2-27/29
EMC防电阻爆裂/防静电 | 符合 EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认可 | CE Ex UL


30

BECKHOFF EL403x: 产品概述

EL403x - 介绍

1-, 2-, 4-, 8 通道模拟输出端子, -10..+10 V, 12 bits

EL4031，EL4032，EL4034和EL4038模拟输出端子，在-10和10V之间产生信号。电压分辨率为12位，并且电气绝缘。EtherCAT端子的输出通道都有共同接地电位。当单通道的EL4001与EL95xx结合，特别适合电隔离的接地电位信号。输出级由24 V电源供电。EtherCAT端子模块的信号状态由发光二极管指示。
EL403x 支持分布式时钟，输入数据可以被其他与分布式时钟终端连接的数据进行同步监测。整个系统的精度小于100 ns。

快速链接

• EtherCAT 基础功能
• 调试
• EL40xx基础功能
• CoE对象的描述和参数化


EL403x - Technical data

BECKHOFF EL403x: 产品概述

EL403x - 技术数据

技术数据 | EL4031 | EL4032 | EL4034 | EL4038
输出个数 | 1 | 2 | 4 | 8
电源 | 通过电源触点的24伏直流电
信号电压 | -10 ..+10 V
负载 | > 5 kΩ (短路保护)
测量误差 | < 0,1 % (相对于最大刻度)
分辨率 | 12 位
转换时间 | ~ 100 µs | ~ 150 µs | ~ 250 µs | ~ 400 µs
内部E-Bus电路的电源电压 | 通过E-Bus
分布式时钟 | 是
E-Bus电流消耗 | typ. 190 mA
电气隔离 | 500 Vrms (E-Bus/信号电压)
过程映像的位宽 | 1 x 16 位 AO 输出 | 2 x 16 位 AO 输出 | 4 x 16 位 AO 输出 | 8 x 16 位 AO 输出
配置 | 无地址设置，通过TwinCAT系统管理器配置
重量 | 大约 60 g
工作温度 | 0°C ... + 55°C
存储温度 | -25°C ... + 85°C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm
安装 | 35毫米的安装导轨符合EN 50022标准
抗振动/抗冲击性能 | 符合 EN 60068-2-6/EN 60068-2-27/29
EMC防电阻爆裂/防静电 | 符合 EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认可 | CE Ex UL

115


KLxxxx, KSxxxx, ELxxxx, ESxxxx - Connection system

BECKHOFF Feldbuskomponenten: 安装与装线

连接系统

警告 		触电和设备损坏的风险!
总线端子系统带入一个安全，断电状态，然后开始安装，拆卸或接线总线端子！

总线端子模块系统提供相应应用程序的不同连接选项:

  • KLxxxx和ELxxxx系列标准接线端子，包括在单一机箱内的电子设备和连接水平。
  • KSxxxx和ESxxxx系列端子模块功能的可插拔连接水平，同时在更换时能稳定地布线。

标准接线

KLxxxx和ELxxxx系列端子模块已经经过多年尝试和测试。
它们的特点是快速和简单地整合无螺纹弹簧力技术。

可插拔接线

KSxxxx和ESxxxx系列端子模块功能的可插拔连接水平。
KS系列的组装和接线过程与KLxxxx和ELxxxx系列相同。
KS/ES系列允许完整布线。
较低的部分可以通过拉解锁标签 从端子模块拦截。
在接线的连接器中插入新的组件和插件。
这样就减少了安装时间并消除了电线混乱的风险。

端子模块的尺寸仅略有改变。新的连接器增加了约3毫米。端子模块的最大高度保持不变。

在许多应用中，为了简化装配和防止混乱，个别的连接线需要被被删除。

导线截面在0.08 mm2到2.5 mm2之间，可以继续使用弹簧力技术。

KSxxxx和ESxxxx系列产品名称的概述和 命名一直从KLxxxx和ELxxxx系列保留下来。

注意 		接线高密度端子模块
KLx8xx和ELx8xx系列的高密度端子模块只适合标准接线。

2


24

BECKHOFF EL40xx: 安装与装线

EL40xx - LED和连接

• EL40x1, EL40x2
• EL40x4, EL40x8

LEDs

LED | 颜色 | 含义
运行 | 绿 | 本LED反映终端的运行状态:
 |  | 暗 | EtherCAT State Machine的状态: INIT = 终端初始化 或 BOOTSTRAP = 终端的固件升级功能。
 |  | 闪烁 | EtherCAT State Machine的状态: PREOP = mailbox通讯的设置和不同的标准设置。
 |  | 一闪而过 | EtherCAT State Machine的状态: SAFEOP = 同步管理 和 分布时钟的通道检测。 在安全模式下输出。
 |  | 亮 | EtherCAT State Machine的状态: OP = 普通操作模式，能进行过程数据通讯和mailbox通讯 。

如果有大于1盏指示灯亮起，那么所有的指示灯拥有相同的功能。

EL40x1的连接

端子 | 编号 | 介绍
Output 1 | 1 | 输出1
- | 2 | 未连接
0 V | 3 | 0 V (与终端7和电源负极触点内部连接)
Shield | 4 | 屏蔽(与终端8内部相连)
- | 5 | 未连接
- | 6 | 未连接
0 V | 7 | 0 V (与终端3和电源负极触点内部连接)
Shield | 8 | 屏蔽(与终端4内部相连)

EL40x2的连接

端子 | 编号 | 介绍
Output 1 | 1 | 输出1
- | 2 | 未连接
0 V | 3 | 0 V (与终端7和电源负极触点内部连接)
Shield | 4 | 屏蔽(与终端8内部相连)
Output 2 | 5 | 输出2
- | 6 | 未连接
0 V | 7 | 0 V (与终端3和电源负极触点内部连接)
Shield | 8 | 屏蔽(与终端4内部相连)

LEDs

LED | 颜色 | 含义
运行 | 绿 | 本LED反映终端的运行状态:
 |  | 暗 | EtherCAT State Machine的状态: INIT = 终端初始化 或 BOOTSTRAP = 终端的固件升级功能。
 |  | 闪烁 | EtherCAT State Machine的状态: PREOP = mailbox通讯的设置和不同的标准设置。
 |  | 一闪而过 | EtherCAT State Machine的状态: SAFEOP = 同步管理 和 分布时钟的通道检测。 在安全模式下输出。
 |  | 亮 | EtherCAT State Machine的状态: OP = 普通操作模式，能进行过程数据通讯和mailbox通讯 。

如果有大于1盏指示灯亮起，那么所有的指示灯拥有相同的功能。

EL40x4的连接

端子 | 编号 | 介绍
Output 1 | 1 | 输出1
Ground | 2 | 0 V (与终端4，6，8内部连接)
Output 3 | 3 | 输出3
Ground | 4 | 0 V (与终端2，6，8内部连接)
Output 2 | 5 | 输出2
Ground | 6 | 0 V (与终端2，4，8内部连接)
Output 4 | 7 | 输出4
Ground | 8 | 0 V (与终端2，4，6内部连接)

EL40x8的连接

端子 | 编号 | 介绍
Output 1 | 1 | 输出1
Output 3 | 2 | 输出3
Output 5 | 3 | 输出5
Output 7 | 4 | 输出7
Output 2 | 5 | 输出2
Output 4 | 6 | 输出4
Output 6 | 7 | 输出6
Output 8 | 8 | 输出8


EtherCAT状态机

EtherCAT从站的状态由EtherCAT状态机（EMS）控制。 依据不同的状态，可以在EtherCAT从站中得到或执行不同的功能。 EtherCAT主站必须发送特殊指令来控制设备的每个状态，尤其是启动从站的时候。

有以下几种状态

  • Init
  • Pre-Operational
  • Safe-Operational
  • Operational
  • Boot

启动后每个EtherCAT从站的最终状态是OP状态。

Init

通电后EtherCAT为Init状态。 mailbox和过程数据无法通讯 。 EtherCAT主站初始化通道0和1同步管理器，为mailbox 通讯准备。

Pre-Operational (Pre-Op)

在 Init 和 Pre-Op的过渡过程中，EtherCAT从站检查mailbox是否正确初始化。

在 Pre-Op 状态 mailbox可以通讯, 但是过程数据无法通讯。 EtherCAT主站初始化过程数据的同步管理器通道 (来自于同步管理器通道2), FMMU通道和, 如果从站支持可调整映射，PDO映射或同步管理器PDO分配。 在这个状态，过程数据的传输设置和端子模块特殊设置也会被传输。

Safe-Operational (Safe-Op)

在 Pre-Op 和 Safe-Op的过渡过程中，EtherCAT从站检查是否过程数据通信的同步管理器通道和分布式时钟设置是否正确。 在确认状态转换之前，EtherCAT从站会将当前输入数据复制到EtherCAT从站控制器（ECSC）中的DP-RAM区域。

在Safe-Op状态可以进行mailbox和过程数据通讯，尽管从站的输出处于安全状态，但是输入数据可以循环更新。

Operational (Op)

在EtherCAT主站切换它的从站从Safe-Op到 Op 状态之前，必须传递有效的输出数据。

在 Op状态，从站复制主站输出数据到从站的输出。 可以进行mailbox和过程数据通讯

Boot

在 Boot 状态，可以更新从站的固件 Boot 状态只能从 Init 状态转换过来。

在 Boot状态，mailbox通讯可以通过file access over EtherCAT (FoE) 协议实现, 但是其他形式的mailbox和过程数据通讯不支持。


CoE-接口

CoE接口是 EtherCAT 设备的参数设定接口。 在CAN-over-EtherCAT (CoE)的管理机构中，特定的固件参数可以在网上或EtherCAT的离线参数中获得。

CoE接口的详细信息可以在Beckhoff 网站上 EtherCAT system documentation 中找到。


5

BECKHOFF EL40xx: 调试

往EtherCAT 终端机网络插入终端

(版本: TwinCAT 2.11)

注意 		最新XML设备类型的安装
请确认您已经在TwinCAT中安装了最新的XML设备类型.。可以从倍福官网下载(http://www.beckhoff.com/english/default.htm?download/elconfg.htm) 并按照安装说明书安装。

终端中的自动扫描

• | 在终端被插入到终端机网络前，总线终端系统必须处于安全、断开电源的状态，参见 导轨装配安装。
• | 打开工作电压, 打开 TwinCAT System Manager (Config 模式), 在终端中扫描(见图1)。得到“OK”的对话框, 这样配置就工作在了 "FreeRun" 模式.

图. 1: 扫描EtherCAT 配置 (I/O Devices-> right-click -> Scan Devices...

手动添加一个终端

• | 在终端被插入到终端机网络前，总线终端系统必须处于安全、断开电源的状态，参见 导轨装配安装。
• | 打开工作电压，打开 TwinCAT System Manager (Config 模式)
• | 添加一个新的 I/O 设备 (见 图. 2). 在对话框中出现选择设备 EtherCAT (Direct 模式), 见图. 3 并且点OK确认。

图. 2: 添加一个新的I/O设备 (I/O Devices-> right-click -> Append Device... )

图. 3: 选择设备EtherCAT (Direct 模式)

• 添加一个新的box(见 图. 4).。在对话框中出现选择 EK1100 系统耦合器, (见 图. 5)，点OK确认。

图. 4: 添加一个新的box(Device -> right-click -> Append Box... )

图. 5: 选择一个系统耦合器(例 EK1100)
• | 添加一个新的box (见 图. 6). 在对话框中出现选择 EL40xx (见 图 7) 并点OK确认。
• | 终端被插入到 TwinCAT 树 (图. 8).

图. 6: 添加一个新的box (Device -> right-click -> Append Box... )

图. 7: 选择终端EL40xx

图. 8: EL400x 终端在 TwinCAT 树之中


221

BECKHOFF EL40xx: 产品概述

基本原理

想要委任请参阅"委任". 确认信目标的描述在 "目标描述和参数化"中提到。

有关分布式时钟的信息可以在系统描述中找到。

过程数据和运行模式

Contents
• 同步管理

• 运行模式和设置

- Presentation
 - 看门狗
 - 校准
- 产品代号

同步管理(SM)

PDO 分配

SM2, PDO assignment 0x1C12
索引 | 排斥的 PDOs索引 | 大小 (字节.位) | 名称 | PDO 内容
0x1600 (默认) | - | 2.0 | AO 输出 通道1 | 索引0x7000:01 - 模拟输出
0x1601 (默认) * | - | 2.0 | AO 输出 通道2 | 索引 0x7010:01 - 模拟输出
0x1602 (默认) ** | - | 2.0 | AO 输出 通道3 | 索引 0x7020:01 - 模拟输出
0x1603(默认) ** | - | 2.0 | AO 输出 通道4 | 索引 0x7030:01 - 模拟输出
0x1604(默认) *** | - | 2.0 | AO 输出 通道5 | 索引 0x7040:01 - 模拟输出
0x1605(默认) *** | - | 2.0 | AO 输出 通道6 | 索引 0x7050:01 - 模拟输出
0x1606(默认) *** | - | 2.0 | AO 输出 通道7 | 索引 0x7060:01 - 模拟输出
0x1607(默认) *** | - | 2.0 | AO 输出 通道8 | 索引 0x7070:01 - 模拟输出

* 只有EL40x2, EL40x4 和 EL40x8
** 只有 EL40x4 和EL40x8
*** 只有 EL40x8

目录.1: 同步管理的PDO分配

运行模式和设置

介绍,索引 80x0:02

在发送状态,测量值是以二进制补码形式为输出(带符号整数).。
索引 80x0:02 使改变测量值表现方式变为可能。

输出信号 | 数值
EL400x | 十进制 | 十六进制
0 V | 0 | 0x0000
5 V | 16383 | 0x3FFF
10 V | 32767 | 0x7FFF
输出信号 | 数值
EL401x | 十进制 | 十六进制
0 mA | 0 | 0x0000
10 mA | 16383 | 0x3FFF
20 mA | 32767 | 0x7FFF
输出信号 | 数值
EL402x | 十进制 | 十六进制
4 mA | 0 | 0x0000
12 mA | 16383 | 0x3FFF
20 mA | 32767 | 0x7FFF
输出信号 | 信号
EL403x | 十进制 | 十六进制
-10 V | -32767 | 0x8001
-5 V | -16383 | 0xC001
0 V | 0 | 0x0000
5 V | 16383 | 0x3FFF
10 V | 32767 | 0x7FFF

注解 		介绍
• | 带符号数: 输出值是二进制补码 形式。 16位的最大表示范围= -32768 .. +32767 例如: 1000 0000 0000 0000bin = 0x8000hex = - 32768dec 1111 1111 1111 1110bin = 0xFFFEhex = - 2dec 1111 1111 1111 1111bin = 0xFFFFhex = - 1dec 0000 0000 0000 0001bin = 0x0001hex = +1dec 0000 0000 0000 0010bin = 0x0002hex = +2dec 0111 1111 1111 1111bin = 0x7FFFhex = +32767dec
• | 无符号数: 输出值是16位。 最大表示范围(16 位) : 0 .. +65535dec
• | 带最高有效位的绝对值 : 输出值是数值符号形式 。 16位的最大表示范围= -32767 .. +32767 例如: 1111 1111 1111 1111bin = 0xFFFFhex = - 32767dec 1000 0000 0000 0010bin = 0x8002hex = - 2dec 1000 0000 0000 0001bin = 0x8001hex = - 1dec 0000 0000 0000 0001bin = 0x0001hex = +1dec 0000 0000 0000 0010bin = 0x0002hex = +2dec 0111 1111 1111 1111bin = 0x7FFFhex = +32767dec
• | 绝对值 输出值若为负，则将表示成正值 (绝对值)

看门狗,索引 80x0:05

对于和控制器通讯失败而言，模拟输出量可以被设成用户特定的值。"看门狗默认值" 必须以下拉菜单为场景，在索引 80x0:13 中之前输入的值是输出值。
如果用户特定的值只能在出错的一段时间后才被接近，那么斜坡函数 "看门狗斜坡" (索引 80x0:14) 可以被设置。这数值以digits/ms为单位的输入值。
在出错后，"最近的输出值" 能够输出最近有效的输出值。

校准

用户缩放, 索引 80x0:01

用户缩放通过索引 80x0:01被使用。 参数化通过目录来取代。

• | 80x0:11 用户缩放补偿
• | 80x0:12 用户缩放增益

制造商校准, 索引 80xF

制造商校准是通过索引 80x0:08授权。参数化通过目录来取代。

• | 80xF:01 补偿 (制造商校准)
• | 80xF:02 增益 (制造商校准)

用户校准, 索引 80x0:15, 80x0:16

用户校准是通过索引 80x0:07授权。参数化通过目录来取代。

• | 80x0:15 用户补偿校准
• | 80x0:16 用户增益校准

过程数据计算

终端连续记录过程数据并且把D/A转换器的原始值放入DAC原始值目标 80xE:01. 在得到每个过程数据后，将会计算制造商的校准修正。 用户缩放会遵循这规律(可选的):
YH = (XDAC - BK) x AK | 根据制造商校准的输出值 (如果索引 80x0:01 是闲置的，将符合YA )
YA = YH x AW x 2-16 + BW | 根据用户缩放的输出值

说明

名称 | 指示 | 索引
XADC | D/A转换器的输出值 | 80xE:01
BK | 制造商校准补偿(只有当生产代号 F008 设置后才是可改变的) | 80xF:01
AK | 制造商校准增益 (只有当生产代号 F008 设置后才是可改变的) | 80xF:02
BW | 用户缩放补偿(通过80x0:01可被激活) | 80x0:15
AW | 用户缩放增益 (通过80x0:01可被激活) | 80x0:16
YA | 输出值 | -

生产商代码

注解 		生产商代码
生产商保留了对终端的基本校准的解释权。 因此生产商代码现在是被保留的。


89

BECKHOFF EL40xx: 调试

EL4x1x, EL4x2x 电流输出

EL4xxx 电流输出的负载能力受限于特定的操作限制。在技术资料中，这些信息被称作“最大负载” 。对于每个通道而言，这是对于每个终端可以持续提供最大输出电流的最大负载电阻。相应参数是每个终端有效通道的数量 (不是使用中的通道个数)。

通道数量 | 最大负载 | 特点
2 | < 500 Ω | 防短路
4 | < 350 Ω | 防短路
8 | < 150 Ω | -

尽管一个通道不能再输出最大电流并受限于超载，但对于一个更大的负载电阻，它仍然能够工作。

注意 		工作在过高负载的情况下
如下图所示，不建议在各通道数的参数范围外进行操作。如果过程量的规格导致运行在规定范围之外，则可能会损坏输出级。

图.1: EL4xx2 电流输出的允许工作范围

图.2: EL4xx4 电流输出的允许工作范围

图.3: EL4xx8 电流输出的允许工作范围


TwinCAT System Manager - Configuration

BECKHOFF TwinCAT系统管理器: 配置

通过TwinCAT system manager配置

(TwinCAT 版本 2.10.0 (Build 1241), 使用EL5001 ，以固件版本 0.7 为例)

在TwinCAT system manager的左边窗口中, 点击你需要的配置 (例如： EL5001 终端6).

在TwinCAT system manager的右边窗口 可以看到不同的选项卡。.

General 选项卡

名称 | EtherCAT 设备的名称
Id | EtherCAT 设备的数量
Type | EtherCAT 设备类型
Comment | 添加评论
Disabled | 停用EtherCAT 设备
Create symbols | 仅当控制柜是激活的，才有权通过ADS进入到EtherCAT从站

EtherCAT 选项卡

Type | EtherCAT 设备类型
Product/Revision | EtherCAT 设备的产品号和版本号
Auto Inc Addr. | EtherCAT 设备的自动增加. 通过物理位置，这可以用来访问每个EtherCAT 设备。当Ethercat主机给设备分配地址时，将在启动阶段使用自动增加地址。第一个EtherCAT从站将拥有地址 0000hex.。其他从站地址将依次减1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | EtherCAT 从站的固定地址.。这地址由EtherCAT主站在启动阶段分配。要修改默认值，将控制柜标记于输入区域的左侧。
Previous Port | 连接着的 EtherCAT 设备的名称和端口。如果在不改变设备顺序的情况下，能通过另一个设备连接该设备I，那么这个结合区域将被激活，并且将选择连接着的EtherCAT设备。
Advanced Settings | 这个按钮能打开高级设置

底下的链接能连上EtherCAT设备的主页。

Process Data 选项卡

过程数据的配置。从站的输入和输出数据将被表示成硬件协议PDO.如果EtherCAT从站支持的话，用户可以通过PDO分配来选择PDO并且修改独立的PDO内容 。

同步管理

列出同步管理的配置。
如果EtherCAT 设备有mailbox, SM0将被用于mailbox输出(MbxOut) ， SM1 为mailbox输入(MbxIn).
SM2 为输出过程数据(outputs) ，SM3 (inputs) 为输入过程数据。

选择了一个输入后，相应的PDO分配将在PDO 分配 显示

PDO 分配

PDO的分配选定的同步管理器。这里列出了此同步管理器类型中定义的所有的PDO:

  • 如果输出的同步管理器（输出）在同步管理器列表中选择，显示所有RxPDOs。
  • 如果输入的同步管理器（输入）在同步管理器列表中选择，显示所有TxPDOs。

所选条目是参与的过程中数据传输的PDO。在系统管理器的树形图显示这些PDO的EtherCAT设备的变量。 在PDO列表中变量的名称和PDO参数的名称相同。如果PDO分配列表中的条目无效（未选中，灰色），这表明是从PDO分配中排除的输入。为了能够做选择一个灰色显示的PDO，先要取消当前选定的PDO。

注意 		激活PDO的分配
如果你更改了PDO分配，为了激活新的PDO分配，
  • EtherCAT从站需要通过PS状态过渡周期运行(运行前安全业务) (请参阅 联机选项卡),
  • 系统管理器中重新载入EtherCAT从站( [image] 按钮)

PDO 列表

这EtherCAT设备支持所有的PDO列表。选定的PDO的内容显示在PDO的内容列表。 PDO的配置可以通过双击一个条目进行修改。

列 | 描述
Index | PDO 索引
Size | PDO 的尺寸（以字节为单位）
Name | PDO的名称 如果这个PDO被分配到同步管理器, 它显示为一个从站变量。
Flag | F | 固定内容：本PDO的内容是固定的，不能被系统管理员改动。
 | M | 强制性的PDO. PDO是强制性的，因此必须被分配到同步管理器! 因此，此PDO不能从PDO分配列表中删除
SM | 同步管理PDO分配。如果这个项目是空的，这个PDO将不是数据流量的一部分。
SU | 同步分配的PDO单元。

PDO 的内容

表示PDO的内容。如果PDO未设置标志F,则可以修改内容。

下载

如果该设备是智能mailbox，PDO的配置和PDO的分配可以下载到设备中。 这是一项可选功能，不是所有的EtherCAT从站都支持。

PDO 的分配

如果此复选框被选中，在PDO分配列表中以配置的PDO分配将会下载到设备上启动。需要发送到设备的命令，请查看 启动 选项卡。

PDO 的配置

如果此复选框被选中，各自的PDO（如PDO的列表和PDO的内容所示）的配置将下载到EtherCAT从站。

Startup 选项卡

EtherCAT从站如果有一个mailbox，并支持在EtherCAT（CoE）或EtherCAT协议的伺服驱动器的CANopen“启动”选项卡上显示。此标签表明下载请求在启动期间被发送到mailbox。它也可以添加新的mailbox并在列表中显示。下载请求被发送到从站的顺序与在列表中的顺序相同

列 | 描述
Transition 过渡到该请求被发送。这可以是：
  • 提前运行过渡到安全运行 (PS)
  • 安全运行过渡到运行(SO)

如果过渡是在封闭的“<>”（如：<PS>），mailbox要求是固定的，不能修改或删除用户.
Protocol | mailbox协议类型
Index | 对象的索引
Data | 下载此对象的日期
Comment | 对于请求的描述将被发送至mailbox
Move Up | 将选定的请求上移一位
Move Down | 将选定的请求下移一位
New | 在启动时添加一个新的下载请求
Delete | 删除所选条目
Edit | 编辑一个已存在的请求

CoE - Online 选项卡

额外CoE - 如果EtherCAT从站在CoE协议中支持CANopen，将显示 Online 选项卡。此对话框列出的从站对象（SDO上传）的内容，使用户能够在这个名单中修改对象的内容。独立的EtherCAT设备对象的详细信息，可以在设备中特定对象的描述中发现。

对象列表显示
列 | 描述
Index | 对象的索引和子索引
Name | 对象的名称
Flag | RW | 对象可读，并且数据可以写入对象（读/写）
 | RO | 对象可读，但是数据不能写入（只读）
 | P | 增设一个P标志识别过程数据对象
Value | 对象的值
Update List | 更新列表中所有对象
Auto Update | 如果此复选框被选中时，对象的内容会自动更新。
Advanced | “高级”按钮打开“高级设置”对话框。在这里您可以指定哪些对象在列表中显示.

Online - via SDO Information | 如果选择此按钮，包含在从站的对象列表中的对象通过SDO将从从站上传。下面的列表可用于指定哪些对象类型需要上传。
Offline - via EDS File | 如果选择此按钮，在对象列表中的对象将从用户提供的EDS文件读取。

Online 选项卡

状态机

Init | 此按钮尝试设置EtherCAT设备的初始状态。
Pre-Op | 此按钮尝试设置EtherCAT设备到 预操作状态。
Op | 此按钮尝试设置EtherCAT设备的操作状态。
Bootstrap | 此按钮尝试设置EtherCAT设备的引导状态。
Safe-Op | 此按钮尝试设置EtherCAT设备的安全运行状态。
Clear Error | 此按钮尝试删除故障显示. 如果EtherCAT从站在状态变化过程中失败，它 将设置一个错误标志。 例如: EtherCAT从站处于 PREOP状态 (操作前). 主站请求SAFEOP状态 (安全运行). 如果从站在改变状态过程中失败，它将设置一个错误标志。当前状态将显示成 ERR PREOP. 当按下Clear Error 按钮，错误标志被删除，当前状态将重新变为 PREOP。
Current State | 指示EtherCAT设备的当前状态。
Requested State | 指示EtherCAT设备要求的状态。

DLL 的状态

指示 EtherCAT从机的独立端口的DLL状态。DLL有以下四种不同的状态：

状态 | 描述
No Carrier / Open | 无载波信号在端口可用，但该端口是开放的
No Carrier / Closed | 无载波信号在端口可用，但该端口是关闭的
Carrier / Open | 载波信号在端口可用，但该端口是开放的
Carrier / Closed | 载波信号在端口可用，但该端口是关闭的

在EtherCAT的文件访问

Download | 点击这个按钮，一个文件可以被写入到EtherCAT设备
Upload | 点击这个按钮，一个文件可以从EtherCAT设备读出.

184


EL40xx - Overview

BECKHOFF EL40xx: 概述

在TwinCAT System Manager中使用EL40xx

内容
• 过程数据

• 默认设置

• 更改CoE目录的从站参数

想获取更多信息请参阅 对象描述和参数 和 基本原理.

过程数据

在完整版本的el4008，例如，提供以下过程中使用的数据:

图. 1: EL4008 过程数据

在EL4008的情况下，8套的过程数据可用，每套都有一个测量通道。

  • 模拟输出通道1 - 8: 模拟输出值

默认设置

EL40xx 默认设置:

  • 用户规模：禁用
  • 制造商校准：启用
  • 用户校准：禁用
  • 看门狗：启用默认输出值

更改CoE目录的从站参数

在调试过程中，它对于改变CoE参数可能是必要的。

  • 如果终端在线访问，CoE的目录是从从站读取，并可以改变;见图. 6。
  • 如果终端访问脱机（终端，然后不寻址）用于从XML描述数据。不能改变参数。

CoE参数可以在EtherCAT 从站的"CoE-Online"选项卡中改变

图. 2: 通过TwinCAT System Manager访问CoE参数

警告 		在CoE目录中的变化
因此，在交换EtherCAT从站的情况下，新的从战中CoE参数设置正确。客户端中的变化，必须输入到启动列表中。

注意 		在CoE目录中的变化，程序访问
在操作过程中使用相应的控制命令PLC，那么CoE的参数可以读取和写入。有关详细信息，请参阅Beckhoff的信息系统中相应的文章。

224


EL40xx - Object description and parameterization

BECKHOFF EL40xx: 配置

Object说明和参数化

注解 		EtherCAT XML 设备说明
设备描述符合于EtherCAT XML 设备描述的显示。强烈建议从倍福官网下载最新版本的相关XML文件(http://www.beckhoff.com/english/default.htm?download/elconfg.htm) 并按照安装说明书安装。

注解 		参数化
终端参数化受CoE选项卡（双击相关对象）或过程数据（PDO分配）管理。

介绍

对象概述
• 还原对象
• 配置数据
• 输出数据
• 标准对象

还原对象

索引 1011 还原默认参数
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1011:0 | 还原默认参数 | 在EtherCAT从站中还原默认设置 | UINT8 | RO | 0x01 (1dec)
1011:01 | 分指数 001 | 如果对象被设成 "0x64616F6C" ("设定模拟量") 所有特定终端对象被还原到出厂设置。 | UINT32 | RW | 0x00000000 (0dec)

配置数据

索引 8pp0 AO settings Ch.1-8
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
8pp0:0 | AO settings Ch.1-8 | 最大分指数 | UINT8 | RO | 0x16 (22dec)
8pp0:01 | 使能用户规模 | 用户规模已使能 | BOOLEAN | RW | 0x00 (0dec)
8pp0:02 | 介绍 | 0: 带符号介绍 输出值是带符号数的二进制补码形式。 最大输出范围(16 Bit) = -32768dec .. +32767dec 1: 无符号介绍 最大表示范围 (16 Bit) : 0 .. +65535dec 2: 带最高有效位的绝对值 输出值是数值符号形式。 最大输出范围(16 Bit) = -32767dec .. +32767dec 3: 绝对值 对于负的输出值将变为正值。 | BIT3 | RW | 0x00 (0dec)
8pp0:05 | 看门狗 | 0: 看门狗默认值 默认值有效 (8pp0:13) 1: 看门狗斜坡 默认值有效.(8pp0:14) 2: 最新输出值 如果看门狗有效, 最新的过程数据将被递交 | BIT2 | RW | 0x00 (0dec)
8pp0:07 | 使能用户校准 | 如果位被设置，就是能用户校准 | BOOLEAN | RW | 0x00 (0dec)
8pp0:08 | 使能制造商校准 | 如果位被设置，就是能用户校准 | BOOLEAN | RW | 0x01 (1dec)
8pp0:11 | 补偿 | 用户校准补偿 | INT16 | RW | 0x0000 (0dec)
8pp0:12 | 增益 | 用户校准增益 增益被表示成定点模式,带有因数2-16. 增益的值1相当于 65535dec (0x00010000). | INT32 | RW | 0x00010000 (65536dec)
8pp0:13 | 默认输出 | 默认输出值 | INT16 | RW | 0x0000 (0dec)
8pp0:14 | 默认输出斜坡 | 默认输出斜坡值以 Digit / ms为单位 | UINT16 | RW | 0xFFFF (65535dec)
8pp0:15 | 用户校准补偿 | 用户校准补偿 | INT16 | RW | 0x0000 (0dec)
8pp0:16 | 用户校准增益 | 用户校准增益 | UINT16 | RW | 0xFFFF (65535dec)
索引 8ppE AO 内部数据 Ch.1-8
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
8ppE:0 | AO 内部数据 Ch.1-8 | 最大分指数 | UINT8 | RO | 0x01 (1dec)
8ppE:01 | DAC 原始值 | DAC 原始值 | UINT16 | RO | 0x0000 (0dec)
索引 8ppF AO 制造商数据 Ch.1-8
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
8ppF:0 | AO 制造商数据 Ch.1-8 | AO 制造商数据 Ch.1 | UINT8 | RO | 0x02 (2dec)
8ppF:01 | 校准补偿 | 校准补偿 | INT16 | RW | 0x0000 (0dec)
8ppF:02 | 校准增益 | 校准增益 | UINT16 | RW | 0x1EFA (7930dec)

输出数据

索引 7pp0 AO 输出 Ch.1-8
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
7pp0:0 | AO 输出 Ch.1-8 | 最大分指数 | UINT8 | RO | 0x01 (1dec)
7pp0:01 | 模拟输出 | 模拟输出数据 | INT16 | RO | 0x0000 (0dec)

标准对象 (0x1000-0x1FFF)

所有 EtherCAT从站的标准对象有相同含义

索引 1000 设备类型
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1000:0 | 设备类型 | EtherCAT从站的设备类型: 低字包含CoE配置支持(5001).。高字包含模块配置与模块设备配置一致 。 | UINT32 | RO | 0x01901389 (26219401dec)
索引 1008 设备名称
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1008:0 | 设备名称 | EtherCAT从站的设备名称 | STRING | RO | EL40xx-0000
索引 1009 硬件版本
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1009:0 | 硬件版本 | EtherCAT从站的硬件版本 | STRING | RO | 01
索引 100A 软件版本
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
100A:0 | 软件版本 | EtherCAT从站的固件版本 | STRING | RO | 01
索引 1018 特性
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1018:0 | 特性 | 包含鉴定EtherCAT从站的信息 | UINT8 | RO | 0x04 (4dec)
1018:01 | 制造商ID | EtherCAT从站的制造商ID | UINT32 | RO | 0x00000002 (2dec)
1018:02 | 产品代码 | EtherCAT从站的产品代码 | UINT32 | RO | 0x0Fx83052
1018:03 | 修正 | EtherCAT从站的修正值, 低字 (Bit 0-15) 表明特殊功能终端值; 高字(Bit 16-31) 引用设备描述。 | UINT32 | RO | 0x00100000 (1048576dec)
1018:04 | 序号 | EtherCAT从站的序号, 低字的低位(Bit 0-7) 包含生产年份，低字的高位包含 (Bit 8-15) 生产周信息， 高字 (Bit 16-31) 是 0 . | UINT32 | RO | 0x00000000 (0dec)
索引 10F0 备份参数处理
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
10F0:0 | 备份参数处理 | 包含备份词目的标准化上传和下载的信息 | UINT8 | RO | 0x01 (1dec)
10F0:01 | 校验和 | 对所有备份词目的校验和 | UINT32 | RO | 0x00000000 (0dec)
索引 1600 RxPDO-Map输出 Ch.1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1600:0 | RxPDO-Map 输出 Ch.1 | PDO 绘图 RxPDO 1 | UINT8 | RW | 0x01 (1dec)
1600:01 | 分指数 001 | 1. PDO 绘图条目 (object 0x7000 (AO 输出 Ch.1), 条目 0x01 (模拟输出)) | UINT32 | RW | 0x7000:01, 16
索引 1601 RxPDO-Map 输出Ch.2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1601:0 | RxPDO-Map 输出 Ch.2 | PDO 绘图 RxPDO 2 | UINT8 | RW | 0x01 (1dec)
1601:01 | 分指数 001 | 1. PDO 绘图条目(object 0x7010 (AO 输出 Ch.2), 条目 0x01 (模拟输出)) | UINT32 | RW | 0x7010:01, 16
索引 1602 RxPDO-Map 输出 Ch.3
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1602:0 | RxPDO-Map 输出 Ch.3 | PDO 绘图 RxPDO 3 | UINT8 | RW | 0x01 (1dec)
1602:01 | 分指数 001 | 1. PDO 绘图条目(object 0x7020 (AO 输出 Ch.3), 条目 0x01 (模拟输出)) | UINT32 | RW | 0x7020:01, 16
索引 1603 RxPDO-Map 输出 Ch.4
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1603:0 | RxPDO-Map 输出 Ch.4 | PDO 绘图 RxPDO 4 | UINT8 | RW | 0x01 (1dec)
1603:01 | 分指数 001 | 1. PDO 绘图条目(object 0x7030 (AO 输出 Ch.4), 条目 0x01 (模拟输出)) | UINT32 | RW | 0x7030:01, 16
索引 1604 RxPDO-Map 输出 Ch.5
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1604:0 | RxPDO-Map 输出 Ch.5 | PDO 绘图 RxPDO 5 | UINT8 | RW | 0x01 (1dec)
1604:01 | 分指数 001 | 1. PDO 绘图 条目 (object 0x7040 (AO 输出 Ch.5), 条目 0x01 (Analog output)) | UINT32 | RW | 0x7040:01, 16
索引 1605 RxPDO-Map 输出 Ch.6
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1605:0 | RxPDO-Map 输出 Ch.6 | PDO 绘图 RxPDO 6 | UINT8 | RW | 0x01 (1dec)
1605:01 | 分指数 001 | 1. PDO 绘图 条目 (object 0x7050 (AO 输出 Ch.6), 条目 0x01 (Analog output)) | UINT32 | RW | 0x7050:01, 16
索引 1606 RxPDO-Map 输出 Ch.7
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1606:0 | RxPDO-Map 输出 Ch.7 | PDO 绘图 RxPDO 7 | UINT8 | RW | 0x01 (1dec)
1606:01 | 分指数 001 | 1. PDO 绘图 条目 (object 0x7060 (AO 输出 Ch.7), 条目 0x01 (Analog output)) | UINT32 | RW | 0x7060:01, 16
索引 1607 RxPDO-Map 输出 Ch.8
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1607:0 | RxPDO-Map 输出 Ch.8 | PDO 绘图 RxPDO 8 | UINT8 | RW | 0x01 (1dec)
1607:01 | 分指数 001 | 1. PDO 绘图 条目 (object 0x7070 (AO 输出 Ch.8), 条目 0x01 (Analog output)) | UINT32 | RW | 0x7070:01, 16
索引 1C00 同步管理类型
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C00:0 | 同步管理类型 | 同步管理通道的使用方法 | UINT8 | RO | 0x04 (4dec)
1C00:01 | 分指数 001 | 同步管理类型通道1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | 分指数 002 | 同步管理类型通道2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | 分指数 003 | 同步管理类型通道3: Process Data Write (输出) | UINT8 | RO | 0x03 (3dec)
1C00:04 | 分指数 004 | 同步管理类型通道4: Process Data Read (输入) | UINT8 | RO | 0x04 (4dec)
索引 1C12 RxPDO 分配
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C12:0 | RxPDO 分配 | PDO分配输出 | UINT8 | RW | 0x08 (8dec)
1C12:01 | 分指数 001 | 1. 指定的 RxPDO (包含对应的RxPDO绘图对象) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | 分指数 002 | 2. 指定的 RxPDO (包含对应的RxPDO绘图对象) | UINT16 | RW | 0x1601 (5633dec)
1C12:03 | 分指数 003 | 3. 指定的 RxPDO (包含对应的RxPDO绘图对象) | UINT16 | RW | 0x1602 (5634dec)
1C12:04 | 分指数 004 | 4. 指定的 RxPDO (包含对应的RxPDO绘图对象) | UINT16 | RW | 0x1603 (5635dec)
1C12:05 | 分指数 005 | 5. 指定的 RxPDO (包含对应的RxPDO绘图对象) | UINT16 | RW | 0x1604 (5636dec)
1C12:06 | 分指数 006 | 6. 指定的 RxPDO (包含对应的RxPDO绘图对象) | UINT16 | RW | 0x1605 (5637dec)
1C12:07 | 分指数 007 | 7. 指定的 RxPDO (包含对应的RxPDO绘图对象) | UINT16 | RW | 0x1606 (5638dec)
1C12:08 | 分指数 008 | 8. 指定的 RxPDO (包含对应的RxPDO绘图对象) | UINT16 | RW | 0x1607 (5639dec)
索引 1C32 SM 输出参数
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C32:0 | SM 输出参数 | 输出的同步参数 | UINT8 | RO | 0x07 (7dec)
1C32:01 同步模式 实际同步模式:
  • 0: 空转
  • 1: 与SM 2同步
  • 2: 与SYNC0 直流同步
  • 3: 与SYNC1 直流同步
 UINT16 RW 0x0001 (1dec)
1C32:02 周期 周期 (纳秒):
  • 空转: 当地计时器的周期
  • 与SM 2 同步: 主站的周期
  • 直流模式: SYNC0/SYNC1周期
 UINT32 RW 0x00000000 (0dec)
1C32:03 | 时间顺序 | 在 SYNC0 和输出值之间的时间(纳秒，直流模式) | UINT32 | RW | 0x00000000 (0dec)
1C32:04 支持同步模式 支持同步模式:
  • Bit 0 = 1: 支持空转
  • Bit 1 = 1: 支持与SM 2 同步
  • Bit 2-3 = 01: 支持直流模式
  • Bit 4-5 = 10: 改变SYNC1的输出(直流模式)
  • Bit 14 = 1: 动态时间 (能被1C32:08测量)
 UINT16 RO 0x8007 (32775dec)
1C32:05 | 最小周期 | 支持最小周期(纳秒) | UINT32 | RO | 0x00000000 (0dec)
1C32:06 | 计算并复制时间 | 在SYNC0和 SYNC1之间的最小时间 (纳秒，直流模式) | UINT32 | RO | 0x00000000 (0dec)
1C32:08 指令
  • 0: 停止时间测量
  • 1: 开始时间测量

1C32:03, 1C32:05, 1C32:06, 1C32:09 会更新至最大测量值

UINT16 RW 0x0000 (0dec)
1C32:09 | 延迟时间 | 在SYNC1和输出值之间的时间(纳秒，直流模式) | UINT32 | RO | 0x00000000 (0dec)
1C32:0B | SM 偏差计算 | 在运作状态中，SM偏差的值(直流模式) | UINT16 | RO | 0x0000 (0dec)
1C32:0C | 周期溢出计算 | 在运作状态中，周期溢出的值 | UINT16 | RO | 0x0000 (0dec)
1C32:0D | 最小距离计算 | SYNC0 和SYNC1 的最小距离 (直流模式) | UINT16 | RO | 0x0000 (0dec)
1C32:20 | 同步错误 | TRUE: 在最后一个周期中，同步出错 (直流模式) | BOOLEAN | RO | 0x00 (0dec)
索引 F000 模块设备
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
F000:0 | 模块设备 | 模块设备的一般信息 | UINT8 | RO | 0x02 (2dec)
F000:01 | 模块距离 | 模块距离 | UINT16 | RO | 0x0010 (16dec)
F000:02 | 模块的最大值 | 模块的最大值 | UINT16 | RO | 0x0008 (8dec)
索引 F008 代码字
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
F008:0 | 代码字 | 保留 | UINT32 | RW | 0x00000000 (0dec)

65


ELxxxx - 恢复出厂设置

BECKHOFF ELxxxx: 配置

恢复出厂设置

恢复ELxxxx端子模块的出厂设置, 在TwinCAT System Manager的CoE对象 "Restore default parameters"中, 选择SubIndex 001 子项 (配置模式) (见图1)

图 1 选择 "Restore default parameters" PDO

双击SubIndex 001进入参数设定对话框。 输入 1684107116十进制或0x64616F6C十六进制，并点击 OK (图2).
所有数据恢复出厂设置

图 2 在设置值对话框中输入复位码

说明 		其他复位码

某些老端子模块请使用以下复位码：

十进制： "1819238756"

十六进制： "0x6C6F6164"

输入错误的复位码无效。


UL 需求

BECKHOFF EKxxxx, ELxxxx: 附录

UL 说明

应用
Beckhoff EtherCAT 模块仅适用于Beckhoff UL 列表中的EtherCAT系统。
测试
更据cULus 测试, Beckhoff I/O 系统仅进行了防火和电击测试 has only been investigated for risk of fire and electrical shock (更据 UL508 和 CSA C22.2 No. 142).
对于以太网接口设备
不适用于连接通信线路

基本原理

倍福EtherCAT产品的两个UL认证，因产品而异：

  • 符合UL508标准的UL认证
    拥有该认证的设备会有这样的标记：

  • 符合限制电源消耗UL508标准的UL认证
    设备消耗的最大电流限制为4A。拥有该认证的设备会有这样的标记。

几乎所有的EtherCAT产品（截止到2010/5）都是非限制的UL认证。

应用

如果端子模块通过 限制认证 , 那么24 V DC 电流消耗必须受到电源限制。

  • 由一个拥有最大电流为4A的保险丝保护的独立电源供电（根据UL248）或者
  • 由一个符合 NEC class 2的电源供电。
    符合 NEC class 2 的电源不能与另一个 NEC class 2 电源串联或并联使用!

这些要求适用于所有的EtherCAT总线耦合器电源，电源适配器端子模块，总线端子模块以及它们的电源触点。


ELxxxx - 固件

BECKHOFF ELxxxx: 设备升级

固件 EL/ES/EMxxxx

这部分描述了Beckhoff EtherCAT从站 EL/ES, EM, EK和EP系列的版本升级。. 固件的升级只能在咨询Beckhoff技术支持之后才能执行。

目录
• 存储位置
• ESI版本定义
• 设备描述升级 ESI/*.xml
• 固件版本描述
• 固件升级文件 *.efw
• 固件升级文件 *.rbf
• 批量更新

存储位置

EtherCAT从站在3个地方存储运行数据：

  • 更据功能和性能EtherCAT从站有一个或几个本地控制器用于传输I/O数据。 所对应的程序称为 固件 为 *.efw 格式。
  • 某些EtherCAT从站的EtherCAT通讯功能也集成在控制器中。 这种情况的控制器叫做 FPGA 芯片使用 *.rbf 格式的固件。
  • 另外每个EtherCAT从站有存储芯片保持设备参数叫做 EEPROM. 通电后自动加载参数，EtherCAT通信也相应设定。 设备描述可以从 http://www.beckhoff.com 下载区下载。 所有 ESI 文件(EtherCAT Slave Information) 压缩成ZIP格式。

客户可以通过 EtherCAT 现场总线和其通信机制访问数据。 ESC读写来实现异步mailbox通讯或访问寄存器。

TwinCAT System Manager提供配置所有这3部分数据的方法，如果从站支持这些数据。 通常从站不会检查新数据是否适合，例如，数据不适合的话从站就再也无法工作。

注意 		小心设备损坏!
当下载新的设备文件时注意如下几点
  • 下载固件到EtherCAT设备时不能被打断
  • 确保EtherCAT通信稳定。 不能有CRC错误或 LostFrames。
  • 供电必须稳定。 信号等级必须达到规范。

设备更新数据时发生故障可能使模块不能使用，需要返厂修复。

设备描述 ESI文件/XML

注意 		关于ESI说明/EEPROM的更新的注意事项
一些从站在产品的EEPROM中存储了标度和配置的数据。 这些在数据更新中被覆盖。

ESI设备描述存储在本机，并且启动时载入。 每个设备描述为唯一的从站名（10个字符数）和版本号（4个数字） 每个从站的名称都在System Manager的 EtherCAT 页面显示:

图 1: 设备识别符号由名称EL3204-0000和修订号-0016组成

配置识别符号必须与实际的硬件设备兼容。在启动时读取从站型号（如EL3204)。 通常配置的修订号必须等于或高于端子模块的版本 。

说明 		更新 XML/ESI 描述文件
用于硬件设备的固件版本是紧密联系在一起的。 不相容的组合会导致故障或设备关机。
相应的更新只能在咨询Beckhoff技术支持之后才能进行。

显示 ESI从站型号

最简单的确定实际设备描述与配置的设备描述是否一致的方法是在 TwinCAT Config/Freerun 模式下扫描EtherCAT 设备：

图 2: 在Config/FreeRun模式下右键EtherCAT device 然后 Scan Boxes

如果实际与配置相符，则显示下

图 3: 配置相同

否则就显示修改对话框来修改配置

图 4: 修改对话框

在图4例子中。实际为 EL3201-0000-0017 ，原来的配置为 EL3201-0000-0016 。 这种情况下可用CopyBefore按钮来修改配置。 ExtendedInformation复选框必须勾上才能显示版本信息。

修改 ESI 从站版本

ESI/EEPROM 版本可以通过 TwinCAT更新:

  • EtherCAT从站通讯不能中断.
  • 从站的状态不重要。
  • 在online标签中右键从站以打开 EEPROM Update 对话框，图 5

图 5: EEPROM 更新

在对话框中选择新ESI 描述文件, 见图 6. ShowHiddenDevices 复选框钩上可以显示老的版本号，默认不显示。

图 6: 选择新ESI 描述文件

System Manager中的进度条显示当前进度。 数据写入后再进行校验。

说明 		重启后更新生效
大多数EtherCAT立刻读取修改的ESI说明或者在初始化启动之后。 一些通讯设置比如分布式时钟仅在电源打开后读取。
因此为了使修改后的参数生效，EtherCAT从站必须断电重启。

确定固件版本

通过序列号确定固件版本

Beckhoff EtherCAT从站的序列号是用激光刻上的。 序列号的结构如下： KK YY FF HH

KK - 生产周 (CW, 日历周)
YY - 生产年
FF - 固件版本
HH - 硬件版本

12 10 03 02:

12 - 第 12周生产
10 - 2010 年生产
03 - 固件版本 03
02 - 硬件版本 02

System Manager确定版本

主站和从站通信上之后TwinCAT System Manager 即可显示从站控制器的固件版本。 选中你想查看的那个E-Bus端子模块 (本例terminal 2 (EL3204))然后选择CoE Online (CAN over EtherCAT).

说明 		CoE Online和 Offline CoE
有2个CoE 目录：
  • online: 如果从站支持的话，由EtherCAT从站控制器提供。
    只有从站处于连接和运行的状态这个CoE目录才会被显示。
  • offline: EtherCAT 从站信息文件 ESI/XML包含 CoE默认数据.
    CoE目录只显示包含在ESI文件中的信息 (e.g. "Beckhoff EL5xxx.xml")。

Advanced 按钮用于切换这两种显示。

在图7中 CoE索引x100A EL3204的固件版本为03

图 7: 显示 EL3204固件版本

(A) TwinCAT 2.11 指示当前显示 Online CoE 目录 如果当前不是这样, 可以进入 Advanced Settings (B) Online选项 然后双击 AllObjects. 显示所有的Online目录。

升级控制器固件 *.efw

说明 		CoE 目录
由控制器管理的Online CoE目录存储在专用的EEPROM中，这个目录通常在固件更新时不会被改变。

为了更新从站控制固件，选中 Online， 见图8

图 8: 固件更新

如果没有Beckhoff技术支持指导话，请按如下步骤进行。

  • 切换从站到 INIT (A)
  • 切换从站到BOOTSTRAP
  • 检查当前状态 (B, C)
  • 下载新 *efw 文件
  • 下载完成后切换到 INIT状态，然后切换到 OP状态
  • 从站重上电一次

FPGA 固件文件 *.rbf

如果是 FPGA芯片负责处理EtherCAT通讯，可以通过更新 *.rbf文件来完成升级。.

  • 控制器固件 处理 I/O信号
  • FPGA 固件 处理EtherCAT 通信 (仅针对采用 FPGA芯片的端子模块)

包括在端子模块的序列号的固件版本号包含这两个固件组件。 如果其中一个固件更新，那这个版本号就会被更新。

通过System Manager查看版本

在TwinCAT System Manager查看FPGA固件版本。 选中EtherCAT 卡 (本例中的 Device 2) 然后选择 Online 标签

Reg:0002 列分别用十六进制和十进制显示了每个EtherCAT设备的固件版本。

图 9: FPGA固件版本确认

如果 Reg:0002列不显示，在表格中右键然后选择Properties...

图 10: 弹出菜单Properties

Advanced Settings对话框显示哪些列可以被显示。 在 Diagnosis/Online View下 '0002 ETxxxx Build'选中复选框，使FPGA固件版本可以显示。

图 11: 高级设置对话框

更新

更新 FPGA固件

  • EtherCAT耦合器 FPGA固件版本为11或以上;
  • E-bus端子模块FPGA固件版本为10或以上。

更早的固件件版本只能由制造商来更新！

升级EtherCAT设备

在TwinCAT System Manager中选择你想升级FPGA固件的端子模块 (本例 terminal 5: EL5001) 然后
点击EtherCAT中的 Advanced Settings按钮。

图 12: 选择高级设置对话框

Advanced Settings对话框显示。 在 ESC Access/E²PROM/FPGA点击 Write FPGA 按钮,

图 13: 选择写FPGA对话框

选择新 FPGA固件文件 (*.rbf) 然后下载到 EtherCAT设备。

注意 		小心设备损坏!
EtherCAT设备的固件更新过程中不能中断！

如果下载过程被取消，电源断开或是Ethernet连接中断，那此EtherCAT设备只能由制造商来修复！

为了激活新的FPGA固件，EtherCAT设备必须重启（将电源关闭再启动）。

同时更新数台 EtherCAT 设备

如果设备有相同的固件文件/ESI，那么几台设备的固件和ESI描述可以同步更新。

图 14: 多重选择和固件更新

选择需要的从站然后在BOOTSTRAP模式下执行固件的更新。


技术支持与售后

Beckhof f 及其合作伙伴遍布世界各地，可为您提供全方位的技术支持与服务，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff 分公司及代表处

有关 Beckhoff 产品的本地技术支持和服务信息，请联系当地的 Beckhoff 分公司和代表处！

有关 Beckhoff 在全球各地分公司和代理商的地址，您可以登录Beckhoff 的官方网站：
http://www.beckhoff.com

此外，您也可以在该网站上查看更多关于 Beckhoff 组件的文档资料。

Beckhoff 总部

德国倍福自动化有限公司

Eiserstr. 5
33415 Verl
德国

电话 | +49(0)5246/963-0
传真： | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff 技术支持

Beckhoff为您提供全面的技术支持，除了Beckhoff 具体产品的应用以外，还包括更广泛的服务：

  • 技术支持
  • 复杂自动化系统的设计、编程和调试
  • 各种 Beckhoff 系统组件培训方案
热线： | +49(0)5246/963-157
传真： | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心提供全方位的售后技术服务:

  • 现场服务
  • 维修服务
  • 零部件服务
  • 热线服务
热线： | +49(0)5246/963-460
传真： | +49(0)5246/963-479
e-mail: | service@beckhoff.com