EL41xx - Analog Output Terminals

BECKHOFF Fieldbus Components

文件材料

2 通道模拟输出终端

EL4102 (0 V to +10 V, 2通道)

EL4112 (0 mA to 20 mA, 2通道)

EL4112-0010 (-10 mA to +10 mA, 2通道)

EL4122 (4 mA to 20 mA, 2通道)

EL4132 (-10 V to +10 V, 2通道)

EL4104 (0 V to +10 V, 4通道)

EL4114 (0 mA to 20 mA, 4通道)

EL4124 (4 mA to 20 mA, 4通道)

EL4134 (-10 V to +10 V, 4通道)

版本: 2.5
日期: 2011-08-15

EtherCAT® 是注册商标和专利技术， Beckhoff Automation GmbH, Germany的许可。


EL41xx - Documentation issue status

BECKHOFF EL41xx : Foreword

文档版本

版本 | 注释
2.5 | - 增加固件兼容表和技术数据
2.4 | - 增加章节“电流输出”
2.3 | - 增加EL4104, EL4114, EL4124, EL4134
2.2 | - 增加操作模式
2.1 | - 增加技术数据
2.0 | - 增加EL4112-0010, 增加技术数据
1.2.0 | - 增加对象描述, 增加计算实例
1.0.1 | - 升级版本号
1.0 | - 更新基本功能原则
0.1 | - EL41xx 的第一个临时文件


版本说明

BECKHOFF: 前言

EtherCAT 设备版本说明

命名方法

BECKHOFF EtherCAT

  • 系列关键字
  • 类型
  • 版本
  • 子版本
例子 | 系列 | 类型 | 版本 | 子版本
EL3314-0000-0016 | EL 端子模块 (12 mm, 非可插拔式连接) | 3314 (4-通道 热电偶端子模块) | 0000 (基本类型) | 0016
CU2008-0000-0000 | CU 设备 | 2008（8口快速以太网交换机) | 0000 (基本类型) | 0000
ES3602-0010-0017 | ES 端子模块 (12 mm, 非可插拔式连接) | 3602 (2-通道电压测量) | 0010 (高精度版本) | 0017

说明

  • 订货号由以下组成
    - 系列关键字
    - 类型
    - 版本
  • 子版本 表示技术改进过程
    原则上高子版本兼容底子版本，特殊除外
    每个修订版通常有一个相关XML的描述（ESI,EtherCAT Slave信息），可以在Beckhoff官网下载。
  • 类型，版本，子版本都以十进制数表示

序列号

Beckhoff EtherCAT 设备有一个8位数的序列号, 印刷在设备上或标签上。 序列号标明了出厂时的状态

序列号说明

序列号结构 KK YY FF HH

KK - 生产周 (CW, 日历周)
YY - 生产年
FF - 固件版本
HH - 硬件版本

序列号例子: 12 06 3A 02:

12 - 第 12周生产
06 - 2006 年生产
3A - 固件版本 3A
02 - 硬件版本 02

序列号举例

图 1: EL6688 EL 端子模块

图 2: CU2016 交换机

图 3: EK1100 EtherCAT 耦合器


EL4102, EL4132 - Introduction

BECKHOFF EL4102, EL4132: Product Overview

EL4102, EL4132 - 介绍

2通道模拟输出端子0 V to +10 V或-10 V to +10 V

EL4102模拟输出端子在0 V到+10 V范围之间发出信号。
EL4132模拟输出端子在-10 V到+10 V范围之间发出信号。
电压分辨率为16位，并电气隔离。终端的输出通道有一个共同的接地电位。运行LEDs显示数据与EtherCAT耦合器互换。

LEDs

LED | 颜色 | 意义
运行 | 绿 | 这个LED显示终端在工作状态：
 |  | 关 | EtherCAT状态机状态: INIT = 初始化终端或者引导 =终端固件升级功能。
 |  | 闪烁 | EtherCAT状态机状态: PREOP = 设置邮箱通信和不同的标准设置。
 |  | 单闪 | EtherCAT状态机状态: SAFEOP = 同步管理通道检查和分布式时钟。输出保持在安全操作模式下。
 |  | 开 | EtherCAT状态机状态: OP = 正常工作模式，可以使用邮箱和过程数据通信。

如果超过一个RUN LED亮着，它们的功能相同。

连接

端点 | No. | 注释
Output 1 | 1 | 输出1
+24 V | 2 | 没有连接
GND | 3 | 内部接地 (内部接地)
Shield | 4 | PE接触(与端点8内部连接)
Output 2 | 5 | 输出2
+24 V | 6 | 没有连接
GND | 7 | I内部接地(与端点3内部连接)
Shield | 8 | PE接触 (与端点4内部连接)


EL4102, EL4132 - Technical data

BECKHOFF EL4102, EL4132: Product Overview

EL4102, EL4132 - 技术数据

技术数据 | EL4102 | EL4132
输出的数量 | 2
信号电压 | 0 V to +10 V (短路保护) | -10 V to +10 V (短路保护)
精确度 | ± 0,1 % 相对于满刻度值
分辨率 | 16位
转换时间 | 大约40 µs (快速模式大约25 µs)
负载 | > 5 kΩ
电源输出 | 通过 E-bus
分布式时钟 | (从EL4102-0000-1017) | (从EL4102-0000-1017)
输出电流消耗 (通过E-bus) | 每次输出最大15 mA (规定的最大负载)
内部E-bus电路的电源电压 | 通过E-bus
E-bus的电流消耗 | 类型210 mA
电气隔离 | 500 Vrms (E-bus/信号电压)
过程映像位宽 | 输出: 2 x 16位数据
配置 | 无地址设置，通过TwinCAT系统管理器配置
重量 | 大约55 g
工作温度 | 0 °C ... + 55 °C
存储温度 | -25 °C ... + 85 °C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm
安装 | 35毫米的安装导轨符合EN 50022标准
抗振动/抗冲击性能 | 符合EN60068-2-6/EN 60068-2-27/29
EMC防电阻爆裂/防静电 | 符合EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认可 | CE Ex UL


EL4112, EL4112-0010, EL4122 - Introduction

BECKHOFF EL4112, EL4112-0010, EL4122: Product Overview

EL4112, EL4122 - 介绍

2通道模拟输出端子0 mA到20 mA, -10到+10 mA或4到20 mA

EL4112模拟输出端子在0 mA到20 mA范围之间发出信号。
EL4112-0010模拟输出端子在-10 mA 到+10 mA范围之间发出信号。
EL4122模拟输出端子在4 mA到20 mA范围之间发出信号。
电压分辨率为16位， 并电气隔离。终端的输出通道有一个共同的接地电位。运行LEDs显示数据与EtherCAT耦合器互换。

LEDs

LED | 颜色 | 意义
运行 | 绿 | 这个LED显示终端在工作状态：
 |  | 关 | EtherCAT状态机状态: INIT = 初始化终端或者引导 =终端固件升级功能。
 |  | 闪烁 | EtherCAT状态机状态: PREOP = 设置邮箱通信和不同的标准设置。
 |  | 单闪 | EtherCAT状态机状态: SAFEOP = 同步管理通道检查和分布式时钟。输出保持在安全操作模式下。
 |  | 开 | EtherCAT状态机状态: OP = 正常工作模式，可以使用邮箱和过程数据通信。

如果超过一个RUN LED亮着，它们都是同一个功能。

连接

Terminal point | No. | Comment
Output 1 | 1 | 输出1
+24 V | 2 | +24 V (与端点6内部连接并接负电)
GND | 3 | 内部接地(与端点7内部连接)
Shield | 4 | PE 接触(与端点8内部连接)
Output 2 | 5 | 输出2
+24 V | 6 | +24 V (与端点2内部连接并接负电)
GND | 7 | 内部接地(与端点3内部连接)
Shield | 8 | PE接触(与端点4内部连接)


EL4112, EL4112-0010, EL4122 - Technical data

BECKHOFF EL4112, EL4112-0010, EL4122: Product Overview

EL4112, EL4112-0010, EL4122 - 技术数据

技术数据 | EL4112 | EL4112-0010 | EL4122
输出的数量 | 2
每条通道的信号电压 | 0 to 20 mA (短路保护) | -10 to +10 mA (短路保护) | 4 to 20 mA (短路保护)
精确度 | ± 0,2 % 相对于满刻度值 | ± 0,3 % 相对于满刻度值 (负载 200 Ω) | ± 0,2 % 相对于满刻度值
分辨率 | 16 bit
转换时间 | 大约40 µs (快速模式大约25 µs)
负载 | < 500 Ω
分布式时钟 | (从EL4102-0000-1017) | (从EL4102-0000-1017) | (从 EL4102-0000-1017)
电源输出 | 通过电源接触
负载电压的电流消耗 (电源触电) | 类型15 mA + 输出电流
内部E-bus电路的电源电压 | 通过E-bus
E-bus的电流消耗 | 类型190 mA
电气隔离 | 500 Veff (E-Bus/电压保护)
过程映像位宽 | 输出: 2 x 16 位数据
配置 | 无地址设置，通过TwinCAT系统管理器配置
重量 | 大约55 g
工作温度 | 0 °C ... + 55 °C
存储温度 | -25 °C ... + 85 °C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm (宽度对齐: 12 mm)
安装 | 35毫米的安装导轨符合EN 50022标准
抗振动/抗冲击性能 | 符合EN60068-2-6/EN 60068-2-27/29
EMC防电阻爆裂/防静电 | 符合EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置. | 任意
认可 | CE Ex UL


EL4104, EL4134 - Introduction

BECKHOFF EL4104, EL4134: Product Overview

EL4104, EL4134 -介绍

4通道模拟输出端子0 V to +10 V或-10 V to +10 V

EL4104和EL4134模拟输出端子在0 V到+10 V和-10 V到+10 V范围之间发出信号。电压分辨率为16位， 并电气隔离。终端的输出通道有一个共同的接地电位。输出级由24V电压供应，运行LEDs显示数据与EtherCAT耦合器互换。

LEDs

LED | 颜色 | 意义
运行 | 绿 | 这个LED显示终端在工作状态：
 |  | 关 | EtherCAT状态机状态: INIT = 初始化终端或者引导 =终端固件升级功能。
 |  | 闪烁 | EtherCAT状态机状态: PREOP = 设置邮箱通信和不同的标准设置。
 |  | 单闪 | EtherCAT状态机状态: SAFEOP = 同步管理通道检查和分布式时钟。输出保持在安全操作模式下。
 |  | 开 | EtherCAT状态机状态: OP = 正常工作模式，可以使用邮箱和过程数据通信。

如果超过一个RUN LED亮着，它们都是同一个功能

连接EL4104

端点 | No. | 注释
Output 1 | 1 | 输出1
GND | 2 | 接地
Output 3 | 3 | 输出1
GND | 4 | 接地
Output 2 | 5 | 输出2
GND | 6 | 接地
Output 4 | 7 | 输出1
GND | 8 | 接地

连接EL4134

端点 | No. | 注释
Output 1 | 1 | 输出1
0 V | 2 | 0 V ( 端点4, 6, 8内部连接并接负电)
Output 3 | 3 | 输出3
0 V | 4 | 0 V ( 端点2, 6, 8内部连接并接负电)
Output 2 | 5 | 输出2
0 V | 6 | 0 V ((端点2, 4, 8内部连接并接负电)
Output 4 | 7 | 输出4
0 V | 8 | 0 V ((端点2, 4, 6内部连接并接负电)


EL4104, EL4134 - Technical data

BECKHOFF EL4104, EL4134: Product Overview

EL4104, EL4134 - 技术数据

Technical data | EL4104 | EL4134
输出的数量 | 4
信号电压 | 0 V to +10 V (短路保护) | -10 V to +10 V (短路保护)
精确度 | ± 0,1 % 相对于满刻度值
分辨率 | 16位
转换时间 | 大约80 µs
负载 | > 5 kΩ
电源输出 | 通过 E-bus
分布式时钟 | 是
输出电流消耗 (通过E-bus) | 通过电源触点
内部E-bus电路的电源电压 | 通过E-bus
E-bus的电流消耗 | 类型260 mA | 类型260 mA
电气隔离 | 500 Veff (E-Bus/保护电压)
过程映像位宽 | 输出 4 x 16 位数据
配置 | 没有地址设定, 通过TwinCAT系统管理配置
重量 | 大约 65 g
工作温度 | 0 °C ... + 55 °C
存储温度 | -25 °C ... + 85 °C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm (宽度对齐: 12 mm)
安装 | 35毫米的安装导轨符合EN 50022标准
抗振动/抗冲击性能 | 符合EN60068-2-6/EN 60068-2-27/29
EMC防电阻爆裂/防静电 | 符合EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认可 | CE Ex UL


EL4114, EL4124 - Introduction

BECKHOFF EL4114, EL4124: Product Overview

EL4114, EL4124 - 介绍

通道模拟输出端子0 mA到20 mA或4 mA到20 mA

EL4114和EL4124模拟输出端子在 0到20 mA和4 mA到20 mA范围之间发出信号。电压分辨率为16位， 并电气隔离。终端的输出通道有一个共同的接地电位。输出级由24 V电源供电。运行LEDs显示数据与EtherCAT耦合器互换。

LEDs

LED | 颜色 | 意义
运行 | 绿 | 这个LED显示终端在工作状态：
 |  | 关 | EtherCAT状态机状态: INIT = 初始化终端或者引导 =终端固件升级功能。
 |  | 闪烁 | EtherCAT状态机状态: PREOP = 设置邮箱通信和不同的标准设置。
 |  | 单闪 | EtherCAT状态机状态: SAFEOP = 同步管理通道检查和分布式时钟。输出保持在安全操作模式下。
 |  | 开 | EtherCAT状态机状态: OP = 正常工作模式，可以使用邮箱和过程数据通信。

如果超过一个RUN LED亮着，它们都是同一个功能。

连接

端点 | No. | 注释
Output 1 | 1 | 输出1
0 V | 2 | 0 V ( 端点4, 6, 8内部连接并接负电)
Output 3 | 3 | 输出3
0 V | 4 | 0 V ( 端点2, 6, 8内部连接并接负电)
Output 2 | 5 | 输出2
0 V | 6 | 0 V ((端点2, 4, 8内部连接并接负电)
Output 4 | 7 | 输出4
0 V | 8 | 0 V ((端点2, 4, 6内部连接并接负电)


EL4114, EL4124 - Technical data

BECKHOFF EL4114, EL4124: Product Overview

EL4114, EL4124 - 技术数据

技术数据 | EL4114 | EL4124
输出的数量 | 4
每条通道的信号电压 | 0 mA to 20 mA (短路保护) | 4 mA to 20 mA (短路保护)
精确度 | ± 0,2 %相对于满刻度值
分辨率 | 16 bit (包括信号)
转换时间 | 接近80 µs
负载 | < 350 Ω (短路保护f)
分布式时钟 | 是
电源输出 | 通过电源接触
内部E-bus电路的电源电压 | 通过 E-bus
E-bus的电流消耗 | 类型190 mA
电气隔离 | 500 Veff (E-Bus/电压保护))
过程映像位宽 | 输出: 4 x 16 位数据
配置 | 无地址设置，通过TwinCAT系统管理器配置
重量 | 大约65 g
工作温度 | 0 °C ... + 55 °C
存储温度 | -25 °C ... + 85 °C
相对湿度 | 95%, 无冷凝
尺寸 | 大约15 mm x 100 mm x 70 mm (宽度对齐: 12 mm)
安装 | 35毫米的安装导轨符合EN 50022标准
抗振动/抗冲击性能 | 符合EN60068-2-6/EN 60068-2-27/29
EMC防电阻爆裂/防静电 | 符合EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置. | 任意
认可 | CE Ex UL


Start

BECKHOFF EL44xx: Product overview

开始

调试:

  • 安装EL44xx在 "Mounting and wiring"章节中有解释
  • TwinCAT中配置EL44xx 在 "Commissioning"章节中有解释


EtherCAT Grundlagen

BECKHOFF EL5101: Basics communication

EtherCAT基础

请参考“EtherCAT System Documentation”章节的现场总线基本要素。


EtherCAT 接线

BECKHOFF EtherCAT: 通信基础

EtherCAT 布线 – 接线

两台EtherCAT设备间电缆长度不能超过100米。 这与快速以太网技术一致，因为超过这个电缆的长度，会使信号衰减。允许的最长连接长度是5 + 90 + 5米。 详见 对 EtherCAT/Ethernet的设计建议.

电缆和接头

只有以太网连接器（电缆+插头）符合EN 50173 或ISO/IEC 11801至少category 5（CAt5)才可以连接EtherCAT设备。 EtherCAT用4根线来进行信号传输。

例如，EtherCAT用RJ45插头。 其引线分配符合以太网标准(ISO/IEC 8802-3)。

针脚 | 导体颜色 | 信号 | 描述
1 | 黄 | TD + | Transmission Data +
2 | 橙 | TD - | Transmission Data -
3 | 白 | RD + | Receiver Data +
6 | 蓝 | RD - | Receiver Data -

由于实现自动电缆检测，可以在Beckhoff的EtherCAT设备之间，使用对称或交叉电缆。

说明 		推荐电缆
适于连接EtherCAT设备的电缆可以在 Beckhoff 官网上找到!

E-Bus 电源供给

总线耦合器可以通过E-bus系统将5V电压供给EL端子； 一个耦合器可以提供2A电流。 每个EL端子要消耗多少E-bus电流，可以从网站或样本里得到资料。 如果所用的端子模块的电流总和大于耦合器的提供能力，那么就需要增加E-bus电源模块(例如 EL9400) 在端子模块中的合适位置。

在TwinCAT 系统管理中会显示出E-bus预先计算好的电流理论最大值。 如果电流不足将会显示一个感叹号； 那么就需要在这个位置之前加一个电源模块。

图 1: 系统管理中电流的计算值

注意 		小心! 可能故障
在同一个端子模块组中，所有的EtherCAT端子的E-bus供电必须有相同的对地电势。


看门狗设置说明

ELxxxx 总线端子模块装有一个安全装置（看门狗）在发生数据传输中断一定时间后关闭输出。
EL2xxx总线端子模块的EtherCAT从站控制器(ESC)装有2个看门狗：

  • SM 看门狗 (默认: 100 ms)
  • PDI 看门狗 (默认: 100 ms)

SM 看门狗 (SyncManager 看门狗)

SyncManager 看门狗将会在每次EtherCAT成功通讯之后复位。 如果和终端模块没有EtherCAT数据传输的时间长于SM看门狗的设定时间，例如：在发生线路中断时，看门狗会触发并将输出设为FALSE。 端子模块的 OP状态不受影响 看门狗只会在成功进行EtherCAT数据传输之后复位。 设置上述的监视时间。

SyncManager看门狗在EtherCAT方面，监视ESC过程数据通讯的正确性。

PDI 看门狗 (过程数据看门狗)

如果EtherCAT从站控制器(ESC)与PDI看门狗没有数据传输的时间长于PDI看门狗的设定时间，就会激活PDI看门狗。
PDI (Process Data Interface) 是ESC和本地EtherCAT从站处理器之间的内部接口。 PDI 看门狗可用于监视此通信是否成功。

PDI看门狗在应用方面，监视ESC过程数据通讯的正确性。

图 1 EtherCAT tab -> Advanced Settings -> Behavior

倍增器

每个看门狗通过本地端子循环接收脉冲，由监视倍增器拆分。

1/25 MHz * (看门狗倍增器 + 2) = 100 µs (倍增器默认设置为 2498)

SM看门狗默认设置是1000相当于释放时间是100ms。

倍增数值+2相当于40ns倍数代表了看门狗的时间。
倍增器可以修改，以适应在更大范围内的看门狗时间。

例子"设定 SM 看门狗"

复选框使能手动设定看门狗时间。 如果设定了输出且EtherCAT通信中断，SM 看门狗将在设定时候到后复位输出。 修改这个设置以适应较慢的EtherCAT主站或更长的扫描周期。 默认SM看门狗设定为100 ms. 设定范围 0..65535. 加上倍增器范围是1~65535涵盖了看门狗0~170秒的周期。

计算

倍增数 = 2498 → 看门狗基准时间 = 1 / 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM 看门狗 = 10000 → 10000 * 100 µs = 1 second 看门狗监视时间

小心 		小心! 可能出现未定义状态!
只能在端子版本-0016上实现通过设定SM看门狗=0 来关闭SM看门狗功能。
在之前的版本这项功能不能使用。

小心 		小心! 设备损坏和可能出现未定义状态！
如果在SM看门狗激活之后，输入数字0，看门狗就会关闭。
这时如果通信中断了那么输出就不会被复位。


CoE-接口

CoE接口是 EtherCAT 设备的参数设定接口。 在CAN-over-EtherCAT (CoE)的管理机构中，特定的固件参数可以在网上或EtherCAT的离线参数中获得。

CoE接口的详细信息可以在Beckhoff 网站上 EtherCAT system documentation 中找到。


分布时钟

分布式时钟代为EtherCAT从站控制器（ESC)中的本地时钟，有如下的特性：

• 单位 1 ns
• 零点1.1.2000 00:00
• 大小 64 位 (最多支持 584 年; 有些 EtherCAT 从站只提供对32位的支持, 即大约4.2S)
• EtherCAT主站会自动同步主站时钟和EhterCAT总线中的本地时钟，精度达< 100 ns。

更详细的信息参考EtherCAT system description.


KLxxxx, KSxxxx, ELxxxx, ESxxxx - 连接系统

BECKHOFF 现场总线组件: 安装和接线

连接系统

警告 		小心电击危险和损坏设备！
在安装，拆卸和连线之前确保总线终端处于安全的断开状态!

概述

总线端子系统为不同的设备提供不同的最优连接：

  • KLxxx和ELxxxx系列接线端子模块连接器和电子元件封装在同一个外壳中。
  • KSxxxx 和 ESxxxx系列接线端子模块采用可插拔的连接器使更换时不需要接线。
  • 高密度端子模块系列 (HD Terminals)连接器和电子元件封装在同一个外壳中，封装密度更高。

标准接线

KLxxx和Elxxx端子系列经过多年测试。
集成无螺丝弹簧压紧技术，提供了快速简单的装配。

可插拔式接线

KSxxx和ESxxx端子系列的特点是可插拔式连接。
KS系列的安装和接线方式与KLxxxx 和 ELxxxx 系列类似。
KS/ES端子系列可以使插拔式连接器从外壳上完整移走便于维护。
拉起 解锁条可以把下部的模块从导轨上移除.
插入新的模块装上带线的连接器
节省安装时间减少接线错误

端子模块的尺寸基本相同，只有很小的变化。 新的连接器增加了约3mm 端子模块的最大高度保持不变

扎线环有助于扎紧电线，避免电线在拔下连接器时缠绕。

线径位于 0.08 mm2 和 2.5 mm2 都可以用弹簧连接器.

KSxxxx 和 ESxxxx 系列模块的型号命名方式 KLxxxx 和 ELxxxx 系列相同.

高密度端子模块 (HD Terminals)

KLx8xx 系列总线端子模块有16个连接点，是特别紧凑的设计，是传统12 mm 总线端子模块连接点数量的2倍。 硬导线和压了线套的导线可以直接插入弹簧接线孔而不需要工具。

说明 		高密度模块接线
高密度端子模块KLx8xx 和 ELx8xx 系列没有对应的可插拔连接器系列。

说明 		超声 “焊接" 导线
可以使用超声波“粘合”（超声波焊接）导体来连接标准或高密度端子模块。
在这种情况下, 请注意 下面线径说明表!

接线

连接 ELxxxx / KLxxxx 标准接线端子和 ESxxxx / KSxxxx可插拔式连接器

最多可以连接8根线到总线端子模块，把线扎在总线端子模块连接器上。 端子连接采用弹簧力连接技术。 根据下面的步骤来接线：

  1. 用螺丝刀插入位于接口上方的方形孔来打开弹簧接线端子。
  2. 现在电线可以毫不费力的直接插入圆形孔。
  3. 当拔掉螺丝刀后弹簧端口会自动合上，将接线永久牢固的接上。

端子模块外壳 | ELxxxx, KLxxxx | ESxxxx, KSxxxx
线径 | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
剥线长度 | 8 ... 9 mm | 9 ... 10 mm

高密度端子模块 ELx8xx, KLx8xx (HD)

单芯硬线连接HD端子模块的接点只需要剥线之后直接插入即可，不需要额外的工具。 导线可以用螺丝刀卸下。 下表为对线径的要求。

端子模块外壳 | ELx8xx, KLx8xx (HD)
线径 (conductors with a wire end sleeve) | 0.14... 0.75 mm2
线径 (单芯硬线) | 0.08 ... 1.5 mm2
线径 (细导线) | 0.25 ... 1.5 mm2
线径 (超声 “焊接" 导线) | 只能 1.5 mm2 (见 说明!)
剥线长度 | 8 ... 9 mm

Shielding

说明 		屏蔽
模拟传感器和执行器总是用屏蔽双绞线相连。


TwinCAT System Manager - Configuration

BECKHOFF TwinCAT系统管理器: 配置

通过TwinCAT system manager配置

(TwinCAT 版本 2.10.0 (Build 1241), 使用EL5001 ，以固件版本 0.7 为例)

在TwinCAT system manager的左边窗口中, 点击你需要的配置 (例如： EL5001 终端6).

在TwinCAT system manager的右边窗口 可以看到不同的选项卡。.

General 选项卡

名称 | EtherCAT 设备的名称
Id | EtherCAT 设备的数量
Type | EtherCAT 设备类型
Comment | 添加评论
Disabled | 停用EtherCAT 设备
Create symbols | 仅当控制柜是激活的，才有权通过ADS进入到EtherCAT从站

EtherCAT 选项卡

Type | EtherCAT 设备类型
Product/Revision | EtherCAT 设备的产品号和版本号
Auto Inc Addr. | EtherCAT 设备的自动增加. 通过物理位置，这可以用来访问每个EtherCAT 设备。当Ethercat主机给设备分配地址时，将在启动阶段使用自动增加地址。第一个EtherCAT从站将拥有地址 0000hex.。其他从站地址将依次减1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | EtherCAT 从站的固定地址.。这地址由EtherCAT主站在启动阶段分配。要修改默认值，将控制柜标记于输入区域的左侧。
Previous Port | 连接着的 EtherCAT 设备的名称和端口。如果在不改变设备顺序的情况下，能通过另一个设备连接该设备I，那么这个结合区域将被激活，并且将选择连接着的EtherCAT设备。
Advanced Settings | 这个按钮能打开高级设置

底下的链接能连上EtherCAT设备的主页。

Process Data 选项卡

过程数据的配置。从站的输入和输出数据将被表示成硬件协议PDO.如果EtherCAT从站支持的话，用户可以通过PDO分配来选择PDO并且修改独立的PDO内容 。

同步管理

列出同步管理的配置。
如果EtherCAT 设备有mailbox, SM0将被用于mailbox输出(MbxOut) ， SM1 为mailbox输入(MbxIn).
SM2 为输出过程数据(outputs) ，SM3 (inputs) 为输入过程数据。

选择了一个输入后，相应的PDO分配将在PDO 分配 显示

PDO 分配

PDO的分配选定的同步管理器。这里列出了此同步管理器类型中定义的所有的PDO:

  • 如果输出的同步管理器（输出）在同步管理器列表中选择，显示所有RxPDOs。
  • 如果输入的同步管理器（输入）在同步管理器列表中选择，显示所有TxPDOs。

所选条目是参与的过程中数据传输的PDO。在系统管理器的树形图显示这些PDO的EtherCAT设备的变量。 在PDO列表中变量的名称和PDO参数的名称相同。如果PDO分配列表中的条目无效（未选中，灰色），这表明是从PDO分配中排除的输入。为了能够做选择一个灰色显示的PDO，先要取消当前选定的PDO。

注意 		激活PDO的分配
如果你更改了PDO分配，为了激活新的PDO分配，
  • EtherCAT从站需要通过PS状态过渡周期运行(运行前安全业务) (请参阅 联机选项卡),
  • 系统管理器中重新载入EtherCAT从站( [image] 按钮)

PDO 列表

这EtherCAT设备支持所有的PDO列表。选定的PDO的内容显示在PDO的内容列表。 PDO的配置可以通过双击一个条目进行修改。

列 | 描述
Index | PDO 索引
Size | PDO 的尺寸（以字节为单位）
Name | PDO的名称 如果这个PDO被分配到同步管理器, 它显示为一个从站变量。
Flag | F | 固定内容：本PDO的内容是固定的，不能被系统管理员改动。
 | M | 强制性的PDO. PDO是强制性的，因此必须被分配到同步管理器! 因此，此PDO不能从PDO分配列表中删除
SM | 同步管理PDO分配。如果这个项目是空的，这个PDO将不是数据流量的一部分。
SU | 同步分配的PDO单元。

PDO 的内容

表示PDO的内容。如果PDO未设置标志F,则可以修改内容。

下载

如果该设备是智能mailbox，PDO的配置和PDO的分配可以下载到设备中。 这是一项可选功能，不是所有的EtherCAT从站都支持。

PDO 的分配

如果此复选框被选中，在PDO分配列表中以配置的PDO分配将会下载到设备上启动。需要发送到设备的命令，请查看 启动 选项卡。

PDO 的配置

如果此复选框被选中，各自的PDO（如PDO的列表和PDO的内容所示）的配置将下载到EtherCAT从站。

Startup 选项卡

EtherCAT从站如果有一个mailbox，并支持在EtherCAT（CoE）或EtherCAT协议的伺服驱动器的CANopen“启动”选项卡上显示。此标签表明下载请求在启动期间被发送到mailbox。它也可以添加新的mailbox并在列表中显示。下载请求被发送到从站的顺序与在列表中的顺序相同

列 | 描述
Transition 过渡到该请求被发送。这可以是：
  • 提前运行过渡到安全运行 (PS)
  • 安全运行过渡到运行(SO)

如果过渡是在封闭的“<>”（如：<PS>），mailbox要求是固定的，不能修改或删除用户.
Protocol | mailbox协议类型
Index | 对象的索引
Data | 下载此对象的日期
Comment | 对于请求的描述将被发送至mailbox
Move Up | 将选定的请求上移一位
Move Down | 将选定的请求下移一位
New | 在启动时添加一个新的下载请求
Delete | 删除所选条目
Edit | 编辑一个已存在的请求

CoE - Online 选项卡

额外CoE - 如果EtherCAT从站在CoE协议中支持CANopen，将显示 Online 选项卡。此对话框列出的从站对象（SDO上传）的内容，使用户能够在这个名单中修改对象的内容。独立的EtherCAT设备对象的详细信息，可以在设备中特定对象的描述中发现。

对象列表显示
列 | 描述
Index | 对象的索引和子索引
Name | 对象的名称
Flag | RW | 对象可读，并且数据可以写入对象（读/写）
 | RO | 对象可读，但是数据不能写入（只读）
 | P | 增设一个P标志识别过程数据对象
Value | 对象的值
Update List | 更新列表中所有对象
Auto Update | 如果此复选框被选中时，对象的内容会自动更新。
Advanced | “高级”按钮打开“高级设置”对话框。在这里您可以指定哪些对象在列表中显示.

Online - via SDO Information | 如果选择此按钮，包含在从站的对象列表中的对象通过SDO将从从站上传。下面的列表可用于指定哪些对象类型需要上传。
Offline - via EDS File | 如果选择此按钮，在对象列表中的对象将从用户提供的EDS文件读取。

Online 选项卡

状态机

Init | 此按钮尝试设置EtherCAT设备的初始状态。
Pre-Op | 此按钮尝试设置EtherCAT设备到 预操作状态。
Op | 此按钮尝试设置EtherCAT设备的操作状态。
Bootstrap | 此按钮尝试设置EtherCAT设备的引导状态。
Safe-Op | 此按钮尝试设置EtherCAT设备的安全运行状态。
Clear Error | 此按钮尝试删除故障显示. 如果EtherCAT从站在状态变化过程中失败，它 将设置一个错误标志。 例如: EtherCAT从站处于 PREOP状态 (操作前). 主站请求SAFEOP状态 (安全运行). 如果从站在改变状态过程中失败，它将设置一个错误标志。当前状态将显示成 ERR PREOP. 当按下Clear Error 按钮，错误标志被删除，当前状态将重新变为 PREOP。
Current State | 指示EtherCAT设备的当前状态。
Requested State | 指示EtherCAT设备要求的状态。

DLL 的状态

指示 EtherCAT从机的独立端口的DLL状态。DLL有以下四种不同的状态：

状态 | 描述
No Carrier / Open | 无载波信号在端口可用，但该端口是开放的
No Carrier / Closed | 无载波信号在端口可用，但该端口是关闭的
Carrier / Open | 载波信号在端口可用，但该端口是开放的
Carrier / Closed | 载波信号在端口可用，但该端口是关闭的

在EtherCAT的文件访问

Download | 点击这个按钮，一个文件可以被写入到EtherCAT设备
Upload | 点击这个按钮，一个文件可以从EtherCAT设备读出.

184


EL41x2 - Basis function principles (version A)

BECKHOFF EL41x2: Commissioning

基本功能—正常功能范围

索引
• 同步控制

• 操作模式和设定

- watchdog
- 制造商和用户特定输出值之间的切换
- 激活用户规格化
- 显示
- 代码字开发者

同步控制(SM)

PDO任务

SM2, PDO 任务 0x1C12
索引 | 索引排除PDOs | 尺寸 (byte.bit) | 名称 | PDO索引
1600 (默认) | - | 2.0 | 输出(频道1) | 索引 3001:01 -模拟输出
1601 (默认) | - | 2.0 | 输出(频道2) | 索引 3002:01 - 模拟输出

标签。1: PDO 同步管理任务

操作模式和设定

Watchdog激活 / 去活 (索引4061:01, 通道1; 索引 40A1:01, 通道2)

watchdog计时器不能使用。万一通信中断模拟输出值不复位到制造商或用户缺省值。
如果该位不设置，按照制造商或用户缺省值输出（延时）。

出厂值和用户特定输出值之间的切换(索引 4061:02, 通道 1;索引 40A1:02 通道 2)

模拟输出值可以设定用户特定值，比如在控制器通信失败的情况下（索引4063）。对像 4061:02 (通道1) 或对象40A1:02 (通道2) 激活选项(值： TRUE)；输出值指定为对象4063 (通道1)或对象 40A3 (通道2)。如果这个功能无效（对象4061:02的通道1或对象40A1:02的通道2的值是FALSE）, 输出出厂值(EL4102, EL4132: 0 V, EL4112: 0 mA, EL4122: 4 mA) 。
watchdog计时器的标准输出值不消除（对象4061:02的通道1或对象40A1:02的通道2的值是TRUE）。

激活用户规格化 (索引4061:03, 通道1; 索引40A1:03 通道2)

用户规格化激活 (置位):

例子: 计算和校准输出值

终端把原始值从d/A转换器放置到DAC原始值对象4041:01 或 4081:01 (RAM). 输出值校准为制造商校准值。用户规格化可以按此校准：

YH = (XDAC - BK) x AK | 制造商校准后的输出值为 (当特定的对象4061:03或40A1:03不活动时，相当于Yout)
YHN = (XDAC - BK) x AKN | 只对于EL4132: 制造商校准后的输出值为负 (当特定的对象4061:03或40A1:03不活动时，相当于 Y-out)
YA = YH x AW x 2-16+ BW | 输出值按照用户规格化
例子: 输出范围限制为-5V到+5V (EL4132), 计算用户规格化的增益系数
YA = YH x AW x 2-16 + BW

Û (YA - BW ) / (YH x 2-16 ) = AW

(16383 - 0) / 32767 x 2-16

= AW = 32767
         上限为+5 V 时，计算用户规格化的增益系数
[相当于-5V的低电压 (取消主要信号)]
YA = 16383dec | 符合预期的电压上限值为+5 V
YH = 32767dec | 符合初始的上限值为+10 V
BW = 0dec | 符合补偿值为用户规格化
AW= 32767dec | 符合增益系数为用户规格化(系数0.5)
例子: 输出范围从-3 V到+10 V的调节器 (EL4132), 计算用户规格化的OFFSET值
YA = YH x AW x 2-16 + BW

Û YA - YH x AW x 2-16 = BW

(- 9831) - ( - 32769 x 65536 x 2-16 )

= BW = 22938
         下限电压为-3 V时，计算用户规格化的OFFSET值
YA = (- 9831dec) | 符合预期的电压下限值为 -3V
YH = (-32769dec) | 符合初始的下限值为-10V
AW = 65536dec | 符合增益系数为用户规格化(系数1)
BW = 22938dec | 符合补偿值+7V为用户规格化

注意 		补偿值
调节输出的补偿值线性偏移为-10 V / -10 mA（下限）或者+10 V / +10 mA（上限）
说明
简称 | 名称 | 对象索引
XDAC | D/A转换器输出值 | -
Yout | 过程数据控制器 | -
BK | 制造商校准补偿（只能用于产品代码 4040或4080的对象设置） | 4042:01, 4082:01
AK | 制造商校准增益（只能用于产品代码 4040或4080的对象设置） | 4042:02, 4082:02
AKN | 制造商校准的负增益[只对于EL4132] （只能用于产品代码 4040或4080的对象设置） | 4042:03, 4082:03
BW | 用户规格化的补偿（可以通过索引4061:01或40A1:01下的对象4061或40A1激活） | 4062:01, 40A2:01
AW | 用户规格化的增益（可以通过索引4061:01或40A1:01下的对象4061或40A1激活） | 4062:02, 40A2:02

介绍, 索引 4061:04, 4061:05 (通道1); Index 40A1:04, 40A1:05 (通道2)

在交付状态输出电压测量值以2进制补码的格式显示（带符号整数）。
索引 4061:04 , 4061:05 (通道1) 和索引 40A1:04 , 40A1:05 (通道2) 给电压值变化提供一个可能的改变方法（带符号整数, 量级符号格式或绝对值）。

输出信号 | 值
EL4102 | 十进制 | 十六进制
0 V | 0 | 0x0000
5 V | 16383 | 0x3FFF
10 V | 32767 | 0x7FFF
输出信号 | 值
EL4112 | 十进制 | 十六进制
0 mA | 0 | 0x0000
10 mA | 16383 | 0x3FFF
20 mA | 32767 | 0x7FFF
输出信号 | 值
EL4112-0010 | 十进制 | 十六进制
-10 mA | -32768 | 0x8000
-5 mA | -16383 | 0xC001
0 mA | 0 | 0x0000
5 mA | 16383 | 0x3FFF
10 mA | 32767 | 0x7FFF
输出信号 | 值
EL4122 | 十进制 | 十六进制
4 mA | 0 | 0x0000
12 mA | 16383 | 0x3FFF
20 mA | 32767 | 0x7FFF
输出信号 | 值
EL4132 | 十进制 | 十六进制
-10 V | -32768 | 0x8000
-5 V | -16383 | 0xC001
0 V | 0 | 0x0000
5 V | 16383 | 0x3FFF
10 V | 32767 | 0x7FFF

注意 		制造商代码
制造商保留对终端的基本校准的权力。因此目前保留制造商的代码。


Object description and parameterization - normal functional range

BECKHOFF EL41x2: Commissioning

Object的描述和参数化 - 普通功能范围

注意 		EtherCAT XML 设备描述
这个描述相当于展示EtherCAT XML设备描述的CoE对象。强烈推荐从Beckhoff官网 (http://www.beckhoff.com/english/Default.htm?download/elconfg.htm) 下载最新版本的相应XML文件并按照安装说明安装。

注意 		参数化
端子模块参数受CoE标签 (双击相关对象) 或过程数据标签(PDO分配)指挥。

介绍

CoE概述包括不同应用程序中的对象：

  • 在调试过程中需要参数化的对象。
  • 用来正常运行的对象，例如通过ADS access。
  • 要求内部设置的对象 (可能是固定的)

下一个段落首先描述对象正常工作的要求，其次是其他对象的完整描述。

调试对象

索引1011还原默认参数
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1011:0 | 还原默认参数 | 对象的长度 | UINT8 | RO | 0x01 (1dec)
1011:01 | 分索引001 | 如果对象被设成 "0x64616F6C" ("设定模拟量") 所有特定端子模块对象被还原到出厂设置。 | UINT32 | RW | 0x00000000 (0dec)

通道1

索引 4061 功能位 1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4061:0 | 功能位 1 | 对象长度 | UINT8 | RO | 0x05 (5dec)
4061:01 | watchdog计时器输出失败 | TRUE watchdog计时器无效。通信失败时，拟输出值设置为制造商或用户的默认值。 FALSE watchdog开启。通信失败时，拟输出值设置为制造商或用户的默认值。 | BOOLEAN | RW | 0x00 (0dec)
4061:02 | 使用户默认输出 | TRUE 如果watchdog计时器触发, 用户规定输出值输出(对象4063) FALSE 如果watchdog计时器触发，输出制造商的值; EL4102, EL 4112-0010, EL4132: 0 V, EL4112: 0 mA, EL4122: 4 mA | BOOLEAN | RW | 0x00 (0dec)
4061:03 | 使能用户规格化 | TRUE 用户规格化开启(对象4062) ; 输出值就被设为计算范例中描述的值。 FALSE 用户规格化无效。 | BOOLEAN | RW | 0x00 (0dec)
4061:04 | MSB信号使能绝对值 | TRUE 输出值为信号量级格式 (EL4132, EL4112-0010): 0x7FFF = +10 Volt resp. +10 mA 0xFFFF = -10 Volt resp. -10 mA FALSE 输出值为二进制带符号整数 (EL4132, EL4112-0010): 0x7FFF = +10 Volt resp. +10 mA 0x8000 = -10 Volt resp. -10 mA | BOOLEAN | RW | 0x00 (0dec)
4061:05 | 使能绝对值 | TRUE 在负数范围, 输出值为绝对值(EL4132, EL4112-0010) : 0x7FFF = 10 Volt resp. 10 mA 0x8001 = 10 Volt resp. 10 mA FALSE 输出值被定义在对象4061:04. | BOOLEAN | RW | 0x00 (0dec)
索引 4062 用户规格化 1
索引 | 名称 | 含义 |  | 数据类型 | 标记 | 默认值
4062:0 | 用户规格化 1 | 对象的长度 |  | UINT8 | RO | 0x02 (2dec)
4062:01 | 补偿 | 这些对象包括了用户规格化。 这个规模通过 4061:03激活。 输出值就被设为计算范例中描述的值。 | 增益修正， 用户规格化通道 1 | INT16 | RW | 0x0000 (0dec)
4062:02 | 增益 |  | 增益修正， 用户规格化通道 1 这个增益代表不动点格式，系数为2-16. 系数1的值相当于65535dec (0x00010000). | INT32 | RW | 0x00007FFF (32767dec)
索引 4063 默认值输出1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4063:0 | 默认值输出1 | 用户默认输出值的定义为如果watchdog计时器循环通信激活就输出。 | INT16 | RW | 0x0000 (0dec)

通道 2

索引 4061 功能位 2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4061:0 | 功能位 2 | 对象长度 | UINT8 | RO | 0x05 (5dec)
4061:01 | watchdog计时器输出失败 | TRUE watchdog计时器无效。通信失败时，拟输出值设置为制造商或用户的默认值。 FALSE watchdog开启。通信失败时，拟输出值设置为制造商或用户的默认值。 | BOOLEAN | RW | 0x00 (0dec)
4061:02 | 使能用户默认输出 | TRUE 如果watchdog计时器触发, 用户规定输出值输出(对象4063) FALSE 如果watchdog计时器触发，输出制造商的值; EL4102, EL 4112-0010, EL4132: 0 V, EL4112: 0 mA, EL4122: 4 mA | BOOLEAN | RW | 0x00 (0dec)
4061:03 | 使能用户规格化 | TRUE 用户规格化开启(对象4062) ; 输出值就被设为计算范例中描述的值。 FALSE 用户规格化无效。 | BOOLEAN | RW | 0x00 (0dec)
4061:04 | MSB信号使能绝对值 | TRUE 输出值为信号量级格式 (EL4132, EL4112-0010): 0x7FFF = +10 Volt resp. +10 mA 0xFFFF = -10 Volt resp. -10 mA FALSE 输出值为二进制带符号整数 (EL4132, EL4112-0010): 0x7FFF = +10 Volt resp. +10 mA 0x8000 = -10 Volt resp. -10 mA | BOOLEAN | RW | 0x00 (0dec)
4061:05 | 使能绝对值 | TRUE 在负数范围, 输出值为绝对值(EL4132, EL4112-0010) : 0x7FFF = 10 Volt resp. 10 mA 0x8001 = 10 Volt resp. 10 mA FALSE 输出值被定义在对象4061:04. | BOOLEAN | RW | 0x00 (0dec)
索引 4062 用户规格化 2
索引 | 名称 | 含义 |  | 数据类型 | 标记 | 默认值
4062:0 | 用户规格化 2 | 对象的长度 |  | UINT8 | RO | 0x02 (2dec)
4062:01 | 补偿 | 这些对象包括了用户规格化。 这个规模通过 4061:03激活。 输出值就被设为计算范例中描述的值。 | 增益修正， 用户规格化通道 2 | INT16 | RW | 0x0000 (0dec)
4062:02 | 增益 |  | 增益修正， 用户规格化通道 2 这个增益代表不动点格式，系数为2-16. 系数1的值相当于65535dec (0x00010000). | INT32 | RW | 0x00007FFF (32767dec)
索引 4063 默认值输出2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4063:0 | 默认值输出1 | 用户默认输出值的定义为如果watchdog计时器循环通信激活就输出。 | INT16 | RW | 0x0000 (0dec)

正常工作对象

正常工作范围的EL4104没有这样的功能

完整的概述

标准对象 (0x1000-0x1FFF)

所有EtherCAT从站的标准设置是同一个含义。

索引 1000 设备类型
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1000:0 | 设备类型 | EtherCAT 从站的设备类型: 低字包含CoE配置支持(5001).。高字包含模块配置与模块设备配置一致 。 | UINT32 | RO | 0x01901389 (26219401dec)
索引 1008 设备名称
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1008:0 | 设备名称 | EtherCAT 从站的设备名称 | STRING | RO | EL40xx-0000

索引 1009 硬件版本
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1009:0 | 硬件版本 | EtherCAT 从站的硬件版本 | STRING | RO | 07
索引 100A 软件版本
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
100A:0 | 软件版本 | EtherCAT 从站的固件版本 | STRING | RO | 05
索引 1018 Identity
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1018:0 | 定义 | 包含定义EtherCAT从站的信息 | UINT8 | RO | 0x04 (4dec)
1018:01 | 制造商ID | EtherCAT从站的的制造商ID | UINT32 | RO | 0x00000002 (2dec)
1018:02 | 产品代码 | EtherCAT从站的产品代码 | UINT32 | RO | 0x10243052 (270807122dec)
1018:03 | 修正 | EtherCAT从站的修正值, 低字 (Bit 0-15) 表明特殊功能端子模块值; 高字(Bit 16-31) 引用设备描述。 | UINT32 | RO | 0x03F80000 (66584576dec)
1018:04 | 序列号 | EtherCAT从站的序列号, 低字的低位(Bit 0-7) 包含生产年份，低字的高位包含 (Bit 8-15) 生产周信息， 高字 (Bit 16-31) 是 0 . | UINT32 | RO | 0x00000000 (0dec)
索引 10F0 备份参数处理
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
10F0:0 | 备份参数处理 | 包含备份词目的标准化上传和下载的信息 | UINT8 | RO | 0x01 (1dec)
10F0:01 | 校验和 | 对所有EtherCAT从站备份词目的校验和 | UINT32 | RO | 0x00000000 (0dec)
索引 1400 RxPDO 01 映射
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1400:0 | RxPDO 01 映射 | PDO 参数 RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | 排除 RxPDOs | RxPDOs (RxPDO映射对象的索引), 不能一起传输给 RxPDO 1 | OCTET-STRING[8] | RO | 02 16 03 16 10 16 00 00
索引 1401 RxPDO 02 映射
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1400:0 | RxPDO 02 映射 | PDO 参数 RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1400:06 | 排除 RxPDOs | RxPDOs (RxPDO映射对象的索引), 不能一起传输给 RxPDO 2 | OCTET-STRING[8] | RO | 02 16 03 16 10 16 00 00
索引 1402 AO RxPDO-Par Ch.1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1400:0 | AO RxPDO-Par Ch.1 | PDO 参数 RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1400:06 | 排除 RxPDOs | RxPDOs (RxPDO映射对象的索引), 不能一起传输给 RxPDO 3 | OCTET-STRING[8] | RO | 02 16 03 16 10 16 00 00
索引 1403 AO RxPDO-Par Ch.2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1400:0 | AO RxPDO-Par Ch.2 | PDO 参数 RxPDO 4 | UINT8 | RO | 0x06 (6dec)
1400:06 | 排除 RxPDOs | RxPDOs (RxPDO映射对象的索引), 不能一起传输给 RxPDO 4 | OCTET-STRING[8] | RO | 02 16 03 16 10 16 00 00
索引 1410 RxPDO 017 映射
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1400:0 | RxPDO 017 映射 | PDO 参数 RxPDO 17 | UINT8 | RO | 0x06 (6dec)
1400:06 | 排除 RxPDOs | RxPDOs (RxPDO映射对象的索引), 不能一起传输给 RxPDO 17 | OCTET-STRING[8] | RO | 00 16 01 16 02 16 03 16
索引 1600 RxPDO 01 映射
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1600:0 | RxPDO 01 映射 | PDO 映射 RxPDO 1 | UINT8 | RO | 0x01 (1dec)
1600:01 | Sub索引 001 | 1. PDO 映射条目(对象 0x3001 (通道1), 条目0x01 (输出) | UINT32 | RO | 0x3001:01, 16
索引 1601 RxPDO 02 映射
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1601:0 | RxPDO 02 映射 | PDO 映射 RxPDO 2 | UINT8 | RO | 0x01 (1dec)
1601:01 | Sub索引 001 | 1. PDO 映射条目 (对象 0x3002 (通道 2), 条目 0x01 (输出) | UINT32 | RO | 0x3002:01, 16
索引 1602 AO RxPDO-Map Ch.1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1602:0 | AO RxPDO-Map Ch.1 | PDO 映射 RxPDO 3 | UINT8 | RO | 0x01 (1dec)
1602:01 | 分索引 001 | 1. PDO 映射条目 (对象 0x7010 (AO 输出 Ch.1), 条目 0x01 (模拟输出) | UINT32 | RO | 0x7010:01, 16
索引 1603 AO RxPDO-Map Ch.2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1603:0 | AO RxPDO-Map Ch.2 | PDO 映射 RxPDO 4 | UINT8 | RO | 0x01 (1dec)
1603:01 | Sub索引 001 | 1. PDO 映射条目 (对象0x7020 (AO 输出 Ch.2), 条目 0x01 (模拟输出) | UINT32 | RO | 0x7020:01, 16
索引 1610 RxPDO 017 映射
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1610:0 | RxPDO 017 映射 | PDO 映射 RxPDO 17 | UINT8 | RO | 0x02 (2dec)
1610:01 | Sub索引 001 | 1. PDO 映射条目 (对象 0x6001, 条目 0x01) | UINT32 | RO | 0x6001:01, 16
1610:02 | Sub索引 002 | 2. PDO 映射条目 (对象 0x6001, 条目 0x02) | UINT32 | RO | 0x6001:02, 16
索引 1C00 同步管理类型
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C00:0 | 同步管理类型 | 同步管理通道的用途 | UINT8 | RO | 0x04 (4dec)
1C00:01 | 分索引 001 | 同步管理类型通道 1: 写邮箱 | UINT8 | RO | 0x01 (1dec)
1C00:02 | 分索引 002 | 同步管理类型通道2: 读邮箱 | UINT8 | RO | 0x02 (2dec)
1C00:03 | 分索引 003 | 同步管理类型通道3: 写过程数据 (输出) | UINT8 | RO | 0x03 (3dec)
1C00:04 | 分索引 004 | 同步管理类型通道 4: 读过程数据 (输入) | UINT8 | RO | 0x04 (4dec)
索引 1C12 RxPDO 分配
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C12:0 | RxPDO 分配 | PDO 输出分配 | UINT8 | RW | 0x02 (2dec)
1C12:01 | 分索引 001 | 1. 指定的 RxPDO (包含对应的RxPDO映射对象) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | 分索引 002 | 2. 指定的 RxPDO (包含对应的RxPDO映射对象) | UINT16 | RW | 0x1601 (5633dec)
索引 1C13 TxPDO 分配
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C13:0 | TxPDO 费喷 | PDO 分配输入 | UINT8 | RW | 0x00 (0dec)
索引 1C32 SM 输出参数
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C32:0 | SM 输出参数 | 输出的同步参数 | UINT8 | RO | 0x07 (7dec)
1C32:01 同步模式 实际同步模式:
  • 0: 空转
  • 1: 与SM 2同步
  • 2: 与SYNC0 直流同步
  • 3: 与SYNC1 直流同步
 UINT16 RW 0x0001 (1dec)
1C32:02 周期 周期 (纳秒):
  • 空转: 当地计时器的周期
  • 与SM 2 同步: 主站的周期
  • 直流模式: SYNC0/SYNC1周期
 UINT32 RW 0x00000000 (0dec)
1C32:03 | 时间顺序 | 在 SYNC0 和输出值之间的时间(纳秒，直流模式) | UINT32 | RW | 0x00000000 (0dec)
1C32:04 支持同步模式 支持同步模式:
  • Bit 0 = 1: 支持空转
  • Bit 1 = 1: 支持与SM 2 同步
  • Bit 2-3 = 01: 支持直流模式
  • Bit 4-5 = 10: 改变SYNC1的输出(直流模式)
  • Bit 14 = 1: 动态时间 (能被1C32:08测量)
 UINT16 RO 0x8007 (32775dec)
1C32:05 | 最小周期 | 支持最小周期(纳秒) | UINT32 | RO | 0x00000000 (0dec)
1C32:06 | 计算并复制时间 | 在SYNC0和 SYNC1之间的最小时间 (纳秒，直流模式) | UINT32 | RO | 0x00000000 (0dec)
1C32:08 指令
  • 0: 停止时间测量
  • 1: 开始时间测量

1C32:03, 1C32:05, 1C32:06, 1C32:09 会更新至最大测量值

UINT16 RW 0x0000 (0dec)
1C32:09 | 延迟时间 | 在SYNC1和输出值之间的时间(纳秒，直流模式) | UINT32 | RO | 0x00000000 (0dec)
1C32:0B | SM 偏差计算 | 在运作状态中，SM偏差的值(直流模式) | UINT16 | RO | 0x0000 (0dec)
1C32:0C | 周期溢出计算 | 在运作状态中，周期溢出的值 | UINT16 | RO | 0x0000 (0dec)
1C32:0D | 最小距离计算 | SYNC0 和SYNC1 的最小距离 (直流模式) | UINT16 | RO | 0x0000 (0dec)
1C32:20 | 同步错误 | TRUE: 在最后一个周期中，同步出错 (直流模式) | BOOLEAN | RO | 0x00 (0dec)
索引 3001 通道1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
3001:0 | 通道 1 | 对象长度 | UINT8 | RO | 0x01 (1dec)
3001:01 | 输出 | 输出过程数据通道1 | INT16 | RO | 0x0000 (0dec)
索引 3001 通道2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
3001:0 | 通道 2 | 对象长度 | UINT8 | RO | 0x01 (1dec)
3001:01 | 输出 | 输出过程数据通道2 | INT16 | RO | 0x0000 (0dec)
索引 4040 生厂商代码字 1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4040:0 | 生厂商代码字 1 | 保留 | UINT16 | RW | 0x0000 (0dec)
索引 4041 DAC 初值 1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4041:0 | DAC 初值 1 | 对象长度 | UINT8 | RO | 0x01 (1dec)
4041:01 | 分索引 1 | 这是一个电路DAC初值。他转化为输出值通过计算机增益和补偿校准。 | UINT16 | RO | 0x0000 (0dec)
索引 4042 校准数据 1

注意 		校准
制造商保留对端子模块的基本校准的权力。因此保留生产商的校准。
索引 | 名称 | 含义 |  | 数据类型 | 标记 | 默认值
4062:0 | 用户规格化 1 | 对象的长度 |  | UINT8 | RO | 0x02 (2dec)
4062:01 | 补偿 | 这些对象包括了用户规格化。 这个规模通过 4061:03激活。 输出值就被设为计算范例中描述的值。 | 增益修正， 用户规格化通道 1 | INT16 | RW | 0x0000 (0dec)
4062:02 | 增益 |  | 增益修正， 用户规格化通道 1 这个增益代表不动点格式，系数为2-16. 系数1的值相当于65535dec (0x00010000). | INT32 | RW | 0x00007FFF (32767dec)
索引 | 名称 | 含义 |  | 数据类型 | 标记 | 默认值
4042:0 | 校准数据 1 | 对象的长度 |  | UINT8 | RO | 0x02 (2dec)
4042:01 | 补偿 | 这个对象用来修正确定输出值的容差 。 这个值只有在生厂商代码字(对象 4040)设定时再能被改变。 | 修正补偿通道1 | INT16 | RW | 0x0000 (0dec)
4042:02 | 增益 |  | 修正增益通道1 | UINT16 | RW | 0xF0CC (61644dec)
Index 4080 生产商代码字 2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4080:0 | 生产商代码字 2 | 保留 | UINT16 | RW | 0x0000 (0dec)
Index 4081 DAC 初值 2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4081:0 | DAC 初值 2 | 对象长度 | UINT8 | RO | 0x01 (1dec)
4081:01 | 分索引 2 | 这是一个电路DAC初值。他转化为输出值通过计算机增益和补偿校准。 | UINT16 | RO | 0x0000 (0dec)
Index 4082 校准数据 2

注意 		校准
制造商保留对端子模块的基本校准的权力。因此保留生产商的校准。
索引 | 名称 | 含义 |  | 数据类型 | 标记 | 默认值
4082:0 | 校准数据 2 | 对象的长度 |  | UINT8 | RO | 0x02 (2dec)
4082:01 | 补偿 | 这些对象包括了用户规格化。 这个规模通过 40A1:03激活。 输出值就被设为计算范例中描述的值。 | 增益修正， 用户规格化通道 2 | INT16 | RW | 0x0000 (0dec)
4082:02 | 增益 |  | 增益修正， 用户规格化通道 2 这个增益代表不动点格式，系数为2-16. 系数1的值相当于65535dec (0x00010000). | UINT16 | RW | 0xF0CC (61644dec)

配置文件的特定对象(0x6000-0xFFFF)

支持5001配置文件特定对象的所有EtherCAT从站有相同的含义。

索引 6411 输出
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
6411:0 | 输出 | 对象的长度 | UINT8 | RO | 0x02 (2dec)
6411:01 | 分索引 001 | 输出过程数据通道1 | INT16 | RO | 0x0000 (0dec)
6411:02 | 分索引 002 | 输出过程数据通道2 | INT16 | RO | 0x0000 (0dec)


EL40xx - Grundlagen zur Funktion

BECKHOFF EL41x2: Commissioning

基本功能—增强的功能范围

Contents
• 同步控制

• 操作模式和设定

- watchdog
- 制造商和用户特定输出值之间的切换
- 激活用户规格化
- 显示
- 代码字开发者

同步控制(SM)

PDO任务

SM2, PDO 任务 0x1C12
索引 | 索引排除PDOs | 尺寸 (byte.bit) | 名称 | PDO索引
1600 (延时) | 1602 1603 1610 | 2.0 | 通道 1 | 索引 3001:01 - 输出通道 1
1601 (延时) | 1602 1603 1610 | 2.0 | 通道 2 | 索引 3002:01 - 输出通道 2
1602 | 1600 1601 1610 | 2.0 | AO Rx-PDO-Map Ch.1 | 索引7010:01 - 模拟输出通道 1
1603 | 1600 1601 1610 | 2.0 | AO Rx-PDO-Map Ch.2 | 索引7020:01 - 模拟输出通道 2
1610 | 1600 1601 1602 1603 | 4.0 | RxPDO 017 mapping | 索引 6411:01 - 输出通道 1 索引 6411:02 - 输出通道 2

标签 1: PDO 同步管理任务

操作模式和设定

介绍, 索引 8010:02 (通道 1), 索引 8020:02 (通道 2)

在交付状态输出电压测量值以2进制补码的格式显示（带符号整数）。
索引 8010:02/8020:02 (通道1) 给电压值变化提供一个可能的改变方法（带符号整数, 量级符号格式或绝对值）。

输出信号 | 值
EL4102 | 十进制 | 十六进制
0 V | 0 | 0x0000
5 V | 16383 | 0x3FFF
10 V | 32767 | 0x7FFF
输出信号 | 值
EL4112 | 十进制 | 十六进制
0 mA | 0 | 0x0000
10 mA | 16383 | 0x3FFF
20 mA | 32767 | 0x7FFF
输出信号 | 值
EL4112-0010 | 十进制 | 十六进制
-10 mA | -32768 | 0x8000
-5 mA | -16383 | 0xC001
0 mA | 0 | 0x0000
5 mA | 16383 | 0x3FFF
10 mA | 32767 | 0x7FFF
输出信号 | 值
EL4122 | 十进制 | 十六进制
4 mA | 0 | 0x0000
12 mA | 16383 | 0x3FFF
20 mA | 32767 | 0x7FFF
输出信号 | 值
EL4132 | 十进制 | 十六进制
-10 V | -32768 | 0x8000
-5 V | -16383 | 0xC001
0 V | 0 | 0x0000
5 V | 16383 | 0x3FFF
10 V | 32767 | 0x7FFF

注意 		描述
• | 带符号整数： 输出值是以2进制补码形式出现的。 16位的最大显示范围= -32768 .. +32767 例子: 1000 0000 0000 0000bin = 0x8000hex = - 32768dec 1111 1111 1111 1110bin = 0xFFFEhex = - 2dec 1111 1111 1111 1111bin = 0xFFFFhex = - 1dec 0000 0000 0000 0001bin = 0x0001hex = +1dec 0000 0000 0000 0010bin = 0x0002hex = +2dec 0111 1111 1111 1111bin = 0x7FFFhex = +32767dec
• | 无符号整数： 输出值显示分辨率为16位。 16位的最大显示范围: 0 .. +65535dec
• | 信号最高有效位的绝对值： 输出信号以信号级形式呈现。 16位的最大显示范围:= -32767 .. +32767 例子: 1111 1111 1111 1111bin = 0xFFFFhex = - 32767dez 1000 0000 0000 0010bin = 0x8002hex = - 2dez 1000 0000 0000 0001bin = 0x8001hex = - 1dez 0000 0000 0000 0001bin = 0x0001hex = +1dez 0000 0000 0000 0010bin = 0x0002hex = +2dez 0111 1111 1111 1111bin = 0x7FFFhex = +32767dez
• | 绝对值 负输出值变正（绝对值）

watchdog,索引 8010:05 (通道1), 索引 8020:05 (通道 2)

模拟输出值可以设定用户特定值，比如在控制器通信失败的情况下。在下拉菜单选择"Default watchdog value"。先前进入索引8010:13或8010:13的值是输出。
如果处理用户特定值在某一发生故障的时间内，可以设置watchdog斜坡功能（索引8010:14或8010:14）。输入值是数字量。
在发生故障后的最后一个输出值被设置为“最后输出值“。

校准

激活用户规格化; 索引 8010:01 (通道 1), 索引 8020:01 (通道 2)

用户规格化通过索引8010:01或8020:01激活。通过指数进行参数设定。

• | 8010:11or 8020:11 用户规格化补偿
• | 8010:12or 8020:12 用户规格化增益

制造商补偿; ，索引 8010:08 (通道 1),索引 8020:08 (通道 2)
制造商校准通过80n0:08或8020:08激活。制造商补偿通过索引8010:08或8020:08激活。这个目标的缺省值是”TRUE“。

注意 		制作人代码字
制造商有保留终端基本校准权。制作人代码字因此保留。
• | 801F:01 or 802F:01 偏移补偿
• | 801F:02or 802F:02 增益补偿

用户补偿; 索引 8010:15 (通道l 1),索引 8020:15 (通道 2) 和索引 8010:16 (通道 1), 索引 8020:16 (通道 2)

用户补偿通过索引8010:07或8020:07激活。通过指数进行参数设定。

• | 8010:15or 8020:15 用户偏移补偿
• | 8010:15or 8020:15 用户增益补偿

过程数据计算
终端连续接收过程数据和储存初始值通过对象801E:01或802E:01内的数模转换器。通过制造商校准值计算每个更正后的过程数据传输。然后进行用户规格化（随机的）：
YH = (XDAC - BK) x AK | 制造商校准后的输出值 （如果索引8010:01或8020:01不活动相当于YA0
YA = YH x AW x 2-16 + BW | 输出值更随用户规格化

说明
简称 | 名称 | 对象索引
XDAC | D/A转换器输出值 | 801E:01 resp.. 802E:01
BK | 制造商校准补偿 ( Producer codeword F008 设置时才能使用) | 801F:01 resp.. 802F:01
AK | 制造商校准增益( Producer codeword F008 设置时才能使用) | 801F:02 resp.. 802F:02
BW | 用户规格化补偿 (通过索引8010:01或8020:01再能被激活) | 8010:15 resp.. 8020:15
AW | 用户规格化增益(通过索引8010:01或8020:01再能被激活) | 8010:16 resp.. 8020:16
YA | 输出值 | -

制作人代码字

注意 		制作人代码字
制造商有保留终端基本校准权。制作人代码字因此保留。


Object description and parameterization - enhanced functional range

BECKHOFF EL41x2: Commissioning

Object的描述和参数化 - 加强功能范围

注意 		EtherCAT XML 设备描述
这个描述相当于展示EtherCAT XML设备描述的CoE对象。强烈推荐从Beckhoff官网 (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) 下载最新版本的相应XML文件并按照安装说明安装。

注意 		参数化
端子模块参数受CoE标签 (双击相关对象) 或过程数据标签(PDO分配)指挥。

介绍

CoE概述包括不同应用程序中的对象：

  • 在调试过程中需要参数化的对象。
  • 用来正常运行的对象，例如通过ADS access。
  • 要求内部设置的对象 (可能是固定的)

下一个段落首先描述对象正常工作的要求，其次是其他对象的完整描述。

调试对象

索引1011还原默认参数
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1011:0 | 还原默认参数 | 对象的长度 | UINT8 | RO | 0x01 (1dec)
1011:01 | 分索引001 | 如果对象被设成 "0x64616F6C" ("设定模拟量") 所有特定端子模块对象被还原到出厂设置。 | UINT32 | RW | 0x00000000 (0dec)

配置数据

索引 8010 AO 设置 Ch.1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
8pp0:0 | AO 设定 Ch.1 | 最大分索引 | UINT8 | RO | 0x16 (22dec)
8pp0:01 | 使能用户规格化 | 用户规格化已使能 | BOOLEAN | RW | 0x00 (0dec)
8pp0:02 | 介绍 | 0: 带符号介绍 输出值是带符号数的二进制补码形式。 最大输出范围(16 Bit) = -32768dec .. +32767dec 1: 无符号介绍 最大表示范围 (16 Bit) : 0 .. +65535dec 2: 带最高有效位的绝对值 输出值是数值符号形式。 最大输出范围(16 Bit) = -32767dec .. +32767dec 3: 绝对值 对于负的输出值将变为正值。 | BIT3 | RW | 0x00 (0dec)
8pp0:05 | 看门狗 | 0: 看门狗默认值 默认值有效 (8pp0:13) 1: 看门狗斜坡 默认值有效.(8pp0:14) 2: 最新输出值 如果看门狗有效, 最新的过程数据将被递交 | BIT2 | RW | 0x00 (0dec)
8pp0:07 | 使能用户校准 | 如果位被设置，就是能用户校准 | BOOLEAN | RW | 0x00 (0dec)
8pp0:08 | 使能制造商校准 | 如果位被设置，就是能用户校准 | BOOLEAN | RW | 0x01 (1dec)
8pp0:11 | 补偿 | 用户校准补偿 | INT16 | RW | 0x0000 (0dec)
8pp0:12 | 增益 | 用户校准增益 增益被表示成定点模式,带有因数2-16. 增益的值1相当于 65535dec (0x00010000). | INT32 | RW | 0x00010000 (65536dec)
8pp0:13 | 默认输出 | 默认输出值 | INT16 | RW | 0x0000 (0dec)
8pp0:14 | 默认输出斜坡 | 默认输出斜坡值以 Digit / ms为单位 | UINT16 | RW | 0xFFFF (65535dec)
8pp0:15 | 用户校准补偿 | 用户校准补偿 | INT16 | RW | 0x0000 (0dec)
8pp0:16 | 用户校准增益 | 用户校准增益 | UINT16 | RW | 0xFFFF (65535dec)

Channel 2

索引 8020 AO 设定 Ch.2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
8pp0:0 | AO 设定 Ch.2 | 最大分索引 | UINT8 | RO | 0x16 (22dec)
8pp0:01 | 使能用户规格化 | 用户规格化已使能 | BOOLEAN | RW | 0x00 (0dec)
8pp0:02 | 介绍 | 0: 带符号介绍 输出值是带符号数的二进制补码形式。 最大输出范围(16 Bit) = -32768dec .. +32767dec 1: 无符号介绍 最大表示范围 (16 Bit) : 0 .. +65535dec 2: 带最高有效位的绝对值 输出值是数值符号形式。 最大输出范围(16 Bit) = -32767dec .. +32767dec 3: 绝对值 对于负的输出值将变为正值。 | BIT3 | RW | 0x00 (0dec)
8pp0:05 | 看门狗 | 0: 看门狗默认值 默认值有效 (8pp0:13) 1: 看门狗斜坡 默认值有效.(8pp0:14) 2: 最新输出值 如果看门狗有效, 最新的过程数据将被递交 | BIT2 | RW | 0x00 (0dec)
8pp0:07 | 使能用户校准 | 如果位被设置，就是能用户校准 | BOOLEAN | RW | 0x00 (0dec)
8pp0:08 | 使能制造商校准 | 如果位被设置，就是能用户校准 | BOOLEAN | RW | 0x01 (1dec)
8pp0:11 | 补偿 | 用户校准补偿 | INT16 | RW | 0x0000 (0dec)
8pp0:12 | 增益 | 用户校准增益 增益被表示成定点模式,带有因数2-16. 增益的值1相当于 65535dec (0x00010000). | INT32 | RW | 0x00010000 (65536dec)
8pp0:13 | 默认输出 | 默认输出值 | INT16 | RW | 0x0000 (0dec)
8pp0:14 | 默认输出斜坡 | 默认输出斜坡值以 Digit / ms为单位 | UINT16 | RW | 0xFFFF (65535dec)
8pp0:15 | 用户校准补偿 | 用户校准补偿 | INT16 | RW | 0x0000 (0dec)
8pp0:16 | 用户校准增益 | 用户校准增益 | UINT16 | RW | 0xFFFF (65535dec)

正常工作对象

正常工作范围的EL4104没有这样的功能

完整的概述

标准对象 (0x1000-0x1FFF)

所有EtherCAT从站的标准设置是同一个含义。

索引 1000 设备类型
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1000:0 | 设备类型 | EtherCAT slave的设备类型: 低字包含CoE配置支持(5001).。高字包含模块配置与模块设备配置一致 。 | UINT32 | RO | 0x01901389 (26219401dec)
索引 1008 设备名称
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1008:0 | 设备名称 | EtherCAT 从站的设备名称 | STRING | RO | EL40xx-0000

索引 1009 硬件版本
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1009:0 | 硬件版本 | EtherCAT 从站的硬件版本 | STRING | RO | 07
索引 100A 软件版本
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
100A:0 | 软件版本 | EtherCAT 从站的固件版本 | STRING | RO | 05
索引 1018 Identity
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1018:0 | 定义 | 包含定义EtherCAT从站的信息 | UINT8 | RO | 0x04 (4dec)
1018:01 | 制造商ID | EtherCAT从站的的制造商ID | UINT32 | RO | 0x00000002 (2dec)
1018:02 | 产品代码 | EtherCAT从站的产品代码 | UINT32 | RO | 0x10243052 (270807122dec)
1018:03 | 修正 | EtherCATslave的修正值, 低字 (Bit 0-15) 表明特殊功能端子模块值; 高字(Bit 16-31) 引用设备描述。 | UINT32 | RO | 0x03F80000 (66584576dec)
1018:04 | 序列号 | EtherCAT-Slave的序列号, 低字的低位(Bit 0-7) 包含生产年份，低字的高位包含 (Bit 8-15) 生产周信息， 高字 (Bit 16-31) 是 0 . | UINT32 | RO | 0x00000000 (0dec)
索引 10F0 备份参数处理
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
10F0:0 | 备份参数处理 | 包含备份词目的标准化上传和下载的信息 | UINT8 | RO | 0x01 (1dec)
10F0:01 | 校验和 | 对所有EtherCAT从站备份词目的校验和 | UINT32 | RO | 0x00000000 (0dec)
索引 1400 RxPDO 01 映射
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1400:0 | RxPDO 01 映射 | PDO 参数 RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | 排除 RxPDOs | RxPDOs (RxPDO映射对象的索引), 不能一起传输给 RxPDO 1 | OCTET-STRING[8] | RO | 02 16 03 16 10 16 00 00
索引 1401 RxPDO 02 映射
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1400:0 | RxPDO 02 映射 | PDO 参数 RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1400:06 | 排除 RxPDOs | RxPDOs (RxPDO映射对象的索引), 不能一起传输给 RxPDO 2 | OCTET-STRING[8] | RO | 02 16 03 16 10 16 00 00
索引 1402 AO RxPDO-Par Ch.1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1400:0 | AO RxPDO-Par Ch.1 | PDO 参数 RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1400:06 | 排除 RxPDOs | RxPDOs (RxPDO映射对象的索引), 不能一起传输给 RxPDO 3 | OCTET-STRING[8] | RO | 02 16 03 16 10 16 00 00
索引 1403 AO RxPDO-Par Ch.2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1400:0 | AO RxPDO-Par Ch.2 | PDO 参数 RxPDO 4 | UINT8 | RO | 0x06 (6dec)
1400:06 | 排除 RxPDOs | RxPDOs (RxPDO映射对象的索引), 不能一起传输给 RxPDO 4 | OCTET-STRING[8] | RO | 02 16 03 16 10 16 00 00
索引 1410 RxPDO 017 映射
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1400:0 | RxPDO 017 映射 | PDO 参数 RxPDO 17 | UINT8 | RO | 0x06 (6dec)
1400:06 | 排除 RxPDOs | RxPDOs (RxPDO映射对象的索引), 不能一起传输给 RxPDO 17 | OCTET-STRING[8] | RO | 00 16 01 16 02 16 03 16
索引 1600 RxPDO 01 映射
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1600:0 | RxPDO 01 映射 | PDO 映射 RxPDO 1 | UINT8 | RO | 0x01 (1dec)
1600:01 | Sub索引 001 | 1. PDO 映射条目(对象 0x3001 (通道1), 条目0x01 (输出) | UINT32 | RO | 0x3001:01, 16
索引 1601 RxPDO 02 映射
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1601:0 | RxPDO 02 映射 | PDO 映射 RxPDO 2 | UINT8 | RO | 0x01 (1dec)
1601:01 | Sub索引 001 | 1. PDO 映射条目 (对象 0x3002 (通道 2), 条目 0x01 (输出) | UINT32 | RO | 0x3002:01, 16
索引 1602 AO RxPDO-Map Ch.1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1602:0 | AO RxPDO-Map Ch.1 | PDO 映射 RxPDO 3 | UINT8 | RO | 0x01 (1dec)
1602:01 | 分索引 001 | 1. PDO 映射条目 (对象 0x7010 (AO 输出 Ch.1), 条目 0x01 (模拟输出) | UINT32 | RO | 0x7010:01, 16
索引 1603 AO RxPDO-Map Ch.2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1603:0 | AO RxPDO-Map Ch.2 | PDO 映射 RxPDO 4 | UINT8 | RO | 0x01 (1dec)
1603:01 | Sub索引 001 | 1. PDO 映射条目 (对象0x7020 (AO 输出 Ch.2), 条目 0x01 (模拟输出) | UINT32 | RO | 0x7020:01, 16
索引 1610 RxPDO 017 映射
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1610:0 | RxPDO 017 映射 | PDO 映射 RxPDO 17 | UINT8 | RO | 0x02 (2dec)
1610:01 | Sub索引 001 | 1. PDO 映射条目 (对象 0x6001, 条目 0x01) | UINT32 | RO | 0x6001:01, 16
1610:02 | Sub索引 002 | 2. PDO 映射条目 (对象 0x6001, 条目 0x02) | UINT32 | RO | 0x6001:02, 16
索引 1C00 同步管理类型
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C00:0 | 同步管理类型 | 同步管理通道的用途 | UINT8 | RO | 0x04 (4dec)
1C00:01 | 分索引 001 | 同步管理类型通道 1: 写邮箱 | UINT8 | RO | 0x01 (1dec)
1C00:02 | 分索引 002 | 同步管理类型通道2: 读邮箱 | UINT8 | RO | 0x02 (2dec)
1C00:03 | 分索引 003 | 同步管理类型通道3: 写过程数据 (输出) | UINT8 | RO | 0x03 (3dec)
1C00:04 | 分索引 004 | 同步管理类型通道 4: 读过程数据 (输入) | UINT8 | RO | 0x04 (4dec)
索引 1C12 RxPDO 分配
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C12:0 | RxPDO 分配 | PDO 输出分配 | UINT8 | RW | 0x02 (2dec)
1C12:01 | 分索引 001 | 1. 指定的 RxPDO (包含对应的RxPDO映射对象) | UINT16 | RW | 0x1600 (5632dec)
1C12:02 | 分索引 002 | 2. 指定的 RxPDO (包含对应的RxPDO映射对象) | UINT16 | RW | 0x1601 (5633dec)
索引 1C13 TxPDO 分配
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C13:0 | TxPDO 费喷 | PDO 分配输入 | UINT8 | RW | 0x00 (0dec)
索引 1C32 SM 输出参数
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C32:0 | SM 输出参数 | 输出的同步参数 | UINT8 | RO | 0x07 (7dec)
1C32:01 同步模式 实际同步模式:
  • 0: 空转
  • 1: 与SM 2同步
  • 2: 与SYNC0 直流同步
  • 3: 与SYNC1 直流同步
 UINT16 RW 0x0001 (1dec)
1C32:02 周期 周期 (纳秒):
  • 空转: 当地计时器的周期
  • 与SM 2 同步: 主站的周期
  • 直流模式: SYNC0/SYNC1周期
 UINT32 RW 0x00000000 (0dec)
1C32:03 | 时间顺序 | 在 SYNC0 和输出值之间的时间(纳秒，直流模式) | UINT32 | RW | 0x00000000 (0dec)
1C32:04 支持同步模式 支持同步模式:
  • Bit 0 = 1: 支持空转
  • Bit 1 = 1: 支持与SM 2 同步
  • Bit 2-3 = 01: 支持直流模式
  • Bit 4-5 = 10: 改变SYNC1的输出(直流模式)
  • Bit 14 = 1: 动态时间 (能被1C32:08测量)
 UINT16 RO 0x8007 (32775dec)
1C32:05 | 最小周期 | 支持最小周期(纳秒) | UINT32 | RO | 0x00000000 (0dec)
1C32:06 | 计算并复制时间 | 在SYNC0和 SYNC1之间的最小时间 (纳秒，直流模式) | UINT32 | RO | 0x00000000 (0dec)
1C32:08 指令
  • 0: 停止时间测量
  • 1: 开始时间测量

1C32:03, 1C32:05, 1C32:06, 1C32:09 会更新至最大测量值

UINT16 RW 0x0000 (0dec)
1C32:09 | 延迟时间 | 在SYNC1和输出值之间的时间(纳秒，直流模式) | UINT32 | RO | 0x00000000 (0dec)
1C32:0B | SM 偏差计算 | 在运作状态中，SM偏差的值(直流模式) | UINT16 | RO | 0x0000 (0dec)
1C32:0C | 周期溢出计算 | 在运作状态中，周期溢出的值 | UINT16 | RO | 0x0000 (0dec)
1C32:0D | 最小距离计算 | SYNC0 和SYNC1 的最小距离 (直流模式) | UINT16 | RO | 0x0000 (0dec)
1C32:20 | 同步错误 | TRUE: 在最后一个周期中，同步出错 (直流模式) | BOOLEAN | RO | 0x00 (0dec)
索引 3001 通道1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
3001:0 | 通道 1 | 对象长度 | UINT8 | RO | 0x01 (1dec)
3001:01 | 输出 | 输出过程数据通道1 | INT16 | RO | 0x0000 (0dec)
索引 3001 通道2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
3001:0 | 通道 2 | 对象长度 | UINT8 | RO | 0x01 (1dec)
3001:01 | 输出 | 输出过程数据通道2 | INT16 | RO | 0x0000 (0dec)
索引 4040 生厂商代码字1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4040:0 | 生厂商代码字 1 | 保留 | UINT16 | RW | 0x0000 (0dec)
索引 4041 DAC 初值 1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4041:0 | DAC 初值 1 | 对象长度 | UINT8 | RO | 0x01 (1dec)
4041:01 | 分索引 1 | 这是一个电路DAC初值。他转化为输出值通过计算机增益和补偿校准。 | UINT16 | RO | 0x0000 (0dec)
索引 4042 校准数据 1

注意 		校准
制造商保留对端子模块的基本校准的权力。因此保留生产商的校准。
索引 | 名称 | 含义 |  | 数据类型 | 标记 | 默认值
4042:0 | 校准数据 1 | 对象的长度 |  | UINT8 | RO | 0x02 (2dec)
4042:01 | 补偿 | 这个对象用来修正确定输出值的容差 。 这个值只有在生厂商代码字(对象 4040)设定时再能被改变。 | 修正补偿通道1 | INT16 | RW | 0x0000 (0dec)
4042:02 | 增益 |  | 修正增益通道1 | UINT16 | RW | 0xF0CC (61644dec)
索引 4061 功能位 1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4061:0 | 功能位 1 | 对象长度 | UINT8 | RO | 0x05 (5dec)
4061:01 | 看门狗计时器输出失败 | TRUE 看门狗计时器无效。通信失败时，拟输出值设置为制造商或用户的默认值。 FALSE 看门狗开启。通信失败时，拟输出值设置为制造商或用户的默认值。 | BOOLEAN | RW | 0x00 (0dec)
4061:02 | 使能用户默认输出 | TRUE 如果看门狗计时器触发, 用户规定输出值输出(对象4063) FALSE 如果看门狗计时器触发，输出制造商的值; EL4102, EL 4112-0010, EL4132: 0 V, EL4112: 0 mA, EL4122: 4 mA | BOOLEAN | RW | 0x00 (0dec)
4061:03 | 使能用户规格化 | TRUE 用户规格化开启(对象4062) ; 输出值就被设为计算范例中描述的值。 FALSE 用户规格化无效。 | BOOLEAN | RW | 0x00 (0dec)
4061:04 | MSB信号使能绝对值 | TRUE 输出值为信号量级格式 (EL4132, EL4112-0010): 0x7FFF = +10 Volt resp. +10 mA 0xFFFF = -10 Volt resp. -10 mA FALSE 输出值为二进制带符号整数 (EL4132, EL4112-0010): 0x7FFF = +10 Volt resp. +10 mA 0x8000 = -10 Volt resp. -10 mA | BOOLEAN | RW | 0x00 (0dec)
4061:05 | 使能绝对值 | TRUE 在负数范围, 输出值为绝对值(EL4132, EL4112-0010) : 0x7FFF = 10 Volt resp. 10 mA 0x8001 = 10 Volt resp. 10 mA FALSE 输出值被定义在对象4061:04. | BOOLEAN | RW | 0x00 (0dec)
索引 4062 用户规格化 1
索引 | 名称 | 含义 |  | 数据类型 | 标记 | 默认值
4062:0 | 用户规格化 1 | 对象的长度 |  | UINT8 | RO | 0x02 (2dec)
4062:01 | 补偿 | 这些对象包括了用户规格化。 这个规模通过 4061:03激活。 输出值就被设为计算范例中描述的值。 | 增益修正， 用户规格化通道 2 | INT16 | RW | 0x0000 (0dec)
4062:02 | 增益 |  | 增益修正， 用户规格化通道 2 这个增益代表不动点格式，系数为2-16. 系数1的值相当于65535dec (0x00010000). | INT32 | RW | 0x00007FFF (32767dec)
索引 4063 默认值输出1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4063:0 | 默认值输出1 | 用户默认输出值的定义为如果看门狗计时器循环通信激活就输出。 | INT16 | RW | 0x0000 (0dec)
索引 4080 生厂商代码字 2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4040:0 | 生厂商代码字 2 | 保留 | UINT16 | RW | 0x0000 (0dec)
索引 4081 DAC 初值 2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4041:0 | DAC 初值 2 | 对象长度 | UINT8 | RO | 0x01 (1dec)
4041:01 | 分索引 2 | 这是一个电路DAC初值。他转化为输出值通过计算机增益和补偿校准。 | UINT16 | RO | 0x0000 (0dec)
索引 4082 校准数据 2

注意 		校准
制造商保留对端子模块的基本校准的权力。因此保留生产商的校准。
索引 | 名称 | 含义 |  | 数据类型 | 标记 | 默认值
4062:0 | 用户规格化 2 | 对象的长度 |  | UINT8 | RO | 0x02 (2dec)
4062:01 | 补偿 | 这些对象包括了用户规格化。 这个规模通过 4061:03激活。 输出值就被设为计算范例中描述的值。 | 增益修正， 用户规格化通道 2 | INT16 | RW | 0x0000 (0dec)
4062:02 | 增益 |  | 增益修正， 用户规格化通道 2 这个增益代表不动点格式，系数为2-16. 系数1的值相当于65535dec (0x00010000). | INT32 | RW | 0x00007FFF (32767dec)
索引 40A1 功能位 2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4061:0 | 功能位 2 | 对象长度 | UINT8 | RO | 0x05 (5dec)
4061:01 | 看门狗计时器输出失败 | TRUE 看门狗计时器无效。通信失败时，拟输出值设置为制造商或用户的默认值。 FALSE 看门狗开启。通信失败时，拟输出值设置为制造商或用户的默认值。 | BOOLEAN | RW | 0x00 (0dec)
4061:02 | 使能用户默认输出 | TRUE 如果看门狗计时器触发, 用户规定输出值输出(对象4063) FALSE 如果看门狗计时器触发，输出制造商的值; EL4102, EL 4112-0010, EL4132: 0 V, EL4112: 0 mA, EL4122: 4 mA | BOOLEAN | RW | 0x00 (0dec)
4061:03 | 使能用户规格化 | TRUE 用户规格化开启(对象4062) ; 输出值就被设为计算范例中描述的值。 FALSE 用户规格化无效。 | BOOLEAN | RW | 0x00 (0dec)
4061:04 | MSB信号使能绝对值 | TRUE 输出值为信号量级格式 (EL4132, EL4112-0010): 0x7FFF = +10 Volt resp. +10 mA 0xFFFF = -10 Volt resp. -10 mA FALSE 输出值为二进制带符号整数 (EL4132, EL4112-0010): 0x7FFF = +10 Volt resp. +10 mA 0x8000 = -10 Volt resp. -10 mA | BOOLEAN | RW | 0x00 (0dec)
4061:05 | 使能绝对值 | TRUE 在负数范围, 输出值为绝对值(EL4132, EL4112-0010) : 0x7FFF = 10 Volt resp. 10 mA 0x8001 = 10 Volt resp. 10 mA FALSE 输出值被定义在对象4061:04. | BOOLEAN | RW | 0x00 (0dec)
索引 40A2 用户规格化 2
索引 | 名称 | 含义 |  | 数据类型 | 标记 | 默认值
4062:0 | 用户规格化 2 | 对象的长度 |  | UINT8 | RO | 0x02 (2dec)
4062:01 | 补偿 | 这些对象包括了用户规格化。 这个规模通过 4061:03激活。 输出值就被设为计算范例中描述的值。 | 增益修正， 用户规格化通道 2 | INT16 | RW | 0x0000 (0dec)
4062:02 | 增益 |  | 增益修正， 用户规格化通道 2 这个增益代表不动点格式，系数为2-16. 系数1的值相当于65535dec (0x00010000). | INT32 | RW | 0x00007FFF (32767dec)
索引 40A3 默认值输出2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
4063:0 | 默认值输出1 | 用户默认输出值的定义为如果看门狗计时器循环通信激活就输出。 | INT16 | RW | 0x0000 (0dec)

配置文件的特定对象(0x6000-0xFFFF)

支持5001配置文件特定对象的所有EtherCAT从站有相同的含义。

索引 6411 输出
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
6411:0 | 输出 | 对象的长度 | UINT8 | RO | 0x02 (2dec)
6411:01 | 分索引 001 | 输出过程数据通道1 | INT16 | RO | 0x0000 (0dec)
6411:02 | 分索引 002 | 输出过程数据通道2 | INT16 | RO | 0x0000 (0dec)
索引 7010 AO 输出 Ch.1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认
7010:0 | AO 输出 Ch.1 | 最大分索引 | UINT8 | RO | 0x01 (1dec)
7010:01 | 模拟输出 | 模拟输出数据 | INT16 | RO | 0x0000 (0dec)
索引 7020 AO 输出 Ch.2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认
7020:0 | AO 输出 Ch.2 | 最大分索引 | UINT8 | RO | 0x01 (1dec)
7020:01 | 模拟输出 | 模拟输出数据 | INT16 | RO | 0x0000 (0dec)
索引 801E AO 内部数据 Ch.1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认
801E:0 | AO 内部 Ch.1 | 最大分索引 | UINT8 | RO | 0x01 (1dec)
801E:01 | DAC 初始值 | DAC 初始值 | UINT16 | RO | 0x0000 (0dec)
索引 801F AO 制造商数据 Ch.1

注意 		校准
制造商保留对端子模块的基本校准的权力。因此保留生产商的校准。
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认
801F:0 | AO 制造商数据 Ch.1 | 最大分索引 | UINT8 | RO | 0x02 (2dec)
801F:01 | 校准补偿 | 校准补偿 | INT16 | RW | 0x0000 (0dec)
801F:02 | 校准增益 | 校准增益 | UINT16 | RW | 0x1EFA (7930dec)
索引 802E AO 内部数据 Ch.2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认
802E:0 | AO 内部数据 Ch.1 | 最大分索引 | UINT8 | RO | 0x01 (1dec)
802E:01 | DAC 初始值 | DAC 初始值 | UINT16 | RO | 0x0000 (0dec)
索引 802F AO 制造商数据 Ch.2

注意 		校准
制造商保留对端子模块的基本校准的权力。因此保留生产商的校准。
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认
802F:0 | AO 制造商数据 Ch.2 | 最大分索引 | UINT8 | RO | 0x02 (2dec)
802F:01 | 校准补偿 | 校准补偿 | INT16 | RW | 0x0000 (0dec)
802F:02 | 校准增益 | 校准增益 | UINT16 | RW | 0x1EFA (7930dec)
索引 F000 模块化设备配置文件
索引 | 名称 | 含义
F000:0 | 模块设备 | 模块设备的一般信息
F000:01 | 模块距离 | 模块距离
F000:02 | 模块的最大值 | 模块的最大值
索引 F008 代码字
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认
F008:0 | 代码字 | 保留 | UINT32 | RW | 0x00000000 (0dec)
索引 F010 Module list
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认
F010:0 | 模块列表 | 最大分索引 | UINT32 | RW | 0x03 (3dec)
F010:01 | 分索引 001 | 保留 | UINT32 | RW | 0x00000000 (0dec)
F010:02 | 分索引 002 | 保留 | UINT32 | RW | 0x00000190 (400dec)
F010:03 | 分索引 003 | 保留 | UINT32 | RW | 0x00000190 (400dec)


EL40xx - Grundlagen zur Funktion

BECKHOFF EL41x4: Commissioning

基本功能

索引
• 同步控制

• 转换时间

• 操作模式和设定

- 显示
- watchdog
- 校准
- 制作人代码字

按照这些功能，EL41x4终端相当于EL41x2的高级功能。

同步控制(SM)

PDO分配

SM2, PDO 分配t 0x1C12
索引 | 索引排除PDOs | 尺寸 (byte.bit) | 名称 | PDO索引
1600 (默认) | - | 2.0 | AO Rx-PDO-Map Ch.1 | 索引7000:01 - 模拟输出通道1
1601 (默认) | - | 2.0 | AO Rx-PDO-Map Ch.2 | 索引 7010:01 - 模拟输出通道2
1602 (默认) | - | 2.0 | AO Rx-PDO-Map Ch.3 | 索引 7020:01 - 模拟输出通道3
1603 (默认) | - | 2.0 | AO Rx-PDO-Map Ch.4 | 索引 7030:01 - 模拟输出通道4

表1: 同步管理PDO分配

转换时间

EL41x4标准的转换时间是290 µs.

4通道输出的输出只是同时的。

分布式时钟

EL41x4能在有和没有分布式时钟时操作，具体看图2的转换

图2: EL41x4到DC模式的转换

DC模式的EL41x4输出值与其他输出装置同步输出值，考虑到DC设定(DC标签 --> 高级设定)和电气转换时间。

关于FW01的注意: 在DC模式下EtherCAT循环时间的操作不可能小于400 µs；EL41x4保持SAFEOP。

操作模式和设定

陈述 (描述);索引 80n0:02

在交付状态标准的输出电压值有两个补充格式显示(带符号整数).
索引80n0:02提供一个可能改变的输出电压表示方法（带符号整数，量级符号格式或绝对值）。

输出信号 | 值
EL4102 | 十进制 | 十六进制
0 V | 0 | 0x0000
5 V | 16383 | 0x3FFF
10 V | 32767 | 0x7FFF
输出信号 | 值
EL4112 | 十进制 | 十六进制
0 mA | 0 | 0x0000
10 mA | 16383 | 0x3FFF
20 mA | 32767 | 0x7FFF
输出信号 | 值
EL4112-0010 | 十进制 | 十六进制
-10 mA | -32768 | 0x8000
-5 mA | -16383 | 0xC001
0 mA | 0 | 0x0000
5 mA | 16383 | 0x3FFF
10 mA | 32767 | 0x7FFF
输出信号 | 值
EL4122 | 十进制 | 十六进制
4 mA | 0 | 0x0000
12 mA | 16383 | 0x3FFF
20 mA | 32767 | 0x7FFF
输出信号 | 值
EL4132 | 十进制 | 十六进制
-10 V | -32768 | 0x8000
-5 V | -16383 | 0xC001
0 V | 0 | 0x0000
5 V | 16383 | 0x3FFF
10 V | 32767 | 0x7FFF

注意
描述
• | 带符号整数： 输出值是以2进制补码形式出现的。 16位的最大显示范围= -32768 .. +32767 例子: 1000 0000 0000 0000bin = 0x8000hex = - 32768dec 1111 1111 1111 1110bin = 0xFFFEhex = - 2dec 1111 1111 1111 1111bin = 0xFFFFhex = - 1dec 0000 0000 0000 0001bin = 0x0001hex = +1dec 0000 0000 0000 0010bin = 0x0002hex = +2dec 0111 1111 1111 1111bin = 0x7FFFhex = +32767dec
• | 无符号整数： 输出值显示分辨率为16位。 16位的最大显示范围: 0 .. +65535dec
• | 信号最高有效位的绝对值： 输出信号以信号量级形式呈现。 16位的最大显示范围:= -32767 .. +32767 例子: 1111 1111 1111 1111bin = 0xFFFFhex = - 32767dez 1000 0000 0000 0010bin = 0x8002hex = - 2dez 1000 0000 0000 0001bin = 0x8001hex = - 1dez 0000 0000 0000 0001bin = 0x0001hex = +1dez 0000 0000 0000 0010bin = 0x0002hex = +2dez 0111 1111 1111 1111bin = 0x7FFFhex = +32767dez
• | 绝对值 负输出值变正（绝对值）

• | 带符号整数: 输出值是以2进制补码形式出现的。 16位的最大显示范围= -32768 .. +32767 例子: 1000 0000 0000 0000bin = 0x8000hex = - 32768dec 1111 1111 1111 1110bin = 0xFFFEhex = - 2dec 1111 1111 1111 1111bin = 0xFFFFhex = - 1dec 0000 0000 0000 0001bin = 0x0001hex = +1dec 0000 0000 0000 0010bin = 0x0002hex = +2dec 0111 1111 1111 1111bin = 0x7FFFhex = +32767dec
• | 无符号整数: 输出值显示分辨率为16位。 16位的最大显示范围: 0 .. +65535dec
• | 信号最高有效位的绝对值： 输出信号以信号量级形式呈现。 16位的最大显示范围= -32767 .. +32767 例子: 1111 1111 1111 1111bin = 0xFFFFhex = - 32767dez 1000 0000 0000 0010bin = 0x8002hex = - 2dez 1000 0000 0000 0001bin = 0x8001hex = - 1dez 0000 0000 0000 0001bin = 0x0001hex = +1dez 0000 0000 0000 0010bin = 0x0002hex = +2dez 0111 1111 1111 1111bin = 0x7FFFhex = +32767dez
• | 绝对值 负输出值变正（绝对值）

watchdog,索引 80x0:05

与控制器的通信中断的情况下，指定输出值可以有3种方法：

  • 索引80n0:05 = 0 "默认watchdog值"; 设置为用户指定值:
    把值输入索引 80n0:13立刻输出。
  • 索引80n0:05 = 1 "watchdog斜坡"; 线性驱动用户的指定值:
    用户指定的驱动器速度[digit/ms]的值80n0:13是80n0:14调整的速度
  • 索引80n0:05 = 2 "最后的输出值"; 保持最后的输出值。

校准

用户规格化激活; 索引80n0:01

用户规格化通过索引80n0:01激活，通过指数进行参数设定。

• | 80n0:11 用户规格化偏移
• | 80n0:12 用户规格化增益

制造商补偿;索引80n0:08
制造商校准通过80n0:08激活。这个对象的强制默认值是 "TRUE"

注意 		制作人代码字
制造商有保留终端基本校准权。制作人代码字因此保留。
• | 80nF:01 偏移补偿
• | 80nF:02 增益补偿

用户补偿; 索引80n0:15 和索引80n0:16

用户补偿通过索引8010:07激活。通过指数进行参数设定。

• | 80n0:15 用户偏移补偿
• | 80n0:16 用户增益补偿

过程数据计算
终端连续接收过程数据和储存初始值通过对象801E:01或802E:01内的数模转换器。通过制造商校准值计算每个更正后的过程数据传输。然后进行用户规格化（随机的）：
YH = (XDAC - BK) x AK | 制造商校准后的输出值 （如果索引8010:01或8020:01不活动相当于YA0
YA = YH x AW x 2-16 + BW | 输出值跟随用户规格化

Legend
简称 | 名称 | 对象索引
XDAC | D/A转换器输出值 | 80nE:01
BK | 制造商校准补偿 ( Producer codeword F008 设置时才能使用) | 80nF:01
AK | 制造商校准增益( Producer codeword F008 设置时才能使用) | 80nF:02
BW | 用户规格化补偿 (通过索引8010:01或8020:01再能被激活) | 80n0:15
AW | 用户规格化增益(通过索引8010:01或8020:01再能被激活) | 80n0:16
YA | 输出值 | -

制作人代码字

注意 		制作人代码字
制造商有保留终端基本校准权。制作人代码字因此保留。


EL41x4 - Object description and parameterization

BECKHOFF ELEL41x4 : Commissioning

Object的描述和参数化

注意 		EtherCAT XML 设备描述
这个描述相当于展示EtherCAT XML设备描述的CoE对象。强烈推荐从Beckhoff官网 (http://www.beckhoff.com/english/default.htm?download/elconfg.htm) 下载最新版本的相应XML文件并按照安装说明安装。

注意 		参数化
终端参数花受CoE标签 (双击相关对象) 或过程数据标签(PDO分配)指挥。

介绍

概述包括不同应用程序中的对象：

  • 在调试过程中需要参数化的对象。
  • 用来正常运行的对象，例如通过ADS access。
  • 要求内部设置的对象 (可能是固定的)

下一个段落首先描述对象正常工作的要求，其次是其他对象的完整描述。

调试对象

索引1011还原默认参数
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1011:0 | 还原默认参数 | 对象的长度 | UINT8 | RO | 0x01 (1dec)
1011:01 | 分索引001 | 如果对象被设成 "0x64616F6C" ("设定模拟量") 所有特定终端对象被还原到出厂设置。 | UINT32 | RW | 0x00000000 (0dec)

索引8010 AO设置(for 0 ≤ n ≤ 3), Ch. 1 - 4
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
8010:0 | AO设置 | 最大分索引 | UINT8 | RO | 0x16 (22dec)
80n0:01 | 使能用户规格化 | 用户规格化已使能 | BOOLEAN | RW | 0x00 (0dec)
80n0:02 | 介绍 | 0: 带符号介绍 输出值是带符号数的二进制补码形式。 最大输出范围(16 Bit) = -32768dec .. +32767dec 1: 无符号介绍 最大表示范围 (16 Bit) : 0 .. +65535dec 2: 带最高有效位的绝对值 输出值是数值符号形式。 最大输出范围(16 Bit) = -32767dec .. +32767dec 3: 绝对值 对于负的输出值将变为正值。 | BIT3 | RW | 0x00 (0dec)
80n0:05 | watchdog | 0: watchdog默认值 默认值有效 (8pp0:13) 1: watchdog斜坡 默认值有效.(8pp0:14) 2: 最新输出值 如果watchdog有效, 最新的过程数据将被递交 | BIT2 | RW | 0x00 (0dec)
80n0:07 | 使能用户校准 | 如果置位，就用户校准 | BOOLEAN | RW | 0x00 (0dec)
80n0:08 | 使能制造商校准 | 如果置位，就用户校准 | BOOLEAN | RW | 0x01 (1dec)
80n0:11 | 补偿 | 用户校准补偿 | INT16 | RW | 0x0000 (0dec)
80n0:12 | 增益 | 用户校准增益 增益被表示成定点模式,带有因数2-16. 增益的值1相当于 65535dec (0x00010000). | INT32 | RW | 0x00010000 (65536dec)
80n0:13 | 默认输出 | 默认输出值 | INT16 | RW | 0x0000 (0dec)
80n0:14 | 默认输出斜坡 | 默认输出斜坡值以 Digit / ms为单位 | UINT16 | RW | 0xFFFF (65535dec)
80n0:15 | 用户校准补偿 | 用户校准补偿 | INT16 | RW | 0x0000 (0dec)
80n0:16 | 用户校准增益 | 用户校准增益 | UINT16 | RW | 0xFFFF (65535dec)

正常工作对象

正常工作范围的EL4104没有这样的功能

完整的概述

标准对象 (0x1000-0x1FFF)

所有EtherCAT从站的标准设置是同一个含义。

索引 1000 设备类型
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1000:0 | 设备类型 | EtherCAT从站的设备类型: 低字包含CoE配置支持(5001).。高字包含模块配置与模块设备配置一致 。 | UINT32 | RO | 0x01901389 (26219401dec)
索引 1008 设备类型
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1008:0 | 设备名称 | EtherCAT 从站的设备名称 | STRING | RO | EL4104-0000, EL4114-0000, EL4124-0000, EL4134-0000
索引 1009 硬件版本
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1009:0 | 硬件版本 | EtherCAT 从站的硬件版本 | STRING | RO | 07
索引 100A 软件版本
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
100A:0 | 软件版本 | EtherCAT 从站的固件版本 | STRING | RO | 05
索引 1018 定义
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1018:0 | 定义 | 包含定义EtherCAT从站的信息 | UINT8 | RO | 0x04 (4dec)
1018:01 | 制造商ID | EtherCAT从站的的制造商ID | UINT32 | RO | 0x00000002 (2dec)
1018:02 | 产品代码 | EtherCAT从站的产品代码 | UINT32 | RO | EL4104: 0x10083052 (268972114dec) EL4114: 0x101C3052 (270282834dec) EL4124: 0x101C3052 (270282834dec) EL4134: 0x101C3052 (270282834dec)
1018:03 | 修正 | EtherCAT从站的修正值, 低字 (Bit 0-15) 表明特殊功能终端值; 高字(Bit 16-31) 引用设备描述。 | UINT32 | RO | 0x03F80000 (66584576dec)
1018:04 | 序列号 | EtherCAT-从站的序列号, 低字的低位(Bit 0-7) 包含生产年份，低字的高位包含 (Bit 8-15) 生产周信息， 高字 (Bit 16-31) 是 0 . | UINT32 | RO | 0x00000000 (0dec)
索引 10F0 备份参数处理
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
10F0:0 | 备份参数处理 | 包含备份词目的标准化上传和下载的信息 | UINT8 | RO | 0x01 (1dec)
10F0:01 | 校验和 | 对所有备份词目的校验和 | UINT32 | RO | 0x00000000 (0dec)
索引 1600 AO RxPDO-Map输出Ch.1
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1600:0 | AO RxPDO-Map 输出Ch.1 | PDO 映射 RxPDO 1 | UINT8 | RO | 0x01 (1dec)
1600:01 | 分索引001 | 1. PDO 映射 条目(对象0x7000 (AO 输出 Ch.1), 条目 0x01 (模拟输出) | UINT32 | RO | 0x7000:01, 16
索引 1601 AO RxPDO-Map输出Ch.2
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1601:0 | AO RxPDO-Map 输出Ch.2 | PDO 映射 RxPDO 2 | UINT8 | RO | 0x01 (1dec)
1601:01 | 分索引001 | 1. PDO 映射 条目 (对象 0x7010 (AO 输出 Ch.2), 条目0x01 (模拟输出) | UINT32 | RO | 0x7010:01, 16
索引 1602 AO RxPDO-Map输出Ch.3
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1602:0 | AO RxPDO-Map 输出Ch.3 | PDO 映射 RxPDO 3 | UINT8 | RO | 0x01 (1dec)
1602:01 | 分索引 001 | 1. PDO 映射 条目 (对象 0x7020 (AO 输出 Ch.3), 条目0x01 (模拟输出) | UINT32 | RO | 0x7020:01, 16
索引 1603 AO RxPDO-Map输出Ch.4
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1603:0 | AO RxPDO-Map 输出Ch.4 | PDO 映射 RxPDO 4 | UINT8 | RO | 0x01 (1dec)
1603:01 | 分索引001 | 1. PDO 映射 条目(对象0x7030 (AO 输出 Ch.4), 条目 0x01 (模拟输出) | UINT32 | RO | 0x7030:01, 16
索引 1C00 同步管理类型
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C00:0 | 同步管理类型 | 同步管理通道的用途 | UINT8 | RO | 0x04 (4dec)
1C00:01 | 分索引 001 | 同步管理类型通道 1: 写邮箱 | UINT8 | RO | 0x01 (1dec)
1C00:02 | 分索引 002 | 同步管理类型通道2: 读邮箱 | UINT8 | RO | 0x02 (2dec)
1C00:03 | 分索引 003 | 同步管理类型通道3: 写过程数据 (输出) | UINT8 | RO | 0x03 (3dec)
1C00:04 | 分索引 004 | 同步管理类型通道 4: 读过程数据 (输入) | UINT8 | RO | 0x04 (4dec)
索引1C12 RxPDO 分配
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C12:0 | RxPDO 分配 | PDO 分配输出 | UINT8 | RO | 0x04 (4dec)
1C12:01 | 分索引 001 | 1.指定的 RxPDO (包含对应的RxPDO绘图对象) | UINT16 | RO | 0x1600 (5632dec)
1C12:02 | 分索引 002 | 2.指定的 RxPDO (包含对应的RxPDO绘图对象) | UINT16 | RO | 0x1601 (5633dec)
1C12:03 | 分索引 003 | 3. 指定的 RxPDO (包含对应的RxPDO绘图对象) | UINT16 | RO | 0x1602 (5634dec)
1C12:04 | 分索引 004 | 4. 指定的 RxPDO (包含对应的RxPDO绘图对象) | UINT16 | RO | 0x1603 (5635dec)
索引 1C13 TxPDO 分配
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C13:0 | TxPDO 分配 | PDO 分配输入 | UINT8 | RW | 0x00 (0dec)
索引 1C32 SM 输出参数
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
1C32:0 | SM 输出参数 | 输出的同步参数 | UINT8 | RO | 0x07 (7dec)
1C32:01 同步模式 实际同步模式:
  • 0: 空转
  • 1: 与SM 2同步
  • 2: 与SYNC0 直流同步
  • 3: 与SYNC1 直流同步
 UINT16 RW 0x0001 (1dec)
1C32:02 周期 周期 (纳秒):
  • 空转: 当地计时器的周期
  • 与SM 2 同步: 主站的周期
  • 直流模式: SYNC0/SYNC1周期
 UINT32 RW 0x00000000 (0dec)
1C32:03 | 时间顺序 | 在 SYNC0 和输出值之间的时间(纳秒，直流模式) | UINT32 | RW | 0x00000000 (0dec)
1C32:04 支持同步模式 支持同步模式:
  • Bit 0 = 1: 支持空转
  • Bit 1 = 1: 支持与SM 2 同步
  • Bit 2-3 = 01: 支持直流模式
  • Bit 4-5 = 10: 改变SYNC1的输出(直流模式)
  • Bit 14 = 1: 动态时间 (能被1C32:08测量)
 UINT16 RO 0x8007 (32775dec)
1C32:05 | 最小周期 | 支持最小周期(纳秒) | UINT32 | RO | 0x00000000 (0dec)
1C32:06 | 计算并复制时间 | 在SYNC0和 SYNC1之间的最小时间 (纳秒，直流模式) | UINT32 | RO | 0x00000000 (0dec)
1C32:08 指令
  • 0: 停止时间测量
  • 1: 开始时间测量

1C32:03, 1C32:05, 1C32:06, 1C32:09 会更新至最大测量值

UINT16 RW 0x0000 (0dec)
1C32:09 | 延迟时间 | 在SYNC1和输出值之间的时间(纳秒，直流模式) | UINT32 | RO | 0x00000000 (0dec)
1C32:0B | SM 偏差计算 | 在运作状态中，SM偏差的值(直流模式) | UINT16 | RO | 0x0000 (0dec)
1C32:0C | 周期溢出计算 | 在运作状态中，周期溢出的值 | UINT16 | RO | 0x0000 (0dec)
1C32:0D | 最小距离计算 | SYNC0 和SYNC1 的最小距离 (直流模式) | UINT16 | RO | 0x0000 (0dec)
1C32:20 | 同步错误 | TRUE: 在最后一个周期中，同步出错 (直流模式) | BOOLEAN | RO | 0x00 (0dec)

特定对象的配置文件 (0x6000-0xFFFF)

特定对象的配置文件对所有支持5001的配置文件的EtherCAT从站由相同的含义。

索引 70n0 AO 输出 (for 0 ≤ n ≤ 3), Ch. 1 - 4
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
70n0:0 | AO 输出 | 最大分索引 | UINT8 | RO | 0x01 (1dec)
70n0:01 | 同步输出 | 模拟输出数据 | INT16 | RO | 0x0000 (0dec)
索引 80nE AO 内部数据 (for 0 ≤ n ≤ 3), Ch. 1 - 4
索引 | 索引 | 含义 | 数据类型 | 标记 | 默认值
80nE:0 | AO 内部数据 | 最大分索引 | UINT8 | RO | 0x01 (1dec)
80nE:01 | DAC 初始值 | DAC 初始值 | UINT16 | RO | 0x0000 (0dec)
索引 80nF AO 制造商数据 (for 0 ≤ n ≤ 3), Ch. 1 - 4

注意 		校准
制造商保留对终端的基本校准的权力。因此保留生产商的校准。
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
80nF:0 | AO 制造商数据 | 最大分索引 | UINT8 | RO | 0x02 (2dec)
80nF:01 | 校准补偿 | 校准补偿 | INT16 | RW | 0x0000 (0dec)
80nF:02 | 校准增益 | 校准增益 | UINT16 | RW | 0xFFFF (65535dec)
索引 F000 模块设备配置文件
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
F000:0 | 模块设备 | 模块设备配置文件的一般信息 | UINT8 | RO | 0x02 (2dec)
F000:01 | 模块索引距离 | 两个通道对象之间的索引距离 | UINT16 | RO | 0x0010 (16dec)
F000:02 | 模块的最大值 | 模块的最大值 | UINT16 | RO | 0x0008 (8dec)
索引 F008 代码字

注意 		校准
制造商保留对终端的基本校准的权力。因此保留生产商的校准。
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
F008:0 | 代码字 | 保留 | UINT32 | RW | 0x00000000 (0dec)
索引 F010 模块列表
索引 | 名称 | 含义 | 数据类型 | 标记 | 默认值
F010:0 | 模块列表 | 最大分索引 | UINT32 | RW | 0x04 (4dec)
F010:01 | 分索引 001 | 模拟输出 (400) | UINT32 | RW | 0x00000190 (400dec)
F010:02 | 分索引 002 | 模拟输出 (400) | UINT32 | RW | 0x00000190 (400dec)
F010:03 | 分索引 003 | 模拟输出 (400) | UINT32 | RW | 0x00000190 (400dec)
F010:04 | 分索引 004 | 模拟输出 (400) | UINT32 | RW | 0x00000190 (400dec)


UL 需求

BECKHOFF EKxxxx, ELxxxx: 附录

UL 说明

应用
Beckhoff EtherCAT 模块仅适用于Beckhoff UL 列表中的EtherCAT系统。
测试
更据cULus 测试, Beckhoff I/O 系统仅进行了防火和电击测试 has only been investigated for risk of fire and electrical shock (更据 UL508 和 CSA C22.2 No. 142).
对于以太网接口设备
不适用于连接通信线路

基本原理

倍福EtherCAT产品的两个UL认证，因产品而异：

  • 符合UL508标准的UL认证
    拥有该认证的设备会有这样的标记：

  • 符合限制电源消耗UL508标准的UL认证
    设备消耗的最大电流限制为4A。拥有该认证的设备会有这样的标记。

几乎所有的EtherCAT产品（截止到2010/5）都是非限制的UL认证。

应用

如果端子模块通过 限制认证 , 那么24 V DC 电流消耗必须受到电源限制。

  • 由一个拥有最大电流为4A的保险丝保护的独立电源供电（根据UL248）或者
  • 由一个符合 NEC class 2的电源供电。
    符合 NEC class 2 的电源不能与另一个 NEC class 2 电源串联或并联使用!

这些要求适用于所有的EtherCAT总线耦合器电源，电源适配器端子模块，总线端子模块以及它们的电源触点。


Firmware Kompatibilität

BECKHOFF EL41xx: Appendix

固件兼容性

Beckhoff EtherCAT设备在交付时装备了最有效地固件。固件和硬件有确定的相关性，不是所有的制品都能兼容。
下面时固件兼容某一硬件的状态概述

注意

  • 强烈建议在特别的硬件上使用最新的有效地固件。
  • 没有付费给Beckhoff公司的产品的客户无法给固件升级。

注意 		设备可能的危险
请在special page注意关于固件升级的细节
如果你在引导程序模式运行设备来给固件升级， 可能还没有校验固件的兼容性。
设备可能会损坏！
请确保固件在适合的硬件设备状态！
EL4102
硬件(HW) | 固件(FW) | 文件名, 发布日期
06 - 08 | 05 | EL4102_05.efw, 03/2008
 | 06 | EL4102_06.efw, 03/2009
09 - 10* | 07 | EL4102_07.efw, 03/2010
 | 08* | EL4102_08.efw, 11/2010
EL4112
硬件 (HW) | 固件 (FW) | 文件名, 发布日期
04 | 04 | EL4112_04.efw, 04/2008
 | 05 | EL4112_05.efw, 03/2009
05 | 05 | EL4112_05.efw, 03/2009
06* | 07 | EL4112_07.efw, 03/2010
 | 08* | EL4112_08.efw, 11/2010
EL4112-0010
硬件 (HW) | 固件 (FW) | 文件名, 发布日期
01 - 02 | 02 | EL4112-0010_02.efw, 11/2008
 | 06 | EL4112-0010_06.efw, 03/2009
03 | 07 | EL4112-0010_07.efw, 03/2010
 | 08* | EL4112-0010_08.efw, 11/2010
EL4122
硬件 (HW) | 固件 (FW) | 文件名, 发布日期
04 | 04 | EL4122_04.efw, 04/2008
 | 05 | EL4122_05.efw, 03/2009
05 | 05 | EL4122_05.efw, 03/2009
06* | 07 | EL4122_07.efw, 03/2010
 | 08* | EL4122_08.efw, 11/2010
EL4132
硬件 (HW) | 固件 (FW) | 文件名, 发布日期
07 | 06 | EL4132_06.efw, 10/2008
07 - 11* | 07 | EL4132_07.efw, 03/2009
 | 08* | EL4132_08.efw, 11/2010
EL4104
硬件 (HW) | 固件 (FW) | 文件名, 发布日期
00 - 01 | 01 | EL4104_01.efw, 08/2009
 | 02 | EL4104_02.efw, 12/2010
EL4114
硬件 (HW) | 固件 (FW) | 文件名, 发布日期
00 - 01 | 01 | EL4114_01.efw, 06/2009
 | 02 | EL4114_02.efw, 12/2010
EL4124
硬件 (HW) | 固件 (FW) | 文件名, 发布日期
00 - 01 | 01 | EL4124_01.efw, 08/2009
 | 02 | EL4124_02.efw, 12/2010
EL4134
硬件 (HW) | 固件 (FW) | 文件名, 发布日期
00 - 01 | 01 | EL4134_01.efw, 08/2009
 | 02 | EL4134_02.efw, 12/2010

*) 在创建这个文件时是兼容硬件的状态。请查阅Beckhoff的最近文件的网页。


ELxxxx - 固件

BECKHOFF ELxxxx: 设备升级

固件 EL/ES/EMxxxx

这部分描述了Beckhoff EtherCAT从站 EL/ES, EM, EK和EP系列的版本升级。. 固件的升级只能在咨询Beckhoff技术支持之后才能执行。

目录
• 存储位置
• ESI版本定义
• 设备描述升级 ESI/*.xml
• 固件版本描述
• 固件升级文件 *.efw
• 固件升级文件 *.rbf
• 批量更新

存储位置

EtherCAT从站在3个地方存储运行数据：

  • 更据功能和性能EtherCAT从站有一个或几个本地控制器用于传输I/O数据。 所对应的程序称为 固件 为 *.efw 格式。
  • 某些EtherCAT从站的EtherCAT通讯功能也集成在控制器中。 这种情况的控制器叫做 FPGA 芯片使用 *.rbf 格式的固件。
  • 另外每个EtherCAT从站有存储芯片保持设备参数叫做 EEPROM. 通电后自动加载参数，EtherCAT通信也相应设定。 设备描述可以从 http://www.beckhoff.com 下载区下载。 所有 ESI 文件(EtherCAT Slave Information) 压缩成ZIP格式。

客户可以通过 EtherCAT 现场总线和其通信机制访问数据。 ESC读写来实现异步mailbox通讯或访问寄存器。

TwinCAT System Manager提供配置所有这3部分数据的方法，如果从站支持这些数据。 通常从站不会检查新数据是否适合，例如，数据不适合的话从站就再也无法工作。

注意 		小心设备损坏!
当下载新的设备文件时注意如下几点
  • 下载固件到EtherCAT设备时不能被打断
  • 确保EtherCAT通信稳定。 不能有CRC错误或 LostFrames。
  • 供电必须稳定。 信号等级必须达到规范。

设备更新数据时发生故障可能使模块不能使用，需要返厂修复。

设备描述 ESI文件/XML

注意 		关于ESI说明/EEPROM的更新的注意事项
一些从站在产品的EEPROM中存储了标度和配置的数据。 这些在数据更新中被覆盖。

ESI设备描述存储在本机，并且启动时载入。 每个设备描述为唯一的从站名（10个字符数）和版本号（4个数字） 每个从站的名称都在System Manager的 EtherCAT 页面显示:

图 1: 设备识别符号由名称EL3204-0000和修订号-0016组成

配置识别符号必须与实际的硬件设备兼容。在启动时读取从站型号（如EL3204)。 通常配置的修订号必须等于或高于端子模块的版本 。

说明 		更新 XML/ESI 描述文件
用于硬件设备的固件版本是紧密联系在一起的。 不相容的组合会导致故障或设备关机。
相应的更新只能在咨询Beckhoff技术支持之后才能进行。

显示 ESI从站型号

最简单的确定实际设备描述与配置的设备描述是否一致的方法是在 TwinCAT Config/Freerun 模式下扫描EtherCAT 设备：

图 2: 在Config/FreeRun模式下右键EtherCAT device 然后 Scan Boxes

如果实际与配置相符，则显示下

图 3: 配置相同

否则就显示修改对话框来修改配置

图 4: 修改对话框

在图4例子中。实际为 EL3201-0000-0017 ，原来的配置为 EL3201-0000-0016 。 这种情况下可用CopyBefore按钮来修改配置。 ExtendedInformation复选框必须勾上才能显示版本信息。

修改 ESI 从站版本

ESI/EEPROM 版本可以通过 TwinCAT更新:

  • EtherCAT从站通讯不能中断.
  • 从站的状态不重要。
  • 在online标签中右键从站以打开 EEPROM Update 对话框，图 5

图 5: EEPROM 更新

在对话框中选择新ESI 描述文件, 见图 6. ShowHiddenDevices 复选框钩上可以显示老的版本号，默认不显示。

图 6: 选择新ESI 描述文件

System Manager中的进度条显示当前进度。 数据写入后再进行校验。

说明 		重启后更新生效
大多数EtherCAT立刻读取修改的ESI说明或者在初始化启动之后。 一些通讯设置比如分布式时钟仅在电源打开后读取。
因此为了使修改后的参数生效，EtherCAT从站必须断电重启。

确定固件版本

通过序列号确定固件版本

Beckhoff EtherCAT从站的序列号是用激光刻上的。 序列号的结构如下： KK YY FF HH

KK - 生产周 (CW, 日历周)
YY - 生产年
FF - 固件版本
HH - 硬件版本

12 10 03 02:

12 - 第 12周生产
10 - 2010 年生产
03 - 固件版本 03
02 - 硬件版本 02

System Manager确定版本

主站和从站通信上之后TwinCAT System Manager 即可显示从站控制器的固件版本。 选中你想查看的那个E-Bus端子模块 (本例terminal 2 (EL3204))然后选择CoE Online (CAN over EtherCAT).

说明 		CoE Online和 Offline CoE
有2个CoE 目录：
  • online: 如果从站支持的话，由EtherCAT从站控制器提供。
    只有从站处于连接和运行的状态这个CoE目录才会被显示。
  • offline: EtherCAT 从站信息文件 ESI/XML包含 CoE默认数据.
    CoE目录只显示包含在ESI文件中的信息 (e.g. "Beckhoff EL5xxx.xml")。

Advanced 按钮用于切换这两种显示。

在图7中 CoE索引x100A EL3204的固件版本为03

图 7: 显示 EL3204固件版本

(A) TwinCAT 2.11 指示当前显示 Online CoE 目录 如果当前不是这样, 可以进入 Advanced Settings (B) Online选项 然后双击 AllObjects. 显示所有的Online目录。

升级控制器固件 *.efw

说明 		CoE 目录
由控制器管理的Online CoE目录存储在专用的EEPROM中，这个目录通常在固件更新时不会被改变。

为了更新从站控制固件，选中 Online， 见图8

图 8: 固件更新

如果没有Beckhoff技术支持指导话，请按如下步骤进行。

  • 切换从站到 INIT (A)
  • 切换从站到BOOTSTRAP
  • 检查当前状态 (B, C)
  • 下载新 *efw 文件
  • 下载完成后切换到 INIT状态，然后切换到 OP状态
  • 从站重上电一次

FPGA 固件文件 *.rbf

如果是 FPGA芯片负责处理EtherCAT通讯，可以通过更新 *.rbf文件来完成升级。.

  • 控制器固件 处理 I/O信号
  • FPGA 固件 处理EtherCAT 通信 (仅针对采用 FPGA芯片的端子模块)

包括在端子模块的序列号的固件版本号包含这两个固件组件。 如果其中一个固件更新，那这个版本号就会被更新。

通过System Manager查看版本

在TwinCAT System Manager查看FPGA固件版本。 选中EtherCAT 卡 (本例中的 Device 2) 然后选择 Online 标签

Reg:0002 列分别用十六进制和十进制显示了每个EtherCAT设备的固件版本。

图 9: FPGA固件版本确认

如果 Reg:0002列不显示，在表格中右键然后选择Properties...

图 10: 弹出菜单Properties

Advanced Settings对话框显示哪些列可以被显示。 在 Diagnosis/Online View下 '0002 ETxxxx Build'选中复选框，使FPGA固件版本可以显示。

图 11: 高级设置对话框

更新

更新 FPGA固件

  • EtherCAT耦合器 FPGA固件版本为11或以上;
  • E-bus端子模块FPGA固件版本为10或以上。

更早的固件件版本只能由制造商来更新！

升级EtherCAT设备

在TwinCAT System Manager中选择你想升级FPGA固件的端子模块 (本例 terminal 5: EL5001) 然后
点击EtherCAT中的 Advanced Settings按钮。

图 12: 选择高级设置对话框

Advanced Settings对话框显示。 在 ESC Access/E²PROM/FPGA点击 Write FPGA 按钮,

图 13: 选择写FPGA对话框

选择新 FPGA固件文件 (*.rbf) 然后下载到 EtherCAT设备。

注意 		小心设备损坏!
EtherCAT设备的固件更新过程中不能中断！

如果下载过程被取消，电源断开或是Ethernet连接中断，那此EtherCAT设备只能由制造商来修复！

为了激活新的FPGA固件，EtherCAT设备必须重启（将电源关闭再启动）。

同时更新数台 EtherCAT 设备

如果设备有相同的固件文件/ESI，那么几台设备的固件和ESI描述可以同步更新。

图 14: 多重选择和固件更新

选择需要的从站然后在BOOTSTRAP模式下执行固件的更新。


ELxxxx - 恢复出厂设置

BECKHOFF ELxxxx: 配置

恢复出厂设置

恢复ELxxxx端子模块的出厂设置, 在TwinCAT System Manager的CoE对象 "Restore default parameters"中, 选择SubIndex 001 子项 (配置模式) (见图1)

图 1 选择 "Restore default parameters" PDO

双击SubIndex 001进入参数设定对话框。 输入 1684107116十进制或0x64616F6C十六进制，并点击 OK (图2).
所有数据恢复出厂设置

图 2 在设置值对话框中输入复位码

说明 		其他复位码

某些老端子模块请使用以下复位码：

十进制： "1819238756"

十六进制： "0x6C6F6164"

输入错误的复位码无效。


技术支持与售后

Beckhof f 及其合作伙伴遍布世界各地，可为您提供全方位的技术支持与服务，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff 分公司及代表处

有关 Beckhoff 产品的本地技术支持和服务信息，请联系当地的 Beckhoff 分公司和代表处！

有关 Beckhoff 在全球各地分公司和代理商的地址，您可以登录Beckhoff 的官方网站：
http://www.beckhoff.com

此外，您也可以在该网站上查看更多关于 Beckhoff 组件的文档资料。

Beckhoff 总部

德国倍福自动化有限公司

Eiserstr. 5
33415 Verl
德国

电话 | +49(0)5246/963-0
传真： | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff 技术支持

Beckhoff为您提供全面的技术支持，除了Beckhoff 具体产品的应用以外，还包括更广泛的服务：

  • 技术支持
  • 复杂自动化系统的设计、编程和调试
  • 各种 Beckhoff 系统组件培训方案
热线： | +49(0)5246/963-157
传真： | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心提供全方位的售后技术服务:

  • 现场服务
  • 维修服务
  • 零部件服务
  • 热线服务
热线： | +49(0)5246/963-460
传真： | +49(0)5246/963-479
e-mail: | service@beckhoff.com


安装辅助端子模块

说明 		安装辅助端子模块注意点
EtherCAT 总线端子模块 (ELxxxx / ESxxxx), 不担任数据传输任务的模块称为辅助端子模块。
辅助端子模块不消耗 E-bus电流
为确保最优的数据传输，不能连续连接超过两个接线端子模块。
辅助接线端子模块的实例（高亮部分）

例子 1: 正确的配置

例子 2: 错误的配置


BECKHOFF TwinCAT System Manager: Notes for setting the watchdog

BECKHOFF TwinCAT System Manager: EL4xxx watchdog configuration

设置看门狗的注意事项

EL4xxx终端装有安全设备（看门狗）在数据通信万一中断时，可以在指定时间切断输出。
EL4xxx终端中的EtherCAT从站控制器（ESC）的特点是有两种看门狗，当只有一种用于EL4xxx设备的描述如下：

  • SM看门狗 (延时: 100 ms)
  • PDI看门狗(延时: 100 ms) - 未使用

同步控制看门狗 (SM watchdog)

同步管理看门狗在每次EtherCAT与终端完成数据通信过程后重置。如果与终端的数据通信过程发生的时间比设定和激活SM看门狗的时间短，即万一线路中断，看门狗就被触发，输出设置为FALSE。终端的OP状态不受影响。看门狗只在EtherCAT数据存取过程成功后才会重置。如上所述设置监控时间。

同步管理看门狗通过EtherCAT端从站控制器正确且及时的监控数据通信过程。

PDI看门狗

如果EtherCAT从属控制器的PDI通信时间比设定和激活SM看门狗的时间短，看门狗就被触发。
PDI (过程数据接口)是ESC和EtherCAT从属本地处理器的内部接口，举例来说，PDI看门狗可以用来监控通信是否失败。

PDI看门狗通过应用端从站控制器正确且及时的监控数据通信过程。

PDI看门狗在PDI没有通讯发生时停止EL4xxx 终端的活动。

设置看门狗对话

TwinCAT系统管理对话设置两个看门狗 。ESC在EtherCAT开始的时候把设定值载入适当的寄存器中。

  • 乘法器设置在reg. x400
  • PDI看门狗设置在reg. x410
  • 同步管理看门狗设置在reg. x420

从站支持的情况下，在x410或x420中输入“0”值可以使两个看门狗分别失效

图1 EtherCAT tab -> Advanced Settings -> Behavior

当两个看门狗收到来自本地终端的周期脉冲时，乘法器会把两者分开：

1/25 MHz * (看门狗乘法器+ 2) = 100 µs (2498设置为默认的参数)。

1000标准设置的SM看门狗相当于释放时间为100ms。

注意 		看门狗时间乘法器
乘法器的值+2相当于40ns的滴答的基础数，即为为看门狗的滴答。为适应更大时间范围的看门狗，加法器可以进行修改。

"设置SM看门狗"

这个复选框可以手动设置看门狗的时间。如果输出固定且EtherCAT被中断，SM看门狗就在设定时间触发并且消除输出。 此设定可用于适应较慢的EtherCAT主站终端或长周期时间。默认的SM看门狗设置为100ms。设定的范围时0..65535.连接乘法器的范围是1..65535，包括在0..~70秒内的看门狗周期。

通常情况下，看门狗也可以完全消除。

例子

乘法器 = 2498 → 看门狗基准时间 = 1 / 25 MHz * (2498 + 2) = 0.0001s= 100 µs
SM看门狗= 10000 → 10000 * 100 µs = 1 s 看门狗监控时间

警告 		警告！可能的不能控制系统！
通过SM看门狗=0 断开SM看门狗的功能只在0016版本的终端中采用。

以前的版本不能使用这个操作状态。

警告 		警告！可能的不能控制系统！
如果SM看门狗被激活并且输入0值看门狗会被完全关闭。
如果通信中断，设置输出不复位。