EL5001 - SSI Sensor Interface

BECKHOFF 现场总线组件

说明文档

EL5001

1 通道 SSI 传感器接口

EL5001-0011

1 通道 SSI 监视器总线端子模块

EL5002

2 通道 SSI 传感器接口

版本: 1.5
日期: 2012-01-06

EtherCAT® 是注册商标和专利技术， Beckhoff Automation GmbH, Germany的许可。

164

Extracted by Trial version of ChmDecompiler (Download Now).

Once registered, all restrictions of the Trial version are removed.

Buy Now


25

BECKHOFF EL5001, EL5001-0011, EL5002: 前言

文档版本

Version | Comment
1.5 | - 更新结构和技术参数
1.4 | - 增加EL5002，EL5001 DC方式
1.3 | - 增加技术数据，EL5001-0011
1.2 | - 修正技术数据
1.1 | - 增加对象信息说明 - 修正技术数据(ASIC)
1.0.1 | - 增加对象信息说明(3101)
1.0 | - 增加信息控制/状态字
0.1 | - EL5001的第一个临时文件


32

BECKHOFF: 产品概述

EtherCAT设备的版本说明

名称

一个Beckhoff EtherCAT设备有14位的名称，由以下组成：

  • 系列序号
  • 类型
  • 版本
  • 修订号
例子 | 系列 | 类型 | 版本 | 修订号
EL3314-0000-0016 | EL 端子 (12 mm, 非可插入式 连接等级) | 3314 (4-通道热电偶端子) | 0000 (基础型号) | 0016
CU2008-0000-0000 | CU 设备 | 2008 (8-端口 快速以太网交换机) | 0000 (基础型号) | 0000
ES3602-0010-0017 | ES 端子 (12 mm, 插入式连接等级) | 3602 (2-通道 电压测量) | 0010 (高精度版本) | 0017

注意

  • 订单标示符由以下组成：
    - 系列序号
    - 类型
    - 版本
  • 修正表明技术更新，是由Beckhoff来 管理。
    从原则上讲，一个设备有更高的版本可以取代它的低版本，除非有特殊的说明。
    每个修正通常有相关的XML描述（ESI，EtherCAT从属信息），都可以从Beckhoff的官网上下载。
  • 型号，版本和修订本都是用十进制数来表达的。

序列号的含义
序号的含义

序号的结构: KK YY FF HH

KK - 生产星期 (CW, 日历周)
YY - 生产年份
FF - 固件版本
HH - 硬件版本

例如 no.: 12 06 3A 02:

12 -第12周出产
06 - 2006年生产
3A - 固件版本是3A
02 - 硬件版本是02

序号举例

图 1: EL6688 EL 终端

图2: CU2016 开关

图3: EK1100 EtherCAT 耦合器


149

BECKHOFF EL5001: 产品概述

EL5001 - 介绍

SSI 传感器接口

EL5001是一款具有SSI编码器接口的EtherCAT总线端子模块，编码器信号可以直接接入其中，而EL5002具有2通道SSI接口EtherCAT 端子模块，它允许两路SSI编码器信号接入。接口电路模块通过发出脉冲信号来读取编码器数据，并将它们保存到控制器的过程数据中。通过对模块工作模式的操作，可以将传输频率和位宽信息永久的保存到寄存器中。

在控制系统中，EL5002和EL5001中的固件10分布式时钟循环读取SSI编码器数据，因此能够得到高精度、详细的轴向动态分析来准备启动。

在 TwinCAT2.11中，EL5002和EL5001中的固件10 from FW10有一个全新、可供选择的过程镜像供简单的试运行使用。在交货状态，试运行及测试过程镜像包含已经设置好的参数值和状态。

快速链接

• EtherCAT 基本 信息
• 安装与接线
• 试运行


23

BECKHOFF EL500x: 产品概述

EL5001, EL5002 - 技术参数

技术数据 | EL5001 | EL5002
传感器连接 | 二进制输入D+，D-；二进制输出CL+，CL-
内部SSI回路供电 | 24VDC通过电源连接端子
电流消耗（不包含传感器） | 典型值 20mA
传感器供电 | 24VDC(-15%/+20%)通过电源连接端子 | 通过分布式电位端子EL91xx使用
数据传输速率 | 最高可达1MHz，预设250kHz
串行输入 | 24位宽（可调）
数据方向 | 读
分布式时钟 | 是 (固件11) | 是
信号输出 | 差分信号（RS422）
信号输入 | 差分信号（RS422）
内部E-bus供电 | 通过E-bus总线
E-bus电流消耗 | 典型值 120mA
电气隔离 | 500 Veff (E-bus/场电位)
过程数据位宽 | 输入: 1 x 32 位数据 (1 x 8 位 控制/状态 可选择)
配置 | 使用TwinCAT System Manager进行配置
重量 | 约55克
工作温度 | 0 °C ... + 55 °C
储藏温度 | -25 °C ... + 85 °C
相对湿度 | 95%,不结露
尺寸 | 约 15 mm x 100 mm x 70 mm (排列宽度: 12 mm
安装 | 安装在35mm的标准导轨上，符合EN50022
抗振性 | 符合EN 60068-2-6/EN 60068-2-27/29
EMC抗爆性/ESD | 符合EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认证 | CE Ex UL | CE Ex


67

BECKHOFF EL5001-0011: 产品概述

EL5001-0011 - 介绍

SSI 监控模块

EL5001-0011是一款用于监控SSI主站和SSI从站直接数据交换的EtherCAT总线模块。编码器可以从SSI主站获得供电，同样也可以从EL5001-0011模块上获取24v电源。EL5001-0011不会参与到数据通讯之中。

EL5001-0011能够自动调整频率，数据宽度可以预置。通过控制寄存器可以永久地设置各种操作模式。如果使用分布式时钟功能，监控模块能够精确的接收到寄存器启动的时间。

快速链接

• EtherCAT 基本信息
• 安装和接线
• 调试


111

BECKHOFF EL5001-0011: 产品概述

EL5001-0011 - 技术参数

技术数据 | EL5001-0011
传感器连接 | 数据输入D+，D-；时钟输入CL+，CL-；差分信号（RS422）
内部SSI回路供电 | 24VDC通过电源连接端子
传感器供电 | 24VDC(-15%/+20%)通过电源连接端子
输入频率/时钟脉冲率 | 125 kHz - 1 MHz,自适应
数据宽度 | 1 - 32 位
编码 | 格雷码，对偶码
电源失效位 | 可以激活
分布式时钟 | 是
内部E-bus供电 | 通过E-bus总线
E-bus电流消耗 | 典型值 120mA
电气隔离 | 500 Veff (E-bus/场电位)
配置 | 使用TwinCAT System Manager进行配置
重量 | 约100克
工作温度 | 0 °C ... + 55 °C
储藏温度 | -25 °C ... + 85 °C
相对湿度 | 95%,不结露
尺寸 | 约 15 mm x 100 mm x 70 mm (排列宽度: 12 mm)
安装 | 安装在35mm的标准导轨上，符合EN50022
抗振性 | 符合EN 60068-2-6/EN 60068-2-27/29
EMC抗爆性/ESD | 符合EN 61000-6-2/EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认证 | CE Ex UL


17

BECKHOFF EL500x: 产品概述

开始

调试:

  • 装配EL500x参考章节"装配和接线"
  • 在TwinCAT中配置EL500x参考章节"调试"


71

BECKHOFF EtherCAT: 基础交流

EtherCAT 基础

请参见 "EtherCAT System Documentation" 中有关EtherCAT现场总线的相关章节。


143

BECKHOFF EtherCAT: 基础交流

CoE接口

目录表格
• 综述
 • 数据管理
 • Online/offline 列表
 • 基于通道的顺序

综述

CoE 接口是 EtherCAT 设备的参数管理机构。EtherCAT 从站或 EtherCAT 主站管理是固定的（只读）或操作、诊断、调试参数是可变的。

COE 参数位于表层。 原则上，用户可以通过现场总线进行访问。EtherCAT 主站（TwinCAT 管理器）可以通过 EtherCAT

COE 参数是在一个阶层结构的表单之中。原则上，用户可以通过总线进行读取。EtherCAT主站（TwinCAT System Manager）可以通过EtherCAT总线访问本地的从站的CoE列表，并且根据参数的属性进行读或写的操作。

不同CoE参数，其类型也不尽相同，有字符型（文本），整形数字，波尔型变量或多字节数据。他们可以描述模块众多的特性。例如有些参数包含了制造商ID，序列号，过程数据设定，设备名称，模拟量测量的校正值以及密码。

通过2层16进制编码进行顺序标注：（主）索引，子索引。他们的范围如下

  • 索引：0…65535

  • 子索引：0…255

一个参数的地址通常被写为x8010:07这样的形式，x代表十六进制数，冒号将索引与子索引隔开。

与EtherCAT总线用户相关的区域：

  • x1000:这里保存了一些固定的信息，如名称，制造商，序列号等。附加一些当前可使用的过程数据的配置信息。

  • x8000: 这是保存了所有通道的操作和功能参数，如过滤设置或输出频率。

其他重要的区域：

  • x4000：保存一些EtherCAT设备的通道参数（可以替代x8000区域）

  • x6000：输入PDOs（映射来自EtherCAT主站的“输入”）

  • x7000：输出PDOs（映射来自EtherCAT主站的“输出”）

注意 		可用性
并不是所有 EtherCAT 设备都必须有一个CoE 列表。
没有专用处理器的普通的I/O 模块没有可变参数，因此没有CoE列表。

如果设备含有CoE列表，在TwinCAT System Manager中会以一个独立的选项卡来显示参数列表。

Fig. 1: "CoE Online" tab

图1显示的是EL2502的CoE对象列表，包含范围从x1000到x1600，索引x1080已经展开。

数据管理

有些参数，特别是从站的设定参数是可以进行配置的。可以通过读写模式来进行配置。

  • 通过System Manager（图1）点击
    对于调试系统或者从站是很有用的。点击到需要设定参数的那一列，在“setvalue”对话框中输入相应的值。
  • 通过控制系统/PLC 上的 ADS 通讯，如利用 TcEtherCAT.lib 库里的功能块。

    在系统正在运行或者没有 System Manager 可以操作的情况建议使用这样的方法修改参数。

注意 		数据管理

如果在线修改从站的 CoE 参数，Beckhoff 设备将会把参数的变换以自动容错方式保存在 EEPROM 中。

例如，修改过的 CoE 参数在重启后依然有效。

这与其他厂商可能会有所不同。

Start-up 列表

注意 		Startup 列表
如果模块被替换，那么在模块中的CoE列表保存的参数变化将会丢失。新的模块换上后，将会使用默认设置。因此建议将EtherCAT从站CoE列表中所有变化的参数都添加进startup列表中。这样每当EtherCAT总线启动，从站中的参数将自动被startup列表中的参数所替换。

如果EtherCAT从站不具备保存本地CoE参数值的功能，Startup列表必须被使用。

手动修改CoE参数的建议

  • 在System Manager中进行必要的参数改变
    变化值将会保存在本地的EtherCAT从站中
  • 如果变化值需要永久的保存，将其添加到 Startup 列表中

    Startup 中参数的顺序无关紧要。

图2：TwinCAT System Manager中的Startup 列表

在Startup列表中已经包含了ESI指定配置参数。其他和应用相关的参数可以进行创建添加。

Online/offline 列表

当TwinCAT System Manager运行时，如何来辨别EtherCAT设备是否可用，通过EtherCAT连接上的设备会显示为Online，没有连接上的设备在配置中显示为offline。

两种情况下，CoE列表如图1所示，连接状态显示为offline/online.

  • 如果从站处于offline状态
    -     Offline列表中显示的是ESI文件中的内容。在这种情况下，所做的任何修改都不起作用。
    -     配置的状态显示在“Identity”之后
    -     Firmware和硬件版本都不会显示，因为他们属于设备本身的特性
    -     offline 显示为红色

    图3：Offline 列表
  • 如果从站是Online状态
    -     读取的是当前的从站数据，这将需要几秒的时间，取决于数据的大小和循环周期。
    -     显示实际的Identity
    -     显示当前模块的firmware和硬件版本
    -     Online 显示为绿色

    图4：online列表

基于通道的顺序

在CoE列表中，EtherCAT设备的每个通道往往都有许多相同的功能。例如，一个通道的0-10V模拟量输入模块有4个物理通道，因此就会有4组独立的参数设定。为了避免字文档中列举每个通道的列表，就会使用“n”来表示通道号。

在CoE系统中是主索引是以16进制排列，每个主索引包含255个子索引，足以用来表示所用通道的参数信息。基于通道的顺序是按照16dec/10hex的步序来排列。例如参数范围x8000：

  • 通道0：参数范围 x8000:00…x800F：255
  • 通道1：参数范围 x8010:00…x801F：255
  • 通道2：参数范围 x8020:00…x802F：255...

通常写成x80n0的形式

更多关于CoE接口的信息可以在倍福网站上查询EtherCAT system documentation


176

BECKHOFF EtherCAT: 基础交流

分布式时钟

EtherCAT从站控制器中的本地分布式时钟有如下的特点：

• 单位 1 ns
• 零点1.1.2000 00:00
• 大小 64 位(可以连续使用584年;然而,有些EtherCAT从站只提供32位,即. 在大约4.2秒后变量溢出)
• EtherCAT主站自动将本地时钟与主站时钟进行同步，精度<100ns。

详情请见 EtherCAT system description.


119

BECKHOFF Feldbuskomponenten: 安装和接线

系统连接

警告 		电击危险和损坏设备的风险！
在开始安装，拆卸和接线之前，使总线端子系统处于安全的断电状态！

概述

总线端子系统为不同的应用提供最合适的连接：

  • KLxxx和ELxxx端子系列有标准的接线，包括独立封装的电子和连接等级。
  • KLxxx和Elxxx端子系列的特点是可插式连接以保证稳定的接线。
  • 高密度的终端 (HD Terminals)包括独立封装的电子和连接等级和优先封装密度。

标准接线

KLxxx和Elxxx端子系列经过多年测试。
集成无螺纹弹簧技术提供了快速简单的装配。

可插式接线

KSxxx和ESxxx端子系列的特点是可插式连接。
为KS系列生产的装配和接线同样适用于KLxxx和Elxxx系列。
KS/ES端子系列可以使完整的布线像插入式连接器那样被从外壳上移走。
通过拉动下半部分的 解锁扣 就可以从终端接线板上拔出。
用电线安装新的元件然后插入连接器。
这样可以减少安装的时间，降低线路混淆的可能。

尺寸相似的端口只能做些微的改动。新的连接器可以增加大约3mm。不能改变端口的最大高度。

当连接器被移动时，电缆的标签可以简化装配还可以防止混淆独立的连接线。

导体横截面在 0.08 mm2 和 2.5mm2之间的可以通过弹簧技术继续使用。

KSxxx和ESxxx系列的概述和学名被沿用至KLxxx和ELxxx系列。

高密度终端 (HD Terminals)

KLx8xx系列的总线终端有16个连接点区别于特别紧凑的设计，它的包装设计是12mm总线终端的两倍大。巨大的导体和导线两端的套筒可以直接插入装有弹簧的插口不需要任何工具。

注意 		HD端口接线
KLx8xx和ELx8xx系列的高密度终端不支持稳定的布线。

注意
超声 “焊接" 导线
可以使用超声波“粘合”（超声波焊接）导体来连接标准或高密度端子模块。

在这种情况下, 请注意 下面线径说明表!

接线

ELxxxx / KLxxxx终端的标准接线和ESxxxx / KSxxxx终端的固定接线

绞线可以通过八个连接点接到总线终端。端口都采用弹簧技术。根据下面的步骤来接线：

  1. 用螺丝刀轻轻推动位于接口上方的方形孔来打开载入弹簧的终端。
  2. 现在导线可以直接插入圆形孔无需外力。
  3. 当撤去外力的时候端口会自动合上，将接线永久安全的接上。

端口外壳 | ELxxxx, KLxxxx | ESxxxx, KSxxxx
电线宽度 | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
剥线长度 | 8 ... 9 mm | 9 ... 10 mm

高密度终端 ELx8xx, KLx8xx (HD)高密度终端

HD终端的导体通过插入技术可以直接与单线导体相连，即拨线后可以直接插入连接点。导线可以像往常那样用螺丝刀卸下。如下表找到合适的宽度。

端口外壳 | ELx8xx, KLx8xx (HD)
电线宽度 (导体两端有套筒) | 0.14... 0.75 mm2
电线宽度 (单芯线) | 0.08 ... 1.5 mm2
电线宽度 (细导线) | 0.25 ... 1.5 mm2
电线宽度 (细导线) (ultrasonically “bonded" conductors) | only 1.5 mm2 (详见 注意！)
剥线长度 | 8 ... 9 mm

屏蔽

注意 		屏蔽
模拟传感器和执行器总是用屏蔽双绞线相连。


11

BECKHOFF EtherCAT: 安装和接线

接线端子模块的安装

注意 		装配接线端子模块的提示
EtherCAT 的总线端子 (ELxxxx / ESxxxx)，其在终端接线盒中并不担任数据传输的任务。
接线端子模块在E-Bus之外没有电流消耗。
为确保最优的数据传输，你不能直接将两个接线端子模块连接起来。

装配接线端子模块的实例 (高亮部分)：

例子1: 正确的配置

例子2: 错误的配置


232

BECKHOFF EL500x: 安装和接线

EL5001, EL5002; EL5001-0011 - LEDs和连接

目录
• EL5001-0000
• EL5002
• EL5001-0011

EL5001

LEDs

LED | Color | Meaning
RUN | 绿色 | 该LED指示灯表示模块的运行状态。
 |  | off | EtherCAT 设备状态：INIT=模块初始化。
 |  | blinking | EtherCAT 设备状态：PREOP =设置邮箱通讯以及不同的标准设定。
 |  | Single flash | EtherCAT设备状态：SAFEOP=通道 同步管理 以及分布式时钟检查。输出处于安全工作模式。
 |  | on | EtherCAT设备状态： OP=普通工作模式，邮箱和过程数据通讯。
 |  | flickering | EtherCAT设备状态： BOOTSTRAP=模块固件升级 功能。

连接

Terminal | No. | Comment
D+ | 1 | SSI 数据输入 D+
+24 V | 2 | +24V（和端口6和内部电源正极连通）
0 V | 3 | 0V （和端口7和内部电源负极连通）
CL+ | 4 | 时钟输出 CL+
D- | 5 | SSI 数据输入 D-
+24 V | 6 | +24V（和端口2和内部电源正极连通）
0 V | 7 | 0V（和端口3和内部电源负极连通）
CL- | 8 | 时钟输出 CL-

EL5002

LEDs

LED | Color | Meaning
RUN | 绿色 | 该LED指示灯表示模块的运行状态。
 |  | off | EtherCAT 设备状态：INIT=模块初始化。
 |  | blinking | EtherCAT 设备状态：PREOP =设置邮箱通讯以及不同的标准设定。
 |  | Single flash | EtherCAT设备状态：SAFEOP=通道 同步管理 以及分布式时钟检查。输出处于安全工作模式。
 |  | on | EtherCAT设备状态： OP=普通工作模式，邮箱和过程数据通讯。
 |  | flickering | EtherCAT设备状态： BOOTSTRAP=模块固件升级 功能。

连接

Terminal | No. | Comment
D+ | 1 | SSI 数据输入 D1+
+24 V | 2 | 时钟输出 CL1+
0 V | 3 | SSI 数据输入 D2+
CL+ | 4 | 时钟输出 CL2+
D- | 5 | SSI 数据输入 D1-
+24 V | 6 | 时钟输出 CL1-
0 V | 7 | SSI 数据输入 D2-
CL- | 8 | 时钟输出 CL2-

EL5001-0011

LEDs

LED | Color | Meaning
RUN | 绿色 | 该LED指示灯表示模块的运行状态。
 |  | off | EtherCAT 设备状态：INIT=模块初始化。
 |  | blinking | EtherCAT 设备状态：PREOP =设置邮箱通讯以及不同的标准设定。
 |  | Single flash | EtherCAT设备状态：SAFEOP=通道同步管理 以及分布式时钟检查。输出处于安全工作模式。
 |  | on | EtherCAT设备状态： OP=普通工作模式，邮箱和过程数据通讯。
 |  | flickering | EtherCAT设备状态： BOOTSTRAP=模块固件升级 功能。
电源指示 | 绿色 | 供电电压正常
数据 | 绿色 | 信号数据输入
时钟 | 绿色 | 信号时钟输入

连接

Terminal | No. | Comment
D+ | 1 | SSI 数据输入 D+
CL+ | 2 | 时钟输出 CL+
- | 3 | 不连接
- | 4 | 不连接
D- | 5 | SSI 数据输入 D-
CL- | 6 | 时钟输出 CL-
- | 7 | 不连接
- | 8 | 不连接
- | 1' | 不连接
+24 V | 2' | +24V（和端口6和内部电源正极连通）
0 V | 3' | 0V（和端口7和内部电源负极连通）
- | 4' | 不连接
- | 5' | 不连接
+24 V | 6' | +24V（和端口2和内部电源正极连通）
0 V | 7' | 0V（和端口3和内部电源负极连通）
屏蔽 | 8' | 屏蔽


Installation of the TwinCAT real-time driver

BECKHOFF EtherCAT: EtherCAT 基础

安装 TwinCAT 实时驱动

为了使 IPC 控制器的以太网端口就有实时性，必须在Windows 下对该端口安装 Beckhoff 实时驱动。

有几种方式可以实现。一种方式描述如下：

在系统管理器调用 TwinCAT 本地网络接口概述：Options -> Show Real Time Ethernet Compatible Devices.

图 1: 系统管理选项

图 2: 网络接口概述

通过“Install” 按钮实现“Compatible devices”下的接口驱动。该驱动只能在兼容性良好的设备上安装。

忽略 Windows 提示的未授权驱动程序警告。

驱动程序安装完成后在 Windows 概述中出现激活网络接口 (Windows Start -->

图 3: 网络接口 Windows 属性

警告 		IP 地址/DHCP
大多数情况下，以太网端口当做EtherCAT 设备进行配置不传输 IP 数据包。签于此，使用 EL6601 或类似设备通过“Internet Protocol TCP/IP” 启动设置关闭 DHCP 来指定固定的 IP 地址。

用这种方式，为以太网端口的 DHCP 客户端指定默认 IP 地址。In this way the delay associated with the DHCP client for the Ethernet port assigning itself a default IP address in the absence of a DHCP server is avoided.

例如：一个合适的地址是 192.168.x.x 。

图 4: 以太网端口 TCP/IP 设置

另外，在系统管理器中，可以通过 EtherCAT 属性查看以太网端口。

图 5: EtherCAT 设备属性

74


204

BECKHOFF EL500x: Commissioning

功能原理及注意点

EL5001/EL5002是用于连接周期轮询的SSI设备的主站模块。EL5002可以连接2个从站。

EL500x通常用于获取位置信号的场合，每次IO循环都会触发一次SSI通讯，由此来提供编码器的当前位置。如果时间小于EtherCAT硬件上设置的最小循环时间，那么他们之间的内部关系将不再得到保证，SSI传输不再和EtherCAT周期或者DC周期同步（请参考下文：EtherCAT循环时间）

Contents

• SSI principles SSI原理
 • EL500x functionality EL500x功能
 • Commissioning 调试
 • CoE settings CoE设定
 • Process data 过程数据
 • Distributed Clocks 分布式时钟

SSI 原理

SSI 通讯序列

  • SSI主站以固定周期在数据线上发送脉冲信号，将其送入SSI从站的移位寄存器中。
  • SSI从站通常从数据线上获取25位的数据，当数据信号传输时，SSI编码器通过时钟信号的第一个下降沿来获得当前的位置信息。
  • 一旦规定数量的数据位发送完毕，时钟信号就会终止。
  • 停顿之后，由SSI主站发起重新轮询。

最后的数据位可以是电源故障位。例如：从站发出电源故障信号。该信号取决于从站。

数据位数量的变化取决于时钟频率，例如，最大数据传输周期是1MHZ，即1Mbit/s。

EL5001-0011不能工作在单端信号的环境中。

EL500x设备在接入的数据线上有一个120 Ω的终端电阻。

EL500x SSI主站的部分参数需要设置以确保SSI数据能够顺利的传输

  • baud rate (e.g. 500 kbaud) 波特率（例如：500kbaud）
  • coding (e.g. Gray code) 编码类型（例如：格雷码）
  • data frame type, e.g. multi-turn 25 bit 数据帧类型（例如：多圈25位）
  • data frame size, e.g. 25 bit 数据帧大小（例如：25位）
  • 数据长度 数据帧中的多少位是代表当前的实际位置的（例如：24位）

这些信息需要在SSI从站的数据参数中确认，并在EL500x的CoE字典中进行设置。

Fig. 1: Schematic diagram

EL500x 功能

技术进步使得EL5001的功能得到不断的发展。是否支持一下扩展功能取决于模块硬件和软件版本

EL5001至firmware（FW）10（至EL5001-0000-0001）

  • 主站模块开始SSI通讯取决于EtherCAT循环周期，这就是所谓的同步模式。
  • CoE设定（波特率，帧长度…）在对象字典4060ff里。
  • 过程数据包含状态（1byte）和数值（4byte）

EL5001从firmware（FM）11开始（从EL5001-0000-1017）以及EL5002（从EL5002-0000-0016开始）

  • 这些版本增加了分布式时钟功能，可以将SSI从站信号其他分布式时钟设备进行精确同步。这样就能消除通讯带来的时间误差，能够显著的减少时间上的不确定性。
  • CoE设置（波特率，帧长度…）绝大多数是在对象8010（EL5001）或者8000/8010（EL5002）以及其子索引中进行设定。
  • 默认设置下，EL500x过程数据中包含状态（1byte）和值（4byte）。
    另外，也可以扩展成过程数据包含状态（2byte）和值（4byte）。从TwinCAT2.11开始状态变量中的bit可以单独地进行连接

Note 		Firmware Update
Older EL5001 devices with firmware version 10 cannot be updated with later firmware!

调试

默认设定: 25 位, 格雷码，500kbaud，没有电源故障位。

在调试中，以上这些参数必须根据CoE，DC模式，过程数据进行设定

EtherCAT循环时间

如果EL500x本身的运行循环时间比SSI通讯以及处理的时间快的话，下一次SSI通讯将不再和EtherCAT总线循环周期以及分布式时钟信号同步，直到下一次同步信号或者本次SSI通讯处理完成。

最小的循环时间取决于firmware版本，相关数据见表1，在一些特定的应用中也会因帧长度和禁止时间而改变。

型号 | 建议最小循环时间
EL5001 up to FW10 | 400 µs
EL5002, EL5001 from FW11 | 200 µs

Table 1: Typical minimum recommended EtherCAT cycle time

扩展状态字中的TxPdo触发型号能被用来计算实际的数据更新频率。

Coe设置

模块通过CoE-Online tab或者Process Data tab来设定参数，（双击下面提及的对象）

根据firmware版本的不同，EL500x可以在索引4060或者8010中设定参数。

  • EL5001 FW10之前版本（含FW10）在4060ff里设定
  • EL5001（从FW11开始），EL5002用户可以在8010（8000/8010）中进行设定，当然也可以继续在4060ff中进行设定。两个索引修改任何一方，另一方的数据将会被自动复制。

注意 		通过COE列表的参数（CAN over EtherCAT）
Please note the following general CoE information when using/manipulating the CoE parameters:
- Maintain the startup list of the terminal in case it has to be replaced
- Distinguish between online/offline dictionary, check for existence of a current XML device description
- Use "CoE reload" for resetting changes

当使用/操纵CoE参数时请注意以下的CoE信息：
- 保持启动列表中的端子，以防它不得不被替换
- 区分在线/离线字典，检查当前的XML设备描述是否存在
- 使用“ CoE reload“来复位变化

注意 		EtherCAT XML 设备描述
CoE对象显示匹配EtherCAT的XML设备描述。我们建议从Beckhoff的网站（ http://www.beckhoff.de/english/default.htm?download/elconfg.htm ）从下载区下载最新的XML文件，根据安装说明进行安装。

在 TwinCAT 2.11 中，在线CoE列表的结构如下所示:

图. 2: 在TwinCAT2.11中的CoE 设置 以及 EL500x 过程数据

  • 红: 给对象4060ff 设置范围。
  • 蓝: 给对象 8010 的分类指数设置范围。
  • 绿: 在线数据就是显示的EL终端的数据，如果物理上端子没有连接好，它将与从XML描述/ ESI文件的脱机数据进行对比。例如，
    启动列表中应包含能永久修改的CoE，以确保设置在TwinCAT重启后重新加载到EL端子。否则如果设备被替换的话设置会丢失。

SSI设定

  • 索引 8000: 01, 禁用错误帧
    如果该位设为TRUE，在数据错误过程记录中将不再显示诸如无效的报文长度这样的错误信息。
  • 索引 8000: 02, 电源故障位使能
    如果该位设为TRUE，过程变量中的报文最后一位将作为电源故障位。
  • I 索引 8000: 03, 禁止时间使能
    如果该位设为TRUE，当下一次SSI通讯开始（索引8010:13），甚至开始请求已经通过EtherCAT或者分布式时钟发出，系统会等到禁止时间结束在进行通讯。
  • 索引 8000:04, 测试模式使能
    仅仅用于生产的目的
  • 索引 8000: 06/4066, SSI编码
    设定对偶码或格雷码（标准）
  • 索引 8000: 09/4067, SSI波特率
    可以设定为125,250,500kbaud（默认）或者1Mbaud
  • )索引 8000: 0F/4068, SSI帧类型
    25, 13 或者可变位宽 (默认: 25)
  • 索引8000: 11/4069, SSI帧大小
    整个数据长度包含电源故障位
  • 所以 8000:12/406A, SSI数据长度
    数据长度不包含电源故障位
  • 所以 8000:13/406B, 最小禁止时间[µs]
    见索引8000:03

过程数据

EL500x每个通道提供位置数据（4bytes）和状态信息（1或2bytes），他们的区别在于：

  • EL5001 FW10之前（含FW10）版本包含位置数据和1个状态字节。
  • EL5001（从FW11开始），EL5002提供位置数据和2个状态字节，低8位的字节数据得以保留和原来意义相同，高位字节为将来新的信息预留

In the following example are three EL5001 devices are configured in order to illustrate the differences.

Fig. 3: EL500x process data

  • Terminal A, EL5001-0000-0001
    仅支持1个状态字节
  • Terminal B, EL5001-0000-1017
    默认的过程数据
  • 在SyncManager 3（input 蓝色），PDO对象由1A00（默认）1A01，表现为2个状态字节的形式。
    另外，在TwinCAT 2.11的环境下，状态字被分割为可以进行单独连接的位，因此在调试中，每个位的状态都可以被读到。
    为了监控在Online Overview中监控各个位的状态（D），“Show Sub Variables”必须要激活（E）。

Note 		SubVariables and TwinCAT 2.10
Under TwinCAT 2.10 the consolidated representation of subvariables as shown for 16-bit status in Fig. 3 is not possible. Only the individually linkable bits are shown.

分布式时钟(DC)

在分布式时钟模式下，SSI通讯不会随着EtherCAT帧的到达而开始，而是根据在整个EtherCAT系统中，所有支持分布式时钟的从站设备发出同步信号，实现同步的。尽管EL500x内部处理SSI通讯能够达到< ±500 ns的精度，已经达到相对理想的同步时间，但DC同步的精度可以达到100ns

更多关于DC系统的信息可以参考 Basic EtherCAT documentation

EtherCAT最小循环时间也推荐应用在DC模式中，如果EL500x工作循环时间比SSI通讯处理时间快，那么SyncErrorstatus位会被置位。

DC模式在DC tab中设定，TwinCAT restart或者reload后功能生效。

Fig. 4: DC mode settings

SSI通讯开始

如果要将SSI通讯的开始时间要在控制系统（TwinCAT 2.11或者更高）进行计算，以下的功能必须要被激活。

System Manager | EL500x | Advanced settings | Behavior | IncludeDcShiftTimes = TRUE

Fig. 5: EL500x shift times

虽然在System Manager中到每个模块的偏移/转换时间的设定是在本地同步信号与主站侧DC同步时间范围之内[µs]，但在runtime时，该值是恒定的。依据DC模式，SSI本地开始的时间可以用以下的公式计算。

例如

StartSSI = DCPLC + DcInputShift

在每个PLC循环中都会被计算，更详细信息参见 Basic EtherCAT documentation。


15

BECKHOFF EL500x: 调试

对象描述和参数化

注意 		EtherCAT XML 设备描述
该描述相当于 EtherCAT XML 设备描述的 CoE 对象显示。强烈建议从 Beckhoff 网站(http://www.beckhoff.com/english/default.htm?download/elconfg.htm) 下载最新的相应 XML 修订版并按照说明进行安装。

注意 		参数化
CoE 标签 (双击the referring object) 或 过程数据标签 (PDO assignment)能够实现端口的参数化。

介绍

CoE 概述包含不同应用程序对象：

  • 调试过程中的要求对象的参数化
  • 常规操作对象，例如：ADS 数据库。
  • 指定内部设置对象 (可能是固定的)

以下章节首先描述正常操作的对象请求，剩下的是其他对象的完整概述。

调试对象

1011 恢复默认参数
Index | Name | Meaning | Data type | Flags | Default
1011:0 | 恢复默认参数 | 恢复 EtherCAT 从站默认设置 | UINT8 | 只读 | 0x01 (1dez)
1011:01 | 子索引 001 | 如果对象设为 "0x64616F6C" ("Set Value Dialog") ，所有的 terminal-specific 对象在交付状态重新设置。 | UINT32 | 读写 | 0x00000000 (0dez)
对象 0x4061 标志位（仅针对EL5001）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
4061:0 | 特征位 | 该对象长度 | UINT8 | 只读 | 0x04 (4dez)
4061:01 | 禁用错误帧 | 0： 不禁用错误帧 1： 禁用错误帧 | BOOLEAN | 读写 | 0x00 (0dez)
4061:02 | 电源故障使能位 | 0：电源故障位不激活 1：电源故障位激活：显示在帧的最后一位(特定编码器错误位)如同错误位在状态寄存器的Bit 2 一样。 | BOOLEAN | 读写 | 0x00 (0dez)
4061:03 | 禁止时间使能 | 0：禁止时间不激活 1：禁止时间激活 | BOOLEAN | 读写 | 0x00 (0dez)
4061:04 | 测试模式使能 | 0：测试模式不激活 1：测试模式激活 | BOOLEAN | 读写 | 0x00 (0dez)
对象 0x4066 SSI-编码（仅针对EL5001）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
4066:0 | SSI 编码 | 0：对偶码激活 1：格雷码激活 | UINT16 | 读写 | 0x0001 (1dez)
对象 0x4067 SSI-波特率（仅针对EL5001）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
4067:0 | SSI-波特率 | 0: 保留 1: 1250 kBaud 2: 1000 kBaud 3: 500 kBaud 4: 250 kBaud 5: 125 kBaud 6 - 65535: 保留 | UINT16 | 读写 | 0x0003 (3dez)
对象 0x4068 SSI 帧类型（仅针对EL5001）
索引 | 名称 | 意义 | 数据类型 | Flags | Default
4068:0 | SSI 帧类型 | 0: 多圈解析激活 (25位数据帧) 1: 单圈解析激活 (13位数据帧) 2: 可变数据帧长度解析激活。数据帧长度（1至32位）通过索引4069设定。 | UINT16 | 读写 | 0x0000 (0dez)
对象 0x4069 SSI 帧长度（仅针对EL5001）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
4069:0 | SSI 帧长度 | SSI 数据帧长度 | UINT16 | 读写 | 0x0019 (25dez)
对象 0x406A 数据长度（仅针对EL5001）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
406A:0 | 数据长度 | 数据长度 | UINT16 | 读写 | 0x0018 (24dez)
对象 0x406B 最小禁止时间（仅针对EL5001）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
406B:0 | 最小禁止时间[µs] | 最小禁止时间 （µs） | UINT16 | 读写 | 0x0000 (0dez)
索引8000 SSI设定（仅EL5002）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
8000:0 | SSI设定 | 对象的长度 | UINT8 | RO | 0x13 (19dez)
8000:01 | 禁用错误帧 | 0: 不禁用错误帧 1: 禁用错误帧 | BOOLEAN | RW | 0x00 (0dez)
8000:02 | 电源故障使能位 | 0:电源故障位不激活 1: 电源故障位激活: 显示在帧的最后一位(特定编码器错误位)如同错误位在状态寄存器的6000:03一样。 | BOOLEAN | RW | 0x00 (0dez)
8000:03 | 禁止时间使能 | 0: 不激活禁止时间 1: 激活禁止时间 | BOOLEAN | RW | 0x00 (0dez)
8000:04 | 测试模式使能 | 0: 测试模式不激活 1: 测试模式激活 | BOOLEAN | RW | 0x00 (0dez)
8000:06 | SSI编码 | 0:对偶码激活 1: 格雷码激活 | BIT1 | RW | 0x01 (1dez)
8000:09 | SSI波特率 | 0: 保留 1: 1250 kBaud 2: 1000 kBaud 3: 500 kBaud 4: 250 kBaud 5: 125 kBaud 6 - 65535: 保留 | BIT3 | RW | 0x03 (3dez)
8000:0F | SSI帧类型 | 0: 多圈解析激活 (25位数据帧) 1: 单圈解析激活 (13-位数据帧) 2: 可变数据帧长度解析激活。数据帧长度（1至32位）通过索引8000:11设定。 | BIT2 | RW | 0x00 (0dez)
8000:11 | SSI帧长度 | SSI数据帧长度 | UINT16 | RW | 0x0019 (25dez)
8000:12 | SSI数据长度 | 数据长度 | UINT16 | RW | 0x0018 (24dez)
8000:13 | 最小禁止时间 | 最小禁止时间µs | UINT16 | RW | 0x0000 (0dez)
索引8010 SSI设定（仅针对FW11及以上版本EL5001）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
8010:0 | SSI设定 | 对象的长度 | UINT8 | RO | 0x13 (19dez)
8010:01 | 禁用错误帧 | 0: 不禁用错误帧 1: 禁用错误帧 | BOOLEAN | RW | 0x00 (0dez)
8010:02 | 电源故障使能位 | 0: 电源故障位不激活 1: 电源故障位激活: 显示在帧的最后一位(特定编码器错误位)如同错误位在状态寄存器的6010:03一样。 | BOOLEAN | RW | 0x00 (0dez)
8010:03 | 禁止时间使能 | 0: 不激活禁止时间 1: 激活禁止时间 | BOOLEAN | RW | 0x00 (0dez)
8010:04 | 测试模式使能 | 0: 测试模式不激活 1: 测试模式激活 | BOOLEAN | RW | 0x00 (0dez)
8010:06 | SSI编码 | 0: 对偶码激活 1: 格雷码激活 | BIT1 | RW | 0x01 (1dez)
8010:09 | SSI波特率 | 0: 保留 1: 1250 kBaud 2: 1000 kBaud 3: 500 kBaud 4: 250 kBaud 5: 125 kBaud 6 - 65535: 保留 | BIT3 | RW | 0x03 (3dez)
8010:0F | SSI帧类型 | 0: 多圈解析激活 (25位数据帧) 1: 单圈解析激活 (13-位数据帧) 2: 可变数据帧长度解析激活。数据帧长度（1至32位）通过索引8010:11设定。 | BIT2 | RW | 0x00 (0dez)
8010:11 | SSI帧长度 | SSI数据帧长度 | UINT16 | RW | 0x0019 (25dez)
8010:12 | SSI数据长度 | 数据长度 | UINT16 | RW | 0x0018 (24dez)
8010:13 | 最小禁止时间[µs] | 最小禁止时间µs | UINT16 | RW | 0x0000 (0dez)

常规操作对象

EL5001没有特别的对象用于强化工作模式下。

其他对象

标准对象 (0x1000-0x1FFF)

EtherCAT从站的标准目标对象都具有相同的意义。

对象 1000 设备类型
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
1000:0 | 设备类型 | EtherCAT从站的设备类型：低位字包含支持的CoE属性（5001）。高位字包含了模块属性。 | UINT32 | 只读 | EL5001: 0x00001389 (5001dez) EL5002: 0x01F51389 (32838537dez)
对象 1008 硬件版本
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
1008:0 | 设备名称 | EtherCAT 从站的设备名称 | STRING | 只读 | EL5001
对象 1009 硬件版本
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
1009:0 | 硬件版本 | EtherCAT 从站的硬件版本 | STRING | 只读 | 09
对象 100A 软件版本
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
100A:0 | 软件版本 | EtherCAT 从站的固件版本 | STRING | 只读 | 11
对象 1018 标示对象
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
1018:0 | 标示对象 | 包含Ether CAT 从站标示信息 | UINT8 | 只读 | 0x04 (4dez)
1018:01 | 制造商 ID | EtherCAT 从站制造商 | UINT32 | 只读 | 0x00000002 (2dez)
1018:02 | 产品代码 | EtherCAT 从站产品代码 | UINT32 | 只读 | EL5001: 0x13893052 (327757906dez) EL5002: 0x138A3052 (327823442dez)
1018:03 | 修订号 | EtherCAT 从站修订号，低位字显示特殊功能模块号码，高位字表示设备描述 | UINT32 | 只读 | EL5001: 0x03F90000 (66650112dez) EL5002: 0x00100000 (1048576dez)
1018:04 | 序列号 | EtherCAT 从站序列号，.低位字的低八位（0-7位）表示生产年份，高八位（8-15位）表示生产周，高位字（16-31位）为0。 | UINT32 | 只读 | 0x00000000 (0dez)
索引10F0 备份参数处理
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
10F0:0 | 备份参数处理 | 包含标准上传下载备份条目的信息 | UINT8 | RO | 0x01 (1dez)
10F0:01 | 校验和 | 所有备份条目的校验和 | UINT32 | RO | 0x00000000 (0dez)
索引1800 TxPDO 001映射（仅EL5001）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
1800:0 | TxPDO 001 映射 | PDO 参数 TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | TxPDOs 除外 | 该条目包含了不通过TxPDO1传输的TxPDO（TxPDO映射对象的索引） | OCTET-STRING[2] | RO | 01 1A
索引1801 SSI TxPDO-Par 输入（仅EL5001）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
1801:0 | SSI TxPDO-Par输入 | PDO 参数 TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1801:06 | TxPDO 以外 | 该条目包含了不通过TxPDO2传输的TxPDO（TxPDO映射对象的索引） | OCTET-STRING[2] | RO | 00 1A
1801:07 | TxPDO 状态 | 如果相应的输入数据不能正常地读取，TxPDO状态会被置位 | BOOLEAN | RO | 0x00 (0dez)
1801:09 | TxPDO 触发 | 每一次对应的输入数据更新TxPDO触发位都会置位。 | BOOLEAN | RO | 0x00 (0dez)
对象 1A00 TxPDO 001 映射（仅针对EL5001）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
1A00:0 | TxPDO 001 映射 | TxPDO1映射PDO1 | UINT8 | 只读 | 0x02 (2dez)
1A00:01 | 子索引001 | 1.PDO映射条目（对象0x6000（SSI输入），条目0x01（数据错误）） | UINT32 | 只读 | 0x3101:01, 8
1A00:02 | 子索引002 | 2. PDO映射条目（对象0x6000（SSI输入），条目0x02（帧错误）） | UINT32 | 只读 | 0x3101:02, 32
索引 1A00 SSI TxPDO 映射输入（仅针对EL5002）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
1A00:0 | SSI TxPDO映射输入 | TxPDO1映射PDO | UINT8 | RO | 0x08 (8dez)
1A00:01 | 子索引001 | 1.PDO映射条目（对象0x6000（SSI输入），条目0x01（数据错误）） | UINT32 | RO | 0x6000:01, 1
1A00:02 | 子索引002 | 2. PDO映射条目（对象0x6000（SSI输入），条目0x02（帧错误）） | UINT32 | RO | 0x6000:02, 1
1A00:03 | 子索引003 | 3.PDO映射条目（对象0x6000（SSI输入），条目0x03（电源故障）） | UINT32 | RO | 0x6000:03, 1
1A00:04 | 子索引004 | 4. PDO映射条目(10bits排列) | UINT32 | RO | 0x0000:00, 10
1A00:05 | 子索引005 | 5.PDO映射条目(索引0x1C32，条目0x20) | UINT32 | RO | 0x1C32:20, 1
1A00:06 | 子索引006 | 6. PDO映射条目(索引0x1800，条目0x07) | UINT32 | RO | 0x1800:07, 1
1A00:07 | 子索引007 | 7. PDO映射条目(索引0x1800，条目0x09) | UINT32 | RO | 0x1800:09, 1
1A00:08 | 子索引008 | 8. PDO映射条目(索引0x6000（SSI输入），条目0x11（计数值）) | UINT32 | RO | 0x6000:11, 32
索引 1A01 SSI TxPDO 映射输入（仅针对FW11及以上版本EL5001）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
1A01:0 | SSI TxPDO映射输入 | TxPDO2映射PDO | UINT8 | RO | 0x08 (8dez)
1A01:01 | 子索引001 | 1. PDO映射条目(索引0x6000（SSI输入），条目0x12（时间戳）) | UINT32 | RO | 0x6010:01, 1
1A01:02 | 子索引002 | 2. PDO映射条目(索引0x6010（SSI输入），条目0x02（帧错误）) | UINT32 | RO | 0x6010:02, 1
1A01:03 | 子索引 003 | 3. PDO映射条目(索引0x6010（SSI输入），条目0x03（时间戳）) | UINT32 | RO | 0x6010:03, 1
1A01:04 | 子索引 004 | 4. PDO映射条目(10bits排列) | UINT32 | RO | 0x0000:00, 10
1A01:05 | 子索引 005 | 5. PDO映射条目(索引0x1C32，条目0x20) | UINT32 | RO | 0x1C32:20, 1
1A01:06 | 子索引 006 | 6. PDO映射条目(索引0x1801（SSITxPDO-Par输入），条目0x07（TxPDO状态）) | UINT32 | RO | 0x1801:07, 1
1A01:07 | 子索引 007 | 7.PDO映射条目(索引0x1801（SSITxPDO-Par输入），条目0x09（TxPDO触发）) | UINT32 | RO | 0x1801:09, 1
1A01:08 | 子索引 008 | 8. PDO映射条目(索引0x6010（SSI输入），条目0x11（计数值）) | UINT32 | RO | 0x6010:11, 32
对象 1C00 同步管理类型
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
1C00:0 | 同步管理类型 | 同步管理通道用法 | UINT8 | 只读 | 0x04 (4dez)
1C00:01 | 同步管理-参数1 | 同步管理类型通道1：写邮箱 | UINT8 | 只读 | 0x01 (1dez)
1C00:02 | 同步管理-参数2 | 同步管理类型通道2：读邮箱 | UINT8 | 只读 | 0x02 (2dez)
1C00:03 | 同步管理-参数3 | 同步管理类型通道3：写过程变量（输出） | UINT8 | 只读 | 0x03 (3dez)
1C00:04 | 同步管理-参数4 | 同步管理类型通道4：读过程数据（输入） | UINT8 | 只读 | 0x04 (4dez)
Index 1C12 RxPDO assign
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dez)
对象 1C13 TxPDO 分配
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dez)
1C13:01 | Subindex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02** | SubIndex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RO | 0x1A01 (6657dez)

**) 仅EL5002

索引 1C33 SM输入参数（仅针对FW11及以上版本EL5001）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
1C33:0 | SM输入参数 | 输入的同步参数 | UINT8 | RO | 0x20 (32dez)
1C33:01 同步模式 实际同步模式
  • 0: 自由运行
  • 1: 与SM3事件同步（没有输出）
  • 2: 与SYNC0事件DC同步
  • 3: 与SYNC1事件DC同步
  • 34: 与SM2事件同步（有输出）
 UINT16 RW 0x0022 (34dez)
1C33:02 循环时间 循环时间（ns）:
  • 自由运行：本地时钟的循环时间
  • 与SM2事件同步：主站的循环时间
  • DC模式：SYNC0/SYNC1循环时间
 UINT32 RW 0x000F4240 (1000000dez)
1C33:03 | 切换时间 | SYNC0事件和输入锁存之间的时间（ns，仅在DC模式） | UINT32 | RO | 0x00000000 (0dez)
1C33:04 支持的同步模式 支持的同步模式：
  • 位0：支持自由运行模式
  • 位1：支持与SM2事件同步（有输出）
  • 位1：支持与SM3事件同步（没有输出）
  • 位2-3=01：支持DC模式
  • 位4-5=01：由本地事件转换输入（有输出）
  • 位4-5=10：由SYNC1事件转换输入（没有输出）
  • 位14=1：动态时间（能够通过写1C33:08 来测量）
 UINT16 RO 0xC007 (49159dez)
1C33:05 | 最小循环时间 | 支持最小循环时间（ns） | UINT32 | RO | 0x00014C08 (85000dez)
1C33:06 | 计算和复制时间 | 输入锁存到主站获得输入之间的时间（ns，仅DC模式） | UINT32 | RO | 0x00000000 (0dez)
1C33:07 | 最小延迟时间 | 最小延迟时间 | UINT32 | RO | 0x00000000 (0dez)
1C33:08 命令 在这个条目中，能够实现测量过程数据分配的时间
  • 0: 停止测量时间
  • 1: 开始测量时间

条目1C33:03,1C33:06，1C33:09将会根据最大测量值进行更新。

为了后续的测量，测量值将会被重置。

UINT16 RW 0x0000 (0dez)
1C33:09 | 最大延迟时间 | SYNC1时间和输入锁存之间的时间 | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM事件丢失计数器 | 在OP状态下，SM事件丢失的数量（仅DC模式） | UINT16 | RO | 0x0000 (0dez)
1C33:0C | 周期超出计数 | 在OP状态下，周期超出的数量 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | 切换太短计数 | SYSC0和SYNC1事件距离太短的数量（仅DC模式） | UINT16 | RO | 0x0000 (0dez)
1C33:20 | 同步错误 | TRUE：上个周期发生同步错误（仅DC模式） | BOOLEAN | RO | 0x00 (0dez)
对象 3101 输入（仅针对EL5001）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
3101:0 | 输入 | 该对象长度 | UINT8 | 只读 | 0x02 (2dez)
3101:01 | 状态 | 状态字节 | UINT8 | 只读 | 0x00 (0dez)
3101:02 | 输入数据 | 过程变量输入 | UINT32 | 只读 | 0x00000000 (0dez)

属性指定的对象(0x6000-0xFFFF)

属性指定的对象和所有支持5001属性的EtherCAT从站具有相同的意义。

索引 6000 SSI 输入（仅EL5002）

索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
6000:0 | SSI输入 | 对象的长度 | UINT8 | RO | 0x11 (17dez)
6000:01 | 数据错误 | SSI输入错误: - SSI没有供电 - SSI数据输入D+,D-断线 - 数据线交换 如果没有数据通信，SSI输入为低电平 | BOOLEAN | RO | 0x00 (0dez)
6000:02 | 帧错误 | 数据帧错误，如，数据帧没有以0结尾。（可能是时钟电缆断路） | BOOLEAN | RO | 0x00 (0dez)
6000:03 | 电源故障 | 发生明显的编码器错误。这个错误位仅在索引8000：02被激活时才会显示。 | BOOLEAN | RO | 0x00 (0dez)
6000:0E | 同步错误 | 上个周期发生同步错误（仅在DC模式） | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO状态 | TxPDO关联数据的有效性（0=有效，1=无效） | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO触发 | 如果从站上相应的PDO数据有更新，TxPDO触发器将会被触发。 | BOOLEAN | RO | 0x00 (0dez)
6000:11 | 计数值 | 计数值 | UINT32 | RO | 0x00000000 (0dez)
索引 6010 SSI 输入（仅EL5001 FW11及以上版本）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
6010:0 | SSI输入 | 对象的长度 | UINT8 | RO | 0x11 (17dez)
6010:01 | 数据错误 | 输入错误: - SSI没有供电 - SSI数据输入D+,D-断线 - 数据线交换如果没有数据通信，SSI输入为低电平 | BOOLEAN | RO | 0x00 (0dez)
6010:02 | 帧错误 | 数据帧错误，如，数据帧没有以0结尾。（可能是时钟电缆断路） | BOOLEAN | RO | 0x00 (0dez)
6010:03 | 电源故障 | 发生明显的编码器错误。这个错误位仅在索引8010：02被激活时才会显示。 | BOOLEAN | RO | 0x00 (0dez)
6010:0E | 同步错误 | 上个周期发生同步错误（仅在DC模式） | BOOLEAN | RO | 0x00 (0dez)
6010:0F | TxPDO状态 | TxPDO关联数据的有效性（0=有效，1=无效） | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO触发 | 如果从站上相应的PDO数据有更新，TxPDO触发器将会被触发。 | BOOLEAN | RO | 0x00 (0dez)
6010:11 | 计数值 | 计数值 | UINT32 | RO | 0x00000000 (0dez)
索引F000 模块设备属性（EL5001 FW11及以上版本）
索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
F000:0 | 模块设备属性 | 模块设备属性的通用信息 | UINT8 | RO | 0x02 (2dez)
F000:01 | 模块索引距离 | 两个通道对象间索引的距离 | UINT16 | RO | 0x0010 (16dez)
F000:02 | 模块的最大数量 | 通道数 | UINT16 | RO | 0x0002 (2dez)

索引F008 编码字（EL5001 FW11及以上版本）

索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
F008:0 | 编码字 | 保留 | UINT32 | RW | 0x00000000 (0dez)

索引F010 模块列表（EL5001 FW11及以上版本）

索引 | 名称 | 意义 | 数据类型 | 标记 | 默认值
F010:0 | 模块列表 | 对象的长度 | UINT8 | RW | 0x02 (2dez)
F010:01 | 子索引001 | - | UINT32 | RW | 0x000001F4 (500dez)
F010:02 | 子索引002 | - | UINT32 | RW | 0x000001F5 (501dez)


191

BECKHOFF EL5001: 调试

控制与状态字节

状态字节

状态字节（SB）位于输入过程数据中，从模块传输至控制器。

位 | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
名称 | - | 错误 | - | - | - | 电源故障 | 帧错误 | SSI 内部错误
说明
位 | 名称 | 意义
SB.7 | - | 0bin | 保留
SB.6 | 错误 | 1bin | 某个帧或者SSI内部错误发生。
SB.5 | - | 0bin | 保留
SB.4 | - | 0bin | 保留
SB.3 | - | 0bin | 保留
SB.2 | 电源故障 | 1bin | 特殊编码器错误。该错误仅发生在index 4061:02被激活的情况下。
SB.1 | 帧错误 | 1bin | 数据帧错误，例如数据帧没有以零作为结束（可能时钟电缆发生断路）。
SB.0 | SSI 内部错误 | 1bin | SSI 输入错误： - SSI 没有供电 - SSI 数据输入 D+ or D- 断线 - 数据电缆交错 如果没有数据通讯，SSI 模块输入端为低电平。

控制字节

EL5001 没有控制字节。


UL Requirements

BECKHOFF EKxxxx, ELxxxx: 附录

UL 认证说明

应用
Beckhoff的EtherCAT模块只能用于UL列出的EtherCAT系统。
检查
在cULus测试中，Beckhoff I/O系统只调查了其防火性和耐电击性。（与UL508和CSA C22.2 No.142一致）
用于有以太网连接器的设备
不适用于连接无线电通讯电路。

基本原理

两个UL证书都在Beckhoff产品领域里，依赖于不同的组件：

  • UL 证书依据UL508
    有这个证书的产品都有如下标记：

  • UL证书依据UL508有限制功耗
    设备的电流损耗是有最大限制的。可能有4A的电流损耗。有这个证书的产品都有如下标记：

几乎现在所有的EtherCAT产品（如2010/05)都经UL认证没有限制条件。

应用

如果端口的使用是受限制的，那么在24v直流电下的电流损耗也是有限的，由电源大小决定

  • or 保险丝为最大4A的独立电源保护(根据UL248)
  • 电压输入依照NEC class 2.
    一个遵照NEC Class2的电压源不可以与另外的NEC Class2电压源串联或者并联！
这些要求应用于所有EtherCAT总线耦合器，电源配适器端口，总线终端和其电源接口。
195


254

BECKHOFF EL500x 附录

固件兼容性

Beckhoff EtherCAT设备在交付时装备了最新的固件。固件和硬件之间存在一定的依赖性，不是所有的组合都能兼容。
下面是固件与硬件兼容的概述。

注意

  • 强烈建议在特殊的硬件上使用最新有效的固件。
  • 倍福公司先前交付的免费产品没有固件升级的客户权限。

注意 		设备可能的危险!
请在special page注意关于固件升级的细节。
如果在引导程序模式运行设备来给固件升级，可能未校验固件的兼容性。
这可能有设备损坏的危险!
请确保固件适合的硬件设备状态！
EL5001
硬件 (HW) | 固件 (FW) | 版本 No. | 文件名，发布日期
05 | 08 | EL5001-0000-0000 | EL5001_08.efw, 2005/01
05 - 06 | 09 |  | EL5001_09.efw, 2005/03
07 - 08 | 10 |  | EL5001_10.efw, 2005/07
09 - 10* | 11 | EL5001-0000-0017 | EL5001_11.efw, 2009/10
 | 12* |  | EL5001_12.efw, 2010/11
EL5001-0011
硬件 (HW) | 固件 (FW) | 版本 No. | 文件名，发布日期
01 - 03* | 01* | EL5001-0011-0016 | EL5001-0011_01.efw, 2009/04
EL5002
硬件 (HW) | 固件 (FW) | 版本 No. | 文件名，发布日期
00* | 01 | EL5002-0000-0016 | EL5002_01.efw, 2009/10
 | 02* | EL5002-0000-0017 | EL5002_02.efw, 2011/02

*) 在创建这个文件时兼容硬件的状态。请查阅 Beckhoff的最近文件的页面。


0

BECKHOFF ELxxxx: 配置

恢复出厂设置

恢复ELxxxx端子模块的出厂设置, 在TwinCAT System Manager的CoE对象 "Restore default parameters"中, 选择SubIndex 001 子项 (配置模式) (见图1)

图 1 选择 "Restore default parameters" PDO

双击SubIndex 001进入参数设定对话框。 输入 1684107116十进制或0x64616F6C十六进制，并点击 OK (图2).
所有数据恢复出厂设置

图 2 在设置值对话框中输入复位码

说明 		其他复位码

某些老端子模块请使用以下复位码：

十进制: "1819238756"

十六进制: "0x6C6F6164"

输入错误的复位码无效。


14

BECKHOFF Automation: 附录

技术支持与售后

Beckhof f 及其合作伙伴遍布世界各地，可为您提供全方位的技术支持与服务，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff 分公司及代表处

有关 Beckhoff 产品的本地技术支持和服务信息，请联系当地的 Beckhoff 分公司和代表处。

有关 Beckhoff 在全球各地分公司和代理商的地址，您可以登录Beckhoff 的官方网站：
http://www.beckhoff.com

此外，您也可以在该网站上查看更多关于 Beckhoff 组件的文档资料。

Beckhoff 总部

德国倍福自动化有限公司

Eiserstr. 5
33415 Verl
Germany

电话： | +49(0)5246/963-0
传真： | +49(0)5246/963-198
电子邮箱： | info@beckhoff.com
Beckhoff 技术支持

Beckhoff为您提供全面的技术支持，除了Beckhoff 具体产品的应用以外，还包括更广泛的服务：

  • 技术支持
  • 复杂自动化系统的设计、编程和调试
  • 各种 Beckhoff 系统组件培训方案
热线： | +49(0)5246/963-157
传真： | +49(0)5246/963-9157
电子邮箱： | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心提供全方位的售后技术服务：

  • 现场服务
  • 维修服务
  • 零部件服务
  • 热线服务
热线： | +49(0)5246/963-460
传真： | +49(0)5246/963-479
电子邮箱： | service@beckhoff.com


EL5001-0011 - Object description and parameterization

BECKHOFF EL5000-0011: Commissioning

Object description and parameterization

Note 		EtherCAT XML Device Description
The description correspond to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website (http://www.beckhoff.com/english/default.htm?download/elconfg.htm) and follow the installation instructions.

Note 		Parameterization
Terminals' parameterization will be conducted by the CoE tab (double-click on the referring object) or the Process data tab (PDO assignment)

Introduction

The CoE overview contains objects for different intended applications:

  • Objects required for parameterization during commissioning
  • Objects intended for regular operation, e.g. through ADS access.
  • Objects for indicating internal settings (may be fixed)

The following section first describes the objects require for normal operation, followed by a complete overview of other objects.

Objects for commissioning

Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore the default settings in the EtherCAT slave | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" ("Set Value Dialog") all terminal-specific objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 SSI Settings
Index | Name | Meaning | Datentyp | Flags | Default
8000:0 | SSI Settings | Length of this object | UINT8 | RO | 0x13 (19dez)
8000:01 | Disable frame error | 0: Frame error is not suppressed 1: Frame error is suppressed | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Enable power failure bit | 0: Power failure bit is not active 1: Power failure bit is active: The last bit of the data frame (encoder-specific error bit) is shown as error bit in 6000:03 of the status register. | BOOLEAN | RW | 0x00 (0dez)
8000:05 | Check SSI-frame size | Activates "SSI-frame size" check . If there is a difference between the values of Index 8000:11 and A000:01, the "Frame error" bit (6000:02) is set | BOOLEAN | RW | 0x00 (0dez)
8000:06 | SSI-coding | 0: Dual code active 1: Gray code active | BIT1 | RW | 0x01 (1dez)
8000:0F | SSI-frame type | 0: Multi-turn analysis is active (25-bit data frame) 1: Single-turn-analysis is active (13-bit data frame) 2: Variable analysis is active. The length of the data frame (1 to 32 bit) is specified via Index 8000:11. | BIT2 | RW | 0x00 (0dez)
8000:11 | SSI-frame size | Length of the SSI data frame in bits | UINT16 | RW | 0x0019 (25dez)
8000:12 | SSI-data length | Data length | UINT16 | RW | 0x0018 (24dez)

Objects for regular operation

Tthe EL5000-0011 has no such objects.

Other objects

Standard objects (0x1000-0x1FFF)

The standard objects of all EtherCAT slaves have the same meaning.

Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device Type of the EtherCAT slave: The Lo-Word contains the supported CoE Profile (5001). The Hi-Word contains the Module Profile corresponding to the Modular Device Profile. | UINT32 | RO | 0x01F51389 (32838537dez)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EL5001-0011
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slaves | STRING | RO | -
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slaves | STRING | RO | -
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | contains informations to identify the EtherCAT slave | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x13893052 (327757906dez)
1018:03 | Revision | Revision number of the EtherCAT-Slave, the Lo-Word (Bit 0-15) indicates the special functions terminal number; the Hi-Word (Bit 16-31) refers to the device description. | UINT32 | RO | 0x0010000B (1048587dez)
1018:04 | Serial number | Serial number of the EtherCAT-Slave, the Lo-Byte (Bit 0-7) of the Lo-Word contains the year of manufacturing, the Hi-Byte (Bit 8-15) of the Lo-Word contains the week of manufacturing, the Hi-Word (Bit 16-31) is 0 . | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | contains informations for the standardized Upload and Download of the Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksum over all backup entries | UINT32 | RO | 0x00000000 (0dez)
Index 1801 SSI TxPDO-Par Timest.
Index | Name | Meaning | Datentyp | Flags | Default
1801:0 | SSI TxPDO-Par Timest. | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 2 | OCTET-STRING[2] | RO | 02 1A
Index 1802 SSI TxPDO-Par Timest. comp.
Index | Name | Meaning | Datentyp | Flags | Default
1802:0 | SSI TxPDO-Par Timest. comp. | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | This entry contains the TxPDOs (Index of the TxPDO Mapping objects) which shall not be transmitted with TxPDO 3 | OCTET-STRING[2] | RO | 01 1A
Index 1A00 SSI TxPDO-Map Inputs
Index | Name | Meaning | Datentyp | Flags | Default
1A00:0 | SSI TxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x01 (Data error)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x02 (Frame error)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x03 (Power failure)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x0E (Sync Error)) | UINT32 | RO | 0x6000:0E, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1800, entry 0x07) | UINT32 | RO | 0x1800:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1800, entry 0x09) | UINT32 | RO | 0x1800:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A01 SSI TxPDO-Map Timest.
Index | Name | Meaning | Datentyp | Flags | Default
1A01:0 | SSI TxPDO-Map Timest. | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x12 (Timestamp)) | UINT32 | RO | 0x6000:12, 64
Index 1A02 SSI TxPDO-Map Timest. comp.
Index | Name | Meaning | Datentyp | Flags | Default
1A02:0 | SSI TxPDO-Map Timest. comp. | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x12 (Timestamp)) | UINT32 | RO | 0x6000:12, 32
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index | Name | Meaning | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dez)
Index 1C13 TxPDO assign
Index | Name | Meaning | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dez)
1C13:01 | Subindex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x0000 (0dez)
Index 1C33 SM input parameter
Index | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Synchronization parameter of the inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 Sync mode actual synchronization mode:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (no Outputs available)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs available)
 UINT16 RW 0x0022 (34dez)
1C33:02 Cycle time Cycle time (in ns):
  • Free Run: cycle time of the local timer
  • Synchron with SM 2 Event: Cycle time of the master
  • DC-Mode: SYNC0/SYNC1 Cycle time
 UINT32 RW 0x000F4240 (1000000dez)
1C33:03 | Shift time | time between SYNC0-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:04 Sync modes supported Supported synchronization modes:
  • Bit 0: Free Run is supported
  • Bit 1: Synchron with SM 2 Event is supported (Outputs available)
  • Bit 1: Synchron with SM 3 Event is supported (no Outputs available)
  • Bit 2-3 = 01: DC-Mode is supported
  • Bit 4-5 = 01: Input Shift with local event (Outputs available)
  • Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available)
  • Bit 14 = 1: dynamic times (could be measured by writing 1C33:08)
 UINT16 RO 0xC007 (49159dez)
1C33:05 | Minimum cycle time | Minimum cycle time supported (in ns) | UINT32 | RO | 0x00014C08 (85000dez)
1C33:06 | Calc and copy time | time between Input Latch and the availability of the inputs for the master (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:07 | Minimum delay time | Minimum delay time | UINT32 | RO | 0x00000000 (0dez)
1C33:08 Command With this entry, a measurement of the real required process data allocation time can be realized.
  • 0: Measurement of the times will be stopped
  • 1: Measurement of the times will be started

The Entries 1C33:03, 1C33:06, 1C33:09 will be updated with the maximum measured values.
For a subsequent measurement the measured values are reset

UINT16 RW 0x0000 (0dez)
1C33:09 | Maximum Delay time | time between SYNC1-Event and Input Latch (in ns, only in DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | Number of the missed SM-Events in state OPERATIONAL (only in DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | Number of the exceeded cycles in state OPERATIONAL | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | Number of the too short distances between SYNC0 and SYNC1 Event (only in DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error | TRUE: In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RO | 0x00 (0dez)

Profile specific objects (0x6000-0xFFFF)

The profile specific objects have the same meaning for all EtherCAT Slaves which support the profile 5001.

Index 6000 SSI Inputs
Index | Name | Meaning | Datentyp | Flags | Default
6000:0 | SSI Inputs | Length of this object | UINT8 | RO | 0x11 (17dez)
6000:01 | Data error | SSI input error: - SSI without power supply - Broken wire at SSI data inputs D+ or D- - Data cables interchanged If no data communication takes place the SSI input of the terminal is on low level. | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Frame error | The data frame is wrong, i.e. the data frame was not terminated with zero (perhaps wire breakage on clock cables). | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Power failure | A encoder-specific error has occurred. This error bit is only displayed if it was previously activated through Index 8000:02. | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | In the last cycle the synchronization was not correct (only in DC Mode) | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO (0 = valid, 1 = invalid). | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | The TxPDO Toggle is toggled by the slave, if the data of the corresponding PDO was updated. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Counter value | UINT32 | RO | 0x00000000 (0dez)
6000:12 | Timestamp | Timestamp of the last detected counter value | UINT64 | RO | 0x0000000000000000(0dez)
Index A000 SSI Diag data
Index | Name | Meaning | Datentyp | Flags | Default
A000:0 | SSI Diag data | Length of this object | UINT8 | RO | 0x01 (1dez)
A000:01 | Detected SSI-frame size | Size of the SSI-frame detected by the terminal | UINT8 | RO | 0x00 (0dez)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information's about the Modular Device Profile | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Index distance between the objects of two channels | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0002 (2dez)
Index F008 Code word
Index | Name | Meaning | Datentyp | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index | Name | Meaning | Datentyp | Flags | Default
F010:0 | Module list | Length of this object | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 | - | UINT32 | RW | 0x000001F4 (500dez)
F010:02 | SubIndex 002 | - | UINT32 | RW | 0x000001F5 (501dez)

91

Extracted by Trial version of ChmDecompiler (Download Now).

Once registered, all restrictions of the Trial version are removed.

Buy Now