EL7031, EL7041-x00x - Stepper Motor Terminal

BECKHOFF 现场总线组件

EL7031

步进电机端子模块, 24 V DC, 1,5 A

EL7041-x00x

步进电机端子模块, 50 V DC, 5 A, 带增量编码器

的技术文档

版本 1.5
日期: 2011-08-25

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Safety Instructions

BECKHOFF 自动化: 前言

安全说明书

安全条例

相关的责任人必须保证在应用或使用产品前应满足所有安全需求的说明，包括所有相关的法律、规则、指南和标准。

交付说明

所有组件均针对其具体应用进行了特定的软、硬件配置。任何人不得对软、硬件配置进行本文档中规定之外的修改，德国倍福自动化有限公司对因此而造成的一切后果不承担任何责任。

人员资质

本手册仅供那些受过适当培训，熟悉各种适用国家标准的“控制、自动化和驱动工程”领域专业人员使用。

安全符号说明

以下是本操作手册所用到的安全符号，提醒读者相关安全说明。

DANGER 		严重损害风险！
如果您不注意此符号而进行操作,会立即给您的生命与健康带来危险!

WARNING 		损害风险！
如果您不注意此符号而进行操作,会给您的生命与健康带来危险!

CAUTION 		个人危险！
如果您不注意此符号而进行操作,会给个人带来明显的危险!

Attention 		环境与设备危险！
如果您不注意此符号而进行操作,会给环境与设备带来明显的危险!

Note 		注意事项！
此符号用于显示说明及信息,有助于更好的理解!
UL 标识
此符号用于显示关于UL-compliant的重要信息.


EL7031, EL7041-x00x - Documentation Issue Status

BECKHOFF EL7031, EL7041-x00x: 前言

文档发行状况

版本 | 注释
1.5 | - 附加的 CoE 对象
1.4 | - 附加的 CoE 对象, 增加技术说明
1.3 | - 增加应用例子, 增加技术说明
1.2 | - 技术参数 & 增加对象说明
1.1 | - 附加的 CoE 对象, 增加 EL7041-0001
1.0 | - 修正, 发布第一版
0.2 - 0.5 | - 修正 & 附录
0.1 | - EL7041的预备文档


EL7031 - Technical Data

BECKHOFF EL7031: 产品概述

EL7031 - 技术参数

技术参数 | EL7031
输出点数 | 1 步进电机, 2 相
输入点数 | 2
电源输出等级 (通过电源触点) | 8 VDC 到 24 VDC
电源电压 | 24 V DC 通过电源触点, 通过 E-bus
输出电流 | 2 x 1 A, 2 x 1.5 峰值电流，过载和短路保护
最大步频 | 1,000, 2,000, 4,000 或 8,000 步/秒 (可配置)
步模式 | 全步，半步，最大 64 细分
电流控制器频率 | 约 25 kHz
输入信号电压 „0“ | -3 V … 2 V
输入信号电压 „1“ | 2.5 V … 28 V
输入电流 | 5 mA
诊断 LED | 故障相位 A 和 B，失步/停转，电源，使能
分辨率 | 典型应用中约 5000 个位置（每转）
电源 | 通过 E-Bus, 编码器/驱动级/电机: 通过电源触点
E-bus 电流消耗 | 120 mA
电气隔离 | 500 Vrms (E-bus/信号电压)
配置 | 无地址设置, 通过 TwinCAT System Manager 配置
尺寸 | 约 27mm x 100 mm x 70 mm (宽度对齐: 24 mm)
重量 | 约 105 g
工作温度 | 0 °C ... +55 °C
储藏温度 | -25 °C ... +85 °C
相对湿度 | 95%，无冷凝
安装 | 安装在35 mm 导轨上并符合 EN 50022
抗振/抗冲击性能 | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
抗电磁干扰/抗电磁辐射性能 | 符合 EN 61000-6-2 / EN 61000-6-4
防护等级 | IP 20
安装位置 | 可变
认证 | CE UL


EL7041-x00x - Introduction

BECKHOFF EL7041-x00x: 产品概述

EL7041-x00x - 介绍

步进电机端子模块, 50 V DC, 5 A, 带增量编码器

EL7041-x00x EtherCAT 端子模块用于连接中等性能的步进电机。PWM 输出端适用于各种电压和电流。 EtherCAT端子模块中有限位开关的两个输入端。 仅通过更改几个参数，EL7041-x00x即可适用于特定的电机和应用场合。64 细分可保证电机运行平稳、精确。 若与步进电机配套使用, EL7041-x00x 可作为一个经济的小型伺服轴。 EL7041-x00x 步进电机端子模块仅通过更改几个参数即可适用于特定的电机。

快速链接

连接说明

• 章节 "安装及接线"，
- LED显示与接口
- 接线举例

启动说明

• 章节 "启动"，
- 插入端子模块到 EtherCAT 端子模块网络中
- 集成到 NC configuration 中

配置说明

• 章节 "启动"，
- 主要参数的配置

• 章节 "TwinCAT System Manager的配置"，
- 对象描述与参数设定

应用案例

• 章节 "启动"，
- 应用案例


EL7041-x00x - Technical Data

BECKHOFF EL7041-x00x: 产品概述

EL7041-x00x - 技术参数

技术参数 | EL7041-0000 | EL7041-0001 | EL7041-1000
输出点数 | 1 步进电机, 2 相
输入点数 | 2个限位位置, 4个用于编码器系统 | 1个限位位置, 4个用于编码器系统 | 2个限位位置, 4个用于编码器系统
数字输出点数 | - | 1 输出 (可配置为 制动) | -
电源电压 | 8…50 V DC
输出电流 | 2 x 3.5 A, 2 x 5 A 峰值电流
最大步频 | 1,000, 2,000, 4,000 或 8,000 步/秒 (可配置)
步模式 | 64 细分
电流控制器频率 | 约 30 kHz
编码器脉冲频率 | 最大 400,000 增量/秒 (4倍计数)
输入信号电压 „0“ | -3 V … 2 V
输入信号电压 „1“ | 2.5 V … 28 V
输入电流 | 5 mA
诊断 LED | 故障相位 A 和 B, 电源, 使能
分辨率 | 典型应用中约 5000 个位置（每转）
电源 | 通过 E-Bus, 编码器/驱动级/电机: 通过电源触点
E-bus 电流消耗 | 140 mA
电气隔离 | 500 Vrms (E-bus/信号电压)
配置 | 无地址设置, 通过 TwinCAT System Manager 配置
尺寸 | 大约 27mm x 100 mm x 70 mm (宽度对齐: 24 mm)
重量 | 大约 105 g
工作温度 | 0 °C ... +55 °C
储藏温度 | -25 °C ... +85 °C
相对湿度 | 95%, 无冷凝
安装 | 安装在35 mm 导轨上并符合 EN 50022
抗振/抗冲击性能 | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
抗电磁干扰/抗电磁辐射性能 | 符合 EN 61000-6-2 / EN 61000-6-4
防护等级 | IP 20
安装位置 | 可变
认证 | CE UL


EL7031, EL7041-x00x, EP7041-000x operating modes

BECKHOFF EL7031, EL7041-x00x, EP7041-000x: 产品概述

运行模式

当前只支持"Velocity, direct"模式. 更多的运行模式在准备中.

Velocity, direct

这个模式是专门为数字控制器(NC)的循环速度接口准备的.在这个模式中,NC指定了一个具体的速度,启动的斜坡与电机的减速也由NC控制.


CoE-Interface

BECKHOFF EtherCAT: 基础通信

CoE-接口

CoE接口用于对EtherCAT设备进行参数管理，在CAN-over-EtherCAT (CoE)管理中，特定的固件参数可以EtherCAT中在线或离线配置.

CoE接口的具体信息可以在Beckhoff网站的 EtherCAT 系统文档 中找到.


ELxxxx, KLxxxx - Installation on mounting rails

BECKHOFF 现场总线组件: 安装与接线

导轨上的安装

WARNING 		有触电与损坏设备的危险！
请在处于安全,电源关闭的情况下进行安装或拆除本总线端子模块.

安装

只要用很小的力就可以把总线耦合器与总线端子模块安装在通用的35mmC形导轨上: (DIN 导轨符合 EN 50022) :

  1. 首先把总线耦合器安装在导轨上。
  2. 总线端子模块安装在总线耦合器的右边。 端子模块与耦合器以及端子模块与端子模块之间通过槽扣方式连接, 紧贴着扣槽把端子模块卡在导轨上，卡上后会发出咔的响声。如果安装在导轨上的端子模块槽扣没有扣在一起K总线将不会导通！安装正确的话连接处是没有缝隙的。

NOTE 		导轨的固定
在安装总线端子模块的时候，注意不要让端子模块碰到固定导轨的螺丝.

拆卸

每个端子模块通过卡锁固定在导轨上，在拆卸端子模块的时候要释放卡锁:

  1. 小心地把橘黄色抽拉条拉出大约1cm，底部的卡锁就会释放，不需要很大的力就可以把端子从导轨分离.
  2. 用拇指和食指抓住模块的上部和下部的外壳向外拉，把模块彻底从导轨上拆下来.

总线端子模块的连接

总线耦合器和端子之间的电气连接在安装模块的时候自动完成:

  • 六个 K-Bus/E-Bus 总线弹簧连接片传输总线端子模块的数据和电源.
  • 现场电子组件的电源供电通过电源触点完成，插在一起的电源触点形成了一个电源链。总线耦合器提供电源触点 (达 24 V)或通过电源反馈端子模块提供更高的电压.

Note 		电源触点
由于一些总线端子模块(例如模拟量总线端子模块或4-通道数字总线端子模块) 都没有通过这些电源触点形成回路，必须考虑总线端子模块的分配。电源供电端子模块 (KL91xx, KL92xx or EL91xx, EL92xx)提供电源触点，并代表一个新的电源链的开始。

PE 电源触点

标有“PE” 标签的电源触点用于对地保护。出于安全的原因这些点应首先插接在一起，它最多可承担125A的对地短路电流。

CAUTION 		可能损坏设备
需要注意的是，出于电磁兼容性方面的考虑，PE 触点与安装导轨之间为电容偶合特性。在绝缘测试期间可能产生错误结果或毁坏端子模块(如：在设备230 V绝缘测试的时候造成对地击穿)。
绝缘测试时，总线控制器和电源端子模块的PE端必须断开。为了断开更多的反馈点进行测试，这些供电端子模块必须拉出来10mm。

WARNING 		触电危险!
PE的电源触点不能用于其它电位！


Mounting of Passive Terminals

BECKHOFF EtherCAT: 安装与接线

安装无源端子模块

Note 		安装无源端子模块的提示
在EtherCAT 总线端子模块 (ELxxxx / ESxxxx)中, 不在总线端子模块中参与数据交换的称为无源端子模块.
无源端子模块不消耗 E-Bus 电流.
为了确保数据传输最优,请不要把两个以上的无源端子模块直接串接在一起!

安装无源端子模块的提示的例子 (加亮显示):

例 1: 正确的配置

例 2: 错误的配置


EL7031 - LEDs und Anschlussbelegung

BECKH暗 EL7031: 产品概述

EL7031 - LED显示与接口

WARNING 		警告! 可能会触电和损坏设备!
为了确保总线端子系统的安全,在安装,拆除或者接线总线端子模块前断电!

LED显示

LED | 颜色 | 含义
RUN | 绿 | LED指明了端子模块的工作状态:
暗 | EtherCAT状态机的状态: INIT = 端子模块的初始化或 BOOTSTRAP = 端子模块的 固件更新 功能
闪烁 | EtherCAT状态机的状态: PREOP = 设置邮箱通信与多种标准设置
闪一次 | EtherCAT状态机的状态: SAFEOP = 检查 同步管理 与分布式时钟的通道. 输出处于安全运行模式
亮 | EtherCAT状态机的状态: OP = 正常运行模式, 可以进行邮箱与过程数据通信
Power 绿 暗 缺少电源电压 (50VDC) 或
电机控制停止 (未设置索引 6010:02 )
亮 | 已接上电源电压 (50VDC)
Turn CW | 绿 | 亮 | 顺时钟启动电机
Turn CCW | 绿 | 亮 | 逆时钟启动电机
Enable | 绿 | 暗 | 电机控制停止 (未设置索引 6010:02 )或 EL7041未准备运行
亮 | 电机控制启动 (已设置索引 6010:02 )或 EL7041已准备运行
Warning | 黄 | 暗 | 没有错误
亮 配置错误, 例如:
  • 没有连接电机电源
  • 温度超过80°C
  • 达到100%负荷
  • ...
Error A 红 亮 输出级 A 的配置错误, 例如:
  • 温度超过100°C
  • 短路
  • 打开负载/断开线
  • ...
Error B 红 亮 输出级 B 的配置错误, 例如:
  • 温度超过100°C
  • 短路
  • 打开负载/断开线
  • ...

接口

接线点 | 名称 | 信号
1 | A1 | 电机绕组 A
2 | B1 | 电机绕组 B
3 | Motor supply +24V | 输出级供给(最大 +24VDC)
4 | Input 1 | 数字输入1 (24 VDC)
5 | A2 | 电机绕组 A
6 | B2 | 电机绕组 B
7 | Motor supply 0V | 输出级供给(0 VDC)
8 | Input 2 | 数字输入2 (24 VDC)


EL7031 - General connection examples

BECKHOFF EL7031: 安装与接线

EL7031 - 常见接线举例

WARNING 		有触电以及损坏设备的危险!
为了确保总线端子系统的安全,在安装,拆除或者接线总线端子模块前断电!

Attention 		正确地连接电机导线!
一个电机相绕组只能连接步进电机端子相同输出级的端点, 例如:
  • 一相连接到端点A1和A2,
  • 另一相连接到端点B1 和B2.
如果连接电机相到模块的不同输出端点(e.g. A1 和 B1), 这样会损坏步进电机端子的输出级!

连接类型

步进电机模块EL7031有双极性输出端，能控制双极和单极性电机.

双极性电机

双极性电机的双极性串联控制
双极性电机的双极性并联控制

Note 		Beckhoff步进电机的资料
这两个例子是Beckhoff 双极性电机AS1010, AS1020 或者 AS1030的接线.
更多Beckhoff 步进电机的信息可以在我们的网站 www.beckhoff.com 中的资料库中找到.

单极性电机

单极性电机的双极性控制
只能控制一半绕组.


EL7041-x00x - General connection examples

BECKHOFF EP7041-x00x: 安装与接线

EL7041 - 常见接线举例

WARNING 		有触电以及损坏设备的危险!
为了确保总线端子系统的安全,在安装,拆除或者接线总线端子模块前断电!

Attention 		正确地连接电机导线!
一个电机相绕组只能连接步进电机端子相同输出级的端点, 例如:
  • 一相连接到端点A1和A2,
  • 另一相连接到端点B1 和B2.
如果连接电机相到模块的不同输出端点(e.g. A1 和 B1), 这样会损坏步进电机端子的输出级!

Attention 		通过缓冲电容器端子模块(EL9570) 应对瞬间减速!
非常瞬时的减速将导致反馈的暂时增加，在这种情况下端子模块将报错. 因此一个 缓冲电容器端子模块 (EL9570) 应该与电机的电源并联，这样所有反馈的能量就会被吸收.

连接类型

步进电机模块EL7041有双极性输出端，能控制双极和单极性电机.

双极性电机

双极性电机的双极性串联控制
双极性电机的双极性并联控制

Note 		Beckhoff步进电机的资料
这两个例子是Beckhoff 双极性电机AS1010, AS1020 或者 AS1030的接线.
更多Beckhoff 步进电机的信息可以在我们的网站 www.beckhoff.com 中的资料库中找到.

单极性电机

单极性电机的双极性控制

只能控制一半绕组

编码器

连接一个编码器 (24 V)

电源触点端点3 (+24 V) 和7 (0 V)来给编码器供电.


EL7031, EL7041-x00x, EP7041-000x - Commissioning

BECKHOFF EL7031, EL7041-x00x, EP7041-000x: 调试

插入端子模块到EtherCAT端子模块网络中(主站: TwinCAT 2.11)

Note 		安装最新的XML设备说明
请确保你已经在TwinCAT中安装了最新的XML设备说明.这可以在Beckhoff网站上下载 (http://www.beckhoff.de/english/default.htm?download/elconfg.htm) 并且根据安装说明书进行安装.

自动扫描端子模块

• | 在端子模块插入到端子网络之前总线端子系统必须处于安全且不通电的状态，这会在 导轨的安装 章节中说明.
• | 开启工作电压, 打开 TwinCAT System Manager (Config mode), 并且在端子模块中扫描 (见图 1). 点击"OK"确认所有的对话框, 使处于"FreeRun" 配置模式.

图 1: 在 EtherCAT configuration 中扫描 (I/O Devices-> 右击 -> Scan Devices...

手动添加一个端子模块

• | 在端子模块插入到端子网络之前总线端子系统必须处于安全且不通电的状态，这会在 导轨的安装 章节中说明.
• | 开启工作电压, 打开 TwinCAT System Manager (Config mode)
• | 添加一个新 I/O 设备 (见图 2). 在对话框中选中 EtherCAT 设备(Direct Mode), 见图 3 并且点击OK确认.

图 2: 添加一个新 I/O 设备 (I/O Devices-> 右击 -> Append Device... )

图 3: 选中 EtherCAT 设备 (Direct Mode)

• 添加一个新 (见图 4). 在对话框选中一个例如 EK1100 系统耦合器, 例如 (见图 5), 并且点击OK确认.

图 4: 添加一个新盒 (Device -> 右击 -> Append Box... )

图 5: 选中一个系统耦合器 (例如 EK1100)
• | 添加一个新盒 (见图 6). 在对话框选中一个 EL7031, EL7041, EP7041-xxxx (见图 7) 并且点击OK确认.
• | 插入到 TwinCAT 树中的端子模块 (图 8).

图 6: 添加一个新盒 (Device -> 右击 -> Append Box... )

图 7: 选中端子模块

图 8: 在 TwinCAT 树中的端子模块


Firmware compatibility

BECKHOFF EL70x1: 附录

固件兼容性

Beckhoff EtherCAT设备在出厂时都已安装最新的固件. 在固件与硬件之间有特定的联系,所以不是所有的组合都是互相兼容的.
以下的概述表明了固件是兼容哪种特定的硬件的.

注意

  • 严格推荐将最新的固件应用到特定的硬件上
  • 对于已从Beckhoff公司出厂的产品,客户无权免费得到固件更新.

Attention 		可能会损坏设备!
请注意 特殊页面 上关于固件更新的细节
如果你在BOOTSTRAP模式中运行一个设备来启动一个固件更新,而不检查硬件的兼容性.
可能会损坏设备!
请一定要确认固件是否适合设备的硬件状态!
EL7031
固件 (FW) | 版本 (FW) | 发布日期
01* | 01 | EL7031_01.efw, 2009/10/12
 | 02 | EL7031_02.efw, 2010/02/12
 | 03 | EL7031_03.efw, 2010/06/08
 | 04 | EL7031_04.efw, 2010/09/02
 | 05 | EL7031_05.efw, 2010/12/17
 | 06* | EL7031_06.efw, 2011/05/05
EL7041
固件 (FW) | 版本 (FW) | 发布日期
00 - 01 | 01 | EL7041-0000_01.efw, 2009/11/05
 | 02 | EL7041-0000_02.efw, 2009/11/05
02 - 04* | 03 | EL7041-0000_03.efw, 2010/02/04
 | 04 | EL7041-0000_04.efw, 2010/06/08
 | 05 | EL7041-0000_05.efw, 2010/08/31
 | 06* | EL7041-0000_06.efw, 2011/05/05
EL7041-0001
固件 (FW) | 版本 (FW) | 发布日期
00 | 00 | EL7041-0001_01.efw, 2009/11/05
 | 02 | EL7041-0001_02.efw, 2009/11/05
01 | 02.001 | EL7041-0001_02.001.efw, 2010/02/09
02 - 04* | 03 | EL7041-0001_03.efw, 2010/03/22
 | 04 | EL7041-0001_04.efw, 2010/06/08
 | 05 | EL7041-0001_05.efw, 2010/09/02
 | 06* | EL7041-0001_06.efw, 2011/05/05
EL7041-1000
固件 (FW) | 版本 (FW) | 发布日期
00 | 01 | EL7041-1000_01.efw, 2009/12/03
01* | 02* | EL7041-1000_02.efw, 2010/02/17

*) 创建这个文档时描述的是当时兼容的硬件状态. 所以请查阅Beckhoff 网站最新的技术文档.


ELxxxx - restoring the delivery state

BECKHOFF ELxxxx: 配置

恢复出厂设置

为了用ELxxxx端子模块中的备份来恢复出厂设置,需要在TwinCAT System Manager(Config mode)下的CoE中选择"Restore default"下的SubIndex 001 (见图 1)

图. 1 选中 "Restore default parameters" PDO

双击SubIndex 001进入Set Value 对话框.在"Dec"下输入1684107116或在"Hex"下输入0x64616F6C然后点OK确定(图 2).
所有的备份都被重置为出厂状态.

图. 2 在Set Value对话框中输入一个恢复值

Note 		可选的恢复值

在一些老的端子模块中要通过另一个恢复值来恢复备份:

十进制值: "1819238756"

十六进制值: "0x6C6F6164"

输入一个错误的恢复值没有任何效果.


Support and Service

BECKHOFF 自动化: 附录

技术支持与服务

Beckhoff 及其全世界的合作伙提供全方位的技术服务和技术支持，确保快速协助解决与 Beckhoff产品和系统解决方案相关的所有问题。

Beckhoff 的分支机构及代表处

有关 Beckhoff 产品的任何问题，请与负责本地技术支持与技术服务的 Beckhoff 分支机构或代表处联系!

有关 Beckhoff 分布在世界各地的分支机构及代表处的地址，请见公司官方网页：http://www.beckhoff.com.cn

公司网站还提供更多有关Beckhoff 组件信息的文档资料。

Beckhoff 总部

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com

Beckhoff 技术支持

Beckhoff 可为您提供全面的技术支持，除了Beckhoff 具体产品的应用之外，还提供更广泛的服务：

  • 全球技术支持
  • 复杂自动化系统的设计、编程和调试
  • Beckhoff 系统组件培训方案
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心为您提供的售后服务：

  • 现场服务
  • 维修服务
  • 备件服务
  • 热线服务
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com