EtherCAT – application notes for industrial Ethernet cabling with EtherCAT

BECKHOFF EtherCAT

EtherCAT/Ethernet基础
关于设备的设计，安装和测试的技术上的建议和说明

Version: 1.5
Date: 16.08.11

EtherCAT® 是已经由德国倍福有限责任公司的注册商标与专利技术，版权所有，未经授权不可使用。


Documentation issue status

BECKHOFF EtherCAT cabling notes: Foreword

文档材料的发行情况

版本 | 说明
1.5 | - 补遗
1.4 | - 补遗
1.3 | - 补遗
1.2 | - 屏蔽的数据材料
1.1 | - 用通道适配器代替PL适配器来进行标准测试的资料
1.0 | - 公开版本
0.1 | - 临时版本


Total transmission link

BECKHOFF EtherCAT cabling notes: Basic principles

传输总线

传统的以太网铜芯绞线(根据BS EN 50173标准)有如下特点：

  • 最长90米的固定电缆（根据EN50288-X-1标准），以及两个最长5米的电缆连接装置（根据EN50288-X-2标准），总共最长达到100米
  • 中间部分由最多达到4个接插口以及两个终端接口
  • 线缆符合EN50288标准
  • 双耦合器（指两个RJ45接口的连接）独立，通常数为两个插头连接
  • 所有的电缆必须具备相同的标称特性阻抗：100± 5W 或120 ± 5 W @ 100 MHz.
  • 可以选择现有的整体电缆屏蔽或 单独的绞线屏蔽。建议EtherCAT使用专用的屏蔽电缆。
    下图对传输链路部分进行了展示：

图1 ：传输链路

模型 A:

模型A根据EN50173-1,展示了最大的允许模型，其中包括

  • 最大达到90米的永久链接，电缆按照EN50288-2-1标准
  • 总共6个C型插口连接，包括终端连接点
  • 最大有两个遵照EN50288-2-2标准的连接电缆，跳线

验收测试的决定性因素是

  • 对于永久链路的测试时根据EN50173-1标准，附录A包含了两个连接点
  • 通道测量也是根据EN50173-1标准，标准中的第五章并没有包含这两个连接点

这个主要针对楼宇网络建设 SO11801/EN50173 ，从结构上（插线台、中间配电盘、楼层配线设备）越来越明确。最多有4个插头连接可以通过电缆分布在其他位置，比如 配线间隔；见模型B。

模型B,C

模型B,C在工业领域代表了更为经典的传输链路；他们在EN50173-1或者ISO24702 标准中有规定

连接器

由于衰减、反射和线间干扰，一个过渡点对整个的传输链路产生不利影响。因此，符合EN50173标准的转换过渡点的数量被限制到6个以内。

一个插头连接器（物体C在图1）代表了一个过渡点正处于两个插接器之间

图2：简单的插接器转换

图3：简单的插接器转换

双耦合器的代表2个转换点，除非它已被制造商定义为1个转换点的插头。

图4：

双耦合器

图5；双耦合器；左边是CAT5 塑料材料；右边是CAT6，全金属

目前只有CAT6双耦合器是符合EN50173-3,附录B的标准。可以操作的符合EN50173 D类标准传输链路的性能的维护的任务，CAT6超过CAT5类组件的标准。比如墙通孔，可以用一个简单的插头/插座过渡。

传输链路的性能

EN50173-1:2007,第五章根据允许的频率范围定义了8个类别的链路性能

类别 | 频率范围
SRKG | 最高可达0.1MHZ
A | 最高可达 100 kHz
B | 最高可达1 MHz
C | 最高可达 16 MHz
D | 最高可达 100 MHz
E | 最高可达250 MHz
F | 最高可达600 MHz
RuK-S | 最高可达 1000 MHz

表格1：根据EN50173-1得到的性能等级

根据依赖于频率的极限曲线（如范围内的1至100 MHz，D类），可以把方程相关的以太网性能等级D,E,F计算出来。根据不同的参数，在限制曲线的上下浮动的情况下，测量值必须可测存在。

图1：测量的实例：”Insertion loss“和”NEXT “依赖频率的限制曲线用红色标识。在每种情况下，定义一下参数：

图1：

中文 | 英语 | 缩写
回波损耗 | Return Loss | RL
耦合衰减 | Insertion Loss, Coupling Attenuation |
近端串扰 | nearend crosstalk loss | NEXT
综合功率近端串扰 | powersum NEXT | PSNEXT
串扰损耗 近端/远端 | Attenuation to crosstalk ratio near/far | ACR-N ACR-F
衰减串扰比功率总值 | powersum ACR | PSACR
对等级远端串扰 | equal level far end crosstalk ratio | ELFEXT
综合功率对等级远端串扰 | powersum ELFEXT | PSELFEXT
电阻 | Resistance | -
电阻变化 | Resistance Difference | -
传播时延 | Propagation Delay | -
时延差 | Delay skew | -
横向转换损耗 | Transverse Conversion Loss | TCL

表2：根据EN50173 - 1：2007标准的参数概览
 并非所有的参数强制对应于每个性能等级，必须按照EN50346标准进行测量。

提取的EN50173 D类的特征值

特征值 | 通道 | 永久链路
长度 [米] | 最长可达100米 | 最长可达90米
最大的内部损耗 [dB @ 100 MHz, 100m] | 24 dB | 20.4 dB
NEXT [dB @ 100 MHz, 100m] | 30.1 dB | 32.3 dB
最大的传播延时[ns @ 100MHz] | 548 ns | 491 ns

表三：根据EN50173 - 1 D类的标准，选定的传输链路的特征值

评论：

  • 最大的（信息）计算量。根据EN50173 - 1标准 特征值被限定。根据5.2章内容，最大假定允许4通道的插头。
  • EN50173 D类标准允许最大100兆赫，548 ns的信号传播延迟。这将限制过长的电缆的使用。假定标称传输速度NVP达到60%，则通道的长度被限制在100米。
  • 所有限定值是基于一个假设的环境温度为20 ° C。根据EN50173标准，规定出降额为（0.2％/ ° C），并在某些局部最多可达60° C.电缆/插头的特性随着温度的升高而变差，因此，随着温度的增加，允许的最大的沟道长度减小。

说明 		对于规定标准的偏差
上文所引的ISO11801/EN50173规格可能发生偏离，例如：更多的插头或超多允许的电缆长度或不合格电缆料。在这种情况下，建议在安装后，必须对传输链路，必须根据ISO11801/EN50173标准进行核查/核证。

设备的连接电缆的注意事项

验收测试设备的连接电缆/插接线的通常的方法是根据EN50173标准使用特殊的插接线适配器（如美国福禄克）和插接线限 定值。
最长达到20米，因此忽略电缆上的衰减。
只有RL和NEXT的参数被测量，对它们的要求比对其他的参数的要求更加严格。


Notes on Ethernet components – cables

BECKHOFF EtherCAT cabling notes: Components

对于以太网电缆的注意事项

EN50173-1标准的第七章规定，双绞线电缆的使用必须符合EN50288标准的规定。这包括屏蔽电缆和非屏蔽电缆。其中屏蔽电缆常用于EtherCAT连接，其中各个事项会在下文中解答。

相关的EN50288-2标准中包含了刚性电缆和柔性电缆，双绞线和星型隔断绞线。星型隔断绞线更加好：机械性能更稳定（移动应用情况，横向抗压），更少的空间占用，更好的NEXT值。

具体标准的相关数据如下：

EN50288-2-1

  • 用途：屏蔽电缆100MHZ，永久安装的水平/垂直领域
  • ‘刚性丝结构’, 实心铜导体
  • 横截面基本符合AWG24 to 21的规定
  • 插入损耗最大为21.3 dB/100 m @ 100 MHz
  • 直流环路电阻 < 19 W / 100m

EN50288-2-2

  • 用途: 屏蔽电缆 -100 MHz,设备连接电缆
  • ‘软线结构’, 绞线 – 单股或者多股导线（必须为7股）
  • 插入损耗最大为32 dB/100 m @ 100 MHz
  • 直流环路损耗< 29 W / 100m

以上数据适用于20 °C

电缆可以由制造商根据MICE等级分类，参考EN50173-1中的第五章或附录G的指定的环境条件

说明 		跳线和衰减

从上面的技术数据可以看到，通过符合EN50288-2-2标准的跳线实现一个满足EN50173 D类标准的信道，并且插入损耗达到4 dB/100 m @ 100 MHz是无法实现的。

如果要使用长度超过十米跳线电缆（根据EN50288-2-2）要做相应的技术指标降级。

对于电缆和插口的结合，预先定义的插塞式电缆连同限定值在EN50173-1,第九章中有规定

IEC61784-5-12标准中“用于EtherCAT网络的安装配置”中规定了连接器最大连接长度100米，且使用AWG22电缆（注：EN50288 - 2 - 1型）。

说明 		屏蔽
现有的屏蔽可能会增加其他电缆的插入损耗。这一影响可能只在 屏蔽体尺寸非常大的时候在可能被感觉到。如果电缆截面由于这个原因不能承受，那这是有别的方法解决的。例如，我们可以使用更粗的电缆而不是取消屏蔽电缆。

屏蔽可以提高回波损耗RL。

说明 		"与CAT.5类似"的说明

由于电缆的发展经历了科技的进步，由于这些标准的建立，现在市场上出现了大量的适用于以太网通讯的电缆，注意事项如下：

· 作为符合EN50173FF标准的电气特性，但不满足复杂的单个情况下的要求。（根据EN50288标准）

确定这样的电缆，比如，表格”与CAT.5相似“中的备注中，可以根据制造商的规定。这是一个电缆的特定应用，应受到认证测试后才能安装

电缆结构

根据美国线规，直径尺寸被定义为AWGxx/y: xx = AWG 数字，y=电缆数

举例:

  • AWG22/1 代表着单核，对应AWG22/1
  • AWG22/7代表着7核，总的界面对应到AWG22

根据ISO/IEC11801,电缆的结构定义如下 :

图1：电缆结构

说明 		电缆结构

建议使用完全屏蔽的传输链路，比如SF/FTP, S/FTP 或者 SF/UTP.

保证终端设备的屏蔽连接正确。在笔记上注意这些

经济效益

2009/02: 安装电缆的均价(非工业级的)

Cat. 5e: 大约 0.75欧元/米

Cat. 7: 约。 0.78欧元/米


Notes on Ethernet components – plug connections

BECKHOFF EtherCAT cabling notes: Components

以太网元件说明 – 插头连接件

快速以太网的连接装备必须在电子和结构规格上符合EN50173中D类标准。这一点保证了向上兼容性;更高规格的连接设备也可以满足D类标准。
根据在EN50173-3, 第5章或者附录G中关于周设环境说明的MICE（千兆工业以太网）分类，制造商可以选择满足条件的插头元件。

插头连接件实质上会影响传输环节的电特质，特别是参数的屏蔽影响，衰减，串音和回程亏损。在传输环节设计中，单个抽口连接件的插入亏损大概为0.4dB(EN50173-1,附录A)。

以下配套界面用于D类标准：

EN60607: "RJ45"

图一: EN60603-7连接器,现场配置; 左: 仅兼容快速以太网, 按1-2-3-6分配; 右: 兼容GBit , 可完全分配

按照TIA-568B标准要求，分配一个4芯电缆足够支持快速以太网（100Mbit/s）。

EN61076-2-101: "M12"

按照EN61076-2-101要求，该四极针脚配件仅用于支持快速以太网。

图二: EN61076-2-101连接器, D型

EN61076-2-101: M8

按照EN61076-2-101要求，该四极针脚配件仅支持快速以太网。

图三: EN61076-2-101连接器, D型

其他

除了以上提到的连接器，在电和机械特性上满足EN50173-1:2007或附录D的连接器均可使用。此外，EtherCAT IEC61784-5-12的安装文件需要被遵守。

缆芯分配

信号 | 作用 | RJ45 | M12 | M8 | 按照TIA-568B要求的电缆颜色 | 按照EN61918要求的电缆颜色
TD + | 传输数据 + | 1 | 1 | 1 | 白/橙 | 黄
TD- | 传输数据 - | 2 | 2 | 4 | 橙 | 橙
RD+ | 接收数据 + | 3 | 3 | 2 | 白/绿 | 白
RD- | 接收数据 - | 6 | 4 | 3 | 绿 | 蓝
- | 3rd pair + | 4 | - | - | 蓝 | -
- | 3rd pair - | 5 | - | - | 白/蓝 | -
- | 4th pair + | 7 | - | - | 白/棕 | -
- | 4th pair - | 8 | - | - | 棕 | -
Screen | Screening | Housing | Housing | Housing | n.def. | n.def.

图标一: 连接器针脚分配

屏蔽效果

需要确认的是，屏蔽效果会延续至电缆材料到连接器的传输。同时，在连接器/电缆过渡的区域内，屏蔽的材料（编带，箔片）必须存在于低阻抗的连接器结构中，且必须360°包围电缆。

需遵守附在连接器上的关于屏蔽和器件注释。


Overview of Beckhoff RJ45/M8 cables for EtherCAT systems

BECKHOFF EtherCAT cabling notes: Beckhoff cables

针对EtherCAT系统的RJ45/M8电缆的概览

倍福对于下面适用EtherCAT系统的电缆的推荐如下：

注意 		针对电缆的数据表
请参考倍福推荐的这些电缆的有关技术数据的表格和文档；这些资料可以在我们的网站上下载(www.beckhoff.com).
型号 | Cable
ZB9010 | 工业以太网/EtherCAT 电缆, 固定安装, CAT 5e, 4芯
ZB9020 | 工业以太网t/EtherCAT电缆, 适合拖链, CAT 5e, 4芯
ZB9030 | EtherCAT/工业以太网电缆, PVC,带屏蔽
ZB9031 | EtherCAT/工业以太网电缆, PUR, 适合拖链，带屏蔽
ZB9032 | EtherCAT/工业以太网电缆, PUR, 适合拖链，高度柔性

表格1；按米销售

ZK1090-9191-xxxx*

型号 | 长度
 | ZK1090-9191-0001 | 0.17 m
 | ZK1090-9191-0002 | 0.26 m
 | ZK1090-9191-0005 | 0.50 m
 | ZK1090-9191-0010 | 1.00 m
 | ZK1090-9191-0020 | 2.00 m
 | ZK1090-9191-0030 | 3.00 m
 | ZK1090-9191-0050 | 5.00 m
 | ZK1090-9191-0100 | 10.0 m

表格 2: EtherCAT 跳接线， 2x RJ45 插口

请参考如下目录，或从我们的网站上查询。 (www.beckhoff.com)

型号 | 长度
 | ZK1090-6161-0005 | 0.50 m
 | ZK1090-6161--0010 | 1.00 m
 | ZK1090-6161--0020 | 2.00 m
 | ZK1090-6161--0025 | 2.50 m
 | ZK1090-6161--0050 | 5.00 m
 | ZK1090-6161--0100 | 10.0 m

表格3 : EtherCAT 电缆, 2 x M12 连接器 (D-coded), 负责完整装配

请参考如下目录，或从我们的网站上查询。 (www.beckhoff.com) .

型号 | 长度
 | ZK1090-6292-0005 | 0.50 m
 | ZK1090-6292--0020 | 2.00 m
 | ZK1090-6292--0050 | 5.00 m
 | ZK1090-6292--0100 | 10.0 m

表格4: EtherCAT 电缆, M12 焊接 – RJ45 插口, 负责完整装配

请参考如下目录，或从我们的网站上查询。 (www.beckhoff.com) .

型号 | 长度
 | ZK1090-3131-0020 | 2.00 m
 | ZK1090-3131-0030 | 3.00 m
 | ZK1090-3131-0040 | 4.00 m
 | ZK1090-3131-0050 | 5.00 m
 | ZK1090-3131-0075 | 7.50 m
 | ZK1090-3131-0100 | 10.0 m
 | ZK1090-3131-0150 | 15.0m
 | ZK1090-3131-0200 | 20.0 m
 | ZK1090-3131-0250 | 25.0 m
 | ZK1090-3131-0300 | 30.0 m
 | ZK1090-3131-0350 | 35.0 m
 | ZK1090-3131-0400 | 40.0 m
 | ZK1090-3131-0450 | 45.0 m
 | ZK1090-3131-0500 | 50.0 m

表格 5: EtherCAT 电缆, PVC,负责完整装配， 2 x M8 连接器

请参考如下目录，或从我们的网站上查询。 (www.beckhoff.com) .

型号 | 长度
 | ZK1090-3191-3020 | 2.00 m
 | ZK1090-3191-3050 | 5.00 m

表格 6: EtherCAT 电缆, PVC, 1 x M8 连接器, 1 x RJ45,负责完整装配

请参考如下目录，或从我们的网站上查询。 (www.beckhoff.com) .

型号 | 长度
 | ZK1090-3100-3020 | 2.00 m
 | ZK1090-3100-3050 | 5.00 m

表格 7: EtherCAT 电缆, PVC, 1 x M8 连接器, 1个开口端

请参考如下目录，或从我们的网站上查询。 (www.beckhoff.com) .

型号 | 长度
 | ZK1090-3131-0001 | 0.15 m
 | ZK1090-3131-0003 | 0.30 m
 | ZK1090-3131-0005 | 0.50 m
 | ZK1090-3131-0010 | 1.00 m
 | ZK1090-3131-0020 | 2.00 m
 | ZK1090-3131-0030 | 3.00 m
 | ZK1090-3131-0040 | 4.00 m
 | ZK1090-3131-0050 | 5.00 m
 | ZK1090-3131-0075 | 7.50 m
 | ZK1090-9191-0100 | 10.0 m
 | ZK1090-3131-0150 | 15.0m
 | ZK1090-3131-0200 | 20.0 m
 | ZK1090-3131-0250 | 25.0 m
 | ZK1090-3131-0300 | 30.0 m
 | ZK1090-3131-0350 | 35.0 m
 | ZK1090-3131-0400 | 40.0 m
 | ZK1090-3131-0450 | 45.0 m
 | ZK1090-3131-0500 | 50.0 m

表格 8: EtherCAT 电缆, PUR, 可弯曲, 2 x M8 连接器，负责完整安装

请参考如下目录，或从我们的网站上查询。 (www.beckhoff.com) .

型号 | 长度
 | ZK1090-3191-0020 | 2.00 m
 | ZK1090-3191-0050 | 5.00 m

表格 9: EtherCAT 电缆, PUR, 可弯曲, 1 x M8 连接器, 1 x RJ45, fully 负责完整安装

请参考如下目录，或从我们的网站上查询。 (www.beckhoff.com) .

型号 | 长度
 | ZK1090-3100-0020 | 2.00 m
 | ZK1090-3100-0050 | 5.00 m

表格10: EtherCAT 电缆, PUR, 可弯曲, 1 x M8 连接器, 1 个开口端

请参考如下目录，或从我们的网站上查询。 (www.beckhoff.com) .

说明 		超长电缆
更多关于超长电缆的信息可以从我们的网站上查询到(www.beckhoff.com)


Overview of Beckhoff plug connectors for EtherCAT systems

BECKHOFF EtherCAT cabling notes: Beckhoff cables

倍福EtherCAT插头系列

在EtherCAT系统中，倍福推荐使用以下插头系列。
名称 | 描述
ZS190-0003 | RJ45 接口，4针, IP 20防护级别, 用于现场装配
ZS190-0005 | RJ45 接口, 8针，IP 20防护级别, 适用于现场装配和千兆比特以太网
ZS190-0004 | M12 接口,4针， IP67防护级别, 用于现场装配,D编码
ZS190-0006 | M8 接口, 4针，IP67防护级别, 用于现场装配

表一: 倍福推荐插头

说明 		插头相应的说明文档
使用时请进一步参考该插头相应的文件资料，详见倍福官方网站(www.beckhoff.com)
ZS1090-0003
RJ45 接口, 4针，IP 20防护级别, 用于现场装配
ZS1090-0005
RJ45 接口,8针，IP 20防护级别, 适用于现场装配和千兆比特以太网
ZS1090-0004
M12 接口, 4针，IP67防护级别, 用于现场装配,D编码
ZS1090-0006
M8 接口,4针， IP67防护级别, 用于现场装配

倍福推荐使用的控制柜馈给器件

ZK1090-6292-0000
用于连接M12和RJ45插座, 直形
ZK1090-6294-0000
用于连接M12和RJ45插座, 90°弯形

说明 		器件之间的连接（包括电缆之间，电缆与插口，插座之间）尽可能少
推荐使用只有一个连接点的控制柜馈给器件，即简单的插口/插座连接器件(见 ZK1090-6292)


Assembly notes

BECKHOFF EtherCAT cabling notes: Basic principles

安装说明

倍福的“EtherCAT”总线安装指导。主要针对以下方面：

  • EMC安装规范，干扰抑制措施
  • 导线导体之间合适间距
  • 屏蔽的规范
  • 弯曲半径(会削弱屏蔽效果)


BECKHOFF ELxxxx - CoE: TwinCAT System Manager

BECKHOFF EtherCAT cabling notes: Appendix

AWG转换

下表ISO/IEC61918 ED.2.0附录F中美国线规的直径与传统公米制直径对照表。 越细的导线，生产过程就需要更多的拉长次数。AWG美国线规表达数字直接对应拉拽次数。

mm² | AWG
0,05 | 30
0,08 | 28
0,14 | 26
0,20 | 24
0,28 | 23
0,34 | 22
0,38 | 21
0,50 | 20
0,75 | 18
1,0 | 17
1,5 | 16
2,5 | 14
4 | 12
6 | 10
10 | 8
16 | 6
25 | 4
35 | 2
50 | 1
55 | 1/0
70 | 2/0
95 | 3/0
120 | 4/0