KL2531, KL2541 - One channel stepper motor terminals

BECKHOFF Fieldbus Components

KL2531和KL2541的相关资料

单通道步进电机端子

版本: 1.7.0

日期: 2009-02-06


Notes on the documentation

BECKHOFF Automation: Foreword

文档编制说明

本说明书仅供那些在控制与自动化工程领域中熟悉国家标准并受过培训专业人士使用。

在安装和调试这些组件时，操作人员须遵循下列说明和解释。

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

免责声明

此文档需注意的是：尽管本文档经过精心编制，但所述的产品正处在不断地更新换代中。

因此，我们并不能保证文档中所描述的产品性能数据、标准或其它特性与实际产品相一致。

倘若，本文档出现一些技术或编辑上的错误，我们时刻保留对文档信息作出修改的权力，且恕不另行通知。

对于所提供产品，如果在本文档中已对数据、图表以及说明进行了修改，我们将不再特别加以声明。

商标

Beckhoff®, TwinCAT®, EtherCAT®商标以及EtherCAT®, TwinSAFE® 和XFC® 的安全商标已为Beckhoff 自动化有限公司的注册商标并已由Beckhoff 自动化有限公司授权。

未经许可，任何在公共场合以盈利为目的使用本公司的商标，本公司将依法追究。

申请中的专利

TwinCAT技术已被注册，包含但不局限于如下专利申请和专利：

在许多其他国家有关EP0851348, US6167425的相关申请和注册。

版权

© Beckhoff 自动化有限公司

未经许可，任何人不得复制、分发和使用本手册以及内容传递。
违者将追究损害赔偿，倘若批准一个专利、使用模式或设计，本公司保留所有权利。


Safety Instructions

BECKHOFF Automation: Foreword

安全说明

安全条例

请参考以下说明书的安全内容和描述!
产品特殊安全说明会出现在后几页或在安装、接线、调试过程中进行描述

免责声明

所有组件都在特殊的软件和硬件的适当的配置下应用. 禁止修改文件中关于硬件或软件配置的描述和取消 Beckhoff Automation 有限公司的权益.

人员资格

此说明仅供符合国家标准的控制技术,自动化技术和驱动技术培训使用.

符号说明

以下是说明内容中的安全提示警告标志,请您务必要仔细阅读!

.

DANGER

严重受伤风险!

如果您不注意此符号而进行操作,那么您的人生安全会立即受到威胁!

WARNING

受伤风险!

如果您不注意此符号而进行操作,您的人生安全会受到威胁!

CAUTION

个人危害!

如果您不注意此符号而进行操作,会造成个人不必要的损失!

Note

注意事项！

此符号用于显示说明及信息,有助于更好的理解.


KL2531, KL2541 - Documentation issue status

BECKHOFF KL2531, KL2541: Foreword

文件出版情况

版本

注释

1.7.0
  • 增加装配注释
  • 更新技术数据
  • 增加温度监控说明
  • 举例不同颜色的导线匹配Beckhoff 步进电机 (AS10x0)的电机电缆tZK4000-6200-2xxx的连接

1.6.3
  • 增加操作模式说明
  • 增加寄存器说明
  • 增加ks2000配置软件的说明

1.6.2
  • 更新过程映像的说明

1.6.1
  • 增加过程映像的说明
  • 更新基本功能原理
  • 增加操作模式的说明

1.6.0
  • 增加基本功能原理
  • 增加操作模式说明
  • 更新介绍和接线注意事项
  • 更新技术数据
  • 更新控制字结合状态字节的说明
  • 增加寄存器描述
  • 增加了装配说明

1.5.0
  • 增加基本功能原理的说明
  • 增加操作模式的说明
  • 增加寄存器说明
  • 增加了ks2000配置软件的说明
  • 更新技术数据

1.4.1

小错误例行修正 (笔误,拼写错误等.)

1.4

(只有德语版本)

  • 增加基础功能原理的说明
  • 增加操作模式的说明
  • 更新接线示例
  • 增加寄存器说明
  • 增加了控制字节和状态字节的说明
  • 增加了控制字和状态字的说明
  • 增加了ks2000配置软件的说明
  • 添加了端子处理的多个示例

1.3
  • 修改了KL2531的接线示例
  • 添加了 KL2541接线示例

1.2
  • 增加了KL2541电源连接的说明
  • 增加了指令寄存器的说明

1.1

简化了寄存器值的运算方程

1.0
  • 增加了基本功能原理的说明
  • 增加了操作模式的说明
  • 添加了 travel command mode的示例
  • 增加了ks2000配置软件的说明

0.2
  • 添加KL2541
  • 更新寄存器的说明和添加了寄存器页码
  • 添加了更多的操作模块:
  • 添加了ks2000配置软件的说明

0.1
  • KL2531的第一个临时文件
  • 仅仅描述了 velocity mode

Firm and hardware versions

Documentation Version | KL2531-0000 |  | KL2541-0000
 | Firmware | Hardware | Firmware | Hardware
1.7.0 | 3E | 02 | 4A | 10
1.6.3 | 3E | 02 | 3E | 08
1.6.2 | 3D | 02 | 3D | 07
1.6.1 | 3D | 02 | 3D | 07
1.6.0 | 3D | 02 | 3D | 07
1.5.0 | 3A | 02 | 3A | 06
1.4.1 | 2C | 01 | 2D | 02
1.4 | 2C | 01 | 2D | 02
1.3 | 2B | 01 | 2C | 02
1.2 | 2B | 01 | 2C | 02
1.1 | 2B | 01 | 2C | 02
1.0 | 2B | 01 | 2C | 02
0.2 | 2B | 01 | 2C | 01
0.1 | 1B | 01 | - | -

The firmware and hardware version (delivery state) can be found in the serial number printed at the side of the terminal.

Syntax of the serial number

Structure of the serial number: WW YY FF HH

WW - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 12 06 3A 02:

12 - week of production 12
06 - year of production 2006
3A - firmware version 3A
02 - hardware version 02


KL2531 - Introduction

BECKHOFF KL2531: Product overview

介绍

KL2531 总线端子模块用于直接连接各种小型步进电机。总线端子模块的PWM输出端可直接连接到马达的两组线圈，另有用于限位开关的两个(24 V)输入端。仅通过更改几个参数，KL2531 即可适用于特定电机和应用。64 微步可保证电机运行平稳、精确。在许多应用中，由于其集成了负载监控的系统，不一定需要编码器或限位开关。


KL2531-0000 - Technical data

BECKHOFF KL2531-0000: Product overview

技术数据

技术数据 | KL2531-0000
数字量输出点数 | 一个两相步进电机
输出端电压 (通过电源触点) | 8 VDC ~24 VDC
输出电流 | 2 x 1 A, 2 x 1.5 A 峰值电流, 过载和短路保护
电流控制器频率 | 大约 25 kHz
最大步频 | 125 kHz
步模式 | 全步, 半步, 4 / 8 / 16 / 32 / 64微步
分辨率 | 最大 64微步
每圈分辨率 | 典型应用中约 5000 个位置
诊断用LED指示灯 | 故障相位 A 和 B，失步/停转，电源，使能, 旋转方向,数字输入
数字量输入点数 | 2
额定电压 | 24 VDC (-15%/+20%)
"0" 信号电压 | -3 V ... 5 V
"1"信号电压 | 15 V ... 30 V
输入滤波时间 | 0.2 ms
输入电流 | 5 mA
电气隔离 | 500 Vrms (K-Bus/信号电压)
电子设备供电 | 通过 K-Bus
K-Bus的电流消耗 | 60 mA
输入过程映像中的位宽 | 1 x 8 位状态, 2 x 16 位数据
输出过程映像中的位宽 | 1 x 8位控制, 2 x 16位数据
尺寸(W x H x D) | 约 15mm x 100 mm x 70 mm (线性宽度: 12 mm)
重量 | 约. 55 g
工作允许环境温度 | 0°C... +55°C
储存允许环境温度 | -25°C... + 85°C
允许相对湿度 | 95%, 无冷凝
装配 | 按照EN 50022标准安装在35 mm 导轨上
抗震 / 防冲击 | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC / ESD | 符合 EN 61000-6-2 / EN 61000-6-4
防护等级 | IP 20
安装位置. | 任意
认证 | CE


KL2531 - LED display

BECKHOFF KL2531: Product overview

LED display

LED | Display
Run (green) | on | K-Bus 开始传输数据
Turn CW (green) | on | 电机顺时针转动
Enable (green) | off | 电机没有使能 (在状态字节中SB.0为0 ) 或者KL2531没有准备好
 | on | 电机使能 (在状态字节中SB.0 为1)同时 KL2531 准备就绪
Error A (red) | flashes (1 Hz) | 配置错误 (在状态字中SW.15为1): - 最小转速为 0 (R38) -最大转速为 0 (R39) - 最大加速度的值为 0 (R40) - 线圈电流值在a > ath时为0 (R42) - 线圈电流值在 a ≤ ath 时为 0 (R43)
Power (green) | off | 没有 (24VDC) 电源电压或者 电机没有使能 (在状态字节中SB.0 为0)
 | on | 有 (24VDC)电源电压
Turn CCW (green) | on | 电机逆时针转动
Stall detect (yellow) | on | 电机没有使能 (在状态字节中SB.0为0)
 | flashes (1 Hz) | 电流 load angle (SB.3 to SB.1) 大于配置的 load angle的极限 (R47).
Error B (red) | flashes (1 Hz) | 电源或者负载电压错误 - 电源电压 (24 VDC)太低 (在状态字中SW.9为1) - A桥负载开路(在状态字中SW.11为1 ) - B桥负载开路(在状态字中SW.12 为1) - A 桥电流过载(在状态字中SW.13为1) - B桥电流过载(在状态字中SW.11为1)


KL2541 - Introduction

BECKHOFF KL2541: Product overview

介绍

KL2541 总线端子模块用于中等性能的步进电机。PWM 输出端适用于各种电压和电流。总线端子模块中有两个数字量输入端的限位开关(24 V)和一个增量编码器接口(24 V)。 仅通过更改几个参数，KL2541 即可适用于特定电机和应用。64 微步可保证电机运行平稳、精确。若与步进电机配套使用，KL2541 可作为一个经济的小型伺服轴。


KL2541-0000 - Technical data

BECKHOFF KL2541-0000: Product overview

技术数据

技术数据 | KL2541-0000
数字量输出点数 | 一个两相步进电机
输出端电压 (通过端子触电 4' 和 8') | 8 VDC to 50 VDC
输出电流 | 2 x 5 A 峰值电流
电流控制器频率 | 约 25 kHz
最大步频率 | 125 kHz
步模式 | 全步, 半步, 4 / 8 / 16 / 32 / 64微步
分辨率 | 最大64微步
每圈分辨率 | 典型应用中约 5000 个位置
编码器输入个数 | 4个，用于一个编码系统
"0" 编码器电压 | -3 V ... 2 V
"1"编码器电压 | 2.5 V ... 28 V
编码器频率 | 最大 250 kHz (在四倍值时的一个1MHz的增量信号)
数字量输入点数 | 2个，用作限位
额定电压 | 24 VDC (-15%/+20%)
"0" 信号电压 | -3 V ... 5 V
"1"信号电压 | 15 V ... 30 V
输入滤波时间 | 0.2 ms
输入电流 | 5 mA
诊断用LED指示灯 | 故障相位 A 和 B，失步/停转，电源，使能, 旋转方向,编码器信号，数字输入
电气隔离 | 500 Vrms (K-Bus/信号电压)
电子设备供电 | 通过K-Bus
K-Bus消耗电流 | 80 mA
输入过程映像中的位宽 | 1 x 8 位状态, 2 x 16 位数据
输出过程映像中的位宽 | 1 x 8 为控制, 2 x 16 位数据
尺寸 (W x H x D) | 约 27mm x 100 mm x 70 mm (线性宽度: 24 mm)
重量 | 约 100 g
工作允许环境温度 | 0°C... +55°C (参考 Installation of terminals with increased thermal power loss!)
储存允许环境温度 | -25°C... + 85°C
相对湿度 | 95%无冷凝
装配 | 按照EN 50022标准安装在35 mm 导轨上
抗震 / 防冲击 | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC / ESD | 符合 EN 61000-6-2 / EN 61000-6-4
安全等级 | IP 20
安装位置 | 由负载决定 (参考Installation of terminals with increased thermal power loss!)
认证 | CE


KL2541 - LED display

BECKHOFF KL2541: Product overview

LED显示

左侧LED
LED | 显示
Run (green) | on | K-Bus开始传输数据
A (green) | on | 编码器输入端A有信号
C (green) | on | 编码器输入端C有信号
Input 1 (green) | on | 数字量输入端E1号.
- | 预留
B (green) | on | 编码器输入端B信号.
Latch (green) | on | 编码器门闩输入端有信号
Input 2 (green) | on | 数字量输入端E2.
右侧LED
LED | 显示
- | 预留
Turn CW (green) | on | 电机顺时针转动
Enable (green) | off | 电机没有使能(状态字节中SB.0置0)者L2541没有准备好
 | on | 电机使能 (状态字节中SB.0置1)并且KL2541 准备就绪
Error A (red) | flashes (1 Hz) | 配置错误, 如: -电机全步0(R33) - 编码器增量为 0 (R34) -最小转速 vmin 为0 (R38) - 最大转速 vmax为0 (R39) - 最大加速度 amax 为0 (R40) - 线圈电流在 > ath时为0R42) - 线圈电流在a ≤ ath 时为0 (R43)
Power (green) | off | 没有 (50VDC) 电源电压 或者 电机没有使能(状态字节 SB.0 置0)
 | on | 有 (50VDC)电源电压
Turn CCW (green) | on | 电机逆时针转动
Stall detect (yellow) | on | 电机没有使能 (在状态字节中SB.0位置0 )
 | flashes (>1 Hz) | 电流 load angle (SB.3 to SB.1) 大于配置load angle极限(R47).
Error B (red) | flashes (1 Hz) | 电源或者负载错误 - 电源电压太低24 VDC) (在状态字中 SW.9 位置1) - A桥开路负载 (在状态字中SW.11 位置1) - B桥开路负载 (在状态字中SW.12位置1) - A桥过载电流 (在状态字中SW.13 位置1) - B桥过载电流 (在状态字中SW.11位置1)


KL2531, KL2541 - Basic function principles

BECKHOFF KL2531, KL2541: Product overview

基本功能原理

KL2531和 KL2541步进电机端子模块集成了针对200 W的微型步进电机紧凑运动控制解决方案.

步进电机

步进电机是电动电机，可比拟同步电机.它的转子是永磁铁, 它的定子是线圈萦绕而成。与同步电机不同处在于, 步进电机有着大量的电极对。从一个最小控制配置角度看，步进电机是电极到电极运动或者步到步的运动.

步进电机已经遍布世界很多年. 它即耐用又容易控制同时还提供高扭矩. 在很多应用中, 步进电机的计算步数的方式节省了昂贵的反馈回路部分. 甚至在不断广泛应用同步伺服电机的时代, 步进电机也绝不会过时。步进电机是成熟技术的代表，同时它正在继续向着降低价格和物理尺寸、 提高扭矩和提高可靠性的目的进一步发展。

Beckhoff总线端子系统中KL2531和KL2541总线端子模块的发展 开启了新的应用领域. 微步步进电机和最新的半导体技术有着很多优势:

  • 平稳运转
  • 避免共振
  • 降低能耗
  • 更低的电机热应力
  • 最小电磁辐射
  • 更长的电缆线
  • 更简单的操作
  • 更小的电子设备尺寸
  • 简单的集成更高级系统
  • 集成了反馈系统

两步电机端子模块的最佳操作特性

KL2531和 KL2541 步进电机端子模块在性能上是不同的.

KL2531

只有12 mm大小的KL2531 适用于更低级的性能范围.供电电压为24 VDC. 此设备是为简单集成24 VDC控制系统而设计的. 每相都有1.5A的峰值电流, 能供给大量的小型驱动器和轴控。

KL2541

KL2541的性能高于小型伺服驱动器.例如有着5 A峰值电流的KL2541在连接了标准步进电机时能产生5 Nm的力矩 。50 VDC 的电源电压能实现带有扭矩的高速转动因此能实现(大约 200 W)高机械输出. ,尽管只有 24 mm 宽，KL2541 有一个 集成增量编码器接口来连接所有驱动器电缆。

两个步进电机端子提供两个可控的正弦/余弦电流. 25 kHz电流控制能实现无共振稳定电流输出. 高动态, 低电感电机和有着小型转子的步进电机运行情况相同. 电流分辨率为每段时间64步 (64微步). 有着1.8° 步角的 标准电机运行稳定并且每转可设置12,800 个电位置. 经验表明根据力学标准大约可以实现5,000个位置。

典型的步进电机问题例如明显的共振已经是过去的事情了. 微步电机和相关的设定值避免了转子冲击. 并且, 转子也不会在每到一个位置后左右摆动.诸如抗振减震器或者为了增加精度而减少齿轮数量的机械措施已不再需要. 从而降低了价格和开发的复杂性.

新型步进电机端子模块 也节省了控制方的开发时间.在所有普通现场总线中，两个总线端子可以像标准总线端子那样使用. 因此不再需要编程接口.启动,停止或者共振频率也不再是问题 . 对于简单的定位任务, 在 考虑加速度斜坡和最大频率的情况下，两个总线端子模块可以自动地使驱动器定位,.

通过步进电机的电压反馈来鉴定转子位置的方法已经不再广泛使用了. KL2531和 KL2541总线端子模块提供有状态反馈，它反馈的是一个有着3个位分辨率的电机负载. 这种反馈类型不适合“真正的”位置控制. 然而, 因为步进电机主要按照自身的控制同时在过负载时易于停止, 所以在实际中这种技术是可以接受的:只要没有过负载那么电机就将到达指定位置. 总线端子中计数的位的值就是O.K.

更多高要求定位任务的实现

更多高要求的控制任务能通过Beckhoff的自动化软件TwinCAT来实现. 和其他轴控一样, 两个步进电机端子模块通过TwinCAT system manager 联系起来同时他们能像标准伺服轴一样使用.特殊步进电机的特性，例如在有大量错误时转速的下降，会通过 stepper motor axis选项自动的载入. 从伺服电机到步进电机再从步进电机到伺服电机的转变和从现场总线到基于TwinCAT的现场总线的转变所带来的成就是同样伟大的。

步进电机的输出级有一个过负载保护 ，它是以超温警告和关闸的方式实现保护. 短路检测和诊断数据在控制器的过程映像中. 此外,这个状态连同其他信息一起通过总线端子的 LED显示. 输出级通过一个使能位打开.通过参数值可以设置和减少电机电流。

对电机的优化适应性操作和节能特性的实现都需要最小化的编程. 通过测试通道, KS2000组态软件能使速度和效果最优化 . 由于所有数据都是通过软件参数设定, 所以总线端子能轻易的更换同时参数将会储存下来或者传输到下一个项目中. 因此不再需要通过电位器或DIP开关进行设置参数了。.

步进电机的参数

扭矩

参考在不同转速下的最大电机扭矩. 用特性曲线表示扭矩的参数. 步进电机在低转速范围有着相当高的扭矩. 在很多运用中, 这使得步进电机能在没有传动装置的情况下直接使用。与其他电机相比,步进电机能很容易的提供一个和扭矩同个数量级的持续力矩.

旋转速度

步进电机有着很低的最大转速, 它是由最大步进频率决定的.

相位数量

2 到 5 相位的电机是很普遍的. KL2531 和KL2541 总线端子模块支持2相位电机. 4相电机基本上是带有独立绕线末端的2相电机. 他们能直接连接总线端子.

额定电压, 电源电压和绕组电阻

在稳态下, 额定电压下的额定电流取决于绕线电阻. 这个电压不应该和总线端子的电压输出级的电源电压混淆. KL2531和KL2541将控制电流传给电机绕线. 如果电源电压小于额定电压, 那么电源输出级不能提供全部电流, 导致扭矩消失. 对低绕线电阻和高电源电压系统需求是为了限制警告和在高速转动时达到高扭矩的目的.

共振

在一定的转速下步进电机很难平稳运行.如果电机在没有负载的情况下运行，这种现象是十分显著的.在某种情况下, 甚至会停止转动. 这是由于共振造成的. 共振可以粗略的区分为以下两种

  • 范围在大约250Hz 低频段的共振
  • 在中高频率范围内的共振.

在中高频率范围内的共振基本是由于电气参数引起的，例如电机绕组的电感参数和运输线容量。他们可以通过控制系统的高脉冲进行相对容易的控制.

低频段共振基本是由于机械电机参数所引起的. 这种共振除了影响平稳运行外，它还能导致扭矩的大量损失甚至电机步长的损失，因此这种共振是特别不希望出现的.
原则上, 步进电机是一种震荡系统 (相当于一个质量/弹簧系统), 它是由带有一个转动惯量和一个磁场的动转子组成，磁场产生一个恢复力作用在转子上.启动和停止转子都会产生阻尼振动. 如果控制频率符合共振频率，那么振荡会加剧,因此在最糟糕的情况下转子将不再按照步来运行,而是来回振荡.
KL2531和 KL2541总线端子模块能在 几乎所有标准电机中杜绝这种现象，由于他们正弦/余弦电流分布.因此转子不是以步到步的形式运动,所有它不是跳入下位置, 而是通过64微步运行的,也就是说转子是慢慢的从一个步转到下个步. 在某些转速下的普通扭矩损失是可以避免的, 并且在特殊应用下能达到最优化的操作.这就意味着有着高扭矩的低转速范围也能充分利用.

步进角

步进角是在每个步之间转动的角度.典型值为 3.6°, 1.8° 或 0.9°, 等于电机每次循环的100, 200 或400步 .这个值连同下游传动比都是对定位精度的测量. 由于技术原因, 步进角不能减少下游的某个值. 定位精度只能通过机械装置(传送装置)进一步改善. 改善定位精度的优质解决方案是KL2531 和KL2541提供的微步功能.它能达到64个微步. 更小型的人工步进角有着更好的效果: 能以更高的速度进行驱动操作, 却有着相同的精度.,尽管驱动操作受到机械分辨率的限制，但是最大转速没有改变.

步进电机的说明

1. 确定定位精度的需求和步的分辨率. 第一个任务就是决定能达到的最大分辨率.通过如主轴，传动装置或者齿条的机械传动减少装置来提高分辨率. 同时必须考虑步进电机端子模块的64微步.

2. 确定质量M和所有运动部分的的转动惯量(j).

3. 计算由运动物质的时间需求所引起的加速度.

4. 计算质量，转动惯量和各自加速度所产生的力的大小

5. 在高效率的情况下改变转子轴的力和速度, 摩擦力矩和机械参数例如齿数比. 从最后个电子元件开始计算常常是最好的，一般是负载. 每个元件都会使力和速度发生转变并且由于摩擦导致产生更大的力或扭矩. 在定位过程中, 所有的力和扭矩都作用在电机轴上. 结果显示是一条电机提供的转速/扭矩曲线.

6. 使用典型的转扭矩力曲线, 选择一个满足这些最小需求的电机. 必须添加电机的转动惯量进行完整驱动. 核实你的选项. 为了提供充分安全裕度,扭矩应该增大20%到30%.如果加速度主要提供给转子的惯性那么电机的最优化就会有所不同.如果是这种情况, 电机应尽可能的小.

7. 在实际应用环境中测试电机: 在连续操作中检测机壳温度.如果检测结果不是计算结果，那么检测假设参数和边界条件.检测其他影响因素是很重要的，这些因素有共振， 机械动作, 设置最大操作频率和斜坡斜率.

8. 不同的测量对驱动性能的最优化是有效的: 使用更轻的材质或者用空心的来代替实心的来减少机械质量. 控制系统对驱动器动作也有很大的影响. 总线端子模块能在不同的电源下进行操作. 典型的转矩扭力曲线可以通过增加电压来引申. 既然这样那么在重要时刻提高电流就可以提供一个更好的扭矩，虽然电流的下降能减小电机的温度.对于特殊的应用条件,建议使用一个特殊的适合的电机绕组.

更多参数

负载角

在电机轴上负载角提供有关电流机械负荷的信息.它以三个位(SB.1-SB.3) 的值来显示 并且在每次满步之后都会自动更新.因为负载角取决于电机电流, 所以它的值直接取决于以下因素:

  • 转速 – 中等转速有益于解析负载角; 高转速或者低转速都导致高负载角的出现 .
  • 共振 –在电机侧 电机共振会形成高机械负荷并使测量结果失真.
  • 加速度 – 在电机侧加速度相位也会产生高负荷.
  • 混合衰减– 如果激活这个选项，那么就是外加了一个电机电流. 因此通过设置CW.9达到钝化的作用对于负载角分辨率是有积极作用的 .
  • 电机电流 – 固定线圈电流直接影响负载角分辨率,也就是说电流越小，分辨率越小 .

对每一个应用,使用者都应该确定能达到满意的负载角分辨率的最优转速.

电流表格

在一些应用中，电流(正弦曲线)必须和步进电机匹配的. 必须激活最后的特征位R32.7. 用户应该在register page 1保存已调试好的电流表格.

混合衰减模式

混合衰减参数用于改善和降低线圈电流.在第二个半微步相位通过脉冲时用 辅助晶体管将线圈电流传送到半桥上来实现混合衰减功能. 在微步模式下, 混合衰减模式对电机运动有着积极的影响.通过电机运行更稳定，位控制更精确.混合衰减模式在低电压和 静止状态下切断.

通过对CW.9位的控制能使混合衰减失效。.

CAUTION

在混合衰减模式失效的情况下很可能发生位偏移的情况

当混合衰减失效, 最糟糕的情况就是：由于线圈电流的改变，位置可能移动几微步。

自动 / 手动减小电流

步进电机端子模块提供用户减少电流的选项来保护不必要的电机受热:

  • 自动,通过寄存器R44设置
  • 手动, 通过寄存器 R45设置

当电机停机的时候(v=0), 设置 R44的保持电流为自动。电流值与端子线圈的设定电流有关 ，与端子的额定电流无关!

例如为了使用户达到最大的控制效果，可以设定R45是定为50%，这样电流值就为100%. 通过设置控制位CB.3 或 CW.11手动地将保持电流输入电机绕组中. 这个动作可以在停顿时和电机运行时操作.

指定设置位(通过寄存器)

用户能设定或者删除位置设定值. 寄存器 R2 和R3 根据参考资料使用:

  • CW.13的上升沿删除给定的设定位(如果 CW.10和CW.13 同时设定，CW.10有更高的优先级)
  • CW.10 的上升沿设定设置位的值给寄存器R2 和 R3

通过状态字 SW.2实现相应

路径控制

由于电机位置是由PLC控制的,所以 路径控制是最优的解决办法.在这个模式中, 一个32位位置的值和多种参数例如转速和加速度是由端子模块决定的. 一旦对此模块进行使能, 那么端子模块将自动运行到目标位.

位置误差检测

通过一个外部传感器(e.g. 一个感应引发开关)连接数字量输入通道2，端子模块就能识别电机相对位置误差(仅对内部定位).寄存器 RP0.R51指定了电机每次旋转的脉冲数 (e.g. 如果小齿轮没用). 通过设定控制字的CW.7 位, 用户能把误差列入进程数据库并用PLC分析错误。

端子模块通过使用这些参数计算出位置三角:

1.1 | IF = MS x Reg33 / Reg51 | 脉冲因素
1.2 | ∆Pos = Pos - IC x IF | 相对位置误差

key:

IF | 脉冲因素 | [IF] = 每次脉冲的微步值
IC | 脉冲计数器 | 数字量输入通道2中计算脉冲
MS | 每次满步时的微步值 | MS = 2R46
Reg33 | 电机满步 |
Reg46 | 每1/4时间间隔的步的大小 |
Reg51 | 每次旋转的脉冲数 |
Pos | 当前位置 (必须是值) | [Pos] =微步
∆Pos | 相对位置误差 | [∆Pos] =微步
图:带有感应引发开关的小齿轮 (寄存器 R51 = 8)

相对定位误差必须通过用户进行分析.对于微步损失的确切值是没有办法直接给出结果的. 这是由于以下原因导致的：因为端子模块不能计算得到运动开始时的误差(从电机运转到第一个传感器脉冲时微步的数值).同样公差和延长时间也不能得到准确值，带有传感器开关 的24V是不需要的.

从这点考虑，在解析中必须给予独立的速率.在匀速转动情况下， 一些微步会有误差波动, 但是中值是相同的. 事实上,由以下小错误引起的小波动是无需在意的：

  • 电机在同一时间失步 (可以通过跳针误差来消除失步).
  • 电机彻底停止可以通过稳定上升的定位误差进行检测.

编码器接口

编码器以四倍的评估值工作.

门闩功能

电机内部编码器提供一个或多个门闩寄存器选项. 一个门闩可以通过C端信号，门闩/门信号，输入1或者输入2通道的输入信号来激发. 电机端子在默认状态下提供一个门闩值.通设置特征位 R32.9 和参数寄存器R37能激活门闩数组，增加门闩的数值 ，因此电机可以提供多个门闩值.

通过以下设置能激活电机端子对门闩功能的响应:

  • 设置控制位 CW.0 激活C端输入口的上升沿 (如果多个控制位同时设置那么此控制位有最高的优先级)
  • 设置控制位 CW.3 激活C端输入口的上升沿 (第二优先级)
  • 设置控制位 CW.4 激活门闩/门端输入口的下降沿 (第三优先级)
  • 设置控制位 CW.1激活数字输入端口1的上升沿 (第四优先级)
  • 设置控制位 CW.2 激活数字输入端口2的上升沿 (最低优先级)

通过激活 R32.8 一个门闩事件也能用于删除电机的当前位置. 为此, 必须先通过控制位CW.13使上述操作项中的一项启动。在下一个门闩项工作时电机的当前位将被删除 。

一旦在下一个门闩事件工作时用户运行此功能，电机端子就会保存当前位的值并通过设置状态字 SW.4显示. 如果激活门闩数组, 以上情况只有R37指定的门闩事件才会发生. 读门闩的值必须通过设置 CW.5来实现,在 DataIN 过程数据中可以显示低位字的值 (端子可以通过状态字SW.5显示数据). 高位字只能通过寄存器通讯从寄存器R5读出.之后的门闩值能通过改变控制字CW.6重新获得. 端子通过改变状态字 SW.6来确认门闩值.现在下一个门闩值应用并在DataIN中显示.一旦端子SW.6不再根据CW.6而改变，那么就能得到最后的门闩值.

Note

Enabling has to be hold up!

当读门闩值的时候，之前的门闩使能设置不得不被拦截. 一旦没有使能那么门闩值会消失!

数字输入

数字量输入可以配置制动器触点. 因此必须在feature register 2中将输入端1的 RP0R.52.14 位和 输入端2 的RP0.R52.15位 设为1bin. 在传输状态中两个输入可以配置闭合触点.

错误指示

步进电机端子模块提供给客户多种诊断选项. 这些错误信息被细分为配置错误, 硬件警告和硬件错误.

配置错误

在不符合逻辑的配置中 (也就是：如果寄存器 R33, R34 (只是 KL2541), R38, R39, R40, R42, R43 or R50 为零), 配置错误位(SW.15)在状态字下置位. 通过这些寄存器，端子模块可以计算更多内部通道的控制参数. 如果这些计算结果反馈值超出允许范围, 也就是说如果不能达到规定转速和加速度的特定目标位,那么这个错误位也将置位. 一旦改变寄存器的值使计算结果正确那么错误位将自动复位.这些错误不会使状态字SB.6 置位!

硬件警告

如果模块内部温度达到 80 °C, 状态字节的SB.5 (警告)位置位. 如果温度低于60 °C, SB.5会自动复位.

硬件错误

如果以下错误出现, 那么电机切换到无电流状态,状态字节中的 SB.6位置1.

  • 温度过高 (OverTemperature SW.8)
  • 低电压 (UnderVoltage SW.9)
  • A桥开路负载 (OpenLoad Br A, SW.10)
  • B桥开路负载 (OpenLoad Br B, SW.11)
  • A桥过电流(OverCurrent Br A, SW.12)
  • B桥过电流 (OverCurrent Br B, SW.13)
  • 24 V控制电压失效(NoControlPower, SW.14)
    (    如果控制电压返回那么端子将自动重启)

如果发生一个错误, 首先调整错误然后确认并通过设置控制字节的 CB.6 位取消错误.


KL2531, KL2541 - Temperature monitoring

BECKHOFF KL2531, KL2541: Product overview

温度监控

步进电机端子模块KL2531 和KL2541已经集成了对外壳温度和步进控制器芯片的监控.

温度警告

如果端子模块的内壳温度达到80°C, 状态字SB.5 (警告) 置位.如果温度低于60°C, SB.5 自动复位.

你可以从温度寄存器R6读到目前外壳温度.

自动切断电源

如果温度超过125°C,

  • 步进电机控制器芯片自动切断电机. 此外
  • 状态字 SW.8 (OverTemperature) 位置位,
  • LED Error B闪烁,
  • 状态字节SB.6 (Error) 位置位
    (    状态字节SB.6 位可以通过设置控制字节CB.6.)

CAUTION

温度监控控制

如果你在步进电机模块KL2531和 KL2541 性能允许范围内操作他们，那么你可以通过用户编程控制温度监控!
KL2541的温度曲线

下列图表适用于hardware version 10的KL2541 .

此图是在55°C 环境温度、最大电动机电流的情况下， KL2541的壳温度 (最坏条件) 变化曲线:

  • X是时间轴，单位为妙.
  • Y是温度轴，单位为摄氏度.

在温度刚开始上升时(t = 0 s) KL2541未使能. 从那时起步进电机的转动电流为5 A.

通过图表用户可以估算KL2541在最大环境温度和最大负载电流情况下能运行多长时间，直到步进控制器芯片自动切断功能切断电机自启动。


KL2531, KL2541 - Microstepping

BECKHOFF KL2531, KL2541: Product overview

微步步进电机

微步步进电机在R46和R48 到R63寄存器 或者在ks2000配置软件的 current table 对话框中有详细说明。

Microstepping | Steps per quarter period
Full step | 1u
Half step | 2
1/4 step | 4
1/8 step | 8
1/16 step | 16
1/32 step | 32
1/64 step | 64

Full step: | Half step:
1/4 step: | 1/8 step:
1/16 step: | 1/32 step:
1/64 step: |


KL2531, KL2541 - Operating modes

BECKHOFF KL2531, KL2541: Product overview

操作模式

KL2531和 KL2541步进电机端子模块提供以下操作模式:

  • Velocity, direct
  • Velocity, with ramps
  • Position tracking
  • Path control
    - Manual (velocity, with ramps)
    - Travel command (single)
    - Travel command (multi)
    - Auto-start function
    - Auto-stop function
    - Fast-stop function
    - Referencing (via digital inputs)
    - Self adjusting

控制模式可以通过 KS2000 配置软件或者寄存器通讯和特征寄存器 RP0.32进行选择。

Operation mode |  | for operation with | Range of values for DataOUT
Velocity, direct |  | NC, cyclic velocity interface | -7FFFhex to +7FFFhex
Velocity, with ramps |  | PLC | -7FFFhex to -0010hex +0010hex to +7FFFhex
Position tracking (in preparation) |  | NC, cyclic position interface | -7FFFhex to +7FFFhex
Path control | Manual | PLC | -7FFFhex to -0010hex +0010hex to +7FFFhex
 | Travel command |  | 0000hex

Velocity, direct

此模式为数字控制器(NC)的周期转速接口. 在此模式中, NC指定设定转速值.电机的启动加速和 刹车都是通过NC进行控制的.

DataOUT

此端子模块分析 15 位和(VZ)符号:

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Contents | VZ | Velocity value

Value range: -7FFFhex to +7FFFhex (-32767dec to +32767dec)

Velocity, with ramps

此模式用于传统PLC的简单电机控制(not NC).

步进电机端子模快按照PLC转速说明书, 考虑端子模块的斜坡来决定 maximum velocity (RP0.R39), maximum acceleration (RP0.R40), and minimum velocity (RP0.R38)的参数. 用KS2000配置软件参数设置， 或通过端子寄存器中的寄存器通讯可以将这些参数存储至模块内部.

DataOUT

端子模块分析11位和符号位的值 (VZ),这意味着，这意味着此模式16位的分辨率低于在 velocity, direct 模式:

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Contents | VZ | Velocity value |  |  |  |  |  |  |  |  |  |  | 0 | 0 | 0 | 0

Value range: -7FFFhex to -10hex and +10hex to +7FFFhex (-32767dec to -16dec and +16dec to +32767dec)

Calculation of the velocity (in microsteps)

根据下面的公式，步进电机端子模块将输出数据字的数值转换为转速.

最大转速在寄存器RP0.R39设定，在控制模式 velocity, with ramps and path control下限制电机速度.

1.1 | R = DataOUT / 32767 x f x 2047 / 262144 | DataOUT = R / f x 262144 x 32767 / 2047
Simplified formulas: |  |
1.2 | R = DataOUT x 3.812951 | DataOUT = R / 3.812951
1.3 | RFS = DataOUT x 3.812951 / MS | DataOUT = RFS x MS / 3.812951
1.4 | RPS = DataOUT x 3.812951 / (R33 x MS) | DataOUT = RPS x R33 x MS / 3.812951
Conversion to full steps / revolutions per second
2.1 | RFS = R / MS; RFS = R / 2R46
2.2 | RPS = RFS / R33

with

R

微步下的转速

[R] = microsteps / s

RFS

满步下的转速

[RFS] = full steps / s

RPS

没秒的分辨率

[RPS] = N / s

MS

微步

MS = 2R46

f

内部时钟频率

f = 16 MHz

RP0.R33

寄存器33中的值

Number of full motor steps per revolution

RP0.R46

寄存器 46中的值

R46 | 0 | 1 | 2 | 3 | 4 | 5 | 6
MS | 1 | 2 | 4 | 8 | 16 | 32 | 64

DataOUT

在输出数据字中的值

Calculation of register values (Reg) für R38, R39, R40, R41, R50, R58

Minimum and maximum velocity
3.1 | Reg = R / f x 262144 | Velocity in MS / s
3.2 | Reg = RFS x MS / f x 262144 | Velocity in FS / s
Simplified formulas: |  |
3.3 | Reg = R x 0,016384 | Velocity in MS / s
3.4 | Reg = RFS x MS x 0,016384 | Velocity in FS / s

with:

R | 微步中的转速 | [R] = microsteps / s
RFS | 满步中的转速 | [RFS] = full steps / s
RPS | 每秒分辨率 | [RPM] = N / s
MS | 微步 | MS = 2R46
f | 内部时钟频率 | f = 16 MHz
Reg.- | R38或者 R39寄存器的值 |
Maximum acceleration and acceleration threshold
4.1 | Reg = ∆R x 238 / f2 | Acceleration in MS/s2
4.2 | Reg = ∆RFSx MS x 238 / f2 | Acceleration in FS/s2
Simplified formulas: |  |
4.3 | Reg = ∆R x 1.073742 x 10-3 | Acceleration in MS/s2
4.4 | Reg = ∆RFSx MS x 1.073742 x 10-3 | Acceleration in FS/s2
Conversion to full steps

5.1

∆RFS = ∆R / MS; ∆RFS = R / 2R46

with:

∆R | 加速度 | [∆R] = microsteps / s2
∆RFS | 满步时的加速度 | [∆RFS] = full steps / s2
MS | 微步 | MS = 2R46
f | 内部时钟频率 | f = 16 MHz
Reg | R40或者R41寄存器的值 |
amax | 最大加速度(R40) | [amax] = 1

Position tracking

(在准备中)

此模式用于数字控制(NC)的循环定位接口. NC 指定一个16位的设置位置. 端子模块通过它内部定位控制器计算得到的转速来尝试追踪位置. 寄存器R48 (Kp factor)和R49 (Kv factor)中的两个参数就是用于此目的.

Path control

此模式用于传统PLC的简单的定位(not NC).

Path control 模式提供以下变体:

Manual

手动模式，与velocity interface with ramps相同. 如果激活行程指令(CB.2 = 0)，端子模块将自动选择此模式.

Travel command (single)

用单通道路径控制,将距当前位最大距离为+/- 231 的位置增量的值定义为端子模块的定位值. 控制器能从寄存器R0和R1中读到当前值.当一个行程指令激活，控制器就已经对端子模块的一下个行程指令进行参数化处理. 新的参数写入寄存器的RAM选项中(为此,代码字寄存器必须删除!). 精确的进程在下面了示例中有详细的描述.

为了确保有意义和高效的运动, 以下寄存器值要重新参数化:

  • R2: 目标位 (低字位的值)
  • R3: 目标位(高字位的值)
  • RP0.R38:最小转速
  • RP0.R39:最大转速
  • RP0.R40: 最大加速度
  • RP0.R58:最大减速度(必须通过特征寄存器2的RP0.R52.1位使能)
Example

在以下示例中, 启动一个行程指令, 在运动中指定一个新的位置.之后启动第二个行程指令. 电机手动运行并且再次停止.

1. 在控制字节中, 将CB.0 位设为 1，能控制电机.

2. 通过寄存器通讯在寄存器R2和 R3 中输入设置位(32 bit).

3. 如果需要修改，我们可以通过寄存器通讯在寄存器R37, R38, R39 和R40中输入剩下的参数.

4. 将过程输出数据DataOUT 置零来启动行程指令.

5. 在控制字节中,将 CB.2位置 1 来启动行程指令. 现在步进电机将独自把电机转动到指定位置. CB.2 位置1直到电机到达所需位置. 可以通过删除CB.2位来终止行程指令.

6. 在激活状态期间，如果需要修改，可以通过寄存器通讯，在寄存器R37, R38, R39 和 R40中 输入新的参数.

7. 当到达目标位时，端子模块会将状态字的SW.3 位置1。

8. 在控制字节中删除CB.2 位完成第一次行程指令.

9. 端子模块可以通过删除SW.3位来告知已收到.

10. CB.2置 1 启动新的行程指令.

11. 当到达第二个目标位时,端子模块会再次将状态字的SW.3 位置1。

12. 在控制字节中删除CB.2 位完成第二个行程指令.

13. 端子通过再次设置SW.3位来告知已收到.

14. 通过过程数据通信，在DataOUT中输入转速值实现手动移位.

15. 删除DataOUT中的转速值来停止电机.

Specify set-position via process data (only for KL2531-1000 and KL2541-1000)

对特殊类型KL2531-1000和KL2541-1000，通过过程数据能选择指定位设定. 步骤如下:

1. 储存当前转速值.

2. 通过设定CW.14位交换过程输出数据DataOUT (定位接口激活).

3. 将新的设置位写入过程输出数据DataOut.

4. 通过设置CW.10位接受新的设置位.

5. 将设定转速设置回储存转速值.

6. 通过设回CW.14位换回过程输出数据DataOUT (转速接口激活).

Travel command (multi)

通过多路径控制，端子模块可以给予多达16个位置值，16个转速值和16个加速度的值(固件3E)，储存在内部的不同表格中.一个定位值由两个寄存器组成, 存档在register page 2的寄存器R32到R63. 每个定位值允许偏离当前位，最大+/- 231 位置值增量. 当前位置值能通过PLC从寄存器R0 和R1中读出. 转速值存档于寄存器R32到R47中，加速度的值存档于Register-Page 3寄存器R48 到R63中.

在一个行程指令运行时，PLC就已经能用参数表示端子的下一个行程指令 (除了R39 和 R40,这些寄存器将在下个行程指令启动时重写). 在这种情况下，新的参数写入端子的RAM-Area中(因此代码字寄存器必须删除!).

通过写寄存器R7，可以启动一个多个行程指令

  • 用command 0x0500 (在每个行程指令之后，这里的内部位置索引加1，直到到达位置15，这意味着表格正向计算) 或者
  • 用command 0x0510 (在每个行程指令之后，这里的内部位置索引减1，直到到达位置0，这意味着表格逆向计算).

通过对指令编码0x0500 或者 0x0510加一个偏移量开始定位(e.g. 0x0504 ->从位置4开始向前, 0x0518 -> 从位置8开始回退). 一个多行程指令能通过指令command 0x0540停止. 精确过程在以下的示例中有详细描述.

多达16个目标位置可在以下寄存器中设定:

  • RP2.R32: 目标位置 0 (低字位的值)
  • RP2.R33: 目标位置 0 (高字位的值)
  • RP2.R34: 目标位置 1 (低字位的值)
  • RP2.R35: 目标位置 1 (高字位的值)
  • etc.

多达16个转速值在以下寄存器中设定:

  • RP3.R32: 转速0
  • RP3.R33: 转速1
  • etc.

多达16个加速度值在以下寄存器中设定:

  • RP3.R32: 加速度 0
  • RP3.R33: 加速度1
  • etc.

为了使多位置行程操作有用而高效，以下寄存器可用于重设参数:

  • RP0.R38: 最小转速
  • RP0.R58: 最大减速度 (必须通过特征寄存器2的RP0.R52.1位使能)
Example

在以下示例中，多行程指令从索引5开始运行,然后到达3个位置 (位置5, 6 和7). 随后位置索引设为3， 到达两个位置(位置 3 和 2). 然后多行程指令停止.

1. 通过寄存器通讯(最大每32位16个位置值)写寄存器RP2.R32 to RP2.R63设定目标位置。

2. 设置控制字节的CB.0 位为1bin,，使电机控制使能.

3. 如果需要重置参数，可以通过寄存器通讯将更多参数写入寄存器 RP0.R37, RP0.R38, RP0.R39, RP0.R40 和 RP0.R58 ,.

4. 现在, 将过程输出数据DataOUT 置零. 就可以启动行程指令。

5. 通过寄存器通讯将开始指令0x0505 (0x0500 + 偏差 5)写入寄存器R7中,将位置索引设定为5作为第一个目标位置。

6. 设定控制字节的CB.2 位为1bin, 启动第一个行程指令.

7. 现在, 步进电机端子模块自动驱动电机转到目标位置。.保持CB.2位为 1bin 直到电机到达所需位置.如果行程指令需要终止，将CB.2位设回 0bin.

8. 在行程指令运行期间, 如果需要再次设参，可以通过寄存器通讯将新的参数写入寄存器RP0.R37, RP0.R38, RP0.R39, RP0.R40和RP0.R58,

9. 到达目标位置后，端子模块会自动设置状态字的SW.3位为1bin 。

10. 将控制字节的CB.2位设回0bin，完成第一次行程指令.

11. 端子通过设置SW.3位为0bin收到指令.这样，位置索引自动加一.(到位置6).

12. 设置控制字节的CB.2位为1bin ，启动第二个行程指令.

13. 设置控制字节的CB.2位为0bin 完成第二个行程指令,之后模块自动将SW.3位设回0bin 表示到达位置6.

14. 设置控制字节的CB.2位为1bin启动第三个行程指令.

15. 将控制字节的CB.2位设为0bin完成第三次行程指令, 之后模块自动将SW.3位设回0bin 表示到达位置7.

16. 通过寄存器通讯将开始指令(0x0510 +偏差3)写入寄存器R7,将位置索引设为3，作为下一个目标位置.

17. 将控制字节的CB.2位设为1bin启动第四个行程指令.

18. 将控制字节的CB.2位设回0bin完成第四个行程指令, 之后模块自动将SW.3位设回0bin 表示到达位置3.这样，位置索引就自动增加一个位(到位置2).

19. 设置控制字节CB.2位为1bin启动第五个行程指令.

20. 将控制字节的CB.2位设回0bin完成第五个行程指令, 之后模块自动将SW.3位设回0bin 表示到达位置2.

21. 通过寄存器通讯将停止指令0x0540写入寄存器R7，停止多行程指令.

Auto-start function

在任何操作模式下，在特征寄存器中设置RP0.R32.0可激活自启动功能.

此功能能使用户在独立于PLC的情况下进行快速而简单的定位。
 为此，数字输入1用于预选设定位置。如同标准行程命令一样，用户必须将设定值写入寄存器T R2 和R3。.然后在控制字节的CB.4位触发自启动的使能. 根据数字输入1的状态，步进电机运行到以下位置, 如果:

  • 数字输入1 是高电位 (24 V),运行到R2 和R3中给定的位置值 .
  • 数字输入 1 是低电位 (0 V), 电机回到位置0.

在运行期间，数字输入能改变电机转动状态. 端子模块立即识别改变，停止电机，朝另一个方向转动.端子模块通过设定状态字的SW.3位提示已到达目标位置。

WARNING

Motor starts immediately!

如果步进电机位于0位和更高目标位置(由R2和R3给出)之间，当激活控制字节的CB.4位，步进电机就会立即启动.
在激活之前,建议先删除当前位置，将输出1设为低电位.

在确保系统稳定的情况下允许自启动，可以不用考虑自启动对人和机器的危害!

Auto-stop function

自停止功能能通过设定特征寄存器的RP0.R32.1位来激活.

此功能能使用户自动停止电机(e.g.通过两个限制开关). 在控制字节中对CB.5 置位就能启动此功能. 如果电机运行到一个限位开关，在输入1或者输入2中产生一个上升沿信号,电机就会紧急减速停止(可通过寄存器RP0.R50配置). 通过R52.14位和R52.15位能断开输入1和2的配置连接 (这表示LOW的激活状态). 电机也会在断线情况下停止。.

Fast-stop function

PLC 停止功能相当于自停止功能, 但此功能只能用PLC实现.此功能不必在特征寄存器中激活。通过对特征寄存器的CB.1置位激活此功能，电机紧急减速停止。例如，对于用低减速配置一个有效的行程指令，这是很有用的.

Referencing

步进电机端子提供简单的寻原点功能(homing).数字量输入端作为凸轮向导.如果只使用一个参考输入点, 第二个输入点可以通过RP0.52.4 或者 RP0.52.5位禁用。 下面的例子详细描述了寻原点的过程。

以下寄存器在寻原点过程中可预设参数：

  • RP0.R40: 最大加速度
  • RP0.R50: 紧急加速度
  • RP0.R53: 反向参考速度 vref,b (反向指位置回退)
  • RP0.R54: 正向参考速度 vref,f (前向指位置前进)
  • RP0.R55: 参考位置(低字的值)
  • RP0.R56: 参考位置(高字的值)
Example

以下描述了寻原点的过程：

1. 通过寄存器通讯将参数写入寄存器RP0.R40, P0.R50, RP0.R53, RP0.R54, RP0.R55 和 RP0.R56.

2. 将控制字节的CB.0位设为1bin使能电机控制.

3. 通过寄存器通讯将指令0x0520 写入寄存器R7准备寻原点过程。

4. 现在,过程输出数据DataOUT必须为零，即可开始寻原点。

5. 在寻原点开始阶段，不允许驱动两个数字量输入端,因为他们相互间没有关联!

6. 将控制字节的CB.2位设为1bin 启动寻原点。 此时，步进电机端子模块以速度vref,b 驱动电机向限位开关反向行进 (如果要以vref,f 速度正向行进，要将RP0.R52.0置位).

7. 如果端子模块两个输入端的任一个检测到上升沿信号则表明到达限位, 即采用紧急加速来停止电机转动.

8. 之后步进电机端子模块驱动电机以速度vref,b向相反方向行进

9. 如果在已驱动的数字输入端出现下降沿(表明电机已经离开限位开关), 端子模块用紧急减速来停止电机.

10. 现在，端子通过设定状态字的SW.3位报告已成功完成寻原点。同时在寄存器RP0.R55和RP0.R56 中将原点位置写入作为实际位置。

11. 将控制字节的CB.2位设回0bin完成寻原点。

12. SW.3位变为0bin表明端子已接受命令。

Self adjusting

步进电机模块提供了一个简单的自调整功能"on the fly".自调节可用于线性轴.

一个开关, 作为触发传感器安装在延伸处. 如果开关被触发，那么在端子上就会引起门闩事件(任何门闩输入都能使用).

第一次产生的门闩值作为参考位置。 在下一次开关触发时， 保存了一个新的门闩值，端子模块就会纠正参考位置的值和在运行操纵下门闩值之间的差.
在以下示例中，详细描述了该过程.

Example

以下示例是一个自调节的设置过程.

1. 将控制字节的CB.0位设为1bin使能电机控制.

2. 通过寄存器通讯将指令0x0530写入寄存器R7中，激活自调节.

3. 通过使用控制字tCW.0 到 CW.4的位可以激活一个latch event 锁存参考位置。

4. 将转速写入过程数据字DataOUT驱动电机向参考位置行进。

5. 一旦到达参考位置，端子模块将状态字的SW.4位置位。

6. 在过程数据字DataOUT中设置速度值为零，删除门闩使能 (直到现在才存储参考位置).

7. 将反向转速值写入过程数据字DataOUT中,再次驱动电机回到起始位置.

8. 一旦到达起始位置,在控制字中再次激活之前应用的门闩事件.

9. 将转速值写入过程数据字DataOUT中，参考第3步再次激活latch event。

10. 在过程数据字DataOUT中将转速值设为零，删除门闩使能(修正当前位置).

11. 通过寄存器通讯将停止指令0x0540写入寄存器R7中结束自调整.


ELxxxx, KLxxxx - Installation on mounting rails

BECKHOFF Fieldbus Components: Mounting and wiring

导轨上的安装

WARNING

防止触电!

请在处于安全,电源关闭的情况下进行安装或拆除本总线端子模块.

装配

只要用很小的力就可以把总线耦合器和总线控制安装在通用的35mmC形导轨上：

1. 首先把总线耦合器安装在导轨上。

2. 总线端子安装在总线耦合器的右边。 端子与耦合器以及端子与端子之间通过槽扣方式连接, 紧贴着扣槽把端子卡在导轨上，卡上后会发出咔的响声。如果安装在导轨上的端子槽扣没有扣在一起K总线将不会导通！安装正确的话连接处是没有缝隙的。

在安装总线端子的时候，注意不要让端子碰到固定导轨的螺丝。

拆卸

端子依靠卡锁固定在导轨上，在拆卸端子的时候要释放卡锁:

1. 小心地把橙色的拉杆拉出大约 1cm，底部的卡锁就会释放，不需要很大的力就可以把端子从导轨分离。

  2. 用拇指和食指抓住模块的上部和下部的外壳向外拉，把模块彻底从导轨上拆下来。

总线端子的连接

总线耦合器和端子之间的电气连接在安装模块的时候自动完成：

  • 六个K总线弹簧连接片传输总线端子的数据和电源。
  • 现场电子组件的电源供电通过电源触点完成，插在一起的电源触点形成了一个电源链。总线耦合器提供电源触点。

NOTE

Power Contacts

由于一些总线端子(例如 模拟量总线端子或4-通道数字总线端子) 都没有通过这些电源触点形成回路，必须考虑总线端子的分配。电源供电端子 (KL91xx, KL92xx) 提供电源触点，并代表一个新的电源链的开始。

PE 连接

标有“PE” 标签的电源触点用于对地保护。出于安全的原因这些点应首先插接在一起，它最多可承担 125A 的对地短路电流。

CAUTION

Possible damage of the device!

需要注意的是，出于电磁兼容性方面的考虑，PE 触点与安装导轨之间为电容偶合特性。在绝缘测试期间可能产生错误结果或毁坏端子(如：在设备230 V绝缘测试的时候造成对地击穿)。

绝缘测试时，总线控制器和电源端子的PE端必须断开。为了断开更多的反馈点进行测试，这些供电端子必须拉出来 10mm。

WARNING

Risk of electric shock!

PE的电源连接不能用于其它电位。

Wiring

端子最多有8个点可用粗线或细线连接，端子连接采用弹簧连接技术：

1. 把起子插入端子上面的方孔撬开弹簧端子。

2. 电线可以很容易的插入端子上的圆孔内。

  3. 拔出起子当压力释放时，端子会自动关闭，并且安全而牢固的卡住连线。.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm

NOTE

屏蔽

模拟传感器应与双绞线相连接.


KL2531 - Connection

BECKHOFF KL2531: Mounting and wiring

接线

WARNING

Risk of electric shock and damage of device!

为了确保总线端子系统的安全,在安装,拆除或者接线总线端子前断电!

Terminal point | No | Connection
A1 | 1 | 电机绕组A
B1 | 2 | 电机绕组B
Sense A | 3 | 电机绕组A
Input 1 | 4 | 数字量输入通道1 (24 VDC) 如果控制字中的CW.1被置位，并且在数字量输入通道1上有一个上升沿触发, 则当前计数器值作为参考点保存到锁存寄存器中。
A2 | 5 | 电机绕组A
B2 | 6 | 电机绕组B
Sense B | 7 | 电机绕组 B
Input 2 | 8 | 数字输入通道2 (24 VDC) 如果控制字中的CW.1被置位，并且在数字量输入通道1上有一个上升沿触发, 则当前计数器值作为参考点保存到锁存寄存器中。

Note

接线示例

注意KL2531的 connection examples .


KL2531 - General connection examples

BECKHOFF KL2531: Mounting and wiring

KL2531 – 常见接线举例

WARNING

Risk of electric shock and damage of device!

为了确保总线端子系统的安全,在安装,拆除或者接线总线端子前断电!

CAUTION

Connect motor phases correctly!

一个电机相绕组只能连接步进电机端子相同输出级的端点, e.g.

  • 一相连接到端点A1和 A2,
  • 另一相连接到端点B1 和B2.

如果连接电机相到模块的不同输出端点(e.g. A1 和 B1), 这样会损坏步进电机端子的输出级!

Connection modes

步进电机模块KL2531有双极性输出端，能控制双极和单极性电机.

双极性电机

双极性电机的双极性串联控制
双极性电机的双极性并联控制

Note

Beckhoff 步进电机的资料

这两个例子是Beckhoff 双极性电机AS1010, AS1020 或者 AS1030的接线.
更多Beckhoff 步进电机的信息可以在我们的网站www.beckhoff.com中的资料库中找到.

单极性电机

单极性电机的双极性控制

只能控制一半绕组.


KL2541 - Connection

BECKHOFF KL2541: Mounting and wiring

接线

WARNING

Risk of electric shock and damage of device!

为了确保总线端子系统的安全,在安装,拆除或者接线总线端子前断电!

端点

左手边的外壳截面

Terminal point

No

Connection

A

1

编码器输入端A

C

2

编码器输入端C (零输入). 如果在控制字中CW.0位置1，在编码器输入端C有上升沿触发，那么在门闩寄存器中保存当前计数值作为参考值.

编码器供电 +24 V

3

编码器供电(正极电压触电)

输入端1

4

数字量输入端1 (24 VDC)

B

5

编码器输入端 B

门闩/门

6

门闩输入. 在门闩寄存器中保存当前计数值作为参考值，在控制字中

  • CW.3位值1，在门闩输入端上升沿触发; 或者
  • CW.4 位值1，在门闩输入端下降沿触发.

如果通过以下对门闩输入的设置，计数器就会失效

  • 特征位 RP0.R32.12 置1，门闩/门输入端低电势; 或者
  • 特征位 RP0.R32.13 置1，门闩/门输入端高电势

如果计数器失效，通过状态位SW.7，将失效信息从端子模块报告给寄存器.

编码器供电 0 V

7

编码器供电(负极电压触电)

输入端 2

8

数字量输入端2 (24 VDC)
右手边的外壳截面
Terminal point (right) | No | Connection for
A1 | 1' | 电机绕组 A
B1 | 2' | 电机绕组 B
感应端 A | 3' | 电机绕组 A
电机供电 | 4' | 输出级馈电 (最大 +50 VDC)
A2 | 5' | 电机绕组 A
B2 | 6' | 电机绕组 B
感应端 B | 7' | 电机绕组 B
电机供电 | 8' | 输出级馈电(0 VDC)

Note

Connection examples

注意KL2541的connection examples !

电源触点

电源触点对以下负载提供+24 VDC电压:

  • 增量编码器(端点3 和 7)
  • 数字量输入(端点 4和 8)
  • 步进电机端子的输出驱动

Note

电源电压的接通指令

当K-Bus 电压接通时，电源触点的电压必须激活,，初始化内部电路(输出驱动).
如果由于应用条件的限制而不能实现初始化(e. g. 用带有紧急停止开关的电路连接供电电源), 那么你就必须在启动系统之后对端子模块进行软件复位(参考 command 8000).
固件版本为2D中通过SW.14位识别和显示失控的电压 (24 V, 来自电源触点). 控制电压的反馈值会立刻识别，并且完成初始化.

WARNING

电机在K-Bus电压失效情况下不会停止运转!

如果 K-Bus 电压 (5V) 失效, 电机控制器不会设回初值!
这就意味着, 如果电机在运转，就不会停止!


KL2541 - General connection examples

WARNING

Risk of electric shock and damage of device!

为了确保总线端子系统的安全,在安装,拆除或者接线总线端子前断电!

CAUTION

Connect motor phases correctly!

一个电机相绕组只能连接步进电机端子相同输出级的端点, e.g.

  • 一相的端点A1和 A2,
  • 另一相的端点B1 和B2.

如果连接电机相的不同输出级的端点(e.g. A1 和 B1), 这样会损坏步进电机端子的输出级!

Connection modes

步进电机模块KL2541有双极性输出端，能控制双极和单极性电机.

双极性电机

双极性电机的双极性串联控制
双极性电机的双极性并联控制

Note

Documentation for stepper motors from Beckhoff

这两个例子是Beckhoff 双极性电机AS1010, AS1020, AS1030, AS1050 或者 AS1060的接线.
更多Beckhoff 步进电机的信息可以在我们的网站www.beckhoff.com中的资料库中找到.

单极性电机

单极性电机的双极性控制

只控制每个绕组的一半.

Connection of an encoder (24 V)

电源触点端点3 (+24 V) 和7 (0 V)供电给编码器.


KS2000 Configuration Software

BECKHOFF Fieldbus Components: KS2000 Configuration Software

KS2000 组态软件

KS2000组态软件可以对总线耦合器及所连模块、,现场总线盒进行调试以及参数设置.现场总线组件与 PC 之间通过串行电缆或总线连接。

组态

您可在脱机状态下使用组态软件对现场总线站进行设置,意思是, 建立一个与耦合器和端子能分别设置的终端站点.现场总线盒能在调试阶段之前准备完成.接着,在调试阶段此组态依靠下载的方式能被转换至终端站点,出于记录目的,将会为你提供损坏的终端站,模块清单和您所修改的参数项目清单.在上传之后,建立现场总线站并等待您的后续操作.

使用 KS2000 软件,可以非常简便地访问现场总线站的参数:特殊高级别的对话可以用于所有的总线耦合器,所有总线耦合器,所有智能总线端子以及现场总线端子盒模块都提供有对话框,以便轻松修改设置.另外,还可通过直接访问所有内部寄存器对现场总线组件进行参数设定.

调试步骤

KS2000软件方便了机器零件和现场总线站的运作:配置设置能够依靠下载被转移到现场总线端子.在登录到终端之后,它可以在网上直接对耦合器,端子模块以及现场总线盒进行定义.在配置阶段,同样高级别的对话以及寄存器的访问是可以达到这个目的的.

KS2000能够访问总线耦合器和现场总线端子盒模块的进程映像.

  • 因此,耦合器的输入输出图像时可以观察出来的.
  • 进程值可以指定在输入图像的输出模块调试.

在联机模式下的情况可以与终端站的实际现场总线模式并行使用.但现场总线协议一般有较高的优先级.


KL2531, KL2541 - Parameterization with KS2000

BECKHOFF KL2531, KL2541: KS2000 Configuration software

KS2000参数设置

配置PC串口，连接KS2000电缆至现场总线耦合器的配置接口，并启动KS2000组态软件.

点击Login 按钮后,KS2000会加载所连现场总线站点的所有连接总线模块信息,这里举个例子,如下:

  • 1台 BK9000: 以太网耦合器
  • 1块 KL1xx2: 数字量输入端子模块
  • 1块 KL2531: 单通道步进电机端子模块
  • 1块 KL9010: 总线终端模块

KS2000左半边窗口树形化显示了所有现场总线端子模块。
KS2000右半边窗口图形化显示了所有现场总线段子模块。

在左侧窗口的树结构中,点击端子旁边的加号后即可进入该模块的参数设置部分（例子中为第二块模块）

对于KL2531 或者KL2541, Register, Settings and ProcData 显示为:

  • Register 能直接访问KL2531/KL2541寄存器地址.
  • KL2531/KL2541.的参数的对话框能够在settings下方找到.
  • ProcData 显示KL2531/KL2541的过程数据.


KL2531, KL2541 - KS2000 Register

BECKHOFF KL2531, KL2541: KS2000 Configuration software

寄存器

在 Register 下你可以直接访问 KL2531/KL2541寄存器。寄存器的内容在register overview中说明..


KL2531, KL2541 - KS2000 Settings 1

BECKHOFF KL2531, KL2541: KS2000 Configuration software

Settings 1

表 Settings 1 用于设置 KL2531和KL2541的参数.

操作模式 (RP0.R32.4, RP0.R32.3)

选择步进电机端子模块 mode:

  • speed, direct
  • speed, with ramps
  • position tracking
  • path control:
    - manual
    - travel command

根据选择的模式, 通过配置步进电机端子模块可以在 General, encoder and Register values下对步进电机端子模块进行多参数的配置.

Ramps

在 path control 模式下, 你可以指定斜坡类型 (RP0.R32.5):
- Ramps,线性
- Ramps,指数型 (在减速时)

只有在一个行程指令期间才能激活此设置. 在 velocity, with ramps 模式和手动 path control 模式下, 加速度总是基于直线斜坡.

General

Watchdog timer active (RP0.R32.2)

这里你可以取消看门狗 (默认:激活 ).如果激活看门狗，步进电机端子在超过100ms时间内没有接收到控制器的过程数据，那么看门狗触发，电机停转.

Auto start function active (RP0.R32.0)

这里你可以激活Auto-start function. 此作用只有在操作模式 path control 下才可行 (default: inactive).

Auto stop Function active (RP0.R32.1)

这里你可以激活Auto-stop function. 此作用只有在操作模式 path control 下才可行 (default: inactive).

Deceleration ramp active (RP0.R52.1)

这里你能激活减速斜坡. 此作用只有在操作模式 path control 下才可行(Default: inactive).

Latch event deletes counter (RP0.R32.7)

当门闩事件触发时，这里你能激活对计数器的检查(default: inactive).

Store multiple latch values (RP0.R32.9)

这里你可以激活多门闩值的存储(default: inactive).

reverse digital input 1 for break contacts (RP0.R52.14)

这里你能将数字量输入1端设为常开触点(default: inactive,常闭触点).

reverse digital input 2 for break contacts (RP0.R52.15)

这里你能将数字量输入2端设为常开触点 (default: inactive, 常闭触点).

Show idle Status (RP0.R52.3)

这里你可以激活在状态字节之间的闲置状态值的显示(SB.4) (default: inactive).

Invert position feedback (RP0.R32.6)

这里你能颠倒位置反馈,位置值来源于编码器，编码器安装在步进电机反方向的传动轴上(default: inactive).

Encoder position feedback (KL2541 only) (RP0.R32.11)

这里你可以停用KL2541编码器输出端 (default: active). 这也能激活内部位检测功能.

Register values

maximum coil current A (RP0.R35)

这里你可以指定绕组A的限制电流，从0到100%额定端子电流 (default: 100%).
KL2531-0000: 100% = 1.5 A
KL2541-0000: 100% = 5.0 A

maximum coil current B (RP0.R36)

这里你可以指定绕组B的限制电流，从0到100%额定端子电流(default: 100%).
KL2531-0000: 100% = 1.5 A
KL2541-0000: 100% = 5.0 A

Number of latch values (RP0.R37)

如果激活store multiple latch values选项 ,已保存的门闩值的位数能在这指定(default: 20).

minimum velocity vmax (RP0.R38)

你可以指定path control模式下的滑行速度 (default: 10dec).

滑行速度是指：步进电机立即停止并且不发生步进误差情况下所能达到的最大转速. 它取决于电机的保持扭矩和传动轴的最大旋转.

maximum velocity vmin (RP0.R39)

这里可以指定操作模式velocity, with ramps 和path control下的最大转速 (default: 0x07FF, maximum: 0x07FF).

maximum acceleration aacc (RP0.R40)

这里可以指定操作模式velocity, with ramps 和path control下的最大加速度(default: 0x07FF, maximum: 0x07FF).

maximum deceleration adec (RP0.R58)

这里可以指定操作模式velocity, with ramps 和path control下的最大减速度 (default: 0x07FF, maximum: 0x07FF).

maximum emergency acceleration ae (RP0.R50)

这里可以指定操作模式path control下的最大紧急加速度 (default: 2047, maximum: 2047). 在CB.1位的上升沿 , 用紧急加速度停止电机.如果激活auto-stop function (RP0.R32.1 = 1bin and CB.5 = 1bin), 这同样也在数字量输入1或2端的上升沿发生.

Acceleration threshold ath (RP0.R41)

加速度这里你可以指定加速度极限(default: 0x03FF, maximum: 0x03FF).

Load angle threshold (RP0.R47)

这里你可以指定Stall Detect LED 开始闪烁时的负载角极限. (default=7).

负载角是电机负载的测量值，它的显示值在0和7之间, 7代表最大负载情况.

Coil current, a > ath (RP0.R42)

当a > ath 时，这里你能指定0到100%之间的额定端子线圈的线圈电流(default: 100%).

ath: 设定加速度
a: 加速度

Coil current for a ≤ ath (RP0.R43)

当a ≤ ath 时，这里你能指定0到100%之间的额定端子线圈的线圈电流(default: 100%).

Coil current for v = 0 (automatic) (RP0.R44)

这里你能指定自动保持电流(default: 50%).

当电机处于停滞状态,线圈电流自动减小为保持电流的值, 确保不必要的电机热耗. 保护电流的值参考端子的设定线圈电流的值.

Coil current for v = 0 (manual) (RP0.R45)

这里你可以指定手动保持电流(default: 50%).

如果控制字节CB.3 或CW.11 置1, 线圈电流手动减小为保持电流的值, 确保不必要的电机热耗. 保护电流的值参考端子的设定线圈电流的值. 自动和手动减小线圈电流是不能叠加的! 手动值有更高的优先级!

Number of impulses per revolution (Motor) (RP0.R51)

控制电机运动的传感器输入数(default: 1). 这个要素用于计算定位偏差.

Full steps per revolution (motor) (RP0.R33)

连接步进电机的满步输入个数需要一个完整的旋转(default: 200).

Increments per revolution (encoder), KL2541 only (RP0.R34)

在一个完整的旋转中，输入的增量数通过连接在KL2541的编码器给出 (default: 4000).


KL2531, KL2541 - KS2000 Settings 2

BECKHOFF KL2531, KL2541: KS2000 Configuration software

Settings 2

表Settings 2用于设置 KL2531和KL2541的参数.

Referencing

这些参数只能在操作模式path control下可行.

reverse direction of reference journey (RP0.R52.0)

这里你能使行程基准方向反向(default: inactive).

Reference input 1 active (RP0.R52.4)

这里你能使基准输入1失效(default: active).

Reference input 2 active (RP0.R52.5)

这里你能使基准输入2失效(default: active).

vref,b towards the cam, referencing speed backward (RP0.R53)

这里你可以指定电机朝基准行程凸轮方向运动的速度(default: 500dec).
反向运动表示端子用减少定位值的方法驱动电机.

vref,f from the cam, referencing speed forward (RP0.R54)

这里你可以指定电机远离基准行程凸轮方向运动的速度 (default: 50dec).
向前运动表示,端子在上升定位值的方法驱动电机.

Reference position (RP0.R56 and RP0.R55)

这里你可以指定基准行程的基准位(default: 0).

Encoder (KL2541 only)

Counter mode active (R32.15)

这里你可以激活计数器模式 (default: inactive). 如果计数模式激活, 那么 KL2541编码器输入 可以对一个32位的正向/反向计数机进行操作(signal A=cycle, signal B=direction, C=enable).

Input filter active (R32.14)

这里你可以停用编码器信号的输入滤波(default: active).

Show encoder signals (R32.10)

对于KL2541, 按照如下操作你可以激活状态字信号显示:
- 将C信号 输入到SW.6位中
- 将gate信号输入到 SW.7位中
(default: inactive).在这种情况下, LatchDataToggled 确认 CW.6位 ，EncoderDisabled 位不能使用.

A positive level at the gate locks the counter (R32.13)

这里你能通过在KL2541的门输入端的一个正向信号电平使计数器失效(default: inactive).

A negative level at the gate locks the counter (R32.12)

这里你能通过在KL2541的门输入端的一个负向信号电平使计数器失效 (default: inactive).

Target positions

这里你可以在path control操作模式下指定16个target positions. 这些参数只能在path control操作模式下可行.

Position 0 (RP2.R33 and RP2.R32)

这里你可以指定0 目标位(default: 0).

Position 1 (RP2.R35 and RP2.R34)

这里你可以指定1目标位(default: 0).

等待

Velocity 0 (RP3.R32)

这里你可以指定到达0目标位的速度 (default: 2047).

Velocity 1 (RP3.R33)

这里你可以指定到达1目标位的速度 (default: 2047).

等等

Acceleration 0 (RP3.R48)

这里你能指定到达0速度的加速度(default: 2047).

Acceleration 1 (RP3.R49)

这里你能指定到达1速度的加速度(default: 2047).

等等


KL2531, KL2541 - KS2000 - Current table

BECKHOFF KL2531, KL2541: KS2000 Configuration software

Current table

Current table 表用于设置fKL2531 和KL2541的参数.

在第一个四分之一周期中能指定多达64步. 使用下面的检测框，对每个步你都能指定0到15之间的电流值

第一个四分之一周期的指定电流自动作为剩下的四分之三周期中的电流(带有所需信号的相关改变).

Step size (RP0.R46)

选择四分之一周期下的步的值.

Step size | 1/64 | 1/32 | 1/16 | 1/8 | 1/4 | 1/2 (half step) | 1/1 full step
Steps/quarter period | 64 | 32 | 16 | 8 | 4 | 2 | 1

Current values

对1/64步大小，你可以手动指定电流值. 他们在用户电流表中保存.
对所有的微步大小都能使用正弦曲线.

Manual specification of the current values

Group

在四组数据中指定电流值，每组包括16位电流值.
用下面的16位检测盒选择你需要用参数表示的组:

  • 1 - 16
  • 17 - 32
  • 33 - 48
  • 49 - 64

通过按 [image] 键，输入电流值传送到端子并储存在用户电流表格中.

电流表格的激活(RP0.R32.7)

用这个选项你可以激活用户电流表格代替内部电流表格.

  • 内部电流表显示的是正弦曲线.只指定步的大小.
  • 用户电流表(如果选择激活1/64 步的大小)能使用检测盒自由编辑.
Reload

读取存于端子中(RP1.R32 to RP1.R47)的值并显示出来.

Sine

显示正玄曲线.

Examples

Full step: | Half step:
1/4 step: | 1/8 step:
1/16 step: | 1/32 step:
1/64 step (all selection boxes are active): |


KS2000 - Process Data

BECKHOFF Fieldbus Components: KS2000 Configuration Software

过程数据

状态字(State), 控制字(Ctrl)以及过程数据(Data)会像树结构一样显示在ProcData下..

标有眼镜标志的数据会在History框中以图形显示。

当前值会以数值形式显示在 Value 中。

初始值可以进行修改,通过直接输入或者通过滑块进行修改.

CAUTION

对个人、环境 、材料的危害!

注意改变初始值(强迫修改)会直接影响设备的正常运行.
只有在设备条件允许和对人和机器没有危害的情况下才能修改这些初始值,

在按"Settings "按钮之后,你可以设定十六进制，十进制，二进制的显示格式(数值型):


KL2531-0000, KL2541-0000 - Process image

BECKHOFF KL2531-0000, KL2541-0000: Access from the user program

过程映像

Note

没有紧凑型过程映像

紧凑型过程映像(没有控制字节和状态字节)是不能控制 KL2531 和KL2541 的,因为端子模块的过程数据模式只有有了控制字节和状态字节才有意义. 即使你的总线耦合器设置为紧凑型过程映像,然而KL2531和KL2541 只能用完整的过程映像表示!

在过程映像中最少要有5个字节的输入和五个字节的输出数据才能表示KL2531-0000和KL2541-0000. 如下表所示:

Byte offset (without word alignment) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Byte | SB | CB
1 | 2 | Word | DataIN | DataOUT
3 |  | Word | SW | CW

*) Word alignment: 总线耦合器在偶数位地址上设定

Key

SB: 状态字节
CB:控制字节

DataIN: 输入数据字 (当前位置)
DataOUT: 输出数据字(e. g. 设定转速, 观察过程数据)

SW:附加状态字
CW: 附加控制字

过程数据

通过步进电机端子模块的 operation mode模式在过程数据模式下的过程数据字DataIN 和DataOUT之间传输数据。

Operation mode | DataIN | DataOUT
Velocity, direct | 当前位置 (低位字)..通过寄存器通讯从寄存器R0和R1中能读取所有当前位(32 位) | 转速值(带符号15位 ), 查看formula
Velocity, with ramps |  | 转速值 (带符号的11位), 查看formula. 端子只能识别4到15位.
Position tracking |  | 设置位 (带符号的15位)
Path control |  | 手动操作: 手动模式下的转速值 (带符号的11位 ) , 查看 formula. 端子只能识别4到15位. 为了能手动指定转速值，必须停止行程指令(CB.2=0)! 行程指令: 通过寄存器通讯，在寄存器R2 和R3中输入行程指令的设定位 (32位). 为了启动行程指令，DataOUT 必须为0!

Note

特殊类型

你可以在附加的文档(KL2531-1000e.chm)中找到关于特殊类型 KL2531-1000和KL2541-1000的信息, 如果需要请向相关人员索取。


Control and status byte

BECKHOFF KL2531, KL2541: Access from the user program

控制字节和状态字节

过程数据模式

控制字节 (过程数据模式)

控制字节 (CB) 位于output image中,并从控制器传入到端子模块 .

Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.3 | CB.0
Name | RegAccess | Reset | AutoStop | AutoStart | Reduced Current | Start | FastStop | Enable
说明
Bit | Name | Description
CB.7 | RegAccess | 0bin | 寄存器通讯无效(过程数据模式)
CB.6 | Reset | 1bin | 通过这个位置1，重置所有可能发生的错误(上升沿触发)
CB.5 | AutoStop1 | 1bin | 激活自停止功能
CB.4 | AutoStart2 | 1bin | 激活自启动功能
CB.3 | Reduced Current (identical to bit CW.11) | 1bin | (当点击停止时)激活减小线圈电流功能 (通过 R45设定)
CB.2 | Start2 | 0bin | 终止行程指令
 |  | 1bin | 启动行程指令
CB.1 | FastStop2 | 1bin | 用紧急加速度停止电机(R50) (上升沿触发)
CB.0 | Enable | 0bin | 停止电机控制
 |  | 1bin | 启动电机控制

1) 除了Position tracking ,在所有操作模式中都可行.
2) 仅在Path control 操作模式中可行.

状态字节 (过程数据模式)

状态字节 (SB) 位于 input image中, 并从端子模块传送到控制器.

Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | Warning | Idle | LoadAngle |  |  | Ready
Legend
Bit | Name | Description
SB.7 | RegAccess | 0bin | 确认过程数据模式
SB.6 | Error | 0bin | 无错误
 |  | 1bin | 发生一个错误(SW.13-SW.9)
SB.5 | Warning | 1bin | 端子模块的内部温度高于 80°C或者负载角大于寄存器 R.47的值
SB.4 | Idle | 0bin | 现在端子模块执行一个任务 (激活电机转动或者行程指令)
 |  | 1bin | 端子模块没有工作 (闲置)
SB.3 to SB.1 | LoadAngle | 负载角(电机侧的电流机械负载,取决于最大线圈电流和当前转速 )
SB.0 | Ready | 0bin | 电机控制无效或者发生一个错误(SB.6=1)
 |  | 1bin | 电机控制有效并没有发生错误(使能确认, SB.6=0)

寄存器通讯

控制字节(寄存器通讯)

控制字节 (CB) 位于output image中,并从控制器传入到端子模块.

Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.3 | CB.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit | Name | Description
CB.7 | RegAccess | 1bin | 开启寄存器通讯
CB.6 | R/W | 0bin | 可读
 |  | 1bin | 可写
CB.5 to CB.0 | Reg. no. | 寄存器数: - 你想用输入数据字DataIn读或者 - 你想用输出数据字DataOut写 的输入register 数.

状态字节 (寄存器通讯)

状态字节 (SB) 位于 input image中, 并从端子模块传送到控制器.

Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit | Name | Description
SB.7 | RegAccess | 1bin | 确定寄存器可用
SB.6 | R | 0bin | 可读
SB.5 to SB.0 | Reg. no. | 读和写的寄存器数.


KL2531, KL2541 - Control and status word

BECKHOFF KL2531, KL2541: Access from the user program

控制字和状态字

控制字

控制字 (CW) 位于output image中,并从控制器传入到端子模块.

Bit | CW.15 | CW.14 | CW.13 | CW.12 | CW.11 | CW.10 | CW.9 | CW.8
Name | - | Set-Position in ProcData | Clear Position | Reduced Current (drive) | Reduced Current | SetPos | disMixed Decay | GetEncoder Position
Bit | CW.7 | CW.6 | CW.5 | CW.4 | CW.3 | CW.2 | CW.1 | CW.0
Name | GetPosition Error | Toggle LatchData | Get LatchData | enLatch FallEdge | enLatch RiseEdge | enLatch Input2 | enLatch Input1 | enLatchC
说明
Bit | Name | Description
CW.15 | - | 0bin | 预留
CW.14 | Set-Position in ProcData | 1bin | 来自set-velocity to set-position 的交换机过程数据( 参考specify set-position功能)
CW.13 | ClearPosition | 1bin | 删除定位值 (上升沿触发) 注意: 比CW.10的优先级更高
CW.12 | Reduced Current (drive) | 1bin | 当电机转动时激活减小线圈电流(通过R45指定)
CW.11 | ReducedCurrent (same function as bit CB.3) | 1bin | 当电机停止时激活减小线圈电流(通过R45指定)
CW.10 | SetPos | 1bin | 通过寄存器R2和R3 设置定位值(上升沿触发) 注意:只有CW.13=0时才能激活
CW.9 | disMixedDecay | 0bin | 通过每半波的2次脉冲晶体管控制电机
 |  | 1bin | 通过每半波的1个脉冲晶体管和1个开关通道晶体管控制电机
CW.8 | GetEncoder Position1, 2 | 1bin | 在过程映像中显示当前编码器位置
CW.7 | GetPositionError1 | 0bin | 在输入过程数据的位2和位3中显示当前位置
 |  | 1bin | 在输入过程数据的位2和位3中显示相对position error
CW.6 | ToggleLatchData | 0bin | 如果改变这个位,激活门闩数组 (R32.9) 和对CW.5置1，那么存有的多达20个门闩值将恢复.
 |  | 1bin
CW.5 | GetLatchData | 0bin | 在输入过程数据的2,3位中显示当前位
 |  | 1bin | 在输入过程数据的2,3位中显示当前门闩值
CW.4 | enLatchFallEdge (external) | 1bin | 外部门闩事件有效(由于门闩下降沿输出,端子模块保存当前位) 注意: 高于CW.1和CW.2的优先级!
CW.3 | enLatchRiseEdge (external) | 1bin | 外部门闩事件有效(由于门闩上升沿输出,端子模块保存当前位) 注意: 高于CW.1,CW.2和CW.4的优先级!
CW.2 | enLatchInput2 | 1bin | 外部门闩事件有效 (在数字量输入1的上升沿，端子模块保存当前位置)
CW.1 | enLatchInput1 | 1bin | 外部门闩事件有效 (在数字量输入2的上升沿，端子模块保存当前位置) 注意: 比CW.2有更高的优先级!
CW.0 | enLatchC (internal) | 1bin | 内部门闩事件有效 (由于C端上升沿输入,端子模块保存当前位置) 注意:高于CW.1, CW.2, CW.3 和CW.4的优先级!

1) 只能在内部定位
2) 只用于KL2541

状态字

状态字节(SW) 位于 input image中, 并从端子模块传送到控制器.

Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8
Name | Config Error | NoControl Power | OverCurrent Br B | OverCurrent Br A | OpenLoad Br B | OpenLoad Br A | Under Voltage | Over Temperature
Bit | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | Encoder Disabled | LatchData Toggled | LatchData InByte2,3 | LatchValid | Target Reached | SetPos Ready | Input 2 | Input 1
说明
Bit | Name | Description
SW.15 ConfigError 1bin 配置错误(terror A LED置1). 原因:
  • 电机全步为0 (R33), 只有KL2541
  • 编码器增量值为0 (R34), 只有KL2541
  • 最小转速值vmin为0 (R38)
  • 最大转速值vmax为0 (R39)
  • 最大加速度值amax0 (R40)
  • 当a > ath，线圈电流的值 IS 为 0 (R42)
  • 当a ≤ ath，线圈电流的值 IS 为0 (R43)

如果错误配置寄存器写入正确的数据，那么错误显示将自动删除.

SW.14 NoControl Power 0bin 控制电源加压击穿(error B LED 闪烁, 端子自动关闭电机). 如果返回控制电源电压那么端子会自动重启.
注意: 通过设置控制字节的CB.6位确认用户已使用的错误信息!
SW.13 OverCurrent Br B 1bin 过电流, B桥 (error B LED 闪烁, 端子自动关闭电机)
A注意: 通过设置控制字节的CB.6位确认用户已使用的错误信息!
SW.12 OverCurrent Br A 1bin 过电流, 桥A (error B LED 闪烁, 端子自动关闭电机)
注意: 通过设置控制字节的CB.6位确认用户已使用的错误信息!
SW.11 OpenLoad Br B 1bin 开路负载, 桥 B (error B LED 闪烁, 端子自动关闭电机)
注意: 通过设置控制字节的CB.6位确认用户已使用的错误信息!
SW.10 OpenLoad Br A 1bin 开路负载,桥 A (error B LED 闪烁, 端子自动关闭电机)
注意: 通过设置控制字节的CB.6位确认用户已使用的错误信息!
SW.9 UnderVoltage 1bin 供电电压太低(error B LED 闪烁, 端子自动关闭电机)
A注意: 通过设置控制字节的CB.6位确认用户已使用的错误信息!
SW.8 OverTemperature 1bin 超温 (参考 SB.5) - 步进控制器芯片温度高于125 °C (error B LED 闪烁, 端子自动关闭电机).
注意: 通过设置控制字节的CB.6位确认用户已使用的错误信息!
SW.7 | EncoderDisabled | 0bin | 编码器有效
1bin | 编码器无效(特征位 R32.12为1 ，门闩输出=0 或者 R32.13为1，门闩输入为1)
SW.6 | LatchDataToggled | 0bin | 如果修改CW.6 ，SW.6有新的状态(确认 ToggleLatchData)，那么新门闩值就会输入输入过程数据的2,3位.
1bin
SW.5 | LatchDataInByte2,3 | 0bin | 在输入过程数据的2,3位显示当前位置
1bin | 在输入过程数据的2,3位显示最后的门闩值 (确认 GetLatchData)
SW.4 | LatchValid | 1bin | 发生门闩事件(CW.0=1, CW.3=1或CW.4=1); 如果激活门闩数组 (R32.9), 一旦储存R37 规定的门闩值的数那么这个位就置1.
SW.3 | TargetReached3 | 1bin | 到达目标位
SW.2 | SetPosReady | 1bin | 删除当前位( CW.13=1) 或者当前位置1 (for CW.10=1) (确认 ClearPos 和SetPos)
SW.1 | Input 2 | 数字量输入2的状态. 用特征寄存器2的RP0.R52.15 位对数字量输入2的值取反.
SW.0 | Input 1 | 数字量输入1的状态. 用特征寄存器2的RP0.R52.14位对数字量输入1的值取反.

3) 只能在Path control操作模式


KL2531, KL2541 - Register overview

BECKHOFF KL2531, KL2541: Access from the user program

寄存器概述

此寄存器用于步进电机的参数调节. 通过 register communication可对寄存器进行读和写.

寄存器 0 ~31有着相同的意义. 寄存器32 ~ 63需要通过寄存器编码选择寄存器R4来指定.

Register no. | Comment |  | Default value |  | R/W | Memory
R0 | Actual position (low-order word) |  | - | - | R | RAM
R1 | Actual position (high-order word) |  | - | - | R | RAM
R2 | Set target position or position (low-order word) |  | - | - | R/W | RAM
R3 | Set target position or position (high-order word) |  | - | - | R/W | RAM
R4 | Register page selection register (range of values: 0 to 2) |  | 0x0000 | 0dec | R/W | RAM
R5 | Latch value (high-order word) |  | - | - | R | RAM
R6 | Temperature register |  | e.g. 0x003C | e.g. 60dec | R | RAM
R7 | Command register |  | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | KL2531: | 0x09E3 | 2531dec | R | ROM
 |  | KL2541: | 0x09ED | 2541dec
R9 | Firmware revision level |  | e.g. 0x3141 | e.g. 1AASCII | R | ROM
R10 | Multiplex shift register |  | 0x0128 | 296dec | R | ROM
R11 | Signal channels |  | 0x0128 | 296dec | R | ROM
R12 | Minimum data length |  | 0x2828 | 10260dec | R | ROM
R13 | Data structure |  | 0x0004 | 4dec | R | ROM
R14 | reserved |  | - | - | - | -
R15 | Alignment register |  | 0x7F80 | 32640 | R/W | RAM
R16 | Hardware version number |  | e.g. 0x0000 | e.g. 0dec | R/W | EEPROM
R17 | reserved |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R30 | reserved |  | - | - | - | -
R31 | Code word register |  | 0x0000 | 0dec | R/W | RAM
R32 to R63 | Register for showing register page 0, register page 1, register page 2 or register page 3 |  |  |  |  |
Register page 0 (further parameters)
Register no. | Comment | Default value |  | R/W | Memory
R32 | Feature register 1 | 0x0000 | 0dec | R/W | EEPROM
R33 | Full motor steps | 0x00C8 | 200dec | R/W | EEPROM
R34 | Encoder increments (KL2541 only) | 0x0FA0 | 4000dec | R/W | EEPROM
R35 | Maximum coil current A | 0x0064 | 100dec | R/W | EEPROM
R36 | Maximum coil current B | 0x0064 | 100dec | R/W | EEPROM
R37 | Number of latch values | 0x0014 | 20dec | R/W | RAM / EEPROM
R38 | Min. velocity vmin | 0x000A | 10dec | R/W | RAM / EEPROM
R39 | Max. velocity vmax | 0x07FF | 2047dec | R/W | RAM / EEPROM
R40 | Max. acceleration amax | 0x07FF | 2047dec | R/W | RAM / EEPROM
R41 | Acceleration threshold ath | 0x03FF | 1023dec | R/W | EEPROM
R42 | Coil current IS, a > ath | 0x0064 | 100dec | R/W | EEPROM
R43 | Coil current IS, a ≤ ath | 0x0064 | 100dec | R/W | EEPROM
R44 | Coil current IS, v = 0 (automatic) | 0x0032 | 50dec | R/W | EEPROM
R45 | Coil current IS, (manual) | 0x0032 | 50dec | R/W | EEPROM
R46 | Step size per quarter period | 0x0006 | 6dec | R/W | EEPROM
R47 | Load angle threshold | 0x0007 | 7dec | R/W | RAM / EEPROM
R48 | Kp factor | 0x0000 | 0dec | R/W | RAM / EEPROM
R49 | Kv factor | 0x0000 | 0dec | R/W | RAM / EEPROM
R50 | Emergency acceleration ae | 0x07FF | 2047dec | R/W | RAM / EEPROM
R51 | Number of impulses per revolution | 0x0001 | 1dec | R/W | EEPROM
R52 | Feature-Register 2 | 0x0000 | 0dec | R/W | EEPROM
R53 | Referencing speed backward vref,b | 0x01F4 | 500dec | R/W | EEPROM
R54 | Referencing speed forward vref,f | 0x0032 | 50dec | R/W | EEPROM
R55 | Referencing position (lower value word) | 0x0000 | 0dec | R/W | EEPROM
R56 | Referencing position (higher value word) | 0x0000 | 0dec | R/W | EEPROM
R57 | Encoder tolerance (only KL2541) | 0x0000 | 0dec | R/W | EEPROM
R58 | max. deceleration adec | 0x07FF | 2047dec | R/W | RAM
R59 | reserved | - | - | - | -
... | ... | ... | ... | ... | ...
R63 | reserved | - | - | - | -
Register page 1 (user current table)
Register no. | Comment | Default value |  | R/W | Memory
R32 | Current value 4 to 1 | 0x1100 | 4352dec | R/W | EEPROM
R33 | Current value 8 to 5 | 0x3221 | 12833dec | R/W | EEPROM
R34 | Current value 12 to 9 | 0x4433 | 17459dec | R/W | EEPROM
R35 | Current value 16 to 13 | 0x5554 | 21844dec | R/W | EEPROM
R36 | Current value 20 to 17 | 0x7666 | 30310dec | R/W | EEPROM
R37 | Current value 24 to 21 | 0x8877 | 34935dec | R/W | EEPROM
R38 | Current value 28 to 25 | 0x9998 | 39320dec | R/W | EEPROM
R39 | Current value 32 to 29 | 0xAAAA | 43690dec | R/W | EEPROM
R40 | Current value 36 to 33 | 0xBBBB | 48059dec | R/W | EEPROM
R41 | Current value 40 to 37 | 0xCCCC | 52428dec | R/W | EEPROM
R42 | Current value 44 to 41 | 0xDDDC | 56796dec | R/W | EEPROM
R43 | Current value 48 to 45 | 0xEEDD | 61149dec | R/W | EEPROM
R44 | Current value 52 to 49 | 0xEEEE | 61166dec | R/W | EEPROM
R45 | Current value 56 to 53 | 0xFFEE | 65518dec | R/W | EEPROM
R46 | Current value 60 to 57 | 0xFFFF | 65535dec | R/W | EEPROM
R47 | Current value 64 to 61 | 0xFFFF | 65535dec | R/W | EEPROM
R48 | reserved | - | - | - | -
... | ... | ... | ... | ... | ...
R63 | reserved | - | - | - | -
Register-Page 2 (user positions table)
Register no. | Comment | Default value |  | R/W | Memory
R32 | Target position 0 (lower-value word) (start value for register 2) | 0x0000 | 0dec | R/W | EEPROM
R33 | Target position 0 (higher-value word) (start value for register 3) | 0x0000 | 0dec | R/W | EEPROM
R34 | Target position 1 (lower-value word) | 0x0000 | 0dec | R/W | EEPROM
R35 | Target position 1 (higher-value word) | 0x0000 | 0dec | R/W | EEPROM
... | ... | ... | ... | ... | ...
... | ... | ... | ... | ... | ...
R62 | Target position 15 (lower-value word) | 0x0000 | 0dec | R/W | EEPROM
R63 | Target position 15 (higher-value word) | 0x0000 | 0dec | R/W | EEPROM
Register-Page 3 (Anwender-Geschwindigkeits- und Beschleunigungstabelle)
Register-Nr. | Kommentar | Default-Wert |  | R/W | Speicher
R32 | Velocity 0 (start value for register 39) | 0x07FF | 2047dez | R/W | EEPROM
R33 | Velocity 1 | 0x07FF | 2047dez | R/W | EEPROM
... | ... | ... | ... | ... | EEPROM
R47 | Velocity 15 | 0x07FF | 2047dez | R/W | EEPROM
R48 | Acceleration 0 (start value for register 40) | 0x07FF | 2047dez | R/W | EEPROM
R49 | Acceleration 1 | 0x07FF | 2047dez | R/W | EEPROM
... | ... | ... | ... | ... | EEPROM
R63 | Acceleration 15 | 0x07FF | 2047dez | R/W | EEPROM


Examples of Register Communication

BECKHOFF Fieldbus Components: Access from the User Program

寄存器通讯实用案例

在例子中,字节是根据无字对齐的说明来编号的.

例1: 在端子模块寄存器9中读取固件版本状态

输出数据
Byte 0: 控制字 | Byte 1: DataOUT1, 高位字节 | Byte 2: DataOUT1,低位字节
0x89 (1000 1001bin) | 0xXX | 0xXX

说明:

  • Bit 0.7 置1显示寄存器通讯激活.
  • Bit 0.6 置0显示读取寄存器.
  • Bit 0.5 至 Bit 0.0 的二进制数为001001那么寄存器号就是9.
  • 输出数据字(Byte 1 and Byte 2)在读访问的时候没有作用.如果你想要改变寄存器,你必须将所需要的数值写入输入数据字中。
输入数据(总线端子的响应)
Byte 0: 状态字 | Byte 1: DataIN1, 高位字节 | Byte 2: DataIN1, 低位字节
0x89 | 0x33 | 0x41

说明:

  • 端子以状态字的状态反馈控制字的值，相当于一个确认过程。.
  • 端子以ASCII码反馈固件版本状态,在输入数据字(字节1和字节2)中,被译成ASCII码:
    - ASCII    码 0x33 代表密码为3
    - ASCII    码 0x41代表密码为 A
    因此此版本为3A.

例 2: 写入用户寄存器

NOTE

Code word

在正常操作除了寄存器31都是被被写保护的.
如果要关闭写保护,你必须在寄存器31中写编码(0x1235).通过写入除了0x1235以外的值来再次启动写入保护.
注意一些在寄存器中的设置在端子下一次开关时会激活状态。

I. 写寄存器31的代码(0x1235)

输出数据
Byte 0:控制字 | Byte 1: DataOUT1, 高位字节 | Byte 2: DataOUT1,低位字节
0xDF (1101 1111bin) | 0x12 | 0x35

说明:

  • Bit 0.7置1: 寄存通讯激活
  • Bit 0.6置1: 写入寄存器
  • Bit 0.5 至 Bit 0.0 的二进制数为011111那么寄存器号31.
  • 输出数据字(Byte 1 and Byte 2)包含了代码0x1235用来关闭写保护.
输入数据(总线端子响应)
Byte 0: 状态字 | Byte 1: DataIN1, 高位字节 | Byte 2: DataIN1, 低位字节
0x9F (1001 1111bin) | 0xXX | 0xXX

说明:

  • 端子返回一个值显示在状态字中，该值的bit0.6与控制字节的bit0.6相反
  • 输入数据(Byte 1 and Byte 2)在写访问后没有作用, 这可能会显示无效值!

II. 读寄存器31 (验证设置码)

输出数据
Byte 0: 控制字 | Byte 1: DataOUT1, 高位字节 | Byte 2: DataOUT1, 低位字节
0x9F (1001 1111bin) | 0xXX | 0xXX

说明:

  • Bit 0.7置1: 寄存通讯激活
  • Bit 0.6置1 : 写入寄存器
  • Bit 0.5 至 Bit 0.0的二进制数为011111那么寄存器号31.
  • 输出数据字(Byte 1 and Byte 2)在读访问时没有作用.
输入数据 (总线端子响应)
Byte 0: 状态字 | Byte 1: DataIN1, 高位字节 | Byte 2: DataIN1, 低位字节
0x9F (1001 1111bin) | 0x12 | 0x35

说明:

  • 端子以状态字的状态反馈控制字的值，相当于一个确认过程。.
  • 端子在输入数据字(Byte 1或Byte 2)中反馈编码寄存器的电流值.

III. 写入寄存器32 (改变特征寄存器的内容)

输出数据
Byte 0:控制字 | Byte 1: DataIN1, 高位字节 | Byte 2: DataIN1, 低位字节
0xE0 (1110 0000bin) | 0x00 | 0x02

说明:

  • Bit 0.7置1: 寄存通讯激活
  • Bit 0.6置1: 写入寄存器
  • Bit 0.5 至 Bit 0.0 的二进制数为100000那么寄存器号为32.
  • 输出数据字(Byte 1 和 Byte 2)包含了特征寄存器新的值.

CAUTION

注意寄存器的说明!

0x0002 只是一个例子!
该特征寄存器会改变端子的特性并且包含多种含义,这取决于端子的类型,在改变它的值之前请检查您端子种类的特征寄存器的说明!
输入数据 (总线端子响应)
Byte 0: 状态字 | Byte 1: DataIN1, 高位字节 | Byte 2: DataIN1,低位字节
0xA0 (1010 0000bin) | 0xXX | 0xXX

说明:

  • 端子返回一个值显示在状态字中,该值的bit0.6与控制字节的bit0.6相反
  • 在写访问后输出数据字(Byte 1 和 Byte 2)没有作用。该值可视为无效值!

IV. 读取寄存器 32 (检验特征寄存器的变化)

输出数据
Byte 0: 控制字 | Byte 1: DataOUT1, 高位字节 | Byte 2: DataOUT1, 低位字节
0xA0 (1010 0000bin) | 0xXX | 0xXX

说明:

  • Bit 0.7置1: 寄存通讯激活
  • Bit 0.6置1：写入寄存器
  • Bit 0.5 至 Bit 0.0的二进制数为100000那么寄存器号32.
  • 在读访问时输出数据字(Byte 1 和 Byte 2)是没有作用的
输入数据 (总线端子相应)
Byte 0: 状态字 | Byte 1: DataIN1, 高位字节 | Byte 2: DataIN1,低位字节
0xA0 (1010 0000bin) | 0x00 | 0x02

说明:

  • 端子以控制字的状态反馈控制字的值，相当于一个确认过程。.
  • 端子在输入数据字(Byte 1或Byte 2)中反馈编码寄存器的电流值。

V. 写入寄存器 31 (编码返回设置)

输出数据
Byte 0: 控制字e | Byte 1: DataOUT1, 高位字节 | Byte 2: DataOUT1, 低位字节
0xDF (1101 1111bin) | 0x00 | 0x00

说明:

  • Bit 0.7置1: 寄存通讯激活
  • Bit 0.6置1 : 写入寄存器
  • Bit 0.5 至 Bit 0.0的二进制数为011111那么寄存器号为31.
  • 输出数据(Byte 1 和 Byte 2)包含0x0000将会在下一次的写入保护时被激活.
输入数据 (总线端子相应)
Byte 0: 状态字 | Byte 1: DataIN1高位字节 | Byte 2: DataIN1, 低位字节
0x9F (1001 1111bin) | 0xXX | 0xXX

说明:

  • 端子返回一个值显示在状态字中,该值的bit0.6与控制字节的bit0.6相反。
  • 在写操作后输出数据字(Byte 1 和 Byte 2)没有作用. 该值是无效的!


Support and Service

BECKHOFF Automation: Appendix

Beckhoff 技术支持&技术服务

Beckhoff 及其合作伙伴活跃于世界各地，提供全方位的技术服务和技术支持，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff'的分公司和代表处

请联系Beckhoff 分公司或者在 Beckhoff 产品上local support and service的代表处!

全世界Beckhoff's分公司和代表处地址你可以在网站上找到:
http://www.beckhoff.com

您还可以在此找到更多关于Beckhoff产品说明书 。

Beckhoff 总部

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff 技术支持
Beckhoff 技术支持提供全面的技术支持, 不仅支持你个人Beckhoff产品的应用而且也支持其他服务：
  • 全球技术支持
  • 复杂自动化系统的设计、编程和调试
  • Beckhoff 系统组件培训方案
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心支持售后服务的所有项目:

  • 上门服务
  • 维修服务
  • 备件服务
  • 热线服务
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


KLxxxx, ELxxxx - Installation spacing

BECKHOFF Fieldbus Components: Mounting and wiring

Installation of terminals with increased thermal power loss

Installation spacing

CAUTION 		Damage or destruction of devices possible!
When installing terminals with increased thermal power loss ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Minimum spacing of components