KL3222, KS3222 -Pt100双通道精确输入端子模块（RTD）

BECKHOFF 现场总线组件

说明书：

KL3222 和 KS3222

Pt100双通道精确输入端子模块（RTD）

版本: 1.1.0
日期 2011-08-22


说明书说明

本说明书仅供那些在控制与自动化工程方面受过适当培训且熟悉各种适用国家标准的专业人士使用。
在安装和调试这些组件时，操作人员必须严格遵循下列说明和解释。

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

免责声明

尽管本文档经过精心编制， 但由于其中所描述的产品仍处于不断更新换代中，
我们可能不会在每次更新后都检查文档中所描述的产品性能数据、标准或其它特性总是与实际产品相一致。
本文档中难免会出现一些技术或者编辑错误，我们保留随时对文档信息作出修改之权力，恕不另行通知。
对于已经变更的产品，如果本文档中的数据、图表以及文字描述没有修改，我们将不再特别加以声明。

商标

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® 已为Beckhoff 自动化有限公司的注册商标
本出版物中的相关名称若被第三方出于个人目的，用作商标，将侵犯其拥有者的权利。

申请中的专利

已包含EtherCAT技术但不局限于如下专利申请和专利:
EP1590927, EP1789857, DE102004044764, DE102007017835
在许多其他国家有关EP0851348, US6167425的相关申请和注册。

TwinCAT 技术受下列专利申请书和专利权（包括但不限于）的保护：
在许多其他国家有关EP0851348, US6167425的相关申请和注册。

版权声明

© 德国倍福自动化有限公司.
未经许可，任何人不得复制、分发和使用本手册以及内容传播。
若发生违反行为 , 须履行损失赔偿义务。 德国倍福自动化有限公司保留所有发明、实用新型和外观设计专利权。


安全说明

安全规程

请仔细阅读下列安全说明 及相关描述！
有关产品特定安全规程，请见后面页或有关安装，接线及调试等章节。

免责声明

所有组件在供货前均针对其具体应用进行了特定的软、硬件配置。 任何人不得对软、硬件配置进行文本档中规定之外的修改，德国倍福自动化有限公司对因此而造成的一切后果不承担任何责任。

人员资质

本手册仅供那些受过适当培训，熟悉各种适用国家标准的“控制、自动化和驱动工程”领域专业人员使用。

安全标志说明

本操作手册中用到了下列安全标志及相应的安全说明。 请仔细阅读并严格遵守。

危险 		有严重人身伤害危险!
不遵守本标志相关的安全说明将直接危及个人生命和健康安全!

警告 		受伤的危险
不遵守本标志相关的安全说明将危及个人生命和健康安全!

小心 		危害个人
不遵守本标志相关的安全说明可能明显危害个人安全!

注意
不遵守本标志相关安全说明可能明显危害环境和设备安全.

说明 		说明或提示
该标志表示这些信息能够帮助您更好地理解安全说明。


KL3222, KS3222 - 说明书版本说明

BECKHOFF KL3222, KS3222: 前言

说明书版本说明

版本 | 意见
1.1.0
  • 增加了寄存器描述
  • 增加了使用KS2000软件设置参数
1.0.0 | 第一次发行

公司和硬件版本

文档资料 版本 | 固件 | 硬件
1.1.0 | 1B | 00
1.0.0 | 1B | 00

端子模块的厂商和硬件版本可以（在交货状态）从序列号中获得，印在端子模块的侧面。

序列号说明

序列号结构 KK YY FF HH

WW - 生产周（日历周）
YY - 年
FF - 固件版本
HH - 硬件版本

序列号举例 No. 20 09 1A 00:

20 - 第 20周生产
09 - 2009 年生产
1A - 固件版本 1A
00 - 硬件版本 00


KL3222, KS3222 - 简介

BECKHOFF KL3222, KS3222: 产品概览

简介

EL3222 模拟量输入端子模块可以直接连接电阻型传感器。 总线端子模块电路可采用 2 线制、 3 线制或4线制连接方式来运作传感器。

整个温度范围的线性化由一个微处理器来实现。 温度范围可以任意选定。 总线端子模块的标准设置为： 四线制连接下在PT100 传感器的温度范围内分辨率 为0.01°C 。

运行LED 指示总线耦合器的数据交换状态。 故障LED 指示传感器故障（例如断线）。


KL3222, KS3222 - 技术参数

BECKHOFF KL3222, KS3222: 产品概览

技术参数

技术参数 |  | KL3222, KS3222
输入 |  | 2
传感器类型 |  | PT1000, Ni1000
连接方式 |  | 2-, 3-, 4-线 (默认: 四线制)
测量范围 | PT 传感器 | -200…+850°C
 | Ni 传感器 | -60…+250°C
 | 高精度 | -200..0.320°C
转换时间 |  | 大约 50 ms
测量电流 |  | 典型值 0.5 mA
分辨率 |  | 00.1°C 每数位
测量精度 |  | 在40°C环境温度下，4线制连接的PT100传感器和50 Hz滤波器的精度为0.1°
输入过程映像的位宽度 |  | 2×16位，2 x 8位控制字（可选）
输出过程映像的位宽度 |  | 2 x 8位状态字（可选）
电子器件供电 |  | 通过 K-Bus
K-Bus电能消耗 |  | 典型值 60 mA
电气隔离 |  | 500V（K-bus /信号电压）
端点 |  | 弹簧接线技术
可插拔式接线 |  | 适用于所有 KSxxxx 总线端子模块
重量 |  | 大约 70 g
尺寸 (W x H x D) |  | 大约 15mmx100mmx70mm（对齐宽度12mm）
安装 |  | 35 mm 导轨安装 符合 EN 50022
允许的运行环境温度范围 |  | 0 °C ... + 55 °C
允许的存储环境温度范围 |  | -25 °C ... + 85 °C
允许相对湿度 |  | 95%，无冷凝
抗振/抗冲击性能 |  | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC 防爆性 / ESD |  | 符合 EN 61000-6-2 / EN 61000-6-4
防护等级 |  | IP20
安装位置 |  | 可变
认证 |  | CE


ELxxxx, KLxxxx - Installation on mounting rails

BECKHOFF 现场总线组件: 安装和接线

安装到导轨上

警告 		小心电击危险和损坏设备！
在安装，拆卸和连线之前确保总线终端处于安全的断开状态!

安装

总线耦合和总线终端都可以毫不费力地安装在35mm导轨上。这个导轨可以在市场上买到 (DIN 轨道依据 EN 50022标准)：

  1. 首先将现场总线耦合器安装在导轨上。
  2. 总线端子模块安装在总线耦合器的右侧。 通过卡槽将元件连接在一起且将端子按在导轨上，直到将锁扣扣在轨道上。
    如果先将终端模块夹在安装导轨上然后再连接到一起，且不使用卡槽连接，这样连接将不会运转！ 正确的连接是模块之间没有可见的缝隙。

说明 		安装导轨的固定
端子模块和耦合器的卡扣机构延伸到安装导轨的侧面。
在总线终端模块安装完之后，总线端子模块的卡扣机构不能与安装轨道上的固定螺丝相碰。
为了将端子模块和耦合器安装在7.5毫米高度的安装导轨上，你应该使用平面安装连接（例如，埋头螺钉或铆钉）。

拆卸

每个端子都用锁扣固定在安装轨道上，在拆卸的时候必须解开锁扣：
  1. 将端子模块上的橘黄色卡扣从安装轨道上拉出大约1cm。 这样做端子模块底部的导轨锁就松开了，然后你可以毫不费力的把端子模块模块拔出来。
  2. 同时用拇指和食指抓住总线端子模块上、下槽表面并拉出总线端子模块。

总线端子模块组合

总线耦合器和总线端子模块组合在一起后就自动完成了电气连接。

  • K-Bus/E-Bus的6个弹簧连接点负责数据传输和和总线端子模块的供电。
  • 电源触点负责给现场传感器供电，并在总线端子模块组中形成供电链。 总线耦合器电源触点供电最高为 24 V，如要更高的电压需要另外的电源供电模块。

说明 		电源触点
在设计总线端子模块时，必须计算总线端子的引脚分配，因为有些型号不会或不完全通过电源连接。（例如：模拟总线端子模块或4通道的数字总线端子模块）。
供电端子模块 (KL91xx, KL92xx or EL91xx, EL92xx) 中断电源并重新开始一个电源供应链路。

PE 电源触点

有PE标示的电源触片是用来接地保护的。 出于安全因素这个触片要先连接在一起，对地的最大短路电流是125 A。

注意 		可能损坏设备
考虑到电磁兼容性，PE触点与安装轨道之间是电容耦合的。 这可能会在绝缘测试时导致错误或损坏端子（例如：客户在绝缘测试时把230V放电到PE短路）。

如果要进行绝缘测试， 断开总线耦合器或供电端子模块的PE！ 为了完全断开供电触点, 把供电端子模块从导轨上拉出至少10mm。

警告 		小心触电
PE连接不能用来接其他的电位！


KLxxxx, KSxxxx, ELxxxx, ESxxxx - 连接系统

BECKHOFF 现场总线组件: 安装和接线

连接系统

警告 		小心电击危险和损坏设备！
在安装，拆卸和连线之前确保总线终端处于安全的断开状态!

概述

总线端子系统为不同的设备提供不同的最优连接：

  • KLxxx和ELxxxx系列接线端子模块连接器和电子元件封装在同一个外壳中。
  • KSxxxx 和 ESxxxx系列接线端子模块采用可插拔的连接器使更换时不需要接线。
  • 高密度端子模块系列 (HD Terminals)连接器和电子元件封装在同一个外壳中，封装密度更高。

标准接线

KLxxx和Elxxx端子系列经过多年测试。
集成无螺丝弹簧压紧技术，提供了快速简单的装配。

可插拔式接线

KSxxx和ESxxx端子系列的特点是可插拔式连接。
KS系列的安装和接线方式与KLxxxx 和 ELxxxx 系列类似。
KS/ES端子系列可以使插拔式连接器从外壳上完整移走便于维护。
拉起 解锁条可以把下部的模块从导轨上移除.
插入新的模块装上带线的连接器
这样一来，可大大减少安装时间，避免电缆线误接。

端子模块的尺寸基本相同，只有很小的变化。 新的连接器增加了约3mm 端子模块的最大高度保持不变

扎线环有助于扎紧电线，避免电线在拔下连接器时缠绕。

线径位于 0.08 mm2 和 2.5 mm2 都可以用弹簧连接器.

KSxxxx 和 ESxxxx 系列模块的型号命名方式 KLxxxx 和 ELxxxx 系列相同.

高密度端子模块 (HD Terminals)

KLx8xx 系列总线端子模块有16个连接点，是特别紧凑的设计，是传统12 mm 总线端子模块连接点数量的2倍。 硬导线和压了线套的导线可以直接插入弹簧接线孔而不需要工具。

说明 		高密度模块接线
高密度端子模块KLx8xx 和 ELx8xx 系列没有对应的可插拔连接器系列。

说明 		超声 “焊接" 导线
可以使用超声波“粘合”（超声波焊接）导体来连接标准或高密度端子模块。
在这种情况下, 请注意 下面线径说明表!

接线

连接 ELxxxx / KLxxxx 标准接线端子和 ESxxxx / KSxxxx可插拔式连接器

最多可以连接8根线到总线端子模块，把线扎在总线端子模块连接器上。 端子连接采用弹簧力连接技术。 根据下面的步骤来接线：

  1. 用螺丝刀插入位于接口上方的方形孔来打开弹簧接线端子。
  2. 现在电线可以毫不费力的直接插入圆形孔。
  3. 当拔掉螺丝刀后弹簧端口会自动合上，将接线永久牢固的接上。

端子模块外壳 | ELxxxx, KLxxxx | ESxxxx, KSxxxx
线径 | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
剥线长度 | 8 ... 9 mm | 9 ... 10 mm

高密度端子模块 ELx8xx, KLx8xx (HD)

单芯硬线连接HD端子模块的接点只需要剥线之后直接插入即可，不需要额外的工具。 通常，借助螺丝刀松开触点，然后再松开电缆。 下表为对线径的要求。

端子模块外壳 | ELx8xx, KLx8xx (HD)
线径 (导体两端有线鼻子） | 0.14... 0.75 mm2
线径 (单芯硬线) | 0.08 ... 1.5 mm2
线径 (软线) | 0.25 ... 1.5 mm2
线径 (超声 “焊接" 导线) | 只能 1.5 mm2 (见 说明!)
剥线长度 | 8 ... 9 mm

屏蔽

说明 		屏蔽
模拟传感器和执行器总是用屏蔽双绞线相连。


KL3222, KS3222 - 连接

BECKHOFF KL3222, KS3222: 安装和接线

接线

警告 		小心电击危险和损坏设备！
在安装，拆卸和连线之前确保总线终端处于安全的断开状态!

端子模块点 | No. | 连接到
+R1 | 1 | Channel 1: +R
+RL1 | 2 | Channel 1: +RL
-R1 | 3 | Channel 1: -R
-RL1 | 4 | Channel 1: -RL
+R1 | 5 | Channel 2: +R
+RL1 | 6 | Channel 2: +RL
-R1 | 7 | Channel 2: -R
-RL1 | 8 | Channel 2: -RL


KS2000 配置软件

KS2000设置软件用来设置总线耦合器、总线控制器和连在它们后面的总线端子。 可以通过专用的KS2000配置电缆来配置总线耦合器、总线控制器和端子，也可以通过总线方式进行配置。

组态

可以用KS2000软件离线配置总线站。 在现场总线模块配置之前，设定好所有总线站的耦合器和端子的参数。 然后通过下载的方式把设置参数下载到总线站中。 为了便于说明，我们采用最简化的端子站组合，列出部分可以修改的参数。 upload之后,就会列出所有的现场总线站，可以进行参数修改。

参数化

KS2000提供了简单的设置现场总线站的参数方法： 可以设置包括所有总线耦合器，所有智能总线端子模块和现场总线端子盒，并且这些设置可以轻松地进行修改。 或者，你可以直接修改总线耦合器和智能端子模块的寄存器。 需要参考每个寄存器的说明。

配置

KS2000软件易于配置机器部件和现场总线站： 配置的设置可以通过下载方式传输到现场总线模块。 login 到端子站之后,就可以 在线修改总线耦合器，总线端子模块和现场总线盒。 同样也可以通过修改寄存器参数的高级设置页面进行参数修改。

KS2000也可以读取总线耦合器和 现场总线盒 的过程数据。

  • 总线耦合器的输入和输出数据可以被监视。
  • 过程数据可以写到输出过程映像，用于调试输出模块。

在 online 模式 总线站可以与现场总线的通信同时进行。 但现场总线协议一般有较高的优先级。


KL3222, KS3222 - 用KS2000设定参数

BECKHOFF KL3222, KS3222: KS2000配置软件

用KS2000设定参数

通过配置电缆将你的现场总线配置接口和PC串口连接，并启动KS2000配置软件。

点击Login按钮。 配置软件会将加载连接的现场总线站信息。
本例中:
  • BK9000: 以太网耦合器
  • a KL1xx2: 数字量输入端子模块
  • a KL3222
  • a KL9010: 总线末端端子模块

KS2000 左边的窗口在树形结构中显示了现场总线站的端子模块。
KS2000 右边的窗口包含了现场总线站端子模块的图形显示。

在左边窗口的树型结构中，点击你想要改变参数的端子模块旁边的加号(示例中的item 2)。

对于KL3222，会显示以下分支：Register，Setting和ProcData

  • Register可以直接访问KL3222寄存器。
  • 在Settings下有一个对话框可以修改KL3222的参数。
  • ProcData 显示了 KL3222 的 过程数据。


KL3222, KS3222 - KS2000 设置

BECKHOFF KL3222, KS3222: KS2000 配置软件

设置

在setting下可以找到设置KL3222/KS3222参数的对话框。

运行模式

这里你能

  • 激活用户比例（R32.0）,默认: 停用
  • 停用看门狗定时器（R32.2）,默认： 激活
  • 激活西门子 S5 格式（R32.4）,默认： 停用
  • 设置分辨率（R32.5），默认： 1/100°C（高精度）
滤波器设置

这里你能设置终端（R37）的输入滤波。

  • 50 Hz (默认)
  • 60 Hz
  • 100 Hz
  • 500 Hz
  • 1000 Hz
  • 2000 Hz
  • 3750 Hz
  • 7500 Hz
  • 15000 Hz
  • 30000 Hz
  • 5 Hz
  • 10 Hz
电阻温度计（传感器类型）

这里你能设置KL3222与已连接传感器（R32.15-R32.08）的类型:

  • PT100
  • NI100
  • PT1000
  • PT500
  • PT200
  • NI1000
  • NI120
  • RS1000
  • RTD_RES16
  • RTD_RES64
  • RTD_KTSIEMENS2K
  • KTY81110
  • KTY81121
  • KTY81122
  • KTY81151
  • KTY81221
  • KTY81210
  • KTY81221
  • KTY81222
  • KTY81251
  • KTY81252
  • KTY83110
  • KTY83121
  • KTY83122
  • KTY83151
  • KTY83152
  • KTY84130
  • KTY84151
  • KTSIEMENS1K
  • KTSIEMENS2K_5
  • KTSIEMENS2K_7
  • KTSIEMENS1K_5
  • KTSIEMENS1K_7


KL3222, KS3222 -过程映像

BECKHOFF KL3222, KS3222: 通过程序设置

过程映像

完整的过程映像

在过程映像中KL3222/KS3222被表示成最多6个字节的输入数据和2字节的输出数据。 配置如下：

字节偏移(无字对齐) | 字节偏移 (有字对齐*) | 格式 | 输入数据 | 输出数据
0 | 0 | byte | SB1 | CB1
1 | 2 | word | DataIN1 | -
3 | 4 | byte | SB2 | CB2
4 | 6 | word | DataIN2 | -
简略的过程映像

在简略的过程映像中KL3222被表示成最多16个字节的输入数据并且没有输出数据。 配置如下：

字节偏移(无字对齐) | 字节偏移 (有字对齐*) | 格式 | 输入数据 | 输出数据
0 | 0 | word | DataIN1 | -
1 | 1 | word | DataIN2 | -

*）字对齐： 总线耦合器在偶字节地址添加值。

Key

SB1, SB2: 通道1和2的状态字
CB1, CB2: 通道1和2的控制字
DataIN1, DataIN2: 通道1和2的输入数据字
DataOUT: 不存在


KL3222,KS3222 - 控制字 -和状态字

BECKHOFF KL3222, KS3222: 通过程序设置

控制字和状态字

Channel 1

过程数据模式

控制字 1（在过程数据模式)

控制字1（CB1）位于输出映像,并且从控制器传输到端子模块。

位 | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
名称 | RegAccess | - | Cali | Gain | Offset | Clock | up | down
Key
位 | 名称 | 描述
CB1.7 | RegAccess | 0bin | 寄存器通信关闭（过程数据模式）
CB1.6 | - | 0bin | 保留
CB1.5 | Cali | 1bin | 校准被激活的终端 | 在过程数据模式中通过控制字完成增益和偏移的校准。 为了校准，保护码必须被写入到上述R31寄存器。 参数将会永久保存，直到保护码被重新设置。
CB1.4 | Gain | 1bin | 校准： 增益值
CB1.3 | Offset | 1bin | 校准： 偏移量
CB1.2 | Clock | 0bin | 快速时钟
 |  | 1bin | 慢速时钟
CB1.1 | up | 1bin | 上
CB1.0 | down | 1bin | 下

状态字节 1（过程数据模式)

状态字节1（SB1）位于 输入映像，并且从端子模块传送到控制器。

位 | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
名称 | RegAccess | Error | - | - | - | - | Overrange | Underrange
Key
位 | 名称 | 描述
SB1.7 | RegAccess | 0bin | 过程数据模式确认
SB1.6 | Error | 0bin | 没有故障
 |  | 1bin | 一个故障出现
SB1.5 ... SB1.2 | - | 0bin | 保留
SB1.1 | Overrange | 1bin | 超出允许的测量范围
SB1.0 | Underrange | 1bin | 低于测量范围的限制

寄存器通信

寄存器通信（控制字 1的使用)

控制字节 1 (CB1) 位于 输出映像，并且从控制器传到端子模块。

位 | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
名称 | RegAccess | R/W | Reg. No.
Key
位 | 名称 | 描述
CB1.7 | RegAccess | 1bin | 启动寄存器通信
CB1.6 | R/W | 0bin | 读访问
 |  | 1bin | 写访问
CB1.5 to CB1.0 | Reg. No. | 寄存号： 输入 寄存器 号如果你 想要读取输入数据字DataIn或者 想要写出输出数据字DataOut。

寄存器通信（状态字 1的说明)

状态字节1（SB1）位于 输入映像，并且从端子模块传送到控制器。

位 | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
名称 | RegAccess | R/W | Reg. No.
Key
位 | 名称 | 描述
SB1.7 | RegAccess | 1bin | 寄存器通信确认
SB1.6 | R | 0bin | 读访问
SB1.5 bis SB1.0 | Reg. No. | 读取或写入的寄存器号。

Channel 2

通道2的控制字和状态字（ CB2 和 SB2）的结构和通道1的控制字和状态字一样。


KL3222, KS3222 – 寄存器概述

BECKHOFF KL3222, KS3222: 通过程序设置

寄存器概述

寄存器是用于总线端子模块的参数化，并且每个通道一次 它们可以通过register communication来读取或写入。

寄存器号 | 说明 | 默认值 |  | R/W | 内存
R0 | A / D转换，初始值 | 可变 | 可变 | R | RAM
R1 | A / D转换，线的初始值 | 可变 | 可变 | R | RAM
R2 | 保留 | 0x0000 | 0dec | R | RAM
... | ... | ... | ... | ... | -
R5 | 保留 | 0x0000 | 0dec | R | RAM
R6 | 诊断寄存器 | 0x0000 | 0dec | R | RAM
R7 | 命令寄存器（未使用） | 0x0000 | 0dec | R/W | RAM
R8 | 端子模块类型 | 0x0C96 | 3222dec | R | ROM
R9 | 固件版本 | 例如 0x3141 | 例如 12609dec | R | ROM
R10 | 多重移位寄存器 | 0x0218 / 0x0130 | 536dec / 304dec | R | ROM
R11 | 信号通道 | 0x0218 | 536dec | R | ROM
R12 | 通道的最小数据长度 | 0x0098 | 152dec | R | ROM
R13 | 数据结构 | 0x0000 | 0dec | R | ROM
R14 | 保留 | - | - | - | -
R15 | 队列寄存器 | 可变 | 可变 | R/W | RAM
R16 | 硬件版本号码 | 例如 0x0000 | 例如 0dec | R/W | SEEPROM
R17 | 制造商补偿： 偏移量 | 特定的 | 特定的 | R/W | SEEPROM
R18 | 制造商补偿： 增益值 | 特定的 | 特定的 | R/W | SEEPROM
R19 | 制造商缩放： 偏移量 | 0x0000 | 0dez | R/W | SEEPROM
R20 | 制造商缩放： 增益值 | 0x0100 | 256dez | R/W | SEEPROM
R21 | 保留 | 0x0000 | 0dec | R/W | SEEPROM
... | - | ... | ... | ... | ...
R30 | 保留 | 0x0000 | 0dec | R/W | SEEPROM
R31 | 密码寄存器 | 0x0000 | 0dec | R/W | RAM
R32 | 特征寄存器 | 0x0000 | 0dec | R/W | SEEPROM
R33 | 用户缩放： 偏移量 | 0x0000 | 0dec | R/W | SEEPROM
R34 | 用户缩放： 增益值 | 0x0100 | 256dec | R/W | SEEPROM
R35 | ... | ... | ... | - | -
R36 | ... | ... | ... | - | -
R37 | A/D转换器的滤波器常数 | 0x0138 | 312dec | R/W | SEEPROM
R38 | 保留 | 0x0000 | 0dec | R/W | SEEPROM
... | 保留 | ... | ... | ... | ...
R63 | 保留 | 0x0000 | 0dec | R/W | SEEPROM


KL3222, KS3222 - 寄存器描述

BECKHOFF KL3222, KS3222: 通过程序设置

寄存器描述

寄存器可用于总线端子模块的参数化，并且每个通道立即生效。 它们可以通过register communication来读取或写入。

R0: A / D转换，初始值

寄存器R0包含模拟/数字转换器的初始值。 这是缩放前未经改变过的模拟量值。

R1: A / D转换，线路初始值

寄存器R1包含线电阻的初始值，它在+R1到-RL1或者+R2到-RL2之间。

R6: 诊断寄存器

通道n的状态字SBn显示在R6的寄存器的低字节

R7: 指令寄存器

KL3222的指令寄存器当前没有被使用

R8: 端子模块说明

端子模块的标识符包含在寄存器R8中： KL3222: 0x0C9C (3228dec)

R9: 固件版本

寄存器R9包含端子模块固件版本的ASCII编码，例如 0x3141 = '1A'. 这里的'0x31' 对应ASCII字符'1',而 '0x41' 代表 ASCII 字符 'A'.
这个值不能被改变

R12: 通道的最小数据长度

高位字节的0到6位以位的形式表示输出数据的最小数量： 000.0000bin = 0dec so 0 bytes.

低位字节的0到6位以位的形式表示输入数据的最小数量： 001.1000bin = 24dec so 3 bytes.
事实上第7位被设置则表示控制字和状态字未被端子模块的功能强制并且不以简略模式传送。

R16: 硬件版本号码

寄存器R16包含端子模块的硬件版本号码

R17: 制造商补偿 - 偏移量

该寄存器包含制造商补偿的偏移量。

R18: 制造商补偿 -增益量

该寄存器包含制造商补偿的增益量。

R19: 制造商缩放 - 偏移量

该寄存器包含制造商缩放的偏移量。 它可以被特征寄存器的里R32.1激活

R20: 制造商缩放 - 增益量：

该寄存器包含制造商缩放的增益量。 它可以被特征寄存器的里R32.1激活

R21: 两线连接的偏移寄存器

+R1—RL1或者+R2-RL2短路时寄存器1的值。

R23: 参考校准值： 偏移量

寄存器包含校准的参考值，它在制造商补偿期间被确定

R24: 参考校准值： 增益值

寄存器包含校准的参考值，它在制造商补偿期间被确定

R31: 密码寄存器

  • 如果你写入用户寄存器的时候事先不将用户保护码(0x1235)写入密码寄存器 ，那么这个段子模块不会接收这个提供的数据。
  • 如果你在向用户寄存器写入值之前在密码寄存器中输入了用户密码(0x1235) ，那么这些值会保存在RAM寄存器中同时也会保存在 EPROM 寄存器中，因此当端子模块重启时信息不会丢失。

当端子模块重启时，密码字会被重置。

R32: 特征寄存器

特征寄存器指定了端子模块的运行模式。

位 | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
名称 | SensorType
位 | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
名称 | ConnectionTech |  | Resolution | - | - | Watchdog | enManScal | enUsrScal
Key
位 | 名称 | 描述 |  | 默认
R32.15 ... R32.08 | SensorType | 0dez | PT100 | 0bin
 |  | 1dez | NI100
 |  | 2dez | PT1000
 |  | 3dez | PT500
 |  | 4dez | PT200
 |  | 5dez | NI1000
 |  | 6dez | NI120
 |  | 7dez | RS1000
 |  | 14dez | RTD_RES16
 |  | 15dez | RTD_RES64
 |  | 16dez | RTD_KTSIEMENS2K
 |  | 17dez | KTY81110
 |  | 18dez | KTY81121
 |  | 19dez | KTY81122
 |  | 20dez | KTY81151
 |  | 21dez | KTY81221
 |  | 22dez | KTY81210
 |  | 23dez | KTY81221
 |  | 24dez | KTY81222
 |  | 25dez | KTY81251
 |  | 26dez | KTY81252
 |  | 27dez | KTY83110
 |  | 28dez | KTY83121
 |  | 29dez | KTY83122
 |  | 30dez | KTY83151
 |  | 31dez | KTY83152
 |  | 32dez | KTY84130
 |  | 33dez | KTY84151
 |  | 34dez | KTSIEMENS1K
 |  | 35dez | KTSIEMENS2K_5
 |  | 36dez | KTSIEMENS2K_7
 |  | 37dez | KTSIEMENS1K_5
 |  | 38dez | KTSIEMENS1K_7
 |  | 其它 | 保留
R32.7...R32.6 | ConnectionTech | 00dez | 两线 | 10bin
 |  | 01dez | 三线
 |  | 10dez | 四线
 |  | 11dez | 未连接
R32.5 | Resolution | 0bin | 分辨率: 1/10°C | 1bin
 |  | 1bin | 分辨率: 1/100°C（高精度）
R32.4 | enS-Format | 0bin | 西门子-格式没有激活 | 0bin
 |  | 1bin | 西门子-格式激活
R32.3 | - | 0bin | 保留 | 0bin
R32.2 | Watchdog | 0bin | 看门狗没有激活 | 1bin
 |  | 1bin | 看门狗激活
R32.1 | enManScal | 0bin | 制造商缩放没有激活 | 0bin
 |  | 1bin | 制造商缩放激活
R32.0 | enUsrScal | 0bin | 用户缩放没有激活 | 0bin
 |  | 1bin | 用户缩放激活

R33: 用户缩放 - 偏移量

寄存器包含用户缩放的偏移量 用户缩放可以在特征寄存器中通过R32.0位来激活

R34: 用户缩放 - 增益量

寄存器包含用户缩放的增益量 用户缩放可以在特征寄存器中通过R32.0位来激活

R37: A / D转换器滤波器常数

Wert in R37 | 截止频率 | 默认
0dez | 50 Hz | 0dez
1dez | 60 Hz
2dez | 100 Hz
3dez | 500 Hz
4dez | 1000 Hz
5dez | 2000 Hz
6dez | 3750 Hz
7dez | 7500 Hz
8dez | 15 kHz
9dez | 30 kHz
10dez | 5 Hz
11dez | 10 Hz


寄存器通讯举例

下例中, 数据以字节编号。没有字对齐。

例子 1 通过读取端子模块的Register 9（模块固件版本）。

输出数据
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX

解释:

  • Bit 0.7 为1表示寄存器通讯。
  • Bit 0.6 为0表示读寄存器.
  • Bit 0.5到Bit 0.0 为寄存器号以00 1001bin表示寄存器编号9
  • 输出数据字 (Byte 1 and Byte 2) 在读过程没有意义。 如果在写寄存器的过程中需要对输出字写值。
输入数据 (总线端子模块的应答)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41

解释:

  • 端子模块把控制字的内容写到状态字，作为命令相应。
  • 端子返回固件版本的ASCII码 0x3341，输入数据(Byte 1 and Byte 2)。 需要转换为ASCII码：
    ASCII 码 0x33 表示 3
    ASCII 码 0x41 表示 A
    因此固件版本是 3A.

例子 2 写用户寄存器

说明 		保护码
正常模式下除了寄存器31，都是写保护的。
为了关闭写保护，写入密码(0x1235) 到寄存器31。 写入其他值写保护又会起作用。
有些设置要在重启（断电上电）之后才会起作用。

I. 写密码 (0x1235) 到 寄存器31

输出数据
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35

解释:

  • bit0.7设置表示： 寄存器通讯激活：
  • bit0.6为0表示： 写入寄存器
  • Bit 0.5到Bit 0.0 显示值为 01 1111bin 则寄存器号为 31.
  • 输出数据字 (Byte 1 and Byte 2) 包含密码 (0x1235) 关闭写保护。
输入数据 (总线端子模块的应答)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX

解释:

  • 状态字中只有 0.6这位与控制字不同。
  • 输入数据字(Byte 1 and Byte 2) 在写过程没有意义。 即使有数据显示也不代表任何含义。

II. 读取寄存器 31 (检验保护码是否写入)

输出数据
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX

解释:

  • Bit 0.7 为1表示寄存器通讯。
  • Bit 0.6 为0表示读寄存器.
  • Bit 0.5 to Bit 0.0 显示值为 01 1111bin 则寄存器号为 31.
  • 输出数据字 (Byte 1 and Byte 2) 在读过程没有意义。
输入数据 (总线端子模块的应答)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35

解释:

  • 端子模块把控制字的内容写到状态字，作为命令相应。
  • 端子模块在数据输入字(Byte 1 and Byte 2)时返回密码寄存器的当前值

III. 写入寄存器32（改变特征寄存器的内容）

输出数据
Byte 0: Control Byte | Byte 1: DataIN1, high byte | Byte 2: DataOUT1, low byte
0x0F (1110 0000bin) | 0x00 | 0x02

解释:

  • Bit 0.7 为1表示寄存器通讯。
  • Bit 0.6 为0表示： 写入寄存器
  • Bit 0.5 to Bit 0.0 显示值为 10 0000bin 则寄存器号为 32.
  • 输出数据字（字节 1字节 2）包含功能寄存器的新值。

    小心     		注意寄存器的描述！
    给定值0x0002仅仅是一个例子！
    特征寄存器的位改变端子模块的属性，并有不同的含义，取决于端子模块类型。 在改变值之前，请仔细检查您端子模块的类型所对应的特征寄存器的关于位的具体含义的描述（寄存器描述一章）
输入数据 (总线端子模块的应答)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x0F (1010 0000bin) | 0xXX | 0xXX

解释:

  • 状态字中只有 0.6这位与控制字不同。
  • 输入数据字(Byte 1 and Byte 2) 在写过程没有意义。 即使有数据显示也不代表任何含义。

IV. 读取寄存器32（确认已改变的特征寄存器）

输出数据
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x0F (1010 0000bin) | 0xXX | 0xXX

解释:

  • Bit 0.7 为1表示寄存器通讯。
  • Bit 0.6 为0表示读寄存器.
  • Bit 0.5 to Bit 0.0 显示值为 10 0000bin 则寄存器号为 32.
  • 输出数据字 (Byte 1 and Byte 2) 在读过程没有意义。
输入数据 (总线端子模块的应答)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x0F (1010 0000bin) | 0x00 | 0x02

解释:

  • 端子模块把控制字的内容写到状态字，作为命令相应。
  • 在输入数据字中端子模块返回特征寄存器的当前值(Byte 1 and Byte 2).

V. 写入寄存器31（设置保护码返回）

输出数据
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00

解释:

  • Bit 0.7 为1表示寄存器通讯。
  • Bit 0.6 为0表示： 写入寄存器
  • Bit 0.5 to Bit 0.0 显示值为 01 1111bin 则寄存器号为 31.
输入数据 (总线端子模块的应答)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX

解释:

  • 状态字中只有 0.6这位与控制字不同。
  • 输入数据字(Byte 1 and Byte 2) 在写过程没有意义。 即使有数据显示也不代表任何含义。


技术支持与售后

Beckhof f 及其合作伙伴遍布世界各地，可为您提供全方位的技术支持与服务，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff 分公司及代表处

有关 Beckhoff 产品的本地技术支持和服务信息，请联系当地的 Beckhoff 分公司和代表处！

有关 Beckhoff 在全球各地分公司和代理商的地址，您可以登录Beckhoff 的官方网站：
http://www.beckhoff.com

此外，您也可以在该网站上查看更多关于 Beckhoff 组件的文档资料。

Beckhoff 总部

德国倍福自动化有限公司

Eiserstr. 5
33415 Verl
德国

电话 ： | +49(0)5246/963-0
传真： | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff 技术支持

Beckhoff为您提供全面的技术支持，除了Beckhoff 具体产品的应用以外，还包括更广泛的服务：

  • 技术支持
  • 复杂自动化系统的设计、编程和调试
  • 各种 Beckhoff 系统组件培训方案
热线： | +49(0)5246/963-157
传真： | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 技术服务

Beckhoff 服务中心提供全方位的售后技术服务:

  • 现场服务
  • 维修服务
  • 零部件服务
  • 热线服务
热线： | +49(0)5246/963-460
传真： | +49(0)5246/963-479
e-mail: | service@beckhoff.com