KL3403, KS3403 - 3-Phase Power Measurement Terminals

倍福 现场总线组件

文档资料

KL3403 / KS3403

3相功率测量端子模块

版本: 1.9.0
日期: 2012-01-11


KL3403 - LED displays

倍福 KL3403: 产品概述

LED 显示

LED | 序号 | 显示
K-Bus 运行 (绿色) | A | K-Bus数据传输
ERR L1 (红色) | B | L1 和 N 之间的电压小于10 V (默认*) | *) 每一个通道的阈值可以通过它的寄存器 R36 改变。
ERR L2 (红色) | C | L2 和 N 之间的电压小于10 V (默认*)
ERR L3 (红色) | D | L3 和 N 之间的电压小于10 V (默认*)

引脚分配可参见 连接 KL3403。


KL3403 - Technical data

倍福 KL3403: 产品概述

技术数据

技术数据 |  |  | KL3403-... KS3403-...
 |  |  | 0000 | 0010 | 0014 | 0020 | 0022 | 0021 | 0025 | 0026
测量值 |  |  | U, I | U, I | U* | U, I | I** | U, I | U, I | U, I
计算值 |  |  | effective power, energy, power factor (cosj)
测量电压 |  |  | max. 500 VAC 3~ |  |  |  | 20 mA** | max. 500 VAC 3~
按照UL规定的测量电压 (参见 UL 规定) |  |  | max. 300 VAC 3~ |  |  |  | 20 mA** | max. 300 VAC 3~
测量电流 (连续运行) | 直流(最大) |  | 1 A | 5 A | 60 mV* | 20 mA | 20 mA | 50 mA | 250 mA | 1 A
 | 通过具有变换比 R 的电流互感器(最大) |  | R x 1 A | R x 5 A | - | R x 20 mA | R x 20 mA | R x 50 mA | R x 250 mA | R x 1 A
电压电路的输入电阻 (典型值) |  |  | 500 kW | 500 kW | 500 kW | 500 kW | 10 W** | 500 kW | 500 kW | 500 kW
电流电路的输入电阻 (典型值) |  |  | 33 mW | 6,8 mW | app. 10 kW* | 10 W | 10 W | 4 W | 100 mW | 33 mW
分辨率 |  |  | 16 bit (内部 21 bit)
频率范围 |  |  | 10 Hz to 500 Hz
 |  |  | 0 Hz to 500 Hz (使用 skipped DC-Filter 和 current transformers，可以提供一个这样的范围)
截止频率 |  |  | 大约 2 kHz
信号波形形状 |  |  | 任意 (考虑到频率范围和截止频率)
测量精度(满量程, 与最大值之间的关系) |  | 电压 | 0.5% | 0.5% | 0.5% | 0.5% | - | 0.5%
 |  | 电流 | 0.5% | 1.0% | - | 0.5% | 0.5% | 0.5%
测量过程 |  |  | 实际有效值 64000 samples / s
测量周期 |  |  | 自由配置 (默认每200 ms 测量一次)
绝缘强度 |  |  | 1500 V (端子模块/K-Bus)
输入过程映像的宽度 |  |  | 72 bits 输入 (3 x 8 bits 状态，3 x 16 bits 数据)
输出过程映像的宽度 |  |  | 72 bits 输出 (3 x 8 bits 控制，3 x 16 bits 数据)
电子器件供电 |  |  | 通过 K-Bus
K-Bus电能消耗 |  |  | 典型值 115 mA
可插拔接线 |  |  | 所有 KSxxxx 系列端子模块
允许的运行环境温度范围 |  |  | 0°C ... + 55°C
允许的存储环境温度范围 |  |  | -25 °C ... + 85°C
允许相对湿度 |  |  | 95%，无冷凝
抗振/抗冲击性能 |  |  | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC 防爆性 / ESD |  |  | 符合 EN 61000-6-2 / EN 61000-6-4
重量 |  |  | 大约 75 g
尺寸 (W x H x D) |  |  | 大约 15mm x 100 mm x 70 mm (对齐宽度12 mm)
装配 |  |  | 35 mm 安装导轨 符合 EN 50022
安装位置 |  |  | 任意
防护类型 |  |  | IP20
认证 |  |  | CE

*) 对于 KL3403-0014：三个电压电路代替了电流电路：60 mV 用于连接外部分流

**) 对于 KL3403-0022：三个电流电路代替电压电路：也可以是 20 mA


ELxxxx, KLxxxx - Installation on mounting rails

倍福 现场总线组件: 安装和接线

在导轨上的安装方法

警告 		小心触电和损坏设备！
在开始安装，拆卸或为总线端口接线之前，使终端系统处于安全断电的状态

安装

总线耦合器和总线终端只需轻轻按压即可安装在35mm轨道(依据EN 50022的DIN轨道)上：

1. 首先将现场总线耦合器连接在安装轨道上。

2. 现在，总线端子安装在现场总线耦合器的右边。通过卡槽将组件与端子连接并按在安装轨道上，直到将锁扣扣在轨道上。

如果先将终端夹在安装轨道上然后再连接到一起，且不使用卡槽连接，这样的连接无法正常工作！模块之间没有可见的缝隙才是正确的连接。

注意 		安装导轨上的固定

在安装总线端子的时候，注意不要让端子碰到固定导轨的螺丝。

拆卸

端子依靠卡锁固定在导轨上，在拆卸端子的时候要释放卡锁:

1. 小心地把橙色的拉杆拉出大约1cm，底部的卡锁就会释放，只需很小的力就可以把端子从导轨分离。

2. 用拇指和食指抓住模块的上部和下部的外壳向外拉，把模块彻底从导轨上拆下来。

总线端子模块的连接

总线耦合器和端子之间的电气连接在安装模块的时候自动完成：

  • 六个传输数据和为端子模块供电的K/E总线弹簧连接片。
  • 为现场总线供电的电源触点在端子模块链的内部就相当于组成了一个电源链。可通过总线耦合器上的端子(最高24伏)电源触点供电或者可通过供电端子提供更高的电压。

注意 		电源触点
在总线端子块的设计过程中，必须考虑独立总线端子的引脚分配，因为某些类型的端子（譬如模拟量总线端子或者数字量4通道的总线端子）不能或者不能完全通过这些电源触点形成回路。

供电端子（KL91xx, KL92xx or EL91xx, EL92xx）中断电源连接，就意味开始了一个新的电源链。

PE 电源触片

有PE标示的电源触片可用作保护接地。出于安全因素这个触片要先连接在一起，并且可接地的最大短路电流是125A。

注意 		设备可能损坏
考虑到电磁兼容性，PE触点与安装轨道之间是电容耦合的。这可能会在安装测试时导致错误的结果或损坏端子（例如：在客户用230V的标准电压进行安装测试时会击穿PE层）。

在安装测试时，不要将PE电源线与总线耦合器或供电端子连接！为了解耦更多的供电触点用来测试，这些供电端子可以从端子组释放并且至少拉出10mm。

警告 		触电危险！
PE连接不能用来接其他的电位！


KL3403 - Application example for DC

倍福 KL3403: 安装和接线

DC应用示例

警告 		小心触电和损坏设备！
在开始安装，拆卸或为总线端口接线之前，使终端系统处于安全断电的状态！

注意 		对于DC直流滤波器的测量开关
关闭 KL3403 的 DC 滤波器 (使用 KS2000 配置软件 或者寄存器通信 (寄存器 R32.4)) 来测量直流电压和电流。

现场总线站的功率测量

这个例子说明了现场总线站的三个电流电路的功率测量。端子模块测量了：

  • 总线耦合器和K-Bus电源的输入功率
  • 电源触点的输入功率
  • AS-i 功率供应模块 (KL9528) 的输入功率

注意 		注意额定电流！
示例中使用了具有扩展电流测量范围(最大 5 A)的特殊端子模块 KL3403-0010。
由于窄小的电流测量范围 (1A)，标准类型的 KL3403 不适用于本应用示例！


KS2000 Configuration Software

BECKHOFF Fieldbus Components: KS2000 Configuration Software

KS2000 配置软件

KS2000配置软件可以对总线耦合器及所连模块、,现场总线盒进行调试以及参数设置.现场总线组件与 PC 之间通过串行电缆或总线连接。

配置
您可在脱机状态下使用组态软件对现场总线站进行设置,意思是, 建立一个与耦合器和端子能分别设置的终端站点.现场总线盒能在调试阶段之前准备完成.接着,在调试阶段此组态依靠下载的方式能被转换至终端站点,出于记录目的,将会为你提供损坏的终端站,模块清单和您所修改的参数项目清单.在上传之后,建立现场总线站并等待您的后续操作.

修改参数

使用 KS2000 软件,可以非常简便地访问现场总线站的参数:特殊高级别的对话可以用于所有的总线耦合器,所有总线耦合器,所有智能总线端子以及现场总线端子盒模块都提供有对话框,以便轻松修改设置.另外,还可通过直接访问所有内部寄存器对现场总线组件进行参数设定.

调试

KS2000软件方便了机器零件和现场总线站的运作:配置设置能够依靠下载被转移到现场总线端子.在登录到终端之后,它可以在网上直接对耦合器,端子模块以及现场总线盒进行定义.在配置阶段,同样高级别的对话以及寄存器的访问是可以达到这个目的的.

KS2000能够访问总线耦合器和现场总线端子盒模块的进程映像.

  • 因此,耦合器的输入输出图像时可以观察出来的.
  • 进程值可以指定在输入图像的输出模块调试.

在联机模式下的情况可以与终端站的实际现场总线模式并行使用.但现场总线协议一般有较高的优先级。


KL3403 - Process image

倍福 KL3403: 从用户程序访问

过程映像

在过程映像中，KL3403有至少9个字节的输入和输出数据。 配置如下：:

字节偏移(无字对齐*) | 字节偏移 (有字对齐*) | 格式 | 输入数据 | 输出数据
0 | 0 | Byte | Status byte 1 (SB1) | Control byte 1 (CB1)
1 | 2 | Word | DataIN1 | DataOUT1
3 | 4 | Byte | Status byte 2 (SB2) | Control byte 2 (CB2
4 | 6 | Word | DataIN2 | DataOUT2
6 | 8 | Byte | Status byte 3 (SB3) | Control byte 3 (CB3)
7 | 10 | Word | DataIN3 | DataOUT3

*) 字对齐：总线耦合器在偶字节地址添加值。

注意 		无紧凑的过程映像
由于在KL3403 的过程数据模式中必须有控制和状态字节才能正常工作，所以KL3403 不能通过紧凑过程变量(无控制和状态字) 进行运作。即使你的总线耦合器设置了紧凑型过程映像，KL3403也会进行完整映像！
输出值
端子模块类型 | 额定值 (rms) | 输出额定值
KL3403-0000 | 1,0 A | 1000dec
KL3403-0010 | 5,0 A | 1000dec
KL3403-0014 | 60 mV | 25000dec
KL3403-0020 | 20 mA | 1000dec
KL3403-0021 | 50 mA | 1000dec
KL3403-0022 | 20 mA | 1000dec
KL3403-0025 | 250 mA | 1000dec
KL3403-0026 | 1,0 A | 1000dec


KL3403 - Register overview

倍福 KL3403: 从用户程序访问

寄存器概述

这些寄存器用于每个通道的功率测量端子模块参数化。它们可以通过 寄存器通信 来读取或写入。

寄存器号 | 备注 |  | 默认值 |  | R/W | 存储
R0 | 电能消耗溢出寄存器 |  | 0x0000 | 0dec | R/W | Flash
R1 | 保留 |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R4 | 保留 |  | - | - | - | -
R5 | 密码改变寄存器 |  | - | - | - | -
R6 | 诊断寄存器 |  | - | - | R | RAM
R7 | 指令寄存器 |  | - | - | - | -
R8 | 端子模块类型 |  | 0x0D4B | 3403dec | R | ROM
R9 | 固件修订等级 |  | 例如 0x3143 | 12611dec | R | ROM
R10 | 多重移位寄存器 |  | 0x0230 / 0x0318 | 560dec / 792dec | R | ROM
R11 | 信号通道 |  | 0x0318 | 792dec | R | ROM
R12 | 最小数据长度 |  | 0x1818 | 6168dec | R | ROM
R13 | 数据结构 |  | 0x0007 | 7dec | R | ROM
R14 | 保留 |  | - | - | - | -
R15 | 对齐寄存器 |  | - | - | R/W | RAM
R16 | 硬件版本 |  | 例如 0x0000 | 例如 0dec | R/W | Flash
R17 | 电压增益补偿 |  | 例如 0x0400 | 例如 1024dec | R/W | Flash
R18 | 电流增益补偿 |  | 例如 0x0400 | 例如 1024dec | R/W | Flash
R19 | 保留 |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R29 | 端子模块类型特别标识 |  | 例如 0x0000 | 例如 0dec |  |
R30 | 保留 |  | - | - | - | -
R31 | 密码字寄存器 |  | 0x0000 | 0dec | R/W | RAM
R32 | 功能寄存器 | KL3403-0000, KL3403-0010, KL3403-0025, KL3403-0026 | 0x0020 | 32dec | R/W | Flash
 |  | KL3403-0014, KL3403-0020, KL3403-0021, KL3403-0022 | 0x0030 | 48dec
R33 | 保留 |  | - | - | - | -
R34 | 保留 |  | - | - | - | -
R35 | 电能测量范围因数 |  | 0x0004 | 4dec | R/W | Flash
R36 | 欠电压阈值 |  | 0x0064 | 100dec | R/W | Flash
R37 | 电流互感器变换比除数 |  | 0x0001 | 1dec | R/W | Flash
R38 | 自动删除最小值和峰值的时间常数 |  | 0x00C8 | 200dec | R/W | Flash
R39 | 测量周期时间 |  | 0x0032 | 50dec | R/W | Flash
R40 | 保留 |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R63 | 保留 |  | - | - | - | -


KL3403 - Measuring error at measuring of direct voltages

倍福 KL3403: 附录

直流电压的测量误差

由于 KL3403 的电压输入有一个小的非线性，测量低直流电压时将会出现略微的测量误差。

在 10 到 20 V 之间通常会出现一个1 to 2 V的台阶状变化。


KL3403 - Application examples - Overview

BECKHOFF KL3403: Application examples

Application examples - Overview

  • Application example for AC
  • Application example for DC
  • Application example with frequency converter
  • Application example for KL3403-0014 (without internal shunts for current measuring)