KL6021-0023 and KL6023 - Serial interface terminal and wireless adaptor for EnOcean radio technology

BECKHOFF Fieldbus Components

说明书

KL6021-0023 and KL6023

连续接口终端与 EnOcean 无线技术 无线适配器

Version: 1.1
Date: 31.08.2011


KL6021-0023, KL6023 - Documentation Issue Status

BECKHOFF KL6021-0023, KL6023: Foreword

文档版本说明

版本 | 特点
1.1
  • 增加了装配描述
  • 增加了基本功能准则
  • 增加了KL6023功能块的介绍
1.0
  • 增加了KL6023模块的描述 (EnOcean无限适配器)
  • 增加有线设备
  • 增加了KS2000 软件配置的描述
  • 扩展了技术数据
0.1 | 初始版本

固件硬件版本

文字材料版本 | KL6021-0023 |  | KL6023
 | 固件 | 硬件 | 固件 | 硬件
1.1 | 5D | 01 | 1A | 01
1.0 | 5A | 00 | 1A | 00
0.1 | 5A | 00 | - | -

固件与硬件的版本号（交货时）可以在终端设备的侧面上找到

连续数字的语法

连续数字的结构: WW YY FF HH

WW - 出厂周数
YY - 出厂年数
FF - 固件版本
HH - 硬件版本

例如no.: 12 06 3A 02:

12 - 出厂周数为 12
06 - y出厂年数为 2006
3A -固件版本3A
02 - 硬件版本 02


KL6021-0023 - Introduction

BECKHOFF KL6021-0023: Product Overview

KL6021-0023 介绍

LEDs

LED | 颜色 | 含义
RUN | 绿 | 此LED灯显示了终端的运行状态：
 |  | 开 | 正常运行
 |  | 关 | 看门狗计时器溢出。如果100ms内没有过程数据被发射到总线耦合器，红灯就会熄灭。
TxD | 绿 | 信号线传输状态
RxD | 绿 | 信号线接收状态

Connections

端点 | 名称 | 信号
1 | TxD+ | 信号线（传输数据）
5 | TxD- | 信号线（传输数据）
2 | RxD+ | 信号线（接收数据）
6 | RxD- | 信号线（接收数据）
3 | GND | KL6023接地 (与端点 7内部连接)
7 | GND | KL6023接地 (与端点 3内部连接)
4 | +5V | 为 KL6023供电 (与端点8内部连接)
8 | +5V | 为KL6023供电 (与端点4内部连接)


KL6021-0023 - Technical Data

BECKHOFF KL6021-0023: Product overview

KL6021-0023 - 技术资料

技术资料 | KL6021-0023接口终端 EnOcean 无线适配器
输入数量 | 1, 用于无线适配器 (EnOcean无线技术)
电缆阻抗 | app. 120 Ω
KL6023 无线适配器的连接电缆 | 双绞线
KL6023 无线适配器的连接电缆的长度 | 最多 300 m
过程图像中的字节宽度 | 11 x 8 位用户数据， 1 x 8 位 控制/地位
电子元件的供电 | K-BUS
K-Bus的一般功耗 | 一般多为 65 mA
重量 | 约. 60 g
体积(宽x 高 x 厚) | 约. 15mm x 100 mm x 70 mm
安装 | 根据EN 50022标准 35MM安装轨道
工作温度 | 0°C ... +55°C
存储时，允许环境温度 | -25°C... +85°C
允许相对湿度 | 95% ,无凝结
耐震强度 | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29标准
电磁兼容性 / ESD | 符合EN 61000-6-2 / EN 61000-6-4
防护等级 | IP 20
安装位置 | 任意
认可标准 | CE标准


KL6023 - Technical Data

BECKHOFF KL6023: Product overview

KL6023 - 技术资料

技术资料 | EnOcean无线技术 无线适配器
连接 | 2 双芯绞合线传输给母线终端KL6021-0023
电源 | 带电气隔离的母线终端 KL6021-0023
KL6021-0023连接电缆长度 | 最长300 m
配置 | 无要求
频带 | 868,35 MHz
传播范围 | 空地：300 m 室内> 30 m
无线电波 | 取决于传感器 - 32位传感器识别号码 - 使用字节数无限制
接收天线 | 整合在外壳内
外壳 | 盒箱：聚苯乙烯 (灰) M16 高强度电缆密封套用于电缆连接 表面：聚碳酸酯 (透明)
重量 | 约. 55 g
体积 (宽x 高 x 厚) | 约. 52mm x 50mm x 35.5mm (不包含PG螺纹连接件)
工作时，允许环境温度 | 0°C... +55°C
存储时，允许环境温度 | -25°C... +85°C
耐震强度 | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
耐静电强度/ESD | 符合 EN 61000-6-2 / EN 61000-6-4
防护等级 | IP 66
安装位置 | 任意
认可机构 | CE


ELxxxx, KLxxxx - Installation on mounting rails

BECKHOFF Fieldbus Components: Mounting and Wiring

安装及配线方法

警告 防止触电！

请在处于安全，电源关闭的情况下进行安装或拆除本总线端子模块

装配

只要用很小的力就可以把总线耦合器和总线控制安装在通用的35mmC形导轨上：

1. 首先把总线耦合器安装在导轨上。

2. 总线端子安装在总线耦合器的右边。 端子与耦合器以及端子与端子之间通过槽扣方式连接, 紧贴着扣槽把端子卡在导轨上，卡上后会发出咔的响声。如果安装在导轨上的端子槽扣没有扣在一起K总线将不会导通！安装正确的话连接处是没有缝隙的。

在安装总线端子的时候，注意不要让端子碰到固定导轨的螺丝。

拆卸

端子依靠卡锁固定在导轨上，在拆卸端子的时候要释放卡锁:

1. 小心地把橙色的拉杆拉出大约1cm，底部的卡锁就会释放，不需要很大的力就可以把端子从导轨分离。

2. 用拇指和食指抓住模块的上部和下部的外壳向外拉，把模块彻底从导轨上拆下来。

总线终端块的连接

总线端子的连接

总线耦合器和端子之间的电气连接在安装模块的时候自动完成：

  • 六个K总线弹簧连接片传输总线端子的数据和电源。
  • 现场电子组件的电源供电通过电源触点完成，插在一起的电源触点形成了一个电源链。总线耦合器提供电源触点。
注意

由于一些总线端子(例如 模拟量总线端子或4-通道数字总线端子) 都没有通过这些电源触点形成回路，必须考虑总线端子的分配。电源供电端子 (KL91xx, KL92xx) 提供电源触点，并代表一个新的电源链的开始

PE连接

标有“PE” 标签的电源触点用于对地保护。出于安全的原因这些点应首先插接在一起，它最多可承担125A的对地短路电流。

警告 需要注意的是，出于电磁兼容性方面的考虑，PE触电与安装导轨之间为电容耦合特性。在绝缘测试期间可能产生错误结果或毁坏端子（如：在设备230V绝缘测试的时候造成对地击穿）。

绝缘测试时，总线控制器和电源端子的PE端必须断开。为了断开更多的反馈点进行测试，这些供电端子必须拉出来10mm。
危险 PE的电源连接不能用于其他电位。

接线

端子最多有8个点可用粗线或细线连接，端子连接采用弹簧连接技术：

1. 把起子插入端子上面的方孔撬开弹簧端子。

2. 电线可以很容易的插入端子上的圆孔内。

3. 拔出起子当压力释放时，端子会自动关闭，并且安全而牢固的卡住连线。

终端外罩 | ELxxxx, KLxxxx | ESxxxx, KSxxxx
线宽 | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
线长 | 8 ... 9 mm | 9 ... 10 mm
注意 模拟传感器和双绞线相连接。


KL6021-0023, KL6023 - Connecting the Wireless Adaptor

BECKHOFF KL6021-0023, KL6023: Mounting and wiring

无线适配器的连接

危险 防止触电

请在处于安全，电源关闭的情况下进行安装或拆除本总线端子模块。

KL6021-0023 |  | KL6023 - 无线适配器
信号 | 终端点 | 信号 | 终端点
RxD+ | 2 | RxD+ | 1
RxD- | 6 | RxD- | 2
GND | 3 or 7 | GND | 3
5 V | 4 or 8 | 5 V | 4


KL6021-0023 - KS2000-Register

BECKHOFF KL6021-0023: KS2000 Configuration Software

寄存器

可以直接通过寄存器与 KL6021-0023联系。寄存器的使用方法参见register overview.


KL6021-0023 - KS2000-Settings

BECKHOFF KL6021-0023: KS2000 Configuration Software

设置器

KL6021-0023 与 KL6023中没有特殊的终端设置。


KS2000 - Process Data

BECKHOFF Fieldbus Components: KS2000 Configuration Software

过程数据

状态字节 (State)，控制字节 (Ctrl) 和过程字节 (Data) 在 ProcData 中以树状图显示。

示波器显示了History box中的数据。

电流值在Value中数字量的形式给出

初始值可以直接通过输入端修改或者通过增益调节器修改

危险 改变初始值会对设备产生直接的影响。
只有确定设定的改变不会影响人生安全以及机器的运行安全时方可对初始值进行修改！

在按下Settings键，你可以设置显示的数字的方式是十六进制的，小数形式的或二进制的。


KL6021-0023 - Process Image

BECKHOFF KL6021-0023: Access from the User Programm

过程IMAGE

KL6021-0023在过程镜像输入数据和输出数据都是12字节的。它们由构成如下：

字节补偿 | 格式 | 输入数据 | 输出数据
0 | Byte | Status Byte (SB) | Control Byte (CB)
1 | Byte | DataIn0 | DataOut0
2 | Byte | DataIn1 | DataOut1
3 | Byte | DataIn2 | DataOut2
4 | Byte | DataIn3 | DataOut3
5 | Byte | DataIn4 | DataOut4
6 | Byte | DataIn5 | DataOut5
7 | Byte | DataIn6 | DataOut6
8 | Byte | DataIn7 | DataOut7
9 | Byte | DataIn8 | DataOut8
10 | Byte | DataIn9 | DataOut9
11 | Byte | DataIn10 | DataOut10


Control and Status Byte

BECKHOFF KL6021-0023: Access from the User Program

控制字与状态字

通讯寄存器

寄存器通讯的控制字节

控制字节位于output image， 并由控制器传输到终端。

位 | CB7 | CB6 | CB5 | CB4 | CB3 | CB2 | CB1 | CB0
名称 | RegAccess | R/W | Reg. no.
关键词
位 | 名称 | 描述
CB.7 | RegAccess | 1bin | 通讯寄存器功能打开
CB.6 | R/W | 0bin | 读取端
 |  | 1bin | 写入端
CB.5 to CB.0 | Reg. no. | 记录数值： 输入欲读写寄存器register 的号码。

通讯寄存器状态字

状态字节位于input image中，并由终端传输到控制器。

位 | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
名称 | RegAccess | R/W | Reg. no.
关键位
位 | 名称 | 描述
SB.7 | RegAccess | 1bin | 寄存器确认
SB.6 | R | 0bin | 读取
SB.5 to SB.0 | Reg. no. | 已读写寄存器的号码

注意 在寄存器通信中，所演示的过程数据被设定为0！

过程数据模式

在过程数据模式中的控制字节

控制字节位于output image中， 并由控制器传输到终端。

位 | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.3 | CB.0
名称 | RegAccess | - | - | - | - | - | - | NextTelegramReq
关键位
位 | 名称 | 描述
CB.7 | RegAccess | 0bin | 通讯寄存器关闭（过程数据模式）
CB.6 to CB.2 | - | 0bin | 保留
CB.0 | NextTelegramReq | 0/1bin | 通过反接这一位， 在KL6021-0023输入存储器中的下一个EnOcean电报被复制到过称数据中 。

在过程数据模式中的状态字节

状态字节位于输入图像中， 并由终端传输到控制器。

位 | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
名称 | RegAccess | Error | - | - | BufferFull | NewTelegram | SameTelegram | NextTelegramAck
关键位
位 | 名称 | 描述
SB.7 | RegAccess | 0bin | 过称数据模式的确认
SB.6 | Error | 1bin | 目前被显示在KL6021-0023中的过程数据模式的EnOcean 报 文有一个错误的校验值
SB.5 | - | 0bin | 保留
SB.4 | - | 0bin | 保留
SB.3 | BufferFull | 1bin | KL6021-0023的存储接收器存储已满
SB.2 | NewTelegram | 1bin | 至少有一个新的EnOcean电报在KL6021-0023的接受存储器中
SB.1 | SameTelegram
 |  | 1bin | 因为报文包含超过4个字节的数据。当前显示的报文与之前显示的报文都属于同一个EnOcean电报
SB.0 | NextTelegramAck | 0/1bin | EnOcean电报已被复制到过程数据中的确认。当电报已被复制到过程数据时，该位采用控制位CB.0 的值


KL6021-0023 - Register Overview

BECKHOFF KL6021-0023: Access from the User Program

寄存器总览

这些寄存器用来设定终端KL6021的参数 。它们通过通信寄存器register communication读写。

寄存号 | 意见 | 系统默认值 |  | R/W | 内存
R0 | 保留 | - | - | - | -
... | ... | ... | ... | ... | ...
R5 | 保留 | - | - | - | -
R6 | 诊断寄存器 | 0x0000 | 0dec | R | RAM
R7 | 命令寄存器 | 0x0000 | 0dec | R/W | RAM
R8 | 终端描述 | 0x1785 | 6021dec | R | ROM
R9 | 固件修正等级 | e.g. 0x3141 | e.g. 13633dec | R | ROM
R10 | 多元转换寄存器 | 0x0230 | 560dec | R | ROM
R11 | 信号通道 | 0x0160 | 352dec | R | ROM
R12 | 最小数据长度 | 0x6060 | 24672dec | R | ROM
R13 | 数据结构 | 0x0002 | 2dec | R | ROM
R14 | 保留 | - | - | - | -
R15 | 校准寄存器 | typically 0x7F80 | typically 32640dec | R/W | RAM
R16 | 硬件版本号 | e.g. 0x0000 | e.g. 0dec | R/W | SEEPROM
R17 | 保留 | - | - | - | -
... | ... | ... | ... | ... | ...
R28 | 保留 | - | - | - | -
R29 | 终端类型—特殊鉴别 | 0x0017 | 23dec | R | ROM
R30 | 保留 | - | - | - | -
R31 | 码字寄存器 | 0x0000 | 0dec | R/W | RAM
R32 | 特征寄存器 | 0x0000 | 0dec | R/W | SEEPROM
R33 | 保留 | - | - | - | -
R34 | 保留 | - | - | - | -
R35 | 被寄送给总线耦合器的数据字节数量 | 0x000B | 11dec | R | ROM
R36 | 保留 | - | - | - | -
... | ... | ... | ... | ... | ...
R63 | 保留 | - | - | - | -