KL6811 - DALI/DSI Master Terminal

BECKHOFF Fieldbus Components

Documentation for

KL6811

DALI/DSI Master Terminal with integrated Power Supply

Version 1.3.0
Date: 2010-04-30


KL6811 - Documentation issue status

BECKHOFF KL6811: Foreword

Documentation issue status

Version | Comment
1.3.0
  • 更新KS2000屏幕截图
  • 技术数据升级
1.2.2
  • 更新总线端子导轨安装的信息
  • 更新基本函数
1.2.1
  • LEDs升级说明
  • 更新产品概述
1.2
  • 增加通过KS2000设置KL6811及DALI设备的参数的内容
  • 增加状态字节的说明
  • 技术数据升级
  • 修订寄存器说明
1.1
  • 增加通过KS2000设置KL6811及DALI设备的参数的功能
  • 增加DALI指令的说明
  • 增加寄存器通信的例子
1.0
  • 对LED的说明及增加引脚分配信息
  • 补充了文献及相关的基本信息
  • 提供英语版本
0.2 | 技术升级 (只提供德语版本)
0.1 | 首次发行(只提供德语版本)

Firmware and hardware versions

Documentation Version | KL6811
 | Firmware | Hardware
1.3.0 | 2F | 07
1.2.2 | 1J | 04
1.2.1 | 1J | 04
1.2 | 1J | 03
1.1 | 1G | 03
1.0 |  | 01
0.2 |  | 01
0.1 |  | 01

软件及硬件版本（发行时间）可以在总线端子右侧的序列号上找到 。

Syntax of the serial number

Structure of the serial number: WW YY FF HH

WW - 生产周 (日历周)
YY - 生产年
FF - 软件版本
HH - 硬件版本

Example with ser. no.: 35 04 1B 01:

35 - 第35周生产
04 - 2004年生产
1B - 软件版本为 1B
01 - 硬件版本为 01


KL6811 - Introduction

BECKHOFF KL6811: Product overview

简介

KL6811 最多可以连接64个DALI设备（DALI从站）.在PC上使用KS2000软件可以对其进行简单配置.通过RS232接口或者现场总线，PC直接对总线耦合器进行配置 . 集成的供电单元形成了一个24V直流输出电压的电气隔离.操作DALI从站不需要其他的元件. KL6811 可以独立的进行操作.


KL6811 - Technical data

BECKHOFF KL6811: Product Overview

技术数据

技术数据 | KL6811
传输通道 | 1
DALI 从站数 / DALI 组数 | 最多64 / 最多16
电气隔离(K-Bus / DALI bus) | 1500 Vrms
K-Bus I/O位宽 | 2 x 8 位用户数据, 1 x 8 bit 位控制/状态字
输入过程映象位宽 | 1 数据字, 1 状态字节
输出过程映象位宽 | 1 数据字, 1 状态字节
配置 | 使用KS2000 configuration 软件通过 - 总线耦合器和配置电缆 - 现场总线
模块供电 | 通过K-Bus总线
K-Bus电流消耗 | 55 mA
短路保护 | 有, 自启动
输入电压 | 24 VDC (-15%/+ 20%)
隔离电压 | DALI bus / K-Bus: 1500 VAC permanent load DALI bus / power contacts: 1500 VAC permanent load K-Bus / power contacts: 500 VAC permanent load
DALI / DSI | 符合标准, 开路电压 11.5 ... 15 VDC
高 / 低电平 | 电流 130 mA / 250 mA
过压能力 | 275 VAC permanent load
重量 | 约 80 g
尺寸 (W x H x D) | 约 15mm x 100 mm x 70 mm
安装 | 在35 mm符合EN 50022的导轨上
功率损耗 | 0.5 W + 连接的DALI从站产生的功率损耗
工作温度 | 0°C ... + 55°C
储藏温度 | -25 °C ... + 85°C
相对湿度 | 95%, no condensation
抗震性 | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
抗电磁干扰 | 符合 EN 61000-6-2 / EN 61000-6-4
防护等级 | IP20
安装位置 | variable
认证 | CE


KL6811 - Basic function principles

BECKHOFF KL6811: Product Overview

基本功能原理

众所周知，控制系统最大的竞争就在于价格。 建筑物的照明是通过许多设备来实现的. 因此, 每一盏灯的价格对整个控制系统而言是非常有意义的.

DALI

数字地址照明接口DALI 是一种用于楼宇自动化的简单总线系统，用来给灯光设备传输数字操作信号. 灯、传感器、按钮和开关，分别接到控制器上. 其他的执行器, 例如加热控制阀或者百叶窗电机被增加到数字控制后.

DALI 有以下优点:

  • 便宜且安装方便
  • 全数字控制灯
  • 所有主要的厂家支持DALI.

Beckhoff 的KL6811 DALI主站缩小照明设备控制器和灯之间的距离并且最多能连接64个DALI设备(DALI从站).

KL6811集成到Beckhoff总线端子系统中作为一个正常的总线端子，因此它是总线独立的. 高等级的总线耦合器从DALI主站端子传输数据到控制器.DALI电源供电单元是集成的，由KL6811给DALI总线供电. 操作DALI不需要更多的设备.

在启动期间, KL6811 搜索连接的DALI从站和支持在系统调试时的用户.使用 KS2000 配置软件, 在PC上可以配置DALI 主站端子. 配置操作通过现场总线或者RS232接口实现.

DSI

此外，你可以使用KL6811作为DSI主站. 数字串行接口 (DSI)是一个非常简单的灯光控制总线 . DSI 主站发送数字亮度值到DSI从站. 从站的亮度值可在 1% 到100%之间调节. 亮度和电弧功率成对数关系,所以电弧功率成线性增长, 亮度提高了人为观察的稳定性. 从站可以不用改变他们的总电压, 只需要设置电弧功率为0就可以使其变暗.


KL6811 - LED display

BECKHOFF KL6811: Product overview

LED 指示灯状态

LED | No | Meaning
RUN | A | on | 在K-Bus上开始数据传输
Bus | B | flashing | 活动:在 DALI/DSI 总线上有数据传输
 |  | on | 没有为电源触电提供24 VDC电源
DALI / DSI | C | on | 操作模式 | LED on: DALI 模式
 |  | off |  | LED off: DSI 模式
Error | D | on | 在 DALI 模式: 内部 DALI供应超载 在 DSI 模式: DSI 反馈


KL6811 - Connection

BECKHOFF KL6811: Mounting and wiring

接线

警告 		触电和设备损坏的风险!
在总线端子开始安装、拆卸和接线前，保证端子系统在安全、断电状态!

引脚分配
Terminal point | No | Connection for
DALI + | 1 | DALI/DSI 控制线 (内部与4号脚连通)
+24 V | 2 | 电源触点 +24 V
0 V | 3 | 电源触点 +0 V
DALI + | 4 | DALI/DSI 控制线 (内部与1号脚连通)
DALI - | 5 | DALI/DSI 控制线 (内部与8号脚连通)
+24 V | 6 | 电源触点 +24 V
0 V | 7 | 电源触点 +0 V
DALI - | 8 | DALI/DSI 控制线 (内部与5号脚连通)

注意 		主电源不能连接到电源触点上
电源触点(+24 V, 0 V)在任何情况下都禁止连接到230V电源电压上,这会使KL6811损坏.

注 		DALI控制线 (DALI+, DALI-) 和主电源的连接
如果DALI控制 (DALI+, DALI-)不小心接到 230 V上, KL6811不会坏掉。

DALI模式下的导线长度

DALI的布线方式可以是总线型或星型，也可以是混合型。两个DALI设备之间的距离不能超过300米！

导线长度 | 导线直径
100米 | 最小 0,5 mm2
150米 | 最小0,75 mm2
300米 | 最小1,5 mm2

DALI导线不需要连接到终端电阻.


KS2000 Configuration Software

BECKHOFF Fieldbus Components: KS2000 Configuration Software

KS2000配置软件

The KS2000配置软件可以对总线耦合器和其所连接的总线端子和端子盒模块进行配置, 调试和参数设置. 总线耦合器/总线端子盒和PC之间的连接是通过串行配置电缆或者总线建立的.

配置

你可以通过KS2000配置软件脱机对现场总线站进行配置. 这意味着,设置一个总线站就是设置所有总线耦合器和连接的端子.在调试阶段前要准备好现场总线端子盒模块.稍后,在调试阶段通过下载可以将这个配置传递到总线端子站 . 通过文件,可以得到损坏的端子站,使用模块的部分列表和已经设置的参数.上载后,可以得到总线站信息,可以进行后续配置.

参数化

KS2000提供简单的访问现场总线站的参数：可以与所有总线耦合器、所有智能总线端子和现场总线端子盒模块进行具体的高等级对话,并可以轻松设置其参数.另外,您可以完全访问总线耦合器和智能端子的所有内部寄存器.寄存器的含义参考寄存器的描述.

调试

KS2000软件使机器部件或其现场总线站的调试非常方便: 配置文件通过下载传输到现场总线模块.在 login到端子站后, 可以在线的调试耦合器、端子和现场总线盒模块. 在配置时,可以进行对寄存器访问.

KS2000提供总线耦合器和现场总线端子盒模块过程映像的访问.

  • 因此，可以监控耦合器的输入和输出映像.
  • 在调试输出模块时可以指定输出映像的过程值.

在Online模式下，可以访问到所有现场总线的站点。在这种情况下现场总线协议总是有更高的优先级.

在并联使用端子站的实际现场总线模式时可以使用联机模式下所有功能.在这种情况下现场总线协议总是有更高的优先级.


Parameterization with KS2000

BECKHOFF KL6811: Configuration software KS2000

用KS2000设置参数

通过配置电缆和启动KS2000配置软件,用PC的串行接口连接现场总线耦合器的配置接口.

点击 Login 按钮.设置软件会上载总线站的信息.
例子如下：
  • 一个 BK9000 Ethernet总线耦合器
  • 一个 KL1xx2 数字输入端子
  • 一个 KL6811 DALI 主站端子
  • 一个 KL9010 总线终端端子

KS2000 左侧窗口以树型结构显示总线站的端子.
KS2000 左侧窗口以图形方式显示总线站的端子.

在左侧窗口树型结构中, 点击所想修改其参数的端子前面的＋号(例如item 2).

对于 KL6811,显示了 Register, Settings 和 ProcData三个分支

  • 在Register设置中允许直接修改KL6811的寄存器参数.
  • 在Settings中可以找到KL6811参数设置的图形窗口.
  • ProcData 显示了KL6811的过程数据.


KS2000 - Register

BECKHOFF KL6811: Configuration software KS2000

寄存器

在Register中可以设置KL6811的寄存器参数. 寄存器的定义在register overview中说明.


KS2000 Settings

BECKHOFF KL6811: Configuration software KS2000

Settings

在 Settings中，你可以看到一个界面，上面显示了所连接的DALI/DSI设备。.

Device settings

你可以在该界面中设置 DALI/DSI devices .

Addressing

你可以在该界面中获取 addressing of the DALI devices.

Options

你可以在该界面中指定options for the KL6811.


Settings of the DALI devices - Light Control / Queries

BECKHOFF KL6811: Configuration software KS2000

灯光亮度控制/查询

点击设备号 (例子中为 Device #00). 出现3个对话框 direct lamp control, indirect lamp control 和 query.

直接灯光亮度控制 (通过 直接控制灯光亮度的DALI命令控制)

通过指定值直接设定亮度

间接灯光亮度控制 (通过间接灯光亮度控制的DALI命令 控制)

对与一些主要功能给所选设备发送相关DALI命令的按钮是可用的.

Off

关闭连接到DALI设备的灯 (发送 DALI 命令 0 dec).

Down

按选定的渐变率以200ms为周期使DALI设备变暗(发送 DALI 命令 2 dec)

Up

按选定的渐变率以200ms为周期使DALI设备变亮 (发送 DALI 命令 1 dec)

Step Down

如果灯光亮度还没有达到设定的最小值,那么降低当前灯光亮度一个等级(发送 DALI 命令 4 dec).如果灯光亮度已经到达设定的最小值,他是不会改变的,将一直保持打开状态. 最小值可以在变量 表中设置 .

Step Up

使灯光亮度提高一个等级除非它已经是最亮的了(发送 DALI 命令 3 dec). 如果灯是关闭的,这个指令无法使灯打开.

Step Down and off

降低当前灯光亮度一个等级(发送DALI 命令 7 dec).如果亮度已经达到设置的最小值,灯将关闭. 最小值可以在变量 表中设置 .

On and Step Up

使灯光亮度提高一个等级 (DALI 命令 8 dec).如果灯是关闭的,灯将被打开到设定的最小亮度. 最小值可以在变量 表中设置 .

Recall MIN LEVEL

将灯光亮度调到最小值 (发送DALI 命令 6 dec). 如果灯光是关闭的,灯将被打开.

Recall MAX LEVEL

将灯光亮度调到最大值 (发送 DALI 命令 5 dec). 如果灯光是关闭的,灯将被打开.

Go to Scene
  • 选择一个场景.
  • 点击 Go to scene 按钮.

设置DALI设备灯光亮度为所选定场景中设定的值 (发送 DALI 命令 16 到 31 dec). 这个值在 场景 表中设置.

查询

这个对话框允许查询关于DALI设备的状态信息:

  • 选择需要查询的内容
  • 点击 Send Query 按钮.
Query ballast

询问 DALI 设备是否准备好数据交换(DALI 命令 145dec).

Query lamp failure

询问 DALI 设备是否有灯光故障 (DALI 命令 146 dec).

Query lamp power supply switched on

查询 DALI 设备的电源是否打开(DALI 命令 147 dec).

Query limit value error

查询 DALI 设备是否出现极限值错误 (DALI 命令 148 dec).

Query reset status

查询 DALI 设备是否在重启状态 (DALI 命令149 dec).

Query missing short address

A查询 DALI 设备是否缺少短地址 (DALI 命令 150 dec).

Query DTR contents

读取DALI 设备的 Data Transfer Register (DTR) (DALI 命令152 dec).

Query device type

查询 DALI 设备的类型 (DALI 命令153 dec). 存在下列设备类型:
0: 标准设备
1: 紧急照明设备
2: HID 灯光设备
3: 调光设备
5 到255 保留给更多的设备类型. 可以在 DIN EN 60929 标准中找到更多的信息.

Query power supply fault

查询 DALI 设备是否出现电源错误(DALI 命令 155 dec).


Settings of the DALI devices - Groups

BECKHOFF KL6811: Configuration software KS2000

组

点击组. 出现DALI设备编组对话框.

在这个对话框里面最多可以将每个DALI设备添加到16个组中.如果一个分组已经参数化,当DALI设备接收到关于这个分组的命令时,那么它将执行这个命令.


Settings of the DALI devices - Scenes

BECKHOFF KL6811: Configuration software KS2000

场景

通过这个对话框可以在每个DALI设备上存储16个不同场景的光照强度.如果一个场景已经参数化,当DALI设备接收到这个场景号时（例如在广播消息中）,它将给场景设置指定的亮度. 如果给这个场景指定的值是255,DALI设备则保持当前值.


KS2000 - Adressing the DALI devices

BECKHOFF KL6811: Configuration software KS2000

设置DALI设备地址

物理设置地址

注 		不要打断地址设置
设地址的时候不能受到其它的DALI指令干扰.确保在设地址的时候，PLC程序或者K-Bus循环处于停止状态.
物理设置地址的步骤
  1. 点击 Start 按钮开始设置地址

    注     		地址
    如果选择Complete new installation, 所有先前的地址将被删除.否则可以增加更多的设备到现有的地址方案中.
    如果选择Delete all group assignments, 组的地址分配将保留.重新分配地址时要考虑这一点!
  2. 状态栏显示以下信息:
    等一个设备被选中时,拔掉所选设备的灯泡!
  3. 拔掉灯之后，状态栏显示以下信息:
    设备以设好,请装上灯泡!
    装回灯后闪三次说明设置成功.
    新的设备地址在短地址列表中显示.
  4. 重复2和3步设置所有的DALI 设备.
  5. 设置完成后点击 Cancel 按钮.

新的设备地址在短地址列表中显示:

随机设置地址

通过这种方法随机设置设备的地址.

用户无法决定地址的顺序.但以后可以通过 Change addresses 来改变地址.

单独设置地址

通过这种方法KL6811所连接的所有DALI从站将获得同一个新的地址.实际上一般你只能连接一个DALI设备,在点击start 按钮前应该选好新的地址.

更改地址

在右边窗口选择你想要修改地址的设备,在 new address 下拉框中选择新地址.当选完所有新地址后点 start 按钮.

Optical selection feedback

如果选项 optical selection feedback 打勾。被选中的设备 (例如Device #04)的亮度会调到最亮。


KL6811 - KS2000 Options

BECKHOFF KL6811: Configuration software KS2000

KL6811 选项

这个对话框允许指定KL6811的多种选项.

运行模式 (R32.12-15)

这里可以指定KL6811的运行模式:
  • DALI: KL6811 作为 DALI 主站运行
  • DSI: KL6811 作为 DSI 主站运行

供电单元 (R32.3)

这里可以打开或者关闭 DALI/DSI 供电单元.

DALI设备的计数 (R32.4)

在启动KL6811后可以启动或者关闭DALI设备的计数.

固件版本 (R9)

显示KL6811的固件版本.


Archive

BECKHOFF KL6811: Konfigurations-Software KS2000

存档

这个对话框通过清晰的表格来指定KL6811所连接的DALI从站的信息

  • 16个场景灯的亮度
  • 16个 组的成员

场景

在这个对话框中你可以为最多16个场景（水平列表）指定最多64个DALI从站（垂直列表）的灯光亮度.

允许下列项目:

  • 0 to 254: 灯光亮度 (0: 关闭, 254: 最大亮度)
  • 255: Mask (当改变到一个新场景时,保持它先前的亮度值.）

示例

  • DALI 从站1 场景3亮度50, 场景5亮度100,场景10亮度250.
  • DALI 从站8 场景4亮度200, 场景6亮度150,场景12亮度20.
  • DALI 从站18 场景3、4、5、6、10、12亮度254.
Optical selection feedback

如果选择 optical selection feedback ,然后选中某列场景, 这个场景中的所有DALI从站就会按照设定的亮度点亮.
需要先选择KS2000的选项 Online Monitoring 并且耦合器 LED I/O Run 必须闪烁.

组

在这个对话框中你可以为最多16个组（水平列表）指定最多64个DALI从站（垂直列表）的分组关系.

允许下列项目:

  • 1: 表示DALI从站隶属于这个组
  • 0: 表示DALI从站不隶属于这个组

示例

  • DALI 从站1 属于组7, 9 和11.
  • DALI 从站 8 属于2, 8 和 10.
  • DALI 从站 18 属于 2, 7, 8, 9, 10 和 11.
Optical selection feedback

如果选择 optical selection feedback ,然后选中组号, 这个组中的所有DALI从站会达到最大亮度.
需要先选择KS2000的选项 Online Monitoring 并且耦合器 LED I/O Run 必须闪烁.

选项

打开

打开一个保存在计算机上的配置文件 (*.xml).

保存

保存配置文件 (*.xml) .

下载

下载配置信息到 DALI 从站.

上传

上传DALI 从站的配置信息.


KS2000 - Process Data

BECKHOFF KL6811: Configuration software KS2000

过程数据

过程数据在ProcData下以图形来显示.


Process Image

BECKHOFF KL6811: Access from the User Program

过程映像

在过程映像中,KL6811代表输入和输出数据的3个字节,这些如下:

字节偏移量(无字对齐) | 字节偏移量(字对齐) | 形式 | 输入数据 | 输出数据
0 | 0 | 字节 | Status byte (SB) | Control byte (CB)
1 | 2 | 字 | DataIN | DataOUT

*) 字对齐: 总线耦合器以偶字节地址放置地址

在DALI模式下过程数据字

过程输出字(DataOUT)

位 | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
名称 | Y | 地址位(A) |  |  |  |  |  | S | 命令(X)
Key
位 | 名称 | 描述
15 | Y | 0bin | 地址位 9 到 14包含 DALI 短地址.
 |  | 1bin | 地址位 9 到 14包含DALI组地址或者 DALI 广播式地址.
14 到 9 | 地址位 (A) | 0bin | DALI 短地址. DALI 组地址或者 DALI 广播式地址.
8 | 选择位 (S) | 0bin | 位 0 到 7 包含灯的亮度值.
 |  | 1bin | 位 0 到 7 包含DALI 命令.
7 到 0 | 命令 (X) | 灯亮度值或者DALI命令

*) DALI命令清单可以在DALI 命令中找到

注 		DALI 从站接受到的命令
请注意一旦DALI从站的负荷边接通电源(230 V),便开始接受指令,因为DALI从站的PIC (单片微型控制器) 由负载电压供电.

过程输入字 (DataIN)

位 | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
名称 | 保留 |  |  |  |  |  |  | OK | 参数
Key
位 | 名字 | 描述
15 到 9 | - | 保留
8 | OK | 0bin | 位0 到 7 不包含有效数据
 |  | 1bin | 位0 到 7 包含DALI从站的有效响应
7 到 0 | 参数 | DALI 从站的响应

在DSI模式下的过程数据字

过程输出字(DataOUT)

位 | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
名称 | 保留 |  |  |  |  |  |  |  | DSI 的亮度值
Key
位 | 名称 | 描述
15到 8 | - | 保留
7到 0 | DSI亮度值 | 这里可以位DSI从站指定8位亮度值.

过程输入字 (DataIN)

在DSI模式下, 过程输入字没有作用.

位 | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
名称 | 保留


Control and Status bytes

BECKHOFF KL6811: Access from the User Program

控制和状态字节

过程数据模式

在过程数据模式下的控制字节

控制字节 (CB) 位于 输出映像 中并且从控制器传送到KL6811.

位 | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
名称 | RegAccess | R/W | - | - | - | - | RepeatASC | Toggle
Key
位 | 名称 | 描述
CB.7 | RegAccess | 0bin | 寄存器通信关闭 (过程数据模式)
CB.6 | R/W | 0bin | 读访问
 |  | 1bin | 写访问
CB.5 到 CB.2 | - | 保留
CB.1 | RepeatASC | 0bin | KL6811 不重复相关应用扩展命令 (224dec-255dec).
 |  | 1bin | KL6811 重复相关应用扩展命令 (224dec-255dec).
CB.0 | Toggle | 每个边缘触发位变化改变时,KL6811发送一个DALI或DSI的报文. 报文每隔25ms发送一次.例如在100ms中KL6811最多可以发送4个报文. 根据内容（有或没有回传信道）,DALI报文周期的持续时间是25和43.34 ms之间.在状态字节中边缘触发位(SB.0).表示DALI报文周期的结束.

在过程数据模式下的状态字节

状态字节 (SB)位于 输入映像 中并且从KL6811传送到控制器.

位 | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
名称 | RegAccess | Error | - | - | - | BC Collision | FC Collision | Toggle
Key
位 | 名称 | 描述
SB.7 | RegAccess | 0bin | 过程数据模式的确认
SB.6 | Error | 0bin | 没有错误
1bin 错误:
  • 在DALI模式下如果KL6811的内部DALI供电单元被使用: KL6811d的内部DALI供电单元过载(总线欠压)
  • 在DSI 模式下:DSI设备的一个（几个）错误信息
SB.5 到 SB.3 - 保留
SB2 BC Collision (only in DALI
mode) 		0bin 没有冲突
1bin | 在反向通道上发现DALI 冲突: 在DALI报文传送时,发现和另一个DALI从站发送的数据有冲突. 在位SB.0的下一个边缘SB.2被复位,除非另一个DALI冲突发生.
SB.1 FC Collision (only in DALI
mode) 		0bin 没有冲突
1bin | 在反向通道上发现DALI 冲突: 在DALI报文传送时,发现和另一个DALI从站发送的数据有冲突. 在位SB.0的下一个边缘SB.1被复位,除非另一个DALI冲突发生.
SB.0 | Toggle | SB.0边缘确认控制字节(CB.0)的触发位和报文周期的结束位。通过DALI/ DSI总线发送电报。在DALI模式下，冲突位（SB.1）提供有关任何可能发生的冲突的信息。

寄存器通信

寄存器通信中的控制字节

控制字节(CB)位于 output image并且从控制器传送到KL6811.

位 | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.3 | CB.0
名称 | RegAccess | R/W | Reg. no.
Key
位 | 名称 | 描述
CB.7 | RegAccess | 1bin | 开启寄存器通信
CB.6 | R/W | 0bin | 读访问
 |  | 1bin | 写访问
CB.5 to CB.0 | Reg. no. | 寄存器号: 输入寄存器 的号码 - 可以读取输入数据字0 - 可以写输出数据字0

注意 		在寄存器通信中过程数据无效!
在寄存器通信中不能访问数据寄存器!仍然要显示过程数据是无效的!

在寄存器通信中的状态字节

状态字节 (SB) 位于输入映像 中并且从KL6811传送到控制器.

位 | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
名称 | RegAccess | R | Reg. no.
Key
位 | 名称 | 描述
SB.7 | RegAccess | 1bin | 寄存器访问的确定
SB.6 | R | 0bin | 读访问
SB.5 to SB.0 | Reg. no. | 读或写的寄存器号.


Register Overview

BECKHOFF KL6811: Access from the User Programm

寄存器概述

寄存器 | 注释 | 默认值 |  | R/W | 存储位置
R0 | 保留 | - | - | - | -
R1 | DALI 从站计数器 | - | - | R | RAM
R2 to R5 | 保留 | - | - | - | -
R6 | 诊断寄存器 | - | - | R | RAM
R7 | 命令寄存器 | 0x0000 | 0dez | R/W | RAM
R8 | 端子类型 | 0x1A9B | 6811dez | R | ROM
R9 | 固件版本等级 | e.g. 0x3143 | e.g. 12611dez | R | ROM
R10 | 多重移位寄存器 | 0x0118 | 280dez | R | ROM
R11 | 信号通道 | 0x0118 | 280dez | R | ROM
R12 | 最小数据长度 | 0x1818 | 6168dez | R | ROM
R13 | 数据结构 | 0x0000 | 0dez | R | ROM
R14 | 保留 | - | - | - | -
R15 | 对齐寄存器 | - | - | R/W | RAM
R16 | 硬件版本 | e.g. 0x0000 | z.B. 0dez | R/W | SEEROM/RAM
R17 to R30 | 保留 | - | - | - | -
R31 | 注册码寄存器 | 0x0000 | 0dez | R/W | RAM
R32 | 功能寄存器 | 0x0000 | 0dez | R/W | SEEROM/RAM
R33 to R63 | 保留 | - | - | - | -


List of Literature

BECKHOFF KL6811: Appendix

文献列表

书

  • DALI AG的DALI 手册 (DALI活动组,参见 http://www.dali-ag.org).

标准

  • IEC 60929: 电子镇流器性能要求的国际标准(DIN EN 60929), 附录E.