KL8001, KL9060 -端子模块

Beckhoff 现场总线组件

KL8001和KL9060文档

Sirius 3RT10 系列接触器的电源端子

版本 1.2.0
日期 2006-02-09


文档说明

本说明书仅供那些在控制与自动化工程方面受过适当培训且熟悉各种适用国家标准的专业人士使用。
在安装和调试这些组件时，操作人员必须严格遵循下列说明和解释。

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

免责声明

尽管本文档经过精心编制， 但由于其中所描述的产品仍处于不断更新换代中，
我们可能不会在每次更新后都检查文档中所描述的产品性能数据、标准或其它特性总是与实际产品相一致。
本文档中难免会出现一些技术或者编辑错误，我们保留随时对文档信息作出修改之权力，恕不另行通知。
对于已经变更的产品，如果本文档中的数据、图表以及文字描述没有修改，我们将不再特别加以声明。

商标

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® 已为Beckhoff 自动化有限公司的注册商标
本出版物中的相关名称若被第三方出于个人目的，用作商标，将侵犯其拥有者的权利。

申请中的专利

已包含EtherCAT技术但不局限于如下专利申请和专利:
EP1590927, EP1789857, DE102004044764, DE102007017835
在许多其他国家有关EP0851348, US6167425的相关申请和注册。

已包含TwinCAT技术但不局限于如下专利申请和专利:
在许多其他国家有关EP0851348, US6167425的相关申请和注册。

版权

© 德国倍福自动化有限公司版权所有
未经许可，任何人不得复制、分发和使用本手册以及内容传播。
违者将追究损害赔偿 保留所有出现的专利，实用新型的模型和外观设计的版权。


安全说明

安全规程

请仔细阅读下列安全说明 及相关描述！
有关产品特定安全规程，请见后面页或有关安装，接线及调试等章节。

免责声明

所有组件在供货前均针对其具体应用进行了特定的软、硬件配置。 任何人不得对软、硬件配置进行文本档中规定之外的修改，德国倍福自动化有限公司对因此而造成的一切后果不承担任何责任。

人员资质

本手册仅供那些受过适当培训，熟悉各种适用国家标准的“控制、自动化和驱动工程”领域专业人员使用。

安全标志说明

本操作手册中用到了下列安全标志及相应的安全说明。 请仔细阅读并严格遵守。

危险 		有严重人身伤害危险!
如果你 不遵循安全建议相邻这个符号,有直接的威胁生命和健康的个体!

警告 		受伤的危险
如果你你 不遵循安全建议相邻这个符号,有危险的个人生活和健康!

小心 		危害个人
如果你不 不遵循安全建议相邻这个符号,有明显的危害个人!

注意 		对环境和设备有危险
如果你不 遵循该通知相邻这个符号,有明显的危害环境和设备.

说明 		说明或提示
该标志表示这些信息能够帮助您更好地理解安全说明。
UL 说明
这个标志用于表示有关UL标准的重要信息。.


KL8001, KL9060 - 文档版本说明

BECKHOFF: KL8001, KL9060: 前言

文档版本说明

版本 | 注释
1.2.0
  • 前言 及 附录 更新
  • 订货信息 更新
  • 技术数据 更新
  • 特征寄存器描述更新
  • 指令寄存器的描述补充
  • 参数寄存器PR33, PR40, PR46: 决议修订:
  • 描述数据寄存器的修改
1.1
  • 技术数据 更新
  • 描述参数寄存器扩展
1.0
  • 描述参数寄存器更新
  • 英文版本
0.3 (只有德国版本)
  • 产品概览 修改
  • 描述von控制和状态字节修订
  • 寄存器描述修改
  • 订货信息扩展
0.2 (只有德国版本)
  • 功能描述
  • 技术数据更新
  • 安装和布线添加信息
  • 添加应用示例
  • 补充描述KS2000软件的的参数
  • 修改过程映像的描述
  • 扩展寄存器描述
  • 添加订货信息
0.1 | 初步版本(只有德国版本)

Firm及硬件版本

文档资料 版本 | KL8001 |  |  |  | KL9060
 | 测量PCB |  | K-bus PCB |  | 软件 | 硬件
 | 软件 | 硬件 | 软件 | 硬件
1.2.0 | 5 (=3C) | 4 | 6 (=3C) | 1 | 00 | 01
1.1 | 2 (=2A) | 3 | 3 (=1C) | 0 | 00 | 00
1.0 | 1 (=1B) | 1 | 1 (=1B) | 0 | 00 | 00
0.3 |  |  |  |  | 00 | 00
0.2 |  |  |  |  | 00 | 00
0.1 |  |  |  |  | 00 | 00

软件及硬件版本序列号(交货状态)可以在打印在KL9060侧面的序号中找到.

固件版本的KL8000的PCB测量可以从数据寄存器DR37.
固件版本 的KL8000的K-bus PCB显示在ks2000设置.
硬件版本的测量及 K-bus PCB在KL8001的序列号中.

KL9060序列号说明

序列号结构 KK YY FF HH

KK - 生产周 (CW, 日历周)
YY - 生产年
FF - 固件版本
HH - 硬件版本

例子 with ser. 无.: 02 06 00 01:

02 - 第 02周生产
06 - 2006 年生产
00 - 固件版本 00
01 - 硬件版本 01

序列号说明KL8001

序列号结构 KK YY FH fh

KK - 生产周 (CW, 日历周)
YY - 生产年
FH - 固件版本 (F) 及 硬件版本 (H) of the measuring PCB (coded)
F h - 固件版本 (F) und 硬件版本 (h) of the K-bus PCB (coded)

例子 with ser. 无.: 02 06 54 61:

02 - 第 02周生产
06 - 2006 年生产
54 - Measuring PCB: 固件版本 5 (=3C), 硬件版本 4
61 - K-bus PCB: 固件版本 6 (=3C), 硬件版本 1


KL8001 Power 端子模块

BECKHOFF: KL8001: 产品概览

KL8001电源端子模块

KL8001电源端子模块是专门用于西门子接触器从西门子3RT10系列, Size S00. 它同样也是适用于标准电机保护继电器. 电机启动器端子模块直接控制所连接的接触器，并具有电机保护继电器所具备的所有功能。 除了纯粹的电机过载保护功能以外，电源端子模块还可在电机上执行大量的诊断功能，并通过现场总线将诊断数据传送到控制器中。

名称 | 描述
K-bus输入 | K-bus总线输入连接头
K-bus输出 | K-bus总线输出连接头. 此处插入总线末端插头 , 包括KL9060，总线端子块中的最后一个电源端子.
L1, L2, L3 | 主电源负载回炉连接端子.
L1', L2', L3' | 连接到接触器负载回路的连接点.
13, 13' | 连接通过辅助触点.
Out1 | 接触器工作线圈连接点（向右运动时反向连接接触器）
Out2 | 接触器工作线圈连接点（向左运动时反向连接接触器）
1 A | 手动调节额定电流旋转开关（分辨率1A）
0.1 A | 手动调节额定电流旋转开关(分辨率0.1 A)
开 (motor) | 电机诊断功能：LED: 指示电机是否接通
过载 (motor) | 电机诊断功能：LED: 指示电机过载
run (现场总线) | K-bus诊断LED: 指示数据在K-bus上传送
停止 (现场总线) | K-bus诊断LED: 指示数据在K-bus上传送中断
Lugs | 用于将KL8001安装在西门子接触器的手柄


KL9060 - 连接端子模块

BECKHOFF: KL9060: 产品概览

KL9060连接端子模块

KL9060适配器端子用于将电源端子连接到BECLHOFF总线端子系统的K-bus总线上.

名称 | 描述
K-bus Out | K-bus总线输出插接点. 用长扁平电缆插入连接(大约. 10 cm) 在此处第一个电源端子模块.
ZS1010-1610 | 插入ZS1010-1610总线末端插头到K-bus总线 末端连接器最后一个端子模块.
2及6 | +24V电源端子连接触点
3及7 | 0V电源端子连接触点
4及8 | PE接地端子连接触点
+24 VP | +24V电源触点
0 VP | 0V电源触点
PEP | PE接地触点


KL8001 - Functional 描述

BECKHOFF: KL8001: 产品概览

功能描述

旋转开关调节额定电流

设置 额定电流使用电源端子上的两个旋转开关. 上面的旋转开关每格分辨率为1A，而下面的旋转开关每格分辨率为 0.1A. 设定的值范围为 0.9 到 9.9A. 该设定值施加于全部三相中.

如果你将两个旋转开关设置为零,则必须用三个寄存器– 额定电机电流：PR33, PR39 和 PR45参数指定电机额定电流. 该种方式下

  • 对各相分别设置不同的额定电流：, 例如：连接三个单相电机.
  • 使用扩展的设置范围从10.0至15(放),不能设置的旋转开关.

LED

电源端子有4个LED指示灯用于状态指示及允许快速诊断. 可能的状态在下表中列出.

LED | 状态 | 描述
开 (motor) | 开 | 电机运行，正转或反转
 | 关 | 电机断电，或过载保护已触发
过载 (motor) | 开 | 电机由于过载而被断电
 | 闪烁 (2 Hz) | 电源已下降到低于最小负载：门槛值
 | 闪烁(5 Hz) | 超出过载门槛值
 | 关 | 正常操作方式 (负载：既没有低于最小值也没有超出最大值), 或电机为断电状态
run (现场总线) | 开 | 与端子总线的– 通讯正常
 | 关 | 与端子总线没有通讯(看门狗定时器已经触发100ms)
停止 (现场总线) | 开 | 与端子总线没有通讯
 | 闪烁 | 错误代码和错误点用闪烁代码指示
 | 关 | 与端子总线的– 通讯正常

闪烁代码

如果现场总线错误, 停止 LED 指示灯指示一个闪烁代码，可更加准确地说明故障:

LED 指示灯在开始输出错误前，大约闪烁2秒输出： 1 x 16 位数据（ 1 x 8 位控制 / 状态可选）. 经过清楚可见的停顿后，错误代码用慢速闪烁指示，并且错误点在经过另一个停顿后指示. 下表可让你借助这两项信息的帮助，更加准确地确定错误.

代码 | 出错点 | 描述 | 解决方法
1 0 没有额定电流设置: 两个旋转开关及及
  • 寄存器PR33为零(单项分析没有激活)或
  • 至少寄存器PR33，PR39或PR45之一为零(单项分析已经激活)
 可使用旋转开关设置额定电流,或输入额定电流：到寄存器PR33, PR39 及 PR45.
2 | n | – 通讯第N个 ADC通讯故障 | 联系方式与供货.
3 | n | – 通讯 N个第霍尔传感器通讯故障

说明 在改变端子寄存器后，为了使新值匹配测量单元。应执行一次断电复位(端子切断电源并再次上电）！
  • 一个断电复位(通过切换终端了,然后再上)或
  • 一个 软件复位 (通过指令寄存器)!


KL8001 - 技术数据

BECKHOFF: KL8001: 产品概览

技术数据

KL8001 | 电源端子模块
每个总线耦合器可连接的电源端子数量 | 最多10 | 如果你用每个电源端子操作两个接触器(反向接触器连接)，则每个总线偶合器仅能使用5个电源端子. 也可观察 最大电流 那你的总线耦合器可以供应到K-bus!
接触器的总线耦合器 | 最多10个
连接的类型和机械连接 | 适合西门子接触器Sirius 3RT10系列尺寸S00
电源通路连接类型 | 螺钉端子，导线截面可达到2x2mm2
电源侧电流负载(备用熔丝) | 最大25A
电源侧短路强度 | 可达到5000 A
电源侧内部阻抗 | < 1 mΩ
电流设定范围 | 通过旋转开关: 0,9 to 9,9 A
 | 通过KS2000 或参数寄存器: 0.9到15.0A
可选择的触发等级 | 等级5, 10, 15, 20, 25, 30
测量值 | 电流,电压,有功功率,功率因数, 电能消耗,开关周期,工作小时数
测量精度 | 0.15A有效值; 2 V有效值; 5 W; 1 kWh
Crosstalk between the channels at unbalanced 负载： | up to 3% from the difference
测量值 | 500,1 V
K-bus 连接方式 | 2 x扁平接插槽，10管脚
K-bus电流消耗 (5VDC) | 典型值150mA Observe the maximum 电流 that your 总线耦合器 can supply to the K-bus!
接触器控制电压电流消耗(24 VDC) | 当接触器切断时 典型值 7 mA
 | 当接触器接通时: 典型值7mA+接触器线圈电流
绝缘强度 | 500V有效值 (电源触点/K-bus), 6000V有效值 (电源/K-bus)
Behavior under short-circuit conditions | 符合 EN 60947 标准（指定类型 4 ） /VDE 1
触发公差 | 符合 IEC 947 以及 UL 和 CSA 标准
配置 facilities | Automatic over the 现场总线 using the KS2000 配置软件, manual (额定电流)
过程映像中的位宽 | 96 位 I/O (see 描述 of the 过程映像)
允许的运行环境温度范围 | 0°C ... +55°C
允许的存储环境温度范围 | -25 °C ... +85°C
允许相对湿度 | 95%，无冷凝
抗振/抗冲击性能 | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC 防爆性 / ESD | 符合 EN 61000-6-2/EN 61000-6-4 标准
重量 | 大约 90 g
尺寸 (W x H x D) | 大约 45 mm x 69 mm x 74 mm
安装 | With lugs 及 connecting pins to 西门子接触器 of the 3RT1016 series
安装位置 | 任意 (although you must observe the permitted 安装方式 positions of the contactors)
防护等级 | IP 20
认证 | CE


KL9060 - 技术数据

BECKHOFF: KL9060: 产品概览

技术数据

KL9060 | 连接端子模块
电源触点电压 ( 带状电缆 电缆) | 24 VDC (-15%, +20%)
电源触点电流装载 (带状电缆： 电缆) | 最大1400毫安(短路证明). 记住当前消费的电力终端和接触器线圈
电压的K ：总线电源(带状电缆) | 5 VDC
电流消耗K-bus电源 (带状电缆 电缆) | 最大2000 mA 观察最大电流你的总线耦合器可以供应到总线! 例如： 低成本耦合器: 500 mA 经济型耦合器: 500 mA 经济增强型耦合器: 1750 mA 标准耦合器: 1750 mA KL9400供电单位终端: 2000 mA 使用KL9400供电单位终端如果当前消费的终端超过最大电流,你可以喂总线耦合器的K ：总线供应.
KL9060电机启动器端子模块的数量 | 最多10 | 如果你操作两个接触器与每个电源端子(换向接触器连接),那么你可能只使用5电力终端与每个KL9060. 观察最大电流 你的总线耦合器可以供应到K-bus!
KL9060接触器的数量 | 最多10
允许的运行环境温度范围 | 0°C ... +55°C
允许的存储环境温度范围 | -25 °C ... +85°C
允许相对湿度 | 95%，无冷凝
抗振/抗冲击性能 | 符合EN60068-2-6/EN 60068-2-27,EN 60068-2-29
EMC防爆性/ESD | 符合EN61000-6-2/EN61000-6-4标准
重量 | 大约50g
尺寸 (W x H x D) | 大约33mmx100mmx70mm
安装 | 35mm导轨安装符合EN 50022
安装位置 | 任意
防护等级 | IP20
认证 | CE


KL8001 - Mounting

BECKHOFF: KL8001: 安装和接线

安装

准备安装

  1. 解开西门子接触器主连接侧的所有5个端子模块 (1L1, 3L2, 5L3, 13No, A1+)
  2. 将电源端子的两个手柄插入到西门子接触器底部的两个开口式矩形条中使其固定.
  3. 推入电源端子的5个触点到5个打开的螺钉端子中，即西门子接触器主连接侧上。直到电源端子与西门子接触器牢固结合. 电源端子的两个手柄不允许滑出西门子接触器底部的矩形孔!
  4. 紧西门子接触器主回路侧的所有5个螺钉端子. 电源端子必须和西门子接触器牢固、紧密地结合!
警告 KL8001 电源端子仅能同西门子 SIRIUS 3RT10（尺寸 S00）系列接触器结合使用，参见订货信息!

安装带电源端子的总线端子块

安装期间, 安装总线终端上安装rails.

  1. 确保系统已经断电并处于安全状态.
  2. 在C型道轨上，安装由现场总线偶合器和所需要的任何总线端子组成的总线端子模块.
    将KL9060适配器端子作为总线端子块上的最后一个总线端子，并取代标准的末端子(KL9010).
  3. 卡紧西门子接触器，其上安装有电源端子。距离KL9060适配器端子大约 3cm.
  4. 使用扁平电缆，大约10cm 长，包括KL9060适配器端子，将电源端子与 KL9060连接.
  5. 使用扁平电缆，大约 3 cm 长，包括电源端子，将其与下一个电源端子连接
    or
    将包含在 KL9060适配器端子中的终端器插入到最后一个电源端子的出口端连接器上.
    一个总线端子块上最多可连接10个KL8001 电源端子类型 .


KL8001 - 接线

BECKHOFF: KL8001: 安装和接线

接线

K-bus, 接触器控制电压(24 V ：) 均由KL9060通过约10cm长的扁平电缆供电给第一个电源端子. 其它的电源端子使用约3cm长的扁平电缆连接. 在最后一个电源端子插入ZS1010-1610 总线终端器包含在KL9060中的ZS1010-1610 !

电源经 K-bus 总线提供给 KL8001 电子部件(通过扁平电缆).

用于电源端子切换开关的24V：接触器控制电压也通过该扁平电缆提供，但它与 K-bus 总线之间电气隔离. 你可以简单地将接触器线圈(A2-)的接地点与KL9060适配器端子的自由接地端子(0V ,触点3和7)点连接.

警告 KL9060 适配器端子可以提供1.4A的额定电流给接触器线圈供电(24 V ：DC). 必须确认不能超过该额定电流值.


KL8001 - 应用示例

BECKHOFF: KL8001: 安装和接线

应用示例

危险 确保负载：回路只能使用每相最大25A的熔断器.

电机控制

下图为使用一个KL8001和一个西门子接触器控制一个三相 AC 电机的示例 电源端子 Out1的输出控制西门子接触器.

将接触器连接反转

下图为使用一个 KL8001 和两个西门子接触器的反向接触器连接示例. 电源端子的Out1和Out2输出分别控制两个西门子接触器.

说明

应使用 西门子设备工具作反向组合 为了简单直接地安装电源端子，括反向接触器连接.

为此，移去西门子设备主回路侧桥的辅助触点和A1连接，这可通过断开为此目的而设计的定位连接实现(红线).

由KL8001控制的反向接触器连接不再需要辅助触点和A1的连接，因为 KL8001在其内部连锁了两个接触器.


在C型导轨上安装总线端子模块

危险 应将总线系统置于安全的、断电状态！
开始安装、拆装或连线总线端子模块之前!

安装

总线耦合和总线终端都可以毫不费力地安装在35mm导轨上。这个导轨可以在市场上买到 (DIN 轨道依据 EN 50022标准)：

  1. 首先将现场总线耦合器安装在导轨上。
  2. 总线端子模块安装在总线耦合器的右侧。 通过卡槽将元件连接在一起且将端子按在导轨上，直到将锁扣扣在轨道上。
    如果先将终端模块夹在安装导轨上然后再连接到一起，且不使用卡槽连接，这样连接将不会运转！ 正确的连接是模块之间没有可见的缝隙。

在总线终端模块安装完之后，总线端子模块的锁定机构不能与安装轨道上的固定螺丝相碰。

拆卸

每个端子都用锁扣固定在安装轨道上，在拆卸的时候必须解开锁扣：

  1. 小心地在拆装的端子上拉出橙色条约 1cm，直到凸出物完全松弛. 安装导轨上的卡锁现在释放了该端子，此时端子可以从安装导轨上轻易拉出.
  2. 同时用拇指和食指抓住总线端子模块上、下槽表面并拉出总线端子模块。

总线端子模块组合

总线耦合器和总线端子模块组合在一起后就自动完成了电气连接。

  • K-Bus/E-Bus的6个弹簧连接点负责数据传输和和总线端子模块的供电。
  • 电源触点负责给现场传感器供电，并在总线端子模块组中形成供电链。 电源触点通过总线耦合器给端子供电.
说明

在设计总线端子模块时，必须计算总线端子的引脚分配，因为有些型号不会或不完全通过电源连接。（例如：模拟总线端子模块或4通道的数字总线端子模块）。
供电端子模块 (KL91xx, KL92xx or EL91xx, EL92xx) 中断电源并重新开始一个电源供应链路。

PE电源触点

有PE标示的电源触片是用来接地保护的。 出于安全因素这个触片要先连接在一起，对地的最大短路电流是125 A。

警告

考虑到电磁兼容性，PE触点与安装轨道之间是电容耦合的。 这可能会在绝缘测试时导致错误或损坏端子（例如：客户在绝缘测试时把230V放电到PE短路）。

如果要进行绝缘测试， 断开总线耦合器或供电端子模块的PE！ 为了完全断开供电触点, 把供电端子模块从导轨上拉出至少10mm。

PE连接不能用来接其他的电位！

接线

最多可以连接8根线到总线端子模块，把线扎在总线端子模块连接器上。 端子连接采用弹簧力连接技术。 根据下面的步骤来接线：

  1. 用螺丝刀插入位于接口上方的方形孔来打开弹簧接线端子。
  2. 现在电线可以毫不费力的直接插入圆形孔。
  3. 当拔掉螺丝刀后弹簧端口会自动合上，将接线永久牢固的接上。
说明 模拟传感器和执行器总是用屏蔽双绞线相连。


KS2000 配置软件

KS2000设置软件用来设置总线耦合器、总线控制器和连在它们后面的总线端子。 可以通过专用的KS2000配置电缆来配置总线耦合器、总线控制器和端子，也可以通过总线方式进行配置。

配置

可以用KS2000软件离线配置总线站。 在现场总线模块配置之前，设定好所有总线站的耦合器和端子的参数。 然后通过下载的方式把设置参数下载到总线站中。 为了便于说明，我们采用最简化的端子站组合，列出部分可以修改的参数。 下载之后,就会列出所有的现场总线站，可以进行参数修改。

参数化

KS2000提供了简单的设置现场总线站的参数方法： 可以设置包括所有总线耦合器，所有智能总线端子模块和现场总线端子盒，并且这些设置可以轻松地进行修改。 或者，你可以直接修改总线耦合器和智能端子模块的寄存器。 需要参考每个寄存器的说明。

配置

KS2000软件易于配置机器部件和现场总线站： 配置的设置可以通过下载方式传输到现场总线模块。 login 到端子站之后,就可以 在线修改总线耦合器，总线端子模块和现场总线盒。 同样也可以通过修改寄存器参数的高级设置页面进行参数修改。

KS2000也可以读取总线耦合器和 现场总线盒 的过程数据。

  • 总线耦合器的输入和输出数据可以被监视。
  • 过程数据可以写到输出过程映像，用于调试输出模块。

在 online 模式 总线站可以与现场总线的通信同时进行。 但现场总线协议一般有较高的优先级。


KL8001 - 用KS2000设定参数

BECKHOFF: KL8001: 组态软件 KS2000

用KS2000设定参数

通过配置电缆将你的现场总线配置接口和PC串口连接，并启动KS2000配置软件。

点击Login按钮。 配置软件会将加载连接的现场总线站信息。
本例中
  • A BK9000 总线耦合器 for Ethernet
  • 一个 KL1xx2 数字输入端子模块
  • 一个KL9060适配器端子用于连接电源端子（某些版本的KS2000没有显示）
  • 一个KL8001电源端子模块用于连接西门子Sirius R3系列接触器
  • 一个ZS1010-1610总线末端插头(一些版本的KS2000仍然显示总线为KL9010末端子)

KS2000 左边的窗口在树形结构中显示了现场总线站的端子模块。
KS2000 右边的窗口包含了现场总线站端子模块的图形显示。

在左边窗口的树型结构中，点击你想要改变参数的端子模块旁边的加号(示例中的项目2)。

点击设置. 你可以在显示的组态表单中修改电源端子配置

  • 运行模式
  • 快速关断
  • 寄存器数据


KL8001设置

BECKHOFF: KL8001: 组态软件 KS2000

设置

最上方

Pos. | 端子模块在端子排中的位置
Type | 端子模块类型
Channel | 参数在配置表格中
固件 | 固件子版本的K-bus PCB

组态表当

在设置 表单中你可以设置KL8001电源端子的特性.

运行模式

在此选择电机状态.

右转运动控制 (PR32.0) 默认： enabled | 允许电机右转. 使用 扩展控制字节5 允许电机向右启动运行.
左转运动控制 (PR32.1) 默认： not enabled | 允许电机左转. 使用扩展控制字节位6允许电机向左启动运行.
看门狗定时器有效 (PR32.2) 默认： active | 看门狗有效. 如果电源端子在 100ms 时间内，没有从现场总线中接收到任何数据，看门狗将切断电机并且停止数据传送.
单项分析 (PR32.3) 默认： not active | 单相分析有效. 各相都和对应的数据寄存器比较,并且独立分析. 如果你禁止单相分析，则输入给L1相的值作用于所有三相.
读扶轮永久地切换 (PR32.5) 默认： active | 旋转开关 旋转开关调节额定电流是在正常操作期间读永久额定电流 是在正常操作期间读永久. 没有复位需要接管改变值.

快速关断

在此选择电机状态，当触发 500ms 后将其快速关断.

非对称性负载： (PR32.8) 默认： not active | 激活快速关断，如果L1,L2和L3之间的 电流差超过了最大允许差值.
相对故障 (PR32.9) 默认： active | 激活快速关断，如果相故障.
过压* (PR32.10) 默认： not active | 激活快速关断，如果发生过压. | *) 三相电压用Y型连接参考点测量.
欠压* (PR32.11) 默认： not active | 激活快速关断，如果发生欠压.
过载 (PR32.12) 默认： not active | 激活快速关断，如果发生过载.
欠载 (PR32.13) 默认： not active | 激活快速关断，如果发生欠载.

寄存器数据

在此处输入各种门槛值. 某些 输入： 盒对值范围有限制(例如 额定电流必须在0.0和25.0A), 并且在输入：期间自动限幅.

额定电流 (PR33, PR39, PR45) 默认： 0 A 允许设定值范围: 0,9 bis 15,0 A | 指定L1,L2和L3相的额定电流 . 这些值仅在 两个旋转开关 KL8001面板上都设置的额定电流为零时才使用. 否则，旋转开关上设置的值将施加于所有三相.
开通门槛值 (PR34, PR40, PR46) 默认： 0 | 指 定 L1,L2和L3相的过压门槛值.
过压* (PR35, PR41, PR47) 默认： 350,1 V | 指定L1，L2和L3相的过压门槛值. | *) 三相电压用Y型连接参考点测量.
欠压* (PR36, PR42, PR48) 默认： 150,1 V | 指定L1，L2和L3相的欠压门槛值.
过载 (PR37, PR43, PR49) 默认： 25 A | 指定 L1,L2和L3相的过载门槛值.
欠载 (PR38, PR44, PR50) 默认： 0 A | 指定 L1,L2和L3相的欠载门槛值.
最大电流差值 (PR51) 默认 5 A | 指定L1,L2和L3相间的最大允许电流差值.
触发等级 (PR52) 默认： 10 s | 指定触发等级.
测量时间 (PR53) 默认： 50 ms | 指定测量时间.


KL8001 - 过程映像

BECKHOFF: KL8001: 通过程序设置

过程映像

电机启动器端子模块在过程映像区中分别用12字节的输入和输出数据表示 输入： . 配置如下：

字节偏移(无字对齐*) | 字节偏移 (有字对齐*) | 格式 | 输入数据 | 输出数据
0 | 0 | Byte | 状态字节 0 (SB0) | 控制字节 0 (CB0)
1 | 2 | 字 | 数据输入0 | 数据输出0
3 | 4 | 字节 | 状态字节1 (SB1) | 控制字节1(CB1)
4 | 6 | 字 | 数据输入1 | 数据输出1
6 | 8 | 字节 | 状态字节2 (SB2) | 控制字节2(CB2)
7 | 10 | 字 | 数据输入2 | 数据输出2
9 | 12 | 字节 | 扩展状态字节 (ESB) | 扩展控制字节 (ECB)
10 | 14 | 字 | 未使用** | 未使用**

*) 字对齐: 字对齐：总线耦合器在偶字节地址添加值。

**) 过程映像用输入及 输出中未使用字进行扩展，以便电源端子看起来像一个四通道的模拟量端子.


KL8001控制字和状态字

BECKHOFF: KL8001: 通过程序设置

控制字和状态字

控制字节0及状态字节 0

过程数据模式

过程数据模式的控制字节0

控制字节0(CB0)位于输出图像从控制器传到电源端子中。

位 | CB0.7 | CB0.6 | CB0.5 | CB0.4 | CB0.3 | CB0.2 | CB0.1 | CB0.0
Name | 寄存器存取 | R/W | DR 无.
重点
位 | Name | 描述
CB0.7 | 寄存器存取 | 0bin | 寄存器通信关闭（过程数据模式）
CB0.6 | R/W | 0bin | 读访问
 |  | (1bin) | 因为KL8001数据寄存器只能读和写访问不是有用的.
CB0.5 to CB0.0 | DR 无. | 数据寄存号: 输入号你想读输入数据字0的数据寄存器.

过程数据模式状态字节0

状态字节0(SB0) 位于输入图像从电源端子传输到控制器。

位 | SB0.7 | SB0.6 | SB0.5 | SB0.4 | SB0.3 | SB0.2 | SB0.1 | SB0.0
Name | 寄存器存取 | ES故障信息 | DR 无.
重点
位 | Name | 描述
SB0.7 | 寄存器存取 | 0bin | 过程数据模式确认
SB0.6 | ES故障信息 | 1bin | 扩展状态字节的低半字节（ES.3到ES.0)包含故障信息. 评估扩展状态字节!
SB0.5 to SB0.0 | DR 无. | 读入的数据寄存器.

寄存器通信

寄存器通信控制字节0的使用

控制字节0(CB0) 位于 输出图像从控制器传到 KL3403电源端子。

位 | CB0.7 | CB0.6 | CB0.5 | CB0.4 | CB0.3 | CB0.2 | CB0.1 | CB0.0
Name | 寄存器存取 | R/W | PR 无.
重点
位 | Name | 描述
CB0.7 | 寄存器存取 | 1bin | 启动寄存器通信
CB0.6 | R/W | 0bin | 读访问
 |  | 1bin | 写访问
CB0.5 to CB0.0 | PR 无. | 参数寄存号: 输入 寄存器 号 通过输入数据字0读取 或者通过输出数据字0写入。

危险 在寄存器通信期间不能进行过程数据采集！ 显示的过程数据是无效的！

寄存器通信的状态字节0说明

状态字节0(SB0) 位于输出图像从控制器传输到电源端子.

位 | SB0.7 | SB0.6 | SB0.5 | SB0.4 | SB0.3 | SB0.2 | SB0.1 | SB0.0
Name | 寄存器存取 | R | PR 无.
重点
位 | Name | 描述
SB0.7 | 寄存器存取 | 1bin | 寄存器通信确认
SB0.6 | R | 0bin | 读访问
SB0.5到SB0.0 | PR 无. | 需要读或写的参数寄存器号.

控制字节1及状态字节 1

控制字节1(CB1)位于输出图像从控制器传到电源端子(同控制字节0的结构和用法). 注意输入过程数据中的控制字分配 。

状态字节1(SB1)位于输出图像从电源端子传送到控制器(同状态字节0的结构和用法).

控制字节 2及状态字节 2

控制字节2(CB2)位于输出图像从控制器传到电源端子(同控制字节1的结构和用法). 注意输入过程数据中的控制字 分配 。

状态字节2 (SB2)位于输入图像从电源端子传送到控制器(同状态字节0 的结构和用法).


KL8001 - Extended Control Byte

BECKHOFF: KL8001: 通过程序设置

扩展控制字节

扩展控制字节(ECB)传送到过程数据模式从控制器到端子模块, 及控制电源端子的一些功能：

扩展控制字节
位 | ECB.7 | ECB.6 | ECB.5 | ECB.4 | ECB.3 | ECB.2 | ECB.1 | ECB.0
Name | - | 电机左转 | 电机右转 | - | - | - | - | 清除Imax
重点
位 | Name | Value | 描述
ECB.7 | - | 0bin | 保留
ECB.6 | 电机左转 | 1bin | 切换电机为左转 电源端子模块的输出： 1 x 16 位数据（1 x 8 位控制 / 状态可选）Out2置位, 为此可通过西门子套件或者reversing combinations.
ECB.5 | 电机右转 | 1bin | 切换电机为右转: 电源端子的输出： 1 x 16 位数据（1 x 8 位控制 / 状态可选）Out1置位,为此可通过直接连接电源端子的接触器连接点.
ECB.4toECB.1 | - | 0bin | 保留
ECB.0 | 清除I最大值 | 1bin | DR2数据寄存器在全部三相寄存器组中被设置为零(它包括电流峰值). 因为电机的转子堵转电流远远大于额定电流DR2数据寄存器指示每次启动的峰值电流. 为了检测正常的工作时的峰值电流，可以随时用该位清除DR2数据寄存器为0.

说明:

  • 右转或左转必须使能(分别为位 0 和位 1)特征寄存器 如果用扩展控制字节使其可切换到向右转(位 5)或向左转(位 6).
  • 如果电机向右运行(输出： 1 x 16 位数据（ 1 x 8 位控制 / 状态可选） Out1被设置), 首先必须关闭该位(复位位 5)，然后用位 6 切换其为左转. 置位位 6，电源端子将切断电机.
  • 如果电机向左运行 (输出： 1 x 16 位数据(1 x 8 位控制 / 状态可选)Out2被设置, 首先必须关闭该位(复位位 6),然后用位 5切换其为右转. 如果电机正在向左运行时,置位5,电源端子将切断电机.
  • 如果你同时置位位5 和位 6,电机保持在切断状态.


KL8001 - Extended Status Byte

BECKHOFF: KL8001: 通过程序设置

扩展状态字节

扩展状态字节 (ESB) 包含KL8001的状态信息,并在下从端子传送到控制器中过程数据模式.

扩展状态字节
位 | ESB.7 | ESB.6 | ESB.5 | ESB.4 | ESB.3 | ESB.2 | ESB.1 | ESB.0
Name | 额定操作 | 点击左转 | 点击右转 | - | SW故障信息 | 点击过载停止 | 欠载 | 过载
重点
位 | Name | Value | 描述
ESB.7 | 额定操作方式 | 0bin | 发生过载或欠载，或电机因为过载而被切断电源.
 |  | 1bin | 电源端子模块为正常操作方式.
ESB.6 | 电机左转 | 1bin | 电源端子模块Out2 输出： 1 x 16 位数据（1 x 8 位控制 / 状态可选）置位.
ESB.5 | 电机右转 | 1bin | 电源端子模块Out1 输出： 1 x 16 位数据（1 x 8 位控制 / 状态可选）置位.
ESB.4 | - | 0bin | 保留
ESB.3 | SW故障信息 | 1bin | 状态字中包含出错信息. 评估状态字!
ESB.2 | 过载电机停止 | 1bin | 电源端子已经切断电机，因为电流积分 (Data register DR7) 已经达到最大值. 当相开通保护已经发生，并且扩展控制字节 的电机控制位已经复位(ECB.5 和 ECB.6)时，该位将复位.
ESB.1 | 欠载 | 1bin | 相电流中，至少有一个值低于指定的欠载电流门槛值(参数 寄存器 PR38, PR44, PR50).
ESB.0 | 过载 | 1bin | 相电流中，至少有一个值高于指定的欠载电流门槛值(参数 寄存器PR37, PR43, PR49).


KL8001 - Parameter Registers (概述)

BECKHOFF: KL8001: 通过程序设置

参数寄存器(概述)

这些寄存器用于参数化电源端子模块. 它们可以通过 寄存器通信来读取或写入。

PR 无. | 注解 | 默认值 |  | R/W | 内存
PR0 | 保留 | - | - | - | -
... | ... | ... | ... | ... | ...
PR5 | 保留 | - | - | - | -
PR6 | 诊断寄存器 | - | - | R | RAM
PR7 | 指令寄存器 | 0x0000 | 0dec | - | -
PR8 | 端子模块类型 | 0x1F41 | 8001dec | R | ROM
PR9 | 固件版本 | 例如 0x3141 | 12609dec | R | ROM
PR10 | 多路移位寄存器 | 0x0230 / 0x0418 | 560dec / 1048dec | R | ROM
PR11 | 信号通道 | 0x0160 | 352dec | R | ROM
PR12 | 最小数据长度 | 0x6060 | 24672dec | R | ROM
PR13 | 数据结构 | 0x0007 | 7dec | R | ROM
PR14 | 保留 | - | - | - | -
PR15 | 对齐寄存器 | - | - | R/W | RAM
PR16 | 硬件版本 | 例如 0x0000 | 例如 0dec | R/W | Flash
PR17 | L1 电压增益补偿 | 例如 0x0B00 | 例如 2816dec | R/W | Flash
PR18 | L2 电压增益补偿 | 例如 0x0B00 | 例如 2816dec | R/W | Flash
PR19 | L3 电压增益补偿 | 例如 0x0B00 | 例如 2816dec | R/W | Flash
PR20 | L1 电流增益补偿 | 例如 0x3000 | 例如 12288dec | R/W | Flash
PR21 | L2 电流增益补偿 | 例如 0x3000 | 例如 12288dec | R/W | Flash
PR22 | L3 电流增益补偿 | 例如 0x3000 | 例如 12288dec | R/W | Flash
PR23 | 霍尔传感器灵敏度 | 0x1FE3 | 8163dec | R/W | Flash
PR24 | 保留 | - | - | - | -
... | ... | ... | ... | ... | ...
PR30 | 保留 | - | - | - | -
PR31 | 密码寄存器 | - | - | R/W | RAM
PR32 | 特征寄存器 | 0x0221 | 545dec | R/W | Flash
PR33 | 额定电流 L1 | 0x0000 | 0dec | R/W | Flash
PR34 | L1开通门槛值 | 0x0000 | 0dec | R/W | Flash
PR35 | L1过压门槛值 | 0x0DAC | 3500dec | R/W | Flash
PR36 | 欠压门槛值 | 0x0096 | 150dec | R/W | Flash
PR37 | L1过载门槛值 | 0x09C4 | 2500dec | R/W | Flash
PR38 | L1欠载门槛值 | 0x0000 | 0dec | R/W | Flash
PR39 | 额定电流 L2 | 0x0000 | 0dec | R/W | Flash
PR40 | L2开通门槛值 | 0x0000 | 0dec | R/W | Flash
PR41 | L2过压门槛值 | 0x0DAC | 3500dec | R/W | Flash
PR42 | L2欠压门槛值 | 0x0096 | 150dec | R/W | Flash
PR43 | L2过载门槛值 | 0x09C4 | 2500dec | R/W | Flash
PR44 | L2欠压门槛值 | 0x0000 | 0dec | R/W | Flash
PR45 | 额定电流 L3 | 0x0000 | 0dec | R/W | Flash
PR46 | L2欠压门槛值 | 0x0000 | 0dec | R/W | Flash
PR47 | L3过压门槛值 | 0x0DAC | 3500dec | R/W | Flash
PR48 | L3欠压门槛值 | 0x0096 | 150dec | R/W | Flash
PR49 | L3过载门槛值 | 0x09C4 | 2500dec | R/W | Flash
PR50 | L3欠压门槛值 | 0x0000 | 0dec | R/W | Flash
PR51 | 最大电流值 | 0x01F4 | 500dec | R/W | Flash
PR52 | 触发等级 | 0x000A | 10dec | R/W | Flash
PR53 | 测量周期 | 0x0032 | 50dec | R/W | Flash
PR54 | 保留 | - | - | - | -
... | ... | ... | ... | ... | ...
PR63 | 保留 | - | - | - | -

警告 端子寄存器值每次改变时，应执行断电复位（端子断电然后上电），以便更新的值能匹配测量单位!


KL8001 - Parameter Registers (描述)

BECKHOFF: KL8001: 通过程序设置

参数寄存器(描述)

这些寄存器是用于参数化电源端子模块端子模块. 它们可以通过 寄存器通信来读取或写入。

PR7: 指令寄存器

能够调用一个命令，您必须之前输入用户代码字0x1235到 寄存器R31 .

命令0x7000: 恢复出厂值

在寄存器R7中输入0x7000 恢复以下寄存器的出厂设置:

PR32: 545 (0x0221)
PR33: 0
PR34: 0
PR35: 3500
PR36: 150
PR37: 2500
PR38: 0
PR39: 0
PR40: 0
PR41: 3500
PR42: 150 		PR43: 2500
PR44: 0
PR45: 0
PR46: 0
PR47: 3500
PR48: 150
PR49: 2500
PR50: 0
PR51: 500
PR52: 10
PR53: 50
命令0x8000: 软件清零

在寄存器R7中输入0x8000启动一个完整的注册软件复位终端. 删除所有的内部变量. 内部电路（输出驱动程序）是最新初始化软件t.

危险 在一个软件重置接触器连接到功率终端版本. 确保你的系统状态允许这个和那个危害对人或机械已经被排除了!

PR8: 端子模块说明

寄存器R8包含十六进制的端子模块识别码: KL8001: 0x1F41 (8001dec)

PR9: 固件版本

寄存器 R9 包含十六进制的固件版本， 0x3141 (12609dec).

PR17, PR18, PR19: 电压增益补偿

此寄存器包含在生产时确定的补偿值，不能更改。

PR20, PR21, PR22: 电流增益补偿

此寄存器包含在生产时确定的补偿值，不能更改。

PR23: 桥臂传感器灵敏度

桥臂传感器的灵敏度在出厂时已调整，并具有直接的补偿值效果； 不能更改.

PR31: 密码寄存器

  • 如果你在向用户寄存器写入值之前没有在密码寄存器中输入用户密码(0x1235) ，那么这些值只能保存在RAM寄存器中而不是 EPROM 寄存器中，因此当端子模块重启时信息会丢失。
  • 如果你在向用户寄存器写入值之前在密码寄存器中输入了用户密码(0x1235) ，那么这些值会保存在RAM寄存器中同时也会保存在 EPROM 寄存器中，因此当端子模块重启时信息不会丢失。

重新启动将删除代码字.

PR32: 特征寄存器

KL8001的许多功能：能都通过特征寄存器激活或允许

连接到电源端子的三个单相电机可进行单相分析. 此时，过载电流值的检测可分别进行评估. 它表明如果错误条件发生在三相 L1、L2 或 L3 之一时，相应的接触器将被关断.

如果快速关断功能之一被激活并且相应的错误条件发生时，约 500 ms 后快速关断触发.

位 | 名称 | 值 | 描述 | 默认
PR32.15 | - | 0bin | 保留 | 0bin
PR32.14 | - | 0bin | 保留 | 0bin
PR32.13 | 欠载快速关断 | 1bin | 欠载激活并触发时快速关断 | 0bin
PR32.12 | 过载快速关断 | 1bin | 过载激活并触发时快速关断 | 0bin
PR32.11 | 欠压快速关断* | 1bin | 欠压激活并触发时快速关断 | 0bin
PR32.10 | 过压快速关断 | 1bin | 过压激活并触发时快速关断 | 0bin
PR32.9 | 相出错快速关断 | 1bin | 相激活并且事件发生时，快速关断 | 1bin
PR32.8 | 不对称负载快速关断 | 1bin | 如果负载的不对称激活时。快速关断 | 0bin
PR32.7 | - | 0bin | 保留 | 0bin
PR32.6 | - | 0bin | 保留 | 0bin
PR32.5 | enPermanent RotarySwitchEvaluation | 0bin | 旋转开关为手动调整的额定电流 是读入只有在权力复位. | 1bin
 |  | 1bin | 旋转开关为手动调整的额定电流是在正常操作期间读永久.
PR32.4 | DC电流测量 | 1bin | DC电流测量激活: 上升流高通滤波器关闭. | 0bin
PR32.3 | 单-相分析 | 0bin | 单-相分析未激活: 输入给 L1 相的值施加于所有三相. | 0bin
 |  | 1bin | 单-相分析激活: 相值均与各相相关的 register Data比较，并独立分析.
PR32.2 | 看门狗 | 0bin | 看门狗激活： 如果电源端子在 100ms 内没有从现场总线中接收到任何数据，看门狗将切断电机并停止数据传送. | 0bin
PR32.1 | 电机左转允许 | 1bin | 允许电机向左旋转启动，使用扩展控制字节. | 0bin
PR32.0 | 点击允许右转 | 1bin | 允许电机向右旋转启动，使用扩展控制字节. | 1bin

*) 电压测量的三个阶段,参照一个人工星点.

PR33, PR39, PR45: 额定电流

如果KL8001面板上用于设定额定电流的两个旋转开关都设定为零，则保存在寄存器 PR33,PR39 和 PR45 (分辨率为 0.1 A, 允许设定的范围为: 0.9 到9.9A)中的值用于过载监视. 这是很有用的

  • 如果不同的 额定电流：是按单相分析,如当三个不同的单相电机连接.
  • 如果你想使用扩展的设置范围从10.0至15一个,不能设置的旋转开关.

PR34, PR40, PR46: 开通门槛值

当电源端子因过载而关断电机后，再次开通之前，相开通保护被保持. 这个时间对应 触发等级. 换句话说，当触发等级为50时，电机只能在经过50秒后才能再次开通. 该时间可以用这个寄存器使其缩短，它在较大的触发等级循环时非常有用.

输入的值可以用下面的公式计算:

例子:

接通时间 = 10秒, 触发等级=50秒

(1 - 10 sec / 50 sec) x 65535 = 52428

输入的开通门槛值为0xCCCC (52428dec).

PR35: L1过压门槛值*

如果L1点的主电压超过了存储在寄存器PR35中的过压门槛值(分辩率 0.1V)，状态字中的位SW.7将置位 .
*) 三相电压测量值用Y型星接点作参考.

PR36: L1欠压门槛值*

如果L1点的主电压低于存储在寄存器 PR36 中的欠压门槛值(分辩率 0.1 V)，状态字中的位SW.4将被置位.
*) 三相电压测量值用Y型星接点作参考.

PR37: L1过载门槛值

如果L1相的电流超过了存储在寄存器 R37中的过载门槛值(分辩率0.01A)， 扩展状态字节节中的位 ESB.0将被置位过载指示灯将以5HZ的频率闪烁. 如果你在寄存器 PR37中设定的过载门槛值低于设定的额定电流，则电机可提前关断，以避免当超出额定负载时受到更严重的损坏.

PR38: L1欠载门槛值

如果L1相的电流低于存储在寄存器 PR38 中的欠载门槛值(分辩率 0.01 A)， 扩展状态字节中的位ESB.1将置位。过载指示灯将以2HZ的频率闪烁. 如果你在寄存器PR38中设定的欠载门槛值低于设定的额定负载，则电机可在相应的事件发生时关断，如轴断裂，以 避免受到更严重的损坏.

PR39

参考PR33.

PR40

参考PR34.

PR41: L2过压门槛值*

如果L2点的主电压超过了存储在寄存器PR41中的过压门槛值(分辩率 0.1 V)，状态字中的位SW.8将置位.
*) 三相电压测量值用Y型星接点作参考

PR42: L2电压最小值*

如果L2点的主电压低于存储在寄存器 PR42 中的欠压门槛值(分辩率 0.1 V)，状态字中的位SW.5将置位.
*) 三相电压测量值用 Y 型星接点作参考.

PR43: L2过载门槛值

如果L2相的电流超过了存储在寄存器 PR43中的过载门槛值(分辩率0.01 A)， 扩展状态字节中的位ESB.0将置位同时，过载指示灯LED以5Hz的频率闪烁. 如果你在寄存器 PR43中设定的过载门槛值低于设定的额定电流，则电机可提前关断，以避免当超出额定负载时受到更严重的损坏.

PR44: L2欠载门槛值

如果L2相的电流低于存储在寄存器 PR44中的欠载门槛值(分辩率0.01 A)， 扩展状态字节中的位 ESB.1将置位.同时，过载 LED将以2HZ的频率闪烁. 如果你在注册PR44设置值低于额定负载,已经确定,那么电机可以关闭的事件,例如,一个破碎的轴,以避免更严重的伤害.

PR45

参考PR33.

PR46

参考 PR34.

PR47: L3 过压门槛值*

如果L3点的主电压超过了存储在寄存器 PR47 中的过压门槛值(分辩率 0.1 V)，状态字中的位SW.9将置位.
*) 三相电压测量值用 Y 型星接点作参考.

PR48: L3 欠压门槛值*

如果L3点的主电压低于存储在寄存器 PR48 中的欠压门槛值(分辩率 0.1 V)，状态字中的位SW.6将置位.
*) 三相电压测量值用 Y 型星接点作参考.

PR49: L3过载门槛值

如果L3相的电流超过了存储在寄存器 PR49 中的过载门槛值(分辩率 0.01 A)， 扩展状态字节中的位 ESB.0将置位过载 LED将以5HZ的频率闪烁. 如果你在寄存器 PR49中设定的过载门槛值低于设定的额定电流，则电机可提前关断，以避免当超出额定负载时受到更严重的损坏.

PR50: L3欠载门槛值

如果L3相的电流低于存储在寄存器 PR50 中的欠载门槛值(分辩率 0.01 A)，扩张状态字节中的位 ESB.1将置位。同时，过载 LED将以2HZ的频率闪烁. 如果你在寄存器 PR50 中设定的欠载门槛值低于设定的额定负载，则电机可在相应的事件发生时关断，如轴断裂，以避免受到更严重的损坏.

PR51: 最大允许电流差

如果L3相的电流低于存储在寄存器 PR50 中的欠载门槛值(分辩率 0.01 A)，状态字中的位SW.0将置位。同时过载指示灯 LED 以 2Hz 的频率闪烁.

PR52: 触发等级

动作类设置时间延迟在发生过载(分辨率: 1 s). 值的设置对应的释放时间在秒(对于一个过剩电流,正是7.2倍额定电流的设置). 如果多余的电流超过额定电流的7.2倍,释放时间变得相对较短的,是延长如果当前是低于这个值.

例子:

触发等级= 10, 额定电流 = 4.0 A
如果多余的电流电流 is 28,8 A (4,0 A x 7,2), 允许时间变为10 s.

PR53: 测量周期

转换时间的A / D转换器将通过这个寄存器直接(分辨率为1毫秒).

警告 获得正确的测量结果,值小于30 ms不得设置!


寄存器通讯举例

下例中, 数据以字节编号。没有字对齐。

例子1： 通过读取端子模块的寄存器9（模块固件版本）。

输出数据
0字节: 控制状态 | 1字节: 数据输出1,高字节 | 字节2: 数据输出1,低字节
0x89 (1000 1001bin) | 0xXX | 0xXX

解释:

  • 位0.7 为1表示寄存器通讯。
  • 位0.6 为0表示读寄存器.
  • 位0.5到位0.0为寄存器号，00 1001bin表示寄存器 9.
  • 输出数据字 (Byte1 及 Byte 2) 在读过程没有意义。 如果在写寄存器的过程中需要对输出字写值。
输入数据(总线端子模块的应答)
字节0: 状态字节 | 字节1: 数据输入1,高字节 | 字节2: 数据输入1,低字节
0x89 | 0x33 | 0x41

解释:

  • 端子模块把控制字的内容写到状态字，作为命令相应。
  • 端子返回固件版本的ASCII码 0x3341，输入数据(字节1和字节2)。 需要转换为ASCII码：
    ASCII 码 0x33 表示 3
    ASCII 码 0x41 表示 A
    因此固件版本是 3A.

例子2： 写用户寄存器

说明 正常模式下除了寄存器31，都是写保护的。
为了关闭写保护，写入密码(0x1235) 到寄存器31。 写入其他值写保护又会起作用。
有些设置要在重启（断电上电）之后才会起作用。

I. 写密码 (0x1235) 到 寄存器31

输出数据
0字节: 控制字节 | 1字节: 数据输出1，高字节 | 2字节: 数据输出1,低字节
0xDF (1101 1111bin) | 0x12 | 0x35

解释:

  • 位 0.7 为1: 寄存器通讯激活
  • 位 0.6为1: 写入寄存器.
  • 位 0.5 to 位 0.0 显示值为 01 1111bin 则寄存器号为 31.
  • 输出数据字 (字节1和字节2) 包含密码 (0x1235) 关闭写保护。
输入数据 (总线端子模块的应答)
0字节: 状态字节 | 字节1: 数据输入1，高字节 | 字节2: 数据输入1,低字节
0x9F (1001 1111bin) | 0xXX | 0xXX

解释:

  • 状态字中只有 0.6这位与控制字不同。
  • 输入数据字(字节1和字节2) 在写过程没有意义。 即使有数据显示也不代表任何含义。

II. 读取寄存器 31 (检验保护码是否写入)

输出数据
字节0: 控制字节 | 字节1: 数据输出1，高字节 | 字节2: 数据输出1.低字节
0x9F (1001 1111bin) | 0xXX | 0xXX

解释:

  • 位0.7为1表示寄存器通讯。
  • 位0.6为0表示读寄存器.
  • 位 0.5 to 位 0.0 显示值为 01 1111bin 则寄存器号为 31.
  • 输出数据字 (Byte 1 及 Byte 2) 在读过程没有意义。
输入数据 (总线端子模块的应答)
字节0: 状态字节 | 字节1: 数据输入1，高字节 | 字节2: 数据输入1，低字节
0x9F (1001 1111bin) | 0x12 | 0x35

解释:

  • 端子模块把控制字的内容写到状态字，作为命令相应。
  • 终端返回的当前值码字寄存器在输入数据字(字节1和字节2).

III. 写到寄存器32(更改特征寄存器的内容)

输出数据
字节0: 控制字节 | 字节1: 数据输入1，高字节 | 字节2: 数据输入1，低字节
0x0F (1110 0000bin) | 0x00 | 0x02

解释:

  • 位0.7为1表示寄存器通讯。
  • 位0.6为1: 写到寄存器
  • 位 0.5 to 位 0.0 显示值为 10 0000bin 则寄存器号为 32.
  • 输出数据字 (字节1和字节2) 包含了特征寄存器的新的价值.
    注意 给的0x0002仅仅是一个例子!
    功能寄存器的位变化的属性,也有不同的涵义和终端,根据终端类型. 请检查的描述功能寄存器的终端类型(章节寄存器描述) about the meanings of the 位 in detail, before changing the values!
输入数据 (总线端子模块的应答)
字节0: 状态字节 | 字节1: 数据输入1，高字节 | 字节2: 数据输入1，低字节
0x0F (1010 0000bin) | 0xXX | 0xXX

解释:

  • 状态字中只有 0.6这位与控制字不同。
  • 输入数据字(字节1和字节2) 在写过程没有意义。 即使有数据显示也不代表任何含义。

IV. 读寄存器32(验证改变特征寄存器)

输出数据
字节0: 控制字节 | 字节1: 数据输出1，高字节 | 字节2: 数据输出1，低字节
0x0F (1010 0000bin) | 0xXX | 0xXX

解释:

  • 位0.7为1表示寄存器通讯。
  • 位0.6为0表示读寄存器.
  • 位 0.5 to 位 0.0 显示值为 10 0000bin 则寄存器号为 32.
  • 输出数据字 (Byte 1 及 Byte 2) 在读过程没有意义。
输入数据 (总线端子模块的应答)
字节0: 状态字节 | 字节1: 数据输入1，高字节 | 字节2: 数据输入1，低字节
0x0F (1010 0000bin) | 0x00 | 0x02

解释:

  • 端子模块把控制字的内容写到状态字，作为命令相应。
  • 终端返回当前值功能寄存器的输入数据字(字节1和字节2).

V. 写入寄存器31(使代码字返回)

输出数据
字节0: 控制字节 | 字节1: 数据输出1，高字节 | 字节 2: 数据输出1，低字节
0xDF (1101 1111bin) | 0x00 | 0x00

解释:

  • 位0.7为1表示寄存器通讯。
  • 位0.6为1: 写入寄存器.
  • 字节0.5到字节0.0显示值为011111.bin则寄存器号为 31.
  • 输出数据(字节1和字节2) 包含0x0000 再次激活写保护.
输入数据 (总线端子模块的应答)
字节0: 状态字节 | 字节1: 数据输入1，高字节 | 字节2: 数据输入1，低字节
0x9F (1001 1111bin) | 0xXX | 0xXX

解释:

  • 状态字中只有 0.6这位与控制字不同。
  • 输入数据字(字节1字节2) 在写过程没有意义。 即使有数据显示也不代表任何含义。


KL8001 - Data Registers

BECKHOFF: KL8001: 通过程序设置

数据寄存器

这些寄存器是用来存储测量值. 这些仅可以读过程数据模式, 但是不可写.

三组寄存器大体上分配给主回路，但有些扩展也包括通用测量.

KL8001数据寄存器
DR 无. | 寄存器0 (Access 通过数据输入0) |  | 寄存器1 (Access 通过数据输入1) |  | 寄存器2 (Access 通过数据输入2)
 | 内容 | 单位 | 内容 | 单位 | 内容 | 单位
DR0 | 状态字 (1) | - | 状态字 (1) | - | 状态字 (1) | -
DR1 | 电流有效值 (L1, L2 及 L3平均值) | 0.01 A | 电压有效值 （L1, L2 及 L3平均值) | 0.1,1 V | 有功功率 (L1, L2 及 L3之和) | 1 W
DR2 | 电流L1峰值(2)(KL8001开通后) | 0.01 A | 电流L2峰值(2) (KL8001开通后) | 0.01 A | 电流L3峰值(2)(KL8001开通后) | 0.01 A
DR3 | L1电流有效值 | 0.01 A | L2电流有效值 | 0.01 A | L3电流有效值 | 0.01 A
DR4 | L1电压有效值 | 0.1,1 V | L2电压有效值 | 0.1,1 V | L3电压有效值 | 0.1,1 V
DR5 | 有功功率 L1 | 1 W | 有功功率 L2 | 1 W | 有功功率 L3 | 1 W
DR6 | L1有效功率 | 0.01 | L2有效功率 | 0.01 | L3有效功率 | 0.01
DR7 | L1电机负载(L1-L2-L3) | 1 A2 sec | L2电机负载 | 1 A2 sec | L3电机负载 | 1 A2 sec
DR8 | 电能消耗(3) L1 | 1 kWh | 电能消耗(3) L2 | 1 kWh | 电能消耗(3) L3 | 1 kWh
DR9 | 电能消耗 (sum of 3 phases) | 1 kWh | L1，L2，L3的最大电流差 | 0.01 A | 功率因数（L1，L2，L3的平均值） | 0.01
DR10 | 旋转开关侧设置的额定电流 | 0.01 A | 开关周期计数 | 1 | 电机工作小时计数(4) | 0.5 h
DR11- DR17 | 保留 | - | 保留 | - | 保留 | -
DR18- DR36 | 内部寄存器 | - | 内部寄存器 | - | 内部寄存器 | -
DR37 | 软件版测量单位 (例如.: 0x3343 = 5167dez =3CASCII) | - | 软件版测量单位 (例如.: 0x3343 = 5167dez =3CASCII) | - | 软件版测量单位 (例如.: 0x3343 = 5167dez =3CASCII) |
DR38- DR63 | 内部寄存器 | - | 内部寄存器 | - | 内部寄存器 | -

(1) 状态字可以从三个寄存器组中之一读出. 它包括所有三相通道的状态信息.
(2)存储的电流值随时都可用扩展控制字节位0将其复位 .
(3)能量消耗每隔半小时存储于该寄存器中，即使KL8001掉电时，其数据也被保持.
(4) 工作小时每隔半小时存储于该寄存器中，即使KL8001掉电时，其数据也被保持.

读数据寄存器

当在过程数据方式时，如果在相关 控制字节中输入数据寄存器的寄存器号, 其内容将在相应的数据Word中返回.

数据寄存器分配
寄存器组 | 相关的控制字节 | 相关的过程数
0 | 控制字节0 | 数据输入0
1 | 控制字节1 | 数据输入1
2 | 控制字节2 | 数据输入2

示例

读L1相的有功功率:
  • 输入数据寄存号5到控制字节 0.
  • 寄存器1组中的DR5寄存器内容返回到过程数据字数据输入0.
读L2相的能量消耗:
  • 输入数据寄存号8到控制字节 1.
  • 寄存器2组中的DR8寄存器内容返回到过程数据字数据输入1.
读L3的功率因数:
  • 输入数据寄存号6到控制字节 2.
  • 寄存器3组中的DR6寄存器内容返回到过程数据字数据输入2.


KL8001 - 状态字

BECKHOFF: KL8001: 通过程序设置

状态字

状态字中包含很多的有关 KL8001 的状态信息. 在过程数据模式, it can be transmitted from the 端子模块 to the 控制器 using any of the DataIN0, DataIN1 or DataIN2 输入： words.

状态字
位 SW.15 SW.14 SW.13 SW.12 SW.11 SW.10 SW.9 SW.8 SW.7 SW.6 SW.5 SW.4 SW.3 SW.2 SW.1 SW.0
重点
位 | Name | Value | 描述
SW.15 | 其它错误 | 1bin | 其他故障已经发生
SW.14 无额定电流设置 1bin

两个旋转开关及

  • 寄存器PR33为0(single-phase analysis没有被激活) or
  • 至少一个寄存器PR33, PR39 or PR45为0(单项分析激活)
SW.13 | 接触故障 | 1bin | 带接触器关断的电流大小检测
SW.12 保留 - -
SW.11 保留 - -
SW.10 保留 - -
SW.9 | L3过压 | 1bin | 电压 >组态的过压限幅(PR47)
SW.8 | L2过压 | 1bin | 电压 > 组态的过压限幅(PR41)
SW.7 | L1过压 | 1bin | 电压 >组态的过压限幅(PR35)
SW.6 | 欠压 L3 | 1bin | 电压 <组态的欠压限幅(PR48)
SW.5 | 欠压 L2 | 1bin | 电压 <组态的欠压限幅(PR42)
SW.4 | 欠压 L1 | 1bin | 电压 <组态的欠压限幅(PR36)
SW.3 | L3相故障 | 1bin | L3相故障
SW.2 | L2相故障 | 1bin | L2相故障
SW.1 | L1相故障 | 1bin | L1相故障
SW.0 非对称负载： 1bin 电流差>组态的电流差(PR51)


KL8001 - TwinCAT

BECKHOFF: KL8001: 通过程序设置

TwinCAT

  1. 启动， TwinCAT 系统管理器.
  2. 使用鼠标右键在I/O 组态 \ I/O devices分支启动搜索新的设备.
    或插入你的现场总线卡(设备)和总线耦合器(箱)手动.
  3. 用鼠标右键单击在总线耦合器在树结构,并添加所需的巴士站的Insert 端子模块菜单项.

添加电源端子模块

KL8001可以在电机启动器端子模块 (KL800x)中找到. 你最多可以添加10个电源端子，最后为适配器末端子块 KL9060 .

The KL8001的树型架构

TKL8001 在系统管理器中表示为 10 字节的输入数据和 10 字节的输出数据. 空的词(参考过程映像)存在于总线耦合器映射,但是不是,然而,显示的系统管理器.

Beckhoff 信息系统

进一步的信息在配置与TwinCAT系统经理和TwinCAT编程PLC控制可能会发现在Beckhoff信息系统. Beckhoff 信息系统是不断发展壮大的 Beckhoff 产品参考资源。 它包含了技术资料,手册,示例代码,Beckhoff知识库和更多.

Beckhoff信息系统的安装软件可在Beckhoff CD 产品 和 解决方案： 在我们的官网上下载 http://www.beckhoff.com. 此外在线版本的Beckhoff信息系统可能会发现在http://tcinfosys.beckhoff:.com.


KL8001 - 订货信息

BECKHOFF: KL8001: 附录

订货信息

Beckhoff

电源端子模块
订单号 | 包含组件
KL8001 | 1 x 电源端子模块用于控制Sirius 3RT10系列（S00）接触器 1 x short (大约. 3 cm)扁平电缆用于连接总线和电源端子
电源端子模块附件
订单号 | 包含组件
KL9060 | 1 x 适配器端子用于连接电源端子到BECKHOFF总线端子块 1 x long (大约. 10 cm) 扁平电缆用于适配器端子和第一个电源端子间的总线连接 1 x总线末端插销用于最后一个电源端子
ZS1010-1610 | 1 x bus end 插头
ZK1010-8080-3003 | 1 x短的(大约. 3 cm)扁平电缆用于两个电源端子间的总线连接
ZK1010-8080-3005 | 1 x中等(大约. 5 cm)扁平电缆：电缆 for the总线接口 between two 电机启动器端子模块for将接触器连接反转
ZK1010-8080-3010 | 1 x long (大约. 10 cm) 扁平电缆用于总线连接，在适配器端子和第一个电源端子或两个电源端子用于接触器反向连接
KS2000 | 1 x 配置软件 1 x 串行组态电缆用于Beckhoff总线耦合器

西门子

西门子接触器Sirius 3RT10系列
订货号 | 产品 | 电源部分 | 联系方式 | 尺寸 | 接线
3RT1015-1BB41 | 接触器, AC-3 | 3 kW, 400 V ：, 3-针脚 | 1 常开触点, 24VDC | S00 | 螺钉接线
3RT1016-1BB41 | 接触器, AC-3 | 4 kW, 400 V ：, 3-针脚 | 1 常开触点, 24VDC | S00 | 螺钉接线
3RT1017-1BB41 | 接触器, AC-3 | 5.5 kW, 400 V ：, 3-针脚 | 1 常开触点, 24VDC | S00 | 螺钉接线
3RT1015-1BB42 | 接触器, AC-3 | 3 kW, 400 V ：, 3-针脚 | 1 常开触点, 24VDC | S00 | 螺钉接线
3RT1016-1BB42 | 接触器, AC-3 | 4 kW, 400 V ：, 3-针脚 | 1 常开触点, 24VDC | S00 | 螺钉接线
3RT1017-1BB42 | 接触器, AC-3 | 5.5 kW, 400 V ：, 3-针脚 | 1 常开触点, 24VDC | S00 | 螺钉接线
西门子Sirius 3RT10系列接触器附件
订货号 | 描述
3RA1913-2A | 反向连接设备工具


技术支持与售后

BECKHOFF 自动化: 附录

技术支持

Beckhof f 及其合作伙伴遍布世界各地，可为您提供全方位的技术支持与服务，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff 分公司及代表处

有关 Beckhoff 产品的本地技术支持和服务信息，请联系当地的 Beckhoff 分公司和代表处！

有关 Beckhoff 在全球各地分公司和代理商的地址，您可以登录Beckhoff 的官方网站：
http://www.beckhoff.com

此外，您也可以在该网站上查看更多关于 Beckhoff 组件的文档资料。

Beckhoff 总部

德国倍福自动化有限公司

Eiserstr. 5
33415 Verl
德国

电话 | +49(0)5246/963-0
传真： | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff 技术支持

Beckhoff为您提供全面的技术支持，除了Beckhoff 具体产品的应用以外，还包括更广泛的服务：

  • 技术支持
  • 复杂自动化系统的设计、编程和调试
  • 各种 Beckhoff 系统组件培训方案
热线： | +49(0)5246/963-157
传真： | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心提供全方位的售后技术服务:

  • 现场服务
  • 维修服务
  • 零部件服务
  • 热线服务
热线： | +49(0)5246/963-460
传真： | +49(0)5246/963-479
e-mail: | service@beckhoff.com