KL2751, KS2751, KL2761, KS2761 - Single channel universal dimmer terminals

BECKHOFF Fieldbus Components

KL2751, KS2751, KL2761 和KS2761相关文档

单通道通用调光器端子模块

2.4.0版本
日期: 2009-10-21


KL2751, KL2761 - Documentation issue status

BECKHOFF KL2751, KL2761: Foreword

文件出版情况

版本

注释

2.4.0
  • 添加了KS2751 和 KS2761模块
  • 对操作说明进行了补充
  • 对基本功能原理进行了更新

2.3.0
  • 补充了对寄存器的说明和 KS2000 配置软件的说明
  • 更新了技术数据
  • 对操作说明进行了补充

2.2.0
  • 添加KL2751-0011和KL2761-0011的说明
  • 更新了产品概述的内容
  • 添加了KL2751-0011和KL2761-0011 的应用案例
  • 对操作说明进行了补充

2.1.0
  • 添加操作说明的内容

2.0.0
  • 添加了对KL2761-0000 的描述
  • 添加了TWINCAT功能块 FB_Dimmer1SwitchEco

1.2.0
  • 更新寄存器的说明
  • 更新了KS2000 的配置软件
  • 增加了过度工作的内容

1.1.0
  • 添加了对KL2751-1200 的说明
  • 更新了寄存器的说明
  • 更新了KS2000 的配置软件
  • 更新了进程数据的说明

1.0.0
  • 增加了对KS2000 配置软件的说明
  • 对基本功能原理的校验
  • 可用的英语版本

0.1

最初版本

公司及硬件版本

文档版本 | KL2751-0000 |  | KL2751-0011 |  | KL2751-1200 |  | KL2761-0000 |  | KL2761-0011
 | 固件版本 | 硬件版本 | 固件版本 | 硬件版 | 固件版本 | 硬件版 | 固件版本 | 硬件版 | 固件版本 | 硬件版
2.4.0 | 2F | 03 | 2F | 03 | 2F | 03 | 1F | 02 | 1F | 02
2.3.0 | 2E | 01 | 2E | 01 | 2E | 01 | 1E | 00 | 1E | 00
2.2.0 | 2B | 01 | 2B | 01 | 2B | 01 | 1B | 00 | 1B | 00
2.1.0 | 2A | 01 | - | - | 2A | 01 | 1A | 00 | - | -
2.0.0 | 2A | 01 |  |  | 2A | 01 | 1A | 00
1.2.0 | 2A | 01 |  |  | 2A | 01 | - | -
1.1.0 | 1C | 00 |  |  | 1C | 00
1.0.0 | 1A | 00 |  |  | - | -
0.1 | 1A | 00

固件和硬件版本(交货状态)中都能在终端设备边缘处找到序列号

序列号的语法

结构编号: WW YY FF HH

WW - 生产周数
YY - 生产年份
FF - 固件版本
HH - 硬件版本

例如.: 38 06 1C 00:

38 - 生产39周
06 - 生产年份2006
1C - 固件版本 1C
00 - 硬件版本 00


KL2751 - Introduction

BECKHOFF KL2751: Product overview

Introduction

调光器总线端子KL2751专为直接连接电阻式,电感式和电容性质的交流灯而设计,灯源的额定负载为300伏安(瓦). 能对诸如白炽灯,电感,电子镇流器等典型照明设备以正确的方式进行检测与控制.KL2751通过正确计算给定的过程数据调节前沿或者后缘的正确相位角值从而控制光的强度.输出端具有短路保护和过载保护功能。

KL2751-0011不带电源触点(见接线图的右侧),此类型无需使用230V的特殊供电模块.


KL2761 - Introduction

BECKHOFF KL2761: Product overview

Introduction

调光器总线端子KL2761专为直接连接电阻式,电感式和电容性质的交流灯而设计,灯源的额定负载为600伏安(瓦). 能对诸如白炽灯,电感,电子镇流器等典型照明设备以正确的方式进行检测与控制.KL2761通过正确计算给定的过程数据调节前沿或者后缘的正确相位角值从而控制光的强度.输出端具有短路保护和过载保护功能。负载状态是可读的.

KL2761-0011不带电源源触点(见 连线图的右侧), 此类型无需使用230V的特殊供电模块.


KL2751, KL2761 - Technical data

BECKHOFF KL2751, KL2761: Product overview

技术参数

技术参数 | KL2751-0000, KS2751-0000, KL2751-0011, KS2751-0011 | KL2751-1200, KS2751-1200 | KL2761-0000, KS2761-0000, KL2761-0011, KS2761-0011
主电压 | 230 VAC | 120 VAC | 230 VAC
额定功率* | 300 VA (W), 最大 1.35 A | 300 VA (W), 最大. 2.5 A | 600 VA (W), 最大. 2.7 A
允许负载类型 | 电感(只有变压器,没有镇流器的荧光灯) 电容式或电阻式负载. 不支持电机负载! 电感和电容式不能混用! 自动负载检测.
线长 | 最大值. 调光器接线端及灯之间的距离:100 M
控制类型 | 前沿 相位控制,后缘 相位控制, 整流器控制 （+-50%的前沿相位控制）
分辨率 | 最大值. 7 Bit
泄漏电流(OFF状态) | < 2 毫安
电气隔离 | 500 Vrms (K-Bus / field voltage), 3750 VAC (1 min.)
供电 | 经由K-Bus
K-Bus电流消耗 | 通常情况下 65 mA
在输入过程中映像位宽 | 1 x 16 bit data, 1 x 8 bit Status
在输出过程中映像位宽 | 1 x 16 bit data, 1 x 8 bit Control
配置 | 经由总线耦合器或 总线控制器
重量 | 60g
工作温度允许范围 | 0°C ... + 55°C
储藏温度允许范围 | -25°C ... + 85°C
允许相对湿度 | 95%, 无冷凝现象
尺寸 (w x h x d) | 15mm x 100mm x 70mm (aligned width: 12mm)
安装 | 安装在 35毫米安装导轨上,符合EN 50022标准
耐振动/冲击 | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC/ ESD | 符合 to EN 61000-6-2 / EN 61000-6-4
防护等级 | IP 20
安装位置 | 不固定
认证 | CE

*) 额定功率=灯功率+控制机构功率损耗

通常控制机构功率损耗如下:

  • 电子控制机构损失5%的额定功率
  • 感应控制电路损失20%的变压器额定感应功率


KL2751, KL2761 - LED displays

BECKHOFF KL2751, KL2761: Product overview

LED 显示

LED

Display

K-Bus run (green)

off

K-Bus 上无数据传送

on

K-Bus 数据传送激活

Net (green)

off
  • 端子无法与电源同步*
  • 自动负载检测下负载种类无法被检验*

on
  • 端子与电源同步*
  • 负载类型检测

ON (green)

off

过程数据为零

on

过程数据不为零

Error (red)

on

表示负载侧短路

*) 如果连接负载,那么终端即可与电源同步.

WARNING

触电危险!

同步LED关断时，在kl2751的输出端仍然存在电路主电压.
此时自动负载检测及同步尚未完成.
自动负载检测显示

负载检测后(电源电压接通后不久)端子通过以下两种情况指示负载类型：

  • LED以绿红顺序显示: 表示对电阻电容负载的后缘控制
  • LED以红绿顺序显示: 表示对电感负载的前沿控制


ELxxxx, KLxxxx - Installation on mounting rails

BECKHOFF Fieldbus Components: Mounting and wiring

安装及配线方法

警告

防止触电!

请在处于安全,电源关闭的情况下进行安装或拆除本总线端子模块.

装配

只要用很小的力就可以把总线耦合器和总线控制安装在通用的35mmC形导轨上：

1. 首先把总线耦合器安装在导轨上。

2. 总线端子安装在总线耦合器的右边。 端子与耦合器以及端子与端子之间通过槽扣方式连接, 紧贴着扣槽把端子卡在导轨上，卡上后会发出咔的响声。如果安装在导轨上的端子槽扣没有扣在一起K总线将不会导通！安装正确的话连接处是没有缝隙的。

在安装总线端子的时候，注意不要让端子碰到固定导轨的螺丝。

拆卸

端子依靠卡锁固定在导轨上，在拆卸端子的时候要释放卡锁:

1. 小心地把橙色的拉杆拉出大约 1cm，底部的卡锁就会释放，不需要很大的力就可以把端子从导轨分离。

2. 用拇指和食指抓住模块的上部和下部的外壳向外拉，把模块彻底从导轨上拆下来。

总线端子的连接

总线耦合器和端子之间的电气连接在安装模块的时候自动完成：

  • 六个K总线弹簧连接片传输总线端子的数据和电源。
  • 现场电子组件的电源供电通过电源触点完成，插在一起的电源触点形成了一个电源链。总线耦合器提供电源触点。

Note

Power Contacts

由于一些总线端子(例如 模拟量总线端子或4-通道数字总线端子) 都没有通过这些电源触点形成回路，必须考虑总线端子的分配。电源供电端子 (KL91xx, KL92xx) 提供电源触点，并代表一个新的电源链的开始。

PE 连接

标有“PE” 标签的电源触点用于对地保护。出于安全的原因这些点应首先插接在一起，它最多可承担 125A 的对地短路电流。

Attention

Possible damage of the device

需要注意的是，出于电磁兼容性方面的考虑，PE 触点与安装导轨之间为电容偶合特性。在绝缘测试期间可能产生错误结果或毁坏端子(如：在设备230 V绝缘测试的时候造成对地击穿)。

绝缘测试时，总线控制器和电源端子的PE端必须断开。为了断开更多的反馈点进行测试，这些供电端子必须拉出来 10mm。

WARNING

Risk of electric shock!

PE的电源连接不能用于其它电位。

接线

端子最多有8个点可用粗线或细线连接，端子连接采用弹簧连接技术：

1. 把起子插入端子上面的方孔撬开弹簧端子。

2. 电线可以很容易的插入端子上的圆孔内。

3. 拔出起子当压力释放时，端子会自动关闭，并且安全而牢固的卡住连线。

Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm

Note

Shielding

模拟传感器应与双绞线相连接.


KL2751, KL2761 - Connection

BECKHOFF KL2751, KL2761: Mounting and wiring

Connection

WARNING

触电危险!

请在端子未通电时安装,防止触电!

Terminal point | No | KL2751-0000, KL2751-1200, KL2761-0000, connection for | KL2751-0011, KL2761-0011, connection for
Output | 1 | 负载(和端口5的内部连接) | 负载(和i端口5的内部链接)
L1 | 2 | 相位 (和端口6内部连接和电源L1接口连接) | 相位(i和端口6的内部链接)
N | 3 | 中性导体(和端口7的内部连接和电源接口N连接) | 中性导体(和端口7的内部连接)
PE | 4 | 保护导体 (和端口8的内部连接以及PE电源点的连接 | 保护导体(和内部端口8的连接)
Output | 5 | 负载 (和内部端口1的连接) | 负载(和内部端口1的连接)
L1 | 6 | 相位 (和内部端口8的连接以及电源点L1的连接) | 相位(和内部端口2的连接)
N | 7 | 中性导体 (和内部端口3的连接以及电源点N的连接) | 中性导体 (和内部端口3的连接)
PE | 8 | 保护导体(和内部端口4的连接以及电源点PE的连接) | 保护导体 (和内部端口4的连接)

端子供电

通常使用230 VAC / 120 VAC对端子供电并连接电源 (e.g.: KL9150, KL9160, KL9250, KL9260)!

Attention

设备风险!

总线耦合器,总线端子控制器以及供电端子不可连接火线进行通电!
它们只可使用24 V电压,如果接通 230 VAC / 120 VAC将会烧坏!

多个调光模块可以由同一个供电模块供电..

Note

分离端子

如果被一个总线端子排中同时用到24 V 和 230 VAC / 120 VAC，那么可以使用KL9080隔离模块将不同电势相互隔离。

短路限流

调光具有短路限流功能,短路时电流可以限定在大约10~15 A. 通常这也可以防止保险丝烧断。

短路电流会在0.5 ms时间内自动切断, KL2751检测到短路后会尝试再次启动系统并测试火线电压. 一旦确认短路故障已排除，调光模块会继续以之前的调光值工作。

对于火线短路要慎重，尽量避免！短路会导致调光模块的部分元器件损坏,经常短路会 降低模块的使用寿命!

保险丝

调光模块可以采用10A的保险丝。
调光端子能够自我短路保护以及过载保护,一旦在调光模块和负载间发生短路就会自动触发短路保护。.

Attention

可能危害设备!

过载保护是必须的,变压器的保险丝通常不允许被桥接或者改变,否则会导致变压器过热.


KL2751, KL2761 - Notes about operation - Appropriate use

BECKHOFF KL2751, KL2761: Mounting and wiring

Notes about operation - Appropriate use

Supply

主电源

Attention

无上游变压器!

调光端子模块KL2751 und KL2761在无上游变压器的情况下直接操作.

在供应端过度感应会导致调光端子短路!
自动负载检测在上游变压器存在的情况下不可靠.

供电端子

通常使用230 VAC / 120 VAC 的供电端子(e.g.: KL9150, KL9160, KL9250, KL9260)作为输入电压接触.
KL2751-0000, KL2751-1200, KL2761-0000,
KS2751-0000, KS2751-1200, KS2761-0000!

见例子KL2751-0000.

无需供电端子主电压提供只允许在无电连接下的供电端子使用.例如
KL2751-0011, KL2761-0011, KS2751-0011, KS2761-0011!
见例子 KL2751-0011.

主电源断开最小要求

调光端子的断开时间是不得少于3秒(切断或者断路等等)的!
断开时间越短,调光不会失去网络同步以及短时间进入错误调光模式.
在损坏的变压器上进行操作会使调光端子损坏.

广播脉冲控制

Note

广播控制脉冲存在的问题

主电源的外部过滤器控制脉冲能够使得亮度出现起伏.高幅的广播控制脉冲能够对调光端子进行断路侦测.因此调光端子可以关闭或再次打开负载. 此光源转换需要一段时间.
可以使用调光终端所提供的音频滤波器来避免这种情况。

可允许负载

Attention

无电机!

使用调光端子模块只能用于电灯负载,电机负载会损坏端子.
请确认调光端子的输出端所适合的负载类型.

如要使用电机负载请使用FKL2791 (独立电机调速模块)

请勿混合使用容性及感性负载！

容性负载以及感性负载不可在端子中混合使用!
例如,电子镇流器以及变压器不允许被接在同一个端子模块上.

一个电阻负载可以与容性或感性负载一起使用.

无额外开关！

请勿接任何额外开关在:

  • 调光端子以及负载间
  • 调光器以及控制设备间
  • 控制设备以及电灯(照明设备)

操作模式

Attention

请确保操作正确!

每一个负载类型都有一个专门的操作模式:

  • 容性负载必须在上升沿进行控制.
  • 感性负载必须在下降沿进行控制.

只有电气控制设备制造商允许对电容性负载进行上升沿控制以及对电感性负载进行下降沿控制.

如果伏在运行出现错误,回应器端子或者负载的损坏
通常是控制设备输入电容过热T所引起的.

此外为特殊应用(e.g. 混合,震荡传送带.) 操作模式下整流器的开和关都是可以的.

自动负载检测

大线长度

Note

大线长度

调光器端子和负载调光器模块手工预选器之间的大线长度的是要注意的. 因为电容和电感的影响可能导致负载的误解所以自动负载检测可能会失败.

请注意线的最大长度！
用户程序

Note

参数化的调光器端子控制(PLC)

如果你不使用默认值来调控调光端子的值, 建议在启动PLC时初始化用户程序，然后使用不同的值以便能够节省更换端子时复杂的初始化过程中个人手动服务以避免错误的数据.

无次级负载的损坏变压器

Attention

无空转变压器!

当主电源开启失败时,端子可自动检测连接负载种类,如果无次级负载的变压器已经连接.当主电源开启时则确保调光端子不操作电机空转!i
注意当更换次级连接负载为照明设备的时候.

Gentle operation of low voltage illuminants

Note

低电压高功率光源

低压光源的操作使用高功率(如卤钨灯12 V, 100 W, GY6,35 通过控制设备*)设置比 默认值为500ms更高的调光跳转时间。由于这些光源的纤维需要更厚的低功耗灯,并且性质不活泼,无法长时间承受高电流,因此导致灯泡过快衰老.采用平滑调光方式可以延缓其老化。
*) 此控制设备能够被放置于调光端子及卤钨灯之间 (见mains power supply)!


KL2751, KL2761 - Application examples - overview

BECKHOFF KL2751, KL2761: Application examples

应用实例 - 概述

  • KL2751-0000, KL2761-0000: 带电源触点的调光模块
  • KL2751-0011, KL2761-0011: 不带电源触点的调光模块
  • 功能块 FB_Dimmer1SwitchEco


KL2751-0000, KL2761-0000 - Application example

BECKHOFF KL2751-0000, KL2761-0000: Application examples

应用实例

警告 		当心触电!
请在总线终端处于安全,主电源断电的情况下进行安装和接线!

供电端子模块

通常采用230VAC/120VAC供电端子模块对电源触点供电 (e.g.: KL9150, KL9160, KL9250, KL9260)!

注意 		当心损坏设备!
24v总线耦合器,总线终端控制器和供电端子不可与火线相连.
它们只适用于24v电压,在30 VAC / 120 VAC 条件下会导致模块损坏.

本实例说明了以KL2751控制的白炽灯,通过KL9160端子模块给电源触提供(230 VAC) 电源.

多个调光模块可以共用一个供电模块。.


KL2751-0011, KL2761-0011 - Application example

BECKHOFF KL2751-0011, KL2761-0011: Application examples

应用实例

警告 		当心触电!
请在总线终端处于安全,主电源断电的情况下进行安装和接线!

不使用供电端子模块供电

注意 		当心损坏设备!
无需采用供电模块，不带电源触点的调光模块:
KL2751-0011, KL2761-0011,
KS2751-0011, KS2761-0011

本实例说明了以KL2751-0011控制的白炽灯,(230 VAC) 主电源直接连接到KL2751-0011.


KL2751, KL2761 - KS2000 Register

BECKHOFF KL2751, KL2761: KS2000 Configuration Software

寄存器

您可以在Register下直接访问调光端子的寄存器.寄存器的内容在register overview中说明.

下方的图片为KL2751的寄存器.


KL2751, KL2761 - KS2000 settings

BECKHOFF KL2751, KL2761: KS2000 Configuration Software

设置

点击settings就会出现KL2751/KL2761参数设置对话框.

操作模式

Watchdog timer active (R32.2)

在这里你可以关闭你的看门狗(默认:启动).

User scaling active (R32.0

在这里你可以激活User scaling (默认: 关闭).

Dim ramp absolute (R32.3

在这里您可以将调光斜坡从相对模式间(默认)改为到绝对模式.

  • 在相对的调光斜坡模式中, 可设置调光的斜坡时间来使光强从0～100%变化
  • 在绝对的调光斜坡模式中, 可设置调光斜坡时间来直接改变光的强度.

Note

绝对调光斜坡模式

下面例子为两个调光模块使用绝对调光斜坡模式同步驱动两个负载灯

例:
1#灯10%的亮度，2#灯 30%的亮度.
现在 1#调光端子调节1#灯 ， 2#调光端子调节2#灯，两灯同时为50%亮度.
用绝对调光斜坡模式设置可以使两灯同时达到50%的亮度.

寄存器值

User offset(R33)

你可以在user-scaling设定偏移量(默认值是0)。

User gain(R34)

在这里你可以指定user-scaling的增益(默认是:1)。

Ramp time (R35)

在这里你可以选择斜坡时间(默认500 ms)。

允许的时间:50ms,100 ms,200 ms,500 ms,1 s,2s,5s,10s.

Timeout (R36)

在这里你可以设定总线检查错误的超时时间(默认:100 ms)。

Light value for timeout (on)(R37)

设置当发生超时时负载灯启动时的亮度。(默认值：50%)

Light value for timeout (off) (R38)

设置当发生超时时负载灯关闭的亮度(默认值：0％)。

Dimmer mode (R39)

在这里你可以指定调光模式:

  • 自动负载检测*: 调光端子可以自动检测负载类型(电容/电阻或者电感)并且自动切换前沿控制或者后缘控制(默认值)
  • 后缘控制: 用于电容性负载(镇流器)或者电阻式负载(灯泡)
  • 前沿控制:通常为感性负载(变压器)
  • 整流器的正半曲线模式:只有当正半波通过负载时可以用前沿控制.
    请勿在用KL2751的 firmware version 2E以及KL2761的firmware version 1E 时使用此调光模式!
    需要用整流负半曲线控制模式代替！
  • 整流器的负半曲线模式: 只有负半波通过负载时可以使用后缘控制.

Note

*) 自动检测和最大连线长度

在调光模块和负载间使用较长连线时推荐使用该模式。

由于电感和电容线的影响可能会导致负载出错，自动负载检测可能会失败。
Bypass behavior (R40)

在短路后你可以在负载输出端对调光端子进行调节。

调光端子具有短路限流功能，电流限制在10～15A，可以防止保险丝熔断，短路限流可在0.5ms内生效，并自动重启。

  • 关闭:
    用户须在短路后重新启动系统.
  • 再次启动( 默认):
     在短路被检测出来后调光端子会设法重新启动系统并且会通过较低电压对火线进行检测.如果进行了短路操作,调光端子还是会维持先前的调光值.
行频率 (R41)

在这里您可以设置调光端子的行频率,默认值:
50 Hz (KL2751-0000, KL2761-0000)
60 Hz (KL2751-1200)


KS2000 - Process Data

BECKHOFF Fieldbus Components: KS2000 Configuration Software

过程数据

状态字(State), 控制字(Ctrl)以及过程数据(Data)会像树结构一样显示在ProcData下.

以眼镜标志的数据会在History框中图形化显示。

当前值会以数值形式显示在 Value 中

初始值可以进行修改,通过直接输入或者通过滑块进行修改.

注意

对个人、环境 、材料危害!

注意改变初始值(强迫修改)会直接影响设备的正常运行.
 只有在设备条件允许和对人和机器没有危害的情况下才能修改这些初始值,

在按"Settings "按钮之后,你可以设定十六进制，十进制，二进制的显示格式(数值型):


KL2751, KL2761 - Process Image

BECKHOFF KL2751, KL2761: Access from the user programm

过程映像

在复杂型过程映像中, KL2751和KL2761有三字节的输入数据和三字节的输出.数据如下表所示:

字节偏移(无字对齐) | 字节偏移(带字对齐) | 格式 | 输入数据 | 输出数据
0 | 0 | byte | SB | CB
1 | 2 | word | DataIN | DataOUT

在紧凑型过程映像,KL2751和KL2761只有两字节的输出数据没有输入字节.这些组织如下:

字节偏移(无字对齐) | 字节偏移(带字对齐) | 格式 | 输入数据 | 输出数据
0 | 0 | word | - | DataOUT

*) 字对齐:总线耦合器把值放到偶数字节地址上

Key

SB: Status Byte
CB: Control Byte
DataIN: input word
DataOUT: output word下

在过程数据模式下，输出数据DataOUT控制调光端子的输出功率,有效值从 0dec 到 32767dec.


KL2751 - Control and Status Bytes

BECKHOFF KL2751: Access from the user program

KL2751控制和状态字

过程数据模式

目前,在过程数据模式中还没有控制和状态字的功能.

寄存器通信

控制字(寄存器通信)

控制字节(CB)是基于输出映像上的.,并且是由控制器传送至端子上的.

Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.3 | CB.0
Name | RegAccess | R/W | 寄存器的号
Legend
Bit | Name | Description
CB.7 | RegAccess | 1bin | 寄存器通信开机
CB.6 | R/W | 0bin | 读访问
 |  | 1bin | 写访问
CB.5 to CB.0 | Reg. no. | 寄存器号: 输入你希望的寄存器号码: - 读取DataIn的输入数据 - 输出数据写入到DataOut中.

状态字(寄存器通信)

状态字节(SB)是基于输入映像上的, 并且是由端子传送至控制器上的.

Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | 寄存器的号
Legend
Bit | Name | Description
SB.7 | RegAccess | 1bin | 确认寄存器访问
SB.6 | R | 0bin | 读取访问
SB.5 to SB.0 | Reg. no. | 读或写寄存器号


KL2761 - Control and status byte

BECKHOFF KL2761: Access from the user programm

KL2761 控制和状态字

过程数据模式

控制字 (在过程数据模式下)

控制字节(CB)是基于输出映像上的.,并且是由控制器传送至端子上的.

Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | - | ManualAutoDetect
Key
Bit | Name | Description
CB17 | RegAccess | 0bin | 寄存器通信关闭 (过程数据模式)
CB1.6 to CB1.1 | - | 0bin | 保留
CB1.0 | ManualAutoDetect | 1bin | 开始自动负荷检测操作(上升沿)

状态字 (在过程数据模式下)

状态字节(SB)是基于输入映像上的, 并且是由端子传送至控制器上的.

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | 错误 | 温度警告 | 过载 | 操作模式 |  |  | 同步
Key
Bit | Name | Description
SB1.7 | RegAccess | 0bin | 确认过程数据模式
SB1.6 | Error | 1bin | 短路检测
SB1.5 | Temperature warning | 1bin | 温度(> 80°C) 检测:过程数据限制在20% (t如果温度低于60°C额定设定自动返回)
SB1.4 | Overload | 1bin | 过载检测(例如:高负荷开关)
SB1.3 to SB1.1 | Operation mode | 手动设置或自动检测运行方式
 |  | 0dec | 自动检测运行
 |  | 1dec | 后缘控制
 |  | 2dec | 前沿控制
 |  | 3dec | 整流模式(positive half-wave with leading edge control)
 |  | 4dec | 整流模式 (positive half-wave with leading edge control)
SB1.0 | Synchronized | 0bin | 端子没有和主电流同步或者存在单侧负载短路
 |  | 1bin | 端子与总线同步

寄存器通讯

控制字(在注册通讯中的内容)

控制字节(CB)是基于输出映像上的.,并且是由控制器传送至端子上的.

Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | 寄存器号
Key
Bit | Name | Description
CB1.7 | RegAccess | 1bin | 寄存器通信开机
CB1.6 | R/W | 0bin | 读访问
 |  | 1bin | 写访问
CB1.5 to CB1.0 | Register no. | 注册码: 输入你希望的寄存器号码: - 读取DataIn的输入数据, - 将输出数据写入DataOut.

状态字(寄存器通信)

状态字(SB)是基于输入映像上的, 并且是由端子传送至控制器上的.

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | 寄存器号
Key
Bit | Name | Description
SB1.7 | RegAccess | 1bin | 确认寄存器访问
SB1.6 | R | 0bin | 读取访问
SB1.5 to SB1.0 | Register no. | 读或写寄存器号


KL2751, KL2761 - Register overview

BECKHOFF KL2751, KL2761: Access from the user program

寄存器概述

寄存器是用来设置调光端子调光的参数，可以通过寄存器通信对参数进行写操作和读操作。

Register No. | Comment |  | Default-Wert |  | R/W | Memory
R0 | reserved |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R6 | reserved |  | - | - | - | -
R7 | Command register |  | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | KL2751-0000 | 0x0ABF | 2751dec | R | ROM
 |  | KL2751-0011
 |  | KL2751-1200 | 0x0ABF | 2751dec
 |  | KL2761-0000 | 0x0AC9 | 2761dec
 |  | KL2761-0011
R9 | Firmware revision level |  | e.g. 0x3141 | e.g. 1AASCII | R | ROM
R10 | Multiplex shift register |  | 0x0118 | 280dec | R | ROM
R11 | Signal channels |  | 0x0118 | 280dec | R | ROM
R12 | minimum data length |  | 0x9800 | 38912dec | R | ROM
R13 | Data structure |  | 0x0004 | 4dec | R | ROM
R14 | reserved |  | - | - | - | -
R15 | Alignment-Register |  | 0x7F80 | 32640dec | R/W | RAM
R16 | Hardware versions number |  | e.g. 0x0000 | e.g. 0dec | R/W | EEPROM
R17 | reserved |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R28 | reserved |  | - | - | - | -
R29 | Terminal type, special type | KL2751-0000 | 0x0000 | 0dec | R | ROM
 |  | KL2751-0011 | 0x000B | 11dec
 |  | KL2751-1200 | 0x04B0 | 1200dec
 |  | KL2761-0000 | 0x0000 | 0dec
 |  | KL2761-0011 | 0x000B | 11dec
R30 | reserved |  | - | - | - | -
R31 | Code word register |  | 0x0000 | 0dec | R/W | RAM
R32 | Feature register |  | 0x0000 | 0dec | R/W | EEPROM
R33 | User scaling - offset |  | 0x0000 | 0dec | R/W | EEPROM
R34 | User scaling - gain |  | 0x0100 | 256dec | R/W | EEPROM
R35 | Ramp time |  | 0x0003 | 3dec | R/W | EEPROM
R36 | Watchdog timeout |  | 0x000A | 10dec | R/W | EEPROM
R37 | Light value for timeout (on) |  | 0x3FFF | 16383dec | R/W | EEPROM
R38 | Light value for timeout (off) |  | 0x0000 | 0dec | R/W | EEPROM
R39 | Dimmer mode |  | 0x0000 | 0dec | R/W | EEPROM
R40 | Bypass behavior |  | 0x0001 | 1dec | R/W | EEPROM
R41 | Line frequency | KL2751-0000 | 0x0000 | 0dec (50 Hz) | R/W | EEPROM
 |  | KL2751-0011
 |  | KL2751-1200 | 0x0001 | 1dec (60 Hz)
 |  | KL2761-0000 | 0x0000 | 0dec (50 Hz)
 |  | KL2761-0011
R42 | reserved |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R63 | reserved |  | - | - | - | -


KL2751, KL2761 - register description

BECKHOFF KL2751, KL2761: Access from the user program

寄存器说明

所有的寄存器可以通过寄存器通讯被读或写.它们是用来对终端进行参数设置的.

R7: Command register

Note

用户指令

执行以下命令.需要用户指令,0x1235F,0x1235, 导入register R31.
Command 0x7000: 恢复默认设置

Entering 0x7000 在寄存器R7中恢复了出厂设定,如下::
R33: 0dec
R34: 256dec
R35: 3dec
R36: 10dec
R37: 16383dec
R38: 0dec
R39: 0dec
R41: 0dec (KL2751-0000, KL2751-0011, KL2761-0000, KL2761-0011)
R41: 1dec (KL2751-1200)

R8: Terminal type

寄存器R8中 描述了模块类型: KL2751 或 KL2761

R9: Firmware revision level

寄存器R9以ASCII码描述了固件版本,例如:0x3141 = '1A'. '0x31' 对应的ASCII码是'1', 而 '0x41' 代表的 ASCII 码为'A'. 该值不可改变。.

R16: Hardware version number

寄存器R16包含了模块的硬件版本号

R29: Terminal type

寄存器R29包含了该端子的类型.

R31: Code word register

如果您第一次没有对R31寄存器写一个值(0x1235)而直接写入其他寄存器，模块不会接受你所写的值。若模块重启则R31中的值会被重置.

R32: Feature register

特征寄存器主要用于描述端子组态.

Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | - | - | - | -

Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | - | DimRamp | disWatchdog | - | enUserScale
Key
Bit | Name | Description |  | Default
R32.15 - R32.4 | - | 备用
R32.3 | DimRamp | 0bin | 相对调光斜坡模式: 在寄存器R35中的斜坡时间 是与整个过程数据范围时间(0dec - 32767dec)相关的. 这意味着调光器需要用这个时间来调节从关（0dec）到全开（32767dec）的过程 | 0bin
 |  | 1bin | 绝对调光斜坡 模式 : 在寄存器R35中的斜坡时间 是与整个过程数据变化有关. 这意味着调光器需要用这个时间来改变目前的光强
R32.2 | disWatchdog | 1bin | 网络监测(时间可调)停用 | 0bin
R32.1 | - | 默认
R32.0 | enUserScale | 1bin | 用户缩放启用 ( R33+ R34) | 0bin

R33: User scaling - offset

如果user scaling启用(R32.0=1bin), (默认值=0).,可在此输入其偏移量

R34: User scaling - gain

如果user scaling启用(R32.0=1bin), (默认值=0).可在此输入其增益值
例子:
128dec = 0x80 = factor 0,5
256dec = 0x100 = factor 1,0 (默认)
512dec = 0x200 = factor 2,0

R35:Ramp time

该寄存器描述斜坡时间

  • (if R32.3 = 0bin) 范围0dec to 32767dec (全角度控制).
  • (if R32.3 = 1bin) 调节改变当前亮度

0dec: 50 ms
1dec: 100 ms
2dec: 200 ms
3dec: 500 ms (default)
4dec: 1 s
5dec: 2 s
6dec: 5 s
7dec: 10 s

R36: Watchdog-Timeout

该寄存器指定了现场总线的超时错误,该单位为10毫秒(默认值: 10dec = 100 ms).

R37: Light value for timeout (on)

该寄存器描述现场总线错误时的亮度值，其当前进程数据>0 (默认值: 16383dec).
单位是 1 . (R32.2=1bin).

R38: Light value for timeout (off)

该寄存器描述现场总线错误时的亮度值，其当前进程数据=0 (默认值: 0dec).
单位是 1 . (R32.2=1bin).

R39: Dimmer mode

该寄存器是用来指定调光模式的.
0dec: 自动检测(默认)
1dec:后缘控制
2dec前沿控制
3dec: 整流模式,正向 (前沿控制下正 半波形)
在KL2751固件版本2E 与KL2761固件版本1E中不要使用此操作模式!只能使用负向整流模式。
4dec: 整流模式, 负向 (后缘控制下的负半波形)

R40: Bypass behavior

此寄存器指定短路后的行为.
0dec: 关闭
1dec: 再次打开(默认)

R41: Line frequency

此寄存器指定了线性频率:

0dez: 50 Hz
1dez: 60 Hz

默认值:

KL2751-0000: 0dec (50 Hz)
KL2751-0011: 0dec (50 Hz)
KL2751-1200: 1dec (60 Hz)
KL2761-0000: 0dec (50 Hz)
KL2761-0011: 0dec (50 Hz)


TwinCAT

PLC and Motion Control on the PC

TwinCAT - The Windows Control and Automation Technology

The automation software TwinCAT turns any compatible PC into a real-time controller with a multi-PLC, NC axis control, programming environment and operating station. TwinCAT replaces conventional PLC and NC/CNC controllers as well as operating devices with:

  • open, compatible PC hardware
  • embedded IEC 61131-3 software PLC, software NC and software CNC in Windows NT/2000/XP, NT/XP Embedded, CE
  • programming and run-time systems optionally together on one PC or separated
  • connection to all common fieldbus systems
  • PC interfaces are supported
  • data communication with user interfaces and other programs by means of open Microsoft standards (OPC, OCX, DLL, etc.)

TwinCAT architecture

TwinCAT consists of run-time systems that execute control programs in real-time and the development environments for programming, diagnostics and configuration. Any Windows programs, for instance visualization programs or Office programs, can access TwinCAT data via Microsoft interfaces, or can execute commands.

A practically oriented software solution

TwinCAT offers a precise time-base in which programs are executed with the highest deterministic features, independently of other processor tasks. The real-time load on a PC is set with TwinCAT; defined operating behavior is achieved in this way. TwinCAT indicates the system load for programs that are running. A load threshold can be set in order to assure a defined computing capacity for the operating programs and for Windows NT/2000/XP. If this threshold is exceeded, a system message is generated.

TwinCAT supports system diagnosis

The general use of hardware and software from the open PC world requires some checking: Unsuitable components can upset the PC system. Beckhoff have integrated a practical indicator of the real-time jitter into their product, giving administrators an easy way to evaluate the hardware and software. A system message during operation can draw attention to incorrect states.

Start/stop behavior

Depending on the setting, TwinCAT is started and stopped manually or automatically. Since TwinCAT is integrated into Windows NT/2000/XP as a service, an operator is not needed to start the system: switching on is enough.

Restarting and data backup

When a program is started or restarted, TwinCAT loads programs and remanent data. To back up data, and to shut down Windows NT/2000/XP correctly, a UPS (uninterruptible power supply) is of great value.

TwinCAT and „Blue Screen“

The TwinCAT system can be configured such that real-time capability is maintained in the event of a BSOD (Blue Screen of Death) operating system crash. Real-time tasks such as PLC and NC can therefore continue to run and bring the controlled process into a safe state. Ultimately, it is the decision of the programmer whether or not to utilize this feature, bearing in mind that data or programs may already have been destroyed by the BSOD.

World-wide connection through message routing - "remote" connection is inherent to the system

According to the requirement for operating resources, the TwinCAT software devices can be distributed: TwinCAT PLC programs can run on the PCs or on Beckhoff Bus Terminal Controllers. A "message router" manages and distributes all the messages, both in the system and via TCP/IP connections. PC systems can be connected with each other via TCP/IP; Bus Terminal Controllers are integrated via serial interfaces and fieldbus systems (EtherCAT, Lightbus, PROFIBUS DP, PROFINET, Interbus, CANopen, DeviceNet, RS232, RS485, Ethernet TCP/IP, Ethernet/IP).

World-wide access

Since standard TCP/IP services of NT/2000/XP can be used, this data can be exchanged across the world. The system offers scalable communication capacity and timeout periods for the supervision of communications. OPC provides a standardized means for accessing many different SCADA packets. The SOAP (Simple Object Access Protocol) enables a connection between two computers to be established by means of an internet connection via standard HTTP. A TwinCAT component is available for this purpose.

Beckhoff Information System

You may find further information about the automation software TwinCAT in the Beckhoff-Information System.

The setup for the Beckhoff Information System is available on the Beckhoff DVD Products & Solutions and for download on our internet pages.

Furthermore the online version of the Beckhoff Information System may be found under http://infosys.beckhoff.com.


Import of a fuction block

BECKHOFF Fieldbus Components: TwinCAT

功能块导入

如果想导入功能块至您的TwinCAT中,请点击TwinCAT PLC Control菜单中Project/Import

选择您已储存的EXP文件夹 (DB_Dimmer1SwitchEco.exp在这个例子中), 选择DB_Dimmer1SwitchEco.exp然后打开.

在成功导入后,PLC 控制器会显示导入成功.


Support and Service

BECKHOFF Automation: Appendix

Beckhoff 技术支持&技术服务

Beckhoff 及其合作伙伴活跃于世界各地，提供全方位的技术服务和技术支持，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff's 公司的分公司和代表

请联系当地的支持和对Beckhoff产品服务您的Beckhoff的分支机构或代表！想·

对Beckhoff分公司和代表的地址可以在她的Internet网页找到：
http://www.beckhoff.com

您还可以在此找到更多关于Beckhoff的文 件信息

Beckhoff 总公司

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff 支持

支持为您提供全面的技术支持,帮助你不仅仅只与个人Beckhoff应用产品,而且与其他广泛的服务:

  • 全球技术支持

  • 复杂自动化系统的设计、编程和调试

  • Beckhoff 系统组件培训方案

Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心的在以下方面都为您提供售后服务:

  • 上门服务
  • 维修服务
  • 备件服务
  • 热线服务
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com