Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Commands

TwinCAT CAM Design Tool: Commands

命令

凸轮设计编辑器提供下列命令，它们能够通过相关图形窗口上的工具条调用：

对图形命令 [image] ，只有当输入模式 [image] 激活时，这些命令才能够调用。

所有这些命令仅仅适用于相关的窗口。

调整为极限值

窗口的坐标被调整到运动的极限值

距离测量

在窗口右上角显示从鼠标左键单击拾取点到当前点的水平及垂直距离（使用时请按住鼠标键）。

当前位置

在窗口右上角显示当前鼠标左键单击拾取点的绝对水平以及垂直位置（使用时请按住鼠标键）。

水平移动

水平地移动所选择的点

在同步功能的速度窗口：在位置窗口，沿着直线移动。

图形区域的左边缘能够临时以这种方式移动，以至于能够轻易读取数值。

垂直移动

垂直地移动所选择的点

在同步功能的速度窗口：在位置窗口，调整位置与速度的关系

在自动功能的加速度窗口：调整加速度。

平移

移动所选择的点

下面的命令仅仅适用于图形窗口的位置:

插入点

在光标位置插入点

同步功能

选择的参数段将按同步功能运行。

自动功能

对选择的参数段，包括边界值的调整，自动选择最佳功能

删除点

删除选择的点，以及相应参数段的点。

下面四项定义了点的边界条件：

在表窗口中的点前面相应地显示了点类型。此限制条件表明一个参数段的终点值与下一个参数段的起点值不相等。

静止点

选择的点被定义为静止点（边界条件：v=0, a=0）

速度点

选择的点被定义为速度点（边界条件：a＝0）

反向点

选择的点被定义为反向点（边界条件：v＝0）

运动点

选择的点被定义为运动点（没有边界条件）

滑动点

不改变选择的参数段，在光标位置设置下一个参数段的起点位置或者前一个参数段的终点位置。

然后采用水平移动命令，此点能够移动到相应的参数段。.

删除滑动点

删除滑动点，因此两参数段连接在一起，类似于只有前一个参数段。