Interfaces

TwinCAT NC PTP

接口

用户可以通过系统管理器和 PLC 访问 PTP。也可以通过周期轮询 NC-PLC 轴接口进行访问。

系统管理器中的 PTP 接口

在系统管理器中，用户可以访问 PTP 轴的所有功能以及 NC-PLC 轴接口的所有变量。

NC-PLC 功能块

通过特殊的 PLC 功能块，用户可以访问 PTP 轴的所有功能。

NC-PLC 接口

NC-PLC 接口包括轴的过程映像，也可以访问各种轴变量。


Overview

TwinCAT NC SLAVE AXES

NC Error Handling

1. Extended NC error handling for coupled axes

Sample of the NC axis parameters from the TwinCAT System Manager:

The extended NC error handling for coupled axes can be configured by means of the parameter Fehlerreaktionsmodus (Error reaction mode).

INSTANTANEOUS setting:

Selecting Instantaneous here corresponds to the reactions to errors of TwinCAT up to 2.10 (default). In the event of a error in one axis, the NC immediately initiates an error reaction, and halts all the axes involved in the master/slave group.

DELAYED setting:

The basic idea of this setting is to not initiate an automatic, immediate NC error reaction whenever an error occurs. The user has the option of initiating an error reaction that has been individually adapted to the particular application.
If a runtime error now occurs in a coupled axis, then only this particular axis is switched without delay into an error state by means of an error reaction, whereas the other axes in the master/slave group are not affected immediately (local error reaction). Propagation of the error through to the other axes involved is suppressed for the delay time parameterised in Fehlerreaktionsverzögerung (Error reaction delay). During this period, the user is responsible for initiating the error reaction that he requires (e.g. stopping the master axis, or decoupling from parts of the master/slave structure).
Once the parameterised delay time has elapsed, the familiar NC error reaction comes into play (global error reaction). This error reaction, however, acts only on the group of axes present at the time to which the axis with the error belongs. It is possible, for instance, for the original master/slave group to first be decoupled to create one group with no error and another group with an error.

Comment on the axis interface:

If a runtime error occurs in a master/slave axis configured as DELAYED, it is indicated at the same time by the two NC status bits Error (bit 31) and ErrorPropagationDelayed (bit 6). Once the error reaction delay time has elapsed, the ErrorPropagationDelayed bit is reset to FALSE.

Requirements:

The extended NC error handling (error reaction mode) and the changeover to actual value coupling (use actual value in deactivated state) only applies to master/slave axes whose axis types are Continuous Axis (PTP axis) and Encoder Axis.

2. Changeover to actual value coupling

Sample of the NC axis parameters from the TwinCAT System Manager:

Basically, the generation of set values between coupled axes is always based on the set values rather than the actual values.
The changeover to actual value coupling feature is parameterised by the Use actual values in deactivated state parameter, and is always to be understood in the context of a master/slave coupling. There are two different cases to distinguish here.

1st case: Switch to actual values when an axis has an error

If an error occurs in a coupled axis when error reaction is delayed (error reaction mode: DELAYED), then this axis can be switched over by the NC from set values to actual values. Although this changeover does not have any effect on the faulty axis itself (which has already been halted in an error state), it remains possible to drive the subsidiary slave axes by means of the actual values for this axis. This property can result, in the case of an error, in better synchronicity between the axis with the fault and the subsidiary slave axes if the axis that has the error moves further due to its inertia.

2nd case: Change to actual values when the main master axis has been deactivated

The changeover to actual values even when no error is present is only available to the main master, i.e. the head of the coupling in a master/slave structure. A master/slave group without errors, in which the NC controller enable has set all the axes ready for operation (position control) is a precondition for this changeover.

If the NC controller enable is now removed from the main master, the entire group is controlled according to the actual values of the main master. In this way, for instance, the main master can be pushed manually, and all the other axes that are coupled to this master follow in accordance with their mathematical coupling specification (e.g. cam plates).

Requirements:

The extended NC error handling (error reaction mode) and the changeover to actual value coupling (use actual value in deactivated state) only applies to master/slave axes whose axis types are Continuous Axis (PTP axis) and Encoder Axis.