Overview

TwinCAT PLC HMI 网页可视化

概述

TwinCAT PLC HMI Web 是一款TwinCAT的附属产品，他提供了TwinCAT PLC的基于网页的可视化页面。

TwinCAT PLC HMI Web 可以通过Setup来安装。

IEC61131 的PLC "TwinCAT PLC Control" 可作为 HTML 编辑器。

在TwinCAT PLC-Control 创建可视化网页的过程与"TwinCAT Target Visualisation" and "TwinCAT PLC HMI"可视化类似。

除了编译PLC代码，可视化的页面也转换为HTML网页，也可以与PLC工程一起下载到目标控制系统中。

TwinCAT PLC Control无接口集成优点是，除了创建可视化的IEC61131编程代码，所有的TwinCAT PLC 控制程序的变量可以直接使用。

许可

对于每一个 Runtime (CE/XP)，我们都需要一个许可. (在"free of charge"TwinCAT PLC Control里已经包括了编辑器).

试用版

试用版本有限制，不可用。

产品组件:

  • 编辑器：

    IEC61131 PLC 编辑器"TwinCAT PLC Control" 可作为编辑器。

  • Runtime CE:
    Beckhoff 所支持的CE 平台可作为CE 平台: CE-X86 和CE-ARM。
  • Runtime XP:
    产品已经在Windows XP/Windows XPE/Windows 标准下进行过测试。
    系统在 Vista and Windows server下的测试还没有进行。

要求：

  • 创建网页：
    TwinCAT 2.10 Build 1326 (或更高)
  • Runtime CE：
    • Beckhoff CE-X86 或 CE-ARM 带有 CE Image 2.18 (或更高) 的设备
    • 最低级别为 TwinCAT Level PLC
  • Runtime XP：
    • 最低级别为 TwinCAT Level PLC
  • 网页显示：

    浏览器要求带有 Java VM 用来显示基于网页的可视化页面 TwinCAT PLC HMI Web。
    对于 XP系统 这可以从一些供应商免费获得的 (比如 Sun).
    我们并没有找到CE系统下免费的Java-VM 。


CE Runtime: Installation

CE Runtime: 安装

要求：

  • PC：编辑器：TwinCAT 2.10 Build 1320
  • CE设备：CE Image 2.18 (或更高)

安装：

  • 第一步：
    主机上安装附属软件TwinCAT PLC HMI Web 。
    一旦输入了所需的正确的序列号，并同意许可协议，补充软件会被安装到主机的..\TwinCAT\CE文件夹中。

例如：安装TwinCAT PLC HMI Web
在主机上安装软件会自动生成文件夹 "..\TwinCAT\CE\TwinCAT PLC HMI Web" ，并在安装文件夹里包含CE*.cab 。
例如：
X86: TwinCAT_PLC_HMI_Web_CE.I586.CABcj
ARM: TwinCAT_PLC_HMI_Web_CE.ARM.CAB

  • 第二步：
    把 CE Cab 安装文件放到 CE 设备中 (通过记忆卡/FTP/共享文件夹/CF 卡...)

    当CE设备在运行时，双击Cab 文件夹并点击OK确认。
    在安装完成后，Cab文件会自行销毁。

    通过"Start -> Suspend"重启设备来保存所有在闪存和CF卡上的数据。

设备已经为 TwinCAT PLC HMI Web配置完毕。


XP Runtime: Installation and configuration

XP Runtime: 安装和配置

要求：

  • PC：编辑器：TwinCAT 2.10 Build 1326

安装：

安装TwinCAT PLC HMI Web应用程序后可以创建基于Web的可视化界面，所创建的可视化界面可以作为目标平台在XP系统的IIS（Internet Information Services）中运行，可以通过IE浏览器访问并控制所创建的可视化界面。

系统要求：

1、需要安装TwinCAT 2.10 Build 1326 (或更高)版本

2、TwinCAT安装级别最低为PLC级

3、客户端浏览器需要安装Sun 的Java虚拟机（Sun提供XP系统免费版Java虚拟机）

(注：文档配套例程软件版本：TwinCAT 2.11 Build 1533；TcPlcHmiWeb 1.0.0.8；JAVA虚拟机 1.6.0)

安装及配置：

1、安装 TwinCAT (若已经安装 TwinCAT 2.10 或更高版本，则不需要执行该步)，安装成功后重启系统。

2、安装 TcPlcHmiWeb（该软件可以向倍福销售人员购买获得），依照安装向导输入正确序列号进行安装，如下图所示：

3、编写 PLC 程序

创建 TwinCAT PLC HMI Web 页面与创建一般的 TwinCAT PLC HMI 类似，通过开始菜单新建“TwinCAT PLC Control”工程，然后切换到 Visualization 下并添加新页面：

依照向导输入新建页面名称（以 MainPage 为例）后，通过工具栏添加需要的控件并依照控件属性编写相应 PLC 程序，如下图：

界面和 PLC 程序编写完成后，依照如下步骤设置属性：

最后编译程序。

4、安装 IIS

在“控制面板”中打开“添加删除”界面，在“添加删除 Windows 组件”中选中 IIS 并点击下一步，如下图：

在安装过程中依照安装向导插入 XP 专业版系统光盘进行安装。

IIS 安装成功后打开控制面板进行如下操作：

设置 IIS 参数：

按下图共享 WebVisu 文件夹，且共享名为 UPnPDevice：

修改 UPnPDevice 文件夹访问权限：

参数设置完成后重启 IIS：

到此，IIS 已经安装并设置完成。

4、安装 JAVA 虚拟机

通过 http://www.java.com/zh_CN/ download/manual.jsp 下载 jre-6u16-windows-i586-iftw 虚拟机安装程序，按下图完成安装：

5、测试

完成上面所有步骤后，切换到TwinCAT PLC HMI编辑界面，选择“Run-Time1”—>“Login”后系统自动下载文件到“..\TwinCAT\Boot\WebVisu”路径下，按下图即可在浏览器中打开HMI界面：

或在 IE 浏览器中直接按下图输入地址访问 IIS（其中 10.41.2.10 为计算机 IP 地址，也可以改为计算机名）：

也可以在局域网内安装有 SUN 的 JAVA 虚拟机的电脑通过 http://10.41.2.10/index.htm 方式访问 IIS，如果需要外网进行访问则需要进行域名解析，配置方法可以参考 Winsdows 服务器配置相关文档。

应用例程点此打开

注意事项：

1、 问题：IIS 服务启动不了。

原因：IIS 服务默认使用端口为 80，该端口被其它程序占用了，比如迅雷下载。

解决：暂停迅雷，或者修改其默认端口，手动启动 IIS 服务。

2、 问题：画面上的动态数字不会更新。

原因：

解决：此时重启 IIS 服务，重启 TwinCAT 服务。

3、 问题：PLC Control 中画面修改后，IE 里访问到还是以前的画面。

原因：新的画面没有自动保存到 C:\TwinCAT\Boot\WebVisu，

解决：退出 PLC Control 重新进入，LOGIN 即可。或者手动清空 WebVisu。

4、 问题：贴图不能显示。

原因：贴图源文件采用了中文路径.

解决：放到英文路径下。


Windows 7 Runtime: Installation and configuration

Windows 7 Runtime: 安装及配置

要求：

  • PC: 编辑器: TwinCAT 2.10 Build 1326 或更高

安装：

TwinCAT PLC HMI Web 是一款附属产品 可直接通过Setup安装。需要一个许可证序列号。DEMO版本不可使用。
安装分三步：

  • 第一步：
    安装Internet Information Server IIS.
    nternet Information Server (IIS) Windows 7中默认是不安装的。这个功能是随后自行选择安装的。

详情见 http://http://technet.microsoft.com/de-de/library/cc725762%28v=ws.10%29.aspx

确保 ISAPI filter 和 其余的内容都被勾选(如图)

  • 第二步：
    在PC上安装附属软件。
    在WIN7主机上安装附属软件，输入正确的序列号并同意相关条例。

  • 第三步：
    配置 Internet Information Server (IIS)

- 创建一个 “virtual directory” 名字为 “UPnPDevice” 并与文件夹 “.\Programs\Beckhoff \UPnP\WebSite”连接上。
- 创建一个“virtual directory” 名字为 “TcWebVisu” 并与文件夹 “.\TwinCAT\Boot\WebVisu”连接上。

- 在 “IIS/ISAPI and CGI Restrictions” 下添加下列的DLL文件并允许他们“Execute”：

- C:\Program Files\Beckhoff\UPnP\WebSite\TcPlcDataServiceDa.dll

- C:\Program Files\Beckhoff\UPnP\WebSite\TcPlcDataService.dll

- 在 “Handler Mappings”下允许“Execute” 。

- 在 “IIS \Authentication\Anonymous Authentication”下选择 “Applications pool identity”

- 重启 IIS 服务

安装完成。


Editor

编辑

要求：

  • PC：编辑：TwinCAT 2.10 Build 1320 或更高 (可以创建一个CE系统的web solution)
  • PC：编辑：TwinCAT 2.10 Build 1326 或更高 (可以创建一个XP系统的web solution)

配置：

一旦Runtime for TwinCAT PLC HMI Web visualisation 安装到目标系统之后，在PLC工程中网页选择应该选为IEC1131 editor TwinCAT PLC Control。

在 PLC 控制对话框 "Project:"-->"Options..."-->"TwinCAT"里选择"Enable Web Visualization" 在 PLC 控制对话框里 "Project:"-->"Options..."-->"TwinCAT".

随着PLC程序下载到目标系统之后，网页可视化需求的文件被存到目标系统并存到文件夹.\TwinCAT\Boot\WebVisu中。

当把PLC切换为“Run”模式后，基于网页的可视化可用于客户端。（浏览器）

注意
应用TwinCAT PC HMI Web，并不要求选择"Download Symbol description" 。


Website call

打开网页

要求：

客户端（浏览器）需要Java VM 显示网页可视化 TwinCAT PLC HMI Web (Java VM 版本可参照我们下面的提示)。

  • 对于基于PC的系统，这可以免费从多个厂商获得，例如 www.sun.com
  • 对于基于CE的系统，没有免费的Java VM。

启动：

客户端用这个URL打开网页 (无论文件名是什么，VISU页面都能创建在TwinCAT PLC Control中）

http://<ip-or-hostname-of-device>/TcWebVisu/Index.htm

或者

http://<ip-or-hostname-of-device>/TcWebVisu/

例如：

http://192.16.18.213/TcWebVisu/Index.htm

http://192.16.18.213/TcWebVisu/ （CE系统需要输入这个ip）

http://CX_012345/TcWebVisu/Index.htm

http://CX_012345/TcWebVisu/

如果你改变了项目但浏览器仍然显示的是旧项目，你可能需要清空浏览器的缓存显示新页面。对于 Internet Explorer 8，操作为Shift-button +用鼠标点击 side-refresh-button 。一个新的浏览器窗口或普通刷新不起作用。

注意
在基于 Windows XP的系统中，IP 地址和主机的NetID必须是唯一的。
例如：如果 IP 地址是192.16.18.213，NetID 必须是192.16.18.213.1.1。

注意
不起作用：

http://localhost/TcWebVisu/

注意
如果 Java-VM版本是 1.6.0_14 你需要做如下的设定：

在你的控制面板(Windows XP / XPe)你可以找到"Java"。如果你单击之后，"Java Control Panal" 窗口打开。选择按钮 "Network Settings..."。在这里选择 "Direct connection"。


Feature Overview

TwinCAT PLC Visualisierung

TwinCAT 可视化特点浏览

以下表格显示了TwinCAT提供的可视化元素。

 | PLC Control | PLC HMI | PLC HMI Web | PLC HMI CE | 注释
现在测试的版本： | Build 1010 | 2.10.0.900 | 1.0.0.7 | 1.0.9.10 | TwinCAT 2.10 Build 1334
矩形 |  |  |  |  |
圆角矩形 |  |  |  |  |
椭圆 |  |  |  |  |
多边形 |  |  |  |  |
曲线 |  |  |  |  |
饼图 |  |  |  |  |
位图 |  |  |  |  |
Visaualisation |  |  |  |  |
按钮 |  |  |  |  |
WMF/JPG 文件 |  |  |  |  |
表格 |  |  |  |  |
ActiveX 元素 |  |  |  |  |
趋势 |  |  |  | / | HMI CE：只支持在线趋势
报警表 |  |  |  |  |
仪表 |  |  |  |  |
条形图 |  |  |  |  |
柱形图 |  |  |  |  |
不可见元素 |  |  |  |  |
颜色变换 |  |  |  |  |
背景位图 |  |  |  |  |
按钮背景 |  |  |  |  |
工具提示 |  |  |  |  | HMI CE：内容不要太靠近边缘或者工具栏不要超出窗口
安全 |  |  |  |  |
占位符 |  |  | / | / | Web/HMI CE：在缩放命令中不能缩放占位符
打印功能 |  |  |  |  |
修改密码 |  |  |  |  |
修改用户等级 |  |  |  |  |
语言对话框 |  |  |  |  |
自动更换语言 |  |  |  |  |
退出 |  |  |  |  |
跟踪 |  |  |  |  |
文本输入 'Text' |  |  |  |  | Web：请不要超出变量的最大字符串长度 HMI CE：不支持隐藏功能
文本输入 'Numpad' |  |  |  |  | HMI CE：不支持隐藏功能
文本输入 'Keypad' |  |  |  |  | Web: 请不要超出变量的最大字符串长度 HMI CE：不支持隐藏功能

限制：Restrictions