Notes on the documentation

BECKHOFF Automation: 前言

文档编制说明

本说明书仅供那些在控制与自动化工程方面受过适当培训且熟悉各种适用国家标准的专业人士使用。在安装和调试这些组件时，操作人员必须严格遵循下列说明和解释。

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

免责声明

尽管本文档经过精心编制，但由于其中所描述的产品仍处于不断更新换代中，我们可能不会在每次更新后都检查文档中所描述的产品性能数据、标准或其它特性总是与实际产品相一致。本文档中难免会出现一些技术或者编辑错误，我们保留随时对文档信息作出修改之权力，恕不另行通知。对于已经变更的产品，如果本文档中的数据、图表以及文字描述没有修改，我们将不再特别加以声明。

商标

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® 和XFC® 的注册商标,由倍福自动化有限公司授权。
在公共场合其他名称中使用的商标，可能是为了私人的目的向第三方组织使用，这有可能侵犯版权。

专利申请

TwinCAT 技术是覆盖,包括但不局限于下列专利申请与专利:在许多其它国家注册或有相关应用的EP0851348,US6167425 专利。

版权

© Beckhoff Automation GmbH.
本手册内容受版权保护。未经德国倍福自动化有限公司书面许可，任何人不得部分或全部复制，发行或者交流本手册。

违者将承担带来损失的赔偿。保留所有出现的专利，实用新型模型和外观设计的版权


TCPlcLibSystemCX5020_Overview

TwinCAT PLC Library: CX5020 系统

概述

这个文库包含了使用嵌入式PC CX5020的特殊函数。

函数

名称 | 描述
F_GetVersionTcSystemCX5020 | 该函数返回库版本信息

功能块

名称 | 描述
FB_CX5020SetWatchdog | 激活/关闭看门狗 (如果PLC出现问题，CX5020将 自动重启)

要求

组件 | 版本
TwinCAT on the development PC | 2.9 Build 959 或更高


FUNCTION F_GetVersionTcSystemCX5020

TwinCAT PLC Library: CX5020 系统

函数 F_GetVersionTcSystemCX5020

该函数返回库的版本信息。

函数 F_GetVersionTcSystemCX5020 : UINT

VAR_INPUT
        nVersionElement : INT;
END_VAR

nVersionElement : 版本要素:

  • 1 : 主号码;
  • 2 : 次设备号码;
  • 3 : 修订号码;
开发环境 | 目标平台 | 包含的PLC 库
TwinCAT v2.9.0 | PC (i386) | TcSystemCX5020.Lib


FUNCTION_BLOCK FB_CX5020SetWatchdog

TwinCAT PLC Library: CX5020 系统

功能块 FB_CX5020SetWatchdog

函数FB_CX5020SetWatchdog 激活了CX5020上一个硬件看门狗。当bEnable = TRUE以及有延时时间时，看门狗被启用。最小延迟时间是2秒，最大的延迟时间是 255秒。

一旦看门狗被激活，这个函数将被循环调用，因为如果 tTimeOut-time 结束 ，CX5020 会自动重启。如果PLC死机，那么看门狗会自动重启系统(例如无限循环)。

当 bEnable = FALSE. 看门狗关闭，

注意：
在使用中断前，重置一个或者所有PLC前，TwinCAT停止前，配置模式改变或者激活配置之前，必须要关闭看门狗，否则一旦延时时间结束，CX5020就会立刻重启！

功能块 FB_CX5020SetWatchdog

VAR_INPUT

VAR_INPUT
        tTimeout               : TIME;
        bEnable                : BOOL;
END_VAR

tTimeOut : 看门狗扫描时间，一旦结束系统自动重启

bEnable : 激活/关闭看门狗

VAR_OUTPUT

VAR_OUTPUT
        bEnabled               : BOOL;
        bError         : BOOL;
END_VAR

bEnabled : TRUE = 激活看门狗, FALSE = 不激活看门狗

bError : 当激活/关闭看门狗时出现错误