Overview

TwinCAT System

概述

TwinCAT system是连接Windows NT 和TwinCAT的单元。例如在开始运行Windows NT期间，也会启动TwinCAT 系统，或者当关闭Windows NT时，也会安全终止TwinCAT系统。另外，TwinCAT系统能够执行所有TwinCAT服务器对 Windows NT服务的访问。TwinCAT系统由TwinCAT System Service 和TwinCAT System Control组成。

定义:

TwinCAT -Total Windows Control and Automation Technology

ADS - Automation Device Specification

AMS -Automation Message Specification

TwinCAT System Service

TwinCAT System Control

TwinCAT System Service

TwinCAT System Service 是作为 Windows NT服务在本地系统帐户上运行的。以这种方式，在用户登录之前，Windows NT会启动TwinCAT System Service 。作为一个活性符号，TwinCAT服务系统会把它的计算机图标添加到桌面的任务栏中。此外，这种图标的颜色可指示出TwinCAT系统的状态。

图标的颜色:

红:

TwinCAT运行停止.

蓝:

TwinCAT配置模式

黄:

TwinCAT启动中.

绿:

TwinCAT已启动.

TwinCAT系统主要负责启动和停止TwinCAT run time system。在启动TwinCAT系统时，它可装载所有已配置的服务器并对其进行初始化。

通过鼠标点击（左或右）图标或使用组合键<ALT-+>，可显示服务系统的上下文菜单。

TwinCAT控制系统

通过TwinCAT System Control参数化TwinCAT run time system

可进行如下设置：

  • 添加TwinCAT server
  • 参数化TwinCAT system start
  • 配置远程连接
  • 参数化message router
  • 参数化PLC run time system