CP-Link - Ethernet based Desktop Transmission 软件

BECKHOFF: CP-Link 3

CP-Link 3

的文档资料

基于以太网的桌面传输软件

版本: 1.5
日期 2012-09-17


文档说明

本说明书仅供那些在控制与自动化工程方面受过适当培训且熟悉各种适用国家标准的专业人士使用。
在安装和调试这些组件时，操作人员必须严格遵循下列说明和解释。

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

免责声明

尽管本文档经过精心编制， 但由于其中所描述的产品仍处于不断更新换代中，
我们可能不会在每次更新后都检查文档中所描述的产品性能数据、标准或其它特性总是与实际产品相一致。
本文档中难免会出现一些技术或者编辑错误，我们保留随时对文档信息作出修改之权力，恕不另行通知。
对于已经变更的产品，如果本文档中的数据、图表以及文字描述没有修改，我们将不再特别加以声明。

商标

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® 已为Beckhoff 自动化有限公司的注册商标
本出版物中的相关名称若被第三方出于个人目的，用作商标，将侵犯其拥有者的权利。

申请中的专利

已包含EtherCAT技术但不局限于如下专利申请和专利：
EP1590927, EP1789857, DE102004044764, DE102007017835
在许多其他国家有关EP0851348， US6167425的相关申请和注册。

已包含TwinCAT技术但不局限于如下专利申请和专利：
在许多其他国家有关EP0851348，US6167425的相关申请和注册。

版权

© 德国倍福自动化有限公司版权所有
未经许可，任何人不得复制、分发和使用本手册以及内容传播。
违者将追究损害赔偿 保留所有出现的专利，实用新型的模型和外观设计的版权。


安全说明

安全规程

请仔细阅读下列安全说明及相关描述！
有关产品特定安全规程，请见后面页或有关安装，接线及调试等章节。

免责声明

所有组件在供货前均针对其具体应用进行了特定的软、硬件配置。 任何人不得对软、硬件配置进行文本档中规定之外的修改，德国倍福自动化有限公司对因此而造成的一切后果不承担任何责任。

人员资质

本手册仅供那些受过适当培训，熟悉各种适用国家标准的“控制、自动化和驱动工程”领域专业人员使用。

安全标志说明

本操作手册中用到了下列安全标志及相应的安全说明。 请仔细阅读并严格遵守。

危险 		有严重人身伤害危险！
不遵循本标志相关的安全说明，将直接危及个人生命和健康安全！

警告 		受伤的危险
不遵守本标志相关的安全说明将危及个人生命和健康安全！

小心 		危害个人
不遵守本标志相关的安全说明可能明显危害个人安全！

注意 		危险的设备和环境
不遵守本标志相关安全说明可能明显危害环境和设备安全.

说明 		说明或提示
该标志表示这些信息能够帮助您更好地理解安全说明。


CP-Link 3 - 文档版本说明

BECKHOFF CP-Link 3: 前言

文档版本说明

版本 注释
1.5
  • 更新部分 客户端安装 (Windows 7 / Windows XP下安装客户端软件)
  • 更新部分主机安装
  • 更新部分编辑客户端名单 (Broadcast Search)
  • 更新部分 客户端配置 (USB,Serial)
  • 更新部分客户端浏览器
  • 描述防火墙配置
  • 描述USB设备过滤器列表
  • 更新部分在客户端上使用本地USB设备
  • 布线的提示新的部分
  • 更新部分 排错
1.4
  • 更新Windows 7支持的文档
  • 更新部分组态接口
  • 更新部分Windows显示设置
  • 描述网络拓扑结构
1.3
  • 有关卸载CP-Link 3扩展桌面设备的描述(组态接口)
  • 更新部分 客户端配置-主机显示设备的分辨率,图形数据传输协议
  • 更新部分使用CPx8xx USB总线耦合器
  • 更新部分在客户端使用本地的USB设备
  • 配置RT Ethernet设备的描述
  • CP-Link 3 LaunchApp的描述
  • 更新部分手动设置HID focus
  • CP-Link 3设备的描述
  • 客户端浏览器的描述
  • 更新部分 纠错
1.2
  • 更新部分 技术数据-客户的系统需求
  • 客户端上lock symbol positioning的描述(客户端配置)
1.1
  • 在客户端上安装CP-Link 3的描述
  • 更新主控PC上安装CP-Link 3的描述
  • 更新USB总线耦合器的CP-Link 3用法的描述
1.0
  • 第一版


CP-Link 3 - Functioning

BECKHOFF CP-Link 3: 产品概览

Functioning

基于以太网的桌面传输软件

CP-Link 3通过实时以太网向一个或多个面板PC传送主机PC的屏幕内容，这些被传送画面的面板PC就叫做CP-Link 3客户端，另外客户端鼠标和键盘的输入也可以被传送到主控PC，当操作其中一台客户端的鼠标或者键盘的时候，那么另一台客户端会被锁定，由于TwinCAT PLC是通过软件接口技术(ADS)，因此即使有多个用户，也不会相互影响。 可以用经济标准型以太网电缆(CAT 5)或适用于拖链的以太网电缆，将网络中的设备连接在一起。 CP-Link 3的标准配置包括服务器软件和客户端软件。 Windows 7，Windows XP或Windows XP Embedded都可以作为服务器软件的操作系统。 Windows CE面板型PC可以作为客户端。无论客户端的数量有多少个。 每一个主机PC只需要一个CP-Link 3授权即可。

虚拟USB

主机PC访问一个客户端的USB设备可以像访问主机PC的本地连接的USB设备一样正常访问，通过这种方法，客户端的键盘的输入，触摸屏，以及特殊功能键都可以被传送到主机PC。客户端的U盘， USB打印机或USB条形码扫描仪可以通过主机PC控制。“虚拟USB”在主机中仿真一个USB根集线器。 如果将一台 USB设备连接到一个面板型PC，虚拟集线器将设备登录到主机的操作系统中，并透明的传输后续的通讯数据。 对于操作系统来说，就像是USB设备直接连接到主控PC 。 “虚拟USB”传输单位标准是USB 1.1和USB 2.0信号。 由于通讯是用100 Mbit/s以太网实现的，因此，USB2.0的传输性能(480 Mbit/s)会受到限制。

连接的USB设备进行通讯是通过一个正常的TCP/IP连接协议。 因此不可能保证这些设备在一个确定的周期时间进行查询。 如果在客户端有额外的输入或输出设备如特殊功能键, 功能键等等，那么作为替代方案有必要用一个固定的时间去查询，与这些设备进行通讯可以通过一个额外的通讯通道(RT Ethernet)，所以确保有固定的周期时间。

虚拟串行端口

在主机电脑上也可以创建一个虚拟串行端口来使用客户端的串行接口 这就允许串行接口的设备可以连接到客户端，在主机电脑上通过应用程序或者驱动使用。 主机PC上的虚拟串行接口和客户端上的实际的串行接口之间的通讯也是通过一个正常的TCP/IP连接。

虚拟图像

为了传送屏幕内容,需要在主机PC上安装一个或多个虚拟图形适配器。CP-Link 3-镜像设备和CP-Link 3-扩展设备之间是有区别的，CP-Link 3-镜像设备从标准显示画面中捕捉屏幕的内容，并且将其发送到一个或多个客户端。标准显示设备也就是当Windows操作系统启动的时候首先使用的那个画面。一个CP-Link 3-扩展桌面设备是扩展主机PC的Windows桌面到额外的显示设备，其屏幕内容可以被传送到一个或多个客户端。一个应用程序的程序窗口也可以被移动到扩展桌面的额外的屏幕上。CP-Link 3客户端可以显示CP-Link 3-扩展桌面或标准显示设备的任何内容。其他显示设备的内容(例如。额外的显卡)不能在CP-Link 3客户端显示。

画面可以通过TCP/IP或UDP/IP (组播)传输。 组播传输的优势是数据可以同时的传到多个客户端，无需增加通过接收机的数量来增加发射机的带宽。

说明 		在Windows 7/Windows XP最多连接10个显示设备
显示设备的总数量不能超过10个，包括安装在硬件上的显卡，根据不同的类型(单或双模头)可以连接一个或多个显示设备。 CP-Link 3 - 扩展桌面设备对应一个单头显卡因此是一个显示设备。

9个CP-Link 3 - 扩展桌面设备因此可以被安装在一个单头显卡上使用。 如果一个双头显卡被使用了,只可以安装8个CP-Link 3 - 扩展桌面设备。


CP-Link3–软件 版本

BECKHOFF CP-Link 3: 产品概览

软件型号说明

CP-Link3有三种形式：

  • CP-Link3单桌面
  • CP-Link3多桌面
  • CP-Link 3 扩展桌面

“虚拟 USB”及“虚拟串口”这些功能都包括在三种形式的CP-Link3中，以及对它们的使用没有限制。 ( Functioning)。

“虚拟图像”的范围在三种形式中是不一样的如下：

  • CP-Link 3单一桌面： 一个虚拟图像适配器（Beckhoff CP-Link 3-镜像设备）从主控PC的标准显示装置中捕捉屏幕内容。 客户端PC上面显示主控PC的标准显示画面。
  • CP-Link3多个桌面： 一个虚拟图像适配器(Beckhoff CP-Link 3 - 镜像设备)从主控PC的标准显示装置中捕捉屏幕内容。 最多支持255个客户端PC上面显示主控PC的标准显示画面。
  • CP-Link 3扩展桌面： 一个或多个虚拟图像适配器(Beckhoff:CP-Link 3 - 扩展桌面设备)用作扩展主控PC的桌面。 最多支持255个客户端显示一到十个不同的屏幕内容。 这些画面内容包括主机PC的标准显示画面以及主机PC的扩展显示画面。


CP-Link 3-技术数据

BECKHOFF CP-Link 3： 产品概览

技术数据

主控PC的系统要求
硬件 | Beckhoff 工业PC,Beckhoff嵌入式PC的Intel® Celeron® M ULV 1 GHz 1GB RAM
操作系统 | Windows 7 Professional, Windows 7 Ultimate, Windows Embedded Standard 7, Windows XP Professional, Windows XP Embedded或Windows Embedded Standard
软件 | Microsoft ：.NET Framework 2.0
客户端系统要求是Windows CE - (面板型 PC/控制面板)
硬件 | 面板型PC： 例如 CP77xx，CP62xx， CP72xx， CP67xx 控制面板： CP66xx 64 MB RAM
操作系统 | Windows CE 6 TwinCAT 2.10： Image版本3.09j或更加新的 TwinCAT 2.11： Image 版本 3.21j 或更加新的
Windows XP/Windows 7系统的客户端系统要求
硬件 | Beckhoff 工业 PC, Beckhoff 嵌入式 PC 的Intel® Celeron® M ULV 1 GHz 1 GB RAM
操作系统 | Windows 7 Professional, Windows 7 Ultimate, Windows Embedded Standard 7, Windows XP Professional, Windows XP Embedded 或 Windows Embedded Standard
General
传输介质 | 标准以太网电缆 (CAT 5)
传输协定 | TCP/IP或UDP/IP
客户端最多个数： | TCP/IP： 每一个主控PC的显示设备最多可以连接10个客户端 UDP/IP： 每一个主控PC的显示设备最多可以连接255个客户端
虚拟USB | 每个客户端最多允许7个USB设备


CP-Link3-安装方式

BECKHOFF CP-Link 3: 安装方式

Host的安装方式

执行程序CPLink3Setup.exe开始安装CP-Link 3。 打开安装向导它将指导您完成安装过程。 首先，检查安装的条件； 如果必要，需要安装安装包列表中显示的软件。 "Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)"包含在应用程序安装包中，如有必要，将会自动安装。 "Microsoft .NET Framework 2.0"不包含在应用程序的安装包中，但是可以通过互联网下载安装应用程序。 如果不能在网络上下载，这个步骤可以跳过。 在CP-Link 3被安装以后"Microsoft ： .NET Framework 2.0"或更新的版本可以手动安装。

说明 		安装的前提条件
.NET Framework Version 2.0软件或一个更新的版本是安装CP-Link 3的前提条件。 这个软件是免费的，可以直接从Microsoft的网站上下载。

安装向导然后显示"Welcome"点击下一步

在点击Next以后，会要求您声明你的协议和许可条件:

点击Next会出现一个叫你在其中输入用户数据的对话框。 填写User Name Organization以及向 Serial Number 表格中输入序列号。

说明 		序列号
您购买了CP-Link 3，将会获得序列号。

这个序列号包含了已经购买的许可证的级别。

点击Next，在接下来的对话框中选择CP-Link 3 Host Software安装。 你可以通过Change按钮更改安装路径。

如果 Extended-Desktop 许可证级别已经被安装，你现在可以定义将安装几个CP-Link 3 - Extended Desktop设备(见 Functioning选项)。

说明 		额外的扩展桌面设备
额外的CP-Link 3 - Extended Desktop设备也可以随时被添加通过CP-Link 3配置界面(见 配置界面选项)。

点击Next将会到安装程序的最后一个窗口。 如果你想再对安装参数做修改，返回单击Back，否则启动安装程序通过点击Install。

现在所有的必要的文件被复制到安装目录中，必要的驱动也会安装在您的系统中。

说明 		屏幕闪烁

花费一些时间来安装驱动。 在安装的过程中屏幕可能会闪烁好多次。

在安装的过程中也有可能有多个显示"Windows Logo Test"还没有通过CP-Link 3硬件有关的消息将会出现。 忽视这些信息，点击Continue Anyway。

安装完成以后，将会出现一个成功的消息：

点击Finish结束安装过程。 安装完成以后操作系统需要重启。 必要的软件组件现在已经安装在你的电脑上，在桌面上有一个链接到CP-Link 3配置的应用程序的图标。

说明 		代替TcUsb.sys - TwinCAT-安装方式
根据不同的TwinCAT的安装版本和CP-Link 3的安装顺序，TwinCAT还需要更新驱动文件TcUsb.sys。 (见TcUsb.sys更新)。


CP-Link 3-安装方式

BECKHOFF CP-Link 3: 安装方式

客户端的安装方式

除了在主机上安装CP-Link 3，也需在CP-Link 3的客户端上安装CP-Link 3。

在Windows 7 / Windows XP系统中安装客户端软件

从CP-Link 3 1.5.x版本开始，安装程序CPLink3Setup.exe中除了安装在主机上的CP-Link 3软件，也包括Windows 7 和 Windows XP系统的客户端软件。 在主机电脑上执行程序CPLink3Setup.exe启动安装。 遵循安装向导的说明。

在用户数据输入的的对话框中完成User Name及Organization的输入：

说明 		客户端软件不需要序列号
如果你打算只是在电脑上安装这个客户端软件序列号可以是空的。

在接下来的对话框中，选择安装CP-Link 3Client Software：

点击下一步将会来到安装程序的最后一个窗口。 通过单击Install启动安装程序。

在安装的过程中也有可能有多个显示"Windows Logo Test"还没有通过CP-Link 3硬件有关的消息将会出现。 忽略这些消息，点击Continue Anyway。

当安装完成，会显示一个成功的消息。 如果你完成了安装程序，将会要求你重启电脑。

说明 		客户端PC不具有可操作性
客户端PC不具有可操作性，它只是等待主机CP-Link 3的连接。 如果没有主机和客户端进行链接，一分钟以后才可以对客户端进行操作。 客户端通过一个信息框的显示客户机当前的状态。

在Windows CE系统下安装

在主机电脑程序目录的子文件夹"CE\X86"或"CE\ARM"中包含了Windows CE基于客户端的安装文件。

说明 		Windows CE 6和特定的image版本要求
请注意在Windows CE系统客户端的系统要求列表中的要求 (见 技术数据)。

第一次相应的CE-cab安装文件需要被复制到CE设备中(通过内存卡/ FTP / Public Folder / ...)。 双击在CE设备中的cab文件开始安装，按照安装向导指示安装。 为了保证CP-Link 3功能的正确性，通常安装在安装向导指定的文件夹内。 在安装完成以后，cab文件将会被自动删除。

说明 		安装目录
为了保证CP-Link 3功能的正确性，通常安装在安装向导指定的文件夹内。

说明 		在安装完成以后，cab文件将会被自动删除。
在安装完成以后，cab文件将会被自动删除。 因此你应该把 原始文件复制并传送给客户端。

说明 		CE设备最初不具有可操作性
CE设备最初不具有可操作性只是等待主机CP-Link 3的连接。 如果没有主机和客户端进行链接，一分钟以后CE系统的客户机将具有可操作性。 从CP-Link 3 1.1.19版本开始，客户端通过一个信息框的显示客户机当前的状态。

颜色深度调整

为了最大化CP-Link 3虚拟图像的性能，客户端的颜色深度应该与主机显示的颜色深度一样。 通常的，客户端的颜色深度必须设置为32位。

调整Window CE系统的客户机颜色深度:

  • 平台特定的目录"\Hard Disk\Regfiles\Samples\Cxxxx"包含了注册文件，客户端的颜色深度可以可以通过注册文件调整的。 说明，注册文件的设置可以被写到注册表，通过在Windows CE Explorer中双击这个文件。
  • 或者，调整颜色深度通过程序调整CX Configuration标签下的Display Settings。


CP-Link 3 - Uninstallation

BECKHOFF CP-Link 3： 安装方式

卸载

在Windows 7/Windows XP系统下卸载主机或客户端软件

从电脑中删除CP-Link 3，在Start -> Control panel -> Add or Remove Programs (Windows XP)，或Start -> Control Panel -> Programs and Functions (Windows 7)，选择Remove这个CP-Link 3软件包。 安装向导将会引导你完成卸载过程。

点击Yes将会从电脑中删除CP-Link 3。


CP-Link 3-Edit the client list

BECKHOFF CP-Link 3: 配置

编辑客户端列表

第一次配置界面出现一个空的客户名单表示CP-Link 3 配置开始：

可以通过单击Broadcast Search或者Add Client客户端列表中添加客户端。 通过单击Remove Client可以从客户端列表中删除客户端。

说明 		通过Apply激活设置
为了将最后的修改写到客户端列表中必须单击Apply。

Broadcast Search

Broadcast Search可以自动搜索网络中的设备，这个就是CP-Link 3的功能。 被Broadcast Search发现的设备可以添加到客户端列表中。

说明 		Windows 防火墙
Windows防火墙是启用的，如果是通过 CP-Link 3功能设备添加客户端，UPnP服务必须有Windows 防火墙的认可。

如果必须在Windows防火墙下做修改，点击Broadcast Search按钮将会出现下面的对话框：

UPnP service is authorized in the Windows Firewall点击Yes。 点击No就会离开但是没有改变Windows防火墙的任何设置，因此不能通过Broadcast Search搜索。

如果Windows防火墙被正确注册，点击Broadcast Search按钮时将会打开 CP-Link 3 Broadcast Search窗口。 在Broadcast Search窗口下点击Start Search将会在网络中搜索UPnP设备：

所需的设备可以通过点击Add按钮或者双击设备，然后需要添加的设备就会出现在客户端名单中 。

当一个客户端被添加时，将会检查是否新设备的IP地址已经存在于客户端列表中。 如果已经存在，会弹出对话框提示是否想要覆盖原先已经存在的客户端。

如果客户端已经添加到客户端列表中，在客户端名字的前面它们任然被标记为绿色的状态字段，一直到单击Apply以后才会改变。

Add Client

如果一个客户端尚未出现在网络，或没有UPnP功能，可以通过Add Client按钮手动添加：

当一个客户端通过Add Client添加， Name，IP Address和Comment，标准设置也自动导入。 这些设置可能需要修改。

如果客户端已经添加到客户端列表中，在客户端名字的前面它们任然被标记为绿色的状态字段，一直到单击Apply以后才会改变。

Remove Client

Remove Client可以被用作从客户端列表中删除客户端。

标签和按钮的功能依赖于选定的客户端的状态字段的颜色：

  • 状态字段被填充为绿色(按钮标记为Remove Client)：

    通过单击 Remove Client客户端将会被立刻从客户端列表中移除。

  • 状态字段被填充为白色(按钮标记为Remove Client)：

    状态字段被填充为红色直到通过单击Apply才会改变。 只有这样客户端最后才会被从客户端列表中删除。

  • 状态字段被填充为红色(按钮标记为Undo Removal)：

    通过单击按钮两次清除标记将被删除。

  • 状态字段中的许多被选择的客户有不同的颜色(按钮被标记为Toggle Removal Marks)：

    客户端字段是绿色的表示即将被从客户端列表中删除，客户端字段是红色的表示将removal标记移除，而客户的状态字段是白色的状态字段会变成红色。

如果将客户端从客户端列表中删除，如果客户端name前面被标记为红色，这些改变不会起作用直到点击Apply。


CP-Link 3-客户端配置

BECKHOFF CP-Link 3： 配置

客户端配置

客户端的配置被分成四个部分，下面详细描述：

  • General -一个客户的通用参数。

  • USB -设置“虚拟USB”。

  • Serial - 设置“虚拟串行端口”。

  • Graphics - 设置“虚拟图形”。

CP-Link 3可以单独启用或禁用每个客户端的功能(虚拟USB、虚拟串行端口及虚拟图形)。 可以在客户端列表中的适当的选择框或者通过下半部分配置窗口中相应选项卡的选择来完成这些配置。

为了配置一个或多个客户，首先必须选择这些客户端设备。 只需在客户端列表中点击它们。 也可以同时选择多个客户。 在这种情况下，选中的的客户端是黑色背景标记，其他的都是蓝色背景：

设置只对那些选中的客户端设备起作用，所做的修改在同时已在选择的客户机上执行。

General

客户端上general参数可以在General标签下面设置。 在图片上半部分的条目中，如果name标签前有一个星号说明“General”部分配置已经改变了，但是没有使用Apply进行激活。

客户的general参数包括IP address，name和description，以及HID focus设置。 IP Address是至关重要的。 此外，上面的条目也包括Name， Comment 及 Model这些信息。 任何名称都可以输入到Name里面。 name中输入的名称可以不对应客户计算机的名称。

说明 		自动输入的IP address
如果一个客户端是通过Add Client功能添加到客户端列表中的，客户端的IP Address 是自动填充的。 也有可能需要修改这个条目!

HID focus

客户端上面的输入可以通过HID FOCUS功能来配置（例如：输入设备焦点）

当一个客户端具有hid foucus，那么只有这个客户端可以通过键盘，鼠标，触摸板输入到主机中，其他客户端的输入将被屏蔽，自动的和手动的HID focus之间有一点区别。

  • Auto HID focus -如果一个客户端有一个输入，HID focus会自动获取。 如果在规定的时间期限没有进一步的输入，客户端失去与HID focus连接。 这个周期可以在Timeout 选项中自己设置。 如果timeout被设置为0，HID focus将会阻止输入，这也意味着这些输入可能会同时进入其他客户端。
  • 手动HID focus - 从客户端最初封锁输入。 HID focus必须在输入之前给客户端 。 有一个软件接口，详细描述请看 设置手动HID focus，为此。当选择手动模式时，timeout自动设置为0ms，这也意味着在所有情况下都需要重启HID focus。 如果timeout设置为任何不为0的值，在给定的时间内没有输入信号给入之后，手动hid focus将会被复位。

如果MouseClipping被选中(即标准设置)，鼠标的指针不能离开客户端的有HID focus的屏幕区域。 这可以防止在客户端之外的桌面的可见区域有意外操作。

Lock symbol

如果在某一个客户端上显示Lock symbol图片，此时客户端上面无法进行任何输入，这说明HID FOCUS已经分配给了另一个客户端。

可以通过按钮Default设置标准的default lock symbol。 也可以选择其他的图形符号来代表lock图片，以满足特定的要求。 Custom按钮是打开一个可以被选择和使用的图片文件选项框。 通过单击预览锁下面的Open Containing Folder，可以打开一个显示选定锁符号存储位置的资源管理器窗口。

说明 		lock Symbol图片的状态
lock symbol图片的大小是有限制的，最大为256 x 256像素。 大于这个像素的将被缩小到256 x 256像素，小于这个像素的图片将会保留原来的大小。

支持图像幻灯片。

Position：

默认情况下，锁符号图片会显示在客户端的显示屏的中间。

通过点击Centered选择框vertical和 horizontal offset，就可以使用Horizontal Offset及 Vertical Offset选项框进行设置。 偏移量的原点是主机显示屏幕左上角，显示在客户端上。

USB

设置客户端的“虚拟USB”的是在USB标签下的。 name标签栏旁边的星号表示"虚拟USB"的设置已经改变，但是还没有通过Apply激活。

客户端“虚拟USB”的功能可以可以通过USB选择框打钩或不打勾被启用和禁用。

说明 		发现新硬件"Beckhoff GmbH USB Control Panel CP6800"
在第一次为客户端激活“虚拟USB”时，会出现"Found new Hardware Wizard"表示这个"Beckhoff GmbH USB Control Panel CP6800"硬件已经被找到了。 这实际上是内部的USB总线耦合器需要TcUsb.sys这个驱动程序。 这个驱动存在于Beckhoff PC中，会通过向导自动安装。

USB Device Filters

Device Blacklist

Device Blacklist是一个过滤器列表。 Blacklist中的每个条目都是一个过滤器，代表那些用于客户端PC的USB设备，而不是用于服务器PC，主机PC将会忽略这些设备(见USB Device Filter Lists)。

Device Whitelist

Device Whitelist是一个过滤器列表。 Whitelist中的每个条目都是一个过滤器，代表一个特殊的群体USB设备，主机PC将不会忽视这些设备即使这些设备有一些条目在Blacklist中 参考USB Device Filter Lists)。

Device Use Local List

Device Use Local List是一个过滤器列表。 在Use Local List中的每个条目都是一个过滤器，代表一个特殊的群体用于本地客户端的USB设备(参考 USB Device Filter Lists)。

说明 		device过滤器显示
如果不止一个客户端被选定，然后只显示列表条目如果所有选择的客户端有相同的列表条目。

编辑USB device filters

编辑USB device filters的步骤和所有的形式的过滤表编辑器一样：

USB设备的过滤器可以被添加或移除通过Add和Remove 按钮。 单击Edit按钮允许编辑已被创建的过滤器。 或者你可以通过右击选择add， remove或者edit filter。 假如你以前使用Client Explorer时复制一个条目到剪切板，你还可以右击选择粘贴 剪切板上面的内容(参考 Client Explorer)。

add或edit的对话框(Add或Edit)是如下结构：

十六进制计数法(0x通常可以省略)通常用于这些的条目。也可以选择一个预定义的设备(例如.大容量存储器)，设置到列表里面。
例如，可以引用ID的供应商(供应商ID)。 如果在黑名单有一个USB条目，这将导致主控PC忽略这些USB设备。 主控PC同样可以忽略自定义的设备的ID、类、子类或协议的所有的设备。

说明 		在Client Explorer查看USB设备过滤器
Client Explorer可以被用作检查为一个特定的设备被配置了什么样的装置过滤器或目前可以被使用的设备。 Client Explorer显示了每一个USB目前的状态(见 Client Explorer).
编辑Device Use Local List

到CP-Link 3 1.4.x版本，Device Use Local List可以通过编辑客户机本身的注册表来配置 (见 在客户端上使用本地列表USB设备)。 从CP-Link 3 1.5.x版本开始，配置可以在主控PC上完成。 如果客户端已经有本地列表条目，它们显示在Device Use Local List标签下：

在Ignore on Client选项框打钩，client-side configured使用本地列表条目被忽略，只配置那些主控PC上的本地设备。
点击 Show / Import to Configuration按钮，显示一个client-side configured Use Local List entries列表：

使用Import按钮，选定的client-side configured Use Local List客户端条目被主控PC上的配置列表采用。

Serial

设置客户端的“虚拟串行端口”是在Serial标签下。 在name条目旁边出现一个星号，说明“虚拟串行端口”的部分设置已经改变，但是还没有通过Apply被激活。

客户端“虚拟串行端口”功能可以通过选择Serial进行使能或禁用。

可以在Com Port of Client 条目下选择端口名称，也可以通过Add添加端口列表。 需要指出的是，只有客户端的串行端口实际存在可以被使用。 当前选择的条目可以从列表中删除通过Remove。

点击Apply激活这些配置。 客户端第一次添加端口时，CP-Link 3将会删除原来已经安装的的串行端口，然后CP-Link 3再重新驱动每一个串行端口。 是使用“找到新的硬件向导”安装这些串行端口。 只有当客户端的TCP/IP连接已经建立，才会在列表中出现虚拟串行端口。

虚拟串行端口的当前状态可以通过点击Refresh从而显示在列表中。 这个列表也显示了客户端的COM端口(客户端COM端口)与主机上面的虚拟COM端口(主机串行端口)之间的映射关系。

端口的名称可以在相关设备的终端找到。 串行设备是内部连接，比如串行触摸屏被记录在设备描述中(例如.面板PC后面的标签)。

说明 		COM端口必须是可用的
只有当连接到客户端的COM端口实际存在并且可用才会安装一个虚拟的COM端口。

Elo触摸面板

一个Elo触摸面板,串行连接可以通过一个虚拟的串行端口进行操作。 需要为每一个选择的端口安装相似的Elo-Touch驱动。 所以，点击EloSetup.exe开始安装应用程序，依照程序的安装向导。

Graphics

客户端的“虚拟图形”的设备是在Graphics标签下。 如果在name标签旁边有星号说明“虚拟图形”的配置已经改变当时还没有通过Apply进行激活。

每个客户端“虚拟图形”的功能可以通过Graphics 选项框进行使能或禁用。

图片的左边显示的是在主控PC上可以使用的显示设备，通过数字显示。 列出的显示设备可以被手动分配给客户端，意味着客户端就应该显示指定的显示设备屏幕的内容。 指定的显示设备就会变为绿色，其他显示设备是蓝色。 如果有显示设备是不可用的，将会被画上交叉影线。 如果显示器图标是透明的意味着这些显示设备将不能分配给客户端。 这些设备包括额外安装的显卡或一个双头显卡的第二个输出设备(见 Functioning)。

将一个显示设备转让给客户端

首先通过点击一个显示器图标选择显示设备，并且可以看到被选中的显示器的边框变为蓝色。 同样，显示设备也可以从边上的(Device) 下拉选项框进行选择。 通过点击Use Selected Device for Client可以将选择的设备可以被分配给客户端或通过右击选择的显示设备。 被选定的客户端会显示为绿色。

说明 		分配显示设备
首次启用“虚拟图形”这个功能时，第一个显示设备自动分配给客户端。

主机/客户端显示设备的分辨率

当前选择的显示设备的分辨率和颜色深度显示在选项框的右边。 如果想更改这些描述的参数，通过点击 Setup对话框(见 组态接口-Setup)。 改变Windows XP系统的参数可以通过Windows display settings(见Windows显示设置)。

如果指定设备和所对应的客户端的分辨率不一样，客户端显示分辨率可以被修改或选择Fit to Client Screen Size选项框：

  • 假如没有选择Fit to Client Screen Size：
    如果指定的显示设备的分辨率低于客户端的分辨率，客户端的屏幕就会居中（有黑色边框）。 相反，指定的显示设备的分辨率高于客户端的分辨率，客户端的将会显示屏幕的左半部分。
  • Fit to Client Screen Size设置：
    如果指定的显示设备的分辨率低于客户端的分辨率，屏幕的内容将会被放大，使用客户端的整个屏幕进行显示。 如果指定的显示设备的分辨率高于客户端的分辨率，屏幕的内容将会被缩小，使用客户端的整个屏幕进行显示。 所有设备的分辨率并没有改变。 只是显示图形被放大缩小。

说明 		显示图形的质量
如果放大或缩小的比率不是整数，放大和缩小对显示图形的质量有一些负面的影响。

连接设置

每个客户端用于传送图形数据的协议可以单独设置。 默认情况下通过预置的TCP进行数据传输。 如果已经选择了TCP，图形数据单独发送给每一个客户。 这增加了数据传送到客户端的速度。 如果已经为一个或多个客户端设置通过UDP(UDP-Multicast)传动数据，与显示设备相关的图形数据通过网络进行传送，所有的客户端都分配给这个显示设备，因为设置了通过UDP进行数据传送，也可以得到这些数据。

通过UDP进行数据传送这样的优点是网络的带宽可以被减到最小。 相比较之下，通过UDP进行数据传送的一个缺点是是一种很容易受干扰。 通过UDP数据传送发生错误，将选择TCP作为传输协议。 然而这样就增加使用的客户端的带宽，当所需的带宽大于实际可用的带宽时， 有一个负面的影响。 在这样的情况下，所有的CP-Link 3的性能(虚拟USB，虚拟串行端口，虚拟图形)将会受到影响。


CP-Link 3 - 组态接口

BECKHOFF CP-Link 3: 配置

配置软件

位于图片上半部分的配置界面的客户端列表任然是空的，选中客户端的配置在图片的下半部分。

编辑客户所描述的客户端列表和配置部分见编辑客户端名单和客户端配置。

Setup

单击Setup打开设置的对话框，其中包括允许用户调整设备的分辨率，色彩深度和位置。 此外，可以安装/卸载额外的CP-Link 3-扩展桌面设备：

Display Devices

通过单击监视器上的方框图标选择一种显示设备，所选择的设备将会出现淡蓝色边框。 同样，显示设备也可以在下面的(Device)选择列表中选择。 选择的显示设备的属性现在可以可以在此对话框的下部修改。 监视器中方框图标的位置可以通过拖动它进行调节。 点击Apply将会激活这些设置。

CP-Link 3 -扩展桌面设备安装和卸载:
在CP-Link 3-扩展桌面设备中可以输入安装的扩展桌面的数量，可以通过单击Install additional device(s)安装扩展桌面。 在安装完成以后，需要重新启动操作系统。
在选择一个CP-Link 3-扩展桌面设备以后，设备也可以通过单击Uninstall selected device进行卸载。 在卸载过程完成以后 需要重启操作系统。

说明 		在Windows 7 / Windows XP中最多可能有10个显示设备
显示设备的数量最多不能超过10个，包括安装在硬件上的显卡有一个或多个显示设备，根据不同类型的(单头或双头) 进行连接。 CP-Link 3 -扩展桌面设备对应一个单头显卡，因此可以连一个显示设备。

说明 		检查许可证级别
只有具有CP-LINK3扩展桌面这个等级的授权，才能安装/卸载扩展桌面。

Miscellaneous

在CP-Link 3 Shell Extension区域CP-Link 3 Shell Extension可以被开启或关闭。 CP-Link 3 Shell Extension是用于扩展桌面文本菜单菜单(也可参考CP-Link 3 Shell Extension)。

About

单击About打开一个窗口显示当前许可证以及安装在电脑上的 CP-Link 3软件的版本信息。

点击OK关闭这个信息窗口。


CP-Link 3-Client Explorer

BECKHOFF CP-Link 3： 功能监视

客户机浏览器

CP-Link 3 Client Explorer是一个监控CP-Link 3功能的一个工具。 CP-Link 3组件的各种警告，错误信息及状态信息都显示在客户端浏览器上。

客户端浏览器用户界面的布局如下：

上部分图片是一个树结构，一方面显示了当前激活的CP-Link 3配置及包含了其他的当前状态信息。 下半部分图片是一个消息窗口，警告错误信息和状态信息是以文本的形式给出的。

树的层次结构：

1. 每个节点的第一级对应一个客户端：

根据当前的配置，节点的文本包含客户机的名称和IP地址。

2. 节点的第二级对应CP-Link 3客户端组件的 “虚拟USB”， “虚拟串行端口”及 “虚拟图形”，这个节点只描写这些组件激活配置。 同时这样的节点的图标是提供了当前组件的状态信息：

- 组件没有网络连接。 主控PC试图连接到客户端。

- 该组件是一个无效的或者是一个错误的状态。 在这种情况消息窗口中显示一个相应的消息(见下文)。
网络与组件已经建立连接，该组件是在初始化阶段。
网络已经和组件连接，初始化阶段已经成功的完成了。
网络已经断开和组件的连接，该组件是在去初始化阶段。
该组件已从配置中被删除，处在去初始化阶段。

3. 第三层次的节点包含了相应的组件的详细信息。

3.1节点下面的一个USB节点： 每一个节点就代表一个客户端连接的USB设备。 节点文本包含了从设备的一端以及在其他的设备群读取的产品的描述。 这样的一个节点的图标提供了当前USB服务的 状态信息：

客户端的USB设备可以通过“虚拟USB”在主机电脑上面使用。
客户端的USB设备可以通过“虚拟USB”在主机电脑上使用，用法是这样的，但是不允许更改主机电脑配置。 在USB设备黑名单里有一个与这个设备的匹配条目(USB装置过滤器列表)。
客户的USB设备可以通过“虚拟USB”在主机电脑使用，在USB设备黑名单以及USB设备的白名单里都有一个这个设备的匹配条目也可参考USB设备筛选器列表)。
客户的USB设备不能通过“虚拟USB”在主机电脑使用，这种装置在本地客户端使用。 在使用本地USB设备的列表中有一个这个设备匹配条目(也可参考USB设备筛选器列表)。

USB设备上 的一个USB设备节点都有子节点包含了详细的信息(制造商、 序列号、 等等) 。

右击一个USB设备打开一个文本菜单你可以向过滤配置的列表中添加选中USB设备(参见客户端配置或者 USB设备过滤列表)：

如果你把设备信息复制到剪贴板(复制到剪贴板)你可以在配置窗口粘贴复制的信息来创建一个设备过滤条目 (参见 客户端配置-编辑USB设备过滤表)。

3.2节点下面一个串行节点： 每个节点代表了一个客户端的串行接口，可通过 “虚拟串行端口”在主机电脑上使用。

节点文本中包含在主机电脑中创建的虚拟串行接口的名称以及对应的客户的串行接口的名称。

消息窗口：

在消息窗口中状态信息和错误消息是按时间显示的。 每个条目都有一个时间戳字段，一个消息申请的客户端字段，一个组件对应的相应的客户端字段，一个它自己消息字段。 错误信息用突出的红色显示。

鼠标右键点击输出字段的顶部打开一个用于选择显示还是不显示组件的信息的字段。

几个输出字段上面的选择框允许定义不同的过滤器。 这些过滤器决定输出字段中哪些信息是显示的或哪些是不显示的。 可以通过使用下列标准的任何组合进行过滤：

  • 过滤某些clients的消息： 根据选择的所有客户端的信息(所有客户端)或在树结构中选择的客户端的消息(仅仅显示这)两者之一。 默认情况下，显示所有客户的信息。

  • 过滤某些components的信息： 显示所选的组件的信息。 默认情况，显示所有组件的消息。

  • 过滤某些类型的messages： 根据所选择的显示所有消息(故障信息及消息)或仅仅是故障信息两者之一。 默认情况，显示所有组件的消息。

在选择框的边上还有更多的有关消息过滤器的按钮：

  • Autoscroll On/Off-如果选择自动滚动开，当有一个新条目插入到消息窗口时，窗口的内容滚动至在消息窗口中可以看见新的消息范围内。 如果选择自动滚动关，自动滚动式关闭的，也就是说窗口的内容不会因为一个新的条目滚动。
  • Copy -所有被选中的消息被复制到剪切板上。
  • Clear All -删除所有的信息。


CP-Link 3 - Network 拓扑结构

BECKHOFF CP-Link 3: Miscellaneous

网络拓扑结构

关于使用CP-Link 3请注以下几点：

  • 建议为CP-Link 3使用单独网络。
  • 通过网络使用的PC必须使用树结构连接在一起，即客户端直接或通过一个或则几个交换机连接到主机电脑。 不可能用环结构、总线结构或串行结构(菊花链)。
  • 两台电脑之间或交换机之间的网络电缆的最大长度为100m。
  • 如果一个主机PC通过实时以太网使用USB总线耦合器内置到客户端，可能还需要为实时以太网使用一个单独的网络(见 使用CPx8xx USB总线耦合器)。


CP-Link 3 - RTEthernetConfig

BECKHOFF CP-Link 3: Miscellaneous

配置实时以太网设备

通过安装特殊的TwinCAT Intel PCI Ethernet适配器驱动程序，网络适配器就变成了实时以太网适配器。 安装完成后在TwinCAT System Manager选择"Options|Show Real Time Ethernet Compatible Devices ..." 对话框。

说明 		CP-Link 3和实时 Ethernet
如果相同的网络适配器用于CP-Link 3作为RT Ethernet在某些特定的情况下会导致失败(见 说明或 故障排除)。 此外，图像数据必须通过TCP/IP发送，由于客户端的实时Ethernet适配器不再接受UDP组播数据包(见 客户端配置)。

向I/O Configuration中添加一个RT Ethernet

一个实时Ethernet设备可以通过"Append Device"被添加到I/O Configuration中。 在Adapter标签下RT device与RT Ethernet adapter相关联。 实时Ethernet设备的周期时间是通过DevState变量与任务变量间接决定的。 任务的周期时间然后定义实时Ethernet设备的周期时间。

下面的插图显示了一个主机PC的I/O Configuration包含一个RT Ethernet设备：

下面的插图显示了一个客户端的I/O Configuration包含一个RT Ethernet device：

RT Ethernet设备的Routing configuration

在Routes标签下有必要选择Enable Routing。 主机PC和客户端PC的NetIds分别输入在各自的主机与客户端Route标签下的Own Netld中。

客户端实时以太网的Netld被添加到主机pc的“Routes”标签下:

主机PC实时以太网的Netld被添加到主机pc的“Routes”标签下:


CP-Link 3-Firewall 配置

BECKHOFF CP-Link 3: Miscellaneous

防火墙配置

//对于通过网络参与CP-Link 3的数据传输,一些防火墙必须被被配置为活跃的防火墙,//以允许CP-Link 3的参与者可以通过防火墙进行通讯. 在安装过程中CP-Link 3软件安装程序配置这些防火墙.

接下来的表格显示了对CP-Link 3客户端的防火墙规则:

组件 | Direction | 端口(十进制) | 协议 | 行为
“虚拟图形” | Incoming | 60000 | UDP | Allow
“虚拟图形” | Incoming | 60001 | TCP | Allow
“虚拟图形” | Incoming | 60002 | TCP | Allow
“虚拟USB” | Incoming | 60308 | TCP | Allow
“虚拟串行端口” | Incoming | 60309 | TCP | Allow
UPnP Network Discovery | Incoming | 2869 | TCP | Allow


CP-Link 3 - USB Device Filter Lists

BECKHOFF CP-Link 3： Miscellaneous

USB装置过滤器列表

可以定义每一个客户端的一组USB设备过滤器列表都-即黑名单，白名单以及使用本地列表(见 客户端配置)。 在这些列表中每个条目可以表示一个USB设备的特定群体。

设备黑名单

主控PC忽视了在黑名单中匹配的条目USB设备
如果“虚拟USB”是活跃的，在黑名单条目有一个与客户端USB设备条目相同，那么它将不会通过"虚拟USB"连接到主控PC。 这个USB设备在主控PC和客户端都是不可用的。

设备白名单

白名单设备的一个匹配条目覆盖设备黑名单中匹配的。 主控PC不会忽略这样一个USB设备，即使在黑名单中有一个与这个USB匹配的条目。
如果“虚拟USB”是激活的以及客户端的USB 设备在黑名单和白名单中都有一个与其相同的条目，“白名单”条目覆盖了黑名单条目，这个设备将会通过"虚拟USB"连接到主控PC上。 这可能对阻止特定类别的USB设备是有用的，例如. HID - Human输入设备，允许阻止这个设备的一个子设备，例如：键盘。

使用本地列表设备

在使用本地列表设备有某一个USB设备的匹配条目，那么这个设备是由客户机在本地使用。
如果“虚拟USB”是活跃的，但在使用本地列表中有一个条目与客户机的USB设备的相同，它将不会通过"虚拟USB"连接到主控PC。 相反这个设备可以被客户机在本地使用。

作用方式

描述的设备过滤器列表是被每一个客户端的USB设备应用如下：

  1. 使用本地列表设备
    使用本地列表是应用在客户机本身。 如果有一个USB设备相同的条目，它将被介绍到客户端的OS，因此可以在本地客户机上使用 。 否则，如果没有和这个USB设备的相同条目，它将通过“虚拟USB”连接到主控PC。
  2. 设备黑名单
    如果在使用本地设备列表中没有与USB设备想匹配的条目，设备黑名单将会被应用在主控PC上。 如果在黑名单中没有与该USB设备相匹配的条目，该设备将会被介绍到主机的OS，因此可以在主控PC上使用。 如果相反有与USB设备相匹配的条目，它将不会被介绍给主机的OS，但是设备白名单将被应用。
  3. 设备白名单
    如果在黑名单中有与该USB设备相匹配的条目，它将不会被介绍到主机的OS，但是设备白名单将被启用。 如果在白名单中有与该设备相匹配的条目，它将被介绍到主控OS不管黑名单中的匹配条目。 “白名单”条目覆盖了黑名单条目以及这个设备可以在主控pPC上被使用。 另一方面，在白名单中没有与USB有相匹配的条目，那么它将不被介绍到主机的OS。 USB设备在主机和客户端上都不能使用。

说明 		USB设备过滤器在Client Explorer中显示
Client Explorer被用作检查哪个设备已经配置了一个特定的USB设备或这些设备被使用的方法。 Client Explorer显示了当前每一个USB设备的状态(见 Client Explorer)。


CP-Link 3 - Windows Display 设置

BECKHOFF CP-Link 3： Miscellaneous

窗口显示设置(XP)

配置显示设置的Windows对话框可以通过文本菜单或控制面板打开。 分辨率，颜色深度，位置等等所有的显示设备都可以在这里设置。 CP-Link 3显示设备也可以通过这个对话框设置。

说明 		在Windows 7改变显示设置
Windows 7系统可以通过Setup对话框更改CP-Link 3-扩展桌面设备的显示设置(见Configuration interface- Setup)。

可以通过点击相应的监控符号选择显示设备，选中以后可以从边框颜色看出来。 现在可以在对话框的下半部分设置选中的显示设备。

特殊设置的方法

在Windows下没有分辨率小于800 x 600像素的标准，因此只有可能间接设置。 这里以设置640 x 480的分辨率显示作为一个例子：

在点击Advanced按钮以后，打开一个设置扩展图形的新的窗口：

如果你点击在Adapter标签下的List All Modes 按钮，适配器支持的所有功能的模块将会列出来：

在选择所需的分辨率后，应用通过点击OK按钮。

DirectX / OpenGL

不支持DirectX 及 OpenGL。


CP-Link 3 - Shell Extension

BECKHOFF CP-Link 3： Miscellaneous

CP-Link 3 Shell扩展

CP-Link 3 Shell扩展扩展桌面的文本菜单。 额外的文本菜单窗口可以移动到其他桌面上显示，因此在自己的桌面上是不可见的。

桌面文本菜单可以通过在桌面上右击打开：

如果把鼠标移到CP-Link 3选项上，将有一个列表显示当前主机电脑打开的所有窗口。

如果一个窗口现在被鼠标选中,他将会移动到文本菜单中那个指定的桌面。


CP-Link 3 - HID Focus

BECKHOFF: CP-Link 3: Miscellaneous

手动设置HID focus

描述如何手动设置HID focus(见 客户端配置-HID-Focus)。

说明 		基本知识要求
手动设置HID focus前提是知道如何使用twincat system的一些基础知识

下面的插图计划性的显示在手动设置HID Focus时hostPC的流程：

“CP-Link 3远程端口Enumerator”的驱动有一个接口，通过该HID focus可以设定为一个特定的客户端。 HID focus也可以通过这个接口被重启。 这个驱动接口可以通过ADS间接访问，也就是通过一个ADS服务器，实现了"CP-Link 3服务 因此这个接口同样也可以在TwinCAT PLC中使用。 通过一个PLC库用法被简化(TcCPLink3.lib)。 CplHidFocusSelect.pro示例程序阐明了库文件里 FB_CPLink3_AcquireHidFocus 功能块可以使用。 当CP-Link 3被安装好，示例程序和库被放在安装程序目录Plc的子文件夹中。 (见 FB_CPLink3_AcquireHidFocus )。

说明 		客户端配置
只有客户端配置了手动设置HID Focus才可以手动设置HID Focus(见 客户端配置 - HID-Focus)。

说明 		CP-Link 3服务
只有在CP-Link 3服务正在运行才可以手动设置HID Focus(见CP-Link 3 Service)。

示例程序: 通过special keys控制HID focus

手动设置HID focus，例如被客户端的special key控制 通过TwinCAT System Manager在PLC程序中特殊的键连接到相对应输入变量。 为每个客户端生成 FB_CPLink3_AcquireHidFocus的一个实例及配置客户端的IP地址 在一个客户的special key被按下以后，将通过R_TRIG功能模块检测到上升沿，PLC程序将通过相应的 FB_CPLink3_AcquireHidFocus实例尝试设置HID focus。 这个功能块可以做到，此外还控制一个输出(如LED)显示是否HID focus已经成功的被设置或是否它仍然试图获得焦点 再次按下special key将会重置HID focus。

FB_CPLink3_AcquireHidFocus功能块的三个实例是使用hFocus变量相互之间交换信息。 这可以用于例如确保只有实例成功设置HID focus才可以重置它 。

三个客户端的PLC程序如下:

PROGRAM MAIN
VAR
button1 AT%IX0.0 : BOOL;
button2 AT%IX0.1 : BOOL;
button3 AT%IX0.2 : BOOL;

led1 AT%QX0.0 : BOOL;
led2 AT%QX0.1 : BOOL;
led3 AT%QX0.2 : BOOL;

hFocus : T_HCPLink3HidFocus;
fbPanel1 : FB_CPLink3_AcquireHidFocus := ( setIP := '192.168.1.1' );
fbPanel2 : FB_CPLink3_AcquireHidFocus := ( setIP := '192.168.1.2' );
fbPanel3 : FB_CPLink3_AcquireHidFocus := ( setIP := '192.168.1.3' );

trigger1 : R_TRIG;
trigger2 : R_TRIG;
trigger3 : R_TRIG;
END_VAR

(* Panel 1 *)
trigger1( CLK := button1 );
IF trigger1.Q THEN
fbPanel1.bEnable := NOT fbPanel1.bEnable;
END_IF
fbPanel1( hFocus:= hFocus, bLED=>LED1);

(* Panel 2 *)
trigger2( CLK := button2 );
IF trigger2.Q THEN
fbPanel2.bEnable := NOT fbPanel2.bEnable;
END_IF
fbPanel2( hFocus:= hFocus, bLED=>LED2 );

(* Panel 3 *)
trigger3( CLK := button3 );
IF trigger3.Q THEN
fbPanel3.bEnable := NOT fbPanel3.bEnable;
END_IF
fbPanel3( hFocus:= hFocus, bLED=>LED3 );

CP-Link 3 ADS 接口

CP-Link 3 ADS服务器可以通过AMS端口19300连接。 目前实现的功能之一是:

AdsWrite

SetHidFocus
IndexGroup: 0x10000
IndexOffset: IP Address in network byte order or 0 to clear HID-Focus

Possible ADS return values:
ADSERR_DEVICE_INVALID_STATE - CP-Link 3 Remote Port Enumerator returned that command was not valid
ADSERR_DEVICE_NOT_FOUND - CP-Link 3 Remote Port Enumerator not installed
ADSERR_DEVICE_ERROR - CP-Link 3 Remote Port Enumerator returned an error
ADSERR_DEVICE_BUSY - HID-Focus was not set as another client has the focus
ADSERR_NOERR - HID-Focus was set to given client


CP-Link 3 - Service

BECKHOFF CP-Link 3： Miscellaneous

CP-Link 3 Service

CP-Link 3 Service提供了一个ADS接口为了可以手动设置HID-Focus(见手动设置HID focus)。 从CP-Link 3 1.3.xx版本开始，CP-Link 3 Service实现了可以作为TwinCAT Server，在早期版本中是作为Windows Service application。

CP-Link 3 Service作为TwinCAT Server(从CP-Link 3 1.3.xx版本开始)

  • 如果在你电脑上安装CP-Link 3之前已经安装了TwinCAT，CP-Link 3 Service在安装的过程中自动的注册为TwinCAT Server。
  • 但是在你的电脑上安装TwinCAT之前已经安装了CP-Link 3，你需要手动注册CP-Link 3 Service作为TwinCAT Server。

说明 		手动注册把CP-Link 3 Service作为TwinCAT Server
在你的电脑上安装TwinCAT之前已经安装了CP-Link 3，CP-Link 3 Service随后必须注册为TwinCAT Server。 这个过程需要停止TwinCAT System。 打开command-line窗口并导航到CP-Link 3 program directory的子文件夹Services中，例如。 "C:\Program Files\Beckhoff ：\CP-Link 3\Services"。 现在在command-line中输入"CPLink3Service.exe /RegTcServer"注册CP-Link 3 Service作为TwinCAT Server。 出现一个窗口给出有关注册结果的信息。

你可以使用TwinCAT Storage Editor证实CP-Link 3 Service被注册为TwinCAT Server。

CP-Link 3 Service是作为Windows Service application(CP-Link 3 1.2.xx之前的版本)

在安装CP-Link 3的过程中，CP-Link 3 Service被自动的注册为Windows Service application。

说明 		验证状态，修改属性
管理Windows Service applications的列表可以通过start menuStart -> Control Panel -> Administrative Tools -> Services打开。 CP-Link 3 Service的状态应该是"Started"以及启动类型应该是"Automatic"。 如果不是，需要根据前面的的标准配置这个service。

万一CP-Link 3 Service不在services列表中，必须手动注册为Windows Service application。 打开一个command-line窗口以及导航到CP-Link 3目录文件夹Services的子文件夹中， 例如 C：\Program Files\Beckhoff ：\CP-Link 3\Services"。 现在把"CPLink3Service.exe /RegServer"以及"CPLink3Service.exe /service"输入到command-line。 刷新services窗口。 现在CP-Link 3 Service就应该在services列表中。 也许你需要修改service的属性来匹配上述的标准。


CP-Link 3 - Using USB Devices – 本地，

BECKHOFF CP-Link 3: Miscellaneous

在客户端使用本地的USB设备

可能需要在客户端上使用特定的USB设备。 这个配置就是使用所谓的使用本地列表设备。 使用本地设备是一个过滤器列表。 在使用本地列表中的每一个条目是一个过滤器，代表一个被客户端在本地使用的USB设备特定的的群体(见使用本地列表设备)。

说明 		从CP-Link 3 1.5.x版本开始，配置使用本地列表在主控PC上完成
到CP-Link 3 1.4.x版本，使用本地列表设备通过编辑客户端本身的注册表进行配置。 从CP-Link 3 1.5.x版本开始，配置使用本地列表在主控PC上完成(见 客户端配置)

添加设备到Device Use Local List (到CP-Link 3 1.4.x 版本)

Device Use Local list被存储在客户端的注册中心在the Key HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff ：\CP-Link 3\UsbDeviceServer\UseLocalList。 在Key下面nListEntryCount值给出了列表条目的数量。 对列表中的一个条目就意味着一个sub-key被创建完成，它的名字是八个字符的十六进制指数(zero-based)。 每一个过滤器的子项可以使用"VendorId"， "ProductId"， "InterfaceClass"， "InterfaceSubClass"，和"InterfaceProtocol"这些值定义，代表一群USB设备。

例如，一个列表的条目代表了所有的USB存储设备。

[HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\CP-Link 3\UsbDeviceServer\UseLocalList]
"nListEntryCount" = dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\CP-Link 3\UsbDeviceServer\UseLocalList\00000000]
"Name" = "Mass Storage"
"VendorId" = dword:00000000
"ProductId" = dword:00000000
"InterfaceClass" = dword:00000008
"InterfaceSubClass" = dword:00000000
"InterfaceProtocol" = dword:00000000

说明 		注册文件的例子
有一些例子被存储在主控PC的程序目录中在CE\Regfiles subfolder。 从1.1.19版本开始注册表文件示例也被复制到客户端通过CAB文件安装。 在"\Hard Disk\Regfiles\Samples\CP-Link 3"目录中。 在Windows CE资源管理器中注册文件的值可以被转移到注册中心通过双击这个文件。

在使用本地设备列表中删除设备(到CP-Link 3 1.4.x版本)

如果一个条目需要从使用本地设备列表中被删除，相对应的subkey必须先被从注册中心移除 。 除此之外nListEntryCount值也必须被修改，必须确保列表中其余的 subkeys条目从00000000开始(八位十六进制零)不断提升顺序编号的数值。


CP-Link 3 - Using the CPx8xx USB 总线耦合器

BECKHOFF CP-Link 3: Miscellaneous

使用CPx8xx USB总线耦合器

CPx8xx型号的总线耦合器是集成到Beckhoff面板PC中的。 各种不同的I/O终端都连接在这些总线耦合器上。 除了一个面板PC标准I/O通道，还可以连接更多的I /O终端，例如通过特殊的键，led灯，旋转开关或类似的项目可操作。 当一个面板PC被用作CP-Link 3客户端，在主机电脑上可能有不同的方法访问客户端的集成USB总线耦合器：

1. 通过CP-Link 3虚拟USB集线器使用

2. 通过“虚拟USB接口(远程)”访问

A.通过Ethernet标准

B.通过RT-Ethernet

3. 通过网络变量(RT Ethernet)访问

4. 通过ADS task或PLC variables linked访问本地客户端上的链接

A.通过标准型 Ethernet

B.通过RT-Ethernet

变量之间的区别解释如下表:

 | 总线耦合器连接到 |  | I/O访问 |  | RT Ethernet | 配置effort | //输出可能Dropout(参考表格下面的解释：)//
 | 主控 PC | 客户端PC | 主控PC | 客户端PC
1 | X |  | X |  |  | low | Yes
2. a |  | X | X |  |  | low-medium | Yes
2.B |  | X | X |  | X | medium | No
3 |  | X |  | X | X | medium-high | No
4. a |  | X |  | X |  | high | No
4.B |  | X |  | X | X | high | No

//USB总线耦合器的输出可能dropout：
内置的客户端USB总线耦合器需要一定的时间间隔可以接收数据写入输出。 CPx8xxx总线耦合器标准配置的间隔时间是100 ms。 如果时间间隔不足100ms，总线耦合器的输出将dropout。 根据使用的USB总线耦合器，实际上在某种特定的条件下，时间间隔可能无法实现以及总线耦合器的输出dropout。 一般来说，这中情况基本不发生，但不能完全排除。 这个情况的原因是类型的网络连接到总线耦合器集成到客户端主机PC或主机电脑的操作系统的架构。 如果在I/O通过标准以太网连接访问主机电脑时发生，在数据与总线耦合器进行交换期间，许多小的数据包。每个周期必须发送连续的IP连接 网络负载和客户端CPU负载发送这些数据包的时间多于定义的时间间隔。
为了确保输出在任何情况下不dropout，I/O从主机电脑访问必须通过 RT Ethernet或者I/O，访问的必须是客户端电脑本身。 如果I/O访问发生在客户端本身这只不过是增加了输入和输出的总线耦合器的配置的effort不能在主机电脑上直接使用，但是必须通过ADS或network变量。

说明 		CP-Link 3及RT Ethernet
如果相同的网络适配器运用CP-Link 3作为RT Ethernet，RT Ethernet影响CP-Link 3的数据吞吐量。 决定于实时任务的周期时间这个影响是很大的，以至于大幅减少了CP-Link 3的性能。

此外，当通过一个RT Ethernet适配器使用CP-Link 3在一定的条件下可导致连接失败(见章节 说明或可选方案 故障排除)。
此外，图形数据必须通过TCP/IP发送，由于客户端的RT Ethernet适配器不接受UDP Multicast数据包(参考 Client configuration)。

因此在某些情况下它可能是合理的使用一个单独的RT Ethernet网络适配器。

1. 通过CP-Link 3虚拟USB集线器使用

在这种情况下，主机电脑看到CPx8xx总线耦合器连接在本地计算机。 由于这个原因也可以通过System Manager解决和配置。 在一个周期的第50ms和80ms之间数据可以和总线耦合器交换。 这涉及到创建任务在适当的周期时间，无论是在TwinCAT PLC或直接在TwinCAT System Manager中，在这个任务中至少连接一个变量从总线耦合器的I/ O通道的变量(见cycle time for data exchange)。

设备USB总线耦合器的数量

如果许多总线耦合器连接到主机电脑，用户必须确保总线耦合器被分配不同的号码。 出厂时集成到面板型PC总线耦合器有效字为0。 如果两个连接的总线耦合器有同样的号码，TwinCAT System Manager仅仅可以识别其中的一个总线耦合器。 在TwinCAT System Manager中， 在“BK95xx/CPx8xx”选项卡中的“Dip switch”右侧的“Change to”按钮可以更改Box参数。 通过点击这个按钮这个值被传送到总线耦合器。 当这个configuration被再次扫描的时候新的box number也是认可的:

Device Handle of the USB Bus Coupler

默认情况下，Device Handle的一个USB总线耦合器是由操作系统生成的名称。 当在一定的条件下通过CP-Link 3使用一个USB 总线耦合器(例如. 例如网络连接断开和重新连接后)这个名字会改变。 在这种情况下System Manager configuration重新配置。
为了从一开始就避免这种影响 Virtual Device Names 选项可以被激活。 在这个方法的基础上，总线耦合器的设备号是唯一的，virtual device name被创建为Device Handle:

2. 通过“虚拟USB接口(远程)”访问

在这种情况下，CPx8xx 总线耦合器被用作一个客户端作为一个当地的USB设备。 在客户端上的CP-Link 3USB设备服务器是通过“se Local List”配置 (也可参考 在本地客户端上使用USB设备)。 从主机PC到I/O通道的总线耦合器的访问不通过CP-Link 3虚拟USB集线器运行而是通过客户端上的总线耦合器的驱动运行ADS。 优势在于在每个周期内更少的数据包通过网络连接发送。 由于这个原因所以使用标准Ethernet通信，用这种方法几乎从未使用超时100ms。 在这里，然而在理论上是不可能排除这种可能性，发送数据包所需的时间将会变得更长。 如果通过RT Ethernet通信数据交换肯定被执行以及输出不能dropout。

说明 		需要TwinCAT v2。11 Build 1542
“虚拟USB接口(远程)”的设备支持TwinCAT 2.11 Build 1542。

2.一个通过标准型 Ethernet“虚拟USB接口 (远程)”

在TwinCAT System Manager中一个“虚拟USB接口(远程)”设备可以插入到“I/O设备”节点通过configuration菜单中的“Append Device”选项。 在“USB”节点可用列表中可以找到“虚拟USB接口 (远程)”设备。
添加“虚拟USB接口(远程)”设备

在设备已经被添加到NetID目标系统中以后可以在“Remote”标签中重新定义。 这个可以直接输入或通过“Choose Target”按钮确定。 当这个目标系统已经到达，然后这个connected boxes可以想平常一样处理和配置。 推荐的总线耦合器终端进行数据交换的周期时间任然为50-80ms(见 数据交换的周期时间)。

说明 		一个USB总线耦合器仅可以用于一个TwinCAT IO 系统。
必须保证USB总线耦合器不是通过两个不同的TwinCAT I/O systems。 当USB耦合器是通过ADS从主机的TwinCAT I/O系统中读取的，然后它可能不能通过本地客户端的TwinCAT I/O系统再被使用。

2.B 通过实时Ethernet的“虚拟USB接口 (远程)”

当一个实时Ethernet连接用于和“虚拟USB接口(接口)”进行通信数据交换是在固定的周期时间内，以及这使得CPx8xx的I/O通道可以被读和写。 推荐的与总线耦合器终端进行数据交换的周期时间 任然为50-80ms(见 数据交换的周期时间)。

建立以太网Ethernet:

  • PC主机和客户端网络适配器都必须配置作为一个实时Ethernet设备以及添加到I/O configuration中(见 实时Ethernet D设备)。
  • 在主机PC和客户端“Routing”必须为实时Ethernet开启。 此外每一个实时Ethernet设备的NetIds必须分别输入在“Routes”标签中(见实时Ethernet设备配置)。

进行更多的配置如2.a所述除了“虚拟USB接口(远程)”通信，客户端实时Ethernet设备将会作为目标系统添加(这不同于平常的NetId)。

3. 通过网络变量(实时Ethernet)访问

在这种情况下，CPx8xx总线耦合器作为一个当地的USB设备在客户端上使用。 在客户端上的CP-Link 3USB设备服务器配置通过“Use Local List”(见 使用本地客户端的USB设备)。 从主机电脑访问I/O通道的总线耦合器得以实现通过使用网络变量(见网络变量)。

建立实时Ethernet：

  • PC主机和客户端网络适配器都必须配置作为一个实时Ethernet设备以及添加到I/O configuration中(见 实时Ethernet设备)。

访问总线耦合器输入：

访问总线耦合器输入，“Publisher”被添加到客户端实时Ethernet设备以及"Subscriber"被添加到主机PC实时Ethernet设备。

一个或多个网络变量被添加到客户端的Publisher被映射到一个总线耦合器的输入。 publisher网络变量，在这个例子“Pub-Var CPX8XX 输入”与总线耦合器的输入变量。

实时Ethernet设备周期时间定义了与总线耦合器进行数据交换的周期时间。 推荐的与总线端子终端进行数据交换的周期时间在50-80ms之间(见 数据交换的周期时间)。

一个或多个网络变量被添加到主机PC Subscriber中，添加的网络变量的配置与客户端上的网络变量的配置相同。 在Publisher computer已经被搜索以后出现一个对话框，会显示一个所有Publisher变量的列表，并且相应的变量可以被添加到Subscriber中。

主机PC网络变量现在可以与PLC或task variables联系。

访问总线耦合器输出：

用于访问总线耦合器输出的“Subscriber”被添加到客户端的实时Ethernet设备中以及“Publisher”被添加到主机的实时Ethernet设备。

一个或多个网络变量被添加到主机PC Publisher根据PLC或task variables映射在总线耦合器的输出。 Publisher网络变量，在 “Pub-Var CPX8XX 输出”这个列子中是与相应的PLC或task variables联系在一起。

一个或多个网络变量被添加到客户端Subscriber，在主机PC上配置相应的网络变量。 在Publisher computer已经被搜索以后出现一个对话框，会显示一个所有Publisher变量的列表，并且相应的变量可以被添加到Subscriber中。

客户端网络变量现在可以与输出变量的总线耦合器相联系。

实时Ethernet设备的周期时间定义了与总线耦合器的进行数据交换的周期时间。 推荐的和总线耦合器终端之间进行数据交换的时间在50-0ms之间(见 数据交换的周期时间)。

4. 通过ADS访问task或PLC variables联系本地的客户端

在这种情况下，CPx8xx总线耦合器是用于客户端作为一个当地的USB设备。 在客户端上的CP-Link 3USB设备服务器相应的配置是通过“Use Local List”(见 使用本地客户端USB设备)。 从主机PC到I/O通道的总线耦合器访问可以通过使用ADS实现。 在这种情况下总线耦合器I/O通道被映射到I/O任务变量中。 这些变量可以在主机PC上通过ADS读(见ADS介绍)。

4.通过标准型Ethernet一个ADS访问

在一个简单的PLC列子中ADS访问到客户变量应该显示在这里。 一个任务被添加到客户端系统配置。 根据输入和输出通道的总线耦合器，任务变量必须被添加以及与输入和输出变量的总线耦合器有联系。

在主机PC PLC program中客户端任务变量“ADS Info”用于ADS通信。

访问一个主机输出总线耦合器的PC PLC program可能看起来像这样:

PROGRAM MAIN
VAR
fbAdsWrite ： ADSWRITE；
netId : STRING := '5.3.112.17.1.1';
port : WORD := 301;
idxGrp : UDINT := 16#F030;
idxOffs : UDINT := 16#0;
data : WORD := 2#1010101010101010;
dataLen :UDINT := 2;
state :BYTE := 0;
END_VAR

CASE state OF
0:
fbAdsWrite(
NETID := netId,
PORT := port,
IDXGRP := idxGrp,
IDXOFFS := idxOffs,
SRCADDR := ADR(data),
LEN := dataLen,
WRITE := TRUE,
TMOUT := T#1s
);

IF fbAdsWrite.ERR THEN
state := 2;
ELSE
state := 1;
END_IF

1:
fbAdsWrite(WRITE := FALSE);
IF fbAdsWrite.ERR THEN
state := 2;
ELSE
IF NOT fbAdsWrite.BUSY THEN
state := 2;
END_IF
END_IF

2:
fbAdsWrite(WRITE := FALSE);
state := 0;
END_CASE

4.B 通过实时Ethernet的ADS访问

当一个实时以太网接口被用作ADS通讯，数据交换消耗确定的周期时间，这允许I/O通道的CPx8xx进行读和写 推荐的与总线耦合器的终端进行数据交换的周期时间仍然在50-80ms之间(见数据交换的周期时间)。 。

建立实时Ethernet:

  • PC主机和客户端网络适配器都必须配置作为一个实时Ethernet设备以及添加到I/O configuration中(见 实时Ethernet的配置)。
  • “Routing”必须开启为了主机PC和客户端的实时Ethernet设备。 此外，每个实时Ethernet设备的NetIds必须分别输入到“Routes”列表中(见实时Ethernet设备配置)。

进一步的配置操作如4.a中描述的一样，除了在PLC program中，客户端实时Ethernet设备的输入作为ADS通讯的NetId(这不同于一般的NetId)。

与总线耦合器数据交换的周期时间

推荐的与总线耦合器终端进行数据交换的数据时间在50-80ms之间。 为了满足于耦合器进行数据交换的周期时间有以下建议：

  • 与I/O通道的总线耦合器有联系的tasks变量必须配置一个大于50ms周期时间。
  • 与I/O通道的总线耦合器有联系的tasks变量必须配置一个小于50ms的周期时间。 在这种情况下有必要为总线耦合器激活Async Mode：


CP-Link 3 - 更新 of TcUsb.sys

BECKHOFF: CP-Link 3: Miscellaneous

TcUsb.sys的更新

取决于安装的TwinCAT的版本以及CP-Link 3和TwinCAT的安装顺序，可能还需要更新驱动文件TcUsb.sys。

  • 如果你在电脑上安装CP-Link 3之前已经安装了TwinCAT，将会检查驱动文件TcUsb.sys的版本，如果必要将会被一个新的版本替代。 在这种情况下更新是没有必要的。
  • 如果你在电脑上安装TwinCAT之前已经安装了CP-Link 3，TwinCAT的安装过程中将会以一个老的版本替代TcUsb.sys这个驱动文件。 在这种情况下你需要检查版本如果有必要更新这个文件。

检查版本

打开Windows Explorer并导航到: C:\Windows\System32\drivers。 如果TwinCAT已经安装了将会包含TcUsb.sys。 可以通过文件属性检查版本号(右击 ->Properties)在Version标签下:

如果TcUsb.sys的版本低于2.10.0.54，有必要更新这个文件。

执行更新

说明 		检查TcUsb.sys的版本
如果TcUsb.sys需要更新总是检查TcUsb.sys的版本(见上面)。

打开Windows Explorer以及导航到: C:\Windows\System32\drivers。 重命名TcUsb.sys这个文件，例如 TcUsb_old.sys。 在CP-Link 3程序目录的子文件夹“Drivers”包含TcUsb.sys这个文件。 复制这个文件到C:\Windows\System32\Drivers。

说明 		重新启动操作系统：
在更新TcUsb.sys完成以后，需要重新启动操作系统!


CP-Link 3 - LaunchApp

BECKHOFF CP-Link 3： Miscellaneous

CP-Link 3 LaunchApp

CP-Link 3 LaunchApp是一个命令行应用程序可以启动任何一个应用程序，在特定的监控窗口打开一个特定大小的应用程序窗口。 你可以得到一个详细的CP-Link 3 LaunchApp用法描述，当你通过没有任何参数的命令行启动系统。 打开一个命令行窗口，导航到CP-Link 3程序目录Tools的子文件夹 例如 "C：\Program Files\Beckhoff\CP-Link 3\Tools"。 现在"CPLink3LaunchApp。exe"导入到命令行中 。


CP-Link 3-Hints for 布线

BECKHOFF CP-Link 3： Miscellaneous

提示布线

为了确保CP-Link 3的正常运转， 请注意以下关于CP-Link 3连接设备布线的提示。

  • 注意提示中列出的部分 网络拓扑结构。
  • 应该将网络电缆和电源连接线分开。 (充分)屏蔽网络电缆。
  • 确保所有CP-Link 3连接的设备有相同的零电位，通过网线以避免潜在的均衡。


CP-Link 3 - 说明

BECKHOFF: CP-Link 3: 附录

说明

常见的问题：

  • TwinCAT RT-Ethernet驱动程序

    如果CP-Link 3使用一个网络适配器同时这个适配器也被配置为TwinCAT RT-Ethernet适配器，这将导致在网络使用量比较大时会连接失败。
    请使用TwinCAT 2.11, Build 1552或更新版本，使用这些新的版本就不会出现这种问题。

  • 图标不可见
    在某种特定的情况下主控PC的桌面或在主机电脑上运行的程序的图标只有部分的用户显示可见。 这种现象只有在多显示器的主控电脑上发生 除此之外，只有那些显示主控PC屏幕内容的标准显示设备会受到影响 这些是在Microsoft 操作系统Windows XP 常见的问题(http://support.microsoft.com/kb/2501595).

限制

  • 远程桌面

    在远程桌面会话中不可能使用CP-Link 3配置。

  • 实时Ethernet

    如果一个CP-Link 3客户端的网络适配器即用于CP-Link 3连接也用于实时Ethernet，不可能通过UDP传送“虚拟图形”数据 如果一个网络适配器对于CP-Link 3和实时Ethernet 是可用的，客户端的“虚拟图形”数据必须通过TCP传送(见 客户端配置 ).

  • CP-Link 3和TwinCAT的安装顺序
    当安装CP-Link 3或TwinCAT时确保在CP-Link 3之前安装TwinCAT(见TcUsb.sys更新).


CP-Link 3 - Troubleshooting

BECKHOFF CP-Link 3: 附录

排错

错误 | 可能的原因 | 解决方法
客户端不是显示主控PC的image，而是客户端的image。 | 错误的网络连接。 错误的配置。 | 检查网络连接。 确定主控PC和客户端PC的网络连接是正确的。 检查CP-Link 3配置(见客户端配置)。
主控PC不能连接到客户端甚至使用Ping命令客户端可以接收到。 | 客户端防火墙设置错误。 基于CE的客户端： 安装在错误的目录中。 | 检查客户端的防火墙设置(见防火墙配置) 基于CE的客户端： 在安装向导默认的文件夹中安装CP-Link 3(见 客户端的安装方式)。
客户端不显示任何image(黑屏)。 | 客户端中的网络适配器被CP-Link 3连接和实时Ethernet使用。 不可能通过UDP传送“虚拟图形”数据(见说明)。 | 改变客户端的“虚拟图形”数据传输协议为TCP(见 客户端配置)。
客户端的图形显示异常慢。 | 客户端显示的颜色深度没有与主控PC的颜色深度一致。 | 调整客户端的颜色深度，与相应的主控PC的颜色深度一致(见客户端的安装方式)。
客户端的image显示是错误的; 屏幕的某些部分没有更新，或者是在一定的延时后更新。 | 当“虚拟图形”正在通过UDP传送时，网络的连接质量比较差。 | 改变客户端的“虚拟图形”数据传输协议为TCP(见 客户端配置)。
//连接dropouts// 客户端有时显示主控PC的image，有时显示客户端操作系统的image。 | 主控PC的网络适配器被用作CP-Link 3连接的同时这个适配器也被配置为一个Twincat 实时Ethernet适配器(见说明)。 | 请使用TwinCAT 2.11， Build 1552或更新的版本，使用这些新的版本就不会出现这种问题。 选项： 网络适配器也许不会被配置为TwinCAT 实时Ethernet适配器。 安装标准型 Intel®网卡驱动程序。
触摸客户端的触摸屏以后，会打开一个对话框"Minimize client window?" | 此客户端的虚拟USB设备没有被激活。 触摸屏被用作本地设备。 | 为这个客户端激活虚拟USB设备。 如果需要向USB Device黑名单中添加HID设备为了阻止用户从这个客户端输入。 (见 客户端配置)。
通过“虚拟USB”的鼠标移动使用触摸屏，但是不是使用手指。 触摸屏校准失败。 | 没有在主控PC上安装触摸屏驱动或这个驱动是过时的。 | 在主控PC上安装一个最新的触摸屏驱动。 在主控PC上运行触摸屏程序。
不能通过ADS或功能块FB_CPLink3_AcquireHidFocus手动设置HID Focus。 | CP-Link 3 Service没有运行。 | 核实CP-Link 3 Service的状态。 也许CP-Link 3 Service需要被重新注册或打开(见 CP-Link 3 Service)。
在使用一个USB总线耦合器，耦合器的输出 dropout 或这个总线耦合器的行为不如预期。 | USB总线耦合器的配置错误或使用错误。 多个总线耦合器有相同设备号。 总线耦合器数据交换的周期时间太短。 | 检查USB总线耦合器的配置(见使用USB总线耦合器)。 确保所有的总线耦合器的设备号不同(见USB 总线耦合器的设备号)。 使用推荐的与总线耦合器进行数据交换的周期时间(见数据交换的周期时间)。
USB总线耦合器的MissedCnt 变量在增加。 | 与总线耦合器进行数据交换的周期时间太短。 当通过实时Ethernet访问总线耦合器实时Ethernet的配置错误。 | 使用推荐的与总线耦合器进行数据交换的周期时间(见数据交换的周期时间)。 当通过实时Ethernet访问总线耦合器的时候检查实时Ethernet配置(见 通过RT Ethernet的“虚拟USB接口(远程)” ， 或 通过网络变量 (RT Ethernet)访问， 或 通过RT EthernetADS访问)
客户端的(运行Windows XP) USB不能被使用如果电脑已经在"Safe Mode"。 | 操作系统阻止加载特定的CP-Link 3驱动，因为这些驱动使用操作系统的网络设备在安全模式下是不可用的。 成功的加载这些驱动需要操作系统加载USB-Hub驱动。 因此，USB-Hub驱动没有加载的话将会导致客户端的USB驱动无法使用。 | 启动"Safe Mode with Networking"这个操作系统。


技术支持与售后

BECKHOFF 自动化： 附录

技术支持

Beckhoff及其合作伙伴遍布世界各地，可为您提供全方位的技术支持与服务，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff 分公司及代表处

有关 Beckhoff 产品的本地技术支持和服务信息，请联系当地的 Beckhoff 分公司和代表处！

有关 Beckhoff 在全球各地分公司和代理商的地址，您可以登录Beckhoff 的官方网站：
http：//www.beckhoff.com

此外，您也可以在该网站上查看更多关于 Beckhoff 组件的文档资料。

Beckhoff 总部

德国倍福自动化有限公司

Eiserstr. 5
33415 Verl
德国

电话 | +49(0)5246/963-0
传真： | +49(0)5246/963-198
e-mail： | info@beckhoff.com
Beckhoff 技术支持

Beckhoff为您提供全面的技术支持，除了Beckhoff 具体产品的应用以外，还包括更广泛的服务：

  • 技术支持
  • 复杂自动化系统的设计、编程和调试
  • 各种 Beckhoff 系统组件培训方案
热线： | +49(0)5246/963-157
传真： | +49(0)5246/963-9157
e-mail： | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心提供全方位的售后技术服务：

  • 现场服务
  • 维修服务
  • 零部件服务
  • 热线服务
热线： | +49(0)5246/963-460
传真： | +49(0)5246/963-479
e-mail： | service@beckhoff.com