EL600x, EL602x - 串行接口端子模块

BECKHOFF 现场总线组件

文件：

串行接口端子模块

EL6001 (1 通道 RS232), EL6021 (1 通道, RS422/RS485)

EL6002 (2 通道, RS232), EL6022 (2 通道, RS422/RS485)

版本: 2.4
日期 2011-03-18

EtherCAT® 是经过注册的专利技术，版本归 Beckhoff Automation GmbH, Germany所有.


文档说明

本说明书仅供那些在控制与自动化工程方面受过适当培训且熟悉各种适用国家标准的专业人士使用。
在安装和调试这些组件时，操作人员必须严格遵循下列说明和解释。

相关负责人员必须确保所述产品的应用或使用满足所有安全要求，包括相关法律、法规、准则和标准。

免责声明

尽管本文档经过精心编制， 但由于其中所描述的产品仍处于不断更新换代中，
我们可能不会在每次更新后都检查文档中所描述的产品性能数据、标准或其它特性总是与实际产品相一致。
本文档中难免会出现一些技术或者编辑错误，我们保留随时对文档信息作出修改之权力，恕不另行通知。
对于已经变更的产品，如果本文档中的数据、图表以及文字描述没有修改，我们将不再特别加以声明。

商标

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® 已为Beckhoff 自动化有限公司的注册商标
本出版物中的相关名称若被第三方出于个人目的，用作商标，将侵犯其拥有者的权利。

申请中的专利

已包含EtherCAT技术但不局限于如下专利申请和专利:
EP1590927, EP1789857, DE102004044764, DE102007017835
在许多其他国家有关EP0851348, US6167425的相关申请和注册。

TwinCAT 技术受下列专利申请书和专利权（包括但不限于）的保护：
在许多其他国家有关EP0851348, US6167425的相关申请和注册。

版权声明

© 德国倍福自动化有限公司.
未经许可，任何人不得复制、分发和使用本手册以及内容传播。
若发生违反行为 , 须履行损失赔偿义务。 德国倍福自动化有限公司保留所有发明、实用新型和外观设计专利权。


安全说明

安全规程

请仔细阅读下列安全说明 及相关描述！
有关产品特定安全规程，请见后面页或有关安装，接线及调试等章节。

免责声明

所有组件在供货前均针对其具体应用进行了特定的软、硬件配置。 任何人不得对软、硬件配置进行文本档中规定之外的修改，德国倍福自动化有限公司对因此而造成的一切后果不承担任何责任。

人员资质

本手册仅供那些受过适当培训，熟悉各种适用国家标准的“控制、自动化和驱动工程”领域专业人员使用。

安全标志说明

本操作手册中用到了下列安全标志及相应的安全说明。 请仔细阅读并严格遵守。

危险 		有严重人身伤害危险!
不遵守本标志相关的安全说明将直接危及个人生命和健康安全!

警告 		受伤的危险
不遵守本标志相关的安全说明将危及个人生命和健康安全!

小心 		危害个人
不遵守本标志相关的安全说明可能明显危害个人安全!

注意 		对环境和设备有危险
不遵守本标志相关安全说明可能明显危害环境和设备安全.

说明 		说明或提示
该标志表示这些信息能够帮助您更好地理解安全说明。
UL 说明
这个标志用于表示有关UL标准的重要信息。.


EL600x, EL602x - 文件发布状态

BECKHOFF EL600x, EL602x: 前言

文档版本说明

版本 | 意见
2.4 | —增加对象描述和技术说明
2.3 | -增加了固件兼容性注意事项，技术说明
2.2 | -附录
2.1 | -附录
2.0 | -第一次公开发布
0.3 | 附录
0.2 | -修正和附录
0.1 | EL60xx的初始文件


版本说明

BECKHOFF: 前言

EtherCAT设备名称版本说明

命名方法

一个Beckhoff EtherCAT设备有14位数字名称组成

  • 系列关键字
  • 类型
  • 版本
  • 子版本
例子 | 系列 | 类型 | 版本 | 子版本
EL3314-0000-0016 | EL 端子模块 (12 mm, 非可插拔式连接) | 3314 (4-通道 热电偶端子模块) | 0000 (基本类型) | 0016
CU2008-0000-0000 | CU 设备 | 2008（8端口高速以太网交换机） | 0000 (基本类型) | 0000
ES3602-0010-0017 | ES 端子模块 (12 mm, 可插拔式连接) | 3602 (2-通道电压测量) | 0010 (高精度版本) | 0017

说明

  • 订货号由以下组成
    - 系列关键字
    - 类型
    - 版本
  • 子版本 表示技术改进过程
    原则上，更高版本的设备可以取代较低版本的设备，除非有特殊规定。
    每个修订版通常有一个相关XML的描述（ESI,EtherCAT Slave信息），可以在Beckhoff官网下载。
  • 类型，版本，子版本都以十进制数表示

序列号

Beckhoff EtherCAT 设备有一个8位数的序列号, 印刷在设备上或标签上。 序列号标明了出厂时的状态

序列号说明

序列号结构 KK YY FF HH

KK - 生产周 (CW, 日历周)
YY - 生产年
FF - 固件版本
HH - 硬件版本

例如序列号： 12 06 3A 02:

12 - 第 12周生产
06 - 2006 年生产
3A - 固件版本 3A
02 - 硬件版本 02

序列号举例

图 1: EL6688 EL 端子模块

图 2: CU2016 交换机

图 3: EK1100 EtherCAT 耦合器


技术

EL600x 和 EL602x 串行接口模块支持以RS232 (或 RS485 / RS 422)接口与设备连接。 对于EL600x，在全双工模式下与控制器交换数据。 对于EL602x，额外支持半双工模式。 接收缓冲区有 864 bytes，发送缓冲区有128 bytes。模块和控制器之间通过握手进行数据传输。 模块出厂参数设置为9600 Baud，8数据位，1停止位，无奇偶校验： 对于EL600x，RTS/CTS 控制被激活; EL602x 运行在全双工模式并禁用点到点连接。

Level接口

EL6001/EL6002的RS232通讯信号以GND为参考地， EL6021/ EL6022的RS422/485通讯采用差分信号。

图. 1: RS232, RS485/422参考电平


EL6001, EL6021 -简介

BECKHOFF EL6001, EL6021: 产品概述

简介

串行接口端子模块(RS232C/RS422/RS485)，1通道

EL6001 和 EL 6021 串行总线接口端子模块分别支持通过RS232 或 RS422/RS485与设备进行连接。 EL6001工作符合 CCITT V6001/DIN .28 66-259 标准。 与 EtherCAT 端子模块 EL6001/EL6021 相连的设备通过总线耦合器直接与自动化设备通讯。 这种主动的通讯通道在全双工或可选的半双工（EL6021）模式下，独立于上一层的总线系统运行，其通讯速率可达115.2 kbaud 。 由于信号经过电气隔离处理， RS232 串口具有很强的抗干扰能力。另外通过差分信号传输对于EL6021也有同样保证。

利用 TwinCAT Virtual Serial COM Driver (见 TwinCAT Supplements – Communication)，EL6001/EL6021 也可以作为普通Windows COM接口使用。

快速连接

• EtherCAT 基础
• 串行接口模块技术
• 调试
• 过程数据，一般注意事项
• EL60x1 CoE 对象描述 和 参数化
• EL60x1 控制和状态数据


EL6001, EL6021 - 技术参数

BECKHOFF EL6001, EL6021: 产品概述

EL6001, EL6021 -技术参数

技术参数 | EL6001 | EL6021
数据传输通道 | TxD 和 RxD ，全双工 | TxD 和 RxD ，全 / 半双工
数据传输速率 | 2400..115200 baud 默认： 9600 baud ， 8 个数据位，无奇偶校验位， 1 个停止位 固件 07以上产品: 还可选12000 baud 和 14400 baud | 2400..115200 baud 默认： 9600 baud ， 8 个数据位，无奇偶校验位， 1 个停止位
数据缓冲区 | 864 byte 接收缓冲区，128 byte 发送缓冲区
位传输 | - | 带差分信号
接口 | RS232 | RS422/RS485
位失真率 | < 3% | -
电缆长度 | max. 15 m | max. 1000 m (双绞线)
线路阻抗 | - | 120 Ω
提供外部供电 | - | -
诊断 | 状态 LED
提供外部供电 | -
电源 | 通过 E-Bus
E-bus 电流消耗 | typ. 120 mA | typ. 220 mA
电气隔离 | 500 Vrms(E-bus/RS232) | 500 Vrms (E-bus/RS422, E-Bus/RS485)
过程映像中的位宽 | 1 x 8 bit 控制/状态，输入/输出： 3 x 8 bit 用户数据 或 1 x 8 bit 控制/状态，输入/输出： 5 x 8 bit 用户数据 或 1 x 16 bit 控制/状态，输入/输出： 22 x 8 bit 用户数据 （可配置）
组态 | 无地址设置， 可通过 TwinCAT 系统管理器编程
外形尺寸 | 大约 15 mm x 100 mm x 70 mm (对齐宽度: 12 mm)
重量（约） | 大约 55 g
工作温度 | 0 °C ... +55 °C
储藏温度 | -25 °C ... +85 °C
相对湿度 | 95%，无冷凝
安装 | 安装在 35 mm 导轨上 根据 EN 50022标准
抗振 / 抗冲击性能 | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
抗电磁及瞬时脉冲干扰 / 静电放电 | 符合 EN 61000-6-2 /EN 61000-6-4 标准
防护等级 | IP 20
安装位置 | 可变
认证 | CE Ex UL


EL6002, EL6022 -简介

RS232/422/485 串行总线接口端子模块, 2 通道

串口端子模块 EL6002 和 EL6022 能够通过D-Sub接头（9针）的两个 RS232 或两个 RS422/RS485 接口连接设备。 连接至EtherCAT 端子模块 EL6002/EL6022的设备可通过耦合器实现与自动化设备的通讯 。 这种主动的通讯通道独立于上位 EtherCAT 系统，并在全双工模式下工作，其通讯速率可达 300baud 至115.2kbaud 。
RS232/RS422/RS485 接口信号经过电气隔离，具有良好的抗干扰性能。

若与 TwinCAT 虚拟串口驱动程序配套使用， EL60xx 可用作为标准的 Windows COM 接口。
EL6022可以为外部设备提供 2 x 5 V / 20 mA的E-Bus电源（电气隔离，短路保护）。

快速连接

• EtherCAT 基础
• 串行接口模块技术
• 调试
• 过程数据，一般注意事项
• EL60x2 CoE 对象描述 和 参数化
• EL60x2 控制和状态数据


EL6002, EL6022 -技术参数

技术参数 | EL6002 | EL6022
数据传输通道 | 2, TxD 和 RxD，全双工 | 2,TxD 和 RxD ，全 / 半双工
接线 | 2 x D-Sub 接头，公头，（DE9），9针 | 2 x D-Sub 接头，母头，（DE9），9针
数据传输速率 | 300...115200 baud 默认： 9600 baud ， 8 个数据位，无奇偶校验位， 1 个停止位
数据缓冲区 | 864 byte 接收缓冲区，128 byte 发送缓冲区
电缆长度 | max. 15 m | max. 1000 m (双绞线)
接口 | RS232 | RS422/RS485
提供外部设备供电 | - | 2 x max. 5 V / 20 mA, E-Bus供电之外，短路保护）
诊断 | 状态 LED
电源 | 通过 E-Bus
E-bus 电流消耗 | 典型值 170 mA | 典型值 350 mA + 外部需求（万一短路 2 x 250 mA）
电气隔离 | 500 Vrms (E-bus/RS232) | 500 Vrms (E-bus/RS422, E-bus/RS485)
过程映像中的位宽（每通道） | 1 x 16 bit 控制/状态，输入/输出： 22 x 8 bit 用户数据
组态 | 无地址设置， 可通过 TwinCAT 系统管理器编程
工作温度 | 0 °C ... +55 °C
储藏温度 | -25 °C ... +85 °C
相对湿度 | 95%，无冷凝
外形尺寸 | 大约 26 mm x 100 mm x 52 mm (对齐宽度: 23 mm)
重量（约） | 大约 70 g
安装 | 安装在 35 mm 导轨上 根据 EN 50022标准
抗振 / 抗冲击性能 | 符合 EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
抗电磁及瞬时脉冲干扰 / 静电放电 | 符合 EN 61000-6-2 /EN 61000-6-4 标准
防护等级 | IP 20
安装位置 | 可变
认证 | CE Ex UL


启动

调试：

  • 如章节"安装与接线"中所示，安装 EL600xx
  • 如章节 “调试”中所示，在TwinCAT中配置EL600xx。


EtherCAT 基础

请参考 "EtherCAT System Documentation"EtherCAT现场总线基础章节。


EtherCAT 接线

BECKHOFF EtherCAT: 通信基础

EtherCAT 布线 – 接线

两台EtherCAT设备间电缆长度不能超过100米。 这与快速以太网技术一致，因为超过这个电缆的长度，会使信号衰减。允许的最长连接长度是5 + 90 + 5米。 详见 对 EtherCAT/Ethernet的设计建议.

电缆和接头

只有以太网连接器（电缆+插头）符合EN 50173 或ISO/IEC 11801至少category 5（CAt5)才可以连接EtherCAT设备。 EtherCAT用4根线来进行信号传输。

例如，EtherCAT用RJ45插头。 其引线分配符合以太网标准(ISO/IEC 8802-3)。

针脚 | 导体颜色 | 信号 | 描述
1 | 黄 | TD + | Transmission Data +
2 | 橙 | TD - | Transmission Data -
3 | 白 | RD + | Receiver Data +
6 | 蓝 | RD - | Receiver Data -

由于实现自动电缆检测，可以在Beckhoff的EtherCAT设备之间，使用对称或交叉电缆。

说明 		推荐电缆
适于连接EtherCAT设备的电缆可以在 Beckhoff 官网上找到!

E-Bus 电源供给

总线耦合器可以通过E-bus系统将5V电压供给EL端子； 一个耦合器可以提供2A电流（详细信息请查阅各个设备各自的文档）。
每个EL端子要消耗多少E-bus电流，可以从网站或样本里得到资料。 如果增加的端子所需的电流大于铜导线能提供的电流，那么供电端子 (例如 EL9400) 必须安装在模块组中合适的位置。

在TwinCAT 系统管理中会显示出E-bus预先计算好的电流理论最大值。 如果电流不足将会显示一个感叹号； 那么就需要在这个位置之前加一个电源模块。

图 1: 系统管理中电流的计算值

注意 		小心! 可能故障
在同一个端子模块组中，所有的EtherCAT端子的E-bus供电必须有相同的对地电势。


看门狗设置说明

ELxxxx 总线端子模块装有一个安全装置（看门狗）在发生数据传输中断一定时间后关闭输出。
EL2xxx总线端子模块的EtherCAT从站控制器(ESC)装有2个看门狗：

  • SM 看门狗（默认值 100 ms）
  • PDI 看门狗（默认值 100 ms）

SM 看门狗 (SyncManager 看门狗)

SyncManager 看门狗将会在每次EtherCAT成功通讯之后复位。 如果和终端模块没有EtherCAT数据传输的时间长于SM看门狗的设定时间，例如：在发生线路中断时，看门狗会触发并将输出设为FALSE。 端子模块的 OP状态不受影响 设置上述监视时间。

SyncManager看门狗在EtherCAT方面，监视ESC过程数据通讯的正确性。

PDI 看门狗 (过程数据看门狗)

如果EtherCAT从站控制器(ESC)与PDI看门狗没有数据传输的时间长于PDI看门狗的设定时间，就会激活PDI看门狗。
PDI (Process Data Interface) 是ESC和本地EtherCAT从站处理器之间的内部接口。 PDI 看门狗可用于监视此通信是否成功。

PDI看门狗在应用方面，监视ESC过程数据通讯的正确性。

图 1 EtherCAT tab -> Advanced Settings -> Behavior

倍增器

每个看门狗通过本地端子循环接收脉冲，由监视倍增器拆分。

1/25 MHz * (看门狗倍增器 + 2) = 100 µs (倍增器默认设置为 2498)

SM看门狗默认设置是1000相当于释放时间是100ms。

倍增数值+2相当于40ns倍数代表了看门狗的时间。
倍增器可以修改，以适应在更大范围内的看门狗时间。

例子"设定 SM 看门狗"

复选框使能手动设定看门狗时间。 如果设定了输出且EtherCAT通信中断，SM 看门狗将在设定时候到后复位输出。 修改这个设置以适应较慢的EtherCAT主站或更长的扫描周期。 默认SM看门狗设定为100 ms. 设定范围 0..65535. 加上倍增器范围是1~65535涵盖了看门狗0~170秒的周期。

计算

倍增数 = 2498 → 看门狗基准时间 = 1 / 25 MHz * (2498 + 2) = 0.0001 seconds = 100 µs
SM 看门狗 = 10000 → 10000 * 100 µs = 1 second 看门狗监视时间

小心 		小心! 可能出现未定义状态!
只能在端子版本-0016上实现通过设定SM看门狗=0 来关闭SM看门狗功能。
在之前的版本这项功能不能使用。

小心 		小心! 设备损坏和可能出现未定义状态！
如果在SM看门狗激活之后，输入数字0，看门狗就会关闭。
这时如果通信中断了那么输出就不会被复位。


EtherCAT状态机

EtherCAT从站的状态由EtherCAT状态机（EMS）控制。 依据不同的状态，可以在EtherCAT从站中得到或执行不同的功能。 EtherCAT主站必须发送特殊指令来控制设备的每个状态，尤其是启动从站的时候。

有以下几种状态

  • Init
  • Pre-Operational
  • Safe-Operational
  • Operational
  • Boot

启动后每个EtherCAT从站的最终状态是OP状态。

Init

通电后EtherCAT为Init状态。 mailbox和过程数据无法通讯 。 EtherCAT主站初始化通道0和1同步管理器，为mailbox 通讯准备。

Pre-Operational (Pre-Op)

在 Init 和 Pre-Op的过渡过程中，EtherCAT从站检查mailbox是否正确初始化。

在 Pre-Op 状态 mailbox可以通讯, 但是过程数据无法通讯。 EtherCAT主站初始化过程数据的同步管理器通道 (来自于同步管理器通道2), FMMU通道和, 如果从站支持可调整映射，PDO映射或同步管理器PDO分配。 在这个状态，过程数据的传输设置和端子模块特殊设置也会被传输。

Safe-Operational (Safe-Op)

在 Pre-Op 和 Safe-Op的过渡过程中，EtherCAT从站检查是否过程数据通信的同步管理器通道和分布式时钟设置是否正确。 在确认状态转换之前，EtherCAT从站会将当前输入数据复制到EtherCAT从站控制器（ECSC）中的DP-RAM区域。

在Safe-Op状态可以进行mailbox和过程数据通讯，尽管从站的输出处于安全状态，但是输入数据可以循环更新。

Operational (Op)

在EtherCAT主站切换它的从站从Safe-Op到 Op 状态之前，必须传递有效的输出数据。

在 Op状态，从站复制主站输出数据到从站的输出。 可以进行mailbox和过程数据通讯

Boot

在 Boot 状态，可以更新从站的固件 Boot 状态只能从 Init 状态转换过来。

在 Boot状态，mailbox通讯可以通过file access over EtherCAT (FoE) 协议实现, 但是其他形式的mailbox和过程数据通讯不支持。


CoE-接口

CoE接口是 EtherCAT 设备的参数设定接口。 在CAN-over-EtherCAT (CoE)的管理机构中，特定的固件参数可以在网上或EtherCAT的离线参数中获得。

CoE接口的详细信息可以在Beckhoff 网站上 EtherCAT system documentation 中找到。


分布式时钟

分布式时钟代为EtherCAT从站控制器（ESC)中的本地时钟，有如下的特性：

• 单位 1 ns
• 零点1.1.2000 00:00
• 大小 64 字 (足够提供584年; 然而，有些EtherCAT只提供32字节的支持 即大约4.2秒）
• EtherCAT主站会自动同步主站时钟和EhterCAT总线中的本地时钟，精度达< 100 ns。

更详细的信息参考EtherCAT system description.


ELxxxx, KLxxxx - Installation on mounting rails

BECKHOFF 现场总线组件: 安装和接线

安装到导轨上

警告 		小心电击危险和损坏设备！
在安装，拆卸和连线之前确保总线终端处于安全的断开状态!

装配

总线耦合和总线终端都可以毫不费力地安装在35mm导轨上。这个导轨可以在市场上买到 (DIN 轨道依据 EN 50022标准)：

  1. 首先将现场总线耦合器安装在导轨上。
  2. 总线端子模块安装在总线耦合器的右侧。 通过卡槽将元件连接在一起且将端子按在导轨上，直到将锁扣扣在轨道上。
    如果先将终端模块夹在安装导轨上然后再连接到一起，且不使用卡槽连接，这样连接将不会运转！ 正确的连接是模块之间没有可见的缝隙。

说明 		固定安装导轨
在总线终端模块安装完之后，总线端子模块的锁定机构不能与安装轨道上的固定螺丝相碰。

拆卸

每个端子都用锁扣固定在安装轨道上，在拆卸的时候必须解开锁扣：
  1. 将端子模块上的橘黄色卡扣从安装轨道上拉出大约1cm。 这样做端子模块底部的导轨锁就松开了，然后你可以毫不费力的把端子模块模块拔出来。
  2. 同时用拇指和食指抓住总线端子模块上、下槽表面并拉出总线端子模块。

总线端子模块组合

总线耦合器和总线端子模块组合在一起后就自动完成了电气连接。

  • K-Bus/E-Bus的6个弹簧连接点负责数据传输和和总线端子模块的供电。
  • 电源触点负责给现场传感器供电，并在总线端子模块组中形成供电链。 总线耦合器电源触点供电最高为 24 V，如要更高的电压需要另外的电源供电模块。

说明 		电源触点
在设计总线端子模块时，必须计算总线端子的引脚分配，因为有些型号不会或不完全通过电源连接。（例如：模拟总线端子模块或4通道的数字总线端子模块）。
供电端子模块 (KL91xx, KL92xx or EL91xx, EL92xx) 中断电源并重新开始一个电源供应链路。

PE 电源触点

有PE标示的电源触片是用来接地保护的。 出于安全因素这个触片要先连接在一起，对地的最大短路电流是125 A。

注意 		可能损坏设备
考虑到电磁兼容性，PE触点与安装轨道之间是电容耦合的。 这可能会在绝缘测试时导致错误或损坏端子（例如：客户在绝缘测试时把230V放电到PE短路）。

如果要进行绝缘测试， 断开总线耦合器或供电端子模块的PE！ 为了完全断开供电触点, 把供电端子模块从导轨上拉出至少10mm。

警告 		小心触电
PE连接不能用来接其他的电位！


KLxxxx, KSxxxx, ELxxxx, ESxxxx - 连接系统

BECKHOFF 现场总线组件: 安装和接线

连接系统

警告 		小心电击危险和损坏设备！
在安装，拆卸和连线之前确保总线终端处于安全的断开状态!

概述

总线端子系统为不同的设备提供不同的最优连接：

  • KLxxx和ELxxxx系列接线端子模块连接器和电子元件封装在同一个外壳中。
  • KSxxxx 和 ESxxxx系列接线端子模块采用可插拔的连接器使更换时不需要接线。
  • 高密度端子模块系列 (HD Terminals)连接器和电子元件封装在同一个外壳中，封装密度更高。

标准接线

KLxxx和Elxxx端子系列经过多年测试。
集成无螺丝弹簧压紧技术，提供了快速简单的装配。

可插拔式接线

KSxxx和ESxxx端子系列的特点是可插拔式连接。
KS系列的安装和接线方式与KLxxxx 和 ELxxxx 系列类似。
KS/ES端子系列可以使插拔式连接器从外壳上完整移走便于维护。
拉起 解锁条可以把下部的模块从导轨上移除.
插入新的模块装上带线的连接器
这样一来，可大大减少安装时间，避免电缆线误接。

端子模块的尺寸基本相同，只有很小的变化。 新的连接器增加了约3mm 端子模块的最大高度保持不变

扎线环有助于扎紧电线，避免电线在拔下连接器时缠绕。

线径位于 0.08 mm2 和 2.5 mm2 都可以用弹簧连接器.

KSxxxx 和 ESxxxx 系列模块的型号命名方式 KLxxxx 和 ELxxxx 系列相同.

高密度端子模块 (HD Terminals)

KLx8xx 系列总线端子模块有16个连接点，是特别紧凑的设计，是传统12 mm 总线端子模块连接点数量的2倍。 硬导线和压了线套的导线可以直接插入弹簧接线孔而不需要工具。

说明 		高密度模块接线
高密度端子模块KLx8xx 和 ELx8xx 系列没有对应的可插拔连接器系列。

说明 		超声 “焊接" 导线
可以使用超声波“粘合”（超声波焊接）导体来连接标准或高密度端子模块。
在这种情况下, 请注意 下面线径说明表!

接线

连接 ELxxxx / KLxxxx 标准接线端子和 ESxxxx / KSxxxx可插拔式连接器

最多可以连接8根线到总线端子模块，把线扎在总线端子模块连接器上。 端子连接采用弹簧力连接技术。 根据下面的步骤来接线：

  1. 用螺丝刀插入位于接口上方的方形孔来打开弹簧接线端子。
  2. 现在电线可以毫不费力的直接插入圆形孔。
  3. 当拔掉螺丝刀后弹簧端口会自动合上，将接线永久牢固的接上。

端子模块外壳 | ELxxxx, KLxxxx | ESxxxx, KSxxxx
线径 | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
剥线长度 | 8 ... 9 mm | 9 ... 10 mm

高密度端子模块 ELx8xx, KLx8xx (HD)

单芯硬线连接HD端子模块的接点只需要剥线之后直接插入即可，不需要额外的工具。 通常，借助螺丝刀松开触点，然后再松开电缆。 下表为对线径的要求。

端子模块外壳 | ELx8xx, KLx8xx (HD)
线径 (导体两端有套筒） | 0.14... 0.75 mm2
线径 (单芯硬线) | 0.08 ... 1.5 mm2
线径 (细导线) | 0.25 ... 1.5 mm2
线径 (超声 “焊接" 导线) | 只能 1.5 mm2 (见 说明!)
剥线长度 | 8 ... 9 mm

屏蔽

说明 		屏蔽
模拟传感器和执行器总是用屏蔽双绞线相连。


EL6001, EL6021-LED和连接

LEDs

LED | 颜色 | 状态
RUN | 绿色 | 该LED灯显示端子模块的运行状态：
 |  | off | EtherCAT 状态机的状态: INIT = 模块初始化 或 BOOTSTRAP = 模块的 固件升级 功能
 |  | 闪烁 | EtherCAT 状态机的状态: PREOP =邮箱通信的设置 及变体标准设置
 |  | 单次闪烁 | EtherCAT 状态机的状态: SAFEOP = 同步管理器及 分布式时钟的通道检查。 输出保持在安全运行模式中。
 |  | on | EtherCAT 状态机的状态: OP =正常运行模式，可进行邮箱-和过程数据通讯。
TxD | 绿色 | 发送信号线的状态
RxD | 绿色 | 接收信号线的状态

EL6001的连接

端子模块点 | Name | 信号
1 | TxD | 信号线（Transmit Data）
5 | RxD | 信号线（Receive Data）
2 | RTS | 控制线(Request To Send)
6 | CTS | 控制线(Clear To Send)
3 | GND | 接地 (内部与模块点7相连)
7 | GND | 接地 (内部与模块点3相连)
4 | 屏蔽 | 屏蔽 (内部与模块点8相连)
8 | 屏蔽 | 屏蔽 (内部与模块点4相连)

EL6021的连接

端子模块点 | 名称 | 信号
1 | TxD+ | 信号线+ (Transmit Data)
5 | TxD- | 信号线- (Transmit Data)
2 | RxD+ | 信号线 + (Receive Data)
6 | RxD- | 信号线 - (Receive Data)
3 | GND | 接地 (内部与模块点7相连)
7 | GND | 接地 (内部与模块点3相连)
4 | 屏蔽 | 屏蔽 (内部与模块点8相连)
8 | 屏蔽 | 屏蔽 (内部与模块点4相连)

RS422传输的连接

在 RS422 模式下，数据以全双工模式传输。 只能建立对等网络（peer-to-peer）的连接。

RS485传输的连接

在RS485模式下，数据以半双工方式交换。 在运行模式中可以建立一个总线结构。

在RS485运行模式中传输线和接收线相互连接。 因此，端子接收的不单是来自其它设备的数据，还有它本身发送的数据。 可以在Settings object中，索引 80n6:06 ‘Enable half duplex’中对此禁用。

在RS485运行模式下，只能在发送完成后接收新的数据。

“支持半双工” | “支持点到点连接（RS422）” | 方式
0 | 0 | RS485: 端子接收它自己的数据以及来自设备的数据。
0 | 1 | RS422: 正常操作模式； 端子运行在全双工模式下。
1 | 0 | RS485: 端子只接收来自其他设备的数据
1 | 1 | RS422: 只有在最后一个数据发送完成后才能接收。


Mounting rail installation EL66xx, EL67xx

BECKHOFF 现场总线组件: 安装和接线

安装与拆卸

警告 		小心电击危险和损坏设备！
在安装，拆卸和连线之前确保总线终端处于安全的断开状态!

安装

图 1

总线耦合和总线终端都可以毫不费力地安装在35mm导轨上。这个导轨可以在市场上买到 (DIN 轨道依据 EN 50022标准)：

  1. 首先将现场总线耦合器安装在导轨上。
  2. 总线端子模块安装在总线耦合器的右侧。 通过卡槽将元件连接在一起且将端子按在导轨上，直到将锁扣扣在轨道上。
    如果先将终端模块夹在安装导轨上然后再连接到一起，且不使用卡槽连接，这样连接将不会运转！ 正确的连接是模块之间没有可见的缝隙。

在总线终端模块安装完之后，总线端子模块的锁定机构不能与安装轨道上的固定螺丝相碰。

拆卸

图 0.2

每个端子都用锁扣固定在安装轨道上，在拆卸的时候必须解开锁扣：

  1. 使用螺丝刀(3)向上撬动拉开挂钩。
  2. 通过一个内部机构两个插销(3a) 缩回到模块内部。 拉开挂钩向前(3b) 移到位置。
  3. 将模块从导轨上拉出(4)。

总线端子模块组合

总线耦合器和总线端子模块组合在一起后就自动完成了电气连接。

  • K-Bus/E-Bus的6个弹簧连接点负责数据传输和和总线端子模块的供电。
  • 电源触点负责给现场传感器供电，并在总线端子模块组中形成供电链。 电源端点通过总线耦合器上的端子模块供电。

说明 		总线端子模块接线盒设计
当设计总线端子模块接线盒以及为个别总线端子模块分配引脚时，请注意现场总线主站端子模块 (EL67xx), 通信端子模块(EL66xx)和串行接口端子模块(EL60xx)没有电源触点。


端子模块-推荐的安装导轨

倍福端子模块： 安装和接线

推荐的安装导轨

KMxxxx 和 EMxxxx 系列的端子模块及EtherCAT模块，同EL66xx 及 EL67xx模块一样可以被安装在下面推荐的导轨上。

  • DIN Rail TH 35-7.5 1 mm 材料厚度（根据EN 60715标准）
  • DIN Rail TH 35-15 1,5 mm 材料厚度

说明 		注意DIN导轨的材料厚度
KMxxxx 和 EMxxxx 系列的端子模块及EtherCAT模块，同EL66xx 及 EL67xx模块一样，不适合DIN Rail TH 35-15 2,2 到 2,5 mm 材料厚度（根据EN 60715标准）


EL6002, EL6022 - LED和连接

BECKHOFF EL6002, EL6022: 安装和接线

EL6002, EL6022 -LED和连接

LED

LED | 颜色 | 含义
RUN | 绿 | 该LED灯显示端子模块的运行状态：
 |  | off | EtherCAT 状态机的状态: INIT = 模块初始化 或 BOOTSTRAP = 模块的 固件升级 功能
 |  | 闪烁 | EtherCAT 状态机的状态: PREOP =邮箱通信的设置 及变体标准设置
 |  | 单次闪烁 | EtherCAT 状态机的状态: SAFEOP = 同步管理器及 分布式时钟的通道检查。 输出保持在安全运行模式中。
 |  | on | EtherCAT 状态机的状态: OP =正常运行模式，可进行邮箱-和过程数据通讯。
Tx Ch. 1 | 橙 | 发送信号线的状态，通道1
Rx Ch. 1 | 绿 | 接收信号线的状态，通道1
Tx Ch. 2 | 橙 | 发送信号线的状态，通道2
Rx Ch. 2 | 绿 | 接收信号线的状态，通道2

EL6002的连接

2 x D-Sub 接口, 公头; 9 针

D-Sub 接口, 公头
（正面图）

通道1引脚设置

通道2引脚设置

针脚 | RS232
1 | DCD （内部与4脚和6脚相连）
2 | Rx CH1
3 | Tx CH1
4 | DTR （内部与1脚和6脚相连）
5 | GND
6 | DSR （内部与1脚和4脚相连）
7 | RTS CH1
8 | CTS CH1
9 | -

针脚 | RS232
1 | DCD （内部与4脚和6脚相连）
2 | Rx CH2
3 | Tx CH2
4 | DTR （内部与1脚和6脚相连）
5 | GND
6 | DSR （内部与1脚和4脚相连）
7 | RTS CH2
8 | CTS CH2
9 | -

EL6022 的连接

2 x D-Sub 接口, 母头; 9 针

D-Sub 接口, 母头
(正面图)

通道1引脚设置

通道2引脚设置

针脚 | RS485/RS422
1 | -
2 | Tx+ CH1
3 | Rx+ CH1
4 | -
5 | GND
6 | +5 V
7 | Tx- CH1
8 | Rx- CH1
9 | -

引脚 | RS485/RS422
1 | -
2 | Tx+ CH2
3 | Rx+ CH2
4 | -
5 | GND
6 | -
7 | Tx- CH2
8 | Rx- CH2
9 | -

RS422传输的连接

在 RS422 模式下，数据以全双工模式传输。 只能建立对等网络（peer-to-peer）的连接。

RS485传输的连接

在RS485模式下，数据以半双工方式交换。 在运行模式中可以建立一个总线结构。

在RS485运行模式中传输线和接收线相互连接。 因此，端子接收的不单是来自其它设备的数据，还有它本身发送的数据。 可以在Settings object中，索引 80n6:06 ‘Enable half duplex’中对此禁用。

在RS485运行模式下，只能在发送完成后接收新的数据。

“支持半双工” | “支持点到点连接（RS422）” | 方式
0 | 0 | RS485: 端子接收它自己的数据以及来自设备的数据。
0 | 1 | RS422: 正常操作模式； 端子运行在全双工模式下。
1 | 0 | RS485: 端子只接收来自其他设备的数据
1 | 1 | RS422: 只有在最后一个数据发送完成后才能接收。


安装辅助端子模块

说明 		安装辅助端子模块注意点
EtherCAT 总线端子模块 (ELxxxx / ESxxxx), 不担任数据传输任务的模块称为辅助端子模块。
辅助端子模块不消耗 E-bus电流
为确保最优的数据传输，不能连续连接超过两个接线端子模块。
辅助接线端子模块的实例（高亮部分）

例子1： 正确的配置

例子 2 错误的配置


EL600x, EL602x -调试

BECKHOFF EL600x, EL602x: 配置

TwinCAT 建立配置

(Master TwinCAT 2.1x)

说明 		最新XML设备描述的安装
请确保你已经在TwinCAT中安装了最新的XML设备描述 ，可以从 Beckhoff 主页上下载 (http://www.beckhoff.de/english/default.htm?download/elconfg.htm) 然后按照安装向导安装。

端子自动扫描

• | •总线端子系统必须按照 安装与拆卸章节中介绍的那样在插入端子网络前切换为安全、断电状态。
• | •连上工作电压，启动TwinCAT System Manager (Config mode)，并扫描端子 (见 图 1). 用 "OK"确认所有的对话框, 使配置在 "FreeRun" 状态下。

图 1: 在EtherCAT配置中进行扫描 (I/O Devices-> right-click -> Scan Devices...

手动添加一个端子模块

• | •总线端子系统必须按照 安装与拆卸章节中介绍的那样在插入端子网络前切换为安全、断电状态。
• | •连上工作电压，启动TwinCAT System Manager (Config mode)
• | 添加一个新的 I/O 设备 (见 图. 2). 在出现的对话框中选择 device EtherCAT (Direct Mode), 见 图. 3 并确认 OK.

图 2: 添加新的 I/O 设备 (I/O Devices-> right-click -> Append Device... ) )

图 3: 选择 device EtherCAT (Direct Mode)

• 添加一个新的 box (见 图. 4). 在出现的对话框中选择 e.g. EK1100 系统耦合器，例如 (见 图. 5), 并确认 OK.

图 4: 添加一个新的box(Device -> right-click -> Append Box... ) )

图 5: 选择系统耦合器 (例如 EK1100)
• | 添加一个新的 box (见 图. 6). 在对话框中出现选择EL600x或EL602x（见 图. 7), 并确认 OK.
• | 端子模块已经插入到 TwinCAT tree中（图 8).

图 6: 添加一个新的box(Device -> right-click -> Append Box... ) )

图 7: 选择端子模块(e.g. EL6002)

图 8: 在 TwinCAT tree 中的EL6002xx端子模块


过程数据

BECKHOFF EL600x, EL602x: 配置

一般注释 过程数据

内容
• EL6001, 6021
- 版本说明
- StartUp entries

• EL6002, EL6022

- 同步管理器
 - 过程数据
- 特征CoE
- 过程数据描述
 - 传输速率
- 传输速率优化
- 连续数据传输
- 优先性

• 数据传输样例

EL6001, EL6021

版本说明

EL6001/EL6021的后续开发中，Firmware (FW) 05 / Hardware (HW) 03, (EL6001); Firmware (FW) 04 / Hardware (HW) 03, (EL6021)以上版本可以通过Index 6000 (profile-specific objects)实现对象的状态监控及参数化，并且可在TwinCAT System Manager中设置参数，这些取决于当前的硬件。

老版本的EL6001/EL6021不支持该功能！

从FW/HW | ESI | 控制/状态/参数化 对象区域
EL6001 01/01 EL6021 01/01 | 从 EL6001-0000-0000 从 EL6021-0000-0000 | Index 300n:01 (控制字) Index 310n:01 (S状态字) Index 4070 发送缓冲区中的数据字节) Index 4071 接收缓冲区内的数据字节) Index 4072 (诊断) Index 4073 (波特率) Index 4074 (数据结构) Index 4075 特征位)
EL6001 05/03 EL6021 04/03 | 从 EL6001-0000-1016 从 EL6021-0000-1016 | 额外的上述对象： Index 6000 COM 输入) Index 7000 COM 输出) Index A000 COM Diag data) Index 8000 (COM 设置)

说明 		设备的兼容性
经Hardware 03 或更高版本使用或设计的 EL6001/EL6021 不能被老硬件版本(<03)的EL6001/EL6021替代！
反之则没有问题！

说明 		过程数据监控
我们建议在每个周期监控以下过程数据：
  • WcState: 如果≠ 0, 该EtherCAT设备不参与过程数据交换。
  • State: 如果≠ 8,该 EtherCAT设备不在OP（运行）状态下
  • TxPDO State, SyncError: 如果≠ 0,则没有有效的过程数据，e.g.由断路造成的。
  • TxPDO Toggle: 如果该位被触发，可得到一个新的过程数据

StartUp entries (硬件 < 03)

说明 		StartUp list entry
EL6001/EL6021的StartUp entries只能在 transition SafeOP -> OP (S -> O)中设定。 默认设置是 PreOP -> SafeOP (P -> S)。
如果您要创建StartUp list entries，确认勾选"S -> O"！ (图 1 a)!

图 1 a: StartUp entry with transition "S ->O"

EL6002, EL6022

同步管理器Sync Manager (SM)

PDO 分配

SM2, PDO 分配 0x1C12
Index | Index of excluded PDOs | 大小 (byte.bit) | Name | PDO 连接
0x1600 | - | 24.0 | COM 输出 通道1 | Index 0x7000:01 - Ctrl__Transmit request
 |  |  |  | Index 0x7000:02 - Ctrl__Receive accepted
 |  |  |  | Index 0x7000:03 - Ctrl__Init request
 |  |  |  | Index 0x7000:04 - Ctrl__Send continous
 |  |  |  | Index 0x7000:09 - Ctrl__Output length
 |  |  |  | Inde 0x 0x7000:11 - Data out 0
 |  |  |  | --
 |  |  |  | Inde 0x 0x7000:26 - Data out 21
0x1601 | - | 24.0 | COM 输出 通道2 | Index 0x7010:01 - Ctrl__Transmit request
 |  |  |  | Index 0x7010:02 - Ctrl__Receive accepted
 |  |  |  | Index 0x7010:03 - Ctrl__Init request
 |  |  |  | Index 0x7010:04 - Ctrl__Send continous
 |  |  |  | Index 0x7010:09 - Ctrl__Output length
 |  |  |  | Index 0x7010:11 - Data out 0
 |  |  |  | --
 |  |  |  | Inde 0x 0x7020:26 - Data out 21
0x1604 (默认) | - | 24.0 | COM 输出 通道1 | Index 0x7001:01 - Ctrl
 |  |  |  | Inde 0x 0x7000:11 - Data out 0
 |  |  |  | --
 |  |  |  | Inde 0x 0x7000:26 - Data out 21
0x1605 (默认) | - | 24.0 | COM 输出 通道2 | Index 0x7011:01 - Ctrl
 |  |  |  | Index 0x7010:11 - Data out 0
 |  |  |  | --
 |  |  |  | Index 0x7010:26 - Data out 21

SM2, PDO 分配 0x1C13
Index | Index of excluded PDOs | 大小 (byte.bit) | 名称 | PDO 连接
0x1A00 | - | 24.0 | COM 输入 通道1 | Index 0x6000:01 - Status__Transmit accepted
 |  |  |  | Index 0x6000:02 - Status__Receive request
 |  |  |  | Index 0x6000:03 - Status__Init accepted
 |  |  |  | Index 0x6000:04 - Status__Buffer full
 |  |  |  | Index 0x6000:05 - Status__Input length
 |  |  |  | Index 0x6000:06 - Status__Framing error
 |  |  |  | Index 0x6000:07 - Status__Overrun error
 |  |  |  | Index 0x6000:09 - Status__Input length
 |  |  |  | Index 0x6000:11 - Data in 0
 |  |  |  | --
 |  |  |  | Index 0x6000:26 - Data in 21
0x1A01 | - | 24.0 | COM 输入 通道2 | Index 0x6010:01 - Status__Transmit accepted
 |  |  |  | Index 0x6010:02 - Status__Receive request
 |  |  |  | Index 0x6010:03 - Status__Init accepted
 |  |  |  | Index 0x6010:04 - Status__Buffer full
 |  |  |  | Index 0x6010:05 - Status__Input length
 |  |  |  | Index 0x6010:06 - Status__Framing error
 |  |  |  | Index 0x6010:07 - Status__Overrun error
 |  |  |  | Index 0x6010:09 - Status__Input length
 |  |  |  | Index 0x6010:11 - Data in 0
 |  |  |  | --
 |  |  |  | Index 0x6010:26 - Data in 21
0x1A04(默认) | - | 24.0 | COM 输入 通道1 | Index 0x6001:01 - Status
 |  |  |  | Index 0x6000:11 - Data in 0
 |  |  |  | --
 |  |  |  | Index 0x6000:26 - Data in 21
0x1A05(默认) | - | 24.0 | COM 输入 通道2 | Index 0x6011:01 - Status
 |  |  |  | Index 0x6010:11 - Data in 0
 |  |  |  | --
 |  |  |  | Index 0x6010:26 - Data in 21

Table 1: 同步管理器 PDO 分配

过程数据

出厂情况下，过程数据传输为22byte的用户数据和1个控制/状态字。

特征CoE (Index 80n0)

参数化可以在 CoE (CAN over EtherCAT) 文件夹中设置。

说明 		通过 CoE 列表 (CAN over EtherCAT)的参数化
请在使用/操作CoE参数时注意下列基本CoE信息：
如果组件需要重置，保留一个startup列表
区分online/offline，确保当前XML description 存在
- 使用 "CoE reload"重置改动

从object 8000开始的CoE默认设置如下：

图 1: ‘CoE online, 模块 EL60x2’ tab

过程数据描述

过程对象由CoE objects 6000 (输入) and 7000 (输出) 产生，并且在章节 对象描述和参数化中有描述

传输速率

端子模块有一个22bytes用户数据的过程映像。 最多第二个周期可以传送或接收这 22bytes。
数据在第一个周期从模块传送到控制器。 第二个周期，控制器必须确认接收到数据。
因此，如果周期是10ms，22byte 每秒可以被传输50次。

由于根据8N1结构设置数据，每个传输的字节由一个开始位，8个数据位和一个停止位组成。 这等于每个用户字节为10位。

根据上述设定，连续数据传输速率：
• 可以达到50[1/s]*22[Byte]*10[Bit] = 11000 bps

略低一级的波特率为9600 baud。 因此，可以保证以10ms 的周期时间 9600的最大波特率连续传输数据。

如果只需低质量的数据传输或偶然接收（e.g. 条线代码扫描器）波特率可以被设得更高，或者加大周期时间。
 如果控制器不能及时地从模块获取数据，数据将被储存在模块内部的缓冲区中。 接收数据缓冲区大小为864 byte。 如果被耗尽，所有新到的数据都将被丢失。

另一种情况： 控制器相较于模块可以传输更大量的数据。 如果‘波特率’设为300，‘数据类型’设为8N1，模块每秒只能传输30 byte。 然而，如果每秒需要接收30 byte以上的数据，这种情况下会先写入到一个128字节的传输缓冲区中。一旦缓冲区满，则所有新到的数据将丢失。

在普通运行模式下接收的数据将立刻被加入过程映像。 为了实现连续的数据流，在Settings object中的‘Enable transfer rate optimization’ 选项标准状况下为激活。 激活此选项，数据会首先快速存储到接收缓冲区中(864 bytes)。

如果超过16bit的时间没有接收到新的字符或缓冲区已满，数据将被复制进过程映像。

数据的连续传输

连续的数据流对于许多应用是不可缺少的。 基于此需求，倍福 EL60xx 在Settings object中特别设置了‘允许连续发送 FIFO 数据’ 设定。 设置此选项后，可以先填充模块的内部发送缓冲区(128 bytes)。 此后缓冲区的条目内容可以被无间断地发送。 于是，数据可以像普通传输一样从控制器发送到模块。 缓冲区的数据只在‘Send continuous’ 位为上升沿时发送。 如果数据被发送，模块通过设置‘Init accepted’ 位告知控制器。 ‘Send continuous’位会复位‘Init accepted’位。

优先级

由于接受到的数据一般不能被重现，因此它比要发送的数据的优先级更高。
而且，随着用到号的递增，优先级递减。 因此，通道1的数据接受具有最高优先级。

数据传输举例

初始化

初始化在第一次传输/接受之前执行。 模块根据相应的Settings object中的数据进行参数化。

过程：

  1. 设置‘Init request’为1
  2. 模块通过设置 ‘Init accepted’确认初始化成功。
  3. 重置 ‘Init request’
  4. 模块将 ‘Init accepted’设为0
模块现已准备好数据传输

数据从控制器传输到模块（发送2个字符）

  1. 设置‘Output length’ 为 2
  2. 以用户数据填充 ‘Data Out 0' 和 ‘Data Out 1’
  3. 改变‘Transmit request’的状态
  4. 端子模块通过改变 ‘TransmitAccepted’ 这一传输接收 位的状态来确认数据的接收.

数据从模块传输到控制器（接收字符）

  1. 模块通过改变‘Receive request’ 位的值表明过程映像中有新的数据。
  2. 接收到的字节个数被写入‘Input length’
  3. 控制器通过改变‘Receive request’确认字节的接收。


EL600x, EL602x –应用示例

BECKHOFF EL600x, EL602x: 应用案例

样例程序1

说明

使用样例程序

本文件包含了我们的产品在某些领域应用的应用样例。 这里提供的应用说明是基于我们产品的典型特征的并且仅仅作为例子使用。 这个文件包含的说明不涉及特殊应用。 用户因此需评估并决定产品是否适用于实际的应用。 我们不对本文件中的源代码的完整性和正确性负责。 我们始终保留修改本文件中内容的权力，并且不承担错误及信息丢失的责任。

串口条码扫描器的连接

Download:

本例中，EL6001将连接一个条码识别器。 识别器读取字符，直到接收到ASCII字符 0x0D (13dec, CR)。

Data:

  • 执行串口通信的快速任务： 1ms周期时间
  • 标准PLC任务 10ms周期时间
  • 通道1连接条码扫描器
  • 需要TwinCAT 2.11
  • 需要‘TwinCAT PLC Serial Communication’ 组件

有关使用串口通信库的详细描述在Beckhoff Information System中。

Beckhoff Information System -> TwinCAT -> TwinCAT PLC -> TwinCAT libraries for PC-based systems -> TwinCAT PLC Library : Serial communication

启动样例程序

应用样例经过了下述测试配置的测试。
在实际设置时可能出现偏差。

测试配置中使用了下列硬件和软件：

  • TwinCAT主站PC，Windows XP Professional SP 3操作系统，TwinCAT 版本 2.11 (Build 1528) INTEL PRO/100 VE以太网适配器。
  • Beckhoff EK1100 EtherCAT耦合器， EL6001端子模块
  • 带9针Sub-D连接器的串口条码扫描器

启动程序的步骤

  • 点击 下载按钮后，保存zip文件到本地，解压*.TSM (配置) and the *.PRO (PLC程序) 到一个临时工作文件夹
  • 运行*.TSM文件和*.PRO文件 TwinCAT System Manger 和TwinCAT PLC 将打开
  • 连接与图1中相同的硬件。 将PC的以太网适配器连接到EtherCAT 耦合器上（更多详细信息可以在相应的耦合器手册上找到）
  • 在System configuration, I/O configuration, I/O devices, Device (EtherCAT)下选择本地 Ethernet适配器（带实时驱动）； 在"Adapter"页上选择"Search..."，选择合适的适配器并确认（见图. 2A + 2B)

    图 2 a: 搜索以太网适配器

    图 2B: 选择并确认以太网适配器

  • 激活配置并确认（图. 3A +3B)

    图 3: 激活配置

    图 3B: 确认激活配置
  • 确认新的变量映射，重启到 RUN 模式（图. 4A + 4B)

    图 4 a: 生成变量映射

    图 4B: 重启 TwinCAT到 RUN 模式
  • 在 TwinCAT PLC中，在 "Project" 下，选择"Rebuild all"来编译项目(图. 5)

    图 5: 建立程序

  • 在 TwinCAT PLC中: 按F11登陆，确认读取项目(图. 6),按F5运行程序

    图 6: 确认程序开始运行

  • 在字符 0x13接收后，条码被存储在 ‘LastBarcode’中。

    图 7: 接收的条码


EL600x, EL602x –应用示例

BECKHOFF EL600x, EL602x: 配置

样例程序2

说明

使用样例程序

本文件包含了我们的产品在某些领域应用的应用样例. 这里提供的应用说明是基于我们产品的典型特征的并且仅仅作为例子使用。 这个文件包含的说明不涉及特殊应用。 用户因此需评估并决定产品是否适用于实际的应用。 我们不对本文件中的源代码的完整性和正确性负责。 我们始终保留修改本文件中内容的权力，并且不承担错误及信息丢失的责任。

下载样例程序

阅读并解析时间报文

本例展示了如何在PLC中处理并解析大部分的串口时间协议。 为此目的，PLC中提供了相关的IEC61131-PLC功能块用于解析数据流，并根据需要，可分离时间及地址信息。 这些信息可以被利用，例如，用于同步控制器或记录位移。

在本例中，采用了Beckhoff EL /KL60xx 串行数据交换端子模块通过22byte接口发送数据。

背景信息

不只在海事应用中时间和位置信息通过串行总线传输： 在多数情况下，数据源将信息通过RS232 / RS485, USB 或 Ethernet循环分发（或触发分发）到低一级的接收者。
时间和位置信息的分布在世界范围内有着非常多的的报文结构 我们通常称之为 ‘sentences’。 这类报文由数据字节组成，并且遵循：

  • 报文以STX, ETX作为起始和结束字符，可能有不止一个结束字符
  • 一个被定义的固定长度
  • 一个被定义的结构
  • 校验和（非必要）
  • 如果需要在句子中有类型指明

众多组织或公司位特别需求开发了开放的或专利的结构。 因此，本例给出两个“样例实现”，可以被简单地应用到特定协议中。 例子中的报文格式为Meinberg标准及NMEA0183 v2.3 类型 RMC。

信息来源

GPS或无线电控制的时钟网关在串行领域被用作数据传输器。 这些设备接收各自的时间信号（GPS通过卫星或者无线电控时钟通过长波）并且转换为串行，线边界的传输，例如 RS232 8N1. 网关通常包含一个本地时间源用于在参考信号短期失效时在特定时间内持续分布可靠的时间信息(GPS, 无线电传输器) 在中欧，采用德国DCF77编码发送。
如果有必要，更多参考信号的信息可以用到：

  • GPS: 定位信息（W/N及高度），upcoming clock change DCF77: 天气信息，重要事件
  • DCF77: 天气信息，重要事件

低级时间从站的同步

通常，低级从站可以被调整为网关的时间，i.e.他们需要同步彼此时间。 以下内容对此很重要：

  • 偏移： 从站的自身时间和网关的参考时间的绝对误差，此信息可以被传输，例如， 在确认时间信息有效时可进行异步及串行传输。从本例中可以通过串行传输方式获得这些偏移信息。
  • 频率比： 当上述绝对偏移有效时，从网关到从站的高精度周期信号允许漂移过程被补偿并且指定时间。 这类信号的一个例子就是广泛使用的PPS（每秒脉冲）。

如果来自网关的串行报文周期地放置到总线，第一位的时间经常可以被解释为PPS信号。 在本例中的模块中，不考虑此情况， 仅对绝对时间信息进行评估。

时间格式

与NMEA0183 标准一致的时间报文被广泛采用。 请注意：

  • 当前（2009）NMEA0183标准有从NMEA0183 1.5 到 4.00 8个版本-不同版本间报文结构有所不同。
  • 仅在NMEA0183 v2.30中有70种不同的形式被定义； 设备制造商也可额外创建自己的形式。
  • 报文被称为一个句子
  • TalkerID（2字符）和TypeID （3字符）在一开始定义了所有句子的类型。
  • 计算报文的校验和
  • 相关信息可以在网上www.nmea.org 或其他地方找到。

而且，许多专利形式存在，例如Meinberg标准Siemens SINEC H1和 SAT 1703，或军用形式例如 IRIG codes (USA).

使用样例程序

PLC程序包含两个功能块（FBs），需要专门地连接到EL/KL600x. 随后从模块采集接收到的字节并且尽可能地解析其内容。 这两个功能块包括:

  • Meinberg 标准
  • NMEA0183 v2.3 type RMC

对于其他时间形式，您可以在已知的报文结构上创建自己的功能块； 联系您的设备制造商来商讨此事。

本例中应用的硬件： EK1100 and EL6001 (或 EL600x, KL600x)
测试的功能块必须链接到System Manager中模块的过程映像(22-byte 过程映像 和控制字/状态字)。
本例中的NMEA模块已链接。 模块的波特率必须被设置成匹配您的发送器。

案例参考

  • www.beuth.de, IEC61162: 基于 NMEA2000
  • www.gpsinformation.org ,专用, 通过 NMEA, 许多形式: http://www.gpsinformation.org/dale/nmea.htm
    http://www.nmea.de/nmea0183datensaetze.html
  • http://www.meinberg.de/german/info/irig.htm, IRIG-codes
  • http://www.siemens-edm.de/FAQ.siemens-edm-faq0.0.html, 时间同步


TwinCAT System Manager -配置

BECKHOFF TwinCAT System Manager: 组态

TwinCAT System Manager进行配置

(以TwinCAT 2.10.0 (Build 1241)版本, 和EL5001 固件版本 0.7以上 为例)

在TwinCAT System manager左手边的窗口，点击你想要设置的模块（如例：EL1014 Terminal 4: EL5001 Terminal 6).

在TwinCAT System manager右手边的窗口，有多个用来设置端子的标签。

General tab

Name | EtherCAT 设备名称
Id | EtherCAT 设备编号
Type | EtherCAT 设备说明
Comment | 这里你可以添加注释(比如，关于系统)。
Disabled | 你可以在这里停止使用EtherCAT设备。
Create symbols | 如果选中复选框，可以通过ADS连接这个EtherCAT从站

EtherCAT tab

Type | EtherCAT 设备说明
Product/Revision | EtherCAT 设备的型号和版本
Auto Inc Addr. | EtherCAT设备的地址自动增量。 自动增量地址可以通过EtherCAT设备的物理地址在通信环中定位它的地址。 自动增量地址更据EtherCAT设备在通信环中的物理位置排列。 在通信环中的第一个EtherCAT从站的地址就是0000hex. 之后的从站地址减 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | 固定 EtherCAT 从站地址。 此地址由EtherCAT 主站启动时分配。 选中左侧的复选框后即可修改。
Previous Port | 已连接的前一个EtherCAT设备的名字和端口。 这里可以通过不改变EtherCAT通讯环来选择这个设备与另一个设备的连接，下拉框里列出可以选择的EtherCAT设备。
Advanced Settings | 点击这个按钮 打开高级设置对话框。

底部的链接指向网站上的产品页面

Process Data tab

为过程数据的设置。 EtherCAT 从站的输入输出数据是用CANopen数据对象(PDO)来表示。 如果EtherCAT从站支持这个功能，可以通过这个对话框修改PDO选项。

Sync Manager

列出Sync Manager（SM）的设置。
如果EtherCAT从站有mailbox，SM0用于mailbox输出(MbxOut)， SM1用于mailbox输入(MbxIn)。
SM2用于输出过程数据 (outputs) ， SM3 (inputs)用于输入过程数据。

如果选定输入, 在下面 PDO Assignment 的列表中显示对应的PDO分配。

PDO Assignment

所选 Sync Manager的PDO分配 当前Sync Manager 类型所定义的所有PDOs 都显示在这里：

  • 如果Sync Manager列表中选择输出Sync Manager (outputs)，所有的RxPDOs都显示在下面。
  • 如果Sync Manager列表中选择输入Sync Manager (inputs)，所有的TxPDOs都显示在下面。

选择的PDOs将确定过程数据的传输。 在System Manager的树形列表中，这些PDOs以EtherCAT从站变量的形式显示。 变量名和在PDO列表中的PDO的参数名 完全一样。 如果PDO分配列表中的条目被禁用，（未被选择并呈灰色），这表示输入被排除在PDO分配之外了。 为了能够选择这个灰色的PDO，首先就要先取消选择当前的PDO。

说明 		激活 PDO 配置
改变PDO配置后，为了使新的PDO配置生效，
  • EtherCAT从站需要通过 PS状态转换循环 (从 pre-operational 到 safe-operational) 一次 (见 Online tab),
  • 然后在System Manager中点击(reload ) EtherCAT 从站按钮

PDO list

列出EtherCAT 设备所支持的所有PDO。 所选择PDO的内容会在 PDO Content 列表中显示出来。 可以通过双击来修改PDO配置。

列 | 描述
Index | PDO 索引
Size | PDO的 byte数
Name | PDO名称 如果这个PDO 分配到Sync Manager，从站的变量名即为此参数。
Flags | F | 固定内容: 这个PDO的内容被固定，且不能用System Manager修改。
 | M | 管理 PDO. 这个PDO是强制的必须分配到Sync Manager! 因此这个PDO不能从 PDO Assignment列表中删除
SM | 显示这个PDO 与哪个Sync Manager 关联。 如果是空的，那么就说明这个PDO不在过程数据中。
SU | 显示这个PDO与哪个Sync unit关联

PDO Content

显示PDO内容 如果这个PDO的 flag 不为F (固定内容) 那么就可以修改它的内容。

Download

对于智能从站且具备mailbox，PDO配置和PDO关联可以下载到从站中。 这是一个可选项不是所有的EtherCAT从站都支持。

PDO Assignment

如果选中此复选框，PDO Assignment列表中的PDO关联会在启动时下载到从站中。 需要的命令会被传输到从站中，并在 Startup中显示。

PDO Configuration

如果选中此复选框，相应的PDO配置(如图中PDO list和PDO Content)将会下载到EtherCAT从站中

Startup tab

Startup 显示 EtherCAT从站是否有mailbox ，是否支持CANopen over EtherCAT (CoE) 或 Servo drive over EtherCAT协议。 此表显示哪个下载请求在启动阶段被发送到mailbox 也可以列表中添加新的mailbox请求。 下载请求以他们在列表中的顺序依次发送到从站。

列 | 描述
Transition 请求发送到哪里。 这可以是
  • 从pre-operational 传输到 safe-operational (PS), 或
  • 从safe-operational 传输到 operational (SO).

如果Transition在"<>" (e.g. <PS>)是关闭的， 则邮箱请求是固定的并且用户无法修改或删除。
协议 | mailbox协议类型
Index | 对象的索引
Data | 下载对象的数据
说明 | 发送到mailbox请求的描述
Move Up | 把请求的位置向上移一位。
Move Down | 把请求的位置向下移一位。
New | 添加一个新的mailbox启动下载请求。
Delete | 删除一个选中的项
Edit | 编辑现有的请求

CoE - Online tab

如果EtherCAT从站支持 CANopen over EtherCAT (CoE) 那么CoE - Online 就会显示。 这个对话框列出了从站对象表中的内容(SDO upload)并且使用户能够从这个表中修改对象的内容。 可以在特定设备的对象描述中找到每个 EtherCAT 从站的对象详细信息。

对象列表显示
列 | 描述
Index | 对象的索引和子索引
Name | 对象的名称
Flags | RW | 对象可读可写(read/write)
 | RO | 对象只读(read only)
 | P | P表示此对象为过程数据对象。
Value | 对象的值
Update List | Update list按钮更新显示列表中的所有对象。
Auto Update | 如果这个复选框勾上，表格中的所有数据自动更新。
Advanced | Advanced按钮打开Advanced Settings 对话框。 选择在列表中显示的对象。

Online - via SDO Information | 如果这个单选框被选中，那么包括在从站对象列表中的对象列表将通过SDO信息的方式上载。 列表显示哪些对象类型可以上载。
Offline - via EDS File | 如果这个单选框被选中，在从站对象列表中的对象列表将从EDS文件中读取。

Online tab

状态机

Init | 这个按钮将EtherCAT 从站设为Init 状态。
Pre-Op | 这个按钮将EtherCAT 从站设为 pre-operational状态
Op | 这个按钮将EtherCAT 从站设为 operational状态
Bootstrap | 这个按钮将EtherCAT 从站设为Bootstrap 状态。
Safe-Op | 这个按钮将EtherCAT 从站设为 safe-operational状态
Clear Error | 这个按钮将删除显示中的错误信息。 如果EtherCAT从站在状态转换中出错了，它就会设定一个出错标志位. 例子: 一个EtherCAT从站处于PREOP状态 (pre-operational)。 主站现在请求它进入SAFEOP状态（safe-operational). 如果从站在状态转换中出错，那么它就会设置错误标志。 当前状态就会显示为ERR PREOP。 当点过 Clear Error按钮后错误标志清楚, 然后状态变为 PREOP。
Current State | 显示EtherCAT从站的当前状态。
Requested State | EtherCAT 从站被要求的状态。

DLL 状态

表明EtherCAT从站独立端口的的DLL状态 (数据链路层状态) DLL有四种不同的状态：

状态 | 描述
No Carrier / Open | 端口无载波信号, 但是端口开放。
No Carrier / Closed | 端口无载波信号, 但是端口是关闭的。
Carrier / Open | 端口有载波信号，但是端口是开放的
Carrier / Closed | 端口有载波信号，但是端口是关闭的。

File Access over EtherCAT

Download | 通过这个按键可以将文件写入EtherCAT设备。
Upload | 通过这个按键可以从EtherCAT设备读取文件。


EL6001, EL6021 -对象描述和参数化

BECKHOFF EL6001, EL6021: 配置

对象描述和参数化

说明

EtherCAT XML 设备描述

本描述对应 EtherCAT XML设备描述中的 CoE对象的显示。 强烈建议从倍福网站(http://www.beckhoff.com/english/default.htm?download/elconfg.htm)下载最新版本的相应XML文件，并遵循安装指引。

说明

参数化

模块的参数化将被 CoE tab （双击相关对象）执行，见以下。

介绍

CoE概述包含了不同预期的应用的对象：

  • 调试过程中参数化需要的对象
  • 表示内部设置的对象 （可被修改）
  • Profile 特殊变量，用于表示输入输出的状态（ 从硬件 03）

下面的章节首先描述了普通操作所需的对象，其后是其他变量的详细概述。

调试对象

Index 1011 恢复默认参数
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1011:0 | 恢复默认参数 | 恢复EtherCAT从站的默认设置 | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | 如果对象设置为"0x64616F6C" ("设定值对话框") 所有模块特殊变量都将设定成他们的delivery state。 | UINT32 | RW | 0x00000000 (0dec)
Index 4073 Baudrate
Index | 名称 | 含义 | 数据类型 | Flags | 默认
4073:0 | 波特率 | 0x0004: 2400 Baud 0x0005: 4800 Baud 0x0006: 9600 Baud 0x0007: 19200 Baud 0x0008: 38400 Baud 0x0009: 57600 Baud 0x000A: 115200 Baud 0x000E: 12000 Baud **) ***) 0x000F: 14400 Baud **) ***) | UINT16 | RW | 0x0006 (6dec)

**) 仅 EL6001
***) firmware 07以上

Index 4074 数据结构
Index | 名称 | 含义 | 数据类型 | Flags | 默认
4074:0 | 数据结构 | 7E1: 7个数据位，偶数奇偶校验，1个停止位 7E2: 7个数据位，偶数奇偶校验，2个停止位 7O1: 7个数据位，奇数奇偶校验，1个停止位 7O2: 7个数据位，奇数奇偶校验，2个停止位 8N1: 8个数据位，无奇偶校验，1个停止位 8N2: 8个数据位，无奇偶校验，2个停止位 8E1: 8个数据位，偶数奇偶校验，1个停止位 8E2: 8个数据位，偶数奇偶校验，2个停止位 8O1: 8个数据位，奇数奇偶校验，1个停止位 8O2: 8个数据位，奇数奇偶校验，2 Stopp-Bis | UINT16 | RW | 0x0003 (3dec)
Index 4075 特征位

Index

名称

含义

数据类型

Flags

默认

4075:0

特征位

Max. subindex

UINT8

RO

0x06 (6dec)

4075:01

EL6001:
Enable RTS/CTS

0: RTS/CTS disabled
1: RTS/CTS enabled

布尔

RW

0x00 (0dec)

EL6021:
支持半双工

0: 全双工模式
1: 半双工模式

4075:02

使能 XON/XOFF支持 tx 数据

0: XON/XOFF不支持发送数据
1: XON/XOFF支持发送数据

布尔

RW

0x00 (0dec)

4075:03

使能 XON/XOFF支持 rx 数据

0: XON/XOFF不支持接收数据
1: XON/XOFF支持接收数据

布尔

RW

0x00 (0dec)

4075:04

EL6001:
使能连续发送 FIFO 数据

0: 不持续发送来自FIFO的数据
1: 控制器填充发送缓冲区（最大到128字节）。 缓冲区中的内容在控制字中的CW.3 位的上升沿发送。 模块通过设置状态字中的SW.2 位来确认数据传输至控制器. CW.3重置SW.2。

布尔

RO

0x00 (0dec)

EL6021:
使能点到点连接（RS422)

0: 不允许点到点连接
1: 允许点到点连接

4075:05

EL6001:
使能优化传输速率

0: 优化传输速率关闭
1: 优化传输速率打开：

输入缓冲区的内容自动传输到过程印象中，如果：

  • 没有接受到其它字节 在数据接收后大约16位的时间里(i.e.接收两byte所需要的时间)
  • 过程数据映像已满

布尔

RO

0x00 (0dec)

EL6021:
使能连续发送 FIFO 数据

0: 不持续发送来自FIFO的数据
1: 控制器填充发送缓冲区（最大到128字节）。 缓冲区中的内容在控制字中的CW.3 位的上升沿发送。 模块通过设置状态字中的SW.2 位来确认数据传输至控制器. CW.3重置SW.2

4075:06

only EL6021:
使能优化传输速率

0: 优化传输速率关闭
1: 优化传输速率打开：

输入缓冲区的内容自动传输到过程印象中，如果

  • 没有接受到其它字节 在数据接收后大约16位的时间里(i.e.接收两byte所需要的时间)
  • 输入缓冲区已满

布尔

RW

0x00 (0dec)
Index 4076 Rx 缓冲区已满通告
Index | 名称 | 含义 | 数据类型 | Flags | 默认
4076:0 | Rx 缓冲区已满通告 | 该值决定了接收FIFO中的数据的个数，由状态字节中的 SW.3 (BUF_F) 位设定。 | UINT16 | RW | 0x0000 (0dec)
Index 8000 COM 设置[来自 硬件 03]

Index

名称

含义

数据类型

Flags

默认

8000:0

COM 设置

Max. subindex

UINT8

RO

0x1A (26dec)

8000:01**)

使能 RTS/CTS

FALSE

不允许RTS/CTS

布尔

RW

0x01 (1dec)

TRUE

RTS/CTS 允许

8000:02

使能 XON/XOFF 支持 tx 数据

FALSE

XON/XOFF不支持发送数据

布尔

RW

0x00 (0dec)

TRUE

XON/XOFF支持发送数据

8000:03

使能 XON/XOFF支持 rx 数据

FALSE

XON/XOFF不支持接收数据

布尔

RW

0x00 (0dec)

TRUE

XON/XOFF支持接收数据

8000:04

使能连续发送 FIFO 数据

FALSE

不持续发送来自FIFO的数据

布尔

RW

0x00 (0dec)

TRUE

持续发送来自FIFO的数据:
控制器填充发送缓冲区（最大到128字节）。 缓冲内容根据 "SendContinious"位的上升沿发送. 模块通过设置 "InitAccepted" 位来确认数据传输至控制器" . "SendContinious"重置"InitAccepted"

8000:05

使能优化传输速率

FALSE

优化传输速率关闭

布尔

RW

0x01 (1dec)

TRUE

优化传输速率打开：
输入缓冲区的内容自动传输到过程印象中，如果

  • 没有接受到其它字节 在数据接收后大约16位的时间里(i.e.接收两byte所需要的时间)
  • 输入缓冲区已满

8000:06***)

支持半双工

FALSE

全双工模式

布尔

RW

0x00 (0dec)

TRUE

半双工模式

8000:07***)

使能点到点连接（RS422)

FALSE

不允许点到点连接

布尔

RW

0x00 (0dec)

TRUE

允许点到点连接

8000:11

波特率

4

2400 baud

BIT4

RW

0x06 (6dec)

5

4800 baud

6

9600 baud

7

19200 baud

8

38400 baud

9

57600 baud

10

115200 baud

14

12000 baud ***) ****)

15

14400 baud ***) ****)

8000:15

数据结构

1

7个数据位，偶数奇偶校验，1个停止位

BIT4

RW

0x03 (3dec)

2

7个数据位，奇数奇偶校验，1个停止位

3

8个数据位，无奇偶校验，1个停止位

4

8个数据位，偶数奇偶校验，1个停止位

5

8个数据位，奇数奇偶校验，1个停止位

9

7个数据位，偶数奇偶校验，2个停止位

10

7个数据位，奇数奇偶校验，2个停止位

11

8个数据位，无奇偶校验，2个停止位

12

8个数据位，偶数奇偶校验，2个停止位

13

8个数据位，奇数奇偶校验，2个停止位

8000:1A***)

Rx 缓冲区已满通告

该值决定了接收FIFO中的数据的个数，由状态字节中的 SW.3 (BUF_F) 位设定。

UINT16

RW

0x0360 (864dec)

**) 仅 EL6001
***) 仅 EL6021
****) 从 固件 07

常规操作的对象

在一般功能范围内 EL6001, EL6021没有这些对象

完整概述

标准对象 (0x1000-0x1FFF)

所有EtherCAT从站的标准对象具有相同意义。

Index 1000 设备类型
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1000:0 | 设备类型 | EtherCAT从站的设备类型 Lo-Word包含了支持的CoE资料（5001） Hi-Word包含了与模块化设备资料对应的模块资料。 | UINT32 | RO | 0x02581389 (39326601dec)
Index 1008 设备名称
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1008:0 | 设备名称 | EtherCAT 从站的设备名称 | STRING | RO | EL6001 EL6021
Index 1009 硬件版本
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1009:0 | 硬件版本 | EtherCAT从站的硬件版本 | STRING | RO | 04
Index 100A 软件版本
Index | 名称 | 含义 | 数据类型 | Flags | 默认
100A:0 | 软件版本 | EtherCAT从站的固件版本 | STRING | RO | 05
Index 1018 认证
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1018:0 | 认证 | 包含了认证EtherCAT 从站的信息 | UINT8 | RO | 0x04 (4dec)
1018:01 | 供应商ID | EtherCAT从站的供应商ID | UINT32 | RO | 0x00000002 (2dec)
1018:02 | 产品代码 | EtherCAT从站的产品代码 | UINT32 | RO | 0x17853052 (394604626dec)
1018:03 | 子版本 | EtherCAT从站的子版本号，Lo-Word (Bit 0-15)表示特殊功能端子模块号码； Hi-Word (Bit 16-31)表示设备描述。 | UINT32 | RO | 0x00100000 (1048576dec)
1018:04 | 序列号 | EtherCAT从站的序列号，Lo-Word的Lo-Byte (Bit 0-7)包含了生产年份，Lo-Word的Hi-Byte (Bit 8-15) 包含了生产的星期，Hi-Word (Bit 16-31) 为0。 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 后备参数处理
Index | 名称 | 含义 | 数据类型 | Flags | 默认
10F0:0 | 后备参数处理 | 包含后备入口的标准化上载与下载信息。 | UINT8 | RO | 0x01 (1dec)
10F0:01 | 校验和 | 所有后备入口的校验和 | UINT32 | RO | 0x00000000 (0dec)
Index 1400 RxPDO-Par Outputs
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1400:0 | RxPDO-Par Outputs | PDO 参数 RxPDO 1 | UINT8 | RO | 0x06 (6dec)
1400:06 | 包含RxPDOs | RxPDO映射对象的索引，不允许和RxPDO 1一起传送 | OCTET-STRING[6] | RO | 01 16 02 16 04 16
Index 1401 RxPDO-Par Outputs
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1401:0 | RxPDO-Par Outputs | PDO 参数 RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1401:06 | 包含RxPDOs | RxPDO映射对象的索引，不允许和RxPDO 2一起传送 | OCTET-STRING[6] | RO | 00 16 02 16 04 16
Index 1402 RxPDO-Par Outputs
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1402:0 | RxPDO-Par Outputs | PDO 参数 RxPDO 3 | UINT8 | RO | 0x06 (6dec)
1402:06 | 包含RxPDOs | RxPDO映射对象的索引，不允许和RxPDO 3一起传送 | OCTET-STRING[6] | RO | 00 16 01 16 04 16
Index 1600 RxPDO-Par Outputs
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1600:0 | RxPDO-Map Outputs | PDO Mapping RxPDO 1 | UINT8 | RO | 0x04 (4dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x3001 ( Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x3001:01, 8
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x3001 ( Outputs), entry 0x02 (Data Out 0)) | UINT32 | RO | 0x3001:02, 8
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x3001 ( Outputs), entry 0x03 (Data Out 1)) | UINT32 | RO | 0x3001:03, 8
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x3001 ( Outputs), entry 0x04 (Data Out 2)) | UINT32 | RO | 0x3001:04, 8
Index 1601 RxPDO-Par Outputs
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1601:0 | RxPDO-Map Outputs | PDO Mapping RxPDO 2 | UINT8 | RO | 0x06 (6dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x3002 ( Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x3002:01, 8
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x3002 ( Outputs), entry 0x02 (Data Out 0)) | UINT32 | RO | 0x3002:02, 8
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x3002 ( Outputs), entry 0x03 (Data Out 1)) | UINT32 | RO | 0x3002:03, 8
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x3002 ( Outputs), entry 0x04 (Data Out 2)) | UINT32 | RO | 0x3002:04, 8
1601:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x3002 ( Outputs), entry 0x05 (Data Out 3)) | UINT32 | RO | 0x3002:05, 8
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x3002 ( Outputs), entry 0x06 (Data Out 4)) | UINT32 | RO | 0x3002:06, 8
Index 1602 RxPDO-Par Outputs
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1602:0 | RxPDO-Map Outputs | PDO Mapping RxPDO 3 | UINT8 | RO | 0x17 (23dec)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x3003:01, 16
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x02 (Data Out 0)) | UINT32 | RO | 0x3003:02, 8
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x03 (Data Out 1)) | UINT32 | RO | 0x3003:03, 8
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x04 (Data Out 2)) | UINT32 | RO | 0x3003:04, 8
1602:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x05 (Data Out 3)) | UINT32 | RO | 0x3003:05, 8
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x06 (Data Out 4)) | UINT32 | RO | 0x3003:06, 8
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x07 (Data Out 5)) | UINT32 | RO | 0x3003:07, 8
1602:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x08 (Data Out 6)) | UINT32 | RO | 0x3003:08, 8
1602:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x09 (Data Out 7)) | UINT32 | RO | 0x3003:09, 8
1602:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x0 (Data Out 8)) | UINT32 | RO | 0x3003:0A, 8
1602:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x0 (Data Out 9)) | UINT32 | RO | 0x3003:0B, 8
1602:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x0 (Data Out 10)) | UINT32 | RO | 0x3003:0C, 8
1602:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x0 (Data Out 11)) | UINT32 | RO | 0x3003:0D, 8
1602:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x0 (Data Out 12)) | UINT32 | RO | 0x3003:0E, 8
1602:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x0 (Data Out 13)) | UINT32 | RO | 0x3003:0F, 8
1602:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x10 (Data Out 14)) | UINT32 | RO | 0x3003:10, 8
1602:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x11 (Data Out 15)) | UINT32 | RO | 0x3003:11, 8
1602:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x12 (Data Out 16)) | UINT32 | RO | 0x3003:12, 8
1602:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x13 (Data Out 17)) | UINT32 | RO | 0x3003:13, 8
1602:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x14 (Data Out 18)) | UINT32 | RO | 0x3003:14, 8
1602:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x15 (Data Out 19)) | UINT32 | RO | 0x3003:15, 8
1602:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x16 (Data Out 20)) | UINT32 | RO | 0x3003:16, 8
1602:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x3003 ( Outputs), entry 0x17 (Data Out 21)) | UINT32 | RO | 0x3003:17, 8
Index 1604 COM RxPDO-Map Outputs [从硬件 03]
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1604:0 | COM RxPDO-Map Outputs | PDO Mapping RxPDO 5 | UINT8 | RO | 0x1C (28dec)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (COM Outputs), entry 0x01 (传送请求)) | UINT32 | RO | 0x7000:01, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (COM Outputs), entry 0x02 (接受接收)) | UINT32 | RO | 0x7000:02, 1
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (COM Outputs), entry 0x03 (初始化请求)) | UINT32 | RO | 0x7000:03, 1
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (COM Outputs), entry 0x04 (连续发送)) | UINT32 | RO | 0x7000:04, 1
1604:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1604:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (COM Outputs), entry 0x09 (输出长度)) | UINT32 | RO | 0x7000:09, 8
1604:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x11 (Data Out 0)) | UINT32 | RO | 0x7000:11, 8
1604:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x12 (Data Out 1)) | UINT32 | RO | 0x7000:12, 8
1604:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x13 (Data Out 2)) | UINT32 | RO | 0x7000:13, 8
1604:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x14 (Data Out 3)) | UINT32 | RO | 0x7000:14, 8
1604:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x15 (Data Out 4)) | UINT32 | RO | 0x7000:15, 8
1604:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x16 (Data Out 5)) | UINT32 | RO | 0x7000:16, 8
1604:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x17 (Data Out 6)) | UINT32 | RO | 0x7000:17, 8
1604:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x18 (Data Out 7)) | UINT32 | RO | 0x7000:18, 8
1604:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x19 (Data Out 8)) | UINT32 | RO | 0x7000:19, 8
1604:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x1 (Data Out 9)) | UINT32 | RO | 0x7000:1A, 8
1604:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x1 (Data Out 10)) | UINT32 | RO | 0x7000:1B, 8
1604:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x1 (Data Out 11)) | UINT32 | RO | 0x7000:1C, 8
1604:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x1 (Data Out 12)) | UINT32 | RO | 0x7000:1D, 8
1604:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x1 (Data Out 13)) | UINT32 | RO | 0x7000:1E, 8
1604:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x1 (Data Out 14)) | UINT32 | RO | 0x7000:1F, 8
1604:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x20 (Data Out 15)) | UINT32 | RO | 0x7000:20, 8
1604:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x21 (Data Out 16)) | UINT32 | RO | 0x7000:21, 8
1604:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x22 (Data Out 17)) | UINT32 | RO | 0x7000:22, 8
1604:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x23 (Data Out 18)) | UINT32 | RO | 0x7000:23, 8
1604:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x24 (Data Out 19)) | UINT32 | RO | 0x7000:24, 8
1604:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x25 (Data Out 20)) | UINT32 | RO | 0x7000:25, 8
1604:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7000 ( Outputs), entry 0x26 (Data Out 21)) | UINT32 | RO | 0x7000:26, 8
Index 1800 TxPDO-Par Inputs
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1800:0 | TxPDO-Par Inputs | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1800:06 | 包含 TxPDOs | RxPDO映射对象的索引，不允许和RxPDO 1一起传送 | OCTET-STRING[6] | RO | 01 1A 02 1A 04 1A
Index 1801 TxPDO-Par Inputs
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1801:0 | TxPDO-Par Inputs | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1801:06 | 包含TxPDOs | RxPDO映射对象的索引，不允许和RxPDO 2一起传送 | OCTET-STRING[6] | RO | 00 1A 02 1A 04 1A
Index 1802 TxPDO-Par Inputs
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1802:0 | TxPDO-Par Inputs | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | 包含TxPDOs | RxPDO映射对象的索引，不允许和RxPDO 3一起传送 | OCTET-STRING[6] | RO | 00 1A 01 1A 04 1A
Index 1A00 TxPDO-Map Inputs
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1A00:0 | TxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x04 (4dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x3101 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x3101:01, 8
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x3101 ( Outputs), entry 0x02 (Data Out 0)) | UINT32 | RO | 0x3101:02, 8
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x3101 ( Outputs), entry 0x03 (Data Out 1)) | UINT32 | RO | 0x3101:03, 8
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x3101 ( Outputs), entry 0x04 (Data Out 2)) | UINT32 | RO | 0x3101:04, 8
Index 1A01 TxPDO-Map Inputs
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1A01:0 | TxPDO-Map Inputs | PDO Mapping TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x3102 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x3102:01, 8
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x3102 ( Outputs), entry 0x02 (Data Out 0)) | UINT32 | RO | 0x3102:02, 8
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x3102 ( Outputs), entry 0x03 (Data Out 1)) | UINT32 | RO | 0x3102:03, 8
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x3102 ( Outputs), entry 0x04 (Data Out 2)) | UINT32 | RO | 0x3102:04, 8
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x3102 ( Outputs), entry 0x05 (Data Out 3)) | UINT32 | RO | 0x3102:05, 8
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x3102 ( Outputs), entry 0x06 (Data Out 4)) | UINT32 | RO | 0x3102:06, 8
Index 1A02 TxPDO-Map Inputs
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1A02:0 | TxPDO-Map Inputs | PDO Mapping TxPDO 3 | UINT8 | RO | 0x17 (23dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x3103 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x3103:01, 16
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x02 (Data Out 0)) | UINT32 | RO | 0x3103:02, 8
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x03 (Data Out 1)) | UINT32 | RO | 0x3103:03, 8
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x04 (Data Out 2)) | UINT32 | RO | 0x3103:04, 8
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x05 (Data Out 3)) | UINT32 | RO | 0x3103:05, 8
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x06 (Data Out 4)) | UINT32 | RO | 0x3103:06, 8
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x07 (Data Out 5)) | UINT32 | RO | 0x3103:07, 8
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x08 (Data Out 6)) | UINT32 | RO | 0x3103:08, 8
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x09 (Data Out 7)) | UINT32 | RO | 0x3103:09, 8
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x0 (Data Out 8)) | UINT32 | RO | 0x3103:0A, 8
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x0 (Data Out 9)) | UINT32 | RO | 0x3103:0B, 8
1A02:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x0 (Data Out 10)) | UINT32 | RO | 0x3103:0C, 8
1A02:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x0 (Data Out 11)) | UINT32 | RO | 0x3103:0D, 8
1A02:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x0 (Data Out 12)) | UINT32 | RO | 0x3103:0E, 8
1A02:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x0 (Data Out 13)) | UINT32 | RO | 0x3103:0F, 8
1A02:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x10 (Data Out 14)) | UINT32 | RO | 0x3103:10, 8
1A02:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x11 (Data Out 15)) | UINT32 | RO | 0x3103:11, 8
1A02:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x12 (Data Out 16)) | UINT32 | RO | 0x3103:12, 8
1A02:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x13 (Data Out 17)) | UINT32 | RO | 0x3103:13, 8
1A02:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x14 (Data Out 18)) | UINT32 | RO | 0x3103:14, 8
1A02:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x15 (Data Out 19)) | UINT32 | RO | 0x3103:15, 8
1A02:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x16 (Data Out 20)) | UINT32 | RO | 0x3103:16, 8
1A02:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x3103 ( Outputs), entry 0x17 (Data Out 21)) | UINT32 | RO | 0x3103:17, 8
Index 1A04 COM TxPDO-Map Inputs [从硬件 03]
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1A04:0 | COM TxPDO-Map Inputs | PDO Mapping TxPDO 5 | UINT8 | RO | 0x1F (31dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (COM Outputs), entry 0x01 (传送请求)) | UINT32 | RO | 0x6000:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (COM Outputs), entry 0x02 (接受接收)) | UINT32 | RO | 0x6000:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (COM Outputs), entry 0x03 (初始化请求)) | UINT32 | RO | 0x6000:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (COM Inputs), entry 0x04 (缓冲满)) | UINT32 | RO | 0x6000:04, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (COM Inputs), entry 0x05 (P奇偶校验错误)) | UINT32 | RO | 0x6000:05, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (COM Inputs), entry 0x06 (结构错误)) | UINT32 | RO | 0x6000:06, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (COM Inputs), entry 0x07 (超限错误)) | UINT32 | RO | 0x6000:07, 1
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (COM Outputs), entry 0x09 (输出长度)) | UINT32 | RO | 0x6000:09, 8
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x11 (Data Out 0)) | UINT32 | RO | 0x6000:11, 8
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x12 (Data Out 1)) | UINT32 | RO | 0x6000:12, 8
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x13 (Data Out 2)) | UINT32 | RO | 0x6000:13, 8
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x14 (Data Out 3)) | UINT32 | RO | 0x6000:14, 8
1A04:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x15 (Data Out 4)) | UINT32 | RO | 0x6000:15, 8
1A04:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x16 (Data Out 5)) | UINT32 | RO | 0x6000:16, 8
1A04:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x17 (Data Out 6)) | UINT32 | RO | 0x6000:17, 8
1A04:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x18 (Data Out 7)) | UINT32 | RO | 0x6000:18, 8
1A04:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x19 (Data Out 8)) | UINT32 | RO | 0x6000:19, 8
1A04:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x1 (Data Out 9)) | UINT32 | RO | 0x6000:1A, 8
1A04:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x1 (Data Out 10)) | UINT32 | RO | 0x6000:1B, 8
1A04:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x1 (Data Out 11)) | UINT32 | RO | 0x6000:1C, 8
1A04:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x1 (Data Out 12)) | UINT32 | RO | 0x6000:1D, 8
1A04:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x1 (Data Out 13)) | UINT32 | RO | 0x6000:1E, 8
1A04:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x1 (Data Out 14)) | UINT32 | RO | 0x6000:1F, 8
1A04:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x20 (Data Out 15)) | UINT32 | RO | 0x6000:20, 8
1A04:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x21 (Data Out 16)) | UINT32 | RO | 0x6000:21, 8
1A04:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x22 (Data Out 17)) | UINT32 | RO | 0x6000:22, 8
1A04:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x23 (Data Out 18)) | UINT32 | RO | 0x6000:23, 8
1A04:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x24 (Data Out 19)) | UINT32 | RO | 0x6000:24, 8
1A04:1E | SubIndex 030 | 30. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x25 (Data Out 20)) | UINT32 | RO | 0x6000:25, 8
1A04:1F | SubIndex 031 | 31. PDO Mapping entry (object 0x6000 ( Outputs), entry 0x26 (Data Out 21)) | UINT32 | RO | 0x6000:26, 8
Index 1C00 同步管理器类型
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1C00:0 | 同步管理器类型 | 同步管理器通道使用率 | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | 同步管理器类型通道1： 邮箱写录 | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | 同步管理器类型通道2： 邮箱读取 | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | 同步管理器类型通道3： 过程数据写入（输出） | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | 同步管理器类型通道4： 过程数据读取（输入） | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x04 (4dec)
1C12:01 | SubIndex 001 | 1. assigned RxPDO (包含相应的 RxPDO 映射对象的索引) | UINT16 | RO | 0x1600 (5632dec)
1C12:02 | SubIndex 002 | 2. assigned RxPDO (包含相应的 RxPDO 映射对象的索引) | UINT16 | RO | 0x1601 (5633dec)
Index 1C13 TxPDO assign
Index | 名称 | 含义 | 数据类型 | Flags | 默认
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x04 (4dec)
1C13:01 | SubIndex 001 | 1. assigned RxPDO (包含相应的 RxPDO 映射兑现过的索引) | UINT16 | RO | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. assigned RxPDO (包含相应的 RxPDO 映射兑现过的索引) | UINT16 | RO | 0x1A01 (6657dec)
Index 1C32 SM output parameter [从硬件 03]

Index

名称

含义

数据类型

Flags

默认

1C32:0

SM 输出参数

输出的同步参数

UINT8

RO

0x20 (32dec)

1C32:01

同步模式

现行同步模式：

  • 0: Free Run
  • 1: 与SM 2 Event同步
  • 2: DC-模式 - 与SYNC0 Event同步
  • 3: DC-模式 - 与SYNC1 Event同步

UINT16

RW

0x0000 (0dec)

1C32:02

周期时间

周期时间 (ns):

  • Free Run: 本地计时器的周期时间
  • 与SM 2 Event同步: 主站的周期时间
  • DC-模式: SYNC0/SYNC1周期时间

UINT32

RW

0x0003D090 (250000dec)

1C32:03

切换时间

SYNC0 Event与输出生效间的时间( ns, 仅在 DC-Mode下 )

UINT32

RO

0x00000000 (0dec)

1C32:04

支持同步模式

支持同步模式：

  • Bit 0 = 1: 支持Free Run
  • Bit 1 = 1: 支持与SM 2 Event同步
  • Bit 2-3 = 01: 支持DC模式
  • Bit 4-5 = 10: 输出与SYNC1 Event切换 （仅DC模式下）
  • Bit 14 = 1: 动态时间（可以通过写 1C32:08来测量）

UINT16

RO

0xC007 (49159dec)

1C32:05

最小周期时间

支持的最小周期时间 (ns)

UINT32

RO

0x00004E20 (20000dec)

1C32:06

计算及复制时间

SYNC0 和 SYNC1 Event 之间的最小时间（ns，仅在DC模式下）

UINT32

RO

0x00000000 (0dec)

1C32:08

指令
  • 0: 时间的测量将停止
  • 1: 时间的测量将开始

条目1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 将以最大的测量值被更新。

UINT16

RW

0x0000 (0dec)

1C32:09

延迟时间

SYNC1 Event与输出生效间的时间( ns, 仅在 DC-Mode下 )

UINT32

RO

0x00000000 (0dec)

1C32:0B

SM event 丢失计数器

在状态OPERATIONAL 中丢失的SM-Events个数（仅在DC模式下）

UINT16

RO

0x0000 (0dec)

1C32:0C

周期超出计数器

在状态OPERATIONAL中周期超出的个数。

UINT16

RO

0x0000 (0dec)

1C32:0D

切换至超短计数器

SYNC0 和 SYNC1 Event 之间的

UINT16

RO

0x0000 (0dec)

1C32:20

同步错误

TRUE: 最后一个周期中同步不正确（仅在DC模式下）

布尔

RO

0x00 (0dec)
Index 1C33 SM output parameter [从硬件 03]

Index

名称

含义

数据类型

Flags

默认

1C33:0

SM输入参数

输出的同步参数

UINT8

RO

0x20 (32dec)

1C33:01

同步模式

现行同步模式：

  • 0: Free Run
  • 1: 与SM 3 Event同步（输出可得）
  • 2: DC-模式 - 与SYNC0 Event同步
  • 3: DC-模式 - 与SYNC1 Event同步
  • 34: 与SM 2 Event同步（输出可得）

UINT16

RW

0x0000 (0dec)

1C33:02

周期时间

与1C32:02相同

UINT32

RW

0x0003D090 (250000dec)

1C33:03

切换时间

SYNC0 Event与输出生效间的时间( ns, 仅在 DC-Mode下 )

UINT32

RO

0x00000000 (0dec)

1C33:04

支持同步模式

支持同步模式：

  • Bit 0: 支持Free Run
  • Bit 1: 支持与SM 2 Event同步)
  • Bit 1: 与SM 3 Event同步（输出不可得）
  • Bit 2-3 = 01: 支持DC模式
  • Bit 4-5 = 01: Input Shift with local event (Outputs available)
  • Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available)
  • Bit 14 = 1: 动态时间（可以通过写 1C32:08 或 1C33:08被测量）。

UINT16

RO

0xC007 (49159dec)

1C33:05

最小周期时间

与1C32:05相同

UINT32

RO

0x00004E20 (20000dec)

1C33:06

计算及复制时间

Input Latch和主站输入有效之间的时间 (ns, 仅在 DC模式下)

UINT32

RO

0x00000000 (0dec)

1C33:08

指令

与1C32:08相同

UINT16

RW

0x0000 (0dec)

1C33:09

延迟时间

SYNC1 Event与输出生效间的时间( ns, 仅在 DC-Mode下 )

UINT32

RO

0x00000000 (0dec)

SM event 丢失计数器

与1C32:11相同

UINT16

RO

0x0000 (0dec)

周期超出计数器

与1C32:12相同

UINT16

RO

0x0000 (0dec)

切换至短计数器

与1C32:13相同

UINT16

RO

0x0000 (0dec)

1C33:20

同步错误

与1C32:32相同

布尔

RO

0x00 (0dec)
Index 3001 输出
Index | 名称 | 含义 | 数据类型 | Flags | 默认
3001:0 | 输出 | Max. subindex | UINT8 | RO | 0x04 (4dec)
3001:01 | Ctrl | Control byte | UINT8 | RO | 0x00 (0dec)
3001:02 | Data Out 0 | 输出 byte 0 | UINT8 | RO | 0x00 (0dec)
3001:03 | Data Out 1 | 输出byte 1 | UINT8 | RO | 0x00 (0dec)
3001:04 | Data Out 2 | 输出byte 2 | UINT8 | RO | 0x00 (0dec)
Index 3002 输出
Index | 名称 | 含义 | 数据类型 | Flags | 默认
3002:0 | 输出 | Max. subindex | UINT8 | RO | 0x06 (6dec)
3002:01 | Ctrl | Control byte | UINT8 | RO | 0x00 (0dec)
3002:02 | Data Out 0 | 输出 byte 0 | UINT8 | RO | 0x00 (0dec)
3002:03 | Data Out 1 | 输出byte 1 | UINT8 | RO | 0x00 (0dec)
3002:04 | Data Out 2 | 输出byte 2 | UINT8 | RO | 0x00 (0dec)
3002:05 | Data Out 3 | 输出byte 3 | UINT8 | RO | 0x00 (0dec)
3002:06 | Data Out 4 | 输出byte 4 | UINT8 | RO | 0x00 (0dec)
Index 3003 输出
Index | 名称 | 含义 | 数据类型 | Flags | 默认
3003:0 | 输出 | Max. subindex | UINT8 | RO | 0x17 (23dec)
3003:01 | Ctrl | Control byte | UINT16 | RO | 0x0000 (0dec)
3003:02 | Data Out 0 | 输出 byte 0 | UINT8 | RO | 0x00 (0dec)
3003:03 | Data Out 1 | 输出byte 1 | UINT8 | RO | 0x00 (0dec)
3003:04 | Data Out 2 | 输出byte 2 | UINT8 | RO | 0x00 (0dec)
3003:05 | Data Out 3 | 输出byte 3 | UINT8 | RO | 0x00 (0dec)
3003:06 | Data Out 4 | 输出byte 4 | UINT8 | RO | 0x00 (0dec)
3003:07 | Data Out 5 | 输出byte 5 | UINT8 | RO | 0x00 (0dec)
3003:08 | Data Out 6 | 输出byte 6 | UINT8 | RO | 0x00 (0dec)
3003:09 | Data Out 7 | 输出byte 7 | UINT8 | RO | 0x00 (0dec)
3003:0A | Data Out 8 | 输出byte 8 | UINT8 | RO | 0x00 (0dec)
3003:0B | Data Out 9 | 输出byte 9 | UINT8 | RO | 0x00 (0dec)
3003:0C | Data Out 10 | 输出byte 10 | UINT8 | RO | 0x00 (0dec)
3003:0D | Data Out 11 | 输出byte 11 | UINT8 | RO | 0x00 (0dec)
3003:0E | Data Out 12 | 输出byte 12 | UINT8 | RO | 0x00 (0dec)
3003:0F | Data Out 13 | 输出byte 13 | UINT8 | RO | 0x00 (0dec)
3003:10 | Data Out 14 | 输出byte 14 | UINT8 | RO | 0x00 (0dec)
3003:11 | Data Out 15 | 输出byte 15 | UINT8 | RO | 0x00 (0dec)
3003:12 | Data Out 16 | 输出byte 16 | UINT8 | RO | 0x00 (0dec)
3003:13 | Data Out 17 | 输出byte 17 | UINT8 | RO | 0x00 (0dec)
3003:14 | Data Out 18 | 输出byte 18 | UINT8 | RO | 0x00 (0dec)
3003:15 | Data Out 19 | 输出byte 19 | UINT8 | RO | 0x00 (0dec)
3003:16 | Data Out 20 | 输出byte 20 | UINT8 | RO | 0x00 (0dec)
3003:17 | Data Out 21 | 输出byte 21 | UINT8 | RO | 0x00 (0dec)
Index 3101 输入
Index | 名称 | 含义 | 数据类型 | Flags | 默认
3101:0 | 输入 | Max. subindex | UINT8 | RO | 0x04 (4dec)
3101:01 | 状态 | Status byte | UINT8 | RO | 0x00 (0dec)
3101:02 | Data In 0 | 输入 byte 0 | UINT8 | RO | 0x00 (0dec)
3101:03 | Data In 1 | 输入 byte 1 | UINT8 | RO | 0x00 (0dec)
3101:04 | Data In 2 | 输入 byte 2 | UINT8 | RO | 0x00 (0dec)
Index 3102 输入
Index | 名称 | 含义 | 数据类型 | Flags | 默认
3102:0 | 输入 | Max. subindex | UINT8 | RO | 0x06 (6dec)
3102:01 | 状态 | 状态 byte | UINT8 | RO | 0x00 (0dec)
3102:02 | Data In 0 | 输入 byte 0 | UINT8 | RO | 0x00 (0dec)
3102:03 | Data In 1 | 输入 byte 1 | UINT8 | RO | 0x00 (0dec)
3102:04 | Data In 2 | 输入 byte 2 | UINT8 | RO | 0x00 (0dec)
3102:05 | Data In 3 | 输入 byte 3 | UINT8 | RO | 0x00 (0dec)
3102:06 | Data In 4 | 输入 byte 4 | UINT8 | RO | 0x00 (0dec)
Index 3103 输入
Index | 名称 | 含义 | 数据类型 | Flags | 默认
3103:0 | 输入 | Max. subindex | UINT8 | RO | 0x17 (23dec)
3103:01 | 状态 | Status-Wort | UINT16 | RO | 0x0000 (0dec)
3103:02 | Data In 0 | 输入 byte 0 | UINT8 | RO | 0x00 (0dec)
3103:03 | Data In 1 | 输入 byte 1 | UINT8 | RO | 0x00 (0dec)
3103:04 | Data In 2 | 输入 byte 2 | UINT8 | RO | 0x00 (0dec)
3103:05 | Data In 3 | 输入 byte 3 | UINT8 | RO | 0x00 (0dec)
3103:06 | Data In 4 | 输入 byte 4 | UINT8 | RO | 0x00 (0dec)
3103:07 | Data In 5 | 输入 byte 5 | UINT8 | RO | 0x00 (0dec)
3103:08 | Data In 6 | 输入 byte 6 | UINT8 | RO | 0x00 (0dec)
3103:09 | Data In 7 | 输入 byte 7 | UINT8 | RO | 0x00 (0dec)
3103:0A | Data In 8 | 输入 byte 8 | UINT8 | RO | 0x00 (0dec)
3103:0B | Data In 9 | 输入 byte 9 | UINT8 | RO | 0x00 (0dec)
3103:0C | Data In 10 | 输入 byte 10 | UINT8 | RO | 0x00 (0dec)
3103:0D | Data In 11 | 输入 byte 11 | UINT8 | RO | 0x00 (0dec)
3103:0E | Data In 12 | 输入 byte 12 | UINT8 | RO | 0x00 (0dec)
3103:0F | Data In 13 | 输入 byte 13 | UINT8 | RO | 0x00 (0dec)
3103:10 | Data In 14 | 输入 byte 14 | UINT8 | RO | 0x00 (0dec)
3103:11 | Data In 15 | 输入 byte 15 | UINT8 | RO | 0x00 (0dec)
3103:12 | Data In 16 | 输入 byte 16 | UINT8 | RO | 0x00 (0dec)
3103:13 | Data In 17 | 输入 byte 17 | UINT8 | RO | 0x00 (0dec)
3103:14 | Data In 18 | 输入 byte 18 | UINT8 | RO | 0x00 (0dec)
3103:15 | Data In 19 | 输入 byte 19 | UINT8 | RO | 0x00 (0dec)
3103:16 | Data In 20 | 输入 byte 20 | UINT8 | RO | 0x00 (0dec)
3103:17 | Data In 21 | 输入 byte 21 | UINT8 | RO | 0x00 (0dec)
Index 4070 发送缓冲区中的数据字节
Index | 名称 | 含义 | 数据类型 | Flags | 默认
4070:0 | 发送缓冲区中的数据字节 | 发送FIFO中的数据字节的个数 | UINT16 | RO | 0x0000 (0dec)
Index 4071 接收缓冲区内的数据字节
Index | 名称 | 含义 | 数据类型 | Flags | 默认
4071:0 | 接收缓冲区内的数据字节 | 接收FIFO中的数据字节的个数 | UINT16 | RO | 0x0000 (0dec)
Index 4072 诊断
Index | 名称 | 含义 | 数据类型 | Flags | 默认
4072:0 | 诊断 | Max. subindex | UINT8 | RO | 0x05 (5dec)
4072:01 | 缓冲区溢出 | 出现缓冲区溢出. | 布尔 | RO | 0x00 (0dec)
4072:02 | 奇偶校验错误 | 出现一个奇偶校验错误. 受影响的数据项目没有被装进模块的接收FIFO并且被丢失了。 | 布尔 | RO | 0x00 (0dec)
4072:03 | 结构错误 | 出现一个结构错误. 受影响的数据项目没有被装进模块的接收FIFO并且被丢失了。 | 布尔 | RO | 0x00 (0dec)
4072:04 | 超限错误 | 出现一个超限错误. 受影响的数据项目没有被装进模块的接收FIFO并且被丢失了。 | 布尔 | RO | 0x00 (0dec)
4072:05 | 缓冲区已满 | 接收FIFO已满。 所有新的输入数据都将丢失。 | 布尔 | RO | 0x00 (0dec)

Profile specific objects (0x6000-0xFFFF) [从硬件 03]

profile specific objects对所有支持profile 5001的EtherCAT从站有相同意义。

Index 6000 COM 输入
Index | 名称 | 含义 |  | 数据类型 | Flags | 默认
6000:0 | COM 输入 | Max. subindex |  | UINT8 | RO | 0x26 (38dec)
6000:01 | 传输接收 | 端子模块通过改变这一位的状态来确认数据的接收。 新的数据可以从控制器传输到模块。 |  | 布尔 | RO | 0x00 (0dec)
6000:02 | 接收请求 | 通过改变此位的状态，端子模块通知控制器，DataIn字节包含了字节的个数并通过 "Input length"位表示. 控制器需要在控制字节中通过改变"ReceiveAccepted"位的状态来确认收到数据". 新的数据可以从模块传输到控制器。 |  | 布尔 | RO | 0x00 (0dec)
6000:03 | 初始化接受 | 0 | 模块已准备好再次进行串行数据交换。 | 布尔 | RO | 0x00 (0dec)
 |  | 1 | 模块初始化完成
6000:04 | 缓冲区已满 | 接收FIFO已满。 所有新的输入数据都将丢失。 |  | 布尔 | RO | 0x00 (0dec)
6000:05 | 奇偶校验错误 | 出现一个奇偶校验错误 |  | 布尔 | RO | 0x00 (0dec)
6000:06 | 结构错误 | 出现一个结构错误 |  | 布尔 | RO | 0x00 (0dec)
6000:07 | 超限错误 | 出现一个超限错误 |  | 布尔 | RO | 0x00 (0dec)
6000:09 | 输入长度 | 从端子模块到控制器的可用的输入字节的个数。 |  | BIT8 | RO | 0x00 (0dec)
6000:11 | Data In 0 | 输入nbsp] byte 0 |  | UINT8 | RO | 0x00 (0dec)
... | ... | .... |  | ... | ... | ...
6000:26 | Data In 21 | 输入 byte 21 |  | UINT8 | RO | 0x00 (0dec)
Index 7000 COM 输出
Index | 名称 | 含义 |  | 数据类型 | Flags | 默认
7000:0 | COM 输出 | Max. subindex |  | UINT8 | RO | 0x26 (38dec)
7000:01 | 传送请求 | 通过改变此位的状态，控制器通过 "Output length" 位来通知模块DataOut bytes包含了的字节数. 模块通过改变 "TransmitAccepted"位的状态开确认状态字节中数据的接收 新的数据可以从控制器传输到模块。 |  | 布尔 | RO | 0x00 (0dec)
7000:02 | 接受接收 | 控制器通过改变这一位的状态来确认数据的接收。 新的数据可以从模块传输到控制器。 |  | 布尔 | RO | 0x00 (0dec)
7000:03 | 初始化请求 | 0 | 控制器再次请求模块准备串行数据交换。 | 布尔 | RO | 0x00 (0dec)
 |  | 1 | 控制器请求模块的初始化。 发送和接收功能被锁定。FIFO 指针被重置且接口被以按照相关的 设置对象初始化。 模块通过"Init accepted"位来确认初始化完成。
7000:04 | 连续发送 | 持续发送来自FIFO的数据。 控制器填充发送缓冲区（最大到128字节）。 缓冲内容根据SC 位的上升沿发送。 模块通过设置 "Init accepted"位来确认数据传输至控制器. "Init accepted"被 "SendContinuous"取消。 |  | 布尔 | RO | 0x00 (0dec)
7000:09 | 输出长度 | 从控制器到端子模块的可用的输出字节的个数 |  | BIT8 | RO | 0x00 (0dec)
7000:11 | Data Out 0 | 输出 byte 0 |  | UINT8 | RO | 0x00 (0dec)
... | ... | .... |  | ... | ... | ...
7000:26 | Data Out 21 | 输出byte 21 |  | UINT8 | RO | 0x00 (0dec)
Index A000 COM Diag data
Index | 名称 | 含义 | 数据类型 | Flags | 默认
A000:0 | COM Diag data | Max. subindex | UINT8 | RO | 0x12 (18dec)
A000:01 | 缓冲区溢出 | 出现缓冲区溢出 | 布尔 | RO | 0x00 (0dec)
A000:02 | 奇偶校验错误 | 出现一个奇偶校验错误 | 布尔 | RO | 0x00 (0dec)
A000:03 | 结构错误 | 出现一个结构错误 | 布尔 | RO | 0x00 (0dec)
A000:04 | 超限错误 | 出现一个超限错误 | 布尔 | RO | 0x00 (0dec)
A000:05 | 缓冲区已满 | 接收FIFO已满。 所有新的输入数据都将丢失。 | 布尔 | RO | 0x00 (0dec)
A000:11 | 发送缓冲区中的数据字节 | 发送FIFO中的数据字节的个数 | UINT16 | RO | 0x0000 (0dec)
A000:12 | 接收缓冲区内的数据字节 | 接收FIFO中的数据字节的个数 | UINT16 | RO | 0x0000 (0dec)
Index F000 模块化设备资料
Index | 名称 | 含义 | 数据类型 | Flags | 默认
F000:0 | 模块化设备资料 | 模块化设备资料的一般信息 | UINT8 | RO | 0x02 (2dec)
F000:01 | 模块索引间隔 | 两通道间对象的索引间隔 | UINT16 | RO | 0x0010 (16dec)
F000:02 | 最大通道数量 | 通道数量 | UINT16 | RO | 0x0004 (4dec)
Index F008 Code word
Index | 名称 | 含义 | 数据类型 | Flags | 默认
F008:0 | 保护码 | 保留 | UINT32 | RW | 0x00000000 (0dec)
Index F010 模块列表
Index | 名称 | 含义 | 数据类型 | Flags | 默认
F010:0 | 模块列表 | Max. subindex | UINT8 | RW | 0x02 (2dec)
F010:01 | SubIndex 001 | - | UINT32 | RW | 0x00000258 (600dec)
F010:02 | SubIndex 002 | - | UINT32 | RW | 0x00000258 (600dec)


EL6001, EL6021 - 控制字和状态字

BECKHOFF EL6001, EL6021: 组态

控制字和状态字

控制字

控制字（CW）位于输出过程映像中，由控制器发送至端子模块。

位 | CW.15 | CW.14 | CW.13 | CW.12 | CW.11 | CW.10 | CW.9 | CW.8 | CW.7 | CW.6 | CW.5 | CW.4 | CW.3 | CW.2 | CW.1 | CW.0
名称 | OL7 | OL6 | OL5 | OL4 | OL3 | OL2 | OL1 | OL0 | - | OL2* | OL1* | OL0* | SC | IR | RA | TR

从CW.15 到 CW.8位只有使用大型过程映像时才显示。
使用小或中型的过程映像时，只有CW.7 到 CW.0位作为控制字节显示。 OL2* ... OL0*显示了从控制器到端子模块的可用的输出字节的个数。 .

说明
位 | Name | 描述
CW.15 ... CW8 | OL7 ... OL0 （输出长度） | 1dec... 22dec | 如果使用大型过程映像： 从控制器到端子模块的可用的输出字节的个数（）。
 |  | - | 如果使用小/中型过程映像： 不显示
CW.7 | - | 0bin | 保留
CW.6 ... CW.4 | OL2* ... OL0* (输出长度*) | 0 | 如果使用大型过程映像： reserved
 |  | 1 ... 6 | 如果使用中型过程映像： 从控制器到端子模块的可用的输出字节的个数。
 |  | 1 ... 4 | 如果使用小型过程映像： 从控制器到端子模块的可用的输出字节的个数
CW.3 | SC (SendContinious) | rise | 持续发送来自FIFO的数据。 控制器填充发送缓冲区（最大到128字节）。 缓冲内容根据SC位的上升沿发送。 模块通过设置SW.2位来确认数据传输至控制器。 CW.3取消SW.2。
CW.2 | IR (InitRequest) | 1bin | 控制器请求模块的初始化。 发送和接收被锁定，FIFO指针被重置并且接口以相关对象的值进行初始化（波特比4073，数据帧4074，特征位4075）。 模块通过SW.2 (IA)位来确认初始化完成。
 |  | 0bin | 控制器再次请求模块准备串行数据交换。
CW.1 | RA (ReceiveAccepted) | toggle | 控制器通过改变这一位的状态来确认数据的接收。 新的数据可以从模块传输到控制器。
CW.0 | TR (TransmitRequest) | toggle | 通过改变此位的状态，控制器通知模块 模块通过改变 SW.0 (TA)位的状态来确认接收到数据。 新的数据可以从控制器传输到模块。

状态字

状态字（SW）放置在输入过程映像中，并且从模块传输到控制器。

位 | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8 | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
名称（小型和中型 过程映像) | - | - | - | - | - | - | - | - | - | IL2* | IL1* | IL0* | BUF_F | IA | RR | TA
名称（大型 过程映像) | IL7 | IL6 | IL5 | IL4 | IL3 | IL2 | IL1 | IL0 | - | OVERRUN ERR | FRAMING ERR | PARITY ERR | BUF_F | IA | RR | TA

SW.15 到 SW.8位只有在使用大型过程映像时才显示。
如果使用的是小型或中型过程映像，只有 SW.7 到 SW.0位作为状态字节显示。 用于从模块到控制器进行传输的可用输入字节的数量由 IL2* ... 等位显示。 IL0*.

说明
位 | Name | 描述
SW.15 ... SW8 | IL7 ... IL0 (InLenght*) | 1dec... 22dec | 如果使用大型过程映像： 从端子模块到控制器的可用的输出字节的个数。
 |  | - | 如果使用小/中型过程映像： 不显示
SW.7 | - | 0bin | reserved
SW.6 | IL2* (InLenght*) OVERRUN ERR | 0 ... 1 | 如果使用大型过程映像： 保留
 |  | 1 ... 6 | 如果使用中型过程映像： 从端子模块到控制器的可用的输入字节的个数。
 |  | 1 ... 4 | 如果使用小型过程映像： 从端子模块到控制器的可用的输入字节的个数。
SW.5 | IL1* (InLenght*) FRAMING ERR | 0 ... 1 | 如果使用大型过程映像： 保留
 |  | 1 ... 6 | 如果使用中型过程映像： 从端子模块到控制器的可用的输入字节的个数。
 |  | 1 ... 4 | 如果使用小型过程映像： 从端子模块到控制器的可用的输入字节的个数。
SW.4 | IL0* (InLenght*) PARITY ERR | 0 ... 1 | 如果使用大型过程映像： 保留
 |  | 1 ... 6 | 如果使用中型过程映像： 从端子模块到控制器的可用的输入字节的个数。
 |  | 1 ... 4 | 如果使用小型过程映像： 从端子模块到控制器的可用的输入字节的个数。
SW.3 | BUF_F | 1bin | 接收FIFO已满。 所有新的输入数据都将丢失！
SW.2 | IA (InitAccepted bit) | 1bin | 模块初始化完成。
 |  | 0bin | 模块已准备好再次进行串行数据交换。
SW.1 | RR (ReceiveRequest) | toggle | 通过改变此位的状态，端子模块通知控制器，DataIn字节包含了字节的个数并通过IL位表示。 控制器需要在控制字节中通过改变CW.1 (RA)位的状态来确认收到数据。 新的数据可以从模块传输到控制器。
SW.0 | TA (TransmitAccepted) | toggle | 端子模块通过改变这一位的状态来确认数据的接收。 新的数据可以从控制器传输到模块。

数据传输举例

例子使用大型过程映像。

数据从控制器传输到模块

控制字 |  | 状态字 |  | 说明
CW.15 ... CW.8 | CW.7 ... CW.1 | SW.15 ... SW.8 | SW.7 ... SW.1
0000 0000bin | 0000 0000bin | xxxx xxxxbin | 0000 x0x0bin | 启动数据传输
0000 00 10bin | 0000 000 1bin | xxxx xxxxbin | 0000 x0x0bin | 控制器请求通过模块进行2byte的传输
0000 0010bin | 0000 0001bin | xxxx xxxxbin | 0000 x0x1bin | 指令实行： 模块将2字节读取到传输FIFO中
0001 0000bin | 0000 000 0bin | xxxx xxxxbin | 0000 x0x1bin | 控制器请求通过模块的16 byte传输
0001 0000bin | 0000 0000bin | xxxx xxxxbin | 0000 x0x0bin | 指令实行： 模块将16字节读取到传输FIFO中

数据从模块传输到控制器

控制字 |  | 状态字 |  | 意见
CW.15 ... CW.8 | CW.7 ... CW.1 | SW.15 ... SW.8 | SW.7 ... SW.1
xxxx xxxxbin | 0000 000xbin | 0000 0000bin | 0000 000xbin | 数据传输的状态
xxxx xxxxbin | 0000 000xbin | 0000 00 11bin | 0000 001xbin | 模块请求来自控制器的3 byte传输
xxxx xxxxbin | 0000 001xbin | 0000 0011bin | 0000 001xbin | 确认： 控制器接收到来自接收FIFO的3 byte字节
xxxx xxxxbin | 0000 001xbin | 0001 0110bin | 0000 000xbin | 模块请求来自控制器的22 byte传输
xxxx xxxxbin | 0000 000xbin | 0001 0110bin | 0000 000xbin | 确认： 控制器接收到来自接收FIFO的22 byte字节

初始化

控制字 |  | 状态字 |  | 意见
CW.15 ... CW.8 | CW.7 ... CW.1 | SW.15 ... SW.8 | SW.7 ... SW.1
xxxx xxxxbin | xxxx xxxxbin | xxxx xxxxbin | xxxx xxxxbin | 数据传输的状态
0000 0000bin | 0000 0100bin | 0000 0000bin | 0000 0000bin | 控制器请求模块初始化
0000 0000bin | 0000 0100bin | 0000 0000bin | 0000 0100bin | 指令实行： 模块初始化完成
0000 0000bin | 0000 0000bin | 0000 0000bin | 0000 0100bin | 控制器再次请求模块准备串行数据交换
0000 0000bin | 0000 0000bin | 0000 0000bin | 0000 0000bin | 指令实行： 模块已准备好再次进行串行数据交换


EL600x, EL602x - 对象描述及参数化

BECKHOFF EL600x, EL602x: 配置

对象描述和参数化

说明 		EtherCAT XML 设备描述
本描述对应 EtherCAT XML设备描述中的 CoE对象的显示。 强烈建议从倍福网站(http://www.beckhoff.com/english/default.htm?download/elconfg.htm)下载最新版本的相应XML文件，并遵循安装指引。

说明 		参数化
模块的参数化将被 CoE tab （双击相关对象）执行，见以下。

介绍

CoE概述包含了不同预期的应用的对象：

  • 调试过程中参数化需要的对象
  • 表示内部设置的对象 （可被修改）
  • Profile 特殊变量，用于表示输入输出的状态（从硬件 03..

下面的章节首先描述了普通操作所需的对象，其后是其他变量的详细概述。

调试对象

Index 1011 恢复默认参数
Index | Name | 含义 | 数据类型 | Flags | 默认
1011:0 | 恢复默认参数 | 恢复EtherCAT从站的默认设置 | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | 如果对象设置为"0x64616F6C" ("设定值对话框") 所有模块特殊变量都将设定成他们的delivery state。 | UINT32 | RW | 0x00000000 (0dec)
Index 80n0 COM Settings Ch. 1 (n = 0), Ch. N = 1)
Index | Name | 含义 | 数据类型 | Flags | 默认
80n0:0 | COM 设置 Ch.1 + 2 | Max. subindex | UINT8 | RO | 0x1A (26dec)
80n0:01** | 使能 RTS/CTS | FALSE | 不允许RTS/CTS | 布尔 | RW | 0x01 (1dec)
TRUE | RTS/CTS 允许
80n0:02 | 使能 XON/XOFF 支持 tx 数据 | FALSE | XON/XOFF不支持发送数据 | 布尔 | RW | 0x00 (0dec)
TRUE | XON/XOFF支持发送数据
80n0:03 | 使能 XON/XOFF支持 rx 数据 | FALSE | XON/XOFF不支持接收数据 | 布尔 | RW | 0x00 (0dec)
TRUE | XON/XOFF支持接收数据
80n0:04 | 使能连续发送 FIFO 数据 | FALSE | 不持续发送来自FIFO的数据 | 布尔 | RW | 0x00 (0dec)
TRUE 持续发送来自FIFO的数据:
控制器填充发送缓冲区（最大到128字节）。 缓冲内容根据 "SendContinious"位的上升沿发送. 模块通过设置 "InitAccepted" 位来确认数据传输至控制器" . "SendContinious"重置"InitAccepted"
80n0:05 | 使能优化传输速率 | FALSE | 优化传输速率关闭 | 布尔 | RW | 0x01 (1dec)
TRUE 优化传输速率打开：
输入缓冲区的内容自动传输到过程印象中，如果
  • 没有接受到其它字节 在数据接收后大约16位的时间里(i.e.接收两byte所需要的时间)
  • 输入缓冲区已满

80n0:06*** | 支持半双工 | FALSE | 全双工模式 | 布尔 | RW | 0x00 (0dec)
TRUE | 半双工模式
80n0:07*** | 使能点到点连接（RS422) | FALSE | 不允许点到点连接 | 布尔 | RW | 0x00 (0dec)
TRUE | 允许点到点连接
80n0:11 | 波特率 | 1 | 300 baud | BIT4 | RW | 0x06 (6dec)
2 | 600 baud
3 | 1200 baud
4 | 2400 baud
5 | 4800 baud
6 | 9600 baud
7 | 19200 baud
8 | 38400 baud
9 | 57600 baud
10 | 115200 baud
80n0:15 | 数据结构 | 1 | 7个数据位，偶数奇偶校验，1个停止位 | BIT4 | RW | 0x03 (3dec)
2 | 7个数据位，奇数奇偶校验，1个停止位
3 | 8个数据位，无奇偶校验，1个停止位
4 | 8个数据位，偶数奇偶校验，1个停止位
5 | 8个数据位，奇数奇偶校验，1个停止位
9 | 7个数据位，偶数奇偶校验，2个停止位
10 | 7个数据位，奇数奇偶校验，2个停止位
11 | 8个数据位，无奇偶校验，2个停止位
12 | 8个数据位，偶数奇偶校验，2个停止位
13 | 8个数据位，奇数奇偶校验，2个停止位
1A | Rx 缓冲区已满通告 | 该值决定了接收FIFO中的数据的个数，由状态字节中的 SW.3 (BUF_F) 位设定。 | UINT16 | RW | 0x0360 (864dec)

*) 对应的模块类型
**) only EL600x
***) only EL602x

常规操作的对象

在一般功能范围内 EL600, EL602没有这些对象

完整概述

标准对象 (0x1000-0x1FFF)

所有EtherCAT从站的标准对象具有相同意义。

Index 1000 设备类型
Index | Name | 含义 | 数据类型 | Flags | 默认
1000:0 | 设备类型 | EtherCAT从站的设备类型 Lo-Word包含了支持的CoE资料（5001） Hi-Word包含了与模块化设备资料对应的模块资料。 | UINT32 | RO | 0x02581389 (39326601dec)
Index 1008 设备名称
Index | Name | 含义 | 数据类型 | Flags | 默认
1008:0 | 设备名称 | EtherCAT 从站的设备名称 | STRING | RO |
Index 1009 硬件版本
Index | Name | 含义 | 数据类型 | Flags | 默认
1009:0 | 硬件版本 | EtherCAT从站的硬件版本 | STRING | RO | 00
Index 100A 软件版本
Index | Name | 含义 | 数据类型 | Flags | 默认
100A:0 | 软件版本 | EtherCAT从站的固件版本 | STRING | RO | 01
Index 1018 认证
Index | Name | 含义 | 数据类型 | Flags | 默认
1018:0 | 认证 | 包含了认证EtherCAT 从站的信息 | UINT8 | RO | 0x04 (4dec)
1018:01 | 供应商ID | EtherCAT从站的供应商ID | UINT32 | RO | 0x00000002 (2dec)
1018:02 | 产品代码 | EtherCAT从站的产品代码 | UINT32 | RO | EL6002: 0x17723052 (393359442dec) EL6022: 0x17863052 (394670162dec)
1018:03 | 子版本 | EtherCAT从站的子版本号，Lo-Word (Bit 0-15)表示特殊功能端子模块号码； Hi-Word (Bit 16-31)表示设备描述。 | UINT32 | RO | 0x00100000 (1048576dec)
1018:04 | 序列号 | EtherCAT从站的序列号，Lo-Word的Lo-Byte (Bit 0-7)包含了生产年份，Lo-Word的Hi-Byte (Bit 8-15) 包含了生产的星期，Hi-Word (Bit 16-31) 为0。 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 后备参数处理
Index | Name | 含义 | 数据类型 | Flags | 默认
10F0:0 | 后备参数处理 | 包含后备入口的标准化上载与下载信息。 | UINT8 | RO | 0x01 (1dec)
10F0:01 | 校验和 | 所有后备入口的校验和 | UINT32 | RO | 0x00000000 (0dec)
Index 1600 COM RxPDO-Map Outputs Ch.1
Index | Name | 含义 | 数据类型 | Flags | 默认
1600:0 |  | PDO Mapping RxPDO 1 | UINT8 | RO | 0x1C (28dec)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (COM Outputs), entry 0.1x0 (传送请求)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (COM Outputs), entry 0.1x0 (接受接收)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (COM Outputs), entry 0.1x0 (初始化请求)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (COM Outputs), entry 0.1x0 (连续发送)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (COM Outputs), entry 0.1x0 (输出长度)) | UINT32 | RO | 0x7000:09, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 11)) | UINT32 | RO | 0x7000:11, 8
1600:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 12)) | UINT32 | RO | 0x7000:12, 8
1600:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 13)) | UINT32 | RO | 0x7000:13, 8
1600:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 14)) | UINT32 | RO | 0x7000:14, 8
1600:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 15)) | UINT32 | RO | 0x7000:15, 8
1600:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 16)) | UINT32 | RO | 0x7000:16, 8
1600:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 17)) | UINT32 | RO | 0x7000:17, 8
1600:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 18)) | UINT32 | RO | 0x7000:18, 8
1600:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 19)) | UINT32 | RO | 0x7000:19, 8
1600:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 1)) | UINT32 | RO | 0x7000:1A, 8
1600:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 1)) | UINT32 | RO | 0x7000:1B, 8
1600:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 1)) | UINT32 | RO | 0x7000:1C, 8
1600:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 1)) | UINT32 | RO | 0x7000:1D, 8
1600:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 1)) | UINT32 | RO | 0x7000:1E, 8
1600:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 1)) | UINT32 | RO | 0x7000:1F, 8
1600:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 20)) | UINT32 | RO | 0x7000:20, 8
1600:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 21)) | UINT32 | RO | 0x7000:21, 8
1600:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 22)) | UINT32 | RO | 0x7000:22, 8
1600:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 23)) | UINT32 | RO | 0x7000:23, 8
1600:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 24)) | UINT32 | RO | 0x7000:24, 8
1600:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 25)) | UINT32 | RO | 0x7000:25, 8
1600:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7000 ( Outputs), entry 0.1x0 (Data Out 26)) | UINT32 | RO | 0x7000:26, 8
Index 1601 COM RxPDO-Map Outputs Ch.2
Index | Name | 含义 | 数据类型 | Flags | 默认
1601:0 |  | PDO Mapping RxPDO 2 | UINT8 | RO | 0x1C (28dec)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (COM Outputs), entry 0.2x0 (传送请求)) | UINT32 | RO | 0x7010:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (COM Outputs), entry 0.2x0 (接受接收)) | UINT32 | RO | 0x7010:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (COM Outputs), entry 0.2x0 (初始化请求)) | UINT32 | RO | 0x7010:03, 1
1601:04 | SubIndex 004 | 4. | UINT32 | RO | 0x7010:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (COM Outputs), entry 0.2x0 (输出长度)) | UINT32 | RO | 0x7010:09, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 11)) | UINT32 | RO | 0x7010:11, 8
1601:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 12)) | UINT32 | RO | 0x7010:12, 8
1601:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 13)) | UINT32 | RO | 0x7010:13, 8
1601:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 14)) | UINT32 | RO | 0x7010:14, 8
1601:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 15)) | UINT32 | RO | 0x7010:15, 8
1601:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 16)) | UINT32 | RO | 0x7010:16, 8
1601:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 17)) | UINT32 | RO | 0x7010:17, 8
1601:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 18)) | UINT32 | RO | 0x7010:18, 8
1601:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 19)) | UINT32 | RO | 0x7010:19, 8
1601:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 1)) | UINT32 | RO |
1601:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 1)) | UINT32 | RO |
1601:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 1)) | UINT32 | RO |
1601:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 1)) | UINT32 | RO |
1601:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 1)) | UINT32 | RO |
1601:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 1)) | UINT32 | RO |
1601:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 20)) | UINT32 | RO | 0x7010:20, 8
1601:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 21)) | UINT32 | RO | 0x7010:21, 8
1601:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 22)) | UINT32 | RO | 0x7010:22, 8
1601:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 23)) | UINT32 | RO | 0x7010:23, 8
1601:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 24)) | UINT32 | RO | 0x7010:24, 8
1601:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 25)) | UINT32 | RO | 0x7010:25, 8
1601:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7010 ( Outputs), entry 0.2x0 (Data Out 26)) | UINT32 | RO | 0x7010:26, 8
Index 1A00 COM TxPDO-Map Inputs Ch.1
Index | Name | 含义 | 数据类型 | Flags | 默认
1A00:0 |  | PDO Mapping TxPDO 1 | UINT8 | RO | 0x1F (31dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (COM Outputs), entry 0.1x0 (传送请求)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (COM Outputs), entry 0.1x0 (接受接收)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (COM Outputs), entry 0.1x0 (初始化请求)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (COM Inputs), entry 0.1x0 (缓冲满)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (COM Inputs), entry 0.1x0 (P奇偶校验错误)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (COM Inputs), entry 0.1x0 (结构错误)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (COM Inputs), entry 0.1x0 (超限错误)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (COM Outputs), entry 0.1x0 (输出长度)) | UINT32 | RO | 0x6000:09, 8
 | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 11)) | UINT32 | RO | 0x6000:11, 8
 | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 12)) | UINT32 | RO | 0x6000:12, 8
 | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 13)) | UINT32 | RO | 0x6000:13, 8
 | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 14)) | UINT32 | RO | 0x6000:14, 8
 | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 15)) | UINT32 | RO | 0x6000:15, 8
 | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 16)) | UINT32 | RO | 0x6000:16, 8
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 17)) | UINT32 | RO | 0x6000:17, 8
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 18)) | UINT32 | RO | 0x6000:18, 8
1A00:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 19)) | UINT32 | RO | 0x6000:19, 8
1A00:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 1)) | UINT32 | RO | 0x6000:1A, 8
1A00:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 1)) | UINT32 | RO | 0x6000:1B, 8
1A00:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 1)) | UINT32 | RO | 0x6000:1C, 8
1A00:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 1)) | UINT32 | RO | 0x6000:1D, 8
1A00:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 1)) | UINT32 | RO | 0x6000:1E, 8
1A00:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 1)) | UINT32 | RO | 0x6000:1F, 8
1A00:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 20)) | UINT32 | RO | 0x6000:20, 8
 | SubIndex 026 | 26. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 21)) | UINT32 | RO | 0x6000:21, 8
 | SubIndex 027 | 27. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 22)) | UINT32 | RO | 0x6000:22, 8
 | SubIndex 028 | 28. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 23)) | UINT32 | RO | 0x6000:23, 8
 | SubIndex 029 | 29. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 24)) | UINT32 | RO | 0x6000:24, 8
 | SubIndex 030 | 30. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 25)) | UINT32 | RO | 0x6000:25, 8
 | SubIndex 031 | 31. PDO Mapping entry (object 0x6000 ( Outputs), entry 0.1x0 (Data Out 26)) | UINT32 | RO | 0x6000:26, 8
Index 1A01 COM TxPDO-Map Inputs Ch.2
Index | Name | 含义 | 数据类型 | Flags | 默认
1A01:0 |  | PDO Mapping TxPDO 2 | UINT8 | RO | 0x1F (31dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (COM Outputs), entry 0.2x0 (传送请求)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (COM Outputs), entry 0.2x0 (接受接收)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (COM Outputs), entry 0.2x0 (初始化请求)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (COM Inputs), entry 0.2x0 (缓冲满)) | UINT32 | RO | 0x6010:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (COM Inputs), entry 0.2x0 (P奇偶校验错误)) | UINT32 | RO | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (COM Inputs), entry 0.2x0 (结构错误)) | UINT32 | RO | 0x6010:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (COM Inputs), entry 0.2x0 (超限错误)) | UINT32 | RO | 0x6010:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (COM Outputs), entry 0.2x0 (输出长度)) | UINT32 | RO | 0x6010:09, 8
 | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 11)) | UINT32 | RO | 0x6010:11, 8
 | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 12)) | UINT32 | RO | 0x6010:12, 8
 | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 13)) | UINT32 | RO | 0x6010:13, 8
 | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 14)) | UINT32 | RO | 0x6010:14, 8
 | SubIndex 014 | 14. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 15)) | UINT32 | RO | 0x6010:15, 8
 | SubIndex 015 | 15. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 16)) | UINT32 | RO | 0x6010:16, 8
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 17)) | UINT32 | RO | 0x6010:17, 8
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 18)) | UINT32 | RO | 0x6010:18, 8
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 19)) | UINT32 | RO | 0x6010:19, 8
1A01:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 1)) | UINT32 | RO |
1A01:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 1)) | UINT32 | RO |
1A01:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 1)) | UINT32 | RO |
1A01:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 1)) | UINT32 | RO |
1A01:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 1)) | UINT32 | RO |
1A01:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 1)) | UINT32 | RO |
1A01:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 20)) | UINT32 | RO | 0x6010:20, 8
 | SubIndex 026 | 26. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 21)) | UINT32 | RO | 0x6010:21, 8
 | SubIndex 027 | 27. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 22)) | UINT32 | RO | 0x6010:22, 8
 | SubIndex 028 | 28. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 23)) | UINT32 | RO | 0x6010:23, 8
 | SubIndex 029 | 29. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 24)) | UINT32 | RO | 0x6010:24, 8
 | SubIndex 030 | 30. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 25)) | UINT32 | RO | 0x6010:25, 8
 | SubIndex 031 | 31. PDO Mapping entry (object 0x6010 ( Outputs), entry 0.2x0 (Data Out 26)) | UINT32 | RO | 0x6010:26, 8
Index 1C00 同步管理器类型
Index | Name | 含义 | 数据类型 | Flags | 默认
1C00:0 | 同步管理器类型 | 同步管理器通道使用率 | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | 同步管理器类型通道1： 邮箱写录 | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | 同步管理器类型通道2： 邮箱读取 | UINT8 | RO | 0x02 (2dec)
Index 1C12 RxPDO assign
Index | Name | 含义 | 数据类型 | Flags | 默认
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x04 (4dec)
1C12:01 | SubIndex 001 | 1. assigned RxPDO (包含相应的 RxPDO 映射对象的索引) | UINT16 | RO | 0x1600 (5632dec)
1C12:02 | SubIndex 002 | 2. assigned RxPDO (包含相应的 RxPDO 映射对象的索引) | UINT16 | RO | 0x1601 (5633dec)
Index 1C13 TxPDO assign
Index | Name | 含义 | 数据类型 | Flags | 默认
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x04 (4dec)
1C13:01 | SubIndex 001 | 1. assigned RxPDO (包含相应的 RxPDO 映射兑现过的索引) | UINT16 | RO | 0x1A00 (6656dec)
1C13:02 | SubIndex 002 | 2. assigned RxPDO (包含相应的 RxPDO 映射兑现过的索引) | UINT16 | RO | 0x1A01 (6657dec)
Index 1C32 SM 输出参数
Index | Name | 含义 | 数据类型 | Flags | 默认
1C32:0 | SM 输出参数 | 输出的同步参数 | UINT8 | RO | 0x20 (32dec)
1C32:01 同步模式 现行同步模式：
  • 0: Free Run
  • 1: 与SM 2 Event同步
  • 2: DC-模式 - 与SYNC0 Event同步
  • 3: DC-模式 - 与SYNC1 Event同步
 UINT16 RW 0x0000 (0dec)
1C32:02 周期时间 周期时间 (ns):
  • Free Run: 本地计时器的周期时间
  • 与SM 2 Event同步: 主站的周期时间
  • DC-模式: SYNC0/SYNC1周期时间
 UINT32 RW 0x0003D090 (250000dec)
1C32:03 | 切换时间 | SYNC0 Event与输出生效间的时间( ns, 仅在 DC-Mode下 ) | UINT32 | RO | 0x00000000 (0dec)
1C32:04 支持同步模式 支持同步模式：
  • Bit 0 = 1: 支持Free Run
  • Bit 1 = 1: 支持与SM 2 Event同步
  • Bit 2-3 = 01: 支持DC模式
  • Bit 4-5 = 10: 输出与SYNC1 Event切换 （仅DC模式下）
  • Bit 14 = 1: 动态时间（可以通过写 1C32:08来测量）
 UINT16 RO 0xC007 (49159dec)
1C32:05 | 最小周期时间 | 支持的最小周期时间 (ns) | UINT32 | RO | 0x00004E20 (20000dec)
1C32:06 | 计算及复制时间 | SYNC0 和 SYNC1 Event 之间的最小时间（ns，仅在DC模式下） | UINT32 | RO | 0x00000000 (0dec)
1C32:08 指令
  • 0: 时间的测量将停止
  • 1: 时间的测量将开始

条目1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 将以最大的测量值被更新。

UINT16 RW 0x0000 (0dec)
1C32:09 | 延迟时间 | SYNC1 Event与输出生效间的时间( ns, 仅在 DC-Mode下 ) | UINT32 | RO | 0x00000000 (0dec)
1C32:0B | SM event 丢失计数器 | 在状态OPERATIONAL 中丢失的SM-Events个数（仅在DC模式下） | UINT16 | RO | 0x0000 (0dec)
1C32:0C | 周期超出计数器 | 在状态OPERATIONAL中周期超出的个数。 | UINT16 | RO | 0x0000 (0dec)
1C32:0D | 切换至超短计数器 | SYNC0 和 SYNC1 Event 之间的 | UINT16 | RO | 0x0000 (0dec)
1C32:20 | 同步错误 | TRUE: 最后一个周期中同步不正确（仅在DC模式下） | 布尔 | RO | 0x00 (0dec)
Index 1C33 SM 输入参数
Index | Name | 含义 | 数据类型 | Flags | 默认
1C33:0 | SM输入参数 | 输出的同步参数 | UINT8 | RO | 0x20 (32dec)
1C33:01 同步模式 现行同步模式：
  • 0: Free Run
  • 1: 与SM 3 Event同步（输出可得）
  • 2: DC-模式 - 与SYNC0 Event同步
  • 3: DC-模式 - 与SYNC1 Event同步
  • 34: 与SM 2 Event同步（输出可得）
 UINT16 RW 0x0000 (0dec)
1C33:02 | 周期时间 | 与1C32:02相同 | UINT32 | RW | 0x0003D090 (250000dec)
1C33:03 | 切换时间 | SYNC0 Event与输出生效间的时间( ns, 仅在 DC-Mode下 ) | UINT32 | RO | 0x00000000 (0dec)
1C33:04 支持同步模式 支持同步模式：
  • Bit 0: 支持Free Run
  • Bit 1: 支持与SM 2 Event同步)
  • Bit 1: 与SM 3 Event同步（输出不可得）
  • Bit 2-3 = 01: 支持DC模式
  • Bit 4-5 = 01: Input Shift with local event (Outputs available)
  • Bit 4-5 = 10: Input Shift with SYNC1 Event (no Outputs available)
  • Bit 14 = 1: 动态时间（可以通过写 1C32:08 或 1C33:08被测量）。
 UINT16 RO 0xC007 (49159dec)
1C33:05 | 最小周期时间 | 与1C32:05相同 | UINT32 | RO | 0x00004E20 (20000dec)
1C33:06 | 计算及复制时间 | Input Latch和主站输入有效之间的时间 (ns, 仅在 DC模式下) | UINT32 | RO | 0x00000000 (0dec)
1C33:08 | 指令 | 与1C32:08相同 | UINT16 | RW | 0x0000 (0dec)
1C33:09 | 延迟时间 | SYNC1 Event与输出生效间的时间( ns, 仅在 DC-Mode下 ) | UINT32 | RO | 0x00000000 (0dec)
SM event 丢失计数器 | 与1C32:11相同 | UINT16 | RO | 0x0000 (0dec)
周期超出计数器 | 与1C32:12相同 | UINT16 | RO | 0x0000 (0dec)
切换至超短计数器 | 与1C32:13相同 | UINT16 | RO | 0x0000 (0dec)
1C33:20 | 同步错误 | 与1C32:32相同 | 布尔 | RO | 0x00 (0dec)

profile specific objects对所有支持profile 5001的EtherCAT从站有相同意义。

Index 60n0 COM Inputs Ch. N = 0. N = 1)
Index | Name | 含义 |  | 数据类型 | Flags | 默认
60n0:0 |  | Max. subindex |  | UINT8 | RO | 0x26 (38dec)
60n0:01 | 传输接收 | 端子模块通过改变这一位的状态来确认数据的接收。 新的数据可以从控制器传输到模块。 |  | 布尔 | RO | 0x00 (0dec)
60n0:02 | 接收请求 | 通过改变此位的状态，端子模块通知控制器，DataIn字节包含了字节的个数并通过 "Input length"位表示. 控制器需要在控制字节中通过改变"ReceiveAccepted"位的状态来确认收到数据". 新的数据可以从模块传输到控制器。 |  | 布尔 | RO | 0x00 (0dec)
60n0:03 | Init accepted | 0 | 模块已准备好再次进行串行数据交换。 | 布尔 | RO | 0x00 (0dec)
 |  | 1 | 模块初始化完成
60n0:04 | 缓冲区满 | 接收FIFO已满 所有新的输入数据都将丢失。 |  | 布尔 | RO | 0x00 (0dec)
60n0:05 | 奇偶错误 | 出现一个奇偶校验错误 |  | 布尔 | RO | 0x00 (0dec)
60n0:06 | 结构错误 | 出现一个结构错误 |  | 布尔 | RO | 0x00 (0dec)
60n0:07 | 超限错误 | 出现一个超限错误 |  | 布尔 | RO | 0x00 (0dec)
60n0:09 | 输入长度 | 从端子模块到控制器的可用的输入字节的个数。 |  | BIT8 | RO | 0x00 (0dec)
60n0:11 | Data In 0 | 输入nbsp] byte 0 |  | UINT8 | RO | 0x00 (0dec)
... | ... | .... |  | ... | ... | ...
60n0:26 | Data In 21 | 输入 byte 21 |  | UINT8 | RO | 0x00 (0dec)

*) 对应的模块类型

Index 60n1 Status Ch. N = 0. N = 1)
Index | Name | 含义 | 数据类型 | Flags | 默认
60n1:0 | 状态 Ch.1 + 2 | Max. subindex | UINT8 | RO | 0x01 (01dec)
60n1:01 | 状态 | 状态字 | UINT16 | RO | 0x00 (0dec)

*) 对应的模块类型

Index 70n0 COM Outputs Ch. N = 0. N = 1)
Index | Name | 含义 |  | 数据类型 | Flags | 默认
70n0:0 | COM 输出 Ch.1 + 2 | Max. subindex |  | UINT8 | RO | 0x26 (38dec)
70n0:01 | 传送请求 | 通过改变此位的状态，控制器通知模块. 模块通过改变 " TransmitAccepted"位的状态开确认状态字节中数据的接收 新的数据可以从控制器传输到模块。 |  | 布尔 | RO | 0x00 (0dec)
70n0:02 | 接收接受 | 控制器通过改变这一位的状态来确认数据的接收。 新的数据可以从模块传输到控制器。 |  | 布尔 | RO | 0x00 (0dec)
70n0:03 | Init 请求 | 0 | 控制器再次请求模块准备串行数据交换。 | 布尔 | RO | 0x00 (0dec)
 |  | 1 | 控制器请求模块的初始化。 发送和接收功能被锁定。FIFO 指针被重置且接口被以按照相关的 设置对象初始化。 模块通过"Init accepted"位来确认初始化完成。
70n0:04 | 发送继续 | 持续发送来自FIFO的数据。 控制器填充发送缓冲区（最大到128字节）。 缓冲内容根据SC 位的上升沿发送。 模块通过设置 "Init accepted"位来确认数据传输至控制器. "Init accepted"被 "SendContinuous"取消。 |  | 布尔 | RO | 0x00 (0dec)
70n0:09 | 输出长度 | 从控制器到端子模块的可用的输出字节的个数 |  | BIT8 | RO | 0x00 (0dec)
70n0:11 | Data Out 0 | 输出 byte 0 |  | UINT8 | RO | 0x00 (0dec)
... | ... | .... |  | ... | ... | ...
70n0:26 | Data Out 21 | 输出byte 21 |  | UINT8 | RO | 0x00 (0dec)

*) 对应的模块类型

Index 70n1 Ctrl Ch. N = 0. N = 1)
Index | Name | 含义 | 数据类型 | Flags | 默认
70n1:0 | Crtl Ch.1 + 2 | Max. subindex | UINT8 | RO | 0x01 (01dec)
70n1:01 | 状态 | 控制字 | UINT16 | RO | 0x00 (0dec)

*) 对应的模块类型

Index A0n0 COM Diag data Ch. N = 0. N = 1)
Index | Name | 含义 | 数据类型 | Flags | 默认
A0n0:0 | COM Diag data Ch.1 + 2 | Max. Subindex | UINT8 | RO | 0x12 (18dec)
A0n0:01 | 缓冲区溢出 | 出现缓冲区溢出 | 布尔 | RO | 0x00 (0dec)
A0n0:02 | 奇偶错误 | 出现一个奇偶校验错误 | 布尔 | RO | 0x00 (0dec)
A0n0:03 | 结构错误 | 出现一个结构错误 | 布尔 | RO | 0x00 (0dec)
A0n0:04 | 超限错误 | 出现一个超限错误 | 布尔 | RO | 0x00 (0dec)
A0n0:05 | 缓冲区满 | 接收FIFO已满 所有新的输入数据都将丢失。 | 布尔 | RO | 0x00 (0dec)
A0n0:11 | 发送缓冲区中的数据字节 | 发送FIFO中的数据字节的个数 | UINT16 | RO | 0x0000 (0dec)
A0n0:21 | 接收缓冲区内的数据字节 | 接收FIFO中的数据字节的个数 | UINT16 | RO | 0x0000 (0dec)

*) 对应的模块类型

Index F000 模块化设备资料
Index | Name | 含义 | 数据类型 | Flags | 默认
F000:0 | 模块化设备资料 | 模块化设备资料的一般信息 | UINT8 | RO | 0x02 (2dec)
F000:01 | 模块索引间隔 | 两通道间对象的索引间隔 | UINT16 | RO | 0x0010 (16dec)
F000:02 | 最大通道数量 | 通道数量 | UINT16 | RO | 0x0004 (4dec)
Index F008 Code word
Index | 名称 | 含义 | 数据类型 | Flags | 默认
F008:0 | 保护码 | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 模块列表
Index | Name | 含义 | 数据类型 | Flags | 默认
F010:0 | Module list | Max. subindex | UINT8 | RW | 0x04 (4dec)
F010:01 | SubIndex 001 | - | UINT32 | RW | 0x00000258 (600dec)
F010:02 | SubIndex 002 | - | UINT32 | RW | 0x00000258 (600dec)


EL6002, EL6022 -控制和状态数据

BECKHOFF EL600x, EL602x: 组态

控制字和状态字

控制和状态数据被置于输入和输出过程映像的前16bit。 模块与控制器间的通信通过这个数据控制

状态数据

Bit 位置 | 名称 | 含义 |  | 数据类型
0 | 传输接收 | 端子模块通过改变这一位的状态来确认数据的接收。 新的数据可以从控制器传输到模块。 |  | 布尔
1 | 接收请求 | 通过改变这一位的状态，模块告知控制器 DataIn byte包含的字节数显示在 ‘Input length’.。 控制器必须通过改变 ReceiveAccepted 位的状态确认接收数据。 此后新的数据蔡可以从模块传输到控制器。 |  | 布尔
2 | Init accepted | 0 | 模块已准备好再次进行串行数据交换。 | 布尔
 |  | 1 | 端子模块已完成初始化
3 | 缓冲区满 | 接收FIFO已满 从这个点开始所有输入的数据都将丢失 |  | 布尔
4 | 奇偶错误 | 出现一个奇偶错误 |  | 布尔
5 | 结构错误 | 出现一个结构错误 |  | 布尔
6 | 超限错误 | 出现一个超限错误 |  | 布尔
7 | - |  |  |
8...15 | 输入长度 | 从端子模块到控制器的可用的输入字节的个数。 |  | UINT8

控制数据

Bit 位置 | Name | 含义 |  | 数据类型
0 | 传送请求 | 通过改变这一位的状态，控制器告知模块DataOut byte包含的字节数显示在 ‘Output length’中。 端子模块通过改变 ‘TransmitAccepted’ 这一位的状态来确认数据的接收. 新的数据可以从控制器传输到模块。 |  | 布尔
1 | 接收接受 | 控制器通过改变这一位的状态来确认数据的接收。 此后新的数据才可以从模块传输到控制器。 |  | 布尔
2 | Init 请求 | 0 | 控制器再次请求模块准备串行数据交换。 | 布尔
 |  | 1 | 控制器请求模块 初始化. 传送和接收功能将被封锁，FIFO指针将被重置，接口将以相关设置对象的值初始化。 初始化的执行将通过‘Init accepted’ 位告知模块。
3 | 发送继续 | 持续发送来自FIFO的数据。 控制器填充发送缓冲区（最大到128字节）。 填充进缓冲区的内容将在位的上升沿发送。 如果数据被发送，模块通过设置‘Init accepted’ 位告知控制器。 ‘Init accepted’被 ‘SendContinuous’清除。 |  | 布尔
4...7 | - |  |  |
8...15 | 输出长度 | 从控制器到端子模块的可用的输出字节的个数 |  | UINT8

PDO Assignment

模块使每个通道有两个输入、输出过程映像。 这些不同仅表现在控制/状态数据中。

至于bit wise表现，数据有效并且显示在上面的表格中。 至于word-wise表现，过程映像的前16位被整合在一个字中。

过程数据对象以控制/状态字为准开始。 需要这个PDO配置以便使用库‘TwinCAT PLC Serial Communication’ 。

状态输入 | 控制输出 | 说明
0x1A00 | 0x1600 | bit wise Ch. 1
0x1A01 | 0x1601 | bit wise Ch. 2
0x1A02 | 0x1602 | bit wise Ch. 3
0x1A03 | 0x1603 | bit wise Ch. 4
0x1A04 | 0x1604 | word-wise Ch 1
0x1A05 | 0x1605 | word-wise Ch 2
0x1A06 | 0x1606 | word-wise Ch 3
0x1A07 | 0x1607 | word-wise Ch 4


UL 需求

BECKHOFF EKxxxx, ELxxxx: 附录

UL 说明

应用
Beckhoff EtherCAT 模块仅适用于Beckhoff UL 列表中的EtherCAT系统。
测试
更据cULus 测试, Beckhoff I/O 系统仅进行了防火和电击测试 has only been investigated for risk of fire and electrical shock (更据 UL508 和 CSA C22.2 No. 142. 142).
对于以太网接口设备
不适用于连接通信线路

基本原理

倍福EtherCAT产品的两个UL认证，因产品而异：

  • 符合UL508标准的UL认证
    拥有该认证的设备会有这样的标记：

  • 符合限制电源消耗UL508标准的UL认证
    由设备所消耗的电流被限制到最大，可能能达到4 A 。 拥有该认证的设备会有这样的标记：

几乎所有的EtherCAT产品（截止到2010/5）都是非限制的UL认证。

应用

如果端子模块通过 限制认证 , 那么24 V DC 电流消耗必须受到电源限制。

  • 从一个由最大保险丝保护的独立来源 4A (按照 UL248) 或者
  • 由一个符合 NEC class 2的电源供电。
    符合 NEC class 2 的电源不能与另一个 NEC class 2 电源串联或并联使用!

这些要求适用于所有的EtherCAT总线耦合器电源，电源适配器端子模块，总线端子模块以及它们的电源触点。


固件兼容性

Beckhoff EtherCAT设备在交付时装备了最新的固件。 固件和硬件之间存在一定的依赖性，不是所有的组合都能兼容。
下面是固件与硬件兼容的概述

注意

  • 强烈建议在特定的硬件上使用最新有效的固件。
  • 倍福公司先前交付的免费产品没有固件升级的客户权限。

注意 		可能损坏设备！
请在special page注意关于固件升级的细节。
如果在引导程序模式运行设备来给固件升级，可能未校验固件的兼容性。
这可能有设备损坏的危险!
请确保固件适合的硬件设备状态！
EL6001
硬件（HW） | 固件（FW） | 文件名； 发布日期
00 - 02 | 01 | EL6001_01.rbf, 05/2006
 | 02 | EL6001_02.rbf, 12/2006
 | 03 | EL6001_03.rbf, 04/2008
 | 04 | EL6001_04.rbf, 04/2008
03* | 05 | EL6001_05.efw, 12/2009
 | 06 | EL6001_06.efw, 04/2010
 | 07* | EL6001_07.efw, 03/2011
EL6021
硬件（HW） | 固件（FW） | 文件名； 发布日期
00 - 02 | 01 | EL6021_01.rbf, 05/2005
 | 02 | EL6021_02.rbf, 12/2006
 | 03 | EL6021_03.rbf, 04/2008
03 - 04* | 04 | EL6021_04.efw, 11/2009
 | 05* | EL6021_05.efw, 05/2010
EL6002
硬件（HW） | 固件（FW） | 文件名； 发布日期
00 - 01* | 01 | EL6002_01.efw, 12/2009
 | 02* | EL6002_02.efw, 06/2010
EL6022
硬件（HW） | 固件（FW） | 文件名； 发布日期
00 - 01* | 01 | EL6002_01.efw, 01/2010
 | 02* | EL6002_02.efw, 06/2010

*)以上是在创建这个文件时当前硬件兼容的状态。 请查阅 Beckhoff的 最近文件的页面。


ELxxxx - 固件

BECKHOFF ELxxxx: 设备升级

固件 EL/ES/EMxxxx

这部分描述了Beckhoff EtherCAT从站 EL/ES, EM, EK和EP系列的版本升级。. 固件的升级只能在咨询Beckhoff技术支持之后才能执行。

目录
• 存储位置
• ESI版本定义
• 设备描述升级 ESI/*.xml
• 固件版本描述
• 固件升级文件 *.efw
• 固件升级文件 *.rbf
• 批量更新

存储位置

EtherCAT从站在3个地方存储运行数据：

  • 更据功能和性能EtherCAT从站有一个或几个本地控制器用于传输I/O数据。 所对应的程序称为 固件 为 *.efw 格式。
  • 某些EtherCAT从站的EtherCAT通讯功能也集成在控制器中。 这种情况的控制器叫做 FPGA 芯片使用 *.rbf 格式的固件。
  • 另外每个EtherCAT从站有存储芯片保持设备参数叫做 EEPROM. 通电后自动加载参数，EtherCAT通信也相应设定。 设备描述可以从 http://www.beckhoff.com 下载区下载。 所有 ESI 文件(EtherCAT Slave Information) 压缩成ZIP格式。

客户可以通过 EtherCAT 现场总线和其通信机制访问数据。 ESC读写来实现异步mailbox通讯或访问寄存器。

TwinCAT System Manager提供配置所有这3部分数据的方法，如果从站支持这些数据。 通常从站不会检查新数据是否适合，例如，数据不适合的话从站就再也无法工作。

注意 		小心设备损坏!
当下载新的设备文件时注意如下几点
  • 下载固件到EtherCAT设备时不能被打断
  • 确保EtherCAT通信稳定。 不能有CRC错误或 LostFrames。
  • 供电必须稳定。 信号等级必须达到规范。

设备更新数据时发生故障可能使模块不能使用，需要返厂修复。

设备描述 ESI文件/XML

注意 		关于ESI说明/EEPROM的更新的注意事项
一些从站在产品的EEPROM中存储了标度和配置的数据。 这些在数据更新中被覆盖。

ESI设备描述存储在本机，并且启动时载入。 每个设备描述为唯一的从站名（10个字符数）和版本号（4个数字） 每个从站的名称都在System Manager的 EtherCAT 页面显示:

图 1: 设备识别符号由名称EL3204-0000和修订号-0016组成

配置识别符号必须与实际的硬件设备兼容。在启动时读取从站型号（如EL3204)。 通常配置的修订号必须等于或高于端子模块的版本 。

说明 		更新 XML/ESI 描述文件
用于硬件设备的固件版本是紧密联系在一起的。 不相容的组合会导致故障或设备关机。
相应的更新只能在咨询Beckhoff技术支持之后才能进行。

显示 ESI从站型号

最简单的确定实际设备描述与配置的设备描述是否一致的方法是在 TwinCAT Config/Freerun 模式下扫描EtherCAT 设备：

图 2: 在Config/FreeRun模式下右键EtherCAT device 然后 Scan Boxes

如果实际与配置相符，则显示下

图 3: 配置相同

否则就显示修改对话框来修改配置

图 4: 修改对话框

在图4中所示的例子中 当 EL3201-0000-0016 配置完成时，EL3201-0000-0017 被发现。 这种情况下可用CopyBefore按钮来修改配置。 ExtendedInformation复选框必须勾上才能显示版本信息。

修改 ESI 从站版本

ESI/EEPROM 版本可以通过 TwinCAT更新:

  • EtherCAT从站通讯不能中断.
  • 从站的状态不重要。
  • 在online标签中右键从站以打开 EEPROM Update 对话框，图 5

图 5: EEPROM 更新

在对话框中选择新ESI 描述文件, 见图 6. ShowHiddenDevices 复选框钩上可以显示老的版本号，默认不显示。

图 6: 选择新ESI 描述文件

System Manager中的进度条显示当前进度。 数据写入后再进行校验。

说明 		重启后更新生效
大多数EtherCAT立刻读取修改的ESI说明或者在初始化启动之后。 一些通讯设置比如分布式时钟仅在电源打开后读取。
因此为了使修改后的参数生效，EtherCAT从站必须断电重启。

确定固件版本

通过序列号确定固件版本

Beckhoff EtherCAT从站的序列号是用激光刻上的。 序列号的结构如下： KK YY FF HH

KK - 生产周 (CW, 日历周)
YY - 生产年
FF - 固件版本
HH - 硬件版本

例如序列号： 12 10 03 02:

12 - 第 12周生产
10 - 2010 年生产
03 - 固件版本 03
02 - 硬件版本 02

通过System Manager查看版本

主站和从站通信上之后TwinCAT System Manager 即可显示从站控制器的固件版本。 选中你想查看的那个E-Bus端子模块 (本例terminal 2 (EL3204))然后选择CoE Online (CAN over EtherCAT).

说明 		CoE Online和 Offline CoE
有2个CoE 目录：
  • online: 如果从站支持的话，由EtherCAT从站控制器提供。
    只有从站处于连接和运行的状态这个CoE目录才会被显示。
  • offline: EtherCAT 从站信息文件 ESI/XML包含 CoE默认数据.
    CoE目录只显示包含在ESI文件中的信息 (e.g. "Beckhoff EL5xxx.xml. "Beckhoff EL5xxx.xml").

Advanced 按钮用于切换这两种显示。

在图. 7中 CoE索引x100A EL3204的固件版本为03

图 7: 显示 EL3204固件版本

(A) TwinCAT 2.11 指示当前显示 Online CoE 目录 如果当前不是这样, 可以进入 Advanced Settings (B) Online选项 然后双击 AllObjects. 显示所有的Online目录。

升级控制器固件 *.efw

说明 		CoE 目录
由控制器管理的Online CoE目录存储在专用的EEPROM中，这个目录通常在固件更新时不会被改变。

为了更新从站控制固件，选中 Online， 见图8 8.

图 8: 固件更新

如果没有Beckhoff技术支持指导话，请按如下步骤进行。

  • 切换从站到 INIT (A)
  • 切换从站到BOOTSTRAP
  • 检查当前状态 (B, C)
  • 下载新 *efw 文件
  • 下载完成后切换到 INIT状态，然后切换到 OP状态
  • 从站重上电一次

FPGA 固件文件 *.rbf

如果是 FPGA芯片负责处理EtherCAT通讯，可以通过更新 *.rbf文件来完成升级。.

  • 控制器固件 处理 I/O信号
  • FPGA 固件 处理EtherCAT 通信 (仅针对采用 FPGA芯片的端子模块)

包括在端子模块的序列号的固件版本号包含这两个固件组件。 如果其中一个固件更新，那这个版本号就会被更新。

通过System Manager查看版本

在TwinCAT System Manager查看FPGA固件版本。 选中EtherCAT 卡 (本例中的 Device 2) 然后选择 Online 标签

Reg:0002 列分别用十六进制和十进制显示了每个EtherCAT设备的固件版本。

图 9: FPGA固件版本确认

如果 Reg:0002列不显示，在表格中右键然后选择Properties...

图 10: 弹出菜单Properties

Advanced Settings对话框显示哪些列可以被显示。 在 Diagnosis/Online View下 '0002 ETxxxx Build'选中复选框，使FPGA固件版本可以显示。

图 11: 高级设置对话框

更新

更新 FPGA固件

  • EtherCAT耦合器 FPGA固件版本为11或以上;
  • E-bus端子模块FPGA固件版本为10或以上。

更早的固件件版本只能由制造商来更新！

升级EtherCAT设备

在TwinCAT System Manager中选择端子，并且你想将这个端子的FPGA固件更新（在这个例子中的端子5： EL5001) 和
点击Advanced Settings in the EtherCAT tab。

图 12: 选择高级设置对话框

Advanced Settings对话框显示。 在 ESC Access/E²PROM/FPGA点击 Write FPGA 按钮,

图 13: 选择写FPGA对话框

选择新 FPGA固件文件 (*.rbf) 然后下载到 EtherCAT设备。

注意 		小心设备损坏!
EtherCAT设备的固件更新过程中不能中断！

如果下载过程被取消，电源断开或是Ethernet连接中断，那此EtherCAT设备只能由制造商来修复！

为了激活新的FPGA固件，EtherCAT设备必须重启（将电源关闭再启动）。

同时更新数台 EtherCAT 设备

如果设备有相同的固件文件/ESI，那么几台设备的固件和ESI描述可以同步更新。

图 14: 多重选择和固件更新

选择需要的从站然后在BOOTSTRAP模式下执行固件的更新。


ELxxxx - 恢复出厂设置

BECKHOFF ELxxxx: 组态

恢复出厂设置

恢复ELxxxx端子模块的出厂设置, 在TwinCAT System Manager的CoE对象 "Restore default parameters"中, 选择SubIndex 001 子项 (配置模式) (见图1. 1)

图 1 选择 "Restore default parameters" PDO

双击SubIndex 001进入参数设定对话框。 输入 1684107116十进制或0x64616F6C十六进制，并点击 OK (图2. 2).
所有数据恢复出厂设置

图 2 在设置值对话框中输入复位码

说明 		其他复位码

某些老端子模块请使用以下复位码：

十进制： "1819238756"

十六进制值： "0x6C6F6164"

输入错误的复位码无效。


技术支持与售后

Beckhof f 及其合作伙伴遍布世界各地，可为您提供全方位的技术支持与服务，确保快速协助解决与 Beckhoff 产品和系统解决方案相关的所有问题。

Beckhoff 分公司及代表处

有关 Beckhoff 产品的本地技术支持和服务信息，请联系当地的 Beckhoff 分公司和代表处！

有关 Beckhoff 在全球各地分公司和代理商的地址，您可以登录Beckhoff 的官方网站：
http://www.beckhoff.com

此外，您也可以在该网站上查看更多关于 Beckhoff 组件的文档资料。

Beckhoff 总部

德国倍福自动化有限公司

Eiserstr. 5
33415 Verl
德国

电话 ： | +49(0)5246/963-0
传真： | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff 技术支持

Beckhoff为您提供全面的技术支持，除了Beckhoff 具体产品的应用以外，还包括更广泛的服务：

  • 技术支持
  • 复杂自动化系统的设计、编程和调试
  • 各种 Beckhoff 系统组件培训方案
热线： | +49(0)5246/963-157
传真： | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff 服务

Beckhoff 服务中心提供全方位的售后技术服务:

  • 现场服务
  • 维修服务
  • 零部件服务
  • 热线服务
热线： | +49(0)5246/963-460
传真： | +49(0)5246/963-479
e-mail: | service@beckhoff.com